DSPLIB: DSPLIB API Reference

  • Main Page
  • Modules
  • Files

DSPLIB API Reference

Release 3.4.0.0

This is the main landing page for the DSPLIB API Reference. You can navigate by functional category using the links provided below or directly to any module (kernel) or it's assocaited soure file using the tabs above. You can always return to this page via the "Main Page" tab above.

Introduction

The TI C6000 DSPLIB is an optimized DSP Function Library for C programmers. It includes many C-callable, optimized, general-purpose signal-processing routines. These routines are typically used in computationally-intensive real-time applications where optimal execution speed is critical. By using these routines, you can achieve execution speeds considerably faster than equivalent code written in standard ANSI C language. In addition, by providing ready-to-use DSP functions, TI DSPLIB can significantly shorten your DSP application development time.

The TI DSPLIB includes commonly used DSP routines. Source code is provided that allows you to modify functions to match your specific needs.

The routines contained in the library are organized into the following seven different functional areas:

Features and Benefits

  • Natural C Source Code
  • Optimized C code with Intrinsics
  • C-callable routines, fully compatible with the TI C6x compiler
  • Fractional Q.15-format operands supported on some benchmarks
  • Benchmarks (cycle and code size)
  • Tested against C model
  • The provided precompiled library was compiled using Code Generation Tools Version 7.4.2

Modules

  • Adaptive filtering
  • Correlation
  • Fast Fourier Transform
  • Filtering and convolution
  • Math
  • Matrix
  • Miscellaneous
Copyright 2014, Texas Instruments Incorporated


DSPLIB: Module Index

DSPLIB Modules

Here is a list of all modules:
  • Adaptive filtering
    • DSP_firlms2
  • Correlation
    • DSP_autocor
  • Fast Fourier Transform
    • DSP_fft16x16
    • DSP_fft16x16r
    • DSP_fft16x16_imre
    • DSP_fft16x32
    • DSP_fft32x32
    • DSP_fft32x32s
    • DSP_ifft16x16
    • DSP_ifft16x16_imre
    • DSP_ifft16x32
    • DSP_ifft32x32
  • Filtering and convolution
    • DSP_fir_cplx
    • DSP_fir_cplx_hM4X4
    • DSP_fir_gen
    • DSP_fir_gen_hM17_rA8X8
    • DSP_fir_r4
    • DSP_fir_r8
    • DSP_fir_r8_hM16_rM8A8X8
    • DSP_fir_sym
    • DSP_iir
    • DSP_iir_lat
    • DSP_iir_ss
  • Math
    • DSP_add16
    • DSP_add32
    • DSP_dotprod
    • DSP_dotp_sqr
    • DSP_maxidx
    • DSP_maxval
    • DSP_minval
    • DSP_mul32
    • DSP_neg32
    • DSP_recip16
    • DSP_vecsumsq
    • DSP_w_vec
  • Matrix
    • DSP_mat_mul
    • DSP_mat_mul_cplx
    • DSP_mat_trans
  • Miscellaneous
    • DSP_bexp
    • DSP_blk_eswap16
    • DSP_blk_eswap32
    • DSP_blk_eswap64
    • DSP_blk_move
    • DSP_fltoq15
    • DSP_minerror
    • DSP_q15tofl


DSPLIB: Adaptive filtering

Adaptive filtering

Collaboration diagram for Adaptive filtering:

Detailed Description

Modules

DSP_firlms2


DSPLIB: DSP_firlms2

DSP_firlms2
[Adaptive filtering]

Collaboration diagram for DSP_firlms2:

Detailed Description

int DSP_firlms2 (short *restrict h, short *restrict x, short b, int nh)

Function Documentation

int DSP_firlms2 | ( | short *restrict | h,
 |  | short *restrict | x,
 |  | short | b,
 |  | int | nh
 | ) |  |

The Least Mean Square Adaptive Filter computes an update of all nh coefficients by adding the weighted error times the inputs to the original coefficients. The input array includes the last nh inputs followed by a new single sample input. The coefficient array includes nh coefficients.

Parameters:
h | = Coefficient Array
x | = Input array
b | = Error from previous FIR
nh | = Number of coefficients. Must be multiple of 4
Algorithm:
DSP_firlms2_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
This routine assumes 16-bit input and output.
The number of coefficients nh must be a multiple of 4.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: Correlation

Correlation

Collaboration diagram for Correlation:

Detailed Description

Modules

DSP_autocor


DSPLIB: DSP_autocor

DSP_autocor
[Correlation]

Collaboration diagram for DSP_autocor:

Detailed Description

void DSP_autocor (short *restrict r, const short *restrict x, int nx, int nr)

Function Documentation

void DSP_autocor | ( | short *restrict | r,
 |  | const short *restrict | x,
 |  | int | nx,
 |  | int | nr
 | ) |  |

This routine performs an autocorrelation of an input vector x. The length of the autocorrelation is nx samples. Since nr such autocorrelations are performed, input vector x needs to be of length nx + nr. This produces nr output results which are stored in an output array r.

The following diagram illustrates how the correlations are obtained.

Example for nr=8, nx=24:
0 nr nx+nr-1
|-------|----------------------| <- x[]
| |----------------------| -> r[0]
| |----------------------| -> r[1]
| |----------------------| -> r[2]
| |----------------------| -> r[3]
| |----------------------| -> r[4]
| |----------------------| -> r[5]
| |----------------------| -> r[6]

Note that x[0] is never used, but is required for padding to make x[nr] double-word aligned.

Parameters:
r | = Output data array of shorts
x | = Input data array of shorts
nx | = Length of autocorrelation
nr | = Number of lags
Algorithm:
DSP_autocor_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
The first nr elements are assumed to be zero.
NX >= 8; NX % 8 == 0
NR >= 4; NR % 4 == 0
x[] must be double word alligned
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: Fast Fourier Transform

Fast Fourier Transform

Collaboration diagram for Fast Fourier Transform:

Detailed Description

Modules

DSP_fft16x16
DSP_fft16x16r
DSP_fft16x16_imre
DSP_fft16x32
DSP_fft32x32
DSP_fft32x32s
DSP_ifft16x16
DSP_ifft16x16_imre
DSP_ifft16x32
DSP_ifft32x32


DSPLIB: DSP_fft16x16

DSP_fft16x16
[Fast Fourier Transform]

Collaboration diagram for DSP_fft16x16:

Detailed Description

void DSP_fft16x16 (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)

Function Documentation

void DSP_fft16x16 | ( | const short *restrict | ptr_w,
 |  | int | npoints,
 |  | short *restrict | ptr_x,
 |  | short *restrict | ptr_y
 | ) |  |

This routine computes a complex forward mixed radix FFT with rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 16-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved real and imaginary parts. The code uses a special ordering of FFT coefficients (also called twiddle factors) and memory accesses to improve performance in the presence of cache.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_fft16x16_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fft16x16r

DSP_fft16x16r
[Fast Fourier Transform]

Collaboration diagram for DSP_fft16x16r:

Detailed Description

void DSP_fft16x16r (int n, short *restrict ptr_x, const short *restrict ptr_w, short *restrict ptr_y, int radix, int offset, int n_max)

Function Documentation

void DSP_fft16x16r | ( | int | n,
 |  | short *restrict | ptr_x,
 |  | const short *restrict | ptr_w,
 |  | short *restrict | ptr_y,
 |  | int | radix,
 |  | int | offset,
 |  | int | n_max
 | ) |  |

This routine implements a complex forward mixed radix FFT with scaling, rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 16-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored as interleaved 16-bit real and imaginary parts. The code uses a special ordering of FFT coefficients (also called twiddle factors).

This redundant set of twiddle factors is size 2*N short samples. As pointed out in subsequent sections, dividing these twiddle factors by 2 will give an effective divide by 4 at each stage to guarantee no overflow. The function is accurate to about 68dB of signal to noise ratio to the DFT function as follows.

Parameters:
n | = length of fft in complex samples
ptr_x | = pointer to complex data input
ptr_w | = pointer to complex twiddle factor
ptr_y | = pointer to complex data output
radix | = smallest fft butterfly used in computation
offset | = index in complex samples of sub-fft from start of main fft
n_max | = size of main fft in complex samples
Algorithm:
DSP_fft16x16r_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
All data are in short precision or Q.15 format. Allowed input dynamic range is 16 - (log2(nx)-ceil[log4(nx)-1]).
Implementation Notes:
The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fft16x16_imre

DSP_fft16x16_imre
[Fast Fourier Transform]

Collaboration diagram for DSP_fft16x16_imre:

Detailed Description

void DSP_fft16x16_imre (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)

Function Documentation

void DSP_fft16x16_imre | ( | const short *restrict | ptr_w,
 |  | int | npoints,
 |  | short *restrict | ptr_x,
 |  | short *restrict | ptr_y
 | ) |  |

This routine computes a complex forward mixed radix FFT with rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 16-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved imaginary and real parts. The code uses a special ordering of FFT coefficients (also called twiddle factors) and memory accesses to improve performance in the presence of cache.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_fft16x16_imre_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the imaginary/real components stored in adjacent locations in the array. The imaginary components are stored at even array indices, and the real components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fft16x32

DSP_fft16x32
[Fast Fourier Transform]

Collaboration diagram for DSP_fft16x32:

Detailed Description

void DSP_fft16x32 (const short *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Function Documentation

void DSP_fft16x32 | ( | const short *restrict | ptr_w,
 |  | int | npoints,
 |  | int *restrict | ptr_x,
 |  | int *restrict | ptr_y
 | ) |  |

This routine computes an extended precision complex forward mixed radix FFT with rounding and digit reversal. Input data x[ ] and output data y[ ] are 32-bit, coefficients w[ ] are 16-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved real and imaginary parts.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_fft16x32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fft32x32

DSP_fft32x32
[Fast Fourier Transform]

Collaboration diagram for DSP_fft32x32:

Detailed Description

void DSP_fft32x32 (const int *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Function Documentation

void DSP_fft32x32 | ( | const int *restrict | ptr_w,
 |  | int | npoints,
 |  | int *restrict | ptr_x,
 |  | int *restrict | ptr_y
 | ) |  |

This routine computes an extended precision complex forward mixed radix FFT with rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 32-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved real and imaginary parts.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_fft32x32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fft32x32s

DSP_fft32x32s
[Fast Fourier Transform]

Collaboration diagram for DSP_fft32x32s:

Detailed Description

void DSP_fft32x32s (const int *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Function Documentation

void DSP_fft32x32s | ( | const int *restrict | ptr_w,
 |  | int | npoints,
 |  | int *restrict | ptr_x,
 |  | int *restrict | ptr_y
 | ) |  |

This routine computes an extended precision complex forward mixed radix FFT with scaling, rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 32-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved real and imaginary parts.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_fft32x32s_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Scaling is performed at each stage by shifting the results right by 1, preventing overflow.
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_ifft16x16

DSP_ifft16x16
[Fast Fourier Transform]

Collaboration diagram for DSP_ifft16x16:

Detailed Description

void DSP_ifft16x16 (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)

Function Documentation

void DSP_ifft16x16 | ( | const short *restrict | ptr_w,
 |  | int | npoints,
 |  | short *restrict | ptr_x,
 |  | short *restrict | ptr_y
 | ) |  |

This code performs a Radix-4 IFFT with digit reversal. The code uses a special ordering of twiddle factors and memory accesses to improve performance in the presence of cache. It operates largely in-place, but the final digit-reversed output is written out-of-place.

Parameters:
ptr_w,: Pointer to vector of Q.15 FFT coefficients of size 2*nx elements.
npoints,: Number of complex elements in vector x.
ptr_x,: Pointer to input vector of size 2*nx elements.
ptr_y,: Pointer to output vector of size 2*nx elements.
Algorithm:
DSP_ifft16x16_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=32768.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_ifft16x16_imre

DSP_ifft16x16_imre
[Fast Fourier Transform]

Collaboration diagram for DSP_ifft16x16_imre:

Detailed Description

void DSP_ifft16x16_imre (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)

Function Documentation

void DSP_ifft16x16_imre | ( | const short *restrict | ptr_w,
 |  | int | npoints,
 |  | short *restrict | ptr_x,
 |  | short *restrict | ptr_y
 | ) |  |

This routine computes a complex inverse mixed radix IFFT with rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 16-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved imaginary and real parts.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_ifft16x16_imre_cn.c is the natural C equivalent of the optimized intrinsic C code without * restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the imaginary/real components stored in adjacent locations in the array. The imaginary components are stored at even array indices, and the real components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_ifft16x32

DSP_ifft16x32
[Fast Fourier Transform]

Collaboration diagram for DSP_ifft16x32:

Detailed Description

void DSP_ifft16x32 (const short *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Function Documentation

void DSP_ifft16x32 | ( | const short *restrict | ptr_w,
 |  | int | npoints,
 |  | int *restrict | ptr_x,
 |  | int *restrict | ptr_y
 | ) |  |

This routine computes an extended precision complex inverse mixed radix FFT with rounding and digit reversal. Input data x[ ] and output data y[ ] are 32-bit, coefficients w[ ] are 16-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved real and imaginary parts.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_ifft16x32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: DSP_ifft32x32

DSP_ifft32x32
[Fast Fourier Transform]

Collaboration diagram for DSP_ifft32x32:

Detailed Description

void DSP_ifft32x32 (const int *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Function Documentation

void DSP_ifft32x32 | ( | const int *restrict | ptr_w,
 |  | int | npoints,
 |  | int *restrict | ptr_x,
 |  | int *restrict | ptr_y
 | ) |  |

This routine computes an extended precision complex inverse mixed radix FFT with rounding and digit reversal. Input data x[ ], output data y[ ], and coefficients w[ ] are 32-bit. The output is returned in the separate array y[ ] in normal order. Each complex value is stored with interleaved real and imaginary parts.

Parameters:
ptr_w | = input twiddle factors
npoints | = number of points
ptr_x | = transformed data reversed
ptr_y | = linear transformed data
Algorithm:
DSP_ifft32x32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
In-place computation is not allowed.
Size of FFT, nx, must be power of 2 and 16<=nx<=65536.
The arrays for the complex input data x[], complex output data y[] and twiddle factor w[] must be double word aligned.
The input and output data are complex, with the real/imaginary components stored in adjacent locations in the array. The real components are stored at even array indices, and the imaginary components are stored at odd array indices.
Implementation Notes:
Endian Support: The intrinsic optimized C code supports both big and little endian modes.
The linear assembly code supports little endian mode only.
Interruptibility: The code is interruptible.


DSPLIB: Filtering and convolution

Filtering and convolution

Collaboration diagram for Filtering and convolution:

Detailed Description

Modules

DSP_fir_cplx
DSP_fir_cplx_hM4X4
DSP_fir_gen
DSP_fir_gen_hM17_rA8X8
DSP_fir_r4
DSP_fir_r8
DSP_fir_r8_hM16_rM8A8X8
DSP_fir_sym
DSP_iir
DSP_iir_lat
DSP_iir_ss


DSPLIB: DSP_fir_cplx

DSP_fir_cplx
[Filtering and convolution]

Collaboration diagram for DSP_fir_cplx:

Detailed Description

void DSP_fir_cplx (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_cplx | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

This complex FIR computes nr complex output samples using nh complex coefficients. It operates on 16-bit data with a 32-bit accumulate. Each array consists of an even and odd term with even terms representing the real part of the element and the odd terms the imaginary part. The pointer to input array x must point to the (nh)th complex sample, i.e. element 2*(nh-1), upon entry to the function. The coefficients are expected in normal order.

Parameters:
x | Complex input data. x must point to x[2*(nh-1)].
h | Complex coefficients (in normal order). h must point to h[2*nh].
r | Complex output data. r must point to r[2*nr].
nh | Number of complex coefficients.
nr | Number of complex output samples.
Algorithm:
DSP_fir_cplx_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap
nr >= 8; nr % 4 == 0
nh >= 4; nh % 2 == 0
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_fir_cplx_hM4X4

DSP_fir_cplx_hM4X4
[Filtering and convolution]

Collaboration diagram for DSP_fir_cplx_hM4X4:

Detailed Description

void DSP_fir_cplx_hM4X4 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_cplx_hM4X4 | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

This complex FIR computes nr complex output samples using nh complex coefficients. It operates on 16-bit data with a 32-bit accumulate. Each array consists of an even and odd term with even terms representing the real part of the element and the odd terms the imaginary part. The pointer to input array x must point to the (nh)th complex sample, i.e. element 2*(nh-1), upon entry to the function. The coefficients are expected in normal order.

Parameters:
x | Complex input data. x must point to x[2*(nh-1)].
h | Complex coefficients (in normal order). h must point to h[2*nh].
r | Complex output data. r must point to r[2*nr].
nh | Number of complex coefficients.
nr | Number of complex output samples.
Algorithm:
DSP_fir_cplx_hM4X4_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap
nr >= 4; nr % 4 == 0
nh >= 4; nh % 4 == 0
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_fir_gen

DSP_fir_gen
[Filtering and convolution]

Collaboration diagram for DSP_fir_gen:

Detailed Description

void DSP_fir_gen (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_gen | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

Computes a real FIR filter (direct-form) using coefficients stored in vector h. The real data input is stored in vector x. The filter output result is stored in vector r. Input data and filter taps are 16-bit, with intermediate values kept at 32-bit precision. Filter taps are expected in Q15 format.

Parameters:
x | = Input array [nr+nh-1 elements]
h | = Coeff array [nh elements]
r | = Output array [nr elements]
nh | = Number of coefficients
nr | = Number of output samples
Algorithm:
DSP_fir_gen_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap.
nr >= 4; nr % 4 == 0.
nh >= 5.
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_fir_gen_hM17_rA8X8

DSP_fir_gen_hM17_rA8X8
[Filtering and convolution]

Collaboration diagram for DSP_fir_gen_hM17_rA8X8:

Detailed Description

void DSP_fir_gen_hM17_rA8X8 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_gen_hM17_rA8X8 | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

Computes a real FIR filter (direct-form) using coefficients stored in vector h. The real data input is stored in vector x. The filter output result is stored in vector r. Input data and filter taps are 16-bit, with intermediate values kept at 32-bit precision. Filter taps are expected in Q15 format.

Parameters:
x | = Input array [nr+nh-1 elements]
h | = Coeff array [nh elements]
r | = Output array [nr elements]
nh | = Number of coefficients
nr | = Number of output samples
Algorithm:
DSP_fir_gen_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap.
nr >= 8; nr % 8 == 0.
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_fir_r4

DSP_fir_r4
[Filtering and convolution]

Collaboration diagram for DSP_fir_r4:

Detailed Description

void DSP_fir_r4 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_r4 | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

This function implements an IIR filter, with a number of biquad stages given by nCoefs / 4. It accepts a single sample of input and returns a single sample of output. Coefficients are expected to be in the range [-2.0, 2.0) with Q14 precision.

Parameters:
x | = Input array [nr+nh-1 elements]
h | = Coeff array [nh elements]
r | = Output array [nr elements]
nh | = Number of coefficients
nr | = Number of output samples
Algorithm:
DSP_fir_r4_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap.
x and h are double word aligned.
nr >= 4; nr % 4 == 0.
nh >= 4; nh % 4 == 0.
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_fir_r8

DSP_fir_r8
[Filtering and convolution]

Collaboration diagram for DSP_fir_r8:

Detailed Description

void DSP_fir_r8 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_r8 | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

Computes a real FIR filter (direct-form) using coefficients stored in vector h. The real data input is stored in vector x. The filter output result is stored in vector r. Input data and filter taps are 16-bit, with intermediate values kept at 32-bit precision. Filter taps are expected in Q15 format.

Parameters:
x | = Input array [nr+nh-1 elements]
h | = Coeff array [nh elements]
r | = Output array [nr elements]
nh | = Number of coefficients
nr | = Number of output samples
Algorithm:
DSP_fir_r8_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Performance Note: For better cycle performance when using Radix 8 coefficients nh <= 24 please use DSP_fir_r8_h8, DSP_fir_r8_h16, DSP_fir_r8_h24 module

Assumptions:
Arrays x, h, and r do not overlap.
nr >= 4; nr % 4 == 0.
nh >= 8; nh % 8 == 0.
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_fir_r8_hM16_rM8A8X8

DSP_fir_r8_hM16_rM8A8X8
[Filtering and convolution]

Collaboration diagram for DSP_fir_r8_hM16_rM8A8X8:

Detailed Description

void DSP_fir_r8_hM16_rM8A8X8 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Function Documentation

void DSP_fir_r8_hM16_rM8A8X8 | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

Computes a real FIR filter (direct-form) using coefficients stored in vector h. The real data input is stored in vector x. The filter output result is stored in vector r. Input data and filter taps are 16-bit, with intermediate values kept at 32-bit precision. Filter taps are expected in Q15 format.

Parameters:
x | = Input array [nr+nh-1 elements]
h | = Coeff array [nh elements]
r | = Output array [nr elements]
nh | = Number of coefficients
nr | = Number of output samples
Algorithm:
DSP_fir_r8_hM16_rM8A8X8_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap
nr >= 8; nr % 8 == 0
nh >= 8; nh % 8 == 0
Implementation Notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fir_sym

DSP_fir_sym
[Filtering and convolution]

Collaboration diagram for DSP_fir_sym:

Detailed Description

void DSP_fir_sym (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr, int s)

Function Documentation

void DSP_fir_sym | ( | const short *restrict | x,
 |  | const short *restrict | h,
 |  | short *restrict | r,
 |  | int | nh,
 |  | int | nr,
 |  | int | s
 | ) |  |

This function applies a symmetric filter to the input samples. The filter tap array h[] provides ‘nh+1’ total filter taps. The filter tap at h[nh] forms the center point of the filter. The taps at h[nh - 1] through h[0] form a symmetric filter about this central tap. The effective filter length is thus 2*nh+1 taps. The filter is performed on 16-bit data with 16-bit coefficients, accumulating intermediate results to 40-bit precision. The accumulator is rounded and truncated according to the value provided in ‘s’. This allows a variety of Q-points to be used.

Parameters:
x | = Input array [nr+2*nh elements]
h | = Coeff array [nh+1 elements]
r | = Output array [nr elements]
nh | = Number of coefficients
nr | = Number of output samples
s | = Number of insignificant digits to truncate e.g., 15 for Q.15 input data and coefficients
Algorithm:
DSP_fir_sym_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h, and r do not overlap.
x, h and r must be double word aligned.
nr >= 4; nr % 4 == 0.
nh >= 4; nh % 4 == 0.
Implementation Notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_iir

DSP_iir
[Filtering and convolution]

Collaboration diagram for DSP_iir:

Detailed Description

void DSP_iir (short *r1, const short *x, short *r2, const short *h2, const short *h1, int nr)

Function Documentation

void DSP_iir | ( | short * | r1,
 |  | const short * | x,
 |  | short * | r2,
 |  | const short * | h2,
 |  | const short * | h1,
 |  | int | nr
 | ) |  |

This real IIR computes nr real output samples using 4 Autoregressive filter coefficients and 5 Moving-average filter coefficients. It operates on 16-bit data with a 32-bit accumulate. The implementation is done in Direct Form I, for the below difference equation

r1(n) = h2(0) * x(n)
+ h2(1) * x(n-1) - h1(1) * r1(n-1)
+ h2(2) * x(n-2) - h1(2) * r1(n-2)
+ h2(3) * x(n-3) - h1(3) * r1(n-3)
+ h2(4) * x(n-4) - h1(4) * r1(n-4)

Parameters:
r1 | Pointer to real output data used.
x | Pointer to real input data.
r2 | Pointer to real output data stored.
h2 | Pointer to 5 Moving-average real filter coefficients.
h1 | Pointer to 4 Autoregressive real filter coefficients.
nr | Holds the value of number of real output samples.
Algorithm:
DSP_iir_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, h1, h2, r1 and r2 do not overlap
x must point to x[nr-4]
h1 points to h1[0], h1[0] is not used, all the coefficients are real
h2 points to h2[0], all the coefficietns are real
r1 must point to r1[nr-4], current response depends on previous 4 responses
r2 must point to r2[0], such that r1[4+i] = r2[nr], for i = 0 to nr;
nr >= 1;
Implementation Notes:
Interruptibility : The code is interruptible. Endian support : supports both Little and Big endian modes.


DSPLIB: DSP_iir_lat

DSP_iir_lat
[Filtering and convolution]

Collaboration diagram for DSP_iir_lat:

Detailed Description

void DSP_iir_lat (short *x, int nx, const short *restrict k, int nk, int *restrict b, short *r)

Function Documentation

void DSP_iir_lat | ( | short * | x,
 |  | int | nx,
 |  | const short *restrict | k,
 |  | int | nk,
 |  | int *restrict | b,
 |  | short * | r
 | ) |  |

This routine implements a real all-pole IIR filter in lattice structure (AR lattice). The filter consists of nk lattice stages. Each stage requires one reflection coefficient k and one delay element b. The routine takes an input vector x[] and returns the filter output in r[]. Prior to the first call of the routine the delay elements in b[] should be set to zero. The input data may have to be pre-scaled to avoid overflow or achieve better SNR. The reflections coefficients lie in the range -1.0 < k < 1.0. The order of the coefficients is such that k[nk-1] corresponds to the first lattice stage after the input and k[0] corresponds to the last stage.

Parameters:
x[nx] | = Input vector (16-bit)
nx | = Length of input vector.
k[nk] | = Reflection coefficients in Q.15 format
nk | = Number of reflection coefficients/lattice stages
b[nk+1] | = Delay line elements from previous call. Should be initialized to all zeros prior to the first call.
r[nx] | = Output vector (16-bit)
Algorithm:
DSP_iir_lat_cn.c is the natural C equivalent of the optimized intrinsic C code withoutrestrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
There are no assumptions.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.


DSPLIB: DSP_iir_ss

DSP_iir_ss
[Filtering and convolution]

Collaboration diagram for DSP_iir_ss:

Detailed Description

short DSP_iir_ss (short Input, const short *restrict Coefs, int nCoefs, short *restrict State)

Function Documentation

short DSP_iir_ss | ( | short | Input,
 |  | const short *restrict | Coefs,
 |  | int | nCoefs,
 |  | short *restrict | State
 | ) |  |

This function implements an IIR filter, with a number of biquad stages given by nCoefs / 4. It accepts a single sample of input and returns a single sample of output. Coefficients are expected to be in the range [-2.0, 2.0) with Q14 precision.

Parameters:
Input | = Single sample input
Coefs | = Coefficients with Q14 precision
nCoefs | = Number of coefficients
State | = State
Algorithm:
DSP_iir_ss_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Coefs and State are double word aligned.
nCoefs is a multiple of 4 and >= 4.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.


DSPLIB: Math

Math

Collaboration diagram for Math:

Detailed Description

Modules

DSP_add16
DSP_add32
DSP_dotprod
DSP_dotp_sqr
DSP_maxidx
DSP_maxval
DSP_minval
DSP_mul32
DSP_neg32
DSP_recip16
DSP_vecsumsq
DSP_w_vec


DSPLIB: DSP_add16

DSP_add16
[Math]

Collaboration diagram for DSP_add16:

Detailed Description

void DSP_add16 (short *restrict x, short *restrict y, short *restrict r, int nx)

Function Documentation

void DSP_add16 | ( | short *restrict | x,
 |  | short *restrict | y,
 |  | short *restrict | r,
 |  | int | nx
 | ) |  |

This program performs a addition on a vector. The result is stored in a vector.

Parameters:
x | = Input data array of shorts
y | = Input data array of shorts
r | = Output data array of shorts
nx | = Number of elements in the arrays
Algorithm:
DSP_add16_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, y, r do not overlap.
Arrays x, y, r are aligned on double word boundaries.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_add32

DSP_add32
[Math]

Collaboration diagram for DSP_add32:

Detailed Description

void DSP_add32 (const int *restrict x, const int *restrict y, int *restrict r, int nx)

Function Documentation

void DSP_add32 | ( | const int *restrict | x,
 |  | const int *restrict | y,
 |  | int *restrict | r,
 |  | int | nx
 | ) |  |

This program performs a addition on a vector. The result is stored in a vector.

Parameters:
x | = Input data array of int
y | = Input data array of int
r | = Output data array of int
nx | = Number of elements in the arrays
Algorithm:
DSP_add32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, y, r do not overlap.
Arrays x, y, r are aligned on double word boundaries.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_dotprod

DSP_dotprod
[Math]

Collaboration diagram for DSP_dotprod:

Detailed Description

int DSP_dotprod (short *restrict x, short *restrict y, int nx)

Function Documentation

int DSP_dotprod | ( | short *restrict | x,
 |  | short *restrict | y,
 |  | int | nx
 | ) |  |

This routine takes two vectors and calculates their dot product. The inputs are 16-bit short data and the output is a 32-bit number.

Parameters:
x | = First vector array
y | = Second vector array
nx | = Number of elements
Algorithm:
DSP_dotprod_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
The input length must be a multiple of 4.
The input data x[] and y[] are stored on double-word aligned boundaries.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_dotp_sqr

DSP_dotp_sqr
[Math]

Collaboration diagram for DSP_dotp_sqr:

Detailed Description

int DSP_dotp_sqr (int G, const short *x, const short *y, int *restrict r, int nx)

Function Documentation

int DSP_dotp_sqr | ( | int | G,
 |  | const short * | x,
 |  | const short * | y,
 |  | int *restrict | r,
 |  | int | nx
 | ) |  |

This routine performs an nx element dot product of x[ ] and y[ ] and stores it in r. It also squares each element of y[ ] and accumulates it in G. This computation of G is used in the VSELP coder.

Parameters:
G | = Calculated value of G (used in the VSELP coder)
x | = First vector array
y | = Second vector array
r | = Result of vector dot product of x and y
nx | = Number of elements
Algorithm:
DSP_dotp_sqr_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4 and greater than or equal to 12.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_maxidx

DSP_maxidx
[Math]

Collaboration diagram for DSP_maxidx:

Detailed Description

int DSP_maxidx (const short *x, int nx)

Function Documentation

int DSP_maxidx | ( | const short * | x,
 |  | int | nx
 | ) |  |

This routine finds the max value of a vector and returns the index of that value. The input array is treated as 16 separate columns that are interleaved throughout the array. If values in different columns are equal to the maximum value, then the element in the leftmost column is returned. If two values within a column are equal to the maximum, then the one with the lower index is returned. Column takes precedence over index. return int Index for vector element with maximum value.

Parameters:
x | = Pointer to input vector of size nx. Must be double-word aligned
nx | = Length of input data vector. Must be multiple of 16 and >=48
Algorithm:
DSP_maxidx_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 16 and greater than or equal to 32 The input vector x[ ] must be double-word aligned
Implementation notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible.


DSPLIB: DSP_maxval

DSP_maxval
[Math]

Collaboration diagram for DSP_maxval:

Detailed Description

short DSP_maxval (const short *restrict x, int nx)

Function Documentation

short DSP_maxval | ( | const short *restrict | x,
 |  | int | nx
 | ) |  |

This routine finds the element with maximum value in the input vector and returns that value.

Parameters:
x | = Pointer to input vector of size nx
nx | = Length of input data vector. Must be multiple of 8 and >=32
Algorithm:
DSP_maxval_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 8 and greater than or equal to 32.
The input vector x[ ] must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_minval

DSP_minval
[Math]

Collaboration diagram for DSP_minval:

Detailed Description

short DSP_minval (const short *restrict x, int nx)

Function Documentation

short DSP_minval | ( | const short *restrict | x,
 |  | int | nx
 | ) |  |

This routine finds the element with minimum value in the input vector and returns that value.

Parameters:
x | = Pointer to input vector of size nx
nx | = Length of input data vector. Must be multiple of 8 and >=32
Algorithm:
DSP_minval_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 8 and greater than or equal to 32.
The input vector x[ ] must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_mul32

DSP_mul32
[Math]

Collaboration diagram for DSP_mul32:

Detailed Description

void DSP_mul32 (const int *restrict x, const int *restrict y, int *restrict r, int nx)

Function Documentation

void DSP_mul32 | ( | const int *restrict | x,
 |  | const int *restrict | y,
 |  | int *restrict | r,
 |  | int | nx
 | ) |  |

The function performs a Q.31 x Q.31 multiply and returns the upper 32 bits of the result. The result of the intermediate multiplies are accumulated into a 40-bit long register pair, as there could be potential overflow. The contribution of the multiplication of the two lower 16-bit halves are not considered. The output is in Q.30 format. Results are accurate to least significant bit.

Parameters:
x | = Pointer to input data vector 1 of size nx
y | = Pointer to input data vector 2 of size nx
r | = Pointer to output data vector of size nx
nx | = Number of elements in input and output vectors
Algorithm:
DSP_mul32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4 and greater than or equal to 4.
Input and output vectors must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_neg32

DSP_neg32
[Math]

Collaboration diagram for DSP_neg32:

Detailed Description

void DSP_neg32 (const int *restrict x, int *restrict r, int nx)

Function Documentation

void DSP_neg32 | ( | const int *restrict | x,
 |  | int *restrict | r,
 |  | int | nx
 | ) |  |

This function negates the elements of a vector (32-bit elements). The input and output arrays must not be overlapped except for where the input and output pointers are exactly equal

Parameters:
x | = Pointer to input data vector of size nx with 32-bit elements
r | = Pointer to output data vector of size nx with 32-bit elements
nx | = Number of elements of input and output vectors
Algorithm:
DSP_neg32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4 and greater than or equal to 4.
The arrays x[ ] and r[ ] must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_recip16

DSP_recip16
[Math]

Collaboration diagram for DSP_recip16:

Detailed Description

void DSP_recip16 (const short *restrict x, short *restrict rfrac, short *restrict rexp, short nx)

Function Documentation

void DSP_recip16 | ( | const short *restrict | x,
 |  | short *restrict | rfrac,
 |  | short *restrict | rexp,
 |  | short | nx
 | ) |  |

This program performs a reciprocal on a vector of Q15 numbers. The result is stored in two parts: a Q15 part and an exponent (power of two) of the fraction. First, the input is loaded, then its absolute value is taken, then it is normalized, then divided using a loop of conditional subtracts, and finally it is negated if the original input was negative.

Parameters:
x | = Input data array of shorts
rfrac | = Output data array containing fractions
rexp | = Output data array containing exponents
nx | = Number of elements in the arrays
Algorithm:
DSP_recip16_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x, rfrac, and rexp do not overlap.
nx must be a multiple of 4 and greater than or equal to 4.
x must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_vecsumsq

DSP_vecsumsq
[Math]

Collaboration diagram for DSP_vecsumsq:

Detailed Description

int DSP_vecsumsq (const short *x, int nx)

Function Documentation

int DSP_vecsumsq | ( | const short * | x,
 |  | int | nx
 | ) |  |

This routine returns the sum of squares of the elements contained in the vector x[ ]. return Sum of the squares.

Parameters:
x | = Pointer to input data vector
nx | = Number of elements of input and output vectors
Algorithm:
DSP_vecsumsq_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4 and greater than or equal to 4.
x must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_w_vec

DSP_w_vec
[Math]

Collaboration diagram for DSP_w_vec:

Detailed Description

void DSP_w_vec (const short *restrict x, const short *restrict y, short m, short *restrict r, int nr)

Function Documentation

void DSP_w_vec | ( | const short *restrict | x,
 |  | const short *restrict | y,
 |  | short | m,
 |  | short *restrict | r,
 |  | int | nr
 | ) |  |

This routine is used to obtain the weighted vector sum. Both the inputs and output are 16-bit numbers

Parameters:
x | = Vector being weighted
y | = Summation vector
m | = Weighting factor
r | = Output vector
nr | = Dimensions of the vectors
Algorithm:
DSP_vecsumsq_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nr must be a multiple of 8 and >= 8.
Vectors x[ ] y[ ] and r[ ] must be double-word aligned.
m is not -32768.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: Matrix

Matrix

Collaboration diagram for Matrix:

Detailed Description

Modules

DSP_mat_mul
DSP_mat_mul_cplx
DSP_mat_trans


DSPLIB: DSP_mat_mul

DSP_mat_mul
[Matrix]

Collaboration diagram for DSP_mat_mul:

Detailed Description

void DSP_mat_mul (const short *restrict x, int r1, int c1, const short *restrict y, int c2, short *restrict r, int qs)

Function Documentation

void DSP_mat_mul | ( | const short *restrict | x,
 |  | int | r1,
 |  | int | c1,
 |  | const short *restrict | y,
 |  | int | c2,
 |  | short *restrict | r,
 |  | int | qs
 | ) |  |

This function computes the expression “r = x * y” for the matrices x and y. The columnar dimension of x must match the row dimension of y. The resulting matrix has the same number of rows as x and the same number of columns as y.
The values stored in the matrices are assumed to be fixed-point or integer values. All intermediate sums are retained to 32-bit precision, and no overflow checking is performed. The results are right-shifted by a user-specified amount, and then truncated to 16 bits.

Parameters:
x | = Pointer to input matrix of size r1*c1
r1 | = Number of rows in matrix x
c1 | = Number of columns in matrix x. Also number of rows in y
y | = Pointer to input matrix of size c1*c2
c2 | = Number of columns in matrix y
r | = Pointer to output matrix of size r1*c2
qs | = Final right-shift to apply to the result
Algorithm:
DSP_mat_mul.c is the natural C equivalent of the optimized intrinsic C code withoutrestrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
The arrays x[], y[], and r[] are stored in distinct arrays.
That is, in-place processing is not allowed.
x, y and r are double word aligned.
c1 is a multiple of 2 and >= 2.
c2 is a multiple of 4 and >= 4.
r1 is a multiple of 2 and >= 2.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.


DSPLIB: DSP_mat_mul_cplx

DSP_mat_mul_cplx
[Matrix]

Collaboration diagram for DSP_mat_mul_cplx:

Detailed Description

void DSP_mat_mul_cplx (const short *restrict x, int r1, int c1, const short *restrict y, int c2, short *restrict r, int qs)

Function Documentation

void DSP_mat_mul_cplx | ( | const short *restrict | x,
 |  | int | r1,
 |  | int | c1,
 |  | const short *restrict | y,
 |  | int | c2,
 |  | short *restrict | r,
 |  | int | qs
 | ) |  |

This function computes the expression “r = x * y” for complex matrices x and y. The columnar dimension of x must match the row dimension of y. The resulting matrix has the same number of rows as x and the same number of columns as y.

The values stored in the matrices are assumed to be type _CPLX16. Each array consists of an even and odd term with even terms representing the real part of the element and the odd terms the imaginary part. All intermediate sums are retained to 32-bit precision. The results are right-shifted by a user-specified amount, and then truncated to 16 bits.

Parameters:
x | = Pointer to input matrix of size r1*c1
r1 | = Number of rows in matrix x
c1 | = Number of columns in matrix x. Also number of rows in y
y | = Pointer to input matrix of size c1*c2
c2 | = Number of columns in matrix y
r | = Pointer to output matrix of size r1*c2
qs | = Final right-shift to apply to the result
Algorithm:
DSP_mat_mul_cplx.c is the natural C equivalent of the optimized intrinsic C code without restrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
The arrays x[], y[], and r[] are stored in distinct arrays.
That is, in-place processing is not allowed.
The arrays x[], y[], and r[] are aligned on double word boundaries.
r1, c1, c2 are multiples of 2 and >= 4.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.


DSPLIB: DSP_mat_trans

DSP_mat_trans
[Matrix]

Collaboration diagram for DSP_mat_trans:

Detailed Description

void DSP_mat_trans (const short *restrict x, short rows, short columns, short *restrict r)

Function Documentation

void DSP_mat_trans | ( | const short *restrict | x,
 |  | short | rows,
 |  | short | columns,
 |  | short *restrict | r
 | ) |  |

This function transposes the input matrix x[ ] and writes the result to matrix r[ ]

Parameters:
x | = Pointer to input matrix
rows | = Number of rows in the input matrix
columns | = Number of columns in the input matrix
r | = Pointer to output matrix
Algorithm:
DSP_mat_trans.c is the natural C equivalent of the optimized intrinsic C code withoutrestrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Rows and columns must be a multiple of 4.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.


DSPLIB: Miscellaneous

Miscellaneous

Collaboration diagram for Miscellaneous:

Detailed Description

Modules

DSP_bexp
DSP_blk_eswap16
DSP_blk_eswap32
DSP_blk_eswap64
DSP_blk_move
DSP_fltoq15
DSP_minerror
DSP_q15tofl


DSPLIB: DSP_bexp

DSP_bexp
[Miscellaneous]

Collaboration diagram for DSP_bexp:

Detailed Description

int DSP_bexp (const int *x, short nx)

Function Documentation

int DSP_bexp | ( | const int * | x,
 |  | short | nx
 | ) |  |

The bexp function, performs a determination of the block exponent of the vector of elements and returns the maximum exponent. This information can then be used to re-normalize the vector. This operation is useful when auto-scaling is required as in a FFT. The bexp operation returns the minimum norm of the vector. The minimum norm corresponds to the maximum exponent.

Parameters:
x | = Input data array of integers
nx | = Number of elements in the input data
Algorithm:
DSP_bexp_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Arrays x and r cannot overlap.
x must be double word alligned.
nx is a multiple of 8.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_blk_eswap16

DSP_blk_eswap16
[Miscellaneous]

Collaboration diagram for DSP_blk_eswap16:

Detailed Description

void DSP_blk_eswap16 (void *restrict src, void *restrict dst, int n_hwords)

Function Documentation

void DSP_blk_eswap16 | ( | void *restrict | src,
 |  | void *restrict | dst,
 |  | int | n_hwords
 | ) |  |

The data in the x[] array is endian swapped, meaning that the byte-order of the bytes within each half-word of the r[] array is reversed. This facilitates moving big-endian data to a little-endian system or vice-versa. When the r pointer is non-NULL, the endian-swap occurs out-of-place, similar to a block move. When the r pointer is NULL, the endian-swap occurs in-place, allowing the swap to occur without using any additional storage.

Parameters:
src | = Source data, must be double-word aligned.
dst | = Destination data, must be double-word aligned.
n_hwords | = Number of 16-bit elements to swap.
Algorithm:
DSP_blk_eswap16_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Input and output arrays do not overlap, except when “dst == NULL” so that the operation occurs in-place.
The input array and output array are double-word aligned.
nx is a multiple of 8.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_blk_eswap32

DSP_blk_eswap32
[Miscellaneous]

Collaboration diagram for DSP_blk_eswap32:

Detailed Description

void DSP_blk_eswap32 (void *restrict src, void *restrict dst, int n_words)

Function Documentation

void DSP_blk_eswap32 | ( | void *restrict | src,
 |  | void *restrict | dst,
 |  | int | n_words
 | ) |  |

The data in the x[] array is endian swapped, meaning that the byte-order of the bytes within each word of the r[] array is reversed. This facilitates moving big-endian data to a little-endian system or vice-versa. When the r pointer is non-NULL, the endian-swap occurs out-of-place, similar to a block move. When the r pointer is NULL, the endian-swap occurs in-place, allowing the swap to occur without using any additional storage.

Parameters:
src | = Source data, must be double-word aligned.
dst | = Destination data, must be double-word aligned.
n_words | = Number of 32-bit elements to swap.
Algorithm:
DSP_blk_eswap32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Input and output arrays do not overlap, except when “dst == NULL” so that the operation occurs in-place.
The input array and output array are double-word aligned.
nx is a multiple of 4.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_blk_eswap64

DSP_blk_eswap64
[Miscellaneous]

Collaboration diagram for DSP_blk_eswap64:

Detailed Description

void DSP_blk_eswap64 (void *restrict src, void *restrict dst, int n_dbls)

Function Documentation

void DSP_blk_eswap64 | ( | void *restrict | src,
 |  | void *restrict | dst,
 |  | int | n_dbls
 | ) |  |

The data in the x[] array is endian swapped, meaning that the byte-order of the bytes within each double-word of the r[] array is reversed. This facilitates moving big-endian data to a little-endian system or vice-versa. When the r pointer is non-NULL, the endian-swap occurs out-of-place, similar to a block move. When the r pointer is NULL, the endian-swap occurs in-place, allowing the swap to occur without using any additional storage.

Parameters:
src | = Source data, must be double-word aligned.
dst | = Destination data, must be double-word aligned.
n_dbls | = Number of 64-bit elements to swap.
Algorithm:
DSP_blk_eswap64_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Input and output arrays do not overlap, except when “dst == NULL” so that the operation occurs in-place.
The input array and output array are double-word aligned.
nx is a multiple of 2.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_blk_move

DSP_blk_move
[Miscellaneous]

Collaboration diagram for DSP_blk_move:

Detailed Description

void DSP_blk_move (short *restrict x, short *restrict r, int nx)

Function Documentation

void DSP_blk_move | ( | short *restrict | x,
 |  | short *restrict | r,
 |  | int | nx
 | ) |  |

This routine moves nx 16-bit elements from one memory location pointed to by x to another pointed to by r. The source and destination blocks can be overlapped.

Parameters:
x | = Block of data to be moved
r | = Destination of block of data
nx | = Number of elements in block
Algorithm:
DSP_blk_move.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 8 and greater than or equal to 8.
x and r must be double word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_fltoq15

DSP_fltoq15
[Miscellaneous]

Collaboration diagram for DSP_fltoq15:

Detailed Description

void DSP_fltoq15 (const float *restrict flt, short *restrict q15, short nx)

Function Documentation

void DSP_fltoq15 | ( | const float *restrict | flt,
 |  | short *restrict | q15,
 |  | short | nx
 | ) |  |

Convert the IEEE floating point numbers stored in vector x[ ] into Q.15 format numbers stored in vector r[ ]. Results are truncated toward zero. Values that exceed the size limit will be saturated to 0x7fff if value is positive and 0x8000 if value is negative. All values too small to be correctly represented will be truncated to 0.

Parameters:
flt | = Pointer to floating-point input vector of size nx. x should contain the numbers normalized between [-1,1)
q15 | = Pointer to output data vector of size nx containing the Q.15 equivalent of vector x.
nx | = Length of input and output data vectors. Must be multiple of 2
Algorithm:
DSP_fltoq15_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 2
Implementation notes:
Endian Support: The code supports both big and little endian modes. Interruptibility: The code is interruptible


DSPLIB: DSP_minerror

DSP_minerror
[Miscellaneous]

Collaboration diagram for DSP_minerror:

Detailed Description

int DSP_minerror (const short *restrict GSP0_TABLE, const short *restrict errCoefs, int *restrict max_index)

Function Documentation

int DSP_minerror | ( | const short *restrict | GSP0_TABLE,
 |  | const short *restrict | errCoefs,
 |  | int *restrict | max_index
 | ) |  |

Returns Maximum dot product result

Parameters:
GSP0_TABLE[9*256] | = GSP0 terms array. Must be double-word aligned
errCoefs[9] | = Array of error coefficients
max_index | = Pointer to GSP0_TABLE[max_index] found
Algorithm:
DSP_minerror_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Array GSP0_TABLE[] must be double-word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSP_q15tofl

DSP_q15tofl
[Miscellaneous]

Collaboration diagram for DSP_q15tofl:

Detailed Description

void DSP_q15tofl (const short *restrict q15, float *restrict flt, int nx)

Function Documentation

void DSP_q15tofl | ( | const short *restrict | q15,
 |  | float *restrict | flt,
 |  | int | nx
 | ) |  |

Converts the values stored in vector x[ ] in Q.15 format to IEEE floating point numbers in output vector r[ ]

Parameters:
q15 | = Pointer to Q.15 input vector of size nx
flt | = Pointer to floating-point output data vector of size nx containing the floating-point equivalent of vector x
nx | = Length of input and output data vectors
Algorithm:
DSP_q15tofl_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4.
q15 and flt are double word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: File Index

  • File List
  • Globals

DSPLIB File List

Here is a list of all files with brief descriptions:
doxygen.h [code]
DSP_add16.h [code]
c64P/DSP_add16.h [code]
DSP_add32.h [code]
c64P/DSP_add32.h [code]
DSP_autocor.h [code]
c64P/DSP_autocor.h [code]
DSP_bexp.h [code]
c64P/DSP_bexp.h [code]
DSP_blk_eswap16.h [code]
c64P/DSP_blk_eswap16.h [code]
DSP_blk_eswap32.h [code]
c64P/DSP_blk_eswap32.h [code]
DSP_blk_eswap64.h [code]
c64P/DSP_blk_eswap64.h [code]
DSP_blk_move.h [code]
c64P/DSP_blk_move.h [code]
DSP_dotp_sqr.h [code]
c64P/DSP_dotp_sqr.h [code]
DSP_dotprod.h [code]
c64P/DSP_dotprod.h [code]
DSP_fft16x16.h [code]
c64P/DSP_fft16x16.h [code]
DSP_fft16x16_imre.h [code]
c64P/DSP_fft16x16_imre.h [code]
DSP_fft16x16r.h [code]
c64P/DSP_fft16x16r.h [code]
DSP_fft16x32.h [code]
c64P/DSP_fft16x32.h [code]
DSP_fft32x32.h [code]
c64P/DSP_fft32x32.h [code]
DSP_fft32x32s.h [code]
c64P/DSP_fft32x32s.h [code]
DSP_fir_cplx.h [code]
c64P/DSP_fir_cplx.h [code]
DSP_fir_cplx_hM4X4.h [code]
c64P/DSP_fir_cplx_hM4X4.h [code]
DSP_fir_gen.h [code]
c64P/DSP_fir_gen.h [code]
DSP_fir_gen_hM17_rA8X8.h [code]
c64P/DSP_fir_gen_hM17_rA8X8.h [code]
DSP_fir_r4.h [code]
c64P/DSP_fir_r4.h [code]
DSP_fir_r8.h [code]
c64P/DSP_fir_r8.h [code]
DSP_fir_r8_hM16_rM8A8X8.h [code]
c64P/DSP_fir_r8_hM16_rM8A8X8.h [code]
DSP_fir_sym.h [code]
c64P/DSP_fir_sym.h [code]
DSP_firlms2.h [code]
c64P/DSP_firlms2.h [code]
DSP_fltoq15.h [code]
c64P/DSP_fltoq15.h [code]
DSP_ifft16x16.h [code]
c64P/DSP_ifft16x16.h [code]
DSP_ifft16x16_imre.h [code]
c64P/DSP_ifft16x16_imre.h [code]
DSP_ifft16x32.h [code]
c64P/DSP_ifft16x32.h [code]
DSP_ifft32x32.h [code]
c64P/DSP_ifft32x32.h [code]
DSP_iir.h [code]
c64P/DSP_iir.h [code]
DSP_iir_lat.h [code]
c64P/DSP_iir_lat.h [code]
DSP_iir_ss.h [code]
c64P/DSP_iir_ss.h [code]
DSP_mat_mul.h [code]
c64P/DSP_mat_mul.h [code]
DSP_mat_mul_cplx.h [code]
c64P/DSP_mat_mul_cplx.h [code]
DSP_mat_trans.h [code]
c64P/DSP_mat_trans.h [code]
DSP_maxidx.h [code]
c64P/DSP_maxidx.h [code]
DSP_maxval.h [code]
c64P/DSP_maxval.h [code]
DSP_minerror.h [code]
c64P/DSP_minerror.h [code]
DSP_minval.h [code]
c64P/DSP_minval.h [code]
DSP_mul32.h [code]
c64P/DSP_mul32.h [code]
DSP_neg32.h [code]
c64P/DSP_neg32.h [code]
DSP_q15tofl.h [code]
c64P/DSP_q15tofl.h [code]
DSP_recip16.h [code]
c64P/DSP_recip16.h [code]
DSP_vecsumsq.h [code]
c64P/DSP_vecsumsq.h [code]
DSP_w_vec.h [code]
c64P/DSP_w_vec.h [code]


DSPLIB: doxygen.h File Reference

doxygen.h File Reference

Go to the source code of this file.


DSPLIB: DSP_add16.h File Reference

DSP_add16.h File Reference

Go to the source code of this file.

Defines

#define _DSP_ADD16_H_ 1

Define Documentation

#define _DSP_ADD16_H_ 1

Definition at line 40 of file DSP_add16.h.


DSPLIB: DSP_add16.h File Reference

DSP_add16.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_add16.h:

Go to the source code of this file.

Defines

#define | DSP_ADD16_H_ 1

Functions

void | DSP_add16 (short *restrict x, short *restrict y, short *restrict r, int nx)

Define Documentation

#define DSP_ADD16_H_ 1

Definition at line 40 of file c64P/DSP_add16.h.


DSPLIB: DSP_add32.h File Reference

DSP_add32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_ADD32_H_ 1

Define Documentation

#define _DSP_ADD32_H_ 1

Definition at line 40 of file DSP_add32.h.


DSPLIB: DSP_add32.h File Reference

DSP_add32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_add32.h:

Go to the source code of this file.

Defines

#define | DSP_ADD32_H_ 1

Functions

void | DSP_add32 (const int *restrict x, const int *restrict y, int *restrict r, int nx)

Define Documentation

#define DSP_ADD32_H_ 1

Definition at line 40 of file c64P/DSP_add32.h.


DSPLIB: DSP_autocor.h File Reference

DSP_autocor.h File Reference

Go to the source code of this file.

Defines

#define _DSP_AUTOCOR_H_ 1

Define Documentation

#define _DSP_AUTOCOR_H_ 1

Definition at line 40 of file DSP_autocor.h.


DSPLIB: DSP_autocor.h File Reference

DSP_autocor.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_autocor.h:

Go to the source code of this file.

Defines

#define | DSP_AUTOCOR_H_ 1

Functions

void | DSP_autocor (short *restrict r, const short *restrict x, int nx, int nr)

Define Documentation

#define DSP_AUTOCOR_H_ 1

Definition at line 39 of file c64P/DSP_autocor.h.


DSPLIB: DSP_bexp.h File Reference

DSP_bexp.h File Reference

Go to the source code of this file.

Defines

#define _DSP_BEXP_H_ 1

Define Documentation

#define _DSP_BEXP_H_ 1

Definition at line 40 of file DSP_bexp.h.


DSPLIB: DSP_bexp.h File Reference

DSP_bexp.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_bexp.h:

Go to the source code of this file.

Functions

int DSP_bexp (const int *x, short nx)


DSPLIB: DSP_blk_eswap16.h File Reference

DSP_blk_eswap16.h File Reference

Go to the source code of this file.

Defines

#define _DSP_BLK_ESWAP16_H_ 1

Define Documentation

#define _DSP_BLK_ESWAP16_H_ 1

Definition at line 40 of file DSP_blk_eswap16.h.


DSPLIB: DSP_blk_eswap16.h File Reference

DSP_blk_eswap16.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_blk_eswap16.h:

Go to the source code of this file.

Defines

#define | DSP_BLK_ESWAP16_H_ 1

Functions

void | DSP_blk_eswap16 (void *restrict src, void *restrict dst, int n_hwords)

Define Documentation

#define DSP_BLK_ESWAP16_H_ 1

Definition at line 41 of file c64P/DSP_blk_eswap16.h.


DSPLIB: DSP_blk_eswap32.h File Reference

DSP_blk_eswap32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_BLK_ESWAP32_H_ 1

Define Documentation

#define _DSP_BLK_ESWAP32_H_ 1

Definition at line 40 of file DSP_blk_eswap32.h.


DSPLIB: DSP_blk_eswap32.h File Reference

DSP_blk_eswap32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_blk_eswap32.h:

Go to the source code of this file.

Defines

#define | DSP_BLK_ESWAP32_H_ 1

Functions

void | DSP_blk_eswap32 (void *restrict src, void *restrict dst, int n_words)

Define Documentation

#define DSP_BLK_ESWAP32_H_ 1

Definition at line 41 of file c64P/DSP_blk_eswap32.h.


DSPLIB: DSP_blk_eswap64.h File Reference

DSP_blk_eswap64.h File Reference

Go to the source code of this file.

Defines

#define _DSP_BLK_ESWAP64_H_ 1

Define Documentation

#define _DSP_BLK_ESWAP64_H_ 1

Definition at line 40 of file DSP_blk_eswap64.h.


DSPLIB: DSP_blk_eswap64.h File Reference

DSP_blk_eswap64.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_blk_eswap64.h:

Go to the source code of this file.

Defines

#define | DSP_BLK_ESWAP64_H_ 1

Functions

void | DSP_blk_eswap64 (void *restrict src, void *restrict dst, int n_dbls)

Define Documentation

#define DSP_BLK_ESWAP64_H_ 1

Definition at line 42 of file c64P/DSP_blk_eswap64.h.


DSPLIB: DSP_blk_move.h File Reference

DSP_blk_move.h File Reference

Go to the source code of this file.

Defines

#define _DSP_BLK_MOVE_H_ 1

Define Documentation

#define _DSP_BLK_MOVE_H_ 1

Definition at line 40 of file DSP_blk_move.h.


DSPLIB: DSP_blk_move.h File Reference

DSP_blk_move.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_blk_move.h:

Go to the source code of this file.

Defines

#define | DSP_BLK_MOVE_H_ 1

Functions

void | DSP_blk_move (short *restrict x, short *restrict r, int nx)

Define Documentation

#define DSP_BLK_MOVE_H_ 1

Definition at line 41 of file c64P/DSP_blk_move.h.


DSPLIB: DSP_dotp_sqr.h File Reference

DSP_dotp_sqr.h File Reference

Go to the source code of this file.

Defines

#define _DSP_DOTP_SQR_H_ 1

Define Documentation

#define _DSP_DOTP_SQR_H_ 1

Definition at line 40 of file DSP_dotp_sqr.h.


DSPLIB: DSP_dotp_sqr.h File Reference

DSP_dotp_sqr.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_dotp_sqr.h:

Go to the source code of this file.

Functions

int DSP_dotp_sqr (int G, const short *x, const short *y, int *restrict r, int nx)


DSPLIB: DSP_dotprod.h File Reference

DSP_dotprod.h File Reference

Go to the source code of this file.

Defines

#define _DSP_DOTPROD_H_ 1

Define Documentation

#define _DSP_DOTPROD_H_ 1

Definition at line 40 of file DSP_dotprod.h.


DSPLIB: DSP_dotprod.h File Reference

DSP_dotprod.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_dotprod.h:

Go to the source code of this file.

Functions

int DSP_dotprod (short *restrict x, short *restrict y, int nx)


DSPLIB: DSP_fft16x16.h File Reference

DSP_fft16x16.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FFT16X16_H_ 1

Define Documentation

#define _DSP_FFT16X16_H_ 1

Definition at line 40 of file DSP_fft16x16.h.


DSPLIB: DSP_fft16x16.h File Reference

DSP_fft16x16.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fft16x16.h:

Go to the source code of this file.

Defines

#define | DSP_FFT16X16_H_ 1

Functions

void | DSP_fft16x16 (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)

Define Documentation

#define DSP_FFT16X16_H_ 1

Definition at line 41 of file c64P/DSP_fft16x16.h.


DSPLIB: DSP_fft16x16_imre.h File Reference

DSP_fft16x16_imre.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FFT16X16_IMRE_H_ 1

Define Documentation

#define _DSP_FFT16X16_IMRE_H_ 1

Definition at line 40 of file DSP_fft16x16_imre.h.


DSPLIB: DSP_fft16x16_imre.h File Reference

DSP_fft16x16_imre.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fft16x16_imre.h:

Go to the source code of this file.

Defines

#define | FFT16X16_IMRE_H_ 1

Functions

void | DSP_fft16x16_imre (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)

Define Documentation

#define FFT16X16_IMRE_H_ 1

Definition at line 42 of file c64P/DSP_fft16x16_imre.h.


DSPLIB: DSP_fft16x16r.h File Reference

DSP_fft16x16r.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FFT16X16R_H_ 1

Define Documentation

#define _DSP_FFT16X16R_H_ 1

Definition at line 40 of file DSP_fft16x16r.h.


DSPLIB: DSP_fft16x16r.h File Reference

DSP_fft16x16r.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fft16x16r.h:

Go to the source code of this file.

Defines

#define | DSP_FFT16X16R_H_ 1

Functions

void | DSP_fft16x16r (int n, short *restrict ptr_x, const short *restrict ptr_w, short *restrict ptr_y, int radix, int offset, int n_max)

Define Documentation

#define DSP_FFT16X16R_H_ 1

Definition at line 41 of file c64P/DSP_fft16x16r.h.


DSPLIB: DSP_fft16x32.h File Reference

DSP_fft16x32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FFT16X32_H_ 1

Define Documentation

#define _DSP_FFT16X32_H_ 1

Definition at line 40 of file DSP_fft16x32.h.


DSPLIB: DSP_fft16x32.h File Reference

DSP_fft16x32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fft16x32.h:

Go to the source code of this file.

Defines

#define | DSP_FFT16X32_H_ 1

Functions

void | DSP_fft16x32 (const short *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Define Documentation

#define DSP_FFT16X32_H_ 1

Definition at line 41 of file c64P/DSP_fft16x32.h.


DSPLIB: DSP_fft32x32.h File Reference

DSP_fft32x32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FFT32X32_H_ 1

Define Documentation

#define _DSP_FFT32X32_H_ 1

Definition at line 40 of file DSP_fft32x32.h.


DSPLIB: DSP_fft32x32.h File Reference

DSP_fft32x32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fft32x32.h:

Go to the source code of this file.

Defines

#define | DSP_FFT32X32_H_ 1

Functions

void | DSP_fft32x32 (const int *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Define Documentation

#define DSP_FFT32X32_H_ 1

Definition at line 42 of file c64P/DSP_fft32x32.h.


DSPLIB: DSP_fft32x32s.h File Reference

DSP_fft32x32s.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FFT32X32S_H_ 1

Define Documentation

#define _DSP_FFT32X32S_H_ 1

Definition at line 40 of file DSP_fft32x32s.h.


DSPLIB: DSP_fft32x32s.h File Reference

DSP_fft32x32s.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fft32x32s.h:

Go to the source code of this file.

Defines

#define | DSP_FFT32X32S_H_ 1

Functions

void | DSP_fft32x32s (const int *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Define Documentation

#define DSP_FFT32X32S_H_ 1

Definition at line 42 of file c64P/DSP_fft32x32s.h.


DSPLIB: DSP_fir_cplx.h File Reference

DSP_fir_cplx.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_CPLX_H_ 1

Define Documentation

#define _DSP_FIR_CPLX_H_ 1

Definition at line 40 of file DSP_fir_cplx.h.


DSPLIB: DSP_fir_cplx.h File Reference

DSP_fir_cplx.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_cplx.h:

Go to the source code of this file.

Functions

void DSP_fir_cplx (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)


DSPLIB: DSP_fir_cplx_hM4X4.h File Reference

DSP_fir_cplx_hM4X4.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_CPLX_HM4X4_H_ 1

Define Documentation

#define _DSP_FIR_CPLX_HM4X4_H_ 1

Definition at line 40 of file DSP_fir_cplx_hM4X4.h.


DSPLIB: DSP_fir_cplx_hM4X4.h File Reference

DSP_fir_cplx_hM4X4.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_cplx_hM4X4.h:

Go to the source code of this file.

Functions

void DSP_fir_cplx_hM4X4 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)


DSPLIB: DSP_fir_gen.h File Reference

DSP_fir_gen.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_GEN_H_ 1

Define Documentation

#define _DSP_FIR_GEN_H_ 1

Definition at line 40 of file DSP_fir_gen.h.


DSPLIB: DSP_fir_gen.h File Reference

DSP_fir_gen.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_gen.h:

Go to the source code of this file.

Functions

void DSP_fir_gen (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)


DSPLIB: DSP_fir_gen_hM17_rA8X8.h File Reference

DSP_fir_gen_hM17_rA8X8.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_GEN_HM17_RA8X8_H_ 1

Define Documentation

#define _DSP_FIR_GEN_HM17_RA8X8_H_ 1

Definition at line 40 of file DSP_fir_gen_hM17_rA8X8.h.


DSPLIB: DSP_fir_gen_hM17_rA8X8.h File Reference

DSP_fir_gen_hM17_rA8X8.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_gen_hM17_rA8X8.h:

Go to the source code of this file.

Defines

#define | DSP_FIR_GEN_HM17_RA8X8_H_ 1

Functions

void | DSP_fir_gen_hM17_rA8X8 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Define Documentation

#define DSP_FIR_GEN_HM17_RA8X8_H_ 1

Definition at line 41 of file c64P/DSP_fir_gen_hM17_rA8X8.h.


DSPLIB: DSP_fir_r4.h File Reference

DSP_fir_r4.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_R4_H_ 1

Define Documentation

#define _DSP_FIR_R4_H_ 1

Definition at line 40 of file DSP_fir_r4.h.


DSPLIB: DSP_fir_r4.h File Reference

DSP_fir_r4.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_r4.h:

Go to the source code of this file.

Functions

void DSP_fir_r4 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)


DSPLIB: DSP_fir_r8.h File Reference

DSP_fir_r8.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_R8_H_ 1

Define Documentation

#define _DSP_FIR_R8_H_ 1

Definition at line 40 of file DSP_fir_r8.h.


DSPLIB: DSP_fir_r8.h File Reference

DSP_fir_r8.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_r8.h:

Go to the source code of this file.

Defines

#define | DSP_FIR_R8_H_ 1

Functions

void | DSP_fir_r8 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Define Documentation

#define DSP_FIR_R8_H_ 1

Definition at line 41 of file c64P/DSP_fir_r8.h.


DSPLIB: DSP_fir_r8_hM16_rM8A8X8.h File Reference

DSP_fir_r8_hM16_rM8A8X8.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_R8_HM16_RM8A8X8_H_ 1

Define Documentation

#define _DSP_FIR_R8_HM16_RM8A8X8_H_ 1

Definition at line 40 of file DSP_fir_r8_hM16_rM8A8X8.h.


DSPLIB: DSP_fir_r8_hM16_rM8A8X8.h File Reference

DSP_fir_r8_hM16_rM8A8X8.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_r8_hM16_rM8A8X8.h:

Go to the source code of this file.

Defines

#define | DSP_FIR_R8_HM16_RM8A8X8_H_ 1

Functions

void | DSP_fir_r8_hM16_rM8A8X8 (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr)

Define Documentation

#define DSP_FIR_R8_HM16_RM8A8X8_H_ 1

Definition at line 41 of file c64P/DSP_fir_r8_hM16_rM8A8X8.h.


DSPLIB: DSP_fir_sym.h File Reference

DSP_fir_sym.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIR_SYM_H_ 1

Define Documentation

#define _DSP_FIR_SYM_H_ 1

Definition at line 40 of file DSP_fir_sym.h.


DSPLIB: DSP_fir_sym.h File Reference

DSP_fir_sym.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fir_sym.h:

Go to the source code of this file.

Defines

#define | DSP_FIR_SYM_H_ 1

Functions

void | DSP_fir_sym (const short *restrict x, const short *restrict h, short *restrict r, int nh, int nr, int s)

Define Documentation

#define DSP_FIR_SYM_H_ 1

Definition at line 41 of file c64P/DSP_fir_sym.h.


DSPLIB: DSP_firlms2.h File Reference

DSP_firlms2.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FIRLMS2_H_ 1

Define Documentation

#define _DSP_FIRLMS2_H_ 1

Definition at line 40 of file DSP_firlms2.h.


DSPLIB: DSP_firlms2.h File Reference

DSP_firlms2.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_firlms2.h:

Go to the source code of this file.

Defines

#define | DSP_FIRLMS2_H_ 1

Functions

int | DSP_firlms2 (short *restrict h, short *restrict x, short b, int nh)

Define Documentation

#define DSP_FIRLMS2_H_ 1

Definition at line 41 of file c64P/DSP_firlms2.h.


DSPLIB: DSP_fltoq15.h File Reference

DSP_fltoq15.h File Reference

Go to the source code of this file.

Defines

#define _DSP_FLTOQ15_H_ 1

Define Documentation

#define _DSP_FLTOQ15_H_ 1

Definition at line 40 of file DSP_fltoq15.h.


DSPLIB: DSP_fltoq15.h File Reference

DSP_fltoq15.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_fltoq15.h:

Go to the source code of this file.

Defines

#define | DSP_FLTOQ15_H_ 1

Functions

void | DSP_fltoq15 (const float *restrict flt, short *restrict q15, short nx)

Define Documentation

#define DSP_FLTOQ15_H_ 1

Definition at line 41 of file c64P/DSP_fltoq15.h.


DSPLIB: DSP_ifft16x16.h File Reference

DSP_ifft16x16.h File Reference

Go to the source code of this file.


DSPLIB: DSP_ifft16x16.h File Reference

DSP_ifft16x16.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_ifft16x16.h:

Go to the source code of this file.

Functions

void DSP_ifft16x16 (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)


DSPLIB: DSP_ifft16x16_imre.h File Reference

DSP_ifft16x16_imre.h File Reference

Go to the source code of this file.


DSPLIB: DSP_ifft16x16_imre.h File Reference

DSP_ifft16x16_imre.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_ifft16x16_imre.h:

Go to the source code of this file.

Functions

void DSP_ifft16x16_imre (const short *restrict ptr_w, int npoints, short *restrict ptr_x, short *restrict ptr_y)


DSPLIB: DSP_ifft16x32.h File Reference

DSP_ifft16x32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_IFFT16X32_H_ 1

Define Documentation

#define _DSP_IFFT16X32_H_ 1

Definition at line 40 of file DSP_ifft16x32.h.


DSPLIB: DSP_ifft16x32.h File Reference

DSP_ifft16x32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_ifft16x32.h:

Go to the source code of this file.

Defines

#define | DSP_IFFT16X32_H_ 1

Functions

void | DSP_ifft16x32 (const short *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Define Documentation

#define DSP_IFFT16X32_H_ 1

Definition at line 41 of file c64P/DSP_ifft16x32.h.


DSPLIB: DSP_ifft32x32.h File Reference

DSP_ifft32x32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_IFFT32X32_H_ 1

Define Documentation

#define _DSP_IFFT32X32_H_ 1

Definition at line 40 of file DSP_ifft32x32.h.


DSPLIB: DSP_ifft32x32.h File Reference

DSP_ifft32x32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_ifft32x32.h:

Go to the source code of this file.

Defines

#define | DSP_IFFT32X32_H_ 1

Functions

void | DSP_ifft32x32 (const int *restrict ptr_w, int npoints, int *restrict ptr_x, int *restrict ptr_y)

Define Documentation

#define DSP_IFFT32X32_H_ 1

Definition at line 41 of file c64P/DSP_ifft32x32.h.


DSPLIB: DSP_iir.h File Reference

DSP_iir.h File Reference

Go to the source code of this file.

Defines

#define _DSP_IIR_H_ 1

Define Documentation

#define _DSP_IIR_H_ 1

Definition at line 40 of file DSP_iir.h.


DSPLIB: DSP_iir.h File Reference

DSP_iir.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_iir.h:

Go to the source code of this file.

Functions

void DSP_iir (short *r1, const short *x, short *r2, const short *h2, const short *h1, int nr)


DSPLIB: DSP_iir_lat.h File Reference

DSP_iir_lat.h File Reference

Go to the source code of this file.

Defines

#define _DSP_IIR_LAT_H_ 1

Define Documentation

#define _DSP_IIR_LAT_H_ 1

Definition at line 40 of file DSP_iir_lat.h.


DSPLIB: DSP_iir_lat.h File Reference

DSP_iir_lat.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_iir_lat.h:

Go to the source code of this file.

Defines

#define | DSP_IIR_LAT_H_ 1

Functions

void | DSP_iir_lat (short *x, int nx, const short *restrict k, int nk, int *restrict b, short *r)

Define Documentation

#define DSP_IIR_LAT_H_ 1

Definition at line 41 of file c64P/DSP_iir_lat.h.


DSPLIB: DSP_iir_ss.h File Reference

DSP_iir_ss.h File Reference

Go to the source code of this file.

Defines

#define _DSP_IIR_SS_H_ 1

Define Documentation

#define _DSP_IIR_SS_H_ 1

Definition at line 40 of file DSP_iir_ss.h.


DSPLIB: DSP_iir_ss.h File Reference

DSP_iir_ss.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_iir_ss.h:

Go to the source code of this file.

Functions

short DSP_iir_ss (short Input, const short *restrict Coefs, int nCoefs, short *restrict State)


DSPLIB: DSP_mat_mul.h File Reference

DSP_mat_mul.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MAT_MUL_H_ 1

Define Documentation

#define _DSP_MAT_MUL_H_ 1

Definition at line 40 of file DSP_mat_mul.h.


DSPLIB: DSP_mat_mul.h File Reference

DSP_mat_mul.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_mat_mul.h:

Go to the source code of this file.

Defines

#define | DSP_MAT_MUL_H_ 1

Functions

void | DSP_mat_mul (const short *restrict x, int r1, int c1, const short *restrict y, int c2, short *restrict r, int qs)

Define Documentation

#define DSP_MAT_MUL_H_ 1

Definition at line 41 of file c64P/DSP_mat_mul.h.


DSPLIB: DSP_mat_mul_cplx.h File Reference

DSP_mat_mul_cplx.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MAT_MUL_CPLX_H_ 1

Define Documentation

#define _DSP_MAT_MUL_CPLX_H_ 1

Definition at line 40 of file DSP_mat_mul_cplx.h.


DSPLIB: DSP_mat_mul_cplx.h File Reference

DSP_mat_mul_cplx.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_mat_mul_cplx.h:

Go to the source code of this file.

Defines

#define | DSP_MAT_MUL_CPLX_H_ 1

Functions

void | DSP_mat_mul_cplx (const short *restrict x, int r1, int c1, const short *restrict y, int c2, short *restrict r, int qs)

Define Documentation

#define DSP_MAT_MUL_CPLX_H_ 1

Definition at line 41 of file c64P/DSP_mat_mul_cplx.h.


DSPLIB: DSP_mat_trans.h File Reference

DSP_mat_trans.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MAT_TRANS_H_ 1

Define Documentation

#define _DSP_MAT_TRANS_H_ 1

Definition at line 40 of file DSP_mat_trans.h.


DSPLIB: DSP_mat_trans.h File Reference

DSP_mat_trans.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_mat_trans.h:

Go to the source code of this file.

Defines

#define | DSP_MAT_TRANS_H_ 1

Functions

void | DSP_mat_trans (const short *restrict x, short rows, short columns, short *restrict r)

Define Documentation

#define DSP_MAT_TRANS_H_ 1

Definition at line 41 of file c64P/DSP_mat_trans.h.


DSPLIB: DSP_maxidx.h File Reference

DSP_maxidx.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MAXIDX_H_ 1

Define Documentation

#define _DSP_MAXIDX_H_ 1

Definition at line 40 of file DSP_maxidx.h.


DSPLIB: DSP_maxidx.h File Reference

DSP_maxidx.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_maxidx.h:

Go to the source code of this file.

Defines

#define | DSP_MAXIDX_H_ 1

Functions

int | DSP_maxidx (const short *x, int nx)

Define Documentation

#define DSP_MAXIDX_H_ 1

Definition at line 41 of file c64P/DSP_maxidx.h.


DSPLIB: DSP_maxval.h File Reference

DSP_maxval.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MAXVAL_H_ 1

Define Documentation

#define _DSP_MAXVAL_H_ 1

Definition at line 40 of file DSP_maxval.h.


DSPLIB: DSP_maxval.h File Reference

DSP_maxval.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_maxval.h:

Go to the source code of this file.

Defines

#define | DSP_MAXVAL_H_ 1

Functions

short | DSP_maxval (const short *restrict x, int nx)

Define Documentation

#define DSP_MAXVAL_H_ 1

Definition at line 41 of file c64P/DSP_maxval.h.


DSPLIB: DSP_minerror.h File Reference

DSP_minerror.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MINERROR_H_ 1

Define Documentation

#define _DSP_MINERROR_H_ 1

Definition at line 40 of file DSP_minerror.h.


DSPLIB: DSP_minerror.h File Reference

DSP_minerror.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_minerror.h:

Go to the source code of this file.

Functions

int DSP_minerror (const short *restrict GSP0_TABLE, const short *restrict errCoefs, int *restrict max_index)


DSPLIB: DSP_minval.h File Reference

DSP_minval.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MINVAL_H_ 1

Define Documentation

#define _DSP_MINVAL_H_ 1

Definition at line 40 of file DSP_minval.h.


DSPLIB: DSP_minval.h File Reference

DSP_minval.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_minval.h:

Go to the source code of this file.

Defines

#define | DSP_MINVAL_H_ 1

Functions

short | DSP_minval (const short *restrict x, int nx)

Define Documentation

#define DSP_MINVAL_H_ 1

Definition at line 41 of file c64P/DSP_minval.h.


DSPLIB: DSP_mul32.h File Reference

DSP_mul32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_MUL32_H_ 1

Define Documentation

#define _DSP_MUL32_H_ 1

Definition at line 40 of file DSP_mul32.h.


DSPLIB: DSP_mul32.h File Reference

DSP_mul32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_mul32.h:

Go to the source code of this file.

Defines

#define | DSP_MUL32_H_ 1

Functions

void | DSP_mul32 (const int *restrict x, const int *restrict y, int *restrict r, int nx)

Define Documentation

#define DSP_MUL32_H_ 1

Definition at line 40 of file c64P/DSP_mul32.h.


DSPLIB: DSP_neg32.h File Reference

DSP_neg32.h File Reference

Go to the source code of this file.

Defines

#define _DSP_NEG32_H_ 1

Define Documentation

#define _DSP_NEG32_H_ 1

Definition at line 40 of file DSP_neg32.h.


DSPLIB: DSP_neg32.h File Reference

DSP_neg32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_neg32.h:

Go to the source code of this file.

Defines

#define | DSP_NEG32_H_ 1

Functions

void | DSP_neg32 (const int *restrict x, int *restrict r, int nx)

Define Documentation

#define DSP_NEG32_H_ 1

Definition at line 40 of file c64P/DSP_neg32.h.


DSPLIB: DSP_q15tofl.h File Reference

DSP_q15tofl.h File Reference

Go to the source code of this file.

Defines

#define _DSP_Q15TOFL_H_ 1

Define Documentation

#define _DSP_Q15TOFL_H_ 1

Definition at line 40 of file DSP_q15tofl.h.


DSPLIB: DSP_q15tofl.h File Reference

DSP_q15tofl.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_q15tofl.h:

Go to the source code of this file.

Defines

#define | DSP_Q15TOFL_H_ 1

Functions

void | DSP_q15tofl (const short *restrict q15, float *restrict flt, int nx)

Define Documentation

#define DSP_Q15TOFL_H_ 1

Definition at line 41 of file c64P/DSP_q15tofl.h.


DSPLIB: DSP_recip16.h File Reference

DSP_recip16.h File Reference

Go to the source code of this file.

Defines

#define _DSP_RECIP16_H_ 1

Define Documentation

#define _DSP_RECIP16_H_ 1

Definition at line 40 of file DSP_recip16.h.


DSPLIB: DSP_recip16.h File Reference

DSP_recip16.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_recip16.h:

Go to the source code of this file.

Defines

#define | DSP_RECIP16_H_ 1

Functions

void | DSP_recip16 (const short *restrict x, short *restrict rfrac, short *restrict rexp, short nx)

Define Documentation

#define DSP_RECIP16_H_ 1

Definition at line 41 of file c64P/DSP_recip16.h.


DSPLIB: DSP_vecsumsq.h File Reference

DSP_vecsumsq.h File Reference

Go to the source code of this file.

Defines

#define _DSP_VECSUMSQ_H_ 1

Define Documentation

#define _DSP_VECSUMSQ_H_ 1

Definition at line 40 of file DSP_vecsumsq.h.


DSPLIB: DSP_vecsumsq.h File Reference

DSP_vecsumsq.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_vecsumsq.h:

Go to the source code of this file.

Defines

#define | DSP_VECSUMSQ_H_ 1

Functions

int | DSP_vecsumsq (const short *x, int nx)

Define Documentation

#define DSP_VECSUMSQ_H_ 1

Definition at line 41 of file c64P/DSP_vecsumsq.h.


DSPLIB: DSP_w_vec.h File Reference

DSP_w_vec.h File Reference

Go to the source code of this file.

Defines

#define _DSP_W_VEC_H_ 1

Define Documentation

#define _DSP_W_VEC_H_ 1

Definition at line 40 of file DSP_w_vec.h.


DSPLIB: DSP_w_vec.h File Reference

DSP_w_vec.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c64P/DSP_w_vec.h:

Go to the source code of this file.

Defines

#define | DSP_W_VEC_H_ 1

Functions

void | DSP_w_vec (const short *restrict x, const short *restrict y, short m, short *restrict r, int nr)

Define Documentation

#define DSP_W_VEC_H_ 1

Definition at line 41 of file c64P/DSP_w_vec.h.


DSPLIB: Data Fields

  • All
  • Functions
  • Defines
  • _
  • d
  • f

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • _DSP_ADD16_H_ : DSP_add16.h
  • _DSP_ADD32_H_ : DSP_add32.h
  • _DSP_AUTOCOR_H_ : DSP_autocor.h
  • _DSP_BEXP_H_ : DSP_bexp.h
  • _DSP_BLK_ESWAP16_H_ : DSP_blk_eswap16.h
  • _DSP_BLK_ESWAP32_H_ : DSP_blk_eswap32.h
  • _DSP_BLK_ESWAP64_H_ : DSP_blk_eswap64.h
  • _DSP_BLK_MOVE_H_ : DSP_blk_move.h
  • _DSP_DOTP_SQR_H_ : DSP_dotp_sqr.h
  • _DSP_DOTPROD_H_ : DSP_dotprod.h
  • _DSP_FFT16X16_H_ : DSP_fft16x16.h
  • _DSP_FFT16X16_IMRE_H_ : DSP_fft16x16_imre.h
  • _DSP_FFT16X16R_H_ : DSP_fft16x16r.h
  • _DSP_FFT16X32_H_ : DSP_fft16x32.h
  • _DSP_FFT32X32_H_ : DSP_fft32x32.h
  • _DSP_FFT32X32S_H_ : DSP_fft32x32s.h
  • _DSP_FIR_CPLX_H_ : DSP_fir_cplx.h
  • _DSP_FIR_CPLX_HM4X4_H_ : DSP_fir_cplx_hM4X4.h
  • _DSP_FIR_GEN_H_ : DSP_fir_gen.h
  • _DSP_FIR_GEN_HM17_RA8X8_H_ : DSP_fir_gen_hM17_rA8X8.h
  • _DSP_FIR_R4_H_ : DSP_fir_r4.h
  • _DSP_FIR_R8_H_ : DSP_fir_r8.h
  • _DSP_FIR_R8_HM16_RM8A8X8_H_ : DSP_fir_r8_hM16_rM8A8X8.h
  • _DSP_FIR_SYM_H_ : DSP_fir_sym.h
  • _DSP_FIRLMS2_H_ : DSP_firlms2.h
  • _DSP_FLTOQ15_H_ : DSP_fltoq15.h
  • _DSP_IFFT16X32_H_ : DSP_ifft16x32.h
  • _DSP_IFFT32X32_H_ : DSP_ifft32x32.h
  • _DSP_IIR_H_ : DSP_iir.h
  • _DSP_IIR_LAT_H_ : DSP_iir_lat.h
  • _DSP_IIR_SS_H_ : DSP_iir_ss.h
  • _DSP_MAT_MUL_CPLX_H_ : DSP_mat_mul_cplx.h
  • _DSP_MAT_MUL_H_ : DSP_mat_mul.h
  • _DSP_MAT_TRANS_H_ : DSP_mat_trans.h
  • _DSP_MAXIDX_H_ : DSP_maxidx.h
  • _DSP_MAXVAL_H_ : DSP_maxval.h
  • _DSP_MINERROR_H_ : DSP_minerror.h
  • _DSP_MINVAL_H_ : DSP_minval.h
  • _DSP_MUL32_H_ : DSP_mul32.h
  • _DSP_NEG32_H_ : DSP_neg32.h
  • _DSP_Q15TOFL_H_ : DSP_q15tofl.h
  • _DSP_RECIP16_H_ : DSP_recip16.h
  • _DSP_VECSUMSQ_H_ : DSP_vecsumsq.h
  • _DSP_W_VEC_H_ : DSP_w_vec.h

- d -

  • DSP_add16() : c64P/DSP_add16.h
  • DSP_ADD16_H_ : c64P/DSP_add16.h
  • DSP_add32() : c64P/DSP_add32.h
  • DSP_ADD32_H_ : c64P/DSP_add32.h
  • DSP_autocor() : c64P/DSP_autocor.h
  • DSP_AUTOCOR_H_ : c64P/DSP_autocor.h
  • DSP_bexp() : c64P/DSP_bexp.h
  • DSP_blk_eswap16() : c64P/DSP_blk_eswap16.h
  • DSP_BLK_ESWAP16_H_ : c64P/DSP_blk_eswap16.h
  • DSP_blk_eswap32() : c64P/DSP_blk_eswap32.h
  • DSP_BLK_ESWAP32_H_ : c64P/DSP_blk_eswap32.h
  • DSP_blk_eswap64() : c64P/DSP_blk_eswap64.h
  • DSP_BLK_ESWAP64_H_ : c64P/DSP_blk_eswap64.h
  • DSP_blk_move() : c64P/DSP_blk_move.h
  • DSP_BLK_MOVE_H_ : c64P/DSP_blk_move.h
  • DSP_dotp_sqr() : c64P/DSP_dotp_sqr.h
  • DSP_dotprod() : c64P/DSP_dotprod.h
  • DSP_fft16x16() : c64P/DSP_fft16x16.h
  • DSP_FFT16X16_H_ : c64P/DSP_fft16x16.h
  • DSP_fft16x16_imre() : c64P/DSP_fft16x16_imre.h
  • DSP_fft16x16r() : c64P/DSP_fft16x16r.h
  • DSP_FFT16X16R_H_ : c64P/DSP_fft16x16r.h
  • DSP_fft16x32() : c64P/DSP_fft16x32.h
  • DSP_FFT16X32_H_ : c64P/DSP_fft16x32.h
  • DSP_fft32x32() : c64P/DSP_fft32x32.h
  • DSP_FFT32X32_H_ : c64P/DSP_fft32x32.h
  • DSP_fft32x32s() : c64P/DSP_fft32x32s.h
  • DSP_FFT32X32S_H_ : c64P/DSP_fft32x32s.h
  • DSP_fir_cplx() : c64P/DSP_fir_cplx.h
  • DSP_fir_cplx_hM4X4() : c64P/DSP_fir_cplx_hM4X4.h
  • DSP_fir_gen() : c64P/DSP_fir_gen.h
  • DSP_fir_gen_hM17_rA8X8() : c64P/DSP_fir_gen_hM17_rA8X8.h
  • DSP_FIR_GEN_HM17_RA8X8_H_ : c64P/DSP_fir_gen_hM17_rA8X8.h
  • DSP_fir_r4() : c64P/DSP_fir_r4.h
  • DSP_fir_r8() : c64P/DSP_fir_r8.h
  • DSP_FIR_R8_H_ : c64P/DSP_fir_r8.h
  • DSP_fir_r8_hM16_rM8A8X8() : c64P/DSP_fir_r8_hM16_rM8A8X8.h
  • DSP_FIR_R8_HM16_RM8A8X8_H_ : c64P/DSP_fir_r8_hM16_rM8A8X8.h
  • DSP_fir_sym() : c64P/DSP_fir_sym.h
  • DSP_FIR_SYM_H_ : c64P/DSP_fir_sym.h
  • DSP_firlms2() : c64P/DSP_firlms2.h
  • DSP_FIRLMS2_H_ : c64P/DSP_firlms2.h
  • DSP_fltoq15() : c64P/DSP_fltoq15.h
  • DSP_FLTOQ15_H_ : c64P/DSP_fltoq15.h
  • DSP_ifft16x16() : c64P/DSP_ifft16x16.h
  • DSP_ifft16x16_imre() : c64P/DSP_ifft16x16_imre.h
  • DSP_ifft16x32() : c64P/DSP_ifft16x32.h
  • DSP_IFFT16X32_H_ : c64P/DSP_ifft16x32.h
  • DSP_ifft32x32() : c64P/DSP_ifft32x32.h
  • DSP_IFFT32X32_H_ : c64P/DSP_ifft32x32.h
  • DSP_iir() : c64P/DSP_iir.h
  • DSP_iir_lat() : c64P/DSP_iir_lat.h
  • DSP_IIR_LAT_H_ : c64P/DSP_iir_lat.h
  • DSP_iir_ss() : c64P/DSP_iir_ss.h
  • DSP_mat_mul() : c64P/DSP_mat_mul.h
  • DSP_mat_mul_cplx() : c64P/DSP_mat_mul_cplx.h
  • DSP_MAT_MUL_CPLX_H_ : c64P/DSP_mat_mul_cplx.h
  • DSP_MAT_MUL_H_ : c64P/DSP_mat_mul.h
  • DSP_mat_trans() : c64P/DSP_mat_trans.h
  • DSP_MAT_TRANS_H_ : c64P/DSP_mat_trans.h
  • DSP_maxidx() : c64P/DSP_maxidx.h
  • DSP_MAXIDX_H_ : c64P/DSP_maxidx.h
  • DSP_maxval() : c64P/DSP_maxval.h
  • DSP_MAXVAL_H_ : c64P/DSP_maxval.h
  • DSP_minerror() : c64P/DSP_minerror.h
  • DSP_minval() : c64P/DSP_minval.h
  • DSP_MINVAL_H_ : c64P/DSP_minval.h
  • DSP_mul32() : c64P/DSP_mul32.h
  • DSP_MUL32_H_ : c64P/DSP_mul32.h
  • DSP_neg32() : c64P/DSP_neg32.h
  • DSP_NEG32_H_ : c64P/DSP_neg32.h
  • DSP_q15tofl() : c64P/DSP_q15tofl.h
  • DSP_Q15TOFL_H_ : c64P/DSP_q15tofl.h
  • DSP_recip16() : c64P/DSP_recip16.h
  • DSP_RECIP16_H_ : c64P/DSP_recip16.h
  • DSP_vecsumsq() : c64P/DSP_vecsumsq.h
  • DSP_VECSUMSQ_H_ : c64P/DSP_vecsumsq.h
  • DSP_w_vec() : c64P/DSP_w_vec.h
  • DSP_W_VEC_H_ : c64P/DSP_w_vec.h

- f -

  • FFT16X16_IMRE_H_ : c64P/DSP_fft16x16_imre.h


DSPLIB: DSP_add16.h Source File

DSP_add16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_add16.h -- Optimized C source interface header file                */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_ADD16_H_
00040 #define _DSP_ADD16_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_add16/c66/DSP_add16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_add16/c64P/DSP_add16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_ADD16_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_add16.h                                              */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_add32.h Source File

DSP_add32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_add32.h -- Optimized C source interface header file                */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_ADD32_H_
00040 #define _DSP_ADD32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_add32/c66/DSP_add32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_add32/c64P/DSP_add32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_ADD32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_add32.h                                              */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_autocor.h Source File

DSP_autocor.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_autocor.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_AUTOCOR_H_
00040 #define _DSP_AUTOCOR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_autocor/c66/DSP_autocor.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_autocor/c64P/DSP_autocor.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_AUTOCOR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_autocor.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_bexp.h Source File

DSP_bexp.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_bexp.h -- Optimized C source interface header file                 */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_BEXP_H_
00040 #define _DSP_BEXP_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_bexp/c66/DSP_bexp.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_bexp/c64P/DSP_bexp.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_BEXP_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_bexp.h                                               */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_blk_eswap16.h Source File

DSP_blk_eswap16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_blk_eswap16.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_BLK_ESWAP16_H_
00040 #define _DSP_BLK_ESWAP16_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_blk_eswap16/c66/DSP_blk_eswap16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_blk_eswap16/c64P/DSP_blk_eswap16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_BLK_ESWAP16_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_blk_eswap16.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_blk_eswap32.h Source File

DSP_blk_eswap32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_blk_eswap32.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_BLK_ESWAP32_H_
00040 #define _DSP_BLK_ESWAP32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_blk_eswap32/c66/DSP_blk_eswap32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_blk_eswap32/c64P/DSP_blk_eswap32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_BLK_ESWAP32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_blk_eswap32.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_blk_eswap64.h Source File

DSP_blk_eswap64.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_blk_eswap64.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_BLK_ESWAP64_H_
00040 #define _DSP_BLK_ESWAP64_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_blk_eswap64/c66/DSP_blk_eswap64.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_blk_eswap64/c64P/DSP_blk_eswap64.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_BLK_ESWAP64_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_blk_eswap64.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_blk_move.h Source File

DSP_blk_move.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_blk_move.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_BLK_MOVE_H_
00040 #define _DSP_BLK_MOVE_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_blk_move/c66/DSP_blk_move.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_blk_move/c64P/DSP_blk_move.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_BLK_MOVE_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_blk_move.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_dotp_sqr.h Source File

DSP_dotp_sqr.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_dotp_sqr.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_DOTP_SQR_H_
00040 #define _DSP_DOTP_SQR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_dotp_sqr/c66/DSP_dotp_sqr.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_dotp_sqr/c64P/DSP_dotp_sqr.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_DOTP_SQR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_dotp_sqr.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_dotprod.h Source File

DSP_dotprod.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_dotprod.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_DOTPROD_H_
00040 #define _DSP_DOTPROD_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_dotprod/c66/DSP_dotprod.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_dotprod/c64P/DSP_dotprod.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_DOTPROD_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_dotprod.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fft16x16.h Source File

DSP_fft16x16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fft16x16.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FFT16X16_H_
00040 #define _DSP_FFT16X16_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fft16x16/c66/DSP_fft16x16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fft16x16/c64P/DSP_fft16x16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FFT16X16_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fft16x16.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fft16x16_imre.h Source File

DSP_fft16x16_imre.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fft16x16_imre.h -- Optimized C source interface header file        */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FFT16X16_IMRE_H_
00040 #define _DSP_FFT16X16_IMRE_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fft16x16_imre/c66/DSP_fft16x16_imre.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fft16x16_imre/c64P/DSP_fft16x16_imre.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FFT16X16_IMRE_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fft16x16_imre.h                                      */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fft16x16r.h Source File

DSP_fft16x16r.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fft16x16r.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FFT16X16R_H_
00040 #define _DSP_FFT16X16R_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fft16x16r/c66/DSP_fft16x16r.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fft16x16r/c64P/DSP_fft16x16r.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FFT16X16R_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fft16x16r.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fft16x32.h Source File

DSP_fft16x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fft16x32.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FFT16X32_H_
00040 #define _DSP_FFT16X32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fft16x32/c66/DSP_fft16x32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fft16x32/c64P/DSP_fft16x32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FFT16X32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fft16x32.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fft32x32.h Source File

DSP_fft32x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fft32x32.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FFT32X32_H_
00040 #define _DSP_FFT32X32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fft32x32/c66/DSP_fft32x32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fft32x32/c64P/DSP_fft32x32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FFT32X32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fft32x32.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fft32x32s.h Source File

DSP_fft32x32s.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fft32x32s.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FFT32X32S_H_
00040 #define _DSP_FFT32X32S_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fft32x32s/c66/DSP_fft32x32s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fft32x32s/c64P/DSP_fft32x32s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FFT32X32S_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fft32x32s.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_cplx.h Source File

DSP_fir_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_cplx.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_CPLX_H_
00040 #define _DSP_FIR_CPLX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_cplx/c66/DSP_fir_cplx.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_cplx/c64P/DSP_fir_cplx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_CPLX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_cplx.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_cplx_hM4X4.h Source File

DSP_fir_cplx_hM4X4.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_cplx_hM4X4.h -- Optimized C source interface header file       */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_CPLX_HM4X4_H_
00040 #define _DSP_FIR_CPLX_HM4X4_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_cplx_hM4X4/c66/DSP_fir_cplx_hM4X4.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_cplx_hM4X4/c64P/DSP_fir_cplx_hM4X4.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_CPLX_HM4X4_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_cplx_hM4X4.h                                     */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_gen.h Source File

DSP_fir_gen.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_gen.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_GEN_H_
00040 #define _DSP_FIR_GEN_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_gen/c66/DSP_fir_gen.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_gen/c64P/DSP_fir_gen.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_GEN_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_gen.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_gen_hM17_rA8X8.h Source File

DSP_fir_gen_hM17_rA8X8.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_gen_hM17_rA8X8.h -- Optimized C source interface header file   */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_GEN_HM17_RA8X8_H_
00040 #define _DSP_FIR_GEN_HM17_RA8X8_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_gen_hM17_rA8X8/c66/DSP_fir_gen_hM17_rA8X8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_gen_hM17_rA8X8/c64P/DSP_fir_gen_hM17_rA8X8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_GEN_HM17_RA8X8_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_gen_hM17_rA8X8.h                                 */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_r4.h Source File

DSP_fir_r4.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_r4.h -- Optimized C source interface header file               */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_R4_H_
00040 #define _DSP_FIR_R4_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_r4/c66/DSP_fir_r4.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_r4/c64P/DSP_fir_r4.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_R4_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_r4.h                                             */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_r8.h Source File

DSP_fir_r8.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_r8.h -- Optimized C source interface header file               */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_R8_H_
00040 #define _DSP_FIR_R8_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_r8/c66/DSP_fir_r8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_r8/c64P/DSP_fir_r8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_R8_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_r8.h                                             */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_r8_hM16_rM8A8X8.h Source File

DSP_fir_r8_hM16_rM8A8X8.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_r8_hM16_rM8A8X8.h -- Optimized C source interface header file  */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_R8_HM16_RM8A8X8_H_
00040 #define _DSP_FIR_R8_HM16_RM8A8X8_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_r8_hM16_rM8A8X8/c66/DSP_fir_r8_hM16_rM8A8X8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_r8_hM16_rM8A8X8/c64P/DSP_fir_r8_hM16_rM8A8X8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_R8_HM16_RM8A8X8_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_r8_hM16_rM8A8X8.h                                */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fir_sym.h Source File

DSP_fir_sym.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fir_sym.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIR_SYM_H_
00040 #define _DSP_FIR_SYM_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fir_sym/c66/DSP_fir_sym.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fir_sym/c64P/DSP_fir_sym.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIR_SYM_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fir_sym.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_firlms2.h Source File

DSP_firlms2.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_firlms2.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FIRLMS2_H_
00040 #define _DSP_FIRLMS2_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_firlms2/c66/DSP_firlms2.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_firlms2/c64P/DSP_firlms2.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FIRLMS2_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_firlms2.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_fltoq15.h Source File

DSP_fltoq15.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_fltoq15.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_FLTOQ15_H_
00040 #define _DSP_FLTOQ15_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_fltoq15/c66/DSP_fltoq15.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_fltoq15/c64P/DSP_fltoq15.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_FLTOQ15_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_fltoq15.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_ifft16x16.h Source File

DSP_ifft16x16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_ifft16x16.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IFFT16X16_H_
00040 #define _DSP_IFFT16X16_H_
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_ifft16x16/c66/DSP_ifft16x16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_ifft16x16/c64P/DSP_ifft16x16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IFFT16X16_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_ifft16x16.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_ifft16x16_imre.h Source File

DSP_ifft16x16_imre.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_ifft16x16_imre.h -- Optimized C source interface header file       */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IFFT16X16_IMRE_H_
00040 #define _DSP_IFFT16X16_IMRE_H_
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_ifft16x16_imre/c66/DSP_ifft16x16_imre.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_ifft16x16_imre/c64P/DSP_ifft16x16_imre.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IFFT16X16_IMRE_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_ifft16x16_imre.h                                     */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_ifft16x32.h Source File

DSP_ifft16x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_ifft16x32.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IFFT16X32_H_
00040 #define _DSP_IFFT16X32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_ifft16x32/c66/DSP_ifft16x32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_ifft16x32/c64P/DSP_ifft16x32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IFFT16X32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_ifft16x32.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_ifft32x32.h Source File

DSP_ifft32x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_ifft32x32.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IFFT32X32_H_
00040 #define _DSP_IFFT32X32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_ifft32x32/c66/DSP_ifft32x32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_ifft32x32/c64P/DSP_ifft32x32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IFFT32X32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_ifft32x32.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_iir.h Source File

DSP_iir.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_iir.h -- Optimized C source interface header file                 */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IIR_H_
00040 #define _DSP_IIR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_iir/c66/DSP_iir.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_iir/c64P/DSP_iir.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IIR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_iir.h                                               */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_iir_lat.h Source File

DSP_iir_lat.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_iir_lat.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IIR_LAT_H_
00040 #define _DSP_IIR_LAT_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_iir_lat/c66/DSP_iir_lat.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_iir_lat/c64P/DSP_iir_lat.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IIR_LAT_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_iir_lat.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_iir_ss.h Source File

DSP_iir_ss.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_iir_ss.h -- Optimized C source interface header file               */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_IIR_SS_H_
00040 #define _DSP_IIR_SS_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_iir_ss/c66/DSP_iir_ss.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_iir_ss/c64P/DSP_iir_ss.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_IIR_SS_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_iir_ss.h                                             */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_mat_mul.h Source File

DSP_mat_mul.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_mat_mul.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MAT_MUL_H_
00040 #define _DSP_MAT_MUL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_mat_mul/c66/DSP_mat_mul.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_mat_mul/c64P/DSP_mat_mul.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MAT_MUL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_mat_mul.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_mat_mul_cplx.h Source File

DSP_mat_mul_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_mat_mul_cplx.h -- Optimized C source interface header file         */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MAT_MUL_CPLX_H_
00040 #define _DSP_MAT_MUL_CPLX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_mat_mul_cplx/c66/DSP_mat_mul_cplx.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_mat_mul_cplx/c64P/DSP_mat_mul_cplx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MAT_MUL_CPLX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_mat_mul_cplx.h                                       */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_mat_trans.h Source File

DSP_mat_trans.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_mat_trans.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MAT_TRANS_H_
00040 #define _DSP_MAT_TRANS_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_mat_trans/c66/DSP_mat_trans.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_mat_trans/c64P/DSP_mat_trans.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MAT_TRANS_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_mat_trans.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_maxidx.h Source File

DSP_maxidx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_maxidx.h -- Optimized C source interface header file               */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MAXIDX_H_
00040 #define _DSP_MAXIDX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_maxidx/c66/DSP_maxidx.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_maxidx/c64P/DSP_maxidx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MAXIDX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_maxidx.h                                             */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_maxval.h Source File

DSP_maxval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_maxval.h -- Optimized C source interface header file               */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MAXVAL_H_
00040 #define _DSP_MAXVAL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_maxval/c66/DSP_maxval.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_maxval/c64P/DSP_maxval.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MAXVAL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_maxval.h                                             */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_minerror.h Source File

DSP_minerror.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_minerror.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MINERROR_H_
00040 #define _DSP_MINERROR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_minerror/c66/DSP_minerror.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_minerror/c64P/DSP_minerror.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MINERROR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_minerror.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_minval.h Source File

DSP_minval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_minval.h -- Optimized C source interface header file               */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MINVAL_H_
00040 #define _DSP_MINVAL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_minval/c66/DSP_minval.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_minval/c64P/DSP_minval.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MINVAL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_minval.h                                             */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_mul32.h Source File

DSP_mul32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_mul32.h -- Optimized C source interface header file                */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_MUL32_H_
00040 #define _DSP_MUL32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_mul32/c66/DSP_mul32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_mul32/c64P/DSP_mul32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_MUL32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_mul32.h                                              */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_neg32.h Source File

DSP_neg32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_neg32.h -- Optimized C source interface header file                */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_NEG32_H_
00040 #define _DSP_NEG32_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_neg32/c66/DSP_neg32.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_neg32/c64P/DSP_neg32.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_NEG32_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_neg32.h                                              */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_q15tofl.h Source File

DSP_q15tofl.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_q15tofl.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_Q15TOFL_H_
00040 #define _DSP_Q15TOFL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_q15tofl/c66/DSP_q15tofl.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_q15tofl/c64P/DSP_q15tofl.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_Q15TOFL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_q15tofl.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_recip16.h Source File

DSP_recip16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_recip16.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_RECIP16_H_
00040 #define _DSP_RECIP16_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_recip16/c66/DSP_recip16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_recip16/c64P/DSP_recip16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_RECIP16_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_recip16.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_vecsumsq.h Source File

DSP_vecsumsq.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_vecsumsq.h -- Optimized C source interface header file             */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_VECSUMSQ_H_
00040 #define _DSP_VECSUMSQ_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_vecsumsq/c66/DSP_vecsumsq.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_vecsumsq/c64P/DSP_vecsumsq.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_VECSUMSQ_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_vecsumsq.h                                           */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_w_vec.h Source File

DSP_w_vec.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSP_w_vec.h -- Optimized C source interface header file                */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSP_W_VEC_H_
00040 #define _DSP_W_VEC_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSP_w_vec/c66/DSP_w_vec.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/dsplib/src/DSP_w_vec/c64P/DSP_w_vec.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSP_W_VEC_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSP_w_vec.h                                              */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSP_add16.h Source File

DSP_add16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_add16.h -- Optimized C source interface header file                 */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef DSP_ADD16_H_
00040 #define DSP_ADD16_H_ 1
00041
00042 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00043 #include "assert.h"                       // intrinsics prototypes
00044 #include "C6xSimulator.h"                 // intrinsics prototypes
00045 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00046 #endif
00047
00049 /* @{ */
00050
00053 /* @{ */
00054
00079  /* }@ */ /* ingroup */
00080  /* }@ */ /* ingroup */
00081
00082 void DSP_add16 (
00083     short * restrict x,   /* Input array of length nx  */
00084     short * restrict y,   /* Input array of length nx  */
00085     short * restrict r,   /* Output array of length nx */
00086     int     nx            /* Number of elements.       */
00087 );
00088
00089 #endif /* DSP_ADD16_H_ */
00090
00091 /* ======================================================================== */
00092 /*  End of file:  DSP_add16.h                                               */
00093 /* ------------------------------------------------------------------------ */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00095 /*                           All Rights Reserved.                           */
00096 /* ======================================================================== */
00097


DSPLIB: DSP_add32.h Source File

DSP_add32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_add32.h -- Optimized C source interface header file                 */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef DSP_ADD32_H_
00040 #define DSP_ADD32_H_ 1
00041
00042 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00043 #include "assert.h"                       // intrinsics prototypes
00044 #include "C6xSimulator.h"                 // intrinsics prototypes
00045 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00046 #endif
00047
00049 /* @{ */
00050
00053 /* @{ */
00054
00079  /* }@ */ /* ingroup */
00080  /* }@ */ /* ingroup */
00081
00082 void DSP_add32 (
00083     const int * restrict x,    /* Input array of length nx  */
00084     const int * restrict y,    /* Input array of length nx  */
00085     int       * restrict r,    /* Output array of length nx */
00086     int                  nx    /* Number of elements.       */
00087 );
00088
00089 #endif /* DSP_ADD32_H_ */
00090
00091 /* ======================================================================== */
00092 /*  End of file:  DSP_add32.h                                               */
00093 /* ------------------------------------------------------------------------ */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00095 /*                           All Rights Reserved.                           */
00096 /* ======================================================================== */
00097


DSPLIB: DSP_autocor.h Source File

DSP_autocor.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  NAME                                                                   */
00003 /*      DSP_autocor -- Autocorrelation                                     */
00004 /*                                                                         */
00005 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /*  Redistribution and use in source and binary forms, with or without     */
00009 /*  modification, are permitted provided that the following conditions     */
00010 /*  are met:                                                               */
00011 /*                                                                         */
00012 /*    Redistributions of source code must retain the above copyright       */
00013 /*    notice, this list of conditions and the following disclaimer.        */
00014 /*                                                                         */
00015 /*    Redistributions in binary form must reproduce the above copyright    */
00016 /*    notice, this list of conditions and the following disclaimer in the  */
00017 /*    documentation and/or other materials provided with the               */
00018 /*    distribution.                                                        */
00019 /*                                                                         */
00020 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00021 /*    its contributors may be used to endorse or promote products derived  */
00022 /*    from this software without specific prior written permission.        */
00023 /*                                                                         */
00024 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00025 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00026 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00027 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00028 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00029 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00030 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00031 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00032 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00033 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00034 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00035 /*                                                                         */
00036 /* ======================================================================= */
00037
00038 #ifndef DSP_AUTOCOR_H_
00039 #define DSP_AUTOCOR_H_ 1
00040
00041 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00042 #include "assert.h"                       // intrinsics prototypes
00043 #include "C6xSimulator.h"                 // intrinsics prototypes
00044 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00045 #endif
00046
00048 /* @{ */
00049
00052 /* @{ */
00053
00100  /* }@ */ /* ingroup */
00101  /* }@ */ /* ingroup */
00102
00103
00104 void DSP_autocor (
00105     short *restrict r,
00106     const short *restrict x,
00107     int nx,
00108     int nr
00109 );
00110
00111 #endif
00112
00113 /* ======================================================================== */
00114 /*  End of file:  DSP_autocor.h                                             */
00115 /* ------------------------------------------------------------------------ */
00116 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00117 /*                           All Rights Reserved.                           */
00118 /* ======================================================================== */
00119


DSPLIB: DSP_bexp.h Source File

DSP_bexp.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_bexp.h -- Block exponent of a vector                                */
00003 /*               Intrinsic C Implementation                                */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /*  Redistribution and use in source and binary forms, with or without     */
00012 /*  modification, are permitted provided that the following conditions     */
00013 /*  are met:                                                               */
00014 /*                                                                         */
00015 /*    Redistributions of source code must retain the above copyright       */
00016 /*    notice, this list of conditions and the following disclaimer.        */
00017 /*                                                                         */
00018 /*    Redistributions in binary form must reproduce the above copyright    */
00019 /*    notice, this list of conditions and the following disclaimer in the  */
00020 /*    documentation and/or other materials provided with the               */
00021 /*    distribution.                                                        */
00022 /*                                                                         */
00023 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00024 /*    its contributors may be used to endorse or promote products derived  */
00025 /*    from this software without specific prior written permission.        */
00026 /*                                                                         */
00027 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00028 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00029 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00030 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00031 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00032 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00033 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00034 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00035 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00036 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00037 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00038 /*                                                                         */
00039 /* ======================================================================= */
00040
00041 #ifndef DSP_BEXP_H_
00042 #define DSP_BEXP_H_
00043
00044 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00045 #include "assert.h"                       // intrinsics prototypes
00046 #include "C6xSimulator.h"                 // intrinsics prototypes
00047 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00048 #endif
00049
00051 /* @{ */
00052
00055 /* @{ */
00056
00084  /* }@ */ /* ingroup */
00085  /* }@ */ /* ingroup */
00086
00087 int DSP_bexp (
00088     const int *x,   /* Input data           */
00089     short nx        /* Number of elements   */
00090 );
00091
00092 #endif /* DSP_BEXP_H_ */
00093
00094 /* ======================================================================= */
00095 /*  End of file:  DSP_bexp.h                                               */
00096 /* ----------------------------------------------------------------------- */
00097 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00098 /*                           All Rights Reserved.                          */
00099 /* ======================================================================= */
00100


DSPLIB: DSP_blk_eswap16.h Source File

DSP_blk_eswap16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_blk_eswap16.h -- Endian-swap a block of 16-bit values               */
00003 /*                      Intrinsic C Implementation                         */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_BLK_ESWAP16_H_
00041 #define DSP_BLK_ESWAP16_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00087  /* }@ */ /* ingroup */
00088  /* }@ */ /* ingroup */
00089
00090 void DSP_blk_eswap16 (
00091     void *restrict src,
00092     void *restrict dst,
00093     int  n_hwords
00094 );
00095
00096 #endif
00097
00098 /* ======================================================================== */
00099 /*  End of file:  DSP_blk_eswap16.h                                         */
00100 /* ------------------------------------------------------------------------ */
00101 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00102 /*                           All Rights Reserved.                           */
00103 /* ======================================================================== */
00104


DSPLIB: DSP_blk_eswap32.h Source File

DSP_blk_eswap32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_blk_eswap32.h -- Endian-swap a block of 32-bit values               */
00003 /*                      Intrinsic C Implementation                         */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_BLK_ESWAP32_H_
00041 #define DSP_BLK_ESWAP32_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00087  /* }@ */ /* ingroup */
00088  /* }@ */ /* ingroup */
00089
00090 void DSP_blk_eswap32 (
00091     void *restrict src,
00092     void *restrict dst,
00093     int  n_words
00094 );
00095
00096 #endif
00097
00098 /* ======================================================================== */
00099 /*  End of file:  DSP_blk_eswap32.h                                         */
00100 /* ------------------------------------------------------------------------ */
00101 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00102 /*                           All Rights Reserved.                           */
00103 /* ======================================================================== */
00104


DSPLIB: DSP_blk_eswap64.h Source File

DSP_blk_eswap64.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_blk_eswap64.h -- Endian-swap a block of 64-bit values               */
00003 /*                      Intrinsic C Implementation                         */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /*  Redistribution and use in source and binary forms, with or without     */
00012 /*  modification, are permitted provided that the following conditions     */
00013 /*  are met:                                                               */
00014 /*                                                                         */
00015 /*    Redistributions of source code must retain the above copyright       */
00016 /*    notice, this list of conditions and the following disclaimer.        */
00017 /*                                                                         */
00018 /*    Redistributions in binary form must reproduce the above copyright    */
00019 /*    notice, this list of conditions and the following disclaimer in the  */
00020 /*    documentation and/or other materials provided with the               */
00021 /*    distribution.                                                        */
00022 /*                                                                         */
00023 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00024 /*    its contributors may be used to endorse or promote products derived  */
00025 /*    from this software without specific prior written permission.        */
00026 /*                                                                         */
00027 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00028 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00029 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00030 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00031 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00032 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00033 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00034 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00035 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00036 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00037 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00038 /*                                                                         */
00039 /* ======================================================================= */
00040
00041 #ifndef DSP_BLK_ESWAP64_H_
00042 #define DSP_BLK_ESWAP64_H_ 1
00043
00044 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00045 #include "assert.h"                       // intrinsics prototypes
00046 #include "C6xSimulator.h"                 // intrinsics prototypes
00047 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00048 #endif
00049
00051 /* @{ */
00052
00055 /* @{ */
00056
00088  /* }@ */ /* ingroup */
00089  /* }@ */ /* ingroup */
00090
00091 void DSP_blk_eswap64 (
00092     void *restrict src,
00093     void *restrict dst,
00094     int   n_dbls
00095 );
00096
00097 #endif
00098
00099 /* ======================================================================== */
00100 /*  End of file:  DSP_blk_eswap64.h                                         */
00101 /* ------------------------------------------------------------------------ */
00102 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00103 /*                           All Rights Reserved.                           */
00104 /* ======================================================================== */
00105


DSPLIB: DSP_blk_move.h Source File

DSP_blk_move.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_blk_move.h -- Move a block of memory                                */
00003 /*                   Intrinsic C Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_BLK_MOVE_H_
00041 #define DSP_BLK_MOVE_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080  /* }@ */ /* ingroup */
00081  /* }@ */ /* ingroup */
00082
00083 void DSP_blk_move (
00084     short *restrict x,
00085     short *restrict r,
00086     int nx
00087 );
00088
00089 #endif
00090
00091 /* ======================================================================== */
00092 /*  End of file:  DSP_blk_move.h                                            */
00093 /* ------------------------------------------------------------------------ */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00095 /*                           All Rights Reserved.                           */
00096 /* ======================================================================== */
00097


DSPLIB: DSP_dotp_sqr.h Source File

DSP_dotp_sqr.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_dotp_sqr.h --  Vector Dot Product and Square implementation         */
00003 /*                    Intrinsic C Implementation                           */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_DOTP_SQR_H_
00041 #define DSP_DOTP_SQR_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00081  /* }@ */ /* ingroup */
00082  /* }@ */ /* ingroup */
00083
00084 int DSP_dotp_sqr (
00085     int G,            /* Sum-of-y-squared initial value */
00086     const short  *x,  /* First input array              */
00087     const short  *y,  /* Second input array.            */
00088     int *restrict r,  /* Accumulation of x[] * y[].     */
00089     int nx            /* Length of the input vector.    */
00090 );
00091
00092 #endif /* DSP_DOTP_SQR_H_ */
00093
00094 /* ======================================================================== */
00095 /*  End of file:  DSP_dotp_sqr.h                                            */
00096 /* ------------------------------------------------------------------------ */
00097 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00098 /*                           All Rights Reserved.                           */
00099 /* ======================================================================== */
00100


DSPLIB: DSP_dotprod.h Source File

DSP_dotprod.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_dotprod.h --   Dot product implementation                           */
00003 /*                    Intrinsic C Implementation                           */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_DOTPROD_H_
00041 #define DSP_DOTPROD_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00079  /* }@ */ /* ingroup */
00080  /* }@ */ /* ingroup */
00081
00082 int DSP_dotprod (
00083     short * restrict x,    /* Pointer to first vector  */
00084     short * restrict y,    /* Pointer to second vector */
00085     int nx                 /* Length of vectors.       */
00086 );
00087
00088 #endif /* DSP_DOTPROD_H_ */
00089
00090 /* ======================================================================== */
00091 /*  End of file:  DSP_dotprod.h                                             */
00092 /* ------------------------------------------------------------------------ */
00093 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00094 /*                           All Rights Reserved.                           */
00095 /* ======================================================================== */
00096


DSPLIB: DSP_fft16x16.h Source File

DSP_fft16x16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fft16x16.h -- 16x16 Mixed Radix FFT                                 */
00003 /*                   Serial ASM Implementation                             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FFT16X16_H_
00041 #define DSP_FFT16X16_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00093 void DSP_fft16x16 (
00094     const short * restrict ptr_w,
00095     int npoints,
00096     short * restrict ptr_x,
00097     short * restrict ptr_y
00098 );
00099
00100 #endif
00101
00102 /* ======================================================================== */
00103 /*  End of file:  DSP_fft16x16.h                                            */
00104 /* ------------------------------------------------------------------------ */
00105 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00106 /*                           All Rights Reserved.                           */
00107 /* ======================================================================== */
00108


DSPLIB: DSP_fft16x16_imre.h Source File

DSP_fft16x16_imre.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fft16x16_imre.h -- 16x16 Mixed Radix FFT                            */
00003 /*                        Serial ASM Implementation                        */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /*  Redistribution and use in source and binary forms, with or without     */
00012 /*  modification, are permitted provided that the following conditions     */
00013 /*  are met:                                                               */
00014 /*                                                                         */
00015 /*    Redistributions of source code must retain the above copyright       */
00016 /*    notice, this list of conditions and the following disclaimer.        */
00017 /*                                                                         */
00018 /*    Redistributions in binary form must reproduce the above copyright    */
00019 /*    notice, this list of conditions and the following disclaimer in the  */
00020 /*    documentation and/or other materials provided with the               */
00021 /*    distribution.                                                        */
00022 /*                                                                         */
00023 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00024 /*    its contributors may be used to endorse or promote products derived  */
00025 /*    from this software without specific prior written permission.        */
00026 /*                                                                         */
00027 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00028 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00029 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00030 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00031 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00032 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00033 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00034 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00035 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00036 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00037 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00038 /*                                                                         */
00039 /* ======================================================================= */
00040
00041 #ifndef FFT16X16_IMRE_H_
00042 #define FFT16X16_IMRE_H_ 1
00043
00044 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00045 #include "assert.h"                       // intrinsics prototypes
00046 #include "C6xSimulator.h"                 // intrinsics prototypes
00047 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00048 #endif
00049
00051 /* @{ */
00052
00055 /* @{ */
00056
00095 void DSP_fft16x16_imre (
00096     const short * restrict ptr_w,
00097     int npoints,
00098     short * restrict ptr_x,
00099     short * restrict ptr_y
00100 );
00101
00102 #endif
00103
00104 /* ======================================================================== */
00105 /*  End of file:  fft16x16_imre.h                                           */
00106 /* ------------------------------------------------------------------------ */
00107 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00108 /*                           All Rights Reserved.                           */
00109 /* ======================================================================== */
00110


DSPLIB: DSP_fft16x16r.h Source File

DSP_fft16x16r.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fft16x16r.h -- 16x16r Mixed Radix FFT                               */
00003 /*                    Serial ASM Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FFT16X16R_H_
00041 #define DSP_FFT16X16R_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00103 void DSP_fft16x16r (
00104     int n,
00105     short * restrict ptr_x,
00106     const short * restrict ptr_w,
00107     short * restrict ptr_y,
00108     int radix,
00109     int offset,
00110     int n_max
00111 );
00112
00113 #endif
00114
00115 /* ======================================================================== */
00116 /*  End of file:  DSP_fft16x16r.h                                           */
00117 /* ------------------------------------------------------------------------ */
00118 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00119 /*                           All Rights Reserved.                           */
00120 /* ======================================================================== */
00121


DSPLIB: DSP_fft16x32.h Source File

DSP_fft16x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fft16x32.h -- 16x32 Mixed Radix FFT                                 */
00003 /*                   Serial ASM Implementation                             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FFT16X32_H_
00041 #define DSP_FFT16X32_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00092 void DSP_fft16x32 (
00093     const short * restrict ptr_w,
00094     int npoints,
00095     int * restrict ptr_x,
00096     int * restrict ptr_y
00097 );
00098
00099 #endif
00100
00101 /* ======================================================================== */
00102 /*  End of file:  DSP_fft16x32.h                                            */
00103 /* ------------------------------------------------------------------------ */
00104 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00105 /*                           All Rights Reserved.                           */
00106 /* ======================================================================== */
00107


DSPLIB: DSP_fft32x32.h Source File

DSP_fft32x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fft32x32.h -- 32x32 Mixed Radix FFT                                 */
00003 /*                   Serial ASM Implementation                             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /*  Redistribution and use in source and binary forms, with or without     */
00012 /*  modification, are permitted provided that the following conditions     */
00013 /*  are met:                                                               */
00014 /*                                                                         */
00015 /*    Redistributions of source code must retain the above copyright       */
00016 /*    notice, this list of conditions and the following disclaimer.        */
00017 /*                                                                         */
00018 /*    Redistributions in binary form must reproduce the above copyright    */
00019 /*    notice, this list of conditions and the following disclaimer in the  */
00020 /*    documentation and/or other materials provided with the               */
00021 /*    distribution.                                                        */
00022 /*                                                                         */
00023 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00024 /*    its contributors may be used to endorse or promote products derived  */
00025 /*    from this software without specific prior written permission.        */
00026 /*                                                                         */
00027 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00028 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00029 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00030 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00031 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00032 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00033 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00034 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00035 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00036 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00037 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00038 /*                                                                         */
00039 /* ======================================================================= */
00040
00041 #ifndef DSP_FFT32X32_H_
00042 #define DSP_FFT32X32_H_ 1
00043
00044 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00045 #include "assert.h"                       // intrinsics prototypes
00046 #include "C6xSimulator.h"                 // intrinsics prototypes
00047 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00048 #endif
00049
00051 /* @{ */
00052
00055 /* @{ */
00056
00093 void DSP_fft32x32 (
00094     const int * restrict ptr_w,
00095     int npoints,
00096     int * restrict ptr_x,
00097     int * restrict ptr_y
00098 );
00099
00100 #endif
00101
00102 /* ======================================================================== */
00103 /*  End of file:  DSP_fft32x32.h                                            */
00104 /* ------------------------------------------------------------------------ */
00105 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00106 /*                           All Rights Reserved.                           */
00107 /* ======================================================================== */
00108


DSPLIB: DSP_fft32x32s.h Source File

DSP_fft32x32s.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fft32x32s.h -- 32x32s Mixed Radix FFT                               */
00003 /*                    Serial ASM Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /*  Redistribution and use in source and binary forms, with or without     */
00012 /*  modification, are permitted provided that the following conditions     */
00013 /*  are met:                                                               */
00014 /*                                                                         */
00015 /*    Redistributions of source code must retain the above copyright       */
00016 /*    notice, this list of conditions and the following disclaimer.        */
00017 /*                                                                         */
00018 /*    Redistributions in binary form must reproduce the above copyright    */
00019 /*    notice, this list of conditions and the following disclaimer in the  */
00020 /*    documentation and/or other materials provided with the               */
00021 /*    distribution.                                                        */
00022 /*                                                                         */
00023 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00024 /*    its contributors may be used to endorse or promote products derived  */
00025 /*    from this software without specific prior written permission.        */
00026 /*                                                                         */
00027 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00028 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00029 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00030 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00031 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00032 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00033 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00034 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00035 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00036 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00037 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00038 /*                                                                         */
00039 /* ======================================================================= */
00040
00041 #ifndef DSP_FFT32X32S_H_
00042 #define DSP_FFT32X32S_H_ 1
00043
00044 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00045 #include "assert.h"                       // intrinsics prototypes
00046 #include "C6xSimulator.h"                 // intrinsics prototypes
00047 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00048 #endif
00049
00051 /* @{ */
00052
00055 /* @{ */
00056
00096 void DSP_fft32x32s (
00097     const int * restrict ptr_w,
00098     int npoints,
00099     int * restrict ptr_x,
00100     int * restrict ptr_y
00101 );
00102
00103 #endif
00104
00105 /* ======================================================================== */
00106 /*  End of file:  DSP_fft32x32s.h                                           */
00107 /* ------------------------------------------------------------------------ */
00108 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00109 /*                           All Rights Reserved.                           */
00110 /* ======================================================================== */
00111


DSPLIB: DSP_fir_cplx.h Source File

DSP_fir_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_cplx.h -- Complex FIR Filter                                    */
00003 /*                   Optimized C Implementation (w/ Intrinsics)            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_CPLX_H_
00041 #define DSP_FIR_CPLX_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00086 void DSP_fir_cplx (
00087     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00088     const short *restrict h,    /* Coeff array [nh elements]      */
00089     short       *restrict r,    /* Output array [nr elements]     */
00090     int nh,                     /* Number of coefficients         */
00091     int nr                      /* Number of output samples       */
00092 );
00093
00094 #endif /* DSP_FIR_CPLX_H_ */
00095
00096 /* ======================================================================= */
00097 /*  End of file:  DSP_fir_cplx.h                                           */
00098 /* ----------------------------------------------------------------------- */
00099 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00100 /*                           All Rights Reserved.                          */
00101 /* ======================================================================= */
00102


DSPLIB: DSP_fir_cplx_hM4X4.h Source File

DSP_fir_cplx_hM4X4.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_cplx_hM4X4.h -- Complex FIR Filter                              */
00003 /*                         Optimized C Implementation (w/ Intrinsics)      */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_CPLX_HM4X4_H_
00041 #define DSP_FIR_CPLX_HM4X4_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00086 void DSP_fir_cplx_hM4X4 (
00087     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00088     const short *restrict h,    /* Coeff array [nh elements]      */
00089     short       *restrict r,    /* Output array [nr elements]     */
00090     int nh,                     /* Number of coefficients         */
00091     int nr                      /* Number of output samples       */
00092 );
00093
00094 #endif /* DSP_FIR_CPLX_HM4X4_H_ */
00095
00096 /* ======================================================================= */
00097 /*  End of file:  DSP_fir_cplx_hM4X4.h                                     */
00098 /* ----------------------------------------------------------------------- */
00099 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00100 /*                           All Rights Reserved.                          */
00101 /* ======================================================================= */
00102


DSPLIB: DSP_fir_gen.h Source File

DSP_fir_gen.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_gen.h -- FIR Filter (General)                                   */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_GEN_H_
00041 #define DSP_FIR_GEN_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00084 void DSP_fir_gen (
00085     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00086     const short *restrict h,    /* Coeff array [nh elements]      */
00087     short       *restrict r,    /* Output array [nr elements]     */
00088     int nh,                     /* Number of coefficients         */
00089     int nr                      /* Number of output samples       */
00090 );
00091
00092 #endif /* DSP_FIR_GEN_H_ */
00093
00094 /* ======================================================================= */
00095 /*  End of file:  DSP_fir_gen.h                                            */
00096 /* ----------------------------------------------------------------------- */
00097 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00098 /*                           All Rights Reserved.                          */
00099 /* ======================================================================= */
00100


DSPLIB: DSP_fir_gen_hM17_rA8X8.h Source File

DSP_fir_gen_hM17_rA8X8.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_gen_hM17_rA8X8.h -- FIR Filter (Radix 8)                        */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_GEN_HM17_RA8X8_H_
00041 #define DSP_FIR_GEN_HM17_RA8X8_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00083 void DSP_fir_gen_hM17_rA8X8 (
00084     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00085     const short *restrict h,    /* Coeff array [nh elements]      */
00086     short       *restrict r,    /* Output array [nr elements]     */
00087     int nh,                     /* Number of coefficients         */
00088     int nr                      /* Number of output samples       */
00089 );
00090
00091 #endif /* DSP_FIR_GEN_HM17_RA8X8_H_ */
00092
00093 /* ======================================================================= */
00094 /*  End of file:  DSP_fir_gen_hM17_rA8X8.h                                 */
00095 /* ----------------------------------------------------------------------- */
00096 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00097 /*                           All Rights Reserved.                          */
00098 /* ======================================================================= */
00099


DSPLIB: DSP_fir_r4.h Source File

DSP_fir_r4.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_r4.h -- FIR Filter (Radix 4)                                    */
00003 /*                 Optimized C Implementation (w/ Intrinsics)              */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_R4_H_
00041 #define DSP_FIR_R4_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00085 void DSP_fir_r4 (
00086     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00087     const short *restrict h,    /* Coeff array [nh elements]      */
00088     short       *restrict r,    /* Output array [nr elements]     */
00089     int nh,                     /* Number of coefficients         */
00090     int nr                      /* Number of output samples       */
00091 );
00092
00093 #endif /* DSP_FIR_R4_H_ */
00094
00095 /* ======================================================================= */
00096 /*  End of file:  DSP_fir_r4.h                                             */
00097 /* ----------------------------------------------------------------------- */
00098 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00099 /*                           All Rights Reserved.                          */
00100 /* ======================================================================= */
00101


DSPLIB: DSP_fir_r8.h Source File

DSP_fir_r8.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_r8.h -- FIR Filter (Radix 8)                                    */
00003 /*                 Optimized C Implementation (w/ Intrinsics)              */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_R8_H_
00041 #define DSP_FIR_R8_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00089 void DSP_fir_r8 (
00090     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00091     const short *restrict h,    /* Coeff array [nh elements]      */
00092     short       *restrict r,    /* Output array [nr elements]     */
00093     int nh,                     /* Number of coefficients         */
00094     int nr                      /* Number of output samples       */
00095 );
00096
00097 #endif /* DSP_FIR_R8_H_ */
00098
00099 /* ======================================================================= */
00100 /*  End of file:  DSP_fir_r8.h                                             */
00101 /* ----------------------------------------------------------------------- */
00102 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00103 /*                           All Rights Reserved.                          */
00104 /* ======================================================================= */
00105


DSPLIB: DSP_fir_r8_hM16_rM8A8X8.h Source File

DSP_fir_r8_hM16_rM8A8X8.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_r8_hM16_rM8A8X8.h -- FIR Filter (Radix 8)                       */
00003 /*                              Intrinsic C Implementation                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_R8_HM16_RM8A8X8_H_
00041 #define DSP_FIR_R8_HM16_RM8A8X8_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00085 void DSP_fir_r8_hM16_rM8A8X8 (
00086     const short *restrict x,    /* Input array [nr+nh-1 elements] */
00087     const short *restrict h,    /* Coeff array [nh elements]      */
00088     short       *restrict r,    /* Output array [nr elements]     */
00089     int nh,                     /* Number of coefficients         */
00090     int nr                      /* Number of output samples       */
00091 );
00092
00093 #endif /* DSP_FIR_R8_HM16_RM8A8X8_H_ */
00094
00095 /* ======================================================================= */
00096 /*  End of file:  DSP_fir_r8_hM16_rM8A8X8.h                                */
00097 /* ----------------------------------------------------------------------- */
00098 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00099 /*                           All Rights Reserved.                          */
00100 /* ======================================================================= */
00101


DSPLIB: DSP_fir_sym.h Source File

DSP_fir_sym.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fir_sym.h -- Symmetric FIR Filter                                   */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIR_SYM_H_
00041 #define DSP_FIR_SYM_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00092 void DSP_fir_sym (
00093     const short *restrict x,    /* Input samples                   */
00094     const short *restrict h,    /* Filter taps                     */
00095     short       *restrict r,    /* Output samples                  */
00096     int nh,                     /* Number of symmetric filter taps */
00097     int nr,                     /* Number of output samples        */
00098     int s                       /* Final output shift              */
00099 );
00100
00101 #endif /* DSP_FIR_SYM_H_ */
00102
00103 /* ======================================================================= */
00104 /*  End of file:  DSP_fir_sym.h                                            */
00105 /* ----------------------------------------------------------------------- */
00106 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00107 /*                           All Rights Reserved.                          */
00108 /* ======================================================================= */
00109


DSPLIB: DSP_firlms2.h Source File

DSP_firlms2.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_firlms2.h -- Least Mean Square Adaptive Filter                      */
00003 /*                  Intrinsic C source                                     */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FIRLMS2_H_
00041 #define DSP_FIRLMS2_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00082  /* }@ */ /* ingroup */
00083  /* }@ */ /* ingroup */
00084
00085 int DSP_firlms2 (
00086     short *restrict h,  /* Filter Coefficients */
00087     short *restrict x,  /* Input Data          */
00088     short           b,  /* Error from previous FIR */
00089     int             nh  /* Number of Coefficients  */
00090 );
00091
00092 #endif /* DSP_FIRLMS2_H_ */
00093
00094 /* ======================================================================== */
00095 /*  End of file:  DSP_firlms2.h                                             */
00096 /* ------------------------------------------------------------------------ */
00097 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00098 /*                           All Rights Reserved.                           */
00099 /* ======================================================================== */
00100


DSPLIB: DSP_fltoq15.h Source File

DSP_fltoq15.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_fltoq15.h -- Float to Q15 conversion                                */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_FLTOQ15_H_
00041 #define DSP_FLTOQ15_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00084 void DSP_fltoq15 (
00085     const float *restrict flt,  /* Input float array    */
00086     short *restrict q15,        /* Output Q15 array     */
00087     short nx                    /* Number of elements   */
00088 );
00089
00090 #endif /* DSP_FLTOQ15_H_ */
00091
00092 /* ======================================================================= */
00093 /*  End of file:  DSP_fltoq15.h                                            */
00094 /* ----------------------------------------------------------------------- */
00095 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00096 /*                           All Rights Reserved.                          */
00097 /* ======================================================================= */
00098


DSPLIB: DSP_ifft16x16.h Source File

DSP_ifft16x16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_ifft16x16.h -- 16x16 Mixed Radix Inverse FFT                        */
00003 /*                    Serial ASM Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IFFT16X16_H_
00041 #define DSP_IFFT16X16_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00091 void DSP_ifft16x16 (
00092     const short * restrict ptr_w,
00093     int npoints,
00094     short * restrict ptr_x,
00095     short * restrict ptr_y
00096 );
00097
00098 #endif
00099
00100 /* ======================================================================== */
00101 /*  End of file:  DSP_ifft16x16.h                                           */
00102 /* ------------------------------------------------------------------------ */
00103 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00104 /*                           All Rights Reserved.                           */
00105 /* ======================================================================== */
00106


DSPLIB: DSP_ifft16x16_imre.h Source File

DSP_ifft16x16_imre.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_ifft16x16_imre.h -- 16x16 Mixed Radix Inverse FFT                   */
00003 /*                         Serial ASM Implementation                       */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IFFT16X16_IMRE_H__
00041 #define DSP_IFFT16X16_IMRE_H__
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00092 void DSP_ifft16x16_imre (
00093     const short * restrict ptr_w,
00094     int npoints,
00095     short * restrict ptr_x,
00096     short * restrict ptr_y
00097 );
00098
00099 #endif
00100
00101 /* ======================================================================== */
00102 /*  End of file:  DSP_ifft16x16_imre.h                                      */
00103 /* ------------------------------------------------------------------------ */
00104 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00105 /*                           All Rights Reserved.                           */
00106 /* ======================================================================== */
00107


DSPLIB: DSP_ifft16x32.h Source File

DSP_ifft16x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_ifft16x32.h -- 16x32 Mixed Radix Inverse FFT                        */
00003 /*                    Serial ASM Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IFFT16X32_H_
00041 #define DSP_IFFT16X32_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00092 void DSP_ifft16x32 (
00093     const short * restrict ptr_w,
00094     int npoints,
00095     int * restrict ptr_x,
00096     int * restrict ptr_y
00097 );
00098
00099 #endif
00100
00101 /* ======================================================================== */
00102 /*  End of file:  DSP_ifft16x32.h                                           */
00103 /* ------------------------------------------------------------------------ */
00104 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00105 /*                           All Rights Reserved.                           */
00106 /* ======================================================================== */
00107


DSPLIB: DSP_ifft32x32.h Source File

DSP_ifft32x32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_ifft32x32.h -- 32x32 Mixed Radix Inverse FFT                        */
00003 /*                    Serial ASM Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IFFT32X32_H_
00041 #define DSP_IFFT32X32_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00092 void DSP_ifft32x32 (
00093     const int * restrict ptr_w,
00094     int npoints,
00095     int * restrict ptr_x,
00096     int * restrict ptr_y
00097 );
00098
00099 #endif
00100
00101 /* ======================================================================== */
00102 /*  End of file:  DSP_ifft32x32.h                                           */
00103 /* ------------------------------------------------------------------------ */
00104 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00105 /*                           All Rights Reserved.                           */
00106 /* ======================================================================== */
00107


DSPLIB: DSP_iir.h Source File

DSP_iir.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_iir.h -- Real IIR Filter                                            */
00003 /*              Intrinsic C Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IIR_H_
00041 #define DSP_IIR_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00095 void DSP_iir (
00096     short *r1,        /* Pointer to real output data used/stored */
00097     const short *x,   /* Pointer to real input data */
00098     short *r2,        /* Pointer to real output data stored */
00099     const short *h2,  /* Pointer to 5 Moving-average real filter coefficients */
00100     const short *h1,  /* Pointer to 4 Autoregressive real filter coefficients */
00101     int nr            /* Holds the value of number of real output samples */
00102 );
00103
00104 #endif /* DSP_IIR_H_ */
00105
00106 /* ======================================================================= */
00107 /*  End of file:  DSP_iir.h                                                */
00108 /* ----------------------------------------------------------------------- */
00109 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00110 /*                           All Rights Reserved.                          */
00111 /* ======================================================================= */
00112


DSPLIB: DSP_iir_lat.h Source File

DSP_iir_lat.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_irr_lat.h -- IIR Lattice Filter                                     */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IIR_LAT_H_
00041 #define DSP_IIR_LAT_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00092 void DSP_iir_lat (
00093     short       *x,
00094     int         nx,
00095     const short *restrict k,
00096     int         nk,
00097     int         *restrict b,
00098     short       *r
00099 );
00100
00101 #endif /* DSP_IIR_LAT_H_ */
00102
00103 /* ======================================================================= */
00104 /*  End of file:  DSP_iir_lat.h                                            */
00105 /* ----------------------------------------------------------------------- */
00106 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00107 /*                           All Rights Reserved.                          */
00108 /* ======================================================================= */
00109


DSPLIB: DSP_iir_ss.h Source File

DSP_iir_ss.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_iir_ss.h -- IIR Filter                                              */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_IIR_SS_H_
00041 #define DSP_IIR_SS_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00082 short DSP_iir_ss (
00083     short                 Input,
00084     const short *restrict Coefs,
00085     int                   nCoefs,
00086     short       *restrict State
00087 );
00088
00089 #endif /* DSP_IIR_SS_H_ */
00090
00091 /* ======================================================================= */
00092 /*  End of file:  DSP_iir_ss.h                                             */
00093 /* ----------------------------------------------------------------------- */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00095 /*                           All Rights Reserved.                          */
00096 /* ======================================================================= */
00097


DSPLIB: DSP_mat_mul.h Source File

DSP_mat_mul.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_mat_mul.h -- Perform Matrix Multiplication                          */
00003 /*                  Intrinsic C Implementation                             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MAT_MUL_H_
00041 #define DSP_MAT_MUL_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00093 void DSP_mat_mul (
00094     const short *restrict x, int r1, int c1,
00095     const short *restrict y,         int c2,
00096     short       *restrict r,
00097     int                   qs
00098 );
00099
00100 #endif
00101
00102 /* ======================================================================== */
00103 /*  End of file:  DSP_mat_mul.h                                             */
00104 /* ------------------------------------------------------------------------ */
00105 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00106 /*                           All Rights Reserved.                           */
00107 /* ======================================================================== */
00108


DSPLIB: DSP_mat_mul_cplx.h Source File

DSP_mat_mul_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_mat_mul_cplx.h -- Perform Matrix Multiplication                     */
00003 /*                  Intrinsic C Implementation                             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MAT_MUL_CPLX_H_
00041 #define DSP_MAT_MUL_CPLX_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00093 void DSP_mat_mul_cplx (
00094     const short *restrict x, int r1, int c1,
00095     const short *restrict y,         int c2,
00096     short       *restrict r,
00097     int                   qs
00098 );
00099
00100 #endif
00101
00102 /* ======================================================================== */
00103 /*  End of file:  DSP_mat_mul_cplx.h                                        */
00104 /* ------------------------------------------------------------------------ */
00105 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00106 /*                           All Rights Reserved.                           */
00107 /* ======================================================================== */
00108


DSPLIB: DSP_mat_trans.h Source File

DSP_mat_trans.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_mat_trans.h -- Matrix Transpose                                     */
00003 /*                    Optimized C Implementation (w/ Intrinsics)           */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MAT_TRANS_H_
00041 #define DSP_MAT_TRANS_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00079 void DSP_mat_trans (
00080     const short *restrict   x,          /* Input matrix             */
00081     short                   rows,       /* Height of input matrix   */
00082     short                   columns,    /* Width of input matrix    */
00083     short *restrict         r           /* Output matrix            */
00084 );
00085
00086 #endif /* DSP_MAT_TRANS_H_ */
00087
00088 /* ======================================================================= */
00089 /*  End of file:  DSP_mat_trans.h                                          */
00090 /* ----------------------------------------------------------------------- */
00091 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00092 /*                           All Rights Reserved.                          */
00093 /* ======================================================================= */
00094


DSPLIB: DSP_maxidx.h Source File

DSP_maxidx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_maxidx.h -- Maximum Vector Value                                    */
00003 /*                 Intrinsic C Implementation                              */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MAXIDX_H_
00041 #define DSP_MAXIDX_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00084 int DSP_maxidx (
00085     const short *x,
00086     int          nx
00087 );
00088
00089 #endif
00090
00091 /* ======================================================================== */
00092 /*  End of file:  DSP_maxidx.h                                              */
00093 /* ------------------------------------------------------------------------ */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00095 /*                           All Rights Reserved.                           */
00096 /* ======================================================================== */
00097


DSPLIB: DSP_maxval.h Source File

DSP_maxval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_maxval.h -- Maximum Value of a Vector                               */
00003 /*                 Intrinsic C source                                      */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MAXVAL_H_
00041 #define DSP_MAXVAL_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00078 short DSP_maxval (
00079     const short * restrict x,     /* x[nx] = input vector    */
00080     int nx                        /* nx = number of elements */
00081 );
00082
00083 #endif /* DSP_MAXVAL_H_ */
00084
00085 /* ======================================================================== */
00086 /*  End of file:  DSP_maxval.h                                              */
00087 /* ------------------------------------------------------------------------ */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00089 /*                           All Rights Reserved.                           */
00090 /* ======================================================================== */
00091


DSPLIB: DSP_minerror.h Source File

DSP_minerror.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_minerror.h -- Minimum Energy Error Search                           */
00003 /*                   Optimized C Implementation (w/ Intrinsics)            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MINERROR_H_
00041 #define DSP_MINERROR_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00077  /* }@ */ /* ingroup */
00078  /* }@ */ /* ingroup */
00079
00080 int DSP_minerror (
00081     const short *restrict GSP0_TABLE,  /* Pointer to GSP0 terms array         */
00082     const short *restrict errCoefs,    /* Array of error coefficients         */
00083     int *restrict max_index            /* Index to the 9-element vector that  */
00084                                        /* resulted in the maximum dot product */
00085 );
00086
00087 #endif /* DSP_MINERROR_H_ */
00088
00089 /* ======================================================================= */
00090 /*  End of file:  DSP_minerror.h                                           */
00091 /* ----------------------------------------------------------------------- */
00092 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00093 /*                           All Rights Reserved.                          */
00094 /* ======================================================================= */
00095


DSPLIB: DSP_minval.h Source File

DSP_minval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_minval.h -- Minimum Value of a Vector                               */
00003 /*                 Intrisic C Implementation                               */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_MINVAL_H_
00041 #define DSP_MINVAL_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00078 short DSP_minval (
00079     const short * restrict x,     /* x[nx] = input vector    */
00080     int nx                        /* nx = number of elements */
00081 );
00082
00083 #endif /* DSP_MINVAL_H_ */
00084
00085 /* ======================================================================== */
00086 /*  End of file:  DSP_minval.h                                              */
00087 /* ------------------------------------------------------------------------ */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00089 /*                           All Rights Reserved.                           */
00090 /* ======================================================================== */
00091


DSPLIB: DSP_mul32.h Source File

DSP_mul32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_mul32.h -- Optimized C source interface header file                 */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef DSP_MUL32_H_
00040 #define DSP_MUL32_H_ 1
00041
00042 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00043 #include "assert.h"                       // intrinsics prototypes
00044 #include "C6xSimulator.h"                 // intrinsics prototypes
00045 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00046 #endif
00047
00049 /* @{ */
00050
00053 /* @{ */
00054
00083 void DSP_mul32 (
00084     const int * restrict x,    /* Input array of length nx  */
00085     const int * restrict y,    /* Input array of length nx  */
00086     int       * restrict r,    /* Output array of length nx */
00087     int                  nx    /* Number of elements.       */
00088 );
00089
00090 #endif /* DSP_MUL32_H_ */
00091
00092 /* ======================================================================== */
00093 /*  End of file:  DSP_mul32.h                                               */
00094 /* ------------------------------------------------------------------------ */
00095 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00096 /*                           All Rights Reserved.                           */
00097 /* ======================================================================== */
00098


DSPLIB: DSP_neg32.h Source File

DSP_neg32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_neg32.h -- Intrinsic C source interface header file                 */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef DSP_NEG32_H_
00040 #define DSP_NEG32_H_ 1
00041
00042 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00043 #include "assert.h"                       // intrinsics prototypes
00044 #include "C6xSimulator.h"                 // intrinsics prototypes
00045 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00046 #endif
00047
00049 /* @{ */
00050
00053 /* @{ */
00054
00079 void DSP_neg32 (
00080     const int * restrict x,    /* Input data array   */
00081     int * restrict r,          /* Output data array  */
00082     int nx                     /* Number of elements */
00083 );
00084
00085 #endif /* DSP_NEG32_H_ */
00086
00087 /* ======================================================================== */
00088 /*  End of file:  dsp_neg32.h                                               */
00089 /* ------------------------------------------------------------------------ */
00090 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00091 /*                           All Rights Reserved.                           */
00092 /* ======================================================================== */
00093


DSPLIB: DSP_q15tofl.h Source File

DSP_q15tofl.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_q15tofl.h -- Q15 to Float conversion                                */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_Q15TOFL_H_
00041 #define DSP_Q15TOFL_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080  /* }@ */ /* ingroup */
00081  /* }@ */ /* ingroup */
00082
00083 void DSP_q15tofl (
00084     const short *restrict q15,  /* Input Q15 array      */
00085     float *restrict flt,        /* Output float array   */
00086     int   nx                    /* Number of elements   */
00087 );
00088
00089 #endif /* DSP_Q15TOFL_H_ */
00090
00091 /* ======================================================================= */
00092 /*  End of file:  DSP_q15tofl.h                                            */
00093 /* ----------------------------------------------------------------------- */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00095 /*                           All Rights Reserved.                          */
00096 /* ======================================================================= */
00097


DSPLIB: DSP_recip16.h Source File

DSP_recip16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_recip16.h -- Reciprocal Function                                    */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_RECIP16_H_
00041 #define DSP_RECIP16_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00086 void DSP_recip16 (
00087     const short *restrict x,    /* Input array                       */
00088     short *restrict rfrac,      /* Output array containg Fractions   */
00089     short *restrict rexp,       /* Output array containing Exponents */
00090     short nx                    /* Number of elements in arrays      */
00091 );
00092
00093 #endif /* DSP_RECIP16_H_ */
00094 /* ======================================================================= */
00095 /*  End of file:  DSP_recip16.h                                            */
00096 /* ----------------------------------------------------------------------- */
00097 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00098 /*                           All Rights Reserved.                          */
00099 /* ======================================================================= */
00100


DSPLIB: DSP_vecsumsq.h Source File

DSP_vecsumsq.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_vecsumsq.h -- Sum of Squares                                        */
00003 /*                   Intrinsic C Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_VECSUMSQ_H_
00041 #define DSP_VECSUMSQ_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00078 int DSP_vecsumsq (
00079     const short * x,
00080     int   nx
00081 );
00082
00083 #endif
00084
00085 /* ======================================================================== */
00086 /*  End of file:  DSP_vecsumsq.h                                            */
00087 /* ------------------------------------------------------------------------ */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00089 /*                           All Rights Reserved.                           */
00090 /* ======================================================================== */
00091


DSPLIB: DSP_w_vec.h Source File

DSP_w_vec.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSP_w_vec.h -- Weighted Vector Sum                                      */
00003 /*                Intrinsic C Implementation                               */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSP_W_VEC_H_
00041 #define DSP_W_VEC_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00082 void DSP_w_vec (
00083     const short * restrict x,   /* Vector being weighted  */
00084     const short * restrict y,   /* Non-weighted vector    */
00085     short m,                    /* weighting factor       */
00086     short * restrict r,         /* Result vector          */
00087     int nr                      /* Number of samples.     */
00088 );
00089
00090 #endif
00091
00092 /* ======================================================================== */
00093 /*  End of file:  DSP_w_vec.h                                               */
00094 /* ------------------------------------------------------------------------ */
00095 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00096 /*                           All Rights Reserved.                           */
00097 /* ======================================================================== */
00098


DSPLIB: doxygen.h Source File

doxygen.h

Go to the documentation of this file.
00001 /*
00002  * This is a little header file which doxygen parses to generate the main
00003  * documentation page
00004  */
00005


DSPLIB: Data Fields

  • All
  • Functions
  • Defines
  • _
  • d
  • f

- _ -

  • _DSP_ADD16_H_ : DSP_add16.h
  • _DSP_ADD32_H_ : DSP_add32.h
  • _DSP_AUTOCOR_H_ : DSP_autocor.h
  • _DSP_BEXP_H_ : DSP_bexp.h
  • _DSP_BLK_ESWAP16_H_ : DSP_blk_eswap16.h
  • _DSP_BLK_ESWAP32_H_ : DSP_blk_eswap32.h
  • _DSP_BLK_ESWAP64_H_ : DSP_blk_eswap64.h
  • _DSP_BLK_MOVE_H_ : DSP_blk_move.h
  • _DSP_DOTP_SQR_H_ : DSP_dotp_sqr.h
  • _DSP_DOTPROD_H_ : DSP_dotprod.h
  • _DSP_FFT16X16_H_ : DSP_fft16x16.h
  • _DSP_FFT16X16_IMRE_H_ : DSP_fft16x16_imre.h
  • _DSP_FFT16X16R_H_ : DSP_fft16x16r.h
  • _DSP_FFT16X32_H_ : DSP_fft16x32.h
  • _DSP_FFT32X32_H_ : DSP_fft32x32.h
  • _DSP_FFT32X32S_H_ : DSP_fft32x32s.h
  • _DSP_FIR_CPLX_H_ : DSP_fir_cplx.h
  • _DSP_FIR_CPLX_HM4X4_H_ : DSP_fir_cplx_hM4X4.h
  • _DSP_FIR_GEN_H_ : DSP_fir_gen.h
  • _DSP_FIR_GEN_HM17_RA8X8_H_ : DSP_fir_gen_hM17_rA8X8.h
  • _DSP_FIR_R4_H_ : DSP_fir_r4.h
  • _DSP_FIR_R8_H_ : DSP_fir_r8.h
  • _DSP_FIR_R8_HM16_RM8A8X8_H_ : DSP_fir_r8_hM16_rM8A8X8.h
  • _DSP_FIR_SYM_H_ : DSP_fir_sym.h
  • _DSP_FIRLMS2_H_ : DSP_firlms2.h
  • _DSP_FLTOQ15_H_ : DSP_fltoq15.h
  • _DSP_IFFT16X32_H_ : DSP_ifft16x32.h
  • _DSP_IFFT32X32_H_ : DSP_ifft32x32.h
  • _DSP_IIR_H_ : DSP_iir.h
  • _DSP_IIR_LAT_H_ : DSP_iir_lat.h
  • _DSP_IIR_SS_H_ : DSP_iir_ss.h
  • _DSP_MAT_MUL_CPLX_H_ : DSP_mat_mul_cplx.h
  • _DSP_MAT_MUL_H_ : DSP_mat_mul.h
  • _DSP_MAT_TRANS_H_ : DSP_mat_trans.h
  • _DSP_MAXIDX_H_ : DSP_maxidx.h
  • _DSP_MAXVAL_H_ : DSP_maxval.h
  • _DSP_MINERROR_H_ : DSP_minerror.h
  • _DSP_MINVAL_H_ : DSP_minval.h
  • _DSP_MUL32_H_ : DSP_mul32.h
  • _DSP_NEG32_H_ : DSP_neg32.h
  • _DSP_Q15TOFL_H_ : DSP_q15tofl.h
  • _DSP_RECIP16_H_ : DSP_recip16.h
  • _DSP_VECSUMSQ_H_ : DSP_vecsumsq.h
  • _DSP_W_VEC_H_ : DSP_w_vec.h

- d -

  • DSP_ADD16_H_ : c64P/DSP_add16.h
  • DSP_ADD32_H_ : c64P/DSP_add32.h
  • DSP_AUTOCOR_H_ : c64P/DSP_autocor.h
  • DSP_BLK_ESWAP16_H_ : c64P/DSP_blk_eswap16.h
  • DSP_BLK_ESWAP32_H_ : c64P/DSP_blk_eswap32.h
  • DSP_BLK_ESWAP64_H_ : c64P/DSP_blk_eswap64.h
  • DSP_BLK_MOVE_H_ : c64P/DSP_blk_move.h
  • DSP_FFT16X16_H_ : c64P/DSP_fft16x16.h
  • DSP_FFT16X16R_H_ : c64P/DSP_fft16x16r.h
  • DSP_FFT16X32_H_ : c64P/DSP_fft16x32.h
  • DSP_FFT32X32_H_ : c64P/DSP_fft32x32.h
  • DSP_FFT32X32S_H_ : c64P/DSP_fft32x32s.h
  • DSP_FIR_GEN_HM17_RA8X8_H_ : c64P/DSP_fir_gen_hM17_rA8X8.h
  • DSP_FIR_R8_H_ : c64P/DSP_fir_r8.h
  • DSP_FIR_R8_HM16_RM8A8X8_H_ : c64P/DSP_fir_r8_hM16_rM8A8X8.h
  • DSP_FIR_SYM_H_ : c64P/DSP_fir_sym.h
  • DSP_FIRLMS2_H_ : c64P/DSP_firlms2.h
  • DSP_FLTOQ15_H_ : c64P/DSP_fltoq15.h
  • DSP_IFFT16X32_H_ : c64P/DSP_ifft16x32.h
  • DSP_IFFT32X32_H_ : c64P/DSP_ifft32x32.h
  • DSP_IIR_LAT_H_ : c64P/DSP_iir_lat.h
  • DSP_MAT_MUL_CPLX_H_ : c64P/DSP_mat_mul_cplx.h
  • DSP_MAT_MUL_H_ : c64P/DSP_mat_mul.h
  • DSP_MAT_TRANS_H_ : c64P/DSP_mat_trans.h
  • DSP_MAXIDX_H_ : c64P/DSP_maxidx.h
  • DSP_MAXVAL_H_ : c64P/DSP_maxval.h
  • DSP_MINVAL_H_ : c64P/DSP_minval.h
  • DSP_MUL32_H_ : c64P/DSP_mul32.h
  • DSP_NEG32_H_ : c64P/DSP_neg32.h
  • DSP_Q15TOFL_H_ : c64P/DSP_q15tofl.h
  • DSP_RECIP16_H_ : c64P/DSP_recip16.h
  • DSP_VECSUMSQ_H_ : c64P/DSP_vecsumsq.h
  • DSP_W_VEC_H_ : c64P/DSP_w_vec.h

- f -

  • FFT16X16_IMRE_H_ : c64P/DSP_fft16x16_imre.h


DSPLIB: Data Fields

  • All
  • Functions
  • Defines
  • d

- d -

  • DSP_add16() : c64P/DSP_add16.h
  • DSP_add32() : c64P/DSP_add32.h
  • DSP_autocor() : c64P/DSP_autocor.h
  • DSP_bexp() : c64P/DSP_bexp.h
  • DSP_blk_eswap16() : c64P/DSP_blk_eswap16.h
  • DSP_blk_eswap32() : c64P/DSP_blk_eswap32.h
  • DSP_blk_eswap64() : c64P/DSP_blk_eswap64.h
  • DSP_blk_move() : c64P/DSP_blk_move.h
  • DSP_dotp_sqr() : c64P/DSP_dotp_sqr.h
  • DSP_dotprod() : c64P/DSP_dotprod.h
  • DSP_fft16x16() : c64P/DSP_fft16x16.h
  • DSP_fft16x16_imre() : c64P/DSP_fft16x16_imre.h
  • DSP_fft16x16r() : c64P/DSP_fft16x16r.h
  • DSP_fft16x32() : c64P/DSP_fft16x32.h
  • DSP_fft32x32() : c64P/DSP_fft32x32.h
  • DSP_fft32x32s() : c64P/DSP_fft32x32s.h
  • DSP_fir_cplx() : c64P/DSP_fir_cplx.h
  • DSP_fir_cplx_hM4X4() : c64P/DSP_fir_cplx_hM4X4.h
  • DSP_fir_gen() : c64P/DSP_fir_gen.h
  • DSP_fir_gen_hM17_rA8X8() : c64P/DSP_fir_gen_hM17_rA8X8.h
  • DSP_fir_r4() : c64P/DSP_fir_r4.h
  • DSP_fir_r8() : c64P/DSP_fir_r8.h
  • DSP_fir_r8_hM16_rM8A8X8() : c64P/DSP_fir_r8_hM16_rM8A8X8.h
  • DSP_fir_sym() : c64P/DSP_fir_sym.h
  • DSP_firlms2() : c64P/DSP_firlms2.h
  • DSP_fltoq15() : c64P/DSP_fltoq15.h
  • DSP_ifft16x16() : c64P/DSP_ifft16x16.h
  • DSP_ifft16x16_imre() : c64P/DSP_ifft16x16_imre.h
  • DSP_ifft16x32() : c64P/DSP_ifft16x32.h
  • DSP_ifft32x32() : c64P/DSP_ifft32x32.h
  • DSP_iir() : c64P/DSP_iir.h
  • DSP_iir_lat() : c64P/DSP_iir_lat.h
  • DSP_iir_ss() : c64P/DSP_iir_ss.h
  • DSP_mat_mul() : c64P/DSP_mat_mul.h
  • DSP_mat_mul_cplx() : c64P/DSP_mat_mul_cplx.h
  • DSP_mat_trans() : c64P/DSP_mat_trans.h
  • DSP_maxidx() : c64P/DSP_maxidx.h
  • DSP_maxval() : c64P/DSP_maxval.h
  • DSP_minerror() : c64P/DSP_minerror.h
  • DSP_minval() : c64P/DSP_minval.h
  • DSP_mul32() : c64P/DSP_mul32.h
  • DSP_neg32() : c64P/DSP_neg32.h
  • DSP_q15tofl() : c64P/DSP_q15tofl.h
  • DSP_recip16() : c64P/DSP_recip16.h
  • DSP_vecsumsq() : c64P/DSP_vecsumsq.h
  • DSP_w_vec() : c64P/DSP_w_vec.h


DSPLIB: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.