DSPLIB: DSPLIB API Reference

  • Main Page
  • Modules
  • Files

DSPLIB API Reference

Release 3.1.1.1

This is the main landing page for the DSPLIB API Reference. You can navigate by functional category using the links provided below or directly to any module (kernel) or it's assocaited soure file using the tabs above. You can always return to this page via the "Main Page" tab above.

Introduction

The TI C6000 DSPLIB is an optimized DSP Function Library for C programmers. It includes many C-callable, optimized, general-purpose signal-processing routines. These routines are typically used in computationally-intensive real-time applications where optimal execution speed is critical. By using these routines, you can achieve execution speeds considerably faster than equivalent code written in standard ANSI C language. In addition, by providing ready-to-use DSP functions, TI DSPLIB can significantly shorten your DSP application development time.

The TI DSPLIB includes commonly used DSP routines. Source code is provided that allows you to modify functions to match your specific needs.

The routines contained in the library are organized into the following seven different functional areas:

Features and Benefits

  • Natural C Source Code
  • Optimized C code with Intrinsics
  • C-callable routines, fully compatible with the TI C6x compiler
  • Fractional Q.15-format operands supported on some benchmarks
  • Benchmarks (cycle and code size)
  • Tested against C model
  • The provided precompiled library was compiled using Code Generation Tools Version 7.2.0

Modules

  • Adaptive filtering
  • Correlation
  • Fast Fourier Transform
  • Filtering and convolution
  • Math
  • Matrix
  • Miscellaneous
Copyright 2012, Texas Instruments Incorporated


DSPLIB: Module Index

DSPLIB Modules

Here is a list of all modules:
  • Adaptive filtering
    • DSPF_sp_lms2
  • Correlation
    • DSPF_sp_autocor
    • DSPF_sp_convol
  • Fast Fourier Transform
    • DSPF_sp_bitrev_cplx
    • DSPF_sp_cfftr2_dit
    • DSPF_sp_cfftr4_dif
    • DSPF_sp_fftSPXSP
    • DSPF_sp_icfftr2_dif
    • DSPF_sp_ifftSPXSP
  • Filtering and convolution
    • DSPF_sp_biquad
    • DSPF_sp_fircirc
    • DSPF_sp_fir_cplx
    • DSPF_sp_fir_gen
    • DSPF_sp_fir_r2
    • DSPF_sp_iir
    • DSPF_sp_iirlat
  • Math
    • DSPF_sp_dotprod
    • DSPF_sp_dotp_cplx
    • DSPF_sp_maxidx
    • DSPF_sp_maxval
    • DSPF_sp_minerr
    • DSPF_sp_minval
    • DSPF_sp_vecmul
    • DSPF_sp_vecrecip
    • DSPF_sp_vecsum_sq
    • DSPF_sp_w_vec
  • Matrix
    • DSPF_sp_mat_mul
    • DSPF_sp_mat_mul_cplx
    • DSPF_sp_mat_trans
  • Miscellaneous
    • DSPF_blk_eswap16
    • DSPF_blk_eswap32
    • DSPF_blk_eswap64
    • DSPF_fltoq15
    • DSPF_q15tofl
    • DSPF_sp_blk_move


DSPLIB: Adaptive filtering

Adaptive filtering

Collaboration diagram for Adaptive filtering:

Detailed Description

Modules

DSPF_sp_lms2


DSPLIB: DSPF_sp_lms2

DSPF_sp_lms2
[Adaptive filtering]

Collaboration diagram for DSPF_sp_lms2:

Detailed Description

float DSPF_sp_lms (const float *x, float *restrict h, const float *y_i, float *restrict y_o, const float ar, float error, const int nh, const int nx)

Function Documentation

float DSPF_sp_lms | ( | const float * | x,
 |  | float *restrict | h,
 |  | const float * | y_i,
 |  | float *restrict | y_o,
 |  | const float | ar,
 |  | float | error,
 |  | const int | nh,
 |  | const int | nx
 | ) |  |

The DSPF_sp_lms implements an LMS adaptive filter. Given an actual input signal and a desired input signal, the filter produces an output signal, the final coefficient values, and returns the final output error signal.

Parameters:
x | Pointer to input samples
h | Pointer to the coefficient array
y_i | Pointer to the desired output array
y_o | Pointer to filtered output array
ar | Adaptation rate
error | Initial error
nh | Number of coefficients
nx | Number of output samples
Algorithm:
DSPF_sp_lms2_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nh must be a multiple of 2 and >= 2.
The coefficient array is assumed to be in reverse order; i.e., h(nh-1), h(nh-2), ..., h(0) will hold coefficients h0, h1, ..., hnh-1, repectively.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: Correlation

Correlation

Collaboration diagram for Correlation:

Detailed Description

Modules

DSPF_sp_autocor
DSPF_sp_convol


DSPLIB: DSPF_sp_autocor

DSPF_sp_autocor
[Correlation]

Collaboration diagram for DSPF_sp_autocor:

Detailed Description

void DSPF_sp_autocor (float *restrict r, float *restrict x, const int nx, const int nr)

Function Documentation

void DSPF_sp_autocor | ( | float *restrict | r,
 |  | float *restrict | x,
 |  | const int | nx,
 |  | const int | nr
 | ) |  |

This routine performs the autocorrelation of the input array x. It is assumed that the length of the input array, x, is a multiple of 2 and the length of the output array, r, is a multiple of 4. It is assumed that input vector x is padded with nr no of zeros in the beginning.

Parameters:
r | Pointer to output array of autocorrelation of length nr
x | Pointer to input array of length nx+nr Input data must be padded with nr consecutive zeros at the beginning
nx | Length of autocorrelation vector
nr | Length of lags
Algorithm:
DSPF_sp_autocor_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx is a multiple of 2 and greater than or equal to 2
nr is a multiple of 4 and greater than or equal to 4
nx is greater than or equal to nr
x is double-word aligned
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_convol

DSPF_sp_convol
[Correlation]

Collaboration diagram for DSPF_sp_convol:

Detailed Description

void DSPF_sp_convol (const float *x, const float *h, float *restrict y, const short nh, const short ny)

Function Documentation

void DSPF_sp_convol | ( | const float * | x,
 |  | const float * | h,
 |  | float *restrict | y,
 |  | const short | nh,
 |  | const short | ny
 | ) |  |

This function calculates the full-length convolution of real vectors x and h using time-domain techniques. The result is placed in real vector y. It is assumed that input vector x is padded with nh-1 no of zeros in the beginning and end.

Parameters:
x | Pointer to real input vector of size = nr+nh-1.
h | pointer to real input vector of size nh in forward order.
y | Pointer to real output vector of size ny.
nh | Number of elements in vector h.
ny | Number of elements in vector y.
Algorithm:
DSPF_sp_convol_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nh is a multiple of 2 and greater than or equal to 2.
ny is a multiple of 2.
x, h and y are assumed to be aligned on a double-word boundary.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: Fast Fourier Transform

Fast Fourier Transform

Collaboration diagram for Fast Fourier Transform:

Detailed Description

Modules

DSPF_sp_bitrev_cplx
DSPF_sp_cfftr2_dit
DSPF_sp_cfftr4_dif
DSPF_sp_fftSPXSP
DSPF_sp_icfftr2_dif
DSPF_sp_ifftSPXSP


DSPLIB: DSPF_sp_bitrev_cplx

DSPF_sp_bitrev_cplx
[Fast Fourier Transform]

Collaboration diagram for DSPF_sp_bitrev_cplx:

Detailed Description

void DSPF_sp_bitrev_cplx (double *restrict x, short *restrict index, int nx)

Function Documentation

void DSPF_sp_bitrev_cplx | ( | double *restrict | x,
 |  | short *restrict | index,
 |  | int | nx
 | ) |  |

This routine performs the bit-reversal of the input array x[], where x[] is a float array of length 2*nx containing single-precision floating-point complex pairs of data. This routine requires the index array provided by the program below. This index should be generated at compile time, not by the DSP. TI retains all rights, title and interest in this code and only authorizes the use of the bit-reversal code and related table generation code with TMS320 family DSPs manufactured by TI.

Parameters:
x | Complex input array to be bit reversed. Contains 2*nx floats
index | Array of size ~sqrt(nx) created by the routine bitrev_index to allow the fast implementation of the bit reversal
nx | Number of elements in array x[]
Algorithm:
DSPF_sp_bitrev_cplx_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx must be a power of 2.
The table from bitrev_index is already created.
The array x is actually an array of 2*nx floats.
Array x is assumed to be double word aligned.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_cfftr2_dit

DSPF_sp_cfftr2_dit
[Fast Fourier Transform]

Collaboration diagram for DSPF_sp_cfftr2_dit:

Detailed Description

void DSPF_sp_cfftr2_dit (float *x, float *w, unsigned short n)

Function Documentation

void DSPF_sp_cfftr2_dit | ( | float * | x,
 |  | float * | w,
 |  | unsigned short | n
 | ) |  |

This routine performs the decimation-in-time (DIT) radix-2 FFT of the input array x. x has N complex floating-point numbers arranged as successive real and imaginary number pairs. Input array x contains N complex points (N*2 elements). The coefficients for the FFT are passed to the function in array w which contains N/2 complex numbers (N elements) as successive real and imaginary number pairs. The FFT coefficients w are in N/2 bit-reversed order The elements of input array x are in normal order The assembly routine performs 4 output samples (2 real and 2 imaginary) for a pass through inner loop.

Parameters:
x | Pointer to complex data input.
w | Pointer to complex twiddle factor in bit-reverse order.
n | Length of FFT in complex samples, power of 2 such that n>=32.
Algorithm:
DSPF_sp_cfftr2_dit_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
N needs to be power of 2 and N >= 32
x, and w should be align on the double-word boundary
The FFT Coefficients w are in bit-reversed order
The elements of input array x are in normal order
The imaginary coefficients of w are negated as {cos(d*0), sin(d*0), cos(d*1), sin(d*1) ...} as opposed to the normal sequence of {cos(d*0), -sin(d*0), cos(d*1), -sin(d*1) ...} where d = 2*PI/n.
Implementation Notes:
Interruptibility: The code is interrupt-tolerant but not interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_cfftr4_dif

DSPF_sp_cfftr4_dif
[Fast Fourier Transform]

Collaboration diagram for DSPF_sp_cfftr4_dif:

Detailed Description

void DSPF_sp_cfftr4_dif (float *x, float *w, unsigned short n)

Function Documentation

void DSPF_sp_cfftr4_dif | ( | float * | x,
 |  | float * | w,
 |  | unsigned short | n
 | ) |  |

This routine implements the DIF (decimation in frequency) complex radix 4 FFT with digit-reversed output and normal order input. The number of points, ‘n’, must be a power of 4 {4, 16, 64, 256, 1024, ...}. This routine is an in-place routine in the sense that the output is written over the input. It is not an in-place routine in the sense that the input is in normal order and the output is in digit-reversed order. There must be n complex points (2*n values), and 3*n/4 complex coefficients (3*n/2 values).

Parameters:
x | Pointer to an array holding the input and output floating-point array which contains ‘n’ complex points.
w | Pointer to an array holding the coefficient floating-point array which contains 3*n/4 complex numbers.
n | Number of complex points in x.
Algorithm:
DSPF_sp_cfftr4_dif_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
N needs to be power of 4
Implementation Notes:
Interruptibility: The code is interrupt-tolerant but not interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_fftSPXSP

DSPF_sp_fftSPXSP
[Fast Fourier Transform]

Collaboration diagram for DSPF_sp_fftSPXSP:

Detailed Description

void DSPF_sp_fftSPxSP (int N, float *ptr_x, float *ptr_w, float *ptr_y, unsigned char *brev, int n_min, int offset, int n_max)

Function Documentation

void DSPF_sp_fftSPxSP | ( | int | N,
 |  | float * | ptr_x,
 |  | float * | ptr_w,
 |  | float * | ptr_y,
 |  | unsigned char * | brev,
 |  | int | n_min,
 |  | int | offset,
 |  | int | n_max
 | ) |  |

The benchmark performs a mixed radix forwards fft.

Parameters:
N | length of FFT in complex samples
ptr_x | pointer to complex data input
ptr_w | pointer to complex twiddle factor
ptr_y | pointer to complex output data
brev | pointer to bit reverse table containing 64 entries
n_min | should be 4 if N can be represented as Power of 4 else, n_min should be 2
offset | index in complex samples of sub-fft from start of main fft
n_max | size of main fft in complex samples
Algorithm:
DSPF_sp_fftSPxSP_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
N needs to be power of 2
8 <= N <= 131072
Arrays pointed by ptr_x, ptr_w, and ptr_y should not overlap
Arrays pointed by ptr_x, ptr_w, and ptr_y should align on the double words boundary
Implementation Notes:
Interruptibility: The code is interrupt-tolerant but not interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_icfftr2_dif

DSPF_sp_icfftr2_dif
[Fast Fourier Transform]

Collaboration diagram for DSPF_sp_icfftr2_dif:

Detailed Description

void DSPF_sp_icfftr2_dif (float *x, float *w, unsigned short n)

Function Documentation

void DSPF_sp_icfftr2_dif | ( | float * | x,
 |  | float * | w,
 |  | unsigned short | n
 | ) |  |

This routine is used to compute the inverse, complex, radix-2, decimation-infrequency Fast Fourier Transform of a single-precision complex sequence of size n, and a power of 2. The routine requires bit-reversed input and bit-reversed coefficents (twiddle factors) and produces results that are in normal order.

Parameters:
x | Input and output sequences (dim-n) (input/output) x has n complex numbers (2*n SP values). The real and imaginary values are interleaved in memory. The input is in bit-reversed order nad output is in normal order.
w | FFT coefficients (dim-n/2) (input) w has n/2 complex numbers (n SP values). FFT coeficients must be in bit-reversed order. The real and imaginary values are interleaved in memory.
n | FFT size (input).
Algorithm:
DSPF_sp_icfftr2_dif_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
Both input x and coefficient w should be aligned on double-word boundary.
x should be padded with 4 words.
n should be greater than 8.
Implementation Notes:
Interruptibility: The code is interrupt-tolerant but not interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_ifftSPXSP

DSPF_sp_ifftSPXSP
[Fast Fourier Transform]

Collaboration diagram for DSPF_sp_ifftSPXSP:

Detailed Description

void DSPF_sp_ifftSPxSP (int N, float *ptr_x, float *ptr_w, float *ptr_y, unsigned char *brev, int n_min, int offset, int n_max)

Function Documentation

void DSPF_sp_ifftSPxSP | ( | int | N,
 |  | float * | ptr_x,
 |  | float * | ptr_w,
 |  | float * | ptr_y,
 |  | unsigned char * | brev,
 |  | int | n_min,
 |  | int | offset,
 |  | int | n_max
 | ) |  |

The benchmark performs a mixed radix inverse fft.

Parameters:
N | length of FFT in complex samples
ptr_x | pointer to complex data input
ptr_w | pointer to complex twiddle factor
ptr_y | pointer to complex output data
brev | pointer to bit reverse table containing 64 entries
n_min | should be 4 if N can be represented as Power of 4 else, n_min should be 2
offset | index in complex samples of sub-fft from start of main fft
n_max | size of main fft in complex samples
Algorithm:
DSPF_sp_ifftSPxSP_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
N needs to be power of 2
8 <= N <= 131072
Arrays pointed by ptr_x, ptr_w, and ptr_y should not overlap
Arrays pointed by ptr_x, ptr_w, and ptr_y should align on the double words boundary
Implementation Notes:
Interruptibility: The code is interrupt-tolerant but not interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: Filtering and convolution

Filtering and convolution

Collaboration diagram for Filtering and convolution:

Detailed Description

Modules

DSPF_sp_biquad
DSPF_sp_fircirc
DSPF_sp_fir_cplx
DSPF_sp_fir_gen
DSPF_sp_fir_r2
DSPF_sp_iir
DSPF_sp_iirlat


DSPLIB: DSPF_sp_biquad

DSPF_sp_biquad
[Filtering and convolution]

Collaboration diagram for DSPF_sp_biquad:

Detailed Description

void DSPF_sp_biquad (float *restrict x, float *b, float *a, float *delay, float *restrict y, const int nx)

Function Documentation

void DSPF_sp_biquad | ( | float *restrict | x,
 |  | float * | b,
 |  | float * | a,
 |  | float * | delay,
 |  | float *restrict | y,
 |  | const int | nx
 | ) |  |

This routine implements a DF 2 transposed structure of the biquad filter

Parameters:
x | Pointer to input samples
b | Pointer to Nr coefs b0, b1, b2
a | Pointer to Dr coefs a1, a2
delay | Pointer to filter delays
y | Pointer to output samples
nx | Number of input/output samples
Algorithm:
DSPF_sp_biquad_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
The value of nx is >= 2.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_fircirc

DSPF_sp_fircirc
[Filtering and convolution]

Collaboration diagram for DSPF_sp_fircirc:

Detailed Description

void DSPF_sp_fircirc (const float *x, float *h, float *restrict y, int index, int csize, int nh, int ny)

Function Documentation

void DSPF_sp_fircirc | ( | const float * | x,
 |  | float * | h,
 |  | float *restrict | y,
 |  | int | index,
 |  | int | csize,
 |  | int | nh,
 |  | int | ny
 | ) |  |

This routine implements a circularly addressed FIR filter. ‘nh’ is the number of filter coefficients. ‘nr’ is the number of the output samples.

Parameters:
x[] | Input array (circular buffer of 2^(csize+1) bytes).
h[nh] | Filter coefficients array. Must be double-word aligned.
y[ny] | Output array
index | Offset by which to start reading from the input array.
csize | Size of circular buffer x[] is 2^(csize+1) bytes.
nh | Number of filter coefficients.
ny | Number of output samples
Algorithm:
DSPF_sp_fircirc_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
The circular input buffer x[] must be aligned at a 2^(csize+1) byte boundary.
h and y must be aligned at double word boundary.
csize must lie in the range 2 <= csize <= 31.
The number of coefficients (nh) must be a multiple of 2 and >= 4.
The number of outputs (nr) must be a multiple of 4 and >= 4.
The 'index' (offset to start reading input array) must be mutiple of 2.
The coefficient array is assured to be in reverse order; i.e., h(nh-1) to h(0).
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_fir_cplx

DSPF_sp_fir_cplx
[Filtering and convolution]

Collaboration diagram for DSPF_sp_fir_cplx:

Detailed Description

void | DSPF_sp_fir_cplx (const float *x, const float *h, float *restrict y, int nh, int nr)
void | DSPF_sp_fir_cplx_opt (const float *x, const float *h, float *restrict y, int nh, int ny)

Function Documentation

void DSPF_sp_fir_cplx | ( | const float * | x,
 |  | const float * | h,
 |  | float *restrict | y,
 |  | int | nh,
 |  | int | nr
 | ) |  |

This function implements the FIR filter for complex input data. The filter has nr output samples and nh coefficients. Each array consists of an even and odd term with even terms representing the real part and the odd terms the imaginary part of the element. The coefficients are expected in normal order.

Parameters:
x[2*(nr+nh-1)] | Pointer to complex input array. The input data pointer x must point to the (nh)th complex element.
h[2*nh] | Pointer to complex coefficient array.
r[2*nr] | Pointer to complex output array.
nh | Number of complex coefficients in vector h.
nr | Number of complex output samples to calculate.
Algorithm:
DSPF_sp_fir_cplx_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nr is a multiple of 2 and greater than or equal to 2.
nh is a multiple of 2 and greater than or equal to 5.
x, h and r are double-word aligned.
x points to 2*(nh-1)th input element.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.

void DSPF_sp_fir_cplx_opt | ( | const float * | x,
 |  | const float * | h,
 |  | float *restrict | y,
 |  | int | nh,
 |  | int | ny
 | ) |  |


DSPLIB: DSPF_sp_fir_gen

DSPF_sp_fir_gen
[Filtering and convolution]

Collaboration diagram for DSPF_sp_fir_gen:

Detailed Description

void DSPF_sp_fir_gen (const float *restrict x, const float *restrict h, float *restrict r, int nh, int nr)

Function Documentation

void DSPF_sp_fir_gen | ( | const float *restrict | x,
 |  | const float *restrict | h,
 |  | float *restrict | r,
 |  | int | nh,
 |  | int | nr
 | ) |  |

This routine implements a block FIR filter. There are “nh” filter coefficients, “nr” output samples, and “nh+nr-1” input samples. The coefficients need to be placed in the “h” array in reverse order {h(nh-1), ... , h(1), h(0)} and the array “x” starts at x(-nh+1) and ends at x(nr-1). The routine calculates y(0) through y(nr-1) using the following formula:
y(n) = h(0)*x(n) + h(1)*x(n-1) + ... + h(nh-1)*x(n-nh+1)
where n = {0, 1, ... , nr-1}.

Parameters:
x | Pointer to array holding the input floating-point array
h | Pointer to array holding the coefficient floating-point array
r | Pointer to output array
nh | Number of coefficents
nr | Number of output values
Algorithm:
DSPF_sp_fir_gen_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nr is a multiple of 4 and greater than or equal to 4.
nh is a multiple of 4 and greater than or equal to 4.
x, h and r are double-word aligned.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_fir_r2

DSPF_sp_fir_r2
[Filtering and convolution]

Collaboration diagram for DSPF_sp_fir_r2:

Detailed Description

void | DSPF_sp_fir_r2 (const float *x, const float *h, float *restrict r, const int nh, const int nr)
void | DSPF_sp_fir_r2_opt (const float *x, const float *h, float *restrict y, const int nh, const int ny)

Function Documentation

void DSPF_sp_fir_r2 | ( | const float * | x,
 |  | const float * | h,
 |  | float *restrict | r,
 |  | const int | nh,
 |  | const int | nr
 | ) |  |

Computes a real FIR filter (direct-form) using coefficients stored in vector h[]. The real data input is stored in vector x[]. The filter output result is stored in vector r[]. The filter calculates nr output samples using nh coefficients. The coefficients are expected to be in reverse order.

Parameters:
x[nr+nh-1] | Pointer to input array of size nr+nh-1.
h[nh] | Pointer to coefficient array of size nh (in reverse order).
r[nr] | Pointer to output array of size nr.
nh | Number of coefficents
nr | Number of output samples
Algorithm:
DSPF_sp_fir_r2_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nr is a multiple of 2 and greater than or equal to 2.
nh is a multiple of 2 and greater than or equal to 8.
x, h and r are double-word aligned.
Coefficients in array h are expected to be in reverse order.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.

void DSPF_sp_fir_r2_opt | ( | const float * | x,
 |  | const float * | h,
 |  | float *restrict | y,
 |  | const int | nh,
 |  | const int | ny
 | ) |  |


DSPLIB: DSPF_sp_iir

DSPF_sp_iir
[Filtering and convolution]

Collaboration diagram for DSPF_sp_iir:

Detailed Description

void | DSPF_sp_iir (float *restrict y1, const float *x, float *restrict y2, const float *hb, const float *ha, int nr)
void | DSPF_sp_iir_opt (float *restrict y1, const float *x, float *restrict y2, const float *hb, const float *ha, int nr)

Function Documentation

void DSPF_sp_iir | ( | float *restrict | y1,
 |  | const float * | x,
 |  | float *restrict | y2,
 |  | const float * | hb,
 |  | const float * | ha,
 |  | int | nr
 | ) |  |

The IIR performs an auto-regressive moving-average (ARMA) filter with 4 auto-regressive filter coefficients and 5 moving-average filter coefficients for nr output samples. The output vector is stored in two locations. This routine is used as a high pass filter in the VSELP vocoder. The 4 values in the r1 vector store the initial values of the delays.

Parameters:
y1[nr+4] | Delay element values (i/p and o/p).
x[nr] | Pointer to the input array.
y2[nr+4] | Pointer to the output array.
hb[5] | Auto-regressive filter coefficients.
ha[5] | Moving average filter coefficients.
nr | Number of output samples.
Algorithm:
DSPF_sp_iir_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
The value of ‘nr’ must be a multiple of 2.
Extraneous loads are allowed in the program.
Implementation Notes:
Interruptibility: The code is interruptible. Endian Support: The code supports both big and little endian modes.

void DSPF_sp_iir_opt | ( | float *restrict | y1,
 |  | const float * | x,
 |  | float *restrict | y2,
 |  | const float * | hb,
 |  | const float * | ha,
 |  | int | nr
 | ) |  |


DSPLIB: DSPF_sp_iirlat

DSPF_sp_iirlat
[Filtering and convolution]

Collaboration diagram for DSPF_sp_iirlat:

Detailed Description

void | DSPF_sp_iirlat (const float *x, int nx, const float *restrict k, int nk, float *restrict b, float *restrict y)
void | DSPF_sp_iirlat_opt (const float *x, int nx, const float *restrict k, int nk, float *restrict b, float *restrict y)

Function Documentation

void DSPF_sp_iirlat | ( | const float * | x,
 |  | int | nx,
 |  | const float *restrict | k,
 |  | int | nk,
 |  | float *restrict | b,
 |  | float *restrict | y
 | ) |  |

This routine implements a real all-pole IIR filter in lattice structure (AR lattice). The filter consists of nk lattice stages. Each stage requires one reflection coefficient k and one delay element b. The routine takes an input vector x[] and returns the filter output in y[]. Prior to the first call of the routine the delay elements in b[] should be set to zero. The input data may have to be pre-scaled to avoid overflow or achieve better SNR. The reflections coefficients lie in the range -1.0 < k < 1.0. The order of the coefficients is such that k[nk-1] corresponds to the first lattice stage after the input and k[0] corresponds to the last stage.

Parameters:
x[nx] | Input vector.
nx | Length of input vector.
k[nk] | Reflection coefficients.
nk | Number of reflection coefficients/lattice stages.
b[nk+1] | Delay line elements from previous call. Should be initialized to all zeros prior to the first call.
y[nx] | Output vector.
Algorithm:
DSPF_sp_iirlat_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx > 0, nk is a multiple of 2 and >= 6.
Extraneous loads are allowed (80 bytes) before the start of array.
The arrays k and b are double-word aligned.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.

void DSPF_sp_iirlat_opt | ( | const float * | x,
 |  | int | nx,
 |  | const float *restrict | k,
 |  | int | nk,
 |  | float *restrict | b,
 |  | float *restrict | y
 | ) |  |


DSPLIB: Math

Math

Collaboration diagram for Math:

Detailed Description

Modules

DSPF_sp_dotprod
DSPF_sp_dotp_cplx
DSPF_sp_maxidx
DSPF_sp_maxval
DSPF_sp_minerr
DSPF_sp_minval
DSPF_sp_vecmul
DSPF_sp_vecrecip
DSPF_sp_vecsum_sq
DSPF_sp_w_vec


DSPLIB: DSPF_sp_dotprod

DSPF_sp_dotprod
[Math]

Collaboration diagram for DSPF_sp_dotprod:

Detailed Description

float DSPF_sp_dotprod (const float *x, const float *y, const int nx)

Function Documentation

float DSPF_sp_dotprod | ( | const float * | x,
 |  | const float * | y,
 |  | const int | nx
 | ) |  |

This routine calculates the dot product of 2 single-precision float vectors

Parameters:
x | Pointer to array holding the first floating-point vector
y | Pointer to array holding the second floating-point vector
nx | Number of values in the x and y vectors
Algorithm:
DSPF_sp_dotprod_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
The x and y arrays must be double-word aligned.
nx is a multple of 8 and >=8.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_dotp_cplx

DSPF_sp_dotp_cplx
[Math]

Collaboration diagram for DSPF_sp_dotp_cplx:

Detailed Description

void DSPF_sp_dotp_cplx (const float *x, const float *y, int nx, float *restrict re, float *restrict im)

Function Documentation

void DSPF_sp_dotp_cplx | ( | const float * | x,
 |  | const float * | y,
 |  | int | nx,
 |  | float *restrict | re,
 |  | float *restrict | im
 | ) |  |

This routine calculates the dot product of 2 single-precision complex float vectors. The even numbered locations hold the real parts of the complex numbers while the odd numbered locations contain the imaginary portions.

Parameters:
x | Pointer to array holding the first floating-point vector
y | Pointer to array holding the second floating-point vector
nx | Number of values in the x and y vectors
re | Pointer to the location storing the real part of the result
im | Pointer to the location storing the imaginary part of the result
Algorithm:
DSPF_sp_dotp_cplx_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
Loop counter must be multiple of 2 and > 0.
The x and y arrays must be double-word aligned.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_maxidx

DSPF_sp_maxidx
[Math]

Collaboration diagram for DSPF_sp_maxidx:

Detailed Description

int DSPF_sp_maxidx (const float *x, const int nx)

Function Documentation

int DSPF_sp_maxidx | ( | const float * | x,
 |  | const int | nx
 | ) |  |

This routine finds out the index of maximum number in the input array. This function returns the index of the greatest value.

Parameters:
x | Pointer to input array.
nx | Number of inputs in the input array.
Algorithm:
DSPF_sp_maxidx_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx is a multiple of 4 and >= 4.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_maxval

DSPF_sp_maxval
[Math]

Collaboration diagram for DSPF_sp_maxval:

Detailed Description

float DSPF_sp_maxval (const float *x, int nx)

Function Documentation

float DSPF_sp_maxval | ( | const float * | x,
 |  | int | nx
 | ) |  |

This routine finds out the maximum number in the input array. This code returns the maximum value in the array.

Parameters:
x | Pointer to input array.
nx | Number of inputs in the input array.
Algorithm:
DSPF_sp_maxval_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx should be multiple of 4 and >= 4
x should be double-word aligned
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_minerr

DSPF_sp_minerr
[Math]

Collaboration diagram for DSPF_sp_minerr:

Detailed Description

float DSPF_sp_minerr (const float *GSP0_TABLE, const float *errCoefs, int *restrict max_index)

Function Documentation

float DSPF_sp_minerr | ( | const float * | GSP0_TABLE,
 |  | const float * | errCoefs,
 |  | int *restrict | max_index
 | ) |  |

Performs a dot product on 256 pairs of 9 element vectors and searches for the pair of vectors which produces the maximum dot product result. This is a large part of the VSELP vocoder codebook search. The function stores the index to the first element of the 9-element vector that resulted in the maximum dot product in the memory location Pointed by max_index. The maximum dot product value is returned by the function.

Parameters:
GSP0_TABLE[256*9] | GSP0 terms array.
errCoefs[9] | Array of error coefficients. Must be double-word aligned.
max_index | Index to GSP0_TABLE[max_index], the first element of the 9-element vector that resulted in the maximum dot product.
Algorithm:
DSPF_sp_maxval_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
errCoefs must be double-word aligned
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_minval

DSPF_sp_minval
[Math]

Collaboration diagram for DSPF_sp_minval:

Detailed Description

float DSPF_sp_minval (const float *x, int nx)

Function Documentation

float DSPF_sp_minval | ( | const float * | x,
 |  | int | nx
 | ) |  |

This routine finds out the minimum number in the input array. This code returns the minimum value in the array.

Parameters:
x | Pointer to input array.
nx | Number of inputs in the input array.
Algorithm:
DSPF_sp_minval_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx should be multiple of 4 and >= 4
x should be double-word aligned
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_vecmul

DSPF_sp_vecmul
[Math]

Collaboration diagram for DSPF_sp_vecmul:

Detailed Description

void DSPF_sp_vecmul (const float *x1, const float *x2, float *restrict y, const int nx)

Function Documentation

void DSPF_sp_vecmul | ( | const float * | x1,
 |  | const float * | x2,
 |  | float *restrict | y,
 |  | const int | nx
 | ) |  |

This routine performs an element by element floating-point multiply of the vectors x1[] and x2[] and returns the values in y[].

Parameters:
x1 | Pointer to first input array.
x2 | Pointer to second input array.
y | Pointer to output array.
nx | Number of elements in arrays.
Algorithm:
DSPF_sp_vecmul_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
The x1, x2 and y arrays must be double-word aligned
nx is a multiple of 4 and >= 4
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_vecrecip

DSPF_sp_vecrecip
[Math]

Collaboration diagram for DSPF_sp_vecrecip:

Detailed Description

void DSPF_sp_vecrecip (const float *x, float *restrict y, const int nx)

Function Documentation

void DSPF_sp_vecrecip | ( | const float * | x,
 |  | float *restrict | y,
 |  | const int | nx
 | ) |  |

The sp_vecrecip module calculates the reciprocal of each element in the array x and returns the output in array r. It uses 2 iterations of the Newton-Raphson method to improve the accuracy of the output generated by the RCPSP instruction generated by RCPSP is 8 bits. So after the first iteration it is 16 bits and after the second it is the full 23 bits. The formula used is:
r[n+1] = r[n](2 - v*r[n])
where v = the number whose reciprocal is to be found.
x[0], the seed value for the algorithm, is given by RCPSP.

Parameters:
x | Pointer to input array.
y | Pointer to output array.
nx | Number of elements in arrays.
Algorithm:
DSPF_sp_vecrecip_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
nx is a multiple of 4 and >= 4.
x and y are double word aligned.
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_vecsum_sq

DSPF_sp_vecsum_sq
[Math]

Collaboration diagram for DSPF_sp_vecsum_sq:

Detailed Description

float DSPF_sp_vecsum_sq (const float *x, const int nx)

Function Documentation

float DSPF_sp_vecsum_sq | ( | const float * | x,
 |  | const int | nx
 | ) |  |

This routine performs a sum of squares of the elements of the array x and returns the sum.

Parameters:
x | Pointer to input array.
nx | Number of elements in arrays.
Algorithm:
DSPF_sp_vecsum_sq_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
Since loads of 8 floats beyond the array occur, a pad must be provided
The x array must be double-word aligned
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: DSPF_sp_w_vec

DSPF_sp_w_vec
[Math]

Collaboration diagram for DSPF_sp_w_vec:

Detailed Description

void DSPF_sp_w_vec (const float *x1, const float *x2, const float m, float *restrict y, const int nx)

Function Documentation

void DSPF_sp_w_vec | ( | const float * | x1,
 |  | const float * | x2,
 |  | const float | m,
 |  | float *restrict | y,
 |  | const int | nx
 | ) |  |

This routine is used to obtain the weighted vector sum. Both the inputs and output are single-precision floating-point numbers.

Parameters:
x1 | Pointer to first input array.
x2 | Pointer to second input array.
m | Weight factor.
y | Output array pointer.
nx | Number of elements in arrays.
Algorithm:
DSPF_sp_w_vec_cn.c is the natural C equivalent of the optimized linear assembly code without restrictions. Note that the linear assembly code is optimized and restrictions may apply.
Assumptions:
The x and y arrays must be double-word aligned
The value of nx must be a multiple of 2 and > 0
Implementation Notes:
Interruptibility: The code is interruptible.
Endian Support: The code supports both big and little endian modes.


DSPLIB: Matrix

Matrix

Collaboration diagram for Matrix:

Detailed Description

Modules

DSPF_sp_mat_mul
DSPF_sp_mat_mul_cplx
DSPF_sp_mat_trans


DSPLIB: DSPF_sp_mat_mul

DSPF_sp_mat_mul
[Matrix]

Collaboration diagram for DSPF_sp_mat_mul:

Detailed Description

void | DSPF_sp_mat_mul (float *x1, const int r1, const int c1, float *x2, const int c2, float *restrict y)
void | DSPF_sp_mat_mul_opt (float *x1, const int r1, const int c1, float *x2, const int c2, float *restrict y)

Function Documentation

void DSPF_sp_mat_mul | ( | float * | x1,
 |  | const int | r1,
 |  | const int | c1,
 |  | float * | x2,
 |  | const int | c2,
 |  | float *restrict | y
 | ) |  |

This function computes the expression “y = x1*x2” for the matrices x1 and x2. The column dimension of x1 must match the row dimension of x2. The resulting matrix has the same number of rows as x1 and the same number of columns as x2. The values stored in the matrices are assumed to be single-precision floating-point values. This code is suitable for dense matrices. No optimizations are made for sparse matrices.

Parameters:
x1 | = Pointer to r1 by c1 input matrix.
r1 | = Number of rows in x1.
c1 | = Number of columns in x1. Also number of rows in x2.
x2 | = Pointer to c1 by c2 input matrix.
c2 | = Number of columns in x2.
y | = Pointer to r1 by c2 output matrix.
Algorithm:
DSPF_sp_mat_mul.c is the natural C equivalent of the optimized intrinsic C code withoutrestrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
The arrays ‘x1’, ‘x2’, and ‘y’ are stored in distinct arrays. That is, in-place processing is not allowed.
All r1, c1, c2 are assumed to be > 1.
5 Floats are always loaded extra from the locations:
x2[c1’ * c2’], x2[c1’ * c2’ + 1],
x1[r1 * c1’], x1[r1’ * c1’] and x1[2 * c1]
where
r1’ = r1 + (r1&1)
c2’ = c2 + (c2&1)
c1’ = c1 + 1 + 2*(c1&1)
If (r1&1) means r1 is odd, one extra row of x1[] matrix is loaded
If (c2&1) means c2 is odd, one extra col of x2[] matrix is loaded
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.

void DSPF_sp_mat_mul_opt | ( | float * | x1,
 |  | const int | r1,
 |  | const int | c1,
 |  | float * | x2,
 |  | const int | c2,
 |  | float *restrict | y
 | ) |  |


DSPLIB: DSPF_sp_mat_mul_cplx

DSPF_sp_mat_mul_cplx
[Matrix]

Collaboration diagram for DSPF_sp_mat_mul_cplx:

Detailed Description

void | DSPF_sp_mat_mul_cplx (const float *x1, int r1, int c1, const float *x2, int c2, float *restrict y)
void | DSPF_sp_mat_mul_cplx_opt (const float *x1, int r1, int c1, const float *x2, int c2, float *restrict y)

Function Documentation

void DSPF_sp_mat_mul_cplx | ( | const float * | x1,
 |  | int | r1,
 |  | int | c1,
 |  | const float * | x2,
 |  | int | c2,
 |  | float *restrict | y
 | ) |  |

This function computes the expression “y = x1*x2?for the matrices x1 and x2. The columnar dimension of x1 must match the row dimension of x2. The resulting matrix has the same number of rows as x1 and the same number of columns as x2. Each element of Matrices are assumed to be complex numbers with real values are stored in even word positions and imaginary values in odd positions.

Parameters:
x1[2*r1*c1] | Input matrix containing r1*c1 complex floating-point numbers
r1 | Number of rows in matrix x1.
c1 | Number of columns in matrix x1. Also number of rows in matrix x2.
x2[2*c1*c2] | Input matrix containing c1*c2 complex floating-point
c2 | Number of columns in matrix x2.
y[2*r1*c2] | Output matrix of c1*c2 complex floating-point numbers
Algorithm:
DSPF_sp_mat_mul_cplx.c is the natural C equivalent of the optimized intrinsic C code withoutrestrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
r1, c1, c2 are multiple of 2.
x1, x2 and y should be double-word aligned.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.

void DSPF_sp_mat_mul_cplx_opt | ( | const float * | x1,
 |  | int | r1,
 |  | int | c1,
 |  | const float * | x2,
 |  | int | c2,
 |  | float *restrict | y
 | ) |  |


DSPLIB: DSPF_sp_mat_trans

DSPF_sp_mat_trans
[Matrix]

Collaboration diagram for DSPF_sp_mat_trans:

Detailed Description

void DSPF_sp_mat_trans (const float *restrict x, const int rows, const int cols, float *restrict y)

Function Documentation

void DSPF_sp_mat_trans | ( | const float *restrict | x,
 |  | const int | rows,
 |  | const int | cols,
 |  | float *restrict | y
 | ) |  |

This function transposes the input matrix x[] and writes the result to matrix y[].

Parameters:
x[r1*c1] | Input matrix containing r1*c1 floating-point numbers
rows | Number of rows in matrix x. Also number of columns in matrix y.
cols | Number of columns in matrix x. Also number of rows in matrix y.
y[c1*r1] | Output matrix containing c1*r1 floating-point numbers
Algorithm:
DSPF_sp_mat_trans.c is the natural C equivalent of the optimized intrinsic C code withoutrestrictions. Note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
The number of rows and columns is multiple of 2 and >=2.
x and y are double-word aligned.
Implementation Notes:
Interruptibility : The code is interruptible.
Endian support : supports both Little and Big endian modes.


DSPLIB: Miscellaneous

Miscellaneous

Collaboration diagram for Miscellaneous:

Detailed Description

Modules

DSPF_blk_eswap16
DSPF_blk_eswap32
DSPF_blk_eswap64
DSPF_fltoq15
DSPF_q15tofl
DSPF_sp_blk_move


DSPLIB: DSPF_blk_eswap16

DSPF_blk_eswap16
[Miscellaneous]

Collaboration diagram for DSPF_blk_eswap16:

Detailed Description

void DSPF_blk_eswap16 (void *restrict src, void *restrict dst, int n_hwords)

Function Documentation

void DSPF_blk_eswap16 | ( | void *restrict | src,
 |  | void *restrict | dst,
 |  | int | n_hwords
 | ) |  |

The data in the x[] array is endian swapped, meaning that the byte-order of the bytes within each half-word of the r[] array is reversed. This facilitates moving big-endian data to a little-endian system or vice-versa. When the r pointer is non-NULL, the endian-swap occurs out-of-place, similar to a block move. When the r pointer is NULL, the endian-swap occurs in-place, allowing the swap to occur without using any additional storage.

Parameters:
src | = Source data, must be double-word aligned.
dst | = Destination data, must be double-word aligned.
n_hwords | = Number of 16-bit elements to swap.
Algorithm:
DSPF_blk_eswap16_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Input and output arrays do not overlap, except when “dst == NULL” so that the operation occurs in-place.
The input array and output array are double-word aligned.
nx is a multiple of 8.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSPF_blk_eswap32

DSPF_blk_eswap32
[Miscellaneous]

Collaboration diagram for DSPF_blk_eswap32:

Detailed Description

void DSPF_blk_eswap32 (void *restrict src, void *restrict dst, int n_words)

Function Documentation

void DSPF_blk_eswap32 | ( | void *restrict | src,
 |  | void *restrict | dst,
 |  | int | n_words
 | ) |  |

The data in the x[] array is endian swapped, meaning that the byte-order of the bytes within each word of the r[] array is reversed. This facilitates moving big-endian data to a little-endian system or vice-versa. When the r pointer is non-NULL, the endian-swap occurs out-of-place, similar to a block move. When the r pointer is NULL, the endian-swap occurs in-place, allowing the swap to occur without using any additional storage.

Parameters:
src | = Source data, must be double-word aligned.
dst | = Destination data, must be double-word aligned.
n_words | = Number of 32-bit elements to swap.
Algorithm:
DSPF_blk_eswap32_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Input and output arrays do not overlap, except when “dst == NULL” so that the operation occurs in-place.
The input array and output array are double-word aligned.
nx is a multiple of 4.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSPF_blk_eswap64

DSPF_blk_eswap64
[Miscellaneous]

Collaboration diagram for DSPF_blk_eswap64:

Detailed Description

void DSPF_blk_eswap64 (void *restrict src, void *restrict dst, int n_dbls)

Function Documentation

void DSPF_blk_eswap64 | ( | void *restrict | src,
 |  | void *restrict | dst,
 |  | int | n_dbls
 | ) |  |

The data in the x[] array is endian swapped, meaning that the byte-order of the bytes within each double-word of the r[] array is reversed. This facilitates moving big-endian data to a little-endian system or vice-versa. When the r pointer is non-NULL, the endian-swap occurs out-of-place, similar to a block move. When the r pointer is NULL, the endian-swap occurs in-place, allowing the swap to occur without using any additional storage.

Parameters:
src | = Source data, must be double-word aligned.
dst | = Destination data, must be double-word aligned.
n_dbls | = Number of 64-bit elements to swap.
Algorithm:
DSPF_blk_eswap64_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
Input and output arrays do not overlap, except when “dst == NULL” so that the operation occurs in-place.
The input array and output array are double-word aligned.
nx is a multiple of 2.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSPF_fltoq15

DSPF_fltoq15
[Miscellaneous]

Collaboration diagram for DSPF_fltoq15:

Detailed Description

void DSPF_fltoq15 (const float *restrict flt, short *restrict q15, int nx)

Function Documentation

void DSPF_fltoq15 | ( | const float *restrict | flt,
 |  | short *restrict | q15,
 |  | int | nx
 | ) |  |

Convert the IEEE floating point numbers stored in vector x[ ] into Q.15 format numbers stored in vector r[ ]. Results are truncated toward zero. Values that exceed the size limit will be saturated to 0x7fff if value is positive and 0x8000 if value is negative. All values too small to be correctly represented will be truncated to 0.

Parameters:
flt | = Pointer to floating-point input vector of size nx. x should contain the numbers normalized between [-1,1)
q15 | = Pointer to output data vector of size nx containing the Q.15 equivalent of vector x.
nx | = Length of input and output data vectors. Must be multiple of 2
Algorithm:
DSPF_fltoq15_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 2
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSPF_q15tofl

DSPF_q15tofl
[Miscellaneous]

Collaboration diagram for DSPF_q15tofl:

Detailed Description

void DSPF_q15tofl (const short *restrict q15, float *restrict flt, int nx)

Function Documentation

void DSPF_q15tofl | ( | const short *restrict | q15,
 |  | float *restrict | flt,
 |  | int | nx
 | ) |  |

Converts the values stored in vector x[ ] in Q.15 format to IEEE floating point numbers in output vector r[ ]

Parameters:
q15 | = Pointer to Q.15 input vector of size nx
flt | = Pointer to floating-point output data vector of size nx containing the floating-point equivalent of vector x
nx | = Length of input and output data vectors
Algorithm:
DSPF_q15tofl_cn.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4.
q15 and flt are double word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: DSPF_sp_blk_move

DSPF_sp_blk_move
[Miscellaneous]

Collaboration diagram for DSPF_sp_blk_move:

Detailed Description

void DSPF_sp_blk_move (const float *x, float *restrict y, const int n)

Function Documentation

void DSPF_sp_blk_move | ( | const float * | x,
 |  | float *restrict | y,
 |  | const int | n
 | ) |  |

This routine moves nx float elements from one memory location pointed to by x to another pointed to by y. The source and destination blocks can be overlapped.

Parameters:
x | = Block of data to be moved
y | = Destination of block of data
nx | = Number of elements in block
Algorithm:
DSPF_sp_blk_move.c is the natural C equivalent of the optimized intrinsic C code without restrictions note that the intrinsic C code is optimized and restrictions may apply.
Assumptions:
nx must be a multiple of 4 and greater than or equal to 4.
x and y must be double word aligned.
Implementation notes:
Endian Support: The code supports both big and little endian modes.
Interruptibility: The code is interruptible.


DSPLIB: File Index

  • File List
  • Globals

DSPLIB File List

Here is a list of all files with brief descriptions:
doxygen.h [code]
DSPF_blk_eswap16.h [code]
c674/DSPF_blk_eswap16.h [code]
DSPF_blk_eswap32.h [code]
c674/DSPF_blk_eswap32.h [code]
DSPF_blk_eswap64.h [code]
c674/DSPF_blk_eswap64.h [code]
DSPF_fltoq15.h [code]
c674/DSPF_fltoq15.h [code]
DSPF_q15tofl.h [code]
c674/DSPF_q15tofl.h [code]
DSPF_sp_autocor.h [code]
c674/DSPF_sp_autocor.h [code]
DSPF_sp_biquad.h [code]
c674/DSPF_sp_biquad.h [code]
DSPF_sp_bitrev_cplx.h [code]
c674/DSPF_sp_bitrev_cplx.h [code]
DSPF_sp_blk_move.h [code]
c674/DSPF_sp_blk_move.h [code]
DSPF_sp_cfftr2_dit.h [code]
c674/DSPF_sp_cfftr2_dit.h [code]
DSPF_sp_cfftr4_dif.h [code]
c674/DSPF_sp_cfftr4_dif.h [code]
DSPF_sp_convol.h [code]
c674/DSPF_sp_convol.h [code]
DSPF_sp_dotp_cplx.h [code]
c674/DSPF_sp_dotp_cplx.h [code]
DSPF_sp_dotprod.h [code]
c674/DSPF_sp_dotprod.h [code]
DSPF_sp_fftSPxSP.h [code]
c674/DSPF_sp_fftSPxSP.h [code]
DSPF_sp_fir_cplx.h [code]
c674/DSPF_sp_fir_cplx.h [code]
DSPF_sp_fir_gen.h [code]
c674/DSPF_sp_fir_gen.h [code]
DSPF_sp_fir_r2.h [code]
c674/DSPF_sp_fir_r2.h [code]
DSPF_sp_fircirc.h [code]
c674/DSPF_sp_fircirc.h [code]
DSPF_sp_icfftr2_dif.h [code]
c674/DSPF_sp_icfftr2_dif.h [code]
DSPF_sp_ifftSPxSP.h [code]
c674/DSPF_sp_ifftSPxSP.h [code]
DSPF_sp_iir.h [code]
c674/DSPF_sp_iir.h [code]
DSPF_sp_iirlat.h [code]
c674/DSPF_sp_iirlat.h [code]
DSPF_sp_lms.h [code]
c674/DSPF_sp_lms.h [code]
DSPF_sp_mat_mul.h [code]
c674/DSPF_sp_mat_mul.h [code]
DSPF_sp_mat_mul_cplx.h [code]
c674/DSPF_sp_mat_mul_cplx.h [code]
DSPF_sp_mat_trans.h [code]
c674/DSPF_sp_mat_trans.h [code]
DSPF_sp_maxidx.h [code]
c674/DSPF_sp_maxidx.h [code]
DSPF_sp_maxval.h [code]
c674/DSPF_sp_maxval.h [code]
DSPF_sp_minerr.h [code]
c674/DSPF_sp_minerr.h [code]
DSPF_sp_minval.h [code]
c674/DSPF_sp_minval.h [code]
DSPF_sp_vecmul.h [code]
c674/DSPF_sp_vecmul.h [code]
DSPF_sp_vecrecip.h [code]
c674/DSPF_sp_vecrecip.h [code]
DSPF_sp_vecsum_sq.h [code]
c674/DSPF_sp_vecsum_sq.h [code]
DSPF_sp_w_vec.h [code]
c674/DSPF_sp_w_vec.h [code]


DSPLIB: doxygen.h File Reference

doxygen.h File Reference

Go to the source code of this file.


DSPLIB: DSPF_blk_eswap16.h File Reference

DSPF_blk_eswap16.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_BLK_ESWAP16_H_ 1

Define Documentation

#define _DSPF_BLK_ESWAP16_H_ 1

Definition at line 41 of file DSPF_blk_eswap16.h.


DSPLIB: DSPF_blk_eswap16.h File Reference

DSPF_blk_eswap16.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_blk_eswap16.h:

Go to the source code of this file.

Defines

#define | DSPF_BLK_ESWAP16_H_ 1

Functions

void | DSPF_blk_eswap16 (void *restrict src, void *restrict dst, int n_hwords)

Define Documentation

#define DSPF_BLK_ESWAP16_H_ 1

Definition at line 41 of file c674/DSPF_blk_eswap16.h.


DSPLIB: DSPF_blk_eswap32.h File Reference

DSPF_blk_eswap32.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_BLK_ESWAP32_H_ 1

Define Documentation

#define _DSPF_BLK_ESWAP32_H_ 1

Definition at line 41 of file DSPF_blk_eswap32.h.


DSPLIB: DSPF_blk_eswap32.h File Reference

DSPF_blk_eswap32.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_blk_eswap32.h:

Go to the source code of this file.

Defines

#define | DSPF_BLK_ESWAP32_H_ 1

Functions

void | DSPF_blk_eswap32 (void *restrict src, void *restrict dst, int n_words)

Define Documentation

#define DSPF_BLK_ESWAP32_H_ 1

Definition at line 41 of file c674/DSPF_blk_eswap32.h.


DSPLIB: DSPF_blk_eswap64.h File Reference

DSPF_blk_eswap64.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_BLK_ESWAP64_H_ 1

Define Documentation

#define _DSPF_BLK_ESWAP64_H_ 1

Definition at line 41 of file DSPF_blk_eswap64.h.


DSPLIB: DSPF_blk_eswap64.h File Reference

DSPF_blk_eswap64.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_blk_eswap64.h:

Go to the source code of this file.

Defines

#define | DSPF_BLK_ESWAP64_H_ 1

Functions

void | DSPF_blk_eswap64 (void *restrict src, void *restrict dst, int n_dbls)

Define Documentation

#define DSPF_BLK_ESWAP64_H_ 1

Definition at line 42 of file c674/DSPF_blk_eswap64.h.


DSPLIB: DSPF_fltoq15.h File Reference

DSPF_fltoq15.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_FLTOQ15_H_ 1

Define Documentation

#define _DSPF_FLTOQ15_H_ 1

Definition at line 41 of file DSPF_fltoq15.h.


DSPLIB: DSPF_fltoq15.h File Reference

DSPF_fltoq15.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_fltoq15.h:

Go to the source code of this file.

Defines

#define | _DSPF_FLTOQ15_H_ 1

Functions

void | DSPF_fltoq15 (const float *restrict flt, short *restrict q15, int nx)

Define Documentation

#define _DSPF_FLTOQ15_H_ 1

Definition at line 41 of file c674/DSPF_fltoq15.h.


DSPLIB: DSPF_q15tofl.h File Reference

DSPF_q15tofl.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_Q15TOFL_H_ 1

Define Documentation

#define _DSPF_Q15TOFL_H_ 1

Definition at line 41 of file DSPF_q15tofl.h.


DSPLIB: DSPF_q15tofl.h File Reference

DSPF_q15tofl.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_q15tofl.h:

Go to the source code of this file.

Defines

#define | _DSPF_Q15TOFL_H_ 1

Functions

void | DSPF_q15tofl (const short *restrict q15, float *restrict flt, int nx)

Define Documentation

#define _DSPF_Q15TOFL_H_ 1

Definition at line 41 of file c674/DSPF_q15tofl.h.


DSPLIB: DSPF_sp_autocor.h File Reference

DSPF_sp_autocor.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_AUTOCOR_H_ 1

Define Documentation

#define _DSPF_SP_AUTOCOR_H_ 1

Definition at line 40 of file DSPF_sp_autocor.h.


DSPLIB: DSPF_sp_autocor.h File Reference

DSPF_sp_autocor.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_autocor.h:

Go to the source code of this file.

Functions

void DSPF_sp_autocor (float *restrict r, float *restrict x, const int nx, const int nr)


DSPLIB: DSPF_sp_biquad.h File Reference

DSPF_sp_biquad.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_BIQUAD_H_ 1

Define Documentation

#define _DSPF_SP_BIQUAD_H_ 1

Definition at line 40 of file DSPF_sp_biquad.h.


DSPLIB: DSPF_sp_biquad.h File Reference

DSPF_sp_biquad.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_biquad.h:

Go to the source code of this file.

Functions

void DSPF_sp_biquad (float *restrict x, float *b, float *a, float *delay, float *restrict y, const int nx)


DSPLIB: DSPF_sp_bitrev_cplx.h File Reference

DSPF_sp_bitrev_cplx.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_BITREV_CPLX_H_ 1

Define Documentation

#define _DSPF_SP_BITREV_CPLX_H_ 1

Definition at line 40 of file DSPF_sp_bitrev_cplx.h.


DSPLIB: DSPF_sp_bitrev_cplx.h File Reference

DSPF_sp_bitrev_cplx.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_bitrev_cplx.h:

Go to the source code of this file.

Functions

void DSPF_sp_bitrev_cplx (double *restrict x, short *restrict index, int nx)


DSPLIB: DSPF_sp_blk_move.h File Reference

DSPF_sp_blk_move.h File Reference

Go to the source code of this file.

Defines

#define DSPF_sp_BLK_MOVE_H_ 1

Define Documentation

#define DSPF_sp_BLK_MOVE_H_ 1

Definition at line 41 of file DSPF_sp_blk_move.h.


DSPLIB: DSPF_sp_blk_move.h File Reference

DSPF_sp_blk_move.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_blk_move.h:

Go to the source code of this file.

Defines

#define | DSPF_sp_BLK_MOVE_H_ 1

Functions

void | DSPF_sp_blk_move (const float *x, float *restrict y, const int n)

Define Documentation

#define DSPF_sp_BLK_MOVE_H_ 1

Definition at line 41 of file c674/DSPF_sp_blk_move.h.


DSPLIB: DSPF_sp_cfftr2_dit.h File Reference

DSPF_sp_cfftr2_dit.h File Reference

Go to the source code of this file.


DSPLIB: DSPF_sp_cfftr2_dit.h File Reference

DSPF_sp_cfftr2_dit.h File Reference

Go to the source code of this file.

Functions

void DSPF_sp_cfftr2_dit (float *x, float *w, unsigned short n)


DSPLIB: DSPF_sp_cfftr4_dif.h File Reference

DSPF_sp_cfftr4_dif.h File Reference

Go to the source code of this file.


DSPLIB: DSPF_sp_cfftr4_dif.h File Reference

DSPF_sp_cfftr4_dif.h File Reference

Go to the source code of this file.

Functions

void DSPF_sp_cfftr4_dif (float *x, float *w, unsigned short n)


DSPLIB: DSPF_sp_convol.h File Reference

DSPF_sp_convol.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_CONVOL_H_ 1

Define Documentation

#define _DSPF_SP_CONVOL_H_ 1

Definition at line 40 of file DSPF_sp_convol.h.


DSPLIB: DSPF_sp_convol.h File Reference

DSPF_sp_convol.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_convol.h:

Go to the source code of this file.

Functions

void DSPF_sp_convol (const float *x, const float *h, float *restrict y, const short nh, const short ny)


DSPLIB: DSPF_sp_dotp_cplx.h File Reference

DSPF_sp_dotp_cplx.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_DOTP_CPLX_H_ 1

Define Documentation

#define _DSPF_SP_DOTP_CPLX_H_ 1

Definition at line 40 of file DSPF_sp_dotp_cplx.h.


DSPLIB: DSPF_sp_dotp_cplx.h File Reference

DSPF_sp_dotp_cplx.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_dotp_cplx.h:

Go to the source code of this file.

Functions

void DSPF_sp_dotp_cplx (const float *x, const float *y, int nx, float *restrict re, float *restrict im)


DSPLIB: DSPF_sp_dotprod.h File Reference

DSPF_sp_dotprod.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_DOTPROD_H_ 1

Define Documentation

#define _DSPF_SP_DOTPROD_H_ 1

Definition at line 40 of file DSPF_sp_dotprod.h.


DSPLIB: DSPF_sp_dotprod.h File Reference

DSPF_sp_dotprod.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_dotprod.h:

Go to the source code of this file.

Functions

float DSPF_sp_dotprod (const float *x, const float *y, const int nx)


DSPLIB: DSPF_sp_fftSPxSP.h File Reference

DSPF_sp_fftSPxSP.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_FFTSPXSP_H_ 1

Define Documentation

#define _DSPF_SP_FFTSPXSP_H_ 1

Definition at line 40 of file DSPF_sp_fftSPxSP.h.


DSPLIB: DSPF_sp_fftSPxSP.h File Reference

DSPF_sp_fftSPxSP.h File Reference

Go to the source code of this file.

Functions

void DSPF_sp_fftSPxSP (int N, float *ptr_x, float *ptr_w, float *ptr_y, unsigned char *brev, int n_min, int offset, int n_max)


DSPLIB: DSPF_sp_fir_cplx.h File Reference

DSPF_sp_fir_cplx.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_FIR_CPLX_H_ 1

Define Documentation

#define _DSPF_SP_FIR_CPLX_H_ 1

Definition at line 40 of file DSPF_sp_fir_cplx.h.


DSPLIB: DSPF_sp_fir_cplx.h File Reference

DSPF_sp_fir_cplx.h File Reference

Go to the source code of this file.

Functions

void | DSPF_sp_fir_cplx (const float *x, const float *h, float *restrict y, int nh, int nr)
void | DSPF_sp_fir_cplx_opt (const float *x, const float *h, float *restrict y, int nh, int ny)


DSPLIB: DSPF_sp_fir_gen.h File Reference

DSPF_sp_fir_gen.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_FIR_GEN_H_ 1

Define Documentation

#define _DSPF_SP_FIR_GEN_H_ 1

Definition at line 40 of file DSPF_sp_fir_gen.h.


DSPLIB: DSPF_sp_fir_gen.h File Reference

DSPF_sp_fir_gen.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_fir_gen.h:

Go to the source code of this file.

Functions

void DSPF_sp_fir_gen (const float *restrict x, const float *restrict h, float *restrict r, int nh, int nr)


DSPLIB: DSPF_sp_fir_r2.h File Reference

DSPF_sp_fir_r2.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_FIR_R2_H_ 1

Define Documentation

#define _DSPF_SP_FIR_R2_H_ 1

Definition at line 40 of file DSPF_sp_fir_r2.h.


DSPLIB: DSPF_sp_fir_r2.h File Reference

DSPF_sp_fir_r2.h File Reference

Go to the source code of this file.

Functions

void | DSPF_sp_fir_r2 (const float *x, const float *h, float *restrict r, const int nh, const int nr)
void | DSPF_sp_fir_r2_opt (const float *x, const float *h, float *restrict y, const int nh, const int ny)


DSPLIB: DSPF_sp_fircirc.h File Reference

DSPF_sp_fircirc.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_FIRCIRC_H_ 1

Define Documentation

#define _DSPF_SP_FIRCIRC_H_ 1

Definition at line 40 of file DSPF_sp_fircirc.h.


DSPLIB: DSPF_sp_fircirc.h File Reference

DSPF_sp_fircirc.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_fircirc.h:

Go to the source code of this file.

Functions

void DSPF_sp_fircirc (const float *x, float *h, float *restrict y, int index, int csize, int nh, int ny)


DSPLIB: DSPF_sp_icfftr2_dif.h File Reference

DSPF_sp_icfftr2_dif.h File Reference

Go to the source code of this file.


DSPLIB: DSPF_sp_icfftr2_dif.h File Reference

DSPF_sp_icfftr2_dif.h File Reference

Go to the source code of this file.

Functions

void DSPF_sp_icfftr2_dif (float *x, float *w, unsigned short n)


DSPLIB: DSPF_sp_ifftSPxSP.h File Reference

DSPF_sp_ifftSPxSP.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_IFFTSPXSP_H_ 1

Define Documentation

#define _DSPF_SP_IFFTSPXSP_H_ 1

Definition at line 40 of file DSPF_sp_ifftSPxSP.h.


DSPLIB: DSPF_sp_ifftSPxSP.h File Reference

DSPF_sp_ifftSPxSP.h File Reference

Go to the source code of this file.

Functions

void DSPF_sp_ifftSPxSP (int N, float *ptr_x, float *ptr_w, float *ptr_y, unsigned char *brev, int n_min, int offset, int n_max)


DSPLIB: DSPF_sp_iir.h File Reference

DSPF_sp_iir.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_IIR_H_ 1

Define Documentation

#define _DSPF_SP_IIR_H_ 1

Definition at line 40 of file DSPF_sp_iir.h.


DSPLIB: DSPF_sp_iir.h File Reference

DSPF_sp_iir.h File Reference

Go to the source code of this file.

Functions

void | DSPF_sp_iir (float *restrict y1, const float *x, float *restrict y2, const float *hb, const float *ha, int nr)
void | DSPF_sp_iir_opt (float *restrict y1, const float *x, float *restrict y2, const float *hb, const float *ha, int nr)


DSPLIB: DSPF_sp_iirlat.h File Reference

DSPF_sp_iirlat.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_IIRLAT_H_ 1

Define Documentation

#define _DSPF_SP_IIRLAT_H_ 1

Definition at line 40 of file DSPF_sp_iirlat.h.


DSPLIB: DSPF_sp_iirlat.h File Reference

DSPF_sp_iirlat.h File Reference

Go to the source code of this file.

Functions

void | DSPF_sp_iirlat (const float *x, int nx, const float *restrict k, int nk, float *restrict b, float *restrict y)
void | DSPF_sp_iirlat_opt (const float *x, int nx, const float *restrict k, int nk, float *restrict b, float *restrict y)


DSPLIB: DSPF_sp_lms.h File Reference

DSPF_sp_lms.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_LMS_H_ 1

Define Documentation

#define _DSPF_SP_LMS_H_ 1

Definition at line 40 of file DSPF_sp_lms.h.


DSPLIB: DSPF_sp_lms.h File Reference

DSPF_sp_lms.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_lms.h:

Go to the source code of this file.

Functions

float DSPF_sp_lms (const float *x, float *restrict h, const float *y_i, float *restrict y_o, const float ar, float error, const int nh, const int nx)


DSPLIB: DSPF_sp_mat_mul.h File Reference

DSPF_sp_mat_mul.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MAT_MUL_H_ 1

Define Documentation

#define _DSPF_SP_MAT_MUL_H_ 1

Definition at line 40 of file DSPF_sp_mat_mul.h.


DSPLIB: DSPF_sp_mat_mul.h File Reference

DSPF_sp_mat_mul.h File Reference

Go to the source code of this file.

Functions

void | DSPF_sp_mat_mul (float *x1, const int r1, const int c1, float *x2, const int c2, float *restrict y)
void | DSPF_sp_mat_mul_opt (float *x1, const int r1, const int c1, float *x2, const int c2, float *restrict y)


DSPLIB: DSPF_sp_mat_mul_cplx.h File Reference

DSPF_sp_mat_mul_cplx.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MAT_MUL_CPLX_H_ 1

Define Documentation

#define _DSPF_SP_MAT_MUL_CPLX_H_ 1

Definition at line 40 of file DSPF_sp_mat_mul_cplx.h.


DSPLIB: DSPF_sp_mat_mul_cplx.h File Reference

DSPF_sp_mat_mul_cplx.h File Reference

Go to the source code of this file.

Functions

void | DSPF_sp_mat_mul_cplx (const float *x1, int r1, int c1, const float *x2, int c2, float *restrict y)
void | DSPF_sp_mat_mul_cplx_opt (const float *x1, int r1, int c1, const float *x2, int c2, float *restrict y)


DSPLIB: DSPF_sp_mat_trans.h File Reference

DSPF_sp_mat_trans.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MAT_TRANS_H_ 1

Define Documentation

#define _DSPF_SP_MAT_TRANS_H_ 1

Definition at line 40 of file DSPF_sp_mat_trans.h.


DSPLIB: DSPF_sp_mat_trans.h File Reference

DSPF_sp_mat_trans.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_mat_trans.h:

Go to the source code of this file.

Functions

void DSPF_sp_mat_trans (const float *restrict x, const int rows, const int cols, float *restrict y)


DSPLIB: DSPF_sp_maxidx.h File Reference

DSPF_sp_maxidx.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MAXIDX_H_ 1

Define Documentation

#define _DSPF_SP_MAXIDX_H_ 1

Definition at line 40 of file DSPF_sp_maxidx.h.


DSPLIB: DSPF_sp_maxidx.h File Reference

DSPF_sp_maxidx.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_maxidx.h:

Go to the source code of this file.

Functions

int DSPF_sp_maxidx (const float *x, const int nx)


DSPLIB: DSPF_sp_maxval.h File Reference

DSPF_sp_maxval.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MAXVAL_H_ 1

Define Documentation

#define _DSPF_SP_MAXVAL_H_ 1

Definition at line 40 of file DSPF_sp_maxval.h.


DSPLIB: DSPF_sp_maxval.h File Reference

DSPF_sp_maxval.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_maxval.h:

Go to the source code of this file.

Functions

float DSPF_sp_maxval (const float *x, int nx)


DSPLIB: DSPF_sp_minerr.h File Reference

DSPF_sp_minerr.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MINERR_H_ 1

Define Documentation

#define _DSPF_SP_MINERR_H_ 1

Definition at line 40 of file DSPF_sp_minerr.h.


DSPLIB: DSPF_sp_minerr.h File Reference

DSPF_sp_minerr.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_minerr.h:

Go to the source code of this file.

Functions

float DSPF_sp_minerr (const float *GSP0_TABLE, const float *errCoefs, int *restrict max_index)


DSPLIB: DSPF_sp_minval.h File Reference

DSPF_sp_minval.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_MINVAL_H_ 1

Define Documentation

#define _DSPF_SP_MINVAL_H_ 1

Definition at line 40 of file DSPF_sp_minval.h.


DSPLIB: DSPF_sp_minval.h File Reference

DSPF_sp_minval.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_minval.h:

Go to the source code of this file.

Functions

float DSPF_sp_minval (const float *x, int nx)


DSPLIB: DSPF_sp_vecmul.h File Reference

DSPF_sp_vecmul.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_VECMUL_H_ 1

Define Documentation

#define _DSPF_SP_VECMUL_H_ 1

Definition at line 40 of file DSPF_sp_vecmul.h.


DSPLIB: DSPF_sp_vecmul.h File Reference

DSPF_sp_vecmul.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_vecmul.h:

Go to the source code of this file.

Functions

void DSPF_sp_vecmul (const float *x1, const float *x2, float *restrict y, const int nx)


DSPLIB: DSPF_sp_vecrecip.h File Reference

DSPF_sp_vecrecip.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_VECRECIP_H_ 1

Define Documentation

#define _DSPF_SP_VECRECIP_H_ 1

Definition at line 40 of file DSPF_sp_vecrecip.h.


DSPLIB: DSPF_sp_vecrecip.h File Reference

DSPF_sp_vecrecip.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_vecrecip.h:

Go to the source code of this file.

Functions

void DSPF_sp_vecrecip (const float *x, float *restrict y, const int nx)


DSPLIB: DSPF_sp_vecsum_sq.h File Reference

DSPF_sp_vecsum_sq.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_VECSUM_SQ_H_ 1

Define Documentation

#define _DSPF_SP_VECSUM_SQ_H_ 1

Definition at line 40 of file DSPF_sp_vecsum_sq.h.


DSPLIB: DSPF_sp_vecsum_sq.h File Reference

DSPF_sp_vecsum_sq.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_vecsum_sq.h:

Go to the source code of this file.

Functions

float DSPF_sp_vecsum_sq (const float *x, const int nx)


DSPLIB: DSPF_sp_w_vec.h File Reference

DSPF_sp_w_vec.h File Reference

Go to the source code of this file.

Defines

#define _DSPF_SP_W_VEC_H_ 1

Define Documentation

#define _DSPF_SP_W_VEC_H_ 1

Definition at line 40 of file DSPF_sp_w_vec.h.


DSPLIB: DSPF_sp_w_vec.h File Reference

DSPF_sp_w_vec.h File Reference

#include "assert.h"
#include "C6xSimulator.h"
#include "C6xSimulator_type_modifiers.h"

Include dependency graph for c674/DSPF_sp_w_vec.h:

Go to the source code of this file.

Functions

void DSPF_sp_w_vec (const float *x1, const float *x2, const float m, float *restrict y, const int nx)


DSPLIB: Data Fields

  • All
  • Functions
  • Defines
  • _
  • d

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • _DSPF_BLK_ESWAP16_H_ : DSPF_blk_eswap16.h
  • _DSPF_BLK_ESWAP32_H_ : DSPF_blk_eswap32.h
  • _DSPF_BLK_ESWAP64_H_ : DSPF_blk_eswap64.h
  • _DSPF_FLTOQ15_H_ : DSPF_fltoq15.h , c674/DSPF_fltoq15.h
  • _DSPF_Q15TOFL_H_ : DSPF_q15tofl.h , c674/DSPF_q15tofl.h
  • _DSPF_SP_AUTOCOR_H_ : DSPF_sp_autocor.h
  • _DSPF_SP_BIQUAD_H_ : DSPF_sp_biquad.h
  • _DSPF_SP_BITREV_CPLX_H_ : DSPF_sp_bitrev_cplx.h
  • _DSPF_SP_CONVOL_H_ : DSPF_sp_convol.h
  • _DSPF_SP_DOTP_CPLX_H_ : DSPF_sp_dotp_cplx.h
  • _DSPF_SP_DOTPROD_H_ : DSPF_sp_dotprod.h
  • _DSPF_SP_FFTSPXSP_H_ : DSPF_sp_fftSPxSP.h
  • _DSPF_SP_FIR_CPLX_H_ : DSPF_sp_fir_cplx.h
  • _DSPF_SP_FIR_GEN_H_ : DSPF_sp_fir_gen.h
  • _DSPF_SP_FIR_R2_H_ : DSPF_sp_fir_r2.h
  • _DSPF_SP_FIRCIRC_H_ : DSPF_sp_fircirc.h
  • _DSPF_SP_IFFTSPXSP_H_ : DSPF_sp_ifftSPxSP.h
  • _DSPF_SP_IIR_H_ : DSPF_sp_iir.h
  • _DSPF_SP_IIRLAT_H_ : DSPF_sp_iirlat.h
  • _DSPF_SP_LMS_H_ : DSPF_sp_lms.h
  • _DSPF_SP_MAT_MUL_CPLX_H_ : DSPF_sp_mat_mul_cplx.h
  • _DSPF_SP_MAT_MUL_H_ : DSPF_sp_mat_mul.h
  • _DSPF_SP_MAT_TRANS_H_ : DSPF_sp_mat_trans.h
  • _DSPF_SP_MAXIDX_H_ : DSPF_sp_maxidx.h
  • _DSPF_SP_MAXVAL_H_ : DSPF_sp_maxval.h
  • _DSPF_SP_MINERR_H_ : DSPF_sp_minerr.h
  • _DSPF_SP_MINVAL_H_ : DSPF_sp_minval.h
  • _DSPF_SP_VECMUL_H_ : DSPF_sp_vecmul.h
  • _DSPF_SP_VECRECIP_H_ : DSPF_sp_vecrecip.h
  • _DSPF_SP_VECSUM_SQ_H_ : DSPF_sp_vecsum_sq.h
  • _DSPF_SP_W_VEC_H_ : DSPF_sp_w_vec.h

- d -

  • DSPF_blk_eswap16() : c674/DSPF_blk_eswap16.h
  • DSPF_BLK_ESWAP16_H_ : c674/DSPF_blk_eswap16.h
  • DSPF_blk_eswap32() : c674/DSPF_blk_eswap32.h
  • DSPF_BLK_ESWAP32_H_ : c674/DSPF_blk_eswap32.h
  • DSPF_blk_eswap64() : c674/DSPF_blk_eswap64.h
  • DSPF_BLK_ESWAP64_H_ : c674/DSPF_blk_eswap64.h
  • DSPF_fltoq15() : c674/DSPF_fltoq15.h
  • DSPF_q15tofl() : c674/DSPF_q15tofl.h
  • DSPF_sp_autocor() : c674/DSPF_sp_autocor.h
  • DSPF_sp_biquad() : c674/DSPF_sp_biquad.h
  • DSPF_sp_bitrev_cplx() : c674/DSPF_sp_bitrev_cplx.h
  • DSPF_sp_blk_move() : c674/DSPF_sp_blk_move.h
  • DSPF_sp_BLK_MOVE_H_ : DSPF_sp_blk_move.h , c674/DSPF_sp_blk_move.h
  • DSPF_sp_cfftr2_dit() : c674/DSPF_sp_cfftr2_dit.h
  • DSPF_sp_cfftr4_dif() : c674/DSPF_sp_cfftr4_dif.h
  • DSPF_sp_convol() : c674/DSPF_sp_convol.h
  • DSPF_sp_dotp_cplx() : c674/DSPF_sp_dotp_cplx.h
  • DSPF_sp_dotprod() : c674/DSPF_sp_dotprod.h
  • DSPF_sp_fftSPxSP() : c674/DSPF_sp_fftSPxSP.h
  • DSPF_sp_fir_cplx() : c674/DSPF_sp_fir_cplx.h
  • DSPF_sp_fir_cplx_opt() : c674/DSPF_sp_fir_cplx.h
  • DSPF_sp_fir_gen() : c674/DSPF_sp_fir_gen.h
  • DSPF_sp_fir_r2() : c674/DSPF_sp_fir_r2.h
  • DSPF_sp_fir_r2_opt() : c674/DSPF_sp_fir_r2.h
  • DSPF_sp_fircirc() : c674/DSPF_sp_fircirc.h
  • DSPF_sp_icfftr2_dif() : c674/DSPF_sp_icfftr2_dif.h
  • DSPF_sp_ifftSPxSP() : c674/DSPF_sp_ifftSPxSP.h
  • DSPF_sp_iir() : c674/DSPF_sp_iir.h
  • DSPF_sp_iir_opt() : c674/DSPF_sp_iir.h
  • DSPF_sp_iirlat() : c674/DSPF_sp_iirlat.h
  • DSPF_sp_iirlat_opt() : c674/DSPF_sp_iirlat.h
  • DSPF_sp_lms() : c674/DSPF_sp_lms.h
  • DSPF_sp_mat_mul() : c674/DSPF_sp_mat_mul.h
  • DSPF_sp_mat_mul_cplx() : c674/DSPF_sp_mat_mul_cplx.h
  • DSPF_sp_mat_mul_cplx_opt() : c674/DSPF_sp_mat_mul_cplx.h
  • DSPF_sp_mat_mul_opt() : c674/DSPF_sp_mat_mul.h
  • DSPF_sp_mat_trans() : c674/DSPF_sp_mat_trans.h
  • DSPF_sp_maxidx() : c674/DSPF_sp_maxidx.h
  • DSPF_sp_maxval() : c674/DSPF_sp_maxval.h
  • DSPF_sp_minerr() : c674/DSPF_sp_minerr.h
  • DSPF_sp_minval() : c674/DSPF_sp_minval.h
  • DSPF_sp_vecmul() : c674/DSPF_sp_vecmul.h
  • DSPF_sp_vecrecip() : c674/DSPF_sp_vecrecip.h
  • DSPF_sp_vecsum_sq() : c674/DSPF_sp_vecsum_sq.h
  • DSPF_sp_w_vec() : c674/DSPF_sp_w_vec.h


DSPLIB: DSPF_blk_eswap16.h Source File

DSPF_blk_eswap16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_blk_eswap16.h -- Endian Swap (16-bit)                              */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_BLK_ESWAP16_H_
00041 #define _DSPF_BLK_ESWAP16_H_ 1
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_blk_eswap16/c674/DSPF_blk_eswap16.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_BLK_ESWAP16_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_blk_eswap16.h                                       */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */
00057


DSPLIB: DSPF_blk_eswap32.h Source File

DSPF_blk_eswap32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_blk_eswap32.h -- Endian Swap (32-bit)                              */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_BLK_ESWAP32_H_
00041 #define _DSPF_BLK_ESWAP32_H_ 1
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_blk_eswap32/c674/DSPF_blk_eswap32.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_BLK_ESWAP32_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_blk_eswap32.h                                       */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */
00057


DSPLIB: DSPF_blk_eswap64.h Source File

DSPF_blk_eswap64.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_blk_eswap64.h -- Endian Swap (64-bit)                              */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_BLK_ESWAP64_H_
00041 #define _DSPF_BLK_ESWAP64_H_ 1
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_blk_eswap64/c674/DSPF_blk_eswap64.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_BLK_ESWAP64_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_blk_eswap64.h                                       */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */
00057


DSPLIB: DSPF_fltoq15.h Source File

DSPF_fltoq15.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_fltoq15.h -- Float to Q15 conversion                               */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_FLTOQ15_H_
00041 #define _DSPF_FLTOQ15_H_ 1
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_fltoq15/c674/DSPF_fltoq15.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_FLTOQ15_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_fltoq15.h                                           */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */
00057


DSPLIB: DSPF_q15tofl.h Source File

DSPF_q15tofl.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_q15tofl.h -- Q15 to Float conversion                               */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_Q15TOFL_H_
00041 #define _DSPF_Q15TOFL_H_ 1
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_q15tofl/c674/DSPF_q15tofl.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_Q15TOFL_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_q15tofl.h                                           */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */
00057


DSPLIB: DSPF_sp_autocor.h Source File

DSPF_sp_autocor.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_autocor.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_AUTOCOR_H_
00040 #define _DSPF_SP_AUTOCOR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_autocor/c66/DSPF_sp_autocor.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_autocor/c674/DSPF_sp_autocor.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_AUTOCOR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_autocor.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_biquad.h Source File

DSPF_sp_biquad.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_biquad.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_BIQUAD_H_
00040 #define _DSPF_SP_BIQUAD_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_biquad/c66/DSPF_sp_biquad.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_biquad/c674/DSPF_sp_biquad.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_BIQUAD_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_biquad.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_bitrev_cplx.h Source File

DSPF_sp_bitrev_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_bitrev_cplx.h -- Optimized C source interface header file      */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_BITREV_CPLX_H_
00040 #define _DSPF_SP_BITREV_CPLX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_bitrev_cplx/c66/DSPF_sp_bitrev_cplx.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_bitrev_cplx/c674/DSPF_sp_bitrev_cplx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_BITREV_CPLX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_bitrev_cplx.h                                    */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_blk_move.h Source File

DSPF_sp_blk_move.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_blk_move.h -- Move a block of memory                            */
00003 /*                   Intrinsic C Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_sp_BLK_MOVE_H_
00041 #define DSPF_sp_BLK_MOVE_H_ 1
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_sp_blk_move/c674/DSPF_sp_blk_move.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif
00050
00051 /* ======================================================================== */
00052 /*  End of file:  DSPF_sp_blk_move.h                                        */
00053 /* ------------------------------------------------------------------------ */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00055 /*                           All Rights Reserved.                           */
00056 /* ======================================================================== */
00057


DSPLIB: DSPF_sp_cfftr2_dit.h Source File

DSPF_sp_cfftr2_dit.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_cfftr2_dit.h -- Complex Forward FFT with Radix 2 and DIT        */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_CFFTR2_DIT_H_
00041 #define _DSPF_SP_CFFTR2_DIT_H_
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_sp_cfftr2_dit/c674/DSPF_sp_cfftr2_dit.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_SP_CFFTR2_DIT_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_sp_cfftr2_dit.h                                     */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */


DSPLIB: DSPF_sp_cfftr4_dif.h Source File

DSPF_sp_cfftr4_dif.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_cfftr4_dif.h -- Complex Forward FFT with Radix 4 and DIF        */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_CFFTR4_DIF_H_
00041 #define _DSPF_SP_CFFTR4_DIF_H_
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_sp_cfftr4_dif/c674/DSPF_sp_cfftr4_dif.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_SP_CFFTR4_DIF_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_sp_cfftr4_dif.h                                     */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */


DSPLIB: DSPF_sp_convol.h Source File

DSPF_sp_convol.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_convol.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_CONVOL_H_
00040 #define _DSPF_SP_CONVOL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_convol/c66/DSPF_sp_convol.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_convol/c674/DSPF_sp_convol.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_CONVOL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_convol.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_dotp_cplx.h Source File

DSPF_sp_dotp_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_dotp_cplx.h -- Optimized C source interface header file        */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_DOTP_CPLX_H_
00040 #define _DSPF_SP_DOTP_CPLX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_dotp_cplx/c66/DSPF_sp_dotp_cplx.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_dotp_cplx/c674/DSPF_sp_dotp_cplx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_DOTP_CPLX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_dotp_cplx.h                                      */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_dotprod.h Source File

DSPF_sp_dotprod.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_dotprod.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_DOTPROD_H_
00040 #define _DSPF_SP_DOTPROD_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_dotprod/c66/DSPF_sp_dotprod.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_dotprod/c674/DSPF_sp_dotprod.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_DOTPROD_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_dotprod.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_fftSPxSP.h Source File

DSPF_sp_fftSPxSP.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_fftSPxSP.h -- Optimized C source interface header file         */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_FFTSPXSP_H_
00040 #define _DSPF_SP_FFTSPXSP_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_fftSPxSP/c66/DSPF_sp_fftSPxSP.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_fftSPxSP/c674/DSPF_sp_fftSPxSP.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_FFTSPXSP_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_fftSPxSP.h                                       */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_fir_cplx.h Source File

DSPF_sp_fir_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_fir_cplx.h -- Optimized C source interface header file         */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_FIR_CPLX_H_
00040 #define _DSPF_SP_FIR_CPLX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_fir_cplx/c66/DSPF_sp_fir_cplx.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_fir_cplx/c674/DSPF_sp_fir_cplx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_FIR_CPLX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_fir_cplx.h                                       */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_fir_gen.h Source File

DSPF_sp_fir_gen.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_fir_gen.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_FIR_GEN_H_
00040 #define _DSPF_SP_FIR_GEN_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_fir_gen/c66/DSPF_sp_fir_gen.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_fir_gen/c674/DSPF_sp_fir_gen.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_FIR_GEN_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_fir_gen.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_fir_r2.h Source File

DSPF_sp_fir_r2.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_fir_r2.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_FIR_R2_H_
00040 #define _DSPF_SP_FIR_R2_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_fir_r2/c66/DSPF_sp_fir_r2.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_fir_r2/c674/DSPF_sp_fir_r2.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_FIR_R2_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_fir_r2.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_fircirc.h Source File

DSPF_sp_fircirc.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_fircirc.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_FIRCIRC_H_
00040 #define _DSPF_SP_FIRCIRC_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_fircirc/c66/DSPF_sp_fircirc.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_fircirc/c674/DSPF_sp_fircirc.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_FIRCIRC_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_fircirc.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_icfftr2_dif.h Source File

DSPF_sp_icfftr2_dif.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_icfftr2_dif.h -- Complex Inverse FFT with Radix 2 and DIF       */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_ICFFTR2_DIF_H_
00041 #define _DSPF_SP_ICFFTR2_DIF_H_
00042
00043 #if defined(_TMS320C6740)
00044 #include <ti/dsplib/src/DSPF_sp_icfftr2_dif/c674/DSPF_sp_icfftr2_dif.h>
00045 #else
00046 #error invalid target
00047 #endif
00048
00049 #endif /* _DSPF_SP_ICFFTR2_DIF_H_ */
00050
00051 /* ======================================================================= */
00052 /*  End of file:  DSPF_sp_icfftr2_dif.h                                    */
00053 /* ----------------------------------------------------------------------- */
00054 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00055 /*                           All Rights Reserved.                          */
00056 /* ======================================================================= */


DSPLIB: DSPF_sp_ifftSPxSP.h Source File

DSPF_sp_ifftSPxSP.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_ifftSPxSP.h -- Optimized C source interface header file        */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_IFFTSPXSP_H_
00040 #define _DSPF_SP_IFFTSPXSP_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_ifftSPxSP/c66/DSPF_sp_ifftSPxSP.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_ifftSPxSP/c674/DSPF_sp_ifftSPxSP.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_IFFTSPXSP_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_ifftSPxSP.h                                      */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_iir.h Source File

DSPF_sp_iir.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_iir.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_IIR_H_
00040 #define _DSPF_SP_IIR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_iir/c66/DSPF_sp_iir.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_iir/c674/DSPF_sp_iir.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_IIR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_iir.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_iirlat.h Source File

DSPF_sp_iirlat.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_iirlat.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_IIRLAT_H_
00040 #define _DSPF_SP_IIRLAT_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_iirlat/c66/DSPF_sp_iirlat.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_iirlat/c674/DSPF_sp_iirlat.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_IIRLAT_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_iirlat.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_lms.h Source File

DSPF_sp_lms.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_lms.h -- Optimized C source interface header file              */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_LMS_H_
00040 #define _DSPF_SP_LMS_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_lms/c66/DSPF_sp_lms.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_lms/c674/DSPF_sp_lms.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_LMS_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_lms.h                                            */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_mat_mul.h Source File

DSPF_sp_mat_mul.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_mat_mul.h -- Optimized C source interface header file          */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MAT_MUL_H_
00040 #define _DSPF_SP_MAT_MUL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_mat_mul/c66/DSPF_sp_mat_mul.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_mat_mul/c674/DSPF_sp_mat_mul.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MAT_MUL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_mat_mul.h                                        */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_mat_mul_cplx.h Source File

DSPF_sp_mat_mul_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_mat_mul_cplx.h -- Optimized C source interface header file     */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MAT_MUL_CPLX_H_
00040 #define _DSPF_SP_MAT_MUL_CPLX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_mat_mul_cplx/c66/DSPF_sp_mat_mul_cplx.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_mat_mul_cplx/c674/DSPF_sp_mat_mul_cplx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MAT_MUL_CPLX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_mat_mul_cplx.h                                   */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_mat_trans.h Source File

DSPF_sp_mat_trans.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_mat_trans.h -- Optimized C source interface header file        */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MAT_TRANS_H_
00040 #define _DSPF_SP_MAT_TRANS_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_mat_trans/c66/DSPF_sp_mat_trans.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_mat_trans/c674/DSPF_sp_mat_trans.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MAT_TRANS_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_mat_trans.h                                      */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_maxidx.h Source File

DSPF_sp_maxidx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_maxidx.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MAXIDX_H_
00040 #define _DSPF_SP_MAXIDX_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_maxidx/c66/DSPF_sp_maxidx.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_maxidx/c674/DSPF_sp_maxidx.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MAXIDX_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_maxidx.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_maxval.h Source File

DSPF_sp_maxval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_maxval.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MAXVAL_H_
00040 #define _DSPF_SP_MAXVAL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_maxval/c66/DSPF_sp_maxval.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_maxval/c674/DSPF_sp_maxval.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MAXVAL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_maxval.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_minerr.h Source File

DSPF_sp_minerr.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_minerr.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MINERR_H_
00040 #define _DSPF_SP_MINERR_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_minerr/c66/DSPF_sp_minerr.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_minerr/c674/DSPF_sp_minerr.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MINERR_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_minerr.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_minval.h Source File

DSPF_sp_minval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_minval.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_MINVAL_H_
00040 #define _DSPF_SP_MINVAL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_minval/c66/DSPF_sp_minval.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_minval/c674/DSPF_sp_minval.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_MINVAL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_minval.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_vecmul.h Source File

DSPF_sp_vecmul.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_vecmul.h -- Optimized C source interface header file           */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_VECMUL_H_
00040 #define _DSPF_SP_VECMUL_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_vecmul/c66/DSPF_sp_vecmul.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_vecmul/c674/DSPF_sp_vecmul.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_VECMUL_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_vecmul.h                                         */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_vecrecip.h Source File

DSPF_sp_vecrecip.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_vecrecip.h -- Optimized C source interface header file         */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_VECRECIP_H_
00040 #define _DSPF_SP_VECRECIP_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_vecrecip/c66/DSPF_sp_vecrecip.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_vecrecip/c674/DSPF_sp_vecrecip.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_VECRECIP_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_vecrecip.h                                       */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_vecsum_sq.h Source File

DSPF_sp_vecsum_sq.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_vecsum_sq.h -- Optimized C source interface header file        */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_VECSUM_SQ_H_
00040 #define _DSPF_SP_VECSUM_SQ_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_vecsum_sq/c66/DSPF_sp_vecsum_sq.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_vecsum_sq/c674/DSPF_sp_vecsum_sq.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_VECSUM_SQ_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_vecsum_sq.h                                      */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_sp_w_vec.h Source File

DSPF_sp_w_vec.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  DSPF_sp_w_vec.h -- Optimized C source interface header file            */
00003 /*                                                                         */
00004 /* Rev 0.0.1                                                               */
00005 /*                                                                         */
00006 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00007 /*                                                                         */
00008 /*                                                                         */
00009 /*  Redistribution and use in source and binary forms, with or without     */
00010 /*  modification, are permitted provided that the following conditions     */
00011 /*  are met:                                                               */
00012 /*                                                                         */
00013 /*    Redistributions of source code must retain the above copyright       */
00014 /*    notice, this list of conditions and the following disclaimer.        */
00015 /*                                                                         */
00016 /*    Redistributions in binary form must reproduce the above copyright    */
00017 /*    notice, this list of conditions and the following disclaimer in the  */
00018 /*    documentation and/or other materials provided with the               */
00019 /*    distribution.                                                        */
00020 /*                                                                         */
00021 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00022 /*    its contributors may be used to endorse or promote products derived  */
00023 /*    from this software without specific prior written permission.        */
00024 /*                                                                         */
00025 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00026 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00027 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00028 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00029 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00030 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00031 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00032 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00033 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00034 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00035 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00036 /*                                                                         */
00037 /* ======================================================================= */
00038
00039 #ifndef _DSPF_SP_W_VEC_H_
00040 #define _DSPF_SP_W_VEC_H_ 1
00041
00042 #if defined(_TMS320C6600)
00043 #include <ti/dsplib/src/DSPF_sp_w_vec/c66/DSPF_sp_w_vec.h>
00044 #elif defined(_TMS320C6740)
00045 #include <ti/dsplib/src/DSPF_sp_w_vec/c674/DSPF_sp_w_vec.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _DSPF_SP_W_VEC_H_ */
00051
00052 /* ======================================================================= */
00053 /*  End of file:  DSPF_sp_w_vec.h                                          */
00054 /* ----------------------------------------------------------------------- */
00055 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00056 /*                           All Rights Reserved.                          */
00057 /* ======================================================================= */
00058


DSPLIB: DSPF_blk_eswap16.h Source File

DSPF_blk_eswap16.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_blk_eswap16.h -- Endian-swap a block of 16-bit values              */
00003 /*                      Intrinsic C Implementation                         */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_BLK_ESWAP16_H_
00041 #define DSPF_BLK_ESWAP16_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00087  /* }@ */ /* ingroup */
00088  /* }@ */ /* ingroup */
00089
00090 void DSPF_blk_eswap16 (
00091     void *restrict src,
00092     void *restrict dst,
00093     int  n_hwords
00094 );
00095
00096 #endif
00097
00098 /* ======================================================================== */
00099 /*  End of file:  DSPF_blk_eswap16.h                                        */
00100 /* ------------------------------------------------------------------------ */
00101 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00102 /*                           All Rights Reserved.                           */
00103 /* ======================================================================== */
00104


DSPLIB: DSPF_blk_eswap32.h Source File

DSPF_blk_eswap32.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_blk_eswap32.h -- Endian-swap a block of 32-bit values              */
00003 /*                      Intrinsic C Implementation                         */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_BLK_ESWAP32_H_
00041 #define DSPF_BLK_ESWAP32_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00087  /* }@ */ /* ingroup */
00088  /* }@ */ /* ingroup */
00089
00090 void DSPF_blk_eswap32 (
00091     void *restrict src,
00092     void *restrict dst,
00093     int  n_words
00094 );
00095
00096 #endif
00097
00098 /* ======================================================================== */
00099 /*  End of file:  DSPF_blk_eswap32.h                                        */
00100 /* ------------------------------------------------------------------------ */
00101 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00102 /*                           All Rights Reserved.                           */
00103 /* ======================================================================== */
00104


DSPLIB: DSPF_blk_eswap64.h Source File

DSPF_blk_eswap64.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_blk_eswap64.h -- Endian-swap a block of 64-bit values              */
00003 /*                      Intrinsic C Implementation                         */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /*                                                                         */
00008 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /*  Redistribution and use in source and binary forms, with or without     */
00012 /*  modification, are permitted provided that the following conditions     */
00013 /*  are met:                                                               */
00014 /*                                                                         */
00015 /*    Redistributions of source code must retain the above copyright       */
00016 /*    notice, this list of conditions and the following disclaimer.        */
00017 /*                                                                         */
00018 /*    Redistributions in binary form must reproduce the above copyright    */
00019 /*    notice, this list of conditions and the following disclaimer in the  */
00020 /*    documentation and/or other materials provided with the               */
00021 /*    distribution.                                                        */
00022 /*                                                                         */
00023 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00024 /*    its contributors may be used to endorse or promote products derived  */
00025 /*    from this software without specific prior written permission.        */
00026 /*                                                                         */
00027 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00028 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00029 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00030 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00031 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00032 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00033 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00034 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00035 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00036 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00037 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00038 /*                                                                         */
00039 /* ======================================================================= */
00040
00041 #ifndef DSPF_BLK_ESWAP64_H_
00042 #define DSPF_BLK_ESWAP64_H_ 1
00043
00044 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00045 #include "assert.h"                       // intrinsics prototypes
00046 #include "C6xSimulator.h"                 // intrinsics prototypes
00047 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00048 #endif
00049
00051 /* @{ */
00052
00055 /* @{ */
00056
00088  /* }@ */ /* ingroup */
00089  /* }@ */ /* ingroup */
00090
00091 void DSPF_blk_eswap64 (
00092     void *restrict src,
00093     void *restrict dst,
00094     int   n_dbls
00095 );
00096
00097 #endif
00098
00099 /* ======================================================================== */
00100 /*  End of file:  DSPF_blk_eswap64.h                                        */
00101 /* ------------------------------------------------------------------------ */
00102 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00103 /*                           All Rights Reserved.                           */
00104 /* ======================================================================== */
00105


DSPLIB: DSPF_fltoq15.h Source File

DSPF_fltoq15.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_fltoq15.h -- Float to Q15 conversion                               */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_FLTOQ15_H_
00041 #define _DSPF_FLTOQ15_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00084 void DSPF_fltoq15 (
00085     const float *restrict flt,  /* Input float array    */
00086     short *restrict q15,        /* Output Q15 array     */
00087     int   nx                    /* Number of elements   */
00088 );
00089
00090 #endif /* _DSPF_FLTOQ15_H_ */
00091
00092 /* ======================================================================= */
00093 /*  End of file:  DSPF_fltoq15.h                                           */
00094 /* ----------------------------------------------------------------------- */
00095 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00096 /*                           All Rights Reserved.                          */
00097 /* ======================================================================= */
00098


DSPLIB: DSPF_q15tofl.h Source File

DSPF_q15tofl.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_q15tofl.h -- Q15 to Float conversion                               */
00003 /*                  Optimized C Implementation (w/ Intrinsics)             */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_Q15TOFL_H_
00041 #define _DSPF_Q15TOFL_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080  /* }@ */ /* ingroup */
00081  /* }@ */ /* ingroup */
00082
00083 void DSPF_q15tofl (
00084     const short *restrict q15,  /* Input Q15 array      */
00085     float *restrict flt,        /* Output float array   */
00086     int   nx                    /* Number of elements   */
00087 );
00088
00089 #endif /* _DSPF_Q15TOFL_H_ */
00090
00091 /* ======================================================================= */
00092 /*  End of file:  DSPF_q15tofl.h                                           */
00093 /* ----------------------------------------------------------------------- */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00095 /*                           All Rights Reserved.                          */
00096 /* ======================================================================= */
00097


DSPLIB: DSPF_sp_autocor.h Source File

DSPF_sp_autocor.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_autocor.h -- Autocorrelation                                    */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_AUTOCOR_H_
00041 #define _DSPF_SP_AUTOCOR_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00086 void DSPF_sp_autocor(float *restrict r,
00087     float *restrict x, const int nx, const int nr);
00088
00089 #endif /* _DSPF_SP_AUTOCOR_H_ */
00090
00091 /* ======================================================================= */
00092 /*  End of file:  DSPF_sp_autocor.h                                        */
00093 /* ----------------------------------------------------------------------- */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00095 /*                           All Rights Reserved.                          */
00096 /* ======================================================================= */
00097


DSPLIB: DSPF_sp_biquad.h Source File

DSPF_sp_biquad.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_biquad.h -- Biquad Filter                                       */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_BIQUAD_H_
00041 #define DSPF_SP_BIQUAD_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080 void DSPF_sp_biquad(float *restrict x, float *b, float *a,
00081     float *delay, float *restrict y, const int nx);
00082
00083 #endif /* DSPF_SP_BIQUAD_H_ */
00084
00085 /* ======================================================================= */
00086 /*  End of file:  DSPF_sp_biquad.h                                         */
00087 /* ----------------------------------------------------------------------- */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00089 /*                           All Rights Reserved.                          */
00090 /* ======================================================================= */
00091


DSPLIB: DSPF_sp_bitrev_cplx.h Source File

DSPF_sp_bitrev_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_bitrev_cplx.h -- Complex Bit Reversal                           */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_BITREV_CPLX_H_
00041 #define DSPF_SP_BITREV_CPLX_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00087 void DSPF_sp_bitrev_cplx (double *restrict x, short *restrict index, int nx);
00088
00089 #endif /* DSPF_SP_BITREV_CPLX_H_ */
00090
00091 /* ======================================================================= */
00092 /*  End of file:  DSPF_sp_bitrev_cplx.h                                    */
00093 /* ----------------------------------------------------------------------- */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00095 /*                           All Rights Reserved.                          */
00096 /* ======================================================================= */


DSPLIB: DSPF_sp_blk_move.h Source File

DSPF_sp_blk_move.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_blk_move.h -- Move a block of memory                            */
00003 /*                   Intrinsic C Implementation                            */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_sp_BLK_MOVE_H_
00041 #define DSPF_sp_BLK_MOVE_H_ 1
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080  /* }@ */ /* ingroup */
00081  /* }@ */ /* ingroup */
00082
00083 void DSPF_sp_blk_move(const float * x, float *restrict y, const int n);
00084
00085 #endif
00086
00087 /* ======================================================================== */
00088 /*  End of file:  DSPF_sp_blk_move.h                                        */
00089 /* ------------------------------------------------------------------------ */
00090 /*            Copyright (c) 2011 Texas Instruments, Incorporated.           */
00091 /*                           All Rights Reserved.                           */
00092 /* ======================================================================== */
00093


DSPLIB: DSPF_sp_cfftr2_dit.h Source File

DSPF_sp_cfftr2_dit.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_cfftr2_dit.h -- Complex Forward FFT with Radix 2 and DIT        */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_CFFTR2_DIT_H_
00041 #define _DSPF_SP_CFFTR2_DIT_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00084 void DSPF_sp_cfftr2_dit(float* x, float* w, unsigned short n);
00085
00086 /* @} */ /* ingroup */
00087 /* @} */ /* ingroup */
00088
00089 #endif /* _DSPF_SP_CFFTR2_DIT_H_ */
00090
00091 /* ======================================================================= */
00092 /*  End of file:  DSPF_sp_cfftr2_dit.h                                     */
00093 /* ----------------------------------------------------------------------- */
00094 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00095 /*                           All Rights Reserved.                          */
00096 /* ======================================================================= */


DSPLIB: DSPF_sp_cfftr4_dif.h Source File

DSPF_sp_cfftr4_dif.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_cfftr4_dif.h -- Complex Forward FFT with Radix 4 and DIF        */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_CFFTR4_DIF_H_
00041 #define _DSPF_SP_CFFTR4_DIF_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00077 void DSPF_sp_cfftr4_dif(float* x, float* w, unsigned short n);
00078
00079 /* @} */ /* ingroup */
00080 /* @} */ /* ingroup */
00081
00082 #endif /* _DSPF_SP_CFFTR4_DIF_H_ */
00083
00084 /* ======================================================================= */
00085 /*  End of file:  DSPF_sp_cfftr4_dif.h                                     */
00086 /* ----------------------------------------------------------------------- */
00087 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00088 /*                           All Rights Reserved.                          */
00089 /* ======================================================================= */


DSPLIB: DSPF_sp_convol.h Source File

DSPF_sp_convol.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_convol.h -- Convolution                                         */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_CONVOL_H_
00041 #define DSPF_SP_CONVOL_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00084 void DSPF_sp_convol(const float *x, const float *h,
00085     float *restrict y, const short nh, const short ny);
00086
00087 #endif /* DSPF_SP_CONVOL_H_ */
00088
00089 /* ======================================================================= */
00090 /*  End of file:  DSPF_sp_convol.h                                         */
00091 /* ----------------------------------------------------------------------- */
00092 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00093 /*                           All Rights Reserved.                          */
00094 /* ======================================================================= */
00095


DSPLIB: DSPF_sp_dotp_cplx.h Source File

DSPF_sp_dotp_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_dotp_cplx.h -- Complex Dot Product                              */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_DOTP_CPLX_H_
00041 #define DSPF_SP_DOTP_CPLX_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00083 void DSPF_sp_dotp_cplx(const float * x, const float * y, int nx,
00084                        float * restrict re, float * restrict im);
00085
00086 #endif /* _DSPF_SP_DOTP_CPLX_H_ */
00087
00088 /* ======================================================================= */
00089 /*  End of file:  DSPF_sp_dotp_cplx.h                                      */
00090 /* ----------------------------------------------------------------------- */
00091 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00092 /*                           All Rights Reserved.                          */
00093 /* ======================================================================= */
00094


DSPLIB: DSPF_sp_dotprod.h Source File

DSPF_sp_dotprod.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_dotprod.h -- Dot Product                                        */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_DOTPROD_H_
00041 #define DSPF_SP_DOTPROD_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00078 float DSPF_sp_dotprod(const float * x, const float * y, const int nx);
00079
00080 #endif /* DSPF_SP_DOTPROD_H_ */
00081
00082 /* ======================================================================= */
00083 /*  End of file:  DSPF_sp_dotprod.h                                        */
00084 /* ----------------------------------------------------------------------- */
00085 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00086 /*                           All Rights Reserved.                          */
00087 /* ======================================================================= */
00088


DSPLIB: DSPF_sp_fftSPxSP.h Source File

DSPF_sp_fftSPxSP.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  TEXAS INSTRUMENTS, INC.                                                */
00003 /*                                                                         */
00004 /*  NAME                                                                   */
00005 /*      DSPF_sp_fftSPXSP.sa -- Optimized linear assembly Implementation    */
00006 /*                                                                         */
00007 /*  USAGE                                                                  */
00008 /*      single precision floating point Forward FFT with mixed radix       */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00012 /*                                                                         */
00013 /*                                                                         */
00014 /*  Redistribution and use in source and binary forms, with or without     */
00015 /*  modification, are permitted provided that the following conditions     */
00016 /*  are met:                                                               */
00017 /*                                                                         */
00018 /*    Redistributions of source code must retain the above copyright       */
00019 /*    notice, this list of conditions and the following disclaimer.        */
00020 /*                                                                         */
00021 /*    Redistributions in binary form must reproduce the above copyright    */
00022 /*    notice, this list of conditions and the following disclaimer in the  */
00023 /*    documentation and/or other materials provided with the               */
00024 /*    distribution.                                                        */
00025 /*                                                                         */
00026 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00027 /*    its contributors may be used to endorse or promote products derived  */
00028 /*    from this software without specific prior written permission.        */
00029 /*                                                                         */
00030 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00031 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00032 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00033 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00034 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00035 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00036 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00037 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00038 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00039 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00040 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00041 /*                                                                         */
00042 /* ======================================================================= */
00043
00044 #ifndef DSPF_SP_fftSPxSP_H_
00045 #define DSPF_SP_fftSPxSP_H_
00046
00048 /* @{ */
00049
00052 /* @{ */
00053
00083 void DSPF_sp_fftSPxSP(int N, float *ptr_x, float *ptr_w, float *ptr_y, unsigned char *brev, int n_min, int offset, int n_max);
00084
00085 /* @} */ /* ingroup */
00086 /* @} */ /* ingroup */
00087
00088 #endif /* DSPF_SP_fftSPxSP_H_ */


DSPLIB: DSPF_sp_fir_cplx.h Source File

DSPF_sp_fir_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_fir_cplx.h -- Complex FIR Filter                                */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_FIR_CPLX_H_
00041 #define DSPF_SP_FIR_CPLX_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00082 void DSPF_sp_fir_cplx(const float * x, const float * h,
00083     float * restrict y, int nh, int nr);
00084
00085 void DSPF_sp_fir_cplx_opt(const float * x, const float * h,
00086     float * restrict y, int nh, int ny);
00087
00088 #endif /* DSPF_SP_FIR_CPLX_H_ */
00089
00090 /* ======================================================================= */
00091 /*  End of file:  DSPF_sp_fir_cplx.h                                       */
00092 /* ----------------------------------------------------------------------- */
00093 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00094 /*                           All Rights Reserved.                          */
00095 /* ======================================================================= */
00096


DSPLIB: DSPF_sp_fir_gen.h Source File

DSPF_sp_fir_gen.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_fir_gen.h -- FIR Filter                                         */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_FIR_GEN_H_
00041 #define DSPF_SP_FIR_GEN_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00088 void DSPF_sp_fir_gen(const float * restrict x,
00089     const float * restrict h,
00090     float * restrict r,
00091     int nh,
00092     int nr);
00093
00094 #endif /* DSPF_SP_FIR_GEN_H_ */
00095
00096 /* ======================================================================= */
00097 /*  End of file:  DSPF_sp_fir_gen.h                                        */
00098 /* ----------------------------------------------------------------------- */
00099 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00100 /*                           All Rights Reserved.                          */
00101 /* ======================================================================= */
00102


DSPLIB: DSPF_sp_fir_r2.h Source File

DSPF_sp_fir_r2.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_fir_r2.h -- FIR Filter                                          */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_FIR_R2_H_
00041 #define DSPF_SP_FIR_R2_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00080 void DSPF_sp_fir_r2(const float * x, const float * h,
00081     float *restrict r, const int nh, const int nr);
00082
00083 void DSPF_sp_fir_r2_opt(const float * x, const float * h,
00084     float *restrict y, const int nh, const int ny);
00085
00086 #endif /* DSPF_SP_FIR_R2_H_ */
00087
00088 /* ======================================================================= */
00089 /*  End of file:  DSPF_sp_fir_r2.h                                         */
00090 /* ----------------------------------------------------------------------- */
00091 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00092 /*                           All Rights Reserved.                          */
00093 /* ======================================================================= */
00094


DSPLIB: DSPF_sp_fircirc.h Source File

DSPF_sp_fircirc.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_fircirc.h -- Circular FIR Filter                                */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_FIRCIRC_H_
00041 #define DSPF_SP_FIRCIRC_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00088 void DSPF_sp_fircirc(const float *x, float *h, float *restrict y,
00089                      int index, int csize, int nh, int ny);
00090
00091 #endif /* DSPF_SP_FIRCIRC_H_ */
00092
00093 /* ======================================================================= */
00094 /*  End of file:  DSPF_sp_fircirc.h                                        */
00095 /* ----------------------------------------------------------------------- */
00096 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00097 /*                           All Rights Reserved.                          */
00098 /* ======================================================================= */
00099


DSPLIB: DSPF_sp_icfftr2_dif.h Source File

DSPF_sp_icfftr2_dif.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_icfftr2_dif.h -- Complex Inverse FFT with Radix 2 and DIF       */
00003 /*                 Assembly Implementation                                 */
00004 /*                                                                         */
00005 /* Rev 0.0.2                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef _DSPF_SP_ICFFTR2_DIF_H_
00041 #define _DSPF_SP_ICFFTR2_DIF_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00078 void DSPF_sp_icfftr2_dif(float* x, float* w, unsigned short n);
00079
00080 /* @} */ /* ingroup */
00081 /* @} */ /* ingroup */
00082
00083 #endif /* _DSPF_SP_ICFFTR2_DIF_H_ */
00084
00085 /* ======================================================================= */
00086 /*  End of file:  DSPF_sp_icfftr2_dif.h                                    */
00087 /* ----------------------------------------------------------------------- */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00089 /*                           All Rights Reserved.                          */
00090 /* ======================================================================= */


DSPLIB: DSPF_sp_ifftSPxSP.h Source File

DSPF_sp_ifftSPxSP.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /*  TEXAS INSTRUMENTS, INC.                                                */
00003 /*                                                                         */
00004 /*  NAME                                                                   */
00005 /*      DSPF_sp_ifftSPXSP.h -- Optimized Implementation                    */
00006 /*                                                                         */
00007 /*  USAGE                                                                  */
00008 /*      single precision floating point Forward FFT with mixed radix       */
00009 /*                                                                         */
00010 /*                                                                         */
00011 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00012 /*                                                                         */
00013 /*                                                                         */
00014 /*  Redistribution and use in source and binary forms, with or without     */
00015 /*  modification, are permitted provided that the following conditions     */
00016 /*  are met:                                                               */
00017 /*                                                                         */
00018 /*    Redistributions of source code must retain the above copyright       */
00019 /*    notice, this list of conditions and the following disclaimer.        */
00020 /*                                                                         */
00021 /*    Redistributions in binary form must reproduce the above copyright    */
00022 /*    notice, this list of conditions and the following disclaimer in the  */
00023 /*    documentation and/or other materials provided with the               */
00024 /*    distribution.                                                        */
00025 /*                                                                         */
00026 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00027 /*    its contributors may be used to endorse or promote products derived  */
00028 /*    from this software without specific prior written permission.        */
00029 /*                                                                         */
00030 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00031 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00032 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00033 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00034 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00035 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00036 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00037 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00038 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00039 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00040 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00041 /*                                                                         */
00042 /* ======================================================================= */
00043
00044 #ifndef DSPF_SP_ifftSPxSP_H_
00045 #define DSPF_SP_ifftSPxSP_H_
00046
00048 /* @{ */
00049
00052 /* @{ */
00053
00083 void DSPF_sp_ifftSPxSP (int N, float *ptr_x, float *ptr_w, float *ptr_y,
00084     unsigned char *brev, int n_min, int offset, int n_max);
00085
00086 /* @} */ /* ingroup */
00087 /* @} */ /* ingroup */
00088
00089 #endif /* DSPF_SP_ifftSPxSP_H_ */
00090


DSPLIB: DSPF_sp_iir.h Source File

DSPF_sp_iir.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_iir.h -- IIR Filter                                             */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_IIR_H_
00041 #define DSPF_SP_IIR_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00079 void DSPF_sp_iir (float* restrict y1,
00080     const float* x,
00081     float* restrict y2,
00082     const float* hb,
00083     const float* ha,
00084     int nr);
00085
00086 void DSPF_sp_iir_opt (float *restrict y1,
00087     const float * x,
00088     float *restrict y2,
00089     const float * hb,
00090     const float * ha,
00091     int nr);
00092
00093 #endif /* DSPF_SP_IIR_H_ */
00094
00095 /* ======================================================================= */
00096 /*  End of file:  DSPF_sp_iir.h                                            */
00097 /* ----------------------------------------------------------------------- */
00098 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00099 /*                           All Rights Reserved.                          */
00100 /* ======================================================================= */
00101


DSPLIB: DSPF_sp_iirlat.h Source File

DSPF_sp_iirlat.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_iirlat.h -- Lattice IIR Filter                                  */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_IIRLAT_H_
00041 #define DSPF_SP_IIRLAT_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00085 void DSPF_sp_iirlat(const float *x, int nx, const float *restrict k,
00086                     int nk, float *restrict b, float *restrict y);
00087
00088 void DSPF_sp_iirlat_opt(const float *x, int nx, const float *restrict k,
00089                     int nk, float *restrict b, float *restrict y);
00090 #endif /* DSPF_SP_IIRLAT_H_ */
00091
00092 /* ======================================================================= */
00093 /*  End of file:  DSPF_sp_iirlat.h                                         */
00094 /* ----------------------------------------------------------------------- */
00095 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00096 /*                           All Rights Reserved.                          */
00097 /* ======================================================================= */
00098


DSPLIB: DSPF_sp_lms.h Source File

DSPF_sp_lms.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_lms.h -- LMS Adaptive Filter                                    */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_LMS_H_
00041 #define DSPF_SP_LMS_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00086  /* }@ */ /* ingroup */
00087  /* }@ */ /* ingroup */
00088
00089 float DSPF_sp_lms(const float *x, float *restrict h, const float *y_i,
00090     float *restrict y_o, const float ar, float error, const int nh, const int nx);
00091
00092 #endif /* DSPF_SP_LMS_H_ */
00093
00094 /* ======================================================================= */
00095 /*  End of file:  DSPF_sp_lms.h                                            */
00096 /* ----------------------------------------------------------------------- */
00097 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00098 /*                           All Rights Reserved.                          */
00099 /* ======================================================================= */
00100


DSPLIB: DSPF_sp_mat_mul.h Source File

DSPF_sp_mat_mul.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_mat_mul.h -- Matrix Multiply                                    */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MAT_MUL_H_
00041 #define DSPF_SP_MAT_MUL_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00090 void DSPF_sp_mat_mul(float *x1, const int r1, const int c1,
00091     float *x2, const int c2, float *restrict y);
00092
00093 void DSPF_sp_mat_mul_opt(float *x1, const int r1, const int c1,
00094     float *x2, const int c2, float *restrict y);
00095
00096 #endif /* DSPF_SP_MAT_MUL_H_ */
00097
00098 /* ======================================================================= */
00099 /*  End of file:  DSPF_sp_mat_mul.h                                        */
00100 /* ----------------------------------------------------------------------- */
00101 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00102 /*                           All Rights Reserved.                          */
00103 /* ======================================================================= */
00104


DSPLIB: DSPF_sp_mat_mul_cplx.h Source File

DSPF_sp_mat_mul_cplx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_mat_mul_cplx.h -- Complex Matrix Multiply                       */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MAT_MUL_CPLX_H_
00041 #define DSPF_SP_MAT_MUL_CPLX_H_
00042
00044 /* @{ */
00045
00048 /* @{ */
00049
00080 void DSPF_sp_mat_mul_cplx(const float* x1, int r1, int c1, const float* x2,
00081                           int c2, float* restrict y);
00082
00083 void DSPF_sp_mat_mul_cplx_opt(const float* x1, int r1, int c1, const float* x2,
00084                           int c2, float* restrict y);
00085
00086 #endif /* DSPF_SP_MAT_MUL_CPLX_H_ */
00087
00088 /* ======================================================================= */
00089 /*  End of file:  DSPF_sp_mat_mul_cplx.h                                   */
00090 /* ----------------------------------------------------------------------- */
00091 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00092 /*                           All Rights Reserved.                          */
00093 /* ======================================================================= */
00094


DSPLIB: DSPF_sp_mat_trans.h Source File

DSPF_sp_mat_trans.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_mat_trans.h -- Matrix Transpose                                 */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MAT_TRANS_H_
00041 #define DSPF_SP_MAT_TRANS_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080 void DSPF_sp_mat_trans(const float *restrict x, const int rows,
00081     const int cols, float *restrict y);
00082
00083 #endif /* DSPF_SP_MAT_TRANS_H_ */
00084
00085 /* ======================================================================= */
00086 /*  End of file:  DSPF_sp_mat_trans.h                                      */
00087 /* ----------------------------------------------------------------------- */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00089 /*                           All Rights Reserved.                          */
00090 /* ======================================================================= */
00091


DSPLIB: DSPF_sp_maxidx.h Source File

DSPF_sp_maxidx.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_maxidx.h -- Max Value Index                                     */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MAXIDX_H_
00041 #define DSPF_SP_MAXIDX_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00077 int DSPF_sp_maxidx(const float* x, const int nx);
00078
00079 #endif /* DSPF_SP_MAXIDX_H_ */
00080
00081 /* ======================================================================= */
00082 /*  End of file:  DSPF_sp_maxidx.h                                         */
00083 /* ----------------------------------------------------------------------- */
00084 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00085 /*                           All Rights Reserved.                          */
00086 /* ======================================================================= */
00087


DSPLIB: DSPF_sp_maxval.h Source File

DSPF_sp_maxval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_maxval.h -- Max Value                                           */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MAXVAL_H_
00041 #define DSPF_SP_MAXVAL_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00078 float DSPF_sp_maxval(const float* x, int nx);
00079
00080 #endif /* DSPF_SP_MAXVAL_H_ */
00081
00082 /* ======================================================================= */
00083 /*  End of file:  DSPF_sp_maxval.h                                         */
00084 /* ----------------------------------------------------------------------- */
00085 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00086 /*                           All Rights Reserved.                          */
00087 /* ======================================================================= */
00088


DSPLIB: DSPF_sp_minerr.h Source File

DSPF_sp_minerr.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_minerr.h -- Vocoder Codebook Search                             */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MINERR_H_
00041 #define DSPF_SP_MINERR_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00083 float DSPF_sp_minerr(const float* GSP0_TABLE,
00084     const float* errCoefs, int *restrict max_index);
00085
00086 #endif /* DSPF_SP_MINERR_H_ */
00087
00088 /* ======================================================================= */
00089 /*  End of file:  DSPF_sp_minerr.h                                         */
00090 /* ----------------------------------------------------------------------- */
00091 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00092 /*                           All Rights Reserved.                          */
00093 /* ======================================================================= */
00094


DSPLIB: DSPF_sp_minval.h Source File

DSPF_sp_minval.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_minval.h -- Minimum Value                                       */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_MINVAL_H_
00041 #define DSPF_SP_MINVAL_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00078 float DSPF_sp_minval(const float* x, int nx);
00079
00080 #endif /* DSPF_SP_MINVAL_H_ */
00081
00082 /* ======================================================================= */
00083 /*  End of file:  DSPF_sp_minval.h                                         */
00084 /* ----------------------------------------------------------------------- */
00085 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00086 /*                           All Rights Reserved.                          */
00087 /* ======================================================================= */
00088


DSPLIB: DSPF_sp_vecmul.h Source File

DSPF_sp_vecmul.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_vecmul.h -- Vector Multiply                                     */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_VECMUL_H_
00041 #define DSPF_SP_VECMUL_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00080 void DSPF_sp_vecmul(const float * x1, const float * x2,
00081     float *restrict y, const int nx);
00082
00083 #endif /* DSPF_SP_VECMUL_H_ */
00084
00085 /* ======================================================================= */
00086 /*  End of file:  DSPF_sp_vecmul.h                                         */
00087 /* ----------------------------------------------------------------------- */
00088 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00089 /*                           All Rights Reserved.                          */
00090 /* ======================================================================= */
00091


DSPLIB: DSPF_sp_vecrecip.h Source File

DSPF_sp_vecrecip.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_vecrecip.h -- Vector Reciprocal                                 */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_VECRECIP_H_
00041 #define DSPF_SP_VECRECIP_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00085 void DSPF_sp_vecrecip(const float * x, float *restrict y, const int nx);
00086
00087 #endif /* DSPF_SP_VECRECIP_H_ */
00088
00089 /* ======================================================================= */
00090 /*  End of file:  DSPF_sp_vecrecip.h                                       */
00091 /* ----------------------------------------------------------------------- */
00092 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00093 /*                           All Rights Reserved.                          */
00094 /* ======================================================================= */
00095


DSPLIB: DSPF_sp_vecsum_sq.h Source File

DSPF_sp_vecsum_sq.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_vecsum_sq.h -- Vector Sum Squared                               */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_VECSUM_SQ_H_
00041 #define DSPF_SP_VECSUM_SQ_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00077 float DSPF_sp_vecsum_sq(const float * x, const int nx);
00078
00079 #endif /* DSPF_SP_VECSUM_SQ_H_ */
00080
00081 /* ======================================================================= */
00082 /*  End of file:  DSPF_sp_vecsum_sq.h                                      */
00083 /* ----------------------------------------------------------------------- */
00084 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00085 /*                           All Rights Reserved.                          */
00086 /* ======================================================================= */
00087


DSPLIB: DSPF_sp_w_vec.h Source File

DSPF_sp_w_vec.h

Go to the documentation of this file.
00001 /* ======================================================================= */
00002 /* DSPF_sp_w_vec.h -- Vector Weighted Add                                  */
00003 /*              Optimized C Implementation (w/ Intrinsics)                 */
00004 /*                                                                         */
00005 /* Rev 0.0.1                                                               */
00006 /*                                                                         */
00007 /* Copyright (C) 2011 Texas Instruments Incorporated - http://www.ti.com/  */
00008 /*                                                                         */
00009 /*                                                                         */
00010 /*  Redistribution and use in source and binary forms, with or without     */
00011 /*  modification, are permitted provided that the following conditions     */
00012 /*  are met:                                                               */
00013 /*                                                                         */
00014 /*    Redistributions of source code must retain the above copyright       */
00015 /*    notice, this list of conditions and the following disclaimer.        */
00016 /*                                                                         */
00017 /*    Redistributions in binary form must reproduce the above copyright    */
00018 /*    notice, this list of conditions and the following disclaimer in the  */
00019 /*    documentation and/or other materials provided with the               */
00020 /*    distribution.                                                        */
00021 /*                                                                         */
00022 /*    Neither the name of Texas Instruments Incorporated nor the names of  */
00023 /*    its contributors may be used to endorse or promote products derived  */
00024 /*    from this software without specific prior written permission.        */
00025 /*                                                                         */
00026 /*  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS    */
00027 /*  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT      */
00028 /*  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR  */
00029 /*  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT   */
00030 /*  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,  */
00031 /*  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT       */
00032 /*  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,  */
00033 /*  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY  */
00034 /*  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT    */
00035 /*  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE  */
00036 /*  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.   */
00037 /*                                                                         */
00038 /* ======================================================================= */
00039
00040 #ifndef DSPF_SP_W_VEC_H_
00041 #define DSPF_SP_W_VEC_H_
00042
00043 #ifndef __TI_COMPILER_VERSION__           // for non TI compiler
00044 #include "assert.h"                       // intrinsics prototypes
00045 #include "C6xSimulator.h"                 // intrinsics prototypes
00046 #include "C6xSimulator_type_modifiers.h"  // define/undefine typing keywords
00047 #endif
00048
00050 /* @{ */
00051
00054 /* @{ */
00055
00081 void DSPF_sp_w_vec(const float *x1, const float *x2, const float m,
00082     float *restrict y, const int nx);
00083
00084 #endif /* DSPF_SP_W_VEC_H_ */
00085
00086 /* ======================================================================= */
00087 /*  End of file:  DSPF_sp_w_vec.h                                          */
00088 /* ----------------------------------------------------------------------- */
00089 /*            Copyright (c) 2011 Texas Instruments, Incorporated.          */
00090 /*                           All Rights Reserved.                          */
00091 /* ======================================================================= */
00092


DSPLIB: doxygen.h Source File

doxygen.h

Go to the documentation of this file.
00001 /*
00002  * This is a little header file which doxygen parses to generate the main
00003  * documentation page
00004  */
00005


DSPLIB: Data Fields

  • All
  • Functions
  • Defines
  • _
  • d

- _ -

  • _DSPF_BLK_ESWAP16_H_ : DSPF_blk_eswap16.h
  • _DSPF_BLK_ESWAP32_H_ : DSPF_blk_eswap32.h
  • _DSPF_BLK_ESWAP64_H_ : DSPF_blk_eswap64.h
  • _DSPF_FLTOQ15_H_ : DSPF_fltoq15.h , c674/DSPF_fltoq15.h
  • _DSPF_Q15TOFL_H_ : DSPF_q15tofl.h , c674/DSPF_q15tofl.h
  • _DSPF_SP_AUTOCOR_H_ : DSPF_sp_autocor.h
  • _DSPF_SP_BIQUAD_H_ : DSPF_sp_biquad.h
  • _DSPF_SP_BITREV_CPLX_H_ : DSPF_sp_bitrev_cplx.h
  • _DSPF_SP_CONVOL_H_ : DSPF_sp_convol.h
  • _DSPF_SP_DOTP_CPLX_H_ : DSPF_sp_dotp_cplx.h
  • _DSPF_SP_DOTPROD_H_ : DSPF_sp_dotprod.h
  • _DSPF_SP_FFTSPXSP_H_ : DSPF_sp_fftSPxSP.h
  • _DSPF_SP_FIR_CPLX_H_ : DSPF_sp_fir_cplx.h
  • _DSPF_SP_FIR_GEN_H_ : DSPF_sp_fir_gen.h
  • _DSPF_SP_FIR_R2_H_ : DSPF_sp_fir_r2.h
  • _DSPF_SP_FIRCIRC_H_ : DSPF_sp_fircirc.h
  • _DSPF_SP_IFFTSPXSP_H_ : DSPF_sp_ifftSPxSP.h
  • _DSPF_SP_IIR_H_ : DSPF_sp_iir.h
  • _DSPF_SP_IIRLAT_H_ : DSPF_sp_iirlat.h
  • _DSPF_SP_LMS_H_ : DSPF_sp_lms.h
  • _DSPF_SP_MAT_MUL_CPLX_H_ : DSPF_sp_mat_mul_cplx.h
  • _DSPF_SP_MAT_MUL_H_ : DSPF_sp_mat_mul.h
  • _DSPF_SP_MAT_TRANS_H_ : DSPF_sp_mat_trans.h
  • _DSPF_SP_MAXIDX_H_ : DSPF_sp_maxidx.h
  • _DSPF_SP_MAXVAL_H_ : DSPF_sp_maxval.h
  • _DSPF_SP_MINERR_H_ : DSPF_sp_minerr.h
  • _DSPF_SP_MINVAL_H_ : DSPF_sp_minval.h
  • _DSPF_SP_VECMUL_H_ : DSPF_sp_vecmul.h
  • _DSPF_SP_VECRECIP_H_ : DSPF_sp_vecrecip.h
  • _DSPF_SP_VECSUM_SQ_H_ : DSPF_sp_vecsum_sq.h
  • _DSPF_SP_W_VEC_H_ : DSPF_sp_w_vec.h

- d -

  • DSPF_BLK_ESWAP16_H_ : c674/DSPF_blk_eswap16.h
  • DSPF_BLK_ESWAP32_H_ : c674/DSPF_blk_eswap32.h
  • DSPF_BLK_ESWAP64_H_ : c674/DSPF_blk_eswap64.h
  • DSPF_sp_BLK_MOVE_H_ : DSPF_sp_blk_move.h , c674/DSPF_sp_blk_move.h


DSPLIB: Data Fields

  • All
  • Functions
  • Defines
  • d

- d -

  • DSPF_blk_eswap16() : c674/DSPF_blk_eswap16.h
  • DSPF_blk_eswap32() : c674/DSPF_blk_eswap32.h
  • DSPF_blk_eswap64() : c674/DSPF_blk_eswap64.h
  • DSPF_fltoq15() : c674/DSPF_fltoq15.h
  • DSPF_q15tofl() : c674/DSPF_q15tofl.h
  • DSPF_sp_autocor() : c674/DSPF_sp_autocor.h
  • DSPF_sp_biquad() : c674/DSPF_sp_biquad.h
  • DSPF_sp_bitrev_cplx() : c674/DSPF_sp_bitrev_cplx.h
  • DSPF_sp_blk_move() : c674/DSPF_sp_blk_move.h
  • DSPF_sp_cfftr2_dit() : c674/DSPF_sp_cfftr2_dit.h
  • DSPF_sp_cfftr4_dif() : c674/DSPF_sp_cfftr4_dif.h
  • DSPF_sp_convol() : c674/DSPF_sp_convol.h
  • DSPF_sp_dotp_cplx() : c674/DSPF_sp_dotp_cplx.h
  • DSPF_sp_dotprod() : c674/DSPF_sp_dotprod.h
  • DSPF_sp_fftSPxSP() : c674/DSPF_sp_fftSPxSP.h
  • DSPF_sp_fir_cplx() : c674/DSPF_sp_fir_cplx.h
  • DSPF_sp_fir_cplx_opt() : c674/DSPF_sp_fir_cplx.h
  • DSPF_sp_fir_gen() : c674/DSPF_sp_fir_gen.h
  • DSPF_sp_fir_r2() : c674/DSPF_sp_fir_r2.h
  • DSPF_sp_fir_r2_opt() : c674/DSPF_sp_fir_r2.h
  • DSPF_sp_fircirc() : c674/DSPF_sp_fircirc.h
  • DSPF_sp_icfftr2_dif() : c674/DSPF_sp_icfftr2_dif.h
  • DSPF_sp_ifftSPxSP() : c674/DSPF_sp_ifftSPxSP.h
  • DSPF_sp_iir() : c674/DSPF_sp_iir.h
  • DSPF_sp_iir_opt() : c674/DSPF_sp_iir.h
  • DSPF_sp_iirlat() : c674/DSPF_sp_iirlat.h
  • DSPF_sp_iirlat_opt() : c674/DSPF_sp_iirlat.h
  • DSPF_sp_lms() : c674/DSPF_sp_lms.h
  • DSPF_sp_mat_mul() : c674/DSPF_sp_mat_mul.h
  • DSPF_sp_mat_mul_cplx() : c674/DSPF_sp_mat_mul_cplx.h
  • DSPF_sp_mat_mul_cplx_opt() : c674/DSPF_sp_mat_mul_cplx.h
  • DSPF_sp_mat_mul_opt() : c674/DSPF_sp_mat_mul.h
  • DSPF_sp_mat_trans() : c674/DSPF_sp_mat_trans.h
  • DSPF_sp_maxidx() : c674/DSPF_sp_maxidx.h
  • DSPF_sp_maxval() : c674/DSPF_sp_maxval.h
  • DSPF_sp_minerr() : c674/DSPF_sp_minerr.h
  • DSPF_sp_minval() : c674/DSPF_sp_minval.h
  • DSPF_sp_vecmul() : c674/DSPF_sp_vecmul.h
  • DSPF_sp_vecrecip() : c674/DSPF_sp_vecrecip.h
  • DSPF_sp_vecsum_sq() : c674/DSPF_sp_vecsum_sq.h
  • DSPF_sp_w_vec() : c674/DSPF_sp_w_vec.h


DSPLIB: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.