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MSP430 Touch Pro Tool 

 

This document describes the MSP430 Touch Pro Tool GUI and its features.   
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1 Overview 

The MSP430 Touch Pro tool is a PC based tool used to verify capacitive touch button, slider and/or 
wheel design(s).   The tool receives and visualizes captouch sensor data to help the user quickly and 
easily evaluate, diagnose, and tune button, slider, and wheel designs. 

Features of Touch Pro tool include: 

 Receive real time data from target board up to 10 signals  

 Points Connected or bar chart display styles for viewing real-time data waveforms 

 User configurable auto-ranging or manual ranging of y-axis  

 Data recording and recall 

 Print waveforms 
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 User selectable individual signal or multi-signal waveform display 

1.1 Touch Pro Tool Revision 

 

V1.00.00.00 Initial release 

V1.10.00.00 Added Bar Chart, plot grid lines, plot signal aliases 

V1.20.00.00 Modified to populate COM port list with all active ports 

2 Hardware and Software Requirements 

The following items are required to run the Touch Pro tool： 

 Microsoft  Windows 7 32_bit or 64_bit operating system 

 USB 1.1-compatible input 

 Java Development Kit, JDK1.5 or greater 

2.1 Hardware 

The MSP430™ Touch Pro Tool can be demonstrated with the MSP430 LaunchPad™ Value Line 
development kit (MSP-EXP430G2) together with the MSP430 Capacitive Touch BoosterPack™ 
(430BOOST-CAPTOUCH) daughterboard.  Both are available for purchase from TI eStore: 

      LaunchPad: https://estore.ti.com/Product3.aspx?ProductId=2031 

BoosterPack: https://estore.ti.com/430BOOST-SENSE1-Capacitive-Touch-BoosterPack-
P2361C42.aspx 

The LaunchPad  kit is connected to a PC or laptop with a mini-USB cable, which is provided with the 
LaunchPad (see Figure 1).  Make sure that all of the jumpers are connected in their default 
configuration.  

 

 
 

http://www.ti.com/tool/msp-exp430g2
http://www.ti.com/tool/430boost-sense1
https://estore.ti.com/Product3.aspx?ProductId=2031
https://estore.ti.com/430BOOST-SENSE1-Capacitive-Touch-BoosterPack-P2361C42.aspx
https://estore.ti.com/430BOOST-SENSE1-Capacitive-Touch-BoosterPack-P2361C42.aspx
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Figure 1.  Hardware Connection 

2.2 Demonstration Projects 

The CCS and IAR source code for the demonstration projects are available in the installation 
package.   

The demo projects require Code Composer Studio™ (CCS) version 5.3 or newer or IAR Embedded 
Workbench®  (IAR) version 5.50 or newer.    

The CCS and IAR projects directory contain two code example files both intended to work with the 
MSP430G2553 microcontroller.  The example that is labeled TouchProTool_Demo_Bit_Banging 
supports the MSP430G2xx2 and MSP430G2xx3 Value Line MSP430 microcontrollers.  The example 
that is labeled TouchProTool_Demo_UART supports only MSP430G2xx3 Value Line MSP430 
microcontrollers, because it requires a UART interface.  The UART module should be wired 
according to the instructions listed in the LaunchPad document.  

After either the CCS or IAR project has been loaded into its respective workspace, connect the 
LaunchPad, with a MSP430G2553 controller, to the host PC and download the firmware.  

3 Launch MSP430 Touch Pro Tool 

The tool can be launched either by double clicking the touchpro.jar file located in the installed 
directory or by selecting the tool in the Windows Start menu. 

3.1 Main window 

When the Touch Pro tool runs, the screen shown in Figure 2 is displayed. 
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Figure 2.  Startup Screen  

The main window (see Figure 2) is divided into four working zones: 

 Main Menu: File, Edit and Help 

 Plot type selection and COM Communication: Select COM, Refresh COM, Pause/Un-pause 
buttons  

 Display Area:  Data display canvas  

 Data Information: Signal, X-Value, Y-Value and distance between two points  

3.2 Communication Setup 

To select the COM port to which the LaunchPad is attached, click the Select COM button.  In the drop 
down menu, select the appropriate COM port for the target device (see Figure 3).  If the COM port is 
not listed in the dropdown menu, click the Refresh COM button and then click Select COM again.   
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           __________________________________________________________________________  

NOTE:  More than one COM port may be listed in the COM window.  To identify the appropriate COM 
port for the Touch Pro Tool, bring up Windows Device Manager and select the COM port with 
the MSP430 Application UART name.   

    __________________________________________________________________________ 

 

Figure 3.  COM Port 

   ______________________________________________________________________ 

 NOTE:  If the COM port cannot be opened, a warning is shown. 

                  ______________________________________________________________________ 

3.2.1 COM open 

When COM port is open, the Select COM  and Refresh COM buttons are disabled and the 
Pause/un-Pause button is enabled.  A legend with checkboxes for selecting and deselecting signals 
is also displayed.   

The tool starts to display data curves when the COM port opens.  The data flow can be paused and 
un-paused without closing the COM port.  

3.2.2 COM closed 

The COM port can be closed in one of two ways; either by selecting to open a history file or by 
exiting the GUI.   

Opening a history file (see Section 3.3.2.2), closes the COM port, enables the Select COM and 
Refresh COM buttons, and disables the Pause/Un-Pause button.    

 With the COM port closed, the tool stops displaying data. 

3.2.3 Pause/Un-Pause 

The data flow can be paused for reviewing or un-paused by clicking the Pause/un-Pause button. 

3.2.4 Refresh COM 

The Refresh Com button repopulates the COM dropdown box with available COM ports.  This allows 
the user to plug in the USB cable while the Touch Pro Tool is open.   The Refresh COM button is 
disabled when a COM port is open, and it is enabled when COM port is closed. 
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3.3 Plot Types 

The tool can display real-time data in two different plot formats, Oscilloscope or Bar Chart. 

 

Figure 4.  Plot type selection  

3.3.1 Oscilloscope 

The Oscilloscope view, displays data for each signal as a continuous line on the plot.  

 

Figure 5.  Oscilloscope plot view 
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3.3.2 Bar Chart 

The Bar Chart view displays the most recent delta value for each signal as a bar. It also provides the 
capability to set a manual threshold value for the displayed signal. 

 

Figure 6.  Bar Chart plot view 

3.4 Data Types 

In the Oscilloscope view, data can be viewed in real-time or historical mode, whereas in Bar Chart 
view, only real-time data can be viewed.  In real time mode, the tool displays data received from the 
COM port in real time.  In historical data mode, data that was previously saved to a CSV file is 
displayed (see Section 3.4.2.1 for details). 
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3.4.1 Real-Time Data Display 

The real-time data display, supported both in Oscilloscope and Bar Chart views, allows the user to 
view data in real time.  When COM port opens, all signals that are sent from the target board are 
displayed.  Data curves or bars can be observed and are displayed in real time in the display area 
(see Figure 5 and Figure 6).  

The user can click on the Pause/Un-Pause button (see Figure 7) to switch between stopping and 
starting of plotting data. In the pause mode, data acquisition and data plotting are stopped.  

 

 

Figure 7. Pause/un-Pause button 

3.4.2 Historical Data Display 

Historical data can be recalled for viewing and analyzing from saved CSV type data files.  Historical 
data display is only supported in the Oscilloscope view. 

3.4.2.1 Saving Data 

To save data, click File->Save or File->Save As.  Data can be saved in real time mode or in pause 
mode.  Data is saved in CSV type formatted files. 

3.4.2.2 Data Recall 

To recall data, click File->Open and select the directory and the desired CSV data file.  Historical 
data can be recalled either in real time mode or in pause mode.    

When a stored data file is opened, the tool automatically closes the COM port.  The display area is 
cleared of all existing data and historical data is displayed. 

3.5 Signal Selection 

The display of each received signal can be individually turned on or off.  To turn on the display of a 
signal, click the checkbox for that signal (see Figure 5).  To turn off the display of a signal, clear the 
checkbox.  To select all signals, click Select All.  To deselect all signals, click Deselect All. When 
the COM port is opened, all signals sent by the target are automatically selected. 

3.6 Signal Alias 

Each plot signal can be assigned a user-defined alias. This can be helpful to map signal numbers to 
meaningful identifiers (see Figure 8). 
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Figure 8. Signal selection and alias 

 

3.7 X and Y Axes Description  

 Y-axis points are data values 

  X-axis points are index counts 

 The y-axis can be labeled.  Click Edit->Display Defaults->Axis Defaults and then enter the label for Y 
Title (see Figure 9). 

 

3.7.1 Auto and Manual Ranging 

If the Y-axis data points vary widely, the values that are displayed can be restricted to a user-defined 
range.   Click Edit->Display Defaults->Axis Defaults and select Manual Ranging Y-Axis (see Figure 9).   
Enter a minimum Y value and a maximum Y value.  The changes to the Y-axis are seen the next time the 
COM port opens.  

The Y-Axis Boundary Settings can be set either during real time data flow or when the data flow is 
paused.  The manual range’s minimum and maximum values are stored when tool closes.  However, 
Auto Ranging Y-Axis is the default setting that is used by the tool when it is opened.  To apply the manual 
range values to the Y-axis after re-starting the tool, select Manual Ranging Y-Axis again.  
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Figure 9. Display Chart Ranging (Axis Defaults Tab) 

3.8 Display Chart Styles 

Two styles of display charts are available:   Points Connected and Bar Chart.  To select the chart type, 
click Edit->Display Defaults->Plot Defaults and select either Points Connected or Bar (see Figure 10).   

3.9 Display Chart Grid Lines 

The user can select to display the horizontal and vertical grid lines by selecting Edit->Display Defaults-
>Plot Defaults window. (see Figure 10).  
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Figure 10. Display Chart Styles (Plot Defaults Tab) 

3.10 Data Protocol Between MCU and Touch Pro Tool 

For Touch Pro tool to display data, the user application must send data in a defined format.  The data 
frame definition of the UART protocol that the Touch Pro Tool expects from the target MCU is show in 
Figure 11:  

 

Figure 11. Data Frame Definition 

 

Frame Header: This is a fixed value. The value is always 0x55 + 0xAA 

Length: Indicates total number of bytes following the frame header bytes. 

   Length = 3 * Signal Numbers + 1. 

For example, when there is only 1 signal of data to send, the length will be 3*1 + 1 = 4 and 
for 5 signals of data, the length will be 3*5 + 1 =16. 

The one is added to the length to account for the checksum byte 

Each signal number is multiplied by 3 to account for Signal number, high order byte and low 
order byte. 

CH#:  Valid signal numbers range from 0 to 9. That means a total of 10 signals can be observed by 
Touch Pro Tool.  
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Frame Length 

Data Field 

Checksum 

High Byte: High 8-bit data of the signal data. 

Low Byte: Low 8-bit data of the signal data. 

CheckSum: Low byte of the value derived from the sum of header bytes, frame length, signal number 
and data bytes. The GUI will ignore the data package if checksum is wrong 

   For example, if the data frame is the following: 

0x55 0xAA 0x0A 0x01 0x0 0x0A 0x14

 

  
   

 
Data Frame total = 55+AA+0A+01+0+0A = 114 
Checksum = 14  

Data is sent at a fixed rate of 9600 baud. 
 

3.11 Waveform Operations 

The following operations can be performed on the displayed waveforms: 

 Zoom in and zoom out 

 Show point values 

 Show distance between points 

 Print 
 

3.11.1 Zoom In and Zoom Out 

Zoom in and zoom out are possible while data flow is paused or during data recall.  

To zoom into a waveform, press and hold the left mouse button and draw a box from top to bottom 
around the area of interest.  To zoom out partially, press and hold the left mouse button and draw a 
box from bottom to top around the area of interest. To zoom out fully, click the right mouse button.  

3.11.2 Show Points Values 

The X and Y points value is displayed in the Data Information zone of the GUI.  When the cursor is 
over a point in the display, the corresponding signal number, X value, and Y value are listed in the 
boxes labeled Signal, X, and Y, respectively.   Figure 12 shows an example point value.  

Frame Header 



                                                                         SLAU486A-January 2013-Revised September 2014  

____________________________________________________________________________________________________ 
SLAU486A-January 2013-Revised September 2014                                                                           MSP430 Touch Pro Tool        13 
 

Copyright © 2013, Texas Instruments Incorporated 

 

Figure 12.  Show Points Values 

 

3.11.3 Show Difference Between Points 

To calculate the difference between two point values:  select the first point, press and hold the right 
mouse button, drag the line that appears to the second point, and release the button.  

The boxes labeled DX and DY show the difference between the two point values in the X and Y 
coordinates.  

3.11.4 Print Waveforms 

To print the waveforms that are shown in the display area of the tool, pause the data flow and then 
click File->Print.   

3.11.5 Clear Display 

To clear the display of waveforms, click Edit->Clear.   The display can be cleared in real time or 
when data flow is paused.   

3.11.6 Reset Axes 

To reset axes after zooming in, click Edit->Reset Axes.  The display resets the x and y axes values 
to the values prior to the zoom in. 


