LPM:

  • Main Page
  • Modules
  • Files
  • Directories
  • Related Pages
disclaimer.html
IMPORTANT NOTICE
Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are sold subject to TI's terms and conditions of sale supplied at the time of order acknowledgment.
TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI's standard warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government requirements, testing of all parameters of each product is not necessarily performed.
TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI regarding third party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of that third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for such altered documentation.
Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.
Mailing Address:
Texas Instruments
Post Office Box 655303
Dallas, Texas 75265
Copyright 2011, Texas Instruments Incorporated


LPM: Module Index

  • Directories
  • Related Pages

Modules

Here is a list of all modules:
  • Shared Definitions


LPM: Shared Definitions

Shared Definitions

All Files Functions Typedefs


LPM: File Index

  • File List
  • Globals

File List

Here is a list of all files with brief descriptions:
dm6446/lpm/lpm_driver.h [code]
dm6446/ocvc/lpm_driver.h [code]
omap2530/lpm/lpm_driver.h [code]
omap3530/lpm/lpm_driver.h [code]
All Files Functions Typedefs


LPM: lpm_driver.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • dm6446
  • lpm
Typedefs | Functions

dm6446/lpm/lpm_driver.h File Reference

Go to the source code of this file.

Typedefs

typedef void(* | LPM_ExtPwrFxn )(void *arg)
Function typedef of the functions which control the external power supply.

Functions

int | lpm_regExtOffFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power off function.
int | lpm_regExtOnFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power on function.

Typedef Documentation

typedef void(* LPM_ExtPwrFxn)(void *arg)

Function typedef of the functions which control the external power supply.

Function Documentation

int lpm_regExtOffFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power off function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.
int lpm_regExtOnFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power on function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.


LPM: lpm_driver.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • dm6446
  • ocvc
Typedefs | Functions

dm6446/ocvc/lpm_driver.h File Reference

Go to the source code of this file.

Typedefs

typedef void(* | LPM_ExtPwrFxn )(void *arg)
Function typedef of the functions which control the external power supply.

Functions

int | lpm_regExtOffFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power off function.
int | lpm_regExtOnFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power on function.

Typedef Documentation

typedef void(* LPM_ExtPwrFxn)(void *arg)

Function typedef of the functions which control the external power supply.

Function Documentation

int lpm_regExtOffFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power off function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.
int lpm_regExtOnFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power on function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.


LPM: lpm_driver.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • omap2530
  • lpm
Typedefs | Functions

omap2530/lpm/lpm_driver.h File Reference

Go to the source code of this file.

Typedefs

typedef void(* | LPM_ExtPwrFxn )(void *arg)
Function typedef of the functions which control the external power supply.

Functions

int | lpm_regExtOffFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power off function.
int | lpm_regExtOnFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power on function.

Typedef Documentation

typedef void(* LPM_ExtPwrFxn)(void *arg)

Function typedef of the functions which control the external power supply.

Function Documentation

int lpm_regExtOffFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power off function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.
int lpm_regExtOnFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power on function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.


LPM: lpm_driver.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • omap3530
  • lpm
Typedefs | Functions

omap3530/lpm/lpm_driver.h File Reference

Go to the source code of this file.

Typedefs

typedef void(* | LPM_ExtPwrFxn )(void *arg)
Function typedef of the functions which control the external power supply.

Functions

int | lpm_regExtOffFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power off function.
int | lpm_regExtOnFxn (char *device, LPM_ExtPwrFxn fxn, void *arg)
Register an external power on function.

Typedef Documentation

typedef void(* LPM_ExtPwrFxn)(void *arg)

Function typedef of the functions which control the external power supply.

Function Documentation

int lpm_regExtOffFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power off function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.
int lpm_regExtOnFxn | ( | char * | device,
 |  | LPM_ExtPwrFxn | fxn,
 |  | void * | arg
 | ) |  |

Register an external power on function.

Parameters:
[in] | device | Linux device name.
[in] | fxn | A function address which will turn off the external power supply to the DSP Power Domain.
[in] | arg | An argument passed to the callback function.
Return values:
0 | The function was successfully registered.
-1 | The given device name was not found.


LPM: Directory Hierarchy

Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • packages
    • ti
      • bios
        • power
          • modules
            • dm6446
              • lpm
              • ocvc
            • omap2530
              • lpm
            • omap3530
              • lpm


LPM: packages/ Directory Reference

  • packages

packages Directory Reference

Directory dependency graph for packages/:

Directories

directory ti


LPM: packages/ti/ Directory Reference

  • ti

ti Directory Reference

Directory dependency graph for packages/ti/:

Directories

directory bios


LPM: packages/ti/bios/ Directory Reference

  • ti
  • bios

bios Directory Reference

Directory dependency graph for packages/ti/bios/:

Directories

directory power


LPM: packages/ti/bios/power/ Directory Reference

  • ti
  • bios
  • power

power Directory Reference

Directory dependency graph for packages/ti/bios/power/:

Directories

directory modules


LPM: packages/ti/bios/power/modules/ Directory Reference

  • ti
  • bios
  • power
  • modules

modules Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/:

Directories

directory | dm6446
directory | omap2530
directory | omap3530


LPM: packages/ti/bios/power/modules/dm6446/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • dm6446

dm6446 Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/dm6446/:

Directories

directory | lpm
directory | ocvc


LPM: packages/ti/bios/power/modules/dm6446/lpm/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • dm6446
  • lpm

lpm Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/dm6446/lpm/:

Files

file dm6446/lpm/lpm_driver.h [code]


LPM: packages/ti/bios/power/modules/dm6446/ocvc/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • dm6446
  • ocvc

ocvc Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/dm6446/ocvc/:

Files

file dm6446/ocvc/lpm_driver.h [code]


LPM: packages/ti/bios/power/modules/omap2530/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • omap2530

omap2530 Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/omap2530/:

Directories

directory lpm


LPM: packages/ti/bios/power/modules/omap2530/lpm/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • omap2530
  • lpm

lpm Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/omap2530/lpm/:

Files

file omap2530/lpm/lpm_driver.h [code]


LPM: packages/ti/bios/power/modules/omap3530/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • omap3530

omap3530 Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/omap3530/:

Directories

directory lpm


LPM: packages/ti/bios/power/modules/omap3530/lpm/ Directory Reference

  • ti
  • bios
  • power
  • modules
  • omap3530
  • lpm

lpm Directory Reference

Directory dependency graph for packages/ti/bios/power/modules/omap3530/lpm/:

Files

file omap3530/lpm/lpm_driver.h [code]


LPM: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:
  • LPM_ExtPwrFxn : dm6446/lpm/lpm_driver.h , dm6446/ocvc/lpm_driver.h , omap3530/lpm/lpm_driver.h , omap2530/lpm/lpm_driver.h
  • lpm_regExtOffFxn() : omap3530/lpm/lpm_driver.h , dm6446/lpm/lpm_driver.h , omap2530/lpm/lpm_driver.h , dm6446/ocvc/lpm_driver.h
  • lpm_regExtOnFxn() : dm6446/lpm/lpm_driver.h , omap2530/lpm/lpm_driver.h , dm6446/ocvc/lpm_driver.h , omap3530/lpm/lpm_driver.h


LPM: disclaimer.dox File Reference

  • File List
  • Globals

disclaimer.dox File Reference

All Files Functions Typedefs


LPM: lpm_driver.h Source File

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • dm6446
  • lpm

dm6446/lpm/lpm_driver.h

Go to the documentation of this file.
00001 /*
00002  *  Copyright 2011 by Texas Instruments Incorporated.
00003  *
00004  *  This program is free software: you can redistribute it and/or modify
00005  *  it under the terms of the GNU General Public License as published by
00006  *  the Free Software Foundation; version 2 of the License.
00007  *
00008  *  This program is distributed in the hope that it will be useful,
00009  *  but WITHOUT ANY WARRANTY; without even the implied warranty of
00010  *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00011  *  GNU General Public License for more details.
00012  *
00013  *  You should have received a copy of the GNU General Public License
00014  *  along with this program.  If not, see <http://www.gnu.org/licenses/>
00015  *
00016  */
00017
00018 /*
00019  *  ======== lpm_driver.h ========
00020  *
00021  */
00022
00023
00038 typedef void (*LPM_ExtPwrFxn)(void *arg);
00039
00040
00053 extern int lpm_regExtOffFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00054
00055
00068 extern int lpm_regExtOnFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00069 /*
00070  *  @(#) ti.bios.power; 1, 1, 1,1; 12-9-2011 14:12:58; /db/atree/library/trees/power/power-g11x/src/ xlibrary
00071
00072  */
00073


LPM: lpm_driver.h Source File

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • dm6446
  • ocvc

dm6446/ocvc/lpm_driver.h

Go to the documentation of this file.
00001 /*
00002  *  Copyright 2011 by Texas Instruments Incorporated.
00003  *
00004  *  This program is free software: you can redistribute it and/or modify
00005  *  it under the terms of the GNU General Public License as published by
00006  *  the Free Software Foundation; version 2 of the License.
00007  *
00008  *  This program is distributed in the hope that it will be useful,
00009  *  but WITHOUT ANY WARRANTY; without even the implied warranty of
00010  *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00011  *  GNU General Public License for more details.
00012  *
00013  *  You should have received a copy of the GNU General Public License
00014  *  along with this program.  If not, see <http://www.gnu.org/licenses/>
00015  *
00016  */
00017
00018 /*
00019  *  ======== lpm_driver.h ========
00020  *
00021  */
00022
00023
00038 typedef void (*LPM_ExtPwrFxn)(void *arg);
00039
00040
00053 extern int lpm_regExtOffFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00054
00055
00068 extern int lpm_regExtOnFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00069 /*
00070  *  @(#) ti.bios.power; 1, 1, 1,1; 12-9-2011 14:12:58; /db/atree/library/trees/power/power-g11x/src/ xlibrary
00071
00072  */
00073


LPM: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • lpm_regExtOffFxn() : dm6446/lpm/lpm_driver.h , dm6446/ocvc/lpm_driver.h , omap3530/lpm/lpm_driver.h , omap2530/lpm/lpm_driver.h
  • lpm_regExtOnFxn() : dm6446/lpm/lpm_driver.h , omap3530/lpm/lpm_driver.h , dm6446/ocvc/lpm_driver.h , omap2530/lpm/lpm_driver.h


LPM: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • LPM_ExtPwrFxn : dm6446/lpm/lpm_driver.h , omap3530/lpm/lpm_driver.h , omap2530/lpm/lpm_driver.h , dm6446/ocvc/lpm_driver.h


LPM: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


LPM: Main Page

LPM Documentation

power-g11

All Files Functions Typedefs


LPM: lpm_driver.h Source File

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • omap2530
  • lpm

omap2530/lpm/lpm_driver.h

Go to the documentation of this file.
00001 /*
00002  *  Copyright 2011 by Texas Instruments Incorporated.
00003  *
00004  *  This program is free software: you can redistribute it and/or modify
00005  *  it under the terms of the GNU General Public License as published by
00006  *  the Free Software Foundation; version 2 of the License.
00007  *
00008  *  This program is distributed in the hope that it will be useful,
00009  *  but WITHOUT ANY WARRANTY; without even the implied warranty of
00010  *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00011  *  GNU General Public License for more details.
00012  *
00013  *  You should have received a copy of the GNU General Public License
00014  *  along with this program.  If not, see <http://www.gnu.org/licenses/>
00015  *
00016  */
00017
00018 /*
00019  *  ======== lpm_driver.h ========
00020  *
00021  */
00022
00023
00038 typedef void (*LPM_ExtPwrFxn)(void *arg);
00039
00040
00053 extern int lpm_regExtOffFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00054
00055
00068 extern int lpm_regExtOnFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00069 /*
00070  *  @(#) ti.bios.power; 1, 1, 1,1; 12-9-2011 14:12:58; /db/atree/library/trees/power/power-g11x/src/ xlibrary
00071
00072  */
00073


LPM: lpm_driver.h Source File

  • File List
  • Globals
  • packages
  • ti
  • bios
  • power
  • modules
  • omap3530
  • lpm

omap3530/lpm/lpm_driver.h

Go to the documentation of this file.
00001 /*
00002  *  Copyright 2011 by Texas Instruments Incorporated.
00003  *
00004  *  This program is free software: you can redistribute it and/or modify
00005  *  it under the terms of the GNU General Public License as published by
00006  *  the Free Software Foundation; version 2 of the License.
00007  *
00008  *  This program is distributed in the hope that it will be useful,
00009  *  but WITHOUT ANY WARRANTY; without even the implied warranty of
00010  *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00011  *  GNU General Public License for more details.
00012  *
00013  *  You should have received a copy of the GNU General Public License
00014  *  along with this program.  If not, see <http://www.gnu.org/licenses/>
00015  *
00016  */
00017
00018 /*
00019  *  ======== lpm_driver.h ========
00020  *
00021  */
00022
00023
00038 typedef void (*LPM_ExtPwrFxn)(void *arg);
00039
00040
00053 extern int lpm_regExtOffFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00054
00055
00068 extern int lpm_regExtOnFxn(char *device, LPM_ExtPwrFxn fxn, void *arg);
00069 /*
00070  *  @(#) ti.bios.power; 1, 1, 1,1; 12-9-2011 14:12:59; /db/atree/library/trees/power/power-g11x/src/ xlibrary
00071
00072  */
00073


LPM: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Disclaimer