Codec Engine System Programming Interface (SPI): Codec Engine SPI Reference

  • Main Page
  • Modules
  • Data Structures
  • Files
  • Directories
  • Related Pages

Codec Engine SPI Reference

ce-s19

Modules

The Codec Engine SPI is partitioned into a several modules:

  • The SPI for algorithm class interfaces.
  • The SPI for algorithm class stubs.
  • The SPI for algorithm class skeletons.
  • A generic set of SPI routines used by several of the above.

Additionally, there are several utility modules provided:

  • Memory - provides services to manage memory is OS independent environments. Also provides the ability to manage contiguous buffers meeting various alignment constraints.
Copyright 2011, Texas Instruments Incorporated


Codec Engine System Programming Interface (SPI):

  • Files
  • Directories
  • Related Pages
disclaimer.html
IMPORTANT NOTICE
Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are sold subject to TI's terms and conditions of sale supplied at the time of order acknowledgment.
TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI's standard warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government requirements, testing of all parameters of each product is not necessarily performed.
TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI regarding third party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of that third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for such altered documentation.
Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.
Mailing Address:
Texas Instruments
Post Office Box 655303
Dallas, Texas 75265


Codec Engine System Programming Interface (SPI): Todo List

Todo List

Global Engine_DllAlgDesc::codecClassConfig
Figure out what this is.


Codec Engine System Programming Interface (SPI): Deprecated List

Deprecated List

Global Engine_ATTRS
Engine_ATTRS is no longer recommended. Please use Engine_initAttrs() instead.

Global Engine_getUsedMem (Engine_Handle engine)
This service has been replaced by Server_getMemStat() to better indicate that this API is not intended for obtaining the current processor's memory statistics, rather it obtains the memory statistics of a remote Server. Also, Server_getMemStat() provides more granularity than Engine_getUsedMem().

Global ti_sdo_ce_osal_Memory_contigAlloc (UInt size, UInt align)
This function has been superceded by ti_sdo_ce_osal_Memory_alloc() and will be removed in a future release. Users are recommended to modify their applications to use the new, more flexible ti_sdo_ce_osal_Memory_alloc() instead.


Codec Engine System Programming Interface (SPI): Module Index

Modules

Here is a list of all modules:
  • IALG - XDAIS Algorithm Interface
  • Memory - OS Independent Memory Interface
  • XDAIS Types and Constants
  • Codec Engine Runtime
  • CE Skeleton SPI
  • VISA - Alg-independent user APIs
  • VISA - CE Stub SPIs
  • VISA - CE interface SPIs


Codec Engine System Programming Interface (SPI): IALG - XDAIS Algorithm Interface

Data Structures | Defines | Typedefs | Enumerations

IALG - XDAIS Algorithm Interface

Data Structures

struct | IALG_MemRec
Memory records. More...
struct | IALG_Obj
Algorithm instance object definition. More...
struct | IALG_Params
Algorithm instance creation parameters. More...
struct | IALG_Status
Pointer to algorithm specific status structure. More...
struct | IALG_Fxns
Defines the fields and methods that must be supplied by all XDAIS algorithms. More...

Defines

#define | IALG_DEFMEMRECS 4
#define | IALG_OBJMEMREC 0
#define | IALG_SYSCMD 256
#define | IALG_EOK 0
#define | IALG_EFAIL -1
#define | IALG_CUSTOMFAILBASE -2048
#define | IALG_CUSTOMFAILEND -256
#define | IALG_MPROG 0x0008
#define | IALG_MXTRN 0x0010
#define | IALG_isProg(s)
#define | IALG_isOffChip(s)

Typedefs

typedef enum IALG_MemAttrs | IALG_MemAttrs
Memory attributes.
typedef enum IALG_MemSpace | IALG_MemSpace
Defined memory spaces.
typedef struct IALG_MemRec | IALG_MemRec
Memory records.
typedef struct IALG_Obj | IALG_Obj
Algorithm instance object definition.
typedef struct IALG_Obj * | IALG_Handle
Handle to an algorithm instance object.
typedef struct IALG_Params | IALG_Params
Algorithm instance creation parameters.
typedef struct IALG_Status | IALG_Status
Pointer to algorithm specific status structure.
typedef unsigned int | IALG_Cmd
Algorithm specific command.
typedef struct IALG_Fxns | IALG_Fxns
Defines the fields and methods that must be supplied by all XDAIS algorithms.

Enumerations

enum IALG_MemAttrs {
IALG_SCRATCH,
IALG_PERSIST,
IALG_WRITEONCE
}

Memory attributes.

More...
enum IALG_MemSpace {
IALG_EPROG,
IALG_IPROG,
IALG_ESDATA,
IALG_EXTERNAL,
IALG_DARAM0 = 0,
IALG_DARAM1 = 1,
IALG_SARAM = 2,
IALG_SARAM0 = 2,
IALG_SARAM1 = 3,
IALG_DARAM2 = 4,
IALG_SARAM2 = 5
}

Defined memory spaces.

More...

Detailed Description

This is the XDAIS IALG interface.

Define Documentation

#define IALG_DEFMEMRECS 4

Default number of memory records.

#define IALG_OBJMEMREC 0

Memory record index of instance object.

#define IALG_SYSCMD 256

Minimum "system" IALG_Cmd value.

#define IALG_EOK 0

Successful return status code.

#define IALG_EFAIL -1

Unspecified error return status code.

#define IALG_CUSTOMFAILBASE -2048

Algorithm-specific failure code end.

Remarks:
This is 0xfffff800.
#define IALG_CUSTOMFAILEND -256

Algorithm-specific failure code base.

Remarks:
This is 0xffffff00.
#define IALG_MPROG 0x0008

Program memory space bit.

#define IALG_MXTRN 0x0010

External memory space bit.

#define IALG_isProg ( s )
Value:
(        \
    (((int)(s)) & IALG_MPROG)   \
)
#define IALG_isOffChip ( s )
Value:
(     \
    (((int)(s)) & IALG_MXTRN)   \
)

Typedef Documentation

typedef enum IALG_MemAttrs IALG_MemAttrs

Memory attributes.

typedef enum IALG_MemSpace IALG_MemSpace

Defined memory spaces.

typedef struct IALG_MemRec IALG_MemRec

Memory records.

typedef struct IALG_Obj IALG_Obj

Algorithm instance object definition.

Remarks:
All XDAIS algorithm instance objects must have this structure as their first element. However, they do not need to initialize it; initialization of this sub-structure is done by the "framework".
typedef struct IALG_Obj* IALG_Handle

Handle to an algorithm instance object.

typedef struct IALG_Params IALG_Params

Algorithm instance creation parameters.

Remarks:
All XDAS algorithm parameter structures must have this as their first element.
typedef struct IALG_Status IALG_Status

Pointer to algorithm specific status structure.

Remarks:
All XDAIS algorithm parameter structures must have this as their first element.
typedef unsigned int IALG_Cmd

Algorithm specific command.

Remarks:
This command is used in conjunction with IALG_Status to get and set algorithm specific attributes via the algControl() method.
typedef struct IALG_Fxns IALG_Fxns

Defines the fields and methods that must be supplied by all XDAIS algorithms.

Enumeration Type Documentation

enum IALG_MemAttrs

Memory attributes.

Enumerator:
IALG_SCRATCH

Scratch memory.

IALG_PERSIST

Persistent memory.

IALG_WRITEONCE

Write-once persistent memory.

enum IALG_MemSpace

Defined memory spaces.

Enumerator:
IALG_EPROG

External program memory Program memory space bit. External memory space bit.

IALG_IPROG

Internal program memory Program memory space bit.

IALG_ESDATA

Off-chip data memory (accessed sequentially) External memory space bit.

IALG_EXTERNAL

Off-chip data memory (accessed randomly) External memory space bit.

IALG_DARAM0

Dual access on-chip data memory

IALG_DARAM1

Block 1, if independant blocks required

IALG_SARAM

Single access on-chip data memory

IALG_SARAM0

Block 0, equivalent to IALG_SARAM

IALG_SARAM1

Block 1, if independant blocks required

IALG_DARAM2

Block 2, if a 3rd independent block required

IALG_SARAM2

Block 2, if a 3rd independent block required


Codec Engine System Programming Interface (SPI): Memory - OS Independent Memory Interface

Data Structures | Defines | Typedefs | Enumerations | Functions | Variables

Memory - OS Independent Memory Interface

Data Structures

struct | ti_sdo_ce_osal_Memory_AllocParams
Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free() More...

Defines

#define | ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT ((UInt)(-1))
Default Alignment.
#define | Memory_MODNAME "ti.sdo.ce.osal.Memory"
Name to pass to Diags_setMask() to enable logging for Memory functions. For example, Diags_setMask(Memory_MODNAME"+EX1234567"); turns on all Log statements in this module. Diags_setMask() must be called after initialization to take effect.
#define | ti_sdo_ce_osal_Memory_GTNAME "OM"
GT name containing the trace mask for this module.
#define | ti_sdo_ce_osal_Memory_CACHED 0x00000000
Cached allocation.
#define | ti_sdo_ce_osal_Memory_NONCACHED 0x00000001
Non-cached allocation.
#define | ti_sdo_ce_osal_Memory_CACHEDMASK 0x00000001
Mask to isolate cache flag.

Typedefs

typedef struct
ti_sdo_ce_osal_Memory_AllocParams 		ti_sdo_ce_osal_Memory_AllocParams
Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()

Enumerations

enum ti_sdo_ce_osal_Memory_type {
ti_sdo_ce_osal_Memory_MALLOC = 0,
ti_sdo_ce_osal_Memory_SEG = 1,
ti_sdo_ce_osal_Memory_CONTIGPOOL = 2,
ti_sdo_ce_osal_Memory_CONTIGHEAP = 3
}

Enum values for ti_sdo_ce_osal_Memory_AllocParams.type.

More...

Functions

Ptr | ti_sdo_ce_osal_Memory_alloc (UInt size, ti_sdo_ce_osal_Memory_AllocParams *params)
General memory allocation.
Void | ti_sdo_ce_osal_Memory_cacheInv (Ptr addr, Int sizeInBytes)
Invalidate a range of cache.
Void | ti_sdo_ce_osal_Memory_cacheWb (Ptr addr, Int sizeInBytes)
Write back cache.
Void | ti_sdo_ce_osal_Memory_cacheWbInv (Ptr addr, Int sizeInBytes)
Write back and invalidate cache.
Void | ti_sdo_ce_osal_Memory_cacheWbInvAll ()
Write back and invalidate the entire cache. Not supported yet on all OS's.
Ptr | ti_sdo_ce_osal_Memory_contigAlloc (UInt size, UInt align)
Allocate physically contiguous blocks of memory.
Bool | ti_sdo_ce_osal_Memory_contigFree (Ptr addr, UInt size)
Free memory allocated by ti_sdo_ce_osal_Memory_contigAlloc()
Bool | ti_sdo_ce_osal_Memory_free (Ptr addr, UInt size, ti_sdo_ce_osal_Memory_AllocParams *params)
Free memory allocated with ti_sdo_ce_osal_Memory_alloc().
Void | ti_sdo_ce_osal_Memory_dumpKnownContigBufsList (Void)
Dumps the list of all translated/registered bufs.
UInt32 | ti_sdo_ce_osal_Memory_getBufferPhysicalAddress (Ptr virtualAddress, Int sizeInBytes, Bool *isContiguous)
Converts application virtual address to a physical address.
Int | ti_sdo_ce_osal_Memory_getHeapId (String name)
Get the heap heap ID corresponding to a heap name. This number will be between 0 and the value returned by ti_sdo_ce_osal_Memory_getNumHeaps(). The heap Id can be passed to ti_sdo_ce_osal_Memory_redefine() and ti_sdo_ce_osal_Memory_restoreHeap().
Int | ti_sdo_ce_osal_Memory_getNumHeaps ()
Get the number of memory heaps.
Ptr | ti_sdo_ce_osal_Memory_getBufferVirtualAddress (UInt32 physicalAddress, Int sizeInBytes)
Obtains the virtual address of a physically contiguous buffer.
Void | ti_sdo_ce_osal_Memory_registerContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes, UInt32 physicalAddress)
Register a physical buffer allocated without ti_sdo_ce_osal_Memory_contigAlloc()
Void | ti_sdo_ce_osal_Memory_unregisterContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes)
Unregisters a physical buffer allocated without ti_sdo_ce_osal_Memory_contigAlloc().

Variables

ti_sdo_ce_osal_Memory_AllocParams ti_sdo_ce_osal_Memory_DEFAULTPARAMS
Default parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()

Detailed Description

This Memory module provides services to manage memory in OS independent environments.

Package Prefix

In order to avoid global namespace collisions, this module prefixes all its exports with the globally unique package name it's contained in (ti_sdo_ce_osal). As a usability feature (and to remain backward compatible with previous releases), these exports are also made available via the more traditional 'short' name - without the package name prefix.

For example, although the actual export may be named 'ti_sdo_ce_osal_Memory_alloc', it's generally usable via the shorter name 'Memory_alloc'. In the rare case where a namespace collision occurs, users can disable the definitions of the 'short' name by defining the symbol 'ti_sdo_ce_osal_Memory__nolocalnames' before including this module's header. For example:

 #define ti_sdo_ce_osal_Memory__nolocalnames
 #include <ti/sdo/ce/osal/Memory.h>

This follows the same approach the XDCtools takes, and further explaination is available here: http://rtsc.eclipse.org/docs-tip/Integrating_RTSC_Modules#Eliminating_Identifier_Conflicts.

Define Documentation

#define ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT ((UInt)(-1))

Default Alignment.

Remarks:
This definition also has a short name alias of Memory_DEFAULTALIGNMENT.
See also:
ti_sdo_ce_osal_Memory_AllocParams.align
#define Memory_MODNAME "ti.sdo.ce.osal.Memory"

Name to pass to Diags_setMask() to enable logging for Memory functions. For example, Diags_setMask(Memory_MODNAME"+EX1234567"); turns on all Log statements in this module. Diags_setMask() must be called after initialization to take effect.

#define ti_sdo_ce_osal_Memory_GTNAME "OM"

GT name containing the trace mask for this module.

Remarks:
This definition also has a short name alias of Memory_GTNAME.
#define ti_sdo_ce_osal_Memory_CACHED 0x00000000

Cached allocation.

Remarks:
This definition also has a short name alias of Memory_CACHED.
See also:
ti_sdo_ce_osal_Memory_AllocParams.flags
#define ti_sdo_ce_osal_Memory_NONCACHED 0x00000001

Non-cached allocation.

Remarks:
This definition also has a short name alias of Memory_NONCACHED.
See also:
ti_sdo_ce_osal_Memory_AllocParams.flags
#define ti_sdo_ce_osal_Memory_CACHEDMASK 0x00000001

Mask to isolate cache flag.

Remarks:
This definition also has a short name alias of Memory_NONCACHEDMASK.
See also:
ti_sdo_ce_osal_Memory_AllocParams.flags

Typedef Documentation

typedef struct ti_sdo_ce_osal_Memory_AllocParams ti_sdo_ce_osal_Memory_AllocParams

Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()

Remarks:
This definition also has a short name alias of Memory_AllocParams.
See also:
ti_sdo_ce_osal_Memory_DEFAULTPARAMS

Enumeration Type Documentation

enum ti_sdo_ce_osal_Memory_type

Enum values for ti_sdo_ce_osal_Memory_AllocParams.type.

Remarks:
This definition also has a short name alias of Memory_type.
See also:
ti_sdo_ce_osal_Memory_AllocParams
Enumerator:
ti_sdo_ce_osal_Memory_MALLOC

malloc()-based allocation

Remarks:
This definition also has a short name alias of Memory_MALLOC.
ti_sdo_ce_osal_Memory_SEG

DSP/BIOS segment-based allocation

Remarks:
This definition also has a short name alias of Memory_SEG.
ti_sdo_ce_osal_Memory_CONTIGPOOL

Contiguous, pool-based allocation

Remarks:
This definition also has a short name alias of Memory_CONTIGPOOL.
ti_sdo_ce_osal_Memory_CONTIGHEAP

Contiguous, heap-based allocation

Remarks:
This definition also has a short name alias of Memory_CONTIGHEAP.

Function Documentation

Ptr ti_sdo_ce_osal_Memory_alloc | ( | UInt | size,
 |  | ti_sdo_ce_osal_Memory_AllocParams * | params
 | ) |  |

General memory allocation.

Parameters:
[in] | size | Number of bytes to allocate.
[in] | params | Parameters controlling the allocation.
Remarks:
This definition also has a short name alias of Memory_alloc.
Return values:
NULL | The memory request failed.
non-NULL | The pointer to a buffer containing the requested memory.
See also:
ti_sdo_ce_osal_Memory_free()
ti_sdo_ce_osal_Memory_contigAlloc()
Void ti_sdo_ce_osal_Memory_cacheInv | ( | Ptr | addr,
 |  | Int | sizeInBytes
 | ) |  |

Invalidate a range of cache.

Parameters:
[in] | addr | Address of the beginning of the buffer to invalidate.
[in] | sizeInBytes | Size of the buffer to invalidate.
Remarks:
In addition to application usage, this is often called by a skeleton implementor after it has received a shared memory buffer from another processor, and before it invokes an algorithm's interface which will operate on that shared memory buffer.
This definition also has a short name alias of Memory_cacheInv.
See also:
ti_sdo_ce_osal_Memory_cacheWb()
ti_sdo_ce_osal_Memory_cacheWbInv()
Void ti_sdo_ce_osal_Memory_cacheWb | ( | Ptr | addr,
 |  | Int | sizeInBytes
 | ) |  |

Write back cache.

Parameters:
[in] | addr | Address of the beginning of the buffer to writeback.
[in] | sizeInBytes | Size of the buffer to writeback.
Remarks:
This definition also has a short name alias of Memory_cacheWb.
See also:
ti_sdo_ce_osal_Memory_cacheInv()
ti_sdo_ce_osal_Memory_cacheWbInv()
Void ti_sdo_ce_osal_Memory_cacheWbInv | ( | Ptr | addr,
 |  | Int | sizeInBytes
 | ) |  |

Write back and invalidate cache.

Parameters:
[in] | addr | Address of the beginning of the buffer to writeback and invalidate.
[in] | sizeInBytes | Size of the buffer to writeback invalidate.
Remarks:
This definition also has a short name alias of Memory_cacheWbInv.
See also:
ti_sdo_ce_osal_Memory_cacheInv()
ti_sdo_ce_osal_Memory_cacheWb()
Void ti_sdo_ce_osal_Memory_cacheWbInvAll ( )

Write back and invalidate the entire cache. Not supported yet on all OS's.

Remarks:
This definition also has a short name alias of Memory_cacheWbInvAll.
See also:
ti_sdo_ce_osal_Memory_cacheInv()
ti_sdo_ce_osal_Memory_cacheWb()
ti_sdo_ce_osal_Memory_cacheWbInv()
Ptr ti_sdo_ce_osal_Memory_contigAlloc | ( | UInt | size,
 |  | UInt | align
 | ) |  |

Allocate physically contiguous blocks of memory.

Deprecated:
This function has been superceded by ti_sdo_ce_osal_Memory_alloc() and will be removed in a future release. Users are recommended to modify their applications to use the new, more flexible ti_sdo_ce_osal_Memory_alloc() instead.
Parameters:
[in] | size | Size of the buffer to allocate.
[in] | align | Alignment of the buffer; must be divisible by a power of two.
Precondition:
align must be divisible by a power of two.
Remarks:
This definition also has a short name alias of Memory_contigAlloc.
Return values:
non-NULL | Address of a physically contiguous buffer.
NULL | Unable to obtain the requested buffer.
Remarks:
This is commonly called by an application wishing to obtain a physically contiguous buffer which it must share with another processor.
For portability reasons, applications commonly use this API even in environments which do not have virtual memory or an MMU (e.g. a single processor, DSP/BIOS based system). Doing so makes them portable to environments which do have to provide physically contiguous memory to remote processors.
See also:
ti_sdo_ce_osal_Memory_alloc()
ti_sdo_ce_osal_Memory_contigFree()
Bool ti_sdo_ce_osal_Memory_contigFree | ( | Ptr | addr,
 |  | UInt | size
 | ) |  |

Free memory allocated by ti_sdo_ce_osal_Memory_contigAlloc()

Parameters:
[in] | addr | Address of a buffer allocated by ti_sdo_ce_osal_Memory_contigAlloc()
[in] | size | Size of the buffer to free.
Remarks:
This definition also has a short name alias of Memory_contigFree.
Return values:
TRUE | The buffer was freed and the memory pointed to by addr is no longer valid.
FALSE | The buffer couldn't be freed.
Precondition:
addr must be a valid address returned by ti_sdo_ce_osal_Memory_contigAlloc()
size must be equivalent to the size passed in during the ti_sdo_ce_osal_Memory_contigAlloc() allocation.
See also:
ti_sdo_ce_osal_Memory_contigAlloc()
Bool ti_sdo_ce_osal_Memory_free | ( | Ptr | addr,
 |  | UInt | size,
 |  | ti_sdo_ce_osal_Memory_AllocParams * | params
 | ) |  |

Free memory allocated with ti_sdo_ce_osal_Memory_alloc().

Parameters:
[in] | addr | Address of a buffer allocated by ti_sdo_ce_osal_Memory_alloc().
[in] | size | Size of the buffer to free.
[in] | params | Parameters controlling the free operation.
Remarks:
This definition also has a short name alias of Memory_free.
Return values:
TRUE | The buffer was freed and the memory pointed to by addr is no longer valid.
FALSE | The buffer couldn't be freed.
Precondition:
addr must be a valid address returned by ti_sdo_ce_osal_Memory_alloc().
size must be equivalent to the size passed in during the ti_sdo_ce_osal_Memory_alloc() allocation.
params must be equivalent to the params passed in during the ti_sdo_ce_osal_Memory_alloc() allocation.
See also:
ti_sdo_ce_osal_Memory_alloc()
Void ti_sdo_ce_osal_Memory_dumpKnownContigBufsList ( Void )

Dumps the list of all translated/registered bufs.

Remarks:
The list is printed using the tracing infrastructure at trace level 5 to tracemask Memory_MODNAME.
There are several mechanisms to enable this trace mask, one would be to do the following from your application:
    Diags_setMask(Memory_MODNAME"+5");
See also:
ti_sdo_ce_osal_Memory_registerContigBuf()
ti_sdo_ce_osal_Memory_unregisterContigBuf()
UInt32 ti_sdo_ce_osal_Memory_getBufferPhysicalAddress | ( | Ptr | virtualAddress,
 |  | Int | sizeInBytes,
 |  | Bool * | isContiguous
 | ) |  |

Converts application virtual address to a physical address.

This API also checks verifies that the buffer is really contiguous.

Parameters:
[in] | virtualAddress | Address of a buffer.
[in] | sizeInBytes | Size of the buffer.
[out] | isContiguous | Optional flag indicating whether the buffer was physically contiguous or not.
Return values:
0 | Failure, the physical address could not be obtained.
non-zero | The physical address of the buffer.
Remarks:
sizeInBytes must be non-zero.
isContiguous is an optional parameter, and can be NULL if the caller doesn't want the results of this check. If isContiguous is NULL but the buffer is not contiguous, error trace will be generated.
If a physically discontiguous buffer is provided in virtualAddress, zero will be returned. And if isContiguous is non-null, it will be set to FALSE.
This is typically called by a stub implementation to translate an application-side virtual address into a physical address usable by a remote skeleton and algorithm.
To enable portable code, this is safe to call on systems without virtual memory. In those cases, the returned physical buffer will be the same as the provided "virtual" buffer.
This definition also has a short name alias of Memory_getBufferPhysicalAddress.
See also:
ti_sdo_ce_osal_Memory_getBufferVirtualAddress()
Int ti_sdo_ce_osal_Memory_getHeapId ( String name )

Get the heap heap ID corresponding to a heap name. This number will be between 0 and the value returned by ti_sdo_ce_osal_Memory_getNumHeaps(). The heap Id can be passed to ti_sdo_ce_osal_Memory_redefine() and ti_sdo_ce_osal_Memory_restoreHeap().

Remarks:
This is an unsupported, private function. There is no contract to provide compatibility between releases, and it may be deleted at any time.
Return values:
>= 0 The heap number.
< 0 No heap with the given name was found.
See also:
ti_sdo_ce_osal_Memory_getNumHeaps()
Int ti_sdo_ce_osal_Memory_getNumHeaps ( )

Get the number of memory heaps.

Remarks:
This is an unsupported, private function. There is no contract to provide compatibility between releases, and it may be deleted at any time.
Return values:
The number of memroy heaps.
Ptr ti_sdo_ce_osal_Memory_getBufferVirtualAddress | ( | UInt32 | physicalAddress,
 |  | Int | sizeInBytes
 | ) |  |

Obtains the virtual address of a physically contiguous buffer.

Parameters:
[in] | physicalAddress | Physical address of a buffer.
[in] | sizeInBytes | Size of the buffer.
Return values:
NULL | Failure, the virtual address could not be obtained.
non-zero | The virtual address of the buffer.
Remarks:
sizeInBytes must be non-zero.
If virtualAddress, was not acquired by ti_sdo_ce_osal_Memory_getBufferPhysicalAddress(), no attempt is made to map the physically contiguous buffer into the application's virtual memory space.
This is typically called by a stub implementation to translate a buffer provided by a remote skeleton and/or algorithm into an application-usable, virtual address.
On some homogenous multicore devices (e.g. C6472), this service translates a local address to a global address that's visible by a different processor.
To enable portable code, this is safe to call on systems without virtual memory. In those cases, the returned "virtual" buffer will be the same as the provided physical buffer.
This definition also has a short name alias of Memory_getBufferVirtualAddress.
See also:
ti_sdo_ce_osal_Memory_getBufferPhysicalAddress()
Void ti_sdo_ce_osal_Memory_registerContigBuf | ( | UInt32 | virtualAddress,
 |  | UInt32 | sizeInBytes,
 |  | UInt32 | physicalAddress
 | ) |  |

Register a physical buffer allocated without ti_sdo_ce_osal_Memory_contigAlloc()

Parameters:
[in] | virtualAddress | Address of the buffer mapped into the process space
[in] | sizeInBytes | Size of the region
[in] | physicalAddress | Physical address of the buffer
Remarks:
A cache of "app-address to codec-address" mappings (e.g. virtual to physical address mappings in DM644x devices) is internally maintained in some environments (e.g. Linux). This is used, for example, by Memory_getBufferPhysicalAddress() and Memory_getBufferVirtualAddress(). This lookup map is automatically updated when using Memory_contigAlloc() and Memory_contigFree(). However, if the user acquires buffers independently, it must use Memory_registerContigBuf() and Memory_unregisterContigBuf() to ensure the lookup map is current.
Individual sub-blocks of a buffer need not be registered; registering the entire buffer once will suffice.
This API is typically only required for environments with virtual memory (e.g. Linux-based systems).
See also:
ti_sdo_ce_osal_Memory_unregisterContigBuf()
ti_sdo_ce_osal_Memory_dumpKnownContigBufsList()
Void ti_sdo_ce_osal_Memory_unregisterContigBuf | ( | UInt32 | virtualAddress,
 |  | UInt32 | sizeInBytes
 | ) |  |

Unregisters a physical buffer allocated without ti_sdo_ce_osal_Memory_contigAlloc().

Parameters:
[in] | virtualAddress | beginning address of the buffer mapped into the process space
[in] | sizeInBytes | size of the region
Remarks:
This API must be used to unregister a buffer allocated outside of Memory_contigAlloc() if the buffer (or a portion of it) is passed on to VISA calls. Segments of the buffer need not be individually unregistered.
See also:
ti_sdo_ce_osal_Memory_registerContigBuf()
ti_sdo_ce_osal_Memory_dumpKnownContigBufsList()

Variable Documentation

ti_sdo_ce_osal_Memory_AllocParams ti_sdo_ce_osal_Memory_DEFAULTPARAMS

Default parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()

Remarks:
This definition also has a short name alias of Memory_DEFAULTPARAMS.
ti_sdo_ce_osal_Memory_DEFAULTPARAMS will be used when NULL is passed in the ti_sdo_ce_osal_Memory_AllocParams parameter for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free(). When passing a non-NULL ti_sdo_ce_osal_Memory_AllocParams parameter, you should first copy ti_sdo_ce_osal_Memory_DEFAULTPARAMS to your structure and then modify individual elements as needed:
      Memory_AllocParams  myParams;

      myParams = Memory_DEFAULTPARAMS;
      myParams.type = Memory_CONTIGHEAP;
See also:
ti_sdo_ce_osal_Memory_alloc()
ti_sdo_ce_osal_Memory_free()


Codec Engine System Programming Interface (SPI): XDAIS Types and Constants

Defines | Typedefs

XDAIS Types and Constants

Defines

#define | XDAS_TRUE 1
#define | XDAS_FALSE 0

Typedefs

typedef Void | XDAS_Void
typedef Uint8 | XDAS_Bool
typedef Int8 | XDAS_Int8
typedef Uint8 | XDAS_UInt8
typedef Int16 | XDAS_Int16
typedef Uint16 | XDAS_UInt16
typedef Int32 | XDAS_Int32
typedef Uint32 | XDAS_UInt32

Define Documentation

#define XDAS_TRUE 1
#define XDAS_FALSE 0

Typedef Documentation

typedef Void XDAS_Void
typedef Uint8 XDAS_Bool
typedef Int8 XDAS_Int8

Actual size chip dependent.

typedef Uint8 XDAS_UInt8

Actual size chip dependent.

typedef Int16 XDAS_Int16

Actual size of type is 16 bits.

typedef Uint16 XDAS_UInt16

Actual size of type is 16 bits.

typedef Int32 XDAS_Int32

Actual size of type is 32 bits.

typedef Uint32 XDAS_UInt32

Actual size of type is 32 bits.


Codec Engine System Programming Interface (SPI): Codec Engine Runtime

Data Structures | Defines | Typedefs | Enumerations | Functions | Variables

Codec Engine Runtime

Data Structures

struct | Engine_Attrs
Attributes of an Engine. More...
struct | Engine_AlgInfo
Properties of an Engine algorithm. More...
struct | Engine_AlgInfo2
Properties of an Engine algorithm. More...
struct | Engine_AlgDesc
Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine. More...
struct | Engine_DllAlgDesc
Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type. More...

Defines

#define | Engine_MODNAME "ti.sdo.ce.Engine"
Name to pass to Diags_setMask() to enable logging for Engine functions.
#define | Engine_EOK 0
#define | Engine_EEXIST 1
#define | Engine_ENOMEM 2
#define | Engine_EDSPLOAD 3
#define | Engine_ENOCOMM 4
#define | Engine_ENOSERVER 5
#define | Engine_ECOMALLOC 6
#define | Engine_ERUNTIME 7
#define | Engine_ECODECCREATE 8
#define | Engine_ECODECSTART 9
#define | Engine_EINVAL 10
#define | Engine_EBADSERVER 11
#define | Engine_ENOTAVAIL 12
#define | Engine_EWRONGSTATE 13
#define | Engine_EINUSE 14
#define | Engine_ENOTFOUND 15
#define | Engine_ETIMEOUT 16
#define | Engine_GETALGDESCFXN "GetEngineAlgDesc"
Name of function that a dynamically loaded codec must supply.

Typedefs

typedef struct Engine_Obj * | Engine_Handle
Opaque handle to an engine.
typedef Int | Engine_Error
Engine error code.
typedef struct Engine_Attrs | Engine_Attrs
Attributes of an Engine.
typedef struct Engine_AlgInfo | Engine_AlgInfo
Properties of an Engine algorithm.
typedef struct Engine_AlgInfo2 | Engine_AlgInfo2
Properties of an Engine algorithm.
typedef enum Engine_CachedMemType | Engine_CachedMemType
Engine Cacheable Memory types.
typedef struct Engine_AlgDesc | Engine_AlgDesc
Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine.
typedef struct Engine_DllAlgDesc | Engine_DllAlgDesc
Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type.
typedef Int(* | Engine_GetAlgDescFxn )(Engine_DllAlgDesc *dllAlgDesc)
Prototype of function that must be supplied by a dynamic codec library to fill in a Engine_DllAlgDesc structure.

Enumerations

enum Engine_CachedMemType {
Engine_USECACHEDMEM_DEFAULT = -1,
Engine_USECACHEDMEM_NONCACHED = 0,
Engine_USECACHEDMEM_CACHED = 1
}

Engine Cacheable Memory types.

More...

Functions

Engine_Error | Engine_addStubFxns (String fxnsName, IALG_Fxns *fxns)
Register stub functions through which a remote algorithm can be called.
Engine_Error | Engine_add (Engine_Desc *pDesc)
Add an Engine to the database of engines that can be opened with Engine_open()
Engine_Error | Engine_addAlg (String name, Engine_Handle engine, String location, Engine_AlgDesc *pAlgDesc)
Dynamically add an algorithm to an Engine.
Engine_Error | Engine_removeAlg (String name, Engine_Handle engine, String algName)
Dynamically remove an algorithm that was added to an Engine with Engine_addAlg().
Void | Engine_close (Engine_Handle engine)
Close an Engine.
Void | Engine_initAlgDesc (Engine_AlgDesc *pAlgDesc)
Initialize an Engine_AlgDesc structure with default values.
Void | Engine_initAttrs (Engine_Attrs *pAttrs)
Initialize an Engine_Attrs structure with default values.
Void | Engine_initDesc (Engine_Desc *pDesc)
Initialize an Engine_Desc structure with default values.
Engine_Handle | Engine_open (String name, Engine_Attrs *attrs, Engine_Error *ec)
Open an Engine.
Int | Engine_fwriteTrace (Engine_Handle engine, String prefix, FILE *out)
Write Server's trace buffer to specifed file stream.
Engine_Error | Engine_getAlgInfo (String name, Engine_AlgInfo *algInfo, Int index)
Get details of an algorithm configured into an engine.
Engine_Error | Engine_getAlgInfo2 (String name, Engine_Handle engine, Engine_AlgInfo2 *algInfo2, Int index)
Get details of an algorithm.
Engine_Error | Engine_getDesc (String name, Engine_Desc *desc)
Fill in an Engine_Desc structure with the values of the Engine descriptor for an Engine.
Engine_Error | Engine_getLastError (Engine_Handle engine)
Get error code of the last failed operation.
String | Engine_getName (Engine_Handle engine)
Get the name of an opened engine.
Engine_Error | Engine_getNumAlgs (String name, Int *numAlgs)
Get the number of algorithms configured into an Engine.
Engine_Error | Engine_getNumAlgs2 (String name, Engine_Handle engine, Int *numAlgs)
Get the number of algorithms statically configured into an engine or the total number of algorithms both statically configured and dynamically added through server information when the engine was opened.
Server_Handle | Engine_getServer (Engine_Handle engine)
Get handle to an Engine's Server.
UInt32 | Engine_getUsedMem (Engine_Handle engine)
Get Server's total memory usage.
Engine_Error | Engine_remove (String engineName)
Remove an engine from the list of engines that can be opened.
Engine_Error | Engine_setDesc (String name, Engine_Desc *desc)
Set values for an Engine's descriptor. This function should only be called when the Engine has not yet been opened.
Int | Engine_setTrace (Engine_Handle engine, String mask)
Set Server's trace mask.

Variables

Engine_Attrs Engine_ATTRS
Default engine attributes.

Define Documentation

#define Engine_MODNAME "ti.sdo.ce.Engine"

Name to pass to Diags_setMask() to enable logging for Engine functions.

Example Usage:
The following code turns on all Log statements in the Engine module.
     Diags_setMask(Engine_MODNAME "+EX1234567");
Remarks:
Using Diags_setMask() to enable Engine Logging must be called after CERuntime_init() (which creates and initializes the Engine trace mask) to have any effect.
#define Engine_EOK 0

Success.

#define Engine_EEXIST 1

Name does not exist.

#define Engine_ENOMEM 2

Unable to allocate memory.

#define Engine_EDSPLOAD 3

Unable to load the DSP.

#define Engine_ENOCOMM 4

Unable to create a comm connection to the DSP.

#define Engine_ENOSERVER 5

Unable to locate the server on the DSP.

#define Engine_ECOMALLOC 6

Unable to allocate communication buffer.

#define Engine_ERUNTIME 7

Internal engine runtime failure.

#define Engine_ECODECCREATE 8

Creation of the Codec failed.

#define Engine_ECODECSTART 9

Start of the Codec failed. For codecs which are implemented as a thread, this implies that the codec thread of execution failed to start.

#define Engine_EINVAL 10

Bad paramater passed to method.

#define Engine_EBADSERVER 11

Incompatible server specified.

#define Engine_ENOTAVAIL 12

Service not available.

#define Engine_EWRONGSTATE 13

Call can not be made at this time.

#define Engine_EINUSE 14

Call can't be made at this time because a required name/resource is in use.

#define Engine_ENOTFOUND 15

Entity was not found.

#define Engine_ETIMEOUT 16

Timeout-based operation timed out.

#define Engine_GETALGDESCFXN "GetEngineAlgDesc"

Name of function that a dynamically loaded codec must supply.

Typedef Documentation

typedef struct Engine_Obj* Engine_Handle

Opaque handle to an engine.

typedef Int Engine_Error

Engine error code.

typedef struct Engine_Attrs Engine_Attrs

Attributes of an Engine.

See also:
Engine_initAttrs().
Engine_open().
typedef struct Engine_AlgInfo Engine_AlgInfo

Properties of an Engine algorithm.

See also:
Engine_getAlgInfo()
typedef struct Engine_AlgInfo2 Engine_AlgInfo2

Properties of an Engine algorithm.

Remarks:
This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a single string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE".
See also:
Engine_getAlgInfo2()
typedef enum Engine_CachedMemType Engine_CachedMemType

Engine Cacheable Memory types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
typedef struct Engine_AlgDesc Engine_AlgDesc

Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine.

See also:
Engine_initAlgDesc()
Engine_addAlg()
typedef struct Engine_DllAlgDesc Engine_DllAlgDesc

Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type.

See also:
Engine_GetAlgDescFxn
typedef Int(* Engine_GetAlgDescFxn)(Engine_DllAlgDesc *dllAlgDesc)

Prototype of function that must be supplied by a dynamic codec library to fill in a Engine_DllAlgDesc structure.

Remarks:
This function will be called by Engine_addAlg() to fill in the dynamic codec's descriptor.
See also:
Engine_DllAlgDesc

Enumeration Type Documentation

enum Engine_CachedMemType

Engine Cacheable Memory types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
Enumerator:
Engine_USECACHEDMEM_DEFAULT

Use default cache setting

Engine_USECACHEDMEM_NONCACHED

Use non-cached memory

Engine_USECACHEDMEM_CACHED

Use cached memory

Function Documentation

Engine_Error Engine_addStubFxns | ( | String | fxnsName,
 |  | IALG_Fxns * | fxns
 | ) |  |

Register stub functions through which a remote algorithm can be called.

Parameters:
[in] | fxnsName | The name of the stub function table (e.g. "UNIVERSAL_STUBS")
[in] | fxns | Address of stub function table (e.g. &UNIVERSAL_STUBS)
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Remarks:
This service is not necessary if you configure your Engine at build/config time using Engine.createFromServer(). When using Engine.createFromServer(), the appropriate alg-specific stubs are added to the system automatically.
When on an RTOS (e.g. SYS/BIOS), the stubs registered are available to all Engines in the system. When on a HLOS (e.g. Linux, WinCE), the stubs registered are available to all Engines in the calling application's process.
The symbol passed to the fxns argument can often be found in the class-specific VISA header file (e.g. UNIVERSAL_STUBS is declared in ti/sdo/ce/universal/universal.h).
For example, to register "UNIVERSAL_STUBS" for use by an IUNIVERSAL-compliant algorithm at runtime, you can do the following:
      #include <ti/sdo/ce/Engine.h>
      #include <ti/sdo/ce/universal/universal.h>

      Engine_register("UNIVERSAL_STUBS",
              (IALG_Fxns *)&UNIVERSAL_STUBS);
Return values:
Engine_EOK | Success.
Engine_ENOMEM | Memory allocation failed.
See also:
Engine_open()
Engine_Error Engine_add ( Engine_Desc * pDesc )

Add an Engine to the database of engines that can be opened with Engine_open()

Parameters:
[in] pDesc The handle of an Engine Descriptor object. Before setting the fields of pDesc, it must first be initialized with Engine_initDesc().
Return values:
Engine_EINVAL | Bad parameter passed, such as pDesc = NULL, or pDesc->name = NULL.
Engine_EINUSE | An engine with the name pDesc->name already exists.
Engine_ENOMEM | A memory allocation failed.
Engine_EOK | Success.
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If the return value is Engine_EOK, Engine_open() can be called with pDesc->name.
Example Usage:
      #include <ti/sdo/ce/Engine.h>

      Engine_Desc desc;

      Engine_initDesc(&desc);

      desc.name = "myEngine";
      desc.remoteName = "myServer.x64P";
      Engine_add(&desc);
See also:
Engine_remove()
Engine_open()
Engine_Error Engine_addAlg | ( | String | name,
 |  | Engine_Handle | engine,
 |  | String | location,
 |  | Engine_AlgDesc * | pAlgDesc
 | ) |  |

Dynamically add an algorithm to an Engine.

Remarks:
If the Engine has not been opened, the name of the Engine is used, otherwise, a handle to the opened Engine. If the Engine has been opened, the added alg will only be accessible to the caller of this function. Either one or the other, but not both, of name and engine should be non-NULL.
Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration, or the name of an engine added with Engine_add(). This can only be non-NULL if the engine is not opened, otherwise, use an engine handle and set name to NULL.
[in] | engine | The handle of an engine returned by Engine_open(). If engine is non-NULL, set name to NULL.
[in] | location | String identifying the location of the algorithm. Often this is a file name, but for systems without a file system, it may be a system-specific string identifier. This may be NULL if the algorithm is built into the executable.
[in] | pAlgDesc | Parameters describing the algorithm being added. Before setting the fields of this structure, it should first be initialized with Engine_initAlgDesc(), to set all fields to default values. If location is non-NULL (a dynamic library), then the following fields of pAlgDesc must be specified: pAlgDesc->name pAlgDesc->isLocal pAlgDesc->groupId All other Engine_AlgDesc fields will be from the dynamic library. If location is NULL (not a dynamic library), the user must set the following fields of pAlgDesc: pAlgDesc->name pAlgDesc->fxns pAlgDesc->idmaFxns, if applicable pAlgDesc->iresFxns, if applicable pAlgDesc->isLocal pAlgDesc->groupId pAlgDesc->types
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
engine is a valid (non-NULL) engine handle which is in the open state.
Remarks:
If there is an existing algorithm in the engine already named name, an error will be returned.
Return values:
Engine_EOK | Success.
Engine_EINUSE | The Engine name is non-NULL, and the Engine is open.
Engine_EINVAL | pAlgDesc or pAlgDesc->name is NULL.
Engine_EINVAL | Both name and engine are NULL. Ensure one of these is non-NULL.
Engine_EINVAL | Both name and engine are non-NULL. Ensure that one of these is NULL.
Engine_EEXIST | There is no engine with the given name.
Engine_EINUSE | The name of the alg in pAlgDesc->name is already in use.
Example Usage:
      #include <ti/sdo/ce/Engine.h>

      Engine_AlgDesc desc;

      Engine_initAlgDesc(&desc);

      desc.groupId = 2;
      desc.isLocal = TRUE;
      desc.fxns = &UNIVERSALCOPY_TI_IUNIVERSALCOPY;
      desc.idmaFxns = NULL;
      desc.iresFxns = NULL;
      desc.memType = Engine_USECACHEDMEM_DEFAULT;
      desc.types = UNIVERSAL_VISATYPE;

      status = Engine_addAlg("myEngine", NULL, NULL, &desc);
See also:
Engine_initAlgDesc()
Engine_open()
Engine_removeAlg()
Engine_Error Engine_removeAlg | ( | String | name,
 |  | Engine_Handle | engine,
 |  | String | algName
 | ) |  |

Dynamically remove an algorithm that was added to an Engine with Engine_addAlg().

Remarks:
The same values of the parameters name and engine that were passed to Engine_addAlg() should be used here. In particular, if name was used to add the alg, all handles to the engine must be closed before calling Engine_removeAlg().
Parameters:
[in] | name | The name of the engine or NULL, that was passed to Engine_addAlg().
[in] | engine | The handle to an engine, previously acquired by a call to Engine_open(), or NULL, that was used in Engine_addAlg().
[in] | algName | Name of the algorithm to remove.
Return values:
Engine_EOK | Success.
Engine_EEXIST | The engine name does not exist.
Engine_ENOTFOUND | algName could not be found in engine.
Engine_EINUSE | The Engine name is still open.
See also:
Engine_open()
Engine_addAlg()
Void Engine_close ( Engine_Handle engine )

Close an Engine.

Parameters:
[in] engine The handle to an engine, previously acquired by a call to Engine_open().
Precondition:
engine must not be referenced by any algorithm instance objects; i.e., you must first delete all algorithm instances associated with engine before closing it.
engine is a valid (non-NULL) engine handle which is in the open state.
See also:
Engine_open()
Void Engine_initAlgDesc ( Engine_AlgDesc * pAlgDesc )

Initialize an Engine_AlgDesc structure with default values.

Parameters:
[in] pAlgDesc Location of Engine_AlgDesc object to initialize. The fields of pAlgDesc will be set to the following:

pAlgDesc->name = NULL; pAlgDesc->uuid.data = 0; pAlgDesc->fxns = NULL; pAlgDesc->idmaFxns = NULL; pAlgDesc->typeTab = NULL; pAlgDesc->isLocal = TRUE; pAlgDesc->groupId = 0; pAlgDesc->rpcProtocolVersion = 0; pAlgDesc->iresFxns = NULL; pAlgDesc->codecClassConfig = NULL; pAlgDesc->memType = Engine_USECACHEDMEM_DEFAULT; pAlgDesc->types = NULL;

See also:
Engine_addAlg()
Void Engine_initAttrs ( Engine_Attrs * pAttrs )

Initialize an Engine_Attrs structure with default values.

Parameters:
[in] pAttrs Location of Engine_Attrs object to initialize.
See also:
Engine_open()
Void Engine_initDesc ( Engine_Desc * pDesc )

Initialize an Engine_Desc structure with default values.

Parameters:
[in] pDesc Location of Engine_Desc object to initialize. The fields of pDesc will be set to the following:

pDesc->name = NULL; pDesc->remoteName = NULL; pDesc->heapId = 0;

See also:
Engine_add()
Engine_Handle Engine_open | ( | String | name,
 |  | Engine_Attrs * | attrs,
 |  | Engine_Error * | ec
 | ) |  |

Open an Engine.

The handle returned may be used to create one or more instances of an algorithm contained in the specified Engine.

An Engine may be opened more than once; each open returns a unique handle that can be used to create algorithm instances or get status of the Engine.

Engine handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via Engine_open()) or explicitly serialize access to a shared handle.

Parameters:
[in] | name | The name of the engine to open. name is specified in the engine configuration.
[in] | attrs | Attributes for the open engine.
[out] | ec | Optional output error code
Return values:
NULL | An error has occurred.
non-NULL | The handle to the opened engine.
Precondition:
name is a non-NULL string.
name is a valid, pre-configured name of an engine.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If the return handle is NULL and ec is non-NULL, *ec is set to a non-zero value indicating the cause of the failure.
If ec is non-NULL, the Engine_Error value is set to one of the following values:
  • Engine_EOK success
  • Engine_EEXIST name does not exist
  • Engine_ENOMEM can't allocate memory
  • Engine_EDSPLOAD can't load the DSP
  • Engine_ENOCOMM can't create a comm connection to DSP
  • Engine_ENOSERVER can't locate the server on the DSP
  • Engine_ECOMALLOC can't allocate communication buffer
See also:
Engine_close()
Engine_add()
Engine_remove()
Int Engine_fwriteTrace | ( | Engine_Handle | engine,
 |  | String | prefix,
 |  | FILE * | out
 | ) |  |

Write Server's trace buffer to specifed file stream.

Parameters:
[in] | engine | The handle to the opened engine.
[in] | prefix | A string to prepend to each line output; this allows one to easily identify trace from the server from the application's trace, for example.
[in] | out | A open FILE stream used to output the Server's trace characters.
Return values:
Integer number of characters copied to the specified FILE stream.
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Postcondition:
In the event a negative value is returned, Engine_getLastError() will return one of the following values:
  • Engine_ERUNTIME Either an internal runtime error occured or the underlying server error occured.
  • Engine_EINUSE Server trace resource is already in use.
Engine_Error Engine_getAlgInfo | ( | String | name,
 |  | Engine_AlgInfo * | algInfo,
 |  | Int | index
 | ) |  |

Get details of an algorithm configured into an engine.

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration.
[out] | algInfo | Structure to store algorithm details. The algInfoSize field of this structure must be set to sizeof(Engine_AlgInfo) by the application.
[out] | index | The index of the algorithm to get the information.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Engine_ENOTFOUND | index is greater than or equal to the total number of algorithms configured for the engine, or index < 0.
Engine_EINVAL | The value of algInfoSize passed to this function does not match the CE library's sizeof(Engine_AlgInfo).
Precondition:
name is a non-NULL string.
algInfo is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name and 0 <= index < the total number of algorithms configured for the engine, then algInfo will contain the information for the engine's ith (i = index) algorithm.
See also:
Engine_getNumAlgs()
Engine_Error Engine_getAlgInfo2 | ( | String | name,
 |  | Engine_Handle | engine,
 |  | Engine_AlgInfo2 * | algInfo2,
 |  | Int | index
 | ) |  |

Get details of an algorithm.

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration. This may be NULL if engine contains a valid engine handle.
[in] | engine | The handle of an engine returned by Engine_open(). If this is NULL, only information for a static alg can be obtained.
[out] | algInfo2 | Structure to store algorithm details. The algInfoSize field of this structure must be set to sizeof(Engine_AlgInfo2) by the application.
[out] | index | The index of the algorithm to get the information.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Engine_ENOTFOUND | index is greater than or equal to the total number of algorithms configured for the engine, or index < 0.
Engine_EINVAL | The value of algInfoSize passed to this function does not match the CE library's sizeof(Engine_AlgInfo2).
Precondition:
name is a non-NULL string or engine is non-NULL.
algInfo2 is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name and 0 <= index < the total number of algorithms configured for the engine, then algInfo2 will contain the information for the engine's ith (i = index) algorithm.
Remarks:
This service supports algorithms statically configured into an Engine at build/config time, or algorithms that have been dynamically added to an opened engine. If the Engine has not been opened yet, the name of the Engine is used to get the statically configured alg. If the Engine has been opened, the Engine handle can be used to get either information for a statically configured alg, or a remote alg that was added when the server was queried during Engine_open().
See also:
Engine_getNumAlgs2().
Engine_Error Engine_getDesc | ( | String | name,
 |  | Engine_Desc * | desc
 | ) |  |

Fill in an Engine_Desc structure with the values of the Engine descriptor for an Engine.

Parameters:
[in] | name | The name of the Engine. name is specified in the engine configuration or a a name that was passed to Engine_add().
[out] | desc | The structure where the descriptor of the Engine specified by name will be copied to.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Precondition:
name is a non-NULL string.
desc is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name, then desc will contain the descriptor of the engine name.
See also:
Engine_setDesc().
Engine_Error Engine_getLastError ( Engine_Handle engine )

Get error code of the last failed operation.

Parameters:
[in] engine The handle to the opened engine.
Return values:
error code (Engine_Error) of the last failed engine operation.
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
engine is a valid (non-NULL) engine handle and the engine is in the open state.
String Engine_getName ( Engine_Handle engine )

Get the name of an opened engine.

Parameters:
[in] engine The handle to the opened engine.
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Return values:
NULL | An error has occurred.
non-NULL | The name of the opened engine.
Engine_Error Engine_getNumAlgs | ( | String | name,
 |  | Int * | numAlgs
 | ) |  |

Get the number of algorithms configured into an Engine.

Parameters:
[in] | name | The name of the Engine. name is specified in the engine configuration.
[out] | numAlgs | The number of algorithms that are configured in the given engine.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Precondition:
name is a non-NULL string.
numAlgs is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name, then numAlgs will contain the number of algorithms configured for the given engine.
See also:
Engine_getAlgs().
Engine_Error Engine_getNumAlgs2 | ( | String | name,
 |  | Engine_Handle | engine,
 |  | Int * | numAlgs
 | ) |  |

Get the number of algorithms statically configured into an engine or the total number of algorithms both statically configured and dynamically added through server information when the engine was opened.

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration. name can be NULL, if engine is a valid Engine_Handle.
[in] | engine | The handle of an engine returned by Engine_open(). If engine is NULL, name must be non-NULL, and only the number of statically configured algorithms will be returned in numAlgs. specified in the engine configuration.
[out] | numAlgs | The number of algorithms that are configured in the given engine.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Precondition:
name is a non-NULL string or engine is non-NULL.
numAlgs is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name, then numAlgs will contain the number of algorithms configured for the given engine.
Remarks:
If the engine has a server, but was not configured with Engine.createFromServer() number of remote algorithms (if any) that were statically configured into the engine, will be counted twice: once for the static alg table, and once for the information queried from the server.
See also:
Engine_getAlgs().
Server_Handle Engine_getServer ( Engine_Handle engine )

Get handle to an Engine's Server.

This function returns the handle to an Engines server, that can be used with Server APIs to obtain information from and control the remote DSP server.

Parameters:
[in] engine The handle to the opened engine.
Return values:
Handle to engine's server.
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
engine is a valid (non-NULL) engine handle and the engine is in the open state.
UInt32 Engine_getUsedMem ( Engine_Handle engine )

Get Server's total memory usage.

Deprecated:
This service has been replaced by Server_getMemStat() to better indicate that this API is not intended for obtaining the current processor's memory statistics, rather it obtains the memory statistics of a remote Server. Also, Server_getMemStat() provides more granularity than Engine_getUsedMem().
Parameters:
[in] engine The handle to the opened engine.
Return values:
Total amount of used memory (in MAUs). If the amount is not available, 0 is returned and the reason can be retrieved via Engine_getLastError().
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Postcondition:
in the event that 0 is returned, Engine_getLastError() will return one of the following values:
  • Engine_ERUNTIME Either an internal runtime error occured or the underlying server error occured.
  • Engine_ENOTAVAIL The memory usage can not be computed.
Engine_Error Engine_remove ( String engineName )

Remove an engine from the list of engines that can be opened.

Parameters:
[in] engineName The name of the engine to be removed.
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
engineName is non-NULL.
Return values:
Engine_EINUSE | The engine cannot be removed because an instance of it is still opened.
Engine_EEXIST | No engine by this name exists.
Engine_EOK | Success.
See also:
Engine_add()
Engine_Error Engine_setDesc | ( | String | name,
 |  | Engine_Desc * | desc
 | ) |  |

Set values for an Engine's descriptor. This function should only be called when the Engine has not yet been opened.

Parameters:
[in] | name | The name of the Engine. name is specified in the engine configuration or a a name that was passed to Engine_add().
[in] | desc | The structure where descriptor values for the Engine specified by name will be copied from.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Engine_EINUSE | The Engine name has already been opened.
Precondition:
name is a non-NULL string.
desc is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name, then the desscriptor for the engine name will have been updated with values from desc.
Remarks:
Use Engine_getDesc() to fill in the descriptor, override the fields you want to change, and then pass the descriptor to Engine_setDesc(). Only the following fields of the Engine_Desc are allowed to be modified: memMap useExtLoader heapId
See also:
Engine_getDesc().
Int Engine_setTrace | ( | Engine_Handle | engine,
 |  | String | mask
 | ) |  |

Set Server's trace mask.

Parameters:
[in] | engine | The handle to the opened engine.
[in] | mask | Trace mask, e.g. "*=01234567"
Return values:
Engine_ENOSERVER | No server for this engine.
Engine_EINUSE | Trace resource is already in use.
Engine_ERUNTIME | Internal runtime error has occurred.
Precondition:
As with all Codec Engine API's, CERuntime_init() must have previously been called.
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Remarks:
This only sets the trace for a remote server. To change the trace mask for the application-side of the framework, use Diags_setMask(), or Diags_setMaskMeta().
See also:
xdc.runtime.Diags

Variable Documentation

Engine_Attrs Engine_ATTRS

Default engine attributes.

Deprecated:
Engine_ATTRS is no longer recommended. Please use Engine_initAttrs() instead.
See also:
Engine_initAttrs() Default attrs.


Codec Engine System Programming Interface (SPI): CE Skeleton SPI

Data Structures | Typedefs

CE Skeleton SPI

Data Structures

struct | SKEL_Fxns
Table of functions defining the interface of a skeleton. More...

Typedefs

typedef VISA_Status(* | SKEL_CALLFXN )(VISA_Handle handle, VISA_Msg msg)
Prototype for a skeleton's call() implementation.
typedef VISA_Handle(* | SKEL_CREATEFXN )(Void *reserved, String name, Void *params)
Prototype for a skeleton's create() API.
typedef Void(* | SKEL_DESTROYFXN )(VISA_Handle handle)
Prototype for a skeleton's destroy() API.
typedef struct SKEL_Fxns | SKEL_Fxns
Table of functions defining the interface of a skeleton.

Typedef Documentation

typedef VISA_Status(* SKEL_CALLFXN)(VISA_Handle handle, VISA_Msg msg)

Prototype for a skeleton's call() implementation.

Parameters:
[in] | handle | A handle to the current skeleton.
[in] | msg | A message sent by the algorithm's stub
typedef VISA_Handle(* SKEL_CREATEFXN)(Void *reserved, String name, Void *params)

Prototype for a skeleton's create() API.

Parameters:
[in] | reserved | Reserved.
[in] | name | Name of the algorithm to create.
[in] | params | Creation parameters for the algorithm.
Return values:
NULL | Error, unable to create the algorithm.
non-NULL | Handle to the successfully created algorithm.
typedef Void(* SKEL_DESTROYFXN)(VISA_Handle handle)

Prototype for a skeleton's destroy() API.

Parameters:
[in] | handle | A handle to the current skeleton.
[in] | msg | A message sent by the algorithm's stub
typedef struct SKEL_Fxns SKEL_Fxns

Table of functions defining the interface of a skeleton.


Codec Engine System Programming Interface (SPI): VISA - Alg-independent user APIs

Defines | Typedefs | Functions

VISA - Alg-independent user APIs

Defines

#define | VISA_EOK 0
Success.
#define | VISA_ERUNTIME -1
Internal runtime error.
#define | VISA_EFAIL -2
General system error.
#define | VISA_EUNSUPPORTED -3
The API is not suported for the given system configuration.
#define | VISA_ETIMEOUT -100
Timeout occurred.
#define | VISA_FOREVER Engine_FOREVER
Special value for timeout parameter indicating never timeout.

Typedefs

typedef Int | VISA_Status
VISA result data type.

Functions

VISA_Status | VISA_getAlgMemRecs (VISA_Handle visa, IALG_MemRec *memTab, Int size, Int *numRecs)
Get the IALG_MemRec memory assigned to an algorithm instance.
VISA_Status | VISA_getAlgNumRecs (VISA_Handle visa, Int *numRecs)
Get the number of IALG_MemRecs assigned to an algorithm.
Ptr | VISA_getCodecClassConfig (VISA_Handle visa)
Get codec-specific values for the VISA class-specific (or codec-specific if the codec doesn't extend VISA) stub-and/ or-skeleton configuration data (that some classes have)
UInt | VISA_getMaxMsgSize (VISA_Handle visa)
Returns max size of messages allocated by VISA_allocMsg()
Void | _VISA_init (Void)
Ininitilize VISA module.
Void | _VISA_exit (Void)
Exit VISA module.
Bool | VISA_isLocal (VISA_Handle visa)
Indicates whether VISA codecs run on a remote or local CPU.

Detailed Description

Codec Engine Algorithm-independent shared definitions and services.

Define Documentation

#define VISA_EOK 0

Success.

#define VISA_ERUNTIME -1

Internal runtime error.

#define VISA_EFAIL -2

General system error.

#define VISA_EUNSUPPORTED -3

The API is not suported for the given system configuration.

#define VISA_ETIMEOUT -100

Timeout occurred.

#define VISA_FOREVER Engine_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef Int VISA_Status

VISA result data type.

Function Documentation

VISA_Status VISA_getAlgMemRecs | ( | VISA_Handle | visa,
 |  | IALG_MemRec * | memTab,
 |  | Int | size,
 |  | Int * | numRecs
 | ) |  |

Get the IALG_MemRec memory assigned to an algorithm instance.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | memTab | Location to store the IALG_MemRecs.
[in] | size | Maximum number of IALG_MemRecs to put in memTab array.
[out] | numRecs | Actual number of IALG_MemRecs copied into memTab array.
Remarks:
Any algorithm instance handle (e.g. VIDDEC2_Handle, AUDDEC1_Handle, etc), can be cast to a visa handle.
Example:
      AUDDEC1_Handle decoder;

      decoder = AUDDEC1_create(...);

      ... likely use VISA_getAlgNumRecs() to alloc enough mem...

      VISA_getAlgMemRecs((VISA_Handle)decoder, ...);
Return values:
VISA_EOK | Success.
VISA_EFAIL | Failure.
See also:
VISA_getAlgNumRecs()
VISA_Status VISA_getAlgNumRecs | ( | VISA_Handle | visa,
 |  | Int * | numRecs
 | ) |  |

Get the number of IALG_MemRecs assigned to an algorithm.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | numRecs | Location to store the number of IALG_MemRecs used.
Remarks:
Any algorithm instance handle (e.g. VIDDEC2_Handle, AUDDEC1_Handle, etc), can be cast to a visa handle.
Example:
      Int numRecs;
      AUDDEC1_Handle decoder;

      decoder = AUDDEC1_create(...);

      VISA_getAlgNumRecs((VISA_Handle)decoder, &numRecs);
Return values:
VISA_EOK | Success.
VISA_EFAIL | Failure.
See also:
VISA_getAlgMemRecs()
Ptr VISA_getCodecClassConfig ( VISA_Handle visa )

Get codec-specific values for the VISA class-specific (or codec-specific if the codec doesn't extend VISA) stub-and/ or-skeleton configuration data (that some classes have)

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
address of the codec class config data structure, or NULL if codec class config data not defined for the codec; the format of the structure is class-specific, and the data in it is codec- specific
Precondition:
visa must be a valid algorithm instance handle.
UInt VISA_getMaxMsgSize ( VISA_Handle visa )

Returns max size of messages allocated by VISA_allocMsg()

Return values:
maxMsgSize Max size of messages allocated by VISA_allocMsg()
Remarks:
This is typically called by an algorithm class' stub.
See also:
VISA_allocMsg()
Void _VISA_init ( Void )

Ininitilize VISA module.

Remarks:
This is typically called by CERuntime_init().
See also:
_VISA_exit()
Void _VISA_exit ( Void )

Exit VISA module.

Remarks:
This is typically called by CERuntime_exit().
See also:
_VISA_init()
Bool VISA_isLocal ( VISA_Handle visa )

Indicates whether VISA codecs run on a remote or local CPU.

Return values:
FALSE | VISA codecs run on remote CPU
TRUE | VISA codecs run on local CPU
Remarks:
This is typically called by an algorithm class' stub.


Codec Engine System Programming Interface (SPI): VISA - CE Stub SPIs

Data Structures | Typedefs | Functions

VISA - CE Stub SPIs

Data Structures

struct | VISA_MsgHeader
VISA message header. More...

Typedefs

typedef struct VISA_MsgHeader | VISA_MsgHeader
VISA message header.

Functions

VISA_Msg | VISA_allocMsg (VISA_Handle visa)
Obtain an algorithm instance's message.
VISA_Status | VISA_call (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and wait for it to complete.
VISA_Status | VISA_callAsync (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and return without waiting for it to complete.
VISA_Status | VISA_wait (VISA_Handle visa, VISA_Msg *msg, UInt timeout)
Wait for the oldest operation from a command specified with VISA_callAsync() to complete.
Void | VISA_freeMsg (VISA_Handle visa, VISA_Msg msg)
Release an algorithm instance's message.
Void | VISA_getContext (VISA_Handle visa, UInt32 *pContext)
Get optional context parameter.
Void | VISA_setContext (VISA_Handle visa, UInt32 context)
Set optional context parameter.

Detailed Description

Codec Engine System Programming Interface (SPI) for stub implementors.

Typedef Documentation

typedef struct VISA_MsgHeader VISA_MsgHeader

VISA message header.

Remarks:
This must be the first field in a message

Function Documentation

VISA_Msg VISA_allocMsg ( VISA_Handle visa )

Obtain an algorithm instance's message.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | General system error
non-NULL | The remote algorithm's message.
Remarks:
This is typically called by an algorithm class' stub.
See also:
VISA_allocMsg()
VISA_Status VISA_call | ( | VISA_Handle | visa,
 |  | VISA_Msg * | msg
 | ) |  |

Invoke the operation specified in the message and wait for it to complete.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | msg | The remote algorithm's message, to be sent to the skeleton.
Remarks:
This is typically called by an algorithm class' stub.
Return values:
VISA_EOK | Success
VISA_ERUNTIME | General system error
See also:
VISA_callAsync()
VISA_Status VISA_callAsync | ( | VISA_Handle | visa,
 |  | VISA_Msg * | msg
 | ) |  |

Invoke the operation specified in the message and return without waiting for it to complete.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | msg | The remote algorithm's message, to be sent to the skeleton.
Remarks:
This is typically called by an algorithm class' stub.
Return values:
VISA_EOK | Success
VISA_ERUNTIME | General system error
See also:
VISA_wait()
VISA_call()
VISA_Status VISA_wait | ( | VISA_Handle | visa,
 |  | VISA_Msg * | msg,
 |  | UInt | timeout
 | ) |  |

Wait for the oldest operation from a command specified with VISA_callAsync() to complete.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | msg | Placeholder for the remote algorithm's return message, retrieved from the skeleton.
[in] | timeout | Amount of "time" to wait ("time" depends on underlying mechanism, such as that used with MSGQ_Get()).
Remarks:
This is typically called by an algorithm class' stub.
Return values:
VISA_EOK | Success
VISA_ERUNTIME | General system error
VISA_ETIMEOUT | Operation timed out
See also:
VISA_callAsync()
Void VISA_freeMsg | ( | VISA_Handle | visa,
 |  | VISA_Msg | msg
 | ) |  |

Release an algorithm instance's message.

Parameters:
[in] | visa | Handle to an algorithm instance.
[in] | msg | Message to free, obtained through a call to VISA_allocMsg().
Return values:
NULL | General system error
non-NULL | The remote algorithm's message.
Remarks:
This is typically called by an algorithm class' stub.
See also:
VISA_allocMsg()
Void VISA_getContext | ( | VISA_Handle | visa,
 |  | UInt32 * | pContext
 | ) |  |

Get optional context parameter.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | pContext | Location to store context.
Precondition:
visa must be a valid algorithm instance handle.
pContext must be a valid pointer.
Remarks:
The VISA_setContext() / VISA_getContext() pair does not work across processors. That is, the context can only be stored and retrieved on the local processor.
See also:
VISA_setContext()
Void VISA_setContext | ( | VISA_Handle | visa,
 |  | UInt32 | context
 | ) |  |

Set optional context parameter.

Parameters:
[in] | visa | Handle to an algorithm instance.
[in] | context | Context.
Precondition:
visa must be a valid algorithm instance handle.
Remarks:
The VISA_setContext() / VISA_getContext() pair does not work across processors. That is, the context can only be stored and retrieved on the local processor.
See also:
VISA_getContext()


Codec Engine System Programming Interface (SPI): VISA - CE interface SPIs

VISA - CE interface SPIs

VISA_Handle | VISA_create (Engine_Handle engine, String name, IALG_Params *params, size_t msgSize, String type)
Create a new instance of an algorithm.
Void | VISA_delete (VISA_Handle visa)
Delete an instance of an algorithm.
VISA_Handle | VISA_create2 (Engine_Handle engine, String name, IALG_Params *params, Int paramsSize, size_t msgSize, String type)
Create a new instance of an algorithm.
Void | VISA_enter (VISA_Handle visa)
Enter an algorithm's critical section. This must be called before any of the algorithm's IALG_Fxns are invoked.
Void | VISA_exit (VISA_Handle visa)
Leave an algorithm's critical section. This must be called after the API has completed calling an algorithm's IALG_Fxns.
Ptr | VISA_getAlgHandle (VISA_Handle visa)
Obtains an algorithm's handle. This is the handle required to be passed to the algorithm's IALG_Fxns.
Ptr | VISA_getAlgorithmHandle (VISA_Handle visa)
Obtains an algorithm's handle. If the algorithm is local, this is the handle that can be passed to Algorithm APIs, not to the IALG_Fxns.
IALG_Fxns * | VISA_getAlgFxns (VISA_Handle visa)
Get implementation functions for this algorithm.

Detailed Description

Codec Engine System Programming Interface (SPI) for class interface implementors.

Function Documentation

VISA_Handle VISA_create | ( | Engine_Handle | engine,
 |  | String | name,
 |  | IALG_Params * | params,
 |  | size_t | msgSize,
 |  | String | type
 | ) |  |

Create a new instance of an algorithm.

Parameters:
[in] | engine | Handle to an engine in which the algorithm has been configured.
[in] | name | Name of the algorithm to create. name is specified in the engine configuration.
[in] | params | Creation parameters.
[in] | msgSize | Size of the message which will be allocated in the event that this algorithm is configured to run remotely.
[in] | type | String name of the "type" of algorithm.
Return values:
NULL | General failure.
non-NULL | Handle to an algorithm instance.
Remarks:
type must match the package/module name of the interface which the algorithm implements. For example, the VISA interface shipped with CE to support xDM video decoders is named "ti.sdo.ce.video.IVIDDEC". That is, the module IVIDDEC is in the package "ti.sdo.ce.video". You will, by definition, find a file named IVIDDEC.xdc in the ti.sdo.ce.video package.
When calling VISA_create(), a string comparison is done between the type parameter and the actual name of the module (described in the previous paragraph). If these strings don't match exactly, VISA_create() will fail.
See also:
VISA_delete()
Void VISA_delete ( VISA_Handle visa )

Delete an instance of an algorithm.

Parameters:
[in] visa Handle to an algorithm instance to delete.
See also:
VISA_create()
VISA_Handle VISA_create2 | ( | Engine_Handle | engine,
 |  | String | name,
 |  | IALG_Params * | params,
 |  | Int | paramsSize,
 |  | size_t | msgSize,
 |  | String | type
 | ) |  |

Create a new instance of an algorithm.

Parameters:
[in] | engine | Handle to an engine in which the algorithm has been configured.
[in] | name | Name of the algorithm to create. name is specified in the engine configuration.
[in] | params | Creation parameters.
[in] | paramsSize | Size of params.
[in] | msgSize | Size of the message which will be allocated in the event that this algorithm is configured to run remotely.
[in] | type | String name of the "type" of algorithm.
Return values:
NULL | General failure.
non-NULL | Handle to an algorithm instance.
Remarks:
type must match the package/module name of the interface which the algorithm implements. For example, the VISA interface shipped with CE to support xDM video decoders is named "ti.sdo.ce.video.IVIDDEC". That is, the module IVIDDEC is in the package "ti.sdo.ce.video". You will, by definition, find a file named IVIDDEC.xdc in the ti.sdo.ce.video package.
When calling VISA_create2(), a string comparison is done between the type parameter and the actual name of the module (described in the previous paragraph). If these strings don't match exactly, VISA_create2() will fail.
VISA_create() is the preferred method to create algorithms. VISA_create2() is provided to enable creation of algorithms which violate the xDAIS spec and do not have a size field of type "Int" as the first field of params.
See also:
VISA_create()
VISA_delete()
Void VISA_enter ( VISA_Handle visa )

Enter an algorithm's critical section. This must be called before any of the algorithm's IALG_Fxns are invoked.

Parameters:
[in] visa Handle to an algorithm instance.
Remarks:
This is typically called by an algorithm class' application API.
This call has the same semantics as IALG's activate fxn.
See also:
VISA_exit()
Void VISA_exit ( VISA_Handle visa )

Leave an algorithm's critical section. This must be called after the API has completed calling an algorithm's IALG_Fxns.

Parameters:
[in] visa Handle to an algorithm instance.
Remarks:
This call has the same semantics as IALG's de-activate fxn.
See also:
VISA_enter()
Ptr VISA_getAlgHandle ( VISA_Handle visa )

Obtains an algorithm's handle. This is the handle required to be passed to the algorithm's IALG_Fxns.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | General system error
non-NULL | The remote algorithm's message.
Remarks:
This is typically called by an algorithm class' application API.
See also:
VISA_getAlgFxns()
Ptr VISA_getAlgorithmHandle ( VISA_Handle visa )

Obtains an algorithm's handle. If the algorithm is local, this is the handle that can be passed to Algorithm APIs, not to the IALG_Fxns.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | General system error
non-NULL | The Algorithm handle.
Remarks:
This is used internally.
See also:
VISA_getAlgHandle()
IALG_Fxns* VISA_getAlgFxns ( VISA_Handle visa )

Get implementation functions for this algorithm.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | An error has occurred.
non-NULL | The algorithm's IALG_Fxns.
Remarks:
This is typically called by an algorithm class' application API.
Both local and remote implementations return a non-NULL pointer. However, the IALG_Fxns functions may be NULL.
In the case of a local algorithm, the algorithm's IALG_Fxns returned. In the case of a remote algorithm, its stubs are returned. In either case, the handle passed as the first arg to the IALG_Fxns must be the value returned by VISA_getAlgHandle().
See also:
VISA_getAlgHandle()


Codec Engine System Programming Interface (SPI): Data Structures

  • Data Structures
  • Data Structure Index
  • Data Fields

Data Structures

Here are the data structures with brief descriptions:
Engine_AlgDesc | Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine
Engine_AlgInfo | Properties of an Engine algorithm
Engine_AlgInfo2 | Properties of an Engine algorithm
Engine_Attrs | Attributes of an Engine
Engine_DllAlgDesc | Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type
IALG_Fxns | Defines the fields and methods that must be supplied by all XDAIS algorithms
IALG_MemRec | Memory records
IALG_Obj | Algorithm instance object definition
IALG_Params | Algorithm instance creation parameters
IALG_Status | Pointer to algorithm specific status structure
SKEL_Fxns | Table of functions defining the interface of a skeleton
ti_sdo_ce_osal_Memory_AllocParams | Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()
VISA_MsgHeader | VISA message header
xdc_runtime_Memory_Stats |


Codec Engine System Programming Interface (SPI): Engine_AlgDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

Engine_AlgDesc Struct Reference
[Codec Engine Runtime]

Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine. More...

#include <Engine.h>

Collaboration diagram for Engine_AlgDesc:
[legend]

Data Fields

String | name
The name of the algorithm. This is used by the application when instantiating an instance of the algorithm through one of the VISA APIs.
NODE_Uuid | uuid
IALG_Fxns * fxns
The address of the xDAIS alg function table. All xDAIS algorithms must define an IALG_Fxns structure that contains implementations of the IALG methods. This field is simply the address of this structure.
Ptr | idmaFxns
The address of the IDMA3_Fxns function table, if the algorithm uses DMA. If the algorithm does not use DMA, this field should set to NULL.
String * | typeTab
Bool | isLocal
If true, the algorithm will be instantiated on the "local" CPU. Otherwise the server will create an instance of the algorithm.
Int | groupId
This id specifies which resource sharing group that this alg will be placed into. This 'group' concept is used by the framework to ensure algorithms in the same group don't pre-empt each other and corrupt the shared resources. This parameter will be ignored if isLocal is FALSE.
Int | rpcProtocolVersion
Ptr | iresFxns
Address of the xDAIS alg IRES Interface function table All xDAIS algorithms that use an IRES resource must define an IRES_Fxns structure containing the pointers to functions implementatng the IRES interface. If the algorithm does not use an IRES resource this field should be set to NULL.
Void * | codecClassConfig
Codec class configuration data, if any.
Engine_CachedMemType memType
Indicates the type of memory the alg's memory requests will be allocated from. The alg's memory will be allocated from cached memory, if memType = Engine_USECACHEDMEM_CACHED, from non-cached memory, if memType = Engine_USECACHEDMEM_NONCACHED, Otherwise, if memType = Engine_USECACHEDMEM_DEFAULT, memory allocations will be determined by the value of ti_sdo_ce_alg_Algorithm_useCache (cached, if TRUE, non-cached, if FALSE).
String | types
A string idicating the type(s) of algorithm this is. This should be a ';' separated string of inherited types. In most cases, types will just be set to the VISA type defined in the Codec Engine algorithm interface header file included by the algorithm, depending on the XDM interface the algorithm implements.

Detailed Description

Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine.

See also:
Engine_initAlgDesc()
Engine_addAlg()

Field Documentation

String Engine_AlgDesc::name

The name of the algorithm. This is used by the application when instantiating an instance of the algorithm through one of the VISA APIs.

NODE_Uuid Engine_AlgDesc::uuid

Id of alg if running on remote target. No need to set this field.

IALG_Fxns* Engine_AlgDesc::fxns

The address of the xDAIS alg function table. All xDAIS algorithms must define an IALG_Fxns structure that contains implementations of the IALG methods. This field is simply the address of this structure.

Ptr Engine_AlgDesc::idmaFxns

The address of the IDMA3_Fxns function table, if the algorithm uses DMA. If the algorithm does not use DMA, this field should set to NULL.

String* Engine_AlgDesc::typeTab

inheritance hierarchy - Do not modify.

Bool Engine_AlgDesc::isLocal

If true, the algorithm will be instantiated on the "local" CPU. Otherwise the server will create an instance of the algorithm.

Int Engine_AlgDesc::groupId

This id specifies which resource sharing group that this alg will be placed into. This 'group' concept is used by the framework to ensure algorithms in the same group don't pre-empt each other and corrupt the shared resources. This parameter will be ignored if isLocal is FALSE.

Int Engine_AlgDesc::rpcProtocolVersion

Protocol version. Do not modify

Ptr Engine_AlgDesc::iresFxns

Address of the xDAIS alg IRES Interface function table All xDAIS algorithms that use an IRES resource must define an IRES_Fxns structure containing the pointers to functions implementatng the IRES interface. If the algorithm does not use an IRES resource this field should be set to NULL.

Void* Engine_AlgDesc::codecClassConfig

Codec class configuration data, if any.

Engine_CachedMemType Engine_AlgDesc::memType

Indicates the type of memory the alg's memory requests will be allocated from. The alg's memory will be allocated from cached memory, if memType = Engine_USECACHEDMEM_CACHED, from non-cached memory, if memType = Engine_USECACHEDMEM_NONCACHED, Otherwise, if memType = Engine_USECACHEDMEM_DEFAULT, memory allocations will be determined by the value of ti_sdo_ce_alg_Algorithm_useCache (cached, if TRUE, non-cached, if FALSE).

See also:
Engine_CachedMemType Memory type for alg's mem reqs.
String Engine_AlgDesc::types

A string idicating the type(s) of algorithm this is. This should be a ';' separated string of inherited types. In most cases, types will just be set to the VISA type defined in the Codec Engine algorithm interface header file included by the algorithm, depending on the XDM interface the algorithm implements.

For example, if the algorithm implements the ISPHDEC1 interface as defined by XDM, types should be set to SPHDEC1_VISATYPE (defined as "ti.sdo.ce.speech1.ISPHDEC1" in the header file ti/sdo/ce/speech1/sphdec1.h).

Another example to illustrate multiple typss specified in typss, if the algorithm implements the (made-up) interface, ti.sdo.ce.test.xvideo.IVIDE, which in turn implements the IVIDDEC interface, we could then set types to VIDDEC_VISATYPE";ti.sdo.ce.test.xvideo.IVIDE" or "ti.sdo.ce.test.xvideo.IVIDE;"VIDDEC_VISATYPE

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine System Programming Interface (SPI): Engine_AlgInfo Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

Engine_AlgInfo Struct Reference
[Codec Engine Runtime]

Properties of an Engine algorithm. More...

#include <Engine.h>

Data Fields

Int | algInfoSize
String | name
String * | typeTab
Bool | isLocal

Detailed Description

Properties of an Engine algorithm.

See also:
Engine_getAlgInfo()

Field Documentation

Int Engine_AlgInfo::algInfoSize

Size of this structure.

String Engine_AlgInfo::name

Name of algorithm.

String* Engine_AlgInfo::typeTab

Inheritance hierarchy.

Bool Engine_AlgInfo::isLocal

If TRUE, run locally.

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine System Programming Interface (SPI): Engine_AlgInfo2 Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

Engine_AlgInfo2 Struct Reference
[Codec Engine Runtime]

Properties of an Engine algorithm. More...

#include <Engine.h>

Data Fields

Int | algInfoSize
String | name
String | types
Bool | isLocal

Detailed Description

Properties of an Engine algorithm.

Remarks:
This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a single string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE".
See also:
Engine_getAlgInfo2()

Field Documentation

Int Engine_AlgInfo2::algInfoSize

Size of this structure.

String Engine_AlgInfo2::name

Name of algorithm.

String Engine_AlgInfo2::types

Inheritance hierarchy.

Bool Engine_AlgInfo2::isLocal

If TRUE, run locally.

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine System Programming Interface (SPI): Engine_Attrs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

Engine_Attrs Struct Reference
[Codec Engine Runtime]

Attributes of an Engine. More...

#include <Engine.h>

Data Fields

String procId

Detailed Description

Attributes of an Engine.

See also:
Engine_initAttrs().
Engine_open().

Field Documentation

String Engine_Attrs::procId

id of the processor that runs the server; only needed in the case that there's more than one processor that can provide the same server.

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine System Programming Interface (SPI): Engine_DllAlgDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

Engine_DllAlgDesc Struct Reference
[Codec Engine Runtime]

Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type. More...

#include <Engine.h>

Collaboration diagram for Engine_DllAlgDesc:
[legend]

Data Fields

IALG_Fxns * fxns
Pointer to codec's IALG_Fxns. This can not be NULL.
Ptr | idmaFxns
Pointer to codec's IDMA3_Fxns table. If the codec does not use DMA, this should be NULL.
Ptr | iresFxns
Pointer to codec's IRES_Fxns function table. This should be NULL if the codec does not implement the IRES_Fxns.
String | types
Inheritance hierarchy of codec. This is a ';' separated string that lists the interfaces inherited by the code. For example:
Void * | codecClassConfig
codec class config data, if any.

Detailed Description

Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type.

See also:
Engine_GetAlgDescFxn

Field Documentation

IALG_Fxns* Engine_DllAlgDesc::fxns

Pointer to codec's IALG_Fxns. This can not be NULL.

Ptr Engine_DllAlgDesc::idmaFxns

Pointer to codec's IDMA3_Fxns table. If the codec does not use DMA, this should be NULL.

Ptr Engine_DllAlgDesc::iresFxns

Pointer to codec's IRES_Fxns function table. This should be NULL if the codec does not implement the IRES_Fxns.

String Engine_DllAlgDesc::types

Inheritance hierarchy of codec. This is a ';' separated string that lists the interfaces inherited by the code. For example:

"ti.sdo.ce.speech1.ISPHDEC1"

or, in the case where a test IVIDE interface inherits IVIDDEC:

"ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE"

Void* Engine_DllAlgDesc::codecClassConfig

codec class config data, if any.

Todo:
Figure out what this is.
The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine System Programming Interface (SPI): IALG_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

IALG_Fxns Struct Reference
[IALG - XDAIS Algorithm Interface]

Defines the fields and methods that must be supplied by all XDAIS algorithms. More...

#include <ialg.h>

Data Fields

Void * | implementationId
Unique pointer that identifies the module implementing this interface.
Void(* | algActivate )(IALG_Handle handle)
Notification to the algorithm that its memory is "active" and algorithm processing methods may be called.
Int(* | algAlloc )(const IALG_Params *params, struct IALG_Fxns **parentFxns, IALG_MemRec *memTab)
Apps call this to query the algorithm about its memory requirements. Must be non-NULL.
Int(* | algControl )(IALG_Handle handle, IALG_Cmd cmd, IALG_Status *status)
Algorithm specific control and status.
Void(* | algDeactivate )(IALG_Handle handle)
Save all persistent data to non-scratch memory.
Int(* | algFree )(IALG_Handle handle, IALG_MemRec *memTab)
Apps call this to allow the algorithm to initialize memory requested via algAlloc(). Must be non-NULL.
Int(* | algInit )(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)
Initialize an algorithm's instance object. Must be non-NULL.
Void(* | algMoved )(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)
Notify algorithm instance that instance memory has been relocated.
Int(* | algNumAlloc )(Void)
Number of memory allocation requests required.

Detailed Description

Defines the fields and methods that must be supplied by all XDAIS algorithms.

Field Documentation

Void* IALG_Fxns::implementationId

Unique pointer that identifies the module implementing this interface.

Void(* IALG_Fxns::algActivate)(IALG_Handle handle)

Notification to the algorithm that its memory is "active" and algorithm processing methods may be called.

Parameters:
[in] handle Handle to an algorithm instance.
Remarks:
algActivate() initializes any of the instance's scratch buffers using the persistent memory that is part of the algorithm's instance object.
The implementation of algActivate() (and algDeactivate()) is required if the algorithm requests memory of type IALG_SCRATCH.
The algActivate() method should only be implemented if a module wants to factor out initialization code that can be executed once prior to processing multiple consecutive frames of data.
If a module does not implement this method, the algActivate() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to the following implementation:
      Void algActivate(IALG_Handle handle)
      {
      }
Precondition:
algActivate() can only be called after a successful return from algInit().
handle must be a valid handle for the algorithm's instance object.
No other algorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
If the algorithm has implemented the IDMA2 interface, algActivate() can only be called after a successful return from dmaInit().
Postcondition:
All methods related to the algorithm may now be executed by client (subject to algorithm specific restrictions).
See also:
algDeactivate().
Int(* IALG_Fxns::algAlloc)(const IALG_Params *params, struct IALG_Fxns **parentFxns, IALG_MemRec *memTab)

Apps call this to query the algorithm about its memory requirements. Must be non-NULL.

Parameters:
[in] | params | Algorithm specific attributes.
[out] | parentFxns | Parent algorithm functions.
[out] | memTab | array of memory records.
Remarks:
algAlloc() returns a table of memory records that describe the size, alignment, type and memory space of all buffers required by an algorithm (including the algorithm's instance object itself). If successful, this function returns a positive non-zero value indicating the number of records initialized. This function can never initialize more memory records than the number returned by algNumAlloc().
If algNumAlloc() is not implemented, the maximum number of initialized memory records is IALG_DEFMEMRECS.
The first argument to algAlloc() is a pointer to the creation parameters for the instance of the algorithm object to be created. This pointer is algorithm-specific; i.e., it points to a structure that is defined by each particular algorithm. This pointer may be NULL; however, in this case, algAlloc() must assume default creation parameters and must not fail.
The second argument to algAlloc() is an optional parameter. algAlloc() may return a pointer to its parent's IALG functions. If this output value is assigned a non-NULL value, the client must create the parent instance object using the designated IALG functions pointer. The parent instance object must then be passed to algInit().
algAlloc() may be called at any time and it must be idempotent; i.e., it can be called repeatedly without any side effects, and always returns the same result.
Algorithms are encouraged to return (and document!) clear, algorithm-specific error codes from algAlloc(). Create-time failures are a common integration issue, and the clearer a return value, the sooner the algorithm integrator can identify and resolve the issue.
Precondition:
The number of memory records in the array memTab[] is no less than the number returned by algNumAlloc().
*parentFxns is a valid pointer to an IALG_Fxns pointer variable.
Postcondition:
If the algorithm needs a parent object to be created, the pointer *parentFxns is set to a non-NULL value that points to a valid IALG_Fxns structure, the parent's IALG implementation. Otherwise, this pointer is not set. algAlloc() may elect to ignore the parentFxns pointer altogether.
For each memory descriptor in memTab with an IALG_WRITEONCE attribute, the algorithm has either set the base field to a non-NULL value, which is the address of a statically allocated and initialized memory buffer of the indicated 'size', or has set the base field to NULL, thereby requiring the memory for the buffer to be provided by the client.
Exactly n elements of the memTab[] array are initialized, where n is the return value from this operation.
For each memory descriptor in memTab with an IALG_PERSIST or IALG_SCRATCH attribute, the algorithm does not set its base field.
memTab[0] defines the memory required for the instance's object and this object's first field is an IALG_Obj structure.
memTab[0] is requested as persistent memory.
See also:
algFree()
Int(* IALG_Fxns::algControl)(IALG_Handle handle, IALG_Cmd cmd, IALG_Status *status)

Algorithm specific control and status.

Parameters:
[in] | handle | Algorithm instance handle.
[in] | cmd | Algorithm specific command.
[out] | status | Algorithm specific status.
Remarks:
algControl() sends an algorithm specific command, cmd, and an input/output status buffer pointer to an algorithm's instance object.
In preemptive execution environments, algControl() may preempt a module's other metods (for example, its processing methods).
The implementation of algControl() is optional. If a module does not implement this method, the algControl() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to the following implementation:
      Void algControl(IALG_Handle handle, IALG_Cmd cmd, IALG_Status *status)
      {
          return (IALG_EFAIL);
      }
Precondition:
algControl() can only be called after a successful return from algInit().
handle must be a valid handle for the algorithm's instance object.
Algorithm specific cmd values are always less than IALG_SYSCMD.
Postcondition:
If the cmd value is not recognized by the algorithm, the return value is not equal to IALG_EOK.
See also:
algInit()
Void(* IALG_Fxns::algDeactivate)(IALG_Handle handle)

Save all persistent data to non-scratch memory.

Parameters:
[in] handle Algorithm instance handle.
Remarks:
algDeactivate() saves any persistent information to non-scratch buffers using the persistent memory that is part of the algorithm's instance object.
handle is used by the algorithm to identify the various buffers that must be saved prior to the next cycle of algActivate() and processing.
The implementation of algDeactivate() (and algActivate()) is required if the algorithm requests memory of type IALG_SCRATCH.
The algDeactivate() method is only implemented if a module wants to factor out initialization code that can be executed once prior to processing multiple consecutive frames of data.
If a module does not implement this method, the algDeactivate() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to the following implementation:
      Void algDeactivate(IALG_Handle handle)
      {
      }
Precondition:
algDeactivate() can only be called after a successful return from algInit().
The instance object is currently "active"; i.e., all instance memory is active and if an algActivate() method is defined, it has been called.
handle must be a valid handle for the algorithm's instance object.
No other algorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
Postcondition:
No methods related to the algorithm may now be executed by the client; only algActivate() or algFree() may be called.
All instance scratch memory may be safely overwritten.
See also:
algActivate()
Int(* IALG_Fxns::algFree)(IALG_Handle handle, IALG_MemRec *memTab)

Apps call this to allow the algorithm to initialize memory requested via algAlloc(). Must be non-NULL.

Parameters:
[in] | handle | Algorithm instance handle.
[out] | memTab | Output array of memory records.
Remarks:
algFree() returns a table of memory records that describe the base address, size, alignment, type and memory space of all buffers previously allocated for the algorithm's instance (including the algorithm's instance object itself) specified by handle. This function always returns a positive non-zero value indicating the number of records initialized. This function can never initialize more memory records than the value returned by algNumAlloc().
Precondition:
The memTab[] array contains at least algNumAlloc() records.
handle must be a valid handle for the algorithm's instance object.
If the prior call to algAlloc() returned a non-NULL parent functions pointer, then the parent instance must be an active instance object created via that function pointer.
No other agorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
Postcondition:
memTab[] contains pointers to all of the memory passed to the algorithm via algInit().
The size and alignment fields contain the same values passed to the client via algAlloc(); i.e., if the client makes changes to the values returned via algAlloc() and passes these new values to algInit(), the algorithm is not responsible for retaining any such changes.
See also:
algAlloc()
Int(* IALG_Fxns::algInit)(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)

Initialize an algorithm's instance object. Must be non-NULL.

Parameters:
[in] | handle | Algorithm instance handle. This is a pointer to an initialized IALG_Obj structure. Its value is identical to the memTab[0].base.
[in] | memTab | Array of allocated buffers.
[in] | parent | Handle of algorithm's parent instance.
[in] | params | Pointer to algorithm's instance parameters.
Remarks:
algInit() performs all initialization necessary to complete the run-time creation of an algorithm's instance object. After a successful return from algInit(), the algorithm's instance object is ready to be used to process data.
handle is a pointer to an initialized IALG_Obj structure. Its value is identical to the memTab[0].base.
memTab is a table of memory records that describe the base address, size, alignment, type, and memory space of all buffers allocated for an algorithm instance (including the algorithm's instance object itself). The number of initialized records is identical to the number returned by a prior call to algAlloc().
parent is a handle to another algorithm instance object. This parameter is often NULL; indicating that no parent object exists. This parameter allows clients to create a shared algorithm instance object and pass it to other algorithm instances. For example, a parent instance object might contain global read-only tables that are used by several instances of a vocoder.
params is a pointer to algorithm-specific parameters that are necessary for the creation and initialization of the instance object. This pointer points to the same parameters passed to the algAlloc() operation. However, this pointer may be NULL. In this case, algInit(), must assume default creation parameters.
Algorithms are encouraged to return (and document!) clear, algorithm-specific error codes from algInit(). Create-time failures are a common integration issue, and the clearer a return value, the sooner the algorithm integrator can identify and resolve the issue.
The algorithm must not access any scratch resources, memory or otherwise, until it has been activated (see algActivate()). A common error is to initialize scratch resources during algInit(). This is an error as another algorithm, or instance of the same algorithm, may be active when this instance's algInit() is called. This algorithm must not access scratch resources until it is active.
The client is not required to satisfy the IALG_MemSpace attribute of the requested memory. Note however that C6000 algorithms that use DMA may strictly require the client to satisfy its on-chip memory requirements and may not function correctly otherwise.
The client may allocate the requested IALG_WRITEONCE buffers once (or never, if the algorithm has assigned a base address in the prior call to algAlloc) and use the same buffers to initialize multiple instances of the same algorithm that are created with identical parameters.
Example:
      typedef struct EncoderObj {
          IALG_Obj ialgObj;
          int workBuf;
          Int workBufLen;
          ... ;
      } EncoderObj;

      Int algInit(IALG_Handle handle, IALG_MemRec memTab[],
              IALG_Handle parent, IALG_Params *params)
      {
          EncoderObj *inst = (EncoderObj *)handle;
          EncoderParams *encParams = (EncoderParams *)params;

          if (encParams == NULL) {
              encParams = MYDEFAULTPARAMS;
          }

          if (IALG_isOffChip(memTab[1].space)) {
              // unsupported off-chip memory, return documented error code
              return (MYMOD_MYVENDOR_EUNSUPPORTEDOFFCHIPWORKBUF);
          }

          inst->workBuf = memTab[1].base;
          inst->workBufLen = encParams->frameDuration * 8;
          ...

          return (IALG_EOK);
      }
Precondition:
memTab contains pointers to non-overlapping buffers with the size and alignment requested via a prior call to algAlloc(). In addition, the algorithm parameters, params, passed to algAlloc() are identical to those passed to this operation.
handle must be a valid handle for the algorithm's instance object; i.e., handle == memTab[0].base and handle->fxns is initialized to point to the appropriate IALG_Fxns structure.
The prior call to algAlloc() using same creation params must have returned value > 1. This pre-condition ensures that any create-time parameter validation can be done once (in algAlloc()), and is not required to be done in algInit(). Note that algInit() can, and should, validate any algorithm- specific requirements on resources received (e.g. internal memory, etc).
If the prior call to algAlloc() has not assigned a non-NULL base address to an IALG_WRITEONCE memTab entry, the client must provide the memory resource with the requested size and alignment.
If the prior call to algAlloc() returned a non-NULL parent functions pointer, then the parent handle, parent, must be a valid handle to an instance object created via that function pointer.
No other algorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
If parent is non-NULL, no other method is currently being run on the parent instance; i.e., this method never preempts any other method on the parent instance.
If the prior call to algAlloc() assigned a non-NULL base address to an IALG_WRITEONCE memTab[] entry, the client may pass back the same address in the base field without allocating additional memory for that persistent write-once buffer. Alternatively, the client may treat IALG_WRITEONCE buffers in the same way as IALG_PERSIST buffers; by allocating new memory and granting it to the algorithm using the base field.
The buffer pointed to in memTab[0] is initialized with a pointer to the appropriate IALG_Fxns structure followed by all 0s.
Postcondition:
With the exception of any initialization performed by algActivate() and any optional auxilary interface initialization functions (such as IRES and IDMA3), all of the instance's persistent and write-once memory is initialized and the object is ready to be used.
All subsequent memory accesses to the IALG_WRITEONCE buffers by this algorithm instance will be read-only.
If the algorithm has implemented the IDMA2 interface, the dmaGetChannels() operation can be called.
Return values:
IALG_EOK

Successful return status code.

IALG_EFAIL

Unspecified error return status code.

Custom error Algorithm-specific error - see algorithm's documentation.
See also:
algAlloc()
algMoved()
Void(* IALG_Fxns::algMoved)(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)

Notify algorithm instance that instance memory has been relocated.

Parameters:
[in] | handle | Algorithm instance handle.
[in] | memTab | Array of allocated buffers.
[in] | parent | Handle of algorithm's parent instance.
[in] | params | Pointer to algorithm's instance parameters.
Remarks:
algMoved() performs any reinitialization necessary to insure that, if an algorithm's instance object has been moved by the client, all internal data references are recomputed.
The implementation of algMoved() is optional. However, it is highly recommended that this method be implemented. If a module does not implement this method, the algMoved() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to asserting that the algorithm's instance objects cannot be moved.
Int(* IALG_Fxns::algNumAlloc)(Void)

Number of memory allocation requests required.

Remarks:
algNumAlloc() returns the maximum number of memory allocation requests that the algAlloc() method requires. This operation allows clients to allocate sufficient space to call the algAlloc() method or fail because insufficient space exists to support the creation of the algorithm's instance object. algNumAlloc() may be called at any time, and it must be idempotent; i.e., it can be called repeatedly without any side effects, and always returns the same result.
algNumAlloc() is optional; if it is not implemented, the maximum number of memory records for algAlloc() is assumed to be IALG_DEFMEMRECS. This is equivalent to the following implementation:
      Void algNumAlloc(Void)
      {
          return (IALG_DEFNUMRECS);
      }
If a module does not implement this method, the algNumAlloc() field in the module's static function table (of type IALG_Fxns) must be set to NULL.
Postcondition:
The return value from algNumAlloc() is always greater than or equal to one and always equals or exceeds the value returned by algAlloc().
Example:
      #define NUMBUF 3
      extern IALG_Fxns *subAlg;

      Int algNumAlloc(Void)
      {
          return (NUMBUF + subAlg->algNumAlloc());
      }

      Int algAlloc(const IALG_Params *p, struct IALG_Fxns **pFxns,
              IALG_MemRec memTab)
      {
          Int n;

          ...

          n = subAlg->algAlloc(0, memTab);
          return (n + NUMBUF);
      }
See also:
algAlloc()
The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine System Programming Interface (SPI): IALG_MemRec Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

IALG_MemRec Struct Reference
[IALG - XDAIS Algorithm Interface]

Memory records. More...

#include <ialg.h>

Data Fields

Uns | size
Int | alignment
IALG_MemSpace space
IALG_MemAttrs attrs
Void * | base

Detailed Description

Memory records.

Field Documentation

Uns IALG_MemRec::size

Size in MAU of allocation

Int IALG_MemRec::alignment

Alignment requirement (MAU)

IALG_MemSpace IALG_MemRec::space

Allocation space

IALG_MemAttrs IALG_MemRec::attrs

Memory attributes

Void* IALG_MemRec::base

Base address of allocated buf

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine System Programming Interface (SPI): IALG_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

IALG_Obj Struct Reference
[IALG - XDAIS Algorithm Interface]

Algorithm instance object definition. More...

#include <ialg.h>

Collaboration diagram for IALG_Obj:
[legend]

Data Fields

struct IALG_Fxns * fxns

Detailed Description

Algorithm instance object definition.

Remarks:
All XDAIS algorithm instance objects must have this structure as their first element. However, they do not need to initialize it; initialization of this sub-structure is done by the "framework".

Field Documentation

struct IALG_Fxns* IALG_Obj::fxns

Pointer to IALG function table.

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine System Programming Interface (SPI): IALG_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

IALG_Params Struct Reference
[IALG - XDAIS Algorithm Interface]

Algorithm instance creation parameters. More...

#include <ialg.h>

Data Fields

Int size

Detailed Description

Algorithm instance creation parameters.

Remarks:
All XDAS algorithm parameter structures must have this as their first element.

Field Documentation

Int IALG_Params::size

Number of MAU in the structure

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine System Programming Interface (SPI): IALG_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

IALG_Status Struct Reference
[IALG - XDAIS Algorithm Interface]

Pointer to algorithm specific status structure. More...

#include <ialg.h>

Data Fields

Int size

Detailed Description

Pointer to algorithm specific status structure.

Remarks:
All XDAIS algorithm parameter structures must have this as their first element.

Field Documentation

Int IALG_Status::size

Number of MAU in the structure

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine System Programming Interface (SPI): SKEL_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

SKEL_Fxns Struct Reference
[CE Skeleton SPI]

Table of functions defining the interface of a skeleton. More...

#include <skel.h>

Data Fields

SKEL_CALLFXN call
SKEL_CREATEFXN apiCreate
SKEL_DESTROYFXN apiDestroy

Detailed Description

Table of functions defining the interface of a skeleton.

Field Documentation

SKEL_CALLFXN SKEL_Fxns::call

A skeleton's "call" implementation.

SKEL_CREATEFXN SKEL_Fxns::apiCreate

A skeleton's "create" API.

SKEL_DESTROYFXN SKEL_Fxns::apiDestroy

A skeleton's "destroy" API.

The documentation for this struct was generated from the following file:
  • skel.h


Codec Engine System Programming Interface (SPI): ti_sdo_ce_osal_Memory_AllocParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

ti_sdo_ce_osal_Memory_AllocParams Struct Reference
[Memory - OS Independent Memory Interface]

Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free() More...

#include <Memory.h>

Data Fields

ti_sdo_ce_osal_Memory_type type
UInt | flags
UInt | align
UInt | seg

Detailed Description

Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()

Remarks:
This definition also has a short name alias of Memory_AllocParams.
See also:
ti_sdo_ce_osal_Memory_DEFAULTPARAMS

Field Documentation

ti_sdo_ce_osal_Memory_type ti_sdo_ce_osal_Memory_AllocParams::type

Type of allocation.

See also:
ti_sdo_ce_osal_Memory_type
UInt ti_sdo_ce_osal_Memory_AllocParams::flags

Flags affecting allocation.

Remarks:
Note that some OS's don't provide cacheability settings on a per-buffer allocation, and this field may be ignored. As an example, BIOS running on C6000 devices use MAR bits (at 16MB granularity) for marking memory regions as cached or not. In those systems, this field is ignored, and the MAR bits will dictate the cacheability of a buffer.
See also:
ti_sdo_ce_osal_Memory_CACHED
ti_sdo_ce_osal_Memory_NONCACHED
UInt ti_sdo_ce_osal_Memory_AllocParams::align

Alignment of allocation.

UInt ti_sdo_ce_osal_Memory_AllocParams::seg

Segment for allocation.

The documentation for this struct was generated from the following file:
  • packages/ti/sdo/ce/osal/Memory.h


Codec Engine System Programming Interface (SPI): VISA_MsgHeader Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

VISA_MsgHeader Struct Reference
[VISA - CE Stub SPIs]

VISA message header. More...

#include <visa.h>

Data Fields

NODE_MsgHeader | header
Int | cmd
VISA_Status status

Detailed Description

VISA message header.

Remarks:
This must be the first field in a message

Field Documentation

NODE_MsgHeader VISA_MsgHeader::header
Int VISA_MsgHeader::cmd

Command id

VISA_Status VISA_MsgHeader::status

Return status

The documentation for this struct was generated from the following file:
  • visa.h


Codec Engine System Programming Interface (SPI): xdc_runtime_Memory_Stats Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields
Data Fields

xdc_runtime_Memory_Stats Struct Reference

#include <Memory.h>

Data Fields

xdc_runtime_Memory_Size totalSize
xdc_runtime_Memory_Size totalFreeSize
xdc_runtime_Memory_Size largestFreeSize

Field Documentation

xdc_runtime_Memory_Size xdc_runtime_Memory_Stats::totalSize
xdc_runtime_Memory_Size xdc_runtime_Memory_Stats::totalFreeSize
xdc_runtime_Memory_Size xdc_runtime_Memory_Stats::largestFreeSize
The documentation for this struct was generated from the following file:
  • cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • algActivate : IALG_Fxns
  • algAlloc : IALG_Fxns
  • algControl : IALG_Fxns
  • algDeactivate : IALG_Fxns
  • algFree : IALG_Fxns
  • algInfoSize : Engine_AlgInfo , Engine_AlgInfo2
  • algInit : IALG_Fxns
  • algMoved : IALG_Fxns
  • algNumAlloc : IALG_Fxns
  • align : ti_sdo_ce_osal_Memory_AllocParams
  • alignment : IALG_MemRec
  • apiCreate : SKEL_Fxns
  • apiDestroy : SKEL_Fxns
  • attrs : IALG_MemRec

- b -

  • base : IALG_MemRec

- c -

  • call : SKEL_Fxns
  • cmd : VISA_MsgHeader
  • codecClassConfig : Engine_AlgDesc , Engine_DllAlgDesc

- f -

  • flags : ti_sdo_ce_osal_Memory_AllocParams
  • fxns : Engine_DllAlgDesc , Engine_AlgDesc , IALG_Obj

- g -

  • groupId : Engine_AlgDesc

- h -

  • header : VISA_MsgHeader

- i -

  • idmaFxns : Engine_AlgDesc , Engine_DllAlgDesc
  • implementationId : IALG_Fxns
  • iresFxns : Engine_AlgDesc , Engine_DllAlgDesc
  • isLocal : Engine_AlgDesc , Engine_AlgInfo2 , Engine_AlgInfo

- l -

  • largestFreeSize : xdc_runtime_Memory_Stats

- m -

  • memType : Engine_AlgDesc

- n -

  • name : Engine_AlgInfo , Engine_AlgDesc , Engine_AlgInfo2

- p -

  • procId : Engine_Attrs

- r -

  • rpcProtocolVersion : Engine_AlgDesc

- s -

  • seg : ti_sdo_ce_osal_Memory_AllocParams
  • size : IALG_MemRec , IALG_Status , IALG_Params
  • space : IALG_MemRec
  • status : VISA_MsgHeader

- t -

  • totalFreeSize : xdc_runtime_Memory_Stats
  • totalSize : xdc_runtime_Memory_Stats
  • type : ti_sdo_ce_osal_Memory_AllocParams
  • types : Engine_AlgInfo2 , Engine_AlgDesc , Engine_DllAlgDesc
  • typeTab : Engine_AlgDesc , Engine_AlgInfo

- u -

  • uuid : Engine_AlgDesc


Codec Engine System Programming Interface (SPI): File Index

  • File List
  • Globals

File List

Here is a list of all files with brief descriptions:
Engine.h [code] | The Codec Engine Runtime
ialg.h [code] | This header defines all types, constants, and functions defined by XDAIS for algorithms
cetools/packages/xdc/runtime/Memory.h [code] |
packages/ti/sdo/ce/osal/Memory.h [code] | The Codec Engine OSAL Memory interface. Provides the user an OS-independent Memory abstraction
skel.h [code] | The Codec Engine System Programming Interface (SPI) for skeleton developers
spi.h [code] |
visa.h [code] | The Codec Engine System Programming Interface. Provides system developers with services necessary to implement stubs and skeletons
xdas.h [code] | This header defines all types and constants used in the XDAS interfaces


Codec Engine System Programming Interface (SPI): Engine.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce
Data Structures | Defines | Typedefs | Enumerations | Functions | Variables

Engine.h File Reference

Detailed Description

The Codec Engine Runtime.

Remarks:
Provides the user an interface to open and manipulate an Engine which can instantiate and communicate with XDAIS algorithms that run either on the local CPU or on a "remote" Server.
#include <ti/sdo/ce/Server.h>
#include <ti/sdo/ce/ipc/Comm.h>
#include <ti/xdais/ialg.h>
#include <ti/sdo/ce/node/node.h>
#include <stddef.h>
#include <stdio.h>
Include dependency graph for Engine.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | Engine_Attrs
Attributes of an Engine. More...
struct | Engine_AlgInfo
Properties of an Engine algorithm. More...
struct | Engine_AlgInfo2
Properties of an Engine algorithm. More...
struct | Engine_AlgDesc
Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine. More...
struct | Engine_DllAlgDesc
Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type. More...

Defines

#define | Engine_MODNAME "ti.sdo.ce.Engine"
Name to pass to Diags_setMask() to enable logging for Engine functions.
#define | Engine_EOK 0
#define | Engine_EEXIST 1
#define | Engine_ENOMEM 2
#define | Engine_EDSPLOAD 3
#define | Engine_ENOCOMM 4
#define | Engine_ENOSERVER 5
#define | Engine_ECOMALLOC 6
#define | Engine_ERUNTIME 7
#define | Engine_ECODECCREATE 8
#define | Engine_ECODECSTART 9
#define | Engine_EINVAL 10
#define | Engine_EBADSERVER 11
#define | Engine_ENOTAVAIL 12
#define | Engine_EWRONGSTATE 13
#define | Engine_EINUSE 14
#define | Engine_ENOTFOUND 15
#define | Engine_ETIMEOUT 16
#define | Engine_GETALGDESCFXN "GetEngineAlgDesc"
Name of function that a dynamically loaded codec must supply.

Typedefs

typedef struct Engine_Obj * | Engine_Handle
Opaque handle to an engine.
typedef Int | Engine_Error
Engine error code.
typedef struct Engine_Attrs | Engine_Attrs
Attributes of an Engine.
typedef struct Engine_AlgInfo | Engine_AlgInfo
Properties of an Engine algorithm.
typedef struct Engine_AlgInfo2 | Engine_AlgInfo2
Properties of an Engine algorithm.
typedef enum Engine_CachedMemType | Engine_CachedMemType
Engine Cacheable Memory types.
typedef struct Engine_AlgDesc | Engine_AlgDesc
Descriptor for an alg. This object can be passed to Engine_addAlg(), to dynamically add an alg to an engine.
typedef struct Engine_DllAlgDesc | Engine_DllAlgDesc
Descriptor for a dynamically loaded alg. A dynamic library for a codec must export a function that fills in a structure of this type.
typedef Int(* | Engine_GetAlgDescFxn )(Engine_DllAlgDesc *dllAlgDesc)
Prototype of function that must be supplied by a dynamic codec library to fill in a Engine_DllAlgDesc structure.

Enumerations

enum Engine_CachedMemType {
Engine_USECACHEDMEM_DEFAULT = -1,
Engine_USECACHEDMEM_NONCACHED = 0,
Engine_USECACHEDMEM_CACHED = 1
}

Engine Cacheable Memory types.

More...

Functions

Engine_Error | Engine_addStubFxns (String fxnsName, IALG_Fxns *fxns)
Register stub functions through which a remote algorithm can be called.
Engine_Error | Engine_add (Engine_Desc *pDesc)
Add an Engine to the database of engines that can be opened with Engine_open()
Engine_Error | Engine_addAlg (String name, Engine_Handle engine, String location, Engine_AlgDesc *pAlgDesc)
Dynamically add an algorithm to an Engine.
Engine_Error | Engine_removeAlg (String name, Engine_Handle engine, String algName)
Dynamically remove an algorithm that was added to an Engine with Engine_addAlg().
Void | Engine_close (Engine_Handle engine)
Close an Engine.
Void | Engine_initAlgDesc (Engine_AlgDesc *pAlgDesc)
Initialize an Engine_AlgDesc structure with default values.
Void | Engine_initAttrs (Engine_Attrs *pAttrs)
Initialize an Engine_Attrs structure with default values.
Void | Engine_initDesc (Engine_Desc *pDesc)
Initialize an Engine_Desc structure with default values.
Engine_Handle | Engine_open (String name, Engine_Attrs *attrs, Engine_Error *ec)
Open an Engine.
Int | Engine_fwriteTrace (Engine_Handle engine, String prefix, FILE *out)
Write Server's trace buffer to specifed file stream.
Engine_Error | Engine_getAlgInfo (String name, Engine_AlgInfo *algInfo, Int index)
Get details of an algorithm configured into an engine.
Engine_Error | Engine_getAlgInfo2 (String name, Engine_Handle engine, Engine_AlgInfo2 *algInfo2, Int index)
Get details of an algorithm.
Engine_Error | Engine_getDesc (String name, Engine_Desc *desc)
Fill in an Engine_Desc structure with the values of the Engine descriptor for an Engine.
Engine_Error | Engine_getLastError (Engine_Handle engine)
Get error code of the last failed operation.
String | Engine_getName (Engine_Handle engine)
Get the name of an opened engine.
Engine_Error | Engine_getNumAlgs (String name, Int *numAlgs)
Get the number of algorithms configured into an Engine.
Engine_Error | Engine_getNumAlgs2 (String name, Engine_Handle engine, Int *numAlgs)
Get the number of algorithms statically configured into an engine or the total number of algorithms both statically configured and dynamically added through server information when the engine was opened.
Server_Handle | Engine_getServer (Engine_Handle engine)
Get handle to an Engine's Server.
UInt32 | Engine_getUsedMem (Engine_Handle engine)
Get Server's total memory usage.
Engine_Error | Engine_remove (String engineName)
Remove an engine from the list of engines that can be opened.
Engine_Error | Engine_setDesc (String name, Engine_Desc *desc)
Set values for an Engine's descriptor. This function should only be called when the Engine has not yet been opened.
Int | Engine_setTrace (Engine_Handle engine, String mask)
Set Server's trace mask.

Variables

Engine_Attrs Engine_ATTRS
Default engine attributes.


Codec Engine System Programming Interface (SPI): ialg.h File Reference

  • File List
  • Globals
  • cetools
  • packages
  • ti
  • xdais
Data Structures | Defines | Typedefs | Enumerations

ialg.h File Reference

Detailed Description

This header defines all types, constants, and functions defined by XDAIS for algorithms.

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IALG_MemRec
Memory records. More...
struct | IALG_Obj
Algorithm instance object definition. More...
struct | IALG_Params
Algorithm instance creation parameters. More...
struct | IALG_Status
Pointer to algorithm specific status structure. More...
struct | IALG_Fxns
Defines the fields and methods that must be supplied by all XDAIS algorithms. More...

Defines

#define | IALG_DEFMEMRECS 4
#define | IALG_OBJMEMREC 0
#define | IALG_SYSCMD 256
#define | IALG_EOK 0
#define | IALG_EFAIL -1
#define | IALG_CUSTOMFAILBASE -2048
#define | IALG_CUSTOMFAILEND -256
#define | IALG_MPROG 0x0008
#define | IALG_MXTRN 0x0010
#define | IALG_isProg(s)
#define | IALG_isOffChip(s)

Typedefs

typedef enum IALG_MemAttrs | IALG_MemAttrs
Memory attributes.
typedef enum IALG_MemSpace | IALG_MemSpace
Defined memory spaces.
typedef struct IALG_MemRec | IALG_MemRec
Memory records.
typedef struct IALG_Obj | IALG_Obj
Algorithm instance object definition.
typedef struct IALG_Obj * | IALG_Handle
Handle to an algorithm instance object.
typedef struct IALG_Params | IALG_Params
Algorithm instance creation parameters.
typedef struct IALG_Status | IALG_Status
Pointer to algorithm specific status structure.
typedef unsigned int | IALG_Cmd
Algorithm specific command.
typedef struct IALG_Fxns | IALG_Fxns
Defines the fields and methods that must be supplied by all XDAIS algorithms.

Enumerations

enum IALG_MemAttrs {
IALG_SCRATCH,
IALG_PERSIST,
IALG_WRITEONCE
}

Memory attributes.

More...
enum IALG_MemSpace {
IALG_EPROG,
IALG_IPROG,
IALG_ESDATA,
IALG_EXTERNAL,
IALG_DARAM0 = 0,
IALG_DARAM1 = 1,
IALG_SARAM = 2,
IALG_SARAM0 = 2,
IALG_SARAM1 = 3,
IALG_DARAM2 = 4,
IALG_SARAM2 = 5
}

Defined memory spaces.

More...


Codec Engine System Programming Interface (SPI): Memory.h File Reference

  • File List
  • Globals
  • cetools
  • packages
  • xdc
  • runtime
Data Structures | Defines | Typedefs | Functions | Variables

cetools/packages/xdc/runtime/Memory.h File Reference

#include <xdc/std.h>
#include <xdc/runtime/xdc.h>
#include <xdc/runtime/Types.h>
#include <xdc/runtime/package/package.defs.h>
#include <xdc/runtime/IModule.h>
#include <xdc/runtime/Error.h>
#include <xdc/runtime/IHeap.h>
#include <xdc/runtime/package/Memory_HeapProxy.h>
Include dependency graph for cetools/packages/xdc/runtime/Memory.h:

Go to the source code of this file.

Data Structures

struct | xdc_runtime_Memory_Stats

Defines

#define | __nested__
#define | xdc_runtime_Memory__top__
#define | __extern extern
#define | xdc_runtime_Memory___VERS 150
#define | xdc_runtime_Memory_Q_BLOCKING (1)
#define | xdc_runtime_Memory_defaultHeapInstance (xdc_runtime_Memory_defaultHeapInstance__C)
#define | xdc_runtime_Memory_Module_startup(state) -1
#define | xdc_runtime_Memory_alloc xdc_runtime_Memory_alloc__E
#define | xdc_runtime_Memory_calloc xdc_runtime_Memory_calloc__E
#define | xdc_runtime_Memory_free xdc_runtime_Memory_free__E
#define | xdc_runtime_Memory_getStats xdc_runtime_Memory_getStats__E
#define | xdc_runtime_Memory_query xdc_runtime_Memory_query__E
#define | xdc_runtime_Memory_getMaxDefaultTypeAlign xdc_runtime_Memory_getMaxDefaultTypeAlign__E
#define | xdc_runtime_Memory_valloc xdc_runtime_Memory_valloc__E
#define | xdc_runtime_Memory_Module_startupDone() xdc_runtime_Memory_Module__startupDone__S()
#define | xdc_runtime_Memory_Object_heap() xdc_runtime_Memory_Object__heap__C
#define | xdc_runtime_Memory_Module_heap() xdc_runtime_Memory_Object__heap__C
#define | xdc_runtime_Memory__localnames__done
#define | Memory_Q_BLOCKING xdc_runtime_Memory_Q_BLOCKING
#define | Memory_Size xdc_runtime_Memory_Size
#define | Memory_Stats xdc_runtime_Memory_Stats
#define | Memory_Module_State xdc_runtime_Memory_Module_State
#define | Memory_defaultHeapInstance xdc_runtime_Memory_defaultHeapInstance
#define | Memory_alloc xdc_runtime_Memory_alloc
#define | Memory_calloc xdc_runtime_Memory_calloc
#define | Memory_free xdc_runtime_Memory_free
#define | Memory_getStats xdc_runtime_Memory_getStats
#define | Memory_query xdc_runtime_Memory_query
#define | Memory_getMaxDefaultTypeAlign xdc_runtime_Memory_getMaxDefaultTypeAlign
#define | Memory_valloc xdc_runtime_Memory_valloc
#define | Memory_Module_name xdc_runtime_Memory_Module_name
#define | Memory_Module_id xdc_runtime_Memory_Module_id
#define | Memory_Module_startup xdc_runtime_Memory_Module_startup
#define | Memory_Module_startupDone xdc_runtime_Memory_Module_startupDone
#define | Memory_Module_hasMask xdc_runtime_Memory_Module_hasMask
#define | Memory_Module_getMask xdc_runtime_Memory_Module_getMask
#define | Memory_Module_setMask xdc_runtime_Memory_Module_setMask
#define | Memory_Object_heap xdc_runtime_Memory_Object_heap
#define | Memory_Module_heap xdc_runtime_Memory_Module_heap

Typedefs

typedef xdc_UArg | xdc_runtime_Memory_Size
typedef xdc_Bits32 | CT__xdc_runtime_Memory_Module__diagsEnabled
typedef xdc_Bits32 | CT__xdc_runtime_Memory_Module__diagsIncluded
typedef xdc_Bits16 * | CT__xdc_runtime_Memory_Module__diagsMask
typedef xdc_Ptr | CT__xdc_runtime_Memory_Module__gateObj
typedef xdc_Ptr | CT__xdc_runtime_Memory_Module__gatePrms
typedef xdc_runtime_Types_ModuleId | CT__xdc_runtime_Memory_Module__id
typedef xdc_Bool | CT__xdc_runtime_Memory_Module__loggerDefined
typedef xdc_Ptr | CT__xdc_runtime_Memory_Module__loggerObj
typedef
xdc_runtime_Types_LoggerFxn0 		CT__xdc_runtime_Memory_Module__loggerFxn0
typedef
xdc_runtime_Types_LoggerFxn1 		CT__xdc_runtime_Memory_Module__loggerFxn1
typedef
xdc_runtime_Types_LoggerFxn2 		CT__xdc_runtime_Memory_Module__loggerFxn2
typedef
xdc_runtime_Types_LoggerFxn4 		CT__xdc_runtime_Memory_Module__loggerFxn4
typedef
xdc_runtime_Types_LoggerFxn8 		CT__xdc_runtime_Memory_Module__loggerFxn8
typedef xdc_Bool(* | CT__xdc_runtime_Memory_Module__startupDoneFxn )(void)
typedef xdc_Int | CT__xdc_runtime_Memory_Object__count
typedef xdc_runtime_IHeap_Handle | CT__xdc_runtime_Memory_Object__heap
typedef xdc_SizeT | CT__xdc_runtime_Memory_Object__sizeof
typedef xdc_Ptr | CT__xdc_runtime_Memory_Object__table
typedef xdc_runtime_IHeap_Handle | CT__xdc_runtime_Memory_defaultHeapInstance

Functions

xdc__CODESECT (xdc_runtime_Memory_Handle__label__S,"xdc_runtime_Memory_Handle__label") extern xdc_runtime_Types_Label *xdc_runtime_Memory_Handle__label__S(xdc_Ptr obj
xdc__CODESECT (xdc_runtime_Memory_Module__startupDone__S,"xdc_runtime_Memory_Module__startupDone") extern xdc_Bool xdc_runtime_Memory_Module__startupDone__S(void)
xdc__CODESECT (xdc_runtime_Memory_Object__create__S,"xdc_runtime_Memory_Object__create") extern xdc_Ptr xdc_runtime_Memory_Object__create__S(xdc_Ptr __oa
xdc__CODESECT (xdc_runtime_Memory_Object__delete__S,"xdc_runtime_Memory_Object__delete") extern xdc_Void xdc_runtime_Memory_Object__delete__S(xdc_Ptr instp)
xdc__CODESECT (xdc_runtime_Memory_Object__destruct__S,"xdc_runtime_Memory_Object__destruct") extern xdc_Void xdc_runtime_Memory_Object__destruct__S(xdc_Ptr objp)
xdc__CODESECT (xdc_runtime_Memory_Object__get__S,"xdc_runtime_Memory_Object__get") extern xdc_Ptr xdc_runtime_Memory_Object__get__S(xdc_Ptr oarr
xdc__CODESECT (xdc_runtime_Memory_Object__first__S,"xdc_runtime_Memory_Object__first") extern xdc_Ptr xdc_runtime_Memory_Object__first__S(void)
xdc__CODESECT (xdc_runtime_Memory_Object__next__S,"xdc_runtime_Memory_Object__next") extern xdc_Ptr xdc_runtime_Memory_Object__next__S(xdc_Ptr obj)
xdc__CODESECT (xdc_runtime_Memory_Params__init__S,"xdc_runtime_Memory_Params__init") extern xdc_Void xdc_runtime_Memory_Params__init__S(xdc_Ptr dst
xdc__CODESECT (xdc_runtime_Memory_Proxy__abstract__S,"xdc_runtime_Memory_Proxy__abstract") extern xdc_Bool xdc_runtime_Memory_Proxy__abstract__S(void)
xdc__CODESECT (xdc_runtime_Memory_Proxy__delegate__S,"xdc_runtime_Memory_Proxy__delegate") extern xdc_Ptr xdc_runtime_Memory_Proxy__delegate__S(void)
xdc__CODESECT (xdc_runtime_Memory_alloc__E,"xdc_runtime_Memory_alloc") extern xdc_Ptr xdc_runtime_Memory_alloc__E(xdc_runtime_IHeap_Handle heap
xdc__CODESECT (xdc_runtime_Memory_alloc__F,"xdc_runtime_Memory_alloc") extern xdc_Ptr xdc_runtime_Memory_alloc__F(xdc_runtime_IHeap_Handle heap
xdc_Ptr | xdc_runtime_Memory_alloc__R (xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block *eb)
xdc__CODESECT (xdc_runtime_Memory_calloc__E,"xdc_runtime_Memory_calloc") extern xdc_Ptr xdc_runtime_Memory_calloc__E(xdc_runtime_IHeap_Handle heap
xdc__CODESECT (xdc_runtime_Memory_calloc__F,"xdc_runtime_Memory_calloc") extern xdc_Ptr xdc_runtime_Memory_calloc__F(xdc_runtime_IHeap_Handle heap
xdc_Ptr | xdc_runtime_Memory_calloc__R (xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block *eb)
xdc__CODESECT (xdc_runtime_Memory_free__E,"xdc_runtime_Memory_free") extern xdc_Void xdc_runtime_Memory_free__E(xdc_runtime_IHeap_Handle heap
xdc__CODESECT (xdc_runtime_Memory_free__F,"xdc_runtime_Memory_free") extern xdc_Void xdc_runtime_Memory_free__F(xdc_runtime_IHeap_Handle heap
xdc_Void | xdc_runtime_Memory_free__R (xdc_runtime_IHeap_Handle heap, xdc_Ptr block, xdc_SizeT size)
xdc__CODESECT (xdc_runtime_Memory_getStats__E,"xdc_runtime_Memory_getStats") extern xdc_Void xdc_runtime_Memory_getStats__E(xdc_runtime_IHeap_Handle heap
xdc__CODESECT (xdc_runtime_Memory_getStats__F,"xdc_runtime_Memory_getStats") extern xdc_Void xdc_runtime_Memory_getStats__F(xdc_runtime_IHeap_Handle heap
xdc_Void | xdc_runtime_Memory_getStats__R (xdc_runtime_IHeap_Handle heap, xdc_runtime_Memory_Stats *stats)
xdc__CODESECT (xdc_runtime_Memory_query__E,"xdc_runtime_Memory_query") extern xdc_Bool xdc_runtime_Memory_query__E(xdc_runtime_IHeap_Handle heap
xdc__CODESECT (xdc_runtime_Memory_query__F,"xdc_runtime_Memory_query") extern xdc_Bool xdc_runtime_Memory_query__F(xdc_runtime_IHeap_Handle heap
xdc_Bool | xdc_runtime_Memory_query__R (xdc_runtime_IHeap_Handle heap, xdc_Int qual)
xdc__CODESECT (xdc_runtime_Memory_getMaxDefaultTypeAlign__E,"xdc_runtime_Memory_getMaxDefaultTypeAlign") extern xdc_SizeT xdc_runtime_Memory_getMaxDefaultTypeAlign__E(void)
xdc__CODESECT (xdc_runtime_Memory_getMaxDefaultTypeAlign__F,"xdc_runtime_Memory_getMaxDefaultTypeAlign") extern xdc_SizeT xdc_runtime_Memory_getMaxDefaultTypeAlign__F(void)
xdc_SizeT | xdc_runtime_Memory_getMaxDefaultTypeAlign__R (void)
xdc__CODESECT (xdc_runtime_Memory_valloc__E,"xdc_runtime_Memory_valloc") extern xdc_Ptr xdc_runtime_Memory_valloc__E(xdc_runtime_IHeap_Handle heap
xdc__CODESECT (xdc_runtime_Memory_valloc__F,"xdc_runtime_Memory_valloc") extern xdc_Ptr xdc_runtime_Memory_valloc__F(xdc_runtime_IHeap_Handle heap
xdc_Ptr | xdc_runtime_Memory_valloc__R (xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_Char value, xdc_runtime_Error_Block *eb)

Variables

__FAR__ const
CT__xdc_runtime_Memory_Module__diagsEnabled 		xdc_runtime_Memory_Module__diagsEnabled__C
__FAR__ const
CT__xdc_runtime_Memory_Module__diagsIncluded 		xdc_runtime_Memory_Module__diagsIncluded__C
__FAR__ const
CT__xdc_runtime_Memory_Module__diagsMask 		xdc_runtime_Memory_Module__diagsMask__C
__FAR__ const
CT__xdc_runtime_Memory_Module__gateObj 		xdc_runtime_Memory_Module__gateObj__C
__FAR__ const
CT__xdc_runtime_Memory_Module__gatePrms 		xdc_runtime_Memory_Module__gatePrms__C
__FAR__ const
CT__xdc_runtime_Memory_Module__id 		xdc_runtime_Memory_Module__id__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerDefined 		xdc_runtime_Memory_Module__loggerDefined__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerObj 		xdc_runtime_Memory_Module__loggerObj__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerFxn0 		xdc_runtime_Memory_Module__loggerFxn0__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerFxn1 		xdc_runtime_Memory_Module__loggerFxn1__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerFxn2 		xdc_runtime_Memory_Module__loggerFxn2__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerFxn4 		xdc_runtime_Memory_Module__loggerFxn4__C
__FAR__ const
CT__xdc_runtime_Memory_Module__loggerFxn8 		xdc_runtime_Memory_Module__loggerFxn8__C
__FAR__ const
CT__xdc_runtime_Memory_Module__startupDoneFxn 		xdc_runtime_Memory_Module__startupDoneFxn__C
__FAR__ const
CT__xdc_runtime_Memory_Object__count 		xdc_runtime_Memory_Object__count__C
__FAR__ const
CT__xdc_runtime_Memory_Object__heap 		xdc_runtime_Memory_Object__heap__C
__FAR__ const
CT__xdc_runtime_Memory_Object__sizeof 		xdc_runtime_Memory_Object__sizeof__C
__FAR__ const
CT__xdc_runtime_Memory_Object__table 		xdc_runtime_Memory_Object__table__C
__FAR__ const
CT__xdc_runtime_Memory_defaultHeapInstance 		xdc_runtime_Memory_defaultHeapInstance__C
xdc_runtime_Types_Label * | lab
xdc_SizeT | __osz
xdc_SizeT xdc_Ptr | __aa
xdc_SizeT xdc_Ptr const xdc_UChar * | __pa
xdc_SizeT xdc_Ptr const
xdc_UChar xdc_SizeT 		__psz
xdc_SizeT xdc_Ptr const
xdc_UChar xdc_SizeT
xdc_runtime_Error_Block * 		__eb
xdc_Int | i
xdc_Ptr | src
xdc_Ptr xdc_SizeT | psz
xdc_Ptr xdc_SizeT xdc_SizeT | isz
xdc_SizeT | size
xdc_SizeT xdc_SizeT | align
xdc_SizeT xdc_SizeT
xdc_runtime_Error_Block * 		eb
xdc_Ptr | block
xdc_runtime_Memory_Stats * stats
xdc_Int | qual
xdc_SizeT xdc_SizeT xdc_Char | value

Define Documentation

#define __nested__
#define xdc_runtime_Memory__top__
#define __extern extern
#define xdc_runtime_Memory___VERS 150
#define xdc_runtime_Memory_Q_BLOCKING (1)
#define xdc_runtime_Memory_defaultHeapInstance (xdc_runtime_Memory_defaultHeapInstance__C)
#define xdc_runtime_Memory_Module_startup ( state ) -1
#define xdc_runtime_Memory_alloc xdc_runtime_Memory_alloc__E
#define xdc_runtime_Memory_calloc xdc_runtime_Memory_calloc__E
#define xdc_runtime_Memory_free xdc_runtime_Memory_free__E
#define xdc_runtime_Memory_getStats xdc_runtime_Memory_getStats__E
#define xdc_runtime_Memory_query xdc_runtime_Memory_query__E
#define xdc_runtime_Memory_getMaxDefaultTypeAlign xdc_runtime_Memory_getMaxDefaultTypeAlign__E
#define xdc_runtime_Memory_valloc xdc_runtime_Memory_valloc__E
#define xdc_runtime_Memory_Module_startupDone ( ) xdc_runtime_Memory_Module__startupDone__S()
#define xdc_runtime_Memory_Object_heap ( ) xdc_runtime_Memory_Object__heap__C
#define xdc_runtime_Memory_Module_heap ( ) xdc_runtime_Memory_Object__heap__C
#define xdc_runtime_Memory__localnames__done
#define Memory_Q_BLOCKING xdc_runtime_Memory_Q_BLOCKING
#define Memory_Size xdc_runtime_Memory_Size
#define Memory_Stats xdc_runtime_Memory_Stats
#define Memory_Module_State xdc_runtime_Memory_Module_State
#define Memory_defaultHeapInstance xdc_runtime_Memory_defaultHeapInstance
#define Memory_alloc xdc_runtime_Memory_alloc
#define Memory_calloc xdc_runtime_Memory_calloc
#define Memory_free xdc_runtime_Memory_free
#define Memory_getStats xdc_runtime_Memory_getStats
#define Memory_query xdc_runtime_Memory_query
#define Memory_getMaxDefaultTypeAlign xdc_runtime_Memory_getMaxDefaultTypeAlign
#define Memory_valloc xdc_runtime_Memory_valloc
#define Memory_Module_name xdc_runtime_Memory_Module_name
#define Memory_Module_id xdc_runtime_Memory_Module_id
#define Memory_Module_startup xdc_runtime_Memory_Module_startup
#define Memory_Module_startupDone xdc_runtime_Memory_Module_startupDone
#define Memory_Module_hasMask xdc_runtime_Memory_Module_hasMask
#define Memory_Module_getMask xdc_runtime_Memory_Module_getMask
#define Memory_Module_setMask xdc_runtime_Memory_Module_setMask
#define Memory_Object_heap xdc_runtime_Memory_Object_heap
#define Memory_Module_heap xdc_runtime_Memory_Module_heap

Typedef Documentation

typedef xdc_UArg xdc_runtime_Memory_Size
typedef xdc_Bits32 CT__xdc_runtime_Memory_Module__diagsEnabled
typedef xdc_Bits32 CT__xdc_runtime_Memory_Module__diagsIncluded
typedef xdc_Bits16* CT__xdc_runtime_Memory_Module__diagsMask
typedef xdc_Ptr CT__xdc_runtime_Memory_Module__gateObj
typedef xdc_Ptr CT__xdc_runtime_Memory_Module__gatePrms
typedef xdc_runtime_Types_ModuleId CT__xdc_runtime_Memory_Module__id
typedef xdc_Bool CT__xdc_runtime_Memory_Module__loggerDefined
typedef xdc_Ptr CT__xdc_runtime_Memory_Module__loggerObj
typedef xdc_runtime_Types_LoggerFxn0 CT__xdc_runtime_Memory_Module__loggerFxn0
typedef xdc_runtime_Types_LoggerFxn1 CT__xdc_runtime_Memory_Module__loggerFxn1
typedef xdc_runtime_Types_LoggerFxn2 CT__xdc_runtime_Memory_Module__loggerFxn2
typedef xdc_runtime_Types_LoggerFxn4 CT__xdc_runtime_Memory_Module__loggerFxn4
typedef xdc_runtime_Types_LoggerFxn8 CT__xdc_runtime_Memory_Module__loggerFxn8
typedef xdc_Bool(* CT__xdc_runtime_Memory_Module__startupDoneFxn)(void)
typedef xdc_Int CT__xdc_runtime_Memory_Object__count
typedef xdc_runtime_IHeap_Handle CT__xdc_runtime_Memory_Object__heap
typedef xdc_SizeT CT__xdc_runtime_Memory_Object__sizeof
typedef xdc_Ptr CT__xdc_runtime_Memory_Object__table
typedef xdc_runtime_IHeap_Handle CT__xdc_runtime_Memory_defaultHeapInstance

Function Documentation

xdc__CODESECT | ( | xdc_runtime_Memory_Handle__label__S | ,
 |  | "xdc_runtime_Memory_Handle__label" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Module__startupDone__S | ,
 |  | "xdc_runtime_Memory_Module__startupDone" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Object__create__S | ,
 |  | "xdc_runtime_Memory_Object__create" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Object__delete__S | ,
 |  | "xdc_runtime_Memory_Object__delete" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Object__destruct__S | ,
 |  | "xdc_runtime_Memory_Object__destruct" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Object__get__S | ,
 |  | "xdc_runtime_Memory_Object__get" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Object__first__S | ,
 |  | "xdc_runtime_Memory_Object__first" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Object__next__S | ,
 |  | "xdc_runtime_Memory_Object__next" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Params__init__S | ,
 |  | "xdc_runtime_Memory_Params__init" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Proxy__abstract__S | ,
 |  | "xdc_runtime_Memory_Proxy__abstract" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_Proxy__delegate__S | ,
 |  | "xdc_runtime_Memory_Proxy__delegate" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_alloc__E | ,
 |  | "xdc_runtime_Memory_alloc" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_alloc__F | ,
 |  | "xdc_runtime_Memory_alloc" |
 | ) |  |
xdc_Ptr xdc_runtime_Memory_alloc__R | ( | xdc_runtime_IHeap_Handle | heap,
 |  | xdc_SizeT | size,
 |  | xdc_SizeT | align,
 |  | xdc_runtime_Error_Block * | eb
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_calloc__E | ,
 |  | "xdc_runtime_Memory_calloc" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_calloc__F | ,
 |  | "xdc_runtime_Memory_calloc" |
 | ) |  |
xdc_Ptr xdc_runtime_Memory_calloc__R | ( | xdc_runtime_IHeap_Handle | heap,
 |  | xdc_SizeT | size,
 |  | xdc_SizeT | align,
 |  | xdc_runtime_Error_Block * | eb
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_free__E | ,
 |  | "xdc_runtime_Memory_free" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_free__F | ,
 |  | "xdc_runtime_Memory_free" |
 | ) |  |
xdc_Void xdc_runtime_Memory_free__R | ( | xdc_runtime_IHeap_Handle | heap,
 |  | xdc_Ptr | block,
 |  | xdc_SizeT | size
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_getStats__E | ,
 |  | "xdc_runtime_Memory_getStats" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_getStats__F | ,
 |  | "xdc_runtime_Memory_getStats" |
 | ) |  |
xdc_Void xdc_runtime_Memory_getStats__R | ( | xdc_runtime_IHeap_Handle | heap,
 |  | xdc_runtime_Memory_Stats * | stats
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_query__E | ,
 |  | "xdc_runtime_Memory_query" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_query__F | ,
 |  | "xdc_runtime_Memory_query" |
 | ) |  |
xdc_Bool xdc_runtime_Memory_query__R | ( | xdc_runtime_IHeap_Handle | heap,
 |  | xdc_Int | qual
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_getMaxDefaultTypeAlign__E | ,
 |  | "xdc_runtime_Memory_getMaxDefaultTypeAlign" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_getMaxDefaultTypeAlign__F | ,
 |  | "xdc_runtime_Memory_getMaxDefaultTypeAlign" |
 | ) |  |
xdc_SizeT xdc_runtime_Memory_getMaxDefaultTypeAlign__R ( void )
xdc__CODESECT | ( | xdc_runtime_Memory_valloc__E | ,
 |  | "xdc_runtime_Memory_valloc" |
 | ) |  |
xdc__CODESECT | ( | xdc_runtime_Memory_valloc__F | ,
 |  | "xdc_runtime_Memory_valloc" |
 | ) |  |
xdc_Ptr xdc_runtime_Memory_valloc__R | ( | xdc_runtime_IHeap_Handle | heap,
 |  | xdc_SizeT | size,
 |  | xdc_SizeT | align,
 |  | xdc_Char | value,
 |  | xdc_runtime_Error_Block * | eb
 | ) |  |

Variable Documentation

__FAR__ const CT__xdc_runtime_Memory_Module__diagsEnabled xdc_runtime_Memory_Module__diagsEnabled__C
__FAR__ const CT__xdc_runtime_Memory_Module__diagsIncluded xdc_runtime_Memory_Module__diagsIncluded__C
__FAR__ const CT__xdc_runtime_Memory_Module__diagsMask xdc_runtime_Memory_Module__diagsMask__C
__FAR__ const CT__xdc_runtime_Memory_Module__gateObj xdc_runtime_Memory_Module__gateObj__C
__FAR__ const CT__xdc_runtime_Memory_Module__gatePrms xdc_runtime_Memory_Module__gatePrms__C
__FAR__ const CT__xdc_runtime_Memory_Module__id xdc_runtime_Memory_Module__id__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerDefined xdc_runtime_Memory_Module__loggerDefined__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerObj xdc_runtime_Memory_Module__loggerObj__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn0 xdc_runtime_Memory_Module__loggerFxn0__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn1 xdc_runtime_Memory_Module__loggerFxn1__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn2 xdc_runtime_Memory_Module__loggerFxn2__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn4 xdc_runtime_Memory_Module__loggerFxn4__C
__FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn8 xdc_runtime_Memory_Module__loggerFxn8__C
__FAR__ const CT__xdc_runtime_Memory_Module__startupDoneFxn xdc_runtime_Memory_Module__startupDoneFxn__C
__FAR__ const CT__xdc_runtime_Memory_Object__count xdc_runtime_Memory_Object__count__C
__FAR__ const CT__xdc_runtime_Memory_Object__heap xdc_runtime_Memory_Object__heap__C
__FAR__ const CT__xdc_runtime_Memory_Object__sizeof xdc_runtime_Memory_Object__sizeof__C
__FAR__ const CT__xdc_runtime_Memory_Object__table xdc_runtime_Memory_Object__table__C
__FAR__ const CT__xdc_runtime_Memory_defaultHeapInstance xdc_runtime_Memory_defaultHeapInstance__C
xdc_runtime_Types_Label* lab
xdc_SizeT __osz
xdc_SizeT xdc_Ptr __aa
xdc_SizeT xdc_Ptr const xdc_UChar* __pa
xdc_SizeT xdc_Ptr const xdc_UChar xdc_SizeT __psz
xdc_SizeT xdc_Ptr const xdc_UChar xdc_SizeT xdc_runtime_Error_Block* __eb
xdc_Int i
xdc_Ptr src
xdc_Ptr xdc_SizeT psz
xdc_Ptr xdc_SizeT xdc_SizeT isz
xdc_SizeT size
xdc_SizeT xdc_SizeT align
xdc_SizeT xdc_SizeT xdc_Char xdc_runtime_Error_Block * eb
xdc_Ptr block
xdc_runtime_Memory_Stats * stats
xdc_Int qual
xdc_SizeT xdc_SizeT xdc_Char value


Codec Engine System Programming Interface (SPI): Memory.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce
  • osal
Data Structures | Defines | Typedefs | Enumerations | Functions | Variables

packages/ti/sdo/ce/osal/Memory.h File Reference

Detailed Description

The Codec Engine OSAL Memory interface. Provides the user an OS-independent Memory abstraction.

Go to the source code of this file.

Data Structures

struct | ti_sdo_ce_osal_Memory_AllocParams
Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free() More...

Defines

#define | ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT ((UInt)(-1))
Default Alignment.
#define | Memory_MODNAME "ti.sdo.ce.osal.Memory"
Name to pass to Diags_setMask() to enable logging for Memory functions. For example, Diags_setMask(Memory_MODNAME"+EX1234567"); turns on all Log statements in this module. Diags_setMask() must be called after initialization to take effect.
#define | ti_sdo_ce_osal_Memory_GTNAME "OM"
GT name containing the trace mask for this module.
#define | ti_sdo_ce_osal_Memory_CACHED 0x00000000
Cached allocation.
#define | ti_sdo_ce_osal_Memory_NONCACHED 0x00000001
Non-cached allocation.
#define | ti_sdo_ce_osal_Memory_CACHEDMASK 0x00000001
Mask to isolate cache flag.

Typedefs

typedef struct
ti_sdo_ce_osal_Memory_AllocParams 		ti_sdo_ce_osal_Memory_AllocParams
Parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()

Enumerations

enum ti_sdo_ce_osal_Memory_type {
ti_sdo_ce_osal_Memory_MALLOC = 0,
ti_sdo_ce_osal_Memory_SEG = 1,
ti_sdo_ce_osal_Memory_CONTIGPOOL = 2,
ti_sdo_ce_osal_Memory_CONTIGHEAP = 3
}

Enum values for ti_sdo_ce_osal_Memory_AllocParams.type.

More...

Functions

Ptr | ti_sdo_ce_osal_Memory_alloc (UInt size, ti_sdo_ce_osal_Memory_AllocParams *params)
General memory allocation.
Void | ti_sdo_ce_osal_Memory_cacheInv (Ptr addr, Int sizeInBytes)
Invalidate a range of cache.
Void | ti_sdo_ce_osal_Memory_cacheWb (Ptr addr, Int sizeInBytes)
Write back cache.
Void | ti_sdo_ce_osal_Memory_cacheWbInv (Ptr addr, Int sizeInBytes)
Write back and invalidate cache.
Void | ti_sdo_ce_osal_Memory_cacheWbInvAll ()
Write back and invalidate the entire cache. Not supported yet on all OS's.
Ptr | ti_sdo_ce_osal_Memory_contigAlloc (UInt size, UInt align)
Allocate physically contiguous blocks of memory.
Bool | ti_sdo_ce_osal_Memory_contigFree (Ptr addr, UInt size)
Free memory allocated by ti_sdo_ce_osal_Memory_contigAlloc()
Bool | ti_sdo_ce_osal_Memory_free (Ptr addr, UInt size, ti_sdo_ce_osal_Memory_AllocParams *params)
Free memory allocated with ti_sdo_ce_osal_Memory_alloc().
Void | ti_sdo_ce_osal_Memory_dumpKnownContigBufsList (Void)
Dumps the list of all translated/registered bufs.
UInt32 | ti_sdo_ce_osal_Memory_getBufferPhysicalAddress (Ptr virtualAddress, Int sizeInBytes, Bool *isContiguous)
Converts application virtual address to a physical address.
Int | ti_sdo_ce_osal_Memory_getHeapId (String name)
Get the heap heap ID corresponding to a heap name. This number will be between 0 and the value returned by ti_sdo_ce_osal_Memory_getNumHeaps(). The heap Id can be passed to ti_sdo_ce_osal_Memory_redefine() and ti_sdo_ce_osal_Memory_restoreHeap().
Int | ti_sdo_ce_osal_Memory_getNumHeaps ()
Get the number of memory heaps.
Ptr | ti_sdo_ce_osal_Memory_getBufferVirtualAddress (UInt32 physicalAddress, Int sizeInBytes)
Obtains the virtual address of a physically contiguous buffer.
Void | ti_sdo_ce_osal_Memory_registerContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes, UInt32 physicalAddress)
Register a physical buffer allocated without ti_sdo_ce_osal_Memory_contigAlloc()
Void | ti_sdo_ce_osal_Memory_unregisterContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes)
Unregisters a physical buffer allocated without ti_sdo_ce_osal_Memory_contigAlloc().

Variables

ti_sdo_ce_osal_Memory_AllocParams ti_sdo_ce_osal_Memory_DEFAULTPARAMS
Default parameters for ti_sdo_ce_osal_Memory_alloc() & ti_sdo_ce_osal_Memory_free()


Codec Engine System Programming Interface (SPI): skel.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce
Data Structures | Typedefs

skel.h File Reference

Detailed Description

The Codec Engine System Programming Interface (SPI) for skeleton developers.

#include <ti/sdo/ce/visa.h>
Include dependency graph for skel.h:

Go to the source code of this file.

Data Structures

struct | SKEL_Fxns
Table of functions defining the interface of a skeleton. More...

Typedefs

typedef VISA_Status(* | SKEL_CALLFXN )(VISA_Handle handle, VISA_Msg msg)
Prototype for a skeleton's call() implementation.
typedef VISA_Handle(* | SKEL_CREATEFXN )(Void *reserved, String name, Void *params)
Prototype for a skeleton's create() API.
typedef Void(* | SKEL_DESTROYFXN )(VISA_Handle handle)
Prototype for a skeleton's destroy() API.
typedef struct SKEL_Fxns | SKEL_Fxns
Table of functions defining the interface of a skeleton.


Codec Engine System Programming Interface (SPI): spi.h File Reference

  • File List
  • Globals

spi.h File Reference

Go to the source code of this file.


Codec Engine System Programming Interface (SPI): visa.h File Reference

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce
Data Structures | Defines | Typedefs | Functions | Variables

visa.h File Reference

Detailed Description

The Codec Engine System Programming Interface. Provides system developers with services necessary to implement stubs and skeletons.

#include <stddef.h>
#include <ti/sdo/ce/node/node.h>
#include <ti/xdais/ialg.h>
#include <ti/sdo/ce/Engine.h>
Include dependency graph for visa.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | VISA_MsgHeader
VISA message header. More...

Defines

#define | VISA_EOK 0
Success.
#define | VISA_ERUNTIME -1
Internal runtime error.
#define | VISA_EFAIL -2
General system error.
#define | VISA_EUNSUPPORTED -3
The API is not suported for the given system configuration.
#define | VISA_ETIMEOUT -100
Timeout occurred.
#define | VISA_FOREVER Engine_FOREVER
Special value for timeout parameter indicating never timeout.
#define | VISA_MODNAME "ti.sdo.ce.VISA"
Name to pass to Diags_setMask() to enable logging for VISA functions. For example, Diags_setMask(VISA_MODNAME"+EX1234567"); turns on all Log statements in this module. Diags_setMask() must be called after initialization to take effect.

Typedefs

typedef Int | VISA_Status
VISA result data type.
typedef struct VISA_Obj * | VISA_Handle
Opaque handle to a node.
typedef struct VISA_MsgHeader | VISA_MsgHeader
VISA message header.
typedef VISA_MsgHeader * | VISA_Msg

Functions

VISA_Msg | VISA_allocMsg (VISA_Handle visa)
Obtain an algorithm instance's message.
VISA_Status | VISA_call (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and wait for it to complete.
VISA_Status | VISA_callAsync (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and return without waiting for it to complete.
VISA_Status | VISA_wait (VISA_Handle visa, VISA_Msg *msg, UInt timeout)
Wait for the oldest operation from a command specified with VISA_callAsync() to complete.
Void | VISA_freeMsg (VISA_Handle visa, VISA_Msg msg)
Release an algorithm instance's message.
VISA_Status | VISA_getAlgMemRecs (VISA_Handle visa, IALG_MemRec *memTab, Int size, Int *numRecs)
Get the IALG_MemRec memory assigned to an algorithm instance.
VISA_Status | VISA_getAlgNumRecs (VISA_Handle visa, Int *numRecs)
Get the number of IALG_MemRecs assigned to an algorithm.
Void | VISA_getContext (VISA_Handle visa, UInt32 *pContext)
Get optional context parameter.
Ptr | VISA_getCodecClassConfig (VISA_Handle visa)
Get codec-specific values for the VISA class-specific (or codec-specific if the codec doesn't extend VISA) stub-and/ or-skeleton configuration data (that some classes have)
UInt | VISA_getMaxMsgSize (VISA_Handle visa)
Returns max size of messages allocated by VISA_allocMsg()
Void | _VISA_init (Void)
Ininitilize VISA module.
Void | _VISA_exit (Void)
Exit VISA module.
Void | VISA_setContext (VISA_Handle visa, UInt32 context)
Set optional context parameter.
Bool | VISA_isLocal (VISA_Handle visa)
Indicates whether VISA codecs run on a remote or local CPU.
VISA_Handle | VISA_create (Engine_Handle engine, String name, IALG_Params *params, size_t msgSize, String type)
Create a new instance of an algorithm.
Void | VISA_delete (VISA_Handle visa)
Delete an instance of an algorithm.
VISA_Handle | VISA_create2 (Engine_Handle engine, String name, IALG_Params *params, Int paramsSize, size_t msgSize, String type)
Create a new instance of an algorithm.
Void | VISA_enter (VISA_Handle visa)
Enter an algorithm's critical section. This must be called before any of the algorithm's IALG_Fxns are invoked.
Void | VISA_exit (VISA_Handle visa)
Leave an algorithm's critical section. This must be called after the API has completed calling an algorithm's IALG_Fxns.
Ptr | VISA_getAlgHandle (VISA_Handle visa)
Obtains an algorithm's handle. This is the handle required to be passed to the algorithm's IALG_Fxns.
Ptr | VISA_getAlgorithmHandle (VISA_Handle visa)
Obtains an algorithm's handle. If the algorithm is local, this is the handle that can be passed to Algorithm APIs, not to the IALG_Fxns.
IALG_Fxns * | VISA_getAlgFxns (VISA_Handle visa)
Get implementation functions for this algorithm.

Variables

Bool | VISA_checked

Define Documentation

#define VISA_MODNAME "ti.sdo.ce.VISA"

Name to pass to Diags_setMask() to enable logging for VISA functions. For example, Diags_setMask(VISA_MODNAME"+EX1234567"); turns on all Log statements in this module. Diags_setMask() must be called after initialization to take effect.

Typedef Documentation

typedef struct VISA_Obj* VISA_Handle

Opaque handle to a node.

typedef VISA_MsgHeader* VISA_Msg

Variable Documentation

Bool VISA_checked


Codec Engine System Programming Interface (SPI): xdas.h File Reference

  • File List
  • Globals
  • cetools
  • packages
  • ti
  • xdais
Defines | Typedefs

xdas.h File Reference

Detailed Description

This header defines all types and constants used in the XDAS interfaces.

Remarks:
The types are mapped to the types defined in std.h.

Go to the source code of this file.

Defines

#define | XDAS_TRUE 1
#define | XDAS_FALSE 0

Typedefs

typedef Void | XDAS_Void
typedef Uint8 | XDAS_Bool
typedef Int8 | XDAS_Int8
typedef Uint8 | XDAS_UInt8
typedef Int16 | XDAS_Int16
typedef Uint16 | XDAS_UInt16
typedef Int32 | XDAS_Int32
typedef Uint32 | XDAS_UInt32


Codec Engine System Programming Interface (SPI): Directory Hierarchy

Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • cetools
    • packages
      • ti
        • xdais
      • xdc
        • runtime
  • packages
    • ti
      • sdo
        • ce
          • osal


Codec Engine System Programming Interface (SPI): cetools/ Directory Reference

  • cetools

cetools Directory Reference

Directory dependency graph for cetools/:

Directories

directory packages


Codec Engine System Programming Interface (SPI): cetools/packages/ Directory Reference

  • cetools
  • packages

packages Directory Reference

Directory dependency graph for cetools/packages/:

Directories

directory | ti
directory | xdc


Codec Engine System Programming Interface (SPI): cetools/packages/ti/ Directory Reference

  • cetools
  • packages
  • ti

ti Directory Reference

Directory dependency graph for cetools/packages/ti/:

Directories

directory xdais


Codec Engine System Programming Interface (SPI): cetools/packages/ti/xdais/ Directory Reference

  • cetools
  • packages
  • ti
  • xdais

xdais Directory Reference

Directory dependency graph for cetools/packages/ti/xdais/:

Files

file | ialg.h [code]

This header defines all types, constants, and functions defined by XDAIS for algorithms.

file | xdas.h [code]

This header defines all types and constants used in the XDAS interfaces.


Codec Engine System Programming Interface (SPI): cetools/packages/xdc/ Directory Reference

  • cetools
  • packages
  • xdc

xdc Directory Reference

Directory dependency graph for cetools/packages/xdc/:

Directories

directory runtime


Codec Engine System Programming Interface (SPI): cetools/packages/xdc/runtime/ Directory Reference

  • cetools
  • packages
  • xdc
  • runtime

runtime Directory Reference

Directory dependency graph for cetools/packages/xdc/runtime/:

Files

file cetools/packages/xdc/runtime/Memory.h [code]


Codec Engine System Programming Interface (SPI): packages/ Directory Reference

  • packages

packages Directory Reference

Directory dependency graph for packages/:

Directories

directory ti


Codec Engine System Programming Interface (SPI): packages/ti/ Directory Reference

  • packages
  • ti

ti Directory Reference

Directory dependency graph for packages/ti/:

Directories

directory sdo


Codec Engine System Programming Interface (SPI): packages/ti/sdo/ Directory Reference

  • packages
  • ti
  • sdo

sdo Directory Reference

Directory dependency graph for packages/ti/sdo/:

Directories

directory ce


Codec Engine System Programming Interface (SPI): packages/ti/sdo/ce/ Directory Reference

  • packages
  • ti
  • sdo
  • ce

ce Directory Reference

Directory dependency graph for packages/ti/sdo/ce/:

Directories

directory | osal

Files

file | Engine.h [code]

The Codec Engine Runtime.

file | skel.h [code]

The Codec Engine System Programming Interface (SPI) for skeleton developers.

file | visa.h [code]

The Codec Engine System Programming Interface. Provides system developers with services necessary to implement stubs and skeletons.


Codec Engine System Programming Interface (SPI): packages/ti/sdo/ce/osal/ Directory Reference

  • packages
  • ti
  • sdo
  • ce
  • osal

osal Directory Reference

Directory dependency graph for packages/ti/sdo/ce/osal/:

Files

file packages/ti/sdo/ce/osal/Memory.h [code]

The Codec Engine OSAL Memory interface. Provides the user an OS-independent Memory abstraction.


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • __aa : cetools/packages/xdc/runtime/Memory.h
  • __eb : cetools/packages/xdc/runtime/Memory.h
  • __extern : cetools/packages/xdc/runtime/Memory.h
  • __nested__ : cetools/packages/xdc/runtime/Memory.h
  • __osz : cetools/packages/xdc/runtime/Memory.h
  • __pa : cetools/packages/xdc/runtime/Memory.h
  • __psz : cetools/packages/xdc/runtime/Memory.h
  • _VISA_exit() : visa.h
  • _VISA_init() : visa.h


Codec Engine System Programming Interface (SPI): Engine.h Source File

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce

Engine.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2011, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== Engine.h ========
00035  */
00036
00051 #ifndef Engine_
00052 #define Engine_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058
00059 #include <ti/sdo/ce/Server.h>
00060 #include <ti/sdo/ce/ipc/Comm.h>
00061 #include <ti/xdais/ialg.h>
00062 #include <ti/sdo/ce/node/node.h>
00063
00064 #include <stddef.h> /* def of size_t */
00065 #include <stdio.h>  /* def of FILE * */
00066
00069
00085 #define Engine_MODNAME "ti.sdo.ce.Engine"
00086
00090 typedef struct Engine_Obj *Engine_Handle;
00091
00095 typedef Int Engine_Error;
00096
00097 #define Engine_EOK          0
00098 #define Engine_EEXIST       1
00099 #define Engine_ENOMEM       2
00100 #define Engine_EDSPLOAD     3
00101 #define Engine_ENOCOMM      4
00104 #define Engine_ENOSERVER    5
00105 #define Engine_ECOMALLOC    6
00106 #define Engine_ERUNTIME     7
00107 #define Engine_ECODECCREATE 8
00108 #define Engine_ECODECSTART  9
00113 #define Engine_EINVAL       10
00114 #define Engine_EBADSERVER   11
00115 #define Engine_ENOTAVAIL    12
00116 #define Engine_EWRONGSTATE  13
00117 #define Engine_EINUSE       14
00120 #define Engine_ENOTFOUND    15
00121 #define Engine_ETIMEOUT     16
00128 typedef struct Engine_NodeObj *Engine_Node;
00129
00133 #define Engine_FOREVER Comm_FOREVER
00134
00143 typedef struct Engine_Attrs {
00144     String procId;
00148 } Engine_Attrs;
00149
00155 typedef struct Engine_AlgInfo {
00156     Int         algInfoSize;
00157     String      name;
00158     String      *typeTab;
00159     Bool        isLocal;
00160 } Engine_AlgInfo;
00161
00174 typedef struct Engine_AlgInfo2 {
00175     Int         algInfoSize;
00176     String      name;
00177     String      types;
00178     Bool        isLocal;
00179 } Engine_AlgInfo2;
00180
00189 extern Engine_Attrs Engine_ATTRS;
00193 typedef Int Engine_Ctrl;
00194
00195 #define Engine_CEXIT    0
00196 #define Engine_MAXSEGNAMELENGTH 32
00197
00205 typedef enum Engine_CachedMemType {
00206     Engine_USECACHEDMEM_DEFAULT = -1,
00207     Engine_USECACHEDMEM_NONCACHED = 0,
00208     Engine_USECACHEDMEM_CACHED = 1
00209 } Engine_CachedMemType;
00210
00211
00212 /*
00213  *  ======== Engine_AlgDesc ========
00214  */
00222 typedef struct Engine_AlgDesc {
00228     String      name;
00229
00230     NODE_Uuid   uuid;
00240     IALG_Fxns   *fxns;
00241
00247     Ptr         idmaFxns;
00248
00249     String      *typeTab;
00256     Bool        isLocal;
00257
00266     Int         groupId;
00267
00268     Int         rpcProtocolVersion;
00278     Ptr         iresFxns;
00279
00283     Void        *codecClassConfig;
00284
00300     Engine_CachedMemType memType;
00326     String      types;
00327 } Engine_AlgDesc;
00328
00329
00333 #define Engine_GETALGDESCFXN  "GetEngineAlgDesc"
00334
00335 /*
00336  *  ======== Engine_DllAlgDesc ========
00337  *  An alg that will be dynamically loaded must have a descriptor of this type.
00338  */
00346 typedef struct Engine_DllAlgDesc {
00350     IALG_Fxns   *fxns;
00351
00356     Ptr         idmaFxns;
00357
00362     Ptr         iresFxns;
00363
00376     String      types;
00377
00383     Void        *codecClassConfig;
00384 } Engine_DllAlgDesc;
00385
00386
00387 /*
00388  *  ======== Engine_GetAlgDescFxn ========
00389  *  A dynamically loaded codec library must supply a function of this type to
00390  *  get properties of the library's algorithm.
00391  */
00401 typedef Int (*Engine_GetAlgDescFxn)(Engine_DllAlgDesc *dllAlgDesc);
00402
00403
00406 /*
00407  *  ======== Engine_AlgCreateAttrs ========
00408  */
00409 typedef struct Engine_AlgCreateAttrs {
00410     Bool            useExtHeap;
00415     Int             priority;
00417 } Engine_AlgCreateAttrs;
00418
00419 /*
00420  *  ======== Engine_Desc ========
00421  */
00428 typedef struct Engine_Desc {
00432     String          name;
00433
00434     Engine_AlgDesc  *algTab;
00441     String          remoteName;
00442
00443     String          memMap;
00454     Bool            useExtLoader;
00455     Int             numAlgs;
00461     Int             heapId;
00462 } Engine_Desc;
00463
00464 /*
00465  *  ======== Engine_Config ========
00466  */
00467 typedef struct Engine_Config {
00468     Engine_Desc *engineTab;
00469     String      localEngine;
00470 } Engine_Config;
00471
00472 /*
00473  *  ======== Engine_MemStat ========
00474  *  This structure must match Server_MemStat.
00475  */
00476 typedef struct Engine_MemStat {
00477     Char   name[Engine_MAXSEGNAMELENGTH + 1]; /* Name of memory segment */
00478     Uint32 base;           /* Base address of memory segment */
00479     Uint32 size;           /* Original size of the memory segment. */
00480     Uint32 used;           /* Number of bytes used. */
00481     Uint32 maxBlockLen;    /* Size of the largest contiguous free block. */
00482 } Engine_MemStat;
00483
00484 /* Default alg create attributes */
00485 extern Engine_AlgCreateAttrs Engine_ALGCREATEATTRS;
00486
00487 /*
00488  *  ======== Engine_config ========
00489  */
00490 extern Engine_Config Engine_config;
00491
00495 /*
00496  *  ======== Engine_addStubFxns ========
00497  */
00540 extern Engine_Error Engine_addStubFxns(String fxnsName, IALG_Fxns *fxns);
00541
00542 /*
00543  *  ======== Engine_add ========
00544  */
00582 extern Engine_Error Engine_add(Engine_Desc *pDesc);
00583
00584 /*
00585  *  ======== Engine_addAlg ========
00586  */
00679 extern Engine_Error Engine_addAlg(String name, Engine_Handle engine,
00680         String location, Engine_AlgDesc *pAlgDesc);
00681
00682 /*
00683  *  ======== Engine_removeAlg ========
00684  */
00710 extern Engine_Error Engine_removeAlg(String name, Engine_Handle engine,
00711         String algName);
00712
00715 /*
00716  *  ======== Engine_call ========
00717  */
00718 extern Int Engine_call(Engine_Node node, Comm_Msg *msg);
00719
00720 /*
00721  *  ======== Engine_callAsync ========
00722  */
00723 extern Int Engine_callAsync(Engine_Node node, Comm_Msg *msg);
00724
00725 /*
00726  *  ======== Engine_callWait ========
00727  */
00728 extern Int Engine_callWait(Engine_Node node, Comm_Msg *msg, UInt timeout);
00729
00730 /*
00731  *  ======== Engine_ctrlNode ========
00732  */
00733 extern Int Engine_ctrlNode(Engine_Node node, Comm_Msg *msg, Engine_Ctrl code);
00734
00737 /*
00738  *  ======== Engine_close ========
00739  */
00755 extern Void Engine_close(Engine_Handle engine);
00756
00758 /*
00759  *  ======== Engine_createNode ========
00760  */
00786 extern Engine_Node Engine_createNode(Engine_Handle engine, String name,
00787     size_t msgSize, IALG_Params *nodeAttrs, Engine_AlgCreateAttrs *attrs);
00788
00789
00790 /*
00791  *  ======== Engine_createNode2 ========
00792  */
00823 extern Engine_Node Engine_createNode2(Engine_Handle engine, String name,
00824     size_t msgSize, IALG_Params *nodeAttrs, Int nodeAttrsSize,
00825     Engine_AlgCreateAttrs *attrs);
00826
00827
00828 /*
00829  *  ======== Engine_deleteNode ========
00830  */
00831 extern Void Engine_deleteNode(Engine_Node node);
00832
00833 /*
00834  *  ======== Engine_getAlgMemRecs ========
00835  */
00849 extern Engine_Error Engine_getAlgMemRecs(Engine_Node node, IALG_MemRec *memTab, Int size,
00850         Int *numRecs);
00851
00852 /*
00853  *  ======== Engine_getAlgNumRecs ========
00854  */
00866 extern Engine_Error Engine_getAlgNumRecs(Engine_Node node, Int *numRecs);
00867
00868 /*
00869  *  ======== Engine_getConstName ========
00870  */
00871 extern String Engine_getConstName(Engine_Handle engine, String name,
00872     String type);
00873
00874 /*
00875  *  ======== Engine_getFxns ========
00876  */
00877 extern IALG_Fxns *Engine_getFxns(Engine_Handle svr, String name, String type,
00878         Bool *isLocal, Ptr *idmaFxns, Ptr *iresFxns, Int *groupId,
00879         Engine_CachedMemType *memType);
00880
00881 /*
00882  *  ======== Engine_getMemId ========
00883  */
00884 extern Int Engine_getMemId(Engine_Handle engine);
00885
00886 /*
00887  *  ======== Engine_getLocalEngine ========
00888  */
00889 extern Engine_Handle Engine_getLocalEngine(Void);
00890
00891 /*
00892  *  ======== Engine_getEngine ========
00893  */
00894 extern Engine_Handle Engine_getEngine(Engine_Node node);
00895
00896 /*
00897  *  ======== Engine_getMemStat ========
00898  */
00899 extern Engine_Error Engine_getMemStat(Server_Handle server, Int segNum,
00900     Engine_MemStat *stat);
00901
00902 /*
00903  *  ======== Engine_getNumMemSegs ========
00904  */
00905 extern Engine_Error Engine_getNumMemSegs(Server_Handle server, Int *numSegs);
00906
00907 /*
00908  *  ======== Engine_getNumEngines ========
00909  */
00910 extern Int Engine_getNumEngines();
00911
00912 /*
00913  *  ======== Engine_getProcId ========
00914  */
00915 extern String Engine_getProcId(Engine_Handle engine);
00916
00917 /*
00918  *  ======== Engine_hasServer ========
00919  */
00920 extern Bool Engine_hasServer(Engine_Handle engine);
00921
00922 /*
00923  *  ======== Engine_init ========
00924  */
00925 extern Void Engine_init(Void);
00926
00927
00930 /*
00931  *  ======== Engine_initAlgDesc ========
00932  */
00954 extern Void Engine_initAlgDesc(Engine_AlgDesc *pAlgDesc);
00955
00956 /*
00957  *  ======== Engine_initAttrs ========
00958  */
00966 extern Void Engine_initAttrs(Engine_Attrs *pAttrs);
00967
00968 /*
00969  *  ======== Engine_initDesc ========
00970  */
00983 extern Void Engine_initDesc(Engine_Desc *pDesc);
00984
00987 /*
00988  *  ======== Engine_getRemoteVisa ========
00989  */
00990 extern UInt32 Engine_getRemoteVisa(Engine_Node node);
00991
00992 /*
00993  *  ======== Engine_getCodecClassConfig ========
00994  */
00995 extern Ptr Engine_getCodecClassConfig(Engine_Handle engine, String name,
00996     String type);
00997
00998 /*
00999  *  ======== Engine_getNodeQueues ========
01000  */
01001 extern Void Engine_getNodeQueues(Engine_Node node, Comm_Id *stdIn, Comm_Handle *stdOut);
01002
01003
01004 /*
01005  *  ======== Engine_initFromServer ========
01006  */
01007 extern Engine_Error Engine_initFromServer(Engine_Handle engine);
01008
01009
01010 /*
01011  *  ======== Engine_redefineHeap ========
01012  */
01013 extern Engine_Error Engine_redefineHeap(Server_Handle server, String name,
01014         Uint32 base, Uint32 size);
01015
01016 /*
01017  *  ======== Engine_releaseTraceToken ========
01018  */
01019 extern Bool Engine_releaseTraceToken(Server_Handle server);
01020
01021 /*
01022  *  ======== Engine_requestTraceToken ========
01023  */
01024 extern Engine_Error Engine_requestTraceToken(Server_Handle server);
01025
01026 /*
01027  *  ======== Engine_restoreHeap ========
01028  */
01029 extern Engine_Error Engine_restoreHeap(Server_Handle server, String name);
01030
01033 /*
01034  *  ======== Engine_open ========
01035  */
01082 extern Engine_Handle Engine_open(String name, Engine_Attrs *attrs,
01083         Engine_Error *ec);
01084
01085 /*
01086  *  ======== Engine_fwriteTrace ========
01087  */
01113 extern Int Engine_fwriteTrace(Engine_Handle engine, String prefix, FILE *out);
01114
01115 /*
01116  *  ======== Engine_getAlgInfo ========
01117  */
01152 extern Engine_Error Engine_getAlgInfo(String name, Engine_AlgInfo *algInfo,
01153         Int index);
01154
01155 /*
01156  *  ======== Engine_getAlgInfo2 ========
01157  */
01206 extern Engine_Error Engine_getAlgInfo2(String name, Engine_Handle engine,
01207         Engine_AlgInfo2 *algInfo2, Int index);
01208
01209
01211 /*
01212  *  ======== Engine_getCpuLoad ========
01213  */
01242 extern Int Engine_getCpuLoad(Engine_Handle engine);
01243
01247 /*
01248  *  ======== Engine_getDesc ========
01249  */
01275 extern Engine_Error Engine_getDesc(String name, Engine_Desc *desc);
01276
01277 /*
01278  *  ======== Engine_getLastError ========
01279  */
01294 extern Engine_Error Engine_getLastError(Engine_Handle engine);
01295
01296 /*
01297  *  ======== Engine_getName ========
01298  */
01310 extern String Engine_getName(Engine_Handle engine);
01311
01312
01313 /*
01314  *  ======== Engine_getNumAlgs ========
01315  */
01339 extern Engine_Error Engine_getNumAlgs(String name, Int *numAlgs);
01340
01341 /*
01342  *  ======== Engine_getNumAlgs2 ========
01343  */
01384 extern Engine_Error Engine_getNumAlgs2(String name, Engine_Handle engine,
01385         Int *numAlgs);
01386
01387 /*
01388  *  ======== Engine_getServer ========
01389  */
01407 extern Server_Handle Engine_getServer(Engine_Handle engine);
01408
01409
01410 /*
01411  *  ======== Engine_getUsedMem ========
01412  */
01442 extern UInt32 Engine_getUsedMem(Engine_Handle engine);
01443
01444
01445 /*
01446  *  ======== Engine_remove ========
01447  */
01465 extern Engine_Error Engine_remove(String engineName);
01466
01467
01468 /*
01469  *  ======== Engine_setDesc ========
01470  */
01508 extern Engine_Error Engine_setDesc(String name, Engine_Desc *desc);
01509
01510
01511 /*
01512  *  ======== Engine_setTrace ========
01513  */
01536 extern Int Engine_setTrace(Engine_Handle engine, String mask);
01537
01538
01541 /*
01542  *  ======== Engine_getDesc ========
01543  *  Internal for testing.
01544  */
01545 extern Engine_Desc *_Engine_getDesc(Int i);
01546
01550
01551 #ifdef __cplusplus
01552 }
01553 #endif
01554
01555 #endif
01556 /*
01557  *  @(#) ti.sdo.ce; 1, 0, 6,464; 8-17-2011 12:04:40; /db/atree/library/trees/ce/ce-s19x/src/ xlibrary
01558
01559  */
01560


Codec Engine System Programming Interface (SPI): Memory.h Source File

  • File List
  • Globals
  • cetools
  • packages
  • xdc
  • runtime

cetools/packages/xdc/runtime/Memory.h

Go to the documentation of this file.
00001 /*
00002  *  Do not modify this file; it is automatically
00003  *  generated and any modifications will be overwritten.
00004  *
00005  * @(#) xdc-x14
00006  */
00007
00008 /*
00009  * ======== GENERATED SECTIONS ========
00010  *
00011  *     PROLOGUE
00012  *     INCLUDES
00013  *
00014  *     INTERNAL DEFINITIONS
00015  *     MODULE-WIDE CONFIGS
00016  *     FUNCTION DECLARATIONS
00017  *     SYSTEM FUNCTIONS
00018  *
00019  *     EPILOGUE
00020  *     STATE STRUCTURES
00021  *     PREFIX ALIASES
00022  */
00023
00024
00025 /*
00026  * ======== PROLOGUE ========
00027  */
00028
00029 #ifndef xdc_runtime_Memory__include
00030 #define xdc_runtime_Memory__include
00031
00032 #ifndef __nested__
00033 #define __nested__
00034 #define xdc_runtime_Memory__top__
00035 #endif
00036
00037 #ifdef __cplusplus
00038 #define __extern extern "C"
00039 #else
00040 #define __extern extern
00041 #endif
00042
00043 #define xdc_runtime_Memory___VERS 150
00044
00045
00046 /*
00047  * ======== INCLUDES ========
00048  */
00049
00050 #include <xdc/std.h>
00051
00052 #include <xdc/runtime/xdc.h>
00053 #include <xdc/runtime/Types.h>
00054 #include <xdc/runtime/package/package.defs.h>
00055
00056 #include <xdc/runtime/IModule.h>
00057 #include <xdc/runtime/Error.h>
00058 #include <xdc/runtime/IHeap.h>
00059 #include <xdc/runtime/package/Memory_HeapProxy.h>
00060
00061
00062 /*
00063  * ======== AUXILIARY DEFINITIONS ========
00064  */
00065
00066 /* Q_BLOCKING */
00067 #define xdc_runtime_Memory_Q_BLOCKING (1)
00068
00069 /* Size */
00070 typedef xdc_UArg xdc_runtime_Memory_Size;
00071
00072 /* Stats */
00073 struct xdc_runtime_Memory_Stats {
00074     xdc_runtime_Memory_Size totalSize;
00075     xdc_runtime_Memory_Size totalFreeSize;
00076     xdc_runtime_Memory_Size largestFreeSize;
00077 };
00078
00079
00080 /*
00081  * ======== INTERNAL DEFINITIONS ========
00082  */
00083
00084
00085 /*
00086  * ======== MODULE-WIDE CONFIGS ========
00087  */
00088
00089 /* Module__diagsEnabled */
00090 typedef xdc_Bits32 CT__xdc_runtime_Memory_Module__diagsEnabled;
00091 __extern __FAR__ const CT__xdc_runtime_Memory_Module__diagsEnabled xdc_runtime_Memory_Module__diagsEnabled__C;
00092
00093 /* Module__diagsIncluded */
00094 typedef xdc_Bits32 CT__xdc_runtime_Memory_Module__diagsIncluded;
00095 __extern __FAR__ const CT__xdc_runtime_Memory_Module__diagsIncluded xdc_runtime_Memory_Module__diagsIncluded__C;
00096
00097 /* Module__diagsMask */
00098 typedef xdc_Bits16* CT__xdc_runtime_Memory_Module__diagsMask;
00099 __extern __FAR__ const CT__xdc_runtime_Memory_Module__diagsMask xdc_runtime_Memory_Module__diagsMask__C;
00100
00101 /* Module__gateObj */
00102 typedef xdc_Ptr CT__xdc_runtime_Memory_Module__gateObj;
00103 __extern __FAR__ const CT__xdc_runtime_Memory_Module__gateObj xdc_runtime_Memory_Module__gateObj__C;
00104
00105 /* Module__gatePrms */
00106 typedef xdc_Ptr CT__xdc_runtime_Memory_Module__gatePrms;
00107 __extern __FAR__ const CT__xdc_runtime_Memory_Module__gatePrms xdc_runtime_Memory_Module__gatePrms__C;
00108
00109 /* Module__id */
00110 typedef xdc_runtime_Types_ModuleId CT__xdc_runtime_Memory_Module__id;
00111 __extern __FAR__ const CT__xdc_runtime_Memory_Module__id xdc_runtime_Memory_Module__id__C;
00112
00113 /* Module__loggerDefined */
00114 typedef xdc_Bool CT__xdc_runtime_Memory_Module__loggerDefined;
00115 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerDefined xdc_runtime_Memory_Module__loggerDefined__C;
00116
00117 /* Module__loggerObj */
00118 typedef xdc_Ptr CT__xdc_runtime_Memory_Module__loggerObj;
00119 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerObj xdc_runtime_Memory_Module__loggerObj__C;
00120
00121 /* Module__loggerFxn0 */
00122 typedef xdc_runtime_Types_LoggerFxn0 CT__xdc_runtime_Memory_Module__loggerFxn0;
00123 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn0 xdc_runtime_Memory_Module__loggerFxn0__C;
00124
00125 /* Module__loggerFxn1 */
00126 typedef xdc_runtime_Types_LoggerFxn1 CT__xdc_runtime_Memory_Module__loggerFxn1;
00127 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn1 xdc_runtime_Memory_Module__loggerFxn1__C;
00128
00129 /* Module__loggerFxn2 */
00130 typedef xdc_runtime_Types_LoggerFxn2 CT__xdc_runtime_Memory_Module__loggerFxn2;
00131 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn2 xdc_runtime_Memory_Module__loggerFxn2__C;
00132
00133 /* Module__loggerFxn4 */
00134 typedef xdc_runtime_Types_LoggerFxn4 CT__xdc_runtime_Memory_Module__loggerFxn4;
00135 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn4 xdc_runtime_Memory_Module__loggerFxn4__C;
00136
00137 /* Module__loggerFxn8 */
00138 typedef xdc_runtime_Types_LoggerFxn8 CT__xdc_runtime_Memory_Module__loggerFxn8;
00139 __extern __FAR__ const CT__xdc_runtime_Memory_Module__loggerFxn8 xdc_runtime_Memory_Module__loggerFxn8__C;
00140
00141 /* Module__startupDoneFxn */
00142 typedef xdc_Bool (*CT__xdc_runtime_Memory_Module__startupDoneFxn)(void);
00143 __extern __FAR__ const CT__xdc_runtime_Memory_Module__startupDoneFxn xdc_runtime_Memory_Module__startupDoneFxn__C;
00144
00145 /* Object__count */
00146 typedef xdc_Int CT__xdc_runtime_Memory_Object__count;
00147 __extern __FAR__ const CT__xdc_runtime_Memory_Object__count xdc_runtime_Memory_Object__count__C;
00148
00149 /* Object__heap */
00150 typedef xdc_runtime_IHeap_Handle CT__xdc_runtime_Memory_Object__heap;
00151 __extern __FAR__ const CT__xdc_runtime_Memory_Object__heap xdc_runtime_Memory_Object__heap__C;
00152
00153 /* Object__sizeof */
00154 typedef xdc_SizeT CT__xdc_runtime_Memory_Object__sizeof;
00155 __extern __FAR__ const CT__xdc_runtime_Memory_Object__sizeof xdc_runtime_Memory_Object__sizeof__C;
00156
00157 /* Object__table */
00158 typedef xdc_Ptr CT__xdc_runtime_Memory_Object__table;
00159 __extern __FAR__ const CT__xdc_runtime_Memory_Object__table xdc_runtime_Memory_Object__table__C;
00160
00161 /* defaultHeapInstance */
00162 #define xdc_runtime_Memory_defaultHeapInstance (xdc_runtime_Memory_defaultHeapInstance__C)
00163 typedef xdc_runtime_IHeap_Handle CT__xdc_runtime_Memory_defaultHeapInstance;
00164 __extern __FAR__ const CT__xdc_runtime_Memory_defaultHeapInstance xdc_runtime_Memory_defaultHeapInstance__C;
00165
00166
00167 /*
00168  * ======== FUNCTION DECLARATIONS ========
00169  */
00170
00171 /* Module_startup */
00172 #define xdc_runtime_Memory_Module_startup( state ) -1
00173
00174 /* Handle__label__S */
00175 xdc__CODESECT(xdc_runtime_Memory_Handle__label__S, "xdc_runtime_Memory_Handle__label")
00176 __extern xdc_runtime_Types_Label* xdc_runtime_Memory_Handle__label__S( xdc_Ptr obj, xdc_runtime_Types_Label* lab );
00177
00178 /* Module__startupDone__S */
00179 xdc__CODESECT(xdc_runtime_Memory_Module__startupDone__S, "xdc_runtime_Memory_Module__startupDone")
00180 __extern xdc_Bool xdc_runtime_Memory_Module__startupDone__S( void );
00181
00182 /* Object__create__S */
00183 xdc__CODESECT(xdc_runtime_Memory_Object__create__S, "xdc_runtime_Memory_Object__create")
00184 __extern xdc_Ptr xdc_runtime_Memory_Object__create__S( xdc_Ptr __oa, xdc_SizeT __osz, xdc_Ptr __aa, const xdc_UChar* __pa, xdc_SizeT __psz, xdc_runtime_Error_Block* __eb );
00185
00186 /* Object__delete__S */
00187 xdc__CODESECT(xdc_runtime_Memory_Object__delete__S, "xdc_runtime_Memory_Object__delete")
00188 __extern xdc_Void xdc_runtime_Memory_Object__delete__S( xdc_Ptr instp );
00189
00190 /* Object__destruct__S */
00191 xdc__CODESECT(xdc_runtime_Memory_Object__destruct__S, "xdc_runtime_Memory_Object__destruct")
00192 __extern xdc_Void xdc_runtime_Memory_Object__destruct__S( xdc_Ptr objp );
00193
00194 /* Object__get__S */
00195 xdc__CODESECT(xdc_runtime_Memory_Object__get__S, "xdc_runtime_Memory_Object__get")
00196 __extern xdc_Ptr xdc_runtime_Memory_Object__get__S( xdc_Ptr oarr, xdc_Int i );
00197
00198 /* Object__first__S */
00199 xdc__CODESECT(xdc_runtime_Memory_Object__first__S, "xdc_runtime_Memory_Object__first")
00200 __extern xdc_Ptr xdc_runtime_Memory_Object__first__S( void );
00201
00202 /* Object__next__S */
00203 xdc__CODESECT(xdc_runtime_Memory_Object__next__S, "xdc_runtime_Memory_Object__next")
00204 __extern xdc_Ptr xdc_runtime_Memory_Object__next__S( xdc_Ptr obj );
00205
00206 /* Params__init__S */
00207 xdc__CODESECT(xdc_runtime_Memory_Params__init__S, "xdc_runtime_Memory_Params__init")
00208 __extern xdc_Void xdc_runtime_Memory_Params__init__S( xdc_Ptr dst, xdc_Ptr src, xdc_SizeT psz, xdc_SizeT isz );
00209
00210 /* Proxy__abstract__S */
00211 xdc__CODESECT(xdc_runtime_Memory_Proxy__abstract__S, "xdc_runtime_Memory_Proxy__abstract")
00212 __extern xdc_Bool xdc_runtime_Memory_Proxy__abstract__S( void );
00213
00214 /* Proxy__delegate__S */
00215 xdc__CODESECT(xdc_runtime_Memory_Proxy__delegate__S, "xdc_runtime_Memory_Proxy__delegate")
00216 __extern xdc_Ptr xdc_runtime_Memory_Proxy__delegate__S( void );
00217
00218 /* alloc__E */
00219 #define xdc_runtime_Memory_alloc xdc_runtime_Memory_alloc__E
00220 xdc__CODESECT(xdc_runtime_Memory_alloc__E, "xdc_runtime_Memory_alloc")
00221 __extern xdc_Ptr xdc_runtime_Memory_alloc__E( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block* eb );
00222 xdc__CODESECT(xdc_runtime_Memory_alloc__F, "xdc_runtime_Memory_alloc")
00223 __extern xdc_Ptr xdc_runtime_Memory_alloc__F( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block* eb );
00224 __extern xdc_Ptr xdc_runtime_Memory_alloc__R( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block* eb );
00225
00226 /* calloc__E */
00227 #define xdc_runtime_Memory_calloc xdc_runtime_Memory_calloc__E
00228 xdc__CODESECT(xdc_runtime_Memory_calloc__E, "xdc_runtime_Memory_calloc")
00229 __extern xdc_Ptr xdc_runtime_Memory_calloc__E( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block* eb );
00230 xdc__CODESECT(xdc_runtime_Memory_calloc__F, "xdc_runtime_Memory_calloc")
00231 __extern xdc_Ptr xdc_runtime_Memory_calloc__F( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block* eb );
00232 __extern xdc_Ptr xdc_runtime_Memory_calloc__R( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_runtime_Error_Block* eb );
00233
00234 /* free__E */
00235 #define xdc_runtime_Memory_free xdc_runtime_Memory_free__E
00236 xdc__CODESECT(xdc_runtime_Memory_free__E, "xdc_runtime_Memory_free")
00237 __extern xdc_Void xdc_runtime_Memory_free__E( xdc_runtime_IHeap_Handle heap, xdc_Ptr block, xdc_SizeT size );
00238 xdc__CODESECT(xdc_runtime_Memory_free__F, "xdc_runtime_Memory_free")
00239 __extern xdc_Void xdc_runtime_Memory_free__F( xdc_runtime_IHeap_Handle heap, xdc_Ptr block, xdc_SizeT size );
00240 __extern xdc_Void xdc_runtime_Memory_free__R( xdc_runtime_IHeap_Handle heap, xdc_Ptr block, xdc_SizeT size );
00241
00242 /* getStats__E */
00243 #define xdc_runtime_Memory_getStats xdc_runtime_Memory_getStats__E
00244 xdc__CODESECT(xdc_runtime_Memory_getStats__E, "xdc_runtime_Memory_getStats")
00245 __extern xdc_Void xdc_runtime_Memory_getStats__E( xdc_runtime_IHeap_Handle heap, xdc_runtime_Memory_Stats* stats );
00246 xdc__CODESECT(xdc_runtime_Memory_getStats__F, "xdc_runtime_Memory_getStats")
00247 __extern xdc_Void xdc_runtime_Memory_getStats__F( xdc_runtime_IHeap_Handle heap, xdc_runtime_Memory_Stats* stats );
00248 __extern xdc_Void xdc_runtime_Memory_getStats__R( xdc_runtime_IHeap_Handle heap, xdc_runtime_Memory_Stats* stats );
00249
00250 /* query__E */
00251 #define xdc_runtime_Memory_query xdc_runtime_Memory_query__E
00252 xdc__CODESECT(xdc_runtime_Memory_query__E, "xdc_runtime_Memory_query")
00253 __extern xdc_Bool xdc_runtime_Memory_query__E( xdc_runtime_IHeap_Handle heap, xdc_Int qual );
00254 xdc__CODESECT(xdc_runtime_Memory_query__F, "xdc_runtime_Memory_query")
00255 __extern xdc_Bool xdc_runtime_Memory_query__F( xdc_runtime_IHeap_Handle heap, xdc_Int qual );
00256 __extern xdc_Bool xdc_runtime_Memory_query__R( xdc_runtime_IHeap_Handle heap, xdc_Int qual );
00257
00258 /* getMaxDefaultTypeAlign__E */
00259 #define xdc_runtime_Memory_getMaxDefaultTypeAlign xdc_runtime_Memory_getMaxDefaultTypeAlign__E
00260 xdc__CODESECT(xdc_runtime_Memory_getMaxDefaultTypeAlign__E, "xdc_runtime_Memory_getMaxDefaultTypeAlign")
00261 __extern xdc_SizeT xdc_runtime_Memory_getMaxDefaultTypeAlign__E( void );
00262 xdc__CODESECT(xdc_runtime_Memory_getMaxDefaultTypeAlign__F, "xdc_runtime_Memory_getMaxDefaultTypeAlign")
00263 __extern xdc_SizeT xdc_runtime_Memory_getMaxDefaultTypeAlign__F( void );
00264 __extern xdc_SizeT xdc_runtime_Memory_getMaxDefaultTypeAlign__R( void );
00265
00266 /* valloc__E */
00267 #define xdc_runtime_Memory_valloc xdc_runtime_Memory_valloc__E
00268 xdc__CODESECT(xdc_runtime_Memory_valloc__E, "xdc_runtime_Memory_valloc")
00269 __extern xdc_Ptr xdc_runtime_Memory_valloc__E( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_Char value, xdc_runtime_Error_Block* eb );
00270 xdc__CODESECT(xdc_runtime_Memory_valloc__F, "xdc_runtime_Memory_valloc")
00271 __extern xdc_Ptr xdc_runtime_Memory_valloc__F( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_Char value, xdc_runtime_Error_Block* eb );
00272 __extern xdc_Ptr xdc_runtime_Memory_valloc__R( xdc_runtime_IHeap_Handle heap, xdc_SizeT size, xdc_SizeT align, xdc_Char value, xdc_runtime_Error_Block* eb );
00273
00274
00275 /*
00276  * ======== SYSTEM FUNCTIONS ========
00277  */
00278
00279 /* Module_startupDone */
00280 #define xdc_runtime_Memory_Module_startupDone() xdc_runtime_Memory_Module__startupDone__S()
00281
00282 /* Object_heap */
00283 #define xdc_runtime_Memory_Object_heap() xdc_runtime_Memory_Object__heap__C
00284
00285 /* Module_heap */
00286 #define xdc_runtime_Memory_Module_heap() xdc_runtime_Memory_Object__heap__C
00287
00288 /* Module_id */
00289 static inline CT__xdc_runtime_Memory_Module__id xdc_runtime_Memory_Module_id( void )
00290 {
00291     return xdc_runtime_Memory_Module__id__C;
00292 }
00293
00294 /* Module_hasMask */
00295 static inline xdc_Bool xdc_runtime_Memory_Module_hasMask( void )
00296 {
00297     return xdc_runtime_Memory_Module__diagsMask__C != NULL;
00298 }
00299
00300 /* Module_getMask */
00301 static inline xdc_Bits16 xdc_runtime_Memory_Module_getMask( void )
00302 {
00303     return xdc_runtime_Memory_Module__diagsMask__C != NULL ? *xdc_runtime_Memory_Module__diagsMask__C : 0;
00304 }
00305
00306 /* Module_setMask */
00307 static inline xdc_Void xdc_runtime_Memory_Module_setMask( xdc_Bits16 mask )
00308 {
00309     if (xdc_runtime_Memory_Module__diagsMask__C != NULL) *xdc_runtime_Memory_Module__diagsMask__C = mask;
00310 }
00311
00312
00313 /*
00314  * ======== EPILOGUE ========
00315  */
00316
00317 #ifdef xdc_runtime_Memory__top__
00318 #undef __nested__
00319 #endif
00320
00321 #endif /* xdc_runtime_Memory__include */
00322
00323
00324 /*
00325  * ======== STATE STRUCTURES ========
00326  */
00327
00328 #if defined(__config__) || (!defined(__nested__) && defined(xdc_runtime_Memory__internalaccess))
00329
00330 #ifndef xdc_runtime_Memory__include_state
00331 #define xdc_runtime_Memory__include_state
00332
00333 /* Module_State */
00334 struct xdc_runtime_Memory_Module_State {
00335     xdc_SizeT maxDefaultTypeAlign;
00336 };
00337
00338 /* Module__state__V */
00339 extern struct xdc_runtime_Memory_Module_State__ xdc_runtime_Memory_Module__state__V;
00340
00341 #endif /* xdc_runtime_Memory__include_state */
00342
00343 #endif
00344
00345
00346 /*
00347  * ======== PREFIX ALIASES ========
00348  */
00349
00350 #if !defined(__nested__) && !defined(xdc_runtime_Memory__nolocalnames)
00351
00352 #ifndef xdc_runtime_Memory__localnames__done
00353 #define xdc_runtime_Memory__localnames__done
00354
00355 /* module prefix */
00356 #define Memory_Q_BLOCKING xdc_runtime_Memory_Q_BLOCKING
00357 #define Memory_Size xdc_runtime_Memory_Size
00358 #define Memory_Stats xdc_runtime_Memory_Stats
00359 #define Memory_Module_State xdc_runtime_Memory_Module_State
00360 #define Memory_defaultHeapInstance xdc_runtime_Memory_defaultHeapInstance
00361 #define Memory_alloc xdc_runtime_Memory_alloc
00362 #define Memory_calloc xdc_runtime_Memory_calloc
00363 #define Memory_free xdc_runtime_Memory_free
00364 #define Memory_getStats xdc_runtime_Memory_getStats
00365 #define Memory_query xdc_runtime_Memory_query
00366 #define Memory_getMaxDefaultTypeAlign xdc_runtime_Memory_getMaxDefaultTypeAlign
00367 #define Memory_valloc xdc_runtime_Memory_valloc
00368 #define Memory_Module_name xdc_runtime_Memory_Module_name
00369 #define Memory_Module_id xdc_runtime_Memory_Module_id
00370 #define Memory_Module_startup xdc_runtime_Memory_Module_startup
00371 #define Memory_Module_startupDone xdc_runtime_Memory_Module_startupDone
00372 #define Memory_Module_hasMask xdc_runtime_Memory_Module_hasMask
00373 #define Memory_Module_getMask xdc_runtime_Memory_Module_getMask
00374 #define Memory_Module_setMask xdc_runtime_Memory_Module_setMask
00375 #define Memory_Object_heap xdc_runtime_Memory_Object_heap
00376 #define Memory_Module_heap xdc_runtime_Memory_Module_heap
00377
00378 /* proxies */
00379 #include <xdc/runtime/package/Memory_HeapProxy.h>
00380
00381 #endif /* xdc_runtime_Memory__localnames__done */
00382 #endif
00383 /*
00384  *  @(#) xdc.runtime; 2, 1, 0,337; 6-14-2011 11:49:32; /db/ztree/library/trees/xdc/xdc-x14x/src/packages/
00385  */
00386


Codec Engine System Programming Interface (SPI): Alphabetical List

  • Data Structures
  • Data Structure Index
  • Data Fields

Data Structure Index

E | I | S | T | V | X
E
Engine_Attrs IALG_MemRec
S
V
Engine_AlgDesc Engine_DllAlgDesc IALG_Obj SKEL_Fxns VISA_MsgHeader
Engine_AlgInfo
I
IALG_Params
T
X


Codec Engine System Programming Interface (SPI): packages/ti/ -> cetools Relation

  • packages
  • ti

ti → cetools Relation

File in packages/ti Includes file in cetools


Codec Engine System Programming Interface (SPI): packages/ti/sdo/ -> cetools Relation

  • packages
  • ti
  • sdo

sdo → cetools Relation

File in packages/ti/sdo Includes file in cetools


Codec Engine System Programming Interface (SPI): packages/ti/sdo/ce/ -> cetools Relation

  • packages
  • ti
  • sdo
  • ce

ce → cetools Relation

File in packages/ti/sdo/ce Includes file in cetools


Codec Engine System Programming Interface (SPI): disclaimer.dox File Reference

  • File List
  • Globals

disclaimer.dox File Reference

All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine System Programming Interface (SPI): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u

- a -

  • algActivate : IALG_Fxns
  • algAlloc : IALG_Fxns
  • algControl : IALG_Fxns
  • algDeactivate : IALG_Fxns
  • algFree : IALG_Fxns
  • algInfoSize : Engine_AlgInfo , Engine_AlgInfo2
  • algInit : IALG_Fxns
  • algMoved : IALG_Fxns
  • algNumAlloc : IALG_Fxns
  • align : ti_sdo_ce_osal_Memory_AllocParams
  • alignment : IALG_MemRec
  • apiCreate : SKEL_Fxns
  • apiDestroy : SKEL_Fxns
  • attrs : IALG_MemRec

- b -

  • base : IALG_MemRec

- c -

  • call : SKEL_Fxns
  • cmd : VISA_MsgHeader
  • codecClassConfig : Engine_AlgDesc , Engine_DllAlgDesc

- f -

  • flags : ti_sdo_ce_osal_Memory_AllocParams
  • fxns : Engine_DllAlgDesc , Engine_AlgDesc , IALG_Obj

- g -

  • groupId : Engine_AlgDesc

- h -

  • header : VISA_MsgHeader

- i -

  • idmaFxns : Engine_AlgDesc , Engine_DllAlgDesc
  • implementationId : IALG_Fxns
  • iresFxns : Engine_AlgDesc , Engine_DllAlgDesc
  • isLocal : Engine_AlgDesc , Engine_AlgInfo2 , Engine_AlgInfo

- l -

  • largestFreeSize : xdc_runtime_Memory_Stats

- m -

  • memType : Engine_AlgDesc

- n -

  • name : Engine_AlgInfo , Engine_AlgDesc , Engine_AlgInfo2

- p -

  • procId : Engine_Attrs

- r -

  • rpcProtocolVersion : Engine_AlgDesc

- s -

  • seg : ti_sdo_ce_osal_Memory_AllocParams
  • size : IALG_MemRec , IALG_Status , IALG_Params
  • space : IALG_MemRec
  • status : VISA_MsgHeader

- t -

  • totalFreeSize : xdc_runtime_Memory_Stats
  • totalSize : xdc_runtime_Memory_Stats
  • type : ti_sdo_ce_osal_Memory_AllocParams
  • types : Engine_AlgInfo2 , Engine_AlgDesc , Engine_DllAlgDesc
  • typeTab : Engine_AlgDesc , Engine_AlgInfo

- u -

  • uuid : Engine_AlgDesc


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • lab : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • Memory_alloc : cetools/packages/xdc/runtime/Memory.h
  • Memory_calloc : cetools/packages/xdc/runtime/Memory.h
  • Memory_defaultHeapInstance : cetools/packages/xdc/runtime/Memory.h
  • Memory_free : cetools/packages/xdc/runtime/Memory.h
  • Memory_getMaxDefaultTypeAlign : cetools/packages/xdc/runtime/Memory.h
  • Memory_getStats : cetools/packages/xdc/runtime/Memory.h
  • Memory_MODNAME : packages/ti/sdo/ce/osal/Memory.h
  • Memory_Module_getMask : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_hasMask : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_heap : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_id : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_name : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_setMask : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_startup : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_startupDone : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_State : cetools/packages/xdc/runtime/Memory.h
  • Memory_Object_heap : cetools/packages/xdc/runtime/Memory.h
  • Memory_Q_BLOCKING : cetools/packages/xdc/runtime/Memory.h
  • Memory_query : cetools/packages/xdc/runtime/Memory.h
  • Memory_Size : cetools/packages/xdc/runtime/Memory.h
  • Memory_Stats : cetools/packages/xdc/runtime/Memory.h
  • Memory_valloc : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • align : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- b -

  • block : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • CT__xdc_runtime_Memory_defaultHeapInstance : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__diagsEnabled : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__diagsIncluded : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__diagsMask : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__gateObj : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__gatePrms : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__id : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerDefined : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn0 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn1 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn2 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn4 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn8 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerObj : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__startupDoneFxn : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__count : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__heap : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__sizeof : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__table : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • eb : cetools/packages/xdc/runtime/Memory.h
  • Engine_add() : Engine.h
  • Engine_addAlg() : Engine.h
  • Engine_addStubFxns() : Engine.h
  • Engine_AlgDesc : Engine.h
  • Engine_AlgInfo : Engine.h
  • Engine_AlgInfo2 : Engine.h
  • Engine_ATTRS : Engine.h
  • Engine_Attrs : Engine.h
  • Engine_CachedMemType : Engine.h
  • Engine_close() : Engine.h
  • Engine_DllAlgDesc : Engine.h
  • Engine_EBADSERVER : Engine.h
  • Engine_ECODECCREATE : Engine.h
  • Engine_ECODECSTART : Engine.h
  • Engine_ECOMALLOC : Engine.h
  • Engine_EDSPLOAD : Engine.h
  • Engine_EEXIST : Engine.h
  • Engine_EINUSE : Engine.h
  • Engine_EINVAL : Engine.h
  • Engine_ENOCOMM : Engine.h
  • Engine_ENOMEM : Engine.h
  • Engine_ENOSERVER : Engine.h
  • Engine_ENOTAVAIL : Engine.h
  • Engine_ENOTFOUND : Engine.h
  • Engine_EOK : Engine.h
  • Engine_Error : Engine.h
  • Engine_ERUNTIME : Engine.h
  • Engine_ETIMEOUT : Engine.h
  • Engine_EWRONGSTATE : Engine.h
  • Engine_fwriteTrace() : Engine.h
  • Engine_GetAlgDescFxn : Engine.h
  • Engine_GETALGDESCFXN : Engine.h
  • Engine_getAlgInfo() : Engine.h
  • Engine_getAlgInfo2() : Engine.h
  • Engine_getDesc() : Engine.h
  • Engine_getLastError() : Engine.h
  • Engine_getName() : Engine.h
  • Engine_getNumAlgs() : Engine.h
  • Engine_getNumAlgs2() : Engine.h
  • Engine_getServer() : Engine.h
  • Engine_getUsedMem() : Engine.h
  • Engine_Handle : Engine.h
  • Engine_initAlgDesc() : Engine.h
  • Engine_initAttrs() : Engine.h
  • Engine_initDesc() : Engine.h
  • Engine_MODNAME : Engine.h
  • Engine_open() : Engine.h
  • Engine_remove() : Engine.h
  • Engine_removeAlg() : Engine.h
  • Engine_setDesc() : Engine.h
  • Engine_setTrace() : Engine.h
  • Engine_USECACHEDMEM_CACHED : Engine.h
  • Engine_USECACHEDMEM_DEFAULT : Engine.h
  • Engine_USECACHEDMEM_NONCACHED : Engine.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • i : cetools/packages/xdc/runtime/Memory.h
  • IALG_Cmd : ialg.h
  • IALG_CUSTOMFAILBASE : ialg.h
  • IALG_CUSTOMFAILEND : ialg.h
  • IALG_DARAM0 : ialg.h
  • IALG_DARAM1 : ialg.h
  • IALG_DARAM2 : ialg.h
  • IALG_DEFMEMRECS : ialg.h
  • IALG_EFAIL : ialg.h
  • IALG_EOK : ialg.h
  • IALG_EPROG : ialg.h
  • IALG_ESDATA : ialg.h
  • IALG_EXTERNAL : ialg.h
  • IALG_Fxns : ialg.h
  • IALG_Handle : ialg.h
  • IALG_IPROG : ialg.h
  • IALG_isOffChip : ialg.h
  • IALG_isProg : ialg.h
  • IALG_MemAttrs : ialg.h
  • IALG_MemRec : ialg.h
  • IALG_MemSpace : ialg.h
  • IALG_MPROG : ialg.h
  • IALG_MXTRN : ialg.h
  • IALG_Obj : ialg.h
  • IALG_OBJMEMREC : ialg.h
  • IALG_Params : ialg.h
  • IALG_PERSIST : ialg.h
  • IALG_SARAM : ialg.h
  • IALG_SARAM0 : ialg.h
  • IALG_SARAM1 : ialg.h
  • IALG_SARAM2 : ialg.h
  • IALG_SCRATCH : ialg.h
  • IALG_Status : ialg.h
  • IALG_SYSCMD : ialg.h
  • IALG_WRITEONCE : ialg.h
  • isz : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- p -

  • psz : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- q -

  • qual : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • size : cetools/packages/xdc/runtime/Memory.h
  • SKEL_CALLFXN : skel.h
  • SKEL_CREATEFXN : skel.h
  • SKEL_DESTROYFXN : skel.h
  • SKEL_Fxns : skel.h
  • src : cetools/packages/xdc/runtime/Memory.h
  • stats : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • ti_sdo_ce_osal_Memory_alloc() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_AllocParams : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_CACHED : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_CACHEDMASK : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheInv() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheWb() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheWbInv() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheWbInvAll() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_contigAlloc() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_contigFree() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_CONTIGHEAP : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_CONTIGPOOL : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_DEFAULTPARAMS : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_dumpKnownContigBufsList() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_free() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getBufferPhysicalAddress() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getBufferVirtualAddress() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getHeapId() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getNumHeaps() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_GTNAME : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_MALLOC : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_NONCACHED : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_registerContigBuf() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_SEG : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_type : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_unregisterContigBuf() : packages/ti/sdo/ce/osal/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • value : cetools/packages/xdc/runtime/Memory.h
  • VISA_allocMsg() : visa.h
  • VISA_call() : visa.h
  • VISA_callAsync() : visa.h
  • VISA_checked : visa.h
  • VISA_create() : visa.h
  • VISA_create2() : visa.h
  • VISA_delete() : visa.h
  • VISA_EFAIL : visa.h
  • VISA_enter() : visa.h
  • VISA_EOK : visa.h
  • VISA_ERUNTIME : visa.h
  • VISA_ETIMEOUT : visa.h
  • VISA_EUNSUPPORTED : visa.h
  • VISA_exit() : visa.h
  • VISA_FOREVER : visa.h
  • VISA_freeMsg() : visa.h
  • VISA_getAlgFxns() : visa.h
  • VISA_getAlgHandle() : visa.h
  • VISA_getAlgMemRecs() : visa.h
  • VISA_getAlgNumRecs() : visa.h
  • VISA_getAlgorithmHandle() : visa.h
  • VISA_getCodecClassConfig() : visa.h
  • VISA_getContext() : visa.h
  • VISA_getMaxMsgSize() : visa.h
  • VISA_Handle : visa.h
  • VISA_isLocal() : visa.h
  • VISA_MODNAME : visa.h
  • VISA_Msg : visa.h
  • VISA_MsgHeader : visa.h
  • VISA_setContext() : visa.h
  • VISA_Status : visa.h
  • VISA_wait() : visa.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • e
  • i
  • l
  • m
  • p
  • q
  • s
  • t
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • XDAS_Bool : xdas.h
  • XDAS_FALSE : xdas.h
  • XDAS_Int16 : xdas.h
  • XDAS_Int32 : xdas.h
  • XDAS_Int8 : xdas.h
  • XDAS_TRUE : xdas.h
  • XDAS_UInt16 : xdas.h
  • XDAS_UInt32 : xdas.h
  • XDAS_UInt8 : xdas.h
  • XDAS_Void : xdas.h
  • xdc__CODESECT() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory___VERS : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory__localnames__done : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory__top__ : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_alloc : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_alloc__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_calloc : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_calloc__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_defaultHeapInstance : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_defaultHeapInstance__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_free : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_free__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getMaxDefaultTypeAlign : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getMaxDefaultTypeAlign__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getStats : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getStats__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__diagsEnabled__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__diagsIncluded__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__diagsMask__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__gateObj__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__gatePrms__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__id__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerDefined__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn0__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn1__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn2__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn4__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn8__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerObj__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__startupDoneFxn__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module_heap : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module_startup : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module_startupDone : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__count__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__heap__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__sizeof__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__table__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object_heap : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Q_BLOCKING : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_query : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_query__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Size : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_valloc : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_valloc__R() : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • e
  • i
  • m
  • t
  • v
  • x

- _ -

  • __extern : cetools/packages/xdc/runtime/Memory.h
  • __nested__ : cetools/packages/xdc/runtime/Memory.h

- e -

  • Engine_EBADSERVER : Engine.h
  • Engine_ECODECCREATE : Engine.h
  • Engine_ECODECSTART : Engine.h
  • Engine_ECOMALLOC : Engine.h
  • Engine_EDSPLOAD : Engine.h
  • Engine_EEXIST : Engine.h
  • Engine_EINUSE : Engine.h
  • Engine_EINVAL : Engine.h
  • Engine_ENOCOMM : Engine.h
  • Engine_ENOMEM : Engine.h
  • Engine_ENOSERVER : Engine.h
  • Engine_ENOTAVAIL : Engine.h
  • Engine_ENOTFOUND : Engine.h
  • Engine_EOK : Engine.h
  • Engine_ERUNTIME : Engine.h
  • Engine_ETIMEOUT : Engine.h
  • Engine_EWRONGSTATE : Engine.h
  • Engine_GETALGDESCFXN : Engine.h
  • Engine_MODNAME : Engine.h

- i -

  • IALG_CUSTOMFAILBASE : ialg.h
  • IALG_CUSTOMFAILEND : ialg.h
  • IALG_DEFMEMRECS : ialg.h
  • IALG_EFAIL : ialg.h
  • IALG_EOK : ialg.h
  • IALG_isOffChip : ialg.h
  • IALG_isProg : ialg.h
  • IALG_MPROG : ialg.h
  • IALG_MXTRN : ialg.h
  • IALG_OBJMEMREC : ialg.h
  • IALG_SYSCMD : ialg.h

- m -

  • Memory_alloc : cetools/packages/xdc/runtime/Memory.h
  • Memory_calloc : cetools/packages/xdc/runtime/Memory.h
  • Memory_defaultHeapInstance : cetools/packages/xdc/runtime/Memory.h
  • Memory_free : cetools/packages/xdc/runtime/Memory.h
  • Memory_getMaxDefaultTypeAlign : cetools/packages/xdc/runtime/Memory.h
  • Memory_getStats : cetools/packages/xdc/runtime/Memory.h
  • Memory_MODNAME : packages/ti/sdo/ce/osal/Memory.h
  • Memory_Module_getMask : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_hasMask : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_heap : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_id : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_name : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_setMask : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_startup : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_startupDone : cetools/packages/xdc/runtime/Memory.h
  • Memory_Module_State : cetools/packages/xdc/runtime/Memory.h
  • Memory_Object_heap : cetools/packages/xdc/runtime/Memory.h
  • Memory_Q_BLOCKING : cetools/packages/xdc/runtime/Memory.h
  • Memory_query : cetools/packages/xdc/runtime/Memory.h
  • Memory_Size : cetools/packages/xdc/runtime/Memory.h
  • Memory_Stats : cetools/packages/xdc/runtime/Memory.h
  • Memory_valloc : cetools/packages/xdc/runtime/Memory.h

- t -

  • ti_sdo_ce_osal_Memory_CACHED : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_CACHEDMASK : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_GTNAME : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_NONCACHED : packages/ti/sdo/ce/osal/Memory.h

- v -

  • VISA_EFAIL : visa.h
  • VISA_EOK : visa.h
  • VISA_ERUNTIME : visa.h
  • VISA_ETIMEOUT : visa.h
  • VISA_EUNSUPPORTED : visa.h
  • VISA_FOREVER : visa.h
  • VISA_MODNAME : visa.h

- x -

  • XDAS_FALSE : xdas.h
  • XDAS_TRUE : xdas.h
  • xdc_runtime_Memory___VERS : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory__localnames__done : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory__top__ : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_alloc : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_calloc : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_defaultHeapInstance : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_free : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getMaxDefaultTypeAlign : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getStats : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module_heap : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module_startup : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module_startupDone : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object_heap : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Q_BLOCKING : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_query : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_valloc : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • Engine_CachedMemType : Engine.h
  • IALG_MemAttrs : ialg.h
  • IALG_MemSpace : ialg.h
  • ti_sdo_ce_osal_Memory_type : packages/ti/sdo/ce/osal/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • Engine_USECACHEDMEM_CACHED : Engine.h
  • Engine_USECACHEDMEM_DEFAULT : Engine.h
  • Engine_USECACHEDMEM_NONCACHED : Engine.h
  • IALG_DARAM0 : ialg.h
  • IALG_DARAM1 : ialg.h
  • IALG_DARAM2 : ialg.h
  • IALG_EPROG : ialg.h
  • IALG_ESDATA : ialg.h
  • IALG_EXTERNAL : ialg.h
  • IALG_IPROG : ialg.h
  • IALG_PERSIST : ialg.h
  • IALG_SARAM : ialg.h
  • IALG_SARAM0 : ialg.h
  • IALG_SARAM1 : ialg.h
  • IALG_SARAM2 : ialg.h
  • IALG_SCRATCH : ialg.h
  • IALG_WRITEONCE : ialg.h
  • ti_sdo_ce_osal_Memory_CONTIGHEAP : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_CONTIGPOOL : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_MALLOC : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_SEG : packages/ti/sdo/ce/osal/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • e
  • t
  • v
  • x

- _ -

  • _VISA_exit() : visa.h
  • _VISA_init() : visa.h

- e -

  • Engine_add() : Engine.h
  • Engine_addAlg() : Engine.h
  • Engine_addStubFxns() : Engine.h
  • Engine_close() : Engine.h
  • Engine_fwriteTrace() : Engine.h
  • Engine_getAlgInfo() : Engine.h
  • Engine_getAlgInfo2() : Engine.h
  • Engine_getDesc() : Engine.h
  • Engine_getLastError() : Engine.h
  • Engine_getName() : Engine.h
  • Engine_getNumAlgs() : Engine.h
  • Engine_getNumAlgs2() : Engine.h
  • Engine_getServer() : Engine.h
  • Engine_getUsedMem() : Engine.h
  • Engine_initAlgDesc() : Engine.h
  • Engine_initAttrs() : Engine.h
  • Engine_initDesc() : Engine.h
  • Engine_open() : Engine.h
  • Engine_remove() : Engine.h
  • Engine_removeAlg() : Engine.h
  • Engine_setDesc() : Engine.h
  • Engine_setTrace() : Engine.h

- t -

  • ti_sdo_ce_osal_Memory_alloc() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheInv() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheWb() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheWbInv() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_cacheWbInvAll() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_contigAlloc() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_contigFree() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_dumpKnownContigBufsList() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_free() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getBufferPhysicalAddress() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getBufferVirtualAddress() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getHeapId() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_getNumHeaps() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_registerContigBuf() : packages/ti/sdo/ce/osal/Memory.h
  • ti_sdo_ce_osal_Memory_unregisterContigBuf() : packages/ti/sdo/ce/osal/Memory.h

- v -

  • VISA_allocMsg() : visa.h
  • VISA_call() : visa.h
  • VISA_callAsync() : visa.h
  • VISA_create() : visa.h
  • VISA_create2() : visa.h
  • VISA_delete() : visa.h
  • VISA_enter() : visa.h
  • VISA_exit() : visa.h
  • VISA_freeMsg() : visa.h
  • VISA_getAlgFxns() : visa.h
  • VISA_getAlgHandle() : visa.h
  • VISA_getAlgMemRecs() : visa.h
  • VISA_getAlgNumRecs() : visa.h
  • VISA_getAlgorithmHandle() : visa.h
  • VISA_getCodecClassConfig() : visa.h
  • VISA_getContext() : visa.h
  • VISA_getMaxMsgSize() : visa.h
  • VISA_isLocal() : visa.h
  • VISA_setContext() : visa.h
  • VISA_wait() : visa.h

- x -

  • xdc__CODESECT() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_alloc__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_calloc__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_free__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getMaxDefaultTypeAlign__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_getStats__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_query__R() : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_valloc__R() : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • c
  • e
  • i
  • s
  • t
  • v
  • x

- c -

  • CT__xdc_runtime_Memory_defaultHeapInstance : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__diagsEnabled : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__diagsIncluded : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__diagsMask : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__gateObj : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__gatePrms : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__id : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerDefined : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn0 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn1 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn2 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn4 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerFxn8 : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__loggerObj : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Module__startupDoneFxn : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__count : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__heap : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__sizeof : cetools/packages/xdc/runtime/Memory.h
  • CT__xdc_runtime_Memory_Object__table : cetools/packages/xdc/runtime/Memory.h

- e -

  • Engine_AlgDesc : Engine.h
  • Engine_AlgInfo : Engine.h
  • Engine_AlgInfo2 : Engine.h
  • Engine_Attrs : Engine.h
  • Engine_CachedMemType : Engine.h
  • Engine_DllAlgDesc : Engine.h
  • Engine_Error : Engine.h
  • Engine_GetAlgDescFxn : Engine.h
  • Engine_Handle : Engine.h

- i -

  • IALG_Cmd : ialg.h
  • IALG_Fxns : ialg.h
  • IALG_Handle : ialg.h
  • IALG_MemAttrs : ialg.h
  • IALG_MemRec : ialg.h
  • IALG_MemSpace : ialg.h
  • IALG_Obj : ialg.h
  • IALG_Params : ialg.h
  • IALG_Status : ialg.h

- s -

  • SKEL_CALLFXN : skel.h
  • SKEL_CREATEFXN : skel.h
  • SKEL_DESTROYFXN : skel.h
  • SKEL_Fxns : skel.h

- t -

  • ti_sdo_ce_osal_Memory_AllocParams : packages/ti/sdo/ce/osal/Memory.h

- v -

  • VISA_Handle : visa.h
  • VISA_Msg : visa.h
  • VISA_MsgHeader : visa.h
  • VISA_Status : visa.h

- x -

  • XDAS_Bool : xdas.h
  • XDAS_Int16 : xdas.h
  • XDAS_Int32 : xdas.h
  • XDAS_Int8 : xdas.h
  • XDAS_UInt16 : xdas.h
  • XDAS_UInt32 : xdas.h
  • XDAS_UInt8 : xdas.h
  • XDAS_Void : xdas.h
  • xdc_runtime_Memory_Size : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • e
  • i
  • l
  • p
  • q
  • s
  • t
  • v
  • x

- _ -

  • __aa : cetools/packages/xdc/runtime/Memory.h
  • __eb : cetools/packages/xdc/runtime/Memory.h
  • __osz : cetools/packages/xdc/runtime/Memory.h
  • __pa : cetools/packages/xdc/runtime/Memory.h
  • __psz : cetools/packages/xdc/runtime/Memory.h

- a -

  • align : cetools/packages/xdc/runtime/Memory.h

- b -

  • block : cetools/packages/xdc/runtime/Memory.h

- e -

  • eb : cetools/packages/xdc/runtime/Memory.h
  • Engine_ATTRS : Engine.h

- i -

  • i : cetools/packages/xdc/runtime/Memory.h
  • isz : cetools/packages/xdc/runtime/Memory.h

- l -

  • lab : cetools/packages/xdc/runtime/Memory.h

- p -

  • psz : cetools/packages/xdc/runtime/Memory.h

- q -

  • qual : cetools/packages/xdc/runtime/Memory.h

- s -

  • size : cetools/packages/xdc/runtime/Memory.h
  • src : cetools/packages/xdc/runtime/Memory.h
  • stats : cetools/packages/xdc/runtime/Memory.h

- t -

  • ti_sdo_ce_osal_Memory_DEFAULTPARAMS : packages/ti/sdo/ce/osal/Memory.h

- v -

  • value : cetools/packages/xdc/runtime/Memory.h
  • VISA_checked : visa.h

- x -

  • xdc_runtime_Memory_defaultHeapInstance__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__diagsEnabled__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__diagsIncluded__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__diagsMask__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__gateObj__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__gatePrms__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__id__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerDefined__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn0__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn1__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn2__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn4__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerFxn8__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__loggerObj__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Module__startupDoneFxn__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__count__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__heap__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__sizeof__C : cetools/packages/xdc/runtime/Memory.h
  • xdc_runtime_Memory_Object__table__C : cetools/packages/xdc/runtime/Memory.h


Codec Engine System Programming Interface (SPI): Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


Codec Engine System Programming Interface (SPI): ialg.h Source File

  • File List
  • Globals
  • cetools
  • packages
  • ti
  • xdais

ialg.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2011, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_IALG_
00047 #define ti_xdais_IALG_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00055
00056 /*---------------------------*/
00057 /*    TYPES AND CONSTANTS    */
00058 /*---------------------------*/
00059
00060 #define IALG_DEFMEMRECS 4
00061 #define IALG_OBJMEMREC  0
00062 #define IALG_SYSCMD     256
00064 #define IALG_EOK        0
00065 #define IALG_EFAIL      -1
00067 #define IALG_CUSTOMFAILBASE  -2048
00071 #define IALG_CUSTOMFAILEND -256
00079 typedef enum IALG_MemAttrs {
00080     IALG_SCRATCH,
00081     IALG_PERSIST,
00082     IALG_WRITEONCE
00083 } IALG_MemAttrs;
00084
00085 #define IALG_MPROG  0x0008
00086 #define IALG_MXTRN  0x0010
00091 /*
00092  *  ======== IALG_MemSpace ========
00093  */
00094 typedef enum IALG_MemSpace {
00095     IALG_EPROG =
00096         IALG_MPROG | IALG_MXTRN,
00097
00098     IALG_IPROG =
00099         IALG_MPROG,
00100
00101     IALG_ESDATA =
00102         IALG_MXTRN + 0,
00103
00104     IALG_EXTERNAL =
00105         IALG_MXTRN + 1,
00106
00107     IALG_DARAM0 = 0,
00108     IALG_DARAM1 = 1,
00110     IALG_SARAM  = 2,
00111     IALG_SARAM0 = 2,
00112     IALG_SARAM1 = 3,
00114     IALG_DARAM2 = 4,
00115     IALG_SARAM2 = 5
00116 } IALG_MemSpace;
00117
00118 /*
00119  *  ======== IALG_isProg ========
00120  */
00121 #define IALG_isProg(s) (        \
00122     (((int)(s)) & IALG_MPROG)   \
00123 )
00124
00125 /*
00126  *  ======== IALG_isOffChip ========
00127  */
00128 #define IALG_isOffChip(s) (     \
00129     (((int)(s)) & IALG_MXTRN)   \
00130 )
00131
00132
00136 typedef struct IALG_MemRec {
00137     Uns             size;
00138     Int             alignment;
00139     IALG_MemSpace   space;
00140     IALG_MemAttrs   attrs;
00141     Void            *base;
00142 } IALG_MemRec;
00143
00144
00153 typedef struct IALG_Obj {
00154     struct IALG_Fxns *fxns;
00155 } IALG_Obj;
00156
00157
00161 typedef struct IALG_Obj *IALG_Handle;
00162
00163
00170 typedef struct IALG_Params {
00171     Int size;
00172 } IALG_Params;
00173
00174
00181 typedef struct IALG_Status {
00182     Int size;
00183 } IALG_Status;
00184
00185
00193 typedef unsigned int IALG_Cmd;
00194
00195
00200 /*
00201  *      algAlloc()        - apps call this to query the algorithm about
00202  *                          its memory requirements. Must be non-NULL.
00203  *      algControl()      - algorithm specific control operations.  May be
00204  *                          NULL; NULL => no operations supported.
00205  *      algDeactivate()   - notification that current instance is about to
00206  *                          be "deactivated".  May be NULL; NULL => do nothing.
00207  *      algFree()         - query algorithm for memory to free when removing
00208  *                          an instance.  Must be non-NULL.
00209  *      algInit()         - apps call this to allow the algorithm to
00210  *                          initialize memory requested via algAlloc().  Must
00211  *                          be non-NULL.
00212  *      algMoved()        - apps call this whenever an algorithms object or
00213  *                          any pointer parameters are moved in real-time.
00214  *                          May be NULL; NULL => object can not be moved.
00215  *      algNumAlloc()     - query algorithm for number of memory requests.
00216  *                          May be NULL; NULL => number of mem recs is less
00217  *                          then #IALG_DEFMEMRECS.
00218  */
00219 typedef struct IALG_Fxns {
00224     Void    *implementationId;
00225
00275     Void    (*algActivate)(IALG_Handle handle);
00276
00355     Int     (*algAlloc)(const IALG_Params *params,
00356         struct IALG_Fxns **parentFxns, IALG_MemRec *memTab);
00357
00398     Int     (*algControl)(IALG_Handle handle, IALG_Cmd cmd,
00399         IALG_Status *status);
00400
00454     Void    (*algDeactivate)(IALG_Handle handle);
00455
00496     Int     (*algFree)(IALG_Handle handle, IALG_MemRec *memTab);
00497
00671     Int     (*algInit)(IALG_Handle handle, const IALG_MemRec *memTab,
00672         IALG_Handle parent, const IALG_Params *params);
00673
00694     Void    (*algMoved)(IALG_Handle handle, const IALG_MemRec *memTab,
00695         IALG_Handle parent, const IALG_Params *params);
00696
00753     Int     (*algNumAlloc)(Void);
00754 } IALG_Fxns;
00755
00758 #ifdef __cplusplus
00759 }
00760 #endif
00761
00762 #endif  /* ti_xdais_IALG_ */
00763 /*
00764  *  @(#) ti.xdais; 1, 2.0, 1,7; 6-14-2011 10:34:31; /db/wtree/library/trees/dais/dais.git/src/ dais-u02
00765  */
00766


Codec Engine System Programming Interface (SPI): Memory.h Source File

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce
  • osal

packages/ti/sdo/ce/osal/Memory.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2011, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== Memory.h ========
00035  */
00051 #ifndef ti_sdo_ce_osal_Memory_
00052 #define ti_sdo_ce_osal_Memory_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00060
00068 #define ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT ((UInt)(-1))
00069
00078 #define Memory_MODNAME "ti.sdo.ce.osal.Memory"
00079
00085 #define ti_sdo_ce_osal_Memory_GTNAME "OM"
00086
00096 typedef struct ti_sdo_ce_osal_Memory_Stat {
00097     String name;
00098     Uint32 base;
00099     UInt size;
00100     UInt used;
00101     UInt length;
00102 } ti_sdo_ce_osal_Memory_Stat;
00103
00113 typedef enum {
00114     ti_sdo_ce_osal_Memory_MALLOC = 0,
00118     ti_sdo_ce_osal_Memory_SEG = 1,
00122     ti_sdo_ce_osal_Memory_CONTIGPOOL = 2,
00126     ti_sdo_ce_osal_Memory_CONTIGHEAP =3
00130 } ti_sdo_ce_osal_Memory_type;
00131
00140 typedef struct ti_sdo_ce_osal_Memory_AllocParams {
00141     ti_sdo_ce_osal_Memory_type type;
00145     UInt flags;
00161     UInt align;
00162     UInt seg;
00163 } ti_sdo_ce_osal_Memory_AllocParams;
00164
00165
00173 #define ti_sdo_ce_osal_Memory_CACHED    0x00000000
00174
00182 #define ti_sdo_ce_osal_Memory_NONCACHED 0x00000001
00183
00191 #define ti_sdo_ce_osal_Memory_CACHEDMASK 0x00000001
00192
00217 extern ti_sdo_ce_osal_Memory_AllocParams ti_sdo_ce_osal_Memory_DEFAULTPARAMS;
00218
00219 /*
00220  *  ======== Memory_alloc ========
00221  */
00237 extern Ptr ti_sdo_ce_osal_Memory_alloc(UInt size,
00238         ti_sdo_ce_osal_Memory_AllocParams *params);
00239
00240 /*
00241  *  ======== Memory_cacheInv ========
00242  */
00261 extern Void ti_sdo_ce_osal_Memory_cacheInv(Ptr addr, Int sizeInBytes);
00262
00263
00264 /*
00265  *  ======== Memory_cacheWb ========
00266  */
00279 extern Void ti_sdo_ce_osal_Memory_cacheWb(Ptr addr, Int sizeInBytes);
00280
00281
00282 /*
00283  *  ======== Memory_cacheWbInv ========
00284  */
00297 extern Void ti_sdo_ce_osal_Memory_cacheWbInv(Ptr addr, Int sizeInBytes);
00298
00299
00300 /*
00301  *  ======== Memory_cacheWbInvAll ========
00302  */
00313 extern Void ti_sdo_ce_osal_Memory_cacheWbInvAll();
00314
00315
00316 /*
00317  *  ======== Memory_contigAlloc ========
00318  */
00353 extern Ptr ti_sdo_ce_osal_Memory_contigAlloc(UInt size, UInt align);
00354
00355
00356 /*
00357  *  ======== Memory_contigFree ========
00358  */
00380 extern Bool ti_sdo_ce_osal_Memory_contigFree(Ptr addr, UInt size);
00381
00382
00385 /*
00386  *  ======== Memory_contigStat ========
00387  */
00406 extern Bool ti_sdo_ce_osal_Memory_contigStat(ti_sdo_ce_osal_Memory_Stat *stat);
00407
00411 /*
00412  *  ======== Memory_free ========
00413  */
00439 extern Bool ti_sdo_ce_osal_Memory_free(Ptr addr, UInt size,
00440         ti_sdo_ce_osal_Memory_AllocParams *params);
00441
00442
00443 /*
00444  *  ======== Memory_dumpKnownContigBufs ========
00445  */
00461 extern Void ti_sdo_ce_osal_Memory_dumpKnownContigBufsList(Void);
00462
00463
00464 /*
00465  *  ======== Memory_getBufferPhysicalAddress ========
00466  */
00505 extern UInt32 ti_sdo_ce_osal_Memory_getBufferPhysicalAddress(Ptr virtualAddress,
00506     Int sizeInBytes, Bool *isContiguous);
00507
00508 /*
00509  *  ======== Memory_getHeapId ========
00510  */
00525 extern Int ti_sdo_ce_osal_Memory_getHeapId(String name);
00526
00527 /*
00528  *  ======== Memory_getNumHeaps ========
00529  */
00538 extern Int ti_sdo_ce_osal_Memory_getNumHeaps();
00539
00540
00541 /*
00542  *  ======== Memory_getBufferVirtualAddress ========
00543  */
00579 extern Ptr ti_sdo_ce_osal_Memory_getBufferVirtualAddress(UInt32 physicalAddress,
00580     Int sizeInBytes);
00581
00584 /*
00585  *  ======== Memory_init ========
00586  */
00587 extern Bool ti_sdo_ce_osal_Memory_init(Void);
00588
00589
00590 /*
00591  *  ======== Memory_exit ========
00592  */
00593 extern Void ti_sdo_ce_osal_Memory_exit(Void);
00594
00595
00598 /*
00599  *  ======== Memory_registerContigBuf ========
00600  */
00630 extern Void ti_sdo_ce_osal_Memory_registerContigBuf(UInt32 virtualAddress,
00631         UInt32 sizeInBytes, UInt32 physicalAddress);
00632
00635 #define Memory_redefine ti_sdo_ce_osal_Memory_redefine
00636 /*
00637  *  ======== Memory_redefine ========
00638  */
00655 extern Bool ti_sdo_ce_osal_Memory_redefine(Int segId, Uint32 base, Uint32 size);
00656
00657 /*
00658  *  ======== Memory_restoreHeap ========
00659  */
00673 extern Bool ti_sdo_ce_osal_Memory_restoreHeap(Int segId);
00674
00675 /*
00676  *  ======== Memory_segAlloc ========
00677  */
00698 extern Ptr ti_sdo_ce_osal_Memory_segAlloc(Int segId, UInt size, UInt align);
00699
00700
00701 /*
00702  *  ======== Memory_segFree ========
00703  */
00732 extern Bool ti_sdo_ce_osal_Memory_segFree(Int segId, Ptr addr, UInt size);
00733
00734
00735 /*
00736  *  ======== Memory_segStat ========
00737  */
00759 extern Bool ti_sdo_ce_osal_Memory_segStat(Int segId,
00760         ti_sdo_ce_osal_Memory_Stat *statbuf);
00761
00764 /*
00765  *  ======== Memory_unregisterContigBuf ========
00766  */
00783 extern Void ti_sdo_ce_osal_Memory_unregisterContigBuf(UInt32 virtualAddress,
00784     UInt32 sizeInBytes);
00785
00788 /*
00789  * ======== PREFIX ALIASES ========
00790  * Same strategy as XDC uses
00791  */
00792 #if !defined(__nested__) && !defined(ti_sdo_ce_osal_Memory__nolocalnames)
00793
00794 /* module prefix */
00795 #define Memory_DEFAULTALIGNMENT ti_sdo_ce_osal_Memory_DEFAULTALIGNMENT
00796 #define Memory_GTNAME ti_sdo_ce_osal_Memory_GTNAME
00797 #define Memory_Stat ti_sdo_ce_osal_Memory_Stat
00798 #define Memory_type ti_sdo_ce_osal_Memory_type
00799 #define Memory_MALLOC ti_sdo_ce_osal_Memory_MALLOC
00800 #define Memory_SEG ti_sdo_ce_osal_Memory_SEG
00801 #define Memory_CONTIGPOOL ti_sdo_ce_osal_Memory_CONTIGPOOL
00802 #define Memory_CONTIGHEAP ti_sdo_ce_osal_Memory_CONTIGHEAP
00803 #define Memory_AllocParams ti_sdo_ce_osal_Memory_AllocParams
00804 #define Memory_CACHED ti_sdo_ce_osal_Memory_CACHED
00805 #define Memory_NONCACHED ti_sdo_ce_osal_Memory_NONCACHED
00806 #define Memory_CACHEDMASK ti_sdo_ce_osal_Memory_CACHEDMASK
00807 #define Memory_DEFAULTPARAMS ti_sdo_ce_osal_Memory_DEFAULTPARAMS
00808
00809 #define Memory_alloc ti_sdo_ce_osal_Memory_alloc
00810 #define Memory_cacheInv ti_sdo_ce_osal_Memory_cacheInv
00811 #define Memory_cacheWb ti_sdo_ce_osal_Memory_cacheWb
00812 #define Memory_cacheWbInv ti_sdo_ce_osal_Memory_cacheWbInv
00813 #define Memory_cacheWbInvAll ti_sdo_ce_osal_Memory_cacheWbInvAll
00814 #define Memory_contigAlloc ti_sdo_ce_osal_Memory_contigAlloc
00815 #define Memory_contigFree ti_sdo_ce_osal_Memory_contigFree
00816 #define Memory_free ti_sdo_ce_osal_Memory_free
00817 #define Memory_getBufferPhysicalAddress ti_sdo_ce_osal_Memory_getBufferPhysicalAddress
00818 #define Memory_getBufferVirtualAddress ti_sdo_ce_osal_Memory_getBufferVirtualAddress
00819 #define Memory_getHeapId ti_sdo_ce_osal_Memory_getHeapId
00820 #define Memory_getNumHeaps ti_sdo_ce_osal_Memory_getNumHeaps
00821 #define Memory_init ti_sdo_ce_osal_Memory_init
00822 #define Memory_exit ti_sdo_ce_osal_Memory_exit
00823 #define Memory_redefine ti_sdo_ce_osal_Memory_redefine
00824 #define Memory_restoreHeap ti_sdo_ce_osal_Memory_restoreHeap
00825 #define Memory_segAlloc ti_sdo_ce_osal_Memory_segAlloc
00826 #define Memory_segFree ti_sdo_ce_osal_Memory_segFree
00827 #define Memory_segStat ti_sdo_ce_osal_Memory_segStat
00828 #endif
00829
00833
00834 #ifdef __cplusplus
00835 }
00836 #endif
00837
00838 #endif
00839 /*
00840  *  @(#) ti.sdo.ce.osal; 2, 0, 2,453; 8-17-2011 18:33:54; /db/atree/library/trees/ce/ce-s19x/src/ xlibrary
00841
00842  */
00843


Codec Engine System Programming Interface (SPI): Page Index

Related Pages

Here is a list of all related documentation pages:
  • Disclaimer
  • Todo List
  • Deprecated List


Codec Engine System Programming Interface (SPI): skel.h Source File

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce

skel.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2011, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== skel.h ========
00035  */
00046 #ifndef ti_sdo_ce_SKEL_
00047 #define ti_sdo_ce_SKEL_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00053 #include <ti/sdo/ce/visa.h>
00054
00057
00064 typedef VISA_Status (*SKEL_CALLFXN)(VISA_Handle handle, VISA_Msg msg);
00065
00076 typedef VISA_Handle (*SKEL_CREATEFXN)(Void *reserved, String name,
00077     Void *params);
00078
00085 typedef Void (*SKEL_DESTROYFXN)(VISA_Handle handle);
00086
00087
00088 /*
00089  *  ======== SKEL_Fxns ========
00090  */
00094 typedef struct SKEL_Fxns {
00095     SKEL_CALLFXN    call;
00096     SKEL_CREATEFXN  apiCreate;
00097     SKEL_DESTROYFXN apiDestroy;
00098 } SKEL_Fxns;
00099
00105 #define SKEL_LOCALBUFFERINVWB 0
00106 #define SKEL_WBINVALL         1
00107 #define SKEL_CACHENONE        2
00108
00113 extern Int ti_sdo_ce_Server_skelCachingPolicy;
00114
00115 #define SKEL_cachingPolicy ti_sdo_ce_Server_skelCachingPolicy
00116
00117
00122
00123 #ifdef __cplusplus
00124 }
00125 #endif
00126
00127 #endif /* _SKEL_ */
00128 /*
00129  *  @(#) ti.sdo.ce; 1, 0, 6,464; 8-17-2011 12:04:42; /db/atree/library/trees/ce/ce-s19x/src/ xlibrary
00130
00131  */
00132


Codec Engine System Programming Interface (SPI): spi.h Source File

  • File List
  • Globals

spi.h

Go to the documentation of this file.
00001 /* --COPYRIGHT--,BSD
00002  * Copyright (c) $(CPYYEAR), Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  * --/COPYRIGHT--
00032  */
00033 /*
00034  * This is a little header file which doxygen parses to generate the main
00035  * documentation page
00036  */
00037


Codec Engine System Programming Interface (SPI): visa.h Source File

  • File List
  • Globals
  • packages
  • ti
  • sdo
  • ce

visa.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2011, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== visa.h ========
00035  */
00060 #ifndef ti_sdo_ce_VISA_
00061 #define ti_sdo_ce_VISA_
00062
00063 #include <stddef.h>     /* for size_t */
00064
00065 #include <ti/sdo/ce/node/node.h>
00066 #include <ti/xdais/ialg.h>
00067 #include <ti/sdo/ce/Engine.h>
00068
00069 #ifdef __cplusplus
00070 extern "C" {
00071 #endif
00072
00077 typedef Int VISA_Status;
00078
00083 #define VISA_EOK        0
00084
00089 #define VISA_ERUNTIME   -1
00090
00095 #define VISA_EFAIL     -2
00096
00101 #define VISA_EUNSUPPORTED  -3
00102
00107 #define VISA_ETIMEOUT  -100
00108
00113 #define VISA_FOREVER Engine_FOREVER
00114
00123 #define VISA_MODNAME "ti.sdo.ce.VISA"
00124
00128 typedef struct VISA_Obj *VISA_Handle;
00129
00137 typedef struct VISA_MsgHeader {
00138     NODE_MsgHeader  header;
00139     Int             cmd;
00140     VISA_Status     status;
00141 } VISA_MsgHeader;
00142
00143 /*
00144  *  ======== VISA_Msg ========
00145  */
00146 typedef VISA_MsgHeader *VISA_Msg;
00147
00148 /*
00149  *  ======== VISA_allocMsg ========
00150  */
00165 extern VISA_Msg VISA_allocMsg(VISA_Handle visa);
00166
00167 /*
00168  *  ======== VISA_call ========
00169  */
00187 extern VISA_Status VISA_call(VISA_Handle visa, VISA_Msg *msg);
00188
00189 /*
00190  *  ======== VISA_callAsync ========
00191  */
00210 extern VISA_Status VISA_callAsync(VISA_Handle visa, VISA_Msg *msg);
00211
00212 /*
00213  *  ======== VISA_wait ========
00214  */
00235 extern VISA_Status VISA_wait(VISA_Handle visa, VISA_Msg *msg, UInt timeout);
00236
00237 /*
00238  *  ======== VISA_freeMsg ========
00239  */
00256 extern Void VISA_freeMsg(VISA_Handle visa, VISA_Msg msg);
00257
00258
00261
00262 /*
00263  *  ======== VISA_create ========
00264  */
00296 extern VISA_Handle VISA_create(Engine_Handle engine, String name,
00297     IALG_Params *params, size_t msgSize, String type);
00298
00299 /*
00300  *  ======== VISA_delete ========
00301  */
00309 extern Void VISA_delete(VISA_Handle visa);
00310
00311
00312 /*
00313  *  ======== VISA_create2 ========
00314  */
00353 extern VISA_Handle VISA_create2(Engine_Handle engine, String name,
00354     IALG_Params *params, Int paramsSize, size_t msgSize, String type);
00355
00356
00357 /*
00358  *  ======== VISA_enter ========
00359  */
00372 extern Void VISA_enter(VISA_Handle visa);
00373
00374 /*
00375  *  ======== VISA_exit ========
00376  */
00387 extern Void VISA_exit(VISA_Handle visa);
00388
00389 /*
00390  *  ======== VISA_getAlgHandle ========
00391  */
00405 extern Ptr VISA_getAlgHandle(VISA_Handle visa);
00406
00407 /*
00408  *  ======== VISA_getAlgorithmHandle ========
00409  */
00423 extern Ptr VISA_getAlgorithmHandle(VISA_Handle visa);
00424
00425 /*
00426  *  ======== VISA_getAlgFxns ========
00427  */
00449 extern IALG_Fxns *VISA_getAlgFxns(VISA_Handle visa);
00450   /* ingroup */
00452
00453 /*
00454  *  ======== VISA_getAlgMemRecs ========
00455  */
00486 extern VISA_Status VISA_getAlgMemRecs(VISA_Handle visa, IALG_MemRec *memTab,
00487         Int size, Int *numRecs);
00488
00489 /*
00490  *  ======== VISA_getAlgNumRecs ========
00491  */
00519 extern VISA_Status VISA_getAlgNumRecs(VISA_Handle visa, Int *numRecs);
00520
00521
00522 /*
00523  *  ======== VISA_getContext ========
00524  */
00543 extern Void VISA_getContext(VISA_Handle visa, UInt32 * pContext);
00544
00545 /*
00546  *  ======== VISA_getCodecClassConfig ========
00547  */
00564 extern Ptr VISA_getCodecClassConfig(VISA_Handle visa);
00565
00566
00567 /*
00568  *  ======== VISA_getMaxMsgSize ========
00569  */
00582 extern UInt VISA_getMaxMsgSize(VISA_Handle visa);
00583
00584 /*
00585  *  ======== _VISA_init ========
00586  */
00596 extern Void _VISA_init(Void);
00597
00598 /*
00599  *  ======== _VISA_exit ========
00600  */
00610 extern Void _VISA_exit(Void);
00611
00612
00613 /*
00614  * Semi-internal variable generatd by Settings.xdt - used in the following
00615  * inline
00616  */
00617 extern Bool VISA_checked;
00618
00619 /*
00620  *  ======== VISA_isChecked ========
00621  */
00635 static inline Bool VISA_isChecked(Void)
00636 {
00637     return (VISA_checked);
00638 }
00639
00640 /*
00641  *  ======== VISA_setContext ========
00642  */
00659 extern Void VISA_setContext(VISA_Handle visa, UInt32 context);
00660
00661 /*
00662  *  ======== VISA_isLocal ========
00663  */
00674 extern Bool VISA_isLocal(VISA_Handle visa);
00675
00676 #ifdef __cplusplus
00677 }
00678 #endif
00679
00680 #endif
00681 /*
00682  *  @(#) ti.sdo.ce; 1, 0, 6,464; 8-17-2011 12:04:43; /db/atree/library/trees/ce/ce-s19x/src/ xlibrary
00683
00684  */
00685


Codec Engine System Programming Interface (SPI): xdas.h Source File

  • File List
  • Globals
  • cetools
  • packages
  • ti
  • xdais

xdas.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2011, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00045 #ifndef ti_xdais_XDAS_
00046 #define ti_xdais_XDAS_
00047
00048 #ifdef __cplusplus
00049 extern "C" {
00050 #endif
00051
00054
00055
00056 #define XDAS_TRUE       1
00057 #define XDAS_FALSE      0
00058
00059
00060 typedef Void            XDAS_Void;
00061 typedef Uint8           XDAS_Bool;
00062
00063
00064 typedef Int8            XDAS_Int8;
00065 typedef Uint8           XDAS_UInt8;
00066 typedef Int16           XDAS_Int16;
00067 typedef Uint16          XDAS_UInt16;
00068 typedef Int32           XDAS_Int32;
00069 typedef Uint32          XDAS_UInt32;
00073
00074
00075 #ifdef __cplusplus
00076 }
00077 #endif
00078
00079 #endif  /* ti_xdais_XDAS_ */
00080 /*
00081  *  @(#) ti.xdais; 1, 2.0, 1,7; 6-14-2011 10:34:31; /db/wtree/library/trees/dais/dais.git/src/ dais-u02
00082  */
00083