Codec Engine Application Programming Interface (API): Codec Engine API Reference

  • Main Page
  • Modules
  • Data Structures
  • Files
  • Directories
  • Related Pages

Codec Engine API Reference

ce-r09

Modules

The Codec Engine is partitioned into several components:

  • The Codec Engine Runtime (CERuntime_* and Engine_*) - Provides codec-independent services.
  • VISA (VISA_*) - A set of services that can be used on algorithms of any class.
  • Codec Engine Server Interface (Server_*) - Provides an interface to Servers containing remote algorithms.
  • The latest VISA APIs - Providing codec-specific interfaces, reflecting the XDM interfaces for the following classes:
    • Video
      • VIDENC1 - Video encoder codec interface
      • VIDDEC2 - Video decoder codec interface
    • Imaging
      • IMGDEC1 - Image decoder codec interface
      • IMGENC1 - Image encoder codec interface
    • Speech
      • SPHDEC1 - Speech decoder codec interface
      • SPHENC1 - Speech 1.0 Encoder Codec Interface
    • Audio
      • AUDDEC1 - AUDDEC1 Audio Decoder Interface
      • AUDENC1 - AUDENC1 Audio Encoder Interface
    • Video Trancoding
      • VIDTRANSCODE - Video Transcode Interface
    • General Purpose Algorithms
      • UNIVERSAL - Universal Algorithm Interface
  • Older VISA APIs continue to be supported, but to align with the XDM roadmap, they are deprecated in this release. These interfaces are comprised of the following:
    • Video
      • VIDDEC1 - Video 1.0 decoder codec interface
      • VIDDEC - VIDDEC Video Decoder Interface
      • VIDENC - VIDENC Video Encoder Interface
    • Imaging
      • IMGDEC - IMGDEC Image Decoder Interface
      • IMGENC - IMGENC Image Encoder Interface
    • Speech
      • SPHDEC - SPHDEC Speech Decoder Interface
      • SPHENC - SPHENC Speech Encoder Interface
    • Audio
      • AUDDEC - AUDDEC Audio Decoder Interface
      • AUDENC - AUDENC Audio Encoder Interface
  • Also, this release includes Beta support for the following XDM interfaces:
    • VIDANALYTICS - Video Analytics Algorithm Interface

Additionally, there are several utility modules provided:

  • Memory - provides services to manage memory is OS independent environments. Also provides the ability to manage contiguous buffers meeting various alignment constraints.
  • TraceUtil - provides utility services to easily manage tracing support.
  • ladclient - provides wrappers to allow communication with the Link Arbiter Daemon (LAD).

Note that the previously available ti.sdo.ce.trace GT module has been moved into ti.sdo.utils.trace, and is now distributed as a part of Framework Components. (The package still exists and redirects users to the new location) You will now find GT documentation in that product.

Copyright 2010, Texas Instruments Incorporated


Codec Engine Application Programming Interface (API):

  • Files
  • Directories
  • Related Pages
disclaimer.html
IMPORTANT NOTICE
Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are sold subject to TI's terms and conditions of sale supplied at the time of order acknowledgment.
TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI's standard warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government requirements, testing of all parameters of each product is not necessarily performed.
TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating safeguards.
TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI regarding third party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of that third party, or a license from TI under the patents or other intellectual property of TI.
Reproduction of information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for such altered documentation.
Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.
Mailing Address:
Texas Instruments
Post Office Box 655303
Dallas, Texas 75265


Codec Engine Application Programming Interface (API): Todo List

Todo List

Global IVIDANALYTICS_MAXEVENTS
Need to understand the size of structs that use this and whether they're "too big".

Global IVIDANALYTICS_MAXTARGETS
This could be 64 if needed. Need to understand the size of structs that use this and whether they're "too big".

Global IVIDANALYTICS_ViewState

Need to further review and define. Probably need hooks for user-defined states, in addition to some pre-defined ones.

Global IVIDTRANSCODE_MAXOUTSTREAMS
Document this.


Codec Engine Application Programming Interface (API): Deprecated List

Deprecated List

Global Engine_getCpuLoad

This service has been replaced by Server_getCpuLoad() to better indicate that this API is not intended for obtaining the current processor's CPU load, rather it obtains the CPU load of a remote Server.

Global Engine_getUsedMem

This service has been replaced by Server_getMemStat() to better indicate that this API is not intended for obtaining the current processor's memory statistics, rather it obtains the memory statistics of a remote Server. Also, Server_getMemStat() provides more granularity than Engine_getUsedMem().

Global IAUDIO_ChannelId
This enumeration is only supported on 0.9 XDM. To use it, you must define "XDM_INCLUDE_DOT9_SUPPORT" prior to including this file. In XDM 1.00, this has been superceded by IAUDIO_ChannelMode.

Global Memory_contigAlloc

This function has been superceded by Memory_alloc() and will be removed in a future release. Users are recommended to modify their applications to use the new, more flexible Memory_alloc() instead.

Group ti_xdais_dm_IAUDDEC
This XDM audio decoder interface has been deprecated, and superceeded by newer IAUDDECx audio decoder interfaces.

Group ti_xdais_dm_IAUDENC
This XDM audio encoder interface has been deprecated, and superceeded by newer IAUDENCx audio encoder interfaces.

Group ti_xdais_dm_IIMGDEC
This XDM image decoder interface has been deprecated, and superceeded by newer IIMGDECx image decoder interfaces.

Group ti_xdais_dm_IIMGENC
This XDM image encoder interface has been deprecated, and superceeded by newer IIMGENCx image encoder interfaces.

Group ti_xdais_dm_ISPHDEC
This XDM speech decoder interface has been deprecated, and superceeded by newer ISPHDECx speech decoder interfaces.

Group ti_xdais_dm_ISPHENC
This XDM speech encoder interface has been deprecated, and superceeded by newer ISPHENCx speech encoder interfaces.

Group ti_xdais_dm_IVIDDEC
This XDM video decoder interface has been deprecated, and superceeded by newer IVIDDECx video decoder interfaces.

Group ti_xdais_dm_IVIDENC
This XDM video encoder interface has been deprecated, and superceeded by newer IVIDENCx video encoder interfaces.

Global XDM_ERUNTIME
This is only supported on 0.9 XDM. To use it, you must define "XDM_INCLUDE_DOT9_SUPPORT". In XDM 1.00+, it is required that codecs return "EFAIL", as "ERUNTIME" is not supported.


Codec Engine Application Programming Interface (API): Module Index

Modules

Here is a list of all modules:
  • XDM IAUDDEC Audio Decoder Interface
  • XDM IAUDDEC1 Audio Decoder Interface
  • XDM IAUDENC Audio Encoder Interface
  • XDM IAUDENC1 Audio Encoder Interface
  • XDM Audio Interface
  • XDM IIMGDEC Image Decoder Interface
  • XDM IIMGDEC1 Image Decoder Interface
  • XDM IIMGENC Image Encoder Interface
  • XDM IIMGENC1 Image Encoder Interface
  • XDM Speech/Voice Interface
  • XDM Speech/Voice Interface
  • XDM Speech/Voice Interface (AMR)
  • XDM Speech/Voice Interface (EVRC)
  • XDM Speech/Voice Interface (G.723)
  • XDM Speech/Voice Interface (G.726)
  • XDM Speech/Voice Interface (PCM)
  • XDM Speech/Voice Interface (SMV)
  • XDM Speech/Voice Interface (WBAMR)
  • XDM ISPHDEC Speech/Voice Decoder Interface
  • XDM ISPHDEC1 Speech/Voice Decoder Interface
  • XDM ISPHENC Speech/Voice Encoder Interface
  • XDM ISPHENC1 Speech/Voice Encoder Interface
  • XDM Beta Universal Algorithm Interface
  • XDM Beta Video Analytics Interface
  • XDM IVIDDEC Video Decoder Interface
  • XDM IVIDDEC1 Video Decoder Interface
  • XDM IVIDDEC2 Video Decoder Interface
  • XDM IVIDENC Video Encoder Interface
  • XDM IVIDENC1 Video Encoder Interface
  • XDM IVIDTRANSCODE Video Transcoder Interface
  • IALG - XDAIS Algorithm Interface
  • LAD Communication Interfaces
  • AUDDEC Audio Decoder Interface
  • AUDENC Audio Encoder Interface
  • AUDDEC1 Audio Decoder Interface
  • AUDENC1 Audio Encoder Interface
  • IMGDEC Image Decoder Interface
  • IMGENC Image Encoder Interface
  • Image decoder codec interface
  • Image encoder codec interface
  • Codec Engine OSAL - Memory
  • SPHDEC Speech Decoder Interface
  • SPHENC Speech Encoder Interface
  • Speech decoder codec interface
  • Speech 1.0 Encoder Codec Interface
  • Universal Algorithm Interface
  • Codec Engine Tracing Utility
  • Video Analytics Algorithm Interface
  • VIDDEC Video Decoder Interface
  • VIDENC Video Encoder Interface
  • Video 1.0 decoder codec interface
  • Video encoder codec interface
  • Split video decoder interface
  • Video decoder codec interface
  • Video Transcoder Codec Interface
  • VISA
  • CE Stub SPI
  • CE interface SPI
  • XDM Video Interface
  • XDM IVIDDEC2-based Video Decoder Split Interface
  • Shared XDM Definitions
  • XDAIS Types and Constants
  • Codec Engine Runtime
  • Codec Engine Server Interface


Codec Engine Application Programming Interface (API): XDM IAUDDEC Audio Decoder Interface

XDM IAUDDEC Audio Decoder Interface

Data Structures

struct | IAUDDEC_Obj
This must be the first field of all IAUDDEC instance objects. More...
struct | IAUDDEC_Params
Defines the creation time parameters for all IAUDDEC instance objects. More...
struct | IAUDDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IAUDDEC_InArgs
Defines the input arguments for all IAUDDEC instance process function. More...
struct | IAUDDEC_Status
Defines instance status parameters (read-only). More...
struct | IAUDDEC_OutArgs
Defines the run time output arguments for all IAUDDEC instance objects. More...
struct | IAUDDEC_Fxns
Defines all of the operations on IAUDDEC objects. More...

Defines

#define | IAUDDEC_CID "ti.xdais.dm.IAUDDEC"
#define | IAUDDEC_ERUNTIME XDM_ERUNTIME
#define | IAUDDEC_EOK XDM_EOK
#define | IAUDDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct IAUDDEC_Obj * | IAUDDEC_Handle
Opaque handle to an IAUDDEC objects.
typedef IALG_Cmd | IAUDDEC_Cmd
Defines the control commands for the IAUDDEC module.

Detailed Description

This is the XDM IAUDDEC Audio Decoder Interface.

Deprecated:
This XDM audio decoder interface has been deprecated, and superceeded by newer IAUDDECx audio decoder interfaces.

Define Documentation

#define IAUDDEC_CID "ti.xdais.dm.IAUDDEC"

IAUDDEC Class ID

#define IAUDDEC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define IAUDDEC_EOK XDM_EOK

Success.

#define IAUDDEC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct IAUDDEC_Obj* IAUDDEC_Handle

Opaque handle to an IAUDDEC objects.

typedef IALG_Cmd IAUDDEC_Cmd

Defines the control commands for the IAUDDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDDEC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IAUDDEC1 Audio Decoder Interface

XDM IAUDDEC1 Audio Decoder Interface

Data Structures

struct | IAUDDEC1_Obj
This must be the first field of all IAUDDEC1 instance objects. More...
struct | IAUDDEC1_Params
Defines the creation time parameters for all IAUDDEC1 instance objects. More...
struct | IAUDDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IAUDDEC1_InArgs
Defines the input arguments for all IAUDDEC1 instance process function. More...
struct | IAUDDEC1_Status
Defines instance status parameters (read-only). More...
struct | IAUDDEC1_OutArgs
Defines the run time output arguments for all IAUDDEC1 instance objects. More...
struct | IAUDDEC1_Fxns
Defines all of the operations on IAUDDEC1 objects. More...

Defines

#define | IAUDDEC1_EOK XDM_EOK
#define | IAUDDEC1_EFAIL XDM_EFAIL
#define | IAUDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IAUDDEC1_Obj * | IAUDDEC1_Handle
Opaque handle to an IAUDDEC1 objects.
typedef IALG_Cmd | IAUDDEC1_Cmd
Defines the control commands for the IAUDDEC1 module.

Detailed Description

This is the XDM IAUDDEC1 Audio Decoder Interface.

Define Documentation

#define IAUDDEC1_EOK XDM_EOK

Success.

#define IAUDDEC1_EFAIL XDM_EFAIL

General failure.

#define IAUDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IAUDDEC1_Obj* IAUDDEC1_Handle

Opaque handle to an IAUDDEC1 objects.

typedef IALG_Cmd IAUDDEC1_Cmd

Defines the control commands for the IAUDDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDDEC1_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IAUDENC Audio Encoder Interface

XDM IAUDENC Audio Encoder Interface

Data Structures

struct | IAUDENC_Obj
This must be the first field of all IAUDENC instance objects. More...
struct | IAUDENC_Params
Defines the creation time parameters for all IAUDENC instance objects. More...
struct | IAUDENC_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IAUDENC_InArgs
Defines the input arguments for all IAUDENC instance process function. More...
struct | IAUDENC_Status
Defines instance status parameters (read-only). More...
struct | IAUDENC_OutArgs
Defines the run time output arguments for all IAUDENC instance objects. More...
struct | IAUDENC_Fxns
Defines all of the operations on IAUDENC objects. More...

Defines

#define | IAUDENC_CID "ti.xdais.dm.IAUDENC"
#define | IAUDENC_ERUNTIME XDM_ERUNTIME
#define | IAUDENC_EOK XDM_EOK
#define | IAUDENC_EFAIL XDM_EFAIL

Typedefs

typedef struct IAUDENC_Obj * | IAUDENC_Handle
Opaque handle to an IAUDENC objects.
typedef IALG_Cmd | IAUDENC_Cmd
Defines the control commands for the IAUDENC module.

Detailed Description

This is the XDM IAUDENC Audio Encoder Interface.

Deprecated:
This XDM audio encoder interface has been deprecated, and superceeded by newer IAUDENCx audio encoder interfaces.

Define Documentation

#define IAUDENC_CID "ti.xdais.dm.IAUDENC"

IAUDENC Class ID

#define IAUDENC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define IAUDENC_EOK XDM_EOK

Success.

#define IAUDENC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct IAUDENC_Obj* IAUDENC_Handle

Opaque handle to an IAUDENC objects.

typedef IALG_Cmd IAUDENC_Cmd

Defines the control commands for the IAUDENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDENC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IAUDENC1 Audio Encoder Interface

XDM IAUDENC1 Audio Encoder Interface

Data Structures

struct | IAUDENC1_Obj
This must be the first field of all IAUDENC1 instance objects. More...
struct | IAUDENC1_Params
Defines the creation time parameters for all IAUDENC1 instance objects. More...
struct | IAUDENC1_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IAUDENC1_InArgs
Defines the input arguments for all IAUDENC1 instance process function. More...
struct | IAUDENC1_Status
Defines instance status parameters (read-only). More...
struct | IAUDENC1_OutArgs
Defines the run time output arguments for all IAUDENC1 instance objects. More...
struct | IAUDENC1_Fxns
Defines all of the operations on IAUDENC1 objects. More...

Defines

#define | IAUDENC1_EOK XDM_EOK
#define | IAUDENC1_EFAIL XDM_EFAIL
#define | IAUDENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IAUDENC1_Obj * | IAUDENC1_Handle
Opaque handle to an IAUDENC1 objects.
typedef IALG_Cmd | IAUDENC1_Cmd
Defines the control commands for the IAUDENC1 module.

Detailed Description

This is the XDM IAUDENC1 Audio Encoder Interface.

Define Documentation

#define IAUDENC1_EOK XDM_EOK

Success.

#define IAUDENC1_EFAIL XDM_EFAIL

General failure.

#define IAUDENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IAUDENC1_Obj* IAUDENC1_Handle

Opaque handle to an IAUDENC1 objects.

typedef IALG_Cmd IAUDENC1_Cmd

Defines the control commands for the IAUDENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDENC1_Fxns::control()


Codec Engine Application Programming Interface (API): XDM Audio Interface

XDM Audio Interface

Enumerations

enum IAUDIO_ChannelId {
IAUDIO_MONO = 0,
IAUDIO_STEREO = 1,
IAUDIO_THREE_ZERO = 2,
IAUDIO_FIVE_ZERO = 3,
IAUDIO_FIVE_ONE = 4,
IAUDIO_SEVEN_ONE = 5
}

XDM supported audio channel configurations.

More...
enum IAUDIO_ChannelMode {
IAUDIO_1_0 = 0,
IAUDIO_2_0 = 1,
IAUDIO_11_0 = 2,
IAUDIO_3_0 = 3,
IAUDIO_2_1 = 4,
IAUDIO_3_1 = 5,
IAUDIO_2_2 = 6,
IAUDIO_3_2 = 7,
IAUDIO_2_3 = 8,
IAUDIO_3_3 = 9,
IAUDIO_3_4 = 10
}

Channel modes for audio streams.

More...
enum IAUDIO_DualMonoMode {
IAUDIO_DUALMONO_LR = 0,
IAUDIO_DUALMONO_LEFT = 1,
IAUDIO_DUALMONO_RIGHT = 2,
IAUDIO_DUALMONO_LR_MIX = 3
}

Dual Mono Channel modes for audio streams.

More...
enum IAUDIO_PcmFormat {
IAUDIO_BLOCK = 0,
IAUDIO_INTERLEAVED = 1
}

XDM supported audio PCM formats.

More...
enum IAUDIO_EncMode {
IAUDIO_CBR = 0,
IAUDIO_VBR = 1
}

Audio encoding modes.

More...

Detailed Description

This is the XDM audio interface shared between the various codecs.

Enumeration Type Documentation

enum IAUDIO_ChannelId

XDM supported audio channel configurations.

Deprecated:
This enumeration is only supported on 0.9 XDM. To use it, you must define "XDM_INCLUDE_DOT9_SUPPORT" prior to including this file. In XDM 1.00, this has been superceded by IAUDIO_ChannelMode.
Enumerator:
IAUDIO_MONO

Single channel.

IAUDIO_STEREO

Two channel.

IAUDIO_THREE_ZERO

Three channel.

IAUDIO_FIVE_ZERO

Five channel.

IAUDIO_FIVE_ONE

5.1 channel.

IAUDIO_SEVEN_ONE

7.1 channel.

enum IAUDIO_ChannelMode

Channel modes for audio streams.

The channel modes not only indicate the number of channels, but also indicate the order in which the channels are placed in the input or output buffer. The placement of channels is indicated next to each channel mode.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IAUDIO_1_0

Mono.

IAUDIO_2_0

Stereo.

IAUDIO_11_0

Dual Mono.

See also:
IAUDIO_DualMonoMode
IAUDIO_3_0

Left, Right, Center.

IAUDIO_2_1

Left, Right, Sur.

IAUDIO_3_1

Left, Right, Center, Sur.

IAUDIO_2_2

Left, Right, SurL, SurR.

IAUDIO_3_2

Left, Right, Center, SurL, SurR.

IAUDIO_2_3

Left, Right, SurL, SurR, surC.

IAUDIO_3_3

Left, Right, Center, SurL, SurR, surC.

IAUDIO_3_4

Left, Right, Center, SurL, SurR, sideL, sideR.

enum IAUDIO_DualMonoMode

Dual Mono Channel modes for audio streams.

Remarks:
In case of Dual Mono the application can play both channels; Left Only, Right Only or Mix and Play both. The default case in most of the applications is the first case of IAUDIO_DUALMONO_LR. That is to play both Left and Right Channel.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IAUDIO_DUALMONO_LR

Play/encode both left and right channel

IAUDIO_DUALMONO_LEFT

Play/encode only left channel.

IAUDIO_DUALMONO_RIGHT

Play/encode only right channel.

IAUDIO_DUALMONO_LR_MIX

Mix and play.

enum IAUDIO_PcmFormat

XDM supported audio PCM formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IAUDIO_BLOCK

Left channel data followed by right channel data. Note, for single channel (mono), right channel data will be the same as the left channel data.

IAUDIO_INTERLEAVED

Left and right channel data interleaved. Note, for single channel (mono), right channel data will be the same as the left channel data.

enum IAUDIO_EncMode

Audio encoding modes.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IAUDIO_CBR

Constant bit rate.

IAUDIO_VBR

Variable bit rate.


Codec Engine Application Programming Interface (API): XDM IIMGDEC Image Decoder Interface

XDM IIMGDEC Image Decoder Interface

Data Structures

struct | IIMGDEC_Obj
This must be the first field of all IIMGDEC instance objects. More...
struct | IIMGDEC_Params
Defines the creation time parameters for all IIMGDEC instance objects. More...
struct | IIMGDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IIMGDEC_InArgs
Defines the input arguments for all IIMGDEC instance process() function. More...
struct | IIMGDEC_Status
Defines instance status parameters (read-only). More...
struct | IIMGDEC_OutArgs
Defines the run time output arguments for all IIMGDEC instance objects. More...
struct | IIMGDEC_Fxns
Defines all of the operations on IIMGDEC objects. More...

Defines

#define | IIMGDEC_CID "ti.xdais.dm.IIMGDEC"
#define | IIMGDEC_ERUNTIME XDM_ERUNTIME
#define | IIMGDEC_EOK XDM_EOK
#define | IIMGDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct IIMGDEC_Obj * | IIMGDEC_Handle
Opaque handle to an IIMGDEC objects.
typedef IALG_Cmd | IIMGDEC_Cmd
Defines the control commands for the IIMGDEC module.

Detailed Description

This is the XDM IIMGDEC Image Decoder Interface.

Deprecated:
This XDM image decoder interface has been deprecated, and superceeded by newer IIMGDECx image decoder interfaces.

Define Documentation

#define IIMGDEC_CID "ti.xdais.dm.IIMGDEC"

IIMGDEC Class ID

#define IIMGDEC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define IIMGDEC_EOK XDM_EOK

Success.

#define IIMGDEC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct IIMGDEC_Obj* IIMGDEC_Handle

Opaque handle to an IIMGDEC objects.

typedef IALG_Cmd IIMGDEC_Cmd

Defines the control commands for the IIMGDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGDEC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IIMGDEC1 Image Decoder Interface

XDM IIMGDEC1 Image Decoder Interface

Data Structures

struct | IIMGDEC1_Obj
This must be the first field of all IIMGDEC1 instance objects. More...
struct | IIMGDEC1_Params
Defines the creation time parameters for all IIMGDEC1 instance objects. More...
struct | IIMGDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IIMGDEC1_InArgs
Defines the input arguments for all IIMGDEC1 instance process() function. More...
struct | IIMGDEC1_Status
Defines instance status parameters. More...
struct | IIMGDEC1_OutArgs
Defines the run time output arguments for all IIMGDEC1 instance objects. More...
struct | IIMGDEC1_Fxns
Defines all of the operations on IIMGDEC1 objects. More...

Defines

#define | IIMGDEC1_EOK XDM_EOK
#define | IIMGDEC1_EFAIL XDM_EFAIL
#define | IIMGDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IIMGDEC1_Obj * | IIMGDEC1_Handle
Opaque handle to an IIMGDEC1 objects.
typedef IALG_Cmd | IIMGDEC1_Cmd
Defines the control commands for the IIMGDEC1 module.

Detailed Description

This is the XDM IIMGDEC1 Image Decoder Interface.

Define Documentation

#define IIMGDEC1_EOK XDM_EOK

Success.

#define IIMGDEC1_EFAIL XDM_EFAIL

General failure.

#define IIMGDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IIMGDEC1_Obj* IIMGDEC1_Handle

Opaque handle to an IIMGDEC1 objects.

typedef IALG_Cmd IIMGDEC1_Cmd

Defines the control commands for the IIMGDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGDEC1_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IIMGENC Image Encoder Interface

XDM IIMGENC Image Encoder Interface

Data Structures

struct | IIMGENC_Obj
This must be the first field of all IIMGENC instance objects. More...
struct | IIMGENC_Params
Defines the creation time parameters for all IIMGENC instance objects. More...
struct | IIMGENC_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IIMGENC_InArgs
Defines the input arguments for all IIMGENC instance process() function. More...
struct | IIMGENC_Status
Defines instance status parameters (read-only). More...
struct | IIMGENC_OutArgs
Defines the run time output arguments for all IIMGENC instance objects. More...
struct | IIMGENC_Fxns
Defines all of the operations on IIMGENC objects. More...

Defines

#define | IIMGENC_CID "ti.xdais.dm.IIMGENC"
#define | IIMGENC_ERUNTIME XDM_ERUNTIME
#define | IIMGENC_EOK XDM_EOK
#define | IIMGENC_EFAIL XDM_EFAIL

Typedefs

typedef struct IIMGENC_Obj * | IIMGENC_Handle
Opaque handle to an IIMGENC objects.
typedef IALG_Cmd | IIMGENC_Cmd
Defines the control commands for the IIMGENC module.

Detailed Description

This is the XDM IIMGENC Image Encoder Interface.

Deprecated:
This XDM image encoder interface has been deprecated, and superceeded by newer IIMGENCx image encoder interfaces.

Define Documentation

#define IIMGENC_CID "ti.xdais.dm.IIMGENC"

IIMGENC Class ID

#define IIMGENC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define IIMGENC_EOK XDM_EOK

Success.

#define IIMGENC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct IIMGENC_Obj* IIMGENC_Handle

Opaque handle to an IIMGENC objects.

typedef IALG_Cmd IIMGENC_Cmd

Defines the control commands for the IIMGENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGENC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IIMGENC1 Image Encoder Interface

XDM IIMGENC1 Image Encoder Interface

Data Structures

struct | IIMGENC1_Obj
This must be the first field of all IIMGENC1 instance objects. More...
struct | IIMGENC1_Params
Defines the creation time parameters for all IIMGENC1 instance objects. More...
struct | IIMGENC1_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IIMGENC1_InArgs
Defines the input arguments for all IIMGENC1 instance process() function. More...
struct | IIMGENC1_Status
Defines instance status parameters. More...
struct | IIMGENC1_OutArgs
Defines the run time output arguments for all IIMGENC1 instance objects. More...
struct | IIMGENC1_Fxns
Defines all of the operations on IIMGENC1 objects. More...

Defines

#define | IIMGENC1_EOK XDM_EOK
#define | IIMGENC1_EFAIL XDM_EFAIL
#define | IIMGENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IIMGENC1_Obj * | IIMGENC1_Handle
Opaque handle to an IIMGENC1 objects.
typedef IALG_Cmd | IIMGENC1_Cmd
Defines the control commands for the IIMGENC1 module.

Detailed Description

This is the XDM IIMGENC1 Image Encoder Interface.

Define Documentation

#define IIMGENC1_EOK XDM_EOK

Success.

#define IIMGENC1_EFAIL XDM_EFAIL

General failure.

#define IIMGENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IIMGENC1_Obj* IIMGENC1_Handle

Opaque handle to an IIMGENC1 objects.

typedef IALG_Cmd IIMGENC1_Cmd

Defines the control commands for the IIMGENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGENC1_Fxns::control()


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface

XDM Speech/Voice Interface

Enumerations

enum ISPEECH_VoiceMode {
ISPEECH_VOICED = 0,
ISPEECH_UNVOICED
}

XDM supported voice modes for speech.

More...
enum ISPEECH_CompoundLaw {
ISPEECH_LINEAR = 0,
ISPEECH_ALAW,
ISPEECH_ULAW
}

Detailed Description

This is the XDM speech/voice interface shared between the various codecs.

Enumeration Type Documentation

enum ISPEECH_VoiceMode

XDM supported voice modes for speech.

Enumerator:
ISPEECH_VOICED
ISPEECH_UNVOICED
enum ISPEECH_CompoundLaw
Enumerator:
ISPEECH_LINEAR
ISPEECH_ALAW
ISPEECH_ULAW


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface

XDM Speech/Voice Interface

Enumerations

enum ISPEECH1_NullTrafficMode {
ISPEECH1_NULLTRAFFICMODE_OFF = 0,
ISPEECH1_NULLTRAFFICMODE_ON = 1,
ISPEECH1_NULLTRAFFICMODE_DEFAULT = ISPEECH1_NULLTRAFFICMODE_OFF
}

Null traffic channel setting.

More...
enum ISPEECH1_PostFilter {
ISPEECH1_POSTFILTER_OFF = 0,
ISPEECH1_POSTFILTER_ON = 1,
ISPEECH1_POSTFILTER_DEFAULT = ISPEECH1_POSTFILTER_ON
}

Post filter setting.

More...
enum ISPEECH1_VADFlag {
ISPEECH1_VADFLAG_OFF = 0,
ISPEECH1_VADFLAG_ON = 1,
ISPEECH1_VADFLAG_DEFAULT = ISPEECH1_VADFLAG_ON
}

Voice Activity Detection (VAD) setting.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various codecs.

Enumeration Type Documentation

enum ISPEECH1_NullTrafficMode

Null traffic channel setting.

See also:
ISPHENC1_InArgs.nullTrafficChannel.
Enumerator:
ISPEECH1_NULLTRAFFICMODE_OFF

Null traffic channel frames disabled, normal speech encoding is enabled.

ISPEECH1_NULLTRAFFICMODE_ON

Null traffic channel frames enabled.

ISPEECH1_NULLTRAFFICMODE_DEFAULT

Null traffic channel frames disabled, normal speech encoding is enabled.

enum ISPEECH1_PostFilter

Post filter setting.

These values are used for enabling/disabling the post filter.

Enumerator:
ISPEECH1_POSTFILTER_OFF

Post Filter disabled.

ISPEECH1_POSTFILTER_ON

Post Filter enabled.

ISPEECH1_POSTFILTER_DEFAULT

Post Filter enabled.

enum ISPEECH1_VADFlag

Voice Activity Detection (VAD) setting.

Enumerator:
ISPEECH1_VADFLAG_OFF

Voice Activity Detection off.

ISPEECH1_VADFLAG_ON

Voice Activity Detection on.

ISPEECH1_VADFLAG_DEFAULT

Voice Activity Detection on.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (AMR)

XDM Speech/Voice Interface (AMR)

Enumerations

enum ISPEECH1_AMR_BitRate {
ISPEECH1_AMR_BITRATE_4P75 = 0,
ISPEECH1_AMR_BITRATE_5P15 = 1,
ISPEECH1_AMR_BITRATE_5P9 = 2,
ISPEECH1_AMR_BITRATE_6P7 = 3,
ISPEECH1_AMR_BITRATE_7P4 = 4,
ISPEECH1_AMR_BITRATE_7P95 = 5,
ISPEECH1_AMR_BITRATE_10P2 = 6,
ISPEECH1_AMR_BITRATE_12P2 = 7,
ISPEECH1_AMR_BITRATE_DEFAULT = ISPEECH1_AMR_BITRATE_12P2
}

Bitrate selection for AMR.

More...
enum ISPEECH1_AMR_CodecSelect {
ISPEECH1_AMR_CODECSELECT_PRIMARY = 0,
ISPEECH1_AMR_CODECSELECT_SECONDARY = 1,
ISPEECH1_AMR_CODECSELECT_DEFAULT = ISPEECH1_AMR_CODECSELECT_PRIMARY
}

Codec selection.

More...
enum ISPEECH1_AMR_PackingType {
ISPEECH1_AMR_PACKTYPE_IF1_NOCRC = 0,
ISPEECH1_AMR_PACKTYPE_IF1_WITHCRC = 1,
ISPEECH1_AMR_PACKTYPE_IF2 = 2,
ISPEECH1_AMR_PACKTYPE_MIME = 3,
ISPEECH1_AMR_PACKTYPEFORMAT_DEFAULT = ISPEECH1_AMR_PACKTYPE_IF1_NOCRC
}

Packing type options for AMR.

More...
enum ISPEECH1_AMR_VADSelect {
ISPEECH1_AMR_VADSELECT_VAD1 = 1,
ISPEECH1_AMR_VADSELECT_VAD2 = 2,
ISPEECH1_AMR_VADSELECT_DEFAULT = ISPEECH1_AMR_VADSELECT_VAD1
}

Voice activity detector (VAD) selection.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various AMR codecs.

Enumeration Type Documentation

enum ISPEECH1_AMR_BitRate

Bitrate selection for AMR.

Enumerator:
ISPEECH1_AMR_BITRATE_4P75

4.75 kbps

ISPEECH1_AMR_BITRATE_5P15

5.15 kbps

ISPEECH1_AMR_BITRATE_5P9

5.9 kbps

ISPEECH1_AMR_BITRATE_6P7

6.7 kbps

ISPEECH1_AMR_BITRATE_7P4

7.4 kbps

ISPEECH1_AMR_BITRATE_7P95

7.95 kbps

ISPEECH1_AMR_BITRATE_10P2

10.2 kbps

ISPEECH1_AMR_BITRATE_12P2

12.2 kbps

ISPEECH1_AMR_BITRATE_DEFAULT

Default setting.

enum ISPEECH1_AMR_CodecSelect

Codec selection.

Remarks:
This parameter is used to select the codec in cases where multiple codecs are supported from the same code base.
Enumerator:
ISPEECH1_AMR_CODECSELECT_PRIMARY

Primary mode - AMR.

ISPEECH1_AMR_CODECSELECT_SECONDARY

Secondary mode - EFR.

ISPEECH1_AMR_CODECSELECT_DEFAULT

Default setting.

enum ISPEECH1_AMR_PackingType

Packing type options for AMR.

Enumerator:
ISPEECH1_AMR_PACKTYPE_IF1_NOCRC

Interface format 1, without CRC check (as per 3GPP 26.101).

ISPEECH1_AMR_PACKTYPE_IF1_WITHCRC

Interface format 1, with CRC check (as per 3GPP 26.101).

ISPEECH1_AMR_PACKTYPE_IF2

Interface format 2 (as per 3GPP 26.101).

ISPEECH1_AMR_PACKTYPE_MIME

MIME/MMSIO/file storage format.

ISPEECH1_AMR_PACKTYPEFORMAT_DEFAULT

Default setting.

enum ISPEECH1_AMR_VADSelect

Voice activity detector (VAD) selection.

Enumerator:
ISPEECH1_AMR_VADSELECT_VAD1

VAD 1

ISPEECH1_AMR_VADSELECT_VAD2

VAD 2

ISPEECH1_AMR_VADSELECT_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (EVRC)

XDM Speech/Voice Interface (EVRC)

Enumerations

enum ISPEECH1_EVRC_NoisePreProc {
ISPEECH1_EVRC_NOISEPREPROC_OFF = 0,
ISPEECH1_EVRC_NOISEPREPROC_ON = 1,
ISPEECH1_EVRC_NOISEPREPROC_DEFAULT = ISPEECH1_EVRC_NOISEPREPROC_ON
}

Enable/disable noise suppression.

More...
enum ISPEECH1_EVRC_TTYMode {
ISPEECH1_EVRC_TTYMODE_OFF = 0,
ISPEECH1_EVRC_TTYMODE_45P45BPS = 1,
ISPEECH1_EVRC_TTYMODE_50BPS = 2,
ISPEECH1_EVRC_TTYMODE_DEFAULT = ISPEECH1_EVRC_TTYMODE_OFF
}

TTY/TDD mode selection.

More...
enum ISPEECH1_EVRC_Mode {
ISPEECH1_EVRC_MODE_PREMIUM = 0,
ISPEECH1_EVRC_MODE_STANDARD = 1,
ISPEECH1_EVRC_MODE_ECONOMY = 2,
ISPEECH1_EVRC_MODE_CAPACITYSAVE = 3,
ISPEECH1_EVRC_MODE_HALFRATE_MAX = 4,
ISPEECH1_EVRC_MODE_DEFAULT = ISPEECH1_EVRC_MODE_PREMIUM
}

Mode selection.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various EVRC codecs.

Enumeration Type Documentation

enum ISPEECH1_EVRC_NoisePreProc

Enable/disable noise suppression.

Enumerator:
ISPEECH1_EVRC_NOISEPREPROC_OFF

The noise suppression is disabled.

ISPEECH1_EVRC_NOISEPREPROC_ON

The noise suppression is enabled.

ISPEECH1_EVRC_NOISEPREPROC_DEFAULT

Default setting.

enum ISPEECH1_EVRC_TTYMode

TTY/TDD mode selection.

Enumerator:
ISPEECH1_EVRC_TTYMODE_OFF

Off

ISPEECH1_EVRC_TTYMODE_45P45BPS

45.45 baud rate

ISPEECH1_EVRC_TTYMODE_50BPS

50 baud rate

ISPEECH1_EVRC_TTYMODE_DEFAULT

Default setting.

enum ISPEECH1_EVRC_Mode

Mode selection.

Remarks:
This is used for rate reduction mode in EVRC codecs. The average bit rate of speech encoding is controlled by these different modes.
Enumerator:
ISPEECH1_EVRC_MODE_PREMIUM

Premium mode.

ISPEECH1_EVRC_MODE_STANDARD

Standard mode.

ISPEECH1_EVRC_MODE_ECONOMY

Economy mode.

ISPEECH1_EVRC_MODE_CAPACITYSAVE

Capacity saving mode.

ISPEECH1_EVRC_MODE_HALFRATE_MAX

Half rate max mode.

ISPEECH1_EVRC_MODE_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (G.723)

XDM Speech/Voice Interface (G.723)

Enumerations

enum ISPEECH1_G723_BitRate {
ISPEECH1_G723_BITRATE_5P3 = 0,
ISPEECH1_G723_BITRATE_6P3 = 1,
ISPEECH1_G723_BITRATE_DEFAULT = ISPEECH1_G723_BITRATE_6P3
}

Bit rate selection for G723.

More...
enum ISPEECH1_G723_NoisePreProc {
ISPEECH1_G723_NOISEPREPROC_OFF = 0,
ISPEECH1_G723_NOISEPREPROC_ON = 1,
ISPEECH1_G723_NOISEPREPROC_DEFAULT = ISPEECH1_G723_NOISEPREPROC_ON
}

Enable/disable high pass filter for G723.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various G.723 codecs.

Enumeration Type Documentation

enum ISPEECH1_G723_BitRate

Bit rate selection for G723.

Enumerator:
ISPEECH1_G723_BITRATE_5P3

5.3 kbps

ISPEECH1_G723_BITRATE_6P3

6.3 kbps

ISPEECH1_G723_BITRATE_DEFAULT

Default setting.

enum ISPEECH1_G723_NoisePreProc

Enable/disable high pass filter for G723.

Enumerator:
ISPEECH1_G723_NOISEPREPROC_OFF

The high pass filter is disabled.

ISPEECH1_G723_NOISEPREPROC_ON

The high pass filter is enabled.

ISPEECH1_G723_NOISEPREPROC_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (G.726)

XDM Speech/Voice Interface (G.726)

Enumerations

enum ISPEECH1_G726_BitRate {
ISPEECH1_G726_BITRATE_16 = 0,
ISPEECH1_G726_BITRATE_24 = 1,
ISPEECH1_G726_BITRATE_32 = 2,
ISPEECH1_G726_BITRATE_40 = 3,
ISPEECH1_G726_BITRATE_DEFAULT = ISPEECH1_G726_BITRATE_40
}

Bit rate selection for G726.

More...
enum ISPEECH1_G726_CompandingLaw {
ISPEECH1_G726_COMPAND_LINEAR = 0,
ISPEECH1_G726_COMPAND_ALAW = 1,
ISPEECH1_G726_COMPAND_ULAW = 2,
ISPEECH1_G726_COMPAND_DEFAULT = ISPEECH1_G726_COMPAND_LINEAR
}

Companding law of encoder input and decoder output samples.

More...
enum ISPEECH1_G726_PackingType {
ISPEECH1_G726_PACKTYPE_LINEAR = 0,
ISPEECH1_G726_PACKTYPE_RTPSPECIAL = 1,
ISPEECH1_G726_PACKTYPEFORMAT_DEFAULT = ISPEECH1_G726_PACKTYPE_LINEAR
}

Packing Type defintions for G.726.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various G.726 codecs.

Enumeration Type Documentation

enum ISPEECH1_G726_BitRate

Bit rate selection for G726.

Enumerator:
ISPEECH1_G726_BITRATE_16

16 kbps

ISPEECH1_G726_BITRATE_24

24 kbps

ISPEECH1_G726_BITRATE_32

32 kbps

ISPEECH1_G726_BITRATE_40

40 kbps

ISPEECH1_G726_BITRATE_DEFAULT

Default setting.

enum ISPEECH1_G726_CompandingLaw

Companding law of encoder input and decoder output samples.

Enumerator:
ISPEECH1_G726_COMPAND_LINEAR

Linear

ISPEECH1_G726_COMPAND_ALAW

A-law

ISPEECH1_G726_COMPAND_ULAW

Mu-law

ISPEECH1_G726_COMPAND_DEFAULT

Default setting.

enum ISPEECH1_G726_PackingType

Packing Type defintions for G.726.

Enumerator:
ISPEECH1_G726_PACKTYPE_LINEAR

Linear packing.

ISPEECH1_G726_PACKTYPE_RTPSPECIAL

RTP special format.

ISPEECH1_G726_PACKTYPEFORMAT_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (PCM)

XDM Speech/Voice Interface (PCM)

Enumerations

enum ISPEECH1_PCM_CompandingLaw {
ISPEECH1_PCM_COMPAND_LINEAR = 0,
ISPEECH1_PCM_COMPAND_ALAW = 1,
ISPEECH1_PCM_COMPAND_ULAW = 2,
ISPEECH1_PCM_COMPAND_DEFAULT = ISPEECH1_PCM_COMPAND_LINEAR
}

Companding law of encoder input and decoder output samples.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various PCM codecs.

Enumeration Type Documentation

enum ISPEECH1_PCM_CompandingLaw

Companding law of encoder input and decoder output samples.

Enumerator:
ISPEECH1_PCM_COMPAND_LINEAR

Linear

ISPEECH1_PCM_COMPAND_ALAW

A-law

ISPEECH1_PCM_COMPAND_ULAW

Mu-law

ISPEECH1_PCM_COMPAND_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (SMV)

XDM Speech/Voice Interface (SMV)

Enumerations

enum ISPEECH1_SMV_NoisePreProc {
ISPEECH1_SMV_NOISEPREPROC_OFF = 0,
ISPEECH1_SMV_NOISEPREPROC_NSA = 1,
ISPEECH1_SMV_NOISEPREPROC_NSB = 2,
ISPEECH1_SMV_NOISEPREPROC_DEFAULT = ISPEECH1_SMV_NOISEPREPROC_NSA
}

Enabling/disabling noise suppression, and selection of noise suppression if the codec supports multiple noise supression modules.

More...
enum ISPEECH1_SMV_VADSelect {
ISPEECH1_SMV_VADSELECT_VADA = 1,
ISPEECH1_SMV_VADSELECT_VADB = 2,
ISPEECH1_SMV_VADSELECT_DEFAULT = ISPEECH1_SMV_VADSELECT_VADA
}

Voice activity detection (VAD) selection.

More...
enum ISPEECH1_SMV_TTYMode {
ISPEECH1_SMV_TTYMODE_OFF = 0,
ISPEECH1_SMV_TTYMODE_45P45BPS = 1,
ISPEECH1_SMV_TTYMODE_50BPS = 2,
ISPEECH1_SMV_TTYMODE_DEFAULT = ISPEECH1_SMV_TTYMODE_OFF
}

TTY/TDD mode selection.

More...
enum ISPEECH1_SMV_DTMFMode {
ISPEECH1_SMV_DTMFMODE_OFF = 0,
ISPEECH1_SMV_DTMFMODE_ON = 1,
ISPEECH1_SMV_DTMFMODE_DEFAULT = ISPEECH1_SMV_DTMFMODE_OFF
}

DTMF mode selection.

More...
enum ISPEECH1_SMV_DataMode {
ISPEECH1_SMV_DATAMODE_OFF = 0,
ISPEECH1_SMV_DATAMODE_HALFRATE = 1,
ISPEECH1_SMV_DATAMODE_FULLRATE = 1,
ISPEECH1_SMV_DATAMODE_DEFAULT = ISPEECH1_SMV_DATAMODE_OFF
}

Enable/disable in band data transmission and data rate selection.

More...
enum ISPEECH1_SMV_Mode {
ISPEECH1_SMV_MODE_PREMIUM = 0,
ISPEECH1_SMV_MODE_STANDARD = 1,
ISPEECH1_SMV_MODE_ECONOMY = 2,
ISPEECH1_SMV_MODE_CAPACITYSAVE = 3,
ISPEECH1_SMV_MODE_PREMIUM_HALFRATE_MAX = 4,
ISPEECH1_SMV_MODE_STANDARD_HALFRATE_MAX = 5,
ISPEECH1_SMV_MODE_DEFAULT = ISPEECH1_SMV_MODE_PREMIUM
}

Rate reduction mode selection.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various SMV codecs.

Enumeration Type Documentation

enum ISPEECH1_SMV_NoisePreProc

Enabling/disabling noise suppression, and selection of noise suppression if the codec supports multiple noise supression modules.

Enumerator:
ISPEECH1_SMV_NOISEPREPROC_OFF

Noise suppression is disabled.

ISPEECH1_SMV_NOISEPREPROC_NSA

Noise suppression is enabled, using option A.

ISPEECH1_SMV_NOISEPREPROC_NSB

Noise suppression is enabled, using option B.

ISPEECH1_SMV_NOISEPREPROC_DEFAULT

Default setting.

enum ISPEECH1_SMV_VADSelect

Voice activity detection (VAD) selection.

Enumerator:
ISPEECH1_SMV_VADSELECT_VADA

VAD A

ISPEECH1_SMV_VADSELECT_VADB

VAD B

ISPEECH1_SMV_VADSELECT_DEFAULT

Default setting.

enum ISPEECH1_SMV_TTYMode

TTY/TDD mode selection.

Enumerator:
ISPEECH1_SMV_TTYMODE_OFF

TTY detection is disabled.

ISPEECH1_SMV_TTYMODE_45P45BPS

TTY detection is enabled, with 45.45 bauds/sec rate.

ISPEECH1_SMV_TTYMODE_50BPS

TTY detection is enabled, with 50 bauds/sec rate.

ISPEECH1_SMV_TTYMODE_DEFAULT

Default setting.

enum ISPEECH1_SMV_DTMFMode

DTMF mode selection.

Enumerator:
ISPEECH1_SMV_DTMFMODE_OFF

DTMF detection is disabled.

ISPEECH1_SMV_DTMFMODE_ON

DTMF detection is enabled.

ISPEECH1_SMV_DTMFMODE_DEFAULT

Default setting.

enum ISPEECH1_SMV_DataMode

Enable/disable in band data transmission and data rate selection.

Enumerator:
ISPEECH1_SMV_DATAMODE_OFF

Data transmission is disabled

ISPEECH1_SMV_DATAMODE_HALFRATE

Data transmission is enabled at half rate.

ISPEECH1_SMV_DATAMODE_FULLRATE

Data transmission is enabled at full rate.

ISPEECH1_SMV_DATAMODE_DEFAULT

Default setting.

enum ISPEECH1_SMV_Mode

Rate reduction mode selection.

Enumerator:
ISPEECH1_SMV_MODE_PREMIUM

Premium mode.

ISPEECH1_SMV_MODE_STANDARD

Standard mode.

ISPEECH1_SMV_MODE_ECONOMY

Economy mode.

ISPEECH1_SMV_MODE_CAPACITYSAVE

Capacity saving mode.

ISPEECH1_SMV_MODE_PREMIUM_HALFRATE_MAX

Premium mode, with half rate maximum.

ISPEECH1_SMV_MODE_STANDARD_HALFRATE_MAX

Standard mode, with half rate maximum.

ISPEECH1_SMV_MODE_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM Speech/Voice Interface (WBAMR)

XDM Speech/Voice Interface (WBAMR)

Enumerations

enum ISPEECH1_WBAMR_PackingType {
ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC = 0,
ISPEECH1_WBAMR_PACKTYPE_IF1_WITHCRC = 1,
ISPEECH1_WBAMR_PACKTYPE_IF2 = 2,
ISPEECH1_WBAMR_PACKTYPE_MIME = 3,
ISPEECH1_WBAMR_PACKTYPEFORMAT_DEFAULT = ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC
}

Packing Type defintions for AMR.

More...
enum ISPEECH1_WBAMR_BitRate {
ISPEECH1_WBAMR_BITRATE_6P60 = 0,
ISPEECH1_WBAMR_BITRATE_8P85 = 1,
ISPEECH1_WBAMR_BITRATE_12P65 = 2,
ISPEECH1_WBAMR_BITRATE_14P25 = 3,
ISPEECH1_WBAMR_BITRATE_15P85 = 4,
ISPEECH1_WBAMR_BITRATE_18P25 = 5,
ISPEECH1_WBAMR_BITRATE_19P85 = 6,
ISPEECH1_WBAMR_BITRATE_23P05 = 7,
ISPEECH1_WBAMR_BITRATE_23P85 = 8,
ISPEECH1_WBAMR_BITRATE_DEFAULT = ISPEECH1_WBAMR_BITRATE_23P85
}

Bitrate selection for AMR.

More...

Detailed Description

This is the XDM speech/voice interface shared between the various WB-AMR codecs.

Enumeration Type Documentation

enum ISPEECH1_WBAMR_PackingType

Packing Type defintions for AMR.

Enumerator:
ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC

Interface format 1, without CRC check (as per 3GPP 26.201).

ISPEECH1_WBAMR_PACKTYPE_IF1_WITHCRC

Interface format 1, with CRC check (as per 3GPP 26.201).

ISPEECH1_WBAMR_PACKTYPE_IF2

Interface format 2 (as per 3GPP 26.201).

ISPEECH1_WBAMR_PACKTYPE_MIME

MIME/MMSIO/file storage format.

ISPEECH1_WBAMR_PACKTYPEFORMAT_DEFAULT

Default setting.

enum ISPEECH1_WBAMR_BitRate

Bitrate selection for AMR.

Enumerator:
ISPEECH1_WBAMR_BITRATE_6P60

6.60 kbps

ISPEECH1_WBAMR_BITRATE_8P85

8.85 kbps

ISPEECH1_WBAMR_BITRATE_12P65

12.65 kbps

ISPEECH1_WBAMR_BITRATE_14P25

14.25 kbps

ISPEECH1_WBAMR_BITRATE_15P85

15.85 kbps

ISPEECH1_WBAMR_BITRATE_18P25

18.25 kbps

ISPEECH1_WBAMR_BITRATE_19P85

19.85 kbps

ISPEECH1_WBAMR_BITRATE_23P05

23.05 kbps

ISPEECH1_WBAMR_BITRATE_23P85

23.85 kbps

ISPEECH1_WBAMR_BITRATE_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM ISPHDEC Speech/Voice Decoder Interface

XDM ISPHDEC Speech/Voice Decoder Interface

Data Structures

struct | ISPHDEC_Obj
This must be the first field of all ISPHDEC instance objects. More...
struct | ISPHDEC_Params
Defines the creation time parameters for all ISPHDEC instance objects. More...
struct | ISPHDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | ISPHDEC_InArgs
Defines the input arguments for all ISPHDEC instance process function. More...
struct | ISPHDEC_Status
Defines instance status parameters (read-only). More...
struct | ISPHDEC_OutArgs
Defines the run time output arguments for all ISPHDEC instance objects. More...
struct | ISPHDEC_Fxns
Defines all of the operations on ISPHDEC objects. More...

Defines

#define | ISPHDEC_CID "ti.xdais.dm.ISPHDEC"
#define | ISPHDEC_ERUNTIME XDM_ERUNTIME
#define | ISPHDEC_EOK XDM_EOK
#define | ISPHDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct ISPHDEC_Obj * | ISPHDEC_Handle
Opaque handle to an ISPHDEC objects.
typedef IALG_Cmd | ISPHDEC_Cmd
Defines the control commands for the ISPHDEC module.

Detailed Description

This is the XDM ISPHDEC Speech/Voice Decoder Interface.

Deprecated:
This XDM speech decoder interface has been deprecated, and superceeded by newer ISPHDECx speech decoder interfaces.

Define Documentation

#define ISPHDEC_CID "ti.xdais.dm.ISPHDEC"

ISPHDEC Class ID

#define ISPHDEC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define ISPHDEC_EOK XDM_EOK

Success.

#define ISPHDEC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct ISPHDEC_Obj* ISPHDEC_Handle

Opaque handle to an ISPHDEC objects.

typedef IALG_Cmd ISPHDEC_Cmd

Defines the control commands for the ISPHDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
ISPHDEC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM ISPHDEC1 Speech/Voice Decoder Interface

XDM ISPHDEC1 Speech/Voice Decoder Interface

Data Structures

struct | ISPHDEC1_Obj
This must be the first field of all ISPHDEC1 instance objects. More...
struct | ISPHDEC1_Params
Defines the creation time parameters for all ISPHDEC1 instance objects. More...
struct | ISPHDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via ISPHDEC1_Fxns.control(). More...
struct | ISPHDEC1_InArgs
Defines the input arguments for all ISPHDEC1 instance process function. More...
struct | ISPHDEC1_Status
Defines instance status parameters. More...
struct | ISPHDEC1_OutArgs
Defines the run time output arguments for all ISPHDEC1 instance objects. More...
struct | ISPHDEC1_Fxns
Defines all of the operations on ISPHDEC1 objects. More...

Defines

#define | ISPHDEC1_EOK XDM_EOK
#define | ISPHDEC1_EFAIL XDM_EFAIL
#define | ISPHDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct ISPHDEC1_Obj * | ISPHDEC1_Handle
Opaque handle to an ISPHDEC1 objects.
typedef IALG_Cmd | ISPHDEC1_Cmd
Defines the control commands for the ISPHDEC1 module.

Enumerations

enum ISPHDEC1_FrameType {
ISPHDEC1_FTYPE_SPEECHGOOD = 0,
ISPHDEC1_FTYPE_SIDUPDATE = 1,
ISPHDEC1_FTYPE_NODATA = 2,
ISPHDEC1_FTYPE_SPEECHLOST = 3,
ISPHDEC1_FTYPE_DEGRADED = 4,
ISPHDEC1_FTYPE_BAD = 5,
ISPHDEC1_FTYPE_SIDFIRST = 6,
ISPHDEC1_FTYPE_SIDBAD = 7,
ISPHDEC1_FTYPE_ONSET = 8
}

Decoder frame types.

More...

Detailed Description

This is the XDM ISPHDEC1 Speech/Voice Decoder Interface.

Define Documentation

#define ISPHDEC1_EOK XDM_EOK

Success.

#define ISPHDEC1_EFAIL XDM_EFAIL

General failure.

#define ISPHDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct ISPHDEC1_Obj* ISPHDEC1_Handle

Opaque handle to an ISPHDEC1 objects.

typedef IALG_Cmd ISPHDEC1_Cmd

Defines the control commands for the ISPHDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional control commands.
See also:
XDM_CmdId
ISPHDEC1_Fxns::control()

Enumeration Type Documentation

enum ISPHDEC1_FrameType

Decoder frame types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
ISPHDEC1_InArgs.frameType
Enumerator:
ISPHDEC1_FTYPE_SPEECHGOOD

Regular speech frame received without errors/loss.

ISPHDEC1_FTYPE_SIDUPDATE

SID update frames.

ISPHDEC1_FTYPE_NODATA

Untransmitted frame for codecs which support internal DTX.

ISPHDEC1_FTYPE_SPEECHLOST

Complete loss of speech frame.

ISPHDEC1_FTYPE_DEGRADED

Speech frame with a correct CRC, some invalid data.

ISPHDEC1_FTYPE_BAD

Speech frame (likely), but invalid.

ISPHDEC1_FTYPE_SIDFIRST

The first frame of comfort noise.

ISPHDEC1_FTYPE_SIDBAD

Corrupt SID update frame.

ISPHDEC1_FTYPE_ONSET

Frames which precede the first speech frame of a speech burst.


Codec Engine Application Programming Interface (API): XDM ISPHENC Speech/Voice Encoder Interface

XDM ISPHENC Speech/Voice Encoder Interface

Data Structures

struct | ISPHENC_Obj
This must be the first field of all ISPHENC instance objects. More...
struct | ISPHENC_Params
Defines the creation time parameters for all ISPHENC instance objects. More...
struct | ISPHENC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | ISPHENC_InArgs
Defines the input arguments for all ISPHENC instance process function. More...
struct | ISPHENC_Status
Defines instance status parameters (read-only). More...
struct | ISPHENC_OutArgs
Defines the run time output arguments for all ISPHENC instance objects. More...
struct | ISPHENC_Fxns
Defines all of the operations on ISPHENC objects. More...

Defines

#define | ISPHENC_CID "ti.xdais.dm.ISPHENC"
#define | ISPHENC_ERUNTIME XDM_ERUNTIME
#define | ISPHENC_EOK XDM_EOK
#define | ISPHENC_EFAIL XDM_EFAIL

Typedefs

typedef struct ISPHENC_Obj * | ISPHENC_Handle
Opaque handle to an ISPHENC objects.
typedef IALG_Cmd | ISPHENC_Cmd
Defines the control commands for the ISPHENC module.

Detailed Description

This is the XDM ISPHENC Speech/Voice Encoder Interface.

Deprecated:
This XDM speech encoder interface has been deprecated, and superceeded by newer ISPHENCx speech encoder interfaces.

Define Documentation

#define ISPHENC_CID "ti.xdais.dm.ISPHENC"

ISPHENC Class ID

#define ISPHENC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define ISPHENC_EOK XDM_EOK

Success.

#define ISPHENC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct ISPHENC_Obj* ISPHENC_Handle

Opaque handle to an ISPHENC objects.

typedef IALG_Cmd ISPHENC_Cmd

Defines the control commands for the ISPHENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
ISPHENC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM ISPHENC1 Speech/Voice Encoder Interface

XDM ISPHENC1 Speech/Voice Encoder Interface

Data Structures

struct | ISPHENC1_Obj
This must be the first field of all ISPHENC1 instance objects. More...
struct | ISPHENC1_Params
Defines the creation time parameters for all ISPHENC1 instance objects. More...
struct | ISPHENC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via ISPHENC1_Fxns.control(). More...
struct | ISPHENC1_InArgs
Defines the input arguments for all ISPHENC1 instance process function. More...
struct | ISPHENC1_Status
Defines instance status parameters. More...
struct | ISPHENC1_OutArgs
Defines the run time output arguments for all ISPHENC1 instance objects. More...
struct | ISPHENC1_Fxns
Defines all of the operations on ISPHENC1 objects. More...

Defines

#define | ISPHENC1_EOK XDM_EOK
#define | ISPHENC1_EFAIL XDM_EFAIL
#define | ISPHENC1_EUNSUPPORTED XDM_EUNSUPPORTED
#define | ISPHENC1_ENOOUTPUT 1
This value signifies no output being available at encoder, for example in the case of intermediate calls in 10msec frame size execution.

Typedefs

typedef struct ISPHENC1_Obj * | ISPHENC1_Handle
Opaque handle to an ISPHENC1 objects.
typedef IALG_Cmd | ISPHENC1_Cmd
Defines the control commands for the ISPHENC1 module.

Enumerations

enum ISPHENC1_FrameType {
ISPHENC1_FTYPE_SPEECH = 0,
ISPHENC1_FTYPE_SIDFRAME = 1,
ISPHENC1_FTYPE_NODATA = 2
}

Encoder frame types.

More...

Detailed Description

This is the XDM ISPHENC1 Speech/Voice Encoder Interface.

Define Documentation

#define ISPHENC1_EOK XDM_EOK

Success.

#define ISPHENC1_EFAIL XDM_EFAIL

General failure.

#define ISPHENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

#define ISPHENC1_ENOOUTPUT 1

This value signifies no output being available at encoder, for example in the case of intermediate calls in 10msec frame size execution.

Typedef Documentation

typedef struct ISPHENC1_Obj* ISPHENC1_Handle

Opaque handle to an ISPHENC1 objects.

typedef IALG_Cmd ISPHENC1_Cmd

Defines the control commands for the ISPHENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional control commands.
See also:
XDM_CmdId
ISPHENC1_Fxns::control()

Enumeration Type Documentation

enum ISPHENC1_FrameType

Encoder frame types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
Enumerator:
ISPHENC1_FTYPE_SPEECH

Speech frame

ISPHENC1_FTYPE_SIDFRAME

SID frames for codecs which support DTX.

ISPHENC1_FTYPE_NODATA

Untransmitted frame for codecs which support DTX.


Codec Engine Application Programming Interface (API): XDM Beta Universal Algorithm Interface

XDM Beta Universal Algorithm Interface

Data Structures

struct | IUNIVERSAL_Obj
This must be the first field of all IUNIVERSAL instance objects. More...
struct | IUNIVERSAL_Params
Defines the creation time parameters for all IUNIVERSAL instance objects. More...
struct | IUNIVERSAL_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IUNIVERSAL_InArgs
Defines the input arguments for all IUNIVERSAL instance process function. More...
struct | IUNIVERSAL_Status
Defines instance status parameters (read-only). More...
struct | IUNIVERSAL_OutArgs
Defines the run time output arguments for all IUNIVERSAL instance objects. More...
struct | IUNIVERSAL_Fxns
Defines all of the operations on IUNIVERSAL objects. More...

Defines

#define | IUNIVERSAL_EOK XDM_EOK
#define | IUNIVERSAL_EFAIL XDM_EFAIL
#define | IUNIVERSAL_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IUNIVERSAL_Obj * | IUNIVERSAL_Handle
Opaque handle to an IUNIVERSAL objects.
typedef IALG_Cmd | IUNIVERSAL_Cmd
Defines the control commands for the IUNIVERSAL module.

Detailed Description

This is the XDM Beta Universal Algorithm Interface.

Define Documentation

#define IUNIVERSAL_EOK XDM_EOK

Success.

#define IUNIVERSAL_EFAIL XDM_EFAIL

General failure.

#define IUNIVERSAL_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IUNIVERSAL_Obj* IUNIVERSAL_Handle

Opaque handle to an IUNIVERSAL objects.

typedef IALG_Cmd IUNIVERSAL_Cmd

Defines the control commands for the IUNIVERSAL module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IUNIVERSAL_Fxns::control()


Codec Engine Application Programming Interface (API): XDM Beta Video Analytics Interface

XDM Beta Video Analytics Interface

Data Structures

struct | IVIDANALYTICS_Grid
Access modes used to declare how the algorithm accessed buffers. More...
struct | IVIDANALYTICS_Rule
Analytics rule. More...
struct | IVIDANALYTICS_Obj
This must be the first field of all IVIDANALYTICS instance objects. More...
struct | IVIDANALYTICS_Params
Defines the creation time parameters for all IVIDANALYTICS instance objects. More...
struct | IVIDANALYTICS_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IVIDANALYTICS_InArgs
Defines the input arguments for all IVIDANALYTICS instance process function. More...
struct | IVIDANALYTICS_Status
Defines instance status parameters. More...
struct | IVIDANALYTICS_OutArgs
Defines the run time output arguments for all IVIDANALYTICS instance objects. More...
struct | IVIDANALYTICS_Fxns
Defines all of the operations on IVIDANALYTICS objects. More...

Defines

#define | IVIDANALYTICS_EOK XDM_EOK
#define | IVIDANALYTICS_EFAIL XDM_EFAIL
#define | IVIDANALYTICS_EUNSUPPORTED XDM_EUNSUPPORTED
#define | IVIDANALYTICS_SETRULE XDM_CLASSCMDBASE
Set a new rule.
#define | IVIDANALYTICS_CLEARRULE XDM_CLASSCMDBASE + 1
Clear a rule.
#define | IVIDANALYTICS_MAXTARGETS 128
Maximum targets that can be detected per process() call.
#define | IVIDANALYTICS_MAXEVENTS 128
Maximum number of events that can be detected per process() call.

Typedefs

typedef struct IVIDANALYTICS_Obj * | IVIDANALYTICS_Handle
Opaque handle to an IVIDANALYTICS objects.
typedef IALG_Cmd | IVIDANALYTICS_Cmd
Defines the control commands for the IVIDANALYTICS module.

Enumerations

enum IVIDANALYTICS_AnalysisMask {
IVIDANALYTICS_MOTIONDETECT = 0,
IVIDANALYTICS_OBJECTTRACKING = 1,
IVIDANALYTICS_USERBASE = 16
}

Access modes used to declare how the algorithm accessed buffers.

More...
enum IVIDANALYTICS_ObjectType {
IVIDANALYTICS_OBJECTTYPE_VEHICLE = 0,
IVIDANALYTICS_OBJECTTYPE_HUMAN = 1,
IVIDANALYTICS_OBJECTTYPE_USERBASE = 256
}

Types of objects.

More...
enum IVIDANALYTICS_ActionType {
IVIDANALYTICS_ACTIONTYPE_LOITER = 0,
IVIDANALYTICS_ACTIONTYPE_ENTER = 1,
IVIDANALYTICS_ACTIONTYPE_EXIT = 2,
IVIDANALYTICS_ACTIONTYPE_APPEAR = 3,
IVIDANALYTICS_ACTIONTYPE_DISAPPEAR = 4,
IVIDANALYTICS_ACTIONTYPE_CROSSL2R = 5,
IVIDANALYTICS_ACTIONTYPE_CROSSR2L = 6,
IVIDANALYTICS_ACTIONTYPE_CROSSU2D = 7,
IVIDANALYTICS_ACTIONTYPE_CROSSD2U = 8,
IVIDANALYTICS_ACTIONTYPE_USERBASE = 256
}

Types of objects.

More...
enum IVIDANALYTICS_ViewState {
IVIDANALYTICS_VIEWSTATE_BAD = 0,
IVIDANALYTICS_VIEWSTATE_GOOD = 1
}

View state of the analytics engine.

More...

Detailed Description

This is the XDM Beta Video Analytics Interface.

Define Documentation

#define IVIDANALYTICS_EOK XDM_EOK

Success.

#define IVIDANALYTICS_EFAIL XDM_EFAIL

General failure.

#define IVIDANALYTICS_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

#define IVIDANALYTICS_SETRULE XDM_CLASSCMDBASE

Set a new rule.

#define IVIDANALYTICS_CLEARRULE XDM_CLASSCMDBASE + 1

Clear a rule.

#define IVIDANALYTICS_MAXTARGETS 128

Maximum targets that can be detected per process() call.

Todo:
This could be 64 if needed. Need to understand the size of structs that use this and whether they're "too big".
#define IVIDANALYTICS_MAXEVENTS 128

Maximum number of events that can be detected per process() call.

Todo:
Need to understand the size of structs that use this and whether they're "too big".

Typedef Documentation

typedef struct IVIDANALYTICS_Obj* IVIDANALYTICS_Handle

Opaque handle to an IVIDANALYTICS objects.

typedef IALG_Cmd IVIDANALYTICS_Cmd

Defines the control commands for the IVIDANALYTICS module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDANALYTICS_Fxns::control()

Enumeration Type Documentation

enum IVIDANALYTICS_AnalysisMask

Access modes used to declare how the algorithm accessed buffers.

Remarks:
The IVIDANALYTICS interface reserves bits 0-15. Bits 16-31 are available to the user.
See also:
IVIDANALYTICS_Mask::enableMask
Enumerator:
IVIDANALYTICS_MOTIONDETECT

Motion detection, bit 0

IVIDANALYTICS_OBJECTTRACKING

Object tracking, bit 1

IVIDANALYTICS_USERBASE

User supplied analysis begins at bit 16.

enum IVIDANALYTICS_ObjectType

Types of objects.

Remarks:
The IVIDANALYTICS interface reserves types 0-255. User-defined objects can be defined from 256 and larger.
Enumerator:
IVIDANALYTICS_OBJECTTYPE_VEHICLE

Object is a vehicle

IVIDANALYTICS_OBJECTTYPE_HUMAN

Object is a human

IVIDANALYTICS_OBJECTTYPE_USERBASE

User supplied objects begins at 256.

enum IVIDANALYTICS_ActionType

Types of objects.

Remarks:
The IVIDANALYTICS interface reserves types 0-255. User-defined actions can be defined from 256 and larger.
Enumerator:
IVIDANALYTICS_ACTIONTYPE_LOITER

Object is loitering

IVIDANALYTICS_ACTIONTYPE_ENTER

Object enters

IVIDANALYTICS_ACTIONTYPE_EXIT

Object exits

IVIDANALYTICS_ACTIONTYPE_APPEAR

Object appears

IVIDANALYTICS_ACTIONTYPE_DISAPPEAR

Object appears

IVIDANALYTICS_ACTIONTYPE_CROSSL2R

Object crosses left to right

IVIDANALYTICS_ACTIONTYPE_CROSSR2L

Object crosses right to left

IVIDANALYTICS_ACTIONTYPE_CROSSU2D

Object crosses up to down

IVIDANALYTICS_ACTIONTYPE_CROSSD2U

Object crosses down to up

IVIDANALYTICS_ACTIONTYPE_USERBASE

User supplied objects begins at 256.

enum IVIDANALYTICS_ViewState

View state of the analytics engine.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
Todo:
Need to further review and define. Probably need hooks for user-defined states, in addition to some pre-defined ones.
See also:
IVIDANALYTICS_OutArgs::viewState
IVIDANALYTICS_Status::viewState
Enumerator:
IVIDANALYTICS_VIEWSTATE_BAD
IVIDANALYTICS_VIEWSTATE_GOOD


Codec Engine Application Programming Interface (API): XDM IVIDDEC Video Decoder Interface

XDM IVIDDEC Video Decoder Interface

Data Structures

struct | IVIDDEC_Obj
This must be the first field of all IVIDDEC instance objects. More...
struct | IVIDDEC_Params
Defines the creation time parameters for all IVIDDEC instance objects. More...
struct | IVIDDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDDEC_InArgs
Defines the input arguments for all IVIDDEC instance process function. More...
struct | IVIDDEC_Status
Defines instance status parameters. More...
struct | IVIDDEC_OutArgs
Defines the run time output arguments for all IVIDDEC instance objects. More...
struct | IVIDDEC_Fxns
Defines all of the operations on IVIDDEC objects. More...

Defines

#define | IVIDDEC_CID "ti.xdais.dm.IVIDDEC"
#define | IVIDDEC_ERUNTIME XDM_ERUNTIME
#define | IVIDDEC_EOK XDM_EOK
#define | IVIDDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct IVIDDEC_Obj * | IVIDDEC_Handle
Opaque handle to an IVIDDEC objects.
typedef IALG_Cmd | IVIDDEC_Cmd
Defines the control commands for the IVIDDEC module.

Detailed Description

This is the XDM IVIDDEC Video Decoder Interface.

Deprecated:
This XDM video decoder interface has been deprecated, and superceeded by newer IVIDDECx video decoder interfaces.

Define Documentation

#define IVIDDEC_CID "ti.xdais.dm.IVIDDEC"

IVIDDEC Class ID

#define IVIDDEC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define IVIDDEC_EOK XDM_EOK

Success.

#define IVIDDEC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct IVIDDEC_Obj* IVIDDEC_Handle

Opaque handle to an IVIDDEC objects.

typedef IALG_Cmd IVIDDEC_Cmd

Defines the control commands for the IVIDDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDDEC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IVIDDEC1 Video Decoder Interface

XDM IVIDDEC1 Video Decoder Interface

Data Structures

struct | IVIDDEC1_Obj
This must be the first field of all IVIDDEC1 instance objects. More...
struct | IVIDDEC1_Params
Defines the creation time parameters for all IVIDDEC1 instance objects. More...
struct | IVIDDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDDEC1_InArgs
Defines the input arguments for all IVIDDEC1 instance process function. More...
struct | IVIDDEC1_Status
Defines instance status parameters. More...
struct | IVIDDEC1_OutArgs
Defines the run time output arguments for all IVIDDEC1 instance objects. More...
struct | IVIDDEC1_Fxns
Defines all of the operations on IVIDDEC1 objects. More...

Defines

#define | IVIDDEC1_EOK XDM_EOK
#define | IVIDDEC1_EFAIL XDM_EFAIL
#define | IVIDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED
#define | IVIDDEC1_FREE_BUFF_SIZE 16

Typedefs

typedef struct IVIDDEC1_Obj * | IVIDDEC1_Handle
Opaque handle to an IVIDDEC1 objects.
typedef IALG_Cmd | IVIDDEC1_Cmd
Defines the control commands for the IVIDDEC1 module.

Enumerations

enum IVIDDEC1_FrameOrder {
IVIDDEC_DISPLAY_ORDER = 0,
IVIDDEC_DECODE_ORDER = 1,
IVIDDEC_FRAMEORDER_DEFAULT = IVIDDEC_DISPLAY_ORDER
}

Video decoder output frame order.

More...

Detailed Description

This is the XDM IVIDDEC1 Video Decoder Interface.

Define Documentation

#define IVIDDEC1_EOK XDM_EOK

Success.

#define IVIDDEC1_EFAIL XDM_EFAIL

General failure.

#define IVIDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

#define IVIDDEC1_FREE_BUFF_SIZE 16

Maximum buffer that can be freed up in a single process call

Typedef Documentation

typedef struct IVIDDEC1_Obj* IVIDDEC1_Handle

Opaque handle to an IVIDDEC1 objects.

typedef IALG_Cmd IVIDDEC1_Cmd

Defines the control commands for the IVIDDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDDEC1_Fxns::control()

Enumeration Type Documentation

enum IVIDDEC1_FrameOrder

Video decoder output frame order.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
IVIDDEC1_DynamicParams::frameOrder
Enumerator:
IVIDDEC_DISPLAY_ORDER

The decoder provides decoded output in in the actual order of displaying the output buffer. The codec assumes the responsibility of reordering the frames.

Remarks:
The output buffer will be delayed by one frame, regardless of whether the frame contains I/P or I/P/B frames.
This is the default mode.
This mode is required to be supported by all video decoder codecs.
IVIDDEC_DECODE_ORDER

The decoder provides decoded output in the the order of decoding. There will be no delay in the output buffers.

Remarks:
It is the application's responsibility to handle the frame re-ordering.
This mode is optional. If it is not supported by the decoder, IVIDDEC_EUNSUPPORTED will be returned.
IVIDDEC_FRAMEORDER_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM IVIDDEC2 Video Decoder Interface

XDM IVIDDEC2 Video Decoder Interface

Data Structures

struct | IVIDDEC2_Obj
This must be the first field of all IVIDDEC2 instance objects. More...
struct | IVIDDEC2_Params
Defines the creation time parameters for all IVIDDEC2 instance objects. More...
struct | IVIDDEC2_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDDEC2_InArgs
Defines the input arguments for all IVIDDEC2 instance process function. More...
struct | IVIDDEC2_Status
Defines instance status parameters. More...
struct | IVIDDEC2_OutArgs
Defines the run time output arguments for all IVIDDEC2 instance objects. More...
struct | IVIDDEC2_Fxns
Defines all of the operations on IVIDDEC2 objects. More...

Defines

#define | IVIDDEC2_MAX_IO_BUFFERS 20
Maximum I/O Buffers.
#define | IVIDDEC2_EOK XDM_EOK
#define | IVIDDEC2_EFAIL XDM_EFAIL
#define | IVIDDEC2_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IVIDDEC2_Obj * | IVIDDEC2_Handle
Opaque handle to an IVIDDEC2 objects.
typedef IALG_Cmd | IVIDDEC2_Cmd
Defines the control commands for the IVIDDEC2 module.

Enumerations

enum IVIDDEC2_FrameOrder {
IVIDDEC2_DISPLAY_ORDER = 0,
IVIDDEC2_DECODE_ORDER = 1,
IVIDDEC2_FRAMEORDER_DEFAULT = IVIDDEC2_DISPLAY_ORDER
}

Video decoder output frame order.

More...

Detailed Description

This is the XDM IVIDDEC2 Video Decoder Interface.

Define Documentation

#define IVIDDEC2_MAX_IO_BUFFERS 20

Maximum I/O Buffers.

See also:
IVIDDEC2_OutArgs
#define IVIDDEC2_EOK XDM_EOK

Success.

#define IVIDDEC2_EFAIL XDM_EFAIL

General failure.

#define IVIDDEC2_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IVIDDEC2_Obj* IVIDDEC2_Handle

Opaque handle to an IVIDDEC2 objects.

typedef IALG_Cmd IVIDDEC2_Cmd

Defines the control commands for the IVIDDEC2 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDDEC2_Fxns::control()

Enumeration Type Documentation

enum IVIDDEC2_FrameOrder

Video decoder output frame order.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
IVIDDEC2_DynamicParams::frameOrder
Enumerator:
IVIDDEC2_DISPLAY_ORDER

The decoder provides decoded output in in the actual order of displaying the output buffer. The codec assumes the responsibility of reordering the frames.

Remarks:
The output buffer will be delayed by one frame, regardless of whether the frame contains I/P or I/P/B frames.
This is the default mode.
This mode is required to be supported by all video decoder codecs.
IVIDDEC2_DECODE_ORDER

The decoder provides decoded output in the the order of decoding. There will be no delay in the output buffers.

Remarks:
It is the application's responsibility to handle the frame re-ordering.
This mode is optional. If it is not supported by the decoder, IVIDDEC_EUNSUPPORTED will be returned.
IVIDDEC2_FRAMEORDER_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDM IVIDENC Video Encoder Interface

XDM IVIDENC Video Encoder Interface

Data Structures

struct | IVIDENC_Obj
This must be the first field of all IVIDENC instance objects. More...
struct | IVIDENC_Params
Defines the creation time parameters for all IVIDENC instance objects. More...
struct | IVIDENC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDENC_InArgs
Defines the input arguments for all IVIDDEC instance process function. More...
struct | IVIDENC_Status
Defines instance status parameters (read-only). More...
struct | IVIDENC_OutArgs
Defines the run time output arguments for all IVIDENC instance objects. More...
struct | IVIDENC_Fxns
Defines all of the operations on IVIDENC objects. More...

Defines

#define | IVIDENC_CID "ti.xdais.dm.IVIDENC"
#define | IVIDENC_ERUNTIME XDM_ERUNTIME
#define | IVIDENC_EOK XDM_EOK
#define | IVIDENC_EFAIL XDM_EFAIL

Typedefs

typedef struct IVIDENC_Obj * | IVIDENC_Handle
Opaque handle to an IVIDENC objects.
typedef IALG_Cmd | IVIDENC_Cmd
Defines the control commands for the IVIDENC module.

Detailed Description

This is the XDM IVIDENC Video Encoder Interface.

Deprecated:
This XDM video encoder interface has been deprecated, and superceeded by newer IVIDENCx video encoder interfaces.

Define Documentation

#define IVIDENC_CID "ti.xdais.dm.IVIDENC"

IVIDENC Class ID

#define IVIDENC_ERUNTIME XDM_ERUNTIME

General runtime failure.

#define IVIDENC_EOK XDM_EOK

Success.

#define IVIDENC_EFAIL XDM_EFAIL

General failure.

Typedef Documentation

typedef struct IVIDENC_Obj* IVIDENC_Handle

Opaque handle to an IVIDENC objects.

typedef IALG_Cmd IVIDENC_Cmd

Defines the control commands for the IVIDENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDENC_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IVIDENC1 Video Encoder Interface

XDM IVIDENC1 Video Encoder Interface

Data Structures

struct | IVIDENC1_Obj
This must be the first field of all IVIDENC1 instance objects. More...
struct | IVIDENC1_Params
Defines the creation time parameters for all IVIDENC1 instance objects. More...
struct | IVIDENC1_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IVIDENC1_InArgs
Defines the input arguments for all IVIDENC1 instance process function. More...
struct | IVIDENC1_Status
Defines instance status parameters. More...
struct | IVIDENC1_OutArgs
Defines the run time output arguments for all IVIDENC1 instance objects. More...
struct | IVIDENC1_MbData
Defines the structure that contains macroblock related encoding parameter estimates. More...
struct | IVIDENC1_Fxns
Defines all of the operations on IVIDENC1 objects. More...

Defines

#define | IVIDENC1_EOK XDM_EOK
#define | IVIDENC1_EFAIL XDM_EFAIL
#define | IVIDENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IVIDENC1_Obj * | IVIDENC1_Handle
Opaque handle to an IVIDENC1 objects.
typedef IALG_Cmd | IVIDENC1_Cmd
Defines the control commands for the IVIDENC1 module.

Detailed Description

This is the XDM IVIDENC1 Video Encoder Interface.

Define Documentation

#define IVIDENC1_EOK XDM_EOK

Success.

#define IVIDENC1_EFAIL XDM_EFAIL

General failure.

#define IVIDENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

Typedef Documentation

typedef struct IVIDENC1_Obj* IVIDENC1_Handle

Opaque handle to an IVIDENC1 objects.

typedef IALG_Cmd IVIDENC1_Cmd

Defines the control commands for the IVIDENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDENC1_Fxns::control()


Codec Engine Application Programming Interface (API): XDM IVIDTRANSCODE Video Transcoder Interface

XDM IVIDTRANSCODE Video Transcoder Interface

Data Structures

struct | IVIDTRANSCODE_Obj
This must be the first field of all IVIDTRANSCODE instance objects. More...
struct | IVIDTRANSCODE_Params
Defines the creation time parameters for all IVIDTRANSCODE instance objects. More...
struct | IVIDTRANSCODE_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDTRANSCODE_InArgs
Defines the input arguments for all IVIDTRANSCODE instance process function. More...
struct | IVIDTRANSCODE_Status
Defines instance status parameters. More...
struct | IVIDTRANSCODE_OutArgs
Defines the run time output arguments for all IVIDTRANSCODE instance objects. More...
struct | IVIDTRANSCODE_Fxns
Defines all of the operations on IVIDTRANSCODE objects. More...

Defines

#define | IVIDTRANSCODE_EOK XDM_EOK
#define | IVIDTRANSCODE_EFAIL XDM_EFAIL
#define | IVIDTRANSCODE_EUNSUPPORTED XDM_EUNSUPPORTED
#define | IVIDTRANSCODE_MAXOUTSTREAMS 2

Typedefs

typedef struct IVIDTRANSCODE_Obj * | IVIDTRANSCODE_Handle
Opaque handle to an IVIDTRANSCODE objects.
typedef IALG_Cmd | IVIDTRANSCODE_Cmd
Defines the control commands for the IVIDTRANSCODE module.

Detailed Description

This is the XDM IVIDENC2 Video Transcoder Interface.

Define Documentation

#define IVIDTRANSCODE_EOK XDM_EOK

Success.

#define IVIDTRANSCODE_EFAIL XDM_EFAIL

General failure.

#define IVIDTRANSCODE_EUNSUPPORTED XDM_EUNSUPPORTED

Request is unsupported.

#define IVIDTRANSCODE_MAXOUTSTREAMS 2
Todo:
Document this.

Typedef Documentation

typedef struct IVIDTRANSCODE_Obj* IVIDTRANSCODE_Handle

Opaque handle to an IVIDTRANSCODE objects.

typedef IALG_Cmd IVIDTRANSCODE_Cmd

Defines the control commands for the IVIDTRANSCODE module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDTRANSCODE_Fxns::control()


Codec Engine Application Programming Interface (API): IALG - XDAIS Algorithm Interface

IALG - XDAIS Algorithm Interface

Data Structures

struct | IALG_MemRec
Memory records. More...
struct | IALG_Obj
Algorithm instance object definition. More...
struct | IALG_Params
Algorithm instance creation parameters. More...
struct | IALG_Status
Pointer to algorithm specific status structure. More...
struct | IALG_Fxns
Defines the fields and methods that must be supplied by all XDAIS algorithms. More...

Defines

#define | IALG_DEFMEMRECS 4
#define | IALG_OBJMEMREC 0
#define | IALG_SYSCMD 256
#define | IALG_EOK 0
#define | IALG_EFAIL -1
#define | IALG_CUSTOMFAILBASE -2048
#define | IALG_CUSTOMFAILEND -256
#define | IALG_MPROG 0x0008
#define | IALG_MXTRN 0x0010
#define | IALG_isProg(s)
#define | IALG_isOffChip(s)

Typedefs

typedef struct IALG_Obj * | IALG_Handle
Handle to an algorithm instance object.
typedef unsigned int | IALG_Cmd
Algorithm specific command.

Enumerations

enum IALG_MemAttrs {
IALG_SCRATCH,
IALG_PERSIST,
IALG_WRITEONCE
}

Memory attributes.

More...
enum IALG_MemSpace {
IALG_EPROG,
IALG_IPROG,
IALG_ESDATA,
IALG_EXTERNAL,
IALG_DARAM0 = 0,
IALG_DARAM1 = 1,
IALG_SARAM = 2,
IALG_SARAM0 = 2,
IALG_SARAM1 = 3,
IALG_DARAM2 = 4,
IALG_SARAM2 = 5
}

Defined memory spaces.

More...

Detailed Description

This is the XDAIS IALG interface.

Define Documentation

#define IALG_DEFMEMRECS 4

Default number of memory records.

#define IALG_OBJMEMREC 0

Memory record index of instance object.

#define IALG_SYSCMD 256

Minimum "system" IALG_Cmd value.

#define IALG_EOK 0

Successful return status code.

#define IALG_EFAIL -1

Unspecified error return status code.

#define IALG_CUSTOMFAILBASE -2048

Algorithm-specific failure code end.

Remarks:
This is 0xfffff800.
#define IALG_CUSTOMFAILEND -256

Algorithm-specific failure code base.

Remarks:
This is 0xffffff00.
#define IALG_MPROG 0x0008

Program memory space bit.

#define IALG_MXTRN 0x0010

External memory space bit.

#define IALG_isProg ( s )
Value:
(        \
    (((int)(s)) & IALG_MPROG)   \
)
#define IALG_isOffChip ( s )
Value:
(     \
    (((int)(s)) & IALG_MXTRN)   \
)

Typedef Documentation

typedef struct IALG_Obj* IALG_Handle

Handle to an algorithm instance object.

typedef unsigned int IALG_Cmd

Algorithm specific command.

Remarks:
This command is used in conjunction with IALG_Status to get and set algorithm specific attributes via the algControl() method.

Enumeration Type Documentation

enum IALG_MemAttrs

Memory attributes.

Enumerator:
IALG_SCRATCH

Scratch memory.

IALG_PERSIST

Persistent memory.

IALG_WRITEONCE

Write-once persistent memory.

enum IALG_MemSpace

Defined memory spaces.

Enumerator:
IALG_EPROG

External program memory

IALG_IPROG

Internal program memory

IALG_ESDATA

Off-chip data memory (accessed sequentially)

IALG_EXTERNAL

Off-chip data memory (accessed randomly)

IALG_DARAM0

Dual access on-chip data memory

IALG_DARAM1

Block 1, if independant blocks required

IALG_SARAM

Single access on-chip data memory

IALG_SARAM0

Block 0, equivalent to IALG_SARAM

IALG_SARAM1

Block 1, if independant blocks required

IALG_DARAM2

Block 2, if a 3rd independent block required

IALG_SARAM2

Block 2, if a 3rd independent block required


Codec Engine Application Programming Interface (API): LAD Communication Interfaces

LAD Communication Interfaces

Data Structures

struct | LAD_DspStatus

Defines

#define | LAD_MAXLENGTHIMAGENAME 512
#define | LAD_MAXLENGTHCONFIGNAME 32

Typedefs

typedef Uns | LAD_ClientHandle

Enumerations

enum LAD_Status {
LAD_SUCCESS = 0,
LAD_FAILURE,
LAD_INVALIDARG,
LAD_ACCESSDENIED,
LAD_ALREADYRUNNING,
LAD_STILLRUNNING,
LAD_IOFAILURE,
LAD_NOTCONNECTED,
LAD_INVALIDVERSION
}
enum LAD_DspState {
LAD_UNKNOWN = 0,
LAD_SETUP,
LAD_LOADED,
LAD_STARTED,
LAD_STOPPED,
LAD_IDLE,
LAD_RESET,
LAD_UNAVAILABLE
}

Functions

LAD_Status | LAD_connect (LAD_ClientHandle *handle)
Connect to LAD.
LAD_Status | LAD_disconnect (LAD_ClientHandle handle)
Disconnect from LAD.
LAD_Status | LAD_getDspStatus (LAD_ClientHandle handle, Int cpuId, LAD_DspStatus *statusInfo)
Get DSP status from LAD.
LAD_Status | LAD_releaseDsp (LAD_ClientHandle handle)
Release control of the DSP. This call is only appropriate if the client previously made a successful call to LAD_startupDsp().
LAD_Status | LAD_startupDsp (LAD_ClientHandle handle, Int cpuId, String linkConfigName, String imageName)
Load and start the DSP running.

Define Documentation

#define LAD_MAXLENGTHIMAGENAME 512

max size for DSP server path name

#define LAD_MAXLENGTHCONFIGNAME 32

max size Link config name

Typedef Documentation

typedef Uns LAD_ClientHandle

handle for communicating with LAD

Enumeration Type Documentation

enum LAD_Status
Enumerator:
LAD_SUCCESS

success

LAD_FAILURE

general failure

LAD_INVALIDARG

invalid argument

LAD_ACCESSDENIED

the request was denied

LAD_ALREADYRUNNING

success; DSP was already running

LAD_STILLRUNNING

success; DSP still running

LAD_IOFAILURE

communication failure

LAD_NOTCONNECTED

not connected to LAD yet

LAD_INVALIDVERSION

unsupported communication protocol

enum LAD_DspState
Enumerator:
LAD_UNKNOWN

state is unknown

LAD_SETUP

setup state

LAD_LOADED

loaded state

LAD_STARTED

running state

LAD_STOPPED

stopped state

LAD_IDLE

idle state

LAD_RESET

reset state

LAD_UNAVAILABLE

state is unavailable

Function Documentation

LAD_Status LAD_connect ( LAD_ClientHandle * handle )

Connect to LAD.

Parameters:
[out] handle The new client handle, as defined by LAD.
Return values:
LAD_SUCCESS | Success.
LAD_INVALIDARG | The handle pointer is NULL.
LAD_ACCESSDENIED | Returned on either of two conditions: this client is trying to establish a second active connection to LAD, and the request is denied; or, the total number of simultaneous client connections to LAD has been reached, and no more client handles are available.
LAD_IOFAILURE | Unable to communicate with LAD, due to an OS-level I/O failure. A full system reboot may be necessary.
LAD_INVALIDVERSION | Unable to communicate with LAD due to a mismatch in the communication protocol between the client and LAD.
See also:
LAD_disconnect().
LAD_Status LAD_disconnect ( LAD_ClientHandle handle )

Disconnect from LAD.

Parameters:
[in] handle The client handle, as returned from previous call to LAD_connect().
Return values:
LAD_SUCCESS | Success.
LAD_INVALIDARG | Invalid client handle.
LAD_NOTCONNECTED | Not currently connected to LAD.
LAD_STILLRUNNING | This client has previously started the DSP via a call to LAD_startupDsp, and must call LAD_releaseDsp before attempting to disconnect from LAD.
LAD_IOFAILURE | Unable to communicate with LAD, due to an OS-level I/O failure, or timeout. A full system reboot may be necessary.
See also:
LAD_connect().
LAD_Status LAD_getDspStatus | ( | LAD_ClientHandle | handle,
 |  | Int | cpuId,
 |  | LAD_DspStatus * | statusInfo
 | ) |  |

Get DSP status from LAD.

Parameters:
[in] | handle | The client handle, as returned from previous call to LAD_connect().
[in] | cpuId | The CPU for which status is to be returned.
[out] | statusInfo | The DSP status structure to be filled in by LAD.
Return values:
LAD_SUCCESS | Success.
LAD_INVALIDARG | Invalid handle or statusInfo pointer.
LAD_NOTCONNECTED | Not currently connected to LAD.
LAD_FAILURE | Failure occurred when querying DSP state.
LAD_IOFAILURE | Unable to communicate with LAD, due to an OS-level I/O failure. A full system reboot may be necessary.
See also:
LAD_connect().
LAD_Status LAD_releaseDsp ( LAD_ClientHandle handle )

Release control of the DSP. This call is only appropriate if the client previously made a successful call to LAD_startupDsp().

Parameters:
[in] handle The client handle, as returned from LAD_connect().
Return values:
LAD_SUCCESS | Success, the DSP has been stopped.
LAD_STILLRUNNING | Success, the DSP is continuing to run due to other client connection(s).
LAD_INVALIDARG | Invalid client handle.
LAD_NOTCONNECTED | Not currently connected to LAD.
LAD_ACCESSDENIED | This client not allowed to stop the DSP because it didn't successfully start it.
LAD_FAILURE | LAD was unable to stop and detach from the DSP.
LAD_IOFAILURE | Unable to communicate with LAD, due to an OS-level I/O failure. A full system reboot may be necessary.
See also:
LAD_startupDsp().
LAD_Status LAD_startupDsp | ( | LAD_ClientHandle | handle,
 |  | Int | cpuId,
 |  | String | linkConfigName,
 |  | String | imageName
 | ) |  |

Load and start the DSP running.

Parameters:
[in] | handle | The client handle, as returned from LAD_connect().
[in] | cpuId | The DSP to be loaded and started.
[in] | linkConfigName | The pre-defined Link configuration known to LAD.
[in] | imageName | The name to the DSP server executable. If an environment variable named "LAD_SERVERPATH" is defined, indicting a repository for server executable files, then this path will be pre-pended to the imageName to form the location of the DSP executable file; if "LAD_SERVERPATH" is not defined, then imageName will be considered to be the full path name of the DSP executable file.
Return values:
LAD_SUCCESS | Success, DSP has been started.
LAD_ALREADYRUNNING | Success, the DSP was already running with the same Link configuration and server executable.
LAD_INVALIDARG | Invalid client handle, cpuId, or linkConfigName.
LAD_NOTCONNECTED | Not currently connected to LAD.
LAD_ACCESSDENIED | LAD has refused the request because the DSP is already running, with a linkConfigName or imageName that does not match this request.
LAD_FAILURE | LAD is unable to start the DSP.
LAD_IOFAILURE | Unable to communicate with LAD, due to an OS-level I/O failure. A full system reboot may be necessary.
See also:
LAD_releaseDsp().


Codec Engine Application Programming Interface (API): AUDDEC Audio Decoder Interface

AUDDEC Audio Decoder Interface

Defines

#define | AUDDEC_EOK IAUDDEC_EOK
#define | AUDDEC_EFAIL IAUDDEC_EFAIL
#define | AUDDEC_ERUNTIME IAUDDEC_ERUNTIME
#define | AUDDEC_ETIMEOUT VISA_ETIMEOUT
#define | AUDDEC_FOREVER VISA_FOREVER

Typedefs

typedef IAUDDEC_Status | AUDDEC_Status
typedef VISA_Handle | AUDDEC_Handle
Opaque handle to a AUDDEC codec.
typedef struct IAUDDEC_Params | AUDDEC_Params
This structure defines the parameters necessary to create an instance of a IAUDDEC-compliant audio decoder.
typedef IAUDDEC_InArgs | AUDDEC_InArgs
typedef IAUDDEC_OutArgs | AUDDEC_OutArgs
typedef IAUDDEC_Cmd | AUDDEC_Cmd
typedef IAUDDEC_DynamicParams | AUDDEC_DynamicParams

Functions

AUDDEC_Handle | AUDDEC_create (Engine_Handle e, String name, AUDDEC_Params *params)
Create an instance of a audio decoder algorithm.
Int32 | AUDDEC_process (AUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs)
Execute the process() method in this instance of an audio decoder algorithm.
Int32 | AUDDEC_control (AUDDEC_Handle handle, AUDDEC_Cmd id, AUDDEC_DynamicParams *params, AUDDEC_Status *status)
Execute the control() method in this instance of an audio decoder algorithm.
Void | AUDDEC_delete (AUDDEC_Handle handle)
Delete the instance of an audio decoder algorithm.
XDAS_Int32 | AUDDEC_processAsync (AUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio decoder algorithm.
XDAS_Int32 | AUDDEC_processWait (AUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDDEC_processAsync() in this instance of an audio decoder algorithm.

Detailed Description

This is the AUDDEC audio decoder interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define AUDDEC_EOK IAUDDEC_EOK

Success.

#define AUDDEC_EFAIL IAUDDEC_EFAIL

General failure.

#define AUDDEC_ERUNTIME IAUDDEC_ERUNTIME

General runtime failure.

#define AUDDEC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define AUDDEC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IAUDDEC_Status AUDDEC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::control()

typedef VISA_Handle AUDDEC_Handle

Opaque handle to a AUDDEC codec.

typedef struct IAUDDEC_Params AUDDEC_Params

This structure defines the parameters necessary to create an instance of a IAUDDEC-compliant audio decoder.

typedef IAUDDEC_InArgs AUDDEC_InArgs

Defines the input arguments for all IAUDDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::process()

typedef IAUDDEC_OutArgs AUDDEC_OutArgs

Defines the run time output arguments for all IAUDDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::process()

typedef IAUDDEC_Cmd AUDDEC_Cmd

Defines the control commands for the IAUDDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDDEC_Fxns::control()

typedef IAUDDEC_DynamicParams AUDDEC_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::control()

Function Documentation

AUDDEC_Handle AUDDEC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | AUDDEC_Params * | params
 | ) |  |

Create an instance of a audio decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via AUDDEC_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of audio decoder. to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created audio decoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the audio decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
AUDDEC_delete()
Int32 AUDDEC_process | ( | AUDDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | AUDDEC_InArgs * | inArgs,
 |  | AUDDEC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of an audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC_EOK | Success.
AUDDEC_EFAIL | Failure.
AUDDEC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the AUDDEC decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to AUDDEC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDDEC_create()
AUDDEC_delete()
AUDDEC_control()
AUDDEC_processAsync()
AUDDEC_processWait()
IAUDDEC_Fxns::process()
Int32 AUDDEC_control | ( | AUDDEC_Handle | handle,
 |  | AUDDEC_Cmd | id,
 |  | AUDDEC_DynamicParams * | params,
 |  | AUDDEC_Status * | status
 | ) |  |

Execute the control() method in this instance of an audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC_EOK | Success.
AUDDEC_EFAIL | Failure.
AUDDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
AUDDEC_create()
AUDDEC_delete()
IAUDDEC_Fxns::control()
Void AUDDEC_delete ( AUDDEC_Handle handle )

Delete the instance of an audio decoder algorithm.

Parameters:
[in] handle Handle to a created audio decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the audio decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the AUDDEC_create() operation (memory, DMA channels, etc.) are freed.
See also:
AUDDEC_create()
XDAS_Int32 AUDDEC_processAsync | ( | AUDDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | AUDDEC_InArgs * | inArgs,
 |  | AUDDEC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC_EOK | Success.
AUDDEC_EFAIL | Failure.
AUDDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the AUDDEC_processWait() API.
The buffers supplied to AUDDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDDEC_create()
AUDDEC_delete()
AUDDEC_control()
AUDDEC_process()
AUDDEC_processWait()
IAUDDEC_Fxns::process()
XDAS_Int32 AUDDEC_processWait | ( | AUDDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | AUDDEC_InArgs * | inArgs,
 |  | AUDDEC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of AUDDEC_processAsync() in this instance of an audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> AUDDEC_FOREVER)
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC_EOK | Success.
AUDDEC_EFAIL | Failure.
AUDENC_ERUNTIME | Internal Runtime Error.
AUDDEC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of AUDDEC_EFOREVER.
There must have previously been an invocation of the AUDDEC_processAsync() API.
The buffers supplied to AUDDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDDEC_create()
AUDDEC_delete()
AUDDEC_control()
AUDDEC_process()
AUDDEC_processAsync()


Codec Engine Application Programming Interface (API): AUDENC Audio Encoder Interface

AUDENC Audio Encoder Interface

Defines

#define | AUDENC_EOK IAUDENC_EOK
#define | AUDENC_EFAIL IAUDENC_EFAIL
#define | AUDENC_ERUNTIME IAUDENC_ERUNTIME
#define | AUDENC_ETIMEOUT VISA_ETIMEOUT
#define | AUDENC_FOREVER VISA_FOREVER

Typedefs

typedef IAUDENC_Status | AUDENC_Status
typedef VISA_Handle | AUDENC_Handle
Opaque handle to a AUDENC codec.
typedef struct IAUDENC_Params | AUDENC_Params
This structure defines the parameters necessary to create an instance of a Audio Encoder object.
typedef IAUDENC_InArgs | AUDENC_InArgs
typedef IAUDENC_OutArgs | AUDENC_OutArgs
typedef IAUDENC_Cmd | AUDENC_Cmd
typedef IAUDENC_DynamicParams | AUDENC_DynamicParams

Functions

AUDENC_Handle | AUDENC_create (Engine_Handle e, String name, AUDENC_Params *params)
Create an instance of an audio encoder algorithm.
Int32 | AUDENC_process (AUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDENC_InArgs *inArgs, AUDENC_OutArgs *outArgs)
Execute the process() method in this instance of an audio encoder algorithm.
Int32 | AUDENC_control (AUDENC_Handle handle, AUDENC_Cmd id, AUDENC_DynamicParams *params, AUDENC_Status *status)
Execute the control() method in this instance of an audio encoder algorithm.
Void | AUDENC_delete (AUDENC_Handle handle)
Delete the instance of an audio encoder algorithm.
XDAS_Int32 | AUDENC_processAsync (AUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio encoder algorithm.
XDAS_Int32 | AUDENC_processWait (AUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDENC_processAsync() in this instance of an audio encoder algorithm.

Detailed Description

This is the AUDENC audio encoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define AUDENC_EOK IAUDENC_EOK

Success.

#define AUDENC_EFAIL IAUDENC_EFAIL

General failure.

#define AUDENC_ERUNTIME IAUDENC_ERUNTIME

General runtime failure.

#define AUDENC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define AUDENC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IAUDENC_Status AUDENC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::control()

typedef VISA_Handle AUDENC_Handle

Opaque handle to a AUDENC codec.

typedef struct IAUDENC_Params AUDENC_Params

This structure defines the parameters necessary to create an instance of a Audio Encoder object.

typedef IAUDENC_InArgs AUDENC_InArgs

Defines the input arguments for all IAUDENC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::process()

typedef IAUDENC_OutArgs AUDENC_OutArgs

Defines the run time output arguments for all IAUDENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::process()

typedef IAUDENC_Cmd AUDENC_Cmd

Defines the control commands for the IAUDENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDENC_Fxns::control()

typedef IAUDENC_DynamicParams AUDENC_DynamicParams

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::control()

Function Documentation

AUDENC_Handle AUDENC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | AUDENC_Params * | params
 | ) |  |

Create an instance of an audio encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via AUDENC_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of audio encoder. to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created audio encoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the audio encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
AUDENC_delete()
Int32 AUDENC_process | ( | AUDENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | AUDENC_InArgs * | inArgs,
 |  | AUDENC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of an audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC_EOK | Success.
AUDENC_EFAIL | Failure.
AUDENC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the AUDENC encoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to AUDENC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
If an error is returned, outArgs->extendedError may indicate further details about the error. See AUDENC_OutArgs::extendedError for details.
See also:
AUDENC_create()
AUDENC_delete()
AUDENC_control()
AUDENC_processAsync()
AUDENC_processWait()
IAUDENC_Fxns::process() - the reflected algorithm interface, which may contain further usage details.
Int32 AUDENC_control | ( | AUDENC_Handle | handle,
 |  | AUDENC_Cmd | id,
 |  | AUDENC_DynamicParams * | params,
 |  | AUDENC_Status * | status
 | ) |  |

Execute the control() method in this instance of an audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC_EOK | Success.
AUDENC_EFAIL | Failure.
AUDENC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
If an error is returned, status->extendedError may indicate further details about the error. See AUDDEC_Status::extendedError for details.
See also:
AUDENC_create()
AUDENC_delete()
IAUDENC_Fxns::control() - the reflected algorithm interface, which may contain further usage details.
Void AUDENC_delete ( AUDENC_Handle handle )

Delete the instance of an audio encoder algorithm.

Parameters:
[in] handle Handle to a created audio encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the audio encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the AUDENC_create() operation (memory, DMA channels, etc.) are freed.
See also:
AUDENC_create()
XDAS_Int32 AUDENC_processAsync | ( | AUDENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IAUDENC_InArgs * | inArgs,
 |  | IAUDENC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC_EOK | Success.
AUDENC_EFAIL | Failure.
AUDENC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the AUDENC_processWait() API.
The buffers supplied to AUDENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDENC_create()
AUDENC_delete()
AUDENC_control()
AUDENC_process()
AUDENC_processWait()
IAUDENC_Fxns::process()
IAUDENC_Fxns::process() - the reflected algorithm interface, which may contain further usage details.
XDAS_Int32 AUDENC_processWait | ( | AUDENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IAUDENC_InArgs * | inArgs,
 |  | IAUDENC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of AUDENC_processAsync() in this instance of an audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> AUDENC_FOREVER)
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC_EOK | Success.
AUDENC_EFAIL | Failure.
AUDENC_ERUNTIME | Internal Runtime Error.
AUDENC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of AUDENC_EFOREVER.
There must have previously been an invocation of the AUDENC_processAsync() API.
The buffers supplied to AUDENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDENC_create()
AUDENC_delete()
AUDENC_control()
AUDENC_process()
AUDENC_processAsync()


Codec Engine Application Programming Interface (API): AUDDEC1 Audio Decoder Interface

AUDDEC1 Audio Decoder Interface

Defines

#define | AUDDEC1_EOK IAUDDEC1_EOK
#define | AUDDEC1_EFAIL IAUDDEC1_EFAIL
#define | AUDDEC1_EUNSUPPORTED IAUDDEC1_EUNSUPPORTED
#define | AUDDEC1_ETIMEOUT VISA_ETIMEOUT
#define | AUDDEC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | AUDDEC1_Handle
Opaque handle to a AUDDEC1 codec.
typedef struct IAUDDEC1_Params | AUDDEC1_Params
This structure defines the parameters necessary to create an instance of an audio decoder object.
typedef IAUDDEC1_InArgs | AUDDEC1_InArgs
typedef IAUDDEC1_OutArgs | AUDDEC1_OutArgs
typedef IAUDDEC1_Cmd | AUDDEC1_Cmd
typedef IAUDDEC1_Status | AUDDEC1_Status
typedef IAUDDEC1_DynamicParams | AUDDEC1_DynamicParams

Functions

Int32 | AUDDEC1_control (AUDDEC1_Handle handle, AUDDEC1_Cmd id, AUDDEC1_DynamicParams *params, AUDDEC1_Status *status)
Execute the control() method in this instance of an audio1 decoder algorithm.
AUDDEC1_Handle | AUDDEC1_create (Engine_Handle e, String name, AUDDEC1_Params *params)
Create an instance of an audio decoder algorithm.
Void | AUDDEC1_delete (AUDDEC1_Handle handle)
Delete the instance of an audio decoder algorithm.
Int32 | AUDDEC1_process (AUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs)
Execute the process() method in this instance of a audio decoder algorithm.
Int32 | AUDDEC1_processAsync (AUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio decoder algorithm.
Int32 | AUDDEC1_processWait (AUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDDEC1_processAsync() in this instance of an audio decoder algorithm.

Detailed Description

This is the AUDDEC1 audio decoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define AUDDEC1_EOK IAUDDEC1_EOK

Success.

#define AUDDEC1_EFAIL IAUDDEC1_EFAIL

General failure.

#define AUDDEC1_EUNSUPPORTED IAUDDEC1_EUNSUPPORTED

Request is unsupported.

#define AUDDEC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define AUDDEC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle AUDDEC1_Handle

Opaque handle to a AUDDEC1 codec.

typedef struct IAUDDEC1_Params AUDDEC1_Params

This structure defines the parameters necessary to create an instance of an audio decoder object.

typedef IAUDDEC1_InArgs AUDDEC1_InArgs

Defines the input arguments for all IAUDDEC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::process()

typedef IAUDDEC1_OutArgs AUDDEC1_OutArgs

Defines the run time output arguments for all IAUDDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::process()

typedef IAUDDEC1_Cmd AUDDEC1_Cmd

Defines the control commands for the IAUDDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDDEC1_Fxns::control()

typedef IAUDDEC1_Status AUDDEC1_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::control()

typedef IAUDDEC1_DynamicParams AUDDEC1_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::control()

Function Documentation

Int32 AUDDEC1_control | ( | AUDDEC1_Handle | handle,
 |  | AUDDEC1_Cmd | id,
 |  | AUDDEC1_DynamicParams * | params,
 |  | AUDDEC1_Status * | status
 | ) |  |

Execute the control() method in this instance of an audio1 decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC1_EOK | Success.
AUDDEC1_EFAIL | Failure.
AUDDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
AUDDEC1_create()
AUDDEC1_delete()
IAUDDEC1_Fxns()control()
AUDDEC1_Handle AUDDEC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | AUDDEC1_Params * | params
 | ) |  |

Create an instance of an audio decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via AUDDEC1_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of audio decoder. to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created audio decoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the audio decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
AUDDEC1_delete()
Void AUDDEC1_delete ( AUDDEC1_Handle handle )

Delete the instance of an audio decoder algorithm.

Parameters:
[in] handle Handle to a created audio decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the audio decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the AUDDEC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
AUDDEC1_create()
Int32 AUDDEC1_process | ( | AUDDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | AUDDEC1_InArgs * | inArgs,
 |  | AUDDEC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC1_EOK | Success.
AUDDEC1_EFAIL | Failure.
AUDDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
Since the AUDDEC1 decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to AUDDEC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDDEC1_create()
AUDDEC1_delete()
AUDDEC1_control()
AUDDEC1_processAsync()
AUDDEC1_processWait()
IAUDDEC1_Fxns::process()
Int32 AUDDEC1_processAsync | ( | AUDDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | AUDDEC1_InArgs * | inArgs,
 |  | AUDDEC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC1_EOK | Success.
AUDDEC1_EFAIL | Failure.
AUDDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the AUDDEC1_processWait() API.
The buffers supplied to AUDDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDDEC1_create()
AUDDEC1_delete()
AUDDEC1_control()
AUDDEC1_process()
AUDDEC1_processWait()
IAUDDEC1_Fxns::process()
Int32 AUDDEC1_processWait | ( | AUDDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | AUDDEC1_InArgs * | inArgs,
 |  | AUDDEC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of AUDDEC1_processAsync() in this instance of an audio decoder algorithm.

Parameters:
[in] | handle | Handle to a created audio decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> AUDDEC1_FOREVER)
Precondition:
handle is a valid (non-NULL) audio decoder handle and the audio decoder is in the created state.
Return values:
AUDDEC1_EOK | Success.
AUDDEC1_EFAIL | Failure.
AUDDEC1_EUNSUPPORTED | Unsupported request.
AUDDEC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of AUDDEC1_EFOREVER.
There must have previously been an invocation of the AUDDEC1_processAsync() API.
The buffers supplied to AUDDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDDEC1_create()
AUDDEC1_delete()
AUDDEC1_control()
AUDDEC1_process()
AUDDEC1_processAsync()


Codec Engine Application Programming Interface (API): AUDENC1 Audio Encoder Interface

AUDENC1 Audio Encoder Interface

Defines

#define | AUDENC1_EOK IAUDENC1_EOK
#define | AUDENC1_EFAIL IAUDENC1_EFAIL
#define | AUDENC1_EUNSUPPORTED IAUDENC1_EUNSUPPORTED
#define | AUDENC1_ETIMEOUT VISA_ETIMEOUT
#define | AUDENC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | AUDENC1_Handle
Opaque handle to a AUDENC1 codec.
typedef struct IAUDENC1_Params | AUDENC1_Params
This structure defines the parameters necessary to create an instance of an audio encoder.
typedef IAUDENC1_InArgs | AUDENC1_InArgs
typedef IAUDENC1_OutArgs | AUDENC1_OutArgs
typedef IAUDENC1_Cmd | AUDENC1_Cmd
typedef IAUDENC1_Status | AUDENC1_Status
typedef IAUDENC1_DynamicParams | AUDENC1_DynamicParams

Functions

Int32 | AUDENC1_control (AUDENC1_Handle handle, AUDENC1_Cmd id, AUDENC1_DynamicParams *params, AUDENC1_Status *status)
Execute the control() method in this instance of an audio encoder algorithm.
AUDENC1_Handle | AUDENC1_create (Engine_Handle e, String name, AUDENC1_Params *params)
Create an instance of an audio encoder algorithm.
Void | AUDENC1_delete (AUDENC1_Handle handle)
Delete the instance of a audio encoder algorithm.
Int32 | AUDENC1_process (AUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs)
Execute the process() method in this instance of a audio encoder algorithm.
Int32 | AUDENC1_processAsync (AUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio encoder algorithm.
Int32 | AUDENC1_processWait (AUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDENC1_processAsync() in this instance of an audio encoder algorithm.

Detailed Description

This is the AUDENC1 audio encoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define AUDENC1_EOK IAUDENC1_EOK

Success.

#define AUDENC1_EFAIL IAUDENC1_EFAIL

General failure.

#define AUDENC1_EUNSUPPORTED IAUDENC1_EUNSUPPORTED

Request is unsupported.

#define AUDENC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define AUDENC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle AUDENC1_Handle

Opaque handle to a AUDENC1 codec.

typedef struct IAUDENC1_Params AUDENC1_Params

This structure defines the parameters necessary to create an instance of an audio encoder.

typedef IAUDENC1_InArgs AUDENC1_InArgs

Defines the input arguments for all IAUDENC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::process()

typedef IAUDENC1_OutArgs AUDENC1_OutArgs

Defines the run time output arguments for all IAUDENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::process()

typedef IAUDENC1_Cmd AUDENC1_Cmd

Defines the control commands for the IAUDENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IAUDENC1_Fxns::control()

typedef IAUDENC1_Status AUDENC1_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::control()

typedef IAUDENC1_DynamicParams AUDENC1_DynamicParams

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::control()

Function Documentation

Int32 AUDENC1_control | ( | AUDENC1_Handle | handle,
 |  | AUDENC1_Cmd | id,
 |  | AUDENC1_DynamicParams * | params,
 |  | AUDENC1_Status * | status
 | ) |  |

Execute the control() method in this instance of an audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC1_EOK | Success.
AUDENC1_EFAIL | Failure.
AUDENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
AUDENC1_create()
AUDENC1_delete()
IAUDENC1_Fxns::control()
AUDENC1_Handle AUDENC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | AUDENC1_Params * | params
 | ) |  |

Create an instance of an audio encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via AUDENC1_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of audio encoder. to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created audio encoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the audio encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
AUDENC1_delete()
Void AUDENC1_delete ( AUDENC1_Handle handle )

Delete the instance of a audio encoder algorithm.

Parameters:
[in] handle Handle to a created audio encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the audio encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the AUDENC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
AUDENC1_create()
Int32 AUDENC1_process | ( | AUDENC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | AUDENC1_InArgs * | inArgs,
 |  | AUDENC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC1_EOK | Success.
AUDENC1_EFAIL | Failure.
AUDENC1_EUNSUPPORTED | Unsupported request.
Remarks:
Since the AUDENC1 encoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to AUDENC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDENC1_create()
AUDENC1_delete()
AUDENC1_control()
AUDENC1_processAsync()
AUDENC1_processWait()
IAUDENC1_Fxns::process()
Int32 AUDENC1_processAsync | ( | AUDENC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | AUDENC1_InArgs * | inArgs,
 |  | AUDENC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC1_EOK | Success.
AUDENC1_EFAIL | Failure.
AUDENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the AUDENC1_processWait() API.
The buffers supplied to AUDENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDENC1_create()
AUDENC1_delete()
AUDENC1_control()
AUDENC1_process()
AUDENC1_processWait()
IAUDENC1_Fxns::process()
Int32 AUDENC1_processWait | ( | AUDENC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | AUDENC1_InArgs * | inArgs,
 |  | AUDENC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of AUDENC1_processAsync() in this instance of an audio encoder algorithm.

Parameters:
[in] | handle | Handle to a created audio encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> AUDENC1_FOREVER)
Precondition:
handle is a valid (non-NULL) audio encoder handle and the audio encoder is in the created state.
Return values:
AUDENC1_EOK | Success.
AUDENC1_EFAIL | Failure.
AUDENC1_EUNSUPPORTED | Unsupported request.
AUDENC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of AUDENC1_EFOREVER.
There must have previously been an invocation of the AUDENC1_processAsync() API.
The buffers supplied to AUDENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
AUDENC1_create()
AUDENC1_delete()
AUDENC1_control()
AUDENC1_process()
AUDENC1_processAsync()


Codec Engine Application Programming Interface (API): IMGDEC Image Decoder Interface

IMGDEC Image Decoder Interface

Data Structures

struct | IIMGDEC_CodecClassConfig
Definition of IIMGDEC codec class configurable parameters. More...

Defines

#define | IMGDEC_EOK IIMGDEC_EOK
#define | IMGDEC_EFAIL IIMGDEC_EFAIL
#define | IMGDEC_ERUNTIME IIMGDEC_ERUNTIME
#define | IMGDEC_ETIMEOUT VISA_ETIMEOUT
#define | IMGDEC_FOREVER VISA_FOREVER

Typedefs

typedef IIMGDEC_Status | IMGDEC_Status
typedef VISA_Handle | IMGDEC_Handle
Opaque handle to a IMGDEC codec.
typedef struct IIMGDEC_Params | IMGDEC_Params
This structure defines the parameters necessary to create an instance of a image decoder object.
typedef IIMGDEC_InArgs | IMGDEC_InArgs
typedef IIMGDEC_OutArgs | IMGDEC_OutArgs
typedef IIMGDEC_Cmd | IMGDEC_Cmd
typedef IIMGDEC_DynamicParams | IMGDEC_DynamicParams

Functions

IMGDEC_Handle | IMGDEC_create (Engine_Handle e, String name, IMGDEC_Params *params)
Create an instance of an image decoder algorithm.
Int32 | IMGDEC_process (IMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs)
Execute the process() method in this instance of a image decoder algorithm.
Int32 | IMGDEC_control (IMGDEC_Handle handle, IMGDEC_Cmd id, IMGDEC_DynamicParams *params, IMGDEC_Status *status)
Execute the control() method in this instance of an image decoder algorithm.
Void | IMGDEC_delete (IMGDEC_Handle handle)
Delete the instance of a image decoder algorithm.
XDAS_Int32 | IMGDEC_processAsync (IMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of an image decoder algorithm.
XDAS_Int32 | IMGDEC_processWait (IMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGDEC_processAsync() in this instance of an image decoder algorithm.

Detailed Description

This is the IMGDEC image decoder interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define IMGDEC_EOK IIMGDEC_EOK

Success.

#define IMGDEC_EFAIL IIMGDEC_EFAIL

General failure.

#define IMGDEC_ERUNTIME IIMGDEC_ERUNTIME

General runtime failure.

#define IMGDEC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define IMGDEC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IIMGDEC_Status IMGDEC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC_Fxns::control()

typedef VISA_Handle IMGDEC_Handle

Opaque handle to a IMGDEC codec.

typedef struct IIMGDEC_Params IMGDEC_Params

This structure defines the parameters necessary to create an instance of a image decoder object.

typedef IIMGDEC_InArgs IMGDEC_InArgs

Defines the input arguments for all IIMGDEC instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC_Fxns::process()

typedef IIMGDEC_OutArgs IMGDEC_OutArgs

Defines the run time output arguments for all IIMGDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::process()

typedef IIMGDEC_Cmd IMGDEC_Cmd

Defines the control commands for the IIMGDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGDEC_Fxns::control()

typedef IIMGDEC_DynamicParams IMGDEC_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC_Fxns::control()

Function Documentation

IMGDEC_Handle IMGDEC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | IMGDEC_Params * | params
 | ) |  |

Create an instance of an image decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via IMGDEC_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of image decoder. to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created image decoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the image decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
IMGDEC_delete()
Int32 IMGDEC_process | ( | IMGDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IMGDEC_InArgs * | inArgs,
 |  | IMGDEC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC_EOK | Success.
IMGDEC_EFAIL | Failure.
IMGDEC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the IMGDEC decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to IMGDEC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
If an error is returned, outArgs->extendedError may indicate further details about the error. See IMGDEC_OutArgs::extendedError for details.
See also:
IMGDEC_create()
IMGDEC_delete()
IMGDEC_control()
IMGDEC_processAsync()
IMGDEC_processWait()
IIMGDEC_Fxns::process() - the reflected algorithm interface, which may contain further usage details.
Int32 IMGDEC_control | ( | IMGDEC_Handle | handle,
 |  | IMGDEC_Cmd | id,
 |  | IMGDEC_DynamicParams * | params,
 |  | IMGDEC_Status * | status
 | ) |  |

Execute the control() method in this instance of an image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC_EOK | Success.
IMGDEC_EFAIL | Failure.
IMGDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
If an error is returned, status->extendedError may indicate further details about the error. See IMGDEC_Status::extendedError for details.
See also:
IMGDEC_create()
IMGDEC_delete()
IIMGDEC_Fxns::control()
Void IMGDEC_delete ( IMGDEC_Handle handle )

Delete the instance of a image decoder algorithm.

Parameters:
[in] handle Handle to a created image decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the image decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the IMGDEC_create() operation (memory, DMA channels, etc.) are freed.
See also:
IMGDEC_create()
XDAS_Int32 IMGDEC_processAsync | ( | IMGDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IMGDEC_InArgs * | inArgs,
 |  | IMGDEC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of an image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC_EOK | Success.
IMGDEC_EFAIL | Failure.
IMGDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the IMGDEC_processWait() API.
The buffers supplied to IMGDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGDEC_create()
IMGDEC_delete()
IMGDEC_control()
IMGDEC_process()
IMGDEC_processWait()
IIMGDEC_Fxns::process()
XDAS_Int32 IMGDEC_processWait | ( | IMGDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IMGDEC_InArgs * | inArgs,
 |  | IMGDEC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of IMGDEC_processAsync() in this instance of an image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> IMGDEC_FOREVER)
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC_EOK | Success.
IMGDEC_EFAIL | Failure.
IMGDEC_ERUNTIME | Internal Runtime Error.
IMGDEC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of IMGDEC_EFOREVER.
There must have previously been an invocation of the IMGDEC_processAsync() API.
The buffers supplied to IMGDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGDEC_create()
IMGDEC_delete()
IMGDEC_control()
IMGDEC_process()
IMGDEC_processAsync()


Codec Engine Application Programming Interface (API): IMGENC Image Encoder Interface

IMGENC Image Encoder Interface

Data Structures

struct | IIMGENC_CodecClassConfig
Definition of IIMGENC codec class configurable parameters. More...

Defines

#define | IMGENC_EOK IIMGENC_EOK
#define | IMGENC_EFAIL IIMGENC_EFAIL
#define | IMGENC_ERUNTIME IIMGENC_ERUNTIME
#define | IMGENC_ETIMEOUT VISA_ETIMEOUT
#define | IMGENC_FOREVER VISA_FOREVER

Typedefs

typedef IIMGENC_Status | IMGENC_Status
typedef VISA_Handle | IMGENC_Handle
Opaque handle to a IMGENC codec.
typedef struct IIMGENC_Params | IMGENC_Params
This structure defines the parameters necessary to create an instance of an image encoder object.
typedef IIMGENC_InArgs | IMGENC_InArgs
typedef IIMGENC_OutArgs | IMGENC_OutArgs
typedef IIMGENC_Cmd | IMGENC_Cmd
typedef IIMGENC_DynamicParams | IMGENC_DynamicParams

Functions

IMGENC_Handle | IMGENC_create (Engine_Handle e, String name, IMGENC_Params *params)
Create an instance of an image encoder algorithm.
Int32 | IMGENC_process (IMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGENC_InArgs *inArgs, IMGENC_OutArgs *outArgs)
Execute the process() method in this instance of an image encoder algorithm.
Int32 | IMGENC_control (IMGENC_Handle handle, IMGENC_Cmd id, IMGENC_DynamicParams *params, IMGENC_Status *status)
Execute the control() method in this instance of an image encoder algorithm.
Void | IMGENC_delete (IMGENC_Handle handle)
Delete the instance of an image encoder algorithm.
XDAS_Int32 | IMGENC_processAsync (IMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of an image encoder algorithm.
XDAS_Int32 | IMGENC_processWait (IMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGENC_processAsync() in this instance of an image encoder algorithm.

Detailed Description

This is the IMGENC image encoder interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define IMGENC_EOK IIMGENC_EOK

Success.

#define IMGENC_EFAIL IIMGENC_EFAIL

General failure.

#define IMGENC_ERUNTIME IIMGENC_ERUNTIME

General runtime failure.

#define IMGENC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define IMGENC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IIMGENC_Status IMGENC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::control()

typedef VISA_Handle IMGENC_Handle

Opaque handle to a IMGENC codec.

typedef struct IIMGENC_Params IMGENC_Params

This structure defines the parameters necessary to create an instance of an image encoder object.

typedef IIMGENC_InArgs IMGENC_InArgs

Defines the input arguments for all IIMGENC instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::process()

typedef IIMGENC_OutArgs IMGENC_OutArgs

Defines the run time output arguments for all IIMGENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::process()

typedef IIMGENC_Cmd IMGENC_Cmd

Defines the control commands for the IIMGENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGENC_Fxns::control()

typedef IIMGENC_DynamicParams IMGENC_DynamicParams

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::control()

Function Documentation

IMGENC_Handle IMGENC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | IMGENC_Params * | params
 | ) |  |

Create an instance of an image encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via IMGENC_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of image encoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created image encoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the image encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
IMGENC_delete()
Int32 IMGENC_process | ( | IMGENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IMGENC_InArgs * | inArgs,
 |  | IMGENC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC_EOK | Success.
IMGENC_EFAIL | Failure.
IMGENC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the IMGENC encoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to IMGENC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
If an error is returned, outArgs->extendedError may indicate further details about the error. See IMGENC_OutArgs::extendedError for details.
See also:
IMGENC_create()
IMGENC_delete()
IMGENC_control()
IMGENC_processAsync()
IMGENC_processWait()
IIMGENC_Fxns::process() - the reflected algorithm interface, which may contain further usage details.
Int32 IMGENC_control | ( | IMGENC_Handle | handle,
 |  | IMGENC_Cmd | id,
 |  | IMGENC_DynamicParams * | params,
 |  | IMGENC_Status * | status
 | ) |  |

Execute the control() method in this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC_EOK | Success.
IMGENC_EFAIL | Failure.
IMGENC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
If an error is returned, status->extendedError may indicate further details about the error. See IMGENC_Status::extendedError for details.
See also:
IMGENC_create()
IMGENC_delete()
IIMGENC_Fxns::control() - the reflected algorithm interface, which may contain further usage details.
Void IMGENC_delete ( IMGENC_Handle handle )

Delete the instance of an image encoder algorithm.

Parameters:
[in] handle Handle to a created image encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the image encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the IMGENC_create() operation (memory, DMA channels, etc.) are freed.
See also:
IMGENC_create()
XDAS_Int32 IMGENC_processAsync | ( | IMGENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IIMGENC_InArgs * | inArgs,
 |  | IIMGENC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC_EOK | Success.
IMGENC_EFAIL | Failure.
IMGENC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the IMGENC_processWait() API.
The buffers supplied to IMGENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGENC_create()
IMGENC_delete()
IMGENC_control()
IMGENC_process()
IMGENC_processWait()
IIMGENC_Fxns::process() - the reflected algorithm interface, which may contain further usage details.
XDAS_Int32 IMGENC_processWait | ( | IMGENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IIMGENC_InArgs * | inArgs,
 |  | IIMGENC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of IMGENC_processAsync() in this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> IMGENC_FOREVER)
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC_EOK | Success.
IMGENC_EFAIL | Failure.
IMGENC_ERUNTIME | Internal Runtime Error.
IMGENC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of IMGENC_EFOREVER.
There must have previously been an invocation of the IMGENC_processAsync() API.
The buffers supplied to IMGENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGENC_create()
IMGENC_delete()
IMGENC_control()
IMGENC_process()
IMGENC_processAsync()


Codec Engine Application Programming Interface (API): Image decoder codec interface

Image decoder codec interface

Data Structures

struct | IIMGDEC1_CodecClassConfig
Definition of IIMGDEC1 codec class configurable parameters. More...

Defines

#define | IMGDEC1_EOK IIMGDEC1_EOK
#define | IMGDEC1_EFAIL IIMGDEC1_EFAIL
#define | IMGDEC1_EUNSUPPORTED IIMGDEC1_EUNSUPPORTED
#define | IMGDEC1_ETIMEOUT VISA_ETIMEOUT
#define | IMGDEC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | IMGDEC1_Handle
Opaque handle to a IMGDEC1 codec.
typedef IIMGDEC1_Params | IMGDEC1_Params
typedef IIMGDEC1_InArgs | IMGDEC1_InArgs
typedef IIMGDEC1_OutArgs | IMGDEC1_OutArgs
typedef IIMGDEC1_Cmd | IMGDEC1_Cmd
typedef IIMGDEC1_DynamicParams | IMGDEC1_DynamicParams
typedef IIMGDEC1_Status | IMGDEC1_Status

Functions

Int32 | IMGDEC1_control (IMGDEC1_Handle handle, IMGDEC1_Cmd id, IMGDEC1_DynamicParams *params, IMGDEC1_Status *status)
Execute the control() method in this instance of an image decoder algorithm.
IMGDEC1_Handle | IMGDEC1_create (Engine_Handle e, String name, IMGDEC1_Params *params)
Create an instance of an image decoder algorithm.
Void | IMGDEC1_delete (IMGDEC1_Handle handle)
Delete the instance of an image decoder algorithm.
Int32 | IMGDEC1_process (IMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs)
Execute the process() method in this instance of an image decoder algorithm.
XDAS_Int32 | IMGDEC1_processAsync (IMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a image decoder algorithm.
XDAS_Int32 | IMGDEC1_processWait (IMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGDEC1_processAsync() in this instance of an image decoder algorithm.

Detailed Description

This is the IMGDEC1 image decoder codec interface. Several of the data types in this API are specified by the XDM IIMGDEC1 interface; please see the XDM documentation for those details.

Define Documentation

#define IMGDEC1_EOK IIMGDEC1_EOK

Success.

#define IMGDEC1_EFAIL IIMGDEC1_EFAIL

General failure.

#define IMGDEC1_EUNSUPPORTED IIMGDEC1_EUNSUPPORTED

Request is unsupported.

#define IMGDEC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define IMGDEC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle IMGDEC1_Handle

Opaque handle to a IMGDEC1 codec.

typedef IIMGDEC1_Params IMGDEC1_Params

Defines the creation time parameters for all IIMGDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

typedef IIMGDEC1_InArgs IMGDEC1_InArgs

Defines the input arguments for all IIMGDEC1 instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::process()

typedef IIMGDEC1_OutArgs IMGDEC1_OutArgs

Defines the run time output arguments for all IIMGDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::process()

typedef IIMGDEC1_Cmd IMGDEC1_Cmd

Defines the control commands for the IIMGDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGDEC1_Fxns::control()

typedef IIMGDEC1_DynamicParams IMGDEC1_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::control()

typedef IIMGDEC1_Status IMGDEC1_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::control()

Function Documentation

Int32 IMGDEC1_control | ( | IMGDEC1_Handle | handle,
 |  | IMGDEC1_Cmd | id,
 |  | IMGDEC1_DynamicParams * | params,
 |  | IMGDEC1_Status * | status
 | ) |  |

Execute the control() method in this instance of an image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC1_EOK | Success.
IMGDEC1_EFAIL | Failure.
IMGDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
IMGDEC1_create()
IMGDEC1_delete()
IIMGDEC1_Fxns()control()
IMGDEC1_Handle IMGDEC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | IMGDEC1_Params * | params
 | ) |  |

Create an instance of an image decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via IMGDEC1_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of image decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created image decoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the image decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
IMGDEC1_delete()
Void IMGDEC1_delete ( IMGDEC1_Handle handle )

Delete the instance of an image decoder algorithm.

Parameters:
[in] handle Handle to a created image decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the image decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the IMGDEC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
IMGDEC1_create()
Int32 IMGDEC1_process | ( | IMGDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IMGDEC1_InArgs * | inArgs,
 |  | IMGDEC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of an image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC1_EOK | Success.
IMGDEC1_EFAIL | Failure.
IMGDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
Since the IMGDEC1 decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to IMGDEC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGDEC1_create()
IMGDEC1_delete()
IMGDEC1_control()
IMGDEC1_processAsync()
IMGDEC1_processWait()
IIMGDEC1_Fxns()process()
XDAS_Int32 IMGDEC1_processAsync | ( | IMGDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IMGDEC1_InArgs * | inArgs,
 |  | IMGDEC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC1_EOK | Success.
IMGDEC1_EFAIL | Failure.
IMGDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the IMGDEC1_processWait() API.
The buffers supplied to IMGDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGDEC1_create()
IMGDEC1_delete()
IMGDEC1_control()
IMGDEC1_process()
IMGDEC1_processWait()
IIMGDEC1_Fxns::process()
XDAS_Int32 IMGDEC1_processWait | ( | IMGDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IMGDEC1_InArgs * | inArgs,
 |  | IMGDEC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of IMGDEC1_processAsync() in this instance of an image decoder algorithm.

Parameters:
[in] | handle | Handle to a created image decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> IMGDEC1_FOREVER)
Precondition:
handle is a valid (non-NULL) image decoder handle and the image decoder is in the created state.
Return values:
IMGDEC1_EOK | Success.
IMGDEC1_EFAIL | Failure.
IMGDEC1_EUNSUPPORTED | Unsupported request.
IMGDEC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of IMGDEC1_EFOREVER.
There must have previously been an invocation of the IMGDEC1_processAsync() API.
The buffers supplied to IMGDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGDEC1_create()
IMGDEC1_delete()
IMGDEC1_control()
IMGDEC1_process()
IMGDEC1_processAsync()


Codec Engine Application Programming Interface (API): Image encoder codec interface

Image encoder codec interface

Data Structures

struct | IIMGENC1_CodecClassConfig
Definition of IIMGENC1 codec class configurable parameters. More...

Defines

#define | IMGENC1_EOK IIMGENC1_EOK
#define | IMGENC1_EFAIL IIMGENC1_EFAIL
#define | IMGENC1_EUNSUPPORTED IIMGENC1_EUNSUPPORTED
#define | IMGENC1_ETIMEOUT VISA_ETIMEOUT
#define | IMGENC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | IMGENC1_Handle
Opaque handle to a IMGENC1 codec.
typedef struct IIMGENC1_Params | IMGENC1_Params
typedef IIMGENC1_InArgs | IMGENC1_InArgs
typedef IIMGENC1_OutArgs | IMGENC1_OutArgs
typedef IIMGENC1_Cmd | IMGENC1_Cmd
typedef IIMGENC1_DynamicParams | IMGENC1_DynamicParams
typedef IIMGENC1_Status | IMGENC1_Status

Functions

Int32 | IMGENC1_control (IMGENC1_Handle handle, IMGENC1_Cmd id, IMGENC1_DynamicParams *params, IMGENC1_Status *status)
Execute the control() method in this instance of an image encoder algorithm.
IMGENC1_Handle | IMGENC1_create (Engine_Handle e, String name, IMGENC1_Params *params)
Create an instance of an image encoder algorithm.
Void | IMGENC1_delete (IMGENC1_Handle handle)
Delete the instance of a image encoder algorithm.
Int32 | IMGENC1_process (IMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGENC1_InArgs *inArgs, IMGENC1_OutArgs *outArgs)
Execute the process() method in this instance of an image encoder algorithm.
XDAS_Int32 | IMGENC1_processAsync (IMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a image encoder algorithm.
XDAS_Int32 | IMGENC1_processWait (IMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGENC1_processAsync() in this instance of an image encoder algorithm.

Detailed Description

This is the IMGENC1 image encoder codec interface. Several of the data types in this API are specified by the XDM IIMGENC1 interface; please see the XDM documentation for those details.

Define Documentation

#define IMGENC1_EOK IIMGENC1_EOK

Success.

#define IMGENC1_EFAIL IIMGENC1_EFAIL

General failure.

#define IMGENC1_EUNSUPPORTED IIMGENC1_EUNSUPPORTED

Request is unsupported.

#define IMGENC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define IMGENC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle IMGENC1_Handle

Opaque handle to a IMGENC1 codec.

typedef struct IIMGENC1_Params IMGENC1_Params

Defines the creation time parameters for all IIMGENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

typedef IIMGENC1_InArgs IMGENC1_InArgs

Defines the input arguments for all IIMGENC1 instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::process()

typedef IIMGENC1_OutArgs IMGENC1_OutArgs

Defines the run time output arguments for all IIMGENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::process()

typedef IIMGENC1_Cmd IMGENC1_Cmd

Defines the control commands for the IIMGENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IIMGENC1_Fxns::control()

typedef IIMGENC1_DynamicParams IMGENC1_DynamicParams

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::control()
Defines instance status parameters.
Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::control()

typedef IIMGENC1_Status IMGENC1_Status

Function Documentation

Int32 IMGENC1_control | ( | IMGENC1_Handle | handle,
 |  | IMGENC1_Cmd | id,
 |  | IMGENC1_DynamicParams * | params,
 |  | IMGENC1_Status * | status
 | ) |  |

Execute the control() method in this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC1_EOK | Success.
IMGENC1_EFAIL | Failure.
IMGENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
IMGENC1_create()
IMGENC1_delete()
IIMGENC1_Fxns::control()
IMGENC1_Handle IMGENC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | IMGENC1_Params * | params
 | ) |  |

Create an instance of an image encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via IMGENC1_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of image encoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created image encoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the image encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
IMGENC1_delete()
Void IMGENC1_delete ( IMGENC1_Handle handle )

Delete the instance of a image encoder algorithm.

Parameters:
[in] handle Handle to a created image encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the image encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the IMGENC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
IMGENC1_create()
Int32 IMGENC1_process | ( | IMGENC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IMGENC1_InArgs * | inArgs,
 |  | IMGENC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC1_EOK | Success.
IMGENC1_EFAIL | Failure.
IMGENC1_EUNSUPPORTED | Unsupported request.
Remarks:
Since the IMGENC1 encoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to IMGENC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGENC1_create()
IMGENC1_delete()
IMGENC1_control()
IMGENC1_processAsync()
IMGENC1_processWait()
IIMGENC1_Fxns::process()
XDAS_Int32 IMGENC1_processAsync | ( | IMGENC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IIMGENC1_InArgs * | inArgs,
 |  | IIMGENC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC1_EOK | Success.
IMGENC1_EFAIL | Failure.
IMGENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the IMGENC1_processWait() API.
The buffers supplied to IMGENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGENC1_create()
IMGENC1_delete()
IMGENC1_control()
IMGENC1_process()
IMGENC1_processWait()
IIMGENC1_Fxns::process()
XDAS_Int32 IMGENC1_processWait | ( | IMGENC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IIMGENC1_InArgs * | inArgs,
 |  | IIMGENC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of IMGENC1_processAsync() in this instance of an image encoder algorithm.

Parameters:
[in] | handle | Handle to a created image encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> IMGENC1_FOREVER)
Precondition:
handle is a valid (non-NULL) image encoder handle and the image encoder is in the created state.
Return values:
IMGENC1_EOK | Success.
IMGENC1_EFAIL | Failure.
IMGENC1_EUNSUPPORTED | Unsupported request.
IMGENC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of IMGENC1_EFOREVER.
There must have previously been an invocation of the IMGENC1_processAsync() API.
The buffers supplied to IMGENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
IMGENC1_create()
IMGENC1_delete()
IMGENC1_control()
IMGENC1_process()
IMGENC1_processAsync()


Codec Engine Application Programming Interface (API): Codec Engine OSAL - Memory

Codec Engine OSAL - Memory

Data Structures

struct | Memory_AllocParams
Parameters for Memory_alloc() & Memory_free(). More...

Defines

#define | Memory_DEFAULTALIGNMENT ((UInt)(-1))
#define | Memory_GTNAME "OM"
#define | Memory_CACHED 0x00000000
#define | Memory_NONCACHED 0x00000001
#define | Memory_CACHEDMASK 0x00000001

Enumerations

enum Memory_type {
Memory_MALLOC = 0,
Memory_SEG = 1,
Memory_CONTIGPOOL = 2,
Memory_CONTIGHEAP = 3
}

Enum values for Memory_AllocParams.type.

More...

Functions

Ptr | Memory_alloc (UInt size, Memory_AllocParams *params)
General memory allocation.
Void | Memory_cacheInv (Ptr addr, Int sizeInBytes)
Invalidate a range of cache.
Void | Memory_cacheWb (Ptr addr, Int sizeInBytes)
Write back cache.
Void | Memory_cacheWbInv (Ptr addr, Int sizeInBytes)
Write back and invalidate cache.
Ptr | Memory_contigAlloc (UInt size, UInt align)
Allocate physically contiguous blocks of memory.
Bool | Memory_contigFree (Ptr addr, UInt size)
Free memory allocated by Memory_contigAlloc().
Bool | Memory_free (Ptr addr, UInt size, Memory_AllocParams *params)
Free memory allocated with Memory_alloc().
Void | Memory_dumpKnownContigBufsList (Void)
Dumps the list of all translated/registered bufs.
UInt32 | Memory_getBufferPhysicalAddress (Ptr virtualAddress, Int sizeInBytes, Bool *isContiguous)
Converts application virtual address to a physical address.
Int | Memory_getHeapId (String name)
Get the heap heap ID corresponding to a heap name. This number will be between 0 and the value returned by Memory_getNumHeaps(). The heap Id can be passed to Memory_redefine(), Memory_restoreHeap(), and Memory_segStat().
Int | Memory_getNumHeaps ()
Get the number of memory heaps.
Ptr | Memory_getBufferVirtualAddress (UInt32 physicalAddress, Int sizeInBytes)
Obtains the virtual address of a physically contiguous buffer.
Void | Memory_registerContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes, UInt32 physicalAddress)
Register a physical buffer allocated without Memory_contigAlloc().
Void | Memory_unregisterContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes)
Unregisters a physical buffer allocated without Memory_contigAlloc().

Variables

Memory_AllocParams Memory_DEFAULTPARAMS
Default parameters for Memory_alloc() & Memory_free().

Define Documentation

#define Memory_DEFAULTALIGNMENT ((UInt)(-1))
#define Memory_GTNAME "OM"
#define Memory_CACHED 0x00000000

Cached allocation.

See also:
Memory_AllocParams.flags
#define Memory_NONCACHED 0x00000001

Non-cached allocation.

See also:
Memory_AllocParams.flags
#define Memory_CACHEDMASK 0x00000001

Mask to isolate cache flag.

See also:
Memory_AllocParams.flags

Enumeration Type Documentation

enum Memory_type

Enum values for Memory_AllocParams.type.

See also:
Memory_AllocParams
Enumerator:
Memory_MALLOC

malloc()-based allocation

Memory_SEG

DSP/BIOS segment-based allocation

Memory_CONTIGPOOL

Contiguous, pool-based allocation

Memory_CONTIGHEAP

Contiguous, heap-based allocation

Function Documentation

Ptr Memory_alloc | ( | UInt | size,
 |  | Memory_AllocParams * | params
 | ) |  |

General memory allocation.

Parameters:
[in] | size | Number of bytes to allocate.
[in] | params | Parameters controlling the allocation.
Return values:
NULL | The memory request failed.
non-NULL | The pointer to a buffer containing the requested memory.
See also:
Memory_free()
Memory_contigAlloc()
Void Memory_cacheInv | ( | Ptr | addr,
 |  | Int | sizeInBytes
 | ) |  |

Invalidate a range of cache.

Parameters:
[in] | addr | Address of the beginning of the buffer to invalidate.
[in] | sizeInBytes | Size of the buffer to invalidate.
Remarks:
In addition to application usage, this is often called by a skeleton implementor after it has received a shared memory buffer from another processor, and before it invokes an algorithm's interface which will operate on that shared memory buffer.
See also:
Memory_cacheWb()
Memory_cacheWbInv()
Void Memory_cacheWb | ( | Ptr | addr,
 |  | Int | sizeInBytes
 | ) |  |

Write back cache.

Parameters:
[in] | addr | Address of the beginning of the buffer to writeback.
[in] | sizeInBytes | Size of the buffer to writeback.
See also:
Memory_cacheInv()
Memory_cacheWbInv()
Void Memory_cacheWbInv | ( | Ptr | addr,
 |  | Int | sizeInBytes
 | ) |  |

Write back and invalidate cache.

Parameters:
[in] | addr | Address of the beginning of the buffer to writeback and invalidate.
[in] | sizeInBytes | Size of the buffer to writeback invalidate.
See also:
Memory_cacheInv()
Memory_cacheWb()
Ptr Memory_contigAlloc | ( | UInt | size,
 |  | UInt | align
 | ) |  |

Allocate physically contiguous blocks of memory.

Deprecated:
This function has been superceded by Memory_alloc() and will be removed in a future release. Users are recommended to modify their applications to use the new, more flexible Memory_alloc() instead.
Parameters:
[in] | size | Size of the buffer to allocate.
[in] | align | Alignment of the buffer; must be divisible by a power of two.
Precondition:
align must be divisible by a power of two.
Return values:
non-NULL | Address of a physically contiguous buffer.
NULL | Unable to obtain the requested buffer.
Remarks:
This is commonly called by an application wishing to obtain a physically contiguous buffer which it must share with another processor.
For portability reasons, applications commonly use this API even in environments which do not have virtual memory or an MMU (e.g. a single processor, DSP/BIOS based system). Doing so makes them portable to environments which do have to provide physically contiguous memory to remote processors.
See also:
Memory_alloc()
Memory_contigFree()
Bool Memory_contigFree | ( | Ptr | addr,
 |  | UInt | size
 | ) |  |

Free memory allocated by Memory_contigAlloc().

Parameters:
[in] | addr | Address of a buffer allocated by Memory_contigAlloc()
[in] | size | Size of the buffer to free.
Return values:
TRUE | The buffer was freed and the memory pointed to by addr is no longer valid.
FALSE | The buffer couldn't be freed.
Precondition:
addr must be a valid address returned by Memory_contigAlloc()
size must be equivalent to the size passed in during the Memory_contigAlloc() allocation.
See also:
Memory_contigAlloc()
Bool Memory_free | ( | Ptr | addr,
 |  | UInt | size,
 |  | Memory_AllocParams * | params
 | ) |  |

Free memory allocated with Memory_alloc().

Parameters:
[in] | addr | Address of a buffer allocated by Memory_alloc().
[in] | size | Size of the buffer to free.
[in] | params | Parameters controlling the free operation.
Return values:
TRUE | The buffer was freed and the memory pointed to by addr is no longer valid.
FALSE | The buffer couldn't be freed.
Precondition:
addr must be a valid address returned by Memory_alloc().
size must be equivalent to the size passed in during the Memory_alloc() allocation.
See also:
Memory_alloc()
Void Memory_dumpKnownContigBufsList ( Void )

Dumps the list of all translated/registered bufs.

Remarks:
The list is printed using the tracing infrastructure at trace level 5 to tracemask Memory_GTNAME.
There are several mechanisms to enable this trace mask, one would be to do the following from your application:
    GT_set(Memory_GTNAME "+5");
See also:
Memory_registerContigBuf()
Memory_unregisterContigBuf()
UInt32 Memory_getBufferPhysicalAddress | ( | Ptr | virtualAddress,
 |  | Int | sizeInBytes,
 |  | Bool * | isContiguous
 | ) |  |

Converts application virtual address to a physical address.

This API also checks verifies that the buffer is really contiguous.

Parameters:
[in] | virtualAddress | Address of a buffer.
[in] | sizeInBytes | Size of the buffer.
[out] | isContiguous | Optional flag indicating whether the buffer was physically contiguous or not.
Return values:
0 | Failure, the physical address could not be obtained.
non-zero | The physical address of the buffer.
Remarks:
sizeInBytes must be non-zero.
isContiguous is an optional parameter, and can be NULL if the caller doesn't want the results of this check. If isContiguous is NULL but the buffer is not contiguous, error trace will be generated.
If a physically discontiguous buffer is provided in virtualAddress, zero will be returned. And if isContiguous is non-null, it will be set to FALSE.
This is typically called by a stub implementation to translate an application-side virtual address into a physical address usable by a remote skeleton and algorithm.
To enable portable code, this is safe to call on systems without virtual memory. In those cases, the returned physical buffer will be the same as the provided "virtual" buffer.
See also:
Memory_getBufferVirtualAddress()
Int Memory_getHeapId ( String name )

Get the heap heap ID corresponding to a heap name. This number will be between 0 and the value returned by Memory_getNumHeaps(). The heap Id can be passed to Memory_redefine(), Memory_restoreHeap(), and Memory_segStat().

Remarks:
This is an unsupported, private function. There is no contract to provide compatibility between releases, and it may be deleted at any time.
Return values:
>= 0 The heap number.
< 0 No heap with the given name was found.
See also:
Memory_getNumHeaps()
Int Memory_getNumHeaps ( )

Get the number of memory heaps.

Remarks:
This is an unsupported, private function. There is no contract to provide compatibility between releases, and it may be deleted at any time.
Return values:
The number of memroy heaps.
See also:
Memory_getHeapId()
Ptr Memory_getBufferVirtualAddress | ( | UInt32 | physicalAddress,
 |  | Int | sizeInBytes
 | ) |  |

Obtains the virtual address of a physically contiguous buffer.

Parameters:
[in] | physicalAddress | Physical address of a buffer.
[in] | sizeInBytes | Size of the buffer.
Return values:
NULL | Failure, the virtual address could not be obtained.
non-zero | The virtual address of the buffer.
Remarks:
sizeInBytes must be non-zero.
If virtualAddress, was not acquired by Memory_getBufferPhysicalAddress(), no attempt is made to map the physically contiguous buffer into a the application's virtual memory space.
This is typically called by a stub implementation to translate a buffer provided by a remote skeleton and/or algorithm into an application-usable, virtual address.
To enable portable code, this is safe to call on systems without virtual memory. In those cases, the returned "virtual" buffer will be the same as the provided physical buffer.
See also:
Memory_getBufferPhysicalAddress()
Void Memory_registerContigBuf | ( | UInt32 | virtualAddress,
 |  | UInt32 | sizeInBytes,
 |  | UInt32 | physicalAddress
 | ) |  |

Register a physical buffer allocated without Memory_contigAlloc().

Parameters:
[in] | virtualAddress | Address of the buffer mapped into the process space
[in] | sizeInBytes | Size of the region
[in] | physicalAddress | Physical address of the buffer
Remarks:
A cache of "app-address to codec-address" mappings (e.g. virtual to physical address mappings in DM644x devices) is internally maintained in some environments (e.g. Linux). This is used, for example, by Memory_getBufferPhysicalAddress() and Memory_getBufferVirtualAddress(). This lookup map is automatically updated when using Memory_contigAlloc() and Memory_contigFree(). However, if the user acquires buffers independently, it must use Memory_registerContigBuf() and Memory_unregisterContigBuf() to ensure the lookup map is current.
Individual sub-blocks of a buffer need not be registered; registering the entire buffer once will suffice.
This API is typically only required for environments with virtual memory (e.g. Linux-based systems).
See also:
Memory_unregisterContigBuf()
Memory_dumpKnownContigBufsList()
Void Memory_unregisterContigBuf | ( | UInt32 | virtualAddress,
 |  | UInt32 | sizeInBytes
 | ) |  |

Unregisters a physical buffer allocated without Memory_contigAlloc().

Parameters:
[in] | virtualAddress | beginning address of the buffer mapped into the process space
[in] | sizeInBytes | size of the region
Remarks:
This API must be used to unregister a buffer allocated outside of Memory_contigAlloc() if the buffer (or a portion of it) is passed on to VISA calls. Segments of the buffer need not be individually unregistered.
See also:
Memory_registerContigBuf()
Memory_dumpKnownContigBufsList()

Variable Documentation

Memory_AllocParams Memory_DEFAULTPARAMS

Default parameters for Memory_alloc() & Memory_free().

Remarks:
Memory_DEFAULTPARAMS will be used when NULL is passed in the Memory_AllocParams parameter for Memory_alloc() & Memory_free(). When passing a non-NULL Memory_AllocParams parameter, you should first copy Memory_DEFAULTPARAMS to your structure and then modify individual elements as needed:
      Memory_AllocParams  myParams;

      myParams = Memory_DEFAULTPARAMS;
      myParams.type = Memory_CONTIGHEAP;
See also:
Memory_alloc()
Memory_free()


Codec Engine Application Programming Interface (API): SPHDEC Speech Decoder Interface

SPHDEC Speech Decoder Interface

Defines

#define | SPHDEC_EOK ISPHDEC_EOK
#define | SPHDEC_EFAIL ISPHDEC_EFAIL
#define | SPHDEC_ERUNTIME ISPHDEC_ERUNTIME
#define | SPHDEC_ETIMEOUT VISA_ETIMEOUT
#define | SPHDEC_FOREVER VISA_FOREVER

Typedefs

typedef ISPHDEC_Status | SPHDEC_Status
typedef VISA_Handle | SPHDEC_Handle
Opaque handle to a SPHDEC codec.
typedef struct ISPHDEC_Params | SPHDEC_Params
This structure defines the parameters necessary to create an instance of a speech decoder object.
typedef ISPHDEC_InArgs | SPHDEC_InArgs
typedef ISPHDEC_OutArgs | SPHDEC_OutArgs
typedef ISPHDEC_Cmd | SPHDEC_Cmd
typedef ISPHDEC_DynamicParams | SPHDEC_DynamicParams

Functions

SPHDEC_Handle | SPHDEC_create (Engine_Handle e, String name, SPHDEC_Params *params)
Create an instance of a speech decoder algorithm.
Int32 | SPHDEC_process (SPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs)
Execute the process() method in this instance of a speech decoder algorithm.
Int32 | SPHDEC_control (SPHDEC_Handle handle, SPHDEC_Cmd id, SPHDEC_DynamicParams *params, SPHDEC_Status *status)
Execute the control method in this instance of a speech decoder algorithm.
Void | SPHDEC_delete (SPHDEC_Handle handle)
Delete the instance of a speech/voice decoder algorithm.
XDAS_Int32 | SPHDEC_processAsync (SPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech decoder algorithm.
XDAS_Int32 | SPHDEC_processWait (SPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHDEC_processAsync() in this instance of an speech decoder algorithm.

Detailed Description

This is the SPHDEC speech decoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define SPHDEC_EOK ISPHDEC_EOK

Success.

#define SPHDEC_EFAIL ISPHDEC_EFAIL

General failure.

#define SPHDEC_ERUNTIME ISPHDEC_ERUNTIME

General runtime failure.

#define SPHDEC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define SPHDEC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef ISPHDEC_Status SPHDEC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::control()

typedef VISA_Handle SPHDEC_Handle

Opaque handle to a SPHDEC codec.

typedef struct ISPHDEC_Params SPHDEC_Params

This structure defines the parameters necessary to create an instance of a speech decoder object.

typedef ISPHDEC_InArgs SPHDEC_InArgs

Defines the input arguments for all ISPHDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::process()

typedef ISPHDEC_OutArgs SPHDEC_OutArgs

Defines the run time output arguments for all ISPHDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::process()

typedef ISPHDEC_Cmd SPHDEC_Cmd

Defines the control commands for the ISPHDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
ISPHDEC_Fxns::control()

typedef ISPHDEC_DynamicParams SPHDEC_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::control()

Function Documentation

SPHDEC_Handle SPHDEC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | SPHDEC_Params * | params
 | ) |  |

Create an instance of a speech decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via SPHDEC_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of speech decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created speech decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the speech decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
SPHDEC_delete()
Int32 SPHDEC_process | ( | SPHDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | SPHDEC_InArgs * | inArgs,
 |  | SPHDEC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC_EOK | Success.
SPHDEC_EFAIL | Failure.
SPHDEC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the SPHDEC decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to SPHDEC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHDEC_create()
SPHDEC_delete()
SPHDEC_control()
SPHDEC_processAsync()
SPHDEC_processWait()
ISPHDEC_Fxns::process()
Int32 SPHDEC_control | ( | SPHDEC_Handle | handle,
 |  | SPHDEC_Cmd | id,
 |  | SPHDEC_DynamicParams * | params,
 |  | SPHDEC_Status * | status
 | ) |  |

Execute the control method in this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC_EOK | Success.
SPHDEC_EFAIL | Failure.
SPHDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
SPHDEC_create()
SPHDEC_delete()
ISPHDEC_Fxns::control()
Void SPHDEC_delete ( SPHDEC_Handle handle )

Delete the instance of a speech/voice decoder algorithm.

Parameters:
[in] handle Handle to a created speech decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the speech decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the SPHDEC_create() operation (memory, DMA channels, etc.) are freed.
See also:
SPHDEC_create()
XDAS_Int32 SPHDEC_processAsync | ( | SPHDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | SPHDEC_InArgs * | inArgs,
 |  | SPHDEC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC_EOK | Success.
SPHDEC_EFAIL | Failure.
SPHDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the SPHDEC_processWait() API.
The buffers supplied to SPHDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHDEC_create()
SPHDEC_delete()
SPHDEC_control()
SPHDEC_process()
SPHDEC_processWait()
ISPHDEC_Fxns::process()
XDAS_Int32 SPHDEC_processWait | ( | SPHDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | SPHDEC_InArgs * | inArgs,
 |  | SPHDEC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of SPHDEC_processAsync() in this instance of an speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> SPHDEC_FOREVER)
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC_EOK | Success.
SPHDEC_EFAIL | Failure.
SPHDEC_ERUNTIME | Internal Runtime Error.
SPHDEC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of SPHDEC_EFOREVER.
There must have previously been an invocation of the SPHDEC_processAsync() API.
The buffers supplied to SPHDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHDEC_create()
SPHDEC_delete()
SPHDEC_control()
SPHDEC_process()
SPHDEC_processAsync()


Codec Engine Application Programming Interface (API): SPHENC Speech Encoder Interface

SPHENC Speech Encoder Interface

Defines

#define | SPHENC_EOK ISPHENC_EOK
#define | SPHENC_EFAIL ISPHENC_EFAIL
#define | SPHENC_ERUNTIME ISPHENC_ERUNTIME
#define | SPHENC_ETIMEOUT VISA_ETIMEOUT
#define | SPHENC_FOREVER VISA_FOREVER

Typedefs

typedef ISPHENC_Status | SPHENC_Status
typedef VISA_Handle | SPHENC_Handle
Opaque handle to a SPHENC codec.
typedef struct ISPHENC_Params | SPHENC_Params
This structure defines the parameters necessary to create an instance of a Speech/Voice Encoder object.
typedef ISPHENC_InArgs | SPHENC_InArgs
typedef ISPHENC_OutArgs | SPHENC_OutArgs
typedef ISPHENC_Cmd | SPHENC_Cmd
typedef ISPHENC_DynamicParams | SPHENC_DynamicParams

Functions

SPHENC_Handle | SPHENC_create (Engine_Handle e, String name, SPHENC_Params *params)
Create an instance of a speech encoder algorithm.
Int32 | SPHENC_process (SPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHENC_InArgs *inArgs, SPHENC_OutArgs *outArgs)
Execute the process() method in this instance of a speech encoder algorithm.
Int32 | SPHENC_control (SPHENC_Handle handle, SPHENC_Cmd id, SPHENC_DynamicParams *params, SPHENC_Status *status)
Execute the control method in this instance of a speech encoder algorithm.
Void | SPHENC_delete (SPHENC_Handle handle)
Delete the instance of a speech/voice encoder algorithm.
XDAS_Int32 | SPHENC_processAsync (SPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech decoder algorithm.
XDAS_Int32 | SPHENC_processWait (SPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHENC_processAsync() in this instance of an speech decoder algorithm.

Detailed Description

This is the SPHENC speech encoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define SPHENC_EOK ISPHENC_EOK

Success.

#define SPHENC_EFAIL ISPHENC_EFAIL

General failure.

#define SPHENC_ERUNTIME ISPHENC_ERUNTIME

General runtime failure.

#define SPHENC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define SPHENC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef ISPHENC_Status SPHENC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::control()

typedef VISA_Handle SPHENC_Handle

Opaque handle to a SPHENC codec.

typedef struct ISPHENC_Params SPHENC_Params

This structure defines the parameters necessary to create an instance of a Speech/Voice Encoder object.

typedef ISPHENC_InArgs SPHENC_InArgs

Defines the input arguments for all ISPHENC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::process()

typedef ISPHENC_OutArgs SPHENC_OutArgs

Defines the run time output arguments for all ISPHENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::process()

typedef ISPHENC_Cmd SPHENC_Cmd

Defines the control commands for the ISPHENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
ISPHENC_Fxns::control()

typedef ISPHENC_DynamicParams SPHENC_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::control()

Function Documentation

SPHENC_Handle SPHENC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | SPHENC_Params * | params
 | ) |  |

Create an instance of a speech encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via SPHENC_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of speech encoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created speech encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the speech encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
SPHENC_delete()
Int32 SPHENC_process | ( | SPHENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | SPHENC_InArgs * | inArgs,
 |  | SPHENC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a speech encoder algorithm.

Parameters:
[in] | handle | Handle to a created speech encoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech encoder handle and the speech encoder is in the created state.
Return values:
SPHENC_EOK | Success.
SPHENC_EFAIL | Failure.
SPHENC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the SPHENC decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to SPHENC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHENC_create()
SPHENC_delete()
SPHENC_control()
SPHENC_processAsync()
SPHENC_processWait()
ISPHENC_Fxns::process()
Int32 SPHENC_control | ( | SPHENC_Handle | handle,
 |  | SPHENC_Cmd | id,
 |  | SPHENC_DynamicParams * | params,
 |  | SPHENC_Status * | status
 | ) |  |

Execute the control method in this instance of a speech encoder algorithm.

Parameters:
[in] | handle | Handle to a created speech encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) speech encoder handle and the speech encoder is in the created state.
Return values:
SPHENC_EOK | Success.
SPHENC_EFAIL | Failure.
SPHENC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
SPHENC_create()
SPHENC_delete()
ISPHENC_Fxns::control()
Void SPHENC_delete ( SPHENC_Handle handle )

Delete the instance of a speech/voice encoder algorithm.

Parameters:
[in] handle Handle to a created speech encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the speech encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the SPHENC_create() operation (memory, DMA channels, etc.) are freed.
See also:
SPHENC_create()
XDAS_Int32 SPHENC_processAsync | ( | SPHENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | ISPHENC_InArgs * | inArgs,
 |  | ISPHENC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHENC_EOK | Success.
SPHENC_EFAIL | Failure.
SPHENC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the SPHENC_processWait() API.
The buffers supplied to SPHENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHENC_create()
SPHENC_delete()
SPHENC_control()
SPHENC_process()
SPHENC_processWait()
ISPHENC_Fxns::process()
XDAS_Int32 SPHENC_processWait | ( | SPHENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | ISPHENC_InArgs * | inArgs,
 |  | ISPHENC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of SPHENC_processAsync() in this instance of an speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> SPHENC_FOREVER)
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHENC_EOK | Success.
SPHENC_EFAIL | Failure.
SPHENC_ERUNTIME | Internal Runtime Error.
SPHENC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of SPHENC_EFOREVER.
There must have previously been an invocation of the SPHENC_processAsync() API.
The buffers supplied to SPHENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHENC_create()
SPHENC_delete()
SPHENC_control()
SPHENC_process()
SPHENC_processAsync()


Codec Engine Application Programming Interface (API): Speech decoder codec interface

Speech decoder codec interface

Defines

#define | SPHDEC1_EOK ISPHDEC1_EOK
#define | SPHDEC1_EFAIL ISPHDEC1_EFAIL
#define | SPHDEC1_EUNSUPPORTED ISPHDEC1_EUNSUPPORTED
#define | SPHDEC1_ETIMEOUT VISA_ETIMEOUT
#define | SPHDEC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | SPHDEC1_Handle
Opaque handle to a SPHDEC1 codec.
typedef ISPHDEC1_Params | SPHDEC1_Params
typedef ISPHDEC1_InArgs | SPHDEC1_InArgs
typedef ISPHDEC1_OutArgs | SPHDEC1_OutArgs
typedef ISPHDEC1_Cmd | SPHDEC1_Cmd
typedef ISPHDEC1_DynamicParams | SPHDEC1_DynamicParams
typedef ISPHDEC1_Status | SPHDEC1_Status

Functions

Int32 | SPHDEC1_control (SPHDEC1_Handle handle, SPHDEC1_Cmd id, SPHDEC1_DynamicParams *params, SPHDEC1_Status *status)
Execute the control() method in this instance of a speech decoder algorithm.
SPHDEC1_Handle | SPHDEC1_create (Engine_Handle e, String name, SPHDEC1_Params *params)
Create an instance of a speech decoder algorithm.
Void | SPHDEC1_delete (SPHDEC1_Handle handle)
Delete the instance of a speech decoder algorithm.
Int32 | SPHDEC1_process (SPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs)
Execute the process() method in this instance of a speech decoder algorithm.
XDAS_Int32 | SPHDEC1_processAsync (SPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech decoder algorithm.
XDAS_Int32 | SPHDEC1_processWait (SPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHDEC1_processAsync() in this instance of an speech decoder algorithm.

Detailed Description

This is the SPHDEC1 speech decoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define SPHDEC1_EOK ISPHDEC1_EOK

Success.

#define SPHDEC1_EFAIL ISPHDEC1_EFAIL

General failure.

#define SPHDEC1_EUNSUPPORTED ISPHDEC1_EUNSUPPORTED

Request is unsupported.

#define SPHDEC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define SPHDEC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle SPHDEC1_Handle

Opaque handle to a SPHDEC1 codec.

typedef ISPHDEC1_Params SPHDEC1_Params

Defines the creation time parameters for all ISPHDEC1 instance objects.

Remarks:
Some of the fields in this structure are optional and depend on the class of speech decoder you're creating.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

typedef ISPHDEC1_InArgs SPHDEC1_InArgs

Defines the input arguments for all ISPHDEC1 instance process function.

typedef ISPHDEC1_OutArgs SPHDEC1_OutArgs

Defines the run time output arguments for all ISPHDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC1_Fxns::process()
Defines the control commands for the ISPHDEC1 module.
Remarks:
This ID can be extended in IMOD interface for additional control commands.
See also:
XDM_CmdId
ISPHDEC1_Fxns::control()

typedef ISPHDEC1_Cmd SPHDEC1_Cmd
typedef ISPHDEC1_DynamicParams SPHDEC1_DynamicParams

This structure defines the codec parameters that can be modified after creation via ISPHDEC1_Fxns.control().

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC1_Fxns::control()
Defines instance status parameters.
Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC1_Fxns::control()

typedef ISPHDEC1_Status SPHDEC1_Status

Function Documentation

Int32 SPHDEC1_control | ( | SPHDEC1_Handle | handle,
 |  | SPHDEC1_Cmd | id,
 |  | SPHDEC1_DynamicParams * | params,
 |  | SPHDEC1_Status * | status
 | ) |  |

Execute the control() method in this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC1_EOK | Success.
SPHDEC1_EFAIL | Failure.
SPHDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
SPHDEC1_create()
SPHDEC1_delete()
ISPHDEC1_Fxns()control()
SPHDEC1_Handle SPHDEC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | SPHDEC1_Params * | params
 | ) |  |

Create an instance of a speech decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via SPHDEC1_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of speech decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created speech decoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the speech1 decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
SPHDEC1_delete()
Void SPHDEC1_delete ( SPHDEC1_Handle handle )

Delete the instance of a speech decoder algorithm.

Parameters:
[in] handle Handle to a created speech decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the speech decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the SPHDEC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
SPHDEC1_create()
Int32 SPHDEC1_process | ( | SPHDEC1_Handle | handle,
 |  | XDM1_SingleBufDesc * | inBuf,
 |  | XDM1_SingleBufDesc * | outBuf,
 |  | SPHDEC1_InArgs * | inArgs,
 |  | SPHDEC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBuf | A buffer descriptor containing an input buffer.
[out] | outBuf | A buffer descriptor containing an output buffer.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC1_EOK | Success.
SPHDEC1_EFAIL | Failure.
SPHDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
Since the SPHDEC1 decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to SPHDEC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHDEC1_create()
SPHDEC1_delete()
SPHDEC1_control()
SPHDEC1_processAsync()
SPHDEC1_processWait()
ISPHDEC1_Fxns()process()
XDAS_Int32 SPHDEC1_processAsync | ( | SPHDEC1_Handle | handle,
 |  | XDM1_SingleBufDesc * | inBuf,
 |  | XDM1_SingleBufDesc * | outBuf,
 |  | SPHDEC1_InArgs * | inArgs,
 |  | SPHDEC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBuf | A buffer descriptor containing the input buffer.
[out] | outBuf | A buffer descriptor containing the output buffer.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC1_EOK | Success.
SPHDEC1_EFAIL | Failure.
SPHDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the SPHDEC1_processWait() API.
The buffers supplied to SPHDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHDEC1_create()
SPHDEC1_delete()
SPHDEC1_control()
SPHDEC1_process()
SPHDEC1_processWait()
ISPHDEC1_Fxns::process()
XDAS_Int32 SPHDEC1_processWait | ( | SPHDEC1_Handle | handle,
 |  | XDM1_SingleBufDesc * | inBuf,
 |  | XDM1_SingleBufDesc * | outBuf,
 |  | SPHDEC1_InArgs * | inArgs,
 |  | SPHDEC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of SPHDEC1_processAsync() in this instance of an speech decoder algorithm.

Parameters:
[in] | handle | Handle to a created speech decoder instance.
[in] | inBuf | A buffer descriptor containing the input buffer.
[out] | outBuf | A buffer descriptor containing the output buffer.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> SPHDEC1_FOREVER)
Precondition:
handle is a valid (non-NULL) speech decoder handle and the speech decoder is in the created state.
Return values:
SPHDEC1_EOK | Success.
SPHDEC1_EFAIL | Failure.
SPHDEC1_EUNSUPPORTED | Unsupported request.
SPHDEC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of SPHDEC1_EFOREVER.
There must have previously been an invocation of the SPHDEC1_processAsync() API.
The buffers supplied to SPHDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHDEC1_create()
SPHDEC1_delete()
SPHDEC1_control()
SPHDEC1_process()
SPHDEC1_processAsync()


Codec Engine Application Programming Interface (API): Speech 1.0 Encoder Codec Interface

Speech 1.0 Encoder Codec Interface

Defines

#define | SPHENC1_EOK ISPHENC1_EOK
#define | SPHENC1_EFAIL ISPHENC1_EFAIL
#define | SPHENC1_EUNSUPPORTED ISPHENC1_EUNSUPPORTED
#define | SPHENC1_ETIMEOUT VISA_ETIMEOUT
#define | SPHENC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | SPHENC1_Handle
Opaque handle to a SPHENC1 codec.
typedef struct ISPHENC1_Params | SPHENC1_Params
This structure defines the parameters necessary to create an instance of a speech encoder.
typedef ISPHENC1_InArgs | SPHENC1_InArgs
typedef ISPHENC1_OutArgs | SPHENC1_OutArgs
typedef ISPHENC1_Cmd | SPHENC1_Cmd
typedef ISPHENC1_Status | SPHENC1_Status
typedef ISPHENC1_DynamicParams | SPHENC1_DynamicParams

Functions

Int32 | SPHENC1_control (SPHENC1_Handle handle, SPHENC1_Cmd id, SPHENC1_DynamicParams *params, SPHENC1_Status *status)
Execute the control() method in this instance of a speech encoder algorithm.
SPHENC1_Handle | SPHENC1_create (Engine_Handle e, String name, SPHENC1_Params *params)
Create an instance of a speech encoder algorithm.
Void | SPHENC1_delete (SPHENC1_Handle handle)
Delete the instance of a speech encoder algorithm.
Int32 | SPHENC1_process (SPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs)
Execute the process() method in this instance of a speech encoder algorithm.
XDAS_Int32 | SPHENC1_processAsync (SPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech encoder algorithm.
XDAS_Int32 | SPHENC1_processWait (SPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHENC1_processAsync() in this instance of an speech encoder algorithm.

Detailed Description

This is the Speech 1.0 Encoder Codec Interface. Several of the data types in this API are specified by the XDM 1.0 interface; please see the XDM documentation for those details.

Define Documentation

#define SPHENC1_EOK ISPHENC1_EOK

Success.

#define SPHENC1_EFAIL ISPHENC1_EFAIL

General failure.

#define SPHENC1_EUNSUPPORTED ISPHENC1_EUNSUPPORTED

Request is unsupported.

#define SPHENC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define SPHENC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle SPHENC1_Handle

Opaque handle to a SPHENC1 codec.

typedef struct ISPHENC1_Params SPHENC1_Params

This structure defines the parameters necessary to create an instance of a speech encoder.

typedef ISPHENC1_InArgs SPHENC1_InArgs

Defines the input arguments for all ISPHENC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

typedef ISPHENC1_OutArgs SPHENC1_OutArgs

Defines the run time output arguments for all ISPHENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC1_Fxns::process()

typedef ISPHENC1_Cmd SPHENC1_Cmd

Defines the control commands for the ISPHENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional control commands.
See also:
XDM_CmdId
ISPHENC1_Fxns::control()

typedef ISPHENC1_Status SPHENC1_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

typedef ISPHENC1_DynamicParams SPHENC1_DynamicParams

This structure defines the codec parameters that can be modified after creation via ISPHENC1_Fxns.control().

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Function Documentation

Int32 SPHENC1_control | ( | SPHENC1_Handle | handle,
 |  | SPHENC1_Cmd | id,
 |  | SPHENC1_DynamicParams * | params,
 |  | SPHENC1_Status * | status
 | ) |  |

Execute the control() method in this instance of a speech encoder algorithm.

Parameters:
[in] | handle | Handle to a created speech encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) speech encoder handle and the speech encoder is in the created state.
Return values:
SPHENC1_EOK | Success.
SPHENC1_EFAIL | Failure.
SPHENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
SPHENC1_create()
SPHENC1_delete()
ISPHENC1_Fxns::control()
SPHENC1_Handle SPHENC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | SPHENC1_Params * | params
 | ) |  |

Create an instance of a speech encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via SPHENC1_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of speech encoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created speech encoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the speech1 encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
SPHENC_delete()
Void SPHENC1_delete ( SPHENC1_Handle handle )

Delete the instance of a speech encoder algorithm.

Parameters:
[in] handle Handle to a created speech encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the speech encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the SPHENC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
SPHENC1_create()
Int32 SPHENC1_process | ( | SPHENC1_Handle | handle,
 |  | XDM1_SingleBufDesc * | inBuf,
 |  | XDM1_SingleBufDesc * | outBuf,
 |  | SPHENC1_InArgs * | inArgs,
 |  | SPHENC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a speech encoder algorithm.

Parameters:
[in] | handle | Handle to a created speech encoder instance.
[in,out] | inBuf | A buffer descriptor containing an input buffer.
[out] | outBuf | A buffer descriptor containing an output buffer.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech encoder handle and the speech encoder is in the created state.
Return values:
SPHENC1_EOK | Success.
SPHENC1_EFAIL | Failure.
SPHENC1_EUNSUPPORTED | Unsupported request.
Remarks:
Since the SPHENC1 encoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to SPHENC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHENC1_create()
SPHENC1_delete()
SPHENC1_control()
SPHENC1_processAsync()
SPHENC1_processWait()
ISPHENC1_Fxns::process()
XDAS_Int32 SPHENC1_processAsync | ( | SPHENC1_Handle | handle,
 |  | XDM1_SingleBufDesc * | inBuf,
 |  | XDM1_SingleBufDesc * | outBuf,
 |  | SPHENC1_InArgs * | inArgs,
 |  | SPHENC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a speech encoder algorithm.

Parameters:
[in] | handle | Handle to a created speech encoder instance.
[in] | inBuf | A buffer descriptor containing the input buffer.
[out] | outBuf | A buffer descriptor containing the output buffer.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) speech encoder handle and the speech encoder is in the created state.
Return values:
SPHENC1_EOK | Success.
SPHENC1_EFAIL | Failure.
SPHENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the SPHENC1_processWait() API.
The buffers supplied to SPHENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHENC1_create()
SPHENC1_delete()
SPHENC1_control()
SPHENC1_process()
SPHENC1_processWait()
ISPHENC1_Fxns::process()
XDAS_Int32 SPHENC1_processWait | ( | SPHENC1_Handle | handle,
 |  | XDM1_SingleBufDesc * | inBuf,
 |  | XDM1_SingleBufDesc * | outBuf,
 |  | SPHENC1_InArgs * | inArgs,
 |  | SPHENC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of SPHENC1_processAsync() in this instance of an speech encoder algorithm.

Parameters:
[in] | handle | Handle to a created speech encoder instance.
[in] | inBuf | A buffer descriptor containing the input buffer.
[out] | outBuf | A buffer descriptor containing the output buffer.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> SPHENC1_FOREVER)
Precondition:
handle is a valid (non-NULL) speech encoder handle and the speech encoder is in the created state.
Return values:
SPHENC1_EOK | Success.
SPHENC1_EFAIL | Failure.
SPHENC1_EUNSUPPORTED | Unsupported request.
SPHENC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of SPHENC1_EFOREVER.
There must have previously been an invocation of the SPHENC1_processAsync() API.
The buffers supplied to SPHENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
SPHENC1_create()
SPHENC1_delete()
SPHENC1_control()
SPHENC1_process()
SPHENC1_processAsync()


Codec Engine Application Programming Interface (API): Universal Algorithm Interface

Universal Algorithm Interface

Defines

#define | UNIVERSAL_EOK IUNIVERSAL_EOK
#define | UNIVERSAL_EFAIL IUNIVERSAL_EFAIL
#define | UNIVERSAL_EUNSUPPORTED IUNIVERSAL_EUNSUPPORTED
#define | UNIVERSAL_ETIMEOUT VISA_ETIMEOUT
#define | UNIVERSAL_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | UNIVERSAL_Handle
Opaque handle to a UNIVERSAL codec.
typedef struct IUNIVERSAL_Params | UNIVERSAL_Params
This structure defines the parameters necessary to create an instance of a "universal" algorithm.
typedef IUNIVERSAL_InArgs | UNIVERSAL_InArgs
typedef IUNIVERSAL_OutArgs | UNIVERSAL_OutArgs
typedef IUNIVERSAL_Cmd | UNIVERSAL_Cmd
typedef IUNIVERSAL_Status | UNIVERSAL_Status
typedef IUNIVERSAL_DynamicParams | UNIVERSAL_DynamicParams

Functions

Int32 | UNIVERSAL_control (UNIVERSAL_Handle handle, UNIVERSAL_Cmd id, UNIVERSAL_DynamicParams *params, UNIVERSAL_Status *status)
Execute the control() method in this instance of a "universal" algorithm.
UNIVERSAL_Handle | UNIVERSAL_create (Engine_Handle e, String name, UNIVERSAL_Params *params)
Create an instance of a universal algorithm.
Void | UNIVERSAL_delete (UNIVERSAL_Handle handle)
Delete the instance of a universal algorithm.
Int32 | UNIVERSAL_process (UNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, UNIVERSAL_InArgs *inArgs, UNIVERSAL_OutArgs *outArgs)
Execute the process() method in this instance of a universal algorithm.
XDAS_Int32 | UNIVERSAL_processAsync (UNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs)
Perform asynchronous submission to this instance of a universal algorithm.
XDAS_Int32 | UNIVERSAL_processWait (UNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of UNIVERSAL_processAsync() in this instance of a universal algorithm.

Detailed Description

This is the "universal" algorithm interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define UNIVERSAL_EOK IUNIVERSAL_EOK

Success.

#define UNIVERSAL_EFAIL IUNIVERSAL_EFAIL

General failure.

#define UNIVERSAL_EUNSUPPORTED IUNIVERSAL_EUNSUPPORTED

Request is unsupported. Timeout occurred.

#define UNIVERSAL_ETIMEOUT VISA_ETIMEOUT

Special value for timeout parameter indicating never timeout.

#define UNIVERSAL_FOREVER VISA_FOREVER

Typedef Documentation

typedef VISA_Handle UNIVERSAL_Handle

Opaque handle to a UNIVERSAL codec.

typedef struct IUNIVERSAL_Params UNIVERSAL_Params

This structure defines the parameters necessary to create an instance of a "universal" algorithm.

typedef IUNIVERSAL_InArgs UNIVERSAL_InArgs

Defines the input arguments for all IUNIVERSAL instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::process()

typedef IUNIVERSAL_OutArgs UNIVERSAL_OutArgs

Defines the run time output arguments for all IUNIVERSAL instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::process()

typedef IUNIVERSAL_Cmd UNIVERSAL_Cmd

Defines the control commands for the IUNIVERSAL module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IUNIVERSAL_Fxns::control()

typedef IUNIVERSAL_Status UNIVERSAL_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::control()

typedef IUNIVERSAL_DynamicParams UNIVERSAL_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::control()

Function Documentation

Int32 UNIVERSAL_control | ( | UNIVERSAL_Handle | handle,
 |  | UNIVERSAL_Cmd | id,
 |  | UNIVERSAL_DynamicParams * | params,
 |  | UNIVERSAL_Status * | status
 | ) |  |

Execute the control() method in this instance of a "universal" algorithm.

Parameters:
[in] | handle | Handle to a created universal algorithm instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for the universal algorithm instance.
[out] | status | Status info returned by the algorithm instance.
Precondition:
handle is a valid (non-NULL) universal algorithm handle and the universal algorithm instance is in the created state.
Return values:
UNIVERSAL_EOK | Success.
UNIVERSAL_EFAIL | Failure.
UNIVERSAL_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
UNIVERSAL_create()
UNIVERSAL_delete()
IUNIVERSAL_Fxns::control()
UNIVERSAL_Handle UNIVERSAL_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | UNIVERSAL_Params * | params
 | ) |  |

Create an instance of a universal algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via UNIVERSAL_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of universal algorithm to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created universal algorithm instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the universal algorithm.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
UNIVERSAL_delete()
Void UNIVERSAL_delete ( UNIVERSAL_Handle handle )

Delete the instance of a universal algorithm.

Parameters:
[in] handle Handle to a created universal algorithm instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the universal algorithm.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the UNIVERSAL_create() operation (memory, DMA channels, etc.) are freed.
See also:
UNIVERSAL_create()
Int32 UNIVERSAL_process | ( | UNIVERSAL_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | XDM1_BufDesc * | inOutBufs,
 |  | UNIVERSAL_InArgs * | inArgs,
 |  | UNIVERSAL_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a universal algorithm.

Parameters:
[in] | handle | Handle to a created universal algorithm instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in,out] | inOutBufs | A buffer descriptor containing in/out buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) universal algorithm handle and the universal algorithm instance is in the created state.
Return values:
UNIVERSAL_EOK | Success.
UNIVERSAL_EFAIL | Failure.
UNIVERSAL_EUNSUPPORTED | Unsupported request.
Remarks:
Since the UNIVERSAL algorithm contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to UNIVERSAL_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
UNIVERSAL_create()
UNIVERSAL_delete()
UNIVERSAL_control()
UNIVERSAL_processAsync()
UNIVERSAL_processWait()
IUNIVERSAL_Fxns::process()
XDAS_Int32 UNIVERSAL_processAsync | ( | UNIVERSAL_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | XDM1_BufDesc * | inOutBufs,
 |  | IUNIVERSAL_InArgs * | inArgs,
 |  | IUNIVERSAL_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a universal algorithm.

Parameters:
[in] | handle | Handle to a created universal algorithm instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in,out] | inOutBufs | A buffer descriptor containing in/out buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) universal algorithm handle and the universal algorithm instance is in the created state.
Return values:
UNIVERSAL_EOK | Success.
UNIVERSAL_EFAIL | Failure.
UNIVERSAL_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the UNIVERSAL_processWait() API.
The buffers supplied to UNIVERSAL_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
UNIVERSAL_create()
UNIVERSAL_delete()
UNIVERSAL_control()
UNIVERSAL_process()
UNIVERSAL_processWait()
IUNIVERSAL_Fxns::process()
XDAS_Int32 UNIVERSAL_processWait | ( | UNIVERSAL_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | XDM1_BufDesc * | inOutBufs,
 |  | IUNIVERSAL_InArgs * | inArgs,
 |  | IUNIVERSAL_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of UNIVERSAL_processAsync() in this instance of a universal algorithm.

Parameters:
[in] | handle | Handle to a created universal algorithm instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in,out] | inOutBufs | A buffer descriptor containing in/out buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> UNIVERSAL_FOREVER)
Precondition:
handle is a valid (non-NULL) universal algorithm handle and the universal algorithm instance is in the created state.
Return values:
UNIVERSAL_EOK | Success.
UNIVERSAL_EFAIL | Failure.
UNIVERSAL_EUNSUPPORTED | Unsupported request.
UNIVERSAL_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of UNIVERSAL_EFOREVER.
There must have previously been an invocation of the UNIVERSAL_processAsync() API.
The buffers supplied to UNIVERSAL_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
UNIVERSAL_create()
UNIVERSAL_delete()
UNIVERSAL_control()
UNIVERSAL_process()
UNIVERSAL_processAsync()


Codec Engine Application Programming Interface (API): Codec Engine Tracing Utility

Codec Engine Tracing Utility

Defines

#define | TRACEUTIL_SUCCESS 0
#define | TRACEUTIL_FAILURE -1

Functions

Int | TraceUtil_start (String engineName)
Begin using the TraceUtil module; create thread that periodically collects DSP trace.
Int | TraceUtil_stop (Void)
Finish using the TraceUtil module, stop the collecting thread.

Define Documentation

#define TRACEUTIL_SUCCESS 0

Success.

#define TRACEUTIL_FAILURE -1

General system error.

Function Documentation

Int TraceUtil_start ( String engineName )

Begin using the TraceUtil module; create thread that periodically collects DSP trace.

Parameters:
[in] engineName Name of the engine. This uses the same name conventions as Engine_open()'s name.
Return values:
TRACEUTIL_SUCCESS | Success.
TRACEUTIL_FAILURE | Failed to initialize the necessary tracing resources.
See also:
TraceUtil_stop()
Int TraceUtil_stop ( Void )

Finish using the TraceUtil module, stop the collecting thread.

Return values:
TRACEUTIL_SUCCESS | Success.
TRACEUTIL_FAILURE | Failed to free the necessary tracing resources.
See also:
TraceUtil_start()


Codec Engine Application Programming Interface (API): Video Analytics Algorithm Interface

Video Analytics Algorithm Interface

Defines

#define | VIDANALYTICS_EOK IVIDANALYTICS_EOK
#define | VIDANALYTICS_EFAIL IVIDANALYTICS_EFAIL
#define | VIDANALYTICS_EUNSUPPORTED IVIDANALYTICS_EUNSUPPORTED
#define | VIDANALYTICS_ETIMEOUT VISA_ETIMEOUT
#define | VIDANALYTICS_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | VIDANALYTICS_Handle
Opaque handle to a VIDANALYTICS codec.
typedef struct IVIDANALYTICS_Params | VIDANALYTICS_Params
This structure defines the parameters necessary to create an instance of a video analytics algorithm.
typedef IVIDANALYTICS_InArgs | VIDANALYTICS_InArgs
typedef IVIDANALYTICS_OutArgs | VIDANALYTICS_OutArgs
typedef IVIDANALYTICS_Cmd | VIDANALYTICS_Cmd
typedef IVIDANALYTICS_Status | VIDANALYTICS_Status
typedef IVIDANALYTICS_DynamicParams | VIDANALYTICS_DynamicParams

Functions

Int32 | VIDANALYTICS_control (VIDANALYTICS_Handle handle, VIDANALYTICS_Cmd id, VIDANALYTICS_DynamicParams *params, VIDANALYTICS_Status *status)
Execute the control() method in this instance of a video analytics algorithm.
VIDANALYTICS_Handle | VIDANALYTICS_create (Engine_Handle e, String name, VIDANALYTICS_Params *params)
Create an instance of a video analytics algorithm.
Void | VIDANALYTICS_delete (VIDANALYTICS_Handle handle)
Delete the instance of a video analytics algorithm.
Int32 | VIDANALYTICS_process (VIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, VIDANALYTICS_InArgs *inArgs, VIDANALYTICS_OutArgs *outArgs)
Execute the process() method in this instance of a video analytics algorithm.
XDAS_Int32 | VIDANALYTICS_processAsync (VIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs, IVIDANALYTICS_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video analytics algorithm.
XDAS_Int32 | VIDANALYTICS_processWait (VIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs, IVIDANALYTICS_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDANALYTICS_processAsync() in this instance of an video analytics algorithm.

Detailed Description

This is the video analytics codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define VIDANALYTICS_EOK IVIDANALYTICS_EOK

Success.

#define VIDANALYTICS_EFAIL IVIDANALYTICS_EFAIL

General failure.

#define VIDANALYTICS_EUNSUPPORTED IVIDANALYTICS_EUNSUPPORTED

Request is unsupported. Timeout occurred.

#define VIDANALYTICS_ETIMEOUT VISA_ETIMEOUT

Special value for timeout parameter indicating never timeout.

#define VIDANALYTICS_FOREVER VISA_FOREVER

Typedef Documentation

typedef VISA_Handle VIDANALYTICS_Handle

Opaque handle to a VIDANALYTICS codec.

typedef struct IVIDANALYTICS_Params VIDANALYTICS_Params

This structure defines the parameters necessary to create an instance of a video analytics algorithm.

typedef IVIDANALYTICS_InArgs VIDANALYTICS_InArgs

Defines the input arguments for all IVIDANALYTICS instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDANALYTICS_Fxns::process()

typedef IVIDANALYTICS_OutArgs VIDANALYTICS_OutArgs

Defines the run time output arguments for all IVIDANALYTICS instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::process()

typedef IVIDANALYTICS_Cmd VIDANALYTICS_Cmd

Defines the control commands for the IVIDANALYTICS module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDANALYTICS_Fxns::control()

typedef IVIDANALYTICS_Status VIDANALYTICS_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDANALYTICS_Fxns::control()

typedef IVIDANALYTICS_DynamicParams VIDANALYTICS_DynamicParams

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDANALYTICS_Fxns::control()

Function Documentation

Int32 VIDANALYTICS_control | ( | VIDANALYTICS_Handle | handle,
 |  | VIDANALYTICS_Cmd | id,
 |  | VIDANALYTICS_DynamicParams * | params,
 |  | VIDANALYTICS_Status * | status
 | ) |  |

Execute the control() method in this instance of a video analytics algorithm.

Parameters:
[in] | handle | Handle to a created video analytics instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for the video analytics instance.
[out] | status | Status info returned by the video analytics instance.
Precondition:
handle is a valid (non-NULL) video analytics handle and the video analytics instance is in the created state.
Return values:
VIDANALYTICS_EOK | Success.
VIDANALYTICS_EFAIL | Failure.
VIDANALYTICS_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDANALYTICS_create()
VIDANALYTICS_delete()
IVIDANALYTICS_Fxns::control()
VIDANALYTICS_Handle VIDANALYTICS_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDANALYTICS_Params * | params
 | ) |  |

Create an instance of a video analytics algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDANALYTICS_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video analytics algorithm to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video analytics instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video analytics algorithm.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
VIDANALYTICS_delete()
Void VIDANALYTICS_delete ( VIDANALYTICS_Handle handle )

Delete the instance of a video analytics algorithm.

Parameters:
[in] handle Handle to a created video analytics instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video analytics algorithm.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDANALYTICS_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDANALYTICS_create()
Int32 VIDANALYTICS_process | ( | VIDANALYTICS_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | VIDANALYTICS_InArgs * | inArgs,
 |  | VIDANALYTICS_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video analytics algorithm.

Parameters:
[in] | handle | Handle to a created video analytics instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video analytics handle and the video analytics algorithm instance is in the created state.
Return values:
VIDANALYTICS_EOK | Success.
VIDANALYTICS_EFAIL | Failure.
VIDANALYTICS_EUNSUPPORTED | Unsupported request.
Remarks:
Since the VIDANALYTICS algorithm contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to VIDANALYTICS_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDANALYTICS_create()
VIDANALYTICS_delete()
VIDANALYTICS_control()
VIDANALYTICS_processAsync()
VIDANALYTICS_processWait()
IVIDANALYTICS_Fxns::process()
XDAS_Int32 VIDANALYTICS_processAsync | ( | VIDANALYTICS_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IVIDANALYTICS_InArgs * | inArgs,
 |  | IVIDANALYTICS_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video analytics algorithm.

Parameters:
[in] | handle | Handle to a created video analytics instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video analytics handle and the video analytics algorithm instance is in the created state.
Return values:
VIDANALYTICS_EOK | Success.
VIDANALYTICS_EFAIL | Failure.
VIDANALYTICS_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDANALYTICS_processWait() API.
The buffers supplied to VIDANALYTICS_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDANALYTICS_create()
VIDANALYTICS_delete()
VIDANALYTICS_control()
VIDANALYTICS_process()
VIDANALYTICS_processWait()
IVIDANALYTICS_Fxns::process()
XDAS_Int32 VIDANALYTICS_processWait | ( | VIDANALYTICS_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM1_BufDesc * | outBufs,
 |  | IVIDANALYTICS_InArgs * | inArgs,
 |  | IVIDANALYTICS_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDANALYTICS_processAsync() in this instance of an video analytics algorithm.

Parameters:
[in] | handle | Handle to a created video analytics instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDANALYTICS_FOREVER)
Precondition:
handle is a valid (non-NULL) video analytics handle and the video analytics algorithm instance is in the created state.
Return values:
VIDANALYTICS_EOK | Success.
VIDANALYTICS_EFAIL | Failure.
VIDANALYTICS_EUNSUPPORTED | Unsupported request.
VIDANALYTICS_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDANALYTICS_EFOREVER.
There must have previously been an invocation of the VIDANALYTICS_processAsync() API.
The buffers supplied to VIDANALYTICS_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDANALYTICS_create()
VIDANALYTICS_delete()
VIDANALYTICS_control()
VIDANALYTICS_process()
VIDANALYTICS_processAsync()


Codec Engine Application Programming Interface (API): VIDDEC Video Decoder Interface

VIDDEC Video Decoder Interface

Data Structures

struct | IVIDDEC_CodecClassConfig
Definition of VIDDEC codec class configurable parameters. More...

Defines

#define | VIDDEC_EOK IVIDDEC_EOK
#define | VIDDEC_EFAIL IVIDDEC_EFAIL
#define | VIDDEC_ERUNTIME IVIDDEC_ERUNTIME
#define | VIDDEC_ETIMEOUT VISA_ETIMEOUT
#define | VIDDEC_FOREVER VISA_FOREVER

Typedefs

typedef IVIDDEC_Status | VIDDEC_Status
typedef VISA_Handle | VIDDEC_Handle
Opaque handle to a VIDDEC codec.
typedef struct IVIDDEC_Params | VIDDEC_Params
This structure defines the parameters necessary to create an instance of a video decoder object.
typedef IVIDDEC_InArgs | VIDDEC_InArgs
typedef IVIDDEC_OutArgs | VIDDEC_OutArgs
typedef IVIDDEC_Cmd | VIDDEC_Cmd
typedef IVIDDEC_DynamicParams | VIDDEC_DynamicParams

Functions

VIDDEC_Handle | VIDDEC_create (Engine_Handle e, String name, VIDDEC_Params *params)
Create an instance of a video decoder algorithm.
Int32 | VIDDEC_process (VIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs)
Execute the process() method in this instance of a video decoder algorithm.
Int32 | VIDDEC_control (VIDDEC_Handle handle, VIDDEC_Cmd id, VIDDEC_DynamicParams *params, VIDDEC_Status *status)
Execute the "control" method in this instance of a video decoder algorithm.
Void | VIDDEC_delete (VIDDEC_Handle handle)
Delete the instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC_processAsync (VIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC_processWait (VIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDDEC_processAsync() in this instance of an video decoder algorithm.

Detailed Description

This is the VIDDEC video decoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define VIDDEC_EOK IVIDDEC_EOK

Success.

#define VIDDEC_EFAIL IVIDDEC_EFAIL

General failure.

#define VIDDEC_ERUNTIME IVIDDEC_ERUNTIME

General runtime failure.

#define VIDDEC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define VIDDEC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IVIDDEC_Status VIDDEC_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::control()

typedef VISA_Handle VIDDEC_Handle

Opaque handle to a VIDDEC codec.

typedef struct IVIDDEC_Params VIDDEC_Params

This structure defines the parameters necessary to create an instance of a video decoder object.

typedef IVIDDEC_InArgs VIDDEC_InArgs

Defines the input arguments for all IVIDDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::process()

typedef IVIDDEC_OutArgs VIDDEC_OutArgs

Defines the run time output arguments for all IVIDDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::process()

typedef IVIDDEC_Cmd VIDDEC_Cmd

Defines the control commands for the IVIDDEC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDDEC_Fxns::control()

typedef IVIDDEC_DynamicParams VIDDEC_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::control()

Function Documentation

VIDDEC_Handle VIDDEC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDDEC_Params * | params
 | ) |  |

Create an instance of a video decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDDEC_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
VIDDEC_delete()
Int32 VIDDEC_process | ( | VIDDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC_InArgs * | inArgs,
 |  | VIDDEC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC_EOK | Success.
VIDDEC_EFAIL | Failure.
VIDDEC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the VIDDEC decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to VIDDEC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC_create()
VIDDEC_delete()
VIDDEC_control()
VIDDEC_processAsync()
VIDDEC_processWait()
IVIDDEC_Fxns::process()
Int32 VIDDEC_control | ( | VIDDEC_Handle | handle,
 |  | VIDDEC_Cmd | id,
 |  | VIDDEC_DynamicParams * | params,
 |  | VIDDEC_Status * | status
 | ) |  |

Execute the "control" method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC_EOK | Success.
VIDDEC_EFAIL | Failure.
VIDDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDDEC_create()
VIDDEC_delete()
IVIDDEC_Fxns::control()
Void VIDDEC_delete ( VIDDEC_Handle handle )

Delete the instance of a video decoder algorithm.

Parameters:
[in] handle Handle to a created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDDEC_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDDEC_create()
XDAS_Int32 VIDDEC_processAsync | ( | VIDDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC_InArgs * | inArgs,
 |  | VIDDEC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC_EOK | Success.
VIDDEC_EFAIL | Failure.
VIDDEC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDDEC_processWait() API.
The buffers supplied to VIDDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC_create()
VIDDEC_delete()
VIDDEC_control()
VIDDEC_process()
VIDDEC_processWait()
IVIDDEC_Fxns::process()
XDAS_Int32 VIDDEC_processWait | ( | VIDDEC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC_InArgs * | inArgs,
 |  | VIDDEC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDDEC_processAsync() in this instance of an video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDDEC_FOREVER)
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC_EOK | Success.
VIDDEC_EFAIL | Failure.
VIDDEC_ERUNTIME | Internal Runtime Error.
VIDDEC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDDEC_EFOREVER.
There must have previously been an invocation of the VIDDEC_processAsync() API.
The buffers supplied to VIDDEC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC_create()
VIDDEC_delete()
VIDDEC_control()
VIDDEC_process()
VIDDEC_processAsync()


Codec Engine Application Programming Interface (API): VIDENC Video Encoder Interface

VIDENC Video Encoder Interface

Data Structures

struct | IVIDENC_CodecClassConfig
Definition of IVIDENC codec class configurable parameters. More...

Defines

#define | VIDENC_EOK IVIDENC_EOK
#define | VIDENC_EFAIL IVIDENC_EFAIL
#define | VIDENC_ERUNTIME IVIDENC_ERUNTIME
#define | VIDENC_ETIMEOUT VISA_ETIMEOUT
#define | VIDENC_FOREVER VISA_FOREVER

Typedefs

typedef IVIDENC_Status | VIDENC_Status
typedef VISA_Handle | VIDENC_Handle
Opaque handle to a VIDENC codec.
typedef struct IVIDENC_Params | VIDENC_Params
This structure defines the parameters necessary to create an instance of a video encoder object.
typedef IVIDENC_InArgs | VIDENC_InArgs
typedef IVIDENC_OutArgs | VIDENC_OutArgs
typedef IVIDENC_Cmd | VIDENC_Cmd
typedef IVIDENC_DynamicParams | VIDENC_DynamicParams

Functions

VIDENC_Handle | VIDENC_create (Engine_Handle e, String name, VIDENC_Params *params)
Create an instance of a video encoder algorithm.
Int32 | VIDENC_process (VIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDENC_InArgs *inArgs, VIDENC_OutArgs *outArgs)
Execute the process() method in this instance of a video encoder algorithm.
Int32 | VIDENC_control (VIDENC_Handle handle, VIDENC_Cmd id, VIDENC_DynamicParams *params, VIDENC_Status *status)
Execute the "control" method in this instance of a video encoder algorithm.
Void | VIDENC_delete (VIDENC_Handle handle)
Delete the instance of a video encoder algorithm.
XDAS_Int32 | VIDENC_processAsync (VIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDENC_processWait (VIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDENC_processAsync() in this instance of an video decoder algorithm.

Detailed Description

This is the VIDENC video encoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define VIDENC_EOK IVIDENC_EOK

Success.

#define VIDENC_EFAIL IVIDENC_EFAIL

General failure.

#define VIDENC_ERUNTIME IVIDENC_ERUNTIME

General runtime failure.

#define VIDENC_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define VIDENC_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IVIDENC_Status VIDENC_Status

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::control()

typedef VISA_Handle VIDENC_Handle

Opaque handle to a VIDENC codec.

typedef struct IVIDENC_Params VIDENC_Params

This structure defines the parameters necessary to create an instance of a video encoder object.

typedef IVIDENC_InArgs VIDENC_InArgs

Defines the input arguments for all IVIDDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::process()

typedef IVIDENC_OutArgs VIDENC_OutArgs

Defines the run time output arguments for all IVIDENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::process()

typedef IVIDENC_Cmd VIDENC_Cmd

Defines the control commands for the IVIDENC module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDENC_Fxns::control()

typedef IVIDENC_DynamicParams VIDENC_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::control()

Function Documentation

VIDENC_Handle VIDENC_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDENC_Params * | params
 | ) |  |

Create an instance of a video encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDENC_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video encoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
VIDENC_delete()
Int32 VIDENC_process | ( | VIDENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDENC_InArgs * | inArgs,
 |  | VIDENC_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video encoder algorithm.

Parameters:
[in] | handle | Handle to a created video encoder instance.
[in] | inBufs | A buffer describer containing input buffers.
[out] | outBufs | A buffer describer containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video encoder handle and the video encoder is in the created state.
Return values:
VIDENC_EOK | Success.
VIDENC_EFAIL | Failure.
VIDENC_ERUNTIME | Internal Runtime Error.
Remarks:
Since the VIDENC decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to VIDENC_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDENC_create()
VIDENC_delete()
VIDENC_control()
VIDENC_processAsync()
VIDENC_processWait()
IVIDENC_Fxns::process()
Int32 VIDENC_control | ( | VIDENC_Handle | handle,
 |  | VIDENC_Cmd | id,
 |  | VIDENC_DynamicParams * | params,
 |  | VIDENC_Status * | status
 | ) |  |

Execute the "control" method in this instance of a video encoder algorithm.

Parameters:
[in] | handle | Handle to a created video encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) video encoder handle and the video encoder is in the created state.
Return values:
VIDENC_EOK | Success.
VIDENC_EFAIL | Failure.
VIDENC_ERUNTIME | Internal Runtime Error.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDENC_create()
VIDENC_delete()
IVIDENC_Fxns::process()
Void VIDENC_delete ( VIDENC_Handle handle )

Delete the instance of a video encoder algorithm.

Parameters:
[in] handle Handle to a created video encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDENC_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDENC_create()
XDAS_Int32 VIDENC_processAsync | ( | VIDENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IVIDENC_InArgs * | inArgs,
 |  | IVIDENC_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDENC_EOK | Success.
VIDENC_EFAIL | Failure.
VIDENC_ERUNTIME | Internal Runtime Error.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDENC_processWait() API.
The buffers supplied to VIDENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDENC_create()
VIDENC_delete()
VIDENC_control()
VIDENC_process()
VIDENC_processWait()
IVIDENC_Fxns::process()
XDAS_Int32 VIDENC_processWait | ( | VIDENC_Handle | handle,
 |  | XDM_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IVIDENC_InArgs * | inArgs,
 |  | IVIDENC_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDENC_processAsync() in this instance of an video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDENC_FOREVER)
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDENC_EOK | Success.
VIDENC_EFAIL | Failure.
VIDENC_ERUNTIME | Internal Runtime Error.
VIDENC_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDENC_EFOREVER.
There must have previously been an invocation of the VIDENC_processAsync() API.
The buffers supplied to VIDENC_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDENC_create()
VIDENC_delete()
VIDENC_control()
VIDENC_process()
VIDENC_processAsync()


Codec Engine Application Programming Interface (API): Video 1.0 decoder codec interface

Video 1.0 decoder codec interface

Data Structures

struct | IVIDDEC1_CodecClassConfig
Definition of IVIDDEC1 codec class configurable parameters. More...

Defines

#define | VIDDEC1_EOK IVIDDEC1_EOK
#define | VIDDEC1_EFAIL IVIDDEC1_EFAIL
#define | VIDDEC1_EUNSUPPORTED IVIDDEC1_EUNSUPPORTED
#define | VIDDEC1_ETIMEOUT VISA_ETIMEOUT
#define | VIDDEC1_FOREVER VISA_FOREVER

Typedefs

typedef IVIDDEC1_Status | VIDDEC1_Status
typedef VISA_Handle | VIDDEC1_Handle
Opaque handle to a VIDDEC1 codec.
typedef struct IVIDDEC1_Params | VIDDEC1_Params
This structure defines the parameters necessary to create an instance of a Video Decoder object.
typedef IVIDDEC1_InArgs | VIDDEC1_InArgs
typedef IVIDDEC1_OutArgs | VIDDEC1_OutArgs
typedef IVIDDEC1_Cmd | VIDDEC1_Cmd
typedef IVIDDEC1_DynamicParams | VIDDEC1_DynamicParams

Functions

VIDDEC1_Handle | VIDDEC1_create (Engine_Handle e, String name, VIDDEC1_Params *params)
Create an instance of a video decoder algorithm.
Int32 | VIDDEC1_process (VIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs)
Execute the process() method in this instance of a video decoder algorithm.
Int32 | VIDDEC1_control (VIDDEC1_Handle handle, VIDDEC1_Cmd id, VIDDEC1_DynamicParams *params, VIDDEC1_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
Void | VIDDEC1_delete (VIDDEC1_Handle handle)
Delete the instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC1_processAsync (VIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC1_processWait (VIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDDEC1_processAsync() in this instance of an video decoder algorithm.

Detailed Description

This is the 1.0 video decoder codec interface. Several of the data types in this API are specified by the XDM 1.0 interface; please see the XDM documentation for those details.

Define Documentation

#define VIDDEC1_EOK IVIDDEC1_EOK

Success.

#define VIDDEC1_EFAIL IVIDDEC1_EFAIL

General failure. Request is unsupported.

#define VIDDEC1_EUNSUPPORTED IVIDDEC1_EUNSUPPORTED
#define VIDDEC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define VIDDEC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IVIDDEC1_Status VIDDEC1_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
All fields correspond to latest IVIDDEC1_Fxns::process() call on the particular instance of the decoder.
See also:
IVIDDEC1_Fxns::control()

typedef VISA_Handle VIDDEC1_Handle

Opaque handle to a VIDDEC1 codec.

typedef struct IVIDDEC1_Params VIDDEC1_Params

This structure defines the parameters necessary to create an instance of a Video Decoder object.

typedef IVIDDEC1_InArgs VIDDEC1_InArgs

Defines the input arguments for all IVIDDEC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::process()

typedef IVIDDEC1_OutArgs VIDDEC1_OutArgs

Defines the run time output arguments for all IVIDDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::process()

typedef IVIDDEC1_Cmd VIDDEC1_Cmd

Defines the control commands for the IVIDDEC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDDEC1_Fxns::control()

typedef IVIDDEC1_DynamicParams VIDDEC1_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::control()

Function Documentation

VIDDEC1_Handle VIDDEC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDDEC1_Params * | params
 | ) |  |

Create an instance of a video decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDDEC1_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
Int32 VIDDEC1_process | ( | VIDDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC1_InArgs * | inArgs,
 |  | VIDDEC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer describer containing input buffers.
[out] | outBufs | A buffer describer containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC1_EOK | Success.
VIDDEC1_EFAIL | Failure.
Remarks:
Since the VIDDEC1 decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to VIDDEC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC1_create()
VIDDEC1_delete()
VIDDEC1_control()
VIDDEC1_processAsync()
VIDDEC1_processWait()
IVIDDEC1_Fxns::process()
Int32 VIDDEC1_control | ( | VIDDEC1_Handle | handle,
 |  | VIDDEC1_Cmd | id,
 |  | VIDDEC1_DynamicParams * | params,
 |  | VIDDEC1_Status * | status
 | ) |  |

Execute the control() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC1_EOK | Success.
VIDDEC1_EFAIL | Failure.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDDEC1_create()
VIDDEC1_delete()
IVIDDEC1_Fxns::process()
Void VIDDEC1_delete ( VIDDEC1_Handle handle )

Delete the instance of a video decoder algorithm.

Parameters:
[in] handle Handle to a created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDDEC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDDEC1_create()
XDAS_Int32 VIDDEC1_processAsync | ( | VIDDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC1_InArgs * | inArgs,
 |  | VIDDEC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC1_EOK | Success.
VIDDEC1_EFAIL | Failure.
VIDDEC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDDEC1_processWait() API.
The buffers supplied to VIDDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC1_create()
VIDDEC1_delete()
VIDDEC1_control()
VIDDEC1_process()
VIDDEC1_processWait()
IVIDDEC1_Fxns::process()
XDAS_Int32 VIDDEC1_processWait | ( | VIDDEC1_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC1_InArgs * | inArgs,
 |  | VIDDEC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDDEC1_processAsync() in this instance of an video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDDEC1_FOREVER)
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC1_EOK | Success.
VIDDEC1_EFAIL | Failure.
VIDDEC1_EUNSUPPORTED | Unsupported request.
VIDDEC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDDEC1_EFOREVER.
There must have previously been an invocation of the VIDDEC1_processAsync() API.
The buffers supplied to VIDDEC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC1_create()
VIDDEC1_delete()
VIDDEC1_control()
VIDDEC1_process()
VIDDEC1_processAsync()


Codec Engine Application Programming Interface (API): Video encoder codec interface

Video encoder codec interface

Defines

#define | VIDENC1_EOK IVIDENC1_EOK
#define | VIDENC1_EFAIL IVIDENC1_EFAIL
#define | VIDENC1_EUNSUPPORTED IVIDENC1_EUNSUPPORTED
#define | VIDENC1_ETIMEOUT VISA_ETIMEOUT
#define | VIDENC1_FOREVER VISA_FOREVER

Typedefs

typedef IVIDENC1_Status | VIDENC1_Status
typedef VISA_Handle | VIDENC1_Handle
Opaque handle to a VIDENC1 codec.
typedef struct IVIDENC1_Params | VIDENC1_Params
This structure defines the parameters necessary to create an instance of a VIDENC1-based video encoder.
typedef IVIDENC1_InArgs | VIDENC1_InArgs
typedef IVIDENC1_OutArgs | VIDENC1_OutArgs
typedef IVIDENC1_Cmd | VIDENC1_Cmd
typedef IVIDENC1_DynamicParams | VIDENC1_DynamicParams

Functions

VIDENC1_Handle | VIDENC1_create (Engine_Handle e, String name, VIDENC1_Params *params)
Create an instance of a video encoder algorithm.
Int32 | VIDENC1_process (VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, VIDENC1_InArgs *inArgs, VIDENC1_OutArgs *outArgs)
Execute the process() method in this instance of a video encoder algorithm.
Int32 | VIDENC1_control (VIDENC1_Handle handle, VIDENC1_Cmd id, VIDENC1_DynamicParams *params, VIDENC1_Status *status)
Execute the control() method in this instance of a video encoder algorithm.
Void | VIDENC1_delete (VIDENC1_Handle handle)
Delete the instance of a video encoder algorithm.
XDAS_Int32 | VIDENC1_processAsync (VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDENC1_processWait (VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDENC1_processAsync() in this instance of an video decoder algorithm.

Detailed Description

This is the VIDENC1 video encoder codec interface. Several of the data types in this API are specified by the XDM IVIDENC1 interface; please see the XDM documentation for those details.

Define Documentation

#define VIDENC1_EOK IVIDENC1_EOK

Success.

#define VIDENC1_EFAIL IVIDENC1_EFAIL

General failure. Request is unsupported.

#define VIDENC1_EUNSUPPORTED IVIDENC1_EUNSUPPORTED
#define VIDENC1_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define VIDENC1_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef IVIDENC1_Status VIDENC1_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::control()

typedef VISA_Handle VIDENC1_Handle

Opaque handle to a VIDENC1 codec.

typedef struct IVIDENC1_Params VIDENC1_Params

This structure defines the parameters necessary to create an instance of a VIDENC1-based video encoder.

typedef IVIDENC1_InArgs VIDENC1_InArgs

Defines the input arguments for all IVIDENC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::process()

typedef IVIDENC1_OutArgs VIDENC1_OutArgs

Defines the run time output arguments for all IVIDENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::process()

typedef IVIDENC1_Cmd VIDENC1_Cmd

Defines the control commands for the IVIDENC1 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDENC1_Fxns::control()

typedef IVIDENC1_DynamicParams VIDENC1_DynamicParams

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::control()

Function Documentation

VIDENC1_Handle VIDENC1_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDENC1_Params * | params
 | ) |  |

Create an instance of a video encoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDENC1_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video encoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video encoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
Int32 VIDENC1_process | ( | VIDENC1_Handle | handle,
 |  | IVIDEO1_BufDescIn * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDENC1_InArgs * | inArgs,
 |  | VIDENC1_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video encoder algorithm.

Parameters:
[in] | handle | Handle to a created video encoder instance.
[in] | inBufs | A buffer describer containing input buffers.
[out] | outBufs | A buffer describer containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video encoder handle and the video encoder is in the created state.
Return values:
VIDENC1_EOK | Success.
VIDENC1_EFAIL | Failure.
Remarks:
Since the VIDENC1 decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to VIDENC1_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDENC1_create()
VIDENC1_delete()
VIDENC1_control()
VIDENC1_processAsync()
VIDENC1_processWait()
IVIDENC1_Fxns::process()
Int32 VIDENC1_control | ( | VIDENC1_Handle | handle,
 |  | VIDENC1_Cmd | id,
 |  | VIDENC1_DynamicParams * | params,
 |  | VIDENC1_Status * | status
 | ) |  |

Execute the control() method in this instance of a video encoder algorithm.

Parameters:
[in] | handle | Handle to a created video encoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for encoding.
[out] | status | Status info upon completion of encode operation.
Precondition:
handle is a valid (non-NULL) video encoder handle and the video encoder is in the created state.
Return values:
VIDENC1_EOK | Success.
VIDENC1_EFAIL | Failure.
Remarks:
This is a blocking call, and will return after the control command has been executed.
If VIDENC1_EFAIL is returned, status->extendedError may indicate further details about the error. See XDM_ErrorBit for details.
See also:
VIDENC1_create()
VIDENC1_delete()
IVIDENC1_Fxns::process()
XDM_ErrorBit
Void VIDENC1_delete ( VIDENC1_Handle handle )

Delete the instance of a video encoder algorithm.

Parameters:
[in] handle Handle to a created video encoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video encoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDENC1_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDENC1_create()
XDAS_Int32 VIDENC1_processAsync | ( | VIDENC1_Handle | handle,
 |  | IVIDEO1_BufDescIn * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IVIDENC1_InArgs * | inArgs,
 |  | IVIDENC1_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDENC1_EOK | Success.
VIDENC1_EFAIL | Failure.
VIDENC1_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDENC1_processWait() API.
The buffers supplied to VIDENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDENC1_create()
VIDENC1_delete()
VIDENC1_control()
VIDENC1_process()
VIDENC1_processWait()
IVIDENC1_Fxns::process()
XDAS_Int32 VIDENC1_processWait | ( | VIDENC1_Handle | handle,
 |  | IVIDEO1_BufDescIn * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IVIDENC1_InArgs * | inArgs,
 |  | IVIDENC1_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDENC1_processAsync() in this instance of an video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDENC1_FOREVER)
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDENC1_EOK | Success.
VIDENC1_EFAIL | Failure.
VIDENC1_EUNSUPPORTED | Unsupported request.
VIDENC1_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDENC1_EFOREVER.
There must have previously been an invocation of the VIDENC1_processAsync() API.
The buffers supplied to VIDENC1_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDENC1_create()
VIDENC1_delete()
VIDENC1_control()
VIDENC1_process()
VIDENC1_processAsync()


Codec Engine Application Programming Interface (API): Split video decoder interface

Split video decoder interface

Data Structures

struct | IVIDDEC2BACK_CodecClassConfig
Definition of IVIDDEC2BACK codec class configurable parameters. More...

Typedefs

typedef IVIDDEC2FRONT_Status | VIDDEC2FRONT_Status
typedef VISA_Handle | VIDDEC2FRONT_Handle
Opaque handle to a VIDDEC2FRONT codec.
typedef VISA_Handle | VIDDEC2BACK_Handle
Opaque handle to a VIDDEC2BACK codec.
typedef IVIDDEC2FRONT_OutArgs | VIDDEC2FRONT_OutArgs

Functions

VIDDEC2BACK_Handle | VIDDEC2BACK_create (Engine_Handle e, String name, VIDDEC2_Params *params)
Create an instance of the BACK end of a split video decoder algorithm.
Int32 | VIDDEC2BACK_process (VIDDEC2BACK_Handle handle, XDM_Context *context, VIDDEC2_OutArgs *outArgs)
Execute the process() method in this instance of a BACK side split video decoder algorithm.
Int32 | VIDDEC2BACK_control (VIDDEC2BACK_Handle handle, XDM_Context *context, VIDDEC2_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
Void | VIDDEC2BACK_delete (VIDDEC2BACK_Handle handle)
Delete the instance of a video decoder algorithm.
VIDDEC2FRONT_Handle | VIDDEC2FRONT_create (Engine_Handle e, String name, VIDDEC2_Params *params)
Create an instance of the FRONT end of a split video decoder algorithm.
Int32 | VIDDEC2FRONT_process (VIDDEC2FRONT_Handle handle, VIDDEC2_InArgs *inArgs, XDM_Context *context, VIDDEC2FRONT_OutArgs *outArgs)
Execute the process() method in this instance of a FRONT side split video decoder algorithm.
Int32 | VIDDEC2FRONT_control (VIDDEC2FRONT_Handle handle, VIDDEC2_Cmd id, VIDDEC2_DynamicParams *params, XDM_Context *context, VIDDEC2FRONT_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
Void | VIDDEC2FRONT_delete (VIDDEC2FRONT_Handle handle)
Delete the instance of a video decoder algorithm.

Detailed Description

This is the split VIDDEC2 video decoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Typedef Documentation

typedef IVIDDEC2FRONT_Status VIDDEC2FRONT_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
All fields correspond to latest IVIDDEC2_Fxns::process() call on the particular instance of the decoder.
See also:
IVIDDEC2_Fxns::control()

typedef VISA_Handle VIDDEC2FRONT_Handle

Opaque handle to a VIDDEC2FRONT codec.

typedef VISA_Handle VIDDEC2BACK_Handle

Opaque handle to a VIDDEC2BACK codec.

typedef IVIDDEC2FRONT_OutArgs VIDDEC2FRONT_OutArgs

Defines the run time output arguments for all IVIDDEC2FRONT instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2FRONT_Fxns::process()

Function Documentation

VIDDEC2BACK_Handle VIDDEC2BACK_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDDEC2_Params * | params
 | ) |  |

Create an instance of the BACK end of a split video decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDDEC2BACK_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
Int32 VIDDEC2BACK_process | ( | VIDDEC2BACK_Handle | handle,
 |  | XDM_Context * | context,
 |  | VIDDEC2_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a BACK side split video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in,out] | context | Context provided to, and managed by, the split codec.
[out] | outArgs | Output results. This is a required parameter
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
Remarks:
Since the VIDDEC2BACK decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to VIDDEC2BACK_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC2BACK_create()
VIDDEC2BACK_delete()
VIDDEC2BACK_control()
VIDDEC2BACK_processAsync()
VIDDEC2BACK_processWait()
IVIDDEC2BACK_Fxns::process()
VIDDEC2FRONT_create()
VIDDEC2FRONT_delete()
VIDDEC2FRONT_control()
IVIDDEC2FRONT_Fxns::process()
Int32 VIDDEC2BACK_control | ( | VIDDEC2BACK_Handle | handle,
 |  | XDM_Context * | context,
 |  | VIDDEC2_Status * | status
 | ) |  |

Execute the control() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in,out] | context | Context provided to, and managed by, the split codec.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDDEC2FRONT_create()
VIDDEC2FRONT_delete()
IVIDDEC2FRONT_Fxns::process()
VIDDEC2BACK_create()
VIDDEC2BACK_delete()
IVIDDEC2BACK_Fxns::process()
Void VIDDEC2BACK_delete ( VIDDEC2BACK_Handle handle )

Delete the instance of a video decoder algorithm.

Parameters:
[in] handle Handle to a created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDDEC2BACK_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDDEC2BACK_create()
VIDDEC2FRONT_Handle VIDDEC2FRONT_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDDEC2_Params * | params
 | ) |  |

Create an instance of the FRONT end of a split video decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDDEC2FRONT_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
Int32 VIDDEC2FRONT_process | ( | VIDDEC2FRONT_Handle | handle,
 |  | VIDDEC2_InArgs * | inArgs,
 |  | XDM_Context * | context,
 |  | VIDDEC2FRONT_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a FRONT side split video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inArgs | Input Arguments.
[in,out] | context | Context provided to, and managed by, the split codec.
[out] | outArgs | Output results. This is a required parameter
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
Remarks:
Since the VIDDEC2FRONT decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to VIDDEC2FRONT_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC2FRONT_create()
VIDDEC2FRONT_delete()
VIDDEC2FRONT_control()
IVIDDEC2FRONT_Fxns::process()
VIDDEC2BACK_create()
VIDDEC2BACK_delete()
VIDDEC2BACK_control()
VIDDEC2BACK_processAsync()
VIDDEC2BACK_processWait()
IVIDDEC2BACK_Fxns::process()
Int32 VIDDEC2FRONT_control | ( | VIDDEC2FRONT_Handle | handle,
 |  | VIDDEC2_Cmd | id,
 |  | VIDDEC2_DynamicParams * | params,
 |  | XDM_Context * | context,
 |  | VIDDEC2FRONT_Status * | status
 | ) |  |

Execute the control() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[in,out] | context | Context provided to, and managed by, the split codec.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDDEC2FRONT_create()
VIDDEC2FRONT_delete()
IVIDDEC2FRONT_Fxns::process()
VIDDEC2BACK_create()
VIDDEC2BACK_delete()
IVIDDEC2BACK_Fxns::process()
Void VIDDEC2FRONT_delete ( VIDDEC2FRONT_Handle handle )

Delete the instance of a video decoder algorithm.

Parameters:
[in] handle Handle to a created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDDEC2FRONT_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDDEC2FRONT_create()


Codec Engine Application Programming Interface (API): Video decoder codec interface

Video decoder codec interface

Data Structures

struct | IVIDDEC2_CodecClassConfig
Definition of IVIDDEC2 codec class configurable parameters. More...

Defines

#define | VIDDEC2_EOK IVIDDEC2_EOK
#define | VIDDEC2_EFAIL IVIDDEC2_EFAIL
#define | VIDDEC2_EUNSUPPORTED IVIDDEC2_EUNSUPPORTED
#define | VIDDEC2_ETIMEOUT VISA_ETIMEOUT
#define | VIDDEC2_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | VIDDEC2_Handle
Opaque handle to a VIDDEC2 codec.
typedef IVIDDEC2_Params | VIDDEC2_Params
typedef IVIDDEC2_InArgs | VIDDEC2_InArgs
typedef IVIDDEC2_OutArgs | VIDDEC2_OutArgs
typedef IVIDDEC2_Cmd | VIDDEC2_Cmd
typedef IVIDDEC2_DynamicParams | VIDDEC2_DynamicParams
typedef IVIDDEC2_Status | VIDDEC2_Status

Functions

Int32 | VIDDEC2_control (VIDDEC2_Handle handle, VIDDEC2_Cmd id, VIDDEC2_DynamicParams *params, VIDDEC2_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
VIDDEC2_Handle | VIDDEC2_create (Engine_Handle e, String name, VIDDEC2_Params *params)
Create an instance of a video decoder algorithm.
Void | VIDDEC2_delete (VIDDEC2_Handle handle)
Delete the instance of a video decoder algorithm.
Int32 | VIDDEC2_process (VIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs)
Execute the process() method in this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC2_processAsync (VIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC2_processWait (VIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDDEC2_processAsync() in this instance of an video decoder algorithm.

Detailed Description

This is the VIDDEC2 video decoder codec interface. Several of the data types in this API are specified by the XDM IVIDDEC2 interface; please see the XDM documentation for those details.

Define Documentation

#define VIDDEC2_EOK IVIDDEC2_EOK

Success.

#define VIDDEC2_EFAIL IVIDDEC2_EFAIL

General failure.

#define VIDDEC2_EUNSUPPORTED IVIDDEC2_EUNSUPPORTED

Request is unsupported.

#define VIDDEC2_ETIMEOUT VISA_ETIMEOUT

Timeout occurred.

#define VIDDEC2_FOREVER VISA_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef VISA_Handle VIDDEC2_Handle

Opaque handle to a VIDDEC2 codec.

typedef IVIDDEC2_Params VIDDEC2_Params

Defines the creation time parameters for all IVIDDEC2 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

typedef IVIDDEC2_InArgs VIDDEC2_InArgs

Defines the input arguments for all IVIDDEC2 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2_Fxns::process()

typedef IVIDDEC2_OutArgs VIDDEC2_OutArgs

Defines the run time output arguments for all IVIDDEC2 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2_Fxns::process()

typedef IVIDDEC2_Cmd VIDDEC2_Cmd

Defines the control commands for the IVIDDEC2 module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDDEC2_Fxns::control()

typedef IVIDDEC2_DynamicParams VIDDEC2_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2_Fxns::control()

typedef IVIDDEC2_Status VIDDEC2_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
All fields correspond to latest IVIDDEC2_Fxns::process() call on the particular instance of the decoder.
See also:
IVIDDEC2_Fxns::control()

Function Documentation

Int32 VIDDEC2_control | ( | VIDDEC2_Handle | handle,
 |  | VIDDEC2_Cmd | id,
 |  | VIDDEC2_DynamicParams * | params,
 |  | VIDDEC2_Status * | status
 | ) |  |

Execute the control() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for decoding.
[out] | status | Status info upon completion of decode operation.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
VIDDEC2_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDDEC2_create()
VIDDEC2_delete()
IVIDDEC2_Fxns::process()
VIDDEC2_Handle VIDDEC2_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDDEC2_Params * | params
 | ) |  |

Create an instance of a video decoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDDEC2_create) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video decoder to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video decoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video decoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
VIDDEC2_delete()
Void VIDDEC2_delete ( VIDDEC2_Handle handle )

Delete the instance of a video decoder algorithm.

Parameters:
[in] handle Handle to a created video decoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video decoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDDEC2_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDDEC2_create()
Int32 VIDDEC2_process | ( | VIDDEC2_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC2_InArgs * | inArgs,
 |  | VIDDEC2_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
VIDDEC2_EUNSUPPORTED | Unsupported request.
Remarks:
Since the VIDDEC2 decoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been decoded.
The buffers supplied to VIDDEC2_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC2_create()
VIDDEC2_delete()
VIDDEC2_control()
VIDDEC2_processAsync()
VIDDEC2_processWait()
IVIDDEC2_Fxns::process()
XDAS_Int32 VIDDEC2_processAsync | ( | VIDDEC2_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC2_InArgs * | inArgs,
 |  | VIDDEC2_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
VIDDEC2_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDDEC2_processWait() API.
The buffers supplied to VIDDEC2_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC2_create()
VIDDEC2_delete()
VIDDEC2_control()
VIDDEC2_process()
VIDDEC2_processWait()
IVIDDEC2_Fxns::process()
XDAS_Int32 VIDDEC2_processWait | ( | VIDDEC2_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDDEC2_InArgs * | inArgs,
 |  | VIDDEC2_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDDEC2_processAsync() in this instance of an video decoder algorithm.

Parameters:
[in] | handle | Handle to a created video decoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDDEC2_FOREVER)
Precondition:
handle is a valid (non-NULL) video decoder handle and the video decoder is in the created state.
Return values:
VIDDEC2_EOK | Success.
VIDDEC2_EFAIL | Failure.
VIDDEC2_EUNSUPPORTED | Unsupported request.
VIDDEC2_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDDEC2_EFOREVER.
There must have previously been an invocation of the VIDDEC2_processAsync() API.
The buffers supplied to VIDDEC2_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDDEC2_create()
VIDDEC2_delete()
VIDDEC2_control()
VIDDEC2_process()
VIDDEC2_processAsync()


Codec Engine Application Programming Interface (API): Video Transcoder Codec Interface

Video Transcoder Codec Interface

Defines

#define | VIDTRANSCODE_EOK IVIDTRANSCODE_EOK
#define | VIDTRANSCODE_EFAIL IVIDTRANSCODE_EFAIL
#define | VIDTRANSCODE_EUNSUPPORTED IVIDTRANSCODE_EUNSUPPORTED
#define | VIDTRANSCODE_ETIMEOUT VISA_ETIMEOUT
#define | VIDTRANSCODE_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | VIDTRANSCODE_Handle
Opaque handle to a VIDTRANSCODE codec.
typedef struct IVIDTRANSCODE_Params | VIDTRANSCODE_Params
This structure defines the parameters necessary to create an instance of a video transcoder.
typedef IVIDTRANSCODE_InArgs | VIDTRANSCODE_InArgs
typedef IVIDTRANSCODE_OutArgs | VIDTRANSCODE_OutArgs
typedef IVIDTRANSCODE_Cmd | VIDTRANSCODE_Cmd
typedef IVIDTRANSCODE_Status | VIDTRANSCODE_Status
typedef IVIDTRANSCODE_DynamicParams | VIDTRANSCODE_DynamicParams

Functions

Int32 | VIDTRANSCODE_control (VIDTRANSCODE_Handle handle, VIDTRANSCODE_Cmd id, VIDTRANSCODE_DynamicParams *params, VIDTRANSCODE_Status *status)
Execute the control() method in this instance of a video transcoder algorithm.
VIDTRANSCODE_Handle | VIDTRANSCODE_create (Engine_Handle e, String name, VIDTRANSCODE_Params *params)
Create an instance of a video transcoder algorithm.
Void | VIDTRANSCODE_delete (VIDTRANSCODE_Handle handle)
Delete the instance of a video transcoder algorithm.
Int32 | VIDTRANSCODE_process (VIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDTRANSCODE_InArgs *inArgs, VIDTRANSCODE_OutArgs *outArgs)
Execute the process() method in this instance of a video transcoder algorithm.
XDAS_Int32 | VIDTRANSCODE_processAsync (VIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs, IVIDTRANSCODE_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video transcoder algorithm.
XDAS_Int32 | VIDTRANSCODE_processWait (VIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs, IVIDTRANSCODE_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDTRANSCODE_processAsync() in this instance of an video transcoder algorithm.

Detailed Description

This is the video transcoder codec interface. Several of the data types in this API are specified by the XDM interface; please see the XDM documentation for those details.

Define Documentation

#define VIDTRANSCODE_EOK IVIDTRANSCODE_EOK

Success.

#define VIDTRANSCODE_EFAIL IVIDTRANSCODE_EFAIL

General failure.

#define VIDTRANSCODE_EUNSUPPORTED IVIDTRANSCODE_EUNSUPPORTED

Request is unsupported. Timeout occurred.

#define VIDTRANSCODE_ETIMEOUT VISA_ETIMEOUT

Special value for timeout parameter indicating never timeout.

#define VIDTRANSCODE_FOREVER VISA_FOREVER

Typedef Documentation

typedef VISA_Handle VIDTRANSCODE_Handle

Opaque handle to a VIDTRANSCODE codec.

typedef struct IVIDTRANSCODE_Params VIDTRANSCODE_Params

This structure defines the parameters necessary to create an instance of a video transcoder.

typedef IVIDTRANSCODE_InArgs VIDTRANSCODE_InArgs

Defines the input arguments for all IVIDTRANSCODE instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::process()

typedef IVIDTRANSCODE_OutArgs VIDTRANSCODE_OutArgs

Defines the run time output arguments for all IVIDTRANSCODE instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::process()

typedef IVIDTRANSCODE_Cmd VIDTRANSCODE_Cmd

Defines the control commands for the IVIDTRANSCODE module.

Remarks:
This ID can be extended in IMOD interface for additional controls.
See also:
XDM_CmdId
IVIDTRANSCODE_Fxns::control()

typedef IVIDTRANSCODE_Status VIDTRANSCODE_Status

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::control()

typedef IVIDTRANSCODE_DynamicParams VIDTRANSCODE_DynamicParams

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::control()

Function Documentation

Int32 VIDTRANSCODE_control | ( | VIDTRANSCODE_Handle | handle,
 |  | VIDTRANSCODE_Cmd | id,
 |  | VIDTRANSCODE_DynamicParams * | params,
 |  | VIDTRANSCODE_Status * | status
 | ) |  |

Execute the control() method in this instance of a video transcoder algorithm.

Parameters:
[in] | handle | Handle to a created video transcoder instance.
[in] | id | Command id for XDM control operation.
[in] | params | Runtime control parameters used for the video transcoder.
[out] | status | Status info returned by the video transcoder instance.
Precondition:
handle is a valid (non-NULL) video transcoder handle and the video transcoder is in the created state.
Return values:
VIDTRANSCODE_EOK | Success.
VIDTRANSCODE_EFAIL | Failure.
VIDTRANSCODE_EUNSUPPORTED | Unsupported request.
Remarks:
This is a blocking call, and will return after the control command has been executed.
See also:
VIDTRANSCODE_create()
VIDTRANSCODE_delete()
IVIDTRANSCODE_Fxns::control()
VIDTRANSCODE_Handle VIDTRANSCODE_create | ( | Engine_Handle | e,
 |  | String | name,
 |  | VIDTRANSCODE_Params * | params
 | ) |  |

Create an instance of a video transcoder algorithm.

Instance handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via VIDTRANSCODE_create()) or explicitly serialize access to a shared handle.

Parameters:
[in] | e | Handle to an opened engine.
[in] | name | String identifier of the type of video transcoder. to create.
[in] | params | Creation parameters.
Return values:
NULL | An error has occurred.
non-NULL | The handle to the newly created video transcoder instance.
Remarks:
params is optional. If it's not supplied, codec-specific default params will be used.
Depending on the configuration of the engine opened, this call may create a local or remote instance of the video transcoder.
In general, name is the name of the codec configured by the system integrator. However, an optional "argument string" may be appended to the codec name, to allow the codec's configured priority and/or the heaps where its memory will be allocated and/or the number of VISA messages to allocate, to be overridden. This optional argument string is of the form ":priority:flag:number-of-messages", and can be specified with an empty field for any element that you don't want to be overridden, e.g. "mp3:::3" to cause 3 messages to be allocated while using the default values for priority and the heap flag.
priority is the new priority to create the codec with.
The flag must be either 0 or 1, and if 1, all memory allocated for the codec will be in the heap that corresponds to IALG_EXTERNAL. If flag is 0, the memory for the codec will be allocated from the heaps it has requested. For example, if a codec named "mp3" has been configured into the system, setting name to "mp3:4" would cause the codec to be created at priority 4, instead of whatever priority was configured. This feature is useful if more than one instance of the codec are to be created at different priorities.
The flag can be used to prevent the codec from using any internal memory, for example, if it is to be run at the same time as another codec that must use internal memory, and there is insufficient internal memory for both.
The number-of-messages overrides the default of 1 message, and is useful (or required, practically speaking) for when the "asynchronous" process method is used, i.e. "AUDENC1_processAsync()"
See also:
Engine_open()
VIDTRANSCODE_delete()
Void VIDTRANSCODE_delete ( VIDTRANSCODE_Handle handle )

Delete the instance of a video transcoder algorithm.

Parameters:
[in] handle Handle to a created video transcoder instance.
Remarks:
Depending on the configuration of the engine opened, this call may delete a local or remote instance of the video transcoder.
Precondition:
handle is a valid (non-NULL) handle which is in the created state.
Postcondition:
All resources allocated as part of the VIDTRANSCODE_create() operation (memory, DMA channels, etc.) are freed.
See also:
VIDTRANSCODE_create()
Int32 VIDTRANSCODE_process | ( | VIDTRANSCODE_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | VIDTRANSCODE_InArgs * | inArgs,
 |  | VIDTRANSCODE_OutArgs * | outArgs
 | ) |  |

Execute the process() method in this instance of a video transcoder algorithm.

Parameters:
[in] | handle | Handle to a created video transcoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video transcoder handle and the video transcoder is in the created state.
Return values:
VIDTRANSCODE_EOK | Success.
VIDTRANSCODE_EFAIL | Failure.
VIDTRANSCODE_EUNSUPPORTED | Unsupported request.
Remarks:
Since the VIDTRANSCODE transcoder contains support for asynchronous buffer submission and retrieval, this API becomes known as synchronous in nature.
This is a blocking call, and will return after the data has been encoded.
The buffers supplied to VIDTRANSCODE_process() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDTRANSCODE_create()
VIDTRANSCODE_delete()
VIDTRANSCODE_control()
VIDTRANSCODE_processAsync()
VIDTRANSCODE_processWait()
IVIDTRANSCODE_Fxns::process()
XDAS_Int32 VIDTRANSCODE_processAsync | ( | VIDTRANSCODE_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IVIDTRANSCODE_InArgs * | inArgs,
 |  | IVIDTRANSCODE_OutArgs * | outArgs
 | ) |  |

Perform asynchronous submission to this instance of a video transcoder algorithm.

Parameters:
[in] | handle | Handle to a created video transcoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
Precondition:
handle is a valid (non-NULL) video transcoder handle and the video transcoder is in the created state.
Return values:
VIDTRANSCODE_EOK | Success.
VIDTRANSCODE_EFAIL | Failure.
VIDTRANSCODE_EUNSUPPORTED | Unsupported request.
Remarks:
This API is the asynchronous counterpart to the process() method. It allows for buffer and argument submission without waiting for retrieval. A response is retrieved using the VIDTRANSCODE_processWait() API.
The buffers supplied to VIDTRANSCODE_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDTRANSCODE_create()
VIDTRANSCODE_delete()
VIDTRANSCODE_control()
VIDTRANSCODE_process()
VIDTRANSCODE_processWait()
IVIDTRANSCODE_Fxns::process()
XDAS_Int32 VIDTRANSCODE_processWait | ( | VIDTRANSCODE_Handle | handle,
 |  | XDM1_BufDesc * | inBufs,
 |  | XDM_BufDesc * | outBufs,
 |  | IVIDTRANSCODE_InArgs * | inArgs,
 |  | IVIDTRANSCODE_OutArgs * | outArgs,
 |  | UInt | timeout
 | ) |  |

Wait for a return message from a previous invocation of VIDTRANSCODE_processAsync() in this instance of an video transcoder algorithm.

Parameters:
[in] | handle | Handle to a created video transcoder instance.
[in] | inBufs | A buffer descriptor containing input buffers.
[out] | outBufs | A buffer descriptor containing output buffers.
[in] | inArgs | Input Arguments.
[out] | outArgs | Output Arguments.
[in] | timeout | Amount of "time" to wait (from 0 -> VIDTRANSCODE_FOREVER)
Precondition:
handle is a valid (non-NULL) video transcoder handle and the video transcoder is in the created state.
Return values:
VIDTRANSCODE_EOK | Success.
VIDTRANSCODE_EFAIL | Failure.
VIDTRANSCODE_EUNSUPPORTED | Unsupported request.
VIDTRANSCODE_ETIMEOUT | Operation timed out.
Remarks:
This is a blocking call, and will return after the data has been decoded.
"Polling" is supported by using a timeout of 0. Waiting forever is supported by using a timeout of VIDTRANSCODE_EFOREVER.
There must have previously been an invocation of the VIDTRANSCODE_processAsync() API.
The buffers supplied to VIDTRANSCODE_processAsync() may have constraints put on them. For example, in dual-processor, shared memory architectures, where the codec is running on a remote processor, the buffers may need to be physically contiguous. Additionally, the remote processor may place restrictions on buffer alignment.
See also:
VIDTRANSCODE_create()
VIDTRANSCODE_delete()
VIDTRANSCODE_control()
VIDTRANSCODE_process()
VIDTRANSCODE_processAsync()


Codec Engine Application Programming Interface (API): VISA

VISA

Defines

#define | VISA_EOK 0
Success.
#define | VISA_ERUNTIME -1
Internal runtime error.
#define | VISA_EFAIL -2
General system error.
#define | VISA_ETIMEOUT -100
Timeout occurred.
#define | VISA_FOREVER Engine_FOREVER
Special value for timeout parameter indicating never timeout.

Typedefs

typedef Int | VISA_Status
VISA result data type.

Functions

VISA_Status | VISA_getAlgMemRecs (VISA_Handle visa, IALG_MemRec *memTab, Int size, Int *numRecs)
Get the IALG_MemRec memory assigned to an algorithm instance.
VISA_Status | VISA_getAlgNumRecs (VISA_Handle visa, Int *numRecs)
Get the number of IALG_MemRecs assigned to an algorithm.
Ptr | VISA_getCodecClassConfig (VISA_Handle visa)
Get codec-specific values for the VISA class-specific (or codec-specific if the codec doesn't extend VISA) stub-and/ or-skeleton configuration data (that some classes have).
UInt | VISA_getMaxMsgSize (VISA_Handle visa)
Returns max size of messages allocated by VISA_allocMsg().
Bool | VISA_isLocal (VISA_Handle visa)
Indicates whether VISA codecs run on a remote or local CPU.

Detailed Description

Codec Engine Algorithm-independent shared definitions and services.

Define Documentation

#define VISA_EOK 0

Success.

#define VISA_ERUNTIME -1

Internal runtime error.

#define VISA_EFAIL -2

General system error.

#define VISA_ETIMEOUT -100

Timeout occurred.

#define VISA_FOREVER Engine_FOREVER

Special value for timeout parameter indicating never timeout.

Typedef Documentation

typedef Int VISA_Status

VISA result data type.

Function Documentation

VISA_Status VISA_getAlgMemRecs | ( | VISA_Handle | visa,
 |  | IALG_MemRec * | memTab,
 |  | Int | size,
 |  | Int * | numRecs
 | ) |  |

Get the IALG_MemRec memory assigned to an algorithm instance.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | memTab | Location to store the IALG_MemRecs.
[in] | size | Maximum number of IALG_MemRecs to put in memTab array.
[out] | numRecs | Actual number of IALG_MemRecs copied into memTab array.
Remarks:
Any algorithm instance handle (e.g. VIDDEC2_Handle, AUDDEC1_Handle, etc), can be cast to a visa handle.
Example:
      AUDDEC1_Handle decoder;

      decoder = AUDDEC1_create(...);

      ... likely use VISA_getAlgNumRecs() to alloc enough mem...

      VISA_getAlgMemRecs((VISA_Handle)decoder, ...);
Return values:
VISA_EOK | Success.
VISA_EFAIL | Failure.
See also:
VISA_getAlgNumRecs()
VISA_Status VISA_getAlgNumRecs | ( | VISA_Handle | visa,
 |  | Int * | numRecs
 | ) |  |

Get the number of IALG_MemRecs assigned to an algorithm.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | numRecs | Location to store the number of IALG_MemRecs used.
Remarks:
Any algorithm instance handle (e.g. VIDDEC2_Handle, AUDDEC1_Handle, etc), can be cast to a visa handle.
Example:
      Int numRecs;
      AUDDEC1_Handle decoder;

      decoder = AUDDEC1_create(...);

      VISA_getAlgNumRecs((VISA_Handle)decoder, &numRecs);
Return values:
VISA_EOK | Success.
VISA_EFAIL | Failure.
See also:
VISA_getAlgMemRecs()
Ptr VISA_getCodecClassConfig ( VISA_Handle visa )

Get codec-specific values for the VISA class-specific (or codec-specific if the codec doesn't extend VISA) stub-and/ or-skeleton configuration data (that some classes have).

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
address of the codec class config data structure, or NULL if codec class config data not defined for the codec; the format of the structure is class-specific, and the data in it is codec- specific
Precondition:
visa must be a valid algorithm instance handle.
UInt VISA_getMaxMsgSize ( VISA_Handle visa )

Returns max size of messages allocated by VISA_allocMsg().

Return values:
maxMsgSize Max size of messages allocated by VISA_allocMsg()
Remarks:
This is typically called by an algorithm class' stub.
See also:
VISA_allocMsg()
Bool VISA_isLocal ( VISA_Handle visa )

Indicates whether VISA codecs run on a remote or local CPU.

Return values:
FALSE | VISA codecs run on remote CPU
TRUE | VISA codecs run on local CPU
Remarks:
This is typically called by an algorithm class' stub.


Codec Engine Application Programming Interface (API): CE Stub SPI

CE Stub SPI

Data Structures

struct | VISA_MsgHeader
VISA message header. More...

Functions

VISA_Msg | VISA_allocMsg (VISA_Handle visa)
Obtain an algorithm instance's message.
VISA_Status | VISA_call (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and wait for it to complete.
VISA_Status | VISA_callAsync (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and return without waiting for it to complete.
VISA_Status | VISA_wait (VISA_Handle visa, VISA_Msg *msg, UInt timeout)
Wait for the oldest operation from a command specified with VISA_callAsync() to complete.
Void | VISA_freeMsg (VISA_Handle visa, VISA_Msg msg)
Release an algorithm instance's message.
Void | VISA_getContext (VISA_Handle visa, UInt32 *pContext)
Get optional context parameter.
Void | VISA_setContext (VISA_Handle visa, UInt32 context)
Set optional context parameter.

Detailed Description

Codec Engine System Programming Interface (SPI) for stub implementors.

Function Documentation

VISA_Msg VISA_allocMsg ( VISA_Handle visa )

Obtain an algorithm instance's message.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | General system error
non-NULL | The remote algorithm's message.
Remarks:
This is typically called by an algorithm class' stub.
See also:
VISA_allocMsg()
VISA_Status VISA_call | ( | VISA_Handle | visa,
 |  | VISA_Msg * | msg
 | ) |  |

Invoke the operation specified in the message and wait for it to complete.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | msg | The remote algorithm's message, to be sent to the skeleton.
Remarks:
This is typically called by an algorithm class' stub.
Return values:
VISA_EOK | Success
VISA_ERUNTIME | General system error
See also:
VISA_callAsync()
VISA_Status VISA_callAsync | ( | VISA_Handle | visa,
 |  | VISA_Msg * | msg
 | ) |  |

Invoke the operation specified in the message and return without waiting for it to complete.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | msg | The remote algorithm's message, to be sent to the skeleton.
Remarks:
This is typically called by an algorithm class' stub.
Return values:
VISA_EOK | Success
VISA_ERUNTIME | General system error
See also:
VISA_wait()
VISA_call()
VISA_Status VISA_wait | ( | VISA_Handle | visa,
 |  | VISA_Msg * | msg,
 |  | UInt | timeout
 | ) |  |

Wait for the oldest operation from a command specified with VISA_callAsync() to complete.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | msg | Placeholder for the remote algorithm's return message, retrieved from the skeleton.
[in] | timeout | Amount of "time" to wait ("time" depends on underlying mechanism, such as that used with MSGQ_Get()).
Remarks:
This is typically called by an algorithm class' stub.
Return values:
VISA_EOK | Success
VISA_ERUNTIME | General system error
VISA_ETIMEOUT | Operation timed out
See also:
VISA_callAsync()
Void VISA_freeMsg | ( | VISA_Handle | visa,
 |  | VISA_Msg | msg
 | ) |  |

Release an algorithm instance's message.

Parameters:
[in] | visa | Handle to an algorithm instance.
[in] | msg | Message to free, obtained through a call to VISA_allocMsg().
Return values:
NULL | General system error
non-NULL | The remote algorithm's message.
Remarks:
This is typically called by an algorithm class' stub.
See also:
VISA_allocMsg()
Void VISA_getContext | ( | VISA_Handle | visa,
 |  | UInt32 * | pContext
 | ) |  |

Get optional context parameter.

Parameters:
[in] | visa | Handle to an algorithm instance.
[out] | pContext | Location to store context.
Precondition:
visa must be a valid algorithm instance handle.
pContext must be a valid pointer.
Remarks:
The VISA_setContext() / VISA_getContext() pair does not work across processors. That is, the context can only be stored and retrieved on the local processor.
See also:
VISA_setContext()
Void VISA_setContext | ( | VISA_Handle | visa,
 |  | UInt32 | context
 | ) |  |

Set optional context parameter.

Parameters:
[in] | visa | Handle to an algorithm instance.
[in] | context | Context.
Precondition:
visa must be a valid algorithm instance handle.
Remarks:
The VISA_setContext() / VISA_getContext() pair does not work across processors. That is, the context can only be stored and retrieved on the local processor.
See also:
VISA_getContext()


Codec Engine Application Programming Interface (API): CE interface SPI

CE interface SPI

VISA_Handle | VISA_create (Engine_Handle engine, String name, IALG_Params *params, size_t msgSize, String type)
 | Create a new instance of an algorithm.
Void | VISA_delete (VISA_Handle visa)
 | Delete an instance of an algorithm.
VISA_Handle | VISA_create2 (Engine_Handle engine, String name, IALG_Params *params, Int paramsSize, size_t msgSize, String type)
 | Create a new instance of an algorithm.
Void | VISA_enter (VISA_Handle visa)
 | Enter an algorithm's critical section. This must be called before any of the algorithm's IALG_Fxns are invoked.
Void | VISA_exit (VISA_Handle visa)
 | Leave an algorithm's critical section. This must be called after the API has completed calling an algorithm's IALG_Fxns.
Ptr | VISA_getAlgHandle (VISA_Handle visa)
 | Obtains an algorithm's handle. This is the handle required to be passed to the algorithm's IALG_Fxns.
Ptr | VISA_getAlgorithmHandle (VISA_Handle visa)
 | Obtains an algorithm's handle. If the algorithm is local, this is the handle that can be passed to Algorithm APIs, not to the IALG_Fxns.
IALG_Fxns * | VISA_getAlgFxns (VISA_Handle visa)
 | Get implementation functions for this algorithm.

Detailed Description

Codec Engine System Programming Interface (SPI) for class interface implementors.

Function Documentation

VISA_Handle VISA_create | ( | Engine_Handle | engine,
 |  | String | name,
 |  | IALG_Params * | params,
 |  | size_t | msgSize,
 |  | String | type
 | ) |  |

Create a new instance of an algorithm.

Parameters:
[in] | engine | Handle to an engine in which the algorithm has been configured.
[in] | name | Name of the algorithm to create. name is specified in the engine configuration.
[in] | params | Creation parameters.
[in] | msgSize | Size of the message which will be allocated in the event that this algorithm is configured to run remotely.
[in] | type | String name of the "type" of algorithm.
Return values:
NULL | General failure.
non-NULL | Handle to an algorithm instance.
Remarks:
type must match the package/module name of the interface which the algorithm implements. For example, the VISA interface shipped with CE to support xDM video decoders is named "ti.sdo.ce.video.IVIDDEC". That is, the module IVIDDEC is in the package "ti.sdo.ce.video". You will, by definition, find a file named IVIDDEC.xdc in the ti.sdo.ce.video package.
When calling VISA_create(), a string comparison is done between the type parameter and the actual name of the module (described in the previous paragraph). If these strings don't match exactly, VISA_create() will fail.
See also:
VISA_delete()
Void VISA_delete ( VISA_Handle visa )

Delete an instance of an algorithm.

Parameters:
[in] visa Handle to an algorithm instance to delete.
See also:
VISA_create()
VISA_Handle VISA_create2 | ( | Engine_Handle | engine,
 |  | String | name,
 |  | IALG_Params * | params,
 |  | Int | paramsSize,
 |  | size_t | msgSize,
 |  | String | type
 | ) |  |

Create a new instance of an algorithm.

Parameters:
[in] | engine | Handle to an engine in which the algorithm has been configured.
[in] | name | Name of the algorithm to create. name is specified in the engine configuration.
[in] | params | Creation parameters.
[in] | paramsSize | Size of params.
[in] | msgSize | Size of the message which will be allocated in the event that this algorithm is configured to run remotely.
[in] | type | String name of the "type" of algorithm.
Return values:
NULL | General failure.
non-NULL | Handle to an algorithm instance.
Remarks:
type must match the package/module name of the interface which the algorithm implements. For example, the VISA interface shipped with CE to support xDM video decoders is named "ti.sdo.ce.video.IVIDDEC". That is, the module IVIDDEC is in the package "ti.sdo.ce.video". You will, by definition, find a file named IVIDDEC.xdc in the ti.sdo.ce.video package.
When calling VISA_create2(), a string comparison is done between the type parameter and the actual name of the module (described in the previous paragraph). If these strings don't match exactly, VISA_create2() will fail.
VISA_create() is the preferred method to create algorithms. VISA_create2() is provided to enable creation of algorithms which violate the xDAIS spec and do not have a size field of type "Int" as the first field of params.
See also:
VISA_create()
VISA_delete()
Void VISA_enter ( VISA_Handle visa )

Enter an algorithm's critical section. This must be called before any of the algorithm's IALG_Fxns are invoked.

Parameters:
[in] visa Handle to an algorithm instance.
Remarks:
This is typically called by an algorithm class' application API.
This call has the same semantics as IALG's activate fxn.
See also:
VISA_exit()
Void VISA_exit ( VISA_Handle visa )

Leave an algorithm's critical section. This must be called after the API has completed calling an algorithm's IALG_Fxns.

Parameters:
[in] visa Handle to an algorithm instance.
Remarks:
This call has the same semantics as IALG's de-activate fxn.
See also:
VISA_enter()
Ptr VISA_getAlgHandle ( VISA_Handle visa )

Obtains an algorithm's handle. This is the handle required to be passed to the algorithm's IALG_Fxns.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | General system error
non-NULL | The remote algorithm's message.
Remarks:
This is typically called by an algorithm class' application API.
See also:
VISA_getAlgFxns()
Ptr VISA_getAlgorithmHandle ( VISA_Handle visa )

Obtains an algorithm's handle. If the algorithm is local, this is the handle that can be passed to Algorithm APIs, not to the IALG_Fxns.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | General system error
non-NULL | The Algorithm handle.
Remarks:
This is used internally.
See also:
VISA_getAlgHandle()
IALG_Fxns* VISA_getAlgFxns ( VISA_Handle visa )

Get implementation functions for this algorithm.

Parameters:
[in] visa Handle to an algorithm instance.
Return values:
NULL | An error has occurred.
non-NULL | The algorithm's IALG_Fxns.
Remarks:
This is typically called by an algorithm class' application API.
Both local and remote implementations return a non-NULL pointer. However, the IALG_Fxns functions may be NULL.
In the case of a local algorithm, the algorithm's IALG_Fxns returned. In the case of a remote algorithm, its stubs are returned. In either case, the handle passed as the first arg to the IALG_Fxns must be the value returned by VISA_getAlgHandle().
See also:
VISA_getAlgHandle()


Codec Engine Application Programming Interface (API): XDM Video Interface

XDM Video Interface

Data Structures

struct | IVIDEO_BufDesc
Buffer descriptor for video buffers. More...
struct | IVIDEO1_BufDescIn
Buffer descriptor for input video buffers. More...
struct | IVIDEO1_BufDesc
Detailed buffer descriptor for video buffers. More...

Defines

#define | IVIDEO_MAX_YUV_BUFFERS 3
Max YUV buffers - one each for 'Y', 'U', and 'V'.

Enumerations

enum IVIDEO_FrameSkip {
IVIDEO_NO_SKIP = 0,
IVIDEO_SKIP_P = 1,
IVIDEO_SKIP_B = 2,
IVIDEO_SKIP_I = 3,
IVIDEO_SKIP_IP = 4,
IVIDEO_SKIP_IB = 5,
IVIDEO_SKIP_PB = 6,
IVIDEO_SKIP_IPB = 7,
IVIDEO_SKIP_IDR = 8,
IVIDEO_SKIP_DEFAULT = IVIDEO_NO_SKIP
}

Video frame skip features for video decoder.

More...
enum IVIDEO_FrameType {
IVIDEO_NA_FRAME = -1,
IVIDEO_I_FRAME = 0,
IVIDEO_P_FRAME = 1,
IVIDEO_B_FRAME = 2,
IVIDEO_IDR_FRAME = 3,
IVIDEO_II_FRAME = 4,
IVIDEO_IP_FRAME = 5,
IVIDEO_IB_FRAME = 6,
IVIDEO_PI_FRAME = 7,
IVIDEO_PP_FRAME = 8,
IVIDEO_PB_FRAME = 9,
IVIDEO_BI_FRAME = 10,
IVIDEO_BP_FRAME = 11,
IVIDEO_BB_FRAME = 12,
IVIDEO_MBAFF_I_FRAME = 13,
IVIDEO_MBAFF_P_FRAME = 14,
IVIDEO_MBAFF_B_FRAME = 15,
IVIDEO_MBAFF_IDR_FRAME = 16,
IVIDEO_FRAMETYPE_DEFAULT = IVIDEO_I_FRAME
}

Video frame types.

More...
enum IVIDEO_ContentType {
IVIDEO_CONTENTTYPE_NA = -1,
IVIDEO_PROGRESSIVE = 0,
IVIDEO_PROGRESSIVE_FRAME = IVIDEO_PROGRESSIVE,
IVIDEO_INTERLACED = 1,
IVIDEO_INTERLACED_FRAME = IVIDEO_INTERLACED,
IVIDEO_INTERLACED_TOPFIELD = 2,
IVIDEO_INTERLACED_BOTTOMFIELD = 3,
IVIDEO_CONTENTTYPE_DEFAULT = IVIDEO_PROGRESSIVE
}

Video content types.

More...
enum IVIDEO_RateControlPreset {
IVIDEO_LOW_DELAY = 1,
IVIDEO_STORAGE = 2,
IVIDEO_TWOPASS = 3,
IVIDEO_NONE = 4,
IVIDEO_USER_DEFINED = 5,
IVIDEO_RATECONTROLPRESET_DEFAULT = IVIDEO_LOW_DELAY
}

Video rate control presets.

More...
enum IVIDEO_SkipMode {
IVIDEO_FRAME_ENCODED = 0,
IVIDEO_FRAME_SKIPPED = 1,
IVIDEO_SKIPMODE_DEFAULT = IVIDEO_FRAME_ENCODED
}

Video frame skipping modes.

More...
enum IVIDEO_OutputFrameStatus {
IVIDEO_FRAME_NOERROR = 0,
IVIDEO_FRAME_NOTAVAILABLE = 1,
IVIDEO_FRAME_ERROR = 2,
IVIDEO_OUTPUTFRAMESTATUS_DEFAULT = IVIDEO_FRAME_NOERROR
}

Video output buffer status.

More...
enum IVIDEO_PictureType {
IVIDEO_NA_PICTURE = -1,
IVIDEO_I_PICTURE = 0,
IVIDEO_P_PICTURE = 1,
IVIDEO_B_PICTURE = 2,
IVIDEO_PICTURE_TYPE_DEFAULT = IVIDEO_I_PICTURE
}

Video Picture types.

More...
enum IVIDEO_Format {
IVIDEO_MPEG1 = 1,
IVIDEO_MPEG2SP = 2,
IVIDEO_MPEG2MP = 3,
IVIDEO_MPEG2HP = 4,
IVIDEO_MPEG4SP = 5,
IVIDEO_MPEG4ASP = 6,
IVIDEO_H264BP = 7,
IVIDEO_H264MP = 8,
IVIDEO_H264HP = 9,
IVIDEO_VC1SP = 10,
IVIDEO_VC1MP = 11,
IVIDEO_VC1AP = 12
}

Video Format types.

More...

Detailed Description

This is the XDM video interface shared between the various codecs.

Define Documentation

#define IVIDEO_MAX_YUV_BUFFERS 3

Max YUV buffers - one each for 'Y', 'U', and 'V'.

Enumeration Type Documentation

enum IVIDEO_FrameSkip

Video frame skip features for video decoder.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_NO_SKIP

Do not skip any frame types.

IVIDEO_SKIP_P

Decode the P frame/skip frames internally, but do not copy the decoded output to the output buffers. This should be indicated by setting the output buffers to NULL.

Remarks:
For example, if a B frame is dependant on the previously decoded P frame, the B frame shall be decoded and displayed successfully. For this, the P frame needs to be decoded, but not copied to the output buffer.
IVIDEO_SKIP_B

Skip B, BI frames. For B frames, the decoder will decode the frame bitstream, and return as soon as the frame type is decisively decoded. Internally, the algorithm will modify its state, so that subsequent decoding of other frames is possible.

IVIDEO_SKIP_I

Skip intra coded frame.

IVIDEO_SKIP_IP

Skip I and P frame/field(s).

IVIDEO_SKIP_IB

Skip I and B frame/field(s).

IVIDEO_SKIP_PB

Skip P and B frame/field(s).

IVIDEO_SKIP_IPB

Skip I/P/B/BI frames.

IVIDEO_SKIP_IDR

Skip IDR Frame.

IVIDEO_SKIP_DEFAULT

Default settings.

enum IVIDEO_FrameType

Video frame types.

Remarks:
For the various IVIDEO_xy_FRAME values, this frame type is interlaced where both top and bottom fields are provided in a single frame. The first field is an "x" frame, the second field is "y" field.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_NA_FRAME

Frame type not available.

IVIDEO_I_FRAME

Intra coded frame.

IVIDEO_P_FRAME

Forward inter coded frame.

IVIDEO_B_FRAME

Bi-directional inter coded frame.

IVIDEO_IDR_FRAME

Intra coded frame that can be used for refreshing video content.

IVIDEO_II_FRAME

Interlaced Frame, both fields are I frames

IVIDEO_IP_FRAME

Interlaced Frame, first field is an I frame, second field is a P frame.

IVIDEO_IB_FRAME

Interlaced Frame, first field is an I frame, second field is a B frame.

IVIDEO_PI_FRAME

Interlaced Frame, first field is a P frame, second field is a I frame.

IVIDEO_PP_FRAME

Interlaced Frame, both fields are P frames.

IVIDEO_PB_FRAME

Interlaced Frame, first field is a P frame, second field is a B frame.

IVIDEO_BI_FRAME

Interlaced Frame, first field is a B frame, second field is an I frame.

IVIDEO_BP_FRAME

Interlaced Frame, first field is a B frame, second field is a P frame.

IVIDEO_BB_FRAME

Interlaced Frame, both fields are B frames.

IVIDEO_MBAFF_I_FRAME

Intra coded MBAFF frame.

IVIDEO_MBAFF_P_FRAME

Forward inter coded MBAFF frame.

IVIDEO_MBAFF_B_FRAME

Bi-directional inter coded MBAFF frame.

IVIDEO_MBAFF_IDR_FRAME

Intra coded MBAFF frame that can be used for refreshing video content.

IVIDEO_FRAMETYPE_DEFAULT

Default setting.

enum IVIDEO_ContentType

Video content types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_CONTENTTYPE_NA

Frame type is not available.

IVIDEO_PROGRESSIVE

Progressive frame.

IVIDEO_PROGRESSIVE_FRAME

Progressive Frame.

IVIDEO_INTERLACED

Interlaced frame.

IVIDEO_INTERLACED_FRAME

Interlaced frame.

IVIDEO_INTERLACED_TOPFIELD

Interlaced picture, top field.

IVIDEO_INTERLACED_BOTTOMFIELD

Interlaced picture, bottom field.

IVIDEO_CONTENTTYPE_DEFAULT

Default setting.

enum IVIDEO_RateControlPreset

Video rate control presets.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_LOW_DELAY

CBR rate control for video conferencing.

IVIDEO_STORAGE

VBR rate control for local storage (DVD) recording.

IVIDEO_TWOPASS

Two pass rate control for non real time applications.

IVIDEO_NONE

No configurable video rate control mechanism.

IVIDEO_USER_DEFINED

User defined configuration using extended parameters.

IVIDEO_RATECONTROLPRESET_DEFAULT

Default setting.

enum IVIDEO_SkipMode

Video frame skipping modes.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_FRAME_ENCODED

Input video frame successfully encoded.

IVIDEO_FRAME_SKIPPED

Input video frame dropped. There is no encoded bitstream corresponding to the input frame.

IVIDEO_SKIPMODE_DEFAULT

Default setting.

enum IVIDEO_OutputFrameStatus

Video output buffer status.

Remarks:
Ownership of the buffers, either by application or algorithm, is conveyed via these values.
This reflects the status of ALL output buffers. For example, if video decoded output is in 4:2:0 format, all the 3 output buffers' status is described by this value. Similarly, for 4:2:2 formatted buffers, this value describes the single buffer's status.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_FRAME_NOERROR

The output buffer is available.

IVIDEO_FRAME_NOTAVAILABLE

The codec doesn't have any output buffers.

IVIDEO_FRAME_ERROR

The output buffer is available and corrupted.

Remarks:
For example, if a bitstream is erroneous and partially decoded, a portion of the decoded image may be available for display. Another example is if the bitstream for a given frame decode may be decoded without error, but the previously decoded dependant frames weren't successfully decoded. This would result in an incorrectly decoded frame.
IVIDEO_OUTPUTFRAMESTATUS_DEFAULT

Default setting.

enum IVIDEO_PictureType

Video Picture types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_NA_PICTURE

Frame type not available.

IVIDEO_I_PICTURE

Intra coded picture.

IVIDEO_P_PICTURE

Forward inter coded picture.

IVIDEO_B_PICTURE

Bi-directional inter coded picture.

IVIDEO_PICTURE_TYPE_DEFAULT

Default setting.

enum IVIDEO_Format

Video Format types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
IVIDEO_MPEG1

Video format is Mpeg1 stream

IVIDEO_MPEG2SP

Video format is Mpeg2/H.262 stream, Simple Profile

IVIDEO_MPEG2MP

Video format is Mpeg2/H.262 stream, Main Profile

IVIDEO_MPEG2HP

Video format is Mpeg2/H.262 stream, High Profile

IVIDEO_MPEG4SP

Video format is Mpeg4 stream, Simple Profile

IVIDEO_MPEG4ASP

Video format is Mpeg4 stream, Advanced Simple Profile

IVIDEO_H264BP

Video format is H.264 stream, Base Profile

IVIDEO_H264MP

Video format is H.264 stream, Main Profile

IVIDEO_H264HP

Video format is H.264 stream, High Profile

IVIDEO_VC1SP

Video format is VC1/WMV9 stream, Simple Profile

IVIDEO_VC1MP

Video format is VC1/WMV9 stream, Main Profile

IVIDEO_VC1AP

Video format is VC1 stream, Advanced Profile


Codec Engine Application Programming Interface (API): XDM IVIDDEC2-based Video Decoder Split Interface

XDM IVIDDEC2-based Video Decoder Split Interface

Data Structures

struct | IVIDDEC2FRONT_Obj
This must be the first field of all IVIDDEC2FRONT instance objects. More...
struct | IVIDDEC2BACK_Obj
This must be the first field of all IVIDDEC2BACK instance objects. More...
struct | IVIDDEC2FRONT_Status
Defines instance status parameters. More...
struct | IVIDDEC2FRONT_OutArgs
Defines the run time output arguments for all IVIDDEC2FRONT instance objects. More...
struct | IVIDDEC2FRONT_Fxns
Defines all of the operations on IVIDDEC2FRONT objects. More...
struct | IVIDDEC2BACK_Fxns
Defines all of the operations on IVIDDEC2BACK objects. More...

Typedefs

typedef struct IVIDDEC2FRONT_Obj * | IVIDDEC2FRONT_Handle
Opaque handle to an IVIDDEC2FRONT objects.
typedef struct IVIDDEC2BACK_Obj * | IVIDDEC2BACK_Handle
Opaque handle to an IVIDDEC2BACK objects.

Detailed Description

This is the XDM split video decoder interface.

Typedef Documentation

typedef struct IVIDDEC2FRONT_Obj* IVIDDEC2FRONT_Handle

Opaque handle to an IVIDDEC2FRONT objects.

typedef struct IVIDDEC2BACK_Obj* IVIDDEC2BACK_Handle

Opaque handle to an IVIDDEC2BACK objects.


Codec Engine Application Programming Interface (API): Shared XDM Definitions

Shared XDM Definitions

Data Structures

struct | XDM_BufDesc
Buffer descriptor for multiple buffers. More...
struct | XDM_SingleBufDesc
Single buffer descriptor. More...
struct | XDM1_SingleBufDesc
Single buffer descriptor. More...
struct | XDM1_BufDesc
Buffer descriptor. More...
struct | XDM_AlgBufInfo
Buffer information descriptor for input and output buffers. More...
struct | XDM_Date
Date and time. More...
struct | XDM_Point
2-dimensional point More...
struct | XDM_Rect
Rectangle. More...
struct | XDM_ContextInfo
Buffer information descriptor for input and output buffers. More...
struct | XDM_Context
Context used by split codecs. More...

Defines

#define | XDM_EOK IALG_EOK
#define | XDM_EFAIL IALG_EFAIL
#define | XDM_EUNSUPPORTED -3
#define | XDM_ERUNTIME -2
General runtime failure.
#define | XDM_MAX_IO_BUFFERS 16
#define | XDM_ISACCESSMODE_READ(x) (((x) >> XDM_ACCESSMODE_READ) & 0x1)
Check an access mask for CPU read access.
#define | XDM_ISACCESSMODE_WRITE(x) (((x) >> XDM_ACCESSMODE_WRITE) & 0x1)
Check an access mask for CPU write access.
#define | XDM_CLEARACCESSMODE_READ(x) ((x) &= (~(0x1 << XDM_ACCESSMODE_READ)))
Clear the "CPU read access" bit in an access mask.
#define | XDM_CLEARACCESSMODE_WRITE(x) ((x) &= (~(0x1 << XDM_ACCESSMODE_WRITE)))
Clear the "CPU write access" bit in an access mask.
#define | XDM_SETACCESSMODE_READ(x) ((x) |= (0x1 << XDM_ACCESSMODE_READ))
Set the bit to indicate CPU read access in an access mask.
#define | XDM_SETACCESSMODE_WRITE(x) ((x) |= (0x1 << XDM_ACCESSMODE_WRITE))
Set the bit to indicate CPU write access in an access mask.
#define | XDM_CUSTOMENUMBASE 0x100
Base of algorithm-specific enum values.
#define | XDM_CUSTOMCMDBASE 0x100
Base of algorithm-specific commands.
#define | XDM_ISFATALERROR(x) (((x) >> XDM_FATALERROR) & 0x1)
#define | XDM_ISUNSUPPORTEDPARAM(x) (((x) >> XDM_UNSUPPORTEDPARAM) & 0x1)
#define | XDM_ISUNSUPPORTEDINPUT(x) (((x) >> XDM_UNSUPPORTEDINPUT) & 0x1)
#define | XDM_ISCORRUPTEDHEADER(x) (((x) >> XDM_CORRUPTEDHEADER) & 0x1)
#define | XDM_ISCORRUPTEDDATA(x) (((x) >> XDM_CORRUPTEDDATA) & 0x1)
#define | XDM_ISINSUFFICIENTDATA(x) (((x) >> XDM_INSUFFICIENTDATA) & 0x1)
#define | XDM_ISAPPLIEDCONCEALMENT(x) (((x) >> XDM_APPLIEDCONCEALMENT) & 0x1)
#define | XDM_SETFATALERROR(x) ((x) |= (0x1 << XDM_FATALERROR))
#define | XDM_SETUNSUPPORTEDPARAM(x) ((x) |= (0x1 << XDM_UNSUPPORTEDPARAM))
#define | XDM_SETUNSUPPORTEDINPUT(x) ((x) |= (0x1 << XDM_UNSUPPORTEDINPUT))
#define | XDM_SETCORRUPTEDHEADER(x) ((x) |= (0x1 << XDM_CORRUPTEDHEADER))
#define | XDM_SETCORRUPTEDDATA(x) ((x) |= (0x1 << XDM_CORRUPTEDDATA))
#define | XDM_SETINSUFFICIENTDATA(x) ((x) |= (0x1 << XDM_INSUFFICIENTDATA))
#define | XDM_SETAPPLIEDCONCEALMENT(x) ((x) |= (0x1 << XDM_APPLIEDCONCEALMENT))
#define | XDM_MAX_CONTEXT_BUFFERS 32
Maximum number of context buffers.

Enumerations

enum XDM_AccessMode {
XDM_ACCESSMODE_READ = 0,
XDM_ACCESSMODE_WRITE = 1
}

Access modes used to declare how the algorithm accessed buffers.

More...
enum XDM_CmdId {
XDM_GETSTATUS = 0,
XDM_SETPARAMS = 1,
XDM_RESET = 2,
XDM_SETDEFAULT = 3,
XDM_FLUSH = 4,
XDM_GETBUFINFO = 5,
XDM_GETVERSION = 6,
XDM_GETCONTEXTINFO = 7
}

Standard control commands that must be implemented by XDM compliant multimedia algorithms.

More...
enum XDM_ErrorBit {
XDM_PARAMSCHANGE = 8,
XDM_APPLIEDCONCEALMENT = 9,
XDM_INSUFFICIENTDATA = 10,
XDM_CORRUPTEDDATA = 11,
XDM_CORRUPTEDHEADER = 12,
XDM_UNSUPPORTEDINPUT = 13,
XDM_UNSUPPORTEDPARAM = 14,
XDM_FATALERROR = 15
}

Extended error information.

More...
enum XDM_DataFormat {
XDM_BYTE = 1,
XDM_LE_16 = 2,
XDM_LE_32 = 3,
XDM_LE_64 = 4,
XDM_BE_16 = 5,
XDM_BE_32 = 6,
XDM_BE_64 = 7
}

Endianness of data.

More...
enum XDM_EncodingPreset {
XDM_DEFAULT = 0,
XDM_HIGH_QUALITY = 1,
XDM_HIGH_SPEED = 2,
XDM_USER_DEFINED = 3
}

Encoding presets.

More...
enum XDM_DecMode {
XDM_DECODE_AU = 0,
XDM_PARSE_HEADER = 1
}

Decode entire access unit or only header.

More...
enum XDM_EncMode {
XDM_ENCODE_AU = 0,
XDM_GENERATE_HEADER = 1
}

Encode entire access unit or only header.

More...
enum XDM_ChromaFormat {
XDM_CHROMA_NA = -1,
XDM_YUV_420P = 1,
XDM_YUV_422P = 2,
XDM_YUV_422IBE = 3,
XDM_YUV_422ILE = 4,
XDM_YUV_444P = 5,
XDM_YUV_411P = 6,
XDM_GRAY = 7,
XDM_RGB = 8,
XDM_YUV_420SP = 9,
XDM_ARGB8888 = 10,
XDM_RGB555 = 11,
XDM_RGB565 = 12,
XDM_YUV_444ILE = 13,
XDM_CHROMAFORMAT_DEFAULT = XDM_YUV_422ILE
}

Chroma formats.

More...

Detailed Description

This is the XDM interface.

Define Documentation

#define XDM_EOK IALG_EOK

Success.

#define XDM_EFAIL IALG_EFAIL

General failure.

#define XDM_EUNSUPPORTED -3

Request is unsupported.

#define XDM_ERUNTIME -2

General runtime failure.

Deprecated:
This is only supported on 0.9 XDM. To use it, you must define "XDM_INCLUDE_DOT9_SUPPORT". In XDM 1.00+, it is required that codecs return "EFAIL", as "ERUNTIME" is not supported.
#define XDM_MAX_IO_BUFFERS 16

Max I/O Buffers

#define XDM_ISACCESSMODE_READ ( x ) (((x) >> XDM_ACCESSMODE_READ) & 0x1)

Check an access mask for CPU read access.

Parameters:
x access mask.
Remarks:
This is typically used by an application.
See also:
XDM1_SingleBufDesc::accessMask
XDM_ISACCESSMODE_WRITE
#define XDM_ISACCESSMODE_WRITE ( x ) (((x) >> XDM_ACCESSMODE_WRITE) & 0x1)

Check an access mask for CPU write access.

Parameters:
x access mask.
Remarks:
This is typically used by an application.
See also:
XDM1_SingleBufDesc::accessMask
XDM_ISACCESSMODE_READ
#define XDM_CLEARACCESSMODE_READ ( x ) ((x) &= (~(0x1 << XDM_ACCESSMODE_READ)))

Clear the "CPU read access" bit in an access mask.

Parameters:
x access mask.
Remarks:
This is typically used by an algorithm.
See also:
XDM_SETACCESSMODE_READ
XDM1_SingleBufDesc::accessMask
#define XDM_CLEARACCESSMODE_WRITE ( x ) ((x) &= (~(0x1 << XDM_ACCESSMODE_WRITE)))

Clear the "CPU write access" bit in an access mask.

Parameters:
x access mask.
Remarks:
This is typically used by an algorithm.
See also:
XDM_SETACCESSMODE_WRITE
XDM1_SingleBufDesc::accessMask
#define XDM_SETACCESSMODE_READ ( x ) ((x) |= (0x1 << XDM_ACCESSMODE_READ))

Set the bit to indicate CPU read access in an access mask.

Parameters:
x access mask.
Remarks:
This is typically used by an algorithm.
See also:
XDM1_SingleBufDesc::accessMask
#define XDM_SETACCESSMODE_WRITE ( x ) ((x) |= (0x1 << XDM_ACCESSMODE_WRITE))

Set the bit to indicate CPU write access in an access mask.

Parameters:
x access mask.
Remarks:
This is typically used by an algorithm.
See also:
XDM1_SingleBufDesc::accessMask
#define XDM_CUSTOMENUMBASE 0x100

Base of algorithm-specific enum values.

Remarks:
This is provided to ensure that future updates to XDM-defined enumerations don't conflict with algorithm-proprietary enumerations.
Custom enumerations should be defined like the following (USERENUM0 and USERENUM1 are simply examples):
  #define MYMODULE_MYVENDOR_USERENUM0 (XDM_CUSTOMENUMBASE + 0)
  #define MYMODULE_MYVENDOR_USERENUM1 (XDM_CUSTOMENUMBASE + 1)
#define XDM_CUSTOMCMDBASE 0x100

Base of algorithm-specific commands.

Remarks:
This is provided to ensure that future updates to XDM_CmdId's enumeration don't conflict with algorithm-proprietary command ID's.
Custom command ID's should be defined like the following (USERCMD0 and USERCMD1 are simply examples):
  #define MYMODULE_MYVENDOR_USERCMD0 (XDM_CUSTOMCMDBASE + 0)
  #define MYMODULE_MYVENDOR_USERCMD1 (XDM_CUSTOMCMDBASE + 1)
See also:
XDM_CmdId
#define XDM_ISFATALERROR ( x ) (((x) >> XDM_FATALERROR) & 0x1)

Check for fatal error

#define XDM_ISUNSUPPORTEDPARAM ( x ) (((x) >> XDM_UNSUPPORTEDPARAM) & 0x1)

Check for unsupported parameter

#define XDM_ISUNSUPPORTEDINPUT ( x ) (((x) >> XDM_UNSUPPORTEDINPUT) & 0x1)

Check for unsupported input

#define XDM_ISCORRUPTEDHEADER ( x ) (((x) >> XDM_CORRUPTEDHEADER) & 0x1)

Check for corrupted header

#define XDM_ISCORRUPTEDDATA ( x ) (((x) >> XDM_CORRUPTEDDATA) & 0x1)

Check for corrupted data

#define XDM_ISINSUFFICIENTDATA ( x ) (((x) >> XDM_INSUFFICIENTDATA) & 0x1)

Check for insufficient data

#define XDM_ISAPPLIEDCONCEALMENT ( x ) (((x) >> XDM_APPLIEDCONCEALMENT) & 0x1)

Check for applied concealment

#define XDM_SETFATALERROR ( x ) ((x) |= (0x1 << XDM_FATALERROR))

Set fatal error bit

#define XDM_SETUNSUPPORTEDPARAM ( x ) ((x) |= (0x1 << XDM_UNSUPPORTEDPARAM))

Set unsupported parameter bit

#define XDM_SETUNSUPPORTEDINPUT ( x ) ((x) |= (0x1 << XDM_UNSUPPORTEDINPUT))

Set unsupported input bit

#define XDM_SETCORRUPTEDHEADER ( x ) ((x) |= (0x1 << XDM_CORRUPTEDHEADER))

Set corrupted header bit

#define XDM_SETCORRUPTEDDATA ( x ) ((x) |= (0x1 << XDM_CORRUPTEDDATA))

Set corrupted data bit

#define XDM_SETINSUFFICIENTDATA ( x ) ((x) |= (0x1 << XDM_INSUFFICIENTDATA))

Set insufficient data bit

#define XDM_SETAPPLIEDCONCEALMENT ( x ) ((x) |= (0x1 << XDM_APPLIEDCONCEALMENT))

Set applied concealment bit

#define XDM_MAX_CONTEXT_BUFFERS 32

Maximum number of context buffers.

Enumeration Type Documentation

enum XDM_AccessMode

Access modes used to declare how the algorithm accessed buffers.

Remarks:
This indicates how the algorithm's CPU accessed the buffer, independent of DMA or other hardware accellerators. For example, if the buffer was written to with DMA (as opposed to writing to the buffer with the CPU write instructions), the algorithm should not set the XDM_ACCESSMODE_WRITE bit.
The value of the enum is the bit offset into a mask. The value of the enum is not the value to assign the mask.
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
XDM1_SingleBufDesc
XDM1_BufDesc
Enumerator:
XDM_ACCESSMODE_READ

The algorithm read from the buffer using the CPU.

See also:
XDM_SETACCESSMODE_READ
XDM_ISACCESSMODE_READ
XDM_ACCESSMODE_WRITE

The algorithm wrote to the buffer using the CPU.

See also:
XDM_SETACCESSMODE_WRITE
XDM_ISACCESSMODE_WRITE
enum XDM_CmdId

Standard control commands that must be implemented by XDM compliant multimedia algorithms.

Remarks:
If an algorithm receives a command it doesn't handle or understand, it must return EUNSUPPORTED.
XDM_GETCONTEXTINFO need only be implemented by split codecs. Standard algorithms should return EUNSUPPORTED if they receive the XDM_GETCONTEXTINFO command.
Any control ID extension in IMOD interface should start from XDM_CUSTOMCMDBASE onward. The ID range from 0 to XDM_CUSTOMCMDBASE is reserved.
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
XDM_CUSTOMCMDBASE
Enumerator:
XDM_GETSTATUS

Query algorithm to fill status structure.

XDM_SETPARAMS

Set run time dynamic parameters.

XDM_RESET

Reset the algorithm. All fields in the internal data structures are reset and all internal buffers are flushed.

XDM_SETDEFAULT

Restore the algorithm's internal state to its original, default values.

Remarks:
The application only needs to initialize the dynamicParams.size and status.size fields prior to calling control() with XDM_SETDEFAULT.
The algorithm must only write to the status.extendedError field, and potentially algorithm specific, extended fields.
XDM_SETDEFAULT differs from XDM_RESET. In addition to restoring the algorithm's internal state, XDM_RESET additionally resets any channel related state.
XDM_FLUSH

Handle end of stream conditions. This command forces the algorithm to output data without additional input. The recommended sequence is to call the control() function (with XDM_FLUSH) followed by repeated calls to the process() function until it returns an error.

Remarks:
The algorithm should return the appropriate, class-specific "EFAIL" error (e.g. ISPHDEC1_EFAIL, IVIDENC1_EFAIL, etc), when flushing is complete.
XDM_GETBUFINFO

Query algorithm instance regarding its properties of input and output buffers.

Remarks:
The application only needs to initialize the dynamicParams.size, the status.size, and set any buffer descriptor fields (e.g. status.data) to NULL prior to calling control() with XDM_GETBUFINFO.
XDM_GETVERSION

Query the algorithm's version. The result will be returned in the data field of the respective _Status structure.

Remarks:
There is no specific format defined for version returned by the algorithm.
XDM_GETCONTEXTINFO

Query a split codec part for its context needs.

Remarks:
Only split codecs are required to implement this command.
enum XDM_ErrorBit

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.
Enumerator:
XDM_PARAMSCHANGE

Bit 8 - Sequence Parameters Change.

Remarks:
This error is applicable for transcoders. It is set when some key parameter of the input sequence changes. The transcoder simply returns after setting this error field and the correct input sequence parameters are updated in outArgs.
XDM_APPLIEDCONCEALMENT

Bit 9 - Applied concealment.

Remarks:
This error is applicable for decoders. It is set when the decoder was not able to able to decode the bitstream, and the decoder has concealed the bitstream error and produced the concealed output.
XDM_INSUFFICIENTDATA

Bit 10 - Insufficient input data.

Remarks:
This error is typically applicable for decoders. This is set when the input data provided is not sufficient to produce of one frame of data. This can be also be set for encoders when the number of valid samples in the input frame is not sufficient to process a frame.
XDM_CORRUPTEDDATA

Bit 11 - Data problem/corruption.

Remarks:
This error is typically applicable for decoders. This is set when the bitstream has an error and not compliant to the standard syntax.
XDM_CORRUPTEDHEADER

Bit 12 - Header problem/corruption.

Remarks:
This error is typically applicable for decoders. This is set when the header information in the bitstream is incorrect. For example, it is set when Sequence/Picture/Slice etc. are incorrect in video decoders.
XDM_UNSUPPORTEDINPUT

Bit 13 - Unsupported feature/parameter in input.

Remarks:
This error is set when the algorithm is not able process a certain input data/bitstream format. It can also be set when a subset of features in a standard are not supported by the algorithm.
For example, if a video encoder only supports 4:2:2 format, it can set this error for any other type of input video format.
XDM_UNSUPPORTEDPARAM

Bit 14 - Unsupported input parameter or configuration.

Remarks:
This error is set when the algorithm doesn't support certain configurable parameters. For example, if the video decoder doesn't support the "display width" feature, it shall return XDM_UNSUPPORTEDPARAM when the control function is called for setting the displayWidth attribute.
XDM_FATALERROR

Bit 15 - Fatal error (stop the codec). If there is an error and this bit is not set, the error is a recoverable one.

Remarks:
This error is set when the algorithm cannot recover from the current state. It informs the system not to try the next frame and possibly delete the multimedia algorithm instance. It implies the codec shall not work when reset.
The user should delete the current instance of the codec.
enum XDM_DataFormat

Endianness of data.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
XDM_BYTE

Big endian stream.

XDM_LE_16

16 bit little endian stream.

XDM_LE_32

32 bit little endian stream.

XDM_LE_64

64 bit little endian stream.

XDM_BE_16

16 bit big endian stream.

XDM_BE_32

32 bit big endian stream.

XDM_BE_64

64 bit big endian stream.

enum XDM_EncodingPreset

Encoding presets.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
XDM_DEFAULT

Default setting of encoder. See codec specific documentation for its encoding behaviour.

XDM_HIGH_QUALITY

High quality encoding.

XDM_HIGH_SPEED

High speed encoding.

XDM_USER_DEFINED

User defined configuration, using advanced parameters.

enum XDM_DecMode

Decode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
XDM_DECODE_AU

Decode entire access unit, including all the headers.

XDM_PARSE_HEADER

Decode only header.

enum XDM_EncMode

Encode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
XDM_ENCODE_AU

Encode entire access unit, including the headers.

XDM_GENERATE_HEADER

Encode only header.

enum XDM_ChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE
Enumerator:
XDM_CHROMA_NA

Chroma format not applicable.

XDM_YUV_420P

YUV 4:2:0 planer.

XDM_YUV_422P

YUV 4:2:2 planer.

XDM_YUV_422IBE

YUV 4:2:2 interleaved (big endian).

XDM_YUV_422ILE

YUV 4:2:2 interleaved (little endian).

XDM_YUV_444P

YUV 4:4:4 planer.

XDM_YUV_411P

YUV 4:1:1 planer.

XDM_GRAY

Gray format.

XDM_RGB

RGB color format.

XDM_YUV_420SP

YUV 420 semi_planar format.(Luma 1st plane, CbCr interleaved 2nd plane)

XDM_ARGB8888

Alpha plane.

XDM_RGB555

RGB 555 color format.

XDM_RGB565

RGB 565 color format.

XDM_YUV_444ILE

YUV 4:4:4 interleaved (little endian).

XDM_CHROMAFORMAT_DEFAULT

Default setting.


Codec Engine Application Programming Interface (API): XDAIS Types and Constants

XDAIS Types and Constants

Defines

#define | XDAS_TRUE 1
#define | XDAS_FALSE 0

Typedefs

typedef Void | XDAS_Void
typedef Uint8 | XDAS_Bool
typedef Int8 | XDAS_Int8
typedef Uint8 | XDAS_UInt8
typedef Int16 | XDAS_Int16
typedef Uint16 | XDAS_UInt16
typedef Int32 | XDAS_Int32
typedef Uint32 | XDAS_UInt32

Define Documentation

#define XDAS_TRUE 1
#define XDAS_FALSE 0

Typedef Documentation

typedef Void XDAS_Void
typedef Uint8 XDAS_Bool
typedef Int8 XDAS_Int8

Actual size chip dependent.

typedef Uint8 XDAS_UInt8

Actual size chip dependent.

typedef Int16 XDAS_Int16

Actual size of type is 16 bits.

typedef Uint16 XDAS_UInt16

Actual size of type is 16 bits.

typedef Int32 XDAS_Int32

Actual size of type is 32 bits.

typedef Uint32 XDAS_UInt32

Actual size of type is 32 bits.


Codec Engine Application Programming Interface (API): Codec Engine Runtime

Codec Engine Runtime

Data Structures

struct | Engine_Attrs
Attributes of an Engine. More...
struct | Engine_AlgInfo
Properties of an Engine algorithm. More...
struct | Engine_AlgInfo2
Properties of an Engine algorithm. This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a singie string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE". More...

Defines

#define | CE_NULL_algs NULL
#define | CE_DECLARE_TYPE(name, types)
Declare an inheritanc hierarchy for an algorithm.
#define | CE_LOCAL_ALG(name, algName, ialgFxns, idma3Fxns, iresFxns, groupId, memType)
Generates a structure containing data for a local algorithm. This macro must be called between the CE_BEGIN_ALG_TABLE() and CE_END_ALG_TABLE() macro calls. It is used in this manner:.
#define | CE_BEGIN_ALG_TABLE(name) static Engine_AlgDesc CE_##name##_algs[] = {
Use this macro and the CE_END_ALG_TABLE() macro around CE_LOCAL_ALG() to generate an algorithm table for an engine. The usage is: CE_BEGIN_ALG_TABLE(engineAlgTab) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineAlgTab).
#define | CE_END_ALG_TABLE(name)
Use this macro after CE_BEGIN_ALG_TABLE() and CE_LOCAL_ALG() for generating an algorithm table for an engine. The usage is: CE_BEGIN_ALG_TABLE(engineAlgTab) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineAlgTab).
#define | CE_ENGINE(algTab, engineName, serverName)
Generates a structure containing data for an engine. This macro must be called between the CE_BEGIN_ENGINE_TABLE() and CE_END_ENGINE_TABLE() macro calls. It is used in this manner:.
#define | CE_BEGIN_ENGINE_TABLE(name)
Use this macro and the CE_END_ENGINE_TABLE() macro around CE_ENGINE() to generate an engine table for the applicaion. The usage is: CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_1, ...) CE_ENGINE(algTab_2, ...) ... CE_ENGINE(algTab_n, ...) CE_END_ENGINE_TABLE(name).
#define | CE_END_ENGINE_TABLE(name)
Use this macro and the CE_BEGIN_ENGINE_TABLE() macro around CE_ENGINE() to generate an engine table for the applicaion. The usage is: CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_1, ...) CE_ENGINE(algTab_2, ...) ... CE_ENGINE(algTab_n, ...) CE_END_ENGINE_TABLE(name).
#define | Engine_GTNAME "CE"
Trace name for the Engine module.
#define | Engine_EOK 0
#define | Engine_EEXIST 1
#define | Engine_ENOMEM 2
#define | Engine_EDSPLOAD 3
#define | Engine_ENOCOMM 4
#define | Engine_ENOSERVER 5
#define | Engine_ECOMALLOC 6
#define | Engine_ERUNTIME 7
#define | Engine_ECODECCREATE 8
#define | Engine_ECODECSTART 9
#define | Engine_EINVAL 10
#define | Engine_EBADSERVER 11
#define | Engine_ENOTAVAIL 12
#define | Engine_EWRONGSTATE 13
#define | Engine_EINUSE 14
#define | Engine_ENOTFOUND 15
#define | Engine_ETIMEOUT 16

Typedefs

typedef struct Engine_Obj * | Engine_Handle
Opaque handle to an engine.
typedef Int | Engine_Error
Engine error code.

Functions

Void | CERuntime_exit (Void)
Exit the Codec Engine Runtime.
Void | CERuntime_init (Void)
Initialize the Codec Engine Runtime.
Void | Engine_close (Engine_Handle engine)
Close an Engine.
Engine_Handle | Engine_open (String name, Engine_Attrs *attrs, Engine_Error *ec)
Open an Engine.
Int | Engine_fwriteTrace (Engine_Handle engine, String prefix, FILE *out)
Write Server's trace buffer to specifed file stream.
Engine_Error | Engine_getAlgInfo (String name, Engine_AlgInfo *algInfo, Int index)
Get details of an algorithm configured into an engine.
Engine_Error | Engine_getAlgInfo2 (String name, Engine_Handle engine, Engine_AlgInfo2 *algInfo2, Int index)
Get details of an algorithm that is configured into an engine, or has been added to an opened engine. If the engine has not been opened yet, the name of the engine is used to get the statically configured alg. If the engine has been opened, the engine handle can be used to get either information for a statically configured alg, or a remote alg that was added when the server was queried during Engine_open().
Int | Engine_getCpuLoad (Engine_Handle engine)
Get Server's cpu usage in percent.
Engine_Error | Engine_getLastError (Engine_Handle engine)
Get error code of the last failed operation.
String | Engine_getName (Engine_Handle engine)
Get the name of an opened engine.
Engine_Error | Engine_getNumAlgs (String name, Int *numAlgs)
Get the number of algorithms configured into an engine.
Engine_Error | Engine_getNumAlgs2 (String name, Engine_Handle engine, Int *numAlgs)
Get the number of algorithms statically configured into an engine or the total number of algorithms both statically configured and dynamically added through server information when the engine was opened.
Server_Handle | Engine_getServer (Engine_Handle engine)
Get handle to an Engine's server.
UInt32 | Engine_getUsedMem (Engine_Handle engine)
Get Server's total memory usage.
Int | Engine_setTrace (Engine_Handle engine, String mask)
Set Server's trace mask.

Variables

Engine_Attrs Engine_ATTRS
Default engine attributes.

Define Documentation

#define CE_NULL_algs NULL
#define CE_DECLARE_TYPE | ( | name,
 |  | types | )
Value:
\
static String typeTab_##name [] = {          \
    types,                                   \
    NULL                                     \
};                                           \
                                             \

Declare an inheritanc hierarchy for an algorithm.

Parameters:
[in] | name | This is a symbol that will be associated with the types argument. It will be used to generate an internal variable name, so don't use the same name for two different calls to CE_DECLARE_TYPE(). name should be used in CE_LOCAL_ALG() to associate an alg to types.
[in] | types | This is a ';' separated string of inheritance hierarchies. It is used to identify the codec class of an algorithm. For example, the declaration: CE_DECLARE_TYPE(mydecoder, "ti.sdo.ce.speech1.ISPHDEC1") indicates that mydecoder (a name that will be used in CE_LOCAL_ALG() to declare a speech decoder), inherits the ti.sdo.ce.speech1.ISPHDEC1 interface.

Another example is the following: CE_DECLARE_TYPE(decoder, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE") This says that the decoder inherits the ti.sdo.ce.test.xvideo.IVIDE interface, which in turn inherits the ti.sdo.ce.video.IVIDDEC interface.

See also:
CE_LOCAL_ALG()
#define CE_LOCAL_ALG | ( | name,
 |  | algName,
 |  | ialgFxns,
 |  | idma3Fxns,
 |  | iresFxns,
 |  | groupId,
 |  | memType | )
Value:
\
    { algName,        /* name */             \
      {0},            /* uuid */             \
      ialgFxns,       /* ialgFxns */         \
      idma3Fxns,      /* idma3Fxns */        \
      typeTab_##name, /* typeTab */          \
      TRUE,           /* isLocal */          \
      groupId,        /* groupId */          \
      0,              /* protocol */         \
      iresFxns,       /* iresFxns */         \
      NULL,           /* stub/skel params */ \
      memType,        /* cached mem type */  \
      NULL,           /* type - typeTab[0] will be used instead */ \
    },

Generates a structure containing data for a local algorithm. This macro must be called between the CE_BEGIN_ALG_TABLE() and CE_END_ALG_TABLE() macro calls. It is used in this manner:.

CE_BEGIN_ALG_TABLE(engineName) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineName)

Parameters:
[in] | name | This symbol is used to associate the algorithm with one of the types passed to CE_DECLARE_TYPE().
[in] | algName | This is the string name that the applicaion will use to create the algorithm, for example, "sphenc1_copy".
[in] | ialgFxns | The address of the IALG_Fxns table for the algorithm.
[in] | idma3Fxns | The address of the algorithm's IDMA3_Fxns table, if it has one, otherwise NULL.
[in] | iresFxns | If the algorithm uses IRES, the address of its IRES_Fxns table, otherwise NULL.
[in] | groupId | Scratch group Id of algorithm.
[in] | memType | The type of memory (cached, non-cached, or whatever the default is), to allocate for the algorithm. Choose from the following values for memType:

Engine_USECACHEDMEM_DEFAULT - default memory allocation Engine_USECACHEDMEM_NONCACHED - non-cached memory allocation Engine_USECACHEDMEM_CACHED - cached memory allocation

See also:
CE_DECLARE_TYPE
CE_BEGIN_ALG_TABLE
#define CE_BEGIN_ALG_TABLE ( name ) static Engine_AlgDesc CE_##name##_algs[] = {

Use this macro and the CE_END_ALG_TABLE() macro around CE_LOCAL_ALG() to generate an algorithm table for an engine. The usage is: CE_BEGIN_ALG_TABLE(engineAlgTab) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineAlgTab).

Parameters:
[in] name A symbol used to generate internal variable names. Use the same name in CE_END_ALG_TABLE(), and in the call to CE_ENGINE(), to associate an engine with this algorithm table.
See also:
CE_END_ALG_TABLE
CE_ENGINE
#define CE_END_ALG_TABLE ( name )
Value:
{NULL},                    \
};

Use this macro after CE_BEGIN_ALG_TABLE() and CE_LOCAL_ALG() for generating an algorithm table for an engine. The usage is: CE_BEGIN_ALG_TABLE(engineAlgTab) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineAlgTab).

Parameters:
[in] name This must be the same symbol name passed to the previous CE_BEGIN_ALG_TABLE() call.
See also:
CE_BEGIN_ALG_TABLE
CE_ENGINE
#define CE_ENGINE | ( | algTab,
 |  | engineName,
 |  | serverName | )
Value:
{ engineName,    /* engine naem */          \
      CE_##algTab##_algs,/* alg table */            \
      serverName,    /* optional server name */ \
      NULL,          /* link config id */       \
      0,             /* # of algs (filled in at runtime) */  \
    },

Generates a structure containing data for an engine. This macro must be called between the CE_BEGIN_ENGINE_TABLE() and CE_END_ENGINE_TABLE() macro calls. It is used in this manner:.

CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_0, "engine_0", NULL) CE_ENGINE(algTab_1, "engine_1", "server.x64P") CE_END_ENGINE_TABLE(name)

Parameters:
[in] algTab Symbol to associate an alg table to this engine. Use the name passed to CE_BEGIN_ALG_TABLE() to associate that alg table with this engine.
See also:
CE_BEGIN_ALG_TABLE
CE_BEGIN_ENGINE_TABLE
#define CE_BEGIN_ENGINE_TABLE ( name )
Value:
static Engine_AlgDesc _localAlgs_000[] = {    \
    {NULL},                                   \
};                                            \
                                              \
static Engine_Desc name##_000[] = {

Use this macro and the CE_END_ENGINE_TABLE() macro around CE_ENGINE() to generate an engine table for the applicaion. The usage is: CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_1, ...) CE_ENGINE(algTab_2, ...) ... CE_ENGINE(algTab_n, ...) CE_END_ENGINE_TABLE(name).

Parameters:
[in] name A symbol used to generate internal variable names. Use the same name in CE_END_ENGINE_TABLE().
See also:
CE_END_ENGINE_TABLE
CE_ENGINE
#define CE_END_ENGINE_TABLE ( name )
Value:
{"local",                                 \
     _localAlgs_000,                          \
     NULL,                                    \
     NULL,                                    \
     0,                                       \
    },                                        \
    {NULL, NULL, NULL, NULL, 0}               \
};                                            \
                                              \
Engine_Config Engine_config = {               \
    name##_000,                               \
    "local"                                   \
};

Use this macro and the CE_BEGIN_ENGINE_TABLE() macro around CE_ENGINE() to generate an engine table for the applicaion. The usage is: CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_1, ...) CE_ENGINE(algTab_2, ...) ... CE_ENGINE(algTab_n, ...) CE_END_ENGINE_TABLE(name).

Parameters:
[in] name A symbol used to generate internal variable names. Use the same name in CE_BEGIN_ENGINE_TABLE().
See also:
CE_BEGIN_ENGINE_TABLE
CE_ENGINE
#define Engine_GTNAME "CE"

Trace name for the Engine module.

#define Engine_EOK 0

Success.

#define Engine_EEXIST 1

Name does not exist.

#define Engine_ENOMEM 2

Unable to allocate memory.

#define Engine_EDSPLOAD 3

Unable to load the DSP.

#define Engine_ENOCOMM 4

Unable to create a comm connection to the DSP.

#define Engine_ENOSERVER 5

Unable to locate the server on the DSP.

#define Engine_ECOMALLOC 6

Unable to allocate communication buffer.

#define Engine_ERUNTIME 7

Internal engine runtime failure.

#define Engine_ECODECCREATE 8

Creation of the Codec failed.

#define Engine_ECODECSTART 9

Start of the Codec failed. For codecs which are implemented as a thread, this implies that the codec thread of execution failed to start.

#define Engine_EINVAL 10

Bad paramater passed to method.

#define Engine_EBADSERVER 11

Incompatible server specified.

#define Engine_ENOTAVAIL 12

Service not available.

#define Engine_EWRONGSTATE 13

Call can not be made at this time.

#define Engine_EINUSE 14

Call can't be made at this time because a required name/resource is in use.

#define Engine_ENOTFOUND 15

Entity was not found.

#define Engine_ETIMEOUT 16

Timeout-based operation timed out.

Typedef Documentation

typedef struct Engine_Obj* Engine_Handle

Opaque handle to an engine.

typedef Int Engine_Error

Engine error code.

Function Documentation

Void CERuntime_exit ( Void )

Exit the Codec Engine Runtime.

Remarks:
This function finalizes the Codec Engine modules used in the current configuration.
Void CERuntime_init ( Void )

Initialize the Codec Engine Runtime.

Remarks:
This function must be called prior to using any Codec Engine APIs; it initializes all Codec Engine modules used in the the current configuration.
Void Engine_close ( Engine_Handle engine )

Close an Engine.

Parameters:
[in] engine The handle to an engine, previously acquired by a call to Engine_open().
Precondition:
engine must not be referenced by any codec instance object; i.e., you must first delete all codec instances associated with engine before closing it.
engine is a valid (non-NULL) engine handle which is in the open state.
Engine_Handle Engine_open | ( | String | name,
 |  | Engine_Attrs * | attrs,
 |  | Engine_Error * | ec
 | ) |  |

Open an Engine.

The handle returned may be used to create one or more instances of a codec "contained" in the specified engine.

An engine may be opened more than once; each open returns a unique handle that can be used to create codec instances or get status of any underlying server.

Engine handles must not be concurrently accessed by multiple threads; each thread must either obtain its own handle (via Engine_open()) or explicitly serialize access to a shared handle.

Parameters:
[in] | name | The name of the engine to open. name is specified in the engine configuration.
[in] | attrs | Attributes for the open engine.
[out] | ec | Optional output error code
Return values:
NULL | An error has occurred.
non-NULL | The handle to the opened engine.
Precondition:
name is a non-NULL string.
name is a valid, pre-configured name of an engine.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If the return handle is NULL and ec is non-NULL, *ec is set to a non-zero value indicating the cause of the failure.
If ec is non-NULL, the Engine_Error value is set to one of the following values:
  • Engine_EOK success
  • Engine_EEXIST name does not exist
  • Engine_ENOMEM can't allocate memory
  • Engine_EDSPLOAD can't load the DSP
  • Engine_ENOCOMM can't create a comm connection to DSP
  • Engine_ENOSERVER can't locate the server on the DSP
  • Engine_ECOMALLOC can't allocate communication buffer
Int Engine_fwriteTrace | ( | Engine_Handle | engine,
 |  | String | prefix,
 |  | FILE * | out
 | ) |  |

Write Server's trace buffer to specifed file stream.

Parameters:
[in] | engine | The handle to the opened engine.
[in] | prefix | A string to prepend to each line output; this allows one to easily identify trace from the server from the application's trace, for example.
[in] | out | A open FILE stream used to output the Server's trace characters.
Return values:
Integer number of characters copied to the specified FILE stream.
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Postcondition:
In the event a negative value is returned, Engine_getLastError() will return one of the following values:
  • Engine_ERUNTIME Either an internal runtime error occured or the underlying server error occured.
  • Engine_EINUSE Server trace resource is already in use.
Engine_Error Engine_getAlgInfo | ( | String | name,
 |  | Engine_AlgInfo * | algInfo,
 |  | Int | index
 | ) |  |

Get details of an algorithm configured into an engine.

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration.
[out] | algInfo | Structure to store algorithm details. The algInfoSize field of this structure must be set to sizeof(Engine_AlgInfo) by the application.
[out] | index | The index of the algorithm to get the information.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Engine_ENOTFOUND | index is greater than or equal to the total number of algorithms configured for the engine, or index < 0.
Engine_EINVAL | The value of algInfoSize passed to this function does not match the CE library's sizeof(Engine_AlgInfo).
Precondition:
name is a non-NULL string.
algInfo is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name and 0 <= index < the total number of algorithms configured for the engine, then algInfo will contain the information for the engine's ith (i = index) algorithm.
See also:
Engine_getNumAlgs().
Engine_Error Engine_getAlgInfo2 | ( | String | name,
 |  | Engine_Handle | engine,
 |  | Engine_AlgInfo2 * | algInfo2,
 |  | Int | index
 | ) |  |

Get details of an algorithm that is configured into an engine, or has been added to an opened engine. If the engine has not been opened yet, the name of the engine is used to get the statically configured alg. If the engine has been opened, the engine handle can be used to get either information for a statically configured alg, or a remote alg that was added when the server was queried during Engine_open().

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration. This may be NULL if engine contains a valid engine handle.
[in] | engine | The handle of an engine returned by Engine_open(). If this is NULL, only information for a static alg can be obtained.
[out] | algInfo2 | Structure to store algorithm details. The algInfoSize field of this structure must be set to sizeof(Engine_AlgInfo2) by the application.
[out] | index | The index of the algorithm to get the information.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Engine_ENOTFOUND | index is greater than or equal to the total number of algorithms configured for the engine, or index < 0.
Engine_EINVAL | The value of algInfoSize passed to this function does not match the CE library's sizeof(Engine_AlgInfo2).
Precondition:
name is a non-NULL string or engine is non-NULL.
algInfo2 is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name and 0 <= index < the total number of algorithms configured for the engine, then algInfo2 will contain the information for the engine's ith (i = index) algorithm.
See also:
Engine_getNumAlgs2().
Int Engine_getCpuLoad ( Engine_Handle engine )

Get Server's cpu usage in percent.

Deprecated:
This service has been replaced by Server_getCpuLoad() to better indicate that this API is not intended for obtaining the current processor's CPU load, rather it obtains the CPU load of a remote Server.
Parameters:
[in] engine The handle to the opened engine.
Return values:
integer between 0-100 indicating percentage of time the Server is processing measured over a period of approximately 1 second. If the load is unavailable, a negative value is returned.
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Postcondition:
In the event a negative value is returned, Engine_getLastError() will return one of the following values:
  • Engine_ERUNTIME Either an internal runtime error occured or the underlying server error occured.
  • Engine_ENOTAVAIL The CPU load can not be computed.
See also:
Server_getCpuLoad()
Engine_Error Engine_getLastError ( Engine_Handle engine )

Get error code of the last failed operation.

Parameters:
[in] engine The handle to the opened engine.
Return values:
error code (Engine_Error) of the last failed engine operation.
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
String Engine_getName ( Engine_Handle engine )

Get the name of an opened engine.

Parameters:
[in] engine The handle to the opened engine.
Return values:
NULL | An error has occurred.
non-NULL | The name of the opened engine.
Engine_Error Engine_getNumAlgs | ( | String | name,
 |  | Int * | numAlgs
 | ) |  |

Get the number of algorithms configured into an engine.

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration.
[out] | numAlgs | The number of algorithms that are configured in the given engine.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Precondition:
name is a non-NULL string.
numAlgs is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name, then numAlgs will contain the number of algorithms configured for the given engine.
See also:
Engine_getAlgs().
Engine_Error Engine_getNumAlgs2 | ( | String | name,
 |  | Engine_Handle | engine,
 |  | Int * | numAlgs
 | ) |  |

Get the number of algorithms statically configured into an engine or the total number of algorithms both statically configured and dynamically added through server information when the engine was opened.

Parameters:
[in] | name | The name of the engine. name is specified in the engine configuration. name can be NULL, if engine is a valid Engine_Handle.
[in] | engine | The handle of an engine returned by Engine_open(). If engine is NULL, name must be non-NULL, and only the number of statically configured algorithms will be returned in numAlgs. specified in the engine configuration.
[out] | numAlgs | The number of algorithms that are configured in the given engine.
Return values:
Engine_EOK | Success.
Engine_EEXIST | There is no engine with the given name.
Precondition:
name is a non-NULL string or engine is non-NULL.
numAlgs is non-NULL.
As with all Codec Engine API's, CERuntime_init() must have previously been called.
Postcondition:
If name is a valid engine name, then numAlgs will contain the number of algorithms configured for the given engine.
Remarks:
If the engine has a server, but was not configured with Engine.createFromServer() number of remote algorithms (if any) that were statically configured into the engine, will be counted twice: once for the static alg table, and once for the information queried from the server.
See also:
Engine_getAlgs().
Server_Handle Engine_getServer ( Engine_Handle engine )

Get handle to an Engine's server.

This function returns the handle to an Engines server, that can be used with Server APIs to obtain information from and control the remote DSP server.

Parameters:
[in] engine The handle to the opened engine.
Return values:
Handle to engine's server.
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
UInt32 Engine_getUsedMem ( Engine_Handle engine )

Get Server's total memory usage.

Deprecated:
This service has been replaced by Server_getMemStat() to better indicate that this API is not intended for obtaining the current processor's memory statistics, rather it obtains the memory statistics of a remote Server. Also, Server_getMemStat() provides more granularity than Engine_getUsedMem().
Parameters:
[in] engine The handle to the opened engine.
Return values:
Total amount of used memory (in MAUs). If the amount is not available, 0 is returned and the reason can be retrieved via Engine_getLastError().
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Postcondition:
in the event that 0 is returned, Engine_getLastError() will return one of the following values:
  • Engine_ERUNTIME Either an internal runtime error occured or the underlying server error occured.
  • Engine_ENOTAVAIL The memory usage can not be computed.
Int Engine_setTrace | ( | Engine_Handle | engine,
 |  | String | mask
 | ) |  |

Set Server's trace mask.

Parameters:
[in] | engine | The handle to the opened engine.
[in] | mask | Trace mask, e.g. "*=01234567"
Return values:
Engine_ENOSERVER | No server for this engine.
Engine_EINUSE | Trace resource is already in use.
Engine_ERUNTIME | Internal runtime error has occurred.
Precondition:
engine is a valid (non-NULL) engine handle and the engine is in the open state.
Remarks:
This only sets the trace for a remote server. To change the trace mask for the application-side of the framework, use GT_set().
See also:
GT_set()

Variable Documentation

Engine_Attrs Engine_ATTRS

Default engine attributes.

Default attrs.


Codec Engine Application Programming Interface (API): Codec Engine Server Interface

Codec Engine Server Interface

Data Structures

struct | Server_AlgInfo
Properties of a Server algorithm. More...
struct | Server_MemStat
Information for a memory heap of a remote DSP server. More...

Defines

#define | Server_GTNAME "CS"
Trace name for the Server module.
#define | Server_MAXSEGNAMELENGTH 32
Maximum number of characters used in memory segment names.

Typedefs

typedef struct Server_Obj * | Server_Handle
Opaque handle to the server for an engine.

Enumerations

enum Server_Status {
Server_EOK = 0,
Server_ENOSERVER = 1,
Server_ENOMEM = 2,
Server_ERUNTIME = 3,
Server_EINVAL = 4,
Server_EWRONGSTATE = 5,
Server_EINUSE = 6,
Server_ENOTFOUND = 7,
Server_EFAIL = 8
}

Server error code.

More...

Functions

Server_Status | Server_connectTrace (Server_Handle server, Int *token)
Connect to server for purposes of collecting trace and/or LOG data.
Server_Status | Server_disconnectTrace (Server_Handle server, Int token)
Disconnect from server when finished collecting trace and/or LOG data.
Int | Server_fwriteTrace (Server_Handle server, String prefix, FILE *out)
Write Server's trace buffer to specifed file stream.
Int | Server_getAlgInfo (Server_Handle server, Int algNum, Server_AlgInfo *algInfo)
Get information about an algorithm on the remote server.
Int | Server_getCpuLoad (Server_Handle server)
Get Server's CPU usage in percent.
Server_Status | Server_getMemStat (Server_Handle server, Int segNum, Server_MemStat *memStat)
Get information on a memory heap segment of a remote DSP server.
Server_Status | Server_getNumAlgs (Server_Handle server, Int *numAlgs)
Get the number of codecs on the remote DSP server.
Server_Status | Server_getNumMemSegs (Server_Handle server, Int *numSegs)
Get the number of memory heap segments of a remote DSP server.
Server_Status | Server_redefineHeap (Server_Handle server, String name, Uint32 base, Uint32 size)
Set the base address and size of a remote DSP server heap.
Server_Status | Server_restoreHeap (Server_Handle server, String name)
Set the base address and size of a remote DSP server heap back to their original values.
Int | Server_setTrace (Server_Handle server, String mask)
Set Server's trace mask.

Define Documentation

#define Server_GTNAME "CS"

Trace name for the Server module.

#define Server_MAXSEGNAMELENGTH 32

Maximum number of characters used in memory segment names.

Typedef Documentation

typedef struct Server_Obj* Server_Handle

Opaque handle to the server for an engine.

Enumeration Type Documentation

enum Server_Status

Server error code.

Enumerator:
Server_EOK

Success.

Server_ENOSERVER

Engine has no server.

Server_ENOMEM

Unable to allocate memory.

Server_ERUNTIME

Internal runtime failure.

Server_EINVAL

Bad value passed to function.

Server_EWRONGSTATE

Server is not in the correct state to execute the requested function.

Server_EINUSE

Server call did not succeed because a because a required resource is in use.

Server_ENOTFOUND

An entity was not found

Server_EFAIL

Unknown failure

Function Documentation

Server_Status Server_connectTrace | ( | Server_Handle | server,
 |  | Int * | token
 | ) |  |

Connect to server for purposes of collecting trace and/or LOG data.

Parameters:
[in] | server | Server handle obtained from Engine_getServer().
[in] | token | Address to store connection token. This token should be specified in the companion call to Server_disconnectTrace().
Return values:
Server_EOK | Success, trace token was acquired.
Server_EINUSE | A connection for server trace is already established.
Server_ERUNTIME | An internal runtime error occurred.
Precondition:
server is non-NULL.
token is non-NULL.
See also:
Server_disconnectTrace().
Server_Status Server_disconnectTrace | ( | Server_Handle | server,
 |  | Int | token
 | ) |  |

Disconnect from server when finished collecting trace and/or LOG data.

Parameters:
[in] | server | Server handle obtained from Engine_getServer().
[in] | token | Connection token (as obtained from earlier, companion call to Server_connectTrace()).
Return values:
Server_EOK | Success.
Server_ERUNTIME | An internal runtime error occurred.
Precondition:
server is non-NULL.
See also:
Server_connectTrace().
Int Server_fwriteTrace | ( | Server_Handle | server,
 |  | String | prefix,
 |  | FILE * | out
 | ) |  |

Write Server's trace buffer to specifed file stream.

Parameters:
[in] | server | Server handle, obtained from Engine_getServer().
[in] | prefix | A string to prepend to each line output; this allows one to easily identify trace from the server from the application's trace, for example.
[in] | out | An open FILE stream used to output the Server's trace characters.
Return values:
Integer number of characters copied to the specified FILE stream.
Precondition:
server is non-NULL.
Corresponding engine is in the open state.
Postcondition:
In the event a negative value is returned, Engine_getLastError() will return the value:
  • Engine_ERUNTIME Either an internal runtime error occured or the underlying server error occured.
Int Server_getAlgInfo | ( | Server_Handle | server,
 |  | Int | algNum,
 |  | Server_AlgInfo * | algInfo
 | ) |  |

Get information about an algorithm on the remote server.

Parameters:
[in] | server | Server handle, obtained from Engine_getServer().
[in] | algNum | Index of algorithm.
[out] | algInfo | Location to store algorithm info.
Return values:
Server_EOK | Success.
Server_ENOTFOUND | algNum is out of range.
Server_ERUNTIME | Internal runtime error occurred.
Precondition:
server is non-NULL.
algNum is between 0 and the number of algorithms returned by Server_getNumAlgs().
algInfo is non-NULL
Postcondition:
On success, algInfo will contain information about the algorithms algNum on the DSP.
See also:
Server_getNumAlgs().
Int Server_getCpuLoad ( Server_Handle server )

Get Server's CPU usage in percent.

Parameters:
[in] server Server handle, obtained from Engine_getServer().
Return values:
Integer between 0-100 indicating percentage of time the Server is processing measured over a period of approximately 1 second. If the load is unavailable, a negative value is returned.
Precondition:
server is non-NULL.
Postcondition:
In the event a negative value is returned, Engine_getLastError() will return one of the following values:
  • Engine_ERUNTIME Either an internal runtime error occured or an underlying server error occured.
  • Engine_EINVAL The Server handle is not valid.
Server_Status Server_getMemStat | ( | Server_Handle | server,
 |  | Int | segNum,
 |  | Server_MemStat * | memStat
 | ) |  |

Get information on a memory heap segment of a remote DSP server.

Parameters:
[in] | server | Server handle obtained from Engine_getServer().
[in] | segNum | The heap number of a segment on the DSP.
[out] | memStat | Structure to store memory segment information.
Return values:
Server_EOK | Success.
Server_ENOTFOUND | segNum is out of range.
Server_ERUNTIME | Internal runtime error occurred.
Precondition:
server is non-NULL.
memStat is non-NULL.
Postcondition:
On success, memStat will contain information about the memory heap segNum on the DSP.
See also:
Server_getNumMemSegs().
Server_Status Server_getNumAlgs | ( | Server_Handle | server,
 |  | Int * | numAlgs
 | ) |  |

Get the number of codecs on the remote DSP server.

Parameters:
[in] | server | Server handle obtained from Engine_getServer().
[out] | numAlgs | The number of algs available on the DSP server.
Return values:
Server_EOK | Success.
Server_ERUNTIME | Internal runtime error occurred.
Precondition:
server is non-NULL.
numAlgs is non-NULL.
Postcondition:
On success, numAlgs will contain the number of codecs on the DSP.
Server_Status Server_getNumMemSegs | ( | Server_Handle | server,
 |  | Int * | numSegs
 | ) |  |

Get the number of memory heap segments of a remote DSP server.

Parameters:
[in] | server | Server handle obtained from Engine_getServer().
[out] | numSegs | The number of heap segments of the DSP server.
Return values:
Server_EOK | Success.
Server_ERUNTIME | Internal runtime error occurred.
Precondition:
server is non-NULL.
numSegs is non-NULL.
Postcondition:
On success, numSegs will contain the number of memory heaps on the DSP.
See also:
Server_getMemStat().
Server_Status Server_redefineHeap | ( | Server_Handle | server,
 |  | String | name,
 |  | Uint32 | base,
 |  | Uint32 | size
 | ) |  |

Set the base address and size of a remote DSP server heap.

This API is used to move and/or resize a named heap of the remote DSP server. The address passed to this API is a DSP address and the memory from base to base + size must be contiguous in physical memory. The size of the heap should be given in DSP MADUs (minimum addressable data units). The name of the heap can be at most Server_MAXSEGNAMELENGTH characters long.

For example, in the case of DM644x, suppose that an application wants to allocate a block of memory on the GPP to be used by the DSP server for the memory segment named "DDRALGHEAP". A block of physically contiguous memory could be obtained by Memory_alloc() and the corresponding DSP address obtained with Memory_getBufferPhysicalAddress(). This DSP address and the size of the block could then be passed to Server_redefineHeap(). For example:

      Server_redefineHeap(server, "DDRALGHEAP", base, size);

This function can only be called when there is no memory currently allocated in the heap (since the heap cannot be changed if it is being used).

Parameters:
[in] | server | Server handle obtained from Engine_getServer().
[in] | name | Name of heap to be redefined.
[in] | base | Base address for algorithm heap.
[in] | size | Size (DSP MADUs) of new heap.
Return values:
Server_EOK | Success.
Server_ERUNTIME | Internal runtime error occurred.
Server_ENOTFOUND | No heap with the specified name was found.
Server_EINVAL | Changing to the new base and size would cause an overlap with another heap.
Server_EINUSE | Memory is currently allocated in the heap.
Precondition:
server is non-NULL.
base is a DSP address of a physically contiguous block of memory.
base is aligned on an 8-byte boundary.
Postcondition:
On success, the server's algorithm heap base will have been set to base, and the size will have been set to size.
See also:
Server_restoreHeap().
Server_Status Server_restoreHeap | ( | Server_Handle | server,
 |  | String | name
 | ) |  |

Set the base address and size of a remote DSP server heap back to their original values.

This function resets the base address and size of a named heap of the remote server, back to their values before the first call to Server_redefineHeap() was made. The name of the heap can be at most Server_MAXSEGNAMELENGTH characters long, otherwise this function will return Server_ENOTFOUND.

As with Server_redefineHeap(), this function can only be called when no memory is currently allocated from the heap (as the heap cannot be changed if it is being used).

Parameters:
[in] | server | Server handle obtained through Engine_getServer().
[in] | name | Name of the heap to be restored.
Return values:
Server_EOK | Success.
Server_ERUNTIME | Internal runtime error occurred.
Server_ENOTFOUND | No heap with the specified name was found.
Server_EINVAL | Changing back to the original base and size would cause an overlap with another heap.
Server_EINUSE | Memory is currently allocated in the heap.
Precondition:
server is non-NULL.
Postcondition:
On success, the server's algorithm heap base and size will have been reset to their original value.
See also:
Server_redefineHeap().
Int Server_setTrace | ( | Server_Handle | server,
 |  | String | mask
 | ) |  |

Set Server's trace mask.

Parameters:
[in] | server | Server handle obtained through Engine_getServer().
[in] | mask | Trace mask, e.g. "*=01234567"
Return values:
Server_EOK | Success.
Server_EINUSE | A connection for server trace is already established.
Server_ENOSERVER | No server for the engine.
Server_ERUNTIME | Internal runtime error occurred.
Precondition:
server is non-NULL.
Corresponding engine is in the open state.
Remarks:
This only sets the trace for a remote server. To change the trace mask for the application-side of the framework, use GT_set().
See also:
GT_set()


Codec Engine Application Programming Interface (API): Data Structures

  • Data Structures
  • Data Structure Index
  • Data Fields

Data Structures

Here are the data structures with brief descriptions:
Engine_AlgInfo | Properties of an Engine algorithm
Engine_AlgInfo2 | Properties of an Engine algorithm. This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a singie string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE"
Engine_Attrs | Attributes of an Engine
IALG_Fxns | Defines the fields and methods that must be supplied by all XDAIS algorithms
IALG_MemRec | Memory records
IALG_Obj | Algorithm instance object definition
IALG_Params | Algorithm instance creation parameters
IALG_Status | Pointer to algorithm specific status structure
IAUDDEC1_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IAUDDEC1_Fxns | Defines all of the operations on IAUDDEC1 objects
IAUDDEC1_InArgs | Defines the input arguments for all IAUDDEC1 instance process function
IAUDDEC1_Obj | This must be the first field of all IAUDDEC1 instance objects
IAUDDEC1_OutArgs | Defines the run time output arguments for all IAUDDEC1 instance objects
IAUDDEC1_Params | Defines the creation time parameters for all IAUDDEC1 instance objects
IAUDDEC1_Status | Defines instance status parameters (read-only)
IAUDDEC_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IAUDDEC_Fxns | Defines all of the operations on IAUDDEC objects
IAUDDEC_InArgs | Defines the input arguments for all IAUDDEC instance process function
IAUDDEC_Obj | This must be the first field of all IAUDDEC instance objects
IAUDDEC_OutArgs | Defines the run time output arguments for all IAUDDEC instance objects
IAUDDEC_Params | Defines the creation time parameters for all IAUDDEC instance objects
IAUDDEC_Status | Defines instance status parameters (read-only)
IAUDENC1_DynamicParams | This structure defines the algorithm parameters that can be modified after creation via control() calls
IAUDENC1_Fxns | Defines all of the operations on IAUDENC1 objects
IAUDENC1_InArgs | Defines the input arguments for all IAUDENC1 instance process function
IAUDENC1_Obj | This must be the first field of all IAUDENC1 instance objects
IAUDENC1_OutArgs | Defines the run time output arguments for all IAUDENC1 instance objects
IAUDENC1_Params | Defines the creation time parameters for all IAUDENC1 instance objects
IAUDENC1_Status | Defines instance status parameters (read-only)
IAUDENC_DynamicParams | This structure defines the algorithm parameters that can be modified after creation via control() calls
IAUDENC_Fxns | Defines all of the operations on IAUDENC objects
IAUDENC_InArgs | Defines the input arguments for all IAUDENC instance process function
IAUDENC_Obj | This must be the first field of all IAUDENC instance objects
IAUDENC_OutArgs | Defines the run time output arguments for all IAUDENC instance objects
IAUDENC_Params | Defines the creation time parameters for all IAUDENC instance objects
IAUDENC_Status | Defines instance status parameters (read-only)
IIMGDEC1_CodecClassConfig | Definition of IIMGDEC1 codec class configurable parameters
IIMGDEC1_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IIMGDEC1_Fxns | Defines all of the operations on IIMGDEC1 objects
IIMGDEC1_InArgs | Defines the input arguments for all IIMGDEC1 instance process() function
IIMGDEC1_Obj | This must be the first field of all IIMGDEC1 instance objects
IIMGDEC1_OutArgs | Defines the run time output arguments for all IIMGDEC1 instance objects
IIMGDEC1_Params | Defines the creation time parameters for all IIMGDEC1 instance objects
IIMGDEC1_Status | Defines instance status parameters
IIMGDEC_CodecClassConfig | Definition of IIMGDEC codec class configurable parameters
IIMGDEC_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IIMGDEC_Fxns | Defines all of the operations on IIMGDEC objects
IIMGDEC_InArgs | Defines the input arguments for all IIMGDEC instance process() function
IIMGDEC_Obj | This must be the first field of all IIMGDEC instance objects
IIMGDEC_OutArgs | Defines the run time output arguments for all IIMGDEC instance objects
IIMGDEC_Params | Defines the creation time parameters for all IIMGDEC instance objects
IIMGDEC_Status | Defines instance status parameters (read-only)
IIMGENC1_CodecClassConfig | Definition of IIMGENC1 codec class configurable parameters
IIMGENC1_DynamicParams | This structure defines the algorithm parameters that can be modified after creation via control() calls
IIMGENC1_Fxns | Defines all of the operations on IIMGENC1 objects
IIMGENC1_InArgs | Defines the input arguments for all IIMGENC1 instance process() function
IIMGENC1_Obj | This must be the first field of all IIMGENC1 instance objects
IIMGENC1_OutArgs | Defines the run time output arguments for all IIMGENC1 instance objects
IIMGENC1_Params | Defines the creation time parameters for all IIMGENC1 instance objects
IIMGENC1_Status | Defines instance status parameters
IIMGENC_CodecClassConfig | Definition of IIMGENC codec class configurable parameters
IIMGENC_DynamicParams | This structure defines the algorithm parameters that can be modified after creation via control() calls
IIMGENC_Fxns | Defines all of the operations on IIMGENC objects
IIMGENC_InArgs | Defines the input arguments for all IIMGENC instance process() function
IIMGENC_Obj | This must be the first field of all IIMGENC instance objects
IIMGENC_OutArgs | Defines the run time output arguments for all IIMGENC instance objects
IIMGENC_Params | Defines the creation time parameters for all IIMGENC instance objects
IIMGENC_Status | Defines instance status parameters (read-only)
ISPHDEC1_DynamicParams | This structure defines the codec parameters that can be modified after creation via ISPHDEC1_Fxns.control()
ISPHDEC1_Fxns | Defines all of the operations on ISPHDEC1 objects
ISPHDEC1_InArgs | Defines the input arguments for all ISPHDEC1 instance process function
ISPHDEC1_Obj | This must be the first field of all ISPHDEC1 instance objects
ISPHDEC1_OutArgs | Defines the run time output arguments for all ISPHDEC1 instance objects
ISPHDEC1_Params | Defines the creation time parameters for all ISPHDEC1 instance objects
ISPHDEC1_Status | Defines instance status parameters
ISPHDEC_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
ISPHDEC_Fxns | Defines all of the operations on ISPHDEC objects
ISPHDEC_InArgs | Defines the input arguments for all ISPHDEC instance process function
ISPHDEC_Obj | This must be the first field of all ISPHDEC instance objects
ISPHDEC_OutArgs | Defines the run time output arguments for all ISPHDEC instance objects
ISPHDEC_Params | Defines the creation time parameters for all ISPHDEC instance objects
ISPHDEC_Status | Defines instance status parameters (read-only)
ISPHENC1_DynamicParams | This structure defines the codec parameters that can be modified after creation via ISPHENC1_Fxns.control()
ISPHENC1_Fxns | Defines all of the operations on ISPHENC1 objects
ISPHENC1_InArgs | Defines the input arguments for all ISPHENC1 instance process function
ISPHENC1_Obj | This must be the first field of all ISPHENC1 instance objects
ISPHENC1_OutArgs | Defines the run time output arguments for all ISPHENC1 instance objects
ISPHENC1_Params | Defines the creation time parameters for all ISPHENC1 instance objects
ISPHENC1_Status | Defines instance status parameters
ISPHENC_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
ISPHENC_Fxns | Defines all of the operations on ISPHENC objects
ISPHENC_InArgs | Defines the input arguments for all ISPHENC instance process function
ISPHENC_Obj | This must be the first field of all ISPHENC instance objects
ISPHENC_OutArgs | Defines the run time output arguments for all ISPHENC instance objects
ISPHENC_Params | Defines the creation time parameters for all ISPHENC instance objects
ISPHENC_Status | Defines instance status parameters (read-only)
IUNIVERSAL_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IUNIVERSAL_Fxns | Defines all of the operations on IUNIVERSAL objects
IUNIVERSAL_InArgs | Defines the input arguments for all IUNIVERSAL instance process function
IUNIVERSAL_Obj | This must be the first field of all IUNIVERSAL instance objects
IUNIVERSAL_OutArgs | Defines the run time output arguments for all IUNIVERSAL instance objects
IUNIVERSAL_Params | Defines the creation time parameters for all IUNIVERSAL instance objects
IUNIVERSAL_Status | Defines instance status parameters (read-only)
IVIDANALYTICS_DynamicParams | This structure defines the algorithm parameters that can be modified after creation via control() calls
IVIDANALYTICS_Fxns | Defines all of the operations on IVIDANALYTICS objects
IVIDANALYTICS_Grid | Access modes used to declare how the algorithm accessed buffers
IVIDANALYTICS_InArgs | Defines the input arguments for all IVIDANALYTICS instance process function
IVIDANALYTICS_Obj | This must be the first field of all IVIDANALYTICS instance objects
IVIDANALYTICS_OutArgs | Defines the run time output arguments for all IVIDANALYTICS instance objects
IVIDANALYTICS_Params | Defines the creation time parameters for all IVIDANALYTICS instance objects
IVIDANALYTICS_Rule | Analytics rule
IVIDANALYTICS_Status | Defines instance status parameters
IVIDDEC1_CodecClassConfig | Definition of IVIDDEC1 codec class configurable parameters
IVIDDEC1_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IVIDDEC1_Fxns | Defines all of the operations on IVIDDEC1 objects
IVIDDEC1_InArgs | Defines the input arguments for all IVIDDEC1 instance process function
IVIDDEC1_Obj | This must be the first field of all IVIDDEC1 instance objects
IVIDDEC1_OutArgs | Defines the run time output arguments for all IVIDDEC1 instance objects
IVIDDEC1_Params | Defines the creation time parameters for all IVIDDEC1 instance objects
IVIDDEC1_Status | Defines instance status parameters
IVIDDEC2_CodecClassConfig | Definition of IVIDDEC2 codec class configurable parameters
IVIDDEC2_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IVIDDEC2_Fxns | Defines all of the operations on IVIDDEC2 objects
IVIDDEC2_InArgs | Defines the input arguments for all IVIDDEC2 instance process function
IVIDDEC2_Obj | This must be the first field of all IVIDDEC2 instance objects
IVIDDEC2_OutArgs | Defines the run time output arguments for all IVIDDEC2 instance objects
IVIDDEC2_Params | Defines the creation time parameters for all IVIDDEC2 instance objects
IVIDDEC2_Status | Defines instance status parameters
IVIDDEC2BACK_CodecClassConfig | Definition of IVIDDEC2BACK codec class configurable parameters
IVIDDEC2BACK_Fxns | Defines all of the operations on IVIDDEC2BACK objects
IVIDDEC2BACK_Obj | This must be the first field of all IVIDDEC2BACK instance objects
IVIDDEC2FRONT_Fxns | Defines all of the operations on IVIDDEC2FRONT objects
IVIDDEC2FRONT_Obj | This must be the first field of all IVIDDEC2FRONT instance objects
IVIDDEC2FRONT_OutArgs | Defines the run time output arguments for all IVIDDEC2FRONT instance objects
IVIDDEC2FRONT_Status | Defines instance status parameters
IVIDDEC_CodecClassConfig | Definition of VIDDEC codec class configurable parameters
IVIDDEC_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IVIDDEC_Fxns | Defines all of the operations on IVIDDEC objects
IVIDDEC_InArgs | Defines the input arguments for all IVIDDEC instance process function
IVIDDEC_Obj | This must be the first field of all IVIDDEC instance objects
IVIDDEC_OutArgs | Defines the run time output arguments for all IVIDDEC instance objects
IVIDDEC_Params | Defines the creation time parameters for all IVIDDEC instance objects
IVIDDEC_Status | Defines instance status parameters
IVIDENC1_DynamicParams | This structure defines the algorithm parameters that can be modified after creation via control() calls
IVIDENC1_Fxns | Defines all of the operations on IVIDENC1 objects
IVIDENC1_InArgs | Defines the input arguments for all IVIDENC1 instance process function
IVIDENC1_MbData | Defines the structure that contains macroblock related encoding parameter estimates
IVIDENC1_Obj | This must be the first field of all IVIDENC1 instance objects
IVIDENC1_OutArgs | Defines the run time output arguments for all IVIDENC1 instance objects
IVIDENC1_Params | Defines the creation time parameters for all IVIDENC1 instance objects
IVIDENC1_Status | Defines instance status parameters
IVIDENC_CodecClassConfig | Definition of IVIDENC codec class configurable parameters
IVIDENC_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IVIDENC_Fxns | Defines all of the operations on IVIDENC objects
IVIDENC_InArgs | Defines the input arguments for all IVIDDEC instance process function
IVIDENC_Obj | This must be the first field of all IVIDENC instance objects
IVIDENC_OutArgs | Defines the run time output arguments for all IVIDENC instance objects
IVIDENC_Params | Defines the creation time parameters for all IVIDENC instance objects
IVIDENC_Status | Defines instance status parameters (read-only)
IVIDEO1_BufDesc | Detailed buffer descriptor for video buffers
IVIDEO1_BufDescIn | Buffer descriptor for input video buffers
IVIDEO_BufDesc | Buffer descriptor for video buffers
IVIDTRANSCODE_DynamicParams | This structure defines the codec parameters that can be modified after creation via control() calls
IVIDTRANSCODE_Fxns | Defines all of the operations on IVIDTRANSCODE objects
IVIDTRANSCODE_InArgs | Defines the input arguments for all IVIDTRANSCODE instance process function
IVIDTRANSCODE_Obj | This must be the first field of all IVIDTRANSCODE instance objects
IVIDTRANSCODE_OutArgs | Defines the run time output arguments for all IVIDTRANSCODE instance objects
IVIDTRANSCODE_Params | Defines the creation time parameters for all IVIDTRANSCODE instance objects
IVIDTRANSCODE_Status | Defines instance status parameters
LAD_DspStatus |
Memory_AllocParams | Parameters for Memory_alloc() & Memory_free()
Server_AlgInfo | Properties of a Server algorithm
Server_MemStat | Information for a memory heap of a remote DSP server
VISA_MsgHeader | VISA message header
XDM1_BufDesc | Buffer descriptor
XDM1_SingleBufDesc | Single buffer descriptor
XDM_AlgBufInfo | Buffer information descriptor for input and output buffers
XDM_BufDesc | Buffer descriptor for multiple buffers
XDM_Context | Context used by split codecs
XDM_ContextInfo | Buffer information descriptor for input and output buffers
XDM_Date | Date and time
XDM_Point | 2-dimensional point
XDM_Rect | Rectangle
XDM_SingleBufDesc | Single buffer descriptor


Codec Engine Application Programming Interface (API): Engine_AlgInfo Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

Engine_AlgInfo Struct Reference
[Codec Engine Runtime]

Properties of an Engine algorithm. More...

#include <Engine.h>

Data Fields

Int | algInfoSize
String | name
String * | typeTab
Bool | isLocal

Detailed Description

Properties of an Engine algorithm.

See also:
Engine_getAlgInfo()

Field Documentation

Int Engine_AlgInfo::algInfoSize

Size of this structure.

String Engine_AlgInfo::name

Name of algorithm.

String* Engine_AlgInfo::typeTab

Inheritance hierarchy.

Bool Engine_AlgInfo::isLocal

If TRUE, run locally.

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine Application Programming Interface (API): Engine_AlgInfo2 Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

Engine_AlgInfo2 Struct Reference
[Codec Engine Runtime]

Properties of an Engine algorithm. This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a singie string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE". More...

#include <Engine.h>

Data Fields

Int | algInfoSize
String | name
String | types
Bool | isLocal

Detailed Description

Properties of an Engine algorithm. This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a singie string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE".

See also:
Engine_getAlgInfo2()

Field Documentation

Int Engine_AlgInfo2::algInfoSize

Size of this structure.

String Engine_AlgInfo2::name

Name of algorithm.

String Engine_AlgInfo2::types

Inheritance hierarchy.

Bool Engine_AlgInfo2::isLocal

If TRUE, run locally.

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine Application Programming Interface (API): Engine_Attrs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

Engine_Attrs Struct Reference
[Codec Engine Runtime]

Attributes of an Engine. More...

#include <Engine.h>

Data Fields

String procId

Detailed Description

Attributes of an Engine.

See also:
Engine_open() and Engine_ATTRS.

Field Documentation

String Engine_Attrs::procId

id of the processor that runs the server; only needed in the case that there's more than one processor that can provide the same server.

The documentation for this struct was generated from the following file:
  • Engine.h


Codec Engine Application Programming Interface (API): IALG_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IALG_Fxns Struct Reference
[IALG - XDAIS Algorithm Interface]

Defines the fields and methods that must be supplied by all XDAIS algorithms. More...

#include <ialg.h>

Data Fields

Void * | implementationId
Unique pointer that identifies the module implementing this interface.
Void(* | algActivate )(IALG_Handle handle)
Notification to the algorithm that its memory is "active" and algorithm processing methods may be called.
Int(* | algAlloc )(const IALG_Params *params, struct IALG_Fxns **parentFxns, IALG_MemRec *memTab)
Apps call this to query the algorithm about its memory requirements. Must be non-NULL.
Int(* | algControl )(IALG_Handle handle, IALG_Cmd cmd, IALG_Status *status)
Algorithm specific control and status.
Void(* | algDeactivate )(IALG_Handle handle)
Save all persistent data to non-scratch memory.
Int(* | algFree )(IALG_Handle handle, IALG_MemRec *memTab)
Apps call this to allow the algorithm to initialize memory requested via algAlloc(). Must be non-NULL.
Int(* | algInit )(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)
Initialize an algorithm's instance object. Must be non-NULL.
Void(* | algMoved )(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)
Notify algorithm instance that instance memory has been relocated.
Int(* | algNumAlloc )(Void)
Number of memory allocation requests required.

Detailed Description

Defines the fields and methods that must be supplied by all XDAIS algorithms.

Field Documentation

Void* IALG_Fxns::implementationId

Unique pointer that identifies the module implementing this interface.

Void(* IALG_Fxns::algActivate)(IALG_Handle handle)

Notification to the algorithm that its memory is "active" and algorithm processing methods may be called.

Parameters:
[in] handle Handle to an algorithm instance.
Remarks:
algActivate() initializes any of the instance's scratch buffers using the persistent memory that is part of the algorithm's instance object.
The implementation of algActivate() (and algDeactivate()) is required if the algorithm requests memory of type IALG_SCRATCH.
The algActivate() method should only be implemented if a module wants to factor out initialization code that can be executed once prior to processing multiple consecutive frames of data.
If a module does not implement this method, the algActivate() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to the following implementation:
      Void algActivate(IALG_Handle handle)
      {
      }
Precondition:
algActivate() can only be called after a successful return from algInit().
handle must be a valid handle for the algorithm's instance object.
No other algorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
If the algorithm has implemented the IDMA2 interface, algActivate() can only be called after a successful return from dmaInit().
Postcondition:
All methods related to the algorithm may now be executed by client (subject to algorithm specific restrictions).
See also:
algDeactivate().
Int(* IALG_Fxns::algAlloc)(const IALG_Params *params, struct IALG_Fxns **parentFxns, IALG_MemRec *memTab)

Apps call this to query the algorithm about its memory requirements. Must be non-NULL.

Parameters:
[in] | params | Algorithm specific attributes.
[out] | parentFxns | Parent algorithm functions.
[out] | memTab | array of memory records.
Remarks:
algAlloc() returns a table of memory records that describe the size, alignment, type and memory space of all buffers required by an algorithm (including the algorithm's instance object itself). If successful, this function returns a positive non-zero value indicating the number of records initialized. This function can never initialize more memory records than the number returned by algNumAlloc().
If algNumAlloc() is not implemented, the maximum number of initialized memory records is IALG_DEFMEMRECS.
The first argument to algAlloc() is a pointer to the creation parameters for the instance of the algorithm object to be created. This pointer is algorithm-specific; i.e., it points to a structure that is defined by each particular algorithm. This pointer may be NULL; however, in this case, algAlloc() must assume default creation parameters and must not fail.
The second argument to algAlloc() is an optional parameter. algAlloc() may return a pointer to its parent's IALG functions. If this output value is assigned a non-NULL value, the client must create the parent instance object using the designated IALG functions pointer. The parent instance object must then be passed to algInit().
algAlloc() may be called at any time and it must be idempotent; i.e., it can be called repeatedly without any side effects, and always returns the same result.
Algorithms are encouraged to return (and document!) clear, algorithm-specific error codes from algAlloc(). Create-time failures are a common integration issue, and the clearer a return value, the sooner the algorithm integrator can identify and resolve the issue.
Precondition:
The number of memory records in the array memTab[] is no less than the number returned by algNumAlloc().
*parentFxns is a valid pointer to an IALG_Fxns pointer variable.
Postcondition:
If the algorithm needs a parent object to be created, the pointer *parentFxns is set to a non-NULL value that points to a valid IALG_Fxns structure, the parent's IALG implementation. Otherwise, this pointer is not set. algAlloc() may elect to ignore the parentFxns pointer altogether.
For each memory descriptor in memTab with an IALG_WRITEONCE attribute, the algorithm has either set the base field to a non-NULL value, which is the address of a statically allocated and initialized memory buffer of the indicated 'size', or has set the base field to NULL, thereby requiring the memory for the buffer to be provided by the client.
Exactly n elements of the memTab[] array are initialized, where n is the return value from this operation.
For each memory descriptor in memTab with an IALG_PERSIST or IALG_SCRATCH attribute, the algorithm does not set its base field.
memTab[0] defines the memory required for the instance's object and this object's first field is an IALG_Obj structure.
memTab[0] is requested as persistent memory.
See also:
algFree()
Int(* IALG_Fxns::algControl)(IALG_Handle handle, IALG_Cmd cmd, IALG_Status *status)

Algorithm specific control and status.

Parameters:
[in] | handle | Algorithm instance handle.
[in] | cmd | Algorithm specific command.
[out] | status | Algorithm specific status.
Remarks:
algControl() sends an algorithm specific command, cmd, and an input/output status buffer pointer to an algorithm's instance object.
In preemptive execution environments, algControl() may preempt a module's other metods (for example, its processing methods).
The implementation of algControl() is optional. If a module does not implement this method, the algControl() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to the following implementation:
      Void algControl(IALG_Handle handle, IALG_Cmd cmd, IALG_Status *status)
      {
          return (IALG_EFAIL);
      }
Precondition:
algControl() can only be called after a successful return from algInit().
handle must be a valid handle for the algorithm's instance object.
Algorithm specific cmd values are always less than IALG_SYSCMD.
Postcondition:
If the cmd value is not recognized by the algorithm, the return value is not equal to IALG_EOK.
See also:
algInit()
Void(* IALG_Fxns::algDeactivate)(IALG_Handle handle)

Save all persistent data to non-scratch memory.

Parameters:
[in] handle Algorithm instance handle.
Remarks:
algDeactivate() saves any persistent information to non-scratch buffers using the persistent memory that is part of the algorithm's instance object.
handle is used by the algorithm to identify the various buffers that must be saved prior to the next cycle of algActivate() and processing.
The implementation of algDeactivate() (and algActivate()) is required if the algorithm requests memory of type IALG_SCRATCH.
The algDeactivate() method is only implemented if a module wants to factor out initialization code that can be executed once prior to processing multiple consecutive frames of data.
If a module does not implement this method, the algDeactivate() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to the following implementation:
      Void algDeactivate(IALG_Handle handle)
      {
      }
Precondition:
algDeactivate() can only be called after a successful return from algInit().
The instance object is currently "active"; i.e., all instance memory is active and if an algActivate() method is defined, it has been called.
handle must be a valid handle for the algorithm's instance object.
No other algorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
Postcondition:
No methods related to the algorithm may now be executed by the client; only algActivate() or algFree() may be called.
All instance scratch memory may be safely overwritten.
See also:
algActivate()
Int(* IALG_Fxns::algFree)(IALG_Handle handle, IALG_MemRec *memTab)

Apps call this to allow the algorithm to initialize memory requested via algAlloc(). Must be non-NULL.

Parameters:
[in] | handle | Algorithm instance handle.
[out] | memTab | Output array of memory records.
Remarks:
algFree() returns a table of memory records that describe the base address, size, alignment, type and memory space of all buffers previously allocated for the algorithm's instance (including the algorithm's instance object itself) specified by handle. This function always returns a positive non-zero value indicating the number of records initialized. This function can never initialize more memory records than the value returned by algNumAlloc().
Precondition:
The memTab[] array contains at least algNumAlloc() records.
handle must be a valid handle for the algorithm's instance object.
If the prior call to algAlloc() returned a non-NULL parent functions pointer, then the parent instance must be an active instance object created via that function pointer.
No other agorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
Postcondition:
memTab[] contains pointers to all of the memory passed to the algorithm via algInit().
The size and alignment fields contain the same values passed to the client via algAlloc(); i.e., if the client makes changes to the values returned via algAlloc() and passes these new values to algInit(), the algorithm is not responsible for retaining any such changes.
See also:
algAlloc()
Int(* IALG_Fxns::algInit)(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)

Initialize an algorithm's instance object. Must be non-NULL.

Parameters:
[in] | handle | Algorithm instance handle. This is a pointer to an initialized IALG_Obj structure. Its value is identical to the memTab[0].base.
[in] | memTab | Array of allocated buffers.
[in] | parent | Handle of algorithm's parent instance.
[in] | params | Pointer to algorithm's instance parameters.
Remarks:
algInit() performs all initialization necessary to complete the run-time creation of an algorithm's instance object. After a successful return from algInit(), the algorithm's instance object is ready to be used to process data.
handle is a pointer to an initialized IALG_Obj structure. Its value is identical to the memTab[0].base.
memTab is a table of memory records that describe the base address, size, alignment, type, and memory space of all buffers allocated for an algorithm instance (including the algorithm's instance object itself). The number of initialized records is identical to the number returned by a prior call to algAlloc().
parent is a handle to another algorithm instance object. This parameter is often NULL; indicating that no parent object exists. This parameter allows clients to create a shared algorithm instance object and pass it to other algorithm instances. For example, a parent instance object might contain global read-only tables that are used by several instances of a vocoder.
params is a pointer to algorithm-specific parameters that are necessary for the creation and initialization of the instance object. This pointer points to the same parameters passed to the algAlloc() operation. However, this pointer may be NULL. In this case, algInit(), must assume default creation parameters.
Algorithms are encouraged to return (and document!) clear, algorithm-specific error codes from algInit(). Create-time failures are a common integration issue, and the clearer a return value, the sooner the algorithm integrator can identify and resolve the issue.
The algorithm must not access any scratch resources, memory or otherwise, until it has been activated (see algActivate()). A common error is to initialize scratch resources during algInit(). This is an error as another algorithm, or instance of the same algorithm, may be active when this instance's algInit() is called. This algorithm must not access scratch resources until it is active.
The client is not required to satisfy the IALG_MemSpace attribute of the requested memory. Note however that C6000 algorithms that use DMA may strictly require the client to satisfy its on-chip memory requirements and may not function correctly otherwise.
The client may allocate the requested IALG_WRITEONCE buffers once (or never, if the algorithm has assigned a base address in the prior call to algAlloc) and use the same buffers to initialize multiple instances of the same algorithm that are created with identical parameters.
Example:
      typedef struct EncoderObj {
          IALG_Obj ialgObj;
          int workBuf;
          Int workBufLen;
          ... ;
      } EncoderObj;

      Int algInit(IALG_Handle handle, IALG_MemRec memTab[],
              IALG_Handle parent, IALG_Params *params)
      {
          EncoderObj *inst = (EncoderObj *)handle;
          EncoderParams *encParams = (EncoderParams *)params;

          if (encParams == NULL) {
              encParams = MYDEFAULTPARAMS;
          }

          if (IALG_isOffChip(memTab[1].space)) {
              // unsupported off-chip memory, return documented error code
              return (MYMOD_MYVENDOR_EUNSUPPORTEDOFFCHIPWORKBUF);
          }

          inst->workBuf = memTab[1].base;
          inst->workBufLen = encParams->frameDuration * 8;
          ...

          return (IALG_EOK);
      }
Precondition:
memTab contains pointers to non-overlapping buffers with the size and alignment requested via a prior call to algAlloc(). In addition, the algorithm parameters, params, passed to algAlloc() are identical to those passed to this operation.
handle must be a valid handle for the algorithm's instance object; i.e., handle == memTab[0].base and handle->fxns is initialized to point to the appropriate IALG_Fxns structure.
The prior call to algAlloc() using same creation params must have returned value > 1. This pre-condition ensures that any create-time parameter validation can be done once (in algAlloc()), and is not required to be done in algInit(). Note that algInit() can, and should, validate any algorithm- specific requirements on resources received (e.g. internal memory, etc).
If the prior call to algAlloc() has not assigned a non-NULL base address to an IALG_WRITEONCE memTab entry, the client must provide the memory resource with the requested size and alignment.
If the prior call to algAlloc() returned a non-NULL parent functions pointer, then the parent handle, parent, must be a valid handle to an instance object created via that function pointer.
No other algorithm method is currently being run on this instance. This method never preempts any other method on the same instance.
If parent is non-NULL, no other method is currently being run on the parent instance; i.e., this method never preempts any other method on the parent instance.
If the prior call to algAlloc() assigned a non-NULL base address to an IALG_WRITEONCE memTab[] entry, the client may pass back the same address in the base field without allocating additional memory for that persistent write-once buffer. Alternatively, the client may treat IALG_WRITEONCE buffers in the same way as IALG_PERSIST buffers; by allocating new memory and granting it to the algorithm using the base field.
The buffer pointed to in memTab[0] is initialized with a pointer to the appropriate IALG_Fxns structure followed by all 0s.
Postcondition:
With the exception of any initialization performed by algActivate() and any optional auxilary interface initialization functions (such as IRES and IDMA3), all of the instance's persistent and write-once memory is initialized and the object is ready to be used.
All subsequent memory accesses to the IALG_WRITEONCE buffers by this algorithm instance will be read-only.
If the algorithm has implemented the IDMA2 interface, the dmaGetChannels() operation can be called.
Return values:
IALG_EOK | Successful return status code.
IALG_EFAIL | Unspecified error return status code.
Custom error | Algorithm-specific error - see algorithm's documentation.
See also:
algAlloc()
algMoved()
Void(* IALG_Fxns::algMoved)(IALG_Handle handle, const IALG_MemRec *memTab, IALG_Handle parent, const IALG_Params *params)

Notify algorithm instance that instance memory has been relocated.

Parameters:
[in] | handle | Algorithm instance handle.
[in] | memTab | Array of allocated buffers.
[in] | parent | Handle of algorithm's parent instance.
[in] | params | Pointer to algorithm's instance parameters.
Remarks:
algMoved() performs any reinitialization necessary to insure that, if an algorithm's instance object has been moved by the client, all internal data references are recomputed.
The implementation of algMoved() is optional. However, it is highly recommended that this method be implemented. If a module does not implement this method, the algMoved() field in the module's static function table (of type IALG_Fxns) must be set to NULL. This is equivalent to asserting that the algorithm's instance objects cannot be moved.
Int(* IALG_Fxns::algNumAlloc)(Void)

Number of memory allocation requests required.

Remarks:
algNumAlloc() returns the maximum number of memory allocation requests that the algAlloc() method requires. This operation allows clients to allocate sufficient space to call the algAlloc() method or fail because insufficient space exists to support the creation of the algorithm's instance object. algNumAlloc() may be called at any time, and it must be idempotent; i.e., it can be called repeatedly without any side effects, and always returns the same result.
algNumAlloc() is optional; if it is not implemented, the maximum number of memory records for algAlloc() is assumed to be IALG_DEFMEMRECS. This is equivalent to the following implementation:
      Void algNumAlloc(Void)
      {
          return (IALG_DEFNUMRECS);
      }
If a module does not implement this method, the algNumAlloc() field in the module's static function table (of type IALG_Fxns) must be set to NULL.
Postcondition:
The return value from algNumAlloc() is always greater than or equal to one and always equals or exceeds the value returned by algAlloc().
Example:
      #define NUMBUF 3
      extern IALG_Fxns *subAlg;

      Int algNumAlloc(Void)
      {
          return (NUMBUF + subAlg->algNumAlloc());
      }

      Int algAlloc(const IALG_Params *p, struct IALG_Fxns **pFxns,
              IALG_MemRec memTab)
      {
          Int n;

          ...

          n = subAlg->algAlloc(0, memTab);
          return (n + NUMBUF);
      }
See also:
algAlloc()
The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine Application Programming Interface (API): IALG_MemRec Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IALG_MemRec Struct Reference
[IALG - XDAIS Algorithm Interface]

Memory records. More...

#include <ialg.h>

Data Fields

Uns | size
Int | alignment
IALG_MemSpace space
IALG_MemAttrs attrs
Void * | base

Detailed Description

Memory records.

Field Documentation

Uns IALG_MemRec::size

Size in MAU of allocation

Int IALG_MemRec::alignment

Alignment requirement (MAU)

IALG_MemSpace IALG_MemRec::space

Allocation space

IALG_MemAttrs IALG_MemRec::attrs

Memory attributes

Void* IALG_MemRec::base

Base address of allocated buf

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine Application Programming Interface (API): IALG_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IALG_Obj Struct Reference
[IALG - XDAIS Algorithm Interface]

Algorithm instance object definition. More...

#include <ialg.h>

Collaboration diagram for IALG_Obj:
[legend]

Data Fields

struct IALG_Fxns * fxns

Detailed Description

Algorithm instance object definition.

Remarks:
All XDAIS algorithm instance objects must have this structure as their first element. However, they do not need to initialize it; initialization of this sub-structure is done by the "framework".

Field Documentation

struct IALG_Fxns* IALG_Obj::fxns [read]

Pointer to IALG function table.

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine Application Programming Interface (API): IALG_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IALG_Params Struct Reference
[IALG - XDAIS Algorithm Interface]

Algorithm instance creation parameters. More...

#include <ialg.h>

Data Fields

Int size

Detailed Description

Algorithm instance creation parameters.

Remarks:
All XDAS algorithm parameter structures must have a this as their first element.

Field Documentation

Int IALG_Params::size

Number of MAU in the structure

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine Application Programming Interface (API): IALG_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IALG_Status Struct Reference
[IALG - XDAIS Algorithm Interface]

Pointer to algorithm specific status structure. More...

#include <ialg.h>

Data Fields

Int size

Detailed Description

Pointer to algorithm specific status structure.

Remarks:
All XDAIS algorithm parameter structures must have this as their first element.

Field Documentation

Int IALG_Status::size

Number of MAU in the structure

The documentation for this struct was generated from the following file:
  • ialg.h


Codec Engine Application Programming Interface (API): IAUDDEC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_DynamicParams Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <iauddec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 downSampleSbrFlag

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::control()

Field Documentation

XDAS_Int32 IAUDDEC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC1_DynamicParams::downSampleSbrFlag

Flag to indicate downsampling for SBR.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_Fxns Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

Defines all of the operations on IAUDDEC1 objects. More...

#include <iauddec1.h>

Collaboration diagram for IAUDDEC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IAUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IAUDDEC1_InArgs *inArgs, IAUDDEC1_OutArgs *outArgs)
Basic audio decoding call.
XDAS_Int32(* | control )(IAUDDEC1_Handle handle, IAUDDEC1_Cmd id, IAUDDEC1_DynamicParams *params, IAUDDEC1_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IAUDDEC1 objects.

Field Documentation

IALG_Fxns IAUDDEC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IAUDDEC1_Fxns::process)(IAUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IAUDDEC1_InArgs *inArgs, IAUDDEC1_OutArgs *outArgs)

Basic audio decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IAUDDEC1_InArgs structure.
outArgs must not be NULL, and must point to a valid IAUDDEC1_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
outBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least outBufs->descs[0].bufSize bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.descs[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must appropriately set/clear the XDM1_BufDesc::descs[].accessMask field in both inBufs and outBufs. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IAUDDEC1_EOK | Success.
IAUDDEC1_EFAIL | General failure. See IAUDDEC1_Status::extendedError for more detailed further error conditions.
IAUDDEC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IAUDDEC1_Fxns::control)(IAUDDEC1_Handle handle, IAUDDEC1_Cmd id, IAUDDEC1_DynamicParams *params, IAUDDEC1_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IAUDDEC1_DynamicParams structure.
status must not be NULL, and must point to a valid IAUDDEC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IAUDDEC1_EOK | Success.
IAUDDEC1_EFAIL | General failure. See IAUDDEC1_Status::extendedError for more detailed further error conditions.
IAUDDEC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_InArgs Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

Defines the input arguments for all IAUDDEC1 instance process function. More...

#include <iauddec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes
XDAS_Int32 desiredChannelMode
XDAS_Int32 lfeFlag

Detailed Description

Defines the input arguments for all IAUDDEC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IAUDDEC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC1_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

XDAS_Int32 IAUDDEC1_InArgs::desiredChannelMode

Desired Channel Configuration.

See also:
IAUDIO_ChannelMode
XDAS_Int32 IAUDDEC1_InArgs::lfeFlag

Flag indicating whether LFE channel data is desired in the output.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_Obj Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

This must be the first field of all IAUDDEC1 instance objects. More...

#include <iauddec1.h>

Collaboration diagram for IAUDDEC1_Obj:
[legend]

Data Fields

struct IAUDDEC1_Fxns * fxns

Detailed Description

This must be the first field of all IAUDDEC1 instance objects.

Field Documentation

struct IAUDDEC1_Fxns* IAUDDEC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_OutArgs Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

Defines the run time output arguments for all IAUDDEC1 instance objects. More...

#include <iauddec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesConsumed
XDAS_Int32 numSamples
XDAS_Int32 channelMode
XDAS_Int32 lfeFlag
XDAS_Int32 dualMonoMode
XDAS_Int32 sampleRate

Detailed Description

Defines the run time output arguments for all IAUDDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IAUDDEC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IAUDDEC1_OutArgs::bytesConsumed

Number of bytes consumed during the process() call.

XDAS_Int32 IAUDDEC1_OutArgs::numSamples

Number of output samples per channel.

XDAS_Int32 IAUDDEC1_OutArgs::channelMode

Output Channel Configuration.

See also:
IAUDIO_ChannelMode
XDAS_Int32 IAUDDEC1_OutArgs::lfeFlag

Flag indicating the precense of LFE channel in the output. When the LFE channel is not in the output, this is set to XDAS_FALSE.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDDEC1_OutArgs::dualMonoMode

Mode to indicate type of Dual Mono. Only used in case of Dual Mono output.

See also:
IAUDIO_DualMonoMode
XDAS_Int32 IAUDDEC1_OutArgs::sampleRate

Sampling frequency, in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_Params Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

Defines the creation time parameters for all IAUDDEC1 instance objects. More...

#include <iauddec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 outputPCMWidth
XDAS_Int32 pcmFormat
XDAS_Int32 dataEndianness

Detailed Description

Defines the creation time parameters for all IAUDDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IAUDDEC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC1_Params::outputPCMWidth

Number of bits per output PCM Sample.

XDAS_Int32 IAUDDEC1_Params::pcmFormat

Output PCM Format Block/Interleaved.

See also:
IAUDIO_PcmFormat
XDAS_Int32 IAUDDEC1_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC1_Status Struct Reference
[XDM IAUDDEC1 Audio Decoder Interface]

Defines instance status parameters (read-only). More...

#include <iauddec1.h>

Collaboration diagram for IAUDDEC1_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int32 validFlag
XDAS_Int32 lfeFlag
XDAS_Int32 bitRate
XDAS_Int32 sampleRate
XDAS_Int32 channelMode
XDAS_Int32 pcmFormat
XDAS_Int32 numSamples
XDAS_Int32 outputBitsPerSample
XDM_AlgBufInfo bufInfo
XDAS_Int32 dualMonoMode

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC1_Fxns::control()

Field Documentation

XDAS_Int32 IAUDDEC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IAUDDEC1_Status::data

Buffer descriptor for data passing.

Remarks:
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int32 IAUDDEC1_Status::validFlag

Reflects the validity of this status structure.

Remarks:
In some cases (e.g. erroneous data streams), just after an error has been detected, the complete status provided by the algorithm may be incorrect (e.g. because of header corruption, etc). This field can "warn" the calling application that the contents of this structure are not valid. (Ideally, the algorithm makes a best attempt to always provide valid data, and this field is always set to XDAS_TRUE.)
Valid values for this field are XDAS_TRUE and XDAS_FALSE.
XDAS_Int32 IAUDDEC1_Status::lfeFlag

Flag indicating the presence of LFE channel in the output. When the LFE channel is not in the output, this is set to XDAS_FALSE.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDDEC1_Status::bitRate

Average bit rate, in bits per second.

XDAS_Int32 IAUDDEC1_Status::sampleRate

Sampling frequency, in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

XDAS_Int32 IAUDDEC1_Status::channelMode

Output Channel Configuration.

See also:
IAUDIO_ChannelMode
XDAS_Int32 IAUDDEC1_Status::pcmFormat

Output PCM Format Block/Interleaved.

See also:
IAUDIO_PcmFormat
XDAS_Int32 IAUDDEC1_Status::numSamples

Number of samples in the output.

XDAS_Int32 IAUDDEC1_Status::outputBitsPerSample

Number of bits per output sample. For example, if the value of the field is 16, there are 16 output bits per PCM sample.

XDM_AlgBufInfo IAUDDEC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
XDAS_Int32 IAUDDEC1_Status::dualMonoMode

Mode to indicate type of Dual Mono. Only used in case of Dual Mono Output.

See also:
IAUDIO_DualMonoMode
The documentation for this struct was generated from the following file:
  • iauddec1.h


Codec Engine Application Programming Interface (API): IAUDDEC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_DynamicParams Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <iauddec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 outputFormat

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::control()

Field Documentation

XDAS_Int32 IAUDDEC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC_DynamicParams::outputFormat

Output PCM format. See IAUDIO_PcmFormat.

The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDDEC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_Fxns Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

Defines all of the operations on IAUDDEC objects. More...

#include <iauddec.h>

Collaboration diagram for IAUDDEC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IAUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDDEC_InArgs *inArgs, IAUDDEC_OutArgs *outArgs)
Basic audio decoding call.
XDAS_Int32(* | control )(IAUDDEC_Handle handle, IAUDDEC_Cmd id, IAUDDEC_DynamicParams *params, IAUDDEC_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IAUDDEC objects.

Field Documentation

IALG_Fxns IAUDDEC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IAUDDEC_Fxns::process)(IAUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDDEC_InArgs *inArgs, IAUDDEC_OutArgs *outArgs)

Basic audio decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IAUDDEC_InArgs structure.
outArgs must not be NULL, and must point to a valid IAUDDEC_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IAUDDEC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* IAUDDEC_Fxns::control)(IAUDDEC_Handle handle, IAUDDEC_Cmd id, IAUDDEC_DynamicParams *params, IAUDDEC_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IAUDDEC_DynamicParams structure.
status must not be NULL, and must point to a valid IAUDDEC_Status structure.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IAUDDEC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDDEC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_InArgs Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

Defines the input arguments for all IAUDDEC instance process function. More...

#include <iauddec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes

Detailed Description

Defines the input arguments for all IAUDDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::process()

Field Documentation

XDAS_Int32 IAUDDEC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC_InArgs::numBytes

Size of valid input data (in bytes) to be processed.

The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDDEC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_Obj Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

This must be the first field of all IAUDDEC instance objects. More...

#include <iauddec.h>

Collaboration diagram for IAUDDEC_Obj:
[legend]

Data Fields

struct IAUDDEC_Fxns * fxns

Detailed Description

This must be the first field of all IAUDDEC instance objects.

Field Documentation

struct IAUDDEC_Fxns* IAUDDEC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDDEC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_OutArgs Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

Defines the run time output arguments for all IAUDDEC instance objects. More...

#include <iauddec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesConsumed

Detailed Description

Defines the run time output arguments for all IAUDDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::process()

Field Documentation

XDAS_Int32 IAUDDEC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IAUDDEC_OutArgs::bytesConsumed

Number of bytes consumed during the process() call.

The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDDEC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_Params Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

Defines the creation time parameters for all IAUDDEC instance objects. More...

#include <iauddec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxSampleRate
XDAS_Int32 maxBitrate
XDAS_Int32 maxNoOfCh
XDAS_Int32 dataEndianness

Detailed Description

Defines the creation time parameters for all IAUDDEC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IAUDDEC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC_Params::maxSampleRate

Maximum sampling frequency in Hz. For example, if the maximum sampling frequency is 44.1 kHz, this field should be 44100.

XDAS_Int32 IAUDDEC_Params::maxBitrate

Maximum bit rate in bits per second. For example, if the maximum bit rate is 128 kbps, set this field to 128000.

XDAS_Int32 IAUDDEC_Params::maxNoOfCh

Maximum Channels. See IAUDIO_ChannelId.

XDAS_Int32 IAUDDEC_Params::dataEndianness

Endianness of input data.

See also:
XDM_DataFormat
The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDDEC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDDEC_Status Struct Reference
[XDM IAUDDEC Audio Decoder Interface]

Defines instance status parameters (read-only). More...

#include <iauddec.h>

Collaboration diagram for IAUDDEC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bitRate
XDAS_Int32 sampleRate
XDAS_Int32 numChannels
XDAS_Int32 numLFEChannels
XDAS_Int32 outputFormat
XDAS_Int32 autoPosition
XDAS_Int32 fastFwdLen
XDAS_Int32 frameLen
XDAS_Int32 outputBitsPerSample
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDDEC_Fxns::control()

Field Documentation

XDAS_Int32 IAUDDEC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDDEC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IAUDDEC_Status::bitRate

Average bit rate, in bits per second.

XDAS_Int32 IAUDDEC_Status::sampleRate

Sampling frequency, in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

XDAS_Int32 IAUDDEC_Status::numChannels

Number of Channels. See IAUDIO_ChannelId.

XDAS_Int32 IAUDDEC_Status::numLFEChannels

Number of LFE (Low Frequency Effects) channels in the stream.

XDAS_Int32 IAUDDEC_Status::outputFormat

The output PCM format. See IAUDIO_PcmFormat.

XDAS_Int32 IAUDDEC_Status::autoPosition

Flag to indicate support for random position decoding, which means that a stream can be decoded from any point. 0 indicates this feature is not supported, 1 indicates this feature is supported.

XDAS_Int32 IAUDDEC_Status::fastFwdLen

Recommended fast forward length in bytes in case of random position decoding.

XDAS_Int32 IAUDDEC_Status::frameLen

Number of samples decoded per process() call.

XDAS_Int32 IAUDDEC_Status::outputBitsPerSample

Number of bits per output sample. For example, if the value of the field is 16, there are 16 output bits per PCM sample.

XDM_AlgBufInfo IAUDDEC_Status::bufInfo

Input and output buffer information. See XDM_AlgBufInfo.

The documentation for this struct was generated from the following file:
  • iauddec.h


Codec Engine Application Programming Interface (API): IAUDENC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_DynamicParams Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

This structure defines the algorithm parameters that can be modified after creation via control() calls. More...

#include <iaudenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 bitRate
XDAS_Int32 sampleRate
XDAS_Int32 channelMode
XDAS_Int32 lfeFlag
XDAS_Int32 dualMonoMode
XDAS_Int32 inputBitsPerSample

Detailed Description

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::control()

Field Documentation

XDAS_Int32 IAUDENC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC1_DynamicParams::bitRate

Average bit rate, in bits per second.

See also:
IAUDENC1_Params.bitRate
IAUDENC1_Status.bitRate
XDAS_Int32 IAUDENC1_DynamicParams::sampleRate

Sampling frequency in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

See also:
IAUDENC1_Params.sampleRate
IAUDENC1_Status.sampleRate
XDAS_Int32 IAUDENC1_DynamicParams::channelMode

Input Channel Mode.

See also:
IAUDIO_ChannelMode
IAUDENC1_Params.channelMode
XDAS_Int32 IAUDENC1_DynamicParams::lfeFlag

Flag indicating whether LFE channel data is present or not in the input.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDENC1_DynamicParams::dualMonoMode

Mode to indicate type of Dual Mono. Applicable only if channelMode is dualMono

See also:
IAUDIO_DualMonoMode
IAUDENC1_Params.dualMonoMode
XDAS_Int32 IAUDENC1_DynamicParams::inputBitsPerSample

Number of input bits per output sample. For example, if there are 16 bits per PCM input sample, this should be set to 16.

See also:
IAUDENC1_Params.inputBitsPerSample
The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_Fxns Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

Defines all of the operations on IAUDENC1 objects. More...

#include <iaudenc1.h>

Collaboration diagram for IAUDENC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IAUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IAUDENC1_InArgs *inArgs, IAUDENC1_OutArgs *outArgs)
Basic audio encoding call.
XDAS_Int32(* | control )(IAUDENC1_Handle handle, IAUDENC1_Cmd id, IAUDENC1_DynamicParams *params, IAUDENC1_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IAUDENC1 objects.

Field Documentation

IALG_Fxns IAUDENC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IAUDENC1_Fxns::process)(IAUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IAUDENC1_InArgs *inArgs, IAUDENC1_OutArgs *outArgs)

Basic audio encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IAUDENC1_InArgs structure.
outArgs must not be NULL, and must point to a valid IAUDENC1_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
outBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least outBufs->descs[0].bufSize bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.descs[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must appropriately set/clear the XDM1_BufDesc::descs[].accessMask field in both inBufs and outBufs. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IAUDENC1_EOK | Success.
IAUDENC1_EFAIL | General failure. See IAUDENC1_Status::extendedError for more detailed further error conditions.
IAUDENC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IAUDENC1_Fxns::control)(IAUDENC1_Handle handle, IAUDENC1_Cmd id, IAUDENC1_DynamicParams *params, IAUDENC1_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IAUDENC1_DynamicParams structure.
status must not be NULL, and must point to a valid IAUDENC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IAUDDEC1_EOK | Success.
IAUDDEC1_EFAIL | General failure. See IAUDDEC1_Status::extendedError for more detailed further error conditions.
IAUDENC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_InArgs Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

Defines the input arguments for all IAUDENC1 instance process function. More...

#include <iaudenc1.h>

Collaboration diagram for IAUDENC1_InArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 numInSamples
XDM1_SingleBufDesc ancData

Detailed Description

Defines the input arguments for all IAUDENC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::process()

Field Documentation

XDAS_Int32 IAUDENC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC1_InArgs::numInSamples

Number of Input Samples per Channel.

See also:
IAUDENC_Params.inputBitsPerSample
XDM1_SingleBufDesc IAUDENC1_InArgs::ancData

Ancillary Data.

Remarks:
Ancillary data contains any extra information to be encoded along with the PCM samples.
The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_Obj Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

This must be the first field of all IAUDENC1 instance objects. More...

#include <iaudenc1.h>

Collaboration diagram for IAUDENC1_Obj:
[legend]

Data Fields

struct IAUDENC1_Fxns * fxns

Detailed Description

This must be the first field of all IAUDENC1 instance objects.

Field Documentation

struct IAUDENC1_Fxns* IAUDENC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_OutArgs Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

Defines the run time output arguments for all IAUDENC1 instance objects. More...

#include <iaudenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesGenerated
XDAS_Int32 numZeroesPadded
XDAS_Int32 numInSamples

Detailed Description

Defines the run time output arguments for all IAUDENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::process()

Field Documentation

XDAS_Int32 IAUDENC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IAUDENC1_OutArgs::bytesGenerated

Number of bytes generated during the process() call.

XDAS_Int32 IAUDENC1_OutArgs::numZeroesPadded

Number of zeroes padded to input.

Remarks:
Some of the encoders pad zeroes at the end of the stream to complete the last frame.
XDAS_Int32 IAUDENC1_OutArgs::numInSamples

Number of input samples per channel consumed by the encoder.

The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_Params Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

Defines the creation time parameters for all IAUDENC1 instance objects. More...

#include <iaudenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 sampleRate
XDAS_Int32 bitRate
XDAS_Int32 channelMode
XDAS_Int32 dataEndianness
XDAS_Int32 encMode
XDAS_Int32 inputFormat
XDAS_Int32 inputBitsPerSample
XDAS_Int32 maxBitRate
XDAS_Int32 dualMonoMode
XDAS_Int32 crcFlag
XDAS_Int32 ancFlag
XDAS_Int32 lfeFlag

Detailed Description

Defines the creation time parameters for all IAUDENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IAUDENC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC1_Params::sampleRate

Sampling Frequency in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

See also:
IAUDENC1_DynamicParams.sampleRate
IAUDENC1_Status.sampleRate
XDAS_Int32 IAUDENC1_Params::bitRate

Average bit rate, in bits per second.

See also:
IAUDENC1_DynamicParams.bitRate
IAUDENC1_Status.bitRate
XDAS_Int32 IAUDENC1_Params::channelMode

Input Channel Mode.

See also:
IAUDIO_ChannelMode
IAUDENC1_DynamicParams.channelMode
XDAS_Int32 IAUDENC1_Params::dataEndianness

Endianness of input data.

See also:
XDM_DataFormat
XDAS_Int32 IAUDENC1_Params::encMode

Encoding mode.

See also:
IAUDIO_EncMode
IAUDENC1_Status.encMode
XDAS_Int32 IAUDENC1_Params::inputFormat

Input format block/interleaved.

See also:
IAUDIO_PcmFormat
XDAS_Int32 IAUDENC1_Params::inputBitsPerSample

Number of input bits per output sample. For example, if there are 16 bits per PCM input sample, this should be set to 16.

See also:
IAUDENC1_DynamicParams.inputBitsPerSample
XDAS_Int32 IAUDENC1_Params::maxBitRate

Maximum bit rate in case of VBR. Some of the encoders allow you to specify max bit rate in case of VBR mode

XDAS_Int32 IAUDENC1_Params::dualMonoMode

Mode to indicate type of Dual Mono. Applicable only if channelMode is dualMono

See also:
IAUDIO_DualMonoMode
IAUDENC1_DynamicParams.dualMonoMode
XDAS_Int32 IAUDENC1_Params::crcFlag

Flag indicating whether the encoder should insert CRC bits into the bitstream or not.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDENC1_Params::ancFlag

Ancillary Data Flag.

Remarks:
This flag indicates to the encoder that Ancillary data needs to be encoded along with the normal audio data. The ancillary data can be provided for each input frame.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDENC1_Params::lfeFlag

Flag indicating whether LFE channel data is present or not in the input.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC1_Status Struct Reference
[XDM IAUDENC1 Audio Encoder Interface]

Defines instance status parameters (read-only). More...

#include <iaudenc1.h>

Collaboration diagram for IAUDENC1_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDM_AlgBufInfo bufInfo
XDAS_Int32 validFlag
XDAS_Int32 lfeFlag
XDAS_Int32 bitRate
XDAS_Int32 sampleRate
XDAS_Int32 channelMode
XDAS_Int32 encMode

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC1_Fxns::control()

Field Documentation

XDAS_Int32 IAUDENC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IAUDENC1_Status::data

Buffer descriptor for data passing.

Remarks:
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDM_AlgBufInfo IAUDENC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
XDAS_Int32 IAUDENC1_Status::validFlag

Flag indicating the validity of the status struct.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDENC1_Status::lfeFlag

Flag indicating whether LFE channel data is present or not in the input.

Valid values for this field are XDAS_TRUE and XDAS_FALSE.

XDAS_Int32 IAUDENC1_Status::bitRate

Average bit rate, in bits per second.

See also:
IAUDENC1_Params.bitRate
IAUDENC1_DynamicParams.bitRate
XDAS_Int32 IAUDENC1_Status::sampleRate

Sampling frequency in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

See also:
IAUDENC1_Params.sampleRate
IAUDENC1_DynamicParams.sampleRate
XDAS_Int32 IAUDENC1_Status::channelMode

Input Channel Mode.

See also:
IAUDIO_ChannelMode for valid values.
IAUDENC1_Params.channelMode
IAUDENC1_DynamicParams.channelMode
XDAS_Int32 IAUDENC1_Status::encMode

Encoding mode.

See also:
IAUDIO_EncMode
IAUDENC1_Params.encMode
The documentation for this struct was generated from the following file:
  • iaudenc1.h


Codec Engine Application Programming Interface (API): IAUDENC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_DynamicParams Struct Reference
[XDM IAUDENC Audio Encoder Interface]

This structure defines the algorithm parameters that can be modified after creation via control() calls. More...

#include <iaudenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 inputFormat
XDAS_Int32 bitRate
XDAS_Int32 sampleRate
XDAS_Int32 numChannels
XDAS_Int32 numLFEChannels
XDAS_Int32 inputBitsPerSample

Detailed Description

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::control()

Field Documentation

XDAS_Int32 IAUDENC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC_DynamicParams::inputFormat

The input PCM format. See IAUDIO_PcmFormat.

XDAS_Int32 IAUDENC_DynamicParams::bitRate

Average bit rate, in bits per second.

XDAS_Int32 IAUDENC_DynamicParams::sampleRate

Sampling frequency in Hz. For example, if the sampling frequency is 44.1 kHz, this field will be 44100.

XDAS_Int32 IAUDENC_DynamicParams::numChannels

Number of Channels. See IAUDIO_ChannelId.

XDAS_Int32 IAUDENC_DynamicParams::numLFEChannels

Number of LFE (Low Frequency Effects) channels in the stream.

XDAS_Int32 IAUDENC_DynamicParams::inputBitsPerSample

Number of input bits per output sample. For example, if there are 16 bits per PCM input sample, this should be set to 16.

The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IAUDENC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_Fxns Struct Reference
[XDM IAUDENC Audio Encoder Interface]

Defines all of the operations on IAUDENC objects. More...

#include <iaudenc.h>

Collaboration diagram for IAUDENC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IAUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs)
Basic audio encoding call.
XDAS_Int32(* | control )(IAUDENC_Handle handle, IAUDENC_Cmd id, IAUDENC_DynamicParams *params, IAUDENC_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IAUDENC objects.

Field Documentation

IALG_Fxns IAUDENC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IAUDENC_Fxns::process)(IAUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs)

Basic audio encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IAUDENC_InArgs structure.
outArgs must not be NULL, and must point to a valid IAUDENC_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IAUDENC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* IAUDENC_Fxns::control)(IAUDENC_Handle handle, IAUDENC_Cmd id, IAUDENC_DynamicParams *params, IAUDENC_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IAUDENC_DynamicParams structure.
status must not be NULL, and must point to a valid IAUDENC_Status structure.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IAUDENC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IAUDENC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_InArgs Struct Reference
[XDM IAUDENC Audio Encoder Interface]

Defines the input arguments for all IAUDENC instance process function. More...

#include <iaudenc.h>

Data Fields

XDAS_Int32 size

Detailed Description

Defines the input arguments for all IAUDENC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::process()

Field Documentation

XDAS_Int32 IAUDENC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IAUDENC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_Obj Struct Reference
[XDM IAUDENC Audio Encoder Interface]

This must be the first field of all IAUDENC instance objects. More...

#include <iaudenc.h>

Collaboration diagram for IAUDENC_Obj:
[legend]

Data Fields

struct IAUDENC_Fxns * fxns

Detailed Description

This must be the first field of all IAUDENC instance objects.

Field Documentation

struct IAUDENC_Fxns* IAUDENC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IAUDENC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_OutArgs Struct Reference
[XDM IAUDENC Audio Encoder Interface]

Defines the run time output arguments for all IAUDENC instance objects. More...

#include <iaudenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesGenerated

Detailed Description

Defines the run time output arguments for all IAUDENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::process()

Field Documentation

XDAS_Int32 IAUDENC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IAUDENC_OutArgs::bytesGenerated

Number of bytes generated during the process() call.

The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IAUDENC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_Params Struct Reference
[XDM IAUDENC Audio Encoder Interface]

Defines the creation time parameters for all IAUDENC instance objects. More...

#include <iaudenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 encodingPreset
XDAS_Int32 maxSampleRate
XDAS_Int32 maxBitrate
XDAS_Int32 maxNoOfCh
XDAS_Int32 dataEndianness

Detailed Description

Defines the creation time parameters for all IAUDENC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IAUDENC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC_Params::encodingPreset

Encoding Preset. See XDM_EncodingPreset.

XDAS_Int32 IAUDENC_Params::maxSampleRate

Maximum sampling frequency in Hz. For example, if the maximum sampling frequency is 44.1 kHz, this field should be 44100.

XDAS_Int32 IAUDENC_Params::maxBitrate

Maximum bit rate in bits per second. For example, if the maximum bit rate is 128 kbps, set this field to 128000.

XDAS_Int32 IAUDENC_Params::maxNoOfCh

Maximum Channels. See IAUDIO_ChannelId.

XDAS_Int32 IAUDENC_Params::dataEndianness

Endianness of output data. See XDM_DataFormat.

The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IAUDENC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IAUDENC_Status Struct Reference
[XDM IAUDENC Audio Encoder Interface]

Defines instance status parameters (read-only). More...

#include <iaudenc.h>

Collaboration diagram for IAUDENC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 frameLen
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IAUDENC_Fxns::control()

Field Documentation

XDAS_Int32 IAUDENC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IAUDENC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IAUDENC_Status::frameLen

Number of samples encoded per process() call.

XDM_AlgBufInfo IAUDENC_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • iaudenc.h


Codec Engine Application Programming Interface (API): IIMGDEC1_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_CodecClassConfig Struct Reference
[Image decoder codec interface]

Definition of IIMGDEC1 codec class configurable parameters. More...

#include <imgdec1.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]

Detailed Description

Definition of IIMGDEC1 codec class configurable parameters.

Field Documentation

Bool IIMGDEC1_CodecClassConfig::manageInBufsCache[16]
Bool IIMGDEC1_CodecClassConfig::manageOutBufsCache[16]
The documentation for this struct was generated from the following file:
  • imgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_DynamicParams Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <iimgdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numAU
XDAS_Int32 decodeHeader
XDAS_Int32 displayWidth

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::control()

Field Documentation

XDAS_Int32 IIMGDEC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC1_DynamicParams::numAU

Number of Access unit to decode. Set to XDM_DEFAULT to decode the entire frame.

XDAS_Int32 IIMGDEC1_DynamicParams::decodeHeader

Decode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_DecMode
XDAS_Int32 IIMGDEC1_DynamicParams::displayWidth

Pitch. If set to zero, imageWidth is used; else, this field (assuming it's larger than imageWidth) is used.

The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_Fxns Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

Defines all of the operations on IIMGDEC1 objects. More...

#include <iimgdec1.h>

Collaboration diagram for IIMGDEC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IIMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGDEC1_InArgs *inArgs, IIMGDEC1_OutArgs *outArgs)
Basic image decoding call.
XDAS_Int32(* | control )(IIMGDEC1_Handle handle, IIMGDEC1_Cmd id, IIMGDEC1_DynamicParams *params, IIMGDEC1_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IIMGDEC1 objects.

Field Documentation

IALG_Fxns IIMGDEC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IIMGDEC1_Fxns::process)(IIMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGDEC1_InArgs *inArgs, IIMGDEC1_OutArgs *outArgs)

Basic image decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IIMGDEC1_InArgs structure.
outArgs must not be NULL, and must point to a valid IIMGDEC1_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
outBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least outBufs->descs[0].bufSize bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.descs[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must appropriately set/clear the XDM1_BufDesc::descs[].accessMask field in both inBufs and outBufs. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IIMGDEC1_EOK | Success.
IIMGDEC1_EFAIL | General failure. See IIMGDEC1_Status::extendedError for more detailed further error conditions.
IIMGDEC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IIMGDEC1_Fxns::control)(IIMGDEC1_Handle handle, IIMGDEC1_Cmd id, IIMGDEC1_DynamicParams *params, IIMGDEC1_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IIMGDEC1_DynamicParams structure.
status must not be NULL, and must point to a valid IIMGDEC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IIMGDEC1_EOK | Success.
IIMGDEC1_EFAIL | General failure. See IIMGDEC1_Status::extendedError for more detailed further error conditions.
IIMGDEC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_InArgs Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

Defines the input arguments for all IIMGDEC1 instance process() function. More...

#include <iimgdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes

Detailed Description

Defines the input arguments for all IIMGDEC1 instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IIMGDEC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC1_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_Obj Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

This must be the first field of all IIMGDEC1 instance objects. More...

#include <iimgdec1.h>

Collaboration diagram for IIMGDEC1_Obj:
[legend]

Data Fields

struct IIMGDEC1_Fxns * fxns

Detailed Description

This must be the first field of all IIMGDEC1 instance objects.

Field Documentation

struct IIMGDEC1_Fxns* IIMGDEC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_OutArgs Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

Defines the run time output arguments for all IIMGDEC1 instance objects. More...

#include <iimgdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesConsumed
XDAS_Int32 currentAU
XDAS_Int32 currentScan

Detailed Description

Defines the run time output arguments for all IIMGDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IIMGDEC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IIMGDEC1_OutArgs::bytesConsumed

Number of bytes consumed during the process() call.

XDAS_Int32 IIMGDEC1_OutArgs::currentAU

Current access unit number.

XDAS_Int32 IIMGDEC1_OutArgs::currentScan

Current scan number.

The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_Params Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

Defines the creation time parameters for all IIMGDEC1 instance objects. More...

#include <iimgdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxScans
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IIMGDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IIMGDEC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC1_Params::maxHeight

Maximum image height.

XDAS_Int32 IIMGDEC1_Params::maxWidth

Maximum image width.

XDAS_Int32 IIMGDEC1_Params::maxScans

Maximum number of scans.

XDAS_Int32 IIMGDEC1_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IIMGDEC1_Params::forceChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat.
The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC1_Status Struct Reference
[XDM IIMGDEC1 Image Decoder Interface]

Defines instance status parameters. More...

#include <iimgdec1.h>

Collaboration diagram for IIMGDEC1_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int32 outputHeight
XDAS_Int32 outputWidth
XDAS_Int32 imageWidth
XDAS_Int32 outputChromaFormat
XDAS_Int32 totalAU
XDAS_Int32 totalScan
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::control()

Field Documentation

XDAS_Int32 IIMGDEC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IIMGDEC1_Status::data

Buffer descriptor for data passing.

Remarks:
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int32 IIMGDEC1_Status::outputHeight

Output height.

XDAS_Int32 IIMGDEC1_Status::outputWidth

Output width. Padding should be taken care of by the decoder.

XDAS_Int32 IIMGDEC1_Status::imageWidth

Image width.

XDAS_Int32 IIMGDEC1_Status::outputChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat
XDAS_Int32 IIMGDEC1_Status::totalAU

Total number of Access Units.

XDAS_Int32 IIMGDEC1_Status::totalScan

Total number of scans.

XDM_AlgBufInfo IIMGDEC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • iimgdec1.h


Codec Engine Application Programming Interface (API): IIMGDEC_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_CodecClassConfig Struct Reference
[IMGDEC Image Decoder Interface]

Definition of IIMGDEC codec class configurable parameters. More...

#include <imgdec.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]

Detailed Description

Definition of IIMGDEC codec class configurable parameters.

See also:
VISA_getCodecClassConfig()

Field Documentation

Bool IIMGDEC_CodecClassConfig::manageInBufsCache[16]
Bool IIMGDEC_CodecClassConfig::manageOutBufsCache[16]
The documentation for this struct was generated from the following file:
  • imgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_DynamicParams Struct Reference
[XDM IIMGDEC Image Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <iimgdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numAU
XDAS_Int32 decodeHeader
XDAS_Int32 displayWidth

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC_Fxns::control()

Field Documentation

XDAS_Int32 IIMGDEC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC_DynamicParams::numAU

Number of Access unit to decode. Set to XDM_DEFAULT to decode the entire frame.

XDAS_Int32 IIMGDEC_DynamicParams::decodeHeader

Decode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_DecMode
XDAS_Int32 IIMGDEC_DynamicParams::displayWidth

Pitch. If set to zero, imageWidth is used; else, this field (assuming it's larger than imageWidth) is used.

The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_Fxns Struct Reference
[XDM IIMGDEC Image Decoder Interface]

Defines all of the operations on IIMGDEC objects. More...

#include <iimgdec.h>

Collaboration diagram for IIMGDEC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IIMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGDEC_InArgs *inArgs, IIMGDEC_OutArgs *outArgs)
Basic image decoding call.
XDAS_Int32(* | control )(IIMGDEC_Handle handle, IIMGDEC_Cmd id, IIMGDEC_DynamicParams *params, IIMGDEC_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IIMGDEC objects.

Field Documentation

IALG_Fxns IIMGDEC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IIMGDEC_Fxns::process)(IIMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGDEC_InArgs *inArgs, IIMGDEC_OutArgs *outArgs)

Basic image decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IIMGDEC_InArgs structure.
outArgs must not be NULL, and must point to a valid IIMGDEC_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IIMGDEC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* IIMGDEC_Fxns::control)(IIMGDEC_Handle handle, IIMGDEC_Cmd id, IIMGDEC_DynamicParams *params, IIMGDEC_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IIMGDEC_DynamicParams structure.
status must not be NULL, and must point to a valid IIMGDEC_Status structure.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IIMGDEC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_InArgs Struct Reference
[XDM IIMGDEC Image Decoder Interface]

Defines the input arguments for all IIMGDEC instance process() function. More...

#include <iimgdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes

Detailed Description

Defines the input arguments for all IIMGDEC instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC_Fxns::process()

Field Documentation

XDAS_Int32 IIMGDEC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_Obj Struct Reference
[XDM IIMGDEC Image Decoder Interface]

This must be the first field of all IIMGDEC instance objects. More...

#include <iimgdec.h>

Collaboration diagram for IIMGDEC_Obj:
[legend]

Data Fields

struct IIMGDEC_Fxns * fxns

Detailed Description

This must be the first field of all IIMGDEC instance objects.

Field Documentation

struct IIMGDEC_Fxns* IIMGDEC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_OutArgs Struct Reference
[XDM IIMGDEC Image Decoder Interface]

Defines the run time output arguments for all IIMGDEC instance objects. More...

#include <iimgdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesconsumed
XDAS_Int32 currentAU
XDAS_Int32 currentScan

Detailed Description

Defines the run time output arguments for all IIMGDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IIMGDEC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IIMGDEC_OutArgs::bytesconsumed

Number of bytes consumed during the process() call.

XDAS_Int32 IIMGDEC_OutArgs::currentAU

Current access unit number.

XDAS_Int32 IIMGDEC_OutArgs::currentScan

Current scan number.

The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_Params Struct Reference
[XDM IIMGDEC Image Decoder Interface]

Defines the creation time parameters for all IIMGDEC instance objects. More...

#include <iimgdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxScans
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IIMGDEC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IIMGDEC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC_Params::maxHeight

Maximum image height.

XDAS_Int32 IIMGDEC_Params::maxWidth

Maximum image width.

XDAS_Int32 IIMGDEC_Params::maxScans

Maximum number of scans.

XDAS_Int32 IIMGDEC_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IIMGDEC_Params::forceChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat.
The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGDEC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGDEC_Status Struct Reference
[XDM IIMGDEC Image Decoder Interface]

Defines instance status parameters (read-only). More...

#include <iimgdec.h>

Collaboration diagram for IIMGDEC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 outputHeight
XDAS_Int32 outputWidth
XDAS_Int32 imageWidth
XDAS_Int32 outChromaformat
XDAS_Int32 totalAU
XDAS_Int32 totalScan
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGDEC_Fxns::control()

Field Documentation

XDAS_Int32 IIMGDEC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGDEC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IIMGDEC_Status::outputHeight

Output height.

XDAS_Int32 IIMGDEC_Status::outputWidth

Output width. Padding should be taken care of by the decoder.

XDAS_Int32 IIMGDEC_Status::imageWidth

Image width.

XDAS_Int32 IIMGDEC_Status::outChromaformat

Output chroma format.

See also:
XDM_ChromaFormat
XDAS_Int32 IIMGDEC_Status::totalAU

Total number of Access Units.

XDAS_Int32 IIMGDEC_Status::totalScan

Total number of scans.

XDM_AlgBufInfo IIMGDEC_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • iimgdec.h


Codec Engine Application Programming Interface (API): IIMGENC1_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_CodecClassConfig Struct Reference
[Image encoder codec interface]

Definition of IIMGENC1 codec class configurable parameters. More...

#include <imgenc1.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]

Detailed Description

Definition of IIMGENC1 codec class configurable parameters.

Field Documentation

Bool IIMGENC1_CodecClassConfig::manageInBufsCache[16]
Bool IIMGENC1_CodecClassConfig::manageOutBufsCache[16]
The documentation for this struct was generated from the following file:
  • imgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_DynamicParams Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

This structure defines the algorithm parameters that can be modified after creation via control() calls. More...

#include <iimgenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numAU
XDAS_Int32 inputChromaFormat
XDAS_Int32 inputHeight
XDAS_Int32 inputWidth
XDAS_Int32 captureWidth
XDAS_Int32 generateHeader
XDAS_Int32 qValue

Detailed Description

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::control()

Field Documentation

XDAS_Int32 IIMGENC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC1_DynamicParams::numAU

Number of Access unit to encode. Set to XDM_DEFAULT to encode the entire frame.

XDAS_Int32 IIMGENC1_DynamicParams::inputChromaFormat

Input chroma format.

See also:
XDM_ChromaFormat
XDAS_Int32 IIMGENC1_DynamicParams::inputHeight

Input frame height.

XDAS_Int32 IIMGENC1_DynamicParams::inputWidth

Input frame width.

XDAS_Int32 IIMGENC1_DynamicParams::captureWidth

Pitch. If set to zero, imageWidth is used; else, this field (assuming it's larger than imageWidth) is used.

XDAS_Int32 IIMGENC1_DynamicParams::generateHeader

Header generation mode.

See also:
XDM_EncMode
XDAS_Int32 IIMGENC1_DynamicParams::qValue

Quality factor for encoder. Set to a value between 0 (lowest quality) and 100 (highest quality).

The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_Fxns Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

Defines all of the operations on IIMGENC1 objects. More...

#include <iimgenc1.h>

Collaboration diagram for IIMGENC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IIMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs)
Basic image encoding call.
XDAS_Int32(* | control )(IIMGENC1_Handle handle, IIMGENC1_Cmd id, IIMGENC1_DynamicParams *params, IIMGENC1_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IIMGENC1 objects.

Field Documentation

IALG_Fxns IIMGENC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IIMGENC1_Fxns::process)(IIMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs)

Basic image encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IIMGENC1_InArgs structure.
outArgs must not be NULL, and must point to a valid IIMGENC1_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
outBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least outBufs->descs[0].bufSize bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.descs[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must appropriately set/clear the XDM1_BufDesc::descs[].accessMask field in both inBufs and outBufs. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IIMGENC1_EOK | Success.
IIMGENC1_EFAIL | General failure. See IIMGENC1_Status::extendedError for more detailed further error conditions.
IIMGENC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IIMGENC1_Fxns::control)(IIMGENC1_Handle handle, IIMGENC1_Cmd id, IIMGENC1_DynamicParams *params, IIMGENC1_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IIMGENC1_DynamicParams structure.
status must not be NULL, and must point to a valid IIMGENC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IIMGENC1_EOK | Success.
IIMGENC1_EFAIL | General failure. See IIMGDEN1_Status::extendedError for more detailed further error conditions.
IIMGENC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_InArgs Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

Defines the input arguments for all IIMGENC1 instance process() function. More...

#include <iimgenc1.h>

Data Fields

XDAS_Int32 size

Detailed Description

Defines the input arguments for all IIMGENC1 instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::process()

Field Documentation

XDAS_Int32 IIMGENC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_Obj Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

This must be the first field of all IIMGENC1 instance objects. More...

#include <iimgenc1.h>

Collaboration diagram for IIMGENC1_Obj:
[legend]

Data Fields

struct IIMGENC1_Fxns * fxns

Detailed Description

This must be the first field of all IIMGENC1 instance objects.

Field Documentation

struct IIMGENC1_Fxns* IIMGENC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_OutArgs Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

Defines the run time output arguments for all IIMGENC1 instance objects. More...

#include <iimgenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesGenerated
XDAS_Int32 currentAU

Detailed Description

Defines the run time output arguments for all IIMGENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::process()

Field Documentation

XDAS_Int32 IIMGENC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IIMGENC1_OutArgs::bytesGenerated

Number of bytes generated during the process() call.

XDAS_Int32 IIMGENC1_OutArgs::currentAU

Current access unit number.

The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_Params Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

Defines the creation time parameters for all IIMGENC1 instance objects. More...

#include <iimgenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxScans
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IIMGENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IIMGENC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC1_Params::maxHeight

Maximum height.

XDAS_Int32 IIMGENC1_Params::maxWidth

Maximum width.

XDAS_Int32 IIMGENC1_Params::maxScans

Maximum number of scans.

XDAS_Int32 IIMGENC1_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IIMGENC1_Params::forceChromaFormat

Force encoding in given Chroma format.

See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC1_Status Struct Reference
[XDM IIMGENC1 Image Encoder Interface]

Defines instance status parameters. More...

#include <iimgenc1.h>

Collaboration diagram for IIMGENC1_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int32 totalAU
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC1_Fxns::control()

Field Documentation

XDAS_Int32 IIMGENC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IIMGENC1_Status::data

Buffer descriptor for data passing.

Remarks:
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int32 IIMGENC1_Status::totalAU

Total number of Access Units.

XDM_AlgBufInfo IIMGENC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • iimgenc1.h


Codec Engine Application Programming Interface (API): IIMGENC_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_CodecClassConfig Struct Reference
[IMGENC Image Encoder Interface]

Definition of IIMGENC codec class configurable parameters. More...

#include <imgenc.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]

Detailed Description

Definition of IIMGENC codec class configurable parameters.

See also:
VISA_getCodecClassConfig()

Field Documentation

Bool IIMGENC_CodecClassConfig::manageInBufsCache[16]
Bool IIMGENC_CodecClassConfig::manageOutBufsCache[16]
The documentation for this struct was generated from the following file:
  • imgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_DynamicParams Struct Reference
[XDM IIMGENC Image Encoder Interface]

This structure defines the algorithm parameters that can be modified after creation via control() calls. More...

#include <iimgenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numAU
XDAS_Int32 inputChromaFormat
XDAS_Int32 inputHeight
XDAS_Int32 inputWidth
XDAS_Int32 captureWidth
XDAS_Int32 generateHeader
XDAS_Int32 qValue

Detailed Description

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::control()

Field Documentation

XDAS_Int32 IIMGENC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC_DynamicParams::numAU

Number of Access unit to encode. Set to XDM_DEFAULT to encode the entire frame.

XDAS_Int32 IIMGENC_DynamicParams::inputChromaFormat

Input chroma format.

See also:
XDM_ChromaFormat
XDAS_Int32 IIMGENC_DynamicParams::inputHeight

Input frame height.

XDAS_Int32 IIMGENC_DynamicParams::inputWidth

Input frame width.

XDAS_Int32 IIMGENC_DynamicParams::captureWidth

Pitch. If set to zero, imageWidth is used; else, this field (assuming it's larger than imageWidth) is used.

XDAS_Int32 IIMGENC_DynamicParams::generateHeader

Header generation mode.

See also:
XDM_EncMode
XDAS_Int32 IIMGENC_DynamicParams::qValue

Quality factor for encoder. Set to a value between 0 (lowest quality) and 100 (highest quality).

The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_Fxns Struct Reference
[XDM IIMGENC Image Encoder Interface]

Defines all of the operations on IIMGENC objects. More...

#include <iimgenc.h>

Collaboration diagram for IIMGENC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IIMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs)
Basic image encoding call.
XDAS_Int32(* | control )(IIMGENC_Handle handle, IIMGENC_Cmd id, IIMGENC_DynamicParams *params, IIMGENC_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IIMGENC objects.

Field Documentation

IALG_Fxns IIMGENC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IIMGENC_Fxns::process)(IIMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs)

Basic image encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IIMGENC_InArgs structure.
outArgs must not be NULL, and must point to a valid IIMGENC_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IIMGENC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* IIMGENC_Fxns::control)(IIMGENC_Handle handle, IIMGENC_Cmd id, IIMGENC_DynamicParams *params, IIMGENC_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IIMGENC_DynamicParams structure.
status must not be NULL, and must point to a valid IIMGENC_Status structure.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IIMGENC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_InArgs Struct Reference
[XDM IIMGENC Image Encoder Interface]

Defines the input arguments for all IIMGENC instance process() function. More...

#include <iimgenc.h>

Data Fields

XDAS_Int32 size

Detailed Description

Defines the input arguments for all IIMGENC instance process() function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::process()

Field Documentation

XDAS_Int32 IIMGENC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_Obj Struct Reference
[XDM IIMGENC Image Encoder Interface]

This must be the first field of all IIMGENC instance objects. More...

#include <iimgenc.h>

Collaboration diagram for IIMGENC_Obj:
[legend]

Data Fields

struct IIMGENC_Fxns * fxns

Detailed Description

This must be the first field of all IIMGENC instance objects.

Field Documentation

struct IIMGENC_Fxns* IIMGENC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_OutArgs Struct Reference
[XDM IIMGENC Image Encoder Interface]

Defines the run time output arguments for all IIMGENC instance objects. More...

#include <iimgenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesGenerated
XDAS_Int32 currentAU

Detailed Description

Defines the run time output arguments for all IIMGENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::process()

Field Documentation

XDAS_Int32 IIMGENC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IIMGENC_OutArgs::bytesGenerated

Number of bytes generated during the process() call.

XDAS_Int32 IIMGENC_OutArgs::currentAU

Current access unit number.

The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_Params Struct Reference
[XDM IIMGENC Image Encoder Interface]

Defines the creation time parameters for all IIMGENC instance objects. More...

#include <iimgenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxScans
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IIMGENC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IIMGENC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC_Params::maxHeight

Maximum height.

XDAS_Int32 IIMGENC_Params::maxWidth

Maximum width.

XDAS_Int32 IIMGENC_Params::maxScans

Maximum number of scans.

XDAS_Int32 IIMGENC_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IIMGENC_Params::forceChromaFormat

Force encoding in given Chroma format.

See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): IIMGENC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IIMGENC_Status Struct Reference
[XDM IIMGENC Image Encoder Interface]

Defines instance status parameters (read-only). More...

#include <iimgenc.h>

Collaboration diagram for IIMGENC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 totalAU
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IIMGENC_Fxns::control()

Field Documentation

XDAS_Int32 IIMGENC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IIMGENC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IIMGENC_Status::totalAU

Total number of Access Units.

XDM_AlgBufInfo IIMGENC_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • iimgenc.h


Codec Engine Application Programming Interface (API): ISPHDEC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_DynamicParams Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

This structure defines the codec parameters that can be modified after creation via ISPHDEC1_Fxns.control(). More...

#include <isphdec1.h>

Data Fields

XDAS_Int16 size
XDAS_Int16 postFilter

Detailed Description

This structure defines the codec parameters that can be modified after creation via ISPHDEC1_Fxns.control().

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC1_Fxns::control()

Field Documentation

XDAS_Int16 ISPHDEC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHDEC1_DynamicParams::postFilter

Assign the postFilter setting.

See also:
ISPEECH1_PostFilter
ISPHDEC1_Status.postFilter
The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_Fxns Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

Defines all of the operations on ISPHDEC1 objects. More...

#include <isphdec1.h>

Collaboration diagram for ISPHDEC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(ISPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, ISPHDEC1_InArgs *inArgs, ISPHDEC1_OutArgs *outArgs)
Basic speech/voice decoding call.
XDAS_Int32(* | control )(ISPHDEC1_Handle handle, ISPHDEC1_Cmd id, ISPHDEC1_DynamicParams *params, ISPHDEC1_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on ISPHDEC1 objects.

Field Documentation

IALG_Fxns ISPHDEC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* ISPHDEC1_Fxns::process)(ISPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, ISPHDEC1_InArgs *inArgs, ISPHDEC1_OutArgs *outArgs)

Basic speech/voice decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBuf | Input buffer descriptor.
[in,out] | outBuf | Output buffer descriptor.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
If inArgs->data is not used in the process() call, the application must set it to NULL. The algorithm must therefore check this field for NULL before accessing it.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid ISPHDEC1_InArgs structure.
outArgs must not be NULL, and must point to a valid ISPHDEC1_OutArgs structure.
inBuf must not be NULL, and must point to a valid XDM1_SingleBufDesc structure.
inBuf->buf must not be NULL, and must point to a valid buffer of data that is at least inBuf->bufSize bytes in length.
outBuf must not be NULL, and must point to a valid XDM1_SingleBufDesc structure.
outBuf->buf must not be NULL, and must point to a valid buffer of data that is at least outBuf->bufSize bytes in length.
The buffers in inBuf and outBuf are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBuf, with the exception of inBuf->accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must set outBuf->bufSize to the size of valid data returned in outBuf->buf .
The algorithm must appropriately set/clear the XDM1_SingleBufDesc.accessMask field in both inBuf and outBuf. For example, if the algorithm only read from inBuf->buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBuf and outBuf are owned by the calling application.
Return values:
ISPHDEC1_EOK | Success.
ISPHDEC1_EFAIL | General failure. See ISPHDEC1_Status::extendedError for more detailed further error conditions.
ISPHDEC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* ISPHDEC1_Fxns::control)(ISPHDEC1_Handle handle, ISPHDEC1_Cmd id, ISPHDEC1_DynamicParams *params, ISPHDEC1_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid ISPHDEC1_DynamicParams structure.
status must not be NULL, and must point to a valid ISPHDEC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
ISPHDEC1_EOK | Success.
ISPHDEC1_EFAIL | General failure. See ISPHDEC1_Status::extendedError for more detailed further error conditions.
ISPHDEC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_InArgs Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

Defines the input arguments for all ISPHDEC1 instance process function. More...

#include <isphdec1.h>

Collaboration diagram for ISPHDEC1_InArgs:
[legend]

Data Fields

XDAS_Int16 size
XDAS_Int16 frameType
XDM1_SingleBufDesc data

Detailed Description

Defines the input arguments for all ISPHDEC1 instance process function.

Field Documentation

XDAS_Int16 ISPHDEC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHDEC1_InArgs::frameType

Frame type of this buffer.

See also:
ISPHDEC1_FrameType
XDM1_SingleBufDesc ISPHDEC1_InArgs::data

Raw data output for data transmission.

The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_Obj Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

This must be the first field of all ISPHDEC1 instance objects. More...

#include <isphdec1.h>

Collaboration diagram for ISPHDEC1_Obj:
[legend]

Data Fields

struct ISPHDEC1_Fxns * fxns

Detailed Description

This must be the first field of all ISPHDEC1 instance objects.

Field Documentation

struct ISPHDEC1_Fxns* ISPHDEC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_OutArgs Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

Defines the run time output arguments for all ISPHDEC1 instance objects. More...

#include <isphdec1.h>

Data Fields

XDAS_Int16 size
XDAS_Int16 dataSize
XDAS_Int32 extendedError

Detailed Description

Defines the run time output arguments for all ISPHDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC1_Fxns::process()

Field Documentation

XDAS_Int16 ISPHDEC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHDEC1_OutArgs::dataSize

Size of raw data output in bits.

XDAS_Int32 ISPHDEC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_Params Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

Defines the creation time parameters for all ISPHDEC1 instance objects. More...

#include <isphdec1.h>

Data Fields

XDAS_Int16 size
XDAS_Int16 compandingLaw
XDAS_Int16 packingType
XDAS_Int16 codecSelection
XDAS_Int16 bitRate
XDAS_Int16 reserved
XDAS_Int8 ** tablesPtr

Detailed Description

Defines the creation time parameters for all ISPHDEC1 instance objects.

Remarks:
Some of the fields in this structure are optional and depend on the class of speech decoder you're creating.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int16 ISPHDEC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHDEC1_Params::compandingLaw

Optional, codec-specific companding law. See your codec-specific interface documentation options.

See also:
ISPEECH1_PCM_CompandingLaw
ISPEECH1_G726_CompandingLaw
XDAS_Int16 ISPHDEC1_Params::packingType

Optional, codec-specific packing type. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_PackingType
ISPEECH1_G726_PackingType
ISPEECH1_WBAMR_PackingType
XDAS_Int16 ISPHDEC1_Params::codecSelection

Optional, codec-specific selection. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_CodecSelect
ISPHDEC1_Status.codecSelection
XDAS_Int16 ISPHDEC1_Params::bitRate

Optional, codec-specific bit rate. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_BitRate
ISPEECH1_G723_BitRate
ISPEECH1_G726_BitRate
ISPEECH1_WBAMR_BitRate
XDAS_Int16 ISPHDEC1_Params::reserved

Reserved - serves to pad this structure.

XDAS_Int8** ISPHDEC1_Params::tablesPtr

Optional pointer to the codec's initialization tables.

The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC1_Status Struct Reference
[XDM ISPHDEC1 Speech/Voice Decoder Interface]

Defines instance status parameters. More...

#include <isphdec1.h>

Collaboration diagram for ISPHDEC1_Status:
[legend]

Data Fields

XDAS_Int16 size
XDAS_Int16 postFilter
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int16 compandingLaw
XDAS_Int16 packingType
XDM_AlgBufInfo bufInfo
XDAS_Int16 codecSelection
XDAS_Int16 bitRate

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC1_Fxns::control()

Field Documentation

XDAS_Int16 ISPHDEC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHDEC1_Status::postFilter

Provides the current postFilter setting.

See also:
ISPEECH1_PostFilter
XDAS_Int32 ISPHDEC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc ISPHDEC1_Status::data

Buffer descriptor for data passing.

Remarks:
If this field is not used, the application must set data.buf to NULL.
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the ISPHDEC1_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int16 ISPHDEC1_Status::compandingLaw

Optional, codec-specific companding law. See your codec-specific interface documentation options.

See also:
ISPEECH1_PCM_CompandingLaw
ISPEECH1_G726_CompandingLaw
XDAS_Int16 ISPHDEC1_Status::packingType

Optional, codec-specific packing type. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_PackingType
ISPEECH1_G726_PackingType
ISPEECH1_WBAMR_PackingType
XDM_AlgBufInfo ISPHDEC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
XDAS_Int16 ISPHDEC1_Status::codecSelection

Optional, codec-specific codec selection. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_CodecSelect
ISPHDEC1_Params.codecSelection
XDAS_Int16 ISPHDEC1_Status::bitRate

Optional, codec-specific bit rate. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_BitRate
ISPEECH1_G723_BitRate
ISPEECH1_G726_BitRate
ISPEECH1_WBAMR_BitRate
The documentation for this struct was generated from the following file:
  • isphdec1.h


Codec Engine Application Programming Interface (API): ISPHDEC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_DynamicParams Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <isphdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 postFilter

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::control()

Field Documentation

XDAS_Int32 ISPHDEC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHDEC_DynamicParams::postFilter

Post filter enabled flag. Set to 1 to enable, 0 to disable.

The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHDEC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_Fxns Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

Defines all of the operations on ISPHDEC objects. More...

#include <isphdec.h>

Collaboration diagram for ISPHDEC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(ISPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHDEC_InArgs *inArgs, ISPHDEC_OutArgs *outArgs)
Basic speech/voice decoding call.
XDAS_Int32(* | control )(ISPHDEC_Handle handle, ISPHDEC_Cmd id, ISPHDEC_DynamicParams *params, ISPHDEC_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on ISPHDEC objects.

Field Documentation

IALG_Fxns ISPHDEC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* ISPHDEC_Fxns::process)(ISPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHDEC_InArgs *inArgs, ISPHDEC_OutArgs *outArgs)

Basic speech/voice decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid ISPHDEC_InArgs structure.
outArgs must not be NULL, and must point to a valid ISPHDEC_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
inBufs.buf[0] must not be NULL, and must point to a valid buffer of data that is at least inBufs.bufSizes[0] bytes in length.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs.buf[0] must not be NULL, and must point to a valid buffer of data that is at least outBufs.bufSizes[0] bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inBufs. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See ISPHDEC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* ISPHDEC_Fxns::control)(ISPHDEC_Handle handle, ISPHDEC_Cmd id, ISPHDEC_DynamicParams *params, ISPHDEC_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid ISPHDEC_DynamicParams structure.
status must not be NULL, and must point to a valid ISPHDEC_Status structure.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See ISPHDEC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHDEC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_InArgs Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

Defines the input arguments for all ISPHDEC instance process function. More...

#include <isphdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 frameType
XDAS_Int32 inBufferSize
XDAS_Int32 bfiFlag

Detailed Description

Defines the input arguments for all ISPHDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::process()

Field Documentation

XDAS_Int32 ISPHDEC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHDEC_InArgs::frameType

Input frame type.

XDAS_Int32 ISPHDEC_InArgs::inBufferSize

Size of valid input data in bytes to be processed.

XDAS_Int32 ISPHDEC_InArgs::bfiFlag

Bad frame indicator. BFI = 1 indicates bad frame.

The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHDEC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_Obj Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

This must be the first field of all ISPHDEC instance objects. More...

#include <isphdec.h>

Collaboration diagram for ISPHDEC_Obj:
[legend]

Data Fields

struct ISPHDEC_Fxns * fxns

Detailed Description

This must be the first field of all ISPHDEC instance objects.

Field Documentation

struct ISPHDEC_Fxns* ISPHDEC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHDEC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_OutArgs Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

Defines the run time output arguments for all ISPHDEC instance objects. More...

#include <isphdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 mode

Detailed Description

Defines the run time output arguments for all ISPHDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::process()

Field Documentation

XDAS_Int32 ISPHDEC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHDEC_OutArgs::mode

Speech voice mode. See ISPEECH_VoiceMode.

The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHDEC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_Params Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

Defines the creation time parameters for all ISPHDEC instance objects. More...

#include <isphdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 dataEnable
XDAS_Int32 compandingLaw
XDAS_Int32 packingType

Detailed Description

Defines the creation time parameters for all ISPHDEC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 ISPHDEC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHDEC_Params::dataEnable

TTY/DTMF enabled flag. Set to 1 to enable, 0 to disable.

XDAS_Int32 ISPHDEC_Params::compandingLaw

Companding Law.

See also:
ISPEECH_CompoundLaw.
XDAS_Int32 ISPHDEC_Params::packingType

Packing Format Option (for codecs that support multiple packing formats - used for selection, 0, 1, 2...)

The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHDEC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHDEC_Status Struct Reference
[XDM ISPHDEC Speech/Voice Decoder Interface]

Defines instance status parameters (read-only). More...

#include <isphdec.h>

Collaboration diagram for ISPHDEC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 postFilter
XDAS_Int32 dataMode
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHDEC_Fxns::control()

Field Documentation

XDAS_Int32 ISPHDEC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHDEC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 ISPHDEC_Status::postFilter

Post filter enabled flag. Set to 1 to enable, 0 to disable.

XDAS_Int32 ISPHDEC_Status::dataMode

To indicate in bavd data reception

XDM_AlgBufInfo ISPHDEC_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo.
The documentation for this struct was generated from the following file:
  • isphdec.h


Codec Engine Application Programming Interface (API): ISPHENC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_DynamicParams Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

This structure defines the codec parameters that can be modified after creation via ISPHENC1_Fxns.control(). More...

#include <isphenc1.h>

Data Fields

XDAS_Int16 size
XDAS_Int16 frameSize
XDAS_Int16 bitRate
XDAS_Int16 mode
XDAS_Int16 vadFlag
XDAS_Int16 noiseSuppressionMode
XDAS_Int16 ttyTddMode
XDAS_Int16 dtmfMode
XDAS_Int16 dataTransmit
XDAS_Int16 reserved

Detailed Description

This structure defines the codec parameters that can be modified after creation via ISPHENC1_Fxns.control().

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int16 ISPHENC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHENC1_DynamicParams::frameSize

Input frame size in bytes for sample based codecs.

XDAS_Int16 ISPHENC1_DynamicParams::bitRate

Optional, codec-specific bit rate. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_BitRate
ISPEECH1_G723_BitRate
ISPEECH1_WBAMR_BitRate
XDAS_Int16 ISPHENC1_DynamicParams::mode

Optional, codec-specific mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_EVRC_Mode
ISPEECH1_SMV_Mode
XDAS_Int16 ISPHENC1_DynamicParams::vadFlag

Voice Activity Detection (VAD) setting.

See also:
ISPEECH1_VADFlag.
XDAS_Int16 ISPHENC1_DynamicParams::noiseSuppressionMode

Optional, codec-specific noise suppression mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_EVRC_NoisePreProc
ISPEECH1_G723_NoisePreProc
ISPEECH1_SMV_NoisePreProc
XDAS_Int16 ISPHENC1_DynamicParams::ttyTddMode

Optional, codec-specific TTY mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_EVRC_TTYMode
ISPEECH1_SMV_TTYMode
XDAS_Int16 ISPHENC1_DynamicParams::dtmfMode

Optional, codec-specific DTMF mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_SMV_DTMFMode
XDAS_Int16 ISPHENC1_DynamicParams::dataTransmit

Optional, codec-specific data transmit mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_SMV_DataMode
XDAS_Int16 ISPHENC1_DynamicParams::reserved

Reserved - serves to pad this structure.

The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_Fxns Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

Defines all of the operations on ISPHENC1 objects. More...

#include <isphenc1.h>

Collaboration diagram for ISPHENC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(ISPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, ISPHENC1_InArgs *inArgs, ISPHENC1_OutArgs *outArgs)
Basic speech/voice decoding call.
XDAS_Int32(* | control )(ISPHENC1_Handle handle, ISPHENC1_Cmd id, ISPHENC1_DynamicParams *params, ISPHENC1_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on ISPHENC1 objects.

Field Documentation

IALG_Fxns ISPHENC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* ISPHENC1_Fxns::process)(ISPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, ISPHENC1_InArgs *inArgs, ISPHENC1_OutArgs *outArgs)

Basic speech/voice decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBuf | Input buffer descriptor.
[in,out] | outBuf | Output buffer descriptor.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
If inArgs->data is not used in the process() call, the application must set it to NULL. The algorithm must therefore check this field for NULL before accessing it.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid ISPHENC1_InArgs structure.
outArgs must not be NULL, and must point to a valid ISPHENC1_OutArgs structure.
inBuf must not be NULL, and must point to a valid XDM1_SingleBufDesc structure.
inBuf->buf must not be NULL, and must point to a valid buffer of data that is at least inBuf->bufSize bytes in length.
outBuf must not be NULL, and must point to a valid XDM1_SingleBufDesc structure.
outBuf->buf must not be NULL, and must point to a valid buffer of data that is at least outBuf->bufSize bytes in length.
The buffers in inBuf and outBuf are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs, with the optional exception of inArgs->data.
The algorithm must not modify the contents of inBuf, with the exception of inBuf->accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must set outBuf->bufSize to the size of valid data returned in outBuf->buf .
The algorithm must appropriately set/clear the XDM1_SingleBufDesc.accessMask field in both inBuf and outBuf. For example, if the algorithm only read from inBuf->buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBuf and outBuf are owned by the calling application.
Return values:
ISPHENC1_EOK | Success.
ISPHENC1_EFAIL | General failure. See ISPHENC1_Status::extendedError for more detailed further error conditions.
ISPHENC1_EUNSUPPORTED | Request is unsupported.
ISPHENC1_ENOOUTPUT | This value signifies no output being available at encoder, for example in the case of intermediate calls in 10msec frame size execution.
XDAS_Int32(* ISPHENC1_Fxns::control)(ISPHENC1_Handle handle, ISPHENC1_Cmd id, ISPHENC1_DynamicParams *params, ISPHENC1_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid ISPHENC1_DynamicParams structure.
status must not be NULL, and must point to a valid ISPHENC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
ISPHENC1_EOK | Success.
ISPHENC1_EFAIL | General failure. See ISPHENC1_Status::extendedError for more detailed further error conditions.
ISPHENC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_InArgs Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

Defines the input arguments for all ISPHENC1 instance process function. More...

#include <isphenc1.h>

Collaboration diagram for ISPHENC1_InArgs:
[legend]

Data Fields

XDAS_Int16 size
XDAS_Int16 nullTrafficChannel
XDM1_SingleBufDesc data

Detailed Description

Defines the input arguments for all ISPHENC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int16 ISPHENC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHENC1_InArgs::nullTrafficChannel

Enable/disable the null traffic channel.

Remarks:
This field is used for enabling/disabling the null traffic channel frames. When enabled, CDMA encoders produce 1/8th rate frames with all bits set to 1 without encoding the actual input.
See also:
ISPEECH1_NullTrafficMode
XDM1_SingleBufDesc ISPHENC1_InArgs::data

Raw data input for data transmission.

The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_Obj Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

This must be the first field of all ISPHENC1 instance objects. More...

#include <isphenc1.h>

Collaboration diagram for ISPHENC1_Obj:
[legend]

Data Fields

struct ISPHENC1_Fxns * fxns

Detailed Description

This must be the first field of all ISPHENC1 instance objects.

Field Documentation

struct ISPHENC1_Fxns* ISPHENC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_OutArgs Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

Defines the run time output arguments for all ISPHENC1 instance objects. More...

#include <isphenc1.h>

Data Fields

XDAS_Int16 size
XDAS_Int16 frameType
XDAS_Int32 extendedError

Detailed Description

Defines the run time output arguments for all ISPHENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC1_Fxns::process()

Field Documentation

XDAS_Int16 ISPHENC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHENC1_OutArgs::frameType

Encoder frame types.

See also:
ISPHENC1_FrameType
XDAS_Int32 ISPHENC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_Params Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

Defines the creation time parameters for all ISPHENC1 instance objects. More...

#include <isphenc1.h>

Data Fields

XDAS_Int16 size
XDAS_Int16 frameSize
XDAS_Int16 compandingLaw
XDAS_Int16 packingType
XDAS_Int16 vadSelection
XDAS_Int16 codecSelection
XDAS_Int16 bitRate
XDAS_Int16 reserved
XDAS_Int8 ** tablesPtr

Detailed Description

Defines the creation time parameters for all ISPHENC1 instance objects.

Remarks:
Some of the fields in this structure are optional and depend on the class of speech encoder you're creating.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int16 ISPHENC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHENC1_Params::frameSize

Input frame size in bytes for sample based codecs.

XDAS_Int16 ISPHENC1_Params::compandingLaw

Optional, codec-specific companding law. See your codec-specific interface documentation options.

See also:
ISPEECH1_PCM_CompandingLaw
ISPEECH1_G726_CompandingLaw
XDAS_Int16 ISPHENC1_Params::packingType

Optional, codec-specific packing type. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_PackingType
ISPEECH1_G726_PackingType
ISPEECH1_WBAMR_PackingType
XDAS_Int16 ISPHENC1_Params::vadSelection

Optional, codec-specific voice activity detection selection. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_VADSelect
ISPEECH1_SMV_VADSelect
XDAS_Int16 ISPHENC1_Params::codecSelection

Optional, codec-specific codec selection. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_CodecSelect
ISPHENC1_Params.codecSelection
XDAS_Int16 ISPHENC1_Params::bitRate

Optional, codec-specific bit rate. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_BitRate
ISPEECH1_G723_BitRate
ISPEECH1_G726_BitRate
ISPEECH1_WBAMR_BitRate
XDAS_Int16 ISPHENC1_Params::reserved

Reserved - serves to pad this structure.

XDAS_Int8** ISPHENC1_Params::tablesPtr

Optional pointer to the codec's initialization tables.

Remarks:
This parameter specifies a pointer to the array of the codec's table block pointers. If the application requires the codec to select the default table address array pointer, it should set this to NULL.
The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC1_Status Struct Reference
[XDM ISPHENC1 Speech/Voice Encoder Interface]

Defines instance status parameters. More...

#include <isphenc1.h>

Collaboration diagram for ISPHENC1_Status:
[legend]

Data Fields

XDAS_Int16 size
XDAS_Int16 frameSize
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int16 bitRate
XDAS_Int16 mode
XDAS_Int16 vadFlag
XDAS_Int16 noiseSuppressionMode
XDAS_Int16 ttyTddMode
XDAS_Int16 dataTransmit
XDAS_Int16 compandingLaw
XDAS_Int16 packingType
XDAS_Int16 vadSelection
XDAS_Int16 codecSelection
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int16 ISPHENC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int16 ISPHENC1_Status::frameSize

Input frame size in bytes for sample based codecs.

XDAS_Int32 ISPHENC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc ISPHENC1_Status::data

Buffer descriptor for data passing.

Remarks:
If this field is not used, the application must set data.buf to NULL.
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the ISPHENC1_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int16 ISPHENC1_Status::bitRate

Optional, codec-specific bit rate. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_BitRate
ISPEECH1_G723_BitRate
ISPEECH1_WBAMR_BitRate
XDAS_Int16 ISPHENC1_Status::mode

Optional, codec-specific mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_EVRC_Mode
ISPEECH1_SMV_Mode
XDAS_Int16 ISPHENC1_Status::vadFlag

Voice Activity Detection (VAD) setting.

See also:
ISPEECH1_VADFlag
XDAS_Int16 ISPHENC1_Status::noiseSuppressionMode

Optional, codec-specific noise suppression mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_EVRC_NoisePreProc
ISPEECH1_G723_NoisePreProc
ISPEECH1_SMV_NoisePreProc
XDAS_Int16 ISPHENC1_Status::ttyTddMode

Optional, codec-specific TTY mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_EVRC_TTYMode
ISPEECH1_SMV_TTYMode
XDAS_Int16 ISPHENC1_Status::dataTransmit

Optional, codec-specific data transmit mode. See your codec-specific interface documentation options.

See also:
ISPEECH1_SMV_DataMode
XDAS_Int16 ISPHENC1_Status::compandingLaw

Optional, codec-specific companding law. See your codec-specific interface documentation options.

See also:
ISPEECH1_PCM_CompandingLaw
ISPEECH1_G726_CompandingLaw
XDAS_Int16 ISPHENC1_Status::packingType

Optional, codec-specific packing type. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_PackingType
ISPEECH1_G726_PackingType
ISPEECH1_WBAMR_PackingType
XDAS_Int16 ISPHENC1_Status::vadSelection

Optional, codec-specific voice activity detection selection. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_VADSelect
ISPEECH1_SMV_VADSelect
XDAS_Int16 ISPHENC1_Status::codecSelection

Optional, codec-specific codec selection. See your codec-specific interface documentation options.

See also:
ISPEECH1_AMR_CodecSelect
ISPHENC1_Params.codecSelection
XDM_AlgBufInfo ISPHENC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • isphenc1.h


Codec Engine Application Programming Interface (API): ISPHENC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_DynamicParams Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <isphenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 frameSize
XDAS_Int32 bitRate
XDAS_Int32 mode
XDAS_Int32 vadFlag
XDAS_Int32 noiseSuppressionMode
XDAS_Int32 ttyTddMode
XDAS_Int32 dtmfMode
XDAS_Int32 dataTransmit
XDAS_Int32 homingMode

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::control()

Field Documentation

XDAS_Int32 ISPHENC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHENC_DynamicParams::frameSize

Input frame size in bytes for sample based codecs.

XDAS_Int32 ISPHENC_DynamicParams::bitRate

Rate selection for multi_rate codecs

XDAS_Int32 ISPHENC_DynamicParams::mode

Mode selection for multi_mode codecs

XDAS_Int32 ISPHENC_DynamicParams::vadFlag

VAD_On =1, VAD_OFF = 0

XDAS_Int32 ISPHENC_DynamicParams::noiseSuppressionMode

0 - OFF, 1 = NS-A, 2 = NS-B etc

XDAS_Int32 ISPHENC_DynamicParams::ttyTddMode

0 = TTY OFF, 1 = 45.45bauds 2 = 50 bauds

XDAS_Int32 ISPHENC_DynamicParams::dtmfMode

0 = DTMF_OFF, 1 = DTMF_ON

XDAS_Int32 ISPHENC_DynamicParams::dataTransmit

1 = ON, 0 = OFF

XDAS_Int32 ISPHENC_DynamicParams::homingMode

0 - DISABLED; 1 - ENABLED

The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): ISPHENC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_Fxns Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

Defines all of the operations on ISPHENC objects. More...

#include <isphenc.h>

Collaboration diagram for ISPHENC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(ISPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs)
Basic speech/voice encoding call.
XDAS_Int32(* | control )(ISPHENC_Handle handle, ISPHENC_Cmd id, ISPHENC_DynamicParams *params, ISPHENC_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on ISPHENC objects.

Field Documentation

IALG_Fxns ISPHENC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* ISPHENC_Fxns::process)(ISPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs)

Basic speech/voice encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid ISPHENC_InArgs structure.
outArgs must not be NULL, and must point to a valid ISPHENC_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
inBufs.buf[0] must not be NULL, and must point to a valid buffer of data that is at least inBufs.bufSizes[0] bytes in length.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs.buf[0] must not be NULL, and must point to a valid buffer of data that is at least outBufs.bufSizes[0] bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inBufs. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See ISPHENC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* ISPHENC_Fxns::control)(ISPHENC_Handle handle, ISPHENC_Cmd id, ISPHENC_DynamicParams *params, ISPHENC_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid ISPHENC_DynamicParams structure.
status must not be NULL, and must point to a valid ISPHENC_Status structure.
Postcondition:
The algorithm *must* not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See ISPHENC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): ISPHENC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_InArgs Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

Defines the input arguments for all ISPHENC instance process function. More...

#include <isphenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 nullTrafficChannel

Detailed Description

Defines the input arguments for all ISPHENC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::process()

Field Documentation

XDAS_Int32 ISPHENC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHENC_InArgs::nullTrafficChannel

1 = ON, 0 = OFF

The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): ISPHENC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_Obj Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

This must be the first field of all ISPHENC instance objects. More...

#include <isphenc.h>

Collaboration diagram for ISPHENC_Obj:
[legend]

Data Fields

struct ISPHENC_Fxns * fxns

Detailed Description

This must be the first field of all ISPHENC instance objects.

Field Documentation

struct ISPHENC_Fxns* ISPHENC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): ISPHENC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_OutArgs Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

Defines the run time output arguments for all ISPHENC instance objects. More...

#include <isphenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 rate
XDAS_Int32 frameType
XDAS_Int32 outbufferSize

Detailed Description

Defines the run time output arguments for all ISPHENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::process()

Field Documentation

XDAS_Int32 ISPHENC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHENC_OutArgs::rate

Current frame bit rate.

XDAS_Int32 ISPHENC_OutArgs::frameType

Current frame type.

XDAS_Int32 ISPHENC_OutArgs::outbufferSize

Output buffer size in bytes.

The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): ISPHENC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_Params Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

Defines the creation time parameters for all ISPHENC instance objects. More...

#include <isphenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 frameSize
XDAS_Int32 compandingLaw
XDAS_Int32 packingType
XDAS_Int32 vadSelection

Detailed Description

Defines the creation time parameters for all ISPHENC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 ISPHENC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHENC_Params::frameSize

Input frame size in bytes for sample based codecs.

XDAS_Int32 ISPHENC_Params::compandingLaw

Companding Law.

See also:
ISPEECH_CompoundLaw.
XDAS_Int32 ISPHENC_Params::packingType

Packing Format Option (for codecs that support multiple packing formats - used for selection, 0, 1, 2...)

XDAS_Int32 ISPHENC_Params::vadSelection

VAD A/VAD B, VAD 1/ VAD 2 etc

The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): ISPHENC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

ISPHENC_Status Struct Reference
[XDM ISPHENC Speech/Voice Encoder Interface]

Defines instance status parameters (read-only). More...

#include <isphenc.h>

Collaboration diagram for ISPHENC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 frameSize
XDAS_Int32 bitRate
XDAS_Int32 mode
XDAS_Int32 vadFlag
XDAS_Int32 noiseSuppressionMode
XDAS_Int32 ttyTddMode
XDAS_Int32 dtmfMode
XDAS_Int32 dataTransmit
XDAS_Int32 homingMode
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
ISPHENC_Fxns::control()

Field Documentation

XDAS_Int32 ISPHENC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 ISPHENC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 ISPHENC_Status::frameSize

Input frame size in bytes for sample based codecs

XDAS_Int32 ISPHENC_Status::bitRate

Rate selection for multi_rate codecs

XDAS_Int32 ISPHENC_Status::mode

Mode selection for multi_mode codecs

XDAS_Int32 ISPHENC_Status::vadFlag

VAD_On =1, VAD_OFF = 0

XDAS_Int32 ISPHENC_Status::noiseSuppressionMode

0 - OFF, 1 = NS-A, 2 = NS-B etc

XDAS_Int32 ISPHENC_Status::ttyTddMode

0 = TTY OFF, 1 = 45.45bauds 2 = 50 bauds

XDAS_Int32 ISPHENC_Status::dtmfMode

0 = DTMF_OFF, 1 = DTMF_ON

XDAS_Int32 ISPHENC_Status::dataTransmit

1 = ON, 0 = OFF

XDAS_Int32 ISPHENC_Status::homingMode

0 - DISABLED; 1 - ENABLED

XDM_AlgBufInfo ISPHENC_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo.
The documentation for this struct was generated from the following file:
  • isphenc.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_DynamicParams Struct Reference
[XDM Beta Universal Algorithm Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <iuniversal.h>

Data Fields

XDAS_Int32 size

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::control()

Field Documentation

XDAS_Int32 IUNIVERSAL_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_Fxns Struct Reference
[XDM Beta Universal Algorithm Interface]

Defines all of the operations on IUNIVERSAL objects. More...

#include <iuniversal.h>

Collaboration diagram for IUNIVERSAL_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IUNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs)
Basic audio decoding call.
XDAS_Int32(* | control )(IUNIVERSAL_Handle handle, IUNIVERSAL_Cmd id, IUNIVERSAL_DynamicParams *params, IUNIVERSAL_Status *status)
Control behaviour of an algorithm.

Detailed Description

Defines all of the operations on IUNIVERSAL objects.

Field Documentation

IALG_Fxns IUNIVERSAL_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IUNIVERSAL_Fxns::process)(IUNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs)

Basic audio decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors.
[in,out] | inOutBufs | Input/Output buffer descriptors.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
handle must be a valid algorithm instance handle.
inArgs must not be NULL, and must point to a valid IUNIVERSAL_InArgs structure.
outArgs must not be NULL, and must point to a valid IUNIVERSAL_OutArgs structure.
inBufs must either be NULL or point to a valid XDM1_BufDesc structure.
outBufs must either be NULL or point to a valid XDM1_BufDesc structure.
inOutBufs must either be NULL or point to a valid XDM1_BufDesc structure.
The buffers in inBufs, outBufs and inOutBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.descs[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must appropriately set/clear the XDM1_BufDesc::descs[].accessMask field in inBufs, outBufs, and inOutBufs. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs, outBufs, and inOutBufs are owned by the calling application.
Return values:
IUNIVERSAL_EOK | Success.
IUNIVERSAL_EFAIL | General failure. See IUNIVERSAL_Status::extendedError for more detailed further error conditions.
IUNIVERSAL_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IUNIVERSAL_Fxns::control)(IUNIVERSAL_Handle handle, IUNIVERSAL_Cmd id, IUNIVERSAL_DynamicParams *params, IUNIVERSAL_Status *status)

Control behaviour of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IUNIVERSAL_DynamicParams structure.
status must not be NULL, and must point to a valid IUNIVERSAL_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IUNIVERSAL_EOK | Success.
IUNIVERSAL_EFAIL | General failure. See IUNIVERSAL_Status::extendedError for more detailed further error conditions.
IUNIVERSAL_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_InArgs Struct Reference
[XDM Beta Universal Algorithm Interface]

Defines the input arguments for all IUNIVERSAL instance process function. More...

#include <iuniversal.h>

Data Fields

XDAS_Int32 size

Detailed Description

Defines the input arguments for all IUNIVERSAL instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::process()

Field Documentation

XDAS_Int32 IUNIVERSAL_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_Obj Struct Reference
[XDM Beta Universal Algorithm Interface]

This must be the first field of all IUNIVERSAL instance objects. More...

#include <iuniversal.h>

Collaboration diagram for IUNIVERSAL_Obj:
[legend]

Data Fields

struct IUNIVERSAL_Fxns * fxns

Detailed Description

This must be the first field of all IUNIVERSAL instance objects.

Field Documentation

struct IUNIVERSAL_Fxns* IUNIVERSAL_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_OutArgs Struct Reference
[XDM Beta Universal Algorithm Interface]

Defines the run time output arguments for all IUNIVERSAL instance objects. More...

#include <iuniversal.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError

Detailed Description

Defines the run time output arguments for all IUNIVERSAL instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::process()

Field Documentation

XDAS_Int32 IUNIVERSAL_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IUNIVERSAL_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_Params Struct Reference
[XDM Beta Universal Algorithm Interface]

Defines the creation time parameters for all IUNIVERSAL instance objects. More...

#include <iuniversal.h>

Data Fields

XDAS_Int32 size

Detailed Description

Defines the creation time parameters for all IUNIVERSAL instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IUNIVERSAL_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IUNIVERSAL_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IUNIVERSAL_Status Struct Reference
[XDM Beta Universal Algorithm Interface]

Defines instance status parameters (read-only). More...

#include <iuniversal.h>

Collaboration diagram for IUNIVERSAL_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_BufDesc data

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IUNIVERSAL_Fxns::control()

Field Documentation

XDAS_Int32 IUNIVERSAL_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IUNIVERSAL_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_BufDesc IUNIVERSAL_Status::data

Buffer descriptor for data passing.

Remarks:
These buffers can be used as either input, output, or input/output buffers, depending on the command.
The buffers will be provided by the application, and returned to the application upon return of the control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
The documentation for this struct was generated from the following file:
  • iuniversal.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_DynamicParams Struct Reference
[XDM Beta Video Analytics Interface]

This structure defines the algorithm parameters that can be modified after creation via control() calls. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_DynamicParams:
[legend]

Data Fields

XDAS_Int32 size
IVIDANALYTICS_Grid * grid
XDM_Date date
IVIDANALYTICS_Rule rule

Detailed Description

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDANALYTICS_Fxns::control()

Field Documentation

XDAS_Int32 IVIDANALYTICS_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

IVIDANALYTICS_Grid* IVIDANALYTICS_DynamicParams::grid

New overlay grid with analytics enable mask

XDM_Date IVIDANALYTICS_DynamicParams::date

Set the current time.

IVIDANALYTICS_Rule IVIDANALYTICS_DynamicParams::rule

Rule associated with this command (if applicable).

The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_Fxns Struct Reference
[XDM Beta Video Analytics Interface]

Defines all of the operations on IVIDANALYTICS objects. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs, IVIDANALYTICS_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDANALYTICS_Handle handle, IVIDANALYTICS_Cmd id, IVIDANALYTICS_DynamicParams *params, IVIDANALYTICS_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDANALYTICS objects.

Field Documentation

IALG_Fxns IVIDANALYTICS_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDANALYTICS_Fxns::process)(IVIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs, IVIDANALYTICS_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
inBufs->numBufs will indicate the total number of input buffers supplied for input frame.
inArgs must not be NULL, and must point to a valid IVIDANALYTICS_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDANALYTICS_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
outBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least outBufs->descs[0].bufSize bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.bufDesc[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must modify the contents of inBufs->descs[].accessMask and appropriately indicate the mode in which each of the buffers in inBufs were read. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs and outBufs are owned by the calling application.
Return values:
IVIDANALYTICS_EOK | Success.
IVIDANALYTICS_EFAIL | General failure. See IVIDANALYTICS_Status::extendedError for more detailed further error conditions.
IVIDANALYTICS_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDANALYTICS_Fxns::control)(IVIDANALYTICS_Handle handle, IVIDANALYTICS_Cmd id, IVIDANALYTICS_DynamicParams *params, IVIDANALYTICS_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDANALYTICS_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDANALYTICS_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IVIDANALYTICS_EOK | Success.
IVIDANALYTICS_EFAIL | General failure. See IVIDANALYTICS_Status::extendedError for more detailed further error conditions.
IVIDANALYTICS_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_Grid Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_Grid Struct Reference
[XDM Beta Video Analytics Interface]

Access modes used to declare how the algorithm accessed buffers. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_Grid:
[legend]

Data Fields

XDAS_Int32 blockHeight
XDAS_Int32 blockWidth
XDAS_Int32 numBlockHorizontal
XDAS_Int32 numBlockVertical
XDM1_SingleBufDesc enableMaskArray

Detailed Description

Access modes used to declare how the algorithm accessed buffers.

Remarks:
The IVIDANALYTICS interface reserves bits 0-15. Bits 16-31 are available to the user.
See also:
IVIDANALYTICS_DynamicParams::grid

Field Documentation

XDAS_Int32 IVIDANALYTICS_Grid::blockHeight

Height of a block

XDAS_Int32 IVIDANALYTICS_Grid::blockWidth

Width of a block

XDAS_Int32 IVIDANALYTICS_Grid::numBlockHorizontal

Number of blocks per row

XDAS_Int32 IVIDANALYTICS_Grid::numBlockVertical

Number of blocks per column

XDM1_SingleBufDesc IVIDANALYTICS_Grid::enableMaskArray

Buffer containing an array representing the type of analysis to enable on each block in the grid.

Remarks:
The array will be numBlockHorizontal * numBlockVertical.
See also:
IVIDANALYTICS_AnalysisMask
The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_InArgs Struct Reference
[XDM Beta Video Analytics Interface]

Defines the input arguments for all IVIDANALYTICS instance process function. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_InArgs:
[legend]

Data Fields

XDAS_Int32 size
XDM_Date date

Detailed Description

Defines the input arguments for all IVIDANALYTICS instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDANALYTICS_Fxns::process()

Field Documentation

XDAS_Int32 IVIDANALYTICS_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDM_Date IVIDANALYTICS_InArgs::date

Set the current time.

The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_Obj Struct Reference
[XDM Beta Video Analytics Interface]

This must be the first field of all IVIDANALYTICS instance objects. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_Obj:
[legend]

Data Fields

struct IVIDANALYTICS_Fxns * fxns

Detailed Description

This must be the first field of all IVIDANALYTICS instance objects.

Field Documentation

struct IVIDANALYTICS_Fxns* IVIDANALYTICS_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_OutArgs Struct Reference
[XDM Beta Video Analytics Interface]

Defines the run time output arguments for all IVIDANALYTICS instance objects. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 numTargets
XDM_Rect | targets [128]
XDAS_Int32 numEvents
XDAS_Int32 | eventId [128]
XDAS_Int32 extendedError
XDM_Date date

Detailed Description

Defines the run time output arguments for all IVIDANALYTICS instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IVIDANALYTICS_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDANALYTICS_OutArgs::numTargets

Number of targets detected

XDM_Rect IVIDANALYTICS_OutArgs::targets[128]

target locations.

Remarks:
If numTargets is zero, the values in this array are undefined.
XDAS_Int32 IVIDANALYTICS_OutArgs::numEvents

Number of events detected

XDAS_Int32 IVIDANALYTICS_OutArgs::eventId[128]

Zero-terminated array containing the ids of rules fired during the process() call.

Remarks:
If numEvents is zero, the values in this array are undefined.
XDAS_Int32 IVIDANALYTICS_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM_Date IVIDANALYTICS_OutArgs::date

Current time.

The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_Params Struct Reference
[XDM Beta Video Analytics Interface]

Defines the creation time parameters for all IVIDANALYTICS instance objects. More...

#include <ividanalytics.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxFrameRate
XDAS_Int32 dataEndianness
XDAS_Int32 inputChromaFormat
XDAS_Int32 maxRules

Detailed Description

Defines the creation time parameters for all IVIDANALYTICS instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IVIDANALYTICS_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDANALYTICS_Params::maxHeight

Maximum video height in pixels.

XDAS_Int32 IVIDANALYTICS_Params::maxWidth

Maximum video width in pixels.

XDAS_Int32 IVIDANALYTICS_Params::maxFrameRate

Maximum frame rate in fps * 1000. For example, if max frame rate is 30 frames per second, set this field to 30000.

XDAS_Int32 IVIDANALYTICS_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IVIDANALYTICS_Params::inputChromaFormat

Chroma format for the input buffer.

See also:
XDM_ChromaFormat
XDAS_Int32 IVIDANALYTICS_Params::maxRules

Maximum number of rules allowed.

The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_Rule Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_Rule Struct Reference
[XDM Beta Video Analytics Interface]

Analytics rule. More...

#include <ividanalytics.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 id
IVIDANALYTICS_ObjectType objectType
IVIDANALYTICS_ActionType actionType

Detailed Description

Analytics rule.

Field Documentation

XDAS_Int32 IVIDANALYTICS_Rule::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDANALYTICS_Rule::id

id associated with this rule.

IVIDANALYTICS_ObjectType IVIDANALYTICS_Rule::objectType

Type of the object associated with this rule.

IVIDANALYTICS_ActionType IVIDANALYTICS_Rule::actionType

Type of action associated with this rule.

The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDANALYTICS_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDANALYTICS_Status Struct Reference
[XDM Beta Video Analytics Interface]

Defines instance status parameters. More...

#include <ividanalytics.h>

Collaboration diagram for IVIDANALYTICS_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_BufDesc data
XDM_AlgBufInfo bufInfo
XDAS_Int32 viewState

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDANALYTICS_Fxns::control()

Field Documentation

XDAS_Int32 IVIDANALYTICS_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDANALYTICS_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_BufDesc IVIDANALYTICS_Status::data

Buffer descriptors for data passing.

Remarks:
If this field is not used, the application must set data.numBufs to 0.
These buffers can be used as either input or output, depending on the command.
The buffers will be provided by the application, and returned to the application upon return of the IVIDANALYTICS_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDM_AlgBufInfo IVIDANALYTICS_Status::bufInfo

Input and output buffer information.

Remarks:
This field provides the application with the algorithm's buffer requirements. The requirements may vary depending on the current configuration of the algorithm instance.
See also:
IVIDANALYTICS_Params
XDM_AlgBufInfo
IVIDANALYTICS_Fxns::control()
XDAS_Int32 IVIDANALYTICS_Status::viewState

View state of the analytics engine.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
Todo:
Need to further review and define. Probably need hooks for user-defined states, in addition to some pre-defined ones.
See also:
IVIDANALYTICS_OutArgs::viewState
IVIDANALYTICS_Status::viewState

See also:
IVIDANALYTICS_ViewState
The documentation for this struct was generated from the following file:
  • ividanalytics.h


Codec Engine Application Programming Interface (API): IVIDDEC1_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_CodecClassConfig Struct Reference
[Video 1.0 decoder codec interface]

Definition of IVIDDEC1 codec class configurable parameters. More...

#include <viddec1.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]

Detailed Description

Definition of IVIDDEC1 codec class configurable parameters.

Field Documentation

Bool IVIDDEC1_CodecClassConfig::manageInBufsCache[16]
Bool IVIDDEC1_CodecClassConfig::manageOutBufsCache[16]
The documentation for this struct was generated from the following file:
  • viddec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_DynamicParams Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <ividdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 decodeHeader
XDAS_Int32 displayWidth
XDAS_Int32 frameSkipMode
XDAS_Int32 frameOrder
XDAS_Int32 newFrameFlag
XDAS_Int32 mbDataFlag

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::control()

Field Documentation

XDAS_Int32 IVIDDEC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC1_DynamicParams::decodeHeader

Decode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_DecMode
XDAS_Int32 IVIDDEC1_DynamicParams::displayWidth

Pitch. If set to zero, use the decoded image width. Else, use given display width in pixels.

XDAS_Int32 IVIDDEC1_DynamicParams::frameSkipMode

Video frame skip features for video decoder.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_FrameSkip
XDAS_Int32 IVIDDEC1_DynamicParams::frameOrder

Video decoder output frame order.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
IVIDDEC1_DynamicParams::frameOrder

See also:
IVIDDEC1_FrameOrder
XDAS_Int32 IVIDDEC1_DynamicParams::newFrameFlag

Flag to indicate that the algorithm should start a new frame.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
This is useful for error recovery, for example when the end of frame cannot be detected by the codec but is known to the application.
XDAS_Int32 IVIDDEC1_DynamicParams::mbDataFlag

Flag to indicate that the algorithm should generate MB Data in addition to decoding the data.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
See also:
IVIDDEC1_OutArgs::mbDataBuf
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_Fxns Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

Defines all of the operations on IVIDDEC1 objects. More...

#include <ividdec1.h>

Collaboration diagram for IVIDDEC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDDEC1_InArgs *inArgs, IVIDDEC1_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDDEC1_Handle handle, IVIDDEC1_Cmd id, IVIDDEC1_DynamicParams *params, IVIDDEC1_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDDEC1 objects.

Field Documentation

IALG_Fxns IVIDDEC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDDEC1_Fxns::process)(IVIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDDEC1_InArgs *inArgs, IVIDDEC1_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
inBufs->numBufs will indicate the total number of input buffers supplied for input frame, and conditionally, the encoders MB data buffer.
If IVIDDEC1_DynamicParams::mbDataFlag was set to XDAS_FALSE in a previous control() call, the application only needs to provide buffers for reconstruction frames.
If IVIDDEC1_DynamicParams::mbDataFlag was set to XDAS_TRUE in a previous control() call, outBufs->bufs[outBufs->numBufs - 1] is a buffer descriptor into which the algorithm will write MB data for each macro block. The size of the MB data buffer will vary based on the decoder type. H.264 may generate N264 bytes per MB, while Mpeg2 may generate NMP2 bytes. The exact size of the buffers should be obtained by calling the algorithm's control() method with XDM_GETBUFINFO.
inArgs must not be NULL, and must point to a valid IVIDDEC1_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDDEC1_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs->buf[0] must not be NULL, and must point to a valid buffer of data that is at least outBufs->bufSizes[0] bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.bufDesc[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must modify the contents of inBufs->descs[].accessMask and appropriately indicate the mode in which each of the buffers in inBufs were read. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs are owned by the calling application.
Return values:
IVIDDEC1_EOK | Success.
IVIDDEC1_EFAIL | General failure. See IVIDDEC1_Status::extendedError for more detailed further error conditions.
IVIDDEC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDDEC1_Fxns::control)(IVIDDEC1_Handle handle, IVIDDEC1_Cmd id, IVIDDEC1_DynamicParams *params, IVIDDEC1_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDDEC1_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDDEC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IVIDDEC1_EOK | Success.
IVIDDEC1_EFAIL | General failure. See IVIDDEC1_Status::extendedError for more detailed further error conditions.
IVIDDEC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_InArgs Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

Defines the input arguments for all IVIDDEC1 instance process function. More...

#include <ividdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes
XDAS_Int32 inputID

Detailed Description

Defines the input arguments for all IVIDDEC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC1_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

XDAS_Int32 IVIDDEC1_InArgs::inputID

The decoder will attach this ID with the corresponding output frames.

Remarks:
This is useful when frames require re-ordering (e.g. B frames).
When there is no re-ordering, IVIDDEC1_OutArgs::outputID will be same as this inputID field.
Zero (0) is not a supported inputID. This value is reserved for cases when there is no output buffer provided in IVIDDEC1_OutArgs::displayBufs.
See also:
IVIDDEC1_OutArgs::outputID.
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_Obj Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

This must be the first field of all IVIDDEC1 instance objects. More...

#include <ividdec1.h>

Collaboration diagram for IVIDDEC1_Obj:
[legend]

Data Fields

struct IVIDDEC1_Fxns * fxns

Detailed Description

This must be the first field of all IVIDDEC1 instance objects.

Field Documentation

struct IVIDDEC1_Fxns* IVIDDEC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_OutArgs Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

Defines the run time output arguments for all IVIDDEC1 instance objects. More...

#include <ividdec1.h>

Collaboration diagram for IVIDDEC1_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 bytesConsumed
XDAS_Int32 | outputID [XDM_MAX_IO_BUFFERS]
IVIDEO1_BufDesc decodedBufs
IVIDEO1_BufDesc | displayBufs [XDM_MAX_IO_BUFFERS]
XDAS_Int32 outputMbDataID
XDM1_SingleBufDesc mbDataBuf
XDAS_Int32 | freeBufID [16]
XDAS_Int32 outBufsInUseFlag

Detailed Description

Defines the run time output arguments for all IVIDDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC1_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC1_OutArgs::bytesConsumed

Number of bytes consumed during the process() call.

XDAS_Int32 IVIDDEC1_OutArgs::outputID[XDM_MAX_IO_BUFFERS]

Output ID corresponding to displayBufs[].

Remarks:
A value of zero (0) indicates an invalid ID. The first zero entry in array will indicate end of valid outputIDs within the array. Hence the application can stop reading the array when it encounters the first zero entry.
See also:
IVIDDEC1_OutArgs::displayBufs
IVIDDEC1_InArgs::inputID
IVIDEO1_BufDesc IVIDDEC1_OutArgs::decodedBufs

The decoder fills this structure with buffer pointers to the decoded frame. Related information fields for the decoded frame are also populated.

When frame decoding is not complete, as indicated by outBufsInUseFlag, the frame data in this structure will be incomplete. However, the algorithm will provide incomplete decoded frame data in case application may choose to use it for error recovery purposes.

See also:
IVIDDEC1_OutArgs::outBufsInUseFlag
IVIDEO1_BufDesc IVIDDEC1_OutArgs::displayBufs[XDM_MAX_IO_BUFFERS]

Array containing display frames corresponding to valid ID entries in the outputID[] array.

Remarks:
Entries in the array corresponding to invalid ID values (zero) in outputID[] will set zero value for the following fields in the IVIDEO1_BufDesc structure: numBufs, frameWidth, frameHeight, and framePitch.
Implied by the previous remark, as this array corresponds to buffer IDs indicated by outputID[], elements of this array are undefined if the corresponding outputID[] element is zero (0).
XDAS_Int32 IVIDDEC1_OutArgs::outputMbDataID

Output ID corresponding with the MB Data

Remarks:
This will be set to zero when there is no MB Data Buffer
XDM1_SingleBufDesc IVIDDEC1_OutArgs::mbDataBuf

The decoder populates the last buffer among the buffers supplied within outBufs->bufs[] with the decoded MB data generated by the ECD module. The pointer buffer along with the buffer size is output via this buffer descriptor.

XDAS_Int32 IVIDDEC1_OutArgs::freeBufID[16]

This is an array of inputID's corresponding to the buffers that have been unlocked in the current process call.

Remarks:
Buffers returned to the application for display (via IVIDDEC1_OutArgs::displayBufs) continue to be owned by the algorithm until they are released - indicated by the ID being returned in this freeBuf array.
The buffers released by the algorithm are indicated by their non-zero ID (previously provided via IVIDDEC1_InArgs::inputID).
A value of zero (0) indicates an invalid ID. The first zero entry in array will indicate end of valid freeBufIDs within the array. Hence the application can stop searching the array when it encounters the first zero entry.
If no buffer was unlocked in the process call, freeBufID[0] will have a value of zero.
See also:
IVIDDEC1_InArgs::inputID
IVIDDEC1_OutArgs::displayBufs
XDAS_Int32 IVIDDEC1_OutArgs::outBufsInUseFlag

Flag to indicate that the outBufs provided with the process() call are in use. No outBufs are required to be supplied with the next process() call.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_Params Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

Defines the creation time parameters for all IVIDDEC1 instance objects. More...

#include <ividdec1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxFrameRate
XDAS_Int32 maxBitRate
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IVIDDEC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IVIDDEC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC1_Params::maxHeight

Maximum video height in pixels.

XDAS_Int32 IVIDDEC1_Params::maxWidth

Maximum video width in pixels.

XDAS_Int32 IVIDDEC1_Params::maxFrameRate

Maximum frame rate in fps * 1000. For example, if max frame rate is 30 frames per second, set this field to 30000.

XDAS_Int32 IVIDDEC1_Params::maxBitRate

Maximum bit rate, bits per second. For example, if bit rate is 10 Mbps, set this field to 10000000

XDAS_Int32 IVIDDEC1_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IVIDDEC1_Params::forceChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC1_Status Struct Reference
[XDM IVIDDEC1 Video Decoder Interface]

Defines instance status parameters. More...

#include <ividdec1.h>

Collaboration diagram for IVIDDEC1_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int32 outputHeight
XDAS_Int32 outputWidth
XDAS_Int32 frameRate
XDAS_Int32 bitRate
XDAS_Int32 contentType
XDAS_Int32 outputChromaFormat
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
All fields correspond to latest IVIDDEC1_Fxns::process() call on the particular instance of the decoder.
See also:
IVIDDEC1_Fxns::control()

Field Documentation

XDAS_Int32 IVIDDEC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IVIDDEC1_Status::data

Buffer descriptor for data passing.

Remarks:
If this field is not used, the application must set data.buf to NULL.
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the IVIDDEC1_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int32 IVIDDEC1_Status::outputHeight

Output height in pixels.

XDAS_Int32 IVIDDEC1_Status::outputWidth

Output width in pixels.

XDAS_Int32 IVIDDEC1_Status::frameRate

Average frame rate in fps * 1000. For example, if average frame rate is 30 frames per second, this field should be 30000.

XDAS_Int32 IVIDDEC1_Status::bitRate

Average bit rate, in bits per second.

XDAS_Int32 IVIDDEC1_Status::contentType

Video content types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_ContentType
XDAS_Int32 IVIDDEC1_Status::outputChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat
XDM_AlgBufInfo IVIDDEC1_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • ividdec1.h


Codec Engine Application Programming Interface (API): IVIDDEC2_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_CodecClassConfig Struct Reference
[Video decoder codec interface]

Definition of IVIDDEC2 codec class configurable parameters. More...

#include <viddec2.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]

Detailed Description

Definition of IVIDDEC2 codec class configurable parameters.

Field Documentation

Bool IVIDDEC2_CodecClassConfig::manageInBufsCache[16]
Bool IVIDDEC2_CodecClassConfig::manageOutBufsCache[16]
The documentation for this struct was generated from the following file:
  • viddec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_DynamicParams Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <ividdec2.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 decodeHeader
XDAS_Int32 displayWidth
XDAS_Int32 frameSkipMode
XDAS_Int32 frameOrder
XDAS_Int32 newFrameFlag
XDAS_Int32 mbDataFlag

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2_Fxns::control()

Field Documentation

XDAS_Int32 IVIDDEC2_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC2_DynamicParams::decodeHeader

Decode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_DecMode
XDAS_Int32 IVIDDEC2_DynamicParams::displayWidth

Pitch. If set to zero, use the decoded image width. Else, use given display width in pixels.

XDAS_Int32 IVIDDEC2_DynamicParams::frameSkipMode

Video frame skip features for video decoder.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_FrameSkip
XDAS_Int32 IVIDDEC2_DynamicParams::frameOrder

Video decoder output frame order.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
See also:
IVIDDEC2_DynamicParams::frameOrder

See also:
IVIDDEC2_FrameOrder
XDAS_Int32 IVIDDEC2_DynamicParams::newFrameFlag

Flag to indicate that the algorithm should start a new frame.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
This is useful for error recovery, for example when the end of frame cannot be detected by the codec but is known to the application.
XDAS_Int32 IVIDDEC2_DynamicParams::mbDataFlag

Flag to indicate that the algorithm should generate MB Data in addition to decoding the data.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
See also:
IVIDDEC2_OutArgs::mbDataBuf
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_Fxns Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

Defines all of the operations on IVIDDEC2 objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDDEC2_InArgs *inArgs, IVIDDEC2_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDDEC2_Handle handle, IVIDDEC2_Cmd id, IVIDDEC2_DynamicParams *params, IVIDDEC2_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDDEC2 objects.

Field Documentation

IALG_Fxns IVIDDEC2_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDDEC2_Fxns::process)(IVIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDDEC2_InArgs *inArgs, IVIDDEC2_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
process() enables codecs to support error resiliency and error concealment. As a result, even if IVIDDEC2_EFAIL is returned from process() because the encoded buffer has an error, it's possible that decoded buffers (outArgs->decodedBufs) and display buffers (outArgs->displayBufs) could still be returned. The codec can indicate that buffers are available by not setting the XDM_ISFATALERROR bit in the respective displayBufs and decodedBufs extendedError field if the buffers contain valid data.
By extension then, if the outArgs->decodedBufs and outArgs->displayBufs buffers are not valid, even if the codec's process() call returns IVIDDEC2_EFAIL, it must also be sure to set the XDM_ISFATALERROR bit in the respective extendedError fields. Failure to do so may result in applications accessing these buffers and causing system instability.
Precondition:
inBufs->numBufs will indicate the total number of input buffers supplied for input frame, and conditionally, the encoders MB data buffer.
If IVIDDEC2_DynamicParams::mbDataFlag was set to XDAS_FALSE in a previous control() call, the application only needs to provide buffers for reconstruction frames.
If IVIDDEC2_DynamicParams::mbDataFlag was set to XDAS_TRUE in a previous control() call, outBufs->bufs[outBufs->numBufs - 1] is a buffer descriptor into which the algorithm will write MB data for each macro block. The size of the MB data buffer will vary based on the decoder type. H.264 may generate N264 bytes per MB, while Mpeg2 may generate NMP2 bytes. The exact size of the buffers should be obtained by calling the algorithm's control() method with XDM_GETBUFINFO.
inArgs must not be NULL, and must point to a valid IVIDDEC2_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDDEC2_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs->buf[0] must not be NULL, and must point to a valid buffer of data that is at least outBufs->bufSizes[0] bytes in length.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.bufDesc[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must modify the contents of inBufs->descs[].accessMask and appropriately indicate the mode in which each of the buffers in inBufs were read. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs are owned by the calling application.
Return values:
IVIDDEC2_EOK | Success.
IVIDDEC2_EFAIL | General failure. See IVIDDEC2_Status::extendedError for more detailed further error conditions.
IVIDDEC2_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDDEC2_Fxns::control)(IVIDDEC2_Handle handle, IVIDDEC2_Cmd id, IVIDDEC2_DynamicParams *params, IVIDDEC2_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDDEC2_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDDEC2_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IVIDDEC2_EOK | Success.
IVIDDEC2_EFAIL | General failure. See IVIDDEC2_Status::extendedError for more detailed further error conditions.
IVIDDEC2_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_InArgs Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

Defines the input arguments for all IVIDDEC2 instance process function. More...

#include <ividdec2.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes
XDAS_Int32 inputID

Detailed Description

Defines the input arguments for all IVIDDEC2 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC2_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC2_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

XDAS_Int32 IVIDDEC2_InArgs::inputID

The decoder will attach this ID with the corresponding output frames.

Remarks:
This is useful when frames require re-ordering (e.g. B frames).
When there is no re-ordering, IVIDDEC2_OutArgs::outputID will be same as this inputID field.
Zero (0) is not a supported inputID. This value is reserved for cases when there is no output buffer provided in IVIDDEC2_OutArgs::displayBufs.
See also:
IVIDDEC2_OutArgs::outputID.
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_Obj Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

This must be the first field of all IVIDDEC2 instance objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2_Obj:
[legend]

Data Fields

struct IVIDDEC2_Fxns * fxns

Detailed Description

This must be the first field of all IVIDDEC2 instance objects.

Field Documentation

struct IVIDDEC2_Fxns* IVIDDEC2_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_OutArgs Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

Defines the run time output arguments for all IVIDDEC2 instance objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 bytesConsumed
XDAS_Int32 | outputID [20]
IVIDEO1_BufDesc decodedBufs
IVIDEO1_BufDesc | displayBufs [20]
XDAS_Int32 outputMbDataID
XDM1_SingleBufDesc mbDataBuf
XDAS_Int32 | freeBufID [20]
XDAS_Int32 outBufsInUseFlag

Detailed Description

Defines the run time output arguments for all IVIDDEC2 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC2_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC2_OutArgs::bytesConsumed

Number of bytes consumed during the process() call.

XDAS_Int32 IVIDDEC2_OutArgs::outputID[20]

Output ID corresponding to displayBufs[].

Remarks:
A value of zero (0) indicates an invalid ID. The first zero entry in array will indicate end of valid outputIDs within the array. Hence the application can stop reading the array when it encounters the first zero entry.
See also:
IVIDDEC2_OutArgs::displayBufs
IVIDDEC2_InArgs::inputID
IVIDEO1_BufDesc IVIDDEC2_OutArgs::decodedBufs

The decoder fills this structure with buffer pointers to the decoded frame. Related information fields for the decoded frame are also populated.

When frame decoding is not complete, as indicated by outBufsInUseFlag, the frame data in this structure will be incomplete. However, the algorithm will provide incomplete decoded frame data in case application may choose to use it for error recovery purposes.

See also:
IVIDDEC2_OutArgs::outBufsInUseFlag
IVIDEO1_BufDesc IVIDDEC2_OutArgs::displayBufs[20]

Array containing display frames corresponding to valid ID entries in the outputID[] array.

Remarks:
Entries in the array corresponding to invalid ID values (zero) in outputID[] will set zero value for the following fields in the IVIDEO1_BufDesc structure: numBufs, frameWidth, frameHeight, and framePitch.
Implied by the previous remark, as this array corresponds to buffer IDs indicated by outputID[], elements of this array are undefined if the corresponding outputID[] element is zero (0).
XDAS_Int32 IVIDDEC2_OutArgs::outputMbDataID

Output ID corresponding with the MB Data

Remarks:
This will be set to zero when there is no MB Data Buffer
XDM1_SingleBufDesc IVIDDEC2_OutArgs::mbDataBuf

The decoder populates the last buffer among the buffers supplied within outBufs->bufs[] with the decoded MB data generated by the ECD module. The pointer buffer along with the buffer size is output via this buffer descriptor.

XDAS_Int32 IVIDDEC2_OutArgs::freeBufID[20]

This is an array of inputID's corresponding to the buffers that have been unlocked in the current process call.

Remarks:
Buffers returned to the application for display (via IVIDDEC2_OutArgs::displayBufs) continue to be owned by the algorithm until they are released - indicated by the ID being returned in this freeBuf array.
The buffers released by the algorithm are indicated by their non-zero ID (previously provided via IVIDDEC2_InArgs::inputID).
A value of zero (0) indicates an invalid ID. The first zero entry in array will indicate end of valid freeBufIDs within the array. Hence the application can stop searching the array when it encounters the first zero entry.
If no buffer was unlocked in the process call, freeBufID[0] will have a value of zero.
See also:
IVIDDEC2_InArgs::inputID
IVIDDEC2_OutArgs::displayBufs
XDAS_Int32 IVIDDEC2_OutArgs::outBufsInUseFlag

Flag to indicate that the outBufs provided with the process() call are in use. No outBufs are required to be supplied with the next process() call.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_Params Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

Defines the creation time parameters for all IVIDDEC2 instance objects. More...

#include <ividdec2.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxFrameRate
XDAS_Int32 maxBitRate
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IVIDDEC2 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IVIDDEC2_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC2_Params::maxHeight

Maximum video height in pixels.

XDAS_Int32 IVIDDEC2_Params::maxWidth

Maximum video width in pixels.

XDAS_Int32 IVIDDEC2_Params::maxFrameRate

Maximum frame rate in fps * 1000. For example, if max frame rate is 30 frames per second, set this field to 30000.

XDAS_Int32 IVIDDEC2_Params::maxBitRate

Maximum bit rate, bits per second. For example, if bit rate is 10 Mbps, set this field to 10000000

XDAS_Int32 IVIDDEC2_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IVIDDEC2_Params::forceChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2_Status Struct Reference
[XDM IVIDDEC2 Video Decoder Interface]

Defines instance status parameters. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDAS_Int32 maxNumDisplayBufs
XDAS_Int32 outputHeight
XDAS_Int32 outputWidth
XDAS_Int32 frameRate
XDAS_Int32 bitRate
XDAS_Int32 contentType
XDAS_Int32 outputChromaFormat
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
All fields correspond to latest IVIDDEC2_Fxns::process() call on the particular instance of the decoder.
See also:
IVIDDEC2_Fxns::control()

Field Documentation

XDAS_Int32 IVIDDEC2_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC2_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IVIDDEC2_Status::data

Buffer descriptor for data passing.

Remarks:
If this field is not used, the application must set data.buf to NULL.
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the IVIDDEC2_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDAS_Int32 IVIDDEC2_Status::maxNumDisplayBufs

The maximum number of buffers that will be required by the codec.

Remarks:
The maximum number of buffers can be IVIDDEC2_MAX_IO_BUFFERS.
XDAS_Int32 IVIDDEC2_Status::outputHeight

Output height in pixels.

XDAS_Int32 IVIDDEC2_Status::outputWidth

Output width in pixels.

XDAS_Int32 IVIDDEC2_Status::frameRate

Average frame rate in fps * 1000. For example, if average frame rate is 30 frames per second, this field should be 30000.

XDAS_Int32 IVIDDEC2_Status::bitRate

Average bit rate, in bits per second.

XDAS_Int32 IVIDDEC2_Status::contentType

Video content types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_ContentType
XDAS_Int32 IVIDDEC2_Status::outputChromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat
XDM_AlgBufInfo IVIDDEC2_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2BACK_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2BACK_CodecClassConfig Struct Reference
[Split video decoder interface]

Definition of IVIDDEC2BACK codec class configurable parameters. More...

#include <viddec2.h>

Data Fields

Bool | manageInBufsCache [32]
Bool | manageOutBufsCache [32]
Bool | manageIntermediateBufsCache [32]

Detailed Description

Definition of IVIDDEC2BACK codec class configurable parameters.

Field Documentation

Bool IVIDDEC2BACK_CodecClassConfig::manageInBufsCache[32]
Bool IVIDDEC2BACK_CodecClassConfig::manageOutBufsCache[32]
Bool IVIDDEC2BACK_CodecClassConfig::manageIntermediateBufsCache[32]
The documentation for this struct was generated from the following file:
  • split/viddec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2BACK_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2BACK_Fxns Struct Reference
[XDM IVIDDEC2-based Video Decoder Split Interface]

Defines all of the operations on IVIDDEC2BACK objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2BACK_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDDEC2BACK_Handle handle, XDM_Context *context, IVIDDEC2_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDDEC2BACK_Handle handle, XDM_Context *context, IVIDDEC2_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDDEC2BACK objects.

Field Documentation

IALG_Fxns IVIDDEC2BACK_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDDEC2BACK_Fxns::process)(IVIDDEC2BACK_Handle handle, XDM_Context *context, IVIDDEC2_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | context | Context provided to, and managed by the split codec.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
context must not be NULL, and must point to a valid XDM_Context structure.
context->numInOutBufs must be zero (0).
outArgs must not be NULL, and must point to a valid IVIDDEC2_OutArgs structure.
Postcondition:
The buffers in context are owned by the calling application.
Return values:
IVIDDEC2_EOK | Success.
IVIDDEC2_EFAIL | General failure. See IVIDDEC2_Status::extendedError for more detailed further error conditions.
IVIDDEC2_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDDEC2BACK_Fxns::control)(IVIDDEC2BACK_Handle handle, XDM_Context *context, IVIDDEC2_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | context | Codec context. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
context must not be NULL, and must point to a valid XDM_Context structure.
status must not be NULL, and must point to a valid IVIDDEC2_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IVIDDEC2_EOK | Success.
IVIDDEC2_EFAIL | General failure. See IVIDDEC2_Status::extendedError for more detailed further error conditions.
IVIDDEC2_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • split/ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2BACK_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2BACK_Obj Struct Reference
[XDM IVIDDEC2-based Video Decoder Split Interface]

This must be the first field of all IVIDDEC2BACK instance objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2BACK_Obj:
[legend]

Data Fields

struct IVIDDEC2BACK_Fxns * fxns

Detailed Description

This must be the first field of all IVIDDEC2BACK instance objects.

Field Documentation

struct IVIDDEC2BACK_Fxns* IVIDDEC2BACK_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • split/ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2FRONT_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2FRONT_Fxns Struct Reference
[XDM IVIDDEC2-based Video Decoder Split Interface]

Defines all of the operations on IVIDDEC2FRONT objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2FRONT_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDDEC2FRONT_Handle handle, IVIDDEC2_InArgs *inArgs, XDM_Context *context, IVIDDEC2FRONT_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDDEC2FRONT_Handle handle, IVIDDEC2_Cmd id, IVIDDEC2_DynamicParams *params, XDM_Context *context, IVIDDEC2FRONT_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDDEC2FRONT objects.

Field Documentation

IALG_Fxns IVIDDEC2FRONT_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDDEC2FRONT_Fxns::process)(IVIDDEC2FRONT_Handle handle, IVIDDEC2_InArgs *inArgs, XDM_Context *context, IVIDDEC2FRONT_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inArgs | Input arguments. This is a required parameter.
[in,out] | context | Context provided to, and managed by the split codec.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
The application must call IVIDDEC2FRONT::control() with XDM_GETCONTEXTINFO to obtain the minimum buffer sizes the codec requires.
context includes input and output buffers, intermediate buffers, and other values used by the codec. See XDM_Context for more details.
Precondition:
context->numInBufs will indicate the total number of input buffers supplied for input frame, and conditionally, the encoders MB data buffer.
If IVIDDEC2_DynamicParams::mbDataFlag was set to XDAS_FALSE in a previous control() call, the application only needs to provide buffers for reconstruction frames.
If IVIDDEC2_DynamicParams::mbDataFlag was set to XDAS_TRUE in a previous control() call, context->outBufs[context->numOutBufs - 1] is a buffer descriptor into which the algorithm will write MB data for each macro block. The size of the MB data buffer will vary based on the decoder type. H.264 may generate N264 bytes per MB, while Mpeg2 may generate NMP2 bytes. The exact size of the buffers should be obtained by calling the algorithm's control() method with XDM_GETBUFINFO.
inArgs must not be NULL, and must point to a valid IVIDDEC2_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDDEC2FRONT_OutArgs structure.
context must not be NULL, and must point to a valid XDM_Context structure.
context->inBufs[0].buf must not be NULL, and must point to a valid buffer of data that is at least context->inBufs[0].bufSize bytes in length.
context->outBufs[0] must not be NULL, and must point to a valid buffer of data that is at least context->outBufs[0].bufSize bytes in length.
context->numInOutBufs must be zero (0).
The buffers in context->inBufs and context->outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of context->inBufs, with the exception of context->inBufs[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must modify the contents of context->inBufs[].accessMask and appropriately indicate the mode in which each of the buffers in context->inBufs were read. For example, if the algorithm only read from context->inBufs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in context->inBufs and context->outBufs are not owned by the calling application.
The buffers in context->algContext and context->intermediateBufs[] are owned by the calling application, but must be provided - unmodified - to the next part in this split codec.
Return values:
IVIDDEC2_EOK | Success.
IVIDDEC2_EFAIL | General failure. See IVIDDEC2_Status::extendedError for more detailed further error conditions.
IVIDDEC2_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDDEC2FRONT_Fxns::control)(IVIDDEC2FRONT_Handle handle, IVIDDEC2_Cmd id, IVIDDEC2_DynamicParams *params, XDM_Context *context, IVIDDEC2FRONT_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[in,out] | context | Context provided to, and managed by the split codec.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDDEC2_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDDEC2FRONT_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Remarks:
context may be NULL. The FRONT part of a codec may be capable of completely handling the control() command. The codec indicates this the application is sure the FRONT part of the codec can return and must point to a valid XDM_Context structure.
Return values:
IVIDDEC2_EOK | Success.
IVIDDEC2_EFAIL | General failure. See IVIDDEC2_Status::extendedError for more detailed further error conditions.
IVIDDEC2_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • split/ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2FRONT_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2FRONT_Obj Struct Reference
[XDM IVIDDEC2-based Video Decoder Split Interface]

This must be the first field of all IVIDDEC2FRONT instance objects. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2FRONT_Obj:
[legend]

Data Fields

struct IVIDDEC2FRONT_Fxns * fxns

Detailed Description

This must be the first field of all IVIDDEC2FRONT instance objects.

Field Documentation

struct IVIDDEC2FRONT_Fxns* IVIDDEC2FRONT_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • split/ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2FRONT_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2FRONT_OutArgs Struct Reference
[XDM IVIDDEC2-based Video Decoder Split Interface]

Defines the run time output arguments for all IVIDDEC2FRONT instance objects. More...

#include <ividdec2.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesConsumed

Detailed Description

Defines the run time output arguments for all IVIDDEC2FRONT instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC2FRONT_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC2FRONT_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC2FRONT_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IVIDDEC2FRONT_OutArgs::bytesConsumed

Number of bytes consumed during the process() call.

The documentation for this struct was generated from the following file:
  • split/ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC2FRONT_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC2FRONT_Status Struct Reference
[XDM IVIDDEC2-based Video Decoder Split Interface]

Defines instance status parameters. More...

#include <ividdec2.h>

Collaboration diagram for IVIDDEC2FRONT_Status:
[legend]

Data Fields

XDM_ContextInfo contextInfo
XDAS_Int32 nextPartRequiredFlag
XDAS_Int32 partialExtendedError
IVIDDEC2_Status fullStatus

Detailed Description

Defines instance status parameters.

Remarks:
All fields correspond to latest IVIDDEC2FRONT_Fxns::process() call on the particular instance of the decoder.
See also:
IVIDDEC2FRONT_Fxns::control()

Field Documentation

XDM_ContextInfo IVIDDEC2FRONT_Status::contextInfo

Context info.

Remarks:
Only valid when the cmd issued to control() is XDM_GETCONTEXTINFO.
XDAS_Int32 IVIDDEC2FRONT_Status::nextPartRequiredFlag

Flag indicating whether the next part in the split codec must be called or not.

Remarks:
If the control() call returned IVIDDEC2_EOK, and this nextPartRequiredFlag field is XDAS_TRUE, the application must call the next part in the split codec.
If the control() call returned failure (i.e., something other than IVIDDEC2_EOK), the codec must set this field to XDAS_FALSE. Further information about the failure can be obtained via the partialExtendedError field.
XDAS_Int32 IVIDDEC2FRONT_Status::partialExtendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
Remarks:
This field should be filled by the codec if the control() call does not return IVIDDEC2_EOK. Otherwise, it is an undefined output field.
IVIDDEC2_Status IVIDDEC2FRONT_Status::fullStatus

Complete status results.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
The size field of this structure must be filled by the application before calling control(). This is necessary even if the FRONT codec is unable to complete the request (e.g., the codec sets the nextPartRequiredFlag to XDAS_TRUE) and further parts of the codec must be called. This size field indicates to the codec whether any codec-specific extensions are requested.
The fullStatus.size field should only indicate the size of the [potentially extended] fullStatus structure.
This field should be used if nextPartRequiredFlag is XDAS_FALSE.
This struct, with the exception of the size field, will be populated by the codec. If the control() call returns IVIDDEC2_EOK, the application must inspect the nextPartRequiredFlag field to determine whether it must call the next part or whether this fullStatus field contains the complete results of the control() call.
The fullStatus.data field should not be used to provide buffers to split codecs. In the same way the application provides data buffers to process() via an XDM_Context argument, control() does the same. As a result, the fullStatus.data field is ignored and unused in this struct.
If control() is called with the XDM_GETVERSION command, the application must provide the buffer into which the codec will place its version string in the context->outBuffers[0] field.
The documentation for this struct was generated from the following file:
  • split/ividdec2.h


Codec Engine Application Programming Interface (API): IVIDDEC_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_CodecClassConfig Struct Reference
[VIDDEC Video Decoder Interface]

Definition of VIDDEC codec class configurable parameters. More...

#include <viddec.h>

Data Fields

Bool | manageInBufsCache [16]
Indicates how to manage the inBuf cache.
Bool | manageOutBufsCache [16]
Indicates how to manage the outBuf cache.
Bool | manageDisplayBufsCache [16]
Indicates how to manage the displayBuf cache.

Detailed Description

Definition of VIDDEC codec class configurable parameters.

See also:
VISA_getCodecClassConfig()

Field Documentation

Bool IVIDDEC_CodecClassConfig::manageInBufsCache[16]

Indicates how to manage the inBuf cache.

Remarks:
Array of Bools, indicating whether a particular inBuf should be invalidated prior to calling the codec's process() method.
Bool IVIDDEC_CodecClassConfig::manageOutBufsCache[16]

Indicates how to manage the outBuf cache.

Remarks:
Array of Bools, indicating whether a particular outBuf should be invalidated prior to calling the codec's process() method, and written back after.
Bool IVIDDEC_CodecClassConfig::manageDisplayBufsCache[16]

Indicates how to manage the displayBuf cache.

Remarks:
Array of Bools, indicating whether a particular displayBuf should be writeback invalidated after calling the codec's process() method.
The documentation for this struct was generated from the following file:
  • viddec.h


Codec Engine Application Programming Interface (API): IVIDDEC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_DynamicParams Struct Reference
[XDM IVIDDEC Video Decoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <ividdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 decodeHeader
XDAS_Int32 displayWidth
XDAS_Int32 frameSkipMode

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::control()

Field Documentation

XDAS_Int32 IVIDDEC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC_DynamicParams::decodeHeader

Number of access units to decode.

See also:
XDM_DecMode
XDAS_Int32 IVIDDEC_DynamicParams::displayWidth

Pitch. If set to zero, use the decoded image width. Else, use given display width in pixels.

XDAS_Int32 IVIDDEC_DynamicParams::frameSkipMode

Frame skip mode.

See also:
IVIDEO_FrameSkip
The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDDEC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_Fxns Struct Reference
[XDM IVIDDEC Video Decoder Interface]

Defines all of the operations on IVIDDEC objects. More...

#include <ividdec.h>

Collaboration diagram for IVIDDEC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDDEC_InArgs *inArgs, IVIDDEC_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDDEC_Handle handle, IVIDDEC_Cmd id, IVIDDEC_DynamicParams *params, IVIDDEC_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDDEC objects.

Field Documentation

IALG_Fxns IVIDDEC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDDEC_Fxns::process)(IVIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDDEC_InArgs *inArgs, IVIDDEC_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
inArgs must not be NULL, and must point to a valid IVIDDEC_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDDEC_OutArgs structure.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inBufs or inArgs. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The buffers in inBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IVIDDEC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* IVIDDEC_Fxns::control)(IVIDDEC_Handle handle, IVIDDEC_Cmd id, IVIDDEC_DynamicParams *params, IVIDDEC_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDDEC_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDDEC_Status structure.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IVIDDEC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDDEC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_InArgs Struct Reference
[XDM IVIDDEC Video Decoder Interface]

Defines the input arguments for all IVIDDEC instance process function. More...

#include <ividdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes
XDAS_Int32 inputID

Detailed Description

Defines the input arguments for all IVIDDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

XDAS_Int32 IVIDDEC_InArgs::inputID

The decoder will attach this ID with the corresponding output frames.

Remarks:
This is useful when frames require re-ordering (e.g. B frames).
When there is no re-ordering, IVIDDEC1_OutArgs::outputID will be same as this inputID field.
Zero (0) is not a supported inputID. This value is reserved for cases when there is no output buffer provided in IVIDDEC1_OutArgs::displayBufs.
See also:
IVIDDEC_OutArgs::outputID.
The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDDEC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_Obj Struct Reference
[XDM IVIDDEC Video Decoder Interface]

This must be the first field of all IVIDDEC instance objects. More...

#include <ividdec.h>

Collaboration diagram for IVIDDEC_Obj:
[legend]

Data Fields

struct IVIDDEC_Fxns * fxns

Detailed Description

This must be the first field of all IVIDDEC instance objects.

Field Documentation

struct IVIDDEC_Fxns* IVIDDEC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDDEC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_OutArgs Struct Reference
[XDM IVIDDEC Video Decoder Interface]

Defines the run time output arguments for all IVIDDEC instance objects. More...

#include <ividdec.h>

Collaboration diagram for IVIDDEC_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesConsumed
XDAS_Int32 decodedFrameType
XDAS_Int32 outputID
IVIDEO_BufDesc displayBufs

Detailed Description

Defines the run time output arguments for all IVIDDEC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::process()

Field Documentation

XDAS_Int32 IVIDDEC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.
.

XDAS_Int32 IVIDDEC_OutArgs::bytesConsumed

Bytes consumed.

XDAS_Int32 IVIDDEC_OutArgs::decodedFrameType

Decoded frame type. See IVIDEO_FrameType.

XDAS_Int32 IVIDDEC_OutArgs::outputID

Output ID. Refer to comment IVIDDEC_InArgs::inputID.

IVIDEO_BufDesc IVIDDEC_OutArgs::displayBufs

The decoder fills this structure to denote the buffer pointers for current displayable frames. In case of sequences having I & P frames only, these values are identical to outBufs passed in process().

The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDDEC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_Params Struct Reference
[XDM IVIDDEC Video Decoder Interface]

Defines the creation time parameters for all IVIDDEC instance objects. More...

#include <ividdec.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxFrameRate
XDAS_Int32 maxBitRate
XDAS_Int32 dataEndianness
XDAS_Int32 forceChromaFormat

Detailed Description

Defines the creation time parameters for all IVIDDEC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementation allowing customization with vendor specific parameters.
The size field must be correctly set by the caller.

Field Documentation

XDAS_Int32 IVIDDEC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC_Params::maxHeight

Maximum video height in pixels.

XDAS_Int32 IVIDDEC_Params::maxWidth

Maximum video width in pixels.

XDAS_Int32 IVIDDEC_Params::maxFrameRate

Maximum frame rate in fps * 1000.

XDAS_Int32 IVIDDEC_Params::maxBitRate

Maximum bit rate, bits per second. For example, if bit rate is 10 Mbps, set this field to 10000000

XDAS_Int32 IVIDDEC_Params::dataEndianness

Endianness of input data.

See also:
XDM_DataFormat
XDAS_Int32 IVIDDEC_Params::forceChromaFormat

Force decode in given Chroma format.

See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDDEC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDDEC_Status Struct Reference
[XDM IVIDDEC Video Decoder Interface]

Defines instance status parameters. More...

#include <ividdec.h>

Collaboration diagram for IVIDDEC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 outputHeight
XDAS_Int32 outputWidth
XDAS_Int32 frameRate
XDAS_Int32 bitRate
XDAS_Int32 contentType
XDAS_Int32 outputChromaFormat
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDDEC_Fxns::control()

Field Documentation

XDAS_Int32 IVIDDEC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDDEC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IVIDDEC_Status::outputHeight

Output height in pixels.

XDAS_Int32 IVIDDEC_Status::outputWidth

Output width in pixels.

XDAS_Int32 IVIDDEC_Status::frameRate

Average frame rate in fps * 1000.

XDAS_Int32 IVIDDEC_Status::bitRate

Average bit rate in bits/second.

XDAS_Int32 IVIDDEC_Status::contentType

Video Content type.

See also:
IVIDEO_ContentType
XDAS_Int32 IVIDDEC_Status::outputChromaFormat

Chroma format of output.

See also:
XDM_ChromaFormat
XDM_AlgBufInfo IVIDDEC_Status::bufInfo

Input and output buffer information.

See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • ividdec.h


Codec Engine Application Programming Interface (API): IVIDENC1_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_DynamicParams Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

This structure defines the algorithm parameters that can be modified after creation via control() calls. More...

#include <ividenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 inputHeight
XDAS_Int32 inputWidth
XDAS_Int32 refFrameRate
XDAS_Int32 targetFrameRate
XDAS_Int32 targetBitRate
XDAS_Int32 intraFrameInterval
XDAS_Int32 generateHeader
XDAS_Int32 captureWidth
XDAS_Int32 forceFrame
XDAS_Int32 interFrameInterval
XDAS_Int32 mbDataFlag

Detailed Description

This structure defines the algorithm parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::control()

Field Documentation

XDAS_Int32 IVIDENC1_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC1_DynamicParams::inputHeight

Input frame height.

XDAS_Int32 IVIDENC1_DynamicParams::inputWidth

Input frame width.

XDAS_Int32 IVIDENC1_DynamicParams::refFrameRate

Reference, or input, frame rate in fps * 1000.

Remarks:
For example, if ref frame rate is 30 frames per second, this field will be 30000.
XDAS_Int32 IVIDENC1_DynamicParams::targetFrameRate

Target frame rate in fps * 1000.

Remarks:
For example, if target frame rate is 30 frames per second, this field will be 30000.
XDAS_Int32 IVIDENC1_DynamicParams::targetBitRate

Target bit rate in bits per second.

XDAS_Int32 IVIDENC1_DynamicParams::intraFrameInterval

The number of frames between two I frames. For example, 30.

Remarks:
For example, this field will be:
  • 0 - Only first frame to be intra coded. e.g. IPPPPPP...
  • 1 - No inter frames (all intra frames).
  • 2 - Consecutive IPIPIP... sequence (if no B frames).
  • 3 - IPPIPP... or IPBIPBI... and so on.
XDAS_Int32 IVIDENC1_DynamicParams::generateHeader

Encode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_EncMode
XDAS_Int32 IVIDENC1_DynamicParams::captureWidth

DEFAULT(0): use imagewidth as pitch else use given capture width for pitch provided it is greater than image width.

XDAS_Int32 IVIDENC1_DynamicParams::forceFrame

Force the current (immediate) frame to be encoded as a specific frame type.

Remarks:
For example, this field will be:
  • IVIDEO_NA_FRAME - No forcing of any specific frame type for the frame.
  • IVIDEO_I_FRAME - Force the frame to be encoded as I frame.
  • IVIDEO_IDR_FRAME - Force the frame to be encoded as an IDR frame (specific to H.264 codecs).
  • IVIDEO_P_FRAME - Force the frame to be encoded as a P frame.
  • IVIDEO_B_FRAME - Force the frame to be encoded as a B frame.
See also:
IVIDEO_FrameType.
XDAS_Int32 IVIDENC1_DynamicParams::interFrameInterval

Number of B frames between two reference frames; that is, the number of B frames between two P frames or I/P frames. DEFAULT(0).

Remarks:
For example, this field will be:
  • 0 - to use maxInterFrameInterval.
  • 1 - 0 B frames between two reference frames.
  • 2 - 1 B frame between two reference frames.
  • 3 - 2 B frames between two reference frames.
  • and so on...
See also:
IVIDENC1_Params.maxInterFrameInterval.
XDAS_Int32 IVIDENC1_DynamicParams::mbDataFlag

Flag to indicate that the algorithm should use MB data supplied in additional buffer within inBufs.

The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_Fxns Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

Defines all of the operations on IVIDENC1 objects. More...

#include <ividenc1.h>

Collaboration diagram for IVIDENC1_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs)
Basic video encoding call.
XDAS_Int32(* | control )(IVIDENC1_Handle handle, IVIDENC1_Cmd id, IVIDENC1_DynamicParams *params, IVIDENC1_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDENC1 objects.

Field Documentation

IALG_Fxns IVIDENC1_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDENC1_Fxns::process)(IVIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs)

Basic video encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input video buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
inBufs->numBufs will indicate the total number of input buffers supplied for input frame, and conditionally, the encoders MB data buffer.
If IVIDENC1_DynamicParams::mbDataFlag was set to XDAS_FALSE in a previous control() call, the application only needs to provide the input frame.
If IVIDENC1_DynamicParams::mbDataFlag was set to XDAS_TRUE in a previous control() call, inBufs->bufs[inBufs->numBufs - 1] is a buffer descriptor containing stacked structures of the type IVIDENC1_MbData, one for each macro block.
inArgs must not be NULL, and must point to a valid IVIDENC1_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDENC1_OutArgs structure.
inBufs must not be NULL, and must point to a valid IVIDEO1_BufDescIn structure.
inBufs->bufDesc[0].bufs must not be NULL, and must point to a valid buffer of data that is at least inBufs->bufDesc[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs->buf[0] must not be NULL, and must point to a valid buffer of data that is at least outBufs->bufSizes[0] bytes in length.
The buffers in inBuf and outBuf are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.bufDesc[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must appropriately set/clear the IVIDEO1_BufDescIn::bufDesc[].accessMask field in inBufs to indicate the mode in which each of the buffers in inBufs were read. For example, if the algorithm only read from inBufs.bufDesc[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs are owned by the calling application.
Remarks:
outBufs->bufs[0] may contain the encoded data buffer. See IVIDENC1_OutArgs.encodedBufs for more details.
outBufs->bufs[1], outBufs->bufs[2], and outBufs->bufs[3] are used when providing reconstruction buffers.
Return values:
IVIDENC1_EOK | Success.
IVIDENC1_EFAIL | General failure. See IVIDENC1_Status::extendedError for more detailed further error conditions.
IVIDENC1_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDENC1_Fxns::control)(IVIDENC1_Handle handle, IVIDENC1_Cmd id, IVIDENC1_DynamicParams *params, IVIDENC1_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDENC1_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDENC1_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IVIDENC1_EOK | Success.
IVIDENC1_EFAIL | General failure. See IVIDENC1_Status::extendedError for more detailed further error conditions.
IVIDENC1_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_InArgs Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

Defines the input arguments for all IVIDENC1 instance process function. More...

#include <ividenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 inputID
XDAS_Int32 topFieldFirstFlag

Detailed Description

Defines the input arguments for all IVIDENC1 instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::process()

Field Documentation

XDAS_Int32 IVIDENC1_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC1_InArgs::inputID

Identifier to attach with the corresponding encoded bitstream frames.

Remarks:
This is useful when frames require buffering (e.g. B frames), and to support buffer management.
When there is no re-ordering, IVIDENC1_OutArgs::outputID will be the same as this inputID field.
Zero (0) is not a supported inputID. This value is reserved for cases when there is no output buffer provided.
See also:
IVIDENC1_OutArgs::outputID.
XDAS_Int32 IVIDENC1_InArgs::topFieldFirstFlag

Flag to indicate the field order in interlaced content.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
This field is only applicable to the input image buffer.
This field is only applicable for interlaced content, not progressive.
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_MbData Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_MbData Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

Defines the structure that contains macroblock related encoding parameter estimates. More...

#include <ividenc1.h>

Data Fields

XDAS_Int32 mbMode
XDAS_Int32 QP
XDAS_Int32 mvFwdXY
XDAS_Int32 mvBwdXY

Detailed Description

Defines the structure that contains macroblock related encoding parameter estimates.

Remarks:
An array of IVIDENC1_MbData is provided within the inBufs parameter to IVIDENC1_Fxns::process() when IVIDENC1_DynamicParams::mbDataFlag is set.
See also:
IVIDENC1_DynamicParams::mbDataFlag
IVIDENC1_Fxns::process()
IVIDENC1_Fxns::control()

Field Documentation

XDAS_Int32 IVIDENC1_MbData::mbMode

MB encoding mode

Remarks:
Valid values are:
  • 0x00 for skip macroblock
  • 0x01 for I Frame macroblock
  • 0x02 for P Frame macroblock
  • 0x03 for B Frame macroblock
  • 0x04 for I Field macroblock
  • 0x05 for P Field macroblock
  • 0x06 for B Field macroblock
  • 0xFF for mbMode not specified
XDAS_Int32 IVIDENC1_MbData::QP

QP estimate.

Remarks:
A value of 0xFF for QP is not specified.
XDAS_Int32 IVIDENC1_MbData::mvFwdXY

Forward Motion vector estimate.

Remarks:
If MVx (XDAS_Int16) and MVy (XDAS_Int16) are the motion vectors in the x and y directions, in quarter pel units, then
   mvFwdXY = ((MVx & 0x0000FFFF) << 16) |
              (MVy & 0x0000FFFF);
A value of 0x7FFF7FFF to indicate mvFwdXY is not specified.
XDAS_Int32 IVIDENC1_MbData::mvBwdXY

Backward motion vector estimate.

Remarks:
The format is the same as IVIDENC1_MbData::mvFwdXY.
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_Obj Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

This must be the first field of all IVIDENC1 instance objects. More...

#include <ividenc1.h>

Collaboration diagram for IVIDENC1_Obj:
[legend]

Data Fields

struct IVIDENC1_Fxns * fxns

Detailed Description

This must be the first field of all IVIDENC1 instance objects.

Field Documentation

struct IVIDENC1_Fxns* IVIDENC1_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_OutArgs Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

Defines the run time output arguments for all IVIDENC1 instance objects. More...

#include <ividenc1.h>

Collaboration diagram for IVIDENC1_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesGenerated
XDAS_Int32 encodedFrameType
XDAS_Int32 inputFrameSkip
XDAS_Int32 outputID
XDM1_SingleBufDesc encodedBuf
IVIDEO1_BufDesc reconBufs

Detailed Description

Defines the run time output arguments for all IVIDENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::process()

Field Documentation

XDAS_Int32 IVIDENC1_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC1_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IVIDENC1_OutArgs::bytesGenerated

Number of bytes generated during the IVIDENC1_Fxns::process() call.

XDAS_Int32 IVIDENC1_OutArgs::encodedFrameType

Video frame types.

Remarks:
For the various IVIDEO_xy_FRAME values, this frame type is interlaced where both top and bottom fields are provided in a single frame. The first field is an "x" frame, the second field is "y" field.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_FrameType
XDAS_Int32 IVIDENC1_OutArgs::inputFrameSkip

Video frame skipping modes.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_SkipMode
XDAS_Int32 IVIDENC1_OutArgs::outputID

Output ID corresponding with the encoded buffer. This shall also be used to free up the corresponding image buffer for further use by client application code.

Remarks:
This will be set to zero when there is no encoded buffer for passing to client application.
See also:
IVIDENC1_InArgs::inputID.
XDM1_SingleBufDesc IVIDENC1_OutArgs::encodedBuf

The encoder fills the buffer with the encoded bitstream. In case of sequences having I & P frames only, these values are identical to outBufs passed in IVIDENC1_Fxns::process().

Remarks:
The encodedbuf.bufSize field returned corresponds to the actual valid bytes available in the buffer.
The bitstream is in encoded order.
outputID and encodedBuf together provide info relating to the corresponding encoded image buffer.
IVIDEO1_BufDesc IVIDENC1_OutArgs::reconBufs

Reconstruction frames.

Remarks:
These output buffers correspond to outBufs->bufs[1], outBufs->bufs[2], and outBufs->bufs[3].
reconBufs.bufDesc[0].buf is equivalent to outBufs->bufs[1], reconBufs.bufDesc[1].buf is equivalent to outBufs->bufs[2], and reconBufs.bufDesc[2].buf is equivalent to outBufs->bufs[3].
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_Params Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

Defines the creation time parameters for all IVIDENC1 instance objects. More...

#include <ividenc1.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 encodingPreset
XDAS_Int32 rateControlPreset
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxFrameRate
XDAS_Int32 maxBitRate
XDAS_Int32 dataEndianness
XDAS_Int32 maxInterFrameInterval
XDAS_Int32 inputChromaFormat
XDAS_Int32 inputContentType
XDAS_Int32 reconChromaFormat

Detailed Description

Defines the creation time parameters for all IVIDENC1 instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IVIDENC1_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC1_Params::encodingPreset

Encoding preset.

XDAS_Int32 IVIDENC1_Params::rateControlPreset

Video rate control presets.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_RateControlPreset
XDAS_Int32 IVIDENC1_Params::maxHeight

Maximum video height in pixels.

XDAS_Int32 IVIDENC1_Params::maxWidth

Maximum video width in pixels.

XDAS_Int32 IVIDENC1_Params::maxFrameRate

Maximum frame rate in fps * 1000. For example, if max frame rate is 30 frames per second, set this field to 30000.

XDAS_Int32 IVIDENC1_Params::maxBitRate

Maximum bit rate, bits per second.

XDAS_Int32 IVIDENC1_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IVIDENC1_Params::maxInterFrameInterval

I to P frame distance. e.g. = 1 if no B frames, 2 to insert one B frame.

Remarks:
This is used for setting the maximum number of B frames between two refererence frames.
XDAS_Int32 IVIDENC1_Params::inputChromaFormat

Chroma format for the input buffer.

See also:
XDM_ChromaFormat
XDAS_Int32 IVIDENC1_Params::inputContentType

Video content type of the buffer being encoded.

See also:
IVIDEO_ContentType
XDAS_Int32 IVIDENC1_Params::reconChromaFormat

Chroma formats for the reconstruction buffers.

Remarks:
The application should set this to XDM_CHROMA_NA if reconstruction buffers are not required.
See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC1_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC1_Status Struct Reference
[XDM IVIDENC1 Video Encoder Interface]

Defines instance status parameters. More...

#include <ividenc1.h>

Collaboration diagram for IVIDENC1_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC1_Fxns::control()

Field Documentation

XDAS_Int32 IVIDENC1_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC1_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IVIDENC1_Status::data

Buffer descriptor for data passing.

Remarks:
If this field is not used, the application must set data.buf to NULL.
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the IVIDENC1_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDM_AlgBufInfo IVIDENC1_Status::bufInfo

Input and output buffer information.

Remarks:
This field provides the application with the algorithm's buffer requirements. The requirements may vary depending on the current configuration of the algorithm instance.
When configured to generate reconstruction buffers (see IVIDENC1_Params::reconChromaFormat), the recontruction buffer information will also be reported here.
See also:
IVIDENC1_Params
XDM_AlgBufInfo
IVIDENC1_Fxns::process()
The documentation for this struct was generated from the following file:
  • ividenc1.h


Codec Engine Application Programming Interface (API): IVIDENC_CodecClassConfig Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_CodecClassConfig Struct Reference
[VIDENC Video Encoder Interface]

Definition of IVIDENC codec class configurable parameters. More...

#include <videnc.h>

Data Fields

Bool | manageInBufsCache [16]
Bool | manageOutBufsCache [16]
Bool | manageReconBufsCache [16]

Detailed Description

Definition of IVIDENC codec class configurable parameters.

See also:
VISA_getCodecClassConfig()

Field Documentation

Bool IVIDENC_CodecClassConfig::manageInBufsCache[16]
Bool IVIDENC_CodecClassConfig::manageOutBufsCache[16]
Bool IVIDENC_CodecClassConfig::manageReconBufsCache[16]
The documentation for this struct was generated from the following file:
  • videnc.h


Codec Engine Application Programming Interface (API): IVIDENC_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_DynamicParams Struct Reference
[XDM IVIDENC Video Encoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <ividenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 inputHeight
XDAS_Int32 inputWidth
XDAS_Int32 refFrameRate
XDAS_Int32 targetFrameRate
XDAS_Int32 targetBitRate
XDAS_Int32 intraFrameInterval
XDAS_Int32 generateHeader
XDAS_Int32 captureWidth
XDAS_Int32 forceIFrame

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::control()

Field Documentation

XDAS_Int32 IVIDENC_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC_DynamicParams::inputHeight

Input frame height.

XDAS_Int32 IVIDENC_DynamicParams::inputWidth

Input frame width.

XDAS_Int32 IVIDENC_DynamicParams::refFrameRate

Reference or input frame rate * 1000.

XDAS_Int32 IVIDENC_DynamicParams::targetFrameRate

Target frame rate * 1000.

XDAS_Int32 IVIDENC_DynamicParams::targetBitRate

Target bit rate in bits per second.

XDAS_Int32 IVIDENC_DynamicParams::intraFrameInterval

I frame interval. For example, 30.

XDAS_Int32 IVIDENC_DynamicParams::generateHeader

Encode entire access unit or only header.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_EncMode
XDAS_Int32 IVIDENC_DynamicParams::captureWidth

DEFAULT(0): use imagewidth as pitch else use given capture width for pitch provided it is greater than image width.

XDAS_Int32 IVIDENC_DynamicParams::forceIFrame

Force the current frame to be encoded as an I-frame.

The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDENC_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_Fxns Struct Reference
[XDM IVIDENC Video Encoder Interface]

Defines all of the operations on IVIDENC objects. More...

#include <ividenc.h>

Collaboration diagram for IVIDENC_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs)
Basic video encoding call.
XDAS_Int32(* | control )(IVIDENC_Handle handle, IVIDENC_Cmd id, IVIDENC_DynamicParams *params, IVIDENC_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDENC objects.

Field Documentation

IALG_Fxns IVIDENC_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDENC_Fxns::process)(IVIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs)

Basic video encoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
inArgs must not be NULL, and must point to a valid IVIDENC_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDENC_OutArgs structure.
The buffers in inBufs and outBufs are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The buffers in inBufs are owned by the calling application.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IVIDENC_OutArgs::extendedError for more detailed further error conditions.
XDAS_Int32(* IVIDENC_Fxns::control)(IVIDENC_Handle handle, IVIDENC_Cmd id, IVIDENC_DynamicParams *params, IVIDENC_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDENC_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDENC_Status structure.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
Return values:
IALG_EOK | Success.
IALG_EFAIL | Failure. See IVIDENC_Status::extendedError for more detailed further error conditions.
The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDENC_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_InArgs Struct Reference
[XDM IVIDENC Video Encoder Interface]

Defines the input arguments for all IVIDDEC instance process function. More...

#include <ividenc.h>

Data Fields

XDAS_Int32 size

Detailed Description

Defines the input arguments for all IVIDDEC instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::process()

Field Documentation

XDAS_Int32 IVIDENC_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDENC_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_Obj Struct Reference
[XDM IVIDENC Video Encoder Interface]

This must be the first field of all IVIDENC instance objects. More...

#include <ividenc.h>

Collaboration diagram for IVIDENC_Obj:
[legend]

Data Fields

struct IVIDENC_Fxns * fxns

Detailed Description

This must be the first field of all IVIDENC instance objects.

Field Documentation

struct IVIDENC_Fxns* IVIDENC_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDENC_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_OutArgs Struct Reference
[XDM IVIDENC Video Encoder Interface]

Defines the run time output arguments for all IVIDENC instance objects. More...

#include <ividenc.h>

Collaboration diagram for IVIDENC_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bytesGenerated
XDAS_Int32 encodedFrameType
XDAS_Int32 inputFrameSkip
IVIDEO_BufDesc reconBufs

Detailed Description

Defines the run time output arguments for all IVIDENC instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::process()

Field Documentation

XDAS_Int32 IVIDENC_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IVIDENC_OutArgs::bytesGenerated

Bytes generated by the encode.

XDAS_Int32 IVIDENC_OutArgs::encodedFrameType

Video frame types.

Remarks:
For the various IVIDEO_xy_FRAME values, this frame type is interlaced where both top and bottom fields are provided in a single frame. The first field is an "x" frame, the second field is "y" field.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_FrameType
XDAS_Int32 IVIDENC_OutArgs::inputFrameSkip

Frame Skip Mode. See IVIDEO_SkipMode.

IVIDEO_BufDesc IVIDENC_OutArgs::reconBufs

Reconstruction Frames.

The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDENC_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_Params Struct Reference
[XDM IVIDENC Video Encoder Interface]

Defines the creation time parameters for all IVIDENC instance objects. More...

#include <ividenc.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 encodingPreset
XDAS_Int32 rateControlPreset
XDAS_Int32 maxHeight
XDAS_Int32 maxWidth
XDAS_Int32 maxFrameRate
XDAS_Int32 maxBitRate
XDAS_Int32 dataEndianness
XDAS_Int32 maxInterFrameInterval
XDAS_Int32 inputChromaFormat
XDAS_Int32 inputContentType

Detailed Description

Defines the creation time parameters for all IVIDENC instance objects.

Remarks:
The application should set the parameters to 0 to use the algorithm's default values.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IVIDENC_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC_Params::encodingPreset

Encoding preset.

XDAS_Int32 IVIDENC_Params::rateControlPreset

Video rate control presets.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_RateControlPreset
XDAS_Int32 IVIDENC_Params::maxHeight

Maximum height.

XDAS_Int32 IVIDENC_Params::maxWidth

Maximum width.

XDAS_Int32 IVIDENC_Params::maxFrameRate

Maximum frame rate * 1000.

XDAS_Int32 IVIDENC_Params::maxBitRate

Maximum bit rate, bits per second.

XDAS_Int32 IVIDENC_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
XDAS_Int32 IVIDENC_Params::maxInterFrameInterval

I to P frame distance. e.g. = 1 if no B frames, 2 to insert one B frame.

XDAS_Int32 IVIDENC_Params::inputChromaFormat

Chroma format for the input buffer.

See also:
XDM_ChromaFormat
XDAS_Int32 IVIDENC_Params::inputContentType

Video content type of the buffer being encoded.

See also:
IVIDEO_ContentType
The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDENC_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDENC_Status Struct Reference
[XDM IVIDENC Video Encoder Interface]

Defines instance status parameters (read-only). More...

#include <ividenc.h>

Collaboration diagram for IVIDENC_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters (read-only).

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDENC_Fxns::control()

Field Documentation

XDAS_Int32 IVIDENC_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDENC_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM_AlgBufInfo IVIDENC_Status::bufInfo

Input & output buffer information. See XDM_AlgBufInfo.

The documentation for this struct was generated from the following file:
  • ividenc.h


Codec Engine Application Programming Interface (API): IVIDEO1_BufDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDEO1_BufDesc Struct Reference
[XDM Video Interface]

Detailed buffer descriptor for video buffers. More...

#include <ivideo.h>

Collaboration diagram for IVIDEO1_BufDesc:
[legend]

Data Fields

XDAS_Int32 numBufs
XDAS_Int32 frameWidth
XDAS_Int32 frameHeight
XDAS_Int32 framePitch
XDM1_SingleBufDesc bufDesc [3]
XDAS_Int32 extendedError
XDAS_Int32 frameType
XDAS_Int32 topFieldFirstFlag
XDAS_Int32 repeatFirstFieldFlag
XDAS_Int32 frameStatus
XDAS_Int32 repeatFrame
XDAS_Int32 contentType
XDAS_Int32 chromaFormat

Detailed Description

Detailed buffer descriptor for video buffers.

Field Documentation

XDAS_Int32 IVIDEO1_BufDesc::numBufs

Number of buffers in bufDesc[].

XDAS_Int32 IVIDEO1_BufDesc::frameWidth

Width of the video frame.

XDAS_Int32 IVIDEO1_BufDesc::frameHeight

Height of the video frame.

XDAS_Int32 IVIDEO1_BufDesc::framePitch

Frame pitch used to store the frame.

Remarks:
This field can also be used to indicate the padded width.
XDM1_SingleBufDesc IVIDEO1_BufDesc::bufDesc[3]

Picture buffers.

XDAS_Int32 IVIDEO1_BufDesc::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IVIDEO1_BufDesc::frameType

Video frame types.

Remarks:
For the various IVIDEO_xy_FRAME values, this frame type is interlaced where both top and bottom fields are provided in a single frame. The first field is an "x" frame, the second field is "y" field.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_FrameType
XDAS_Int32 IVIDEO1_BufDesc::topFieldFirstFlag

Flag to indicate when the application should display the top field first.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
This field is only applicable for interlaced content, not progressive.
This field does not apply to encoder recon bufs.
XDAS_Int32 IVIDEO1_BufDesc::repeatFirstFieldFlag

Flag to indicate when the first field should be repeated.

Remarks:
Valid values are XDAS_TRUE and XDAS_FALSE.
This field is only applicable for interlaced content, not progressive.
This field does not apply to encoder recon bufs.
XDAS_Int32 IVIDEO1_BufDesc::frameStatus

Video output buffer status.

Remarks:
Ownership of the buffers, either by application or algorithm, is conveyed via these values.
This reflects the status of ALL output buffers. For example, if video decoded output is in 4:2:0 format, all the 3 output buffers' status is described by this value. Similarly, for 4:2:2 formatted buffers, this value describes the single buffer's status.
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_OutputFrameStatus
Remarks:
This field does not apply to encoder recon bufs.
XDAS_Int32 IVIDEO1_BufDesc::repeatFrame

Number of times the display process needs to repeat the displayed progressive frame.

Remarks:
This information is useful for progressive content when the decoder expects the display process to repeat the displayed frame for a certain number of times. This is useful for pulldown (frame/field repetition by display system) support where the display frame rate is increased without increasing the decode frame rate.
The default value is 0.
This field does not apply to encoder recon bufs.
XDAS_Int32 IVIDEO1_BufDesc::contentType

Content type of the buffer.

Remarks:
This is useful when the content is both interlaced and progressive. The display process can use this field to determine how to render the display buffer.
See also:
IVIDEO_ContentType
XDAS_Int32 IVIDEO1_BufDesc::chromaFormat

Chroma formats.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
XDM_ChromaFormat
The documentation for this struct was generated from the following file:
  • ivideo.h


Codec Engine Application Programming Interface (API): IVIDEO1_BufDescIn Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDEO1_BufDescIn Struct Reference
[XDM Video Interface]

Buffer descriptor for input video buffers. More...

#include <ivideo.h>

Collaboration diagram for IVIDEO1_BufDescIn:
[legend]

Data Fields

XDAS_Int32 numBufs
XDAS_Int32 frameWidth
XDAS_Int32 frameHeight
XDAS_Int32 framePitch
XDM1_SingleBufDesc bufDesc [XDM_MAX_IO_BUFFERS]

Detailed Description

Buffer descriptor for input video buffers.

Field Documentation

XDAS_Int32 IVIDEO1_BufDescIn::numBufs

Number of buffers in bufDesc[].

XDAS_Int32 IVIDEO1_BufDescIn::frameWidth

Width of the video frame.

XDAS_Int32 IVIDEO1_BufDescIn::frameHeight

Height of the video frame.

XDAS_Int32 IVIDEO1_BufDescIn::framePitch

Frame pitch used to store the frame.

Remarks:
This field can also be used to indicate the padded width.
XDM1_SingleBufDesc IVIDEO1_BufDescIn::bufDesc[XDM_MAX_IO_BUFFERS]

Picture buffers.

The documentation for this struct was generated from the following file:
  • ivideo.h


Codec Engine Application Programming Interface (API): IVIDEO_BufDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDEO_BufDesc Struct Reference
[XDM Video Interface]

Buffer descriptor for video buffers. More...

#include <ivideo.h>

Data Fields

XDAS_Int32 numBufs
XDAS_Int32 width
XDAS_Int8 * | bufs [XDM_MAX_IO_BUFFERS]
XDAS_Int32 | bufSizes [XDM_MAX_IO_BUFFERS]

Detailed Description

Buffer descriptor for video buffers.

Field Documentation

XDAS_Int32 IVIDEO_BufDesc::numBufs

Number of buffers.

XDAS_Int32 IVIDEO_BufDesc::width

Added width of a video frame.

XDAS_Int8* IVIDEO_BufDesc::bufs[XDM_MAX_IO_BUFFERS]

Pointer to vector containing buffer addresses.

XDAS_Int32 IVIDEO_BufDesc::bufSizes[XDM_MAX_IO_BUFFERS]

Size of each buffer in 8-bit bytes.

The documentation for this struct was generated from the following file:
  • ivideo.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_DynamicParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_DynamicParams Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

This structure defines the codec parameters that can be modified after creation via control() calls. More...

#include <ividtranscode.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 readHeaderOnlyFlag
XDAS_Int32 | keepInputResolutionFlag [2]
XDAS_Int32 | outputHeight [2]
XDAS_Int32 | outputWidth [2]
XDAS_Int32 | keepInputFrameRateFlag [2]
XDAS_Int32 inputFrameRate
XDAS_Int32 | outputFrameRate [2]
XDAS_Int32 | targetBitRate [2]
XDAS_Int32 | rateControl [2]
XDAS_Int32 | keepInputGOPFlag [2]
XDAS_Int32 | intraFrameInterval [2]
XDAS_Int32 | interFrameInterval [2]
XDAS_Int32 | forceFrame [2]
XDAS_Int32 | frameSkipTranscodeFlag [2]

Detailed Description

This structure defines the codec parameters that can be modified after creation via control() calls.

Remarks:
It is not necessary that a given implementation support all dynamic parameters to be configurable at run time. If a particular algorithm does not support run-time updates to a parameter that the application is attempting to change at runtime, it may indicate this as an error.
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::control()

Field Documentation

XDAS_Int32 IVIDTRANSCODE_DynamicParams::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDTRANSCODE_DynamicParams::readHeaderOnlyFlag

Read the seq header, populate outargs, and return.

Remarks:
Possible values XDAS_TRUE, XDAS_FALSE
XDAS_Int32 IVIDTRANSCODE_DynamicParams::keepInputResolutionFlag[2]

Flag for each transcoded stream to indicate if the output frame resolution is to be kept equal to the input frame resolution (i.e. no resolution change).

Remarks:
Possible values XDAS_TRUE, XDAS_FALSE
XDAS_Int32 IVIDTRANSCODE_DynamicParams::outputHeight[2]

Output frame height for each of the transcoded outputs.

Remarks:
Used for scaling.
This field is ignored when the keepInputResolutionFlag is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::outputWidth[2]

Output frame for each of the transcoded outputs.

Remarks:
Used for scaling.
This field is ignored when the keepInputResolution is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::keepInputFrameRateFlag[2]

Flag for each transcoded stream to indicate if the input frame rate is to be maintained (i.e., no frame rate change).

Remarks:
Possible values XDAS_TRUE, XDAS_FALSE
XDAS_Int32 IVIDTRANSCODE_DynamicParams::inputFrameRate

Reference, or input, frame rate in fps * 1000.

Remarks:
For example, if ref frame rate is 30 frames per second, this field will be 30000.
This field is ignored when the keepInputFramerate field is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::outputFrameRate[2]

Target frame rate in fps * 1000, for each of the transcoded outputs.

Remarks:
For example, if target frame rate is 30 frames per second, this field will be 30000.
This field is ignored when the keepInputFramerate field is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::targetBitRate[2]

Target bit rate in bits per second, for each of the transcoded outputs.

XDAS_Int32 IVIDTRANSCODE_DynamicParams::rateControl[2]

Rate control related selection for each of the transcoded outputs.

See also:
IVIDEO_RateControlPreset
XDAS_Int32 IVIDTRANSCODE_DynamicParams::keepInputGOPFlag[2]

Retain the input GOP structure (to the extent possible) flag for each transcoded output.

Remarks:
Possible values are XDAS_TRUE, and XDAS_FALSE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::intraFrameInterval[2]

I frame interval for each of the transcoded outputs.

Remarks:
For example, this field will be:
  • 0 - Only first frame to be intra coded. e.g. IPPPPPP...
  • 1 - No inter frames (all intra frames).
  • 2 - Consecutive IPIPIP... sequence (if no B frames).
  • 3 - IPPIPP... or IPBIPBI... and so on.
This field is ignored when the keepInputGOP field is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::interFrameInterval[2]

Number of B frames between two reference frames for each of the transcoded output.

Remarks:
For example, this field will be:
  • 0 - to use maxInterFrameInterval.
  • 1 - 0 B frames between two reference frames.
  • 2 - 1 B frame between two reference frames.
  • 3 - 2 B frames between two reference frames.
  • and so on...
See also:
IVIDTRANSCODE_Params.maxInterFrameInterval.
Remarks:
This field is ignored when the keepInputGOP field is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::forceFrame[2]

Force the current (immediate) frame within the specific transcoded output to be encoded as a specific frame type.

Remarks:
For example, this field will be:
  • IVIDEO_NA_FRAME - No forcing of any specific frame type for the frame.
  • IVIDEO_I_FRAME - Force the frame to be encoded as I frame.
  • IVIDEO_IDR_FRAME - Force the frame to be encoded as an IDR frame (specific to H.264 codecs).
  • IVIDEO_P_FRAME - Force the frame to be encoded as a P frame.
  • IVIDEO_B_FRAME - Force the frame to be encoded as a B frame.
See also:
IVIDEO_FrameType.
Remarks:
This field is ignored when the keepInputGOPFlag field is set to XDAS_TRUE.
XDAS_Int32 IVIDTRANSCODE_DynamicParams::frameSkipTranscodeFlag[2]

A flag per transcoded output to enforce a frame skip.

Remarks:
Possible values XDAS_TRUE, XDAS_FALSE
This field is ignored when the keepInputGOPFlag field is set to XDAS_TRUE.
See also:
IVIDEO_FrameSkipTranscode
The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_Fxns Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_Fxns Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

Defines all of the operations on IVIDTRANSCODE objects. More...

#include <ividtranscode.h>

Collaboration diagram for IVIDTRANSCODE_Fxns:
[legend]

Data Fields

IALG_Fxns ialg
XDAS_Int32(* | process )(IVIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs, IVIDTRANSCODE_OutArgs *outArgs)
Basic video decoding call.
XDAS_Int32(* | control )(IVIDTRANSCODE_Handle handle, IVIDTRANSCODE_Cmd id, IVIDTRANSCODE_DynamicParams *params, IVIDTRANSCODE_Status *status)
Control behavior of an algorithm.

Detailed Description

Defines all of the operations on IVIDTRANSCODE objects.

Field Documentation

IALG_Fxns IVIDTRANSCODE_Fxns::ialg

XDAIS algorithm interface.

See also:
IALG_Fxns
XDAS_Int32(* IVIDTRANSCODE_Fxns::process)(IVIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs, IVIDTRANSCODE_OutArgs *outArgs)

Basic video decoding call.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in,out] | inBufs | Input buffer descriptors.
[in,out] | outBufs | Output buffer descriptors. The algorithm may modify the output buffer pointers.
[in] | inArgs | Input arguments. This is a required parameter.
[out] | outArgs | Ouput results. This is a required parameter.
Remarks:
process() is a blocking call. When process() returns, the algorithm's processing is complete.
Precondition:
inArgs must not be NULL, and must point to a valid IVIDTRANSCODE_InArgs structure.
outArgs must not be NULL, and must point to a valid IVIDTRANSCODE_OutArgs structure.
inBufs must not be NULL, and must point to a valid XDM1_BufDesc structure.
inBufs->descs[0].buf must not be NULL, and must point to a valid buffer of data that is at least inBufs->descs[0].bufSize bytes in length.
outBufs must not be NULL, and must point to a valid XDM_BufDesc structure.
outBufs->buf[0] must not be NULL, and must point to a valid buffer of data that is at least outBufs->bufSizes[0] bytes in length.
The buffers in inBuf and outBuf are physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of inArgs.
The algorithm must not modify the contents of inBufs, with the exception of inBufs.bufDesc[].accessMask. That is, the data and buffers pointed to by these parameters must be treated as read-only.
The algorithm must modify the contents of inBufs->descs[].accessMask and appropriately indicate the mode in which each of the buffers in inBufs were read. For example, if the algorithm only read from inBufs.descs[0].buf using the algorithm processor, it could utilize XDM_SETACCESSMODE_READ to update the appropriate accessMask fields. The application may utilize these returned values to appropriately manage cache.
The buffers in inBufs are owned by the calling application.
Return values:
IVIDTRANSCODE_EOK | Success.
IVIDTRANSCODE_EFAIL | General failure. See IVIDTRANSCODE_Status::extendedError for more detailed further error conditions.
IVIDTRANSCODE_EUNSUPPORTED | Request is unsupported.
XDAS_Int32(* IVIDTRANSCODE_Fxns::control)(IVIDTRANSCODE_Handle handle, IVIDTRANSCODE_Cmd id, IVIDTRANSCODE_DynamicParams *params, IVIDTRANSCODE_Status *status)

Control behavior of an algorithm.

Parameters:
[in] | handle | Handle to an algorithm instance.
[in] | id | Command id. See XDM_CmdId.
[in] | params | Dynamic parameters. This is a required parameter.
[out] | status | Output results. This is a required parameter.
Precondition:
handle must be a valid algorithm instance handle.
params must not be NULL, and must point to a valid IVIDTRANSCODE_DynamicParams structure.
status must not be NULL, and must point to a valid IVIDTRANSCODE_Status structure.
If a buffer is provided in the status->data field, it must be physically contiguous and owned by the calling application.
Postcondition:
The algorithm must not modify the contents of params. That is, the data pointed to by this parameter must be treated as read-only.
If a buffer was provided in the status->data field, it is owned by the calling application.
Return values:
IVIDTRANSCODE_EOK | Success.
IVIDTRANSCODE_EFAIL | General failure. See IVIDTRANSCODE_Status::extendedError for more detailed further error conditions.
IVIDTRANSCODE_EUNSUPPORTED | Request is unsupported.
The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_InArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_InArgs Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

Defines the input arguments for all IVIDTRANSCODE instance process function. More...

#include <ividtranscode.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numBytes
XDAS_Int32 inputID

Detailed Description

Defines the input arguments for all IVIDTRANSCODE instance process function.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::process()

Field Documentation

XDAS_Int32 IVIDTRANSCODE_InArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDTRANSCODE_InArgs::numBytes

Size of input data in bytes, provided to the algorithm for decoding.

XDAS_Int32 IVIDTRANSCODE_InArgs::inputID

The decoder will attach this ID with the corresponding output frames.

The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_Obj Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_Obj Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

This must be the first field of all IVIDTRANSCODE instance objects. More...

#include <ividtranscode.h>

Collaboration diagram for IVIDTRANSCODE_Obj:
[legend]

Data Fields

struct IVIDTRANSCODE_Fxns * fxns

Detailed Description

This must be the first field of all IVIDTRANSCODE instance objects.

Field Documentation

struct IVIDTRANSCODE_Fxns* IVIDTRANSCODE_Obj::fxns [read]
The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_OutArgs Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_OutArgs Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

Defines the run time output arguments for all IVIDTRANSCODE instance objects. More...

#include <ividtranscode.h>

Collaboration diagram for IVIDTRANSCODE_OutArgs:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDAS_Int32 bitsConsumed
XDAS_Int32 | bitsGenerated [2]
XDAS_Int32 decodedPictureType
XDAS_Int32 decodedPictureStructure
XDAS_Int32 | encodedPictureType [2]
XDAS_Int32 | encodedPictureStructure [2]
XDAS_Int32 decodedHeight
XDAS_Int32 decodedWidth
XDAS_Int32 | outputID [2]
XDAS_Int32 | inputFrameSkipTranscodeFlag [2]
XDM1_SingleBufDesc | encodedBuf [2]
XDAS_Int32 outBufsInUseFlag

Detailed Description

Defines the run time output arguments for all IVIDTRANSCODE instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::process()

Field Documentation

XDAS_Int32 IVIDTRANSCODE_OutArgs::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDTRANSCODE_OutArgs::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDAS_Int32 IVIDTRANSCODE_OutArgs::bitsConsumed

Number of bits consumed during the IVIDTRANSCODE_Fxns.process() call.

XDAS_Int32 IVIDTRANSCODE_OutArgs::bitsGenerated[2]

Number of bits generated during the IVIDTRANSCODE_Fxns.process() call for each transcode output.

XDAS_Int32 IVIDTRANSCODE_OutArgs::decodedPictureType

Type of the decoded picture.

See also:
IVIDEO_PictureType
XDAS_Int32 IVIDTRANSCODE_OutArgs::decodedPictureStructure

Structure of the decoded picture.

See also:
IVIDEO_ContentType
XDAS_Int32 IVIDTRANSCODE_OutArgs::encodedPictureType[2]

Type of the encoded picture for each transcode output.

See also:
IVIDEO_PictureType
XDAS_Int32 IVIDTRANSCODE_OutArgs::encodedPictureStructure[2]

Structure of the encoded picture for each transcode output.

See also:
IVIDEO_ContentType
XDAS_Int32 IVIDTRANSCODE_OutArgs::decodedHeight

Decoded frame height

XDAS_Int32 IVIDTRANSCODE_OutArgs::decodedWidth

Decoded frame width

XDAS_Int32 IVIDTRANSCODE_OutArgs::outputID[2]

This is the ID of the encoded buffer for each output. This field is also used by the client to identify the outBufs supplied with the IVIDTRANSCODE_Fxns.process() call that can be reused.

Remarks:
This will be set to zero when there is no encoded buffer for passing to client application.
See also:
IVIDTRANSCODE_InArgs::inputID.
XDAS_Int32 IVIDTRANSCODE_OutArgs::inputFrameSkipTranscodeFlag[2]

Flag to indicate if the current frame was skipped in specific transcode outputs.

Remarks:
Possible values XDAS_TRUE, XDAS_FALSE
XDM1_SingleBufDesc IVIDTRANSCODE_OutArgs::encodedBuf[2]

When outputID for a specific transcode output is non-zero, the corresponding encoded buffer related information is populated here.

XDAS_Int32 IVIDTRANSCODE_OutArgs::outBufsInUseFlag

Flag to indicate that the outBufs provided with the IVIDTRANSCODE_Fxns.process() call are in use. No outBufs are required to be supplied with the next IVIDTRANSCODE_Fxns.process() call.

Remarks:
Possible values XDAS_TRUE, XDAS_FALSE
The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_Params Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_Params Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

Defines the creation time parameters for all IVIDTRANSCODE instance objects. More...

#include <ividtranscode.h>

Data Fields

XDAS_Int32 size
XDAS_Int32 numOutputStreams
XDAS_Int32 formatInput
XDAS_Int32 | formatOutput [2]
XDAS_Int32 maxHeightInput
XDAS_Int32 maxWidthInput
XDAS_Int32 maxFrameRateInput
XDAS_Int32 maxBitRateInput
XDAS_Int32 | maxHeightOutput [2]
XDAS_Int32 | maxWidthOutput [2]
XDAS_Int32 | maxFrameRateOutput [2]
XDAS_Int32 | maxBitRateOutput [2]
XDAS_Int32 dataEndianness

Detailed Description

Defines the creation time parameters for all IVIDTRANSCODE instance objects.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.

Field Documentation

XDAS_Int32 IVIDTRANSCODE_Params::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDTRANSCODE_Params::numOutputStreams

Number of output transcoded streams This allows the possibility of generating more than one transcoded bit-streams from a single incoming bit-stream.

XDAS_Int32 IVIDTRANSCODE_Params::formatInput

Video Format types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_Format
Remarks:
This is the video standard of incoming bit stream.
XDAS_Int32 IVIDTRANSCODE_Params::formatOutput[2]

Video Format types.

Remarks:
This enumeration data type should not be used for storage, but rather only for its constant values.
This enumeration defines a base set of values. Algorithms which require proprietary enumeration values may define them - much like extended fields in base structures. These extended enums should be between XDM_CUSTOMENUMBASE and 0x7FFF.
See also:
XDM_CUSTOMENUMBASE

See also:
IVIDEO_Format
Remarks:
This array indicates the video standard for each of the transcoded bit streams.
XDAS_Int32 IVIDTRANSCODE_Params::maxHeightInput

Maximum video height in pixels.

XDAS_Int32 IVIDTRANSCODE_Params::maxWidthInput

Maximum video width in pixels.

XDAS_Int32 IVIDTRANSCODE_Params::maxFrameRateInput

Maximum frame rate in fps * 1000. For example, if max frame rate is 30 frames per second, set this field to 30000.

XDAS_Int32 IVIDTRANSCODE_Params::maxBitRateInput

Maximum bit rate, bits per second. For example, if bit rate is 10 Mbps, set this field to 10000000

XDAS_Int32 IVIDTRANSCODE_Params::maxHeightOutput[2]

Maximum output video height in pixels for each of the transcoded output.

XDAS_Int32 IVIDTRANSCODE_Params::maxWidthOutput[2]

Maximum output video width in pixels for each of the transcoded output.

XDAS_Int32 IVIDTRANSCODE_Params::maxFrameRateOutput[2]

Maximum frame rate in fps * 1000. for each out the output bitstreams For example, if max frame rate is 30 frames per second, set this field to 30000.

XDAS_Int32 IVIDTRANSCODE_Params::maxBitRateOutput[2]

Maximum bit rate, in bits per second for each of the transcoded bitstreams. For example, if bit rate is 10 Mbps, set this field to 10000000

XDAS_Int32 IVIDTRANSCODE_Params::dataEndianness

Endianness of output data.

See also:
XDM_DataFormat
The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): IVIDTRANSCODE_Status Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

IVIDTRANSCODE_Status Struct Reference
[XDM IVIDTRANSCODE Video Transcoder Interface]

Defines instance status parameters. More...

#include <ividtranscode.h>

Collaboration diagram for IVIDTRANSCODE_Status:
[legend]

Data Fields

XDAS_Int32 size
XDAS_Int32 extendedError
XDM1_SingleBufDesc data
XDM_AlgBufInfo bufInfo

Detailed Description

Defines instance status parameters.

Remarks:
This structure may be extended by individual codec implementations allowing customization with vendor specific parameters. The presence of vendor specific extensions will be detected by the value of the size parameter.
The size field must be correctly set by the caller. See http://tiexpressdsp.com/index.php?title=Extending_data_structures_in_xDM for more details.
See also:
IVIDTRANSCODE_Fxns::control()

Field Documentation

XDAS_Int32 IVIDTRANSCODE_Status::size

Size of this structure in bytes. Because this structure can be extended, this field must be correctly set by the caller.

XDAS_Int32 IVIDTRANSCODE_Status::extendedError

Extended error information.

Remarks:
When an internal error occurs, the algorithm will return an error return value (e.g. EFAIL, EUNSUPPORTED)
The value of each enum is the bit which is set.
Bits 31-16 are reserved. Bits 7-0 are codec and implementation specific.
The algorithm can set multiple bits to 1 based on conditions. e.g. it will set bits XDM_FATALERROR (fatal) and XDM_UNSUPPORTEDPARAM (unsupported params) in case of unsupported run time parameters.
This enumeration data type should not be used for storage, but rather only for its constant values.

See also:
XDM_ErrorBit
XDM1_SingleBufDesc IVIDTRANSCODE_Status::data

Buffer descriptor for data passing.

Remarks:
If this field is not used, the application must set data.buf to NULL.
This buffer can be used as either input or output, depending on the command.
The buffer will be provided by the application, and returned to the application upon return of the IVIDTRANSCODE_Fxns.control() call. The algorithm must not retain a pointer to this data.
See also:
XDM_GETVERSION
XDM_AlgBufInfo IVIDTRANSCODE_Status::bufInfo

Input and output buffer information.

Remarks:
This field provides the application with the algorithm's buffer requirements. The requirements may vary depending on the current configuration of the algorithm instance.
See also:
XDM_AlgBufInfo
The documentation for this struct was generated from the following file:
  • ividtranscode.h


Codec Engine Application Programming Interface (API): LAD_DspStatus Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

LAD_DspStatus Struct Reference
[LAD Communication Interfaces]

#include <ladclient.h>

Data Fields

LAD_DspState dspState
Char | linkConfigName [32]
Int | numClientsStarted
Char | imageName [512]

Field Documentation

LAD_DspState LAD_DspStatus::dspState

DSP state

Char LAD_DspStatus::linkConfigName[32]

Link config name

Int LAD_DspStatus::numClientsStarted

number clients who requested DSP startup

Char LAD_DspStatus::imageName[512]

server executable name

The documentation for this struct was generated from the following file:
  • ladclient.h


Codec Engine Application Programming Interface (API): Memory_AllocParams Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

Memory_AllocParams Struct Reference
[Codec Engine OSAL - Memory]

Parameters for Memory_alloc() & Memory_free(). More...

#include <Memory.h>

Data Fields

Memory_type type
UInt | flags
UInt | align
UInt | seg

Detailed Description

Parameters for Memory_alloc() & Memory_free().

See also:
Memory_DEFAULTPARAMS

Field Documentation

Memory_type Memory_AllocParams::type

Type of allocation.

See also:
Memory_type
UInt Memory_AllocParams::flags

Flags affecting allocation.

See also:
Memory_CACHED
Memory_NONCACHED
UInt Memory_AllocParams::align

Alignment of allocation.

UInt Memory_AllocParams::seg

Segment for allocation.

The documentation for this struct was generated from the following file:
  • Memory.h


Codec Engine Application Programming Interface (API): Server_AlgInfo Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

Server_AlgInfo Struct Reference
[Codec Engine Server Interface]

Properties of a Server algorithm. More...

#include <Server.h>

Data Fields

Int | algInfoSize
String | name
String * | typeTab

Detailed Description

Properties of a Server algorithm.

See also:
Server_getAlgInfo()

Field Documentation

Int Server_AlgInfo::algInfoSize

Size of this structure.

String Server_AlgInfo::name

Name of algorithm.

String* Server_AlgInfo::typeTab

Inheritance hierarchy.

The documentation for this struct was generated from the following file:
  • Server.h


Codec Engine Application Programming Interface (API): Server_MemStat Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

Server_MemStat Struct Reference
[Codec Engine Server Interface]

Information for a memory heap of a remote DSP server. More...

#include <Server.h>

Data Fields

Char | name [32+1]
Uint32 | base
Uint32 | size
Uint32 | used
Uint32 | maxBlockLen

Detailed Description

Information for a memory heap of a remote DSP server.

Remarks:
Sizes are given in DSP data MAUs.
See also:
Server_getMemStat().

Field Documentation

Char Server_MemStat::name[32+1]

Name of memory heap.

Uint32 Server_MemStat::base

Base address of the memory segment.

Uint32 Server_MemStat::size

Original size of the memory segment.

Uint32 Server_MemStat::used

Number of bytes used.

Uint32 Server_MemStat::maxBlockLen

Length of the largest contiguous free block.

The documentation for this struct was generated from the following file:
  • Server.h


Codec Engine Application Programming Interface (API): VISA_MsgHeader Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

VISA_MsgHeader Struct Reference
[CE Stub SPI]

VISA message header. More...

#include <visa.h>

Data Fields

NODE_MsgHeader | header
Int | cmd
VISA_Status status

Detailed Description

VISA message header.

Remarks:
This must be the first field in a message

Field Documentation

NODE_MsgHeader VISA_MsgHeader::header
Int VISA_MsgHeader::cmd

Command id

VISA_Status VISA_MsgHeader::status

Return status

The documentation for this struct was generated from the following file:
  • visa.h


Codec Engine Application Programming Interface (API): XDM1_BufDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM1_BufDesc Struct Reference
[Shared XDM Definitions]

Buffer descriptor. More...

#include <xdm.h>

Collaboration diagram for XDM1_BufDesc:
[legend]

Data Fields

XDAS_Int32 numBufs
XDM1_SingleBufDesc descs [16]

Detailed Description

Buffer descriptor.

Field Documentation

XDAS_Int32 XDM1_BufDesc::numBufs

Number of buffers in descs array.

Remarks:
Must be less than XDM_MAX_IO_BUFFERS.
XDM1_SingleBufDesc XDM1_BufDesc::descs[16]
The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM1_SingleBufDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM1_SingleBufDesc Struct Reference
[Shared XDM Definitions]

Single buffer descriptor. More...

#include <xdm.h>

Data Fields

XDAS_Int8 * buf
XDAS_Int32 bufSize
XDAS_Int32 accessMask

Detailed Description

Single buffer descriptor.

Field Documentation

XDAS_Int8* XDM1_SingleBufDesc::buf

Pointer to a buffer address.

XDAS_Int32 XDM1_SingleBufDesc::bufSize

Size of buf in 8-bit bytes.

XDAS_Int32 XDM1_SingleBufDesc::accessMask

Mask filled by the algorithm, declaring how the buffer was accessed by the algorithm processor.

Remarks:
If the buffer was not accessed by the algorithm processor (e.g., it was filled via DMA or other hardware accelerator that doesn't write through the algorithm's CPU), then no bits in this mask should be set.
It is acceptible (and appropriate!)to set several bits in this mask if the algorithm accessed the buffer in several ways.
This mask is often used by the application and/or framework to appropriately manage cache on cache-based systems.
See also:
XDM_AccessMode
The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_AlgBufInfo Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_AlgBufInfo Struct Reference
[Shared XDM Definitions]

Buffer information descriptor for input and output buffers. More...

#include <xdm.h>

Data Fields

XDAS_Int32 minNumInBufs
XDAS_Int32 minNumOutBufs
XDAS_Int32 | minInBufSize [16]
XDAS_Int32 | minOutBufSize [16]

Detailed Description

Buffer information descriptor for input and output buffers.

Field Documentation

XDAS_Int32 XDM_AlgBufInfo::minNumInBufs

Minimum number of input buffers.

XDAS_Int32 XDM_AlgBufInfo::minNumOutBufs

Minimum number of output buffers.

XDAS_Int32 XDM_AlgBufInfo::minInBufSize[16]

Minimum size, in 8-bit bytes, required for each input buffer.

XDAS_Int32 XDM_AlgBufInfo::minOutBufSize[16]

Minimum size, in 8-bit bytes, required for each output buffer.

The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_BufDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_BufDesc Struct Reference
[Shared XDM Definitions]

Buffer descriptor for multiple buffers. More...

#include <xdm.h>

Data Fields

XDAS_Int8 ** bufs
XDAS_Int32 numBufs
XDAS_Int32 * bufSizes

Detailed Description

Buffer descriptor for multiple buffers.

Precondition:
numBufs can not be larger than XDM_MAX_IO_BUFFERS. Related, *bufs and *bufSizes will never be indexed beyond XDM_MAX_IO_BUFFERS elements.
Remarks:
This data type is commonly used to manage input and output buffers.
If *bufs is a sparse array, *bufSizes will be a similar sparse array. The NULL indexes in bufs will be ignored in bufSizes.
numBufs describes the number of buffers in this descriptor. if *bufs is a sparse array, numBufs describes the number of non-NULL buffers in this descriptor; this is not necessarily the maximum index of the last buffer pointed to by *bufs.
An example utilizing XDM_BufDesc as a sparse array would be the following:
              XDM_BufDesc outBufs;
              XDAS_Int32  bufSizeArray[XDM_MAX_IO_BUFFERS];
              XDAS_Int8  *pBuffers[XDM_MAX_IO_BUFFERS];
              XDAS_Int8   buffer1[4096];
              XDAS_Int8   buffer2[1024];

              // ensure all pBuffers and bufSizeArray are initially NULL
              memset(pBuffers, 0, sizeof(pBuffers[0]) * XDM_MAX_IO_BUFFERS);
              memset(bufSizeArray, 0,
                  sizeof(bufSizeArray[0]) * XDM_MAX_IO_BUFFERS);

              pBuffers[0] = buffer1;
              pBuffers[4] = buffer2;

              bufSizeArray[0] = 4096;
              bufSizeArray[4] = 1024;

              outBufs.bufs = pBuffers;
              outBufs.numBufs = 2;
              outBufs.bufSizes = bufSizeArray;
The following diagram describes graphically the example above.

Field Documentation

XDAS_Int8** XDM_BufDesc::bufs

Pointer to an array containing buffer addresses.

XDAS_Int32 XDM_BufDesc::numBufs

Number of buffers.

XDAS_Int32* XDM_BufDesc::bufSizes

Size of each buffer in 8-bit bytes.

The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_Context Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_Context Struct Reference
[Shared XDM Definitions]

Context used by split codecs. More...

#include <xdm.h>

Collaboration diagram for XDM_Context:
[legend]

Data Fields

XDM1_SingleBufDesc algContext
XDAS_Int32 numInBufs
XDAS_Int32 numOutBufs
XDAS_Int32 numInOutBufs
XDM1_SingleBufDesc | inBufs [32]
XDM1_SingleBufDesc | outBufs [32]
XDM1_SingleBufDesc | inOutBufs [32]
XDM1_SingleBufDesc | intermediateBufs [32]

Detailed Description

Context used by split codecs.

Field Documentation

XDM1_SingleBufDesc XDM_Context::algContext

App allocated and provided.

Remarks:
Split codecs can use this for passing scalar data to the next part.
XDAS_Int32 XDM_Context::numInBufs

Number of input data buffers

XDAS_Int32 XDM_Context::numOutBufs

Number of output data buffers

XDAS_Int32 XDM_Context::numInOutBufs

Number of in/out data buffers

XDM1_SingleBufDesc XDM_Context::inBufs[32]

Input data Cbuffers.

Remarks:
This is a sparse array.
XDM1_SingleBufDesc XDM_Context::outBufs[32]

Output data buffers.

Remarks:
This is a sparse array.
XDM1_SingleBufDesc XDM_Context::inOutBufs[32]

Input/Output data buffers.

Remarks:
This is a sparse array.
XDM1_SingleBufDesc XDM_Context::intermediateBufs[32]

Intermediate, working buffers.

Remarks:
For FRONT codec parts, these buffers are treated as OUT buffers (i.e., written to by the algorithm). For BACK codec parts, these buffers are treated as IN buffers (i.e., read from by the algorithm). For MIDDLE codec parts, these buffers are treated as IN/OUT buffers (i.e., the codec can read from, and write to them).
This is a null-terminated array
The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_ContextInfo Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_ContextInfo Struct Reference
[Shared XDM Definitions]

Buffer information descriptor for input and output buffers. More...

#include <xdm.h>

Data Fields

XDAS_Int32 minContextSize
XDAS_Int32 minIntermediateBufSizes [32]

Detailed Description

Buffer information descriptor for input and output buffers.

Field Documentation

XDAS_Int32 XDM_ContextInfo::minContextSize

Minimum size, in 8-bit bytes, required for the alg context.

XDAS_Int32 XDM_ContextInfo::minIntermediateBufSizes[32]

Minimum size, in 8-bit bytes, required for each intermediate buffer.

Remarks:
The codec indicates the number of intermediate buffers required by zero-terminating this array.
The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_Date Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_Date Struct Reference
[Shared XDM Definitions]

Date and time. More...

#include <xdm.h>

Data Fields

XDAS_Int32 msecsOfDay
XDAS_Int32 month
XDAS_Int32 dayOfMonth
XDAS_Int32 dayOfWeek
XDAS_Int32 year

Detailed Description

Date and time.

Field Documentation

XDAS_Int32 XDM_Date::msecsOfDay

Milliseconds of the day

XDAS_Int32 XDM_Date::month

Month (0 = January, 11 = December)

XDAS_Int32 XDM_Date::dayOfMonth

Month (1 - 31)

XDAS_Int32 XDM_Date::dayOfWeek

Day of week (0 = Sunday, 6 = Saturday)

XDAS_Int32 XDM_Date::year

Year (since 0)

The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_Point Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_Point Struct Reference
[Shared XDM Definitions]

2-dimensional point More...

#include <xdm.h>

Data Fields

XDAS_Int32 x
XDAS_Int32 y

Detailed Description

2-dimensional point

Field Documentation

XDAS_Int32 XDM_Point::x
XDAS_Int32 XDM_Point::y
The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_Rect Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_Rect Struct Reference
[Shared XDM Definitions]

Rectangle. More...

#include <xdm.h>

Collaboration diagram for XDM_Rect:
[legend]

Data Fields

XDM_Point topLeft
XDM_Point bottomRight

Detailed Description

Rectangle.

Field Documentation

XDM_Point XDM_Rect::topLeft
XDM_Point XDM_Rect::bottomRight
The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): XDM_SingleBufDesc Struct Reference

  • Data Structures
  • Data Structure Index
  • Data Fields

XDM_SingleBufDesc Struct Reference
[Shared XDM Definitions]

Single buffer descriptor. More...

#include <xdm.h>

Data Fields

XDAS_Int8 * buf
XDAS_Int32 bufSize

Detailed Description

Single buffer descriptor.

Field Documentation

XDAS_Int8* XDM_SingleBufDesc::buf

Pointer to a buffer address.

XDAS_Int32 XDM_SingleBufDesc::bufSize

Size of buf in 8-bit bytes.

The documentation for this struct was generated from the following file:
  • xdm.h


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- a -

  • accessMask : XDM1_SingleBufDesc
  • actionType : IVIDANALYTICS_Rule
  • algActivate : IALG_Fxns
  • algAlloc : IALG_Fxns
  • algContext : XDM_Context
  • algControl : IALG_Fxns
  • algDeactivate : IALG_Fxns
  • algFree : IALG_Fxns
  • algInfoSize : Engine_AlgInfo , Engine_AlgInfo2 , Server_AlgInfo
  • algInit : IALG_Fxns
  • algMoved : IALG_Fxns
  • algNumAlloc : IALG_Fxns
  • align : Memory_AllocParams
  • alignment : IALG_MemRec
  • ancData : IAUDENC1_InArgs
  • ancFlag : IAUDENC1_Params
  • attrs : IALG_MemRec
  • autoPosition : IAUDDEC_Status


Codec Engine Application Programming Interface (API): File Index

  • File List
  • Globals

File List

Here is a list of all files with brief descriptions:
auddec.h [code] | The AUDDEC audio decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDDEC audio decoder interface
auddec1.h [code] | The AUDDEC1 audio decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDDEC1 audio decoder interface
audenc.h [code] | The AUDENC audio encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDENC audio encoder interface
audenc1.h [code] | The AUDENC1 audio encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDENC1 audio encoder interface
CERuntime.h [code] | The Codec Engine Runtime init module. Provides system wide initialization of the Codec Engine Runtime
Engine.h [code] | The Codec Engine Runtime. Provides the user an inteface to open and manipulate an Engine which can instantiate and communicate with XDAIS algorithms that run either on the local CPU or on a "remote" DSP Server
ialg.h [code] | This header defines all types, constants, and functions defined by XDAIS for algorithms
iauddec.h [code] | This header defines all types, constants, and functions shared by all implementations of the audio decoder algorithms
iauddec1.h [code] | This header defines all types, constants, and functions shared by all implementations of the audio decoder algorithms
iaudenc.h [code] | This header defines all types, constants, and functions shared by all implementations of the audio encoder algorithms
iaudenc1.h [code] | This header defines all types, constants, and functions shared by all implementations of the audio encoder algorithms
iaudio.h [code] | This header defines all types, constants, enums, and functions that are common across the various audio codecs
iimgdec.h [code] | This header defines all types, constants, and functions shared by all implementations of the image decoder algorithms
iimgdec1.h [code] | This header defines all types, constants, and functions shared by all implementations of the image decoder algorithms
iimgenc.h [code] | This header defines all types, constants, and functions shared by all implementations of the image encoder algorithms
iimgenc1.h [code] | This header defines all types, constants, and functions shared by all implementations of the image encoder algorithms
imgdec.h [code] | The IMGDEC image decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IIMGDEC image decoder interface
imgdec1.h [code] | The IMGDEC1 image decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IIMGDEC1 image decoder interface
imgenc.h [code] | The IMGENC image encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IIMGENC image encoder interface
imgenc1.h [code] | The IMGENC1 image encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IIMGENC1 image encoder interface
ispeech.h [code] | This header defines all types, constants, enums, and functions that are common across the various speech codecs
ispeech1.h [code] | This header defines all types, constants, enums, and functions that are common across the various speech codecs
ispeech1_amr.h [code] | This header defines all types, constants, enums, and functions that are needed for AMR
ispeech1_evrc.h [code] | This header defines all types, constants, enums, and functions that are needed for EVRC
ispeech1_g723.h [code] | This header defines all types, constants, enums, and functions that are needed for G.723
ispeech1_g726.h [code] | This header defines all types, constants, enums, and functions that are needed for G.726
ispeech1_pcm.h [code] | This header defines all types, constants, enums, and functions that are common across all G.711/PCM speech codecs
ispeech1_smv.h [code] | This header defines all types, constants, enums, and functions that are common across all SMV speech codecs
ispeech1_wbamr.h [code] | This header defines all types, constants, enums, and functions that are needed for WB-AMR
isphdec.h [code] | This header defines all types, constants, and functions shared by all implementations of the speech/voice decoder algorithms
isphdec1.h [code] | This header defines all types, constants, and functions shared by all implementations of the speech/voice decoder algorithms
isphenc.h [code] | This header defines all types, constants, and functions shared by all implementations of the speech/voice encoder algorithms
isphenc1.h [code] | This header defines all types, constants, and functions shared by all implementations of the speech/voice encoder algorithms
iuniversal.h [code] | This header defines all types, constants, and functions shared by all implementations of the "universal" XDM algorithm
ividanalytics.h [code] | This header defines all types, constants, and functions shared by all implementations of the video analytics algorithms
ividdec.h [code] | This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms
ividdec1.h [code] | This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms
ividdec2.h [code] | This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms
split/ividdec2.h [code] | This header defines all types, constants, enums, and functions that are common across all split IVIDDEC2-based codecs
ividenc.h [code] | This header defines all types, constants, and functions shared by all implementations of the video encoder algorithms
ividenc1.h [code] | This header defines all types, constants, and functions shared by all implementations of the video encoder algorithms
ivideo.h [code] | This header defines all types, constants, enums, and functions that are common across the various video codecs
ividtranscode.h [code] | This header defines all types, constants, and functions shared by all implementations of the video transcoder algorithms
ladclient.h [code] | The Link Arbiter Daemon (LAD) communication interface. Provides wrapper functions to communicate with LAD, allowing a client to: establish a connection to LAD; request startup of a DSP server executable; query DSP status; and release the DSP and disconnect from LAD
Memory.h [code] | The Codec Engine OSAL Memory interface. Provides the user an OS-independent Memory abstraction
Server.h [code] | The Codec Engine Server Interface. Provides the user an inteface to open and manipulate a Server which contains remote algorithms
sphdec.h [code] | The SPHDEC speech decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHDEC speech decoder interface
sphdec1.h [code] | The SPHDEC1 decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHDEC1 speech decoder interface
sphenc.h [code] | The SPHENC speech encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHENC speech encoder interface
sphenc1.h [code] | The Speech 1.0 Encoder Codec Interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM 1.0 Speech Encoder interface
TraceUtil.h [code] | The Codec Engine utility module for trace
universal.h [code] | The "universal" algorithm interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IUNIVERSAL interface
vidanalytics.h [code] | The video analytics codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM video analytics interface
viddec.h [code] | The VIDDEC video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC video decoder interface
viddec1.h [code] | The 1.0 video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM 1.0 video decoder interface
split/viddec2.h [code] | The VIDDEC2 split video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC2FRONT or IVIDDEC2BACK video decoder interface
viddec2.h [code] | The VIDDEC2 video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC2 video decoder interface
videnc.h [code] | The VIDENC video encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDENC video encoder interface
videnc1.h [code] | The VIDENC1 video encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDENC1 video encoder interface
vidtranscode.h [code] | The video transcoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM video transcoder interface
visa.h [code] | The Codec Engine System Programming Interface. Provides system developers with services necessary to implement stubs and skeletons
xdas.h [code] | This header defines all types and constants used in the XDAS interfaces
xdm.h [code] | This header defines all types, constants, and functions shared across the various XDM classes of algorithms


Codec Engine Application Programming Interface (API): auddec.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » audio

auddec.h File Reference

Detailed Description

The AUDDEC audio decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDDEC audio decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iauddec.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for auddec.h:

Go to the source code of this file.

Defines

#define | AUDDEC_EOK IAUDDEC_EOK
#define | AUDDEC_EFAIL IAUDDEC_EFAIL
#define | AUDDEC_ERUNTIME IAUDDEC_ERUNTIME
#define | AUDDEC_ETIMEOUT VISA_ETIMEOUT
#define | AUDDEC_FOREVER VISA_FOREVER

Typedefs

typedef IAUDDEC_Status | AUDDEC_Status
typedef VISA_Handle | AUDDEC_Handle
Opaque handle to a AUDDEC codec.
typedef struct IAUDDEC_Params | AUDDEC_Params
This structure defines the parameters necessary to create an instance of a IAUDDEC-compliant audio decoder.
typedef IAUDDEC_InArgs | AUDDEC_InArgs
typedef IAUDDEC_OutArgs | AUDDEC_OutArgs
typedef IAUDDEC_Cmd | AUDDEC_Cmd
typedef IAUDDEC_DynamicParams | AUDDEC_DynamicParams

Functions

AUDDEC_Handle | AUDDEC_create (Engine_Handle e, String name, AUDDEC_Params *params)
Create an instance of a audio decoder algorithm.
Int32 | AUDDEC_process (AUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs)
Execute the process() method in this instance of an audio decoder algorithm.
Int32 | AUDDEC_control (AUDDEC_Handle handle, AUDDEC_Cmd id, AUDDEC_DynamicParams *params, AUDDEC_Status *status)
Execute the control() method in this instance of an audio decoder algorithm.
Void | AUDDEC_delete (AUDDEC_Handle handle)
Delete the instance of an audio decoder algorithm.
XDAS_Int32 | AUDDEC_processAsync (AUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio decoder algorithm.
XDAS_Int32 | AUDDEC_processWait (AUDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDDEC_processAsync() in this instance of an audio decoder algorithm.


Codec Engine Application Programming Interface (API): auddec1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » audio1

auddec1.h File Reference

Detailed Description

The AUDDEC1 audio decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDDEC1 audio decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iauddec1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for auddec1.h:

Go to the source code of this file.

Defines

#define | AUDDEC1_EOK IAUDDEC1_EOK
#define | AUDDEC1_EFAIL IAUDDEC1_EFAIL
#define | AUDDEC1_EUNSUPPORTED IAUDDEC1_EUNSUPPORTED
#define | AUDDEC1_ETIMEOUT VISA_ETIMEOUT
#define | AUDDEC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | AUDDEC1_Handle
Opaque handle to a AUDDEC1 codec.
typedef struct IAUDDEC1_Params | AUDDEC1_Params
This structure defines the parameters necessary to create an instance of an audio decoder object.
typedef IAUDDEC1_InArgs | AUDDEC1_InArgs
typedef IAUDDEC1_OutArgs | AUDDEC1_OutArgs
typedef IAUDDEC1_Cmd | AUDDEC1_Cmd
typedef IAUDDEC1_Status | AUDDEC1_Status
typedef IAUDDEC1_DynamicParams | AUDDEC1_DynamicParams

Functions

Int32 | AUDDEC1_control (AUDDEC1_Handle handle, AUDDEC1_Cmd id, AUDDEC1_DynamicParams *params, AUDDEC1_Status *status)
Execute the control() method in this instance of an audio1 decoder algorithm.
AUDDEC1_Handle | AUDDEC1_create (Engine_Handle e, String name, AUDDEC1_Params *params)
Create an instance of an audio decoder algorithm.
Void | AUDDEC1_delete (AUDDEC1_Handle handle)
Delete the instance of an audio decoder algorithm.
Int32 | AUDDEC1_process (AUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs)
Execute the process() method in this instance of a audio decoder algorithm.
Int32 | AUDDEC1_processAsync (AUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio decoder algorithm.
Int32 | AUDDEC1_processWait (AUDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDDEC1_processAsync() in this instance of an audio decoder algorithm.


Codec Engine Application Programming Interface (API): audenc.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » audio

audenc.h File Reference

Detailed Description

The AUDENC audio encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDENC audio encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iaudenc.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for audenc.h:

Go to the source code of this file.

Defines

#define | AUDENC_EOK IAUDENC_EOK
#define | AUDENC_EFAIL IAUDENC_EFAIL
#define | AUDENC_ERUNTIME IAUDENC_ERUNTIME
#define | AUDENC_ETIMEOUT VISA_ETIMEOUT
#define | AUDENC_FOREVER VISA_FOREVER

Typedefs

typedef IAUDENC_Status | AUDENC_Status
typedef VISA_Handle | AUDENC_Handle
Opaque handle to a AUDENC codec.
typedef struct IAUDENC_Params | AUDENC_Params
This structure defines the parameters necessary to create an instance of a Audio Encoder object.
typedef IAUDENC_InArgs | AUDENC_InArgs
typedef IAUDENC_OutArgs | AUDENC_OutArgs
typedef IAUDENC_Cmd | AUDENC_Cmd
typedef IAUDENC_DynamicParams | AUDENC_DynamicParams

Functions

AUDENC_Handle | AUDENC_create (Engine_Handle e, String name, AUDENC_Params *params)
Create an instance of an audio encoder algorithm.
Int32 | AUDENC_process (AUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, AUDENC_InArgs *inArgs, AUDENC_OutArgs *outArgs)
Execute the process() method in this instance of an audio encoder algorithm.
Int32 | AUDENC_control (AUDENC_Handle handle, AUDENC_Cmd id, AUDENC_DynamicParams *params, AUDENC_Status *status)
Execute the control() method in this instance of an audio encoder algorithm.
Void | AUDENC_delete (AUDENC_Handle handle)
Delete the instance of an audio encoder algorithm.
XDAS_Int32 | AUDENC_processAsync (AUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio encoder algorithm.
XDAS_Int32 | AUDENC_processWait (AUDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDENC_processAsync() in this instance of an audio encoder algorithm.


Codec Engine Application Programming Interface (API): audenc1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » audio1

audenc1.h File Reference

Detailed Description

The AUDENC1 audio encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDENC1 audio encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iaudenc1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for audenc1.h:

Go to the source code of this file.

Defines

#define | AUDENC1_EOK IAUDENC1_EOK
#define | AUDENC1_EFAIL IAUDENC1_EFAIL
#define | AUDENC1_EUNSUPPORTED IAUDENC1_EUNSUPPORTED
#define | AUDENC1_ETIMEOUT VISA_ETIMEOUT
#define | AUDENC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | AUDENC1_Handle
Opaque handle to a AUDENC1 codec.
typedef struct IAUDENC1_Params | AUDENC1_Params
This structure defines the parameters necessary to create an instance of an audio encoder.
typedef IAUDENC1_InArgs | AUDENC1_InArgs
typedef IAUDENC1_OutArgs | AUDENC1_OutArgs
typedef IAUDENC1_Cmd | AUDENC1_Cmd
typedef IAUDENC1_Status | AUDENC1_Status
typedef IAUDENC1_DynamicParams | AUDENC1_DynamicParams

Functions

Int32 | AUDENC1_control (AUDENC1_Handle handle, AUDENC1_Cmd id, AUDENC1_DynamicParams *params, AUDENC1_Status *status)
Execute the control() method in this instance of an audio encoder algorithm.
AUDENC1_Handle | AUDENC1_create (Engine_Handle e, String name, AUDENC1_Params *params)
Create an instance of an audio encoder algorithm.
Void | AUDENC1_delete (AUDENC1_Handle handle)
Delete the instance of a audio encoder algorithm.
Int32 | AUDENC1_process (AUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs)
Execute the process() method in this instance of a audio encoder algorithm.
Int32 | AUDENC1_processAsync (AUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a audio encoder algorithm.
Int32 | AUDENC1_processWait (AUDENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of AUDENC1_processAsync() in this instance of an audio encoder algorithm.


Codec Engine Application Programming Interface (API): CERuntime.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce

CERuntime.h File Reference

Detailed Description

The Codec Engine Runtime init module. Provides system wide initialization of the Codec Engine Runtime.

#include <ti/sdo/ce/Engine.h>
Include dependency graph for CERuntime.h:

Go to the source code of this file.

Defines

#define | CE_NULL_algs NULL
#define | CE_DECLARE_TYPE(name, types)
Declare an inheritanc hierarchy for an algorithm.
#define | CE_LOCAL_ALG(name, algName, ialgFxns, idma3Fxns, iresFxns, groupId, memType)
Generates a structure containing data for a local algorithm. This macro must be called between the CE_BEGIN_ALG_TABLE() and CE_END_ALG_TABLE() macro calls. It is used in this manner:.
#define | CE_BEGIN_ALG_TABLE(name) static Engine_AlgDesc CE_##name##_algs[] = {
Use this macro and the CE_END_ALG_TABLE() macro around CE_LOCAL_ALG() to generate an algorithm table for an engine. The usage is: CE_BEGIN_ALG_TABLE(engineAlgTab) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineAlgTab).
#define | CE_END_ALG_TABLE(name)
Use this macro after CE_BEGIN_ALG_TABLE() and CE_LOCAL_ALG() for generating an algorithm table for an engine. The usage is: CE_BEGIN_ALG_TABLE(engineAlgTab) CE_LOCAL_ALG(name_1, ...) CE_LOCAL_ALG(name_2, ...) ... CE_LOCAL_ALG(name_n, ...) CE_END_ALG_TABLE(engineAlgTab).
#define | CE_ENGINE(algTab, engineName, serverName)
Generates a structure containing data for an engine. This macro must be called between the CE_BEGIN_ENGINE_TABLE() and CE_END_ENGINE_TABLE() macro calls. It is used in this manner:.
#define | CE_BEGIN_ENGINE_TABLE(name)
Use this macro and the CE_END_ENGINE_TABLE() macro around CE_ENGINE() to generate an engine table for the applicaion. The usage is: CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_1, ...) CE_ENGINE(algTab_2, ...) ... CE_ENGINE(algTab_n, ...) CE_END_ENGINE_TABLE(name).
#define | CE_END_ENGINE_TABLE(name)
Use this macro and the CE_BEGIN_ENGINE_TABLE() macro around CE_ENGINE() to generate an engine table for the applicaion. The usage is: CE_BEGIN_ENGINE_TABLE(name) CE_ENGINE(algTab_1, ...) CE_ENGINE(algTab_2, ...) ... CE_ENGINE(algTab_n, ...) CE_END_ENGINE_TABLE(name).

Functions

Void | CERuntime_exit (Void)
Exit the Codec Engine Runtime.
Void | CERuntime_init (Void)
Initialize the Codec Engine Runtime.


Codec Engine Application Programming Interface (API): Engine.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce

Engine.h File Reference

Detailed Description

The Codec Engine Runtime. Provides the user an inteface to open and manipulate an Engine which can instantiate and communicate with XDAIS algorithms that run either on the local CPU or on a "remote" DSP Server.

#include <ti/sdo/ce/Server.h>
#include <ti/sdo/ce/ipc/Comm.h>
#include <ti/xdais/ialg.h>
#include <ti/sdo/ce/node/node.h>
#include <stddef.h>
#include <stdio.h>
Include dependency graph for Engine.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | Engine_Attrs
Attributes of an Engine. More...
struct | Engine_AlgInfo
Properties of an Engine algorithm. More...
struct | Engine_AlgInfo2
Properties of an Engine algorithm. This structure is identical to Engine_AlgInfo except that the typeTab array of strings is replaced by a singie string called types. The string, types, represents a ';' separated list of inheritance hierarchies of the algorithm, for example, "ti.sdo.ce.video.IVIDDEC;ti.sdo.ce.test.xvideo.IVIDE". More...

Defines

#define | Engine_GTNAME "CE"
Trace name for the Engine module.
#define | Engine_EOK 0
#define | Engine_EEXIST 1
#define | Engine_ENOMEM 2
#define | Engine_EDSPLOAD 3
#define | Engine_ENOCOMM 4
#define | Engine_ENOSERVER 5
#define | Engine_ECOMALLOC 6
#define | Engine_ERUNTIME 7
#define | Engine_ECODECCREATE 8
#define | Engine_ECODECSTART 9
#define | Engine_EINVAL 10
#define | Engine_EBADSERVER 11
#define | Engine_ENOTAVAIL 12
#define | Engine_EWRONGSTATE 13
#define | Engine_EINUSE 14
#define | Engine_ENOTFOUND 15
#define | Engine_ETIMEOUT 16

Typedefs

typedef struct Engine_Obj * | Engine_Handle
Opaque handle to an engine.
typedef Int | Engine_Error
Engine error code.

Functions

Void | Engine_close (Engine_Handle engine)
Close an Engine.
Engine_Handle | Engine_open (String name, Engine_Attrs *attrs, Engine_Error *ec)
Open an Engine.
Int | Engine_fwriteTrace (Engine_Handle engine, String prefix, FILE *out)
Write Server's trace buffer to specifed file stream.
Engine_Error | Engine_getAlgInfo (String name, Engine_AlgInfo *algInfo, Int index)
Get details of an algorithm configured into an engine.
Engine_Error | Engine_getAlgInfo2 (String name, Engine_Handle engine, Engine_AlgInfo2 *algInfo2, Int index)
Get details of an algorithm that is configured into an engine, or has been added to an opened engine. If the engine has not been opened yet, the name of the engine is used to get the statically configured alg. If the engine has been opened, the engine handle can be used to get either information for a statically configured alg, or a remote alg that was added when the server was queried during Engine_open().
Int | Engine_getCpuLoad (Engine_Handle engine)
Get Server's cpu usage in percent.
Engine_Error | Engine_getLastError (Engine_Handle engine)
Get error code of the last failed operation.
String | Engine_getName (Engine_Handle engine)
Get the name of an opened engine.
Engine_Error | Engine_getNumAlgs (String name, Int *numAlgs)
Get the number of algorithms configured into an engine.
Engine_Error | Engine_getNumAlgs2 (String name, Engine_Handle engine, Int *numAlgs)
Get the number of algorithms statically configured into an engine or the total number of algorithms both statically configured and dynamically added through server information when the engine was opened.
Server_Handle | Engine_getServer (Engine_Handle engine)
Get handle to an Engine's server.
UInt32 | Engine_getUsedMem (Engine_Handle engine)
Get Server's total memory usage.
Int | Engine_setTrace (Engine_Handle engine, String mask)
Set Server's trace mask.

Variables

Engine_Attrs Engine_ATTRS
Default engine attributes.


Codec Engine Application Programming Interface (API): ialg.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais

ialg.h File Reference

Detailed Description

This header defines all types, constants, and functions defined by XDAIS for algorithms.

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IALG_MemRec
Memory records. More...
struct | IALG_Obj
Algorithm instance object definition. More...
struct | IALG_Params
Algorithm instance creation parameters. More...
struct | IALG_Status
Pointer to algorithm specific status structure. More...
struct | IALG_Fxns
Defines the fields and methods that must be supplied by all XDAIS algorithms. More...

Defines

#define | IALG_DEFMEMRECS 4
#define | IALG_OBJMEMREC 0
#define | IALG_SYSCMD 256
#define | IALG_EOK 0
#define | IALG_EFAIL -1
#define | IALG_CUSTOMFAILBASE -2048
#define | IALG_CUSTOMFAILEND -256
#define | IALG_MPROG 0x0008
#define | IALG_MXTRN 0x0010
#define | IALG_isProg(s)
#define | IALG_isOffChip(s)

Typedefs

typedef struct IALG_Obj * | IALG_Handle
Handle to an algorithm instance object.
typedef unsigned int | IALG_Cmd
Algorithm specific command.

Enumerations

enum IALG_MemAttrs {
IALG_SCRATCH,
IALG_PERSIST,
IALG_WRITEONCE
}

Memory attributes.

More...
enum IALG_MemSpace {
IALG_EPROG,
IALG_IPROG,
IALG_ESDATA,
IALG_EXTERNAL,
IALG_DARAM0 = 0,
IALG_DARAM1 = 1,
IALG_SARAM = 2,
IALG_SARAM0 = 2,
IALG_SARAM1 = 3,
IALG_DARAM2 = 4,
IALG_SARAM2 = 5
}

Defined memory spaces.

More...


Codec Engine Application Programming Interface (API): iauddec.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iauddec.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the audio decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "iaudio.h"
Include dependency graph for iauddec.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IAUDDEC_Obj
This must be the first field of all IAUDDEC instance objects. More...
struct | IAUDDEC_Params
Defines the creation time parameters for all IAUDDEC instance objects. More...
struct | IAUDDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IAUDDEC_InArgs
Defines the input arguments for all IAUDDEC instance process function. More...
struct | IAUDDEC_Status
Defines instance status parameters (read-only). More...
struct | IAUDDEC_OutArgs
Defines the run time output arguments for all IAUDDEC instance objects. More...
struct | IAUDDEC_Fxns
Defines all of the operations on IAUDDEC objects. More...

Defines

#define | IAUDDEC_CID "ti.xdais.dm.IAUDDEC"
#define | IAUDDEC_ERUNTIME XDM_ERUNTIME
#define | IAUDDEC_EOK XDM_EOK
#define | IAUDDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct IAUDDEC_Obj * | IAUDDEC_Handle
Opaque handle to an IAUDDEC objects.
typedef IALG_Cmd | IAUDDEC_Cmd
Defines the control commands for the IAUDDEC module.


Codec Engine Application Programming Interface (API): iauddec1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iauddec1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the audio decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "iaudio.h"
Include dependency graph for iauddec1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IAUDDEC1_Obj
This must be the first field of all IAUDDEC1 instance objects. More...
struct | IAUDDEC1_Params
Defines the creation time parameters for all IAUDDEC1 instance objects. More...
struct | IAUDDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IAUDDEC1_InArgs
Defines the input arguments for all IAUDDEC1 instance process function. More...
struct | IAUDDEC1_Status
Defines instance status parameters (read-only). More...
struct | IAUDDEC1_OutArgs
Defines the run time output arguments for all IAUDDEC1 instance objects. More...
struct | IAUDDEC1_Fxns
Defines all of the operations on IAUDDEC1 objects. More...

Defines

#define | IAUDDEC1_EOK XDM_EOK
#define | IAUDDEC1_EFAIL XDM_EFAIL
#define | IAUDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IAUDDEC1_Obj * | IAUDDEC1_Handle
Opaque handle to an IAUDDEC1 objects.
typedef IALG_Cmd | IAUDDEC1_Cmd
Defines the control commands for the IAUDDEC1 module.


Codec Engine Application Programming Interface (API): iaudenc.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iaudenc.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the audio encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "iaudio.h"
Include dependency graph for iaudenc.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IAUDENC_Obj
This must be the first field of all IAUDENC instance objects. More...
struct | IAUDENC_Params
Defines the creation time parameters for all IAUDENC instance objects. More...
struct | IAUDENC_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IAUDENC_InArgs
Defines the input arguments for all IAUDENC instance process function. More...
struct | IAUDENC_Status
Defines instance status parameters (read-only). More...
struct | IAUDENC_OutArgs
Defines the run time output arguments for all IAUDENC instance objects. More...
struct | IAUDENC_Fxns
Defines all of the operations on IAUDENC objects. More...

Defines

#define | IAUDENC_CID "ti.xdais.dm.IAUDENC"
#define | IAUDENC_ERUNTIME XDM_ERUNTIME
#define | IAUDENC_EOK XDM_EOK
#define | IAUDENC_EFAIL XDM_EFAIL

Typedefs

typedef struct IAUDENC_Obj * | IAUDENC_Handle
Opaque handle to an IAUDENC objects.
typedef IALG_Cmd | IAUDENC_Cmd
Defines the control commands for the IAUDENC module.


Codec Engine Application Programming Interface (API): iaudenc1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iaudenc1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the audio encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "iaudio.h"
Include dependency graph for iaudenc1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IAUDENC1_Obj
This must be the first field of all IAUDENC1 instance objects. More...
struct | IAUDENC1_Params
Defines the creation time parameters for all IAUDENC1 instance objects. More...
struct | IAUDENC1_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IAUDENC1_InArgs
Defines the input arguments for all IAUDENC1 instance process function. More...
struct | IAUDENC1_Status
Defines instance status parameters (read-only). More...
struct | IAUDENC1_OutArgs
Defines the run time output arguments for all IAUDENC1 instance objects. More...
struct | IAUDENC1_Fxns
Defines all of the operations on IAUDENC1 objects. More...

Defines

#define | IAUDENC1_EOK XDM_EOK
#define | IAUDENC1_EFAIL XDM_EFAIL
#define | IAUDENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IAUDENC1_Obj * | IAUDENC1_Handle
Opaque handle to an IAUDENC1 objects.
typedef IALG_Cmd | IAUDENC1_Cmd
Defines the control commands for the IAUDENC1 module.


Codec Engine Application Programming Interface (API): iaudio.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iaudio.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across the various audio codecs.

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Enumerations

enum IAUDIO_ChannelId {
IAUDIO_MONO = 0,
IAUDIO_STEREO = 1,
IAUDIO_THREE_ZERO = 2,
IAUDIO_FIVE_ZERO = 3,
IAUDIO_FIVE_ONE = 4,
IAUDIO_SEVEN_ONE = 5
}

XDM supported audio channel configurations.

More...
enum IAUDIO_ChannelMode {
IAUDIO_1_0 = 0,
IAUDIO_2_0 = 1,
IAUDIO_11_0 = 2,
IAUDIO_3_0 = 3,
IAUDIO_2_1 = 4,
IAUDIO_3_1 = 5,
IAUDIO_2_2 = 6,
IAUDIO_3_2 = 7,
IAUDIO_2_3 = 8,
IAUDIO_3_3 = 9,
IAUDIO_3_4 = 10
}

Channel modes for audio streams.

More...
enum IAUDIO_DualMonoMode {
IAUDIO_DUALMONO_LR = 0,
IAUDIO_DUALMONO_LEFT = 1,
IAUDIO_DUALMONO_RIGHT = 2,
IAUDIO_DUALMONO_LR_MIX = 3
}

Dual Mono Channel modes for audio streams.

More...
enum IAUDIO_PcmFormat {
IAUDIO_BLOCK = 0,
IAUDIO_INTERLEAVED = 1
}

XDM supported audio PCM formats.

More...
enum IAUDIO_EncMode {
IAUDIO_CBR = 0,
IAUDIO_VBR = 1
}

Audio encoding modes.

More...


Codec Engine Application Programming Interface (API): iimgdec.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgdec.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the image decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
Include dependency graph for iimgdec.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IIMGDEC_Obj
This must be the first field of all IIMGDEC instance objects. More...
struct | IIMGDEC_Params
Defines the creation time parameters for all IIMGDEC instance objects. More...
struct | IIMGDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IIMGDEC_InArgs
Defines the input arguments for all IIMGDEC instance process() function. More...
struct | IIMGDEC_Status
Defines instance status parameters (read-only). More...
struct | IIMGDEC_OutArgs
Defines the run time output arguments for all IIMGDEC instance objects. More...
struct | IIMGDEC_Fxns
Defines all of the operations on IIMGDEC objects. More...

Defines

#define | IIMGDEC_CID "ti.xdais.dm.IIMGDEC"
#define | IIMGDEC_ERUNTIME XDM_ERUNTIME
#define | IIMGDEC_EOK XDM_EOK
#define | IIMGDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct IIMGDEC_Obj * | IIMGDEC_Handle
Opaque handle to an IIMGDEC objects.
typedef IALG_Cmd | IIMGDEC_Cmd
Defines the control commands for the IIMGDEC module.


Codec Engine Application Programming Interface (API): iimgdec1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgdec1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the image decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
Include dependency graph for iimgdec1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IIMGDEC1_Obj
This must be the first field of all IIMGDEC1 instance objects. More...
struct | IIMGDEC1_Params
Defines the creation time parameters for all IIMGDEC1 instance objects. More...
struct | IIMGDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IIMGDEC1_InArgs
Defines the input arguments for all IIMGDEC1 instance process() function. More...
struct | IIMGDEC1_Status
Defines instance status parameters. More...
struct | IIMGDEC1_OutArgs
Defines the run time output arguments for all IIMGDEC1 instance objects. More...
struct | IIMGDEC1_Fxns
Defines all of the operations on IIMGDEC1 objects. More...

Defines

#define | IIMGDEC1_EOK XDM_EOK
#define | IIMGDEC1_EFAIL XDM_EFAIL
#define | IIMGDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IIMGDEC1_Obj * | IIMGDEC1_Handle
Opaque handle to an IIMGDEC1 objects.
typedef IALG_Cmd | IIMGDEC1_Cmd
Defines the control commands for the IIMGDEC1 module.


Codec Engine Application Programming Interface (API): iimgenc.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgenc.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the image encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
Include dependency graph for iimgenc.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IIMGENC_Obj
This must be the first field of all IIMGENC instance objects. More...
struct | IIMGENC_Params
Defines the creation time parameters for all IIMGENC instance objects. More...
struct | IIMGENC_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IIMGENC_InArgs
Defines the input arguments for all IIMGENC instance process() function. More...
struct | IIMGENC_Status
Defines instance status parameters (read-only). More...
struct | IIMGENC_OutArgs
Defines the run time output arguments for all IIMGENC instance objects. More...
struct | IIMGENC_Fxns
Defines all of the operations on IIMGENC objects. More...

Defines

#define | IIMGENC_CID "ti.xdais.dm.IIMGENC"
#define | IIMGENC_ERUNTIME XDM_ERUNTIME
#define | IIMGENC_EOK XDM_EOK
#define | IIMGENC_EFAIL XDM_EFAIL

Typedefs

typedef struct IIMGENC_Obj * | IIMGENC_Handle
Opaque handle to an IIMGENC objects.
typedef IALG_Cmd | IIMGENC_Cmd
Defines the control commands for the IIMGENC module.


Codec Engine Application Programming Interface (API): iimgenc1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgenc1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the image encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
Include dependency graph for iimgenc1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IIMGENC1_Obj
This must be the first field of all IIMGENC1 instance objects. More...
struct | IIMGENC1_Params
Defines the creation time parameters for all IIMGENC1 instance objects. More...
struct | IIMGENC1_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IIMGENC1_InArgs
Defines the input arguments for all IIMGENC1 instance process() function. More...
struct | IIMGENC1_Status
Defines instance status parameters. More...
struct | IIMGENC1_OutArgs
Defines the run time output arguments for all IIMGENC1 instance objects. More...
struct | IIMGENC1_Fxns
Defines all of the operations on IIMGENC1 objects. More...

Defines

#define | IIMGENC1_EOK XDM_EOK
#define | IIMGENC1_EFAIL XDM_EFAIL
#define | IIMGENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IIMGENC1_Obj * | IIMGENC1_Handle
Opaque handle to an IIMGENC1 objects.
typedef IALG_Cmd | IIMGENC1_Cmd
Defines the control commands for the IIMGENC1 module.


Codec Engine Application Programming Interface (API): imgdec.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » image

imgdec.h File Reference

Detailed Description

The IMGDEC image decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IIMGDEC image decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iimgdec.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for imgdec.h:

Go to the source code of this file.

Data Structures

struct | IIMGDEC_CodecClassConfig
Definition of IIMGDEC codec class configurable parameters. More...

Defines

#define | IMGDEC_EOK IIMGDEC_EOK
#define | IMGDEC_EFAIL IIMGDEC_EFAIL
#define | IMGDEC_ERUNTIME IIMGDEC_ERUNTIME
#define | IMGDEC_ETIMEOUT VISA_ETIMEOUT
#define | IMGDEC_FOREVER VISA_FOREVER

Typedefs

typedef IIMGDEC_Status | IMGDEC_Status
typedef VISA_Handle | IMGDEC_Handle
Opaque handle to a IMGDEC codec.
typedef struct IIMGDEC_Params | IMGDEC_Params
This structure defines the parameters necessary to create an instance of a image decoder object.
typedef IIMGDEC_InArgs | IMGDEC_InArgs
typedef IIMGDEC_OutArgs | IMGDEC_OutArgs
typedef IIMGDEC_Cmd | IMGDEC_Cmd
typedef IIMGDEC_DynamicParams | IMGDEC_DynamicParams

Functions

IMGDEC_Handle | IMGDEC_create (Engine_Handle e, String name, IMGDEC_Params *params)
Create an instance of an image decoder algorithm.
Int32 | IMGDEC_process (IMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs)
Execute the process() method in this instance of a image decoder algorithm.
Int32 | IMGDEC_control (IMGDEC_Handle handle, IMGDEC_Cmd id, IMGDEC_DynamicParams *params, IMGDEC_Status *status)
Execute the control() method in this instance of an image decoder algorithm.
Void | IMGDEC_delete (IMGDEC_Handle handle)
Delete the instance of a image decoder algorithm.
XDAS_Int32 | IMGDEC_processAsync (IMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of an image decoder algorithm.
XDAS_Int32 | IMGDEC_processWait (IMGDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGDEC_processAsync() in this instance of an image decoder algorithm.


Codec Engine Application Programming Interface (API): imgdec1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » image1

imgdec1.h File Reference

Detailed Description

The IMGDEC1 image decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IIMGDEC1 image decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iimgdec1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for imgdec1.h:

Go to the source code of this file.

Data Structures

struct | IIMGDEC1_CodecClassConfig
Definition of IIMGDEC1 codec class configurable parameters. More...

Defines

#define | IMGDEC1_EOK IIMGDEC1_EOK
#define | IMGDEC1_EFAIL IIMGDEC1_EFAIL
#define | IMGDEC1_EUNSUPPORTED IIMGDEC1_EUNSUPPORTED
#define | IMGDEC1_ETIMEOUT VISA_ETIMEOUT
#define | IMGDEC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | IMGDEC1_Handle
Opaque handle to a IMGDEC1 codec.
typedef IIMGDEC1_Params | IMGDEC1_Params
typedef IIMGDEC1_InArgs | IMGDEC1_InArgs
typedef IIMGDEC1_OutArgs | IMGDEC1_OutArgs
typedef IIMGDEC1_Cmd | IMGDEC1_Cmd
typedef IIMGDEC1_DynamicParams | IMGDEC1_DynamicParams
typedef IIMGDEC1_Status | IMGDEC1_Status

Functions

Int32 | IMGDEC1_control (IMGDEC1_Handle handle, IMGDEC1_Cmd id, IMGDEC1_DynamicParams *params, IMGDEC1_Status *status)
Execute the control() method in this instance of an image decoder algorithm.
IMGDEC1_Handle | IMGDEC1_create (Engine_Handle e, String name, IMGDEC1_Params *params)
Create an instance of an image decoder algorithm.
Void | IMGDEC1_delete (IMGDEC1_Handle handle)
Delete the instance of an image decoder algorithm.
Int32 | IMGDEC1_process (IMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs)
Execute the process() method in this instance of an image decoder algorithm.
XDAS_Int32 | IMGDEC1_processAsync (IMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a image decoder algorithm.
XDAS_Int32 | IMGDEC1_processWait (IMGDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGDEC1_processAsync() in this instance of an image decoder algorithm.


Codec Engine Application Programming Interface (API): imgenc.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » image

imgenc.h File Reference

Detailed Description

The IMGENC image encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IIMGENC image encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iimgenc.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for imgenc.h:

Go to the source code of this file.

Data Structures

struct | IIMGENC_CodecClassConfig
Definition of IIMGENC codec class configurable parameters. More...

Defines

#define | IMGENC_EOK IIMGENC_EOK
#define | IMGENC_EFAIL IIMGENC_EFAIL
#define | IMGENC_ERUNTIME IIMGENC_ERUNTIME
#define | IMGENC_ETIMEOUT VISA_ETIMEOUT
#define | IMGENC_FOREVER VISA_FOREVER

Typedefs

typedef IIMGENC_Status | IMGENC_Status
typedef VISA_Handle | IMGENC_Handle
Opaque handle to a IMGENC codec.
typedef struct IIMGENC_Params | IMGENC_Params
This structure defines the parameters necessary to create an instance of an image encoder object.
typedef IIMGENC_InArgs | IMGENC_InArgs
typedef IIMGENC_OutArgs | IMGENC_OutArgs
typedef IIMGENC_Cmd | IMGENC_Cmd
typedef IIMGENC_DynamicParams | IMGENC_DynamicParams

Functions

IMGENC_Handle | IMGENC_create (Engine_Handle e, String name, IMGENC_Params *params)
Create an instance of an image encoder algorithm.
Int32 | IMGENC_process (IMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IMGENC_InArgs *inArgs, IMGENC_OutArgs *outArgs)
Execute the process() method in this instance of an image encoder algorithm.
Int32 | IMGENC_control (IMGENC_Handle handle, IMGENC_Cmd id, IMGENC_DynamicParams *params, IMGENC_Status *status)
Execute the control() method in this instance of an image encoder algorithm.
Void | IMGENC_delete (IMGENC_Handle handle)
Delete the instance of an image encoder algorithm.
XDAS_Int32 | IMGENC_processAsync (IMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of an image encoder algorithm.
XDAS_Int32 | IMGENC_processWait (IMGENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGENC_processAsync() in this instance of an image encoder algorithm.


Codec Engine Application Programming Interface (API): imgenc1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » image1

imgenc1.h File Reference

Detailed Description

The IMGENC1 image encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IIMGENC1 image encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iimgenc1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for imgenc1.h:

Go to the source code of this file.

Data Structures

struct | IIMGENC1_CodecClassConfig
Definition of IIMGENC1 codec class configurable parameters. More...

Defines

#define | IMGENC1_EOK IIMGENC1_EOK
#define | IMGENC1_EFAIL IIMGENC1_EFAIL
#define | IMGENC1_EUNSUPPORTED IIMGENC1_EUNSUPPORTED
#define | IMGENC1_ETIMEOUT VISA_ETIMEOUT
#define | IMGENC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | IMGENC1_Handle
Opaque handle to a IMGENC1 codec.
typedef struct IIMGENC1_Params | IMGENC1_Params
typedef IIMGENC1_InArgs | IMGENC1_InArgs
typedef IIMGENC1_OutArgs | IMGENC1_OutArgs
typedef IIMGENC1_Cmd | IMGENC1_Cmd
typedef IIMGENC1_DynamicParams | IMGENC1_DynamicParams
typedef IIMGENC1_Status | IMGENC1_Status

Functions

Int32 | IMGENC1_control (IMGENC1_Handle handle, IMGENC1_Cmd id, IMGENC1_DynamicParams *params, IMGENC1_Status *status)
Execute the control() method in this instance of an image encoder algorithm.
IMGENC1_Handle | IMGENC1_create (Engine_Handle e, String name, IMGENC1_Params *params)
Create an instance of an image encoder algorithm.
Void | IMGENC1_delete (IMGENC1_Handle handle)
Delete the instance of a image encoder algorithm.
Int32 | IMGENC1_process (IMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IMGENC1_InArgs *inArgs, IMGENC1_OutArgs *outArgs)
Execute the process() method in this instance of an image encoder algorithm.
XDAS_Int32 | IMGENC1_processAsync (IMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a image encoder algorithm.
XDAS_Int32 | IMGENC1_processWait (IMGENC1_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of IMGENC1_processAsync() in this instance of an image encoder algorithm.


Codec Engine Application Programming Interface (API): ispeech.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across the various speech codecs.

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Enumerations

enum ISPEECH_VoiceMode {
ISPEECH_VOICED = 0,
ISPEECH_UNVOICED
}

XDM supported voice modes for speech.

More...
enum ISPEECH_CompoundLaw {
ISPEECH_LINEAR = 0,
ISPEECH_ALAW,
ISPEECH_ULAW
}


Codec Engine Application Programming Interface (API): ispeech1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across the various speech codecs.

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Enumerations

enum ISPEECH1_NullTrafficMode {
ISPEECH1_NULLTRAFFICMODE_OFF = 0,
ISPEECH1_NULLTRAFFICMODE_ON = 1,
ISPEECH1_NULLTRAFFICMODE_DEFAULT = ISPEECH1_NULLTRAFFICMODE_OFF
}

Null traffic channel setting.

More...
enum ISPEECH1_PostFilter {
ISPEECH1_POSTFILTER_OFF = 0,
ISPEECH1_POSTFILTER_ON = 1,
ISPEECH1_POSTFILTER_DEFAULT = ISPEECH1_POSTFILTER_ON
}

Post filter setting.

More...
enum ISPEECH1_VADFlag {
ISPEECH1_VADFLAG_OFF = 0,
ISPEECH1_VADFLAG_ON = 1,
ISPEECH1_VADFLAG_DEFAULT = ISPEECH1_VADFLAG_ON
}

Voice Activity Detection (VAD) setting.

More...


Codec Engine Application Programming Interface (API): ispeech1_amr.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_amr.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are needed for AMR.

#include "ispeech1.h"
Include dependency graph for ispeech1_amr.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_AMR_BitRate {
ISPEECH1_AMR_BITRATE_4P75 = 0,
ISPEECH1_AMR_BITRATE_5P15 = 1,
ISPEECH1_AMR_BITRATE_5P9 = 2,
ISPEECH1_AMR_BITRATE_6P7 = 3,
ISPEECH1_AMR_BITRATE_7P4 = 4,
ISPEECH1_AMR_BITRATE_7P95 = 5,
ISPEECH1_AMR_BITRATE_10P2 = 6,
ISPEECH1_AMR_BITRATE_12P2 = 7,
ISPEECH1_AMR_BITRATE_DEFAULT = ISPEECH1_AMR_BITRATE_12P2
}

Bitrate selection for AMR.

More...
enum ISPEECH1_AMR_CodecSelect {
ISPEECH1_AMR_CODECSELECT_PRIMARY = 0,
ISPEECH1_AMR_CODECSELECT_SECONDARY = 1,
ISPEECH1_AMR_CODECSELECT_DEFAULT = ISPEECH1_AMR_CODECSELECT_PRIMARY
}

Codec selection.

More...
enum ISPEECH1_AMR_PackingType {
ISPEECH1_AMR_PACKTYPE_IF1_NOCRC = 0,
ISPEECH1_AMR_PACKTYPE_IF1_WITHCRC = 1,
ISPEECH1_AMR_PACKTYPE_IF2 = 2,
ISPEECH1_AMR_PACKTYPE_MIME = 3,
ISPEECH1_AMR_PACKTYPEFORMAT_DEFAULT = ISPEECH1_AMR_PACKTYPE_IF1_NOCRC
}

Packing type options for AMR.

More...
enum ISPEECH1_AMR_VADSelect {
ISPEECH1_AMR_VADSELECT_VAD1 = 1,
ISPEECH1_AMR_VADSELECT_VAD2 = 2,
ISPEECH1_AMR_VADSELECT_DEFAULT = ISPEECH1_AMR_VADSELECT_VAD1
}

Voice activity detector (VAD) selection.

More...


Codec Engine Application Programming Interface (API): ispeech1_evrc.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_evrc.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are needed for EVRC.

#include "ispeech1.h"
Include dependency graph for ispeech1_evrc.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_EVRC_NoisePreProc {
ISPEECH1_EVRC_NOISEPREPROC_OFF = 0,
ISPEECH1_EVRC_NOISEPREPROC_ON = 1,
ISPEECH1_EVRC_NOISEPREPROC_DEFAULT = ISPEECH1_EVRC_NOISEPREPROC_ON
}

Enable/disable noise suppression.

More...
enum ISPEECH1_EVRC_TTYMode {
ISPEECH1_EVRC_TTYMODE_OFF = 0,
ISPEECH1_EVRC_TTYMODE_45P45BPS = 1,
ISPEECH1_EVRC_TTYMODE_50BPS = 2,
ISPEECH1_EVRC_TTYMODE_DEFAULT = ISPEECH1_EVRC_TTYMODE_OFF
}

TTY/TDD mode selection.

More...
enum ISPEECH1_EVRC_Mode {
ISPEECH1_EVRC_MODE_PREMIUM = 0,
ISPEECH1_EVRC_MODE_STANDARD = 1,
ISPEECH1_EVRC_MODE_ECONOMY = 2,
ISPEECH1_EVRC_MODE_CAPACITYSAVE = 3,
ISPEECH1_EVRC_MODE_HALFRATE_MAX = 4,
ISPEECH1_EVRC_MODE_DEFAULT = ISPEECH1_EVRC_MODE_PREMIUM
}

Mode selection.

More...


Codec Engine Application Programming Interface (API): ispeech1_g723.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_g723.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are needed for G.723.

#include "ispeech1.h"
Include dependency graph for ispeech1_g723.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_G723_BitRate {
ISPEECH1_G723_BITRATE_5P3 = 0,
ISPEECH1_G723_BITRATE_6P3 = 1,
ISPEECH1_G723_BITRATE_DEFAULT = ISPEECH1_G723_BITRATE_6P3
}

Bit rate selection for G723.

More...
enum ISPEECH1_G723_NoisePreProc {
ISPEECH1_G723_NOISEPREPROC_OFF = 0,
ISPEECH1_G723_NOISEPREPROC_ON = 1,
ISPEECH1_G723_NOISEPREPROC_DEFAULT = ISPEECH1_G723_NOISEPREPROC_ON
}

Enable/disable high pass filter for G723.

More...


Codec Engine Application Programming Interface (API): ispeech1_g726.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_g726.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are needed for G.726.

#include "ispeech1.h"
Include dependency graph for ispeech1_g726.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_G726_BitRate {
ISPEECH1_G726_BITRATE_16 = 0,
ISPEECH1_G726_BITRATE_24 = 1,
ISPEECH1_G726_BITRATE_32 = 2,
ISPEECH1_G726_BITRATE_40 = 3,
ISPEECH1_G726_BITRATE_DEFAULT = ISPEECH1_G726_BITRATE_40
}

Bit rate selection for G726.

More...
enum ISPEECH1_G726_CompandingLaw {
ISPEECH1_G726_COMPAND_LINEAR = 0,
ISPEECH1_G726_COMPAND_ALAW = 1,
ISPEECH1_G726_COMPAND_ULAW = 2,
ISPEECH1_G726_COMPAND_DEFAULT = ISPEECH1_G726_COMPAND_LINEAR
}

Companding law of encoder input and decoder output samples.

More...
enum ISPEECH1_G726_PackingType {
ISPEECH1_G726_PACKTYPE_LINEAR = 0,
ISPEECH1_G726_PACKTYPE_RTPSPECIAL = 1,
ISPEECH1_G726_PACKTYPEFORMAT_DEFAULT = ISPEECH1_G726_PACKTYPE_LINEAR
}

Packing Type defintions for G.726.

More...


Codec Engine Application Programming Interface (API): ispeech1_pcm.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_pcm.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across all G.711/PCM speech codecs.

#include "ispeech1.h"
Include dependency graph for ispeech1_pcm.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_PCM_CompandingLaw {
ISPEECH1_PCM_COMPAND_LINEAR = 0,
ISPEECH1_PCM_COMPAND_ALAW = 1,
ISPEECH1_PCM_COMPAND_ULAW = 2,
ISPEECH1_PCM_COMPAND_DEFAULT = ISPEECH1_PCM_COMPAND_LINEAR
}

Companding law of encoder input and decoder output samples.

More...


Codec Engine Application Programming Interface (API): ispeech1_smv.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_smv.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across all SMV speech codecs.

#include "ispeech1.h"
Include dependency graph for ispeech1_smv.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_SMV_NoisePreProc {
ISPEECH1_SMV_NOISEPREPROC_OFF = 0,
ISPEECH1_SMV_NOISEPREPROC_NSA = 1,
ISPEECH1_SMV_NOISEPREPROC_NSB = 2,
ISPEECH1_SMV_NOISEPREPROC_DEFAULT = ISPEECH1_SMV_NOISEPREPROC_NSA
}

Enabling/disabling noise suppression, and selection of noise suppression if the codec supports multiple noise supression modules.

More...
enum ISPEECH1_SMV_VADSelect {
ISPEECH1_SMV_VADSELECT_VADA = 1,
ISPEECH1_SMV_VADSELECT_VADB = 2,
ISPEECH1_SMV_VADSELECT_DEFAULT = ISPEECH1_SMV_VADSELECT_VADA
}

Voice activity detection (VAD) selection.

More...
enum ISPEECH1_SMV_TTYMode {
ISPEECH1_SMV_TTYMODE_OFF = 0,
ISPEECH1_SMV_TTYMODE_45P45BPS = 1,
ISPEECH1_SMV_TTYMODE_50BPS = 2,
ISPEECH1_SMV_TTYMODE_DEFAULT = ISPEECH1_SMV_TTYMODE_OFF
}

TTY/TDD mode selection.

More...
enum ISPEECH1_SMV_DTMFMode {
ISPEECH1_SMV_DTMFMODE_OFF = 0,
ISPEECH1_SMV_DTMFMODE_ON = 1,
ISPEECH1_SMV_DTMFMODE_DEFAULT = ISPEECH1_SMV_DTMFMODE_OFF
}

DTMF mode selection.

More...
enum ISPEECH1_SMV_DataMode {
ISPEECH1_SMV_DATAMODE_OFF = 0,
ISPEECH1_SMV_DATAMODE_HALFRATE = 1,
ISPEECH1_SMV_DATAMODE_FULLRATE = 1,
ISPEECH1_SMV_DATAMODE_DEFAULT = ISPEECH1_SMV_DATAMODE_OFF
}

Enable/disable in band data transmission and data rate selection.

More...
enum ISPEECH1_SMV_Mode {
ISPEECH1_SMV_MODE_PREMIUM = 0,
ISPEECH1_SMV_MODE_STANDARD = 1,
ISPEECH1_SMV_MODE_ECONOMY = 2,
ISPEECH1_SMV_MODE_CAPACITYSAVE = 3,
ISPEECH1_SMV_MODE_PREMIUM_HALFRATE_MAX = 4,
ISPEECH1_SMV_MODE_STANDARD_HALFRATE_MAX = 5,
ISPEECH1_SMV_MODE_DEFAULT = ISPEECH1_SMV_MODE_PREMIUM
}

Rate reduction mode selection.

More...


Codec Engine Application Programming Interface (API): ispeech1_wbamr.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_wbamr.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are needed for WB-AMR.

#include "ispeech1.h"
Include dependency graph for ispeech1_wbamr.h:

Go to the source code of this file.

Enumerations

enum ISPEECH1_WBAMR_PackingType {
ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC = 0,
ISPEECH1_WBAMR_PACKTYPE_IF1_WITHCRC = 1,
ISPEECH1_WBAMR_PACKTYPE_IF2 = 2,
ISPEECH1_WBAMR_PACKTYPE_MIME = 3,
ISPEECH1_WBAMR_PACKTYPEFORMAT_DEFAULT = ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC
}

Packing Type defintions for AMR.

More...
enum ISPEECH1_WBAMR_BitRate {
ISPEECH1_WBAMR_BITRATE_6P60 = 0,
ISPEECH1_WBAMR_BITRATE_8P85 = 1,
ISPEECH1_WBAMR_BITRATE_12P65 = 2,
ISPEECH1_WBAMR_BITRATE_14P25 = 3,
ISPEECH1_WBAMR_BITRATE_15P85 = 4,
ISPEECH1_WBAMR_BITRATE_18P25 = 5,
ISPEECH1_WBAMR_BITRATE_19P85 = 6,
ISPEECH1_WBAMR_BITRATE_23P05 = 7,
ISPEECH1_WBAMR_BITRATE_23P85 = 8,
ISPEECH1_WBAMR_BITRATE_DEFAULT = ISPEECH1_WBAMR_BITRATE_23P85
}

Bitrate selection for AMR.

More...


Codec Engine Application Programming Interface (API): isphdec.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphdec.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the speech/voice decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ispeech.h"
Include dependency graph for isphdec.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ISPHDEC_Obj
This must be the first field of all ISPHDEC instance objects. More...
struct | ISPHDEC_Params
Defines the creation time parameters for all ISPHDEC instance objects. More...
struct | ISPHDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | ISPHDEC_InArgs
Defines the input arguments for all ISPHDEC instance process function. More...
struct | ISPHDEC_Status
Defines instance status parameters (read-only). More...
struct | ISPHDEC_OutArgs
Defines the run time output arguments for all ISPHDEC instance objects. More...
struct | ISPHDEC_Fxns
Defines all of the operations on ISPHDEC objects. More...

Defines

#define | ISPHDEC_CID "ti.xdais.dm.ISPHDEC"
#define | ISPHDEC_ERUNTIME XDM_ERUNTIME
#define | ISPHDEC_EOK XDM_EOK
#define | ISPHDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct ISPHDEC_Obj * | ISPHDEC_Handle
Opaque handle to an ISPHDEC objects.
typedef IALG_Cmd | ISPHDEC_Cmd
Defines the control commands for the ISPHDEC module.


Codec Engine Application Programming Interface (API): isphdec1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphdec1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the speech/voice decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ispeech1.h"
Include dependency graph for isphdec1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ISPHDEC1_Obj
This must be the first field of all ISPHDEC1 instance objects. More...
struct | ISPHDEC1_Params
Defines the creation time parameters for all ISPHDEC1 instance objects. More...
struct | ISPHDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via ISPHDEC1_Fxns.control(). More...
struct | ISPHDEC1_InArgs
Defines the input arguments for all ISPHDEC1 instance process function. More...
struct | ISPHDEC1_Status
Defines instance status parameters. More...
struct | ISPHDEC1_OutArgs
Defines the run time output arguments for all ISPHDEC1 instance objects. More...
struct | ISPHDEC1_Fxns
Defines all of the operations on ISPHDEC1 objects. More...

Defines

#define | ISPHDEC1_EOK XDM_EOK
#define | ISPHDEC1_EFAIL XDM_EFAIL
#define | ISPHDEC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct ISPHDEC1_Obj * | ISPHDEC1_Handle
Opaque handle to an ISPHDEC1 objects.
typedef IALG_Cmd | ISPHDEC1_Cmd
Defines the control commands for the ISPHDEC1 module.

Enumerations

enum ISPHDEC1_FrameType {
ISPHDEC1_FTYPE_SPEECHGOOD = 0,
ISPHDEC1_FTYPE_SIDUPDATE = 1,
ISPHDEC1_FTYPE_NODATA = 2,
ISPHDEC1_FTYPE_SPEECHLOST = 3,
ISPHDEC1_FTYPE_DEGRADED = 4,
ISPHDEC1_FTYPE_BAD = 5,
ISPHDEC1_FTYPE_SIDFIRST = 6,
ISPHDEC1_FTYPE_SIDBAD = 7,
ISPHDEC1_FTYPE_ONSET = 8
}

Decoder frame types.

More...


Codec Engine Application Programming Interface (API): isphenc.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphenc.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the speech/voice encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ispeech.h"
Include dependency graph for isphenc.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ISPHENC_Obj
This must be the first field of all ISPHENC instance objects. More...
struct | ISPHENC_Params
Defines the creation time parameters for all ISPHENC instance objects. More...
struct | ISPHENC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | ISPHENC_InArgs
Defines the input arguments for all ISPHENC instance process function. More...
struct | ISPHENC_Status
Defines instance status parameters (read-only). More...
struct | ISPHENC_OutArgs
Defines the run time output arguments for all ISPHENC instance objects. More...
struct | ISPHENC_Fxns
Defines all of the operations on ISPHENC objects. More...

Defines

#define | ISPHENC_CID "ti.xdais.dm.ISPHENC"
#define | ISPHENC_ERUNTIME XDM_ERUNTIME
#define | ISPHENC_EOK XDM_EOK
#define | ISPHENC_EFAIL XDM_EFAIL

Typedefs

typedef struct ISPHENC_Obj * | ISPHENC_Handle
Opaque handle to an ISPHENC objects.
typedef IALG_Cmd | ISPHENC_Cmd
Defines the control commands for the ISPHENC module.


Codec Engine Application Programming Interface (API): isphenc1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphenc1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the speech/voice encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ispeech1.h"
Include dependency graph for isphenc1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | ISPHENC1_Obj
This must be the first field of all ISPHENC1 instance objects. More...
struct | ISPHENC1_Params
Defines the creation time parameters for all ISPHENC1 instance objects. More...
struct | ISPHENC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via ISPHENC1_Fxns.control(). More...
struct | ISPHENC1_InArgs
Defines the input arguments for all ISPHENC1 instance process function. More...
struct | ISPHENC1_Status
Defines instance status parameters. More...
struct | ISPHENC1_OutArgs
Defines the run time output arguments for all ISPHENC1 instance objects. More...
struct | ISPHENC1_Fxns
Defines all of the operations on ISPHENC1 objects. More...

Defines

#define | ISPHENC1_EOK XDM_EOK
#define | ISPHENC1_EFAIL XDM_EFAIL
#define | ISPHENC1_EUNSUPPORTED XDM_EUNSUPPORTED
#define | ISPHENC1_ENOOUTPUT 1
This value signifies no output being available at encoder, for example in the case of intermediate calls in 10msec frame size execution.

Typedefs

typedef struct ISPHENC1_Obj * | ISPHENC1_Handle
Opaque handle to an ISPHENC1 objects.
typedef IALG_Cmd | ISPHENC1_Cmd
Defines the control commands for the ISPHENC1 module.

Enumerations

enum ISPHENC1_FrameType {
ISPHENC1_FTYPE_SPEECH = 0,
ISPHENC1_FTYPE_SIDFRAME = 1,
ISPHENC1_FTYPE_NODATA = 2
}

Encoder frame types.

More...


Codec Engine Application Programming Interface (API): iuniversal.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iuniversal.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the "universal" XDM algorithm.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
Include dependency graph for iuniversal.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IUNIVERSAL_Obj
This must be the first field of all IUNIVERSAL instance objects. More...
struct | IUNIVERSAL_Params
Defines the creation time parameters for all IUNIVERSAL instance objects. More...
struct | IUNIVERSAL_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IUNIVERSAL_InArgs
Defines the input arguments for all IUNIVERSAL instance process function. More...
struct | IUNIVERSAL_Status
Defines instance status parameters (read-only). More...
struct | IUNIVERSAL_OutArgs
Defines the run time output arguments for all IUNIVERSAL instance objects. More...
struct | IUNIVERSAL_Fxns
Defines all of the operations on IUNIVERSAL objects. More...

Defines

#define | IUNIVERSAL_EOK XDM_EOK
#define | IUNIVERSAL_EFAIL XDM_EFAIL
#define | IUNIVERSAL_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IUNIVERSAL_Obj * | IUNIVERSAL_Handle
Opaque handle to an IUNIVERSAL objects.
typedef IALG_Cmd | IUNIVERSAL_Cmd
Defines the control commands for the IUNIVERSAL module.


Codec Engine Application Programming Interface (API): ividanalytics.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividanalytics.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video analytics algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
Include dependency graph for ividanalytics.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDANALYTICS_Grid
Access modes used to declare how the algorithm accessed buffers. More...
struct | IVIDANALYTICS_Rule
Analytics rule. More...
struct | IVIDANALYTICS_Obj
This must be the first field of all IVIDANALYTICS instance objects. More...
struct | IVIDANALYTICS_Params
Defines the creation time parameters for all IVIDANALYTICS instance objects. More...
struct | IVIDANALYTICS_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IVIDANALYTICS_InArgs
Defines the input arguments for all IVIDANALYTICS instance process function. More...
struct | IVIDANALYTICS_Status
Defines instance status parameters. More...
struct | IVIDANALYTICS_OutArgs
Defines the run time output arguments for all IVIDANALYTICS instance objects. More...
struct | IVIDANALYTICS_Fxns
Defines all of the operations on IVIDANALYTICS objects. More...

Defines

#define | IVIDANALYTICS_EOK XDM_EOK
#define | IVIDANALYTICS_EFAIL XDM_EFAIL
#define | IVIDANALYTICS_EUNSUPPORTED XDM_EUNSUPPORTED
#define | IVIDANALYTICS_SETRULE XDM_CLASSCMDBASE
Set a new rule.
#define | IVIDANALYTICS_CLEARRULE XDM_CLASSCMDBASE + 1
Clear a rule.
#define | IVIDANALYTICS_MAXTARGETS 128
Maximum targets that can be detected per process() call.
#define | IVIDANALYTICS_MAXEVENTS 128
Maximum number of events that can be detected per process() call.

Typedefs

typedef struct IVIDANALYTICS_Obj * | IVIDANALYTICS_Handle
Opaque handle to an IVIDANALYTICS objects.
typedef IALG_Cmd | IVIDANALYTICS_Cmd
Defines the control commands for the IVIDANALYTICS module.

Enumerations

enum IVIDANALYTICS_AnalysisMask {
IVIDANALYTICS_MOTIONDETECT = 0,
IVIDANALYTICS_OBJECTTRACKING = 1,
IVIDANALYTICS_USERBASE = 16
}

Access modes used to declare how the algorithm accessed buffers.

More...
enum IVIDANALYTICS_ObjectType {
IVIDANALYTICS_OBJECTTYPE_VEHICLE = 0,
IVIDANALYTICS_OBJECTTYPE_HUMAN = 1,
IVIDANALYTICS_OBJECTTYPE_USERBASE = 256
}

Types of objects.

More...
enum IVIDANALYTICS_ActionType {
IVIDANALYTICS_ACTIONTYPE_LOITER = 0,
IVIDANALYTICS_ACTIONTYPE_ENTER = 1,
IVIDANALYTICS_ACTIONTYPE_EXIT = 2,
IVIDANALYTICS_ACTIONTYPE_APPEAR = 3,
IVIDANALYTICS_ACTIONTYPE_DISAPPEAR = 4,
IVIDANALYTICS_ACTIONTYPE_CROSSL2R = 5,
IVIDANALYTICS_ACTIONTYPE_CROSSR2L = 6,
IVIDANALYTICS_ACTIONTYPE_CROSSU2D = 7,
IVIDANALYTICS_ACTIONTYPE_CROSSD2U = 8,
IVIDANALYTICS_ACTIONTYPE_USERBASE = 256
}

Types of objects.

More...
enum IVIDANALYTICS_ViewState {
IVIDANALYTICS_VIEWSTATE_BAD = 0,
IVIDANALYTICS_VIEWSTATE_GOOD = 1
}

View state of the analytics engine.

More...


Codec Engine Application Programming Interface (API): ividdec.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividdec.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ivideo.h"
Include dependency graph for ividdec.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDDEC_Obj
This must be the first field of all IVIDDEC instance objects. More...
struct | IVIDDEC_Params
Defines the creation time parameters for all IVIDDEC instance objects. More...
struct | IVIDDEC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDDEC_InArgs
Defines the input arguments for all IVIDDEC instance process function. More...
struct | IVIDDEC_Status
Defines instance status parameters. More...
struct | IVIDDEC_OutArgs
Defines the run time output arguments for all IVIDDEC instance objects. More...
struct | IVIDDEC_Fxns
Defines all of the operations on IVIDDEC objects. More...

Defines

#define | IVIDDEC_CID "ti.xdais.dm.IVIDDEC"
#define | IVIDDEC_ERUNTIME XDM_ERUNTIME
#define | IVIDDEC_EOK XDM_EOK
#define | IVIDDEC_EFAIL XDM_EFAIL

Typedefs

typedef struct IVIDDEC_Obj * | IVIDDEC_Handle
Opaque handle to an IVIDDEC objects.
typedef IALG_Cmd | IVIDDEC_Cmd
Defines the control commands for the IVIDDEC module.


Codec Engine Application Programming Interface (API): ividdec1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividdec1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ivideo.h"
Include dependency graph for ividdec1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDDEC1_Obj
This must be the first field of all IVIDDEC1 instance objects. More...
struct | IVIDDEC1_Params
Defines the creation time parameters for all IVIDDEC1 instance objects. More...
struct | IVIDDEC1_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDDEC1_InArgs
Defines the input arguments for all IVIDDEC1 instance process function. More...
struct | IVIDDEC1_Status
Defines instance status parameters. More...
struct | IVIDDEC1_OutArgs
Defines the run time output arguments for all IVIDDEC1 instance objects. More...
struct | IVIDDEC1_Fxns
Defines all of the operations on IVIDDEC1 objects. More...

Defines

#define | IVIDDEC1_EOK XDM_EOK
#define | IVIDDEC1_EFAIL XDM_EFAIL
#define | IVIDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED
#define | IVIDDEC1_FREE_BUFF_SIZE 16

Typedefs

typedef struct IVIDDEC1_Obj * | IVIDDEC1_Handle
Opaque handle to an IVIDDEC1 objects.
typedef IALG_Cmd | IVIDDEC1_Cmd
Defines the control commands for the IVIDDEC1 module.

Enumerations

enum IVIDDEC1_FrameOrder {
IVIDDEC_DISPLAY_ORDER = 0,
IVIDDEC_DECODE_ORDER = 1,
IVIDDEC_FRAMEORDER_DEFAULT = IVIDDEC_DISPLAY_ORDER
}

Video decoder output frame order.

More...


Codec Engine Application Programming Interface (API): ividdec2.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividdec2.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ivideo.h"
Include dependency graph for ividdec2.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDDEC2_Obj
This must be the first field of all IVIDDEC2 instance objects. More...
struct | IVIDDEC2_Params
Defines the creation time parameters for all IVIDDEC2 instance objects. More...
struct | IVIDDEC2_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDDEC2_InArgs
Defines the input arguments for all IVIDDEC2 instance process function. More...
struct | IVIDDEC2_Status
Defines instance status parameters. More...
struct | IVIDDEC2_OutArgs
Defines the run time output arguments for all IVIDDEC2 instance objects. More...
struct | IVIDDEC2_Fxns
Defines all of the operations on IVIDDEC2 objects. More...

Defines

#define | IVIDDEC2_MAX_IO_BUFFERS 20
Maximum I/O Buffers.
#define | IVIDDEC2_EOK XDM_EOK
#define | IVIDDEC2_EFAIL XDM_EFAIL
#define | IVIDDEC2_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IVIDDEC2_Obj * | IVIDDEC2_Handle
Opaque handle to an IVIDDEC2 objects.
typedef IALG_Cmd | IVIDDEC2_Cmd
Defines the control commands for the IVIDDEC2 module.

Enumerations

enum IVIDDEC2_FrameOrder {
IVIDDEC2_DISPLAY_ORDER = 0,
IVIDDEC2_DECODE_ORDER = 1,
IVIDDEC2_FRAMEORDER_DEFAULT = IVIDDEC2_DISPLAY_ORDER
}

Video decoder output frame order.

More...


Codec Engine Application Programming Interface (API): ividdec2.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm » split

split/ividdec2.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across all split IVIDDEC2-based codecs.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "../xdm.h"
#include "../ividdec2.h"
Include dependency graph for split/ividdec2.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDDEC2FRONT_Obj
This must be the first field of all IVIDDEC2FRONT instance objects. More...
struct | IVIDDEC2BACK_Obj
This must be the first field of all IVIDDEC2BACK instance objects. More...
struct | IVIDDEC2FRONT_Status
Defines instance status parameters. More...
struct | IVIDDEC2FRONT_OutArgs
Defines the run time output arguments for all IVIDDEC2FRONT instance objects. More...
struct | IVIDDEC2FRONT_Fxns
Defines all of the operations on IVIDDEC2FRONT objects. More...
struct | IVIDDEC2BACK_Fxns
Defines all of the operations on IVIDDEC2BACK objects. More...

Typedefs

typedef struct IVIDDEC2FRONT_Obj * | IVIDDEC2FRONT_Handle
Opaque handle to an IVIDDEC2FRONT objects.
typedef struct IVIDDEC2BACK_Obj * | IVIDDEC2BACK_Handle
Opaque handle to an IVIDDEC2BACK objects.


Codec Engine Application Programming Interface (API): ividenc.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividenc.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ivideo.h"
Include dependency graph for ividenc.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDENC_Obj
This must be the first field of all IVIDENC instance objects. More...
struct | IVIDENC_Params
Defines the creation time parameters for all IVIDENC instance objects. More...
struct | IVIDENC_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDENC_InArgs
Defines the input arguments for all IVIDDEC instance process function. More...
struct | IVIDENC_Status
Defines instance status parameters (read-only). More...
struct | IVIDENC_OutArgs
Defines the run time output arguments for all IVIDENC instance objects. More...
struct | IVIDENC_Fxns
Defines all of the operations on IVIDENC objects. More...

Defines

#define | IVIDENC_CID "ti.xdais.dm.IVIDENC"
#define | IVIDENC_ERUNTIME XDM_ERUNTIME
#define | IVIDENC_EOK XDM_EOK
#define | IVIDENC_EFAIL XDM_EFAIL

Typedefs

typedef struct IVIDENC_Obj * | IVIDENC_Handle
Opaque handle to an IVIDENC objects.
typedef IALG_Cmd | IVIDENC_Cmd
Defines the control commands for the IVIDENC module.


Codec Engine Application Programming Interface (API): ividenc1.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividenc1.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video encoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ivideo.h"
Include dependency graph for ividenc1.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDENC1_Obj
This must be the first field of all IVIDENC1 instance objects. More...
struct | IVIDENC1_Params
Defines the creation time parameters for all IVIDENC1 instance objects. More...
struct | IVIDENC1_DynamicParams
This structure defines the algorithm parameters that can be modified after creation via control() calls. More...
struct | IVIDENC1_InArgs
Defines the input arguments for all IVIDENC1 instance process function. More...
struct | IVIDENC1_Status
Defines instance status parameters. More...
struct | IVIDENC1_OutArgs
Defines the run time output arguments for all IVIDENC1 instance objects. More...
struct | IVIDENC1_MbData
Defines the structure that contains macroblock related encoding parameter estimates. More...
struct | IVIDENC1_Fxns
Defines all of the operations on IVIDENC1 objects. More...

Defines

#define | IVIDENC1_EOK XDM_EOK
#define | IVIDENC1_EFAIL XDM_EFAIL
#define | IVIDENC1_EUNSUPPORTED XDM_EUNSUPPORTED

Typedefs

typedef struct IVIDENC1_Obj * | IVIDENC1_Handle
Opaque handle to an IVIDENC1 objects.
typedef IALG_Cmd | IVIDENC1_Cmd
Defines the control commands for the IVIDENC1 module.


Codec Engine Application Programming Interface (API): ivideo.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ivideo.h File Reference

Detailed Description

This header defines all types, constants, enums, and functions that are common across the various video codecs.

This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDEO_BufDesc
Buffer descriptor for video buffers. More...
struct | IVIDEO1_BufDescIn
Buffer descriptor for input video buffers. More...
struct | IVIDEO1_BufDesc
Detailed buffer descriptor for video buffers. More...

Defines

#define | IVIDEO_MAX_YUV_BUFFERS 3
Max YUV buffers - one each for 'Y', 'U', and 'V'.

Enumerations

enum IVIDEO_FrameSkip {
IVIDEO_NO_SKIP = 0,
IVIDEO_SKIP_P = 1,
IVIDEO_SKIP_B = 2,
IVIDEO_SKIP_I = 3,
IVIDEO_SKIP_IP = 4,
IVIDEO_SKIP_IB = 5,
IVIDEO_SKIP_PB = 6,
IVIDEO_SKIP_IPB = 7,
IVIDEO_SKIP_IDR = 8,
IVIDEO_SKIP_DEFAULT = IVIDEO_NO_SKIP
}

Video frame skip features for video decoder.

More...
enum IVIDEO_FrameType {
IVIDEO_NA_FRAME = -1,
IVIDEO_I_FRAME = 0,
IVIDEO_P_FRAME = 1,
IVIDEO_B_FRAME = 2,
IVIDEO_IDR_FRAME = 3,
IVIDEO_II_FRAME = 4,
IVIDEO_IP_FRAME = 5,
IVIDEO_IB_FRAME = 6,
IVIDEO_PI_FRAME = 7,
IVIDEO_PP_FRAME = 8,
IVIDEO_PB_FRAME = 9,
IVIDEO_BI_FRAME = 10,
IVIDEO_BP_FRAME = 11,
IVIDEO_BB_FRAME = 12,
IVIDEO_MBAFF_I_FRAME = 13,
IVIDEO_MBAFF_P_FRAME = 14,
IVIDEO_MBAFF_B_FRAME = 15,
IVIDEO_MBAFF_IDR_FRAME = 16,
IVIDEO_FRAMETYPE_DEFAULT = IVIDEO_I_FRAME
}

Video frame types.

More...
enum IVIDEO_ContentType {
IVIDEO_CONTENTTYPE_NA = -1,
IVIDEO_PROGRESSIVE = 0,
IVIDEO_PROGRESSIVE_FRAME = IVIDEO_PROGRESSIVE,
IVIDEO_INTERLACED = 1,
IVIDEO_INTERLACED_FRAME = IVIDEO_INTERLACED,
IVIDEO_INTERLACED_TOPFIELD = 2,
IVIDEO_INTERLACED_BOTTOMFIELD = 3,
IVIDEO_CONTENTTYPE_DEFAULT = IVIDEO_PROGRESSIVE
}

Video content types.

More...
enum IVIDEO_RateControlPreset {
IVIDEO_LOW_DELAY = 1,
IVIDEO_STORAGE = 2,
IVIDEO_TWOPASS = 3,
IVIDEO_NONE = 4,
IVIDEO_USER_DEFINED = 5,
IVIDEO_RATECONTROLPRESET_DEFAULT = IVIDEO_LOW_DELAY
}

Video rate control presets.

More...
enum IVIDEO_SkipMode {
IVIDEO_FRAME_ENCODED = 0,
IVIDEO_FRAME_SKIPPED = 1,
IVIDEO_SKIPMODE_DEFAULT = IVIDEO_FRAME_ENCODED
}

Video frame skipping modes.

More...
enum IVIDEO_OutputFrameStatus {
IVIDEO_FRAME_NOERROR = 0,
IVIDEO_FRAME_NOTAVAILABLE = 1,
IVIDEO_FRAME_ERROR = 2,
IVIDEO_OUTPUTFRAMESTATUS_DEFAULT = IVIDEO_FRAME_NOERROR
}

Video output buffer status.

More...
enum IVIDEO_PictureType {
IVIDEO_NA_PICTURE = -1,
IVIDEO_I_PICTURE = 0,
IVIDEO_P_PICTURE = 1,
IVIDEO_B_PICTURE = 2,
IVIDEO_PICTURE_TYPE_DEFAULT = IVIDEO_I_PICTURE
}

Video Picture types.

More...
enum IVIDEO_Format {
IVIDEO_MPEG1 = 1,
IVIDEO_MPEG2SP = 2,
IVIDEO_MPEG2MP = 3,
IVIDEO_MPEG2HP = 4,
IVIDEO_MPEG4SP = 5,
IVIDEO_MPEG4ASP = 6,
IVIDEO_H264BP = 7,
IVIDEO_H264MP = 8,
IVIDEO_H264HP = 9,
IVIDEO_VC1SP = 10,
IVIDEO_VC1MP = 11,
IVIDEO_VC1AP = 12
}

Video Format types.

More...


Codec Engine Application Programming Interface (API): ividtranscode.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividtranscode.h File Reference

Detailed Description

This header defines all types, constants, and functions shared by all implementations of the video transcoder algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
#include "xdm.h"
#include "ivideo.h"
Include dependency graph for ividtranscode.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDTRANSCODE_Obj
This must be the first field of all IVIDTRANSCODE instance objects. More...
struct | IVIDTRANSCODE_Params
Defines the creation time parameters for all IVIDTRANSCODE instance objects. More...
struct | IVIDTRANSCODE_DynamicParams
This structure defines the codec parameters that can be modified after creation via control() calls. More...
struct | IVIDTRANSCODE_InArgs
Defines the input arguments for all IVIDTRANSCODE instance process function. More...
struct | IVIDTRANSCODE_Status
Defines instance status parameters. More...
struct | IVIDTRANSCODE_OutArgs
Defines the run time output arguments for all IVIDTRANSCODE instance objects. More...
struct | IVIDTRANSCODE_Fxns
Defines all of the operations on IVIDTRANSCODE objects. More...

Defines

#define | IVIDTRANSCODE_EOK XDM_EOK
#define | IVIDTRANSCODE_EFAIL XDM_EFAIL
#define | IVIDTRANSCODE_EUNSUPPORTED XDM_EUNSUPPORTED
#define | IVIDTRANSCODE_MAXOUTSTREAMS 2

Typedefs

typedef struct IVIDTRANSCODE_Obj * | IVIDTRANSCODE_Handle
Opaque handle to an IVIDTRANSCODE objects.
typedef IALG_Cmd | IVIDTRANSCODE_Cmd
Defines the control commands for the IVIDTRANSCODE module.


Codec Engine Application Programming Interface (API): ladclient.h File Reference

  • File List
  • Globals
packages » ti » dsplink » utils » ladclient

ladclient.h File Reference

Detailed Description

The Link Arbiter Daemon (LAD) communication interface. Provides wrapper functions to communicate with LAD, allowing a client to: establish a connection to LAD; request startup of a DSP server executable; query DSP status; and release the DSP and disconnect from LAD.

Go to the source code of this file.

Data Structures

struct | LAD_DspStatus

Defines

#define | LAD_MAXLENGTHIMAGENAME 512
#define | LAD_MAXLENGTHCONFIGNAME 32

Typedefs

typedef Uns | LAD_ClientHandle

Enumerations

enum LAD_Status {
LAD_SUCCESS = 0,
LAD_FAILURE,
LAD_INVALIDARG,
LAD_ACCESSDENIED,
LAD_ALREADYRUNNING,
LAD_STILLRUNNING,
LAD_IOFAILURE,
LAD_NOTCONNECTED,
LAD_INVALIDVERSION
}
enum LAD_DspState {
LAD_UNKNOWN = 0,
LAD_SETUP,
LAD_LOADED,
LAD_STARTED,
LAD_STOPPED,
LAD_IDLE,
LAD_RESET,
LAD_UNAVAILABLE
}

Functions

LAD_Status | LAD_connect (LAD_ClientHandle *handle)
Connect to LAD.
LAD_Status | LAD_disconnect (LAD_ClientHandle handle)
Disconnect from LAD.
LAD_Status | LAD_getDspStatus (LAD_ClientHandle handle, Int cpuId, LAD_DspStatus *statusInfo)
Get DSP status from LAD.
LAD_Status | LAD_releaseDsp (LAD_ClientHandle handle)
Release control of the DSP. This call is only appropriate if the client previously made a successful call to LAD_startupDsp().
LAD_Status | LAD_startupDsp (LAD_ClientHandle handle, Int cpuId, String linkConfigName, String imageName)
Load and start the DSP running.


Codec Engine Application Programming Interface (API): Memory.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » osal

Memory.h File Reference

Detailed Description

The Codec Engine OSAL Memory interface. Provides the user an OS-independent Memory abstraction.

Go to the source code of this file.

Data Structures

struct | Memory_AllocParams
Parameters for Memory_alloc() & Memory_free(). More...

Defines

#define | Memory_DEFAULTALIGNMENT ((UInt)(-1))
#define | Memory_GTNAME "OM"
#define | Memory_CACHED 0x00000000
#define | Memory_NONCACHED 0x00000001
#define | Memory_CACHEDMASK 0x00000001

Enumerations

enum Memory_type {
Memory_MALLOC = 0,
Memory_SEG = 1,
Memory_CONTIGPOOL = 2,
Memory_CONTIGHEAP = 3
}

Enum values for Memory_AllocParams.type.

More...

Functions

Ptr | Memory_alloc (UInt size, Memory_AllocParams *params)
General memory allocation.
Void | Memory_cacheInv (Ptr addr, Int sizeInBytes)
Invalidate a range of cache.
Void | Memory_cacheWb (Ptr addr, Int sizeInBytes)
Write back cache.
Void | Memory_cacheWbInv (Ptr addr, Int sizeInBytes)
Write back and invalidate cache.
Ptr | Memory_contigAlloc (UInt size, UInt align)
Allocate physically contiguous blocks of memory.
Bool | Memory_contigFree (Ptr addr, UInt size)
Free memory allocated by Memory_contigAlloc().
Bool | Memory_free (Ptr addr, UInt size, Memory_AllocParams *params)
Free memory allocated with Memory_alloc().
Void | Memory_dumpKnownContigBufsList (Void)
Dumps the list of all translated/registered bufs.
UInt32 | Memory_getBufferPhysicalAddress (Ptr virtualAddress, Int sizeInBytes, Bool *isContiguous)
Converts application virtual address to a physical address.
Int | Memory_getHeapId (String name)
Get the heap heap ID corresponding to a heap name. This number will be between 0 and the value returned by Memory_getNumHeaps(). The heap Id can be passed to Memory_redefine(), Memory_restoreHeap(), and Memory_segStat().
Int | Memory_getNumHeaps ()
Get the number of memory heaps.
Ptr | Memory_getBufferVirtualAddress (UInt32 physicalAddress, Int sizeInBytes)
Obtains the virtual address of a physically contiguous buffer.
Void | Memory_registerContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes, UInt32 physicalAddress)
Register a physical buffer allocated without Memory_contigAlloc().
Void | Memory_unregisterContigBuf (UInt32 virtualAddress, UInt32 sizeInBytes)
Unregisters a physical buffer allocated without Memory_contigAlloc().

Variables

Memory_AllocParams Memory_DEFAULTPARAMS
Default parameters for Memory_alloc() & Memory_free().


Codec Engine Application Programming Interface (API): Server.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce

Server.h File Reference

Detailed Description

The Codec Engine Server Interface. Provides the user an inteface to open and manipulate a Server which contains remote algorithms.

#include <stdio.h>
Include dependency graph for Server.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | Server_AlgInfo
Properties of a Server algorithm. More...
struct | Server_MemStat
Information for a memory heap of a remote DSP server. More...

Defines

#define | Server_GTNAME "CS"
Trace name for the Server module.
#define | Server_MAXSEGNAMELENGTH 32
Maximum number of characters used in memory segment names.

Typedefs

typedef struct Server_Obj * | Server_Handle
Opaque handle to the server for an engine.

Enumerations

enum Server_Status {
Server_EOK = 0,
Server_ENOSERVER = 1,
Server_ENOMEM = 2,
Server_ERUNTIME = 3,
Server_EINVAL = 4,
Server_EWRONGSTATE = 5,
Server_EINUSE = 6,
Server_ENOTFOUND = 7,
Server_EFAIL = 8
}

Server error code.

More...

Functions

Server_Status | Server_connectTrace (Server_Handle server, Int *token)
Connect to server for purposes of collecting trace and/or LOG data.
Server_Status | Server_disconnectTrace (Server_Handle server, Int token)
Disconnect from server when finished collecting trace and/or LOG data.
Int | Server_fwriteTrace (Server_Handle server, String prefix, FILE *out)
Write Server's trace buffer to specifed file stream.
Int | Server_getAlgInfo (Server_Handle server, Int algNum, Server_AlgInfo *algInfo)
Get information about an algorithm on the remote server.
Int | Server_getCpuLoad (Server_Handle server)
Get Server's CPU usage in percent.
Server_Status | Server_getMemStat (Server_Handle server, Int segNum, Server_MemStat *memStat)
Get information on a memory heap segment of a remote DSP server.
Server_Status | Server_getNumAlgs (Server_Handle server, Int *numAlgs)
Get the number of codecs on the remote DSP server.
Server_Status | Server_getNumMemSegs (Server_Handle server, Int *numSegs)
Get the number of memory heap segments of a remote DSP server.
Server_Status | Server_redefineHeap (Server_Handle server, String name, Uint32 base, Uint32 size)
Set the base address and size of a remote DSP server heap.
Server_Status | Server_restoreHeap (Server_Handle server, String name)
Set the base address and size of a remote DSP server heap back to their original values.
Int | Server_setTrace (Server_Handle server, String mask)
Set Server's trace mask.


Codec Engine Application Programming Interface (API): sphdec.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » speech

sphdec.h File Reference

Detailed Description

The SPHDEC speech decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHDEC speech decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/isphdec.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for sphdec.h:

Go to the source code of this file.

Defines

#define | SPHDEC_EOK ISPHDEC_EOK
#define | SPHDEC_EFAIL ISPHDEC_EFAIL
#define | SPHDEC_ERUNTIME ISPHDEC_ERUNTIME
#define | SPHDEC_ETIMEOUT VISA_ETIMEOUT
#define | SPHDEC_FOREVER VISA_FOREVER

Typedefs

typedef ISPHDEC_Status | SPHDEC_Status
typedef VISA_Handle | SPHDEC_Handle
Opaque handle to a SPHDEC codec.
typedef struct ISPHDEC_Params | SPHDEC_Params
This structure defines the parameters necessary to create an instance of a speech decoder object.
typedef ISPHDEC_InArgs | SPHDEC_InArgs
typedef ISPHDEC_OutArgs | SPHDEC_OutArgs
typedef ISPHDEC_Cmd | SPHDEC_Cmd
typedef ISPHDEC_DynamicParams | SPHDEC_DynamicParams

Functions

SPHDEC_Handle | SPHDEC_create (Engine_Handle e, String name, SPHDEC_Params *params)
Create an instance of a speech decoder algorithm.
Int32 | SPHDEC_process (SPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs)
Execute the process() method in this instance of a speech decoder algorithm.
Int32 | SPHDEC_control (SPHDEC_Handle handle, SPHDEC_Cmd id, SPHDEC_DynamicParams *params, SPHDEC_Status *status)
Execute the control method in this instance of a speech decoder algorithm.
Void | SPHDEC_delete (SPHDEC_Handle handle)
Delete the instance of a speech/voice decoder algorithm.
XDAS_Int32 | SPHDEC_processAsync (SPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech decoder algorithm.
XDAS_Int32 | SPHDEC_processWait (SPHDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHDEC_processAsync() in this instance of an speech decoder algorithm.


Codec Engine Application Programming Interface (API): sphdec1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » speech1

sphdec1.h File Reference

Detailed Description

The SPHDEC1 decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHDEC1 speech decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/isphdec1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for sphdec1.h:

Go to the source code of this file.

Defines

#define | SPHDEC1_EOK ISPHDEC1_EOK
#define | SPHDEC1_EFAIL ISPHDEC1_EFAIL
#define | SPHDEC1_EUNSUPPORTED ISPHDEC1_EUNSUPPORTED
#define | SPHDEC1_ETIMEOUT VISA_ETIMEOUT
#define | SPHDEC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | SPHDEC1_Handle
Opaque handle to a SPHDEC1 codec.
typedef ISPHDEC1_Params | SPHDEC1_Params
typedef ISPHDEC1_InArgs | SPHDEC1_InArgs
typedef ISPHDEC1_OutArgs | SPHDEC1_OutArgs
typedef ISPHDEC1_Cmd | SPHDEC1_Cmd
typedef ISPHDEC1_DynamicParams | SPHDEC1_DynamicParams
typedef ISPHDEC1_Status | SPHDEC1_Status

Functions

Int32 | SPHDEC1_control (SPHDEC1_Handle handle, SPHDEC1_Cmd id, SPHDEC1_DynamicParams *params, SPHDEC1_Status *status)
Execute the control() method in this instance of a speech decoder algorithm.
SPHDEC1_Handle | SPHDEC1_create (Engine_Handle e, String name, SPHDEC1_Params *params)
Create an instance of a speech decoder algorithm.
Void | SPHDEC1_delete (SPHDEC1_Handle handle)
Delete the instance of a speech decoder algorithm.
Int32 | SPHDEC1_process (SPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs)
Execute the process() method in this instance of a speech decoder algorithm.
XDAS_Int32 | SPHDEC1_processAsync (SPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech decoder algorithm.
XDAS_Int32 | SPHDEC1_processWait (SPHDEC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHDEC1_processAsync() in this instance of an speech decoder algorithm.


Codec Engine Application Programming Interface (API): sphenc.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » speech

sphenc.h File Reference

Detailed Description

The SPHENC speech encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHENC speech encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/isphenc.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for sphenc.h:

Go to the source code of this file.

Defines

#define | SPHENC_EOK ISPHENC_EOK
#define | SPHENC_EFAIL ISPHENC_EFAIL
#define | SPHENC_ERUNTIME ISPHENC_ERUNTIME
#define | SPHENC_ETIMEOUT VISA_ETIMEOUT
#define | SPHENC_FOREVER VISA_FOREVER

Typedefs

typedef ISPHENC_Status | SPHENC_Status
typedef VISA_Handle | SPHENC_Handle
Opaque handle to a SPHENC codec.
typedef struct ISPHENC_Params | SPHENC_Params
This structure defines the parameters necessary to create an instance of a Speech/Voice Encoder object.
typedef ISPHENC_InArgs | SPHENC_InArgs
typedef ISPHENC_OutArgs | SPHENC_OutArgs
typedef ISPHENC_Cmd | SPHENC_Cmd
typedef ISPHENC_DynamicParams | SPHENC_DynamicParams

Functions

SPHENC_Handle | SPHENC_create (Engine_Handle e, String name, SPHENC_Params *params)
Create an instance of a speech encoder algorithm.
Int32 | SPHENC_process (SPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, SPHENC_InArgs *inArgs, SPHENC_OutArgs *outArgs)
Execute the process() method in this instance of a speech encoder algorithm.
Int32 | SPHENC_control (SPHENC_Handle handle, SPHENC_Cmd id, SPHENC_DynamicParams *params, SPHENC_Status *status)
Execute the control method in this instance of a speech encoder algorithm.
Void | SPHENC_delete (SPHENC_Handle handle)
Delete the instance of a speech/voice encoder algorithm.
XDAS_Int32 | SPHENC_processAsync (SPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech decoder algorithm.
XDAS_Int32 | SPHENC_processWait (SPHENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHENC_processAsync() in this instance of an speech decoder algorithm.


Codec Engine Application Programming Interface (API): sphenc1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » speech1

sphenc1.h File Reference

Detailed Description

The Speech 1.0 Encoder Codec Interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM 1.0 Speech Encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/isphenc1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for sphenc1.h:

Go to the source code of this file.

Defines

#define | SPHENC1_EOK ISPHENC1_EOK
#define | SPHENC1_EFAIL ISPHENC1_EFAIL
#define | SPHENC1_EUNSUPPORTED ISPHENC1_EUNSUPPORTED
#define | SPHENC1_ETIMEOUT VISA_ETIMEOUT
#define | SPHENC1_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | SPHENC1_Handle
Opaque handle to a SPHENC1 codec.
typedef struct ISPHENC1_Params | SPHENC1_Params
This structure defines the parameters necessary to create an instance of a speech encoder.
typedef ISPHENC1_InArgs | SPHENC1_InArgs
typedef ISPHENC1_OutArgs | SPHENC1_OutArgs
typedef ISPHENC1_Cmd | SPHENC1_Cmd
typedef ISPHENC1_Status | SPHENC1_Status
typedef ISPHENC1_DynamicParams | SPHENC1_DynamicParams

Functions

Int32 | SPHENC1_control (SPHENC1_Handle handle, SPHENC1_Cmd id, SPHENC1_DynamicParams *params, SPHENC1_Status *status)
Execute the control() method in this instance of a speech encoder algorithm.
SPHENC1_Handle | SPHENC1_create (Engine_Handle e, String name, SPHENC1_Params *params)
Create an instance of a speech encoder algorithm.
Void | SPHENC1_delete (SPHENC1_Handle handle)
Delete the instance of a speech encoder algorithm.
Int32 | SPHENC1_process (SPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs)
Execute the process() method in this instance of a speech encoder algorithm.
XDAS_Int32 | SPHENC1_processAsync (SPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a speech encoder algorithm.
XDAS_Int32 | SPHENC1_processWait (SPHENC1_Handle handle, XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf, SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of SPHENC1_processAsync() in this instance of an speech encoder algorithm.


Codec Engine Application Programming Interface (API): TraceUtil.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » utils » trace

TraceUtil.h File Reference

Detailed Description

The Codec Engine utility module for trace.

#include <ti/sdo/ce/Engine.h>
Include dependency graph for TraceUtil.h:

Go to the source code of this file.

Defines

#define | TRACEUTIL_SUCCESS 0
#define | TRACEUTIL_FAILURE -1

Functions

Int | TraceUtil_start (String engineName)
Begin using the TraceUtil module; create thread that periodically collects DSP trace.
Int | TraceUtil_stop (Void)
Finish using the TraceUtil module, stop the collecting thread.


Codec Engine Application Programming Interface (API): universal.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » universal

universal.h File Reference

Detailed Description

The "universal" algorithm interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IUNIVERSAL interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/iuniversal.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for universal.h:

Go to the source code of this file.

Defines

#define | UNIVERSAL_EOK IUNIVERSAL_EOK
#define | UNIVERSAL_EFAIL IUNIVERSAL_EFAIL
#define | UNIVERSAL_EUNSUPPORTED IUNIVERSAL_EUNSUPPORTED
#define | UNIVERSAL_ETIMEOUT VISA_ETIMEOUT
#define | UNIVERSAL_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | UNIVERSAL_Handle
Opaque handle to a UNIVERSAL codec.
typedef struct IUNIVERSAL_Params | UNIVERSAL_Params
This structure defines the parameters necessary to create an instance of a "universal" algorithm.
typedef IUNIVERSAL_InArgs | UNIVERSAL_InArgs
typedef IUNIVERSAL_OutArgs | UNIVERSAL_OutArgs
typedef IUNIVERSAL_Cmd | UNIVERSAL_Cmd
typedef IUNIVERSAL_Status | UNIVERSAL_Status
typedef IUNIVERSAL_DynamicParams | UNIVERSAL_DynamicParams

Functions

Int32 | UNIVERSAL_control (UNIVERSAL_Handle handle, UNIVERSAL_Cmd id, UNIVERSAL_DynamicParams *params, UNIVERSAL_Status *status)
Execute the control() method in this instance of a "universal" algorithm.
UNIVERSAL_Handle | UNIVERSAL_create (Engine_Handle e, String name, UNIVERSAL_Params *params)
Create an instance of a universal algorithm.
Void | UNIVERSAL_delete (UNIVERSAL_Handle handle)
Delete the instance of a universal algorithm.
Int32 | UNIVERSAL_process (UNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, UNIVERSAL_InArgs *inArgs, UNIVERSAL_OutArgs *outArgs)
Execute the process() method in this instance of a universal algorithm.
XDAS_Int32 | UNIVERSAL_processAsync (UNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs)
Perform asynchronous submission to this instance of a universal algorithm.
XDAS_Int32 | UNIVERSAL_processWait (UNIVERSAL_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs, IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of UNIVERSAL_processAsync() in this instance of a universal algorithm.


Codec Engine Application Programming Interface (API): vidanalytics.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » vidanalytics

vidanalytics.h File Reference

Detailed Description

The video analytics codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM video analytics interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividanalytics.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for vidanalytics.h:

Go to the source code of this file.

Defines

#define | VIDANALYTICS_EOK IVIDANALYTICS_EOK
#define | VIDANALYTICS_EFAIL IVIDANALYTICS_EFAIL
#define | VIDANALYTICS_EUNSUPPORTED IVIDANALYTICS_EUNSUPPORTED
#define | VIDANALYTICS_ETIMEOUT VISA_ETIMEOUT
#define | VIDANALYTICS_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | VIDANALYTICS_Handle
Opaque handle to a VIDANALYTICS codec.
typedef struct IVIDANALYTICS_Params | VIDANALYTICS_Params
This structure defines the parameters necessary to create an instance of a video analytics algorithm.
typedef IVIDANALYTICS_InArgs | VIDANALYTICS_InArgs
typedef IVIDANALYTICS_OutArgs | VIDANALYTICS_OutArgs
typedef IVIDANALYTICS_Cmd | VIDANALYTICS_Cmd
typedef IVIDANALYTICS_Status | VIDANALYTICS_Status
typedef IVIDANALYTICS_DynamicParams | VIDANALYTICS_DynamicParams

Functions

Int32 | VIDANALYTICS_control (VIDANALYTICS_Handle handle, VIDANALYTICS_Cmd id, VIDANALYTICS_DynamicParams *params, VIDANALYTICS_Status *status)
Execute the control() method in this instance of a video analytics algorithm.
VIDANALYTICS_Handle | VIDANALYTICS_create (Engine_Handle e, String name, VIDANALYTICS_Params *params)
Create an instance of a video analytics algorithm.
Void | VIDANALYTICS_delete (VIDANALYTICS_Handle handle)
Delete the instance of a video analytics algorithm.
Int32 | VIDANALYTICS_process (VIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, VIDANALYTICS_InArgs *inArgs, VIDANALYTICS_OutArgs *outArgs)
Execute the process() method in this instance of a video analytics algorithm.
XDAS_Int32 | VIDANALYTICS_processAsync (VIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs, IVIDANALYTICS_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video analytics algorithm.
XDAS_Int32 | VIDANALYTICS_processWait (VIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs, IVIDANALYTICS_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDANALYTICS_processAsync() in this instance of an video analytics algorithm.


Codec Engine Application Programming Interface (API): viddec.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » video

viddec.h File Reference

Detailed Description

The VIDDEC video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC video decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividdec.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for viddec.h:

Go to the source code of this file.

Data Structures

struct | IVIDDEC_CodecClassConfig
Definition of VIDDEC codec class configurable parameters. More...

Defines

#define | VIDDEC_EOK IVIDDEC_EOK
#define | VIDDEC_EFAIL IVIDDEC_EFAIL
#define | VIDDEC_ERUNTIME IVIDDEC_ERUNTIME
#define | VIDDEC_ETIMEOUT VISA_ETIMEOUT
#define | VIDDEC_FOREVER VISA_FOREVER

Typedefs

typedef IVIDDEC_Status | VIDDEC_Status
typedef VISA_Handle | VIDDEC_Handle
Opaque handle to a VIDDEC codec.
typedef struct IVIDDEC_Params | VIDDEC_Params
This structure defines the parameters necessary to create an instance of a video decoder object.
typedef IVIDDEC_InArgs | VIDDEC_InArgs
typedef IVIDDEC_OutArgs | VIDDEC_OutArgs
typedef IVIDDEC_Cmd | VIDDEC_Cmd
typedef IVIDDEC_DynamicParams | VIDDEC_DynamicParams

Functions

VIDDEC_Handle | VIDDEC_create (Engine_Handle e, String name, VIDDEC_Params *params)
Create an instance of a video decoder algorithm.
Int32 | VIDDEC_process (VIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs)
Execute the process() method in this instance of a video decoder algorithm.
Int32 | VIDDEC_control (VIDDEC_Handle handle, VIDDEC_Cmd id, VIDDEC_DynamicParams *params, VIDDEC_Status *status)
Execute the "control" method in this instance of a video decoder algorithm.
Void | VIDDEC_delete (VIDDEC_Handle handle)
Delete the instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC_processAsync (VIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC_processWait (VIDDEC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDDEC_processAsync() in this instance of an video decoder algorithm.


Codec Engine Application Programming Interface (API): viddec1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » video1

viddec1.h File Reference

Detailed Description

The 1.0 video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM 1.0 video decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividdec1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for viddec1.h:

Go to the source code of this file.

Data Structures

struct | IVIDDEC1_CodecClassConfig
Definition of IVIDDEC1 codec class configurable parameters. More...

Defines

#define | VIDDEC1_EOK IVIDDEC1_EOK
#define | VIDDEC1_EFAIL IVIDDEC1_EFAIL
#define | VIDDEC1_EUNSUPPORTED IVIDDEC1_EUNSUPPORTED
#define | VIDDEC1_ETIMEOUT VISA_ETIMEOUT
#define | VIDDEC1_FOREVER VISA_FOREVER

Typedefs

typedef IVIDDEC1_Status | VIDDEC1_Status
typedef VISA_Handle | VIDDEC1_Handle
Opaque handle to a VIDDEC1 codec.
typedef struct IVIDDEC1_Params | VIDDEC1_Params
This structure defines the parameters necessary to create an instance of a Video Decoder object.
typedef IVIDDEC1_InArgs | VIDDEC1_InArgs
typedef IVIDDEC1_OutArgs | VIDDEC1_OutArgs
typedef IVIDDEC1_Cmd | VIDDEC1_Cmd
typedef IVIDDEC1_DynamicParams | VIDDEC1_DynamicParams

Functions

VIDDEC1_Handle | VIDDEC1_create (Engine_Handle e, String name, VIDDEC1_Params *params)
Create an instance of a video decoder algorithm.
Int32 | VIDDEC1_process (VIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs)
Execute the process() method in this instance of a video decoder algorithm.
Int32 | VIDDEC1_control (VIDDEC1_Handle handle, VIDDEC1_Cmd id, VIDDEC1_DynamicParams *params, VIDDEC1_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
Void | VIDDEC1_delete (VIDDEC1_Handle handle)
Delete the instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC1_processAsync (VIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC1_processWait (VIDDEC1_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDDEC1_processAsync() in this instance of an video decoder algorithm.


Codec Engine Application Programming Interface (API): viddec2.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » video2 » split

split/viddec2.h File Reference

Detailed Description

The VIDDEC2 split video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC2FRONT or IVIDDEC2BACK video decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/split/ividdec2.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
#include <ti/sdo/ce/video2/viddec2.h>
Include dependency graph for split/viddec2.h:

Go to the source code of this file.

Data Structures

struct | IVIDDEC2BACK_CodecClassConfig
Definition of IVIDDEC2BACK codec class configurable parameters. More...

Typedefs

typedef IVIDDEC2FRONT_Status | VIDDEC2FRONT_Status
typedef VISA_Handle | VIDDEC2FRONT_Handle
Opaque handle to a VIDDEC2FRONT codec.
typedef VISA_Handle | VIDDEC2BACK_Handle
Opaque handle to a VIDDEC2BACK codec.
typedef IVIDDEC2FRONT_OutArgs | VIDDEC2FRONT_OutArgs

Functions

VIDDEC2BACK_Handle | VIDDEC2BACK_create (Engine_Handle e, String name, VIDDEC2_Params *params)
Create an instance of the BACK end of a split video decoder algorithm.
Int32 | VIDDEC2BACK_process (VIDDEC2BACK_Handle handle, XDM_Context *context, VIDDEC2_OutArgs *outArgs)
Execute the process() method in this instance of a BACK side split video decoder algorithm.
Int32 | VIDDEC2BACK_control (VIDDEC2BACK_Handle handle, XDM_Context *context, VIDDEC2_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
Void | VIDDEC2BACK_delete (VIDDEC2BACK_Handle handle)
Delete the instance of a video decoder algorithm.
VIDDEC2FRONT_Handle | VIDDEC2FRONT_create (Engine_Handle e, String name, VIDDEC2_Params *params)
Create an instance of the FRONT end of a split video decoder algorithm.
Int32 | VIDDEC2FRONT_process (VIDDEC2FRONT_Handle handle, VIDDEC2_InArgs *inArgs, XDM_Context *context, VIDDEC2FRONT_OutArgs *outArgs)
Execute the process() method in this instance of a FRONT side split video decoder algorithm.
Int32 | VIDDEC2FRONT_control (VIDDEC2FRONT_Handle handle, VIDDEC2_Cmd id, VIDDEC2_DynamicParams *params, XDM_Context *context, VIDDEC2FRONT_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
Void | VIDDEC2FRONT_delete (VIDDEC2FRONT_Handle handle)
Delete the instance of a video decoder algorithm.


Codec Engine Application Programming Interface (API): viddec2.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » video2

viddec2.h File Reference

Detailed Description

The VIDDEC2 video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC2 video decoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividdec2.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for viddec2.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | IVIDDEC2_CodecClassConfig
Definition of IVIDDEC2 codec class configurable parameters. More...

Defines

#define | VIDDEC2_EOK IVIDDEC2_EOK
#define | VIDDEC2_EFAIL IVIDDEC2_EFAIL
#define | VIDDEC2_EUNSUPPORTED IVIDDEC2_EUNSUPPORTED
#define | VIDDEC2_ETIMEOUT VISA_ETIMEOUT
#define | VIDDEC2_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | VIDDEC2_Handle
Opaque handle to a VIDDEC2 codec.
typedef IVIDDEC2_Params | VIDDEC2_Params
typedef IVIDDEC2_InArgs | VIDDEC2_InArgs
typedef IVIDDEC2_OutArgs | VIDDEC2_OutArgs
typedef IVIDDEC2_Cmd | VIDDEC2_Cmd
typedef IVIDDEC2_DynamicParams | VIDDEC2_DynamicParams
typedef IVIDDEC2_Status | VIDDEC2_Status

Functions

Int32 | VIDDEC2_control (VIDDEC2_Handle handle, VIDDEC2_Cmd id, VIDDEC2_DynamicParams *params, VIDDEC2_Status *status)
Execute the control() method in this instance of a video decoder algorithm.
VIDDEC2_Handle | VIDDEC2_create (Engine_Handle e, String name, VIDDEC2_Params *params)
Create an instance of a video decoder algorithm.
Void | VIDDEC2_delete (VIDDEC2_Handle handle)
Delete the instance of a video decoder algorithm.
Int32 | VIDDEC2_process (VIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs)
Execute the process() method in this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC2_processAsync (VIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDDEC2_processWait (VIDDEC2_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDDEC2_processAsync() in this instance of an video decoder algorithm.


Codec Engine Application Programming Interface (API): videnc.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » video

videnc.h File Reference

Detailed Description

The VIDENC video encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDENC video encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividenc.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for videnc.h:

Go to the source code of this file.

Data Structures

struct | IVIDENC_CodecClassConfig
Definition of IVIDENC codec class configurable parameters. More...

Defines

#define | VIDENC_EOK IVIDENC_EOK
#define | VIDENC_EFAIL IVIDENC_EFAIL
#define | VIDENC_ERUNTIME IVIDENC_ERUNTIME
#define | VIDENC_ETIMEOUT VISA_ETIMEOUT
#define | VIDENC_FOREVER VISA_FOREVER

Typedefs

typedef IVIDENC_Status | VIDENC_Status
typedef VISA_Handle | VIDENC_Handle
Opaque handle to a VIDENC codec.
typedef struct IVIDENC_Params | VIDENC_Params
This structure defines the parameters necessary to create an instance of a video encoder object.
typedef IVIDENC_InArgs | VIDENC_InArgs
typedef IVIDENC_OutArgs | VIDENC_OutArgs
typedef IVIDENC_Cmd | VIDENC_Cmd
typedef IVIDENC_DynamicParams | VIDENC_DynamicParams

Functions

VIDENC_Handle | VIDENC_create (Engine_Handle e, String name, VIDENC_Params *params)
Create an instance of a video encoder algorithm.
Int32 | VIDENC_process (VIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDENC_InArgs *inArgs, VIDENC_OutArgs *outArgs)
Execute the process() method in this instance of a video encoder algorithm.
Int32 | VIDENC_control (VIDENC_Handle handle, VIDENC_Cmd id, VIDENC_DynamicParams *params, VIDENC_Status *status)
Execute the "control" method in this instance of a video encoder algorithm.
Void | VIDENC_delete (VIDENC_Handle handle)
Delete the instance of a video encoder algorithm.
XDAS_Int32 | VIDENC_processAsync (VIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDENC_processWait (VIDENC_Handle handle, XDM_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDENC_processAsync() in this instance of an video decoder algorithm.


Codec Engine Application Programming Interface (API): videnc1.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » video1

videnc1.h File Reference

Detailed Description

The VIDENC1 video encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDENC1 video encoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividenc1.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for videnc1.h:

Go to the source code of this file.

Defines

#define | VIDENC1_EOK IVIDENC1_EOK
#define | VIDENC1_EFAIL IVIDENC1_EFAIL
#define | VIDENC1_EUNSUPPORTED IVIDENC1_EUNSUPPORTED
#define | VIDENC1_ETIMEOUT VISA_ETIMEOUT
#define | VIDENC1_FOREVER VISA_FOREVER

Typedefs

typedef IVIDENC1_Status | VIDENC1_Status
typedef VISA_Handle | VIDENC1_Handle
Opaque handle to a VIDENC1 codec.
typedef struct IVIDENC1_Params | VIDENC1_Params
This structure defines the parameters necessary to create an instance of a VIDENC1-based video encoder.
typedef IVIDENC1_InArgs | VIDENC1_InArgs
typedef IVIDENC1_OutArgs | VIDENC1_OutArgs
typedef IVIDENC1_Cmd | VIDENC1_Cmd
typedef IVIDENC1_DynamicParams | VIDENC1_DynamicParams

Functions

VIDENC1_Handle | VIDENC1_create (Engine_Handle e, String name, VIDENC1_Params *params)
Create an instance of a video encoder algorithm.
Int32 | VIDENC1_process (VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, VIDENC1_InArgs *inArgs, VIDENC1_OutArgs *outArgs)
Execute the process() method in this instance of a video encoder algorithm.
Int32 | VIDENC1_control (VIDENC1_Handle handle, VIDENC1_Cmd id, VIDENC1_DynamicParams *params, VIDENC1_Status *status)
Execute the control() method in this instance of a video encoder algorithm.
Void | VIDENC1_delete (VIDENC1_Handle handle)
Delete the instance of a video encoder algorithm.
XDAS_Int32 | VIDENC1_processAsync (VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video decoder algorithm.
XDAS_Int32 | VIDENC1_processWait (VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDENC1_processAsync() in this instance of an video decoder algorithm.


Codec Engine Application Programming Interface (API): vidtranscode.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce » vidtranscode

vidtranscode.h File Reference

Detailed Description

The video transcoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM video transcoder interface.

#include <ti/xdais/dm/xdm.h>
#include <ti/xdais/dm/ividtranscode.h>
#include <ti/sdo/ce/Engine.h>
#include <ti/sdo/ce/visa.h>
#include <ti/sdo/ce/skel.h>
Include dependency graph for vidtranscode.h:

Go to the source code of this file.

Defines

#define | VIDTRANSCODE_EOK IVIDTRANSCODE_EOK
#define | VIDTRANSCODE_EFAIL IVIDTRANSCODE_EFAIL
#define | VIDTRANSCODE_EUNSUPPORTED IVIDTRANSCODE_EUNSUPPORTED
#define | VIDTRANSCODE_ETIMEOUT VISA_ETIMEOUT
#define | VIDTRANSCODE_FOREVER VISA_FOREVER

Typedefs

typedef VISA_Handle | VIDTRANSCODE_Handle
Opaque handle to a VIDTRANSCODE codec.
typedef struct IVIDTRANSCODE_Params | VIDTRANSCODE_Params
This structure defines the parameters necessary to create an instance of a video transcoder.
typedef IVIDTRANSCODE_InArgs | VIDTRANSCODE_InArgs
typedef IVIDTRANSCODE_OutArgs | VIDTRANSCODE_OutArgs
typedef IVIDTRANSCODE_Cmd | VIDTRANSCODE_Cmd
typedef IVIDTRANSCODE_Status | VIDTRANSCODE_Status
typedef IVIDTRANSCODE_DynamicParams | VIDTRANSCODE_DynamicParams

Functions

Int32 | VIDTRANSCODE_control (VIDTRANSCODE_Handle handle, VIDTRANSCODE_Cmd id, VIDTRANSCODE_DynamicParams *params, VIDTRANSCODE_Status *status)
Execute the control() method in this instance of a video transcoder algorithm.
VIDTRANSCODE_Handle | VIDTRANSCODE_create (Engine_Handle e, String name, VIDTRANSCODE_Params *params)
Create an instance of a video transcoder algorithm.
Void | VIDTRANSCODE_delete (VIDTRANSCODE_Handle handle)
Delete the instance of a video transcoder algorithm.
Int32 | VIDTRANSCODE_process (VIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDTRANSCODE_InArgs *inArgs, VIDTRANSCODE_OutArgs *outArgs)
Execute the process() method in this instance of a video transcoder algorithm.
XDAS_Int32 | VIDTRANSCODE_processAsync (VIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs, IVIDTRANSCODE_OutArgs *outArgs)
Perform asynchronous submission to this instance of a video transcoder algorithm.
XDAS_Int32 | VIDTRANSCODE_processWait (VIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs, IVIDTRANSCODE_OutArgs *outArgs, UInt timeout)
Wait for a return message from a previous invocation of VIDTRANSCODE_processAsync() in this instance of an video transcoder algorithm.


Codec Engine Application Programming Interface (API): visa.h File Reference

  • File List
  • Globals
packages » ti » sdo » ce

visa.h File Reference

Detailed Description

The Codec Engine System Programming Interface. Provides system developers with services necessary to implement stubs and skeletons.

#include <stddef.h>
#include <ti/sdo/ce/node/node.h>
#include <ti/xdais/ialg.h>
#include <ti/sdo/ce/Engine.h>
Include dependency graph for visa.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | VISA_MsgHeader
VISA message header. More...

Defines

#define | VISA_EOK 0
Success.
#define | VISA_ERUNTIME -1
Internal runtime error.
#define | VISA_EFAIL -2
General system error.
#define | VISA_ETIMEOUT -100
Timeout occurred.
#define | VISA_FOREVER Engine_FOREVER
Special value for timeout parameter indicating never timeout.

Typedefs

typedef Int | VISA_Status
VISA result data type.
typedef struct VISA_Obj * | VISA_Handle
Opaque handle to a node.
typedef VISA_MsgHeader * | VISA_Msg

Functions

VISA_Msg | VISA_allocMsg (VISA_Handle visa)
Obtain an algorithm instance's message.
VISA_Status | VISA_call (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and wait for it to complete.
VISA_Status | VISA_callAsync (VISA_Handle visa, VISA_Msg *msg)
Invoke the operation specified in the message and return without waiting for it to complete.
VISA_Status | VISA_wait (VISA_Handle visa, VISA_Msg *msg, UInt timeout)
Wait for the oldest operation from a command specified with VISA_callAsync() to complete.
Void | VISA_freeMsg (VISA_Handle visa, VISA_Msg msg)
Release an algorithm instance's message.
VISA_Status | VISA_getAlgMemRecs (VISA_Handle visa, IALG_MemRec *memTab, Int size, Int *numRecs)
Get the IALG_MemRec memory assigned to an algorithm instance.
VISA_Status | VISA_getAlgNumRecs (VISA_Handle visa, Int *numRecs)
Get the number of IALG_MemRecs assigned to an algorithm.
Void | VISA_getContext (VISA_Handle visa, UInt32 *pContext)
Get optional context parameter.
Ptr | VISA_getCodecClassConfig (VISA_Handle visa)
Get codec-specific values for the VISA class-specific (or codec-specific if the codec doesn't extend VISA) stub-and/ or-skeleton configuration data (that some classes have).
UInt | VISA_getMaxMsgSize (VISA_Handle visa)
Returns max size of messages allocated by VISA_allocMsg().
Void | VISA_setContext (VISA_Handle visa, UInt32 context)
Set optional context parameter.
Bool | VISA_isLocal (VISA_Handle visa)
Indicates whether VISA codecs run on a remote or local CPU.

VISA_Handle | VISA_create (Engine_Handle engine, String name, IALG_Params *params, size_t msgSize, String type)
Create a new instance of an algorithm.
Void | VISA_delete (VISA_Handle visa)
Delete an instance of an algorithm.
VISA_Handle | VISA_create2 (Engine_Handle engine, String name, IALG_Params *params, Int paramsSize, size_t msgSize, String type)
Create a new instance of an algorithm.
Void | VISA_enter (VISA_Handle visa)
Enter an algorithm's critical section. This must be called before any of the algorithm's IALG_Fxns are invoked.
Void | VISA_exit (VISA_Handle visa)
Leave an algorithm's critical section. This must be called after the API has completed calling an algorithm's IALG_Fxns.
Ptr | VISA_getAlgHandle (VISA_Handle visa)
Obtains an algorithm's handle. This is the handle required to be passed to the algorithm's IALG_Fxns.
Ptr | VISA_getAlgorithmHandle (VISA_Handle visa)
Obtains an algorithm's handle. If the algorithm is local, this is the handle that can be passed to Algorithm APIs, not to the IALG_Fxns.
IALG_Fxns * | VISA_getAlgFxns (VISA_Handle visa)
Get implementation functions for this algorithm.

Typedef Documentation

typedef struct VISA_Obj* VISA_Handle

Opaque handle to a node.

typedef VISA_MsgHeader* VISA_Msg


Codec Engine Application Programming Interface (API): xdas.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais

xdas.h File Reference

Detailed Description

This header defines all types and constants used in the XDAS interfaces.

Remarks:
The types are mapped to the types defined in std.h.
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Defines

#define | XDAS_TRUE 1
#define | XDAS_FALSE 0

Typedefs

typedef Void | XDAS_Void
typedef Uint8 | XDAS_Bool
typedef Int8 | XDAS_Int8
typedef Uint8 | XDAS_UInt8
typedef Int16 | XDAS_Int16
typedef Uint16 | XDAS_UInt16
typedef Int32 | XDAS_Int32
typedef Uint32 | XDAS_UInt32


Codec Engine Application Programming Interface (API): xdm.h File Reference

  • File List
  • Globals
cetools » packages » ti » xdais » dm

xdm.h File Reference

Detailed Description

This header defines all types, constants, and functions shared across the various XDM classes of algorithms.

#include <ti/xdais/ialg.h>
#include <ti/xdais/xdas.h>
Include dependency graph for xdm.h:
This graph shows which files directly or indirectly include this file:

Go to the source code of this file.

Data Structures

struct | XDM_BufDesc
Buffer descriptor for multiple buffers. More...
struct | XDM_SingleBufDesc
Single buffer descriptor. More...
struct | XDM1_SingleBufDesc
Single buffer descriptor. More...
struct | XDM1_BufDesc
Buffer descriptor. More...
struct | XDM_AlgBufInfo
Buffer information descriptor for input and output buffers. More...
struct | XDM_Date
Date and time. More...
struct | XDM_Point
2-dimensional point More...
struct | XDM_Rect
Rectangle. More...
struct | XDM_ContextInfo
Buffer information descriptor for input and output buffers. More...
struct | XDM_Context
Context used by split codecs. More...

Defines

#define | XDM_EOK IALG_EOK
#define | XDM_EFAIL IALG_EFAIL
#define | XDM_EUNSUPPORTED -3
#define | XDM_ERUNTIME -2
General runtime failure.
#define | XDM_MAX_IO_BUFFERS 16
#define | XDM_ISACCESSMODE_READ(x) (((x) >> XDM_ACCESSMODE_READ) & 0x1)
Check an access mask for CPU read access.
#define | XDM_ISACCESSMODE_WRITE(x) (((x) >> XDM_ACCESSMODE_WRITE) & 0x1)
Check an access mask for CPU write access.
#define | XDM_CLEARACCESSMODE_READ(x) ((x) &= (~(0x1 << XDM_ACCESSMODE_READ)))
Clear the "CPU read access" bit in an access mask.
#define | XDM_CLEARACCESSMODE_WRITE(x) ((x) &= (~(0x1 << XDM_ACCESSMODE_WRITE)))
Clear the "CPU write access" bit in an access mask.
#define | XDM_SETACCESSMODE_READ(x) ((x) |= (0x1 << XDM_ACCESSMODE_READ))
Set the bit to indicate CPU read access in an access mask.
#define | XDM_SETACCESSMODE_WRITE(x) ((x) |= (0x1 << XDM_ACCESSMODE_WRITE))
Set the bit to indicate CPU write access in an access mask.
#define | XDM_CUSTOMENUMBASE 0x100
Base of algorithm-specific enum values.
#define | XDM_CUSTOMCMDBASE 0x100
Base of algorithm-specific commands.
#define | XDM_ISFATALERROR(x) (((x) >> XDM_FATALERROR) & 0x1)
#define | XDM_ISUNSUPPORTEDPARAM(x) (((x) >> XDM_UNSUPPORTEDPARAM) & 0x1)
#define | XDM_ISUNSUPPORTEDINPUT(x) (((x) >> XDM_UNSUPPORTEDINPUT) & 0x1)
#define | XDM_ISCORRUPTEDHEADER(x) (((x) >> XDM_CORRUPTEDHEADER) & 0x1)
#define | XDM_ISCORRUPTEDDATA(x) (((x) >> XDM_CORRUPTEDDATA) & 0x1)
#define | XDM_ISINSUFFICIENTDATA(x) (((x) >> XDM_INSUFFICIENTDATA) & 0x1)
#define | XDM_ISAPPLIEDCONCEALMENT(x) (((x) >> XDM_APPLIEDCONCEALMENT) & 0x1)
#define | XDM_SETFATALERROR(x) ((x) |= (0x1 << XDM_FATALERROR))
#define | XDM_SETUNSUPPORTEDPARAM(x) ((x) |= (0x1 << XDM_UNSUPPORTEDPARAM))
#define | XDM_SETUNSUPPORTEDINPUT(x) ((x) |= (0x1 << XDM_UNSUPPORTEDINPUT))
#define | XDM_SETCORRUPTEDHEADER(x) ((x) |= (0x1 << XDM_CORRUPTEDHEADER))
#define | XDM_SETCORRUPTEDDATA(x) ((x) |= (0x1 << XDM_CORRUPTEDDATA))
#define | XDM_SETINSUFFICIENTDATA(x) ((x) |= (0x1 << XDM_INSUFFICIENTDATA))
#define | XDM_SETAPPLIEDCONCEALMENT(x) ((x) |= (0x1 << XDM_APPLIEDCONCEALMENT))
#define | XDM_MAX_CONTEXT_BUFFERS 32
Maximum number of context buffers.

Enumerations

enum XDM_AccessMode {
XDM_ACCESSMODE_READ = 0,
XDM_ACCESSMODE_WRITE = 1
}

Access modes used to declare how the algorithm accessed buffers.

More...
enum XDM_CmdId {
XDM_GETSTATUS = 0,
XDM_SETPARAMS = 1,
XDM_RESET = 2,
XDM_SETDEFAULT = 3,
XDM_FLUSH = 4,
XDM_GETBUFINFO = 5,
XDM_GETVERSION = 6,
XDM_GETCONTEXTINFO = 7
}

Standard control commands that must be implemented by XDM compliant multimedia algorithms.

More...
enum XDM_ErrorBit {
XDM_PARAMSCHANGE = 8,
XDM_APPLIEDCONCEALMENT = 9,
XDM_INSUFFICIENTDATA = 10,
XDM_CORRUPTEDDATA = 11,
XDM_CORRUPTEDHEADER = 12,
XDM_UNSUPPORTEDINPUT = 13,
XDM_UNSUPPORTEDPARAM = 14,
XDM_FATALERROR = 15
}

Extended error information.

More...
enum XDM_DataFormat {
XDM_BYTE = 1,
XDM_LE_16 = 2,
XDM_LE_32 = 3,
XDM_LE_64 = 4,
XDM_BE_16 = 5,
XDM_BE_32 = 6,
XDM_BE_64 = 7
}

Endianness of data.

More...
enum XDM_EncodingPreset {
XDM_DEFAULT = 0,
XDM_HIGH_QUALITY = 1,
XDM_HIGH_SPEED = 2,
XDM_USER_DEFINED = 3
}

Encoding presets.

More...
enum XDM_DecMode {
XDM_DECODE_AU = 0,
XDM_PARSE_HEADER = 1
}

Decode entire access unit or only header.

More...
enum XDM_EncMode {
XDM_ENCODE_AU = 0,
XDM_GENERATE_HEADER = 1
}

Encode entire access unit or only header.

More...
enum XDM_ChromaFormat {
XDM_CHROMA_NA = -1,
XDM_YUV_420P = 1,
XDM_YUV_422P = 2,
XDM_YUV_422IBE = 3,
XDM_YUV_422ILE = 4,
XDM_YUV_444P = 5,
XDM_YUV_411P = 6,
XDM_GRAY = 7,
XDM_RGB = 8,
XDM_YUV_420SP = 9,
XDM_ARGB8888 = 10,
XDM_RGB555 = 11,
XDM_RGB565 = 12,
XDM_YUV_444ILE = 13,
XDM_CHROMAFORMAT_DEFAULT = XDM_YUV_422ILE
}

Chroma formats.

More...


Codec Engine Application Programming Interface (API): Directory Hierarchy

Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • cetools
    • packages
      • ti
        • xdais
          • dm
            • split
  • packages
    • ti
      • dsplink
        • utils
          • ladclient
      • sdo
        • ce
          • audio
          • audio1
          • image
          • image1
          • osal
          • speech
          • speech1
          • universal
          • utils
            • trace
          • vidanalytics
          • video
          • video1
          • video2
            • split
          • vidtranscode


Codec Engine Application Programming Interface (API): cetools/ Directory Reference

cetools

cetools Directory Reference

Directories

directory packages


Codec Engine Application Programming Interface (API): cetools/packages/ Directory Reference

cetools » packages

packages Directory Reference

Directories

directory ti


Codec Engine Application Programming Interface (API): cetools/packages/ti/ Directory Reference

cetools » packages » ti

ti Directory Reference

Directories

directory xdais


Codec Engine Application Programming Interface (API): cetools/packages/ti/xdais/ Directory Reference

cetools » packages » ti » xdais

xdais Directory Reference

Directories

directory | dm

Files

file | ialg.h [code]

This header defines all types, constants, and functions defined by XDAIS for algorithms.

file | xdas.h [code]

This header defines all types and constants used in the XDAS interfaces.


Codec Engine Application Programming Interface (API): cetools/packages/ti/xdais/dm/ Directory Reference

cetools » packages » ti » xdais » dm

dm Directory Reference

Directories

directory | split

Files

file | iauddec.h [code]

This header defines all types, constants, and functions shared by all implementations of the audio decoder algorithms.

file | iauddec1.h [code]

This header defines all types, constants, and functions shared by all implementations of the audio decoder algorithms.

file | iaudenc.h [code]

This header defines all types, constants, and functions shared by all implementations of the audio encoder algorithms.

file | iaudenc1.h [code]

This header defines all types, constants, and functions shared by all implementations of the audio encoder algorithms.

file | iaudio.h [code]

This header defines all types, constants, enums, and functions that are common across the various audio codecs.

file | iimgdec.h [code]

This header defines all types, constants, and functions shared by all implementations of the image decoder algorithms.

file | iimgdec1.h [code]

This header defines all types, constants, and functions shared by all implementations of the image decoder algorithms.

file | iimgenc.h [code]

This header defines all types, constants, and functions shared by all implementations of the image encoder algorithms.

file | iimgenc1.h [code]

This header defines all types, constants, and functions shared by all implementations of the image encoder algorithms.

file | ispeech.h [code]

This header defines all types, constants, enums, and functions that are common across the various speech codecs.

file | ispeech1.h [code]

This header defines all types, constants, enums, and functions that are common across the various speech codecs.

file | ispeech1_amr.h [code]

This header defines all types, constants, enums, and functions that are needed for AMR.

file | ispeech1_evrc.h [code]

This header defines all types, constants, enums, and functions that are needed for EVRC.

file | ispeech1_g723.h [code]

This header defines all types, constants, enums, and functions that are needed for G.723.

file | ispeech1_g726.h [code]

This header defines all types, constants, enums, and functions that are needed for G.726.

file | ispeech1_pcm.h [code]

This header defines all types, constants, enums, and functions that are common across all G.711/PCM speech codecs.

file | ispeech1_smv.h [code]

This header defines all types, constants, enums, and functions that are common across all SMV speech codecs.

file | ispeech1_wbamr.h [code]

This header defines all types, constants, enums, and functions that are needed for WB-AMR.

file | isphdec.h [code]

This header defines all types, constants, and functions shared by all implementations of the speech/voice decoder algorithms.

file | isphdec1.h [code]

This header defines all types, constants, and functions shared by all implementations of the speech/voice decoder algorithms.

file | isphenc.h [code]

This header defines all types, constants, and functions shared by all implementations of the speech/voice encoder algorithms.

file | isphenc1.h [code]

This header defines all types, constants, and functions shared by all implementations of the speech/voice encoder algorithms.

file | iuniversal.h [code]

This header defines all types, constants, and functions shared by all implementations of the "universal" XDM algorithm.

file | ividanalytics.h [code]

This header defines all types, constants, and functions shared by all implementations of the video analytics algorithms.

file | ividdec.h [code]

This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms.

file | ividdec1.h [code]

This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms.

file | ividdec2.h [code]

This header defines all types, constants, and functions shared by all implementations of the video decoder algorithms.

file | ividenc.h [code]

This header defines all types, constants, and functions shared by all implementations of the video encoder algorithms.

file | ividenc1.h [code]

This header defines all types, constants, and functions shared by all implementations of the video encoder algorithms.

file | ivideo.h [code]

This header defines all types, constants, enums, and functions that are common across the various video codecs.

file | ividtranscode.h [code]

This header defines all types, constants, and functions shared by all implementations of the video transcoder algorithms.

file | xdm.h [code]

This header defines all types, constants, and functions shared across the various XDM classes of algorithms.


Codec Engine Application Programming Interface (API): cetools/packages/ti/xdais/dm/split/ Directory Reference

cetools » packages » ti » xdais » dm » split

split Directory Reference

Files

file split/ividdec2.h [code]

This header defines all types, constants, enums, and functions that are common across all split IVIDDEC2-based codecs.


Codec Engine Application Programming Interface (API): packages/ Directory Reference

packages

packages Directory Reference

Directories

directory ti


Codec Engine Application Programming Interface (API): packages/ti/ Directory Reference

packages » ti

ti Directory Reference

Directories

directory | dsplink
directory | sdo


Codec Engine Application Programming Interface (API): packages/ti/dsplink/ Directory Reference

packages » ti » dsplink

dsplink Directory Reference

Directories

directory utils


Codec Engine Application Programming Interface (API): packages/ti/dsplink/utils/ Directory Reference

packages » ti » dsplink » utils

utils Directory Reference

Directories

directory ladclient


Codec Engine Application Programming Interface (API): packages/ti/dsplink/utils/ladclient/ Directory Reference

packages » ti » dsplink » utils » ladclient

ladclient Directory Reference

Files

file ladclient.h [code]

The Link Arbiter Daemon (LAD) communication interface. Provides wrapper functions to communicate with LAD, allowing a client to: establish a connection to LAD; request startup of a DSP server executable; query DSP status; and release the DSP and disconnect from LAD.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ Directory Reference

packages » ti » sdo

sdo Directory Reference

Directories

directory ce


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/ Directory Reference

packages » ti » sdo » ce

ce Directory Reference

Directories

directory | audio
directory | audio1
directory | image
directory | image1
directory | osal
directory | speech
directory | speech1
directory | universal
directory | utils
directory | vidanalytics
directory | video
directory | video1
directory | video2
directory | vidtranscode

Files

file | CERuntime.h [code]

The Codec Engine Runtime init module. Provides system wide initialization of the Codec Engine Runtime.

file | Engine.h [code]

The Codec Engine Runtime. Provides the user an inteface to open and manipulate an Engine which can instantiate and communicate with XDAIS algorithms that run either on the local CPU or on a "remote" DSP Server.

file | Server.h [code]

The Codec Engine Server Interface. Provides the user an inteface to open and manipulate a Server which contains remote algorithms.

file | visa.h [code]

The Codec Engine System Programming Interface. Provides system developers with services necessary to implement stubs and skeletons.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/audio/ Directory Reference

packages » ti » sdo » ce » audio

audio Directory Reference

Files

file | auddec.h [code]

The AUDDEC audio decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDDEC audio decoder interface.

file | audenc.h [code]

The AUDENC audio encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDENC audio encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/audio1/ Directory Reference

packages » ti » sdo » ce » audio1

audio1 Directory Reference

Files

file | auddec1.h [code]

The AUDDEC1 audio decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDDEC1 audio decoder interface.

file | audenc1.h [code]

The AUDENC1 audio encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IAUDENC1 audio encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/image/ Directory Reference

packages » ti » sdo » ce » image

image Directory Reference

Files

file | imgdec.h [code]

The IMGDEC image decoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IIMGDEC image decoder interface.

file | imgenc.h [code]

The IMGENC image encoder interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM-defined IIMGENC image encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/image1/ Directory Reference

packages » ti » sdo » ce » image1

image1 Directory Reference

Files

file | imgdec1.h [code]

The IMGDEC1 image decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IIMGDEC1 image decoder interface.

file | imgenc1.h [code]

The IMGENC1 image encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IIMGENC1 image encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/osal/ Directory Reference

packages » ti » sdo » ce » osal

osal Directory Reference

Files

file Memory.h [code]

The Codec Engine OSAL Memory interface. Provides the user an OS-independent Memory abstraction.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/speech/ Directory Reference

packages » ti » sdo » ce » speech

speech Directory Reference

Files

file | sphdec.h [code]

The SPHDEC speech decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHDEC speech decoder interface.

file | sphenc.h [code]

The SPHENC speech encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHENC speech encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/speech1/ Directory Reference

packages » ti » sdo » ce » speech1

speech1 Directory Reference

Files

file | sphdec1.h [code]

The SPHDEC1 decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM ISPHDEC1 speech decoder interface.

file | sphenc1.h [code]

The Speech 1.0 Encoder Codec Interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM 1.0 Speech Encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/universal/ Directory Reference

packages » ti » sdo » ce » universal

universal Directory Reference

Files

file universal.h [code]

The "universal" algorithm interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IUNIVERSAL interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/utils/ Directory Reference

packages » ti » sdo » ce » utils

utils Directory Reference

Directories

directory trace


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/utils/trace/ Directory Reference

packages » ti » sdo » ce » utils » trace

trace Directory Reference

Files

file TraceUtil.h [code]

The Codec Engine utility module for trace.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/vidanalytics/ Directory Reference

packages » ti » sdo » ce » vidanalytics

vidanalytics Directory Reference

Files

file vidanalytics.h [code]

The video analytics codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM video analytics interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video/ Directory Reference

packages » ti » sdo » ce » video

video Directory Reference

Files

file | viddec.h [code]

The VIDDEC video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC video decoder interface.

file | videnc.h [code]

The VIDENC video encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDENC video encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video1/ Directory Reference

packages » ti » sdo » ce » video1

video1 Directory Reference

Files

file | viddec1.h [code]

The 1.0 video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM 1.0 video decoder interface.

file | videnc1.h [code]

The VIDENC1 video encoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDENC1 video encoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video2/ Directory Reference

packages » ti » sdo » ce » video2

video2 Directory Reference

Directories

directory | split

Files

file | viddec2.h [code]

The VIDDEC2 video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC2 video decoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video2/split/ Directory Reference

packages » ti » sdo » ce » video2 » split

split Directory Reference

Files

file split/viddec2.h [code]

The VIDDEC2 split video decoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM IVIDDEC2FRONT or IVIDDEC2BACK video decoder interface.


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/vidtranscode/ Directory Reference

packages » ti » sdo » ce » vidtranscode

vidtranscode Directory Reference

Files

file vidtranscode.h [code]

The video transcoder codec interface. Provides the user an interface to create and interact with XDAIS algorithms that are compliant with the XDM video transcoder interface.


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- a -

  • AUDDEC1_Cmd : auddec1.h
  • AUDDEC1_control() : auddec1.h
  • AUDDEC1_create() : auddec1.h
  • AUDDEC1_delete() : auddec1.h
  • AUDDEC1_DynamicParams : auddec1.h
  • AUDDEC1_EFAIL : auddec1.h
  • AUDDEC1_EOK : auddec1.h
  • AUDDEC1_ETIMEOUT : auddec1.h
  • AUDDEC1_EUNSUPPORTED : auddec1.h
  • AUDDEC1_FOREVER : auddec1.h
  • AUDDEC1_Handle : auddec1.h
  • AUDDEC1_InArgs : auddec1.h
  • AUDDEC1_OutArgs : auddec1.h
  • AUDDEC1_Params : auddec1.h
  • AUDDEC1_process() : auddec1.h
  • AUDDEC1_processAsync() : auddec1.h
  • AUDDEC1_processWait() : auddec1.h
  • AUDDEC1_Status : auddec1.h
  • AUDDEC_Cmd : auddec.h
  • AUDDEC_control() : auddec.h
  • AUDDEC_create() : auddec.h
  • AUDDEC_delete() : auddec.h
  • AUDDEC_DynamicParams : auddec.h
  • AUDDEC_EFAIL : auddec.h
  • AUDDEC_EOK : auddec.h
  • AUDDEC_ERUNTIME : auddec.h
  • AUDDEC_ETIMEOUT : auddec.h
  • AUDDEC_FOREVER : auddec.h
  • AUDDEC_Handle : auddec.h
  • AUDDEC_InArgs : auddec.h
  • AUDDEC_OutArgs : auddec.h
  • AUDDEC_Params : auddec.h
  • AUDDEC_process() : auddec.h
  • AUDDEC_processAsync() : auddec.h
  • AUDDEC_processWait() : auddec.h
  • AUDDEC_Status : auddec.h
  • AUDENC1_Cmd : audenc1.h
  • AUDENC1_control() : audenc1.h
  • AUDENC1_create() : audenc1.h
  • AUDENC1_delete() : audenc1.h
  • AUDENC1_DynamicParams : audenc1.h
  • AUDENC1_EFAIL : audenc1.h
  • AUDENC1_EOK : audenc1.h
  • AUDENC1_ETIMEOUT : audenc1.h
  • AUDENC1_EUNSUPPORTED : audenc1.h
  • AUDENC1_FOREVER : audenc1.h
  • AUDENC1_Handle : audenc1.h
  • AUDENC1_InArgs : audenc1.h
  • AUDENC1_OutArgs : audenc1.h
  • AUDENC1_Params : audenc1.h
  • AUDENC1_process() : audenc1.h
  • AUDENC1_processAsync() : audenc1.h
  • AUDENC1_processWait() : audenc1.h
  • AUDENC1_Status : audenc1.h
  • AUDENC_Cmd : audenc.h
  • AUDENC_control() : audenc.h
  • AUDENC_create() : audenc.h
  • AUDENC_delete() : audenc.h
  • AUDENC_DynamicParams : audenc.h
  • AUDENC_EFAIL : audenc.h
  • AUDENC_EOK : audenc.h
  • AUDENC_ERUNTIME : audenc.h
  • AUDENC_ETIMEOUT : audenc.h
  • AUDENC_FOREVER : audenc.h
  • AUDENC_Handle : audenc.h
  • AUDENC_InArgs : audenc.h
  • AUDENC_OutArgs : audenc.h
  • AUDENC_Params : audenc.h
  • AUDENC_process() : audenc.h
  • AUDENC_processAsync() : audenc.h
  • AUDENC_processWait() : audenc.h
  • AUDENC_Status : audenc.h


Codec Engine Application Programming Interface (API): CERuntime.h Source File

  • File List
  • Globals
packages » ti » sdo » ce

CERuntime.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== ti/sdo/ce/CERuntime.h ========
00035  */
00036
00047 #ifndef CERuntime_
00048 #define CERuntime_
00049
00050 #ifdef __cplusplus
00051 extern "C" {
00052 #endif
00053
00056
00057 #include <ti/sdo/ce/Engine.h>
00058
00059 /*
00060  *  Macros for runtime configuration
00061  */
00062
00063
00064 /* Define this symbol so alg table for an engine can be NULL */
00065 #define CE_NULL_algs NULL
00066
00067 /*
00068  *  ======== CE_DECLARE_TYPE ========
00069  */
00099 #define CE_DECLARE_TYPE(name, types)         \
00100                                              \
00101 static String typeTab_##name [] = {          \
00102     types,                                   \
00103     NULL                                     \
00104 };                                           \
00105                                              \
00106 /*
00107  *  ======== CE_LOCAL_ALG ========
00108  */
00109
00143 #define CE_LOCAL_ALG(name, algName, ialgFxns, idma3Fxns, iresFxns, groupId, \
00144                      memType) \
00145                                              \
00146     { algName,        /* name */             \
00147       {0},            /* uuid */             \
00148       ialgFxns,       /* ialgFxns */         \
00149       idma3Fxns,      /* idma3Fxns */        \
00150       typeTab_##name, /* typeTab */          \
00151       TRUE,           /* isLocal */          \
00152       groupId,        /* groupId */          \
00153       0,              /* protocol */         \
00154       iresFxns,       /* iresFxns */         \
00155       NULL,           /* stub/skel params */ \
00156       memType,        /* cached mem type */  \
00157       NULL,           /* type - typeTab[0] will be used instead */ \
00158     },
00159
00160
00161 /*
00162  *  ======== CE_BEGIN_ALG_TABLE ========
00163  */
00183 #define CE_BEGIN_ALG_TABLE(name)        \
00184 static Engine_AlgDesc CE_##name##_algs[] = {
00185
00186
00187 /*
00188  *  ======== CE_END_ALG_TABLE ========
00189  */
00207 #define CE_END_ALG_TABLE(name) \
00208     {NULL},                    \
00209 };
00210
00211 /*
00212  *  ======== CE_ENGINE ========
00213  */
00232 #define CE_ENGINE(algTab, engineName, serverName) \
00233     { engineName,    /* engine naem */          \
00234       CE_##algTab##_algs,/* alg table */            \
00235       serverName,    /* optional server name */ \
00236       NULL,          /* link config id */       \
00237       0,             /* # of algs (filled in at runtime) */  \
00238     },
00239
00240
00241 /*
00242  *  ======== CE_BEGIN_ENGINE_TABLE ========
00243  */
00261 #define CE_BEGIN_ENGINE_TABLE(name) \
00262 static Engine_AlgDesc _localAlgs_000[] = {    \
00263     {NULL},                                   \
00264 };                                            \
00265                                               \
00266 static Engine_Desc name##_000[] = {
00267
00268 /*
00269  *  ======== CE_END_ENGINE_TABLE ========
00270  */
00288 #define CE_END_ENGINE_TABLE(name)             \
00289     {"local",                                 \
00290      _localAlgs_000,                          \
00291      NULL,                                    \
00292      NULL,                                    \
00293      0,                                       \
00294     },                                        \
00295     {NULL, NULL, NULL, NULL, 0}               \
00296 };                                            \
00297                                               \
00298 Engine_Config Engine_config = {               \
00299     name##_000,                               \
00300     "local"                                   \
00301 };
00302
00303 /*
00304  *  ======== CERuntime_exit ========
00305  */
00312 extern Void CERuntime_exit(Void);
00313
00314
00315 /*
00316  *  ======== CERuntime_init ========
00317  */
00325 extern Void CERuntime_init(Void);
00326
00329 #ifdef __cplusplus
00330 }
00331 #endif
00332
00333 #endif
00334 /*
00335  *  @(#) ti.sdo.ce; 1, 0, 6,429; 9-20-2010 16:39:34; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00336
00337  */
00338


Codec Engine Application Programming Interface (API): Engine.h Source File

  • File List
  • Globals
packages » ti » sdo » ce

Engine.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== Engine.h ========
00035  */
00036
00049 #ifndef Engine_
00050 #define Engine_
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00056
00057 #include <ti/sdo/ce/Server.h>
00058 #include <ti/sdo/ce/ipc/Comm.h>
00059 #include <ti/xdais/ialg.h>
00060 #include <ti/sdo/ce/node/node.h>
00061
00062 #include <stddef.h> /* def of size_t */
00063 #include <stdio.h>  /* def of FILE * */
00064
00067
00071 #define Engine_GTNAME "CE"
00072
00076 typedef struct Engine_Obj *Engine_Handle;
00077
00081 typedef Int Engine_Error;
00082
00083 #define Engine_EOK          0
00084 #define Engine_EEXIST       1
00085 #define Engine_ENOMEM       2
00086 #define Engine_EDSPLOAD     3
00087 #define Engine_ENOCOMM      4
00090 #define Engine_ENOSERVER    5
00091 #define Engine_ECOMALLOC    6
00092 #define Engine_ERUNTIME     7
00093 #define Engine_ECODECCREATE 8
00094 #define Engine_ECODECSTART  9
00099 #define Engine_EINVAL       10
00100 #define Engine_EBADSERVER   11
00101 #define Engine_ENOTAVAIL    12
00102 #define Engine_EWRONGSTATE  13
00103 #define Engine_EINUSE       14
00106 #define Engine_ENOTFOUND    15
00107 #define Engine_ETIMEOUT     16
00114 typedef struct Engine_NodeObj *Engine_Node;
00115
00119 #define Engine_FOREVER Comm_FOREVER
00120
00128 typedef struct Engine_Attrs {
00129     String procId;
00133 } Engine_Attrs;
00134
00140 typedef struct Engine_AlgInfo {
00141     Int         algInfoSize;
00142     String      name;
00143     String      *typeTab;
00144     Bool        isLocal;
00145 } Engine_AlgInfo;
00146
00157 typedef struct Engine_AlgInfo2 {
00158     Int         algInfoSize;
00159     String      name;
00160     String      types;
00161     Bool        isLocal;
00162 } Engine_AlgInfo2;
00163
00167 extern Engine_Attrs Engine_ATTRS;
00171 typedef Int Engine_Ctrl;
00172
00173 #define Engine_CEXIT    0
00174 #define Engine_MAXSEGNAMELENGTH 32
00175
00181 typedef enum Engine_CachedMemType {
00182     Engine_USECACHEDMEM_DEFAULT = -1,
00183     Engine_USECACHEDMEM_NONCACHED = 0,
00184     Engine_USECACHEDMEM_CACHED = 1
00185 } Engine_CachedMemType;
00186
00187
00188 /*
00189  *  ======== Engine_AlgDesc ========
00190  */
00191 typedef struct Engine_AlgDesc {
00192     String      name;
00193     NODE_Uuid   uuid;
00194     IALG_Fxns   *fxns;
00195     Ptr         idmaFxns;
00196     String      *typeTab;
00197     Bool        isLocal;
00198     Int         groupId;
00199     Int         rpcProtocolVersion;
00200     Ptr         iresFxns;
00201     Void        *codecClassConfig;
00202     Engine_CachedMemType memType;
00212     String      types;
00213 } Engine_AlgDesc;
00214
00215 /*
00216  *  ======== Engine_AlgCreateAttrs ========
00217  */
00218 typedef struct Engine_AlgCreateAttrs {
00219     Bool            useExtHeap;
00224     Int             priority;
00226 } Engine_AlgCreateAttrs;
00227
00228 /*
00229  *  ======== Engine_Desc ========
00230  */
00231 typedef struct Engine_Desc {
00232     String          name;
00233     Engine_AlgDesc  *algTab;
00234     String          remoteName;
00235     String          linkCfg;
00236     Int             numAlgs;
00238 } Engine_Desc;
00239
00240 /*
00241  *  ======== Engine_Config ========
00242  */
00243 typedef struct Engine_Config {
00244     Engine_Desc *engineTab;
00245     String      localEngine;
00246 } Engine_Config;
00247
00248 /*
00249  *  ======== Engine_MemStat ========
00250  *  This structure must match Server_MemStat.
00251  */
00252 typedef struct Engine_MemStat {
00253     Char   name[Engine_MAXSEGNAMELENGTH + 1]; /* Name of memory segment */
00254     Uint32 base;           /* Base address of memory segment */
00255     Uint32 size;           /* Original size of the memory segment. */
00256     Uint32 used;           /* Number of bytes used. */
00257     Uint32 maxBlockLen;    /* Size of the largest contiguous free block. */
00258 } Engine_MemStat;
00259
00260 /* Default alg create attributes */
00261 extern Engine_AlgCreateAttrs Engine_ALGCREATEATTRS;
00262
00263 /*
00264  *  ======== Engine_config ========
00265  */
00266 extern Engine_Config Engine_config;
00267
00268 /*
00269  *  ======== Engine_addStubFxns ========
00270  */
00282 extern Engine_Error Engine_addStubFxns(String fxnsName, IALG_Fxns *fxns);
00283
00284 /*
00285  *  ======== Engine_call ========
00286  */
00287 extern Int Engine_call(Engine_Node node, Comm_Msg *msg);
00288
00289 /*
00290  *  ======== Engine_callAsync ========
00291  */
00292 extern Int Engine_callAsync(Engine_Node node, Comm_Msg *msg);
00293
00294 /*
00295  *  ======== Engine_callWait ========
00296  */
00297 extern Int Engine_callWait(Engine_Node node, Comm_Msg *msg, UInt timeout);
00298
00299 /*
00300  *  ======== Engine_initFromServer ========
00301  */
00302 extern Engine_Error Engine_initFromServer(Engine_Handle engine);
00303
00304 /*
00305  *  ======== Engine_ctrlNode ========
00306  */
00307 extern Int Engine_ctrlNode(Engine_Node node, Comm_Msg *msg, Engine_Ctrl code);
00308
00311 /*
00312  *  ======== Engine_close ========
00313  */
00328 extern Void Engine_close(Engine_Handle engine);
00329
00331 /*
00332  *  ======== Engine_createNode ========
00333  */
00359 extern Engine_Node Engine_createNode(Engine_Handle engine, String name,
00360     size_t msgSize, IALG_Params *nodeAttrs, Engine_AlgCreateAttrs *attrs);
00361
00362
00363 /*
00364  *  ======== Engine_createNode2 ========
00365  */
00396 extern Engine_Node Engine_createNode2(Engine_Handle engine, String name,
00397     size_t msgSize, IALG_Params *nodeAttrs, Int nodeAttrsSize,
00398     Engine_AlgCreateAttrs *attrs);
00399
00400
00401 /*
00402  *  ======== Engine_deleteNode ========
00403  */
00404 extern Void Engine_deleteNode(Engine_Node node);
00405
00406 /*
00407  *  ======== Engine_getAlgMemRecs ========
00408  */
00422 extern Engine_Error Engine_getAlgMemRecs(Engine_Node node, IALG_MemRec *memTab, Int size,
00423         Int *numRecs);
00424
00425 /*
00426  *  ======== Engine_getAlgNumRecs ========
00427  */
00439 extern Engine_Error Engine_getAlgNumRecs(Engine_Node node, Int *numRecs);
00440
00441 /*
00442  *  ======== Engine_getConstName ========
00443  */
00444 extern String Engine_getConstName(Engine_Handle engine, String name,
00445     String type);
00446
00447 /*
00448  *  ======== Engine_getFxns ========
00449  */
00450 extern IALG_Fxns *Engine_getFxns(Engine_Handle svr, String name, String type,
00451         Bool *isLocal, Ptr *idmaFxns, Ptr *iresFxns, Int *groupId,
00452         Engine_CachedMemType *memType);
00453
00454 /*
00455  *  ======== Engine_getMemId ========
00456  */
00457 extern Int Engine_getMemId(Engine_Handle engine);
00458
00459 /*
00460  *  ======== Engine_getLocalEngine ========
00461  */
00462 extern Engine_Handle Engine_getLocalEngine(Void);
00463
00464 /*
00465  *  ======== Engine_getEngine ========
00466  */
00467 extern Engine_Handle Engine_getEngine(Engine_Node node);
00468
00469 /*
00470  *  ======== Engine_getMemStat ========
00471  */
00472 extern Engine_Error Engine_getMemStat(Server_Handle server, Int segNum,
00473     Engine_MemStat *stat);
00474
00475 /*
00476  *  ======== Engine_getNumServerAlgs ========
00477  */
00478 extern Engine_Error Engine_getNumServerAlgs(Server_Handle server, Int *nAlgs);
00479
00480 /*
00481  *  ======== Engine_getServerAlgInfo ========
00482  */
00483 extern Engine_Error Engine_getServerAlgInfo(Server_Handle server, Int algNum,
00484         Engine_AlgInfo *algInfo);
00485
00486 /*
00487  *  ======== Engine_getNumMemSegs ========
00488  */
00489 extern Engine_Error Engine_getNumMemSegs(Server_Handle server, Int *numSegs);
00490
00491 /*
00492  *  ======== Engine_hasServer ========
00493  */
00494 extern Bool Engine_hasServer(Engine_Handle engine);
00495
00496 /*
00497  *  ======== Engine_init ========
00498  */
00499 extern Void Engine_init(Void);
00500
00501 /*
00502  *  ======== Engine_getRemoteVisa ========
00503  */
00504 extern UInt32 Engine_getRemoteVisa(Engine_Node node);
00505
00506 /*
00507  *  ======== Engine_getCodecClassConfig ========
00508  */
00509 extern Ptr Engine_getCodecClassConfig(Engine_Handle engine, String name,
00510     String type);
00511
00512 /*
00513  *  ======== Engine_getNodeQueues ========
00514  */
00515 extern Void Engine_getNodeQueues(Engine_Node node, Comm_Queue *stdIn,
00516         Comm_Queue *stdOut);
00517
00518 /*
00519  *  ======== Engine_redefineHeap ========
00520  */
00521 extern Engine_Error Engine_redefineHeap(Server_Handle server, String name,
00522         Uint32 base, Uint32 size);
00523
00524 /*
00525  *  ======== Engine_releaseTraceToken ========
00526  */
00527 extern Bool Engine_releaseTraceToken(Server_Handle server);
00528
00529 /*
00530  *  ======== Engine_requestTraceToken ========
00531  */
00532 extern Engine_Error Engine_requestTraceToken(Server_Handle server);
00533
00534 /*
00535  *  ======== Engine_restoreHeap ========
00536  */
00537 extern Engine_Error Engine_restoreHeap(Server_Handle server, String name);
00538
00541 /*
00542  *  ======== Engine_open ========
00543  */
00586 extern Engine_Handle Engine_open(String name, Engine_Attrs *attrs,
00587     Engine_Error *ec);
00588
00589 /*
00590  *  ======== Engine_fwriteTrace ========
00591  */
00617 extern Int Engine_fwriteTrace(Engine_Handle engine, String prefix, FILE *out);
00618
00619 /*
00620  *  ======== Engine_getAlgInfo ========
00621  */
00656 extern Engine_Error Engine_getAlgInfo(String name, Engine_AlgInfo *algInfo,
00657         Int index);
00658
00659 /*
00660  *  ======== Engine_getAlgInfo2 ========
00661  */
00707 extern Engine_Error Engine_getAlgInfo2(String name, Engine_Handle engine,
00708         Engine_AlgInfo2 *algInfo2, Int index);
00709
00710 /*
00711  *  ======== Engine_getCpuLoad ========
00712  */
00741 extern Int Engine_getCpuLoad(Engine_Handle engine);
00742
00743 /*
00744  *  ======== Engine_getLastError ========
00745  */
00757 extern Engine_Error Engine_getLastError(Engine_Handle engine);
00758
00759 /*
00760  *  ======== Engine_getName ========
00761  */
00770 extern String Engine_getName(Engine_Handle engine);
00771
00772
00773 /*
00774  *  ======== Engine_getNumAlgs ========
00775  */
00799 extern Engine_Error Engine_getNumAlgs(String name, Int *numAlgs);
00800
00801 /*
00802  *  ======== Engine_getNumAlgs2 ========
00803  */
00844 extern Engine_Error Engine_getNumAlgs2(String name, Engine_Handle engine,
00845         Int *numAlgs);
00846
00847 /*
00848  *  ======== Engine_getServer ========
00849  */
00864 extern Server_Handle Engine_getServer(Engine_Handle engine);
00865
00866
00867 /*
00868  *  ======== Engine_getUsedMem ========
00869  */
00896 extern UInt32 Engine_getUsedMem(Engine_Handle engine);
00897
00898
00899 /*
00900  *  ======== Engine_setTrace ========
00901  */
00921 extern Int Engine_setTrace(Engine_Handle engine, String mask);
00922
00925 #ifdef __cplusplus
00926 }
00927 #endif
00928
00929 #endif
00930 /*
00931  *  @(#) ti.sdo.ce; 1, 0, 6,429; 9-20-2010 16:39:35; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00932
00933  */
00934


Codec Engine Application Programming Interface (API): Memory.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » osal

Memory.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== Memory.h ========
00035  */
00046 #ifndef ti_sdo_ce_osal_Memory_
00047 #define ti_sdo_ce_osal_Memory_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00055
00056 /*
00057  *  ======== Memory_DEFAULTALIGNMENT ========
00058  */
00059 #define Memory_DEFAULTALIGNMENT ((UInt)(-1))
00060
00061 /*
00062  *  ======== Memory_GTNAME ========
00063  */
00064 #define Memory_GTNAME "OM"
00065
00073 typedef struct Memory_Stat {
00074     String name;
00075     Uint32 base;
00076     UInt size;
00077     UInt used;
00078     UInt length;
00079 } Memory_Stat;
00080
00088 typedef enum {
00089     Memory_MALLOC = 0,
00090     Memory_SEG = 1,
00091     Memory_CONTIGPOOL = 2,
00092     Memory_CONTIGHEAP =3
00093 } Memory_type;
00094
00100 typedef struct Memory_AllocParams {
00101     Memory_type type;
00105     UInt flags;
00110     UInt align;
00111     UInt seg;
00112 } Memory_AllocParams;
00113
00114
00115 #define Memory_CACHED           0x00000000
00119 #define Memory_NONCACHED        0x00000001
00124 #define Memory_CACHEDMASK       0x00000001
00149 extern Memory_AllocParams Memory_DEFAULTPARAMS;
00150
00151 /*
00152  *  ======== Memory_alloc ========
00153  */
00167 extern Ptr Memory_alloc(UInt size, Memory_AllocParams *params);
00168
00169 /*
00170  *  ======== Memory_cacheInv ========
00171  */
00188 extern Void Memory_cacheInv(Ptr addr, Int sizeInBytes);
00189
00190
00191 /*
00192  *  ======== Memory_cacheWb ========
00193  */
00204 extern Void Memory_cacheWb(Ptr addr, Int sizeInBytes);
00205
00206
00207 /*
00208  *  ======== Memory_cacheWbInv ========
00209  */
00220 extern Void Memory_cacheWbInv(Ptr addr, Int sizeInBytes);
00221
00224 /*
00225  *  ======== Memory_cacheWbInvAll ========
00226  */
00235 extern Void Memory_cacheWbInvAll();
00236
00239 /*
00240  *  ======== Memory_contigAlloc ========
00241  */
00273 extern Ptr Memory_contigAlloc(UInt size, UInt align);
00274
00275
00276 /*
00277  *  ======== Memory_contigFree ========
00278  */
00297 extern Bool Memory_contigFree(Ptr addr, UInt size);
00298
00299
00302 /*
00303  *  ======== Memory_contigStat ========
00304  */
00323 extern Bool Memory_contigStat(Memory_Stat *statbuf);
00324
00328 /*
00329  *  ======== Memory_free ========
00330  */
00350 extern Bool Memory_free(Ptr addr, UInt size, Memory_AllocParams *params);
00351
00352
00353 /*
00354  *  ======== Memory_dumpKnownContigBufs ========
00355  */
00371 extern Void Memory_dumpKnownContigBufsList(Void);
00372
00373
00374 /*
00375  *  ======== Memory_getBufferPhysicalAddress ========
00376  */
00413 extern UInt32 Memory_getBufferPhysicalAddress(Ptr virtualAddress,
00414     Int sizeInBytes, Bool *isContiguous);
00415
00416 /*
00417  *  ======== Memory_getHeapId ========
00418  */
00432 extern Int Memory_getHeapId(String name);
00433
00434 /*
00435  *  ======== Memory_getNumHeaps ========
00436  */
00446 extern Int Memory_getNumHeaps();
00447
00448
00451 #ifdef ti_sdo_ce_osal_Memory_USEDEPRECATEDAPIS
00452
00453 /*
00454  *  ======== Memory_getPhysicalAddress ========
00455  *  Convert user virtual address to physical address
00456  *  (returns the exact same value everywhere other than on Linux)
00457  *
00458  *  This function is deprecated -- everyone should be calling
00459  *  Memory_getBufferPhysicalAddress() instead.
00460  */
00461 static inline UInt32 Memory_getPhysicalAddress(Ptr virtualAddress)
00462 {
00463     return(Memory_getBufferPhysicalAddress(virtualAddress, 4, NULL));
00464 }
00465
00466 #endif
00467
00471 /*
00472  *  ======== Memory_getBufferVirtualAddress ========
00473  */
00503 extern Ptr Memory_getBufferVirtualAddress(UInt32 physicalAddress,
00504     Int sizeInBytes);
00505
00508 /*
00509  *  ======== Memory_init ========
00510  */
00511 extern Bool Memory_init(Void);
00512
00513
00514 /*
00515  *  ======== Memory_exit ========
00516  */
00517 extern Void Memory_exit(Void);
00518
00519
00520 /*
00521  *  ======== Memory_redefine ========
00522  */
00539 extern Bool Memory_redefine(Int segId, Uint32 base, Uint32 size);
00540
00543 /*
00544  *  ======== Memory_registerContigBuf ========
00545  */
00575 extern Void Memory_registerContigBuf(UInt32 virtualAddress, UInt32 sizeInBytes,
00576     UInt32 physicalAddress);
00577
00580 /*
00581  *  ======== Memory_restoreHeap ========
00582  */
00596 extern Bool Memory_restoreHeap(Int segId);
00597
00598 /*
00599  *  ======== Memory_segAlloc ========
00600  */
00619 extern Ptr Memory_segAlloc(Int segId, UInt size, UInt align);
00620
00621
00622 /*
00623  *  ======== Memory_segFree ========
00624  */
00650 extern Bool Memory_segFree(Int segId, Ptr addr, UInt size);
00651
00652
00653 /*
00654  *  ======== Memory_segStat ========
00655  */
00675 extern Bool Memory_segStat(Int segId, Memory_Stat *statbuf);
00676
00679 /*
00680  *  ======== Memory_unregisterContigBuf ========
00681  */
00698 extern Void Memory_unregisterContigBuf(UInt32 virtualAddress,
00699     UInt32 sizeInBytes);
00700
00701   /* ingroup */
00703
00704 #ifdef __cplusplus
00705 }
00706 #endif
00707
00708 #endif
00709 /*
00710  *  @(#) ti.sdo.ce.osal; 2, 0, 2,424; 9-20-2010 16:41:45; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00711
00712  */
00713


Codec Engine Application Programming Interface (API): Server.h Source File

  • File List
  • Globals
packages » ti » sdo » ce

Server.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== Server.h ========
00035  *  DSP Server module
00036  *
00037  *  APIs for accessing information from remote server.
00038  */
00039
00050 #ifndef ti_sdo_ce_Server_
00051 #define ti_sdo_ce_Server_
00052
00053 #ifdef __cplusplus
00054 extern "C" {
00055 #endif
00056
00057 #include <stdio.h>  /* def of FILE * */
00058
00061
00065 #define Server_GTNAME "CS"
00066
00070 #define Server_MAXSEGNAMELENGTH 32
00071
00072
00076 typedef struct Server_Obj *Server_Handle;
00077
00081 typedef enum Server_Status {
00082     Server_EOK       = 0,
00083     Server_ENOSERVER = 1,
00084     Server_ENOMEM    = 2,
00085     Server_ERUNTIME  = 3,
00086     Server_EINVAL    = 4,
00087     Server_EWRONGSTATE =5,
00089     Server_EINUSE   = 6,
00091     Server_ENOTFOUND = 7,
00092     Server_EFAIL = 8
00093 } Server_Status;
00094
00100 typedef struct Server_AlgInfo {
00101     Int         algInfoSize;
00102     String      name;
00103     String      *typeTab;
00104 } Server_AlgInfo;
00105
00113 typedef struct Server_MemStat {
00114     Char   name[Server_MAXSEGNAMELENGTH + 1];
00115     Uint32 base;
00116     Uint32 size;
00117     Uint32 used;
00118     Uint32 maxBlockLen;
00119 } Server_MemStat;
00120
00121 /*
00122  *  ======== Server_connectTrace ========
00123  */
00145 extern Server_Status Server_connectTrace(Server_Handle server, Int * token);
00146
00147 /*
00148  *  ======== Server_disconnectTrace ========
00149  */
00167 extern Server_Status Server_disconnectTrace(Server_Handle server, Int token);
00168
00169 /*
00170  *  ======== Server_fwriteTrace ========
00171  */
00196 extern Int Server_fwriteTrace(Server_Handle server, String prefix, FILE *out);
00197
00198 /*
00199  *  ======== Server_getAlgInfo ========
00200  *  TODO: Do we need this?
00201  */
00224 extern Int Server_getAlgInfo(Server_Handle server, Int algNum,
00225         Server_AlgInfo *algInfo);
00226
00227 /*
00228  *  ======== Server_getCpuLoad ========
00229  */
00251 extern Int Server_getCpuLoad(Server_Handle server);
00252
00253 /*
00254  *  ======== Server_getMemStat ========
00255  */
00275 extern Server_Status Server_getMemStat(Server_Handle server, Int segNum,
00276         Server_MemStat *memStat);
00277
00278 /*
00279  *  ======== Server_getNumAlgs ========
00280  */
00296 extern Server_Status Server_getNumAlgs(Server_Handle server, Int *numAlgs);
00297
00298 /*
00299  *  ======== Server_getNumMemSegs ========
00300  */
00318 extern Server_Status Server_getNumMemSegs(Server_Handle server, Int *numSegs);
00319
00321 /*
00322  *  ======== Server_init ========
00323  */
00324 extern Void Server_init(Void);
00327 /*
00328  *  ======== Server_redefineHeap ========
00329  */
00380 extern Server_Status Server_redefineHeap(Server_Handle server, String name,
00381         Uint32 base, Uint32 size);
00382
00383 /*
00384  *  ======== Server_restoreHeap ========
00385  */
00417 extern Server_Status Server_restoreHeap(Server_Handle server, String name);
00418
00419 /*
00420  *  ======== Server_setTrace ========
00421  */
00443 extern Int Server_setTrace(Server_Handle server, String mask);
00444   /* ingroup */
00446
00447 #ifdef __cplusplus
00448 }
00449 #endif
00450
00451 #endif
00452 /*
00453  *  @(#) ti.sdo.ce; 1, 0, 6,429; 9-20-2010 16:39:35; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00454
00455  */
00456


Codec Engine Application Programming Interface (API): TraceUtil.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » utils » trace

TraceUtil.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== TraceUtil.h ========
00035  */
00045 #ifndef _TRACEUTIL_H
00046 #define _TRACEUTIL_H
00047
00048 #include <ti/sdo/ce/Engine.h>
00049
00050 #ifdef __cplusplus
00051 extern "C" {
00052 #endif
00053
00056
00057
00058 #define TRACEUTIL_SUCCESS 0
00059 #define TRACEUTIL_FAILURE -1
00061 /*
00062  *  ======== TraceUtil_start ========
00063  */
00064
00077 extern Int  TraceUtil_start(String engineName);
00078
00079 /*
00080  *  ======== TraceUtil_stop ========
00081  */
00091 extern Int  TraceUtil_stop(Void);
00092
00095 extern Void TraceUtil_exit();
00096 extern Void TraceUtil_init();
00097
00101
00102 #ifdef __cplusplus
00103 }
00104 #endif
00105
00106 #endif
00107
00108 /*
00109  *  @(#) ti.sdo.ce.utils.trace; 1, 0, 1,304; 9-20-2010 16:43:09; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00110
00111  */
00112


Codec Engine Application Programming Interface (API): auddec1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » audio1

auddec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== auddec1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_audio1_AUDDEC1_
00053 #define ti_sdo_ce_audio1_AUDDEC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/iauddec1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define AUDDEC1_EOK      IAUDDEC1_EOK
00070 #define AUDDEC1_EFAIL    IAUDDEC1_EFAIL
00073 #define AUDDEC1_EUNSUPPORTED IAUDDEC1_EUNSUPPORTED
00074
00075 #define AUDDEC1_ETIMEOUT VISA_ETIMEOUT
00076 #define AUDDEC1_FOREVER  VISA_FOREVER
00082 typedef VISA_Handle AUDDEC1_Handle;
00083
00088 typedef struct IAUDDEC1_Params AUDDEC1_Params;
00089
00090
00091 typedef IAUDDEC1_InArgs  AUDDEC1_InArgs;
00092 typedef IAUDDEC1_OutArgs AUDDEC1_OutArgs;
00093 typedef IAUDDEC1_Cmd     AUDDEC1_Cmd;
00094 typedef IAUDDEC1_Status  AUDDEC1_Status;
00097 typedef IAUDDEC1_DynamicParams AUDDEC1_DynamicParams;
00098
00099
00106 extern SKEL_Fxns AUDDEC1_SKEL;
00107
00111 extern IAUDDEC1_Fxns AUDDEC1_STUBS;
00112
00116 /*
00117  *  ======== AUDDEC1_control ========
00118  */
00142 extern Int32 AUDDEC1_control(AUDDEC1_Handle handle, AUDDEC1_Cmd id,
00143     AUDDEC1_DynamicParams *params, AUDDEC1_Status *status);
00144
00145
00146 /*
00147  *  ======== AUDDEC1_create ========
00148  */
00176 extern AUDDEC1_Handle AUDDEC1_create(Engine_Handle e, String name,
00177     AUDDEC1_Params *params);
00178
00179
00180 /*
00181  *  ======== AUDDEC1_delete ========
00182  */
00200 extern Void AUDDEC1_delete(AUDDEC1_Handle handle);
00201
00202
00203 /*
00204  *  ======== AUDDEC1_process ========
00205  */
00244 extern Int32 AUDDEC1_process(AUDDEC1_Handle handle, XDM1_BufDesc *inBufs,
00245     XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs);
00246
00247
00248 /*
00249  *  ======== AUDDEC1_processAsync ========
00250  */
00287 extern Int32 AUDDEC1_processAsync(AUDDEC1_Handle handle, XDM1_BufDesc *inBufs,
00288     XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs);
00289
00290
00291 /*
00292  *  ======== AUDDEC1_processWait ========
00293  */
00336 extern Int32 AUDDEC1_processWait(AUDDEC1_Handle handle, XDM1_BufDesc *inBufs,
00337     XDM1_BufDesc *outBufs, AUDDEC1_InArgs *inArgs, AUDDEC1_OutArgs *outArgs,
00338     UInt timeout);
00339
00340
00343 #ifdef __cplusplus
00344 }
00345 #endif
00346
00347 #endif
00348 /*
00349  *  @(#) ti.sdo.ce.audio1; 1, 0, 1,279; 9-20-2010 16:39:24; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00350
00351  */
00352


Codec Engine Application Programming Interface (API): auddec.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » audio

auddec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== auddec.h ========
00035  */
00051 #ifndef ti_sdo_ce_audio_AUDDEC_
00052 #define ti_sdo_ce_audio_AUDDEC_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 /*
00059  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00060  * define XDM_INCLUDE_DOT9_SUPPORT
00061  */
00062 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00063 #define XDM_INCLUDE_DOT9_SUPPORT
00064 #endif
00065 #include <ti/xdais/dm/xdm.h>
00066 #include <ti/xdais/dm/iauddec.h>
00067
00068 #include <ti/sdo/ce/Engine.h>
00069 #include <ti/sdo/ce/visa.h>
00070 #include <ti/sdo/ce/skel.h>
00071
00074
00075 typedef IAUDDEC_Status AUDDEC_Status;
00077 #define AUDDEC_EOK      IAUDDEC_EOK
00078 #define AUDDEC_EFAIL    IAUDDEC_EFAIL
00079 #define AUDDEC_ERUNTIME IAUDDEC_ERUNTIME
00080 #define AUDDEC_ETIMEOUT VISA_ETIMEOUT
00081 #define AUDDEC_FOREVER  VISA_FOREVER
00086 typedef VISA_Handle AUDDEC_Handle;
00087
00092 typedef struct IAUDDEC_Params AUDDEC_Params;
00093
00097 typedef IAUDDEC_InArgs          AUDDEC_InArgs;
00098
00102 typedef IAUDDEC_OutArgs         AUDDEC_OutArgs;
00103
00107 typedef IAUDDEC_Cmd             AUDDEC_Cmd;
00108
00112 typedef IAUDDEC_DynamicParams   AUDDEC_DynamicParams;
00113
00120 extern SKEL_Fxns AUDDEC_SKEL;
00121
00125 extern IAUDDEC_Fxns AUDDEC_STUBS;
00126
00130 /*
00131  *  ======== AUDDEC_create ========
00132  */
00161 extern AUDDEC_Handle AUDDEC_create(Engine_Handle e, String name,
00162     AUDDEC_Params *params);
00163
00164
00165 /*
00166  *  ======== AUDDEC_process ========
00167  */
00206 extern Int32 AUDDEC_process(AUDDEC_Handle handle,
00207         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00208         AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs);
00209
00210
00211 /*
00212  *  ======== AUDDEC_control ========
00213  */
00237 extern Int32 AUDDEC_control(AUDDEC_Handle handle, AUDDEC_Cmd id,
00238         AUDDEC_DynamicParams *params, AUDDEC_Status *status);
00239
00240
00241 /*
00242  *  ======== AUDDEC_delete ========
00243  */
00261 extern Void AUDDEC_delete(AUDDEC_Handle handle);
00262
00263
00264 /*
00265  *  ======== AUDDEC_processAsync ========
00266  */
00303 extern XDAS_Int32 AUDDEC_processAsync(AUDDEC_Handle handle, XDM_BufDesc *inBufs,
00304     XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs);
00305
00306
00307 /*
00308  *  ======== AUDDEC_processWait ========
00309  */
00352 extern XDAS_Int32 AUDDEC_processWait(AUDDEC_Handle handle, XDM_BufDesc *inBufs,
00353     XDM_BufDesc *outBufs, AUDDEC_InArgs *inArgs, AUDDEC_OutArgs *outArgs,
00354     UInt timeout);
00355
00356
00359 #ifdef __cplusplus
00360 }
00361 #endif
00362
00363 #endif
00364 /*
00365  *  @(#) ti.sdo.ce.audio; 1, 0, 2,406; 9-20-2010 16:39:24; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00366
00367  */
00368


Codec Engine Application Programming Interface (API): audenc1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » audio1

audenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== audenc1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_audio1_AUDENC1_
00053 #define ti_sdo_ce_audio1_AUDENC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/iaudenc1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define AUDENC1_EOK      IAUDENC1_EOK
00070 #define AUDENC1_EFAIL    IAUDENC1_EFAIL
00073 #define AUDENC1_EUNSUPPORTED IAUDENC1_EUNSUPPORTED
00074
00075 #define AUDENC1_ETIMEOUT VISA_ETIMEOUT
00076 #define AUDENC1_FOREVER  VISA_FOREVER
00082 typedef VISA_Handle AUDENC1_Handle;
00083
00088 typedef struct IAUDENC1_Params AUDENC1_Params;
00089
00090
00091 typedef IAUDENC1_InArgs  AUDENC1_InArgs;
00092 typedef IAUDENC1_OutArgs AUDENC1_OutArgs;
00093 typedef IAUDENC1_Cmd     AUDENC1_Cmd;
00094 typedef IAUDENC1_Status  AUDENC1_Status;
00097 typedef IAUDENC1_DynamicParams AUDENC1_DynamicParams;
00098
00099
00106 extern SKEL_Fxns AUDENC1_SKEL;
00107
00111 extern IAUDENC1_Fxns AUDENC1_STUBS;
00112
00116 /*
00117  *  ======== AUDENC1_control ========
00118  */
00142 extern Int32 AUDENC1_control(AUDENC1_Handle handle, AUDENC1_Cmd id,
00143     AUDENC1_DynamicParams *params, AUDENC1_Status *status);
00144
00145
00146 /*
00147  *  ======== AUDENC1_create ========
00148  */
00176 extern AUDENC1_Handle AUDENC1_create(Engine_Handle e, String name,
00177     AUDENC1_Params *params);
00178
00179
00180 /*
00181  *  ======== AUDENC1_delete ========
00182  */
00200 extern Void AUDENC1_delete(AUDENC1_Handle handle);
00201
00202
00203 /*
00204  *  ======== AUDENC1_process ========
00205  */
00244 extern Int32 AUDENC1_process(AUDENC1_Handle handle, XDM1_BufDesc *inBufs,
00245     XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs);
00246
00247
00248 /*
00249  *  ======== AUDENC1_processAsync ========
00250  */
00287 extern Int32 AUDENC1_processAsync(AUDENC1_Handle handle, XDM1_BufDesc *inBufs,
00288     XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs);
00289
00290
00291 /*
00292  *  ======== AUDENC1_processWait ========
00293  */
00336 extern Int32 AUDENC1_processWait(AUDENC1_Handle handle, XDM1_BufDesc *inBufs,
00337     XDM1_BufDesc *outBufs, AUDENC1_InArgs *inArgs, AUDENC1_OutArgs *outArgs,
00338     UInt timeout);
00339
00340
00343 #ifdef __cplusplus
00344 }
00345 #endif
00346
00347 #endif
00348 /*
00349  *  @(#) ti.sdo.ce.audio1; 1, 0, 1,279; 9-20-2010 16:39:25; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00350
00351  */
00352


Codec Engine Application Programming Interface (API): audenc.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » audio

audenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== audenc.h ========
00035  */
00051 #ifndef ti_sdo_ce_audio_AUDENC_
00052 #define ti_sdo_ce_audio_AUDENC_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 /*
00059  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00060  * define XDM_INCLUDE_DOT9_SUPPORT
00061  */
00062 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00063 #define XDM_INCLUDE_DOT9_SUPPORT
00064 #endif
00065 #include <ti/xdais/dm/xdm.h>
00066 #include <ti/xdais/dm/iaudenc.h>
00067
00068 #include <ti/sdo/ce/Engine.h>
00069 #include <ti/sdo/ce/visa.h>
00070 #include <ti/sdo/ce/skel.h>
00071
00074
00075 typedef IAUDENC_Status AUDENC_Status;
00077 #define AUDENC_EOK      IAUDENC_EOK
00078 #define AUDENC_EFAIL    IAUDENC_EFAIL
00079 #define AUDENC_ERUNTIME IAUDENC_ERUNTIME
00080 #define AUDENC_ETIMEOUT VISA_ETIMEOUT
00081 #define AUDENC_FOREVER  VISA_FOREVER
00086 typedef VISA_Handle AUDENC_Handle;
00087
00092 typedef struct IAUDENC_Params AUDENC_Params;
00093
00097 typedef IAUDENC_InArgs          AUDENC_InArgs;
00098
00102 typedef IAUDENC_OutArgs         AUDENC_OutArgs;
00103
00107 typedef IAUDENC_Cmd             AUDENC_Cmd;
00108
00112 typedef IAUDENC_DynamicParams   AUDENC_DynamicParams;
00113
00120 extern SKEL_Fxns AUDENC_SKEL;
00121
00125 extern IAUDENC_Fxns AUDENC_STUBS;
00126
00130 /*
00131  *  ======== AUDENC_create ========
00132  */
00161 extern AUDENC_Handle AUDENC_create(Engine_Handle e, String name,
00162         AUDENC_Params *params);
00163
00164
00165 /*
00166  *  ======== AUDENC_process ========
00167  */
00212 extern Int32 AUDENC_process(AUDENC_Handle handle,
00213         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00214         AUDENC_InArgs *inArgs, AUDENC_OutArgs *outArgs);
00215
00216
00217 /*
00218  *  ======== AUDENC_control ========
00219  */
00249 extern Int32 AUDENC_control(AUDENC_Handle handle, AUDENC_Cmd id,
00250         AUDENC_DynamicParams *params, AUDENC_Status *status);
00251
00252
00253 /*
00254  *  ======== AUDENC_delete ========
00255  */
00273 extern Void AUDENC_delete(AUDENC_Handle handle);
00274
00275
00276 /*
00277  *  ======== AUDENC_processAsync ========
00278  */
00318 extern XDAS_Int32 AUDENC_processAsync(AUDENC_Handle handle, XDM_BufDesc *inBufs,
00319     XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs);
00320
00321
00322 /*
00323  *  ======== AUDENC_processWait ========
00324  */
00367 extern XDAS_Int32 AUDENC_processWait(AUDENC_Handle handle, XDM_BufDesc *inBufs,
00368     XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs, IAUDENC_OutArgs *outArgs,
00369     UInt timeout);
00370
00371
00374 #ifdef __cplusplus
00375 }
00376 #endif
00377
00378 #endif
00379 /*
00380  *  @(#) ti.sdo.ce.audio; 1, 0, 2,406; 9-20-2010 16:39:24; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00381
00382  */
00383


Codec Engine Application Programming Interface (API): Alphabetical List

  • Data Structures
  • Data Structure Index
  • Data Fields

Data Structure Index

E | I | L | M | S | V | X
E
IIMGDEC1_DynamicParams ISPHDEC_DynamicParams IVIDDEC1_DynamicParams IVIDENC_CodecClassConfig
Engine_AlgInfo IIMGDEC1_Fxns ISPHDEC_Fxns IVIDDEC1_Fxns IVIDENC_DynamicParams
Engine_AlgInfo2 IIMGDEC1_InArgs ISPHDEC_InArgs IVIDDEC1_InArgs IVIDENC_Fxns
Engine_Attrs IIMGDEC1_Obj ISPHDEC_Obj IVIDDEC1_Obj IVIDENC_InArgs
I
IIMGDEC1_OutArgs ISPHDEC_OutArgs IVIDDEC1_OutArgs IVIDENC_Obj
IALG_Fxns IIMGDEC1_Params ISPHDEC_Params IVIDDEC1_Params IVIDENC_OutArgs
IALG_MemRec IIMGDEC1_Status ISPHDEC_Status IVIDDEC1_Status IVIDENC_Params
IALG_Obj IIMGDEC_CodecClassConfig ISPHENC1_DynamicParams IVIDDEC2_CodecClassConfig IVIDENC_Status
IALG_Params IIMGDEC_DynamicParams ISPHENC1_Fxns IVIDDEC2_DynamicParams IVIDEO1_BufDesc
IALG_Status IIMGDEC_Fxns ISPHENC1_InArgs IVIDDEC2_Fxns IVIDEO1_BufDescIn
IAUDDEC1_DynamicParams IIMGDEC_InArgs ISPHENC1_Obj IVIDDEC2_InArgs IVIDEO_BufDesc
IAUDDEC1_Fxns IIMGDEC_Obj ISPHENC1_OutArgs IVIDDEC2_Obj IVIDTRANSCODE_DynamicParams
IAUDDEC1_InArgs IIMGDEC_OutArgs ISPHENC1_Params IVIDDEC2_OutArgs IVIDTRANSCODE_Fxns
IAUDDEC1_Obj IIMGDEC_Params ISPHENC1_Status IVIDDEC2_Params IVIDTRANSCODE_InArgs
IAUDDEC1_OutArgs IIMGDEC_Status ISPHENC_DynamicParams IVIDDEC2_Status IVIDTRANSCODE_Obj
IAUDDEC1_Params IIMGENC1_CodecClassConfig ISPHENC_Fxns IVIDDEC2BACK_CodecClassConfig IVIDTRANSCODE_OutArgs
IAUDDEC1_Status IIMGENC1_DynamicParams ISPHENC_InArgs IVIDDEC2BACK_Fxns IVIDTRANSCODE_Params
IAUDDEC_DynamicParams IIMGENC1_Fxns ISPHENC_Obj IVIDDEC2BACK_Obj IVIDTRANSCODE_Status
IAUDDEC_Fxns IIMGENC1_InArgs ISPHENC_OutArgs IVIDDEC2FRONT_Fxns
L
IAUDDEC_InArgs IIMGENC1_Obj ISPHENC_Params IVIDDEC2FRONT_Obj LAD_DspStatus
IAUDDEC_Obj IIMGENC1_OutArgs ISPHENC_Status IVIDDEC2FRONT_OutArgs
M
IAUDDEC_OutArgs IIMGENC1_Params IUNIVERSAL_DynamicParams IVIDDEC2FRONT_Status Memory_AllocParams
IAUDDEC_Params IIMGENC1_Status IUNIVERSAL_Fxns IVIDDEC_CodecClassConfig
S
IAUDDEC_Status IIMGENC_CodecClassConfig IUNIVERSAL_InArgs IVIDDEC_DynamicParams Server_AlgInfo
IAUDENC1_DynamicParams IIMGENC_DynamicParams IUNIVERSAL_Obj IVIDDEC_Fxns Server_MemStat
IAUDENC1_Fxns IIMGENC_Fxns IUNIVERSAL_OutArgs IVIDDEC_InArgs
V
IAUDENC1_InArgs IIMGENC_InArgs IUNIVERSAL_Params IVIDDEC_Obj VISA_MsgHeader
IAUDENC1_Obj IIMGENC_Obj IUNIVERSAL_Status IVIDDEC_OutArgs
X
IAUDENC1_OutArgs IIMGENC_OutArgs IVIDANALYTICS_DynamicParams IVIDDEC_Params XDM1_BufDesc
IAUDENC1_Params IIMGENC_Params IVIDANALYTICS_Fxns IVIDDEC_Status XDM1_SingleBufDesc
IAUDENC1_Status IIMGENC_Status IVIDANALYTICS_Grid IVIDENC1_DynamicParams XDM_AlgBufInfo
IAUDENC_DynamicParams ISPHDEC1_DynamicParams IVIDANALYTICS_InArgs IVIDENC1_Fxns XDM_BufDesc
IAUDENC_Fxns ISPHDEC1_Fxns IVIDANALYTICS_Obj IVIDENC1_InArgs XDM_Context
IAUDENC_InArgs ISPHDEC1_InArgs IVIDANALYTICS_OutArgs IVIDENC1_MbData XDM_ContextInfo
IAUDENC_Obj ISPHDEC1_Obj IVIDANALYTICS_Params IVIDENC1_Obj XDM_Date
IAUDENC_OutArgs ISPHDEC1_OutArgs IVIDANALYTICS_Rule IVIDENC1_OutArgs XDM_Point
IAUDENC_Params ISPHDEC1_Params IVIDANALYTICS_Status IVIDENC1_Params XDM_Rect
IAUDENC_Status ISPHDEC1_Status IVIDDEC1_CodecClassConfig IVIDENC1_Status XDM_SingleBufDesc
IIMGDEC1_CodecClassConfig


Codec Engine Application Programming Interface (API): packages/ti/ -> cetools Relation

packages » ti

ti → cetools Relation

File in packages » ti | Includes file in cetools
sdo / ce / audio / auddec.h | packages / ti / xdais / dm / iauddec.h
sdo / ce / audio / auddec.h | packages / ti / xdais / dm / xdm.h
sdo / ce / audio1 / auddec1.h | packages / ti / xdais / dm / iauddec1.h
sdo / ce / audio1 / auddec1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / audio / audenc.h | packages / ti / xdais / dm / iaudenc.h
sdo / ce / audio / audenc.h | packages / ti / xdais / dm / xdm.h
sdo / ce / audio1 / audenc1.h | packages / ti / xdais / dm / iaudenc1.h
sdo / ce / audio1 / audenc1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / Engine.h | packages / ti / xdais / ialg.h
sdo / ce / image / imgdec.h | packages / ti / xdais / dm / iimgdec.h
sdo / ce / image / imgdec.h | packages / ti / xdais / dm / xdm.h
sdo / ce / image1 / imgdec1.h | packages / ti / xdais / dm / iimgdec1.h
sdo / ce / image1 / imgdec1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / image / imgenc.h | packages / ti / xdais / dm / iimgenc.h
sdo / ce / image / imgenc.h | packages / ti / xdais / dm / xdm.h
sdo / ce / image1 / imgenc1.h | packages / ti / xdais / dm / iimgenc1.h
sdo / ce / image1 / imgenc1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / speech / sphdec.h | packages / ti / xdais / dm / isphdec.h
sdo / ce / speech / sphdec.h | packages / ti / xdais / dm / xdm.h
sdo / ce / speech1 / sphdec1.h | packages / ti / xdais / dm / isphdec1.h
sdo / ce / speech1 / sphdec1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / speech / sphenc.h | packages / ti / xdais / dm / isphenc.h
sdo / ce / speech / sphenc.h | packages / ti / xdais / dm / xdm.h
sdo / ce / speech1 / sphenc1.h | packages / ti / xdais / dm / isphenc1.h
sdo / ce / speech1 / sphenc1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / video2 / split / split/viddec2.h | packages / ti / xdais / dm / split / split/ividdec2.h
sdo / ce / video2 / split / split/viddec2.h | packages / ti / xdais / dm / xdm.h
sdo / ce / universal / universal.h | packages / ti / xdais / dm / iuniversal.h
sdo / ce / universal / universal.h | packages / ti / xdais / dm / xdm.h
sdo / ce / vidanalytics / vidanalytics.h | packages / ti / xdais / dm / ividanalytics.h
sdo / ce / vidanalytics / vidanalytics.h | packages / ti / xdais / dm / xdm.h
sdo / ce / video / viddec.h | packages / ti / xdais / dm / ividdec.h
sdo / ce / video / viddec.h | packages / ti / xdais / dm / xdm.h
sdo / ce / video1 / viddec1.h | packages / ti / xdais / dm / ividdec1.h
sdo / ce / video1 / viddec1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / video2 / viddec2.h | packages / ti / xdais / dm / ividdec2.h
sdo / ce / video2 / viddec2.h | packages / ti / xdais / dm / xdm.h
sdo / ce / video / videnc.h | packages / ti / xdais / dm / ividenc.h
sdo / ce / video / videnc.h | packages / ti / xdais / dm / xdm.h
sdo / ce / video1 / videnc1.h | packages / ti / xdais / dm / ividenc1.h
sdo / ce / video1 / videnc1.h | packages / ti / xdais / dm / xdm.h
sdo / ce / vidtranscode / vidtranscode.h | packages / ti / xdais / dm / ividtranscode.h
sdo / ce / vidtranscode / vidtranscode.h | packages / ti / xdais / dm / xdm.h
sdo / ce / visa.h | packages / ti / xdais / ialg.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ -> cetools Relation

packages » ti » sdo

sdo → cetools Relation

File in packages » ti » sdo | Includes file in cetools
ce / audio / auddec.h | packages / ti / xdais / dm / iauddec.h
ce / audio / auddec.h | packages / ti / xdais / dm / xdm.h
ce / audio1 / auddec1.h | packages / ti / xdais / dm / iauddec1.h
ce / audio1 / auddec1.h | packages / ti / xdais / dm / xdm.h
ce / audio / audenc.h | packages / ti / xdais / dm / iaudenc.h
ce / audio / audenc.h | packages / ti / xdais / dm / xdm.h
ce / audio1 / audenc1.h | packages / ti / xdais / dm / iaudenc1.h
ce / audio1 / audenc1.h | packages / ti / xdais / dm / xdm.h
ce / Engine.h | packages / ti / xdais / ialg.h
ce / image / imgdec.h | packages / ti / xdais / dm / iimgdec.h
ce / image / imgdec.h | packages / ti / xdais / dm / xdm.h
ce / image1 / imgdec1.h | packages / ti / xdais / dm / iimgdec1.h
ce / image1 / imgdec1.h | packages / ti / xdais / dm / xdm.h
ce / image / imgenc.h | packages / ti / xdais / dm / iimgenc.h
ce / image / imgenc.h | packages / ti / xdais / dm / xdm.h
ce / image1 / imgenc1.h | packages / ti / xdais / dm / iimgenc1.h
ce / image1 / imgenc1.h | packages / ti / xdais / dm / xdm.h
ce / speech / sphdec.h | packages / ti / xdais / dm / isphdec.h
ce / speech / sphdec.h | packages / ti / xdais / dm / xdm.h
ce / speech1 / sphdec1.h | packages / ti / xdais / dm / isphdec1.h
ce / speech1 / sphdec1.h | packages / ti / xdais / dm / xdm.h
ce / speech / sphenc.h | packages / ti / xdais / dm / isphenc.h
ce / speech / sphenc.h | packages / ti / xdais / dm / xdm.h
ce / speech1 / sphenc1.h | packages / ti / xdais / dm / isphenc1.h
ce / speech1 / sphenc1.h | packages / ti / xdais / dm / xdm.h
ce / video2 / split / split/viddec2.h | packages / ti / xdais / dm / split / split/ividdec2.h
ce / video2 / split / split/viddec2.h | packages / ti / xdais / dm / xdm.h
ce / universal / universal.h | packages / ti / xdais / dm / iuniversal.h
ce / universal / universal.h | packages / ti / xdais / dm / xdm.h
ce / vidanalytics / vidanalytics.h | packages / ti / xdais / dm / ividanalytics.h
ce / vidanalytics / vidanalytics.h | packages / ti / xdais / dm / xdm.h
ce / video / viddec.h | packages / ti / xdais / dm / ividdec.h
ce / video / viddec.h | packages / ti / xdais / dm / xdm.h
ce / video1 / viddec1.h | packages / ti / xdais / dm / ividdec1.h
ce / video1 / viddec1.h | packages / ti / xdais / dm / xdm.h
ce / video2 / viddec2.h | packages / ti / xdais / dm / ividdec2.h
ce / video2 / viddec2.h | packages / ti / xdais / dm / xdm.h
ce / video / videnc.h | packages / ti / xdais / dm / ividenc.h
ce / video / videnc.h | packages / ti / xdais / dm / xdm.h
ce / video1 / videnc1.h | packages / ti / xdais / dm / ividenc1.h
ce / video1 / videnc1.h | packages / ti / xdais / dm / xdm.h
ce / vidtranscode / vidtranscode.h | packages / ti / xdais / dm / ividtranscode.h
ce / vidtranscode / vidtranscode.h | packages / ti / xdais / dm / xdm.h
ce / visa.h | packages / ti / xdais / ialg.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/ -> cetools Relation

packages » ti » sdo » ce

ce → cetools Relation

File in packages » ti » sdo » ce | Includes file in cetools
audio / auddec.h | packages / ti / xdais / dm / iauddec.h
audio / auddec.h | packages / ti / xdais / dm / xdm.h
audio1 / auddec1.h | packages / ti / xdais / dm / iauddec1.h
audio1 / auddec1.h | packages / ti / xdais / dm / xdm.h
audio / audenc.h | packages / ti / xdais / dm / iaudenc.h
audio / audenc.h | packages / ti / xdais / dm / xdm.h
audio1 / audenc1.h | packages / ti / xdais / dm / iaudenc1.h
audio1 / audenc1.h | packages / ti / xdais / dm / xdm.h
Engine.h | packages / ti / xdais / ialg.h
image / imgdec.h | packages / ti / xdais / dm / iimgdec.h
image / imgdec.h | packages / ti / xdais / dm / xdm.h
image1 / imgdec1.h | packages / ti / xdais / dm / iimgdec1.h
image1 / imgdec1.h | packages / ti / xdais / dm / xdm.h
image / imgenc.h | packages / ti / xdais / dm / iimgenc.h
image / imgenc.h | packages / ti / xdais / dm / xdm.h
image1 / imgenc1.h | packages / ti / xdais / dm / iimgenc1.h
image1 / imgenc1.h | packages / ti / xdais / dm / xdm.h
speech / sphdec.h | packages / ti / xdais / dm / isphdec.h
speech / sphdec.h | packages / ti / xdais / dm / xdm.h
speech1 / sphdec1.h | packages / ti / xdais / dm / isphdec1.h
speech1 / sphdec1.h | packages / ti / xdais / dm / xdm.h
speech / sphenc.h | packages / ti / xdais / dm / isphenc.h
speech / sphenc.h | packages / ti / xdais / dm / xdm.h
speech1 / sphenc1.h | packages / ti / xdais / dm / isphenc1.h
speech1 / sphenc1.h | packages / ti / xdais / dm / xdm.h
video2 / split / split/viddec2.h | packages / ti / xdais / dm / split / split/ividdec2.h
video2 / split / split/viddec2.h | packages / ti / xdais / dm / xdm.h
universal / universal.h | packages / ti / xdais / dm / iuniversal.h
universal / universal.h | packages / ti / xdais / dm / xdm.h
vidanalytics / vidanalytics.h | packages / ti / xdais / dm / ividanalytics.h
vidanalytics / vidanalytics.h | packages / ti / xdais / dm / xdm.h
video / viddec.h | packages / ti / xdais / dm / ividdec.h
video / viddec.h | packages / ti / xdais / dm / xdm.h
video1 / viddec1.h | packages / ti / xdais / dm / ividdec1.h
video1 / viddec1.h | packages / ti / xdais / dm / xdm.h
video2 / viddec2.h | packages / ti / xdais / dm / ividdec2.h
video2 / viddec2.h | packages / ti / xdais / dm / xdm.h
video / videnc.h | packages / ti / xdais / dm / ividenc.h
video / videnc.h | packages / ti / xdais / dm / xdm.h
video1 / videnc1.h | packages / ti / xdais / dm / ividenc1.h
video1 / videnc1.h | packages / ti / xdais / dm / xdm.h
vidtranscode / vidtranscode.h | packages / ti / xdais / dm / ividtranscode.h
vidtranscode / vidtranscode.h | packages / ti / xdais / dm / xdm.h
visa.h | packages / ti / xdais / ialg.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/audio/ -> cetools Relation

packages » ti » sdo » ce » audio

audio → cetools Relation

File in packages » ti » sdo » ce » audio | Includes file in cetools
auddec.h | packages / ti / xdais / dm / iauddec.h
auddec.h | packages / ti / xdais / dm / xdm.h
audenc.h | packages / ti / xdais / dm / iaudenc.h
audenc.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/audio1/ -> cetools Relation

packages » ti » sdo » ce » audio1

audio1 → cetools Relation

File in packages » ti » sdo » ce » audio1 | Includes file in cetools
auddec1.h | packages / ti / xdais / dm / iauddec1.h
auddec1.h | packages / ti / xdais / dm / xdm.h
audenc1.h | packages / ti / xdais / dm / iaudenc1.h
audenc1.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/image/ -> cetools Relation

packages » ti » sdo » ce » image

image → cetools Relation

File in packages » ti » sdo » ce » image | Includes file in cetools
imgdec.h | packages / ti / xdais / dm / iimgdec.h
imgdec.h | packages / ti / xdais / dm / xdm.h
imgenc.h | packages / ti / xdais / dm / iimgenc.h
imgenc.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/image1/ -> cetools Relation

packages » ti » sdo » ce » image1

image1 → cetools Relation

File in packages » ti » sdo » ce » image1 | Includes file in cetools
imgdec1.h | packages / ti / xdais / dm / iimgdec1.h
imgdec1.h | packages / ti / xdais / dm / xdm.h
imgenc1.h | packages / ti / xdais / dm / iimgenc1.h
imgenc1.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/speech/ -> cetools Relation

packages » ti » sdo » ce » speech

speech → cetools Relation

File in packages » ti » sdo » ce » speech | Includes file in cetools
sphdec.h | packages / ti / xdais / dm / isphdec.h
sphdec.h | packages / ti / xdais / dm / xdm.h
sphenc.h | packages / ti / xdais / dm / isphenc.h
sphenc.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/speech1/ -> cetools Relation

packages » ti » sdo » ce » speech1

speech1 → cetools Relation

File in packages » ti » sdo » ce » speech1 | Includes file in cetools
sphdec1.h | packages / ti / xdais / dm / isphdec1.h
sphdec1.h | packages / ti / xdais / dm / xdm.h
sphenc1.h | packages / ti / xdais / dm / isphenc1.h
sphenc1.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/universal/ -> cetools Relation

packages » ti » sdo » ce » universal

universal → cetools Relation

File in packages » ti » sdo » ce » universal Includes file in cetools


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/vidanalytics/ -> cetools Relation

packages » ti » sdo » ce » vidanalytics

vidanalytics → cetools Relation

File in packages » ti » sdo » ce » vidanalytics Includes file in cetools


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video/ -> cetools Relation

packages » ti » sdo » ce » video

video → cetools Relation

File in packages » ti » sdo » ce » video | Includes file in cetools
viddec.h | packages / ti / xdais / dm / ividdec.h
viddec.h | packages / ti / xdais / dm / xdm.h
videnc.h | packages / ti / xdais / dm / ividenc.h
videnc.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video1/ -> cetools Relation

packages » ti » sdo » ce » video1

video1 → cetools Relation

File in packages » ti » sdo » ce » video1 | Includes file in cetools
viddec1.h | packages / ti / xdais / dm / ividdec1.h
viddec1.h | packages / ti / xdais / dm / xdm.h
videnc1.h | packages / ti / xdais / dm / ividenc1.h
videnc1.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video2/ -> cetools Relation

packages » ti » sdo » ce » video2

video2 → cetools Relation

File in packages » ti » sdo » ce » video2 | Includes file in cetools
split / split/viddec2.h | packages / ti / xdais / dm / split / split/ividdec2.h
split / split/viddec2.h | packages / ti / xdais / dm / xdm.h
viddec2.h | packages / ti / xdais / dm / ividdec2.h
viddec2.h | packages / ti / xdais / dm / xdm.h
All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/video2/split/ -> cetools Relation

packages » ti » sdo » ce » video2 » split

split → cetools Relation

File in packages » ti » sdo » ce » video2 » split Includes file in cetools


Codec Engine Application Programming Interface (API): packages/ti/sdo/ce/vidtranscode/ -> cetools Relation

packages » ti » sdo » ce » vidtranscode

vidtranscode → cetools Relation

File in packages » ti » sdo » ce » vidtranscode Includes file in cetools


Codec Engine Application Programming Interface (API): disclaimer.dox File Reference

  • File List
  • Globals

disclaimer.dox File Reference

All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): doxygen.txt File Reference

  • File List
  • Globals

doxygen.txt File Reference

All Data Structures Files Functions Variables Typedefs Enumerations Enumerator Defines


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- k -

  • keepInputFrameRateFlag : IVIDTRANSCODE_DynamicParams
  • keepInputGOPFlag : IVIDTRANSCODE_DynamicParams
  • keepInputResolutionFlag : IVIDTRANSCODE_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- l -

  • lfeFlag : IAUDDEC1_InArgs , IAUDDEC1_Status , IAUDENC1_Status , IAUDENC1_DynamicParams , IAUDENC1_Params , IAUDDEC1_OutArgs
  • linkConfigName : LAD_DspStatus


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- m -

  • manageDisplayBufsCache : IVIDDEC_CodecClassConfig
  • manageInBufsCache : IIMGDEC_CodecClassConfig , IIMGDEC1_CodecClassConfig , IVIDDEC1_CodecClassConfig , IVIDDEC2BACK_CodecClassConfig , IIMGENC1_CodecClassConfig , IVIDDEC2_CodecClassConfig , IIMGENC_CodecClassConfig , IVIDDEC_CodecClassConfig , IVIDENC_CodecClassConfig
  • manageIntermediateBufsCache : IVIDDEC2BACK_CodecClassConfig
  • manageOutBufsCache : IVIDDEC_CodecClassConfig , IVIDENC_CodecClassConfig , IVIDDEC1_CodecClassConfig , IVIDDEC2BACK_CodecClassConfig , IVIDDEC2_CodecClassConfig , IIMGDEC_CodecClassConfig , IIMGENC_CodecClassConfig , IIMGDEC1_CodecClassConfig , IIMGENC1_CodecClassConfig
  • manageReconBufsCache : IVIDENC_CodecClassConfig
  • maxBitrate : IAUDDEC_Params , IAUDENC_Params
  • maxBitRate : IAUDENC1_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params
  • maxBitRateInput : IVIDTRANSCODE_Params
  • maxBitRateOutput : IVIDTRANSCODE_Params
  • maxBlockLen : Server_MemStat
  • maxFrameRate : IVIDANALYTICS_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params
  • maxFrameRateInput : IVIDTRANSCODE_Params
  • maxFrameRateOutput : IVIDTRANSCODE_Params
  • maxHeight : IIMGDEC_Params , IIMGDEC1_Params , IIMGENC_Params , IIMGENC1_Params , IVIDANALYTICS_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params
  • maxHeightInput : IVIDTRANSCODE_Params
  • maxHeightOutput : IVIDTRANSCODE_Params
  • maxInterFrameInterval : IVIDENC_Params , IVIDENC1_Params
  • maxNoOfCh : IAUDDEC_Params , IAUDENC_Params
  • maxNumDisplayBufs : IVIDDEC2_Status
  • maxRules : IVIDANALYTICS_Params
  • maxSampleRate : IAUDDEC_Params , IAUDENC_Params
  • maxScans : IIMGENC1_Params , IIMGENC_Params , IIMGDEC_Params , IIMGDEC1_Params
  • maxWidth : IIMGDEC_Params , IIMGDEC1_Params , IIMGENC_Params , IIMGENC1_Params , IVIDDEC2_Params , IVIDENC1_Params , IVIDDEC1_Params , IVIDDEC_Params , IVIDENC_Params , IVIDANALYTICS_Params
  • maxWidthInput : IVIDTRANSCODE_Params
  • maxWidthOutput : IVIDTRANSCODE_Params
  • mbDataBuf : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • mbDataFlag : IVIDDEC2_DynamicParams , IVIDENC1_DynamicParams , IVIDDEC1_DynamicParams
  • mbMode : IVIDENC1_MbData
  • minContextSize : XDM_ContextInfo
  • minInBufSize : XDM_AlgBufInfo
  • minIntermediateBufSizes : XDM_ContextInfo
  • minNumInBufs : XDM_AlgBufInfo
  • minNumOutBufs : XDM_AlgBufInfo
  • minOutBufSize : XDM_AlgBufInfo
  • mode : ISPHENC1_Status , ISPHENC1_DynamicParams , ISPHENC_DynamicParams , ISPHENC_Status , ISPHDEC_OutArgs
  • month : XDM_Date
  • msecsOfDay : XDM_Date
  • mvBwdXY : IVIDENC1_MbData
  • mvFwdXY : IVIDENC1_MbData


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- n -

  • name : Engine_AlgInfo , Engine_AlgInfo2 , Server_MemStat , Server_AlgInfo
  • newFrameFlag : IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • nextPartRequiredFlag : IVIDDEC2FRONT_Status
  • noiseSuppressionMode : ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_DynamicParams , ISPHENC1_Status
  • nullTrafficChannel : ISPHENC_InArgs , ISPHENC1_InArgs
  • numAU : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IIMGDEC_DynamicParams , IIMGDEC1_DynamicParams
  • numBlockHorizontal : IVIDANALYTICS_Grid
  • numBlockVertical : IVIDANALYTICS_Grid
  • numBufs : IVIDEO_BufDesc , IVIDEO1_BufDescIn , IVIDEO1_BufDesc , XDM_BufDesc , XDM1_BufDesc
  • numBytes : IIMGDEC_InArgs , IVIDTRANSCODE_InArgs , IVIDDEC2_InArgs , IAUDDEC_InArgs , IAUDDEC1_InArgs , IIMGDEC1_InArgs , IVIDDEC_InArgs , IVIDDEC1_InArgs
  • numChannels : IAUDDEC_Status , IAUDENC_DynamicParams
  • numClientsStarted : LAD_DspStatus
  • numEvents : IVIDANALYTICS_OutArgs
  • numInBufs : XDM_Context
  • numInOutBufs : XDM_Context
  • numInSamples : IAUDENC1_InArgs , IAUDENC1_OutArgs
  • numLFEChannels : IAUDENC_DynamicParams , IAUDDEC_Status
  • numOutBufs : XDM_Context
  • numOutputStreams : IVIDTRANSCODE_Params
  • numSamples : IAUDDEC1_Status , IAUDDEC1_OutArgs
  • numTargets : IVIDANALYTICS_OutArgs
  • numZeroesPadded : IAUDENC1_OutArgs


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- o -

  • objectType : IVIDANALYTICS_Rule
  • outbufferSize : ISPHENC_OutArgs
  • outBufs : XDM_Context
  • outBufsInUseFlag : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs , IVIDTRANSCODE_OutArgs
  • outChromaformat : IIMGDEC_Status
  • outputBitsPerSample : IAUDDEC_Status , IAUDDEC1_Status
  • outputChromaFormat : IIMGDEC1_Status , IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status
  • outputFormat : IAUDDEC_DynamicParams , IAUDDEC_Status
  • outputFrameRate : IVIDTRANSCODE_DynamicParams
  • outputHeight : IIMGDEC_Status , IIMGDEC1_Status , IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status , IVIDTRANSCODE_DynamicParams
  • outputID : IVIDTRANSCODE_OutArgs , IVIDDEC_OutArgs , IVIDENC1_OutArgs , IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • outputMbDataID : IVIDDEC2_OutArgs , IVIDDEC1_OutArgs
  • outputPCMWidth : IAUDDEC1_Params
  • outputWidth : IVIDDEC_Status , IVIDDEC2_Status , IVIDDEC1_Status , IIMGDEC1_Status , IVIDTRANSCODE_DynamicParams , IIMGDEC_Status


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- b -

  • base : IALG_MemRec , Server_MemStat
  • bfiFlag : ISPHDEC_InArgs
  • bitRate : IAUDDEC_Status , IAUDENC1_DynamicParams , ISPHENC1_Status , IVIDDEC_Status , IAUDENC1_Status , IVIDDEC1_Status , IVIDDEC2_Status , IAUDDEC1_Status , ISPHDEC1_Params , ISPHDEC1_Status , IAUDENC_DynamicParams , ISPHENC_DynamicParams , ISPHENC_Status , IAUDENC1_Params , ISPHENC1_Params , ISPHENC1_DynamicParams
  • bitsConsumed : IVIDTRANSCODE_OutArgs
  • bitsGenerated : IVIDTRANSCODE_OutArgs
  • blockHeight : IVIDANALYTICS_Grid
  • blockWidth : IVIDANALYTICS_Grid
  • bottomRight : XDM_Rect
  • buf : XDM_SingleBufDesc , XDM1_SingleBufDesc
  • bufDesc : IVIDEO1_BufDescIn , IVIDEO1_BufDesc
  • bufInfo : IAUDENC1_Status , ISPHENC_Status , IIMGDEC_Status , IIMGDEC1_Status , IIMGENC_Status , IIMGENC1_Status , ISPHDEC_Status , ISPHDEC1_Status , IVIDTRANSCODE_Status , IAUDENC_Status , ISPHENC1_Status , IVIDANALYTICS_Status , IVIDDEC_Status , IVIDDEC2_Status , IVIDENC_Status , IVIDENC1_Status , IVIDDEC1_Status , IAUDDEC_Status , IAUDDEC1_Status
  • bufs : IVIDEO_BufDesc , XDM_BufDesc
  • bufSize : XDM_SingleBufDesc , XDM1_SingleBufDesc
  • bufSizes : XDM_BufDesc , IVIDEO_BufDesc
  • bytesConsumed : IVIDDEC2FRONT_OutArgs , IVIDDEC2_OutArgs , IAUDDEC_OutArgs , IAUDDEC1_OutArgs , IVIDDEC1_OutArgs
  • bytesconsumed : IIMGDEC_OutArgs
  • bytesConsumed : IVIDDEC_OutArgs , IIMGDEC1_OutArgs
  • bytesGenerated : IIMGENC_OutArgs , IAUDENC1_OutArgs , IAUDENC_OutArgs , IVIDENC_OutArgs , IIMGENC1_OutArgs , IVIDENC1_OutArgs


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- c -

  • captureWidth : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • channelMode : IAUDENC1_DynamicParams , IAUDENC1_Status , IAUDDEC1_Status , IAUDDEC1_OutArgs , IAUDENC1_Params
  • chromaFormat : IVIDEO1_BufDesc
  • cmd : VISA_MsgHeader
  • codecSelection : ISPHDEC1_Params , ISPHDEC1_Status , ISPHENC1_Params , ISPHENC1_Status
  • compandingLaw : ISPHDEC_Params , ISPHDEC1_Params , ISPHDEC1_Status , ISPHENC_Params , ISPHENC1_Params , ISPHENC1_Status
  • contentType : IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status , IVIDEO1_BufDesc
  • contextInfo : IVIDDEC2FRONT_Status
  • control : IUNIVERSAL_Fxns , IAUDENC_Fxns , IVIDTRANSCODE_Fxns , IIMGDEC1_Fxns , IIMGENC_Fxns , IVIDENC1_Fxns , IIMGENC1_Fxns , ISPHDEC1_Fxns , ISPHENC_Fxns , IVIDDEC2FRONT_Fxns , IVIDANALYTICS_Fxns , IVIDDEC_Fxns , ISPHDEC_Fxns , ISPHENC1_Fxns , IVIDENC_Fxns , IAUDENC1_Fxns , IAUDDEC1_Fxns , IAUDDEC_Fxns , IVIDDEC2BACK_Fxns , IIMGDEC_Fxns , IVIDDEC1_Fxns , IVIDDEC2_Fxns
  • crcFlag : IAUDENC1_Params
  • currentAU : IIMGDEC_OutArgs , IIMGENC1_OutArgs , IIMGENC_OutArgs , IIMGDEC1_OutArgs
  • currentScan : IIMGDEC_OutArgs , IIMGDEC1_OutArgs


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- d -

  • data : IAUDDEC1_Status , IAUDENC1_Status , IIMGENC1_Status , ISPHENC1_Status , IUNIVERSAL_Status , ISPHDEC1_InArgs , IVIDANALYTICS_Status , IVIDDEC1_Status , IIMGDEC1_Status , ISPHDEC1_Status , IVIDDEC2_Status , IVIDENC1_Status , ISPHENC1_InArgs , IVIDTRANSCODE_Status
  • dataEnable : ISPHDEC_Params
  • dataEndianness : IAUDDEC_Params , IAUDDEC1_Params , IAUDENC_Params , IAUDENC1_Params , IIMGDEC_Params , IIMGDEC1_Params , IIMGENC_Params , IIMGENC1_Params , IVIDANALYTICS_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params , IVIDTRANSCODE_Params
  • dataMode : ISPHDEC_Status
  • dataSize : ISPHDEC1_OutArgs
  • dataTransmit : ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_DynamicParams , ISPHENC1_Status
  • date : IVIDANALYTICS_OutArgs , IVIDANALYTICS_DynamicParams , IVIDANALYTICS_InArgs
  • dayOfMonth : XDM_Date
  • dayOfWeek : XDM_Date
  • decodedBufs : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • decodedFrameType : IVIDDEC_OutArgs
  • decodedHeight : IVIDTRANSCODE_OutArgs
  • decodedPictureStructure : IVIDTRANSCODE_OutArgs
  • decodedPictureType : IVIDTRANSCODE_OutArgs
  • decodedWidth : IVIDTRANSCODE_OutArgs
  • decodeHeader : IVIDDEC_DynamicParams , IIMGDEC_DynamicParams , IIMGDEC1_DynamicParams , IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • descs : XDM1_BufDesc
  • desiredChannelMode : IAUDDEC1_InArgs
  • displayBufs : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs , IVIDDEC_OutArgs
  • displayWidth : IVIDDEC1_DynamicParams , IIMGDEC1_DynamicParams , IVIDDEC2_DynamicParams , IVIDDEC_DynamicParams , IIMGDEC_DynamicParams
  • downSampleSbrFlag : IAUDDEC1_DynamicParams
  • dspState : LAD_DspStatus
  • dtmfMode : ISPHENC_DynamicParams , ISPHENC1_DynamicParams , ISPHENC_Status
  • dualMonoMode : IAUDDEC1_OutArgs , IAUDENC1_Params , IAUDENC1_DynamicParams , IAUDDEC1_Status


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- e -

  • enableMaskArray : IVIDANALYTICS_Grid
  • encMode : IAUDENC1_Params , IAUDENC1_Status
  • encodedBuf : IVIDENC1_OutArgs , IVIDTRANSCODE_OutArgs
  • encodedFrameType : IVIDENC_OutArgs , IVIDENC1_OutArgs
  • encodedPictureStructure : IVIDTRANSCODE_OutArgs
  • encodedPictureType : IVIDTRANSCODE_OutArgs
  • encodingPreset : IAUDENC_Params , IVIDENC_Params , IVIDENC1_Params
  • eventId : IVIDANALYTICS_OutArgs
  • extendedError : IVIDANALYTICS_OutArgs , IVIDANALYTICS_Status , IUNIVERSAL_OutArgs , IUNIVERSAL_Status , ISPHENC1_OutArgs , ISPHENC1_Status , ISPHENC_Status , ISPHDEC1_OutArgs , ISPHDEC1_Status , ISPHDEC_Status , IIMGENC1_OutArgs , IIMGENC1_Status , IIMGENC_OutArgs , IIMGENC_Status , IIMGDEC1_OutArgs , IIMGDEC1_Status , IIMGDEC_OutArgs , IIMGDEC_Status , IAUDENC1_OutArgs , IAUDENC1_Status , IAUDENC_OutArgs , IAUDENC_Status , IAUDDEC1_OutArgs , IAUDDEC1_Status , IAUDDEC_OutArgs , IAUDDEC_Status , IVIDENC1_Status , IVIDTRANSCODE_OutArgs , IVIDENC_Status , IVIDTRANSCODE_Status , IVIDEO1_BufDesc , IVIDDEC2FRONT_OutArgs , IVIDENC1_OutArgs , IVIDDEC_OutArgs , IVIDDEC2_Status , IVIDENC_OutArgs , IVIDDEC_Status , IVIDDEC1_Status


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- f -

  • fastFwdLen : IAUDDEC_Status
  • flags : Memory_AllocParams
  • forceChromaFormat : IIMGDEC1_Params , IVIDDEC1_Params , IVIDDEC2_Params , IIMGENC_Params , IIMGDEC_Params , IIMGENC1_Params , IVIDDEC_Params
  • forceFrame : IVIDENC1_DynamicParams , IVIDTRANSCODE_DynamicParams
  • forceIFrame : IVIDENC_DynamicParams
  • formatInput : IVIDTRANSCODE_Params
  • formatOutput : IVIDTRANSCODE_Params
  • frameHeight : IVIDEO1_BufDesc , IVIDEO1_BufDescIn
  • frameLen : IAUDDEC_Status , IAUDENC_Status
  • frameOrder : IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • framePitch : IVIDEO1_BufDescIn , IVIDEO1_BufDesc
  • frameRate : IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status
  • frameSize : ISPHENC_Params , ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_Params , ISPHENC1_DynamicParams , ISPHENC1_Status
  • frameSkipMode : IVIDDEC_DynamicParams , IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • frameSkipTranscodeFlag : IVIDTRANSCODE_DynamicParams
  • frameStatus : IVIDEO1_BufDesc
  • frameType : ISPHENC_OutArgs , ISPHDEC_InArgs , ISPHDEC1_InArgs , ISPHENC1_OutArgs , IVIDEO1_BufDesc
  • frameWidth : IVIDEO1_BufDescIn , IVIDEO1_BufDesc
  • freeBufID : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • fullStatus : IVIDDEC2FRONT_Status
  • fxns : IVIDENC_Obj , ISPHENC_Obj , ISPHENC1_Obj , IALG_Obj , IAUDENC_Obj , IAUDDEC1_Obj , IIMGENC1_Obj , ISPHDEC1_Obj , IIMGENC_Obj , IIMGDEC1_Obj , IVIDENC1_Obj , IIMGDEC_Obj , ISPHDEC_Obj , IAUDDEC_Obj , IVIDDEC_Obj , IVIDDEC2FRONT_Obj , IVIDDEC2BACK_Obj , IVIDTRANSCODE_Obj , IAUDENC1_Obj , IVIDDEC1_Obj , IVIDANALYTICS_Obj , IVIDDEC2_Obj , IUNIVERSAL_Obj


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- g -

  • generateHeader : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • grid : IVIDANALYTICS_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- h -

  • header : VISA_MsgHeader
  • homingMode : ISPHENC_Status , ISPHENC_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- i -

  • ialg : IAUDDEC_Fxns , IAUDDEC1_Fxns , IAUDENC1_Fxns , IIMGENC1_Fxns , IVIDDEC1_Fxns , IVIDDEC2_Fxns , ISPHDEC_Fxns , IVIDENC_Fxns , IVIDENC1_Fxns , IIMGDEC_Fxns , ISPHDEC1_Fxns , IVIDTRANSCODE_Fxns , IVIDDEC2FRONT_Fxns , ISPHENC_Fxns , IVIDDEC2BACK_Fxns , IAUDENC_Fxns , IIMGDEC1_Fxns , ISPHENC1_Fxns , IUNIVERSAL_Fxns , IIMGENC_Fxns , IVIDANALYTICS_Fxns , IVIDDEC_Fxns
  • id : IVIDANALYTICS_Rule
  • imageName : LAD_DspStatus
  • imageWidth : IIMGDEC_Status , IIMGDEC1_Status
  • implementationId : IALG_Fxns
  • inBufferSize : ISPHDEC_InArgs
  • inBufs : XDM_Context
  • inOutBufs : XDM_Context
  • inputBitsPerSample : IAUDENC1_Params , IAUDENC1_DynamicParams , IAUDENC_DynamicParams
  • inputChromaFormat : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDANALYTICS_Params , IVIDENC_Params , IVIDENC1_Params
  • inputContentType : IVIDENC1_Params , IVIDENC_Params
  • inputFormat : IAUDENC_DynamicParams , IAUDENC1_Params
  • inputFrameRate : IVIDTRANSCODE_DynamicParams
  • inputFrameSkip : IVIDENC_OutArgs , IVIDENC1_OutArgs
  • inputFrameSkipTranscodeFlag : IVIDTRANSCODE_OutArgs
  • inputHeight : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • inputID : IVIDDEC2_InArgs , IVIDENC1_InArgs , IVIDTRANSCODE_InArgs , IVIDDEC1_InArgs , IVIDDEC_InArgs
  • inputWidth : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • interFrameInterval : IVIDTRANSCODE_DynamicParams , IVIDENC1_DynamicParams
  • intermediateBufs : XDM_Context
  • intraFrameInterval : IVIDENC1_DynamicParams , IVIDTRANSCODE_DynamicParams , IVIDENC_DynamicParams
  • isLocal : Engine_AlgInfo , Engine_AlgInfo2


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- p -

  • packingType : ISPHDEC_Params , ISPHDEC1_Params , ISPHENC_Params , ISPHENC1_Params , ISPHDEC1_Status , ISPHENC1_Status
  • partialExtendedError : IVIDDEC2FRONT_Status
  • pcmFormat : IAUDDEC1_Params , IAUDDEC1_Status
  • postFilter : ISPHDEC_DynamicParams , ISPHDEC_Status , ISPHDEC1_DynamicParams , ISPHDEC1_Status
  • process : ISPHENC_Fxns , ISPHDEC1_Fxns , ISPHDEC_Fxns , IIMGENC1_Fxns , IVIDANALYTICS_Fxns , IIMGDEC1_Fxns , IIMGDEC_Fxns , IAUDENC1_Fxns , IVIDDEC2_Fxns , IAUDDEC1_Fxns , IVIDDEC_Fxns , IVIDENC_Fxns , IVIDTRANSCODE_Fxns , IVIDDEC1_Fxns , IIMGENC_Fxns , IVIDDEC2FRONT_Fxns , IAUDENC_Fxns , IAUDDEC_Fxns , IUNIVERSAL_Fxns , IVIDDEC2BACK_Fxns , IVIDENC1_Fxns , ISPHENC1_Fxns
  • procId : Engine_Attrs


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- q -

  • QP : IVIDENC1_MbData
  • qValue : IIMGENC1_DynamicParams , IIMGENC_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- r -

  • rate : ISPHENC_OutArgs
  • rateControl : IVIDTRANSCODE_DynamicParams
  • rateControlPreset : IVIDENC1_Params , IVIDENC_Params
  • readHeaderOnlyFlag : IVIDTRANSCODE_DynamicParams
  • reconBufs : IVIDENC_OutArgs , IVIDENC1_OutArgs
  • reconChromaFormat : IVIDENC1_Params
  • refFrameRate : IVIDENC_DynamicParams , IVIDENC1_DynamicParams
  • repeatFirstFieldFlag : IVIDEO1_BufDesc
  • repeatFrame : IVIDEO1_BufDesc
  • reserved : ISPHDEC1_Params , ISPHENC1_DynamicParams , ISPHENC1_Params
  • rule : IVIDANALYTICS_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- s -

  • sampleRate : IAUDDEC_Status , IAUDDEC1_Status , IAUDENC_DynamicParams , IAUDENC1_Params , IAUDDEC1_OutArgs , IAUDENC1_DynamicParams , IAUDENC1_Status
  • seg : Memory_AllocParams
  • size : IVIDTRANSCODE_OutArgs , IVIDTRANSCODE_Status , IVIDTRANSCODE_InArgs , IVIDTRANSCODE_DynamicParams , IVIDTRANSCODE_Params , IVIDENC1_OutArgs , IVIDENC1_Status , IVIDENC1_InArgs , IVIDENC1_DynamicParams , IVIDENC1_Params , IVIDENC_OutArgs , IVIDENC_Status , IVIDENC_InArgs , IVIDENC_DynamicParams , IVIDENC_Params , IVIDDEC2_OutArgs , IVIDDEC2_Status , IVIDDEC2_InArgs , IVIDDEC2_DynamicParams , IVIDDEC2_Params , IVIDDEC1_OutArgs , IVIDDEC1_Status , IVIDDEC1_InArgs , IVIDDEC1_DynamicParams , IVIDDEC1_Params , IVIDDEC_OutArgs , IVIDDEC_Status , IVIDDEC_InArgs , IVIDDEC_DynamicParams , IVIDDEC2FRONT_OutArgs , IVIDANALYTICS_OutArgs , IVIDANALYTICS_Status , IVIDANALYTICS_InArgs , IVIDANALYTICS_DynamicParams , IVIDANALYTICS_Params , IVIDANALYTICS_Rule , IUNIVERSAL_OutArgs , IUNIVERSAL_Status , IUNIVERSAL_InArgs , IUNIVERSAL_DynamicParams , IUNIVERSAL_Params , ISPHENC1_OutArgs , ISPHENC1_Status , ISPHENC1_InArgs , Server_MemStat , IAUDDEC1_InArgs , ISPHENC_OutArgs , ISPHENC_Status , ISPHENC_InArgs , ISPHENC_DynamicParams , ISPHENC_Params , ISPHDEC1_OutArgs , ISPHDEC1_Status , ISPHDEC1_InArgs , ISPHDEC1_DynamicParams , ISPHDEC1_Params , ISPHDEC_OutArgs , ISPHDEC_Status , ISPHDEC_InArgs , ISPHDEC_DynamicParams , ISPHDEC_Params , IIMGENC1_OutArgs , IIMGENC1_Status , IIMGENC1_InArgs , IIMGENC1_DynamicParams , IIMGENC1_Params , IIMGENC_OutArgs , IIMGENC_Status , IIMGENC_InArgs , IVIDDEC_Params , IIMGENC_Params , IIMGDEC1_OutArgs , IIMGDEC1_Status , IIMGDEC1_InArgs , IIMGDEC1_DynamicParams , IIMGDEC1_Params , IIMGDEC_Status , ISPHENC1_Params , IIMGDEC_InArgs , IIMGDEC_DynamicParams , IIMGDEC_Params , IAUDENC1_OutArgs , IAUDENC1_Status , IAUDENC1_InArgs , IAUDENC1_DynamicParams , IAUDENC1_Params , IAUDENC_OutArgs , IAUDENC_Status , IAUDENC_InArgs , IIMGENC_DynamicParams , IAUDENC_Params , IAUDDEC1_OutArgs , ISPHENC1_DynamicParams , IIMGDEC_OutArgs , IAUDDEC1_DynamicParams , IAUDDEC1_Params , IAUDDEC_OutArgs , IAUDDEC_Status , IAUDDEC_InArgs , IAUDENC_DynamicParams , IAUDDEC1_Status , IAUDDEC_Params , IALG_Params , IALG_Status , IAUDDEC_DynamicParams , IALG_MemRec
  • space : IALG_MemRec
  • status : VISA_MsgHeader


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- t -

  • tablesPtr : ISPHDEC1_Params , ISPHENC1_Params
  • targetBitRate : IVIDENC1_DynamicParams , IVIDTRANSCODE_DynamicParams , IVIDENC_DynamicParams
  • targetFrameRate : IVIDENC_DynamicParams , IVIDENC1_DynamicParams
  • targets : IVIDANALYTICS_OutArgs
  • topFieldFirstFlag : IVIDENC1_InArgs , IVIDEO1_BufDesc
  • topLeft : XDM_Rect
  • totalAU : IIMGENC1_Status , IIMGDEC_Status , IIMGDEC1_Status , IIMGENC_Status
  • totalScan : IIMGDEC_Status , IIMGDEC1_Status
  • ttyTddMode : ISPHENC1_DynamicParams , ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_Status
  • type : Memory_AllocParams
  • types : Engine_AlgInfo2
  • typeTab : Server_AlgInfo , Engine_AlgInfo


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- u -

  • used : Server_MemStat


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- v -

  • vadFlag : ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_Status , ISPHENC1_DynamicParams
  • vadSelection : ISPHENC1_Status , ISPHENC_Params , ISPHENC1_Params
  • validFlag : IAUDDEC1_Status , IAUDENC1_Status
  • viewState : IVIDANALYTICS_Status


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- w -

  • width : IVIDEO_BufDesc


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- x -

  • x : XDM_Point


Codec Engine Application Programming Interface (API): Data Fields

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all struct and union fields with links to the structures/unions they belong to:

- y -

  • y : XDM_Point
  • year : XDM_Date


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • accessMask : XDM1_SingleBufDesc
  • actionType : IVIDANALYTICS_Rule
  • algActivate : IALG_Fxns
  • algAlloc : IALG_Fxns
  • algContext : XDM_Context
  • algControl : IALG_Fxns
  • algDeactivate : IALG_Fxns
  • algFree : IALG_Fxns
  • algInfoSize : Engine_AlgInfo , Engine_AlgInfo2 , Server_AlgInfo
  • algInit : IALG_Fxns
  • algMoved : IALG_Fxns
  • algNumAlloc : IALG_Fxns
  • align : Memory_AllocParams
  • alignment : IALG_MemRec
  • ancData : IAUDENC1_InArgs
  • ancFlag : IAUDENC1_Params
  • attrs : IALG_MemRec
  • autoPosition : IAUDDEC_Status


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • keepInputFrameRateFlag : IVIDTRANSCODE_DynamicParams
  • keepInputGOPFlag : IVIDTRANSCODE_DynamicParams
  • keepInputResolutionFlag : IVIDTRANSCODE_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • lfeFlag : IAUDDEC1_InArgs , IAUDDEC1_Status , IAUDENC1_Status , IAUDENC1_DynamicParams , IAUDENC1_Params , IAUDDEC1_OutArgs
  • linkConfigName : LAD_DspStatus


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • manageDisplayBufsCache : IVIDDEC_CodecClassConfig
  • manageInBufsCache : IIMGDEC_CodecClassConfig , IIMGDEC1_CodecClassConfig , IVIDDEC1_CodecClassConfig , IVIDDEC2BACK_CodecClassConfig , IIMGENC1_CodecClassConfig , IVIDDEC2_CodecClassConfig , IIMGENC_CodecClassConfig , IVIDDEC_CodecClassConfig , IVIDENC_CodecClassConfig
  • manageIntermediateBufsCache : IVIDDEC2BACK_CodecClassConfig
  • manageOutBufsCache : IVIDDEC_CodecClassConfig , IVIDENC_CodecClassConfig , IVIDDEC1_CodecClassConfig , IVIDDEC2BACK_CodecClassConfig , IVIDDEC2_CodecClassConfig , IIMGDEC_CodecClassConfig , IIMGENC_CodecClassConfig , IIMGDEC1_CodecClassConfig , IIMGENC1_CodecClassConfig
  • manageReconBufsCache : IVIDENC_CodecClassConfig
  • maxBitrate : IAUDDEC_Params , IAUDENC_Params
  • maxBitRate : IAUDENC1_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params
  • maxBitRateInput : IVIDTRANSCODE_Params
  • maxBitRateOutput : IVIDTRANSCODE_Params
  • maxBlockLen : Server_MemStat
  • maxFrameRate : IVIDANALYTICS_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params
  • maxFrameRateInput : IVIDTRANSCODE_Params
  • maxFrameRateOutput : IVIDTRANSCODE_Params
  • maxHeight : IIMGDEC_Params , IIMGDEC1_Params , IIMGENC_Params , IIMGENC1_Params , IVIDANALYTICS_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params
  • maxHeightInput : IVIDTRANSCODE_Params
  • maxHeightOutput : IVIDTRANSCODE_Params
  • maxInterFrameInterval : IVIDENC_Params , IVIDENC1_Params
  • maxNoOfCh : IAUDDEC_Params , IAUDENC_Params
  • maxNumDisplayBufs : IVIDDEC2_Status
  • maxRules : IVIDANALYTICS_Params
  • maxSampleRate : IAUDDEC_Params , IAUDENC_Params
  • maxScans : IIMGENC1_Params , IIMGENC_Params , IIMGDEC_Params , IIMGDEC1_Params
  • maxWidth : IIMGDEC_Params , IIMGDEC1_Params , IIMGENC_Params , IIMGENC1_Params , IVIDDEC2_Params , IVIDENC1_Params , IVIDDEC1_Params , IVIDDEC_Params , IVIDENC_Params , IVIDANALYTICS_Params
  • maxWidthInput : IVIDTRANSCODE_Params
  • maxWidthOutput : IVIDTRANSCODE_Params
  • mbDataBuf : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • mbDataFlag : IVIDDEC2_DynamicParams , IVIDENC1_DynamicParams , IVIDDEC1_DynamicParams
  • mbMode : IVIDENC1_MbData
  • minContextSize : XDM_ContextInfo
  • minInBufSize : XDM_AlgBufInfo
  • minIntermediateBufSizes : XDM_ContextInfo
  • minNumInBufs : XDM_AlgBufInfo
  • minNumOutBufs : XDM_AlgBufInfo
  • minOutBufSize : XDM_AlgBufInfo
  • mode : ISPHENC1_Status , ISPHENC1_DynamicParams , ISPHENC_DynamicParams , ISPHENC_Status , ISPHDEC_OutArgs
  • month : XDM_Date
  • msecsOfDay : XDM_Date
  • mvBwdXY : IVIDENC1_MbData
  • mvFwdXY : IVIDENC1_MbData


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • name : Engine_AlgInfo , Engine_AlgInfo2 , Server_MemStat , Server_AlgInfo
  • newFrameFlag : IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • nextPartRequiredFlag : IVIDDEC2FRONT_Status
  • noiseSuppressionMode : ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_DynamicParams , ISPHENC1_Status
  • nullTrafficChannel : ISPHENC_InArgs , ISPHENC1_InArgs
  • numAU : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IIMGDEC_DynamicParams , IIMGDEC1_DynamicParams
  • numBlockHorizontal : IVIDANALYTICS_Grid
  • numBlockVertical : IVIDANALYTICS_Grid
  • numBufs : IVIDEO_BufDesc , IVIDEO1_BufDescIn , IVIDEO1_BufDesc , XDM_BufDesc , XDM1_BufDesc
  • numBytes : IIMGDEC_InArgs , IVIDTRANSCODE_InArgs , IVIDDEC2_InArgs , IAUDDEC_InArgs , IAUDDEC1_InArgs , IIMGDEC1_InArgs , IVIDDEC_InArgs , IVIDDEC1_InArgs
  • numChannels : IAUDDEC_Status , IAUDENC_DynamicParams
  • numClientsStarted : LAD_DspStatus
  • numEvents : IVIDANALYTICS_OutArgs
  • numInBufs : XDM_Context
  • numInOutBufs : XDM_Context
  • numInSamples : IAUDENC1_InArgs , IAUDENC1_OutArgs
  • numLFEChannels : IAUDENC_DynamicParams , IAUDDEC_Status
  • numOutBufs : XDM_Context
  • numOutputStreams : IVIDTRANSCODE_Params
  • numSamples : IAUDDEC1_Status , IAUDDEC1_OutArgs
  • numTargets : IVIDANALYTICS_OutArgs
  • numZeroesPadded : IAUDENC1_OutArgs


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • objectType : IVIDANALYTICS_Rule
  • outbufferSize : ISPHENC_OutArgs
  • outBufs : XDM_Context
  • outBufsInUseFlag : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs , IVIDTRANSCODE_OutArgs
  • outChromaformat : IIMGDEC_Status
  • outputBitsPerSample : IAUDDEC_Status , IAUDDEC1_Status
  • outputChromaFormat : IIMGDEC1_Status , IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status
  • outputFormat : IAUDDEC_DynamicParams , IAUDDEC_Status
  • outputFrameRate : IVIDTRANSCODE_DynamicParams
  • outputHeight : IIMGDEC_Status , IIMGDEC1_Status , IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status , IVIDTRANSCODE_DynamicParams
  • outputID : IVIDTRANSCODE_OutArgs , IVIDDEC_OutArgs , IVIDENC1_OutArgs , IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • outputMbDataID : IVIDDEC2_OutArgs , IVIDDEC1_OutArgs
  • outputPCMWidth : IAUDDEC1_Params
  • outputWidth : IVIDDEC_Status , IVIDDEC2_Status , IVIDDEC1_Status , IIMGDEC1_Status , IVIDTRANSCODE_DynamicParams , IIMGDEC_Status


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • base : IALG_MemRec , Server_MemStat
  • bfiFlag : ISPHDEC_InArgs
  • bitRate : IAUDDEC_Status , IAUDENC1_DynamicParams , ISPHENC1_Status , IVIDDEC_Status , IAUDENC1_Status , IVIDDEC1_Status , IVIDDEC2_Status , IAUDDEC1_Status , ISPHDEC1_Params , ISPHDEC1_Status , IAUDENC_DynamicParams , ISPHENC_DynamicParams , ISPHENC_Status , IAUDENC1_Params , ISPHENC1_Params , ISPHENC1_DynamicParams
  • bitsConsumed : IVIDTRANSCODE_OutArgs
  • bitsGenerated : IVIDTRANSCODE_OutArgs
  • blockHeight : IVIDANALYTICS_Grid
  • blockWidth : IVIDANALYTICS_Grid
  • bottomRight : XDM_Rect
  • buf : XDM_SingleBufDesc , XDM1_SingleBufDesc
  • bufDesc : IVIDEO1_BufDescIn , IVIDEO1_BufDesc
  • bufInfo : IAUDENC1_Status , ISPHENC_Status , IIMGDEC_Status , IIMGDEC1_Status , IIMGENC_Status , IIMGENC1_Status , ISPHDEC_Status , ISPHDEC1_Status , IVIDTRANSCODE_Status , IAUDENC_Status , ISPHENC1_Status , IVIDANALYTICS_Status , IVIDDEC_Status , IVIDDEC2_Status , IVIDENC_Status , IVIDENC1_Status , IVIDDEC1_Status , IAUDDEC_Status , IAUDDEC1_Status
  • bufs : IVIDEO_BufDesc , XDM_BufDesc
  • bufSize : XDM_SingleBufDesc , XDM1_SingleBufDesc
  • bufSizes : XDM_BufDesc , IVIDEO_BufDesc
  • bytesConsumed : IVIDDEC2FRONT_OutArgs , IVIDDEC2_OutArgs , IAUDDEC_OutArgs , IAUDDEC1_OutArgs , IVIDDEC1_OutArgs
  • bytesconsumed : IIMGDEC_OutArgs
  • bytesConsumed : IVIDDEC_OutArgs , IIMGDEC1_OutArgs
  • bytesGenerated : IIMGENC_OutArgs , IAUDENC1_OutArgs , IAUDENC_OutArgs , IVIDENC_OutArgs , IIMGENC1_OutArgs , IVIDENC1_OutArgs


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • captureWidth : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • channelMode : IAUDENC1_DynamicParams , IAUDENC1_Status , IAUDDEC1_Status , IAUDDEC1_OutArgs , IAUDENC1_Params
  • chromaFormat : IVIDEO1_BufDesc
  • cmd : VISA_MsgHeader
  • codecSelection : ISPHDEC1_Params , ISPHDEC1_Status , ISPHENC1_Params , ISPHENC1_Status
  • compandingLaw : ISPHDEC_Params , ISPHDEC1_Params , ISPHDEC1_Status , ISPHENC_Params , ISPHENC1_Params , ISPHENC1_Status
  • contentType : IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status , IVIDEO1_BufDesc
  • contextInfo : IVIDDEC2FRONT_Status
  • control : IUNIVERSAL_Fxns , IAUDENC_Fxns , IVIDTRANSCODE_Fxns , IIMGDEC1_Fxns , IIMGENC_Fxns , IVIDENC1_Fxns , IIMGENC1_Fxns , ISPHDEC1_Fxns , ISPHENC_Fxns , IVIDDEC2FRONT_Fxns , IVIDANALYTICS_Fxns , IVIDDEC_Fxns , ISPHDEC_Fxns , ISPHENC1_Fxns , IVIDENC_Fxns , IAUDENC1_Fxns , IAUDDEC1_Fxns , IAUDDEC_Fxns , IVIDDEC2BACK_Fxns , IIMGDEC_Fxns , IVIDDEC1_Fxns , IVIDDEC2_Fxns
  • crcFlag : IAUDENC1_Params
  • currentAU : IIMGDEC_OutArgs , IIMGENC1_OutArgs , IIMGENC_OutArgs , IIMGDEC1_OutArgs
  • currentScan : IIMGDEC_OutArgs , IIMGDEC1_OutArgs


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • data : IAUDDEC1_Status , IAUDENC1_Status , IIMGENC1_Status , ISPHENC1_Status , IUNIVERSAL_Status , ISPHDEC1_InArgs , IVIDANALYTICS_Status , IVIDDEC1_Status , IIMGDEC1_Status , ISPHDEC1_Status , IVIDDEC2_Status , IVIDENC1_Status , ISPHENC1_InArgs , IVIDTRANSCODE_Status
  • dataEnable : ISPHDEC_Params
  • dataEndianness : IAUDDEC_Params , IAUDDEC1_Params , IAUDENC_Params , IAUDENC1_Params , IIMGDEC_Params , IIMGDEC1_Params , IIMGENC_Params , IIMGENC1_Params , IVIDANALYTICS_Params , IVIDDEC_Params , IVIDDEC1_Params , IVIDDEC2_Params , IVIDENC_Params , IVIDENC1_Params , IVIDTRANSCODE_Params
  • dataMode : ISPHDEC_Status
  • dataSize : ISPHDEC1_OutArgs
  • dataTransmit : ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_DynamicParams , ISPHENC1_Status
  • date : IVIDANALYTICS_OutArgs , IVIDANALYTICS_DynamicParams , IVIDANALYTICS_InArgs
  • dayOfMonth : XDM_Date
  • dayOfWeek : XDM_Date
  • decodedBufs : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • decodedFrameType : IVIDDEC_OutArgs
  • decodedHeight : IVIDTRANSCODE_OutArgs
  • decodedPictureStructure : IVIDTRANSCODE_OutArgs
  • decodedPictureType : IVIDTRANSCODE_OutArgs
  • decodedWidth : IVIDTRANSCODE_OutArgs
  • decodeHeader : IVIDDEC_DynamicParams , IIMGDEC_DynamicParams , IIMGDEC1_DynamicParams , IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • descs : XDM1_BufDesc
  • desiredChannelMode : IAUDDEC1_InArgs
  • displayBufs : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs , IVIDDEC_OutArgs
  • displayWidth : IVIDDEC1_DynamicParams , IIMGDEC1_DynamicParams , IVIDDEC2_DynamicParams , IVIDDEC_DynamicParams , IIMGDEC_DynamicParams
  • downSampleSbrFlag : IAUDDEC1_DynamicParams
  • dspState : LAD_DspStatus
  • dtmfMode : ISPHENC_DynamicParams , ISPHENC1_DynamicParams , ISPHENC_Status
  • dualMonoMode : IAUDDEC1_OutArgs , IAUDENC1_Params , IAUDENC1_DynamicParams , IAUDDEC1_Status


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • enableMaskArray : IVIDANALYTICS_Grid
  • encMode : IAUDENC1_Params , IAUDENC1_Status
  • encodedBuf : IVIDENC1_OutArgs , IVIDTRANSCODE_OutArgs
  • encodedFrameType : IVIDENC_OutArgs , IVIDENC1_OutArgs
  • encodedPictureStructure : IVIDTRANSCODE_OutArgs
  • encodedPictureType : IVIDTRANSCODE_OutArgs
  • encodingPreset : IAUDENC_Params , IVIDENC_Params , IVIDENC1_Params
  • eventId : IVIDANALYTICS_OutArgs
  • extendedError : IVIDANALYTICS_OutArgs , IVIDANALYTICS_Status , IUNIVERSAL_OutArgs , IUNIVERSAL_Status , ISPHENC1_OutArgs , ISPHENC1_Status , ISPHENC_Status , ISPHDEC1_OutArgs , ISPHDEC1_Status , ISPHDEC_Status , IIMGENC1_OutArgs , IIMGENC1_Status , IIMGENC_OutArgs , IIMGENC_Status , IIMGDEC1_OutArgs , IIMGDEC1_Status , IIMGDEC_OutArgs , IIMGDEC_Status , IAUDENC1_OutArgs , IAUDENC1_Status , IAUDENC_OutArgs , IAUDENC_Status , IAUDDEC1_OutArgs , IAUDDEC1_Status , IAUDDEC_OutArgs , IAUDDEC_Status , IVIDENC1_Status , IVIDTRANSCODE_OutArgs , IVIDENC_Status , IVIDTRANSCODE_Status , IVIDEO1_BufDesc , IVIDDEC2FRONT_OutArgs , IVIDENC1_OutArgs , IVIDDEC_OutArgs , IVIDDEC2_Status , IVIDENC_OutArgs , IVIDDEC_Status , IVIDDEC1_Status


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • fastFwdLen : IAUDDEC_Status
  • flags : Memory_AllocParams
  • forceChromaFormat : IIMGDEC1_Params , IVIDDEC1_Params , IVIDDEC2_Params , IIMGENC_Params , IIMGDEC_Params , IIMGENC1_Params , IVIDDEC_Params
  • forceFrame : IVIDENC1_DynamicParams , IVIDTRANSCODE_DynamicParams
  • forceIFrame : IVIDENC_DynamicParams
  • formatInput : IVIDTRANSCODE_Params
  • formatOutput : IVIDTRANSCODE_Params
  • frameHeight : IVIDEO1_BufDesc , IVIDEO1_BufDescIn
  • frameLen : IAUDDEC_Status , IAUDENC_Status
  • frameOrder : IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • framePitch : IVIDEO1_BufDescIn , IVIDEO1_BufDesc
  • frameRate : IVIDDEC_Status , IVIDDEC1_Status , IVIDDEC2_Status
  • frameSize : ISPHENC_Params , ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_Params , ISPHENC1_DynamicParams , ISPHENC1_Status
  • frameSkipMode : IVIDDEC_DynamicParams , IVIDDEC1_DynamicParams , IVIDDEC2_DynamicParams
  • frameSkipTranscodeFlag : IVIDTRANSCODE_DynamicParams
  • frameStatus : IVIDEO1_BufDesc
  • frameType : ISPHENC_OutArgs , ISPHDEC_InArgs , ISPHDEC1_InArgs , ISPHENC1_OutArgs , IVIDEO1_BufDesc
  • frameWidth : IVIDEO1_BufDescIn , IVIDEO1_BufDesc
  • freeBufID : IVIDDEC1_OutArgs , IVIDDEC2_OutArgs
  • fullStatus : IVIDDEC2FRONT_Status
  • fxns : IVIDENC_Obj , ISPHENC_Obj , ISPHENC1_Obj , IALG_Obj , IAUDENC_Obj , IAUDDEC1_Obj , IIMGENC1_Obj , ISPHDEC1_Obj , IIMGENC_Obj , IIMGDEC1_Obj , IVIDENC1_Obj , IIMGDEC_Obj , ISPHDEC_Obj , IAUDDEC_Obj , IVIDDEC_Obj , IVIDDEC2FRONT_Obj , IVIDDEC2BACK_Obj , IVIDTRANSCODE_Obj , IAUDENC1_Obj , IVIDDEC1_Obj , IVIDANALYTICS_Obj , IVIDDEC2_Obj , IUNIVERSAL_Obj


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • generateHeader : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • grid : IVIDANALYTICS_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • header : VISA_MsgHeader
  • homingMode : ISPHENC_Status , ISPHENC_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • ialg : IAUDDEC_Fxns , IAUDDEC1_Fxns , IAUDENC1_Fxns , IIMGENC1_Fxns , IVIDDEC1_Fxns , IVIDDEC2_Fxns , ISPHDEC_Fxns , IVIDENC_Fxns , IVIDENC1_Fxns , IIMGDEC_Fxns , ISPHDEC1_Fxns , IVIDTRANSCODE_Fxns , IVIDDEC2FRONT_Fxns , ISPHENC_Fxns , IVIDDEC2BACK_Fxns , IAUDENC_Fxns , IIMGDEC1_Fxns , ISPHENC1_Fxns , IUNIVERSAL_Fxns , IIMGENC_Fxns , IVIDANALYTICS_Fxns , IVIDDEC_Fxns
  • id : IVIDANALYTICS_Rule
  • imageName : LAD_DspStatus
  • imageWidth : IIMGDEC_Status , IIMGDEC1_Status
  • implementationId : IALG_Fxns
  • inBufferSize : ISPHDEC_InArgs
  • inBufs : XDM_Context
  • inOutBufs : XDM_Context
  • inputBitsPerSample : IAUDENC1_Params , IAUDENC1_DynamicParams , IAUDENC_DynamicParams
  • inputChromaFormat : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDANALYTICS_Params , IVIDENC_Params , IVIDENC1_Params
  • inputContentType : IVIDENC1_Params , IVIDENC_Params
  • inputFormat : IAUDENC_DynamicParams , IAUDENC1_Params
  • inputFrameRate : IVIDTRANSCODE_DynamicParams
  • inputFrameSkip : IVIDENC_OutArgs , IVIDENC1_OutArgs
  • inputFrameSkipTranscodeFlag : IVIDTRANSCODE_OutArgs
  • inputHeight : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • inputID : IVIDDEC2_InArgs , IVIDENC1_InArgs , IVIDTRANSCODE_InArgs , IVIDDEC1_InArgs , IVIDDEC_InArgs
  • inputWidth : IIMGENC_DynamicParams , IIMGENC1_DynamicParams , IVIDENC1_DynamicParams , IVIDENC_DynamicParams
  • interFrameInterval : IVIDTRANSCODE_DynamicParams , IVIDENC1_DynamicParams
  • intermediateBufs : XDM_Context
  • intraFrameInterval : IVIDENC1_DynamicParams , IVIDTRANSCODE_DynamicParams , IVIDENC_DynamicParams
  • isLocal : Engine_AlgInfo , Engine_AlgInfo2


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • packingType : ISPHDEC_Params , ISPHDEC1_Params , ISPHENC_Params , ISPHENC1_Params , ISPHDEC1_Status , ISPHENC1_Status
  • partialExtendedError : IVIDDEC2FRONT_Status
  • pcmFormat : IAUDDEC1_Params , IAUDDEC1_Status
  • postFilter : ISPHDEC_DynamicParams , ISPHDEC_Status , ISPHDEC1_DynamicParams , ISPHDEC1_Status
  • process : ISPHENC_Fxns , ISPHDEC1_Fxns , ISPHDEC_Fxns , IIMGENC1_Fxns , IVIDANALYTICS_Fxns , IIMGDEC1_Fxns , IIMGDEC_Fxns , IAUDENC1_Fxns , IVIDDEC2_Fxns , IAUDDEC1_Fxns , IVIDDEC_Fxns , IVIDENC_Fxns , IVIDTRANSCODE_Fxns , IVIDDEC1_Fxns , IIMGENC_Fxns , IVIDDEC2FRONT_Fxns , IAUDENC_Fxns , IAUDDEC_Fxns , IUNIVERSAL_Fxns , IVIDDEC2BACK_Fxns , IVIDENC1_Fxns , ISPHENC1_Fxns
  • procId : Engine_Attrs


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- q -

  • QP : IVIDENC1_MbData
  • qValue : IIMGENC1_DynamicParams , IIMGENC_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • rate : ISPHENC_OutArgs
  • rateControl : IVIDTRANSCODE_DynamicParams
  • rateControlPreset : IVIDENC1_Params , IVIDENC_Params
  • readHeaderOnlyFlag : IVIDTRANSCODE_DynamicParams
  • reconBufs : IVIDENC_OutArgs , IVIDENC1_OutArgs
  • reconChromaFormat : IVIDENC1_Params
  • refFrameRate : IVIDENC_DynamicParams , IVIDENC1_DynamicParams
  • repeatFirstFieldFlag : IVIDEO1_BufDesc
  • repeatFrame : IVIDEO1_BufDesc
  • reserved : ISPHDEC1_Params , ISPHENC1_DynamicParams , ISPHENC1_Params
  • rule : IVIDANALYTICS_DynamicParams


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • sampleRate : IAUDDEC_Status , IAUDDEC1_Status , IAUDENC_DynamicParams , IAUDENC1_Params , IAUDDEC1_OutArgs , IAUDENC1_DynamicParams , IAUDENC1_Status
  • seg : Memory_AllocParams
  • size : IVIDTRANSCODE_OutArgs , IVIDTRANSCODE_Status , IVIDTRANSCODE_InArgs , IVIDTRANSCODE_DynamicParams , IVIDTRANSCODE_Params , IVIDENC1_OutArgs , IVIDENC1_Status , IVIDENC1_InArgs , IVIDENC1_DynamicParams , IVIDENC1_Params , IVIDENC_OutArgs , IVIDENC_Status , IVIDENC_InArgs , IVIDENC_DynamicParams , IVIDENC_Params , IVIDDEC2_OutArgs , IVIDDEC2_Status , IVIDDEC2_InArgs , IVIDDEC2_DynamicParams , IVIDDEC2_Params , IVIDDEC1_OutArgs , IVIDDEC1_Status , IVIDDEC1_InArgs , IVIDDEC1_DynamicParams , IVIDDEC1_Params , IVIDDEC_OutArgs , IVIDDEC_Status , IVIDDEC_InArgs , IVIDDEC_DynamicParams , IVIDDEC2FRONT_OutArgs , IVIDANALYTICS_OutArgs , IVIDANALYTICS_Status , IVIDANALYTICS_InArgs , IVIDANALYTICS_DynamicParams , IVIDANALYTICS_Params , IVIDANALYTICS_Rule , IUNIVERSAL_OutArgs , IUNIVERSAL_Status , IUNIVERSAL_InArgs , IUNIVERSAL_DynamicParams , IUNIVERSAL_Params , ISPHENC1_OutArgs , ISPHENC1_Status , ISPHENC1_InArgs , Server_MemStat , IAUDDEC1_InArgs , ISPHENC_OutArgs , ISPHENC_Status , ISPHENC_InArgs , ISPHENC_DynamicParams , ISPHENC_Params , ISPHDEC1_OutArgs , ISPHDEC1_Status , ISPHDEC1_InArgs , ISPHDEC1_DynamicParams , ISPHDEC1_Params , ISPHDEC_OutArgs , ISPHDEC_Status , ISPHDEC_InArgs , ISPHDEC_DynamicParams , ISPHDEC_Params , IIMGENC1_OutArgs , IIMGENC1_Status , IIMGENC1_InArgs , IIMGENC1_DynamicParams , IIMGENC1_Params , IIMGENC_OutArgs , IIMGENC_Status , IIMGENC_InArgs , IVIDDEC_Params , IIMGENC_Params , IIMGDEC1_OutArgs , IIMGDEC1_Status , IIMGDEC1_InArgs , IIMGDEC1_DynamicParams , IIMGDEC1_Params , IIMGDEC_Status , ISPHENC1_Params , IIMGDEC_InArgs , IIMGDEC_DynamicParams , IIMGDEC_Params , IAUDENC1_OutArgs , IAUDENC1_Status , IAUDENC1_InArgs , IAUDENC1_DynamicParams , IAUDENC1_Params , IAUDENC_OutArgs , IAUDENC_Status , IAUDENC_InArgs , IIMGENC_DynamicParams , IAUDENC_Params , IAUDDEC1_OutArgs , ISPHENC1_DynamicParams , IIMGDEC_OutArgs , IAUDDEC1_DynamicParams , IAUDDEC1_Params , IAUDDEC_OutArgs , IAUDDEC_Status , IAUDDEC_InArgs , IAUDENC_DynamicParams , IAUDDEC1_Status , IAUDDEC_Params , IALG_Params , IALG_Status , IAUDDEC_DynamicParams , IALG_MemRec
  • space : IALG_MemRec
  • status : VISA_MsgHeader


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • tablesPtr : ISPHDEC1_Params , ISPHENC1_Params
  • targetBitRate : IVIDENC1_DynamicParams , IVIDTRANSCODE_DynamicParams , IVIDENC_DynamicParams
  • targetFrameRate : IVIDENC_DynamicParams , IVIDENC1_DynamicParams
  • targets : IVIDANALYTICS_OutArgs
  • topFieldFirstFlag : IVIDENC1_InArgs , IVIDEO1_BufDesc
  • topLeft : XDM_Rect
  • totalAU : IIMGENC1_Status , IIMGDEC_Status , IIMGDEC1_Status , IIMGENC_Status
  • totalScan : IIMGDEC_Status , IIMGDEC1_Status
  • ttyTddMode : ISPHENC1_DynamicParams , ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_Status
  • type : Memory_AllocParams
  • types : Engine_AlgInfo2
  • typeTab : Server_AlgInfo , Engine_AlgInfo


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • used : Server_MemStat


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • vadFlag : ISPHENC_DynamicParams , ISPHENC_Status , ISPHENC1_Status , ISPHENC1_DynamicParams
  • vadSelection : ISPHENC1_Status , ISPHENC_Params , ISPHENC1_Params
  • validFlag : IAUDDEC1_Status , IAUDENC1_Status
  • viewState : IVIDANALYTICS_Status


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • width : IVIDEO_BufDesc


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x : XDM_Point


Codec Engine Application Programming Interface (API): Data Fields - Variables

  • Data Structures
  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y : XDM_Point
  • year : XDM_Date


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- l -

  • LAD_ACCESSDENIED : ladclient.h
  • LAD_ALREADYRUNNING : ladclient.h
  • LAD_ClientHandle : ladclient.h
  • LAD_connect() : ladclient.h
  • LAD_disconnect() : ladclient.h
  • LAD_DspState : ladclient.h
  • LAD_FAILURE : ladclient.h
  • LAD_getDspStatus() : ladclient.h
  • LAD_IDLE : ladclient.h
  • LAD_INVALIDARG : ladclient.h
  • LAD_INVALIDVERSION : ladclient.h
  • LAD_IOFAILURE : ladclient.h
  • LAD_LOADED : ladclient.h
  • LAD_MAXLENGTHCONFIGNAME : ladclient.h
  • LAD_MAXLENGTHIMAGENAME : ladclient.h
  • LAD_NOTCONNECTED : ladclient.h
  • LAD_releaseDsp() : ladclient.h
  • LAD_RESET : ladclient.h
  • LAD_SETUP : ladclient.h
  • LAD_STARTED : ladclient.h
  • LAD_startupDsp() : ladclient.h
  • LAD_Status : ladclient.h
  • LAD_STILLRUNNING : ladclient.h
  • LAD_STOPPED : ladclient.h
  • LAD_SUCCESS : ladclient.h
  • LAD_UNAVAILABLE : ladclient.h
  • LAD_UNKNOWN : ladclient.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- m -

  • Memory_alloc() : Memory.h
  • Memory_CACHED : Memory.h
  • Memory_CACHEDMASK : Memory.h
  • Memory_cacheInv() : Memory.h
  • Memory_cacheWb() : Memory.h
  • Memory_cacheWbInv() : Memory.h
  • Memory_contigAlloc() : Memory.h
  • Memory_contigFree() : Memory.h
  • Memory_CONTIGHEAP : Memory.h
  • Memory_CONTIGPOOL : Memory.h
  • Memory_DEFAULTALIGNMENT : Memory.h
  • Memory_DEFAULTPARAMS : Memory.h
  • Memory_dumpKnownContigBufsList() : Memory.h
  • Memory_free() : Memory.h
  • Memory_getBufferPhysicalAddress() : Memory.h
  • Memory_getBufferVirtualAddress() : Memory.h
  • Memory_getHeapId() : Memory.h
  • Memory_getNumHeaps() : Memory.h
  • Memory_GTNAME : Memory.h
  • Memory_MALLOC : Memory.h
  • Memory_NONCACHED : Memory.h
  • Memory_registerContigBuf() : Memory.h
  • Memory_SEG : Memory.h
  • Memory_type : Memory.h
  • Memory_unregisterContigBuf() : Memory.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- c -

  • CE_BEGIN_ALG_TABLE : CERuntime.h
  • CE_BEGIN_ENGINE_TABLE : CERuntime.h
  • CE_DECLARE_TYPE : CERuntime.h
  • CE_END_ALG_TABLE : CERuntime.h
  • CE_END_ENGINE_TABLE : CERuntime.h
  • CE_ENGINE : CERuntime.h
  • CE_LOCAL_ALG : CERuntime.h
  • CE_NULL_algs : CERuntime.h
  • CERuntime_exit() : CERuntime.h
  • CERuntime_init() : CERuntime.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- e -

  • Engine_ATTRS : Engine.h
  • Engine_close() : Engine.h
  • Engine_EBADSERVER : Engine.h
  • Engine_ECODECCREATE : Engine.h
  • Engine_ECODECSTART : Engine.h
  • Engine_ECOMALLOC : Engine.h
  • Engine_EDSPLOAD : Engine.h
  • Engine_EEXIST : Engine.h
  • Engine_EINUSE : Engine.h
  • Engine_EINVAL : Engine.h
  • Engine_ENOCOMM : Engine.h
  • Engine_ENOMEM : Engine.h
  • Engine_ENOSERVER : Engine.h
  • Engine_ENOTAVAIL : Engine.h
  • Engine_ENOTFOUND : Engine.h
  • Engine_EOK : Engine.h
  • Engine_Error : Engine.h
  • Engine_ERUNTIME : Engine.h
  • Engine_ETIMEOUT : Engine.h
  • Engine_EWRONGSTATE : Engine.h
  • Engine_fwriteTrace() : Engine.h
  • Engine_getAlgInfo() : Engine.h
  • Engine_getAlgInfo2() : Engine.h
  • Engine_getCpuLoad() : Engine.h
  • Engine_getLastError() : Engine.h
  • Engine_getName() : Engine.h
  • Engine_getNumAlgs() : Engine.h
  • Engine_getNumAlgs2() : Engine.h
  • Engine_getServer() : Engine.h
  • Engine_getUsedMem() : Engine.h
  • Engine_GTNAME : Engine.h
  • Engine_Handle : Engine.h
  • Engine_open() : Engine.h
  • Engine_setTrace() : Engine.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- i -

  • IALG_Cmd : ialg.h
  • IALG_CUSTOMFAILBASE : ialg.h
  • IALG_CUSTOMFAILEND : ialg.h
  • IALG_DARAM0 : ialg.h
  • IALG_DARAM1 : ialg.h
  • IALG_DARAM2 : ialg.h
  • IALG_DEFMEMRECS : ialg.h
  • IALG_EFAIL : ialg.h
  • IALG_EOK : ialg.h
  • IALG_EPROG : ialg.h
  • IALG_ESDATA : ialg.h
  • IALG_EXTERNAL : ialg.h
  • IALG_Handle : ialg.h
  • IALG_IPROG : ialg.h
  • IALG_isOffChip : ialg.h
  • IALG_isProg : ialg.h
  • IALG_MemAttrs : ialg.h
  • IALG_MemSpace : ialg.h
  • IALG_MPROG : ialg.h
  • IALG_MXTRN : ialg.h
  • IALG_OBJMEMREC : ialg.h
  • IALG_PERSIST : ialg.h
  • IALG_SARAM : ialg.h
  • IALG_SARAM0 : ialg.h
  • IALG_SARAM1 : ialg.h
  • IALG_SARAM2 : ialg.h
  • IALG_SCRATCH : ialg.h
  • IALG_SYSCMD : ialg.h
  • IALG_WRITEONCE : ialg.h
  • IAUDDEC1_Cmd : iauddec1.h
  • IAUDDEC1_EFAIL : iauddec1.h
  • IAUDDEC1_EOK : iauddec1.h
  • IAUDDEC1_EUNSUPPORTED : iauddec1.h
  • IAUDDEC1_Handle : iauddec1.h
  • IAUDDEC_CID : iauddec.h
  • IAUDDEC_Cmd : iauddec.h
  • IAUDDEC_EFAIL : iauddec.h
  • IAUDDEC_EOK : iauddec.h
  • IAUDDEC_ERUNTIME : iauddec.h
  • IAUDDEC_Handle : iauddec.h
  • IAUDENC1_Cmd : iaudenc1.h
  • IAUDENC1_EFAIL : iaudenc1.h
  • IAUDENC1_EOK : iaudenc1.h
  • IAUDENC1_EUNSUPPORTED : iaudenc1.h
  • IAUDENC1_Handle : iaudenc1.h
  • IAUDENC_CID : iaudenc.h
  • IAUDENC_Cmd : iaudenc.h
  • IAUDENC_EFAIL : iaudenc.h
  • IAUDENC_EOK : iaudenc.h
  • IAUDENC_ERUNTIME : iaudenc.h
  • IAUDENC_Handle : iaudenc.h
  • IAUDIO_11_0 : iaudio.h
  • IAUDIO_1_0 : iaudio.h
  • IAUDIO_2_0 : iaudio.h
  • IAUDIO_2_1 : iaudio.h
  • IAUDIO_2_2 : iaudio.h
  • IAUDIO_2_3 : iaudio.h
  • IAUDIO_3_0 : iaudio.h
  • IAUDIO_3_1 : iaudio.h
  • IAUDIO_3_2 : iaudio.h
  • IAUDIO_3_3 : iaudio.h
  • IAUDIO_3_4 : iaudio.h
  • IAUDIO_BLOCK : iaudio.h
  • IAUDIO_CBR : iaudio.h
  • IAUDIO_ChannelId : iaudio.h
  • IAUDIO_ChannelMode : iaudio.h
  • IAUDIO_DUALMONO_LEFT : iaudio.h
  • IAUDIO_DUALMONO_LR : iaudio.h
  • IAUDIO_DUALMONO_LR_MIX : iaudio.h
  • IAUDIO_DUALMONO_RIGHT : iaudio.h
  • IAUDIO_DualMonoMode : iaudio.h
  • IAUDIO_EncMode : iaudio.h
  • IAUDIO_FIVE_ONE : iaudio.h
  • IAUDIO_FIVE_ZERO : iaudio.h
  • IAUDIO_INTERLEAVED : iaudio.h
  • IAUDIO_MONO : iaudio.h
  • IAUDIO_PcmFormat : iaudio.h
  • IAUDIO_SEVEN_ONE : iaudio.h
  • IAUDIO_STEREO : iaudio.h
  • IAUDIO_THREE_ZERO : iaudio.h
  • IAUDIO_VBR : iaudio.h
  • IIMGDEC1_Cmd : iimgdec1.h
  • IIMGDEC1_EFAIL : iimgdec1.h
  • IIMGDEC1_EOK : iimgdec1.h
  • IIMGDEC1_EUNSUPPORTED : iimgdec1.h
  • IIMGDEC1_Handle : iimgdec1.h
  • IIMGDEC_CID : iimgdec.h
  • IIMGDEC_Cmd : iimgdec.h
  • IIMGDEC_EFAIL : iimgdec.h
  • IIMGDEC_EOK : iimgdec.h
  • IIMGDEC_ERUNTIME : iimgdec.h
  • IIMGDEC_Handle : iimgdec.h
  • IIMGENC1_Cmd : iimgenc1.h
  • IIMGENC1_EFAIL : iimgenc1.h
  • IIMGENC1_EOK : iimgenc1.h
  • IIMGENC1_EUNSUPPORTED : iimgenc1.h
  • IIMGENC1_Handle : iimgenc1.h
  • IIMGENC_CID : iimgenc.h
  • IIMGENC_Cmd : iimgenc.h
  • IIMGENC_EFAIL : iimgenc.h
  • IIMGENC_EOK : iimgenc.h
  • IIMGENC_ERUNTIME : iimgenc.h
  • IIMGENC_Handle : iimgenc.h
  • IMGDEC1_Cmd : imgdec1.h
  • IMGDEC1_control() : imgdec1.h
  • IMGDEC1_create() : imgdec1.h
  • IMGDEC1_delete() : imgdec1.h
  • IMGDEC1_DynamicParams : imgdec1.h
  • IMGDEC1_EFAIL : imgdec1.h
  • IMGDEC1_EOK : imgdec1.h
  • IMGDEC1_ETIMEOUT : imgdec1.h
  • IMGDEC1_EUNSUPPORTED : imgdec1.h
  • IMGDEC1_FOREVER : imgdec1.h
  • IMGDEC1_Handle : imgdec1.h
  • IMGDEC1_InArgs : imgdec1.h
  • IMGDEC1_OutArgs : imgdec1.h
  • IMGDEC1_Params : imgdec1.h
  • IMGDEC1_process() : imgdec1.h
  • IMGDEC1_processAsync() : imgdec1.h
  • IMGDEC1_processWait() : imgdec1.h
  • IMGDEC1_Status : imgdec1.h
  • IMGDEC_Cmd : imgdec.h
  • IMGDEC_control() : imgdec.h
  • IMGDEC_create() : imgdec.h
  • IMGDEC_delete() : imgdec.h
  • IMGDEC_DynamicParams : imgdec.h
  • IMGDEC_EFAIL : imgdec.h
  • IMGDEC_EOK : imgdec.h
  • IMGDEC_ERUNTIME : imgdec.h
  • IMGDEC_ETIMEOUT : imgdec.h
  • IMGDEC_FOREVER : imgdec.h
  • IMGDEC_Handle : imgdec.h
  • IMGDEC_InArgs : imgdec.h
  • IMGDEC_OutArgs : imgdec.h
  • IMGDEC_Params : imgdec.h
  • IMGDEC_process() : imgdec.h
  • IMGDEC_processAsync() : imgdec.h
  • IMGDEC_processWait() : imgdec.h
  • IMGDEC_Status : imgdec.h
  • IMGENC1_Cmd : imgenc1.h
  • IMGENC1_control() : imgenc1.h
  • IMGENC1_create() : imgenc1.h
  • IMGENC1_delete() : imgenc1.h
  • IMGENC1_DynamicParams : imgenc1.h
  • IMGENC1_EFAIL : imgenc1.h
  • IMGENC1_EOK : imgenc1.h
  • IMGENC1_ETIMEOUT : imgenc1.h
  • IMGENC1_EUNSUPPORTED : imgenc1.h
  • IMGENC1_FOREVER : imgenc1.h
  • IMGENC1_Handle : imgenc1.h
  • IMGENC1_InArgs : imgenc1.h
  • IMGENC1_OutArgs : imgenc1.h
  • IMGENC1_Params : imgenc1.h
  • IMGENC1_process() : imgenc1.h
  • IMGENC1_processAsync() : imgenc1.h
  • IMGENC1_processWait() : imgenc1.h
  • IMGENC1_Status : imgenc1.h
  • IMGENC_Cmd : imgenc.h
  • IMGENC_control() : imgenc.h
  • IMGENC_create() : imgenc.h
  • IMGENC_delete() : imgenc.h
  • IMGENC_DynamicParams : imgenc.h
  • IMGENC_EFAIL : imgenc.h
  • IMGENC_EOK : imgenc.h
  • IMGENC_ERUNTIME : imgenc.h
  • IMGENC_ETIMEOUT : imgenc.h
  • IMGENC_FOREVER : imgenc.h
  • IMGENC_Handle : imgenc.h
  • IMGENC_InArgs : imgenc.h
  • IMGENC_OutArgs : imgenc.h
  • IMGENC_Params : imgenc.h
  • IMGENC_process() : imgenc.h
  • IMGENC_processAsync() : imgenc.h
  • IMGENC_processWait() : imgenc.h
  • IMGENC_Status : imgenc.h
  • ISPEECH1_AMR_BitRate : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_10P2 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_12P2 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_4P75 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_5P15 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_5P9 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_6P7 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_7P4 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_7P95 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_CodecSelect : ispeech1_amr.h
  • ISPEECH1_AMR_CODECSELECT_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_CODECSELECT_PRIMARY : ispeech1_amr.h
  • ISPEECH1_AMR_CODECSELECT_SECONDARY : ispeech1_amr.h
  • ISPEECH1_AMR_PackingType : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_IF1_NOCRC : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_IF1_WITHCRC : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_IF2 : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_MIME : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPEFORMAT_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_VADSelect : ispeech1_amr.h
  • ISPEECH1_AMR_VADSELECT_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_VADSELECT_VAD1 : ispeech1_amr.h
  • ISPEECH1_AMR_VADSELECT_VAD2 : ispeech1_amr.h
  • ISPEECH1_EVRC_Mode : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_CAPACITYSAVE : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_DEFAULT : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_ECONOMY : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_HALFRATE_MAX : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_PREMIUM : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_STANDARD : ispeech1_evrc.h
  • ISPEECH1_EVRC_NoisePreProc : ispeech1_evrc.h
  • ISPEECH1_EVRC_NOISEPREPROC_DEFAULT : ispeech1_evrc.h
  • ISPEECH1_EVRC_NOISEPREPROC_OFF : ispeech1_evrc.h
  • ISPEECH1_EVRC_NOISEPREPROC_ON : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMode : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_45P45BPS : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_50BPS : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_DEFAULT : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_OFF : ispeech1_evrc.h
  • ISPEECH1_G723_BitRate : ispeech1_g723.h
  • ISPEECH1_G723_BITRATE_5P3 : ispeech1_g723.h
  • ISPEECH1_G723_BITRATE_6P3 : ispeech1_g723.h
  • ISPEECH1_G723_BITRATE_DEFAULT : ispeech1_g723.h
  • ISPEECH1_G723_NoisePreProc : ispeech1_g723.h
  • ISPEECH1_G723_NOISEPREPROC_DEFAULT : ispeech1_g723.h
  • ISPEECH1_G723_NOISEPREPROC_OFF : ispeech1_g723.h
  • ISPEECH1_G723_NOISEPREPROC_ON : ispeech1_g723.h
  • ISPEECH1_G726_BitRate : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_16 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_24 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_32 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_40 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_DEFAULT : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_ALAW : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_DEFAULT : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_LINEAR : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_ULAW : ispeech1_g726.h
  • ISPEECH1_G726_CompandingLaw : ispeech1_g726.h
  • ISPEECH1_G726_PackingType : ispeech1_g726.h
  • ISPEECH1_G726_PACKTYPE_LINEAR : ispeech1_g726.h
  • ISPEECH1_G726_PACKTYPE_RTPSPECIAL : ispeech1_g726.h
  • ISPEECH1_G726_PACKTYPEFORMAT_DEFAULT : ispeech1_g726.h
  • ISPEECH1_NullTrafficMode : ispeech1.h
  • ISPEECH1_NULLTRAFFICMODE_DEFAULT : ispeech1.h
  • ISPEECH1_NULLTRAFFICMODE_OFF : ispeech1.h
  • ISPEECH1_NULLTRAFFICMODE_ON : ispeech1.h
  • ISPEECH1_PCM_COMPAND_ALAW : ispeech1_pcm.h
  • ISPEECH1_PCM_COMPAND_DEFAULT : ispeech1_pcm.h
  • ISPEECH1_PCM_COMPAND_LINEAR : ispeech1_pcm.h
  • ISPEECH1_PCM_COMPAND_ULAW : ispeech1_pcm.h
  • ISPEECH1_PCM_CompandingLaw : ispeech1_pcm.h
  • ISPEECH1_PostFilter : ispeech1.h
  • ISPEECH1_POSTFILTER_DEFAULT : ispeech1.h
  • ISPEECH1_POSTFILTER_OFF : ispeech1.h
  • ISPEECH1_POSTFILTER_ON : ispeech1.h
  • ISPEECH1_SMV_DataMode : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_FULLRATE : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_HALFRATE : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMode : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMODE_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMODE_ON : ispeech1_smv.h
  • ISPEECH1_SMV_Mode : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_CAPACITYSAVE : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_ECONOMY : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_PREMIUM : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_PREMIUM_HALFRATE_MAX : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_STANDARD : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_STANDARD_HALFRATE_MAX : ispeech1_smv.h
  • ISPEECH1_SMV_NoisePreProc : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_NSA : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_NSB : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMode : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_45P45BPS : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_50BPS : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_VADSelect : ispeech1_smv.h
  • ISPEECH1_SMV_VADSELECT_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_VADSELECT_VADA : ispeech1_smv.h
  • ISPEECH1_SMV_VADSELECT_VADB : ispeech1_smv.h
  • ISPEECH1_VADFlag : ispeech1.h
  • ISPEECH1_VADFLAG_DEFAULT : ispeech1.h
  • ISPEECH1_VADFLAG_OFF : ispeech1.h
  • ISPEECH1_VADFLAG_ON : ispeech1.h
  • ISPEECH1_WBAMR_BitRate : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_12P65 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_14P25 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_15P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_18P25 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_19P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_23P05 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_23P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_6P60 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_8P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_DEFAULT : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PackingType : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_IF1_WITHCRC : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_IF2 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_MIME : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPEFORMAT_DEFAULT : ispeech1_wbamr.h
  • ISPEECH_ALAW : ispeech.h
  • ISPEECH_CompoundLaw : ispeech.h
  • ISPEECH_LINEAR : ispeech.h
  • ISPEECH_ULAW : ispeech.h
  • ISPEECH_UNVOICED : ispeech.h
  • ISPEECH_VOICED : ispeech.h
  • ISPEECH_VoiceMode : ispeech.h
  • ISPHDEC1_Cmd : isphdec1.h
  • ISPHDEC1_EFAIL : isphdec1.h
  • ISPHDEC1_EOK : isphdec1.h
  • ISPHDEC1_EUNSUPPORTED : isphdec1.h
  • ISPHDEC1_FrameType : isphdec1.h
  • ISPHDEC1_FTYPE_BAD : isphdec1.h
  • ISPHDEC1_FTYPE_DEGRADED : isphdec1.h
  • ISPHDEC1_FTYPE_NODATA : isphdec1.h
  • ISPHDEC1_FTYPE_ONSET : isphdec1.h
  • ISPHDEC1_FTYPE_SIDBAD : isphdec1.h
  • ISPHDEC1_FTYPE_SIDFIRST : isphdec1.h
  • ISPHDEC1_FTYPE_SIDUPDATE : isphdec1.h
  • ISPHDEC1_FTYPE_SPEECHGOOD : isphdec1.h
  • ISPHDEC1_FTYPE_SPEECHLOST : isphdec1.h
  • ISPHDEC1_Handle : isphdec1.h
  • ISPHDEC_CID : isphdec.h
  • ISPHDEC_Cmd : isphdec.h
  • ISPHDEC_EFAIL : isphdec.h
  • ISPHDEC_EOK : isphdec.h
  • ISPHDEC_ERUNTIME : isphdec.h
  • ISPHDEC_Handle : isphdec.h
  • ISPHENC1_Cmd : isphenc1.h
  • ISPHENC1_EFAIL : isphenc1.h
  • ISPHENC1_ENOOUTPUT : isphenc1.h
  • ISPHENC1_EOK : isphenc1.h
  • ISPHENC1_EUNSUPPORTED : isphenc1.h
  • ISPHENC1_FrameType : isphenc1.h
  • ISPHENC1_FTYPE_NODATA : isphenc1.h
  • ISPHENC1_FTYPE_SIDFRAME : isphenc1.h
  • ISPHENC1_FTYPE_SPEECH : isphenc1.h
  • ISPHENC1_Handle : isphenc1.h
  • ISPHENC_CID : isphenc.h
  • ISPHENC_Cmd : isphenc.h
  • ISPHENC_EFAIL : isphenc.h
  • ISPHENC_EOK : isphenc.h
  • ISPHENC_ERUNTIME : isphenc.h
  • ISPHENC_Handle : isphenc.h
  • IUNIVERSAL_Cmd : iuniversal.h
  • IUNIVERSAL_EFAIL : iuniversal.h
  • IUNIVERSAL_EOK : iuniversal.h
  • IUNIVERSAL_EUNSUPPORTED : iuniversal.h
  • IUNIVERSAL_Handle : iuniversal.h
  • IVIDANALYTICS_ActionType : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_APPEAR : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSD2U : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSL2R : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSR2L : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSU2D : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_DISAPPEAR : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_ENTER : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_EXIT : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_LOITER : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_USERBASE : ividanalytics.h
  • IVIDANALYTICS_AnalysisMask : ividanalytics.h
  • IVIDANALYTICS_CLEARRULE : ividanalytics.h
  • IVIDANALYTICS_Cmd : ividanalytics.h
  • IVIDANALYTICS_EFAIL : ividanalytics.h
  • IVIDANALYTICS_EOK : ividanalytics.h
  • IVIDANALYTICS_EUNSUPPORTED : ividanalytics.h
  • IVIDANALYTICS_Handle : ividanalytics.h
  • IVIDANALYTICS_MAXEVENTS : ividanalytics.h
  • IVIDANALYTICS_MAXTARGETS : ividanalytics.h
  • IVIDANALYTICS_MOTIONDETECT : ividanalytics.h
  • IVIDANALYTICS_OBJECTTRACKING : ividanalytics.h
  • IVIDANALYTICS_ObjectType : ividanalytics.h
  • IVIDANALYTICS_OBJECTTYPE_HUMAN : ividanalytics.h
  • IVIDANALYTICS_OBJECTTYPE_USERBASE : ividanalytics.h
  • IVIDANALYTICS_OBJECTTYPE_VEHICLE : ividanalytics.h
  • IVIDANALYTICS_SETRULE : ividanalytics.h
  • IVIDANALYTICS_USERBASE : ividanalytics.h
  • IVIDANALYTICS_ViewState : ividanalytics.h
  • IVIDANALYTICS_VIEWSTATE_BAD : ividanalytics.h
  • IVIDANALYTICS_VIEWSTATE_GOOD : ividanalytics.h
  • IVIDDEC1_Cmd : ividdec1.h
  • IVIDDEC1_EFAIL : ividdec1.h
  • IVIDDEC1_EOK : ividdec1.h
  • IVIDDEC1_EUNSUPPORTED : ividdec1.h
  • IVIDDEC1_FrameOrder : ividdec1.h
  • IVIDDEC1_FREE_BUFF_SIZE : ividdec1.h
  • IVIDDEC1_Handle : ividdec1.h
  • IVIDDEC2_Cmd : ividdec2.h
  • IVIDDEC2_DECODE_ORDER : ividdec2.h
  • IVIDDEC2_DISPLAY_ORDER : ividdec2.h
  • IVIDDEC2_EFAIL : ividdec2.h
  • IVIDDEC2_EOK : ividdec2.h
  • IVIDDEC2_EUNSUPPORTED : ividdec2.h
  • IVIDDEC2_FrameOrder : ividdec2.h
  • IVIDDEC2_FRAMEORDER_DEFAULT : ividdec2.h
  • IVIDDEC2_Handle : ividdec2.h
  • IVIDDEC2_MAX_IO_BUFFERS : ividdec2.h
  • IVIDDEC2BACK_Handle : split/ividdec2.h
  • IVIDDEC2FRONT_Handle : split/ividdec2.h
  • IVIDDEC_CID : ividdec.h
  • IVIDDEC_Cmd : ividdec.h
  • IVIDDEC_DECODE_ORDER : ividdec1.h
  • IVIDDEC_DISPLAY_ORDER : ividdec1.h
  • IVIDDEC_EFAIL : ividdec.h
  • IVIDDEC_EOK : ividdec.h
  • IVIDDEC_ERUNTIME : ividdec.h
  • IVIDDEC_FRAMEORDER_DEFAULT : ividdec1.h
  • IVIDDEC_Handle : ividdec.h
  • IVIDENC1_Cmd : ividenc1.h
  • IVIDENC1_EFAIL : ividenc1.h
  • IVIDENC1_EOK : ividenc1.h
  • IVIDENC1_EUNSUPPORTED : ividenc1.h
  • IVIDENC1_Handle : ividenc1.h
  • IVIDENC_CID : ividenc.h
  • IVIDENC_Cmd : ividenc.h
  • IVIDENC_EFAIL : ividenc.h
  • IVIDENC_EOK : ividenc.h
  • IVIDENC_ERUNTIME : ividenc.h
  • IVIDENC_Handle : ividenc.h
  • IVIDEO_B_FRAME : ivideo.h
  • IVIDEO_B_PICTURE : ivideo.h
  • IVIDEO_BB_FRAME : ivideo.h
  • IVIDEO_BI_FRAME : ivideo.h
  • IVIDEO_BP_FRAME : ivideo.h
  • IVIDEO_ContentType : ivideo.h
  • IVIDEO_CONTENTTYPE_DEFAULT : ivideo.h
  • IVIDEO_CONTENTTYPE_NA : ivideo.h
  • IVIDEO_Format : ivideo.h
  • IVIDEO_FRAME_ENCODED : ivideo.h
  • IVIDEO_FRAME_ERROR : ivideo.h
  • IVIDEO_FRAME_NOERROR : ivideo.h
  • IVIDEO_FRAME_NOTAVAILABLE : ivideo.h
  • IVIDEO_FRAME_SKIPPED : ivideo.h
  • IVIDEO_FrameSkip : ivideo.h
  • IVIDEO_FrameType : ivideo.h
  • IVIDEO_FRAMETYPE_DEFAULT : ivideo.h
  • IVIDEO_H264BP : ivideo.h
  • IVIDEO_H264HP : ivideo.h
  • IVIDEO_H264MP : ivideo.h
  • IVIDEO_I_FRAME : ivideo.h
  • IVIDEO_I_PICTURE : ivideo.h
  • IVIDEO_IB_FRAME : ivideo.h
  • IVIDEO_IDR_FRAME : ivideo.h
  • IVIDEO_II_FRAME : ivideo.h
  • IVIDEO_INTERLACED : ivideo.h
  • IVIDEO_INTERLACED_BOTTOMFIELD : ivideo.h
  • IVIDEO_INTERLACED_FRAME : ivideo.h
  • IVIDEO_INTERLACED_TOPFIELD : ivideo.h
  • IVIDEO_IP_FRAME : ivideo.h
  • IVIDEO_LOW_DELAY : ivideo.h
  • IVIDEO_MAX_YUV_BUFFERS : ivideo.h
  • IVIDEO_MBAFF_B_FRAME : ivideo.h
  • IVIDEO_MBAFF_I_FRAME : ivideo.h
  • IVIDEO_MBAFF_IDR_FRAME : ivideo.h
  • IVIDEO_MBAFF_P_FRAME : ivideo.h
  • IVIDEO_MPEG1 : ivideo.h
  • IVIDEO_MPEG2HP : ivideo.h
  • IVIDEO_MPEG2MP : ivideo.h
  • IVIDEO_MPEG2SP : ivideo.h
  • IVIDEO_MPEG4ASP : ivideo.h
  • IVIDEO_MPEG4SP : ivideo.h
  • IVIDEO_NA_FRAME : ivideo.h
  • IVIDEO_NA_PICTURE : ivideo.h
  • IVIDEO_NO_SKIP : ivideo.h
  • IVIDEO_NONE : ivideo.h
  • IVIDEO_OutputFrameStatus : ivideo.h
  • IVIDEO_OUTPUTFRAMESTATUS_DEFAULT : ivideo.h
  • IVIDEO_P_FRAME : ivideo.h
  • IVIDEO_P_PICTURE : ivideo.h
  • IVIDEO_PB_FRAME : ivideo.h
  • IVIDEO_PI_FRAME : ivideo.h
  • IVIDEO_PICTURE_TYPE_DEFAULT : ivideo.h
  • IVIDEO_PictureType : ivideo.h
  • IVIDEO_PP_FRAME : ivideo.h
  • IVIDEO_PROGRESSIVE : ivideo.h
  • IVIDEO_PROGRESSIVE_FRAME : ivideo.h
  • IVIDEO_RateControlPreset : ivideo.h
  • IVIDEO_RATECONTROLPRESET_DEFAULT : ivideo.h
  • IVIDEO_SKIP_B : ivideo.h
  • IVIDEO_SKIP_DEFAULT : ivideo.h
  • IVIDEO_SKIP_I : ivideo.h
  • IVIDEO_SKIP_IB : ivideo.h
  • IVIDEO_SKIP_IDR : ivideo.h
  • IVIDEO_SKIP_IP : ivideo.h
  • IVIDEO_SKIP_IPB : ivideo.h
  • IVIDEO_SKIP_P : ivideo.h
  • IVIDEO_SKIP_PB : ivideo.h
  • IVIDEO_SkipMode : ivideo.h
  • IVIDEO_SKIPMODE_DEFAULT : ivideo.h
  • IVIDEO_STORAGE : ivideo.h
  • IVIDEO_TWOPASS : ivideo.h
  • IVIDEO_USER_DEFINED : ivideo.h
  • IVIDEO_VC1AP : ivideo.h
  • IVIDEO_VC1MP : ivideo.h
  • IVIDEO_VC1SP : ivideo.h
  • IVIDTRANSCODE_Cmd : ividtranscode.h
  • IVIDTRANSCODE_EFAIL : ividtranscode.h
  • IVIDTRANSCODE_EOK : ividtranscode.h
  • IVIDTRANSCODE_EUNSUPPORTED : ividtranscode.h
  • IVIDTRANSCODE_Handle : ividtranscode.h
  • IVIDTRANSCODE_MAXOUTSTREAMS : ividtranscode.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- s -

  • Server_connectTrace() : Server.h
  • Server_disconnectTrace() : Server.h
  • Server_EFAIL : Server.h
  • Server_EINUSE : Server.h
  • Server_EINVAL : Server.h
  • Server_ENOMEM : Server.h
  • Server_ENOSERVER : Server.h
  • Server_ENOTFOUND : Server.h
  • Server_EOK : Server.h
  • Server_ERUNTIME : Server.h
  • Server_EWRONGSTATE : Server.h
  • Server_fwriteTrace() : Server.h
  • Server_getAlgInfo() : Server.h
  • Server_getCpuLoad() : Server.h
  • Server_getMemStat() : Server.h
  • Server_getNumAlgs() : Server.h
  • Server_getNumMemSegs() : Server.h
  • Server_GTNAME : Server.h
  • Server_Handle : Server.h
  • Server_MAXSEGNAMELENGTH : Server.h
  • Server_redefineHeap() : Server.h
  • Server_restoreHeap() : Server.h
  • Server_setTrace() : Server.h
  • Server_Status : Server.h
  • SPHDEC1_Cmd : sphdec1.h
  • SPHDEC1_control() : sphdec1.h
  • SPHDEC1_create() : sphdec1.h
  • SPHDEC1_delete() : sphdec1.h
  • SPHDEC1_DynamicParams : sphdec1.h
  • SPHDEC1_EFAIL : sphdec1.h
  • SPHDEC1_EOK : sphdec1.h
  • SPHDEC1_ETIMEOUT : sphdec1.h
  • SPHDEC1_EUNSUPPORTED : sphdec1.h
  • SPHDEC1_FOREVER : sphdec1.h
  • SPHDEC1_Handle : sphdec1.h
  • SPHDEC1_InArgs : sphdec1.h
  • SPHDEC1_OutArgs : sphdec1.h
  • SPHDEC1_Params : sphdec1.h
  • SPHDEC1_process() : sphdec1.h
  • SPHDEC1_processAsync() : sphdec1.h
  • SPHDEC1_processWait() : sphdec1.h
  • SPHDEC1_Status : sphdec1.h
  • SPHDEC_Cmd : sphdec.h
  • SPHDEC_control() : sphdec.h
  • SPHDEC_create() : sphdec.h
  • SPHDEC_delete() : sphdec.h
  • SPHDEC_DynamicParams : sphdec.h
  • SPHDEC_EFAIL : sphdec.h
  • SPHDEC_EOK : sphdec.h
  • SPHDEC_ERUNTIME : sphdec.h
  • SPHDEC_ETIMEOUT : sphdec.h
  • SPHDEC_FOREVER : sphdec.h
  • SPHDEC_Handle : sphdec.h
  • SPHDEC_InArgs : sphdec.h
  • SPHDEC_OutArgs : sphdec.h
  • SPHDEC_Params : sphdec.h
  • SPHDEC_process() : sphdec.h
  • SPHDEC_processAsync() : sphdec.h
  • SPHDEC_processWait() : sphdec.h
  • SPHDEC_Status : sphdec.h
  • SPHENC1_Cmd : sphenc1.h
  • SPHENC1_control() : sphenc1.h
  • SPHENC1_create() : sphenc1.h
  • SPHENC1_delete() : sphenc1.h
  • SPHENC1_DynamicParams : sphenc1.h
  • SPHENC1_EFAIL : sphenc1.h
  • SPHENC1_EOK : sphenc1.h
  • SPHENC1_ETIMEOUT : sphenc1.h
  • SPHENC1_EUNSUPPORTED : sphenc1.h
  • SPHENC1_FOREVER : sphenc1.h
  • SPHENC1_Handle : sphenc1.h
  • SPHENC1_InArgs : sphenc1.h
  • SPHENC1_OutArgs : sphenc1.h
  • SPHENC1_Params : sphenc1.h
  • SPHENC1_process() : sphenc1.h
  • SPHENC1_processAsync() : sphenc1.h
  • SPHENC1_processWait() : sphenc1.h
  • SPHENC1_Status : sphenc1.h
  • SPHENC_Cmd : sphenc.h
  • SPHENC_control() : sphenc.h
  • SPHENC_create() : sphenc.h
  • SPHENC_delete() : sphenc.h
  • SPHENC_DynamicParams : sphenc.h
  • SPHENC_EFAIL : sphenc.h
  • SPHENC_EOK : sphenc.h
  • SPHENC_ERUNTIME : sphenc.h
  • SPHENC_ETIMEOUT : sphenc.h
  • SPHENC_FOREVER : sphenc.h
  • SPHENC_Handle : sphenc.h
  • SPHENC_InArgs : sphenc.h
  • SPHENC_OutArgs : sphenc.h
  • SPHENC_Params : sphenc.h
  • SPHENC_process() : sphenc.h
  • SPHENC_processAsync() : sphenc.h
  • SPHENC_processWait() : sphenc.h
  • SPHENC_Status : sphenc.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- t -

  • TRACEUTIL_FAILURE : TraceUtil.h
  • TraceUtil_start() : TraceUtil.h
  • TraceUtil_stop() : TraceUtil.h
  • TRACEUTIL_SUCCESS : TraceUtil.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- u -

  • UNIVERSAL_Cmd : universal.h
  • UNIVERSAL_control() : universal.h
  • UNIVERSAL_create() : universal.h
  • UNIVERSAL_delete() : universal.h
  • UNIVERSAL_DynamicParams : universal.h
  • UNIVERSAL_EFAIL : universal.h
  • UNIVERSAL_EOK : universal.h
  • UNIVERSAL_ETIMEOUT : universal.h
  • UNIVERSAL_EUNSUPPORTED : universal.h
  • UNIVERSAL_FOREVER : universal.h
  • UNIVERSAL_Handle : universal.h
  • UNIVERSAL_InArgs : universal.h
  • UNIVERSAL_OutArgs : universal.h
  • UNIVERSAL_Params : universal.h
  • UNIVERSAL_process() : universal.h
  • UNIVERSAL_processAsync() : universal.h
  • UNIVERSAL_processWait() : universal.h
  • UNIVERSAL_Status : universal.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- v -

  • VIDANALYTICS_Cmd : vidanalytics.h
  • VIDANALYTICS_control() : vidanalytics.h
  • VIDANALYTICS_create() : vidanalytics.h
  • VIDANALYTICS_delete() : vidanalytics.h
  • VIDANALYTICS_DynamicParams : vidanalytics.h
  • VIDANALYTICS_EFAIL : vidanalytics.h
  • VIDANALYTICS_EOK : vidanalytics.h
  • VIDANALYTICS_ETIMEOUT : vidanalytics.h
  • VIDANALYTICS_EUNSUPPORTED : vidanalytics.h
  • VIDANALYTICS_FOREVER : vidanalytics.h
  • VIDANALYTICS_Handle : vidanalytics.h
  • VIDANALYTICS_InArgs : vidanalytics.h
  • VIDANALYTICS_OutArgs : vidanalytics.h
  • VIDANALYTICS_Params : vidanalytics.h
  • VIDANALYTICS_process() : vidanalytics.h
  • VIDANALYTICS_processAsync() : vidanalytics.h
  • VIDANALYTICS_processWait() : vidanalytics.h
  • VIDANALYTICS_Status : vidanalytics.h
  • VIDDEC1_Cmd : viddec1.h
  • VIDDEC1_control() : viddec1.h
  • VIDDEC1_create() : viddec1.h
  • VIDDEC1_delete() : viddec1.h
  • VIDDEC1_DynamicParams : viddec1.h
  • VIDDEC1_EFAIL : viddec1.h
  • VIDDEC1_EOK : viddec1.h
  • VIDDEC1_ETIMEOUT : viddec1.h
  • VIDDEC1_EUNSUPPORTED : viddec1.h
  • VIDDEC1_FOREVER : viddec1.h
  • VIDDEC1_Handle : viddec1.h
  • VIDDEC1_InArgs : viddec1.h
  • VIDDEC1_OutArgs : viddec1.h
  • VIDDEC1_Params : viddec1.h
  • VIDDEC1_process() : viddec1.h
  • VIDDEC1_processAsync() : viddec1.h
  • VIDDEC1_processWait() : viddec1.h
  • VIDDEC1_Status : viddec1.h
  • VIDDEC2_Cmd : viddec2.h
  • VIDDEC2_control() : viddec2.h
  • VIDDEC2_create() : viddec2.h
  • VIDDEC2_delete() : viddec2.h
  • VIDDEC2_DynamicParams : viddec2.h
  • VIDDEC2_EFAIL : viddec2.h
  • VIDDEC2_EOK : viddec2.h
  • VIDDEC2_ETIMEOUT : viddec2.h
  • VIDDEC2_EUNSUPPORTED : viddec2.h
  • VIDDEC2_FOREVER : viddec2.h
  • VIDDEC2_Handle : viddec2.h
  • VIDDEC2_InArgs : viddec2.h
  • VIDDEC2_OutArgs : viddec2.h
  • VIDDEC2_Params : viddec2.h
  • VIDDEC2_process() : viddec2.h
  • VIDDEC2_processAsync() : viddec2.h
  • VIDDEC2_processWait() : viddec2.h
  • VIDDEC2_Status : viddec2.h
  • VIDDEC2BACK_control() : split/viddec2.h
  • VIDDEC2BACK_create() : split/viddec2.h
  • VIDDEC2BACK_delete() : split/viddec2.h
  • VIDDEC2BACK_Handle : split/viddec2.h
  • VIDDEC2BACK_process() : split/viddec2.h
  • VIDDEC2FRONT_control() : split/viddec2.h
  • VIDDEC2FRONT_create() : split/viddec2.h
  • VIDDEC2FRONT_delete() : split/viddec2.h
  • VIDDEC2FRONT_Handle : split/viddec2.h
  • VIDDEC2FRONT_OutArgs : split/viddec2.h
  • VIDDEC2FRONT_process() : split/viddec2.h
  • VIDDEC2FRONT_Status : split/viddec2.h
  • VIDDEC_Cmd : viddec.h
  • VIDDEC_control() : viddec.h
  • VIDDEC_create() : viddec.h
  • VIDDEC_delete() : viddec.h
  • VIDDEC_DynamicParams : viddec.h
  • VIDDEC_EFAIL : viddec.h
  • VIDDEC_EOK : viddec.h
  • VIDDEC_ERUNTIME : viddec.h
  • VIDDEC_ETIMEOUT : viddec.h
  • VIDDEC_FOREVER : viddec.h
  • VIDDEC_Handle : viddec.h
  • VIDDEC_InArgs : viddec.h
  • VIDDEC_OutArgs : viddec.h
  • VIDDEC_Params : viddec.h
  • VIDDEC_process() : viddec.h
  • VIDDEC_processAsync() : viddec.h
  • VIDDEC_processWait() : viddec.h
  • VIDDEC_Status : viddec.h
  • VIDENC1_Cmd : videnc1.h
  • VIDENC1_control() : videnc1.h
  • VIDENC1_create() : videnc1.h
  • VIDENC1_delete() : videnc1.h
  • VIDENC1_DynamicParams : videnc1.h
  • VIDENC1_EFAIL : videnc1.h
  • VIDENC1_EOK : videnc1.h
  • VIDENC1_ETIMEOUT : videnc1.h
  • VIDENC1_EUNSUPPORTED : videnc1.h
  • VIDENC1_FOREVER : videnc1.h
  • VIDENC1_Handle : videnc1.h
  • VIDENC1_InArgs : videnc1.h
  • VIDENC1_OutArgs : videnc1.h
  • VIDENC1_Params : videnc1.h
  • VIDENC1_process() : videnc1.h
  • VIDENC1_processAsync() : videnc1.h
  • VIDENC1_processWait() : videnc1.h
  • VIDENC1_Status : videnc1.h
  • VIDENC_Cmd : videnc.h
  • VIDENC_control() : videnc.h
  • VIDENC_create() : videnc.h
  • VIDENC_delete() : videnc.h
  • VIDENC_DynamicParams : videnc.h
  • VIDENC_EFAIL : videnc.h
  • VIDENC_EOK : videnc.h
  • VIDENC_ERUNTIME : videnc.h
  • VIDENC_ETIMEOUT : videnc.h
  • VIDENC_FOREVER : videnc.h
  • VIDENC_Handle : videnc.h
  • VIDENC_InArgs : videnc.h
  • VIDENC_OutArgs : videnc.h
  • VIDENC_Params : videnc.h
  • VIDENC_process() : videnc.h
  • VIDENC_processAsync() : videnc.h
  • VIDENC_processWait() : videnc.h
  • VIDENC_Status : videnc.h
  • VIDTRANSCODE_Cmd : vidtranscode.h
  • VIDTRANSCODE_control() : vidtranscode.h
  • VIDTRANSCODE_create() : vidtranscode.h
  • VIDTRANSCODE_delete() : vidtranscode.h
  • VIDTRANSCODE_DynamicParams : vidtranscode.h
  • VIDTRANSCODE_EFAIL : vidtranscode.h
  • VIDTRANSCODE_EOK : vidtranscode.h
  • VIDTRANSCODE_ETIMEOUT : vidtranscode.h
  • VIDTRANSCODE_EUNSUPPORTED : vidtranscode.h
  • VIDTRANSCODE_FOREVER : vidtranscode.h
  • VIDTRANSCODE_Handle : vidtranscode.h
  • VIDTRANSCODE_InArgs : vidtranscode.h
  • VIDTRANSCODE_OutArgs : vidtranscode.h
  • VIDTRANSCODE_Params : vidtranscode.h
  • VIDTRANSCODE_process() : vidtranscode.h
  • VIDTRANSCODE_processAsync() : vidtranscode.h
  • VIDTRANSCODE_processWait() : vidtranscode.h
  • VIDTRANSCODE_Status : vidtranscode.h
  • VISA_allocMsg() : visa.h
  • VISA_call() : visa.h
  • VISA_callAsync() : visa.h
  • VISA_create() : visa.h
  • VISA_create2() : visa.h
  • VISA_delete() : visa.h
  • VISA_EFAIL : visa.h
  • VISA_enter() : visa.h
  • VISA_EOK : visa.h
  • VISA_ERUNTIME : visa.h
  • VISA_ETIMEOUT : visa.h
  • VISA_exit() : visa.h
  • VISA_FOREVER : visa.h
  • VISA_freeMsg() : visa.h
  • VISA_getAlgFxns() : visa.h
  • VISA_getAlgHandle() : visa.h
  • VISA_getAlgMemRecs() : visa.h
  • VISA_getAlgNumRecs() : visa.h
  • VISA_getAlgorithmHandle() : visa.h
  • VISA_getCodecClassConfig() : visa.h
  • VISA_getContext() : visa.h
  • VISA_getMaxMsgSize() : visa.h
  • VISA_Handle : visa.h
  • VISA_isLocal() : visa.h
  • VISA_Msg : visa.h
  • VISA_setContext() : visa.h
  • VISA_Status : visa.h
  • VISA_wait() : visa.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x
Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- x -

  • XDAS_Bool : xdas.h
  • XDAS_FALSE : xdas.h
  • XDAS_Int16 : xdas.h
  • XDAS_Int32 : xdas.h
  • XDAS_Int8 : xdas.h
  • XDAS_TRUE : xdas.h
  • XDAS_UInt16 : xdas.h
  • XDAS_UInt32 : xdas.h
  • XDAS_UInt8 : xdas.h
  • XDAS_Void : xdas.h
  • XDM_AccessMode : xdm.h
  • XDM_ACCESSMODE_READ : xdm.h
  • XDM_ACCESSMODE_WRITE : xdm.h
  • XDM_APPLIEDCONCEALMENT : xdm.h
  • XDM_ARGB8888 : xdm.h
  • XDM_BE_16 : xdm.h
  • XDM_BE_32 : xdm.h
  • XDM_BE_64 : xdm.h
  • XDM_BYTE : xdm.h
  • XDM_CHROMA_NA : xdm.h
  • XDM_ChromaFormat : xdm.h
  • XDM_CHROMAFORMAT_DEFAULT : xdm.h
  • XDM_CLEARACCESSMODE_READ : xdm.h
  • XDM_CLEARACCESSMODE_WRITE : xdm.h
  • XDM_CmdId : xdm.h
  • XDM_CORRUPTEDDATA : xdm.h
  • XDM_CORRUPTEDHEADER : xdm.h
  • XDM_CUSTOMCMDBASE : xdm.h
  • XDM_CUSTOMENUMBASE : xdm.h
  • XDM_DataFormat : xdm.h
  • XDM_DecMode : xdm.h
  • XDM_DECODE_AU : xdm.h
  • XDM_DEFAULT : xdm.h
  • XDM_EFAIL : xdm.h
  • XDM_EncMode : xdm.h
  • XDM_ENCODE_AU : xdm.h
  • XDM_EncodingPreset : xdm.h
  • XDM_EOK : xdm.h
  • XDM_ErrorBit : xdm.h
  • XDM_ERUNTIME : xdm.h
  • XDM_EUNSUPPORTED : xdm.h
  • XDM_FATALERROR : xdm.h
  • XDM_FLUSH : xdm.h
  • XDM_GENERATE_HEADER : xdm.h
  • XDM_GETBUFINFO : xdm.h
  • XDM_GETCONTEXTINFO : xdm.h
  • XDM_GETSTATUS : xdm.h
  • XDM_GETVERSION : xdm.h
  • XDM_GRAY : xdm.h
  • XDM_HIGH_QUALITY : xdm.h
  • XDM_HIGH_SPEED : xdm.h
  • XDM_INSUFFICIENTDATA : xdm.h
  • XDM_ISACCESSMODE_READ : xdm.h
  • XDM_ISACCESSMODE_WRITE : xdm.h
  • XDM_ISAPPLIEDCONCEALMENT : xdm.h
  • XDM_ISCORRUPTEDDATA : xdm.h
  • XDM_ISCORRUPTEDHEADER : xdm.h
  • XDM_ISFATALERROR : xdm.h
  • XDM_ISINSUFFICIENTDATA : xdm.h
  • XDM_ISUNSUPPORTEDINPUT : xdm.h
  • XDM_ISUNSUPPORTEDPARAM : xdm.h
  • XDM_LE_16 : xdm.h
  • XDM_LE_32 : xdm.h
  • XDM_LE_64 : xdm.h
  • XDM_MAX_CONTEXT_BUFFERS : xdm.h
  • XDM_MAX_IO_BUFFERS : xdm.h
  • XDM_PARAMSCHANGE : xdm.h
  • XDM_PARSE_HEADER : xdm.h
  • XDM_RESET : xdm.h
  • XDM_RGB : xdm.h
  • XDM_RGB555 : xdm.h
  • XDM_RGB565 : xdm.h
  • XDM_SETACCESSMODE_READ : xdm.h
  • XDM_SETACCESSMODE_WRITE : xdm.h
  • XDM_SETAPPLIEDCONCEALMENT : xdm.h
  • XDM_SETCORRUPTEDDATA : xdm.h
  • XDM_SETCORRUPTEDHEADER : xdm.h
  • XDM_SETDEFAULT : xdm.h
  • XDM_SETFATALERROR : xdm.h
  • XDM_SETINSUFFICIENTDATA : xdm.h
  • XDM_SETPARAMS : xdm.h
  • XDM_SETUNSUPPORTEDINPUT : xdm.h
  • XDM_SETUNSUPPORTEDPARAM : xdm.h
  • XDM_UNSUPPORTEDINPUT : xdm.h
  • XDM_UNSUPPORTEDPARAM : xdm.h
  • XDM_USER_DEFINED : xdm.h
  • XDM_YUV_411P : xdm.h
  • XDM_YUV_420P : xdm.h
  • XDM_YUV_420SP : xdm.h
  • XDM_YUV_422IBE : xdm.h
  • XDM_YUV_422ILE : xdm.h
  • XDM_YUV_422P : xdm.h
  • XDM_YUV_444ILE : xdm.h
  • XDM_YUV_444P : xdm.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- a -

  • AUDDEC1_EFAIL : auddec1.h
  • AUDDEC1_EOK : auddec1.h
  • AUDDEC1_ETIMEOUT : auddec1.h
  • AUDDEC1_EUNSUPPORTED : auddec1.h
  • AUDDEC1_FOREVER : auddec1.h
  • AUDDEC_EFAIL : auddec.h
  • AUDDEC_EOK : auddec.h
  • AUDDEC_ERUNTIME : auddec.h
  • AUDDEC_ETIMEOUT : auddec.h
  • AUDDEC_FOREVER : auddec.h
  • AUDENC1_EFAIL : audenc1.h
  • AUDENC1_EOK : audenc1.h
  • AUDENC1_ETIMEOUT : audenc1.h
  • AUDENC1_EUNSUPPORTED : audenc1.h
  • AUDENC1_FOREVER : audenc1.h
  • AUDENC_EFAIL : audenc.h
  • AUDENC_EOK : audenc.h
  • AUDENC_ERUNTIME : audenc.h
  • AUDENC_ETIMEOUT : audenc.h
  • AUDENC_FOREVER : audenc.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- l -

  • LAD_MAXLENGTHCONFIGNAME : ladclient.h
  • LAD_MAXLENGTHIMAGENAME : ladclient.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- m -

  • Memory_CACHED : Memory.h
  • Memory_CACHEDMASK : Memory.h
  • Memory_DEFAULTALIGNMENT : Memory.h
  • Memory_GTNAME : Memory.h
  • Memory_NONCACHED : Memory.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- c -

  • CE_BEGIN_ALG_TABLE : CERuntime.h
  • CE_BEGIN_ENGINE_TABLE : CERuntime.h
  • CE_DECLARE_TYPE : CERuntime.h
  • CE_END_ALG_TABLE : CERuntime.h
  • CE_END_ENGINE_TABLE : CERuntime.h
  • CE_ENGINE : CERuntime.h
  • CE_LOCAL_ALG : CERuntime.h
  • CE_NULL_algs : CERuntime.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- e -

  • Engine_EBADSERVER : Engine.h
  • Engine_ECODECCREATE : Engine.h
  • Engine_ECODECSTART : Engine.h
  • Engine_ECOMALLOC : Engine.h
  • Engine_EDSPLOAD : Engine.h
  • Engine_EEXIST : Engine.h
  • Engine_EINUSE : Engine.h
  • Engine_EINVAL : Engine.h
  • Engine_ENOCOMM : Engine.h
  • Engine_ENOMEM : Engine.h
  • Engine_ENOSERVER : Engine.h
  • Engine_ENOTAVAIL : Engine.h
  • Engine_ENOTFOUND : Engine.h
  • Engine_EOK : Engine.h
  • Engine_ERUNTIME : Engine.h
  • Engine_ETIMEOUT : Engine.h
  • Engine_EWRONGSTATE : Engine.h
  • Engine_GTNAME : Engine.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- i -

  • IALG_CUSTOMFAILBASE : ialg.h
  • IALG_CUSTOMFAILEND : ialg.h
  • IALG_DEFMEMRECS : ialg.h
  • IALG_EFAIL : ialg.h
  • IALG_EOK : ialg.h
  • IALG_isOffChip : ialg.h
  • IALG_isProg : ialg.h
  • IALG_MPROG : ialg.h
  • IALG_MXTRN : ialg.h
  • IALG_OBJMEMREC : ialg.h
  • IALG_SYSCMD : ialg.h
  • IAUDDEC1_EFAIL : iauddec1.h
  • IAUDDEC1_EOK : iauddec1.h
  • IAUDDEC1_EUNSUPPORTED : iauddec1.h
  • IAUDDEC_CID : iauddec.h
  • IAUDDEC_EFAIL : iauddec.h
  • IAUDDEC_EOK : iauddec.h
  • IAUDDEC_ERUNTIME : iauddec.h
  • IAUDENC1_EFAIL : iaudenc1.h
  • IAUDENC1_EOK : iaudenc1.h
  • IAUDENC1_EUNSUPPORTED : iaudenc1.h
  • IAUDENC_CID : iaudenc.h
  • IAUDENC_EFAIL : iaudenc.h
  • IAUDENC_EOK : iaudenc.h
  • IAUDENC_ERUNTIME : iaudenc.h
  • IIMGDEC1_EFAIL : iimgdec1.h
  • IIMGDEC1_EOK : iimgdec1.h
  • IIMGDEC1_EUNSUPPORTED : iimgdec1.h
  • IIMGDEC_CID : iimgdec.h
  • IIMGDEC_EFAIL : iimgdec.h
  • IIMGDEC_EOK : iimgdec.h
  • IIMGDEC_ERUNTIME : iimgdec.h
  • IIMGENC1_EFAIL : iimgenc1.h
  • IIMGENC1_EOK : iimgenc1.h
  • IIMGENC1_EUNSUPPORTED : iimgenc1.h
  • IIMGENC_CID : iimgenc.h
  • IIMGENC_EFAIL : iimgenc.h
  • IIMGENC_EOK : iimgenc.h
  • IIMGENC_ERUNTIME : iimgenc.h
  • IMGDEC1_EFAIL : imgdec1.h
  • IMGDEC1_EOK : imgdec1.h
  • IMGDEC1_ETIMEOUT : imgdec1.h
  • IMGDEC1_EUNSUPPORTED : imgdec1.h
  • IMGDEC1_FOREVER : imgdec1.h
  • IMGDEC_EFAIL : imgdec.h
  • IMGDEC_EOK : imgdec.h
  • IMGDEC_ERUNTIME : imgdec.h
  • IMGDEC_ETIMEOUT : imgdec.h
  • IMGDEC_FOREVER : imgdec.h
  • IMGENC1_EFAIL : imgenc1.h
  • IMGENC1_EOK : imgenc1.h
  • IMGENC1_ETIMEOUT : imgenc1.h
  • IMGENC1_EUNSUPPORTED : imgenc1.h
  • IMGENC1_FOREVER : imgenc1.h
  • IMGENC_EFAIL : imgenc.h
  • IMGENC_EOK : imgenc.h
  • IMGENC_ERUNTIME : imgenc.h
  • IMGENC_ETIMEOUT : imgenc.h
  • IMGENC_FOREVER : imgenc.h
  • ISPHDEC1_EFAIL : isphdec1.h
  • ISPHDEC1_EOK : isphdec1.h
  • ISPHDEC1_EUNSUPPORTED : isphdec1.h
  • ISPHDEC_CID : isphdec.h
  • ISPHDEC_EFAIL : isphdec.h
  • ISPHDEC_EOK : isphdec.h
  • ISPHDEC_ERUNTIME : isphdec.h
  • ISPHENC1_EFAIL : isphenc1.h
  • ISPHENC1_ENOOUTPUT : isphenc1.h
  • ISPHENC1_EOK : isphenc1.h
  • ISPHENC1_EUNSUPPORTED : isphenc1.h
  • ISPHENC_CID : isphenc.h
  • ISPHENC_EFAIL : isphenc.h
  • ISPHENC_EOK : isphenc.h
  • ISPHENC_ERUNTIME : isphenc.h
  • IUNIVERSAL_EFAIL : iuniversal.h
  • IUNIVERSAL_EOK : iuniversal.h
  • IUNIVERSAL_EUNSUPPORTED : iuniversal.h
  • IVIDANALYTICS_CLEARRULE : ividanalytics.h
  • IVIDANALYTICS_EFAIL : ividanalytics.h
  • IVIDANALYTICS_EOK : ividanalytics.h
  • IVIDANALYTICS_EUNSUPPORTED : ividanalytics.h
  • IVIDANALYTICS_MAXEVENTS : ividanalytics.h
  • IVIDANALYTICS_MAXTARGETS : ividanalytics.h
  • IVIDANALYTICS_SETRULE : ividanalytics.h
  • IVIDDEC1_EFAIL : ividdec1.h
  • IVIDDEC1_EOK : ividdec1.h
  • IVIDDEC1_EUNSUPPORTED : ividdec1.h
  • IVIDDEC1_FREE_BUFF_SIZE : ividdec1.h
  • IVIDDEC2_EFAIL : ividdec2.h
  • IVIDDEC2_EOK : ividdec2.h
  • IVIDDEC2_EUNSUPPORTED : ividdec2.h
  • IVIDDEC2_MAX_IO_BUFFERS : ividdec2.h
  • IVIDDEC_CID : ividdec.h
  • IVIDDEC_EFAIL : ividdec.h
  • IVIDDEC_EOK : ividdec.h
  • IVIDDEC_ERUNTIME : ividdec.h
  • IVIDENC1_EFAIL : ividenc1.h
  • IVIDENC1_EOK : ividenc1.h
  • IVIDENC1_EUNSUPPORTED : ividenc1.h
  • IVIDENC_CID : ividenc.h
  • IVIDENC_EFAIL : ividenc.h
  • IVIDENC_EOK : ividenc.h
  • IVIDENC_ERUNTIME : ividenc.h
  • IVIDEO_MAX_YUV_BUFFERS : ivideo.h
  • IVIDTRANSCODE_EFAIL : ividtranscode.h
  • IVIDTRANSCODE_EOK : ividtranscode.h
  • IVIDTRANSCODE_EUNSUPPORTED : ividtranscode.h
  • IVIDTRANSCODE_MAXOUTSTREAMS : ividtranscode.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- s -

  • Server_GTNAME : Server.h
  • Server_MAXSEGNAMELENGTH : Server.h
  • SPHDEC1_EFAIL : sphdec1.h
  • SPHDEC1_EOK : sphdec1.h
  • SPHDEC1_ETIMEOUT : sphdec1.h
  • SPHDEC1_EUNSUPPORTED : sphdec1.h
  • SPHDEC1_FOREVER : sphdec1.h
  • SPHDEC_EFAIL : sphdec.h
  • SPHDEC_EOK : sphdec.h
  • SPHDEC_ERUNTIME : sphdec.h
  • SPHDEC_ETIMEOUT : sphdec.h
  • SPHDEC_FOREVER : sphdec.h
  • SPHENC1_EFAIL : sphenc1.h
  • SPHENC1_EOK : sphenc1.h
  • SPHENC1_ETIMEOUT : sphenc1.h
  • SPHENC1_EUNSUPPORTED : sphenc1.h
  • SPHENC1_FOREVER : sphenc1.h
  • SPHENC_EFAIL : sphenc.h
  • SPHENC_EOK : sphenc.h
  • SPHENC_ERUNTIME : sphenc.h
  • SPHENC_ETIMEOUT : sphenc.h
  • SPHENC_FOREVER : sphenc.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- t -

  • TRACEUTIL_FAILURE : TraceUtil.h
  • TRACEUTIL_SUCCESS : TraceUtil.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- u -

  • UNIVERSAL_EFAIL : universal.h
  • UNIVERSAL_EOK : universal.h
  • UNIVERSAL_ETIMEOUT : universal.h
  • UNIVERSAL_EUNSUPPORTED : universal.h
  • UNIVERSAL_FOREVER : universal.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- v -

  • VIDANALYTICS_EFAIL : vidanalytics.h
  • VIDANALYTICS_EOK : vidanalytics.h
  • VIDANALYTICS_ETIMEOUT : vidanalytics.h
  • VIDANALYTICS_EUNSUPPORTED : vidanalytics.h
  • VIDANALYTICS_FOREVER : vidanalytics.h
  • VIDDEC1_EFAIL : viddec1.h
  • VIDDEC1_EOK : viddec1.h
  • VIDDEC1_ETIMEOUT : viddec1.h
  • VIDDEC1_EUNSUPPORTED : viddec1.h
  • VIDDEC1_FOREVER : viddec1.h
  • VIDDEC2_EFAIL : viddec2.h
  • VIDDEC2_EOK : viddec2.h
  • VIDDEC2_ETIMEOUT : viddec2.h
  • VIDDEC2_EUNSUPPORTED : viddec2.h
  • VIDDEC2_FOREVER : viddec2.h
  • VIDDEC_EFAIL : viddec.h
  • VIDDEC_EOK : viddec.h
  • VIDDEC_ERUNTIME : viddec.h
  • VIDDEC_ETIMEOUT : viddec.h
  • VIDDEC_FOREVER : viddec.h
  • VIDENC1_EFAIL : videnc1.h
  • VIDENC1_EOK : videnc1.h
  • VIDENC1_ETIMEOUT : videnc1.h
  • VIDENC1_EUNSUPPORTED : videnc1.h
  • VIDENC1_FOREVER : videnc1.h
  • VIDENC_EFAIL : videnc.h
  • VIDENC_EOK : videnc.h
  • VIDENC_ERUNTIME : videnc.h
  • VIDENC_ETIMEOUT : videnc.h
  • VIDENC_FOREVER : videnc.h
  • VIDTRANSCODE_EFAIL : vidtranscode.h
  • VIDTRANSCODE_EOK : vidtranscode.h
  • VIDTRANSCODE_ETIMEOUT : vidtranscode.h
  • VIDTRANSCODE_EUNSUPPORTED : vidtranscode.h
  • VIDTRANSCODE_FOREVER : vidtranscode.h
  • VISA_EFAIL : visa.h
  • VISA_EOK : visa.h
  • VISA_ERUNTIME : visa.h
  • VISA_ETIMEOUT : visa.h
  • VISA_FOREVER : visa.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v
  • x

- x -

  • XDAS_FALSE : xdas.h
  • XDAS_TRUE : xdas.h
  • XDM_CLEARACCESSMODE_READ : xdm.h
  • XDM_CLEARACCESSMODE_WRITE : xdm.h
  • XDM_CUSTOMCMDBASE : xdm.h
  • XDM_CUSTOMENUMBASE : xdm.h
  • XDM_EFAIL : xdm.h
  • XDM_EOK : xdm.h
  • XDM_ERUNTIME : xdm.h
  • XDM_EUNSUPPORTED : xdm.h
  • XDM_ISACCESSMODE_READ : xdm.h
  • XDM_ISACCESSMODE_WRITE : xdm.h
  • XDM_ISAPPLIEDCONCEALMENT : xdm.h
  • XDM_ISCORRUPTEDDATA : xdm.h
  • XDM_ISCORRUPTEDHEADER : xdm.h
  • XDM_ISFATALERROR : xdm.h
  • XDM_ISINSUFFICIENTDATA : xdm.h
  • XDM_ISUNSUPPORTEDINPUT : xdm.h
  • XDM_ISUNSUPPORTEDPARAM : xdm.h
  • XDM_MAX_CONTEXT_BUFFERS : xdm.h
  • XDM_MAX_IO_BUFFERS : xdm.h
  • XDM_SETACCESSMODE_READ : xdm.h
  • XDM_SETACCESSMODE_WRITE : xdm.h
  • XDM_SETAPPLIEDCONCEALMENT : xdm.h
  • XDM_SETCORRUPTEDDATA : xdm.h
  • XDM_SETCORRUPTEDHEADER : xdm.h
  • XDM_SETFATALERROR : xdm.h
  • XDM_SETINSUFFICIENTDATA : xdm.h
  • XDM_SETUNSUPPORTEDINPUT : xdm.h
  • XDM_SETUNSUPPORTEDPARAM : xdm.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • l
  • m
  • s
  • x

- i -

  • IALG_MemAttrs : ialg.h
  • IALG_MemSpace : ialg.h
  • IAUDIO_ChannelId : iaudio.h
  • IAUDIO_ChannelMode : iaudio.h
  • IAUDIO_DualMonoMode : iaudio.h
  • IAUDIO_EncMode : iaudio.h
  • IAUDIO_PcmFormat : iaudio.h
  • ISPEECH1_AMR_BitRate : ispeech1_amr.h
  • ISPEECH1_AMR_CodecSelect : ispeech1_amr.h
  • ISPEECH1_AMR_PackingType : ispeech1_amr.h
  • ISPEECH1_AMR_VADSelect : ispeech1_amr.h
  • ISPEECH1_EVRC_Mode : ispeech1_evrc.h
  • ISPEECH1_EVRC_NoisePreProc : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMode : ispeech1_evrc.h
  • ISPEECH1_G723_BitRate : ispeech1_g723.h
  • ISPEECH1_G723_NoisePreProc : ispeech1_g723.h
  • ISPEECH1_G726_BitRate : ispeech1_g726.h
  • ISPEECH1_G726_CompandingLaw : ispeech1_g726.h
  • ISPEECH1_G726_PackingType : ispeech1_g726.h
  • ISPEECH1_NullTrafficMode : ispeech1.h
  • ISPEECH1_PCM_CompandingLaw : ispeech1_pcm.h
  • ISPEECH1_PostFilter : ispeech1.h
  • ISPEECH1_SMV_DataMode : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMode : ispeech1_smv.h
  • ISPEECH1_SMV_Mode : ispeech1_smv.h
  • ISPEECH1_SMV_NoisePreProc : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMode : ispeech1_smv.h
  • ISPEECH1_SMV_VADSelect : ispeech1_smv.h
  • ISPEECH1_VADFlag : ispeech1.h
  • ISPEECH1_WBAMR_BitRate : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PackingType : ispeech1_wbamr.h
  • ISPEECH_CompoundLaw : ispeech.h
  • ISPEECH_VoiceMode : ispeech.h
  • ISPHDEC1_FrameType : isphdec1.h
  • ISPHENC1_FrameType : isphenc1.h
  • IVIDANALYTICS_ActionType : ividanalytics.h
  • IVIDANALYTICS_AnalysisMask : ividanalytics.h
  • IVIDANALYTICS_ObjectType : ividanalytics.h
  • IVIDANALYTICS_ViewState : ividanalytics.h
  • IVIDDEC1_FrameOrder : ividdec1.h
  • IVIDDEC2_FrameOrder : ividdec2.h
  • IVIDEO_ContentType : ivideo.h
  • IVIDEO_Format : ivideo.h
  • IVIDEO_FrameSkip : ivideo.h
  • IVIDEO_FrameType : ivideo.h
  • IVIDEO_OutputFrameStatus : ivideo.h
  • IVIDEO_PictureType : ivideo.h
  • IVIDEO_RateControlPreset : ivideo.h
  • IVIDEO_SkipMode : ivideo.h

- l -

  • LAD_DspState : ladclient.h
  • LAD_Status : ladclient.h

- m -

  • Memory_type : Memory.h

- s -

  • Server_Status : Server.h

- x -

  • XDM_AccessMode : xdm.h
  • XDM_ChromaFormat : xdm.h
  • XDM_CmdId : xdm.h
  • XDM_DataFormat : xdm.h
  • XDM_DecMode : xdm.h
  • XDM_EncMode : xdm.h
  • XDM_EncodingPreset : xdm.h
  • XDM_ErrorBit : xdm.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • l
  • m
  • s
  • x

- i -

  • IALG_DARAM0 : ialg.h
  • IALG_DARAM1 : ialg.h
  • IALG_DARAM2 : ialg.h
  • IALG_EPROG : ialg.h
  • IALG_ESDATA : ialg.h
  • IALG_EXTERNAL : ialg.h
  • IALG_IPROG : ialg.h
  • IALG_PERSIST : ialg.h
  • IALG_SARAM : ialg.h
  • IALG_SARAM0 : ialg.h
  • IALG_SARAM1 : ialg.h
  • IALG_SARAM2 : ialg.h
  • IALG_SCRATCH : ialg.h
  • IALG_WRITEONCE : ialg.h
  • IAUDIO_11_0 : iaudio.h
  • IAUDIO_1_0 : iaudio.h
  • IAUDIO_2_0 : iaudio.h
  • IAUDIO_2_1 : iaudio.h
  • IAUDIO_2_2 : iaudio.h
  • IAUDIO_2_3 : iaudio.h
  • IAUDIO_3_0 : iaudio.h
  • IAUDIO_3_1 : iaudio.h
  • IAUDIO_3_2 : iaudio.h
  • IAUDIO_3_3 : iaudio.h
  • IAUDIO_3_4 : iaudio.h
  • IAUDIO_BLOCK : iaudio.h
  • IAUDIO_CBR : iaudio.h
  • IAUDIO_DUALMONO_LEFT : iaudio.h
  • IAUDIO_DUALMONO_LR : iaudio.h
  • IAUDIO_DUALMONO_LR_MIX : iaudio.h
  • IAUDIO_DUALMONO_RIGHT : iaudio.h
  • IAUDIO_FIVE_ONE : iaudio.h
  • IAUDIO_FIVE_ZERO : iaudio.h
  • IAUDIO_INTERLEAVED : iaudio.h
  • IAUDIO_MONO : iaudio.h
  • IAUDIO_SEVEN_ONE : iaudio.h
  • IAUDIO_STEREO : iaudio.h
  • IAUDIO_THREE_ZERO : iaudio.h
  • IAUDIO_VBR : iaudio.h
  • ISPEECH1_AMR_BITRATE_10P2 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_12P2 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_4P75 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_5P15 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_5P9 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_6P7 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_7P4 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_7P95 : ispeech1_amr.h
  • ISPEECH1_AMR_BITRATE_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_CODECSELECT_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_CODECSELECT_PRIMARY : ispeech1_amr.h
  • ISPEECH1_AMR_CODECSELECT_SECONDARY : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_IF1_NOCRC : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_IF1_WITHCRC : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_IF2 : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPE_MIME : ispeech1_amr.h
  • ISPEECH1_AMR_PACKTYPEFORMAT_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_VADSELECT_DEFAULT : ispeech1_amr.h
  • ISPEECH1_AMR_VADSELECT_VAD1 : ispeech1_amr.h
  • ISPEECH1_AMR_VADSELECT_VAD2 : ispeech1_amr.h
  • ISPEECH1_EVRC_MODE_CAPACITYSAVE : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_DEFAULT : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_ECONOMY : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_HALFRATE_MAX : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_PREMIUM : ispeech1_evrc.h
  • ISPEECH1_EVRC_MODE_STANDARD : ispeech1_evrc.h
  • ISPEECH1_EVRC_NOISEPREPROC_DEFAULT : ispeech1_evrc.h
  • ISPEECH1_EVRC_NOISEPREPROC_OFF : ispeech1_evrc.h
  • ISPEECH1_EVRC_NOISEPREPROC_ON : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_45P45BPS : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_50BPS : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_DEFAULT : ispeech1_evrc.h
  • ISPEECH1_EVRC_TTYMODE_OFF : ispeech1_evrc.h
  • ISPEECH1_G723_BITRATE_5P3 : ispeech1_g723.h
  • ISPEECH1_G723_BITRATE_6P3 : ispeech1_g723.h
  • ISPEECH1_G723_BITRATE_DEFAULT : ispeech1_g723.h
  • ISPEECH1_G723_NOISEPREPROC_DEFAULT : ispeech1_g723.h
  • ISPEECH1_G723_NOISEPREPROC_OFF : ispeech1_g723.h
  • ISPEECH1_G723_NOISEPREPROC_ON : ispeech1_g723.h
  • ISPEECH1_G726_BITRATE_16 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_24 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_32 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_40 : ispeech1_g726.h
  • ISPEECH1_G726_BITRATE_DEFAULT : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_ALAW : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_DEFAULT : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_LINEAR : ispeech1_g726.h
  • ISPEECH1_G726_COMPAND_ULAW : ispeech1_g726.h
  • ISPEECH1_G726_PACKTYPE_LINEAR : ispeech1_g726.h
  • ISPEECH1_G726_PACKTYPE_RTPSPECIAL : ispeech1_g726.h
  • ISPEECH1_G726_PACKTYPEFORMAT_DEFAULT : ispeech1_g726.h
  • ISPEECH1_NULLTRAFFICMODE_DEFAULT : ispeech1.h
  • ISPEECH1_NULLTRAFFICMODE_OFF : ispeech1.h
  • ISPEECH1_NULLTRAFFICMODE_ON : ispeech1.h
  • ISPEECH1_PCM_COMPAND_ALAW : ispeech1_pcm.h
  • ISPEECH1_PCM_COMPAND_DEFAULT : ispeech1_pcm.h
  • ISPEECH1_PCM_COMPAND_LINEAR : ispeech1_pcm.h
  • ISPEECH1_PCM_COMPAND_ULAW : ispeech1_pcm.h
  • ISPEECH1_POSTFILTER_DEFAULT : ispeech1.h
  • ISPEECH1_POSTFILTER_OFF : ispeech1.h
  • ISPEECH1_POSTFILTER_ON : ispeech1.h
  • ISPEECH1_SMV_DATAMODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_FULLRATE : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_HALFRATE : ispeech1_smv.h
  • ISPEECH1_SMV_DATAMODE_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMODE_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_DTMFMODE_ON : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_CAPACITYSAVE : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_ECONOMY : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_PREMIUM : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_PREMIUM_HALFRATE_MAX : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_STANDARD : ispeech1_smv.h
  • ISPEECH1_SMV_MODE_STANDARD_HALFRATE_MAX : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_NSA : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_NSB : ispeech1_smv.h
  • ISPEECH1_SMV_NOISEPREPROC_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_45P45BPS : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_50BPS : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_TTYMODE_OFF : ispeech1_smv.h
  • ISPEECH1_SMV_VADSELECT_DEFAULT : ispeech1_smv.h
  • ISPEECH1_SMV_VADSELECT_VADA : ispeech1_smv.h
  • ISPEECH1_SMV_VADSELECT_VADB : ispeech1_smv.h
  • ISPEECH1_VADFLAG_DEFAULT : ispeech1.h
  • ISPEECH1_VADFLAG_OFF : ispeech1.h
  • ISPEECH1_VADFLAG_ON : ispeech1.h
  • ISPEECH1_WBAMR_BITRATE_12P65 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_14P25 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_15P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_18P25 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_19P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_23P05 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_23P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_6P60 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_8P85 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_BITRATE_DEFAULT : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_IF1_WITHCRC : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_IF2 : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPE_MIME : ispeech1_wbamr.h
  • ISPEECH1_WBAMR_PACKTYPEFORMAT_DEFAULT : ispeech1_wbamr.h
  • ISPEECH_ALAW : ispeech.h
  • ISPEECH_LINEAR : ispeech.h
  • ISPEECH_ULAW : ispeech.h
  • ISPEECH_UNVOICED : ispeech.h
  • ISPEECH_VOICED : ispeech.h
  • ISPHDEC1_FTYPE_BAD : isphdec1.h
  • ISPHDEC1_FTYPE_DEGRADED : isphdec1.h
  • ISPHDEC1_FTYPE_NODATA : isphdec1.h
  • ISPHDEC1_FTYPE_ONSET : isphdec1.h
  • ISPHDEC1_FTYPE_SIDBAD : isphdec1.h
  • ISPHDEC1_FTYPE_SIDFIRST : isphdec1.h
  • ISPHDEC1_FTYPE_SIDUPDATE : isphdec1.h
  • ISPHDEC1_FTYPE_SPEECHGOOD : isphdec1.h
  • ISPHDEC1_FTYPE_SPEECHLOST : isphdec1.h
  • ISPHENC1_FTYPE_NODATA : isphenc1.h
  • ISPHENC1_FTYPE_SIDFRAME : isphenc1.h
  • ISPHENC1_FTYPE_SPEECH : isphenc1.h
  • IVIDANALYTICS_ACTIONTYPE_APPEAR : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSD2U : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSL2R : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSR2L : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_CROSSU2D : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_DISAPPEAR : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_ENTER : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_EXIT : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_LOITER : ividanalytics.h
  • IVIDANALYTICS_ACTIONTYPE_USERBASE : ividanalytics.h
  • IVIDANALYTICS_MOTIONDETECT : ividanalytics.h
  • IVIDANALYTICS_OBJECTTRACKING : ividanalytics.h
  • IVIDANALYTICS_OBJECTTYPE_HUMAN : ividanalytics.h
  • IVIDANALYTICS_OBJECTTYPE_USERBASE : ividanalytics.h
  • IVIDANALYTICS_OBJECTTYPE_VEHICLE : ividanalytics.h
  • IVIDANALYTICS_USERBASE : ividanalytics.h
  • IVIDANALYTICS_VIEWSTATE_BAD : ividanalytics.h
  • IVIDANALYTICS_VIEWSTATE_GOOD : ividanalytics.h
  • IVIDDEC2_DECODE_ORDER : ividdec2.h
  • IVIDDEC2_DISPLAY_ORDER : ividdec2.h
  • IVIDDEC2_FRAMEORDER_DEFAULT : ividdec2.h
  • IVIDDEC_DECODE_ORDER : ividdec1.h
  • IVIDDEC_DISPLAY_ORDER : ividdec1.h
  • IVIDDEC_FRAMEORDER_DEFAULT : ividdec1.h
  • IVIDEO_B_FRAME : ivideo.h
  • IVIDEO_B_PICTURE : ivideo.h
  • IVIDEO_BB_FRAME : ivideo.h
  • IVIDEO_BI_FRAME : ivideo.h
  • IVIDEO_BP_FRAME : ivideo.h
  • IVIDEO_CONTENTTYPE_DEFAULT : ivideo.h
  • IVIDEO_CONTENTTYPE_NA : ivideo.h
  • IVIDEO_FRAME_ENCODED : ivideo.h
  • IVIDEO_FRAME_ERROR : ivideo.h
  • IVIDEO_FRAME_NOERROR : ivideo.h
  • IVIDEO_FRAME_NOTAVAILABLE : ivideo.h
  • IVIDEO_FRAME_SKIPPED : ivideo.h
  • IVIDEO_FRAMETYPE_DEFAULT : ivideo.h
  • IVIDEO_H264BP : ivideo.h
  • IVIDEO_H264HP : ivideo.h
  • IVIDEO_H264MP : ivideo.h
  • IVIDEO_I_FRAME : ivideo.h
  • IVIDEO_I_PICTURE : ivideo.h
  • IVIDEO_IB_FRAME : ivideo.h
  • IVIDEO_IDR_FRAME : ivideo.h
  • IVIDEO_II_FRAME : ivideo.h
  • IVIDEO_INTERLACED : ivideo.h
  • IVIDEO_INTERLACED_BOTTOMFIELD : ivideo.h
  • IVIDEO_INTERLACED_FRAME : ivideo.h
  • IVIDEO_INTERLACED_TOPFIELD : ivideo.h
  • IVIDEO_IP_FRAME : ivideo.h
  • IVIDEO_LOW_DELAY : ivideo.h
  • IVIDEO_MBAFF_B_FRAME : ivideo.h
  • IVIDEO_MBAFF_I_FRAME : ivideo.h
  • IVIDEO_MBAFF_IDR_FRAME : ivideo.h
  • IVIDEO_MBAFF_P_FRAME : ivideo.h
  • IVIDEO_MPEG1 : ivideo.h
  • IVIDEO_MPEG2HP : ivideo.h
  • IVIDEO_MPEG2MP : ivideo.h
  • IVIDEO_MPEG2SP : ivideo.h
  • IVIDEO_MPEG4ASP : ivideo.h
  • IVIDEO_MPEG4SP : ivideo.h
  • IVIDEO_NA_FRAME : ivideo.h
  • IVIDEO_NA_PICTURE : ivideo.h
  • IVIDEO_NO_SKIP : ivideo.h
  • IVIDEO_NONE : ivideo.h
  • IVIDEO_OUTPUTFRAMESTATUS_DEFAULT : ivideo.h
  • IVIDEO_P_FRAME : ivideo.h
  • IVIDEO_P_PICTURE : ivideo.h
  • IVIDEO_PB_FRAME : ivideo.h
  • IVIDEO_PI_FRAME : ivideo.h
  • IVIDEO_PICTURE_TYPE_DEFAULT : ivideo.h
  • IVIDEO_PP_FRAME : ivideo.h
  • IVIDEO_PROGRESSIVE : ivideo.h
  • IVIDEO_PROGRESSIVE_FRAME : ivideo.h
  • IVIDEO_RATECONTROLPRESET_DEFAULT : ivideo.h
  • IVIDEO_SKIP_B : ivideo.h
  • IVIDEO_SKIP_DEFAULT : ivideo.h
  • IVIDEO_SKIP_I : ivideo.h
  • IVIDEO_SKIP_IB : ivideo.h
  • IVIDEO_SKIP_IDR : ivideo.h
  • IVIDEO_SKIP_IP : ivideo.h
  • IVIDEO_SKIP_IPB : ivideo.h
  • IVIDEO_SKIP_P : ivideo.h
  • IVIDEO_SKIP_PB : ivideo.h
  • IVIDEO_SKIPMODE_DEFAULT : ivideo.h
  • IVIDEO_STORAGE : ivideo.h
  • IVIDEO_TWOPASS : ivideo.h
  • IVIDEO_USER_DEFINED : ivideo.h
  • IVIDEO_VC1AP : ivideo.h
  • IVIDEO_VC1MP : ivideo.h
  • IVIDEO_VC1SP : ivideo.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • l
  • m
  • s
  • x

- l -

  • LAD_ACCESSDENIED : ladclient.h
  • LAD_ALREADYRUNNING : ladclient.h
  • LAD_FAILURE : ladclient.h
  • LAD_IDLE : ladclient.h
  • LAD_INVALIDARG : ladclient.h
  • LAD_INVALIDVERSION : ladclient.h
  • LAD_IOFAILURE : ladclient.h
  • LAD_LOADED : ladclient.h
  • LAD_NOTCONNECTED : ladclient.h
  • LAD_RESET : ladclient.h
  • LAD_SETUP : ladclient.h
  • LAD_STARTED : ladclient.h
  • LAD_STILLRUNNING : ladclient.h
  • LAD_STOPPED : ladclient.h
  • LAD_SUCCESS : ladclient.h
  • LAD_UNAVAILABLE : ladclient.h
  • LAD_UNKNOWN : ladclient.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • l
  • m
  • s
  • x

- m -

  • Memory_CONTIGHEAP : Memory.h
  • Memory_CONTIGPOOL : Memory.h
  • Memory_MALLOC : Memory.h
  • Memory_SEG : Memory.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • l
  • m
  • s
  • x

- s -

  • Server_EFAIL : Server.h
  • Server_EINUSE : Server.h
  • Server_EINVAL : Server.h
  • Server_ENOMEM : Server.h
  • Server_ENOSERVER : Server.h
  • Server_ENOTFOUND : Server.h
  • Server_EOK : Server.h
  • Server_ERUNTIME : Server.h
  • Server_EWRONGSTATE : Server.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • i
  • l
  • m
  • s
  • x

- x -

  • XDM_ACCESSMODE_READ : xdm.h
  • XDM_ACCESSMODE_WRITE : xdm.h
  • XDM_APPLIEDCONCEALMENT : xdm.h
  • XDM_ARGB8888 : xdm.h
  • XDM_BE_16 : xdm.h
  • XDM_BE_32 : xdm.h
  • XDM_BE_64 : xdm.h
  • XDM_BYTE : xdm.h
  • XDM_CHROMA_NA : xdm.h
  • XDM_CHROMAFORMAT_DEFAULT : xdm.h
  • XDM_CORRUPTEDDATA : xdm.h
  • XDM_CORRUPTEDHEADER : xdm.h
  • XDM_DECODE_AU : xdm.h
  • XDM_DEFAULT : xdm.h
  • XDM_ENCODE_AU : xdm.h
  • XDM_FATALERROR : xdm.h
  • XDM_FLUSH : xdm.h
  • XDM_GENERATE_HEADER : xdm.h
  • XDM_GETBUFINFO : xdm.h
  • XDM_GETCONTEXTINFO : xdm.h
  • XDM_GETSTATUS : xdm.h
  • XDM_GETVERSION : xdm.h
  • XDM_GRAY : xdm.h
  • XDM_HIGH_QUALITY : xdm.h
  • XDM_HIGH_SPEED : xdm.h
  • XDM_INSUFFICIENTDATA : xdm.h
  • XDM_LE_16 : xdm.h
  • XDM_LE_32 : xdm.h
  • XDM_LE_64 : xdm.h
  • XDM_PARAMSCHANGE : xdm.h
  • XDM_PARSE_HEADER : xdm.h
  • XDM_RESET : xdm.h
  • XDM_RGB : xdm.h
  • XDM_RGB555 : xdm.h
  • XDM_RGB565 : xdm.h
  • XDM_SETDEFAULT : xdm.h
  • XDM_SETPARAMS : xdm.h
  • XDM_UNSUPPORTEDINPUT : xdm.h
  • XDM_UNSUPPORTEDPARAM : xdm.h
  • XDM_USER_DEFINED : xdm.h
  • XDM_YUV_411P : xdm.h
  • XDM_YUV_420P : xdm.h
  • XDM_YUV_420SP : xdm.h
  • XDM_YUV_422IBE : xdm.h
  • XDM_YUV_422ILE : xdm.h
  • XDM_YUV_422P : xdm.h
  • XDM_YUV_444ILE : xdm.h
  • XDM_YUV_444P : xdm.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • e
  • i
  • l
  • m
  • s
  • t
  • u
  • v

- a -

  • AUDDEC1_control() : auddec1.h
  • AUDDEC1_create() : auddec1.h
  • AUDDEC1_delete() : auddec1.h
  • AUDDEC1_process() : auddec1.h
  • AUDDEC1_processAsync() : auddec1.h
  • AUDDEC1_processWait() : auddec1.h
  • AUDDEC_control() : auddec.h
  • AUDDEC_create() : auddec.h
  • AUDDEC_delete() : auddec.h
  • AUDDEC_process() : auddec.h
  • AUDDEC_processAsync() : auddec.h
  • AUDDEC_processWait() : auddec.h
  • AUDENC1_control() : audenc1.h
  • AUDENC1_create() : audenc1.h
  • AUDENC1_delete() : audenc1.h
  • AUDENC1_process() : audenc1.h
  • AUDENC1_processAsync() : audenc1.h
  • AUDENC1_processWait() : audenc1.h
  • AUDENC_control() : audenc.h
  • AUDENC_create() : audenc.h
  • AUDENC_delete() : audenc.h
  • AUDENC_process() : audenc.h
  • AUDENC_processAsync() : audenc.h
  • AUDENC_processWait() : audenc.h

- c -

  • CERuntime_exit() : CERuntime.h
  • CERuntime_init() : CERuntime.h

- e -

  • Engine_close() : Engine.h
  • Engine_fwriteTrace() : Engine.h
  • Engine_getAlgInfo() : Engine.h
  • Engine_getAlgInfo2() : Engine.h
  • Engine_getCpuLoad() : Engine.h
  • Engine_getLastError() : Engine.h
  • Engine_getName() : Engine.h
  • Engine_getNumAlgs() : Engine.h
  • Engine_getNumAlgs2() : Engine.h
  • Engine_getServer() : Engine.h
  • Engine_getUsedMem() : Engine.h
  • Engine_open() : Engine.h
  • Engine_setTrace() : Engine.h

- i -

  • IMGDEC1_control() : imgdec1.h
  • IMGDEC1_create() : imgdec1.h
  • IMGDEC1_delete() : imgdec1.h
  • IMGDEC1_process() : imgdec1.h
  • IMGDEC1_processAsync() : imgdec1.h
  • IMGDEC1_processWait() : imgdec1.h
  • IMGDEC_control() : imgdec.h
  • IMGDEC_create() : imgdec.h
  • IMGDEC_delete() : imgdec.h
  • IMGDEC_process() : imgdec.h
  • IMGDEC_processAsync() : imgdec.h
  • IMGDEC_processWait() : imgdec.h
  • IMGENC1_control() : imgenc1.h
  • IMGENC1_create() : imgenc1.h
  • IMGENC1_delete() : imgenc1.h
  • IMGENC1_process() : imgenc1.h
  • IMGENC1_processAsync() : imgenc1.h
  • IMGENC1_processWait() : imgenc1.h
  • IMGENC_control() : imgenc.h
  • IMGENC_create() : imgenc.h
  • IMGENC_delete() : imgenc.h
  • IMGENC_process() : imgenc.h
  • IMGENC_processAsync() : imgenc.h
  • IMGENC_processWait() : imgenc.h

- l -

  • LAD_connect() : ladclient.h
  • LAD_disconnect() : ladclient.h
  • LAD_getDspStatus() : ladclient.h
  • LAD_releaseDsp() : ladclient.h
  • LAD_startupDsp() : ladclient.h

- m -

  • Memory_alloc() : Memory.h
  • Memory_cacheInv() : Memory.h
  • Memory_cacheWb() : Memory.h
  • Memory_cacheWbInv() : Memory.h
  • Memory_contigAlloc() : Memory.h
  • Memory_contigFree() : Memory.h
  • Memory_dumpKnownContigBufsList() : Memory.h
  • Memory_free() : Memory.h
  • Memory_getBufferPhysicalAddress() : Memory.h
  • Memory_getBufferVirtualAddress() : Memory.h
  • Memory_getHeapId() : Memory.h
  • Memory_getNumHeaps() : Memory.h
  • Memory_registerContigBuf() : Memory.h
  • Memory_unregisterContigBuf() : Memory.h

- s -

  • Server_connectTrace() : Server.h
  • Server_disconnectTrace() : Server.h
  • Server_fwriteTrace() : Server.h
  • Server_getAlgInfo() : Server.h
  • Server_getCpuLoad() : Server.h
  • Server_getMemStat() : Server.h
  • Server_getNumAlgs() : Server.h
  • Server_getNumMemSegs() : Server.h
  • Server_redefineHeap() : Server.h
  • Server_restoreHeap() : Server.h
  • Server_setTrace() : Server.h
  • SPHDEC1_control() : sphdec1.h
  • SPHDEC1_create() : sphdec1.h
  • SPHDEC1_delete() : sphdec1.h
  • SPHDEC1_process() : sphdec1.h
  • SPHDEC1_processAsync() : sphdec1.h
  • SPHDEC1_processWait() : sphdec1.h
  • SPHDEC_control() : sphdec.h
  • SPHDEC_create() : sphdec.h
  • SPHDEC_delete() : sphdec.h
  • SPHDEC_process() : sphdec.h
  • SPHDEC_processAsync() : sphdec.h
  • SPHDEC_processWait() : sphdec.h
  • SPHENC1_control() : sphenc1.h
  • SPHENC1_create() : sphenc1.h
  • SPHENC1_delete() : sphenc1.h
  • SPHENC1_process() : sphenc1.h
  • SPHENC1_processAsync() : sphenc1.h
  • SPHENC1_processWait() : sphenc1.h
  • SPHENC_control() : sphenc.h
  • SPHENC_create() : sphenc.h
  • SPHENC_delete() : sphenc.h
  • SPHENC_process() : sphenc.h
  • SPHENC_processAsync() : sphenc.h
  • SPHENC_processWait() : sphenc.h

- t -

  • TraceUtil_start() : TraceUtil.h
  • TraceUtil_stop() : TraceUtil.h

- u -

  • UNIVERSAL_control() : universal.h
  • UNIVERSAL_create() : universal.h
  • UNIVERSAL_delete() : universal.h
  • UNIVERSAL_process() : universal.h
  • UNIVERSAL_processAsync() : universal.h
  • UNIVERSAL_processWait() : universal.h

- v -

  • VIDANALYTICS_control() : vidanalytics.h
  • VIDANALYTICS_create() : vidanalytics.h
  • VIDANALYTICS_delete() : vidanalytics.h
  • VIDANALYTICS_process() : vidanalytics.h
  • VIDANALYTICS_processAsync() : vidanalytics.h
  • VIDANALYTICS_processWait() : vidanalytics.h
  • VIDDEC1_control() : viddec1.h
  • VIDDEC1_create() : viddec1.h
  • VIDDEC1_delete() : viddec1.h
  • VIDDEC1_process() : viddec1.h
  • VIDDEC1_processAsync() : viddec1.h
  • VIDDEC1_processWait() : viddec1.h
  • VIDDEC2_control() : viddec2.h
  • VIDDEC2_create() : viddec2.h
  • VIDDEC2_delete() : viddec2.h
  • VIDDEC2_process() : viddec2.h
  • VIDDEC2_processAsync() : viddec2.h
  • VIDDEC2_processWait() : viddec2.h
  • VIDDEC2BACK_control() : split/viddec2.h
  • VIDDEC2BACK_create() : split/viddec2.h
  • VIDDEC2BACK_delete() : split/viddec2.h
  • VIDDEC2BACK_process() : split/viddec2.h
  • VIDDEC2FRONT_control() : split/viddec2.h
  • VIDDEC2FRONT_create() : split/viddec2.h
  • VIDDEC2FRONT_delete() : split/viddec2.h
  • VIDDEC2FRONT_process() : split/viddec2.h
  • VIDDEC_control() : viddec.h
  • VIDDEC_create() : viddec.h
  • VIDDEC_delete() : viddec.h
  • VIDDEC_process() : viddec.h
  • VIDDEC_processAsync() : viddec.h
  • VIDDEC_processWait() : viddec.h
  • VIDENC1_control() : videnc1.h
  • VIDENC1_create() : videnc1.h
  • VIDENC1_delete() : videnc1.h
  • VIDENC1_process() : videnc1.h
  • VIDENC1_processAsync() : videnc1.h
  • VIDENC1_processWait() : videnc1.h
  • VIDENC_control() : videnc.h
  • VIDENC_create() : videnc.h
  • VIDENC_delete() : videnc.h
  • VIDENC_process() : videnc.h
  • VIDENC_processAsync() : videnc.h
  • VIDENC_processWait() : videnc.h
  • VIDTRANSCODE_control() : vidtranscode.h
  • VIDTRANSCODE_create() : vidtranscode.h
  • VIDTRANSCODE_delete() : vidtranscode.h
  • VIDTRANSCODE_process() : vidtranscode.h
  • VIDTRANSCODE_processAsync() : vidtranscode.h
  • VIDTRANSCODE_processWait() : vidtranscode.h
  • VISA_allocMsg() : visa.h
  • VISA_call() : visa.h
  • VISA_callAsync() : visa.h
  • VISA_create() : visa.h
  • VISA_create2() : visa.h
  • VISA_delete() : visa.h
  • VISA_enter() : visa.h
  • VISA_exit() : visa.h
  • VISA_freeMsg() : visa.h
  • VISA_getAlgFxns() : visa.h
  • VISA_getAlgHandle() : visa.h
  • VISA_getAlgMemRecs() : visa.h
  • VISA_getAlgNumRecs() : visa.h
  • VISA_getAlgorithmHandle() : visa.h
  • VISA_getCodecClassConfig() : visa.h
  • VISA_getContext() : visa.h
  • VISA_getMaxMsgSize() : visa.h
  • VISA_isLocal() : visa.h
  • VISA_setContext() : visa.h
  • VISA_wait() : visa.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- a -

  • AUDDEC1_Cmd : auddec1.h
  • AUDDEC1_DynamicParams : auddec1.h
  • AUDDEC1_Handle : auddec1.h
  • AUDDEC1_InArgs : auddec1.h
  • AUDDEC1_OutArgs : auddec1.h
  • AUDDEC1_Params : auddec1.h
  • AUDDEC1_Status : auddec1.h
  • AUDDEC_Cmd : auddec.h
  • AUDDEC_DynamicParams : auddec.h
  • AUDDEC_Handle : auddec.h
  • AUDDEC_InArgs : auddec.h
  • AUDDEC_OutArgs : auddec.h
  • AUDDEC_Params : auddec.h
  • AUDDEC_Status : auddec.h
  • AUDENC1_Cmd : audenc1.h
  • AUDENC1_DynamicParams : audenc1.h
  • AUDENC1_Handle : audenc1.h
  • AUDENC1_InArgs : audenc1.h
  • AUDENC1_OutArgs : audenc1.h
  • AUDENC1_Params : audenc1.h
  • AUDENC1_Status : audenc1.h
  • AUDENC_Cmd : audenc.h
  • AUDENC_DynamicParams : audenc.h
  • AUDENC_Handle : audenc.h
  • AUDENC_InArgs : audenc.h
  • AUDENC_OutArgs : audenc.h
  • AUDENC_Params : audenc.h
  • AUDENC_Status : audenc.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- l -

  • LAD_ClientHandle : ladclient.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- e -

  • Engine_Error : Engine.h
  • Engine_Handle : Engine.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- i -

  • IALG_Cmd : ialg.h
  • IALG_Handle : ialg.h
  • IAUDDEC1_Cmd : iauddec1.h
  • IAUDDEC1_Handle : iauddec1.h
  • IAUDDEC_Cmd : iauddec.h
  • IAUDDEC_Handle : iauddec.h
  • IAUDENC1_Cmd : iaudenc1.h
  • IAUDENC1_Handle : iaudenc1.h
  • IAUDENC_Cmd : iaudenc.h
  • IAUDENC_Handle : iaudenc.h
  • IIMGDEC1_Cmd : iimgdec1.h
  • IIMGDEC1_Handle : iimgdec1.h
  • IIMGDEC_Cmd : iimgdec.h
  • IIMGDEC_Handle : iimgdec.h
  • IIMGENC1_Cmd : iimgenc1.h
  • IIMGENC1_Handle : iimgenc1.h
  • IIMGENC_Cmd : iimgenc.h
  • IIMGENC_Handle : iimgenc.h
  • IMGDEC1_Cmd : imgdec1.h
  • IMGDEC1_DynamicParams : imgdec1.h
  • IMGDEC1_Handle : imgdec1.h
  • IMGDEC1_InArgs : imgdec1.h
  • IMGDEC1_OutArgs : imgdec1.h
  • IMGDEC1_Params : imgdec1.h
  • IMGDEC1_Status : imgdec1.h
  • IMGDEC_Cmd : imgdec.h
  • IMGDEC_DynamicParams : imgdec.h
  • IMGDEC_Handle : imgdec.h
  • IMGDEC_InArgs : imgdec.h
  • IMGDEC_OutArgs : imgdec.h
  • IMGDEC_Params : imgdec.h
  • IMGDEC_Status : imgdec.h
  • IMGENC1_Cmd : imgenc1.h
  • IMGENC1_DynamicParams : imgenc1.h
  • IMGENC1_Handle : imgenc1.h
  • IMGENC1_InArgs : imgenc1.h
  • IMGENC1_OutArgs : imgenc1.h
  • IMGENC1_Params : imgenc1.h
  • IMGENC1_Status : imgenc1.h
  • IMGENC_Cmd : imgenc.h
  • IMGENC_DynamicParams : imgenc.h
  • IMGENC_Handle : imgenc.h
  • IMGENC_InArgs : imgenc.h
  • IMGENC_OutArgs : imgenc.h
  • IMGENC_Params : imgenc.h
  • IMGENC_Status : imgenc.h
  • ISPHDEC1_Cmd : isphdec1.h
  • ISPHDEC1_Handle : isphdec1.h
  • ISPHDEC_Cmd : isphdec.h
  • ISPHDEC_Handle : isphdec.h
  • ISPHENC1_Cmd : isphenc1.h
  • ISPHENC1_Handle : isphenc1.h
  • ISPHENC_Cmd : isphenc.h
  • ISPHENC_Handle : isphenc.h
  • IUNIVERSAL_Cmd : iuniversal.h
  • IUNIVERSAL_Handle : iuniversal.h
  • IVIDANALYTICS_Cmd : ividanalytics.h
  • IVIDANALYTICS_Handle : ividanalytics.h
  • IVIDDEC1_Cmd : ividdec1.h
  • IVIDDEC1_Handle : ividdec1.h
  • IVIDDEC2_Cmd : ividdec2.h
  • IVIDDEC2_Handle : ividdec2.h
  • IVIDDEC2BACK_Handle : split/ividdec2.h
  • IVIDDEC2FRONT_Handle : split/ividdec2.h
  • IVIDDEC_Cmd : ividdec.h
  • IVIDDEC_Handle : ividdec.h
  • IVIDENC1_Cmd : ividenc1.h
  • IVIDENC1_Handle : ividenc1.h
  • IVIDENC_Cmd : ividenc.h
  • IVIDENC_Handle : ividenc.h
  • IVIDTRANSCODE_Cmd : ividtranscode.h
  • IVIDTRANSCODE_Handle : ividtranscode.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- s -

  • Server_Handle : Server.h
  • SPHDEC1_Cmd : sphdec1.h
  • SPHDEC1_DynamicParams : sphdec1.h
  • SPHDEC1_Handle : sphdec1.h
  • SPHDEC1_InArgs : sphdec1.h
  • SPHDEC1_OutArgs : sphdec1.h
  • SPHDEC1_Params : sphdec1.h
  • SPHDEC1_Status : sphdec1.h
  • SPHDEC_Cmd : sphdec.h
  • SPHDEC_DynamicParams : sphdec.h
  • SPHDEC_Handle : sphdec.h
  • SPHDEC_InArgs : sphdec.h
  • SPHDEC_OutArgs : sphdec.h
  • SPHDEC_Params : sphdec.h
  • SPHDEC_Status : sphdec.h
  • SPHENC1_Cmd : sphenc1.h
  • SPHENC1_DynamicParams : sphenc1.h
  • SPHENC1_Handle : sphenc1.h
  • SPHENC1_InArgs : sphenc1.h
  • SPHENC1_OutArgs : sphenc1.h
  • SPHENC1_Params : sphenc1.h
  • SPHENC1_Status : sphenc1.h
  • SPHENC_Cmd : sphenc.h
  • SPHENC_DynamicParams : sphenc.h
  • SPHENC_Handle : sphenc.h
  • SPHENC_InArgs : sphenc.h
  • SPHENC_OutArgs : sphenc.h
  • SPHENC_Params : sphenc.h
  • SPHENC_Status : sphenc.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- u -

  • UNIVERSAL_Cmd : universal.h
  • UNIVERSAL_DynamicParams : universal.h
  • UNIVERSAL_Handle : universal.h
  • UNIVERSAL_InArgs : universal.h
  • UNIVERSAL_OutArgs : universal.h
  • UNIVERSAL_Params : universal.h
  • UNIVERSAL_Status : universal.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- v -

  • VIDANALYTICS_Cmd : vidanalytics.h
  • VIDANALYTICS_DynamicParams : vidanalytics.h
  • VIDANALYTICS_Handle : vidanalytics.h
  • VIDANALYTICS_InArgs : vidanalytics.h
  • VIDANALYTICS_OutArgs : vidanalytics.h
  • VIDANALYTICS_Params : vidanalytics.h
  • VIDANALYTICS_Status : vidanalytics.h
  • VIDDEC1_Cmd : viddec1.h
  • VIDDEC1_DynamicParams : viddec1.h
  • VIDDEC1_Handle : viddec1.h
  • VIDDEC1_InArgs : viddec1.h
  • VIDDEC1_OutArgs : viddec1.h
  • VIDDEC1_Params : viddec1.h
  • VIDDEC1_Status : viddec1.h
  • VIDDEC2_Cmd : viddec2.h
  • VIDDEC2_DynamicParams : viddec2.h
  • VIDDEC2_Handle : viddec2.h
  • VIDDEC2_InArgs : viddec2.h
  • VIDDEC2_OutArgs : viddec2.h
  • VIDDEC2_Params : viddec2.h
  • VIDDEC2_Status : viddec2.h
  • VIDDEC2BACK_Handle : split/viddec2.h
  • VIDDEC2FRONT_Handle : split/viddec2.h
  • VIDDEC2FRONT_OutArgs : split/viddec2.h
  • VIDDEC2FRONT_Status : split/viddec2.h
  • VIDDEC_Cmd : viddec.h
  • VIDDEC_DynamicParams : viddec.h
  • VIDDEC_Handle : viddec.h
  • VIDDEC_InArgs : viddec.h
  • VIDDEC_OutArgs : viddec.h
  • VIDDEC_Params : viddec.h
  • VIDDEC_Status : viddec.h
  • VIDENC1_Cmd : videnc1.h
  • VIDENC1_DynamicParams : videnc1.h
  • VIDENC1_Handle : videnc1.h
  • VIDENC1_InArgs : videnc1.h
  • VIDENC1_OutArgs : videnc1.h
  • VIDENC1_Params : videnc1.h
  • VIDENC1_Status : videnc1.h
  • VIDENC_Cmd : videnc.h
  • VIDENC_DynamicParams : videnc.h
  • VIDENC_Handle : videnc.h
  • VIDENC_InArgs : videnc.h
  • VIDENC_OutArgs : videnc.h
  • VIDENC_Params : videnc.h
  • VIDENC_Status : videnc.h
  • VIDTRANSCODE_Cmd : vidtranscode.h
  • VIDTRANSCODE_DynamicParams : vidtranscode.h
  • VIDTRANSCODE_Handle : vidtranscode.h
  • VIDTRANSCODE_InArgs : vidtranscode.h
  • VIDTRANSCODE_OutArgs : vidtranscode.h
  • VIDTRANSCODE_Params : vidtranscode.h
  • VIDTRANSCODE_Status : vidtranscode.h
  • VISA_Handle : visa.h
  • VISA_Msg : visa.h
  • VISA_Status : visa.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • e
  • i
  • l
  • s
  • u
  • v
  • x

- x -

  • XDAS_Bool : xdas.h
  • XDAS_Int16 : xdas.h
  • XDAS_Int32 : xdas.h
  • XDAS_Int8 : xdas.h
  • XDAS_UInt16 : xdas.h
  • XDAS_UInt32 : xdas.h
  • XDAS_UInt8 : xdas.h
  • XDAS_Void : xdas.h


Codec Engine Application Programming Interface (API): Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • Engine_ATTRS : Engine.h
  • Memory_DEFAULTPARAMS : Memory.h


Codec Engine Application Programming Interface (API): Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.


Codec Engine Application Programming Interface (API): ialg.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais

ialg.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_IALG_
00047 #define ti_xdais_IALG_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00055
00056 /*---------------------------*/
00057 /*    TYPES AND CONSTANTS    */
00058 /*---------------------------*/
00059
00060 #define IALG_DEFMEMRECS 4
00061 #define IALG_OBJMEMREC  0
00062 #define IALG_SYSCMD     256
00064 #define IALG_EOK        0
00065 #define IALG_EFAIL      -1
00067 #define IALG_CUSTOMFAILBASE  -2048
00071 #define IALG_CUSTOMFAILEND -256
00079 typedef enum IALG_MemAttrs {
00080     IALG_SCRATCH,
00081     IALG_PERSIST,
00082     IALG_WRITEONCE
00083 } IALG_MemAttrs;
00084
00085 #define IALG_MPROG  0x0008
00086 #define IALG_MXTRN  0x0010
00091 /*
00092  *  ======== IALG_MemSpace ========
00093  */
00094 typedef enum IALG_MemSpace {
00095     IALG_EPROG =
00096         IALG_MPROG | IALG_MXTRN,
00097
00098     IALG_IPROG =
00099         IALG_MPROG,
00100
00101     IALG_ESDATA =
00102         IALG_MXTRN + 0,
00103
00104     IALG_EXTERNAL =
00105         IALG_MXTRN + 1,
00106
00107     IALG_DARAM0 = 0,
00108     IALG_DARAM1 = 1,
00110     IALG_SARAM  = 2,
00111     IALG_SARAM0 = 2,
00112     IALG_SARAM1 = 3,
00114     IALG_DARAM2 = 4,
00115     IALG_SARAM2 = 5
00116 } IALG_MemSpace;
00117
00118 /*
00119  *  ======== IALG_isProg ========
00120  */
00121 #define IALG_isProg(s) (        \
00122     (((int)(s)) & IALG_MPROG)   \
00123 )
00124
00125 /*
00126  *  ======== IALG_isOffChip ========
00127  */
00128 #define IALG_isOffChip(s) (     \
00129     (((int)(s)) & IALG_MXTRN)   \
00130 )
00131
00132
00136 typedef struct IALG_MemRec {
00137     Uns             size;
00138     Int             alignment;
00139     IALG_MemSpace   space;
00140     IALG_MemAttrs   attrs;
00141     Void            *base;
00142 } IALG_MemRec;
00143
00144
00153 typedef struct IALG_Obj {
00154     struct IALG_Fxns *fxns;
00155 } IALG_Obj;
00156
00157
00161 typedef struct IALG_Obj *IALG_Handle;
00162
00163
00170 typedef struct IALG_Params {
00171     Int size;
00172 } IALG_Params;
00173
00174
00181 typedef struct IALG_Status {
00182     Int size;
00183 } IALG_Status;
00184
00185
00193 typedef unsigned int IALG_Cmd;
00194
00195
00200 /*
00201  *      algAlloc()        - apps call this to query the algorithm about
00202  *                          its memory requirements. Must be non-NULL.
00203  *      algControl()      - algorithm specific control operations.  May be
00204  *                          NULL; NULL => no operations supported.
00205  *      algDeactivate()   - notification that current instance is about to
00206  *                          be "deactivated".  May be NULL; NULL => do nothing.
00207  *      algFree()         - query algorithm for memory to free when removing
00208  *                          an instance.  Must be non-NULL.
00209  *      algInit()         - apps call this to allow the algorithm to
00210  *                          initialize memory requested via algAlloc().  Must
00211  *                          be non-NULL.
00212  *      algMoved()        - apps call this whenever an algorithms object or
00213  *                          any pointer parameters are moved in real-time.
00214  *                          May be NULL; NULL => object can not be moved.
00215  *      algNumAlloc()     - query algorithm for number of memory requests.
00216  *                          May be NULL; NULL => number of mem recs is less
00217  *                          then #IALG_DEFMEMRECS.
00218  */
00219 typedef struct IALG_Fxns {
00224     Void    *implementationId;
00225
00275     Void    (*algActivate)(IALG_Handle handle);
00276
00355     Int     (*algAlloc)(const IALG_Params *params,
00356         struct IALG_Fxns **parentFxns, IALG_MemRec *memTab);
00357
00398     Int     (*algControl)(IALG_Handle handle, IALG_Cmd cmd,
00399         IALG_Status *status);
00400
00454     Void    (*algDeactivate)(IALG_Handle handle);
00455
00496     Int     (*algFree)(IALG_Handle handle, IALG_MemRec *memTab);
00497
00671     Int     (*algInit)(IALG_Handle handle, const IALG_MemRec *memTab,
00672         IALG_Handle parent, const IALG_Params *params);
00673
00694     Void    (*algMoved)(IALG_Handle handle, const IALG_MemRec *memTab,
00695         IALG_Handle parent, const IALG_Params *params);
00696
00753     Int     (*algNumAlloc)(Void);
00754 } IALG_Fxns;
00755
00758 #ifdef __cplusplus
00759 }
00760 #endif
00761
00762 #endif  /* ti_xdais_IALG_ */
00763 /*
00764  *  @(#) ti.xdais; 1, 2.0, 1,249; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00765
00766  */
00767


Codec Engine Application Programming Interface (API): iauddec1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iauddec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IAUDDEC1_
00048 #define ti_xdais_dm_IAUDDEC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "iaudio.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00063 #define IAUDDEC1_EOK      XDM_EOK
00064 #define IAUDDEC1_EFAIL    XDM_EFAIL
00065 #define IAUDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED
00071 typedef struct IAUDDEC1_Obj {
00072     struct IAUDDEC1_Fxns *fxns;
00073 } IAUDDEC1_Obj;
00074
00075
00079 typedef struct IAUDDEC1_Obj  *IAUDDEC1_Handle;
00080
00081
00088 typedef struct IAUDDEC1_Params {
00089     XDAS_Int32 size;
00090     XDAS_Int32 outputPCMWidth;
00091     XDAS_Int32 pcmFormat;
00095     XDAS_Int32 dataEndianness;
00099 } IAUDDEC1_Params;
00100
00101
00116 typedef struct IAUDDEC1_DynamicParams {
00117     XDAS_Int32 size;
00118     XDAS_Int32 downSampleSbrFlag;
00123 } IAUDDEC1_DynamicParams;
00124
00125
00134 typedef struct IAUDDEC1_InArgs {
00135     XDAS_Int32 size;
00136     XDAS_Int32 numBytes;
00139     XDAS_Int32 desiredChannelMode;
00143     XDAS_Int32 lfeFlag;
00149 } IAUDDEC1_InArgs;
00150
00151
00159 typedef struct IAUDDEC1_Status {
00160     XDAS_Int32 size;
00161     XDAS_Int32 extendedError;
00162     XDM1_SingleBufDesc data;
00178     XDAS_Int32 validFlag;
00201     XDAS_Int32 lfeFlag;
00209     XDAS_Int32 bitRate;
00210     XDAS_Int32 sampleRate;
00215     XDAS_Int32 channelMode;
00219     XDAS_Int32 pcmFormat;
00223     XDAS_Int32 numSamples;
00224     XDAS_Int32 outputBitsPerSample;
00229     XDM_AlgBufInfo  bufInfo;
00233     XDAS_Int32 dualMonoMode;
00238 } IAUDDEC1_Status;
00239
00240
00249 typedef struct IAUDDEC1_OutArgs {
00250     XDAS_Int32 size;
00251     XDAS_Int32 extendedError;
00252     XDAS_Int32 bytesConsumed;
00255     XDAS_Int32 numSamples;
00256     XDAS_Int32 channelMode;
00260     XDAS_Int32 lfeFlag;
00268     XDAS_Int32 dualMonoMode;
00273     XDAS_Int32 sampleRate;
00278 } IAUDDEC1_OutArgs;
00279
00280
00291 typedef  IALG_Cmd IAUDDEC1_Cmd;
00292
00293
00297 typedef struct IAUDDEC1_Fxns{
00298     IALG_Fxns   ialg;
00369     XDAS_Int32   (*process)(IAUDDEC1_Handle handle, XDM1_BufDesc *inBufs,
00370         XDM1_BufDesc *outBufs, IAUDDEC1_InArgs *inArgs,
00371         IAUDDEC1_OutArgs *outArgs);
00372
00373
00409     XDAS_Int32   (*control)(IAUDDEC1_Handle handle, IAUDDEC1_Cmd id,
00410         IAUDDEC1_DynamicParams *params, IAUDDEC1_Status *status);
00411
00412 } IAUDDEC1_Fxns;
00413
00414
00417 #ifdef __cplusplus
00418 }
00419 #endif
00420
00421 #endif
00422 /*
00423  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:03; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00424
00425  */
00426


Codec Engine Application Programming Interface (API): iauddec.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iauddec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_IAUDDEC_
00051 #define ti_xdais_dm_IAUDDEC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064 #include "iaudio.h"
00065
00066 #ifdef __cplusplus
00067 extern "C" {
00068 #endif
00069
00072
00073 #define IAUDDEC_CID      "ti.xdais.dm.IAUDDEC"
00075 #define IAUDDEC_ERUNTIME  XDM_ERUNTIME
00076 #define IAUDDEC_EOK       XDM_EOK
00077 #define IAUDDEC_EFAIL     XDM_EFAIL
00083 typedef struct IAUDDEC_Obj {
00084     struct IAUDDEC_Fxns *fxns;
00085 } IAUDDEC_Obj;
00086
00087
00091 typedef struct IAUDDEC_Obj  *IAUDDEC_Handle;
00092
00093
00103 typedef struct IAUDDEC_Params {
00104     XDAS_Int32 size;
00105     XDAS_Int32 maxSampleRate;
00110     XDAS_Int32 maxBitrate;
00115     XDAS_Int32 maxNoOfCh;
00118     XDAS_Int32 dataEndianness;
00122 } IAUDDEC_Params;
00123
00124
00139 typedef struct IAUDDEC_DynamicParams {
00140     XDAS_Int32 size;
00141     XDAS_Int32 outputFormat;
00144 } IAUDDEC_DynamicParams;
00145
00146
00155 typedef struct IAUDDEC_InArgs {
00156     XDAS_Int32 size;
00157     XDAS_Int32 numBytes;
00160 } IAUDDEC_InArgs;
00161
00162
00170 typedef struct IAUDDEC_Status {
00171     XDAS_Int32 size;
00172     XDAS_Int32 extendedError;
00173     XDAS_Int32 bitRate;
00174     XDAS_Int32 sampleRate;
00179     XDAS_Int32 numChannels;
00182     XDAS_Int32 numLFEChannels;
00185     XDAS_Int32 outputFormat;
00188     XDAS_Int32 autoPosition;
00194     XDAS_Int32 fastFwdLen;
00197     XDAS_Int32 frameLen;
00200     XDAS_Int32 outputBitsPerSample;
00205     XDM_AlgBufInfo  bufInfo;
00208 } IAUDDEC_Status;
00209
00210
00219 typedef struct IAUDDEC_OutArgs {
00220     XDAS_Int32 size;
00221     XDAS_Int32 extendedError;
00222     XDAS_Int32 bytesConsumed;
00225 } IAUDDEC_OutArgs;
00226
00227
00238 typedef  IALG_Cmd IAUDDEC_Cmd;
00239
00240
00244 typedef struct IAUDDEC_Fxns{
00245     IALG_Fxns   ialg;
00290     XDAS_Int32   (*process)(IAUDDEC_Handle handle, XDM_BufDesc *inBufs,
00291         XDM_BufDesc *outBufs, IAUDDEC_InArgs *inArgs,
00292         IAUDDEC_OutArgs *outArgs);
00293
00319     XDAS_Int32   (*control)(IAUDDEC_Handle handle, IAUDDEC_Cmd id,
00320         IAUDDEC_DynamicParams *params, IAUDDEC_Status *status);
00321 } IAUDDEC_Fxns;
00322
00323
00326 #ifdef __cplusplus
00327 }
00328 #endif
00329
00330 #endif
00331 /*
00332  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:03; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00333
00334  */
00335


Codec Engine Application Programming Interface (API): iaudenc1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iaudenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IAUDENC1_
00048 #define ti_xdais_dm_IAUDENC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "iaudio.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00063 #define IAUDENC1_EOK      XDM_EOK
00064 #define IAUDENC1_EFAIL    XDM_EFAIL
00065 #define IAUDENC1_EUNSUPPORTED XDM_EUNSUPPORTED
00071 typedef struct IAUDENC1_Obj {
00072     struct IAUDENC1_Fxns *fxns;
00073 } IAUDENC1_Obj;
00074
00075
00079 typedef struct IAUDENC1_Obj  *IAUDENC1_Handle;
00080
00081
00088 typedef struct IAUDENC1_Params {
00089     XDAS_Int32 size;
00090     XDAS_Int32 sampleRate;
00098     XDAS_Int32 bitRate;
00103     XDAS_Int32 channelMode;
00108     XDAS_Int32 dataEndianness;
00112     XDAS_Int32 encMode;
00117     XDAS_Int32 inputFormat;
00121     XDAS_Int32 inputBitsPerSample;
00127     XDAS_Int32 maxBitRate;
00131     XDAS_Int32 dualMonoMode;
00138     XDAS_Int32 crcFlag;
00145     XDAS_Int32 ancFlag;
00157     XDAS_Int32 lfeFlag;
00163 } IAUDENC1_Params;
00164
00165
00180 typedef struct IAUDENC1_DynamicParams {
00181     XDAS_Int32 size;
00182     XDAS_Int32 bitRate;
00187     XDAS_Int32 sampleRate;
00195     XDAS_Int32 channelMode;
00200     XDAS_Int32 lfeFlag;
00206     XDAS_Int32 dualMonoMode;
00213     XDAS_Int32 inputBitsPerSample;
00219 } IAUDENC1_DynamicParams;
00220
00221
00230 typedef struct IAUDENC1_InArgs {
00231     XDAS_Int32 size;
00232     XDAS_Int32 numInSamples;
00236     XDM1_SingleBufDesc ancData;
00243 } IAUDENC1_InArgs;
00244
00245
00253 typedef struct IAUDENC1_Status {
00254     XDAS_Int32 size;
00255     XDAS_Int32 extendedError;
00256     XDM1_SingleBufDesc data;
00272     XDM_AlgBufInfo bufInfo;
00276     XDAS_Int32 validFlag;
00282     XDAS_Int32 lfeFlag;
00288     XDAS_Int32 bitRate;
00293     XDAS_Int32 sampleRate;
00301     XDAS_Int32 channelMode;
00307     XDAS_Int32 encMode;
00312 } IAUDENC1_Status;
00313
00314
00323 typedef struct IAUDENC1_OutArgs {
00324     XDAS_Int32 size;
00325     XDAS_Int32 extendedError;
00326     XDAS_Int32 bytesGenerated;
00329     XDAS_Int32 numZeroesPadded;
00336     XDAS_Int32 numInSamples;
00339 } IAUDENC1_OutArgs;
00340
00341
00352 typedef  IALG_Cmd IAUDENC1_Cmd;
00353
00354
00358 typedef struct IAUDENC1_Fxns{
00359     IALG_Fxns   ialg;
00430     XDAS_Int32  (*process)(IAUDENC1_Handle handle, XDM1_BufDesc *inBufs,
00431         XDM1_BufDesc *outBufs, IAUDENC1_InArgs *inArgs,
00432         IAUDENC1_OutArgs *outArgs);
00433
00434
00470     XDAS_Int32  (*control)(IAUDENC1_Handle handle, IAUDENC1_Cmd id,
00471         IAUDENC1_DynamicParams *params, IAUDENC1_Status *status);
00472
00473 } IAUDENC1_Fxns;
00474
00475
00478 #ifdef __cplusplus
00479 }
00480 #endif
00481
00482 #endif
00483 /*
00484  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:03; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00485
00486  */
00487


Codec Engine Application Programming Interface (API): iaudenc.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iaudenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_IAUDENC_
00051 #define ti_xdais_dm_IAUDENC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064 #include "iaudio.h"
00065
00066 #ifdef __cplusplus
00067 extern "C" {
00068 #endif
00069
00072
00073 #define IAUDENC_CID      "ti.xdais.dm.IAUDENC"
00075 #define IAUDENC_ERUNTIME  XDM_ERUNTIME
00076 #define IAUDENC_EOK       XDM_EOK
00077 #define IAUDENC_EFAIL     XDM_EFAIL
00083 typedef struct IAUDENC_Obj {
00084     struct IAUDENC_Fxns *fxns;
00085 } IAUDENC_Obj;
00086
00087
00091 typedef struct IAUDENC_Obj  *IAUDENC_Handle;
00092
00093
00103 typedef struct IAUDENC_Params {
00104     XDAS_Int32 size;
00105     XDAS_Int32 encodingPreset;
00108     XDAS_Int32 maxSampleRate;
00113     XDAS_Int32 maxBitrate;
00118     XDAS_Int32 maxNoOfCh;
00121     XDAS_Int32 dataEndianness;
00124 } IAUDENC_Params;
00125
00126
00141 typedef struct IAUDENC_DynamicParams {
00142     XDAS_Int32 size;
00143     XDAS_Int32 inputFormat;
00146     XDAS_Int32 bitRate;
00147     XDAS_Int32 sampleRate;
00152     XDAS_Int32 numChannels;
00155     XDAS_Int32 numLFEChannels;
00158     XDAS_Int32 inputBitsPerSample;
00162 } IAUDENC_DynamicParams;
00163
00164
00173 typedef struct IAUDENC_InArgs {
00174     XDAS_Int32 size;
00175 } IAUDENC_InArgs;
00176
00177
00185 typedef struct IAUDENC_Status {
00186     XDAS_Int32 size;
00187     XDAS_Int32 extendedError;
00188     XDAS_Int32 frameLen;
00191     XDM_AlgBufInfo bufInfo;
00195 } IAUDENC_Status;
00196
00197
00206 typedef struct IAUDENC_OutArgs {
00207     XDAS_Int32 size;
00208     XDAS_Int32 extendedError;
00209     XDAS_Int32 bytesGenerated;
00212 } IAUDENC_OutArgs;
00213
00214
00225 typedef  IALG_Cmd IAUDENC_Cmd;
00226
00227
00231 typedef struct IAUDENC_Fxns{
00232     IALG_Fxns   ialg;
00277     XDAS_Int32  (*process)(IAUDENC_Handle handle, XDM_BufDesc *inBufs,
00278         XDM_BufDesc *outBufs, IAUDENC_InArgs *inArgs,
00279         IAUDENC_OutArgs *outArgs);
00280
00281
00303     XDAS_Int32  (*control)(IAUDENC_Handle handle, IAUDENC_Cmd id,
00304         IAUDENC_DynamicParams *params, IAUDENC_Status *status);
00305
00306 } IAUDENC_Fxns;
00307
00308
00311 #ifdef __cplusplus
00312 }
00313 #endif
00314
00315 #endif
00316 /*
00317  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:03; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00318
00319  */
00320


Codec Engine Application Programming Interface (API): iaudio.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iaudio.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_dm_IAUDIO_
00047 #define ti_xdais_dm_IAUDIO_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00055
00056 #ifdef XDM_INCLUDE_DOT9_SUPPORT
00057
00065 typedef enum {
00066     IAUDIO_MONO = 0,
00067     IAUDIO_STEREO = 1,
00068     IAUDIO_THREE_ZERO = 2,
00069     IAUDIO_FIVE_ZERO = 3,
00070     IAUDIO_FIVE_ONE = 4,
00071     IAUDIO_SEVEN_ONE = 5
00072 } IAUDIO_ChannelId;
00073 #endif
00074
00075
00088 typedef enum
00089 {
00090     IAUDIO_1_0 = 0,
00091     IAUDIO_2_0 = 1,
00092     IAUDIO_11_0 = 2,
00096     IAUDIO_3_0 = 3,
00097     IAUDIO_2_1 = 4,
00098     IAUDIO_3_1 = 5,
00099     IAUDIO_2_2 = 6,
00100     IAUDIO_3_2 = 7,
00101     IAUDIO_2_3 = 8,
00102     IAUDIO_3_3 = 9,
00103     IAUDIO_3_4 =10
00105 } IAUDIO_ChannelMode;
00106
00107
00121 typedef enum
00122 {
00123     IAUDIO_DUALMONO_LR = 0,
00124     IAUDIO_DUALMONO_LEFT = 1,
00125     IAUDIO_DUALMONO_RIGHT = 2,
00126     IAUDIO_DUALMONO_LR_MIX = 3
00127 } IAUDIO_DualMonoMode;
00128
00129
00137 typedef enum {
00143     IAUDIO_BLOCK = 0,
00144
00150     IAUDIO_INTERLEAVED = 1
00151 } IAUDIO_PcmFormat;
00152
00153
00161 typedef enum
00162 {
00163     IAUDIO_CBR = 0,
00164     IAUDIO_VBR = 1
00165 } IAUDIO_EncMode;
00166
00167
00170 #ifdef __cplusplus
00171 }
00172 #endif
00173
00174 #endif
00175 /*
00176  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:03; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00177
00178  */
00179


Codec Engine Application Programming Interface (API): iimgdec1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgdec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IIMGDEC1_
00048 #define ti_xdais_dm_IIMGDEC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058
00061
00062 #define IIMGDEC1_EOK      XDM_EOK
00063 #define IIMGDEC1_EFAIL    XDM_EFAIL
00064 #define IIMGDEC1_EUNSUPPORTED XDM_EUNSUPPORTED
00070 typedef struct IIMGDEC1_Obj {
00071     struct IIMGDEC1_Fxns *fxns;
00072 } IIMGDEC1_Obj;
00073
00074
00078 typedef struct IIMGDEC1_Obj  *IIMGDEC1_Handle;
00079
00080
00087 typedef struct IIMGDEC1_Params {
00088     XDAS_Int32 size;
00089     XDAS_Int32 maxHeight;
00090     XDAS_Int32 maxWidth;
00091     XDAS_Int32 maxScans;
00092     XDAS_Int32 dataEndianness;
00096     XDAS_Int32 forceChromaFormat;
00100 } IIMGDEC1_Params;
00101
00102
00117 typedef struct IIMGDEC1_DynamicParams {
00118     XDAS_Int32 size;
00119     XDAS_Int32 numAU;
00123     XDAS_Int32 decodeHeader;
00127     XDAS_Int32 displayWidth;
00131 } IIMGDEC1_DynamicParams;
00132
00133
00142 typedef struct IIMGDEC1_InArgs {
00143     XDAS_Int32 size;
00144     XDAS_Int32 numBytes;
00147 } IIMGDEC1_InArgs;
00148
00149
00157 typedef struct IIMGDEC1_Status {
00158     XDAS_Int32 size;
00159     XDAS_Int32 extendedError;
00160     XDM1_SingleBufDesc data;
00176     XDAS_Int32 outputHeight;
00177     XDAS_Int32 outputWidth;
00180     XDAS_Int32 imageWidth;
00181     XDAS_Int32 outputChromaFormat;
00185     XDAS_Int32 totalAU;
00186     XDAS_Int32 totalScan;
00187     XDM_AlgBufInfo  bufInfo;
00191 } IIMGDEC1_Status;
00192
00193
00202 typedef struct IIMGDEC1_OutArgs {
00203     XDAS_Int32 size;
00204     XDAS_Int32 extendedError;
00205     XDAS_Int32 bytesConsumed;
00208     XDAS_Int32 currentAU;
00209     XDAS_Int32 currentScan;
00210 } IIMGDEC1_OutArgs;
00211
00212
00223 typedef  IALG_Cmd IIMGDEC1_Cmd;
00224
00225
00229 typedef struct IIMGDEC1_Fxns{
00230     IALG_Fxns   ialg;
00301     XDAS_Int32 (*process)(IIMGDEC1_Handle handle, XDM1_BufDesc *inBufs,
00302         XDM1_BufDesc *outBufs, IIMGDEC1_InArgs *inArgs,
00303         IIMGDEC1_OutArgs *outArgs);
00304
00305
00341     XDAS_Int32 (*control)(IIMGDEC1_Handle handle, IIMGDEC1_Cmd id,
00342         IIMGDEC1_DynamicParams *params, IIMGDEC1_Status *status);
00343
00344 }IIMGDEC1_Fxns;
00345
00346
00349 #ifdef __cplusplus
00350 }
00351 #endif
00352
00353 #endif  /* ti_xdais_dm_IIMGDEC1_ */
00354 /*
00355  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00356
00357  */
00358


Codec Engine Application Programming Interface (API): iimgdec.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgdec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_IIMGDEC_
00051 #define ti_xdais_dm_IIMGDEC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064
00065 #ifdef __cplusplus
00066 extern "C" {
00067 #endif
00068
00071
00072 #define IIMGDEC_CID      "ti.xdais.dm.IIMGDEC"
00074 #define IIMGDEC_ERUNTIME  XDM_ERUNTIME
00075 #define IIMGDEC_EOK       XDM_EOK
00076 #define IIMGDEC_EFAIL     XDM_EFAIL
00082 typedef struct IIMGDEC_Obj {
00083     struct IIMGDEC_Fxns *fxns;
00084 } IIMGDEC_Obj;
00085
00086
00090 typedef struct IIMGDEC_Obj  *IIMGDEC_Handle;
00091
00092
00102 typedef struct IIMGDEC_Params {
00103     XDAS_Int32 size;
00104     XDAS_Int32 maxHeight;
00105     XDAS_Int32 maxWidth;
00106     XDAS_Int32 maxScans;
00107     XDAS_Int32 dataEndianness;
00111     XDAS_Int32 forceChromaFormat;
00115 }IIMGDEC_Params;
00116
00117
00132 typedef struct IIMGDEC_DynamicParams {
00133     XDAS_Int32 size;
00134     XDAS_Int32 numAU;
00138     XDAS_Int32 decodeHeader;
00142     XDAS_Int32 displayWidth;
00146 } IIMGDEC_DynamicParams;
00147
00148
00157 typedef struct IIMGDEC_InArgs {
00158     XDAS_Int32 size;
00159     XDAS_Int32 numBytes;
00162 } IIMGDEC_InArgs;
00163
00164
00172 typedef struct IIMGDEC_Status {
00173     XDAS_Int32 size;
00174     XDAS_Int32 extendedError;
00175     XDAS_Int32 outputHeight;
00176     XDAS_Int32 outputWidth;
00179     XDAS_Int32 imageWidth;
00180     XDAS_Int32 outChromaformat;
00184     XDAS_Int32 totalAU;
00185     XDAS_Int32 totalScan;
00186     XDM_AlgBufInfo  bufInfo;
00190 } IIMGDEC_Status;
00191
00192
00201 typedef struct IIMGDEC_OutArgs {
00202     XDAS_Int32 size;
00203     XDAS_Int32 extendedError;
00204     XDAS_Int32 bytesconsumed;
00207     XDAS_Int32 currentAU;
00208     XDAS_Int32 currentScan;
00209 } IIMGDEC_OutArgs;
00210
00211
00222 typedef  IALG_Cmd IIMGDEC_Cmd;
00223
00224
00228 typedef struct IIMGDEC_Fxns{
00229     IALG_Fxns   ialg;
00274     XDAS_Int32 (*process)(IIMGDEC_Handle handle, XDM_BufDesc *inBufs,
00275             XDM_BufDesc *outBufs, IIMGDEC_InArgs *inArgs,
00276             IIMGDEC_OutArgs *outArgs);
00277
00278
00300     XDAS_Int32 (*control)(IIMGDEC_Handle handle, IIMGDEC_Cmd id,
00301             IIMGDEC_DynamicParams *params, IIMGDEC_Status *status);
00302
00303 }IIMGDEC_Fxns;
00304
00305
00308 #ifdef __cplusplus
00309 }
00310 #endif
00311
00312 #endif
00313 /*
00314  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:03; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00315
00316  */
00317


Codec Engine Application Programming Interface (API): iimgenc1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IIMGENC1_
00048 #define ti_xdais_dm_IIMGENC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058
00061
00062 #define IIMGENC1_EOK        XDM_EOK
00063 #define IIMGENC1_EFAIL      XDM_EFAIL
00064 #define IIMGENC1_EUNSUPPORTED XDM_EUNSUPPORTED
00070 typedef struct IIMGENC1_Obj {
00071     struct IIMGENC1_Fxns *fxns;
00072 } IIMGENC1_Obj;
00073
00074
00078 typedef struct IIMGENC1_Obj  *IIMGENC1_Handle;
00079
00080
00087 typedef struct IIMGENC1_Params {
00088     XDAS_Int32 size;
00089     XDAS_Int32 maxHeight;
00090     XDAS_Int32 maxWidth;
00091     XDAS_Int32 maxScans;
00092     XDAS_Int32 dataEndianness;
00096     XDAS_Int32 forceChromaFormat;
00100 } IIMGENC1_Params;
00101
00102
00117 typedef struct IIMGENC1_DynamicParams {
00118     XDAS_Int32 size;
00119     XDAS_Int32 numAU;
00123     XDAS_Int32 inputChromaFormat;
00127     XDAS_Int32 inputHeight;
00128     XDAS_Int32 inputWidth;
00129     XDAS_Int32 captureWidth;
00133     XDAS_Int32 generateHeader;
00137     XDAS_Int32 qValue;
00141 } IIMGENC1_DynamicParams;
00142
00143
00152 typedef struct IIMGENC1_InArgs {
00153     XDAS_Int32 size;
00154 } IIMGENC1_InArgs;
00155
00156
00164 typedef struct IIMGENC1_Status {
00165     XDAS_Int32 size;
00166     XDAS_Int32 extendedError;
00167     XDM1_SingleBufDesc data;
00183     XDAS_Int32 totalAU;
00184     XDM_AlgBufInfo bufInfo;
00188 } IIMGENC1_Status;
00189
00190
00199 typedef struct IIMGENC1_OutArgs {
00200     XDAS_Int32 size;
00201     XDAS_Int32 extendedError;
00202     XDAS_Int32 bytesGenerated;
00205     XDAS_Int32 currentAU;
00206 } IIMGENC1_OutArgs;
00207
00208
00219 typedef  IALG_Cmd IIMGENC1_Cmd;
00220
00221
00225 typedef struct IIMGENC1_Fxns{
00226     IALG_Fxns   ialg;
00297     XDAS_Int32  (*process)(IIMGENC1_Handle handle, XDM1_BufDesc *inBufs,
00298         XDM1_BufDesc *outBufs, IIMGENC1_InArgs *inArgs,
00299         IIMGENC1_OutArgs *outArgs);
00300
00301
00337     XDAS_Int32  (*control)(IIMGENC1_Handle handle, IIMGENC1_Cmd id,
00338         IIMGENC1_DynamicParams *params, IIMGENC1_Status *status);
00339
00340 } IIMGENC1_Fxns;
00341
00342
00345 #ifdef __cplusplus
00346 }
00347 #endif
00348
00349 #endif
00350 /*
00351  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00352
00353  */
00354


Codec Engine Application Programming Interface (API): iimgenc.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iimgenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_IIMGENC_
00051 #define ti_xdais_dm_IIMGENC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064
00065 #ifdef __cplusplus
00066 extern "C" {
00067 #endif
00068
00071
00072 #define IIMGENC_CID      "ti.xdais.dm.IIMGENC"
00074 #define IIMGENC_ERUNTIME  XDM_ERUNTIME
00075 #define IIMGENC_EOK       XDM_EOK
00076 #define IIMGENC_EFAIL     XDM_EFAIL
00082 typedef struct IIMGENC_Obj {
00083     struct IIMGENC_Fxns *fxns;
00084 } IIMGENC_Obj;
00085
00086
00090 typedef struct IIMGENC_Obj  *IIMGENC_Handle;
00091
00092
00102 typedef struct IIMGENC_Params {
00103     XDAS_Int32 size;
00104     XDAS_Int32 maxHeight;
00105     XDAS_Int32 maxWidth;
00106     XDAS_Int32 maxScans;
00107     XDAS_Int32 dataEndianness;
00111     XDAS_Int32 forceChromaFormat;
00115 }IIMGENC_Params;
00116
00117
00132 typedef struct IIMGENC_DynamicParams {
00133     XDAS_Int32 size;
00134     XDAS_Int32 numAU;
00138     XDAS_Int32 inputChromaFormat;
00142     XDAS_Int32 inputHeight;
00143     XDAS_Int32 inputWidth;
00144     XDAS_Int32 captureWidth;
00148     XDAS_Int32 generateHeader;
00152     XDAS_Int32 qValue;
00156 } IIMGENC_DynamicParams;
00157
00158
00167 typedef struct IIMGENC_InArgs {
00168     XDAS_Int32 size;
00169 } IIMGENC_InArgs;
00170
00171
00179 typedef struct IIMGENC_Status {
00180     XDAS_Int32 size;
00181     XDAS_Int32 extendedError;
00182     XDAS_Int32 totalAU;
00183     XDM_AlgBufInfo bufInfo;
00187 } IIMGENC_Status;
00188
00189
00198 typedef struct IIMGENC_OutArgs {
00199     XDAS_Int32 size;
00200     XDAS_Int32 extendedError;
00201     XDAS_Int32 bytesGenerated;
00204     XDAS_Int32 currentAU;
00205 } IIMGENC_OutArgs;
00206
00207
00218 typedef  IALG_Cmd IIMGENC_Cmd;
00219
00220
00224 typedef struct IIMGENC_Fxns{
00225     IALG_Fxns   ialg;
00270     XDAS_Int32  (*process)(IIMGENC_Handle handle, XDM_BufDesc *inBufs,
00271         XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs,
00272         IIMGENC_OutArgs *outArgs);
00273
00295     XDAS_Int32  (*control)(IIMGENC_Handle handle, IIMGENC_Cmd id,
00296         IIMGENC_DynamicParams *params, IIMGENC_Status *status);
00297
00298 } IIMGENC_Fxns;
00299
00300
00303 #ifdef __cplusplus
00304 }
00305 #endif
00306
00307 #endif
00308 /*
00309  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00310
00311  */
00312


Codec Engine Application Programming Interface (API): imgdec1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » image1

imgdec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== imgdec1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_image1_IMGDEC1_
00053 #define ti_sdo_ce_image1_IMGDEC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/iimgdec1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define IMGDEC1_EOK      IIMGDEC1_EOK
00070 #define IMGDEC1_EFAIL    IIMGDEC1_EFAIL
00073 #define IMGDEC1_EUNSUPPORTED IIMGDEC1_EUNSUPPORTED
00074
00075 #define IMGDEC1_ETIMEOUT VISA_ETIMEOUT
00076 #define IMGDEC1_FOREVER  VISA_FOREVER
00081 typedef VISA_Handle IMGDEC1_Handle;
00082
00083 /* The following are just wrapper typedefs */
00084
00086 typedef IIMGDEC1_Params IMGDEC1_Params;
00087
00089 typedef IIMGDEC1_InArgs  IMGDEC1_InArgs;
00090
00092 typedef IIMGDEC1_OutArgs IMGDEC1_OutArgs;
00093
00095 typedef IIMGDEC1_Cmd     IMGDEC1_Cmd;
00096
00098 typedef IIMGDEC1_DynamicParams IMGDEC1_DynamicParams;
00099
00101 typedef IIMGDEC1_Status  IMGDEC1_Status;
00102
00109 extern SKEL_Fxns IMGDEC1_SKEL;
00110
00114 extern IIMGDEC1_Fxns IMGDEC1_STUBS;
00115
00121 typedef struct IIMGDEC1_CodecClassConfig {
00122     Bool manageInBufsCache [ XDM_MAX_IO_BUFFERS ];
00123     Bool manageOutBufsCache[ XDM_MAX_IO_BUFFERS ];
00124 } IIMGDEC1_CodecClassConfig;
00125
00126
00127 /*
00128  *  ======== IMGDEC1_control ========
00129  */
00153 extern Int32 IMGDEC1_control(IMGDEC1_Handle handle, IMGDEC1_Cmd id,
00154     IMGDEC1_DynamicParams *params, IMGDEC1_Status *status);
00155
00156
00157 /*
00158  *  ======== IMGDEC1_create ========
00159  */
00187 extern IMGDEC1_Handle IMGDEC1_create(Engine_Handle e, String name,
00188     IMGDEC1_Params *params);
00189
00190
00191 /*
00192  *  ======== IMGDEC1_delete ========
00193  */
00211 extern Void IMGDEC1_delete(IMGDEC1_Handle handle);
00212
00213
00214 /*
00215  *  ======== IMGDEC1_process ========
00216  */
00255 extern Int32 IMGDEC1_process(IMGDEC1_Handle handle, XDM1_BufDesc *inBufs,
00256     XDM1_BufDesc *outBufs, IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs);
00257
00258
00259 /*
00260  *  ======== IMGDEC1_processAsync ========
00261  */
00298 extern XDAS_Int32 IMGDEC1_processAsync(IMGDEC1_Handle handle,
00299     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs,
00300     IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs);
00301
00302 /*
00303  *  ======== IMGDEC1_processWait ========
00304  */
00347 extern XDAS_Int32 IMGDEC1_processWait(IMGDEC1_Handle handle,
00348     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs,
00349     IMGDEC1_InArgs *inArgs, IMGDEC1_OutArgs *outArgs, UInt timeout);
00350
00353 #ifdef __cplusplus
00354 }
00355 #endif
00356
00357 #endif
00358 /*
00359  *  @(#) ti.sdo.ce.image1; 1, 0, 1,273; 9-20-2010 16:41:29; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00360
00361  */
00362


Codec Engine Application Programming Interface (API): imgdec.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » image

imgdec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== imgdec.h ========
00035  */
00051 #ifndef ti_sdo_ce_image_IMGDEC_
00052 #define ti_sdo_ce_image_IMGDEC_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 /*
00059  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00060  * define XDM_INCLUDE_DOT9_SUPPORT
00061  */
00062 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00063 #define XDM_INCLUDE_DOT9_SUPPORT
00064 #endif
00065 #include <ti/xdais/dm/xdm.h>
00066 #include <ti/xdais/dm/iimgdec.h>
00067
00068 #include <ti/sdo/ce/Engine.h>
00069 #include <ti/sdo/ce/visa.h>
00070 #include <ti/sdo/ce/skel.h>
00071
00074
00075 typedef IIMGDEC_Status IMGDEC_Status;
00077 #define IMGDEC_EOK      IIMGDEC_EOK
00078 #define IMGDEC_EFAIL    IIMGDEC_EFAIL
00079 #define IMGDEC_ERUNTIME IIMGDEC_ERUNTIME
00080 #define IMGDEC_ETIMEOUT VISA_ETIMEOUT
00081 #define IMGDEC_FOREVER  VISA_FOREVER
00086 typedef VISA_Handle IMGDEC_Handle;
00087
00092 typedef struct IIMGDEC_Params IMGDEC_Params;
00093
00097 typedef IIMGDEC_InArgs          IMGDEC_InArgs;
00098
00102 typedef IIMGDEC_OutArgs         IMGDEC_OutArgs;
00103
00107 typedef IIMGDEC_Cmd             IMGDEC_Cmd;
00108
00112 typedef IIMGDEC_DynamicParams   IMGDEC_DynamicParams;
00113
00120 extern SKEL_Fxns IMGDEC_SKEL;
00121
00125 extern IIMGDEC_Fxns IMGDEC_STUBS;
00126
00134 typedef struct IIMGDEC_CodecClassConfig {
00135     Bool manageInBufsCache [ XDM_MAX_IO_BUFFERS ];
00136     Bool manageOutBufsCache[ XDM_MAX_IO_BUFFERS ];
00137 } IIMGDEC_CodecClassConfig;
00138
00139 /*
00140  *  ======== IMGDEC_create ========
00141  */
00170 extern IMGDEC_Handle IMGDEC_create(Engine_Handle e, String name,
00171         IMGDEC_Params *params);
00172
00173
00174 /*
00175  *  ======== IMGDEC_process ========
00176  */
00221 extern Int32 IMGDEC_process(IMGDEC_Handle handle,
00222         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00223         IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs);
00224
00225
00226 /*
00227  *  ======== IMGDEC_control ========
00228  */
00256 extern Int32 IMGDEC_control(IMGDEC_Handle handle, IMGDEC_Cmd id,
00257         IMGDEC_DynamicParams *params, IMGDEC_Status *status);
00258
00259
00260 /*
00261  *  ======== IMGDEC_delete ========
00262  */
00280 extern Void IMGDEC_delete(IMGDEC_Handle handle);
00281
00282
00283 /*
00284  *  ======== IMGDEC_processAsync ========
00285  */
00322 extern XDAS_Int32 IMGDEC_processAsync(IMGDEC_Handle handle, XDM_BufDesc *inBufs,
00323     XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs);
00324
00325
00326 /*
00327  *  ======== IMGDEC_processWait ========
00328  */
00371 extern XDAS_Int32 IMGDEC_processWait(IMGDEC_Handle handle, XDM_BufDesc *inBufs,
00372     XDM_BufDesc *outBufs, IMGDEC_InArgs *inArgs, IMGDEC_OutArgs *outArgs,
00373     UInt timeout);
00374
00375
00378 #ifdef __cplusplus
00379 }
00380 #endif
00381
00382 #endif
00383 /*
00384  *  @(#) ti.sdo.ce.image; 1, 0, 3,349; 9-20-2010 16:41:28; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00385
00386  */
00387


Codec Engine Application Programming Interface (API): imgenc1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » image1

imgenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== imgenc1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_image1_IMGENC1_
00053 #define ti_sdo_ce_image1_IMGENC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/iimgenc1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define IMGENC1_EOK      IIMGENC1_EOK
00070 #define IMGENC1_EFAIL    IIMGENC1_EFAIL
00073 #define IMGENC1_EUNSUPPORTED IIMGENC1_EUNSUPPORTED
00074
00075 #define IMGENC1_ETIMEOUT VISA_ETIMEOUT
00076 #define IMGENC1_FOREVER  VISA_FOREVER
00081 typedef VISA_Handle IMGENC1_Handle;
00082
00083 /* The following are just wrapper typedefs */
00084
00086 typedef struct IIMGENC1_Params IMGENC1_Params;
00087
00089 typedef IIMGENC1_InArgs  IMGENC1_InArgs;
00090
00092 typedef IIMGENC1_OutArgs IMGENC1_OutArgs;
00093
00095 typedef IIMGENC1_Cmd     IMGENC1_Cmd;
00096
00098 typedef IIMGENC1_DynamicParams IMGENC1_DynamicParams;
00099
00101 typedef IIMGENC1_Status  IMGENC1_Status;
00102
00109 extern SKEL_Fxns IMGENC1_SKEL;
00110
00114 extern IIMGENC1_Fxns IMGENC1_STUBS;
00115
00121 typedef struct IIMGENC1_CodecClassConfig {
00122     Bool manageInBufsCache [ XDM_MAX_IO_BUFFERS ];
00123     Bool manageOutBufsCache[ XDM_MAX_IO_BUFFERS ];
00124 } IIMGENC1_CodecClassConfig;
00125
00126
00127 /*
00128  *  ======== IMGENC1_control ========
00129  */
00153 extern Int32 IMGENC1_control(IMGENC1_Handle handle, IMGENC1_Cmd id,
00154     IMGENC1_DynamicParams *params, IMGENC1_Status *status);
00155
00156
00157 /*
00158  *  ======== IMGENC1_create ========
00159  */
00187 extern IMGENC1_Handle IMGENC1_create(Engine_Handle e, String name,
00188     IMGENC1_Params *params);
00189
00190
00191 /*
00192  *  ======== IMGENC1_delete ========
00193  */
00211 extern Void IMGENC1_delete(IMGENC1_Handle handle);
00212
00213
00214 /*
00215  *  ======== IMGENC1_process ========
00216  */
00255 extern Int32 IMGENC1_process(IMGENC1_Handle handle, XDM1_BufDesc *inBufs,
00256     XDM1_BufDesc *outBufs, IMGENC1_InArgs *inArgs, IMGENC1_OutArgs *outArgs);
00257
00258
00259 /*
00260  *  ======== IMGENC1_processAsync ========
00261  */
00298 extern XDAS_Int32 IMGENC1_processAsync(IMGENC1_Handle handle,
00299     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs,
00300     IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs);
00301
00302 /*
00303  *  ======== IMGENC1_processWait ========
00304  */
00347 extern XDAS_Int32 IMGENC1_processWait(IMGENC1_Handle handle,
00348     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs,
00349     IIMGENC1_InArgs *inArgs, IIMGENC1_OutArgs *outArgs, UInt timeout);
00350
00353 #ifdef __cplusplus
00354 }
00355 #endif
00356
00357 #endif
00358 /*
00359  *  @(#) ti.sdo.ce.image1; 1, 0, 1,273; 9-20-2010 16:41:29; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00360
00361  */
00362


Codec Engine Application Programming Interface (API): imgenc.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » image

imgenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== imgenc.h ========
00035  */
00051 #ifndef ti_sdo_ce_image_IMGENC_
00052 #define ti_sdo_ce_image_IMGENC_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 /*
00059  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00060  * define XDM_INCLUDE_DOT9_SUPPORT
00061  */
00062 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00063 #define XDM_INCLUDE_DOT9_SUPPORT
00064 #endif
00065 #include <ti/xdais/dm/xdm.h>
00066 #include <ti/xdais/dm/iimgenc.h>
00067
00068 #include <ti/sdo/ce/Engine.h>
00069 #include <ti/sdo/ce/visa.h>
00070 #include <ti/sdo/ce/skel.h>
00071
00074
00075 typedef IIMGENC_Status IMGENC_Status;
00077 #define IMGENC_EOK      IIMGENC_EOK
00078 #define IMGENC_EFAIL    IIMGENC_EFAIL
00079 #define IMGENC_ERUNTIME IIMGENC_ERUNTIME
00080 #define IMGENC_ETIMEOUT VISA_ETIMEOUT
00081 #define IMGENC_FOREVER  VISA_FOREVER
00086 typedef VISA_Handle IMGENC_Handle;
00087
00092 typedef struct IIMGENC_Params IMGENC_Params;
00093
00097 typedef IIMGENC_InArgs          IMGENC_InArgs;
00098
00102 typedef IIMGENC_OutArgs         IMGENC_OutArgs;
00103
00107 typedef IIMGENC_Cmd             IMGENC_Cmd;
00108
00112 typedef IIMGENC_DynamicParams   IMGENC_DynamicParams;
00113
00120 extern SKEL_Fxns IMGENC_SKEL;
00121
00125 extern IIMGENC_Fxns IMGENC_STUBS;
00126
00134 typedef struct IIMGENC_CodecClassConfig {
00135     Bool manageInBufsCache [ XDM_MAX_IO_BUFFERS ];
00136     Bool manageOutBufsCache[ XDM_MAX_IO_BUFFERS ];
00137 } IIMGENC_CodecClassConfig;
00138
00139 /*
00140  *  ======== IMGENC_create ========
00141  */
00170 extern IMGENC_Handle IMGENC_create(Engine_Handle e, String name,
00171         IMGENC_Params *params);
00172
00173
00174 /*
00175  *  ======== IMGENC_process ========
00176  */
00221 extern Int32 IMGENC_process(IMGENC_Handle handle,
00222         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00223         IMGENC_InArgs *inArgs, IMGENC_OutArgs *outArgs);
00224
00225
00226 /*
00227  *  ======== IMGENC_control ========
00228  */
00258 extern Int32 IMGENC_control(IMGENC_Handle handle, IMGENC_Cmd id,
00259         IMGENC_DynamicParams *params, IMGENC_Status *status);
00260
00261
00262 /*
00263  *  ======== IMGENC_delete ========
00264  */
00282 extern Void IMGENC_delete(IMGENC_Handle handle);
00283
00284
00285 /*
00286  *  ======== IMGENC_processAsync ========
00287  */
00326 extern XDAS_Int32 IMGENC_processAsync(IMGENC_Handle handle, XDM_BufDesc *inBufs,
00327         XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs);
00328
00329
00330 /*
00331  *  ======== IMGENC_processWait ========
00332  */
00375 extern XDAS_Int32 IMGENC_processWait(IMGENC_Handle handle, XDM_BufDesc *inBufs,
00376     XDM_BufDesc *outBufs, IIMGENC_InArgs *inArgs, IIMGENC_OutArgs *outArgs,
00377     UInt timeout);
00378
00379
00382 #ifdef __cplusplus
00383 }
00384 #endif
00385
00386 #endif
00387 /*
00388  *  @(#) ti.sdo.ce.image; 1, 0, 3,349; 9-20-2010 16:41:28; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00389
00390  */
00391


Codec Engine Application Programming Interface (API): ispeech1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_
00048 #define ti_xdais_dm_ISPEECH1_
00049
00050 #ifdef __cplusplus
00051 extern "C" {
00052 #endif
00053
00056
00057
00063 typedef enum {
00064     ISPEECH1_NULLTRAFFICMODE_OFF = 0,
00068     ISPEECH1_NULLTRAFFICMODE_ON = 1,
00073     ISPEECH1_NULLTRAFFICMODE_DEFAULT = ISPEECH1_NULLTRAFFICMODE_OFF
00074 } ISPEECH1_NullTrafficMode;
00075
00076
00082 typedef enum {
00083     ISPEECH1_POSTFILTER_OFF = 0,
00084     ISPEECH1_POSTFILTER_ON = 1,
00087     ISPEECH1_POSTFILTER_DEFAULT = ISPEECH1_POSTFILTER_ON
00088 } ISPEECH1_PostFilter;
00089
00090
00091
00095 typedef enum {
00096     ISPEECH1_VADFLAG_OFF = 0,
00097     ISPEECH1_VADFLAG_ON = 1,
00100     ISPEECH1_VADFLAG_DEFAULT = ISPEECH1_VADFLAG_ON
00101 } ISPEECH1_VADFlag;
00102
00106 #ifdef __cplusplus
00107 }
00108 #endif
00109
00110 #endif
00111 /*
00112  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00113
00114  */
00115


Codec Engine Application Programming Interface (API): ispeech1_amr.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_amr.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_AMR_
00048 #define ti_xdais_dm_ISPEECH1_AMR_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00063 typedef enum {
00064     ISPEECH1_AMR_BITRATE_4P75 = 0,
00065     ISPEECH1_AMR_BITRATE_5P15 = 1,
00066     ISPEECH1_AMR_BITRATE_5P9  = 2,
00067     ISPEECH1_AMR_BITRATE_6P7  = 3,
00068     ISPEECH1_AMR_BITRATE_7P4  = 4,
00069     ISPEECH1_AMR_BITRATE_7P95 = 5,
00070     ISPEECH1_AMR_BITRATE_10P2 = 6,
00071     ISPEECH1_AMR_BITRATE_12P2 = 7,
00074     ISPEECH1_AMR_BITRATE_DEFAULT = ISPEECH1_AMR_BITRATE_12P2
00075 } ISPEECH1_AMR_BitRate;
00076
00077
00084 typedef enum {
00085     ISPEECH1_AMR_CODECSELECT_PRIMARY = 0,
00086     ISPEECH1_AMR_CODECSELECT_SECONDARY = 1,
00089     ISPEECH1_AMR_CODECSELECT_DEFAULT = ISPEECH1_AMR_CODECSELECT_PRIMARY
00090 } ISPEECH1_AMR_CodecSelect;
00091
00092
00096 typedef enum {
00097     ISPEECH1_AMR_PACKTYPE_IF1_NOCRC = 0,
00101     ISPEECH1_AMR_PACKTYPE_IF1_WITHCRC = 1,
00105     ISPEECH1_AMR_PACKTYPE_IF2 = 2,
00108     ISPEECH1_AMR_PACKTYPE_MIME = 3,
00113     ISPEECH1_AMR_PACKTYPEFORMAT_DEFAULT = ISPEECH1_AMR_PACKTYPE_IF1_NOCRC
00114 } ISPEECH1_AMR_PackingType;
00115
00116
00120 typedef enum {
00121     ISPEECH1_AMR_VADSELECT_VAD1 = 1,
00122     ISPEECH1_AMR_VADSELECT_VAD2 = 2,
00125     ISPEECH1_AMR_VADSELECT_DEFAULT = ISPEECH1_AMR_VADSELECT_VAD1
00126 } ISPEECH1_AMR_VADSelect;
00127
00128   /* ingroup */
00130
00131 #ifdef __cplusplus
00132 }
00133 #endif
00134
00135 #endif  /* ti_xdais_dm_ISPEECH1_AMR_ */
00136 /*
00137  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00138
00139  */
00140


Codec Engine Application Programming Interface (API): ispeech1_evrc.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_evrc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_EVRC_
00048 #define ti_xdais_dm_ISPEECH1_EVRC_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00063 typedef enum {
00064     ISPEECH1_EVRC_NOISEPREPROC_OFF = 0,
00067     ISPEECH1_EVRC_NOISEPREPROC_ON = 1,
00072     ISPEECH1_EVRC_NOISEPREPROC_DEFAULT = ISPEECH1_EVRC_NOISEPREPROC_ON
00073 } ISPEECH1_EVRC_NoisePreProc;
00074
00075
00079 typedef enum {
00080     ISPEECH1_EVRC_TTYMODE_OFF = 0,
00081     ISPEECH1_EVRC_TTYMODE_45P45BPS = 1,
00082     ISPEECH1_EVRC_TTYMODE_50BPS = 2,
00085     ISPEECH1_EVRC_TTYMODE_DEFAULT = ISPEECH1_EVRC_TTYMODE_OFF
00086 } ISPEECH1_EVRC_TTYMode;
00087
00088
00096 typedef enum {
00097     ISPEECH1_EVRC_MODE_PREMIUM = 0,
00098     ISPEECH1_EVRC_MODE_STANDARD = 1,
00099     ISPEECH1_EVRC_MODE_ECONOMY = 2,
00100     ISPEECH1_EVRC_MODE_CAPACITYSAVE = 3,
00101     ISPEECH1_EVRC_MODE_HALFRATE_MAX = 4,
00104     ISPEECH1_EVRC_MODE_DEFAULT = ISPEECH1_EVRC_MODE_PREMIUM
00105 } ISPEECH1_EVRC_Mode;
00106
00107
00110 #ifdef __cplusplus
00111 }
00112 #endif
00113
00114 #endif
00115 /*
00116  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00117
00118  */
00119


Codec Engine Application Programming Interface (API): ispeech1_g723.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_g723.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_G723_
00048 #define ti_xdais_dm_ISPEECH1_G723_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00063 typedef enum {
00064     ISPEECH1_G723_BITRATE_5P3 = 0,
00065     ISPEECH1_G723_BITRATE_6P3 = 1,
00068     ISPEECH1_G723_BITRATE_DEFAULT = ISPEECH1_G723_BITRATE_6P3
00069 } ISPEECH1_G723_BitRate;
00070
00071
00075 typedef enum {
00076     ISPEECH1_G723_NOISEPREPROC_OFF = 0,
00077     ISPEECH1_G723_NOISEPREPROC_ON = 1,
00080     ISPEECH1_G723_NOISEPREPROC_DEFAULT = ISPEECH1_G723_NOISEPREPROC_ON
00081 } ISPEECH1_G723_NoisePreProc;
00082
00085 #ifdef __cplusplus
00086 }
00087 #endif
00088
00089 #endif
00090 /*
00091  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00092
00093  */
00094


Codec Engine Application Programming Interface (API): ispeech1_g726.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_g726.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_G726_
00048 #define ti_xdais_dm_ISPEECH1_G726_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00063 typedef enum {
00064     ISPEECH1_G726_BITRATE_16  = 0,
00065     ISPEECH1_G726_BITRATE_24  = 1,
00066     ISPEECH1_G726_BITRATE_32  = 2,
00067     ISPEECH1_G726_BITRATE_40  = 3,
00070     ISPEECH1_G726_BITRATE_DEFAULT = ISPEECH1_G726_BITRATE_40
00071 } ISPEECH1_G726_BitRate;
00072
00073
00077 typedef enum {
00078     ISPEECH1_G726_COMPAND_LINEAR = 0,
00079     ISPEECH1_G726_COMPAND_ALAW = 1,
00080     ISPEECH1_G726_COMPAND_ULAW = 2,
00083     ISPEECH1_G726_COMPAND_DEFAULT = ISPEECH1_G726_COMPAND_LINEAR
00084 } ISPEECH1_G726_CompandingLaw;
00085
00086
00090 typedef enum {
00091     ISPEECH1_G726_PACKTYPE_LINEAR = 0,
00092     ISPEECH1_G726_PACKTYPE_RTPSPECIAL = 1,
00095     ISPEECH1_G726_PACKTYPEFORMAT_DEFAULT = ISPEECH1_G726_PACKTYPE_LINEAR
00096 } ISPEECH1_G726_PackingType;
00097
00100 #ifdef __cplusplus
00101 }
00102 #endif
00103
00104 #endif
00105 /*
00106  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00107
00108  */
00109


Codec Engine Application Programming Interface (API): ispeech1_pcm.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_pcm.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_PCM_
00048 #define ti_xdais_dm_ISPEECH1_PCM_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00063 typedef enum {
00064     ISPEECH1_PCM_COMPAND_LINEAR = 0,
00065     ISPEECH1_PCM_COMPAND_ALAW = 1,
00066     ISPEECH1_PCM_COMPAND_ULAW = 2,
00069     ISPEECH1_PCM_COMPAND_DEFAULT = ISPEECH1_PCM_COMPAND_LINEAR
00070 } ISPEECH1_PCM_CompandingLaw;
00071
00072
00075 #ifdef __cplusplus
00076 }
00077 #endif
00078
00079 #endif
00080 /*
00081  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00082
00083  */
00084


Codec Engine Application Programming Interface (API): ispeech1_smv.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_smv.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_SMV_
00048 #define ti_xdais_dm_ISPEECH1_SMV_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00065 typedef enum {
00066     ISPEECH1_SMV_NOISEPREPROC_OFF = 0,
00067     ISPEECH1_SMV_NOISEPREPROC_NSA = 1,
00070     ISPEECH1_SMV_NOISEPREPROC_NSB = 2,
00075     ISPEECH1_SMV_NOISEPREPROC_DEFAULT = ISPEECH1_SMV_NOISEPREPROC_NSA
00076 } ISPEECH1_SMV_NoisePreProc;
00077
00078
00082 typedef enum {
00083     ISPEECH1_SMV_VADSELECT_VADA = 1,
00084     ISPEECH1_SMV_VADSELECT_VADB = 2,
00087     ISPEECH1_SMV_VADSELECT_DEFAULT = ISPEECH1_SMV_VADSELECT_VADA
00088 } ISPEECH1_SMV_VADSelect;
00089
00090
00094 typedef enum {
00095     ISPEECH1_SMV_TTYMODE_OFF = 0,
00096     ISPEECH1_SMV_TTYMODE_45P45BPS = 1,
00099     ISPEECH1_SMV_TTYMODE_50BPS =  2,
00104     ISPEECH1_SMV_TTYMODE_DEFAULT = ISPEECH1_SMV_TTYMODE_OFF
00105 } ISPEECH1_SMV_TTYMode;
00106
00107
00111 typedef enum {
00112     ISPEECH1_SMV_DTMFMODE_OFF = 0,
00113     ISPEECH1_SMV_DTMFMODE_ON = 1,
00116     ISPEECH1_SMV_DTMFMODE_DEFAULT = ISPEECH1_SMV_DTMFMODE_OFF
00117 } ISPEECH1_SMV_DTMFMode;
00118
00119
00124 typedef enum {
00125     ISPEECH1_SMV_DATAMODE_OFF = 0,
00126     ISPEECH1_SMV_DATAMODE_HALFRATE = 1,
00129     ISPEECH1_SMV_DATAMODE_FULLRATE = 1,
00134     ISPEECH1_SMV_DATAMODE_DEFAULT = ISPEECH1_SMV_DATAMODE_OFF
00135 } ISPEECH1_SMV_DataMode;
00136
00137
00141 typedef enum {
00142     ISPEECH1_SMV_MODE_PREMIUM = 0,
00143     ISPEECH1_SMV_MODE_STANDARD = 1,
00144     ISPEECH1_SMV_MODE_ECONOMY = 2,
00145     ISPEECH1_SMV_MODE_CAPACITYSAVE = 3,
00146     ISPEECH1_SMV_MODE_PREMIUM_HALFRATE_MAX = 4,
00149     ISPEECH1_SMV_MODE_STANDARD_HALFRATE_MAX = 5,
00154     ISPEECH1_SMV_MODE_DEFAULT = ISPEECH1_SMV_MODE_PREMIUM
00155 } ISPEECH1_SMV_Mode;
00156
00157
00160 #ifdef __cplusplus
00161 }
00162 #endif
00163
00164 #endif
00165 /*
00166  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00167
00168  */
00169


Codec Engine Application Programming Interface (API): ispeech1_wbamr.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech1_wbamr.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPEECH1_WBAMR_
00048 #define ti_xdais_dm_ISPEECH1_WBAMR_
00049
00050 #include "ispeech1.h"
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059
00063 typedef enum {
00064     ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC = 0,
00068     ISPEECH1_WBAMR_PACKTYPE_IF1_WITHCRC = 1,
00072     ISPEECH1_WBAMR_PACKTYPE_IF2 = 2,
00075     ISPEECH1_WBAMR_PACKTYPE_MIME = 3,
00080     ISPEECH1_WBAMR_PACKTYPEFORMAT_DEFAULT = ISPEECH1_WBAMR_PACKTYPE_IF1_NOCRC
00081 } ISPEECH1_WBAMR_PackingType;
00082
00083
00087 typedef enum {
00088     ISPEECH1_WBAMR_BITRATE_6P60  = 0,
00089     ISPEECH1_WBAMR_BITRATE_8P85  = 1,
00090     ISPEECH1_WBAMR_BITRATE_12P65 = 2,
00091     ISPEECH1_WBAMR_BITRATE_14P25 = 3,
00092     ISPEECH1_WBAMR_BITRATE_15P85 = 4,
00093     ISPEECH1_WBAMR_BITRATE_18P25 = 5,
00094     ISPEECH1_WBAMR_BITRATE_19P85 = 6,
00095     ISPEECH1_WBAMR_BITRATE_23P05 = 7,
00096     ISPEECH1_WBAMR_BITRATE_23P85 = 8,
00099     ISPEECH1_WBAMR_BITRATE_DEFAULT = ISPEECH1_WBAMR_BITRATE_23P85
00100 } ISPEECH1_WBAMR_BitRate;
00101
00102
00105 #ifdef __cplusplus
00106 }
00107 #endif
00108
00109 #endif
00110 /*
00111  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00112
00113  */
00114


Codec Engine Application Programming Interface (API): ispeech.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ispeech.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_dm_ISPEECH_
00047 #define ti_xdais_dm_ISPEECH_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00055
00056
00060 typedef enum {
00061     ISPEECH_VOICED = 0,
00062     ISPEECH_UNVOICED
00063 } ISPEECH_VoiceMode;
00064
00065 typedef enum {
00066     ISPEECH_LINEAR = 0,
00067     ISPEECH_ALAW,
00068     ISPEECH_ULAW
00069 } ISPEECH_CompoundLaw;
00070
00073 #ifdef __cplusplus
00074 }
00075 #endif
00076
00077 #endif
00078 /*
00079  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00080
00081  */
00082


Codec Engine Application Programming Interface (API): isphdec1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphdec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPHDEC1_
00048 #define ti_xdais_dm_ISPHDEC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "ispeech1.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00063 #define ISPHDEC1_EOK       XDM_EOK
00064 #define ISPHDEC1_EFAIL     XDM_EFAIL
00065 #define ISPHDEC1_EUNSUPPORTED XDM_EUNSUPPORTED
00071 typedef struct ISPHDEC1_Obj {
00072     struct ISPHDEC1_Fxns *fxns;
00073 } ISPHDEC1_Obj;
00074
00075
00079 typedef struct ISPHDEC1_Obj  *ISPHDEC1_Handle;
00080
00081
00091 typedef struct ISPHDEC1_Params {
00092     XDAS_Int16 size;
00093     XDAS_Int16 compandingLaw;
00100     XDAS_Int16 packingType;
00108     XDAS_Int16 codecSelection;
00115     XDAS_Int16 bitRate;
00124     XDAS_Int16 reserved;
00125     XDAS_Int8  **tablesPtr;
00128 } ISPHDEC1_Params;
00129
00130
00145 typedef struct ISPHDEC1_DynamicParams {
00146     XDAS_Int16 size;
00147     XDAS_Int16 postFilter;
00152 } ISPHDEC1_DynamicParams;
00153
00154
00162 typedef enum {
00163     ISPHDEC1_FTYPE_SPEECHGOOD = 0,
00166     ISPHDEC1_FTYPE_SIDUPDATE = 1,
00167     ISPHDEC1_FTYPE_NODATA = 2,
00170     ISPHDEC1_FTYPE_SPEECHLOST = 3,
00171     ISPHDEC1_FTYPE_DEGRADED = 4,
00174     ISPHDEC1_FTYPE_BAD = 5,
00175     ISPHDEC1_FTYPE_SIDFIRST = 6,
00176     ISPHDEC1_FTYPE_SIDBAD = 7,
00177     ISPHDEC1_FTYPE_ONSET = 8
00180 } ISPHDEC1_FrameType;
00181
00182
00187 typedef struct ISPHDEC1_InArgs {
00188     XDAS_Int16 size;
00190     XDAS_Int16 frameType;
00194     XDM1_SingleBufDesc data;
00197 } ISPHDEC1_InArgs;
00198
00199
00207 typedef struct ISPHDEC1_Status {
00208     XDAS_Int16 size;
00209     XDAS_Int16 postFilter;
00213     XDAS_Int32 extendedError;
00214     XDM1_SingleBufDesc data;
00235     XDAS_Int16 compandingLaw;
00242     XDAS_Int16 packingType;
00250     XDM_AlgBufInfo  bufInfo;
00254     XDAS_Int16 codecSelection;
00261     XDAS_Int16 bitRate;
00270 } ISPHDEC1_Status;
00271
00272
00281 typedef struct ISPHDEC1_OutArgs {
00282     XDAS_Int16 size;
00283     XDAS_Int16 dataSize;
00284     XDAS_Int32 extendedError;
00285 } ISPHDEC1_OutArgs;
00286
00287
00298 typedef  IALG_Cmd ISPHDEC1_Cmd;
00299
00300
00304 typedef struct ISPHDEC1_Fxns{
00305     IALG_Fxns   ialg;
00382     XDAS_Int32 (*process)(ISPHDEC1_Handle handle,
00383         XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00384         ISPHDEC1_InArgs *inArgs, ISPHDEC1_OutArgs *outArgs);
00385
00386
00422     XDAS_Int32 (*control)(ISPHDEC1_Handle handle, ISPHDEC1_Cmd id,
00423         ISPHDEC1_DynamicParams *params, ISPHDEC1_Status *status);
00424
00425 } ISPHDEC1_Fxns;
00426
00427
00430 #ifdef __cplusplus
00431 }
00432 #endif
00433
00434 #endif
00435 /*
00436  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00437
00438  */
00439


Codec Engine Application Programming Interface (API): isphdec.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphdec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_ISPHDEC_
00051 #define ti_xdais_dm_ISPHDEC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064 #include "ispeech.h"
00065
00066 #ifdef __cplusplus
00067 extern "C" {
00068 #endif
00069
00072
00073 #define ISPHDEC_CID      "ti.xdais.dm.ISPHDEC"
00075 #define ISPHDEC_ERUNTIME  XDM_ERUNTIME
00076 #define ISPHDEC_EOK       XDM_EOK
00077 #define ISPHDEC_EFAIL     XDM_EFAIL
00083 typedef struct ISPHDEC_Obj {
00084     struct ISPHDEC_Fxns *fxns;
00085 } ISPHDEC_Obj;
00086
00087
00091 typedef struct ISPHDEC_Obj  *ISPHDEC_Handle;
00092
00093
00103 typedef struct ISPHDEC_Params {
00104     XDAS_Int32 size;
00105     XDAS_Int32 dataEnable;
00108     XDAS_Int32 compandingLaw;
00112     XDAS_Int32 packingType;
00116 } ISPHDEC_Params;
00117
00118
00133 typedef struct ISPHDEC_DynamicParams {
00134     XDAS_Int32 size;
00135     XDAS_Int32 postFilter;
00138 } ISPHDEC_DynamicParams;
00139
00140
00149 typedef struct ISPHDEC_InArgs {
00150     XDAS_Int32 size;
00151     XDAS_Int32 frameType;
00152     XDAS_Int32 inBufferSize;
00155     XDAS_Int32 bfiFlag;
00158 } ISPHDEC_InArgs;
00159
00160
00168 typedef struct ISPHDEC_Status {
00169     XDAS_Int32 size;
00170     XDAS_Int32 extendedError;
00171     XDAS_Int32 postFilter;
00174     XDAS_Int32 dataMode;
00175     XDM_AlgBufInfo  bufInfo;
00179 } ISPHDEC_Status;
00180
00181
00190 typedef struct ISPHDEC_OutArgs {
00191     XDAS_Int32 size;
00192     XDAS_Int32 mode;
00195 } ISPHDEC_OutArgs;
00196
00197
00208 typedef  IALG_Cmd ISPHDEC_Cmd;
00209
00210
00214 typedef struct ISPHDEC_Fxns{
00215     IALG_Fxns   ialg;
00270     XDAS_Int32 (*process)(ISPHDEC_Handle handle, XDM_BufDesc *inBufs,
00271             XDM_BufDesc *outBufs, ISPHDEC_InArgs *inArgs,
00272             ISPHDEC_OutArgs *outArgs);
00273
00299     XDAS_Int32 (*control)(ISPHDEC_Handle handle, ISPHDEC_Cmd id,
00300             ISPHDEC_DynamicParams *params, ISPHDEC_Status *status);
00301 } ISPHDEC_Fxns;
00302
00305 #ifdef __cplusplus
00306 }
00307 #endif
00308
00309 #endif
00310 /*
00311  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00312
00313  */
00314


Codec Engine Application Programming Interface (API): isphenc1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_ISPHENC1_
00048 #define ti_xdais_dm_ISPHENC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "ispeech1.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00063 #define ISPHENC1_EOK       XDM_EOK
00064 #define ISPHENC1_EFAIL     XDM_EFAIL
00065 #define ISPHENC1_EUNSUPPORTED XDM_EUNSUPPORTED
00072 #define ISPHENC1_ENOOUTPUT               1
00073
00078 typedef struct ISPHENC1_Obj {
00079     struct ISPHENC1_Fxns *fxns;
00080 } ISPHENC1_Obj;
00081
00082
00086 typedef struct ISPHENC1_Obj  *ISPHENC1_Handle;
00087
00088
00098 typedef struct ISPHENC1_Params {
00099     XDAS_Int16 size;
00100     XDAS_Int16 frameSize;
00103     XDAS_Int16 compandingLaw;
00110     XDAS_Int16 packingType;
00118     XDAS_Int16 vadSelection;
00126     XDAS_Int16 codecSelection;
00133     XDAS_Int16 bitRate;
00142     XDAS_Int16 reserved;
00143     XDAS_Int8  **tablesPtr;
00155 } ISPHENC1_Params;
00156
00157
00170 typedef struct ISPHENC1_DynamicParams {
00171     XDAS_Int16 size;
00172     XDAS_Int16 frameSize;
00175     XDAS_Int16 bitRate;
00183     XDAS_Int16 mode;
00190     XDAS_Int16 vadFlag;
00193     XDAS_Int16 noiseSuppressionMode;
00202     XDAS_Int16 ttyTddMode;
00209     XDAS_Int16 dtmfMode;
00215     XDAS_Int16 dataTransmit;
00221     XDAS_Int16 reserved;
00222 } ISPHENC1_DynamicParams;
00223
00224
00231 typedef struct ISPHENC1_InArgs {
00232     XDAS_Int16 size;
00233     XDAS_Int16 nullTrafficChannel;
00248     XDM1_SingleBufDesc data;
00251 } ISPHENC1_InArgs;
00252
00253
00259 typedef struct ISPHENC1_Status {
00260     XDAS_Int16 size;
00261     XDAS_Int16 frameSize;
00264     XDAS_Int32 extendedError;
00265     XDM1_SingleBufDesc data;
00286     XDAS_Int16 bitRate;
00294     XDAS_Int16 mode;
00301     XDAS_Int16 vadFlag;
00304     XDAS_Int16 noiseSuppressionMode;
00313     XDAS_Int16 ttyTddMode;
00320     XDAS_Int16 dataTransmit;
00326     XDAS_Int16 compandingLaw;
00333     XDAS_Int16 packingType;
00341     XDAS_Int16 vadSelection;
00349     XDAS_Int16 codecSelection;
00356     XDM_AlgBufInfo  bufInfo;
00359 }ISPHENC1_Status;
00360
00361
00367 typedef enum {
00368     ISPHENC1_FTYPE_SPEECH = 0,
00369     ISPHENC1_FTYPE_SIDFRAME = 1,
00370     ISPHENC1_FTYPE_NODATA = 2
00373 } ISPHENC1_FrameType;
00374
00375
00384 typedef struct ISPHENC1_OutArgs {
00385     XDAS_Int16 size;
00386     XDAS_Int16 frameType;
00390     XDAS_Int32 extendedError;
00391 } ISPHENC1_OutArgs;
00392
00393
00404 typedef  IALG_Cmd ISPHENC1_Cmd;
00405
00406
00410 typedef struct ISPHENC1_Fxns{
00411     IALG_Fxns   ialg;
00490     XDAS_Int32 (*process)(ISPHENC1_Handle handle,
00491         XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00492         ISPHENC1_InArgs *inArgs, ISPHENC1_OutArgs *outArgs);
00493
00494
00530     XDAS_Int32 (*control)(ISPHENC1_Handle handle, ISPHENC1_Cmd id,
00531         ISPHENC1_DynamicParams *params, ISPHENC1_Status *status);
00532
00533 } ISPHENC1_Fxns;
00534
00535
00538 #ifdef __cplusplus
00539 }
00540 #endif
00541
00542 #endif
00543 /*
00544  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00545
00546  */
00547


Codec Engine Application Programming Interface (API): isphenc.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

isphenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_ISPHENC_
00051 #define ti_xdais_dm_ISPHENC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064 #include "ispeech.h"
00065
00066 #ifdef __cplusplus
00067 extern "C" {
00068 #endif
00069
00072
00073 #define ISPHENC_CID      "ti.xdais.dm.ISPHENC"
00075 #define ISPHENC_ERUNTIME  XDM_ERUNTIME
00076 #define ISPHENC_EOK       XDM_EOK
00077 #define ISPHENC_EFAIL     XDM_EFAIL
00083 typedef struct ISPHENC_Obj {
00084     struct ISPHENC_Fxns *fxns;
00085 } ISPHENC_Obj;
00086
00087
00091 typedef struct ISPHENC_Obj  *ISPHENC_Handle;
00092
00093
00103 typedef struct ISPHENC_Params {
00104     XDAS_Int32 size;
00105     XDAS_Int32 frameSize;
00108     XDAS_Int32 compandingLaw;
00112     XDAS_Int32 packingType;
00116     XDAS_Int32 vadSelection;
00117 } ISPHENC_Params;
00118
00119
00134 typedef struct ISPHENC_DynamicParams {
00135     XDAS_Int32 size;
00136     XDAS_Int32 frameSize;
00139     XDAS_Int32 bitRate;
00140     XDAS_Int32 mode;
00141     XDAS_Int32 vadFlag;
00142     XDAS_Int32 noiseSuppressionMode;
00143     XDAS_Int32 ttyTddMode;
00144     XDAS_Int32 dtmfMode;
00145     XDAS_Int32 dataTransmit;
00146     XDAS_Int32 homingMode;
00147 } ISPHENC_DynamicParams;
00148
00149
00158 typedef struct ISPHENC_InArgs {
00159     XDAS_Int32 size;
00160     XDAS_Int32 nullTrafficChannel;
00161 } ISPHENC_InArgs;
00162
00163
00171 typedef struct ISPHENC_Status {
00172     XDAS_Int32 size;
00173     XDAS_Int32 extendedError;
00174     XDAS_Int32 frameSize;
00175     XDAS_Int32 bitRate;
00176     XDAS_Int32 mode;
00177     XDAS_Int32 vadFlag;
00178     XDAS_Int32 noiseSuppressionMode;
00179     XDAS_Int32 ttyTddMode;
00180     XDAS_Int32 dtmfMode;
00181     XDAS_Int32 dataTransmit;
00182     XDAS_Int32 homingMode;
00183     XDM_AlgBufInfo  bufInfo;
00187 } ISPHENC_Status;
00188
00189
00198 typedef struct ISPHENC_OutArgs {
00199     XDAS_Int32 size;
00200     XDAS_Int32 rate;
00201     XDAS_Int32 frameType;
00202     XDAS_Int32 outbufferSize;
00203 } ISPHENC_OutArgs;
00204
00205
00216 typedef  IALG_Cmd ISPHENC_Cmd;
00217
00218
00222 typedef struct ISPHENC_Fxns{
00223     IALG_Fxns   ialg;
00278     XDAS_Int32  (*process)(ISPHENC_Handle handle,  XDM_BufDesc *inBufs,
00279             XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs,
00280             ISPHENC_OutArgs *outArgs);
00281
00282
00308     XDAS_Int32  (*control)(ISPHENC_Handle handle, ISPHENC_Cmd id,
00309             ISPHENC_DynamicParams *params, ISPHENC_Status *status);
00310 } ISPHENC_Fxns;
00311
00312
00315 #ifdef __cplusplus
00316 }
00317 #endif
00318
00319 #endif  /* ISPHENC_ */
00320 /*
00321  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00322
00323  */
00324


Codec Engine Application Programming Interface (API): iuniversal.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

iuniversal.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IUNIVERSAL_
00048 #define ti_xdais_dm_IUNIVERSAL_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00060
00061 #define IUNIVERSAL_EOK      XDM_EOK
00062 #define IUNIVERSAL_EFAIL    XDM_EFAIL
00063 #define IUNIVERSAL_EUNSUPPORTED XDM_EUNSUPPORTED
00069 typedef struct IUNIVERSAL_Obj {
00070     struct IUNIVERSAL_Fxns *fxns;
00071 } IUNIVERSAL_Obj;
00072
00073
00077 typedef struct IUNIVERSAL_Obj  *IUNIVERSAL_Handle;
00078
00079
00086 typedef struct IUNIVERSAL_Params {
00087     XDAS_Int32 size;
00088 } IUNIVERSAL_Params;
00089
00090
00105 typedef struct IUNIVERSAL_DynamicParams {
00106     XDAS_Int32 size;
00107 } IUNIVERSAL_DynamicParams;
00108
00109
00118 typedef struct IUNIVERSAL_InArgs {
00119     XDAS_Int32 size;
00120 } IUNIVERSAL_InArgs;
00121
00122
00130 typedef struct IUNIVERSAL_Status {
00131     XDAS_Int32 size;
00132     XDAS_Int32 extendedError;
00133     XDM1_BufDesc data;
00150 } IUNIVERSAL_Status;
00151
00152
00161 typedef struct IUNIVERSAL_OutArgs {
00162     XDAS_Int32 size;
00163     XDAS_Int32 extendedError;
00164 } IUNIVERSAL_OutArgs;
00165
00166
00177 typedef  IALG_Cmd IUNIVERSAL_Cmd;
00178
00179
00183 typedef struct IUNIVERSAL_Fxns{
00184     IALG_Fxns   ialg;
00250     XDAS_Int32   (*process)(IUNIVERSAL_Handle handle, XDM1_BufDesc *inBufs,
00251             XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs,
00252             IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs);
00253
00254
00290     XDAS_Int32   (*control)(IUNIVERSAL_Handle handle, IUNIVERSAL_Cmd id,
00291         IUNIVERSAL_DynamicParams *params, IUNIVERSAL_Status *status);
00292
00293 } IUNIVERSAL_Fxns;
00294
00295
00298 #ifdef __cplusplus
00299 }
00300 #endif
00301
00302 #endif
00303 /*
00304  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00305
00306  */
00307


Codec Engine Application Programming Interface (API): ividanalytics.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividanalytics.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IVIDANALYTICS_
00048 #define ti_xdais_dm_IVIDANALYTICS_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00060
00061 #define IVIDANALYTICS_EOK       XDM_EOK
00062 #define IVIDANALYTICS_EFAIL     XDM_EFAIL
00063 #define IVIDANALYTICS_EUNSUPPORTED XDM_EUNSUPPORTED
00065 /* IVIDANALYTICS-specific control commands  */
00066
00070 #define IVIDANALYTICS_SETRULE           XDM_CLASSCMDBASE
00071
00075 #define IVIDANALYTICS_CLEARRULE         XDM_CLASSCMDBASE + 1
00076
00083 #define IVIDANALYTICS_MAXTARGETS 128
00084
00091 #define IVIDANALYTICS_MAXEVENTS 128
00092
00100 typedef enum {
00101     IVIDANALYTICS_MOTIONDETECT = 0,
00102     IVIDANALYTICS_OBJECTTRACKING = 1,
00104     IVIDANALYTICS_USERBASE = 16
00107 } IVIDANALYTICS_AnalysisMask;
00108
00109
00118 typedef struct IVIDANALYTICS_Grid {   /* a grid/block is put on top of a video frame. Some blocks are MD-enabled, the others are MD-disabled... */
00119     /* do we need a size field? probably not */
00120     XDAS_Int32 blockHeight;
00121     XDAS_Int32 blockWidth;
00122     XDAS_Int32 numBlockHorizontal;
00123     XDAS_Int32 numBlockVertical;
00125     XDM1_SingleBufDesc enableMaskArray;
00135 } IVIDANALYTICS_Grid;
00136
00143 typedef enum {
00144     IVIDANALYTICS_OBJECTTYPE_VEHICLE = 0,
00145     IVIDANALYTICS_OBJECTTYPE_HUMAN = 1,
00147     IVIDANALYTICS_OBJECTTYPE_USERBASE = 256
00150 } IVIDANALYTICS_ObjectType;
00151
00158 typedef enum {
00159     IVIDANALYTICS_ACTIONTYPE_LOITER = 0,
00160     IVIDANALYTICS_ACTIONTYPE_ENTER = 1,
00161     IVIDANALYTICS_ACTIONTYPE_EXIT = 2,
00162     IVIDANALYTICS_ACTIONTYPE_APPEAR = 3,
00163     IVIDANALYTICS_ACTIONTYPE_DISAPPEAR = 4,
00164     IVIDANALYTICS_ACTIONTYPE_CROSSL2R = 5,
00165     IVIDANALYTICS_ACTIONTYPE_CROSSR2L = 6,
00166     IVIDANALYTICS_ACTIONTYPE_CROSSU2D = 7,
00167     IVIDANALYTICS_ACTIONTYPE_CROSSD2U = 8,
00169     IVIDANALYTICS_ACTIONTYPE_USERBASE = 256
00172 } IVIDANALYTICS_ActionType;
00173
00174
00178 typedef struct IVIDANALYTICS_Rule{
00179     XDAS_Int32 size;
00180     XDAS_Int32 id;
00182     IVIDANALYTICS_ObjectType objectType;
00185     IVIDANALYTICS_ActionType actionType;
00188 } IVIDANALYTICS_Rule;
00189
00190
00195 typedef struct IVIDANALYTICS_Obj {
00196     struct IVIDANALYTICS_Fxns *fxns;
00197 } IVIDANALYTICS_Obj;
00198
00199
00203 typedef struct IVIDANALYTICS_Obj  *IVIDANALYTICS_Handle;
00204
00205
00217 typedef enum {
00218     IVIDANALYTICS_VIEWSTATE_BAD = 0,
00219     IVIDANALYTICS_VIEWSTATE_GOOD = 1
00220 } IVIDANALYTICS_ViewState;
00221
00222
00229 typedef struct IVIDANALYTICS_Params {
00230     XDAS_Int32 size;
00231     XDAS_Int32 maxHeight;
00232     XDAS_Int32 maxWidth;
00233     XDAS_Int32 maxFrameRate;
00238     XDAS_Int32 dataEndianness;
00242     XDAS_Int32 inputChromaFormat;
00246     XDAS_Int32 maxRules;
00247 }IVIDANALYTICS_Params;
00248
00249
00264 typedef struct IVIDANALYTICS_DynamicParams {
00265     XDAS_Int32 size;
00266     IVIDANALYTICS_Grid *grid;
00267     XDM_Date      date;
00269     /* Note, we've removed height & width - no way to change size at runtime - need to recreate the alg instance */
00270
00271     IVIDANALYTICS_Rule rule;
00274 } IVIDANALYTICS_DynamicParams;
00275
00276
00285 typedef struct IVIDANALYTICS_InArgs {
00286     XDAS_Int32    size;
00287     XDM_Date      date;
00288 }IVIDANALYTICS_InArgs;
00289
00290
00298 typedef struct IVIDANALYTICS_Status {
00299     XDAS_Int32 size;
00300     XDAS_Int32 extendedError;
00301     XDM1_BufDesc data;
00322     XDM_AlgBufInfo bufInfo;
00335     XDAS_Int32 viewState;
00339 } IVIDANALYTICS_Status;
00340
00341
00350 typedef struct IVIDANALYTICS_OutArgs {
00351     XDAS_Int32 size;
00352     XDAS_Int32 numTargets;
00353     XDM_Rect targets[IVIDANALYTICS_MAXTARGETS];
00360     XDAS_Int32 numEvents;
00362     XDAS_Int32 eventId[IVIDANALYTICS_MAXEVENTS];
00371     XDAS_Int32 extendedError;
00372     XDM_Date      date;
00373 } IVIDANALYTICS_OutArgs;
00374
00375
00386 typedef  IALG_Cmd IVIDANALYTICS_Cmd;
00387
00388
00392 typedef struct IVIDANALYTICS_Fxns {
00393     IALG_Fxns   ialg;
00465     XDAS_Int32 (*process)(IVIDANALYTICS_Handle handle, XDM1_BufDesc *inBufs,
00466         XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs,
00467         IVIDANALYTICS_OutArgs *outArgs);
00468
00469
00505     XDAS_Int32   (*control)(IVIDANALYTICS_Handle handle, IVIDANALYTICS_Cmd id,
00506             IVIDANALYTICS_DynamicParams *params, IVIDANALYTICS_Status *status);
00507
00508 } IVIDANALYTICS_Fxns;
00509
00510
00513 #ifdef __cplusplus
00514 }
00515 #endif
00516
00517 #endif
00518 /*
00519  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00520
00521  */
00522


Codec Engine Application Programming Interface (API): ividdec1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividdec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IVIDDEC1_
00048 #define ti_xdais_dm_IVIDDEC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "ivideo.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00063 #define IVIDDEC1_EOK       XDM_EOK
00064 #define IVIDDEC1_EFAIL     XDM_EFAIL
00065 #define IVIDDEC1_EUNSUPPORTED XDM_EUNSUPPORTED
00071 typedef struct IVIDDEC1_Obj {
00072     struct IVIDDEC1_Fxns *fxns;
00073 } IVIDDEC1_Obj;
00074
00075
00079 typedef struct IVIDDEC1_Obj  *IVIDDEC1_Handle;
00080
00081
00089 typedef enum {
00090     IVIDDEC_DISPLAY_ORDER = 0,
00106     IVIDDEC_DECODE_ORDER = 1,
00121     IVIDDEC_FRAMEORDER_DEFAULT = IVIDDEC_DISPLAY_ORDER
00122 } IVIDDEC1_FrameOrder;
00123
00124
00131 typedef struct IVIDDEC1_Params {
00132     XDAS_Int32 size;
00133     XDAS_Int32 maxHeight;
00134     XDAS_Int32 maxWidth;
00135     XDAS_Int32 maxFrameRate;
00140     XDAS_Int32 maxBitRate;
00144     XDAS_Int32 dataEndianness;
00148     XDAS_Int32 forceChromaFormat;
00152 } IVIDDEC1_Params;
00153
00154
00169 typedef struct IVIDDEC1_DynamicParams {
00170     XDAS_Int32 size;
00171     XDAS_Int32 decodeHeader;
00175     XDAS_Int32 displayWidth;
00179     XDAS_Int32 frameSkipMode;
00183     XDAS_Int32 frameOrder;
00187     XDAS_Int32 newFrameFlag;
00199     XDAS_Int32 mbDataFlag;
00208 } IVIDDEC1_DynamicParams;
00209
00210
00219 typedef struct IVIDDEC1_InArgs {
00220     XDAS_Int32 size;
00221     XDAS_Int32 numBytes;
00224     XDAS_Int32 inputID;
00243 } IVIDDEC1_InArgs;
00244
00245
00256 typedef struct IVIDDEC1_Status {
00257     XDAS_Int32 size;
00258     XDAS_Int32 extendedError;
00259     XDM1_SingleBufDesc data;
00280     XDAS_Int32 outputHeight;
00281     XDAS_Int32 outputWidth;
00282     XDAS_Int32 frameRate;
00287     XDAS_Int32 bitRate;
00288     XDAS_Int32 contentType;
00292     XDAS_Int32 outputChromaFormat;
00296     XDM_AlgBufInfo bufInfo;
00300 } IVIDDEC1_Status;
00301
00302
00303 #define IVIDDEC1_FREE_BUFF_SIZE 16
00316 typedef struct IVIDDEC1_OutArgs {
00317     XDAS_Int32 size;
00318     XDAS_Int32 bytesConsumed;
00321     XDAS_Int32 outputID[XDM_MAX_IO_BUFFERS];
00336     IVIDEO1_BufDesc decodedBufs;
00351     IVIDEO1_BufDesc displayBufs[XDM_MAX_IO_BUFFERS];
00374     XDAS_Int32 outputMbDataID;
00379     XDM1_SingleBufDesc mbDataBuf;
00386     XDAS_Int32 freeBufID[IVIDDEC1_FREE_BUFF_SIZE];
00423     XDAS_Int32 outBufsInUseFlag;
00432 } IVIDDEC1_OutArgs;
00433
00434
00445 typedef  IALG_Cmd IVIDDEC1_Cmd;
00446
00447
00451 typedef struct IVIDDEC1_Fxns {
00452     IALG_Fxns   ialg;
00539     XDAS_Int32 (*process)(IVIDDEC1_Handle handle, XDM1_BufDesc *inBufs,
00540         XDM_BufDesc *outBufs, IVIDDEC1_InArgs *inArgs,
00541         IVIDDEC1_OutArgs *outArgs);
00542
00543
00579     XDAS_Int32 (*control)(IVIDDEC1_Handle handle, IVIDDEC1_Cmd id,
00580         IVIDDEC1_DynamicParams *params, IVIDDEC1_Status *status);
00581
00582 } IVIDDEC1_Fxns;
00583
00584
00587 #ifdef __cplusplus
00588 }
00589 #endif
00590
00591 #endif
00592 /*
00593  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00594
00595  */
00596


Codec Engine Application Programming Interface (API): ividdec2.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividdec2.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IVIDDEC2_
00048 #define ti_xdais_dm_IVIDDEC2_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "ivideo.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00068 #define IVIDDEC2_MAX_IO_BUFFERS                20
00069
00070 #define IVIDDEC2_EOK       XDM_EOK
00071 #define IVIDDEC2_EFAIL     XDM_EFAIL
00072 #define IVIDDEC2_EUNSUPPORTED XDM_EUNSUPPORTED
00078 typedef struct IVIDDEC2_Obj {
00079     struct IVIDDEC2_Fxns *fxns;
00080 } IVIDDEC2_Obj;
00081
00082
00086 typedef struct IVIDDEC2_Obj  *IVIDDEC2_Handle;
00087
00088
00096 typedef enum {
00097     IVIDDEC2_DISPLAY_ORDER = 0,
00113     IVIDDEC2_DECODE_ORDER = 1,
00128     IVIDDEC2_FRAMEORDER_DEFAULT = IVIDDEC2_DISPLAY_ORDER
00129 } IVIDDEC2_FrameOrder;
00130
00131
00138 typedef struct IVIDDEC2_Params {
00139     XDAS_Int32 size;
00140     XDAS_Int32 maxHeight;
00141     XDAS_Int32 maxWidth;
00142     XDAS_Int32 maxFrameRate;
00147     XDAS_Int32 maxBitRate;
00151     XDAS_Int32 dataEndianness;
00155     XDAS_Int32 forceChromaFormat;
00159 } IVIDDEC2_Params;
00160
00161
00176 typedef struct IVIDDEC2_DynamicParams {
00177     XDAS_Int32 size;
00178     XDAS_Int32 decodeHeader;
00182     XDAS_Int32 displayWidth;
00186     XDAS_Int32 frameSkipMode;
00190     XDAS_Int32 frameOrder;
00194     XDAS_Int32 newFrameFlag;
00206     XDAS_Int32 mbDataFlag;
00215 } IVIDDEC2_DynamicParams;
00216
00217
00226 typedef struct IVIDDEC2_InArgs {
00227     XDAS_Int32 size;
00228     XDAS_Int32 numBytes;
00231     XDAS_Int32 inputID;
00250 } IVIDDEC2_InArgs;
00251
00252
00263 typedef struct IVIDDEC2_Status {
00264     XDAS_Int32 size;
00265     XDAS_Int32 extendedError;
00266     XDM1_SingleBufDesc data;
00287     XDAS_Int32 maxNumDisplayBufs;
00293     XDAS_Int32 outputHeight;
00294     XDAS_Int32 outputWidth;
00295     XDAS_Int32 frameRate;
00300     XDAS_Int32 bitRate;
00301     XDAS_Int32 contentType;
00305     XDAS_Int32 outputChromaFormat;
00309     XDM_AlgBufInfo bufInfo;
00313 } IVIDDEC2_Status;
00314
00315
00324 typedef struct IVIDDEC2_OutArgs {
00325     XDAS_Int32 size;
00326     XDAS_Int32 bytesConsumed;
00330     XDAS_Int32 outputID[IVIDDEC2_MAX_IO_BUFFERS];
00345     IVIDEO1_BufDesc decodedBufs;
00360     IVIDEO1_BufDesc displayBufs[IVIDDEC2_MAX_IO_BUFFERS];
00383     XDAS_Int32 outputMbDataID;
00388     XDM1_SingleBufDesc mbDataBuf;
00395     XDAS_Int32 freeBufID[IVIDDEC2_MAX_IO_BUFFERS];
00432     XDAS_Int32 outBufsInUseFlag;
00441 } IVIDDEC2_OutArgs;
00442
00443
00454 typedef  IALG_Cmd IVIDDEC2_Cmd;
00455
00456
00460 typedef struct IVIDDEC2_Fxns {
00461     IALG_Fxns   ialg;
00567     XDAS_Int32 (*process)(IVIDDEC2_Handle handle, XDM1_BufDesc *inBufs,
00568         XDM_BufDesc *outBufs, IVIDDEC2_InArgs *inArgs,
00569         IVIDDEC2_OutArgs *outArgs);
00570
00571
00607     XDAS_Int32 (*control)(IVIDDEC2_Handle handle, IVIDDEC2_Cmd id,
00608         IVIDDEC2_DynamicParams *params, IVIDDEC2_Status *status);
00609
00610 } IVIDDEC2_Fxns;
00611
00612
00615 #ifdef __cplusplus
00616 }
00617 #endif
00618
00619 #endif  /* ti_xdais_dm_IVIDDEC2_ */
00620 /*
00621  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00622
00623  */
00624


Codec Engine Application Programming Interface (API): ividdec.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividdec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_IVIDDEC_
00051 #define ti_xdais_dm_IVIDDEC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064 #include "ivideo.h"
00065
00066 #ifdef __cplusplus
00067 extern "C" {
00068 #endif
00069
00070
00073
00074 #define IVIDDEC_CID      "ti.xdais.dm.IVIDDEC"
00076 #define IVIDDEC_ERUNTIME  XDM_ERUNTIME
00077 #define IVIDDEC_EOK       XDM_EOK
00078 #define IVIDDEC_EFAIL     XDM_EFAIL
00084 typedef struct IVIDDEC_Obj {
00085     struct IVIDDEC_Fxns *fxns;
00086 } IVIDDEC_Obj;
00087
00088
00092 typedef struct IVIDDEC_Obj  *IVIDDEC_Handle;
00093
00094
00108 typedef struct IVIDDEC_Params {
00109     XDAS_Int32 size;
00114     XDAS_Int32 maxHeight;
00115     XDAS_Int32 maxWidth;
00116     XDAS_Int32 maxFrameRate;
00117     XDAS_Int32 maxBitRate;
00121     XDAS_Int32 dataEndianness;
00125     XDAS_Int32 forceChromaFormat;
00129 } IVIDDEC_Params;
00130
00131
00146 typedef struct IVIDDEC_DynamicParams {
00147     XDAS_Int32 size;
00148     XDAS_Int32 decodeHeader;
00152     XDAS_Int32 displayWidth;
00156     XDAS_Int32 frameSkipMode;
00160 } IVIDDEC_DynamicParams;
00161
00162
00171 typedef struct IVIDDEC_InArgs {
00172     XDAS_Int32 size;
00173     XDAS_Int32 numBytes;
00176     XDAS_Int32 inputID;
00195 } IVIDDEC_InArgs;
00196
00197
00205 typedef struct IVIDDEC_Status {
00206     XDAS_Int32 size;
00207     XDAS_Int32 extendedError;
00208     XDAS_Int32 outputHeight;
00209     XDAS_Int32 outputWidth;
00210     XDAS_Int32 frameRate;
00211     XDAS_Int32 bitRate;
00212     XDAS_Int32 contentType;
00216     XDAS_Int32 outputChromaFormat;
00220     XDM_AlgBufInfo  bufInfo;
00224 } IVIDDEC_Status;
00225
00226
00235 typedef struct IVIDDEC_OutArgs {
00236     XDAS_Int32 size;
00237     XDAS_Int32 extendedError;
00238     XDAS_Int32 bytesConsumed;
00239     XDAS_Int32 decodedFrameType;
00241     XDAS_Int32 outputID;
00244     IVIDEO_BufDesc displayBufs;
00252 } IVIDDEC_OutArgs;
00253
00254
00265 typedef  IALG_Cmd IVIDDEC_Cmd;
00266
00267
00271 typedef struct IVIDDEC_Fxns {
00272     IALG_Fxns   ialg;
00312     XDAS_Int32 (*process)(IVIDDEC_Handle handle, XDM_BufDesc *inBufs,
00313         XDM_BufDesc *outBufs, IVIDDEC_InArgs *inArgs,
00314         IVIDDEC_OutArgs *outArgs);
00315
00316
00342     XDAS_Int32 (*control)(IVIDDEC_Handle handle, IVIDDEC_Cmd id,
00343         IVIDDEC_DynamicParams *params, IVIDDEC_Status *status);
00344
00345 } IVIDDEC_Fxns;
00346
00347
00350 #ifdef __cplusplus
00351 }
00352 #endif
00353
00354 #endif
00355 /*
00356  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:04; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00357
00358  */
00359


Codec Engine Application Programming Interface (API): ividenc1.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IVIDENC1_
00048 #define ti_xdais_dm_IVIDENC1_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "ivideo.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00061
00062 #define IVIDENC1_EOK       XDM_EOK
00063 #define IVIDENC1_EFAIL     XDM_EFAIL
00064 #define IVIDENC1_EUNSUPPORTED XDM_EUNSUPPORTED
00070 typedef struct IVIDENC1_Obj {
00071     struct IVIDENC1_Fxns *fxns;
00072 } IVIDENC1_Obj;
00073
00074
00078 typedef struct IVIDENC1_Obj  *IVIDENC1_Handle;
00079
00080
00087 typedef struct IVIDENC1_Params {
00088     XDAS_Int32 size;
00089     XDAS_Int32 encodingPreset;
00090     XDAS_Int32 rateControlPreset;
00094     XDAS_Int32 maxHeight;
00095     XDAS_Int32 maxWidth;
00096     XDAS_Int32 maxFrameRate;
00101     XDAS_Int32 maxBitRate;
00102     XDAS_Int32 dataEndianness;
00106     XDAS_Int32 maxInterFrameInterval;
00113     XDAS_Int32 inputChromaFormat;
00117     XDAS_Int32 inputContentType;
00122     XDAS_Int32 reconChromaFormat;
00133 } IVIDENC1_Params;
00134
00135
00150 typedef struct IVIDENC1_DynamicParams {
00151     XDAS_Int32 size;
00152     XDAS_Int32 inputHeight;
00153     XDAS_Int32 inputWidth;
00154     XDAS_Int32 refFrameRate;
00161     XDAS_Int32 targetFrameRate;
00168     XDAS_Int32 targetBitRate;
00169     XDAS_Int32 intraFrameInterval;
00181     XDAS_Int32 generateHeader;
00185     XDAS_Int32 captureWidth;
00190     XDAS_Int32 forceFrame;
00208     XDAS_Int32 interFrameInterval;
00225     XDAS_Int32 mbDataFlag;
00229 } IVIDENC1_DynamicParams;
00230
00231
00240 typedef struct IVIDENC1_InArgs {
00241     XDAS_Int32 size;
00242     XDAS_Int32 inputID;
00263     XDAS_Int32 topFieldFirstFlag;
00276 } IVIDENC1_InArgs;
00277
00278
00286 typedef struct IVIDENC1_Status {
00287     XDAS_Int32 size;
00288     XDAS_Int32 extendedError;
00289     XDM1_SingleBufDesc data;
00310     XDM_AlgBufInfo bufInfo;
00330 } IVIDENC1_Status;
00331
00332
00341 typedef struct IVIDENC1_OutArgs {
00342     XDAS_Int32 size;
00343     XDAS_Int32 extendedError;
00344     XDAS_Int32 bytesGenerated;
00347     XDAS_Int32 encodedFrameType;
00351     XDAS_Int32 inputFrameSkip;
00355     XDAS_Int32 outputID;
00366    XDM1_SingleBufDesc encodedBuf;
00388     IVIDEO1_BufDesc reconBufs;
00406 } IVIDENC1_OutArgs;
00407
00408
00419 typedef  IALG_Cmd IVIDENC1_Cmd;
00420
00421
00434 typedef struct IVIDENC1_MbData {
00435     XDAS_Int32 mbMode;
00446     XDAS_Int32 QP;
00451     XDAS_Int32 mvFwdXY;
00467     XDAS_Int32 mvBwdXY;
00472 } IVIDENC1_MbData;
00473
00474
00478 typedef struct IVIDENC1_Fxns {
00479     IALG_Fxns   ialg;
00570     XDAS_Int32 (*process)(IVIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs,
00571         XDM_BufDesc *outBufs, IVIDENC1_InArgs *inArgs,
00572         IVIDENC1_OutArgs *outArgs);
00573
00574
00610     XDAS_Int32 (*control)(IVIDENC1_Handle handle, IVIDENC1_Cmd id,
00611         IVIDENC1_DynamicParams *params, IVIDENC1_Status *status);
00612
00613 } IVIDENC1_Fxns;
00614
00615
00618 #ifdef __cplusplus
00619 }
00620 #endif
00621
00622 #endif
00623 /*
00624  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00625
00626  */
00627


Codec Engine Application Programming Interface (API): ividenc.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00050 #ifndef ti_xdais_dm_IVIDENC_
00051 #define ti_xdais_dm_IVIDENC_
00052
00053 #include <ti/xdais/ialg.h>
00054 #include <ti/xdais/xdas.h>
00055
00056 /*
00057  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00058  * define XDM_INCLUDE_DOT9_SUPPORT
00059  */
00060 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00061 #define XDM_INCLUDE_DOT9_SUPPORT
00062 #endif
00063 #include "xdm.h"
00064 #include "ivideo.h"
00065
00066 #ifdef __cplusplus
00067 extern "C" {
00068 #endif
00069
00070
00073
00074 #define IVIDENC_CID      "ti.xdais.dm.IVIDENC"
00076 #define IVIDENC_ERUNTIME  XDM_ERUNTIME
00077 #define IVIDENC_EOK       XDM_EOK
00078 #define IVIDENC_EFAIL     XDM_EFAIL
00084 typedef struct IVIDENC_Obj {
00085     struct IVIDENC_Fxns *fxns;
00086 } IVIDENC_Obj;
00087
00088
00092 typedef struct IVIDENC_Obj  *IVIDENC_Handle;
00093
00094
00104 typedef struct IVIDENC_Params {
00105     XDAS_Int32 size;
00106     XDAS_Int32 encodingPreset;
00107     XDAS_Int32 rateControlPreset;
00111     XDAS_Int32 maxHeight;
00112     XDAS_Int32 maxWidth;
00113     XDAS_Int32 maxFrameRate;
00114     XDAS_Int32 maxBitRate;
00115     XDAS_Int32 dataEndianness;
00119     XDAS_Int32 maxInterFrameInterval;
00122     XDAS_Int32 inputChromaFormat;
00126     XDAS_Int32 inputContentType;
00131 } IVIDENC_Params;
00132
00133
00148 typedef struct IVIDENC_DynamicParams {
00149     XDAS_Int32 size;
00150     XDAS_Int32 inputHeight;
00151     XDAS_Int32 inputWidth;
00152     XDAS_Int32 refFrameRate;
00153     XDAS_Int32 targetFrameRate;
00154     XDAS_Int32 targetBitRate;
00155     XDAS_Int32 intraFrameInterval;
00158     XDAS_Int32 generateHeader;
00162     XDAS_Int32 captureWidth;
00167     XDAS_Int32 forceIFrame;
00169 } IVIDENC_DynamicParams;
00170
00179 typedef struct IVIDENC_InArgs {
00180     XDAS_Int32 size;
00185 } IVIDENC_InArgs;
00186
00194 typedef struct IVIDENC_Status {
00195     XDAS_Int32 size;
00196     XDAS_Int32 extendedError;
00197     XDM_AlgBufInfo bufInfo;
00200 } IVIDENC_Status;
00201
00202
00211 typedef struct IVIDENC_OutArgs {
00212     XDAS_Int32 size;
00213     XDAS_Int32 extendedError;
00214     XDAS_Int32 bytesGenerated;
00215     XDAS_Int32 encodedFrameType;
00219     XDAS_Int32 inputFrameSkip;
00220     IVIDEO_BufDesc reconBufs;
00221 } IVIDENC_OutArgs;
00222
00223
00234 typedef  IALG_Cmd IVIDENC_Cmd;
00235
00236
00240 typedef struct IVIDENC_Fxns {
00241     IALG_Fxns   ialg;
00278     XDAS_Int32 (*process)(IVIDENC_Handle handle, XDM_BufDesc *inBufs,
00279         XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs,
00280         IVIDENC_OutArgs *outArgs);
00281
00282
00308     XDAS_Int32 (*control)(IVIDENC_Handle handle, IVIDENC_Cmd id,
00309         IVIDENC_DynamicParams *params, IVIDENC_Status *status);
00310
00311 } IVIDENC_Fxns;
00312
00313
00316 #ifdef __cplusplus
00317 }
00318 #endif
00319
00320 #endif
00321 /*
00322  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00323
00324  */
00325


Codec Engine Application Programming Interface (API): ivideo.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ivideo.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_dm_IVIDEO_
00047 #define ti_xdais_dm_IVIDEO_
00048
00049 #ifdef __cplusplus
00050 extern "C" {
00051 #endif
00052
00055
00063 typedef enum {
00064     IVIDEO_NO_SKIP = 0,
00065     IVIDEO_SKIP_P = 1,
00082     IVIDEO_SKIP_B = 2,
00090     IVIDEO_SKIP_I = 3,
00091     IVIDEO_SKIP_IP = 4,
00092     IVIDEO_SKIP_IB = 5,
00093     IVIDEO_SKIP_PB = 6,
00094     IVIDEO_SKIP_IPB = 7,
00095     IVIDEO_SKIP_IDR = 8,
00098     IVIDEO_SKIP_DEFAULT = IVIDEO_NO_SKIP
00099 } IVIDEO_FrameSkip;
00100
00113 typedef enum {
00114     IVIDEO_NA_FRAME = -1,
00115     IVIDEO_I_FRAME = 0,
00116     IVIDEO_P_FRAME = 1,
00117     IVIDEO_B_FRAME = 2,
00118     IVIDEO_IDR_FRAME = 3,
00121     IVIDEO_II_FRAME = 4,
00122     IVIDEO_IP_FRAME = 5,
00125     IVIDEO_IB_FRAME = 6,
00128     IVIDEO_PI_FRAME = 7,
00131     IVIDEO_PP_FRAME = 8,
00132     IVIDEO_PB_FRAME = 9,
00135     IVIDEO_BI_FRAME = 10,
00138     IVIDEO_BP_FRAME = 11,
00141     IVIDEO_BB_FRAME = 12,
00142     IVIDEO_MBAFF_I_FRAME = 13,
00143     IVIDEO_MBAFF_P_FRAME = 14,
00144     IVIDEO_MBAFF_B_FRAME = 15,
00145     IVIDEO_MBAFF_IDR_FRAME = 16,
00149     IVIDEO_FRAMETYPE_DEFAULT = IVIDEO_I_FRAME
00150 } IVIDEO_FrameType;
00151
00159 typedef enum {
00160     IVIDEO_CONTENTTYPE_NA = -1,
00161     IVIDEO_PROGRESSIVE = 0,
00162     IVIDEO_PROGRESSIVE_FRAME = IVIDEO_PROGRESSIVE,
00163     IVIDEO_INTERLACED = 1,
00164     IVIDEO_INTERLACED_FRAME = IVIDEO_INTERLACED,
00165     IVIDEO_INTERLACED_TOPFIELD = 2,
00166     IVIDEO_INTERLACED_BOTTOMFIELD = 3,
00169     IVIDEO_CONTENTTYPE_DEFAULT = IVIDEO_PROGRESSIVE
00170 } IVIDEO_ContentType;
00171
00172
00180 typedef enum {
00181     IVIDEO_LOW_DELAY = 1,
00182     IVIDEO_STORAGE = 2,
00185     IVIDEO_TWOPASS = 3,
00188     IVIDEO_NONE = 4,
00191     IVIDEO_USER_DEFINED = 5,
00196     IVIDEO_RATECONTROLPRESET_DEFAULT = IVIDEO_LOW_DELAY
00197 } IVIDEO_RateControlPreset;
00198
00199
00207 typedef enum {
00208     IVIDEO_FRAME_ENCODED = 0,
00209     IVIDEO_FRAME_SKIPPED = 1,
00215     IVIDEO_SKIPMODE_DEFAULT = IVIDEO_FRAME_ENCODED
00216 } IVIDEO_SkipMode;
00217
00218
00235 typedef enum {
00236     IVIDEO_FRAME_NOERROR = 0,
00238     IVIDEO_FRAME_NOTAVAILABLE = 1,
00241     IVIDEO_FRAME_ERROR = 2,
00264     IVIDEO_OUTPUTFRAMESTATUS_DEFAULT = IVIDEO_FRAME_NOERROR
00265 } IVIDEO_OutputFrameStatus;
00266
00274 typedef enum {
00275     IVIDEO_NA_PICTURE = -1,
00276     IVIDEO_I_PICTURE = 0,
00277     IVIDEO_P_PICTURE = 1,
00278     IVIDEO_B_PICTURE = 2,
00280     IVIDEO_PICTURE_TYPE_DEFAULT = IVIDEO_I_PICTURE
00281 } IVIDEO_PictureType;
00282
00283
00291 typedef enum {
00292     IVIDEO_MPEG1 = 1,
00293     IVIDEO_MPEG2SP = 2,
00294     IVIDEO_MPEG2MP = 3,
00295     IVIDEO_MPEG2HP = 4,
00296     IVIDEO_MPEG4SP = 5,
00297     IVIDEO_MPEG4ASP = 6,
00298     IVIDEO_H264BP = 7,
00299     IVIDEO_H264MP = 8,
00300     IVIDEO_H264HP = 9,
00301     IVIDEO_VC1SP = 10,
00302     IVIDEO_VC1MP = 11,
00303     IVIDEO_VC1AP = 12
00304 } IVIDEO_Format;
00305
00306
00310 typedef struct IVIDEO_BufDesc {
00311     XDAS_Int32  numBufs;
00312     XDAS_Int32  width;
00313     XDAS_Int8  *bufs[XDM_MAX_IO_BUFFERS];
00316     XDAS_Int32  bufSizes[XDM_MAX_IO_BUFFERS];
00319 } IVIDEO_BufDesc;
00320
00324 typedef struct IVIDEO1_BufDescIn {
00325     XDAS_Int32  numBufs;
00326     XDAS_Int32  frameWidth;
00327     XDAS_Int32  frameHeight;
00328     XDAS_Int32  framePitch;
00333     XDM1_SingleBufDesc bufDesc[XDM_MAX_IO_BUFFERS];
00334 } IVIDEO1_BufDescIn;
00335
00336
00340 #define IVIDEO_MAX_YUV_BUFFERS  3
00341
00345 typedef struct IVIDEO1_BufDesc {
00346     XDAS_Int32  numBufs;
00347     XDAS_Int32  frameWidth;
00348     XDAS_Int32  frameHeight;
00349     XDAS_Int32  framePitch;
00354     XDM1_SingleBufDesc bufDesc[IVIDEO_MAX_YUV_BUFFERS];
00355     XDAS_Int32 extendedError;
00356     XDAS_Int32 frameType;
00360     XDAS_Int32 topFieldFirstFlag;
00373     XDAS_Int32 repeatFirstFieldFlag;
00386     XDAS_Int32 frameStatus;
00393     XDAS_Int32 repeatFrame;
00420     XDAS_Int32 contentType;
00434     XDAS_Int32 chromaFormat;
00438 } IVIDEO1_BufDesc;
00439
00440
00443 #ifdef __cplusplus
00444 }
00445 #endif
00446
00447 #endif
00448 /*
00449  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00450
00451  */
00452


Codec Engine Application Programming Interface (API): ividtranscode.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

ividtranscode.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00047 #ifndef ti_xdais_dm_IVIDTRANSCODE_
00048 #define ti_xdais_dm_IVIDTRANSCODE_
00049
00050 #include <ti/xdais/ialg.h>
00051 #include <ti/xdais/xdas.h>
00052 #include "xdm.h"
00053 #include "ivideo.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00061
00062 #define IVIDTRANSCODE_EOK       XDM_EOK
00063 #define IVIDTRANSCODE_EFAIL     XDM_EFAIL
00064 #define IVIDTRANSCODE_EUNSUPPORTED XDM_EUNSUPPORTED
00066 #define IVIDTRANSCODE_MAXOUTSTREAMS 2
00072 typedef struct IVIDTRANSCODE_Obj {
00073     struct IVIDTRANSCODE_Fxns *fxns;
00074 } IVIDTRANSCODE_Obj;
00075
00076
00080 typedef struct IVIDTRANSCODE_Obj  *IVIDTRANSCODE_Handle;
00081
00082
00089 typedef struct IVIDTRANSCODE_Params {
00090     XDAS_Int32 size;
00091     XDAS_Int32 numOutputStreams;
00096     XDAS_Int32 formatInput;
00104     XDAS_Int32 formatOutput[IVIDTRANSCODE_MAXOUTSTREAMS];
00114     XDAS_Int32 maxHeightInput;
00115     XDAS_Int32 maxWidthInput;
00116     XDAS_Int32 maxFrameRateInput;
00121     XDAS_Int32 maxBitRateInput;
00125     XDAS_Int32 maxHeightOutput[IVIDTRANSCODE_MAXOUTSTREAMS];
00128     XDAS_Int32 maxWidthOutput[IVIDTRANSCODE_MAXOUTSTREAMS];
00131     XDAS_Int32 maxFrameRateOutput[IVIDTRANSCODE_MAXOUTSTREAMS];
00138     XDAS_Int32 maxBitRateOutput[IVIDTRANSCODE_MAXOUTSTREAMS];
00145     XDAS_Int32 dataEndianness;
00149 } IVIDTRANSCODE_Params;
00150
00151
00166 typedef struct IVIDTRANSCODE_DynamicParams {
00167     XDAS_Int32 size;
00168     XDAS_Int32 readHeaderOnlyFlag;
00174     XDAS_Int32 keepInputResolutionFlag[IVIDTRANSCODE_MAXOUTSTREAMS];
00183     XDAS_Int32 outputHeight[IVIDTRANSCODE_MAXOUTSTREAMS];
00192     XDAS_Int32 outputWidth[IVIDTRANSCODE_MAXOUTSTREAMS];
00201     XDAS_Int32 keepInputFrameRateFlag[IVIDTRANSCODE_MAXOUTSTREAMS];
00209     XDAS_Int32 inputFrameRate;
00220     XDAS_Int32 outputFrameRate[IVIDTRANSCODE_MAXOUTSTREAMS];
00232     XDAS_Int32 targetBitRate[IVIDTRANSCODE_MAXOUTSTREAMS];
00236     XDAS_Int32 rateControl[IVIDTRANSCODE_MAXOUTSTREAMS];
00242     XDAS_Int32 keepInputGOPFlag[IVIDTRANSCODE_MAXOUTSTREAMS];
00249     XDAS_Int32 intraFrameInterval[IVIDTRANSCODE_MAXOUTSTREAMS];
00266     XDAS_Int32 interFrameInterval[IVIDTRANSCODE_MAXOUTSTREAMS];
00286     XDAS_Int32 forceFrame[IVIDTRANSCODE_MAXOUTSTREAMS];
00310     XDAS_Int32 frameSkipTranscodeFlag[IVIDTRANSCODE_MAXOUTSTREAMS];
00323 } IVIDTRANSCODE_DynamicParams;
00324
00325
00334 typedef struct IVIDTRANSCODE_InArgs {
00335     XDAS_Int32 size;
00336     XDAS_Int32 numBytes;
00339     XDAS_Int32 inputID;
00344 } IVIDTRANSCODE_InArgs;
00345
00346
00354 typedef struct IVIDTRANSCODE_Status {
00355     XDAS_Int32 size;
00356     XDAS_Int32 extendedError;
00357     XDM1_SingleBufDesc data;
00378     XDM_AlgBufInfo bufInfo;
00390 } IVIDTRANSCODE_Status;
00391
00392
00401 typedef struct IVIDTRANSCODE_OutArgs {
00402     XDAS_Int32 size;
00403     XDAS_Int32 extendedError;
00404     XDAS_Int32 bitsConsumed;
00407     XDAS_Int32 bitsGenerated[IVIDTRANSCODE_MAXOUTSTREAMS];
00412     XDAS_Int32 decodedPictureType;
00416     XDAS_Int32 decodedPictureStructure;
00420     XDAS_Int32 encodedPictureType[IVIDTRANSCODE_MAXOUTSTREAMS];
00425     XDAS_Int32 encodedPictureStructure[IVIDTRANSCODE_MAXOUTSTREAMS];
00431     XDAS_Int32 decodedHeight;
00432     XDAS_Int32 decodedWidth;
00433     XDAS_Int32 outputID[IVIDTRANSCODE_MAXOUTSTREAMS];
00446     XDAS_Int32 inputFrameSkipTranscodeFlag[IVIDTRANSCODE_MAXOUTSTREAMS];
00454     XDM1_SingleBufDesc encodedBuf[IVIDTRANSCODE_MAXOUTSTREAMS];
00460     XDAS_Int32 outBufsInUseFlag;
00470 } IVIDTRANSCODE_OutArgs;
00471
00472
00483 typedef  IALG_Cmd IVIDTRANSCODE_Cmd;
00484
00485
00489 typedef struct IVIDTRANSCODE_Fxns {
00490     IALG_Fxns   ialg;
00559     XDAS_Int32 (*process)(IVIDTRANSCODE_Handle handle, XDM1_BufDesc *inBufs,
00560         XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs,
00561         IVIDTRANSCODE_OutArgs *outArgs);
00562
00563
00599     XDAS_Int32 (*control)(IVIDTRANSCODE_Handle handle, IVIDTRANSCODE_Cmd id,
00600         IVIDTRANSCODE_DynamicParams *params, IVIDTRANSCODE_Status *status);
00601
00602 } IVIDTRANSCODE_Fxns;
00603
00604
00607 #ifdef __cplusplus
00608 }
00609 #endif
00610
00611 #endif
00612 /*
00613  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00614
00615  */
00616


Codec Engine Application Programming Interface (API): ladclient.h Source File

  • File List
  • Globals
packages » ti » dsplink » utils » ladclient

ladclient.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== ladclient.h ========
00035  */
00036
00050 #ifndef ti_dsplink_utils_ladclient_
00051 #define ti_dsplink_utils_ladclient_
00052
00053 #ifdef __cplusplus
00054 extern "C" {
00055 #endif
00056
00059
00060 /* limits */
00061 #define LAD_MAXLENGTHIMAGENAME  512
00062 #define LAD_MAXLENGTHCONFIGNAME 32
00064 /* LAD return codes */
00065 typedef enum {
00066     LAD_SUCCESS = 0,
00067     LAD_FAILURE,
00068     LAD_INVALIDARG,
00069     LAD_ACCESSDENIED,
00070     LAD_ALREADYRUNNING,
00071     LAD_STILLRUNNING,
00072     LAD_IOFAILURE,
00073     LAD_NOTCONNECTED,
00074     LAD_INVALIDVERSION
00075 } LAD_Status;
00076
00077 /* DSP states */
00078 typedef enum {
00079     LAD_UNKNOWN = 0,
00080     LAD_SETUP,
00081     LAD_LOADED,
00082     LAD_STARTED,
00083     LAD_STOPPED,
00084     LAD_IDLE,
00085     LAD_RESET,
00086     LAD_UNAVAILABLE
00087 } LAD_DspState;
00088
00089 typedef Uns LAD_ClientHandle;
00091 typedef struct LAD_DspStatus {
00092     LAD_DspState dspState;
00093     Char linkConfigName[LAD_MAXLENGTHCONFIGNAME];
00094     Int numClientsStarted;
00095     Char imageName[LAD_MAXLENGTHIMAGENAME];
00096 } LAD_DspStatus;
00097
00098
00099 /*
00100  *  ======== LAD_connect ========
00101  */
00122 extern LAD_Status LAD_connect(LAD_ClientHandle * handle);
00123
00124 /*
00125  *  ======== LAD_disconnect ========
00126  */
00145 extern LAD_Status LAD_disconnect(LAD_ClientHandle handle);
00146
00147 /*
00148  *  ======== LAD_getDspStatus ========
00149  */
00169 extern LAD_Status LAD_getDspStatus(LAD_ClientHandle handle, Int cpuId,
00170     LAD_DspStatus * statusInfo);
00171
00172 /*
00173  *  ======== LAD_releaseDsp ========
00174  */
00195 extern LAD_Status LAD_releaseDsp(LAD_ClientHandle handle);
00196
00197 /*
00198  *  ======== LAD_startupDsp ========
00199  */
00230 extern LAD_Status LAD_startupDsp(LAD_ClientHandle handle, Int cpuId,
00231     String linkConfigName, String imageName);
00232   /* ingroup */
00234
00235 #ifdef __cplusplus
00236 }
00237 #endif
00238
00239 #endif
00240 /*
00241  *  @(#) ti.dsplink.utils.ladclient; 1, 0, 0,236; 9-20-2010 16:39:16; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00242
00243  */
00244


Codec Engine Application Programming Interface (API): Page Index

Related Pages

Here is a list of all related documentation pages:
  • Disclaimer
  • Todo List
  • Deprecated List


Codec Engine Application Programming Interface (API): sphdec1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » speech1

sphdec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== sphdec1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_speech1_SPHDEC1_
00053 #define ti_sdo_ce_speech1_SPHDEC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/isphdec1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define SPHDEC1_EOK      ISPHDEC1_EOK
00070 #define SPHDEC1_EFAIL    ISPHDEC1_EFAIL
00073 #define SPHDEC1_EUNSUPPORTED ISPHDEC1_EUNSUPPORTED
00074
00075 #define SPHDEC1_ETIMEOUT VISA_ETIMEOUT
00076 #define SPHDEC1_FOREVER  VISA_FOREVER
00081 typedef VISA_Handle SPHDEC1_Handle;
00082
00083 /* The following are just wrapper typedefs */
00084
00086 typedef ISPHDEC1_Params SPHDEC1_Params;
00087
00089 typedef ISPHDEC1_InArgs  SPHDEC1_InArgs;
00090
00092 typedef ISPHDEC1_OutArgs SPHDEC1_OutArgs;
00093
00095 typedef ISPHDEC1_Cmd     SPHDEC1_Cmd;
00096
00098 typedef ISPHDEC1_DynamicParams SPHDEC1_DynamicParams;
00099
00101 typedef ISPHDEC1_Status SPHDEC1_Status;
00102
00109 extern SKEL_Fxns SPHDEC1_SKEL;
00110
00114 extern ISPHDEC1_Fxns SPHDEC1_STUBS;
00115
00119 /*
00120  *  ======== SPHDEC1_control ========
00121  */
00145 extern Int32 SPHDEC1_control(SPHDEC1_Handle handle, SPHDEC1_Cmd id,
00146     SPHDEC1_DynamicParams *params, SPHDEC1_Status *status);
00147
00148
00149 /*
00150  *  ======== SPHDEC1_create ========
00151  */
00179 extern SPHDEC1_Handle SPHDEC1_create(Engine_Handle e, String name,
00180     SPHDEC1_Params *params);
00181
00182
00183 /*
00184  *  ======== SPHDEC1_delete ========
00185  */
00203 extern Void SPHDEC1_delete(SPHDEC1_Handle handle);
00204
00205
00206 /*
00207  *  ======== SPHDEC1_process ========
00208  */
00247 extern Int32 SPHDEC1_process(SPHDEC1_Handle handle,
00248     XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00249     SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs);
00250
00251
00252 /*
00253  *  ======== SPHDEC1_processAsync ========
00254  */
00291 extern XDAS_Int32 SPHDEC1_processAsync(SPHDEC1_Handle handle,
00292     XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00293     SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs);
00294
00295 /*
00296  *  ======== SPHDEC1_processWait ========
00297  */
00340 extern XDAS_Int32 SPHDEC1_processWait(SPHDEC1_Handle handle,
00341     XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00342     SPHDEC1_InArgs *inArgs, SPHDEC1_OutArgs *outArgs, UInt timeout);
00343
00346 #ifdef __cplusplus
00347 }
00348 #endif
00349
00350 #endif
00351 /*
00352  *  @(#) ti.sdo.ce.speech1; 1, 0, 1,273; 9-20-2010 16:42:04; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00353
00354  */
00355


Codec Engine Application Programming Interface (API): sphdec.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » speech

sphdec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== sphdec.h ========
00035  */
00052 #ifndef ti_sdo_ce_speech_SPHDEC_
00053 #define ti_sdo_ce_speech_SPHDEC_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 /*
00060  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00061  * define XDM_INCLUDE_DOT9_SUPPORT
00062  */
00063 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00064 #define XDM_INCLUDE_DOT9_SUPPORT
00065 #endif
00066 #include <ti/xdais/dm/xdm.h>
00067 #include <ti/xdais/dm/isphdec.h>
00068
00069 #include <ti/sdo/ce/Engine.h>
00070 #include <ti/sdo/ce/visa.h>
00071 #include <ti/sdo/ce/skel.h>
00072
00075
00076 typedef ISPHDEC_Status SPHDEC_Status;
00078 #define SPHDEC_EOK      ISPHDEC_EOK
00079 #define SPHDEC_EFAIL    ISPHDEC_EFAIL
00080 #define SPHDEC_ERUNTIME ISPHDEC_ERUNTIME
00081 #define SPHDEC_ETIMEOUT VISA_ETIMEOUT
00082 #define SPHDEC_FOREVER  VISA_FOREVER
00087 typedef VISA_Handle SPHDEC_Handle;
00088
00093 typedef struct ISPHDEC_Params SPHDEC_Params;
00094
00098 typedef ISPHDEC_InArgs          SPHDEC_InArgs;
00099
00103 typedef ISPHDEC_OutArgs         SPHDEC_OutArgs;
00104
00108 typedef ISPHDEC_Cmd             SPHDEC_Cmd;
00109
00113 typedef ISPHDEC_DynamicParams   SPHDEC_DynamicParams;
00114
00121 extern SKEL_Fxns SPHDEC_SKEL;
00122
00126 extern ISPHDEC_Fxns SPHDEC_STUBS;
00127
00130 /*
00131  *  ======== SPHDEC_create ========
00132  */
00157 extern SPHDEC_Handle SPHDEC_create(Engine_Handle e, String name,
00158         SPHDEC_Params *params);
00159
00160
00161 /*
00162  *  ======== SPHDEC_process ========
00163  */
00202 extern Int32 SPHDEC_process(SPHDEC_Handle handle,
00203         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00204         SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs);
00205
00206
00207 /*
00208  *  ======== SPHDEC_control ========
00209  */
00233 extern Int32 SPHDEC_control(SPHDEC_Handle handle, SPHDEC_Cmd id,
00234         SPHDEC_DynamicParams *params, SPHDEC_Status *status);
00235
00236
00237 /*
00238  *  ======== SPHDEC_delete ========
00239  */
00257 extern Void SPHDEC_delete(SPHDEC_Handle handle);
00258
00259
00260 /*
00261  *  ======== SPHDEC_processAsync ========
00262  */
00299 extern XDAS_Int32 SPHDEC_processAsync(SPHDEC_Handle handle, XDM_BufDesc *inBufs,
00300         XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs);
00301
00302
00303 /*
00304  *  ======== SPHDEC_processWait ========
00305  */
00348 extern XDAS_Int32 SPHDEC_processWait(SPHDEC_Handle handle, XDM_BufDesc *inBufs,
00349     XDM_BufDesc *outBufs, SPHDEC_InArgs *inArgs, SPHDEC_OutArgs *outArgs,
00350     UInt timeout);
00351
00352
00355 #ifdef __cplusplus
00356 }
00357 #endif
00358
00359 #endif
00360 /*
00361  *  @(#) ti.sdo.ce.speech; 1, 0, 2,413; 9-20-2010 16:42:03; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00362
00363  */
00364


Codec Engine Application Programming Interface (API): sphenc1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » speech1

sphenc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== sphenc1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_speech1_SPHENC1_
00053 #define ti_sdo_ce_speech1_SPHENC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/isphenc1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define SPHENC1_EOK      ISPHENC1_EOK
00070 #define SPHENC1_EFAIL    ISPHENC1_EFAIL
00073 #define SPHENC1_EUNSUPPORTED ISPHENC1_EUNSUPPORTED
00074
00075 #define SPHENC1_ETIMEOUT VISA_ETIMEOUT
00076 #define SPHENC1_FOREVER  VISA_FOREVER
00081 typedef VISA_Handle SPHENC1_Handle;
00082
00087 typedef struct ISPHENC1_Params SPHENC1_Params;
00088
00089
00090 typedef ISPHENC1_InArgs  SPHENC1_InArgs;
00091 typedef ISPHENC1_OutArgs SPHENC1_OutArgs;
00092 typedef ISPHENC1_Cmd     SPHENC1_Cmd;
00093 typedef ISPHENC1_Status SPHENC1_Status;
00096 typedef ISPHENC1_DynamicParams SPHENC1_DynamicParams;
00097
00098
00105 extern SKEL_Fxns SPHENC1_SKEL;
00106
00110 extern ISPHENC1_Fxns SPHENC1_STUBS;
00111
00115 /*
00116  *  ======== SPHENC1_control ========
00117  */
00141 extern Int32 SPHENC1_control(SPHENC1_Handle handle, SPHENC1_Cmd id,
00142     SPHENC1_DynamicParams *params, SPHENC1_Status *status);
00143
00144
00145 /*
00146  *  ======== SPHENC1_create ========
00147  */
00175 extern SPHENC1_Handle SPHENC1_create(Engine_Handle e, String name,
00176     SPHENC1_Params *params);
00177
00178
00179 /*
00180  *  ======== SPHENC1_delete ========
00181  */
00199 extern Void SPHENC1_delete(SPHENC1_Handle handle);
00200
00201
00202 /*
00203  *  ======== SPHENC1_process ========
00204  */
00243 extern Int32 SPHENC1_process(SPHENC1_Handle handle,
00244     XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00245     SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs);
00246
00247 /*
00248  *  ======== SPHENC1_processAsync ========
00249  */
00286 extern XDAS_Int32 SPHENC1_processAsync(SPHENC1_Handle handle,
00287     XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00288     SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs);
00289
00290 /*
00291  *  ======== SPHENC1_processWait ========
00292  */
00335 extern XDAS_Int32 SPHENC1_processWait(SPHENC1_Handle handle,
00336     XDM1_SingleBufDesc *inBuf, XDM1_SingleBufDesc *outBuf,
00337     SPHENC1_InArgs *inArgs, SPHENC1_OutArgs *outArgs, UInt timeout);
00338
00341 #ifdef __cplusplus
00342 }
00343 #endif
00344
00345 #endif
00346 /*
00347  *  @(#) ti.sdo.ce.speech1; 1, 0, 1,273; 9-20-2010 16:42:04; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00348
00349  */
00350


Codec Engine Application Programming Interface (API): sphenc.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » speech

sphenc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== sphenc.h ========
00035  */
00052 #ifndef ti_sdo_ce_speech_SPHENC_
00053 #define ti_sdo_ce_speech_SPHENC_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 /*
00060  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00061  * define XDM_INCLUDE_DOT9_SUPPORT
00062  */
00063 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00064 #define XDM_INCLUDE_DOT9_SUPPORT
00065 #endif
00066 #include <ti/xdais/dm/xdm.h>
00067 #include <ti/xdais/dm/isphenc.h>
00068
00069 #include <ti/sdo/ce/Engine.h>
00070 #include <ti/sdo/ce/visa.h>
00071 #include <ti/sdo/ce/skel.h>
00072
00075
00076 typedef ISPHENC_Status SPHENC_Status;
00078 #define SPHENC_EOK      ISPHENC_EOK
00079 #define SPHENC_EFAIL    ISPHENC_EFAIL
00080 #define SPHENC_ERUNTIME ISPHENC_ERUNTIME
00081 #define SPHENC_ETIMEOUT VISA_ETIMEOUT
00082 #define SPHENC_FOREVER  VISA_FOREVER
00087 typedef VISA_Handle SPHENC_Handle;
00088
00093 typedef struct ISPHENC_Params SPHENC_Params;
00094
00098 typedef ISPHENC_InArgs          SPHENC_InArgs;
00099
00103 typedef ISPHENC_OutArgs         SPHENC_OutArgs;
00104
00108 typedef ISPHENC_Cmd             SPHENC_Cmd;
00109
00113 typedef ISPHENC_DynamicParams   SPHENC_DynamicParams;
00114
00121 extern SKEL_Fxns SPHENC_SKEL;
00122
00126 extern ISPHENC_Fxns SPHENC_STUBS;
00127
00130 /*
00131  *  ======== SPHENC_create ========
00132  */
00157 extern SPHENC_Handle SPHENC_create(Engine_Handle e, String name,
00158         SPHENC_Params *params);
00159
00160
00161 /*
00162  *  ======== SPHENC_process ========
00163  */
00202 extern Int32 SPHENC_process(SPHENC_Handle handle,
00203         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00204         SPHENC_InArgs *inArgs, SPHENC_OutArgs *outArgs);
00205
00206
00207 /*
00208  *  ======== SPHENC_control ========
00209  */
00233 extern Int32 SPHENC_control(SPHENC_Handle handle, SPHENC_Cmd id,
00234        SPHENC_DynamicParams *params, SPHENC_Status *status);
00235
00236
00237 /*
00238  *  ======== SPHENC_delete ========
00239  */
00257 extern Void SPHENC_delete(SPHENC_Handle handle);
00258
00259
00260 /*
00261  *  ======== SPHENC_processAsync ========
00262  */
00299 extern XDAS_Int32 SPHENC_processAsync(SPHENC_Handle handle, XDM_BufDesc *inBufs,
00300         XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs);
00301
00302
00303 /*
00304  *  ======== SPHENC_processWait ========
00305  */
00348 extern XDAS_Int32 SPHENC_processWait(SPHENC_Handle handle, XDM_BufDesc *inBufs,
00349     XDM_BufDesc *outBufs, ISPHENC_InArgs *inArgs, ISPHENC_OutArgs *outArgs,
00350     UInt timeout);
00351
00352
00355 #ifdef __cplusplus
00356 }
00357 #endif
00358
00359 #endif
00360 /*
00361  *  @(#) ti.sdo.ce.speech; 1, 0, 2,413; 9-20-2010 16:42:03; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00362
00363  */
00364


Codec Engine Application Programming Interface (API): ividdec2.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm » split

split/ividdec2.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_dm_split_IVIDDEC2_
00047 #define ti_xdais_dm_split_IVIDDEC2_
00048
00049 #include <ti/xdais/ialg.h>
00050 #include <ti/xdais/xdas.h>
00051 #include "../xdm.h"
00052
00053 #include "../ividdec2.h"
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059
00062
00067 typedef struct IVIDDEC2FRONT_Obj {
00068     struct IVIDDEC2FRONT_Fxns *fxns;
00069 } IVIDDEC2FRONT_Obj;
00070
00071
00075 typedef struct IVIDDEC2FRONT_Obj  *IVIDDEC2FRONT_Handle;
00076
00081 typedef struct IVIDDEC2BACK_Obj {
00082     struct IVIDDEC2BACK_Fxns *fxns;
00083 } IVIDDEC2BACK_Obj;
00084
00085
00089 typedef struct IVIDDEC2BACK_Obj  *IVIDDEC2BACK_Handle;
00090
00091
00100 typedef struct IVIDDEC2FRONT_Status {
00101     XDM_ContextInfo contextInfo;
00107     XDAS_Int32 nextPartRequiredFlag;
00131     XDAS_Int32 partialExtendedError;
00141     IVIDDEC2_Status fullStatus;
00226 } IVIDDEC2FRONT_Status;
00227
00228
00237 typedef struct IVIDDEC2FRONT_OutArgs {
00238     XDAS_Int32 size;
00239     XDAS_Int32 extendedError;
00240     XDAS_Int32 bytesConsumed;
00243 } IVIDDEC2FRONT_OutArgs;
00244
00245
00249 typedef struct IVIDDEC2FRONT_Fxns {
00250     IALG_Fxns   ialg;
00350     XDAS_Int32 (*process)(IVIDDEC2FRONT_Handle handle, IVIDDEC2_InArgs *inArgs,
00351         XDM_Context *context, IVIDDEC2FRONT_OutArgs *outArgs);
00352
00353
00398     XDAS_Int32 (*control)(IVIDDEC2FRONT_Handle handle, IVIDDEC2_Cmd id,
00399         IVIDDEC2_DynamicParams *params, XDM_Context *context,
00400         IVIDDEC2FRONT_Status *status);
00401
00402 } IVIDDEC2FRONT_Fxns;
00403
00404
00408 typedef struct IVIDDEC2BACK_Fxns {
00409     IALG_Fxns   ialg;
00443     XDAS_Int32 (*process)(IVIDDEC2BACK_Handle handle, XDM_Context *context,
00444         IVIDDEC2_OutArgs *outArgs);
00445
00446
00477     XDAS_Int32 (*control)(IVIDDEC2BACK_Handle handle,
00478         XDM_Context *context, IVIDDEC2_Status *status);
00479
00480 } IVIDDEC2BACK_Fxns;
00481
00482
00485 #ifdef __cplusplus
00486 }
00487 #endif
00488
00489 #endif
00490 /*
00491  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00492
00493  */
00494


Codec Engine Application Programming Interface (API): viddec2.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » video2 » split

split/viddec2.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== viddec2.h ========
00035  */
00052 #ifndef ti_sdo_ce_video2_split_VIDDEC2_
00053 #define ti_sdo_ce_video2_split_VIDDEC2_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/split/ividdec2.h>
00061
00062
00063 #include <ti/sdo/ce/Engine.h>
00064 #include <ti/sdo/ce/visa.h>
00065 #include <ti/sdo/ce/skel.h>
00066 #include <ti/sdo/ce/video2/viddec2.h>
00067
00070
00074 typedef IVIDDEC2FRONT_Status VIDDEC2FRONT_Status;
00075
00076
00080 typedef VISA_Handle VIDDEC2FRONT_Handle;
00081
00082
00086 typedef VISA_Handle VIDDEC2BACK_Handle;
00087
00088
00092 typedef IVIDDEC2FRONT_OutArgs    VIDDEC2FRONT_OutArgs;
00093
00100 extern SKEL_Fxns VIDDEC2FRONT_SKEL;
00101
00106 extern IVIDDEC2FRONT_Fxns VIDDEC2FRONT_STUBS;
00107
00112 extern SKEL_Fxns VIDDEC2BACK_SKEL;
00113
00118 extern IVIDDEC2BACK_Fxns VIDDEC2BACK_STUBS;
00119
00125 typedef struct IVIDDEC2BACK_CodecClassConfig {
00126     Bool manageInBufsCache          [ XDM_MAX_CONTEXT_BUFFERS ];
00127     Bool manageOutBufsCache         [ XDM_MAX_CONTEXT_BUFFERS ];
00128     Bool manageIntermediateBufsCache[ XDM_MAX_CONTEXT_BUFFERS ];
00129 } IVIDDEC2BACK_CodecClassConfig;
00130
00131 /*
00132  *  ======== VIDDEC2BACK_create ========
00133  */
00158 extern VIDDEC2BACK_Handle VIDDEC2BACK_create(Engine_Handle e, String name,
00159     VIDDEC2_Params *params);
00160
00161
00162 /*
00163  *  ======== VIDDEC2BACK_process ========
00164  */
00204 extern Int32 VIDDEC2BACK_process(VIDDEC2BACK_Handle handle,
00205         XDM_Context *context, VIDDEC2_OutArgs *outArgs);
00206
00207
00208 /*
00209  *  ======== VIDDEC2BACK_control ========
00210  */
00235 extern Int32 VIDDEC2BACK_control(VIDDEC2BACK_Handle handle,
00236         XDM_Context *context, VIDDEC2_Status *status);
00237
00238 /*
00239  *  ======== VIDDEC2BACK_delete ========
00240  */
00258 extern Void VIDDEC2BACK_delete(VIDDEC2BACK_Handle handle);
00259
00260
00261 /*
00262  *  ======== VIDDEC2FRONT_create ========
00263  */
00288 extern VIDDEC2FRONT_Handle VIDDEC2FRONT_create(Engine_Handle e, String name,
00289     VIDDEC2_Params *params);
00290
00291
00292 /*
00293  *  ======== VIDDEC2FRONT_process ========
00294  */
00335 extern Int32 VIDDEC2FRONT_process(VIDDEC2FRONT_Handle handle,
00336         VIDDEC2_InArgs *inArgs, XDM_Context *context,
00337         VIDDEC2FRONT_OutArgs *outArgs);
00338
00339
00340 /*
00341  *  ======== VIDDEC2FRONT_control ========
00342  */
00369 extern Int32 VIDDEC2FRONT_control(VIDDEC2FRONT_Handle handle, VIDDEC2_Cmd id,
00370         VIDDEC2_DynamicParams *params, XDM_Context *context,
00371         VIDDEC2FRONT_Status *status);
00372
00373
00374 /*
00375  *  ======== VIDDEC2FRONT_delete ========
00376  */
00394 extern Void VIDDEC2FRONT_delete(VIDDEC2FRONT_Handle handle);
00395
00396   /* ingroup */
00398
00399 #ifdef __cplusplus
00400 }
00401 #endif
00402
00403 #endif
00404 /*
00405  *  @(#) ti.sdo.ce.video2.split; 1, 0, 0,162; 9-20-2010 16:43:20; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00406
00407  */
00408


Codec Engine Application Programming Interface (API): universal.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » universal

universal.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== universal.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_universal_UNIVERSAL_
00053 #define ti_sdo_ce_universal_UNIVERSAL_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/iuniversal.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00070 #define UNIVERSAL_EOK            IUNIVERSAL_EOK
00071
00073 #define UNIVERSAL_EFAIL          IUNIVERSAL_EFAIL
00074
00076 #define UNIVERSAL_EUNSUPPORTED   IUNIVERSAL_EUNSUPPORTED
00077
00079 #define UNIVERSAL_ETIMEOUT VISA_ETIMEOUT
00080
00082 #define UNIVERSAL_FOREVER  VISA_FOREVER
00083
00087 typedef VISA_Handle UNIVERSAL_Handle;
00088
00093 typedef struct IUNIVERSAL_Params UNIVERSAL_Params;
00094
00096 typedef IUNIVERSAL_InArgs  UNIVERSAL_InArgs;
00098 typedef IUNIVERSAL_OutArgs UNIVERSAL_OutArgs;
00100 typedef IUNIVERSAL_Cmd     UNIVERSAL_Cmd;
00102 typedef IUNIVERSAL_Status  UNIVERSAL_Status;
00103
00105 typedef IUNIVERSAL_DynamicParams UNIVERSAL_DynamicParams;
00106
00107
00114 extern SKEL_Fxns UNIVERSAL_SKEL;
00115
00120 extern IUNIVERSAL_Fxns UNIVERSAL_STUBS;
00121
00125 /*
00126  *  ======== UNIVERSAL_control ========
00127  */
00152 extern Int32 UNIVERSAL_control(UNIVERSAL_Handle handle,
00153     UNIVERSAL_Cmd id, UNIVERSAL_DynamicParams *params,
00154     UNIVERSAL_Status *status);
00155
00156
00157 /*
00158  *  ======== UNIVERSAL_create ========
00159  */
00188 extern UNIVERSAL_Handle UNIVERSAL_create(Engine_Handle e, String name,
00189     UNIVERSAL_Params *params);
00190
00191
00192 /*
00193  *  ======== UNIVERSAL_delete ========
00194  */
00212 extern Void UNIVERSAL_delete(UNIVERSAL_Handle handle);
00213
00214
00215 /*
00216  *  ======== UNIVERSAL_process ========
00217  */
00258 extern Int32 UNIVERSAL_process(UNIVERSAL_Handle handle,
00259         XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs,
00260         UNIVERSAL_InArgs *inArgs, UNIVERSAL_OutArgs *outArgs);
00261
00262 /*
00263  *  ======== UNIVERSAL_processAsync ========
00264  */
00303 extern XDAS_Int32 UNIVERSAL_processAsync(UNIVERSAL_Handle handle,
00304         XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs,
00305         IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs);
00306
00307 /*
00308  *  ======== UNIVERSAL_processWait ========
00309  */
00354 extern XDAS_Int32 UNIVERSAL_processWait(UNIVERSAL_Handle handle,
00355         XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, XDM1_BufDesc *inOutBufs,
00356         IUNIVERSAL_InArgs *inArgs, IUNIVERSAL_OutArgs *outArgs, UInt timeout);
00357
00360 #ifdef __cplusplus
00361 }
00362 #endif
00363
00364 #endif
00365 /*
00366  *  @(#) ti.sdo.ce.universal; 1, 0, 0,138; 9-20-2010 16:43:06; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00367
00368  */
00369


Codec Engine Application Programming Interface (API): vidanalytics.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » vidanalytics

vidanalytics.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== vidtranscode.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_vidanalytics_VIDANALYTICS_
00053 #define ti_sdo_ce_vidanalytics_VIDANALYTICS_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/ividanalytics.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00070 #define VIDANALYTICS_EOK            IVIDANALYTICS_EOK
00071
00073 #define VIDANALYTICS_EFAIL          IVIDANALYTICS_EFAIL
00074
00076 #define VIDANALYTICS_EUNSUPPORTED   IVIDANALYTICS_EUNSUPPORTED
00077
00079 #define VIDANALYTICS_ETIMEOUT VISA_ETIMEOUT
00080
00082 #define VIDANALYTICS_FOREVER  VISA_FOREVER
00083
00087 typedef VISA_Handle VIDANALYTICS_Handle;
00088
00093 typedef struct IVIDANALYTICS_Params VIDANALYTICS_Params;
00094
00096 typedef IVIDANALYTICS_InArgs  VIDANALYTICS_InArgs;
00098 typedef IVIDANALYTICS_OutArgs VIDANALYTICS_OutArgs;
00100 typedef IVIDANALYTICS_Cmd     VIDANALYTICS_Cmd;
00102 typedef IVIDANALYTICS_Status  VIDANALYTICS_Status;
00103
00105 typedef IVIDANALYTICS_DynamicParams VIDANALYTICS_DynamicParams;
00106
00107
00114 extern SKEL_Fxns VIDANALYTICS_SKEL;
00115
00120 extern IVIDANALYTICS_Fxns VIDANALYTICS_STUBS;
00121
00125 /*
00126  *  ======== VIDANALYTICS_control ========
00127  */
00152 extern Int32 VIDANALYTICS_control(VIDANALYTICS_Handle handle,
00153     VIDANALYTICS_Cmd id, VIDANALYTICS_DynamicParams *params,
00154     VIDANALYTICS_Status *status);
00155
00156
00157 /*
00158  *  ======== VIDANALYTICS_create ========
00159  */
00188 extern VIDANALYTICS_Handle VIDANALYTICS_create(Engine_Handle e, String name,
00189     VIDANALYTICS_Params *params);
00190
00191
00192 /*
00193  *  ======== VIDANALYTICS_delete ========
00194  */
00212 extern Void VIDANALYTICS_delete(VIDANALYTICS_Handle handle);
00213
00214
00215 /*
00216  *  ======== VIDANALYTICS_process ========
00217  */
00257 extern Int32 VIDANALYTICS_process(VIDANALYTICS_Handle handle,
00258     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, VIDANALYTICS_InArgs *inArgs,
00259     VIDANALYTICS_OutArgs *outArgs);
00260
00261 /*
00262  *  ======== VIDANALYTICS_processAsync ========
00263  */
00301 extern XDAS_Int32 VIDANALYTICS_processAsync(VIDANALYTICS_Handle handle,
00302     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs,
00303     IVIDANALYTICS_OutArgs *outArgs);
00304
00305 /*
00306  *  ======== VIDANALYTICS_processWait ========
00307  */
00351 extern XDAS_Int32 VIDANALYTICS_processWait(VIDANALYTICS_Handle handle,
00352     XDM1_BufDesc *inBufs, XDM1_BufDesc *outBufs, IVIDANALYTICS_InArgs *inArgs,
00353     IVIDANALYTICS_OutArgs *outArgs, UInt timeout);
00354
00357 #ifdef __cplusplus
00358 }
00359 #endif
00360
00361 #endif
00362 /*
00363  *  @(#) ti.sdo.ce.vidanalytics; 1, 0, 1,206; 9-20-2010 16:43:12; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00364
00365  */
00366


Codec Engine Application Programming Interface (API): viddec1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » video1

viddec1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== viddec1.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_video1_VIDDEC1_
00053 #define ti_sdo_ce_video1_VIDDEC1_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/ividdec1.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 typedef IVIDDEC1_Status VIDDEC1_Status;
00071 #define VIDDEC1_EOK      IVIDDEC1_EOK
00072 #define VIDDEC1_EFAIL    IVIDDEC1_EFAIL
00075 #define VIDDEC1_EUNSUPPORTED IVIDDEC1_EUNSUPPORTED
00076
00077 #define VIDDEC1_ETIMEOUT VISA_ETIMEOUT
00078 #define VIDDEC1_FOREVER  VISA_FOREVER
00083 typedef VISA_Handle VIDDEC1_Handle;
00084
00089 typedef struct IVIDDEC1_Params VIDDEC1_Params;
00090
00094 typedef IVIDDEC1_InArgs          VIDDEC1_InArgs;
00095
00099 typedef IVIDDEC1_OutArgs         VIDDEC1_OutArgs;
00100
00104 typedef IVIDDEC1_Cmd             VIDDEC1_Cmd;
00105
00109 typedef IVIDDEC1_DynamicParams   VIDDEC1_DynamicParams;
00110
00117 extern SKEL_Fxns VIDDEC1_SKEL;
00118
00122 extern IVIDDEC1_Fxns VIDDEC1_STUBS;
00123
00129 typedef struct IVIDDEC1_CodecClassConfig {
00130     Bool manageInBufsCache     [ XDM_MAX_IO_BUFFERS ];
00131     Bool manageOutBufsCache    [ XDM_MAX_IO_BUFFERS ];
00132 } IVIDDEC1_CodecClassConfig;
00133
00134 /*
00135  *  ======== VIDDEC1_create ========
00136  */
00160 extern VIDDEC1_Handle VIDDEC1_create(Engine_Handle e, String name,
00161     VIDDEC1_Params *params);
00162
00163
00164 /*
00165  *  ======== VIDDEC1_process ========
00166  */
00204 extern Int32 VIDDEC1_process(VIDDEC1_Handle handle, XDM1_BufDesc *inBufs,
00205     XDM_BufDesc *outBufs, VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs);
00206
00207
00208 /*
00209  *  ======== VIDDEC1_control ========
00210  */
00233 extern Int32 VIDDEC1_control(VIDDEC1_Handle handle, VIDDEC1_Cmd id,
00234     VIDDEC1_DynamicParams *params, VIDDEC1_Status *status);
00235
00236
00237 /*
00238  *  ======== VIDDEC1_delete ========
00239  */
00257 extern Void VIDDEC1_delete(VIDDEC1_Handle handle);
00258
00259 /*
00260  *  ======== VIDDEC1_processAsync ========
00261  */
00298 extern XDAS_Int32 VIDDEC1_processAsync(VIDDEC1_Handle handle,
00299     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs,
00300     VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs);
00301
00302 /*
00303  *  ======== VIDDEC1_processWait ========
00304  */
00347 extern XDAS_Int32 VIDDEC1_processWait(VIDDEC1_Handle handle,
00348     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs,
00349     VIDDEC1_InArgs *inArgs, VIDDEC1_OutArgs *outArgs, UInt timeout);
00350   /* ingroup */
00352
00353 #ifdef __cplusplus
00354 }
00355 #endif
00356
00357 #endif
00358 /*
00359  *  @(#) ti.sdo.ce.video1; 1, 0, 2,266; 9-20-2010 16:43:17; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00360
00361  */
00362


Codec Engine Application Programming Interface (API): viddec2.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » video2

viddec2.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== viddec2.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_video2_VIDDEC2_
00053 #define ti_sdo_ce_video2_VIDDEC2_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/ividdec2.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00069 #define VIDDEC2_EOK      IVIDDEC2_EOK
00070 #define VIDDEC2_EFAIL    IVIDDEC2_EFAIL
00073 #define VIDDEC2_EUNSUPPORTED IVIDDEC2_EUNSUPPORTED
00074
00075 #define VIDDEC2_ETIMEOUT VISA_ETIMEOUT
00076 #define VIDDEC2_FOREVER  VISA_FOREVER
00081 typedef VISA_Handle VIDDEC2_Handle;
00082
00083 /* The following are just wrapper typedefs */
00084
00086 typedef IVIDDEC2_Params VIDDEC2_Params;
00087
00089 typedef IVIDDEC2_InArgs VIDDEC2_InArgs;
00090
00092 typedef IVIDDEC2_OutArgs VIDDEC2_OutArgs;
00093
00095 typedef IVIDDEC2_Cmd VIDDEC2_Cmd;
00096
00098 typedef IVIDDEC2_DynamicParams VIDDEC2_DynamicParams;
00099
00101 typedef IVIDDEC2_Status VIDDEC2_Status;
00102
00109 extern SKEL_Fxns VIDDEC2_SKEL;
00110
00114 extern IVIDDEC2_Fxns VIDDEC2_STUBS;
00115
00121 typedef struct IVIDDEC2_CodecClassConfig {
00122     Bool manageInBufsCache     [ XDM_MAX_IO_BUFFERS ];
00123     Bool manageOutBufsCache    [ XDM_MAX_IO_BUFFERS ];
00124 } IVIDDEC2_CodecClassConfig;
00125
00126
00127 /*
00128  *  ======== VIDDEC2_control ========
00129  */
00153 extern Int32 VIDDEC2_control(VIDDEC2_Handle handle, VIDDEC2_Cmd id,
00154     VIDDEC2_DynamicParams *params, VIDDEC2_Status *status);
00155
00156
00157 /*
00158  *  ======== VIDDEC2_create ========
00159  */
00187 extern VIDDEC2_Handle VIDDEC2_create(Engine_Handle e, String name,
00188     VIDDEC2_Params *params);
00189
00190
00191 /*
00192  *  ======== VIDDEC2_delete ========
00193  */
00211 extern Void VIDDEC2_delete(VIDDEC2_Handle handle);
00212
00213
00214 /*
00215  *  ======== VIDDEC2_process ========
00216  */
00255 extern Int32 VIDDEC2_process(VIDDEC2_Handle handle, XDM1_BufDesc *inBufs,
00256     XDM_BufDesc *outBufs, VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs);
00257
00258
00259 /*
00260  *  ======== VIDDEC2_processAsync ========
00261  */
00298 extern XDAS_Int32 VIDDEC2_processAsync(VIDDEC2_Handle handle,
00299     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs,
00300     VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs);
00301
00302 /*
00303  *  ======== VIDDEC2_processWait ========
00304  */
00347 extern XDAS_Int32 VIDDEC2_processWait(VIDDEC2_Handle handle,
00348     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs,
00349     VIDDEC2_InArgs *inArgs, VIDDEC2_OutArgs *outArgs, UInt timeout);
00350   /* ingroup */
00352
00353 #ifdef __cplusplus
00354 }
00355 #endif
00356
00357 #endif
00358 /*
00359  *  @(#) ti.sdo.ce.video2; 1, 0, 2,173; 9-20-2010 16:43:18; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00360
00361  */
00362


Codec Engine Application Programming Interface (API): viddec.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » video

viddec.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== viddec.h ========
00035  */
00051 #ifndef ti_sdo_ce_video_VIDDEC_
00052 #define ti_sdo_ce_video_VIDDEC_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 /*
00059  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00060  * define XDM_INCLUDE_DOT9_SUPPORT
00061  */
00062 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00063 #define XDM_INCLUDE_DOT9_SUPPORT
00064 #endif
00065 #include <ti/xdais/dm/xdm.h>
00066 #include <ti/xdais/dm/ividdec.h>
00067
00068 #include <ti/sdo/ce/Engine.h>
00069 #include <ti/sdo/ce/visa.h>
00070 #include <ti/sdo/ce/skel.h>
00071
00074
00075 typedef IVIDDEC_Status VIDDEC_Status;
00077 #define VIDDEC_EOK      IVIDDEC_EOK
00078 #define VIDDEC_EFAIL    IVIDDEC_EFAIL
00079 #define VIDDEC_ERUNTIME IVIDDEC_ERUNTIME
00080 #define VIDDEC_ETIMEOUT VISA_ETIMEOUT
00081 #define VIDDEC_FOREVER  VISA_FOREVER
00086 typedef VISA_Handle VIDDEC_Handle;
00087
00092 typedef struct IVIDDEC_Params VIDDEC_Params;
00093
00097 typedef IVIDDEC_InArgs          VIDDEC_InArgs;
00098
00102 typedef IVIDDEC_OutArgs         VIDDEC_OutArgs;
00103
00107 typedef IVIDDEC_Cmd             VIDDEC_Cmd;
00108
00112 typedef IVIDDEC_DynamicParams   VIDDEC_DynamicParams;
00113
00120 extern SKEL_Fxns VIDDEC_SKEL;
00121
00125 extern IVIDDEC_Fxns VIDDEC_STUBS;
00126
00134 typedef struct IVIDDEC_CodecClassConfig {
00142     Bool manageInBufsCache     [ XDM_MAX_IO_BUFFERS ];
00150     Bool manageOutBufsCache    [ XDM_MAX_IO_BUFFERS ];
00158     Bool manageDisplayBufsCache[ XDM_MAX_IO_BUFFERS ];
00159 } IVIDDEC_CodecClassConfig;
00160
00161 /*
00162  *  ======== VIDDEC_create ========
00163  */
00188 extern VIDDEC_Handle VIDDEC_create(Engine_Handle e, String name,
00189     VIDDEC_Params *params);
00190
00191
00192 /*
00193  *  ======== VIDDEC_process ========
00194  */
00233 extern Int32 VIDDEC_process(VIDDEC_Handle handle,
00234         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00235         VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs);
00236
00237
00238 /*
00239  *  ======== VIDDEC_control ========
00240  */
00264 extern Int32 VIDDEC_control(VIDDEC_Handle handle, VIDDEC_Cmd id,
00265         VIDDEC_DynamicParams *params, VIDDEC_Status *status);
00266
00267
00268 /*
00269  *  ======== VIDDEC_delete ========
00270  */
00288 extern Void VIDDEC_delete(VIDDEC_Handle handle);
00289
00290
00291 /*
00292  *  ======== VIDDEC_processAsync ========
00293  */
00330 extern XDAS_Int32 VIDDEC_processAsync(VIDDEC_Handle handle, XDM_BufDesc *inBufs,
00331     XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs);
00332
00333
00334 /*
00335  *  ======== VIDDEC_processWait ========
00336  */
00379 extern XDAS_Int32 VIDDEC_processWait(VIDDEC_Handle handle, XDM_BufDesc *inBufs,
00380     XDM_BufDesc *outBufs, VIDDEC_InArgs *inArgs, VIDDEC_OutArgs *outArgs,
00381     UInt timeout);
00382
00383
00386 #ifdef __cplusplus
00387 }
00388 #endif
00389
00390 #endif
00391 /*
00392  *  @(#) ti.sdo.ce.video; 1, 0, 3,405; 9-20-2010 16:43:15; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00393
00394  */
00395


Codec Engine Application Programming Interface (API): videnc1.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » video1

videnc1.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== videnc1.h ========
00035  */
00051 #ifndef ti_sdo_ce_video1_VIDENC1_
00052 #define ti_sdo_ce_video1_VIDENC1_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 #include <ti/xdais/dm/xdm.h>
00059 #include <ti/xdais/dm/ividenc1.h>
00060
00061 #include <ti/sdo/ce/Engine.h>
00062 #include <ti/sdo/ce/visa.h>
00063 #include <ti/sdo/ce/skel.h>
00064
00067
00068 typedef IVIDENC1_Status VIDENC1_Status;
00070 #define VIDENC1_EOK      IVIDENC1_EOK
00071 #define VIDENC1_EFAIL    IVIDENC1_EFAIL
00074 #define VIDENC1_EUNSUPPORTED IVIDENC1_EUNSUPPORTED
00075
00076 #define VIDENC1_ETIMEOUT VISA_ETIMEOUT
00077 #define VIDENC1_FOREVER  VISA_FOREVER
00082 typedef VISA_Handle VIDENC1_Handle;
00083
00088 typedef struct IVIDENC1_Params VIDENC1_Params;
00089
00093 typedef IVIDENC1_InArgs          VIDENC1_InArgs;
00094
00098 typedef IVIDENC1_OutArgs         VIDENC1_OutArgs;
00099
00103 typedef IVIDENC1_Cmd             VIDENC1_Cmd;
00104
00108 typedef IVIDENC1_DynamicParams   VIDENC1_DynamicParams;
00109
00116 extern SKEL_Fxns VIDENC1_SKEL;
00117
00121 extern IVIDENC1_Fxns VIDENC1_STUBS;
00122
00126 typedef struct IVIDENC1_CodecClassConfig {
00127     Bool manageInBufsCache     [ XDM_MAX_IO_BUFFERS ];
00128     Bool manageOutBufsCache    [ XDM_MAX_IO_BUFFERS ];
00129 } IVIDENC1_CodecClassConfig;
00130
00133 /*
00134  *  ======== VIDENC1_create ========
00135  */
00160 extern VIDENC1_Handle VIDENC1_create(Engine_Handle e, String name,
00161     VIDENC1_Params *params);
00162
00163
00164 /*
00165  *  ======== VIDENC1_process ========
00166  */
00204 extern Int32 VIDENC1_process(VIDENC1_Handle handle, IVIDEO1_BufDescIn *inBufs,
00205     XDM_BufDesc *outBufs, VIDENC1_InArgs *inArgs, VIDENC1_OutArgs *outArgs);
00206
00207
00208 /*
00209  *  ======== VIDENC1_control ========
00210  */
00238 extern Int32 VIDENC1_control(VIDENC1_Handle handle, VIDENC1_Cmd id,
00239     VIDENC1_DynamicParams *params, VIDENC1_Status *status);
00240
00241
00242 /*
00243  *  ======== VIDENC1_delete ========
00244  */
00262 extern Void VIDENC1_delete(VIDENC1_Handle handle);
00263
00264 /*
00265  *  ======== VIDENC1_processAsync ========
00266  */
00303 extern XDAS_Int32 VIDENC1_processAsync(VIDENC1_Handle handle,
00304     IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs,
00305     IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs);
00306
00307 /*
00308  *  ======== VIDENC1_processWait ========
00309  */
00352 extern XDAS_Int32 VIDENC1_processWait(VIDENC1_Handle handle,
00353     IVIDEO1_BufDescIn *inBufs, XDM_BufDesc *outBufs,
00354     IVIDENC1_InArgs *inArgs, IVIDENC1_OutArgs *outArgs, UInt timeout);
00355   /* ingroup */
00357
00358 #ifdef __cplusplus
00359 }
00360 #endif
00361
00362 #endif
00363 /*
00364  *  @(#) ti.sdo.ce.video1; 1, 0, 2,266; 9-20-2010 16:43:17; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00365
00366  */
00367


Codec Engine Application Programming Interface (API): videnc.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » video

videnc.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== videnc.h ========
00035  */
00051 #ifndef ti_sdo_ce_video_VIDENC_
00052 #define ti_sdo_ce_video_VIDENC_
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif
00057
00058 /*
00059  * By definition, this interface is 0.9 XDM.  Before including xdm.h,
00060  * define XDM_INCLUDE_DOT9_SUPPORT
00061  */
00062 #ifndef XDM_INCLUDE_DOT9_SUPPORT
00063 #define XDM_INCLUDE_DOT9_SUPPORT
00064 #endif
00065 #include <ti/xdais/dm/xdm.h>
00066 #include <ti/xdais/dm/ividenc.h>
00067
00068 #include <ti/sdo/ce/Engine.h>
00069 #include <ti/sdo/ce/visa.h>
00070 #include <ti/sdo/ce/skel.h>
00071
00074
00075 typedef IVIDENC_Status VIDENC_Status;
00077 #define VIDENC_EOK      IVIDENC_EOK
00078 #define VIDENC_EFAIL    IVIDENC_EFAIL
00079 #define VIDENC_ERUNTIME IVIDENC_ERUNTIME
00080 #define VIDENC_ETIMEOUT VISA_ETIMEOUT
00081 #define VIDENC_FOREVER  VISA_FOREVER
00086 typedef VISA_Handle VIDENC_Handle;
00087
00092 typedef struct IVIDENC_Params VIDENC_Params;
00093
00097 typedef IVIDENC_InArgs          VIDENC_InArgs;
00098
00102 typedef IVIDENC_OutArgs         VIDENC_OutArgs;
00103
00107 typedef IVIDENC_Cmd             VIDENC_Cmd;
00108
00112 typedef IVIDENC_DynamicParams   VIDENC_DynamicParams;
00113
00120 extern SKEL_Fxns VIDENC_SKEL;
00121
00125 extern IVIDENC_Fxns VIDENC_STUBS;
00126
00134 typedef struct IVIDENC_CodecClassConfig {
00135     Bool manageInBufsCache   [ XDM_MAX_IO_BUFFERS ];
00136     Bool manageOutBufsCache  [ XDM_MAX_IO_BUFFERS ];
00137     Bool manageReconBufsCache[ XDM_MAX_IO_BUFFERS ];
00138 } IVIDENC_CodecClassConfig;
00139
00140 /*
00141  *  ======== VIDENC_create ========
00142  */
00166 extern VIDENC_Handle VIDENC_create(Engine_Handle e, String name,
00167     VIDENC_Params *params);
00168
00169
00170 /*
00171  *  ======== VIDENC_process ========
00172  */
00211 extern Int32 VIDENC_process(VIDENC_Handle handle,
00212         XDM_BufDesc *inBufs, XDM_BufDesc *outBufs,
00213         VIDENC_InArgs *inArgs, VIDENC_OutArgs *outArgs);
00214
00215
00216 /*
00217  *  ======== VIDENC_control ========
00218  */
00242 extern Int32 VIDENC_control(VIDENC_Handle handle, VIDENC_Cmd id,
00243         VIDENC_DynamicParams *params, VIDENC_Status *status);
00244
00245
00246 /*
00247  *  ======== VIDENC_delete ========
00248  */
00266 extern Void VIDENC_delete(VIDENC_Handle handle);
00267
00268
00269 /*
00270  *  ======== VIDENC_processAsync ========
00271  */
00308 extern XDAS_Int32 VIDENC_processAsync(VIDENC_Handle handle, XDM_BufDesc *inBufs,
00309     XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs);
00310
00311
00312 /*
00313  *  ======== VIDENC_processWait ========
00314  */
00357 extern XDAS_Int32 VIDENC_processWait(VIDENC_Handle handle, XDM_BufDesc *inBufs,
00358     XDM_BufDesc *outBufs, IVIDENC_InArgs *inArgs, IVIDENC_OutArgs *outArgs,
00359     UInt timeout);
00360
00361
00364 #ifdef __cplusplus
00365 }
00366 #endif
00367
00368 #endif
00369 /*
00370  *  @(#) ti.sdo.ce.video; 1, 0, 3,405; 9-20-2010 16:43:15; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00371
00372  */
00373


Codec Engine Application Programming Interface (API): vidtranscode.h Source File

  • File List
  • Globals
packages » ti » sdo » ce » vidtranscode

vidtranscode.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== vidtranscode.h ========
00035  */
00036
00052 #ifndef ti_sdo_ce_vidtranscode_VIDTRANSCODE_
00053 #define ti_sdo_ce_vidtranscode_VIDTRANSCODE_
00054
00055 #ifdef __cplusplus
00056 extern "C" {
00057 #endif
00058
00059 #include <ti/xdais/dm/xdm.h>
00060 #include <ti/xdais/dm/ividtranscode.h>
00061
00062 #include <ti/sdo/ce/Engine.h>
00063 #include <ti/sdo/ce/visa.h>
00064 #include <ti/sdo/ce/skel.h>
00065
00068
00070 #define VIDTRANSCODE_EOK            IVIDTRANSCODE_EOK
00071
00073 #define VIDTRANSCODE_EFAIL          IVIDTRANSCODE_EFAIL
00074
00076 #define VIDTRANSCODE_EUNSUPPORTED   IVIDTRANSCODE_EUNSUPPORTED
00077
00079 #define VIDTRANSCODE_ETIMEOUT VISA_ETIMEOUT
00080
00082 #define VIDTRANSCODE_FOREVER  VISA_FOREVER
00083
00084
00088 typedef VISA_Handle VIDTRANSCODE_Handle;
00089
00094 typedef struct IVIDTRANSCODE_Params VIDTRANSCODE_Params;
00095
00097 typedef IVIDTRANSCODE_InArgs  VIDTRANSCODE_InArgs;
00099 typedef IVIDTRANSCODE_OutArgs VIDTRANSCODE_OutArgs;
00101 typedef IVIDTRANSCODE_Cmd     VIDTRANSCODE_Cmd;
00103 typedef IVIDTRANSCODE_Status  VIDTRANSCODE_Status;
00104
00106 typedef IVIDTRANSCODE_DynamicParams VIDTRANSCODE_DynamicParams;
00107
00108
00115 extern SKEL_Fxns VIDTRANSCODE_SKEL;
00116
00121 extern IVIDTRANSCODE_Fxns VIDTRANSCODE_STUBS;
00122
00126 /*
00127  *  ======== VIDTRANSCODE_control ========
00128  */
00153 extern Int32 VIDTRANSCODE_control(VIDTRANSCODE_Handle handle,
00154     VIDTRANSCODE_Cmd id, VIDTRANSCODE_DynamicParams *params,
00155     VIDTRANSCODE_Status *status);
00156
00157
00158 /*
00159  *  ======== VIDTRANSCODE_create ========
00160  */
00188 extern VIDTRANSCODE_Handle VIDTRANSCODE_create(Engine_Handle e, String name,
00189     VIDTRANSCODE_Params *params);
00190
00191
00192 /*
00193  *  ======== VIDTRANSCODE_delete ========
00194  */
00212 extern Void VIDTRANSCODE_delete(VIDTRANSCODE_Handle handle);
00213
00214
00215 /*
00216  *  ======== VIDTRANSCODE_process ========
00217  */
00256 extern Int32 VIDTRANSCODE_process(VIDTRANSCODE_Handle handle,
00257     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, VIDTRANSCODE_InArgs *inArgs,
00258     VIDTRANSCODE_OutArgs *outArgs);
00259
00260 /*
00261  *  ======== VIDTRANSCODE_processAsync ========
00262  */
00299 extern XDAS_Int32 VIDTRANSCODE_processAsync(VIDTRANSCODE_Handle handle,
00300     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs,
00301     IVIDTRANSCODE_OutArgs *outArgs);
00302
00303 /*
00304  *  ======== VIDTRANSCODE_processWait ========
00305  */
00349 extern XDAS_Int32 VIDTRANSCODE_processWait(VIDTRANSCODE_Handle handle,
00350     XDM1_BufDesc *inBufs, XDM_BufDesc *outBufs, IVIDTRANSCODE_InArgs *inArgs,
00351     IVIDTRANSCODE_OutArgs *outArgs, UInt timeout);
00352
00355 #ifdef __cplusplus
00356 }
00357 #endif
00358
00359 #endif
00360 /*
00361  *  @(#) ti.sdo.ce.vidtranscode; 1, 0, 1,224; 9-20-2010 16:43:23; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00362
00363  */
00364


Codec Engine Application Programming Interface (API): visa.h Source File

  • File List
  • Globals
packages » ti » sdo » ce

visa.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033 /*
00034  *  ======== visa.h ========
00035  */
00060 #ifndef ti_sdo_ce_VISA_
00061 #define ti_sdo_ce_VISA_
00062
00063 #include <stddef.h>     /* for size_t */
00064
00065 #include <ti/sdo/ce/node/node.h>
00066 #include <ti/xdais/ialg.h>
00067 #include <ti/sdo/ce/Engine.h>
00068
00069 #ifdef __cplusplus
00070 extern "C" {
00071 #endif
00072
00077 typedef Int VISA_Status;
00078
00083 #define VISA_EOK        0
00084
00089 #define VISA_ERUNTIME   -1
00090
00095 #define VISA_EFAIL     -2
00096
00101 #define VISA_ETIMEOUT  -100
00102
00107 #define VISA_FOREVER Engine_FOREVER
00108
00112 typedef struct VISA_Obj *VISA_Handle;
00113
00121 typedef struct VISA_MsgHeader {
00122     NODE_MsgHeader  header;
00123     Int             cmd;
00124     VISA_Status     status;
00125 } VISA_MsgHeader;
00126
00127 /*
00128  *  ======== VISA_Msg ========
00129  */
00130 typedef VISA_MsgHeader *VISA_Msg;
00131
00132 /*
00133  *  ======== VISA_allocMsg ========
00134  */
00149 extern VISA_Msg VISA_allocMsg(VISA_Handle visa);
00150
00151 /*
00152  *  ======== VISA_call ========
00153  */
00171 extern VISA_Status VISA_call(VISA_Handle visa, VISA_Msg *msg);
00172
00173 /*
00174  *  ======== VISA_callAsync ========
00175  */
00194 extern VISA_Status VISA_callAsync(VISA_Handle visa, VISA_Msg *msg);
00195
00196 /*
00197  *  ======== VISA_wait ========
00198  */
00219 extern VISA_Status VISA_wait(VISA_Handle visa, VISA_Msg *msg, UInt timeout);
00220
00221 /*
00222  *  ======== VISA_freeMsg ========
00223  */
00240 extern Void VISA_freeMsg(VISA_Handle visa, VISA_Msg msg);
00241
00242
00245
00246 /*
00247  *  ======== VISA_create ========
00248  */
00280 extern VISA_Handle VISA_create(Engine_Handle engine, String name,
00281     IALG_Params *params, size_t msgSize, String type);
00282
00283 /*
00284  *  ======== VISA_delete ========
00285  */
00293 extern Void VISA_delete(VISA_Handle visa);
00294
00295
00296 /*
00297  *  ======== VISA_create2 ========
00298  */
00337 extern VISA_Handle VISA_create2(Engine_Handle engine, String name,
00338     IALG_Params *params, Int paramsSize, size_t msgSize, String type);
00339
00340
00341 /*
00342  *  ======== VISA_enter ========
00343  */
00356 extern Void VISA_enter(VISA_Handle visa);
00357
00358 /*
00359  *  ======== VISA_exit ========
00360  */
00371 extern Void VISA_exit(VISA_Handle visa);
00372
00373 /*
00374  *  ======== VISA_getAlgHandle ========
00375  */
00389 extern Ptr VISA_getAlgHandle(VISA_Handle visa);
00390
00391 /*
00392  *  ======== VISA_getAlgorithmHandle ========
00393  */
00407 extern Ptr VISA_getAlgorithmHandle(VISA_Handle visa);
00408
00409 /*
00410  *  ======== VISA_getAlgFxns ========
00411  */
00433 extern IALG_Fxns *VISA_getAlgFxns(VISA_Handle visa);
00434   /* ingroup */
00436
00437 /*
00438  *  ======== VISA_getAlgMemRecs ========
00439  */
00470 extern VISA_Status VISA_getAlgMemRecs(VISA_Handle visa, IALG_MemRec *memTab,
00471         Int size, Int *numRecs);
00472
00473 /*
00474  *  ======== VISA_getAlgNumRecs ========
00475  */
00503 extern VISA_Status VISA_getAlgNumRecs(VISA_Handle visa, Int *numRecs);
00504
00505
00506 /*
00507  *  ======== VISA_getContext ========
00508  */
00527 extern Void VISA_getContext(VISA_Handle visa, UInt32 * pContext);
00528
00529 /*
00530  *  ======== VISA_getCodecClassConfig ========
00531  */
00548 extern Ptr VISA_getCodecClassConfig(VISA_Handle visa);
00549
00550
00551 /*
00552  *  ======== VISA_getMaxMsgSize ========
00553  */
00566 extern UInt VISA_getMaxMsgSize(VISA_Handle visa);
00567
00568
00569 /*
00570  *  ======== VISA_isChecked ========
00571  */
00585 static inline Bool VISA_isChecked(Void)
00586 {
00587     extern Bool VISA_checked;  /* generated by Settings.xdt based 'checked' */
00588
00589     return (VISA_checked);
00590 }
00591
00592 /*
00593  *  ======== VISA_setContext ========
00594  */
00611 extern Void VISA_setContext(VISA_Handle visa, UInt32 context);
00612
00613 /*
00614  *  ======== VISA_isLocal ========
00615  */
00626 extern Bool VISA_isLocal(VISA_Handle visa);
00627
00628 #ifdef __cplusplus
00629 }
00630 #endif
00631
00632 #endif
00633 /*
00634  *  @(#) ti.sdo.ce; 1, 0, 6,429; 9-20-2010 16:39:36; /db/atree/library/trees/ce/ce-r09x/src/ xlibrary
00635
00636  */
00637


Codec Engine Application Programming Interface (API): xdas.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais

xdas.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00045 #ifndef ti_xdais_XDAS_
00046 #define ti_xdais_XDAS_
00047
00048 #ifdef __cplusplus
00049 extern "C" {
00050 #endif
00051
00054
00055
00056 #define XDAS_TRUE       1
00057 #define XDAS_FALSE      0
00058
00059
00060 typedef Void            XDAS_Void;
00061 typedef Uint8           XDAS_Bool;
00062
00063
00064 typedef Int8            XDAS_Int8;
00065 typedef Uint8           XDAS_UInt8;
00066 typedef Int16           XDAS_Int16;
00067 typedef Uint16          XDAS_UInt16;
00068 typedef Int32           XDAS_Int32;
00069 typedef Uint32          XDAS_UInt32;
00073
00074
00075 #ifdef __cplusplus
00076 }
00077 #endif
00078
00079 #endif  /* ti_xdais_XDAS_ */
00080 /*
00081  *  @(#) ti.xdais; 1, 2.0, 1,249; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00082
00083  */
00084


Codec Engine Application Programming Interface (API): xdm.h Source File

  • File List
  • Globals
cetools » packages » ti » xdais » dm

xdm.h

Go to the documentation of this file.
00001 /*
00002  * Copyright (c) 2010, Texas Instruments Incorporated
00003  * All rights reserved.
00004  *
00005  * Redistribution and use in source and binary forms, with or without
00006  * modification, are permitted provided that the following conditions
00007  * are met:
00008  *
00009  * *  Redistributions of source code must retain the above copyright
00010  *    notice, this list of conditions and the following disclaimer.
00011  *
00012  * *  Redistributions in binary form must reproduce the above copyright
00013  *    notice, this list of conditions and the following disclaimer in the
00014  *    documentation and/or other materials provided with the distribution.
00015  *
00016  * *  Neither the name of Texas Instruments Incorporated nor the names of
00017  *    its contributors may be used to endorse or promote products derived
00018  *    from this software without specific prior written permission.
00019  *
00020  * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
00021  * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
00022  * THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
00023  * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
00024  * CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00025  * EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00026  * PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
00027  * OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
00028  * WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
00029  * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
00030  * EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00031  *
00032  */
00033
00046 #ifndef ti_xdais_dm_XDM_
00047 #define ti_xdais_dm_XDM_
00048
00049 #include <ti/xdais/ialg.h>
00050 #include <ti/xdais/xdas.h>
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif
00055
00058
00059 #define XDM_EOK                 IALG_EOK
00060 #define XDM_EFAIL               IALG_EFAIL
00061 #define XDM_EUNSUPPORTED        -3
00064 #ifdef XDM_INCLUDE_DOT9_SUPPORT
00065
00073 #define XDM_ERUNTIME            -2
00074 #endif
00075
00076 #define XDM_MAX_IO_BUFFERS      16
00160 typedef struct XDM_BufDesc {
00161     XDAS_Int8   **bufs;
00164     XDAS_Int32   numBufs;
00165     XDAS_Int32  *bufSizes;
00166 } XDM_BufDesc;
00167
00168
00172 typedef struct XDM_SingleBufDesc {
00173     XDAS_Int8   *buf;
00174     XDAS_Int32  bufSize;
00175 } XDM_SingleBufDesc;
00176
00177
00178
00182 typedef struct XDM1_SingleBufDesc {
00183     XDAS_Int8   *buf;
00184     XDAS_Int32  bufSize;
00185     XDAS_Int32  accessMask;
00211 } XDM1_SingleBufDesc;
00212
00213
00217 typedef struct XDM1_BufDesc {
00218     XDAS_Int32   numBufs;
00223     XDM1_SingleBufDesc descs[XDM_MAX_IO_BUFFERS];
00226 } XDM1_BufDesc;
00227
00228
00248 typedef enum {
00249     XDM_ACCESSMODE_READ = 0,
00255     XDM_ACCESSMODE_WRITE = 1
00261 } XDM_AccessMode;
00262
00263
00274 #define XDM_ISACCESSMODE_READ(x)    (((x) >> XDM_ACCESSMODE_READ) & 0x1)
00275
00276
00287 #define XDM_ISACCESSMODE_WRITE(x)   (((x) >> XDM_ACCESSMODE_WRITE) & 0x1)
00288
00289
00300 #define XDM_CLEARACCESSMODE_READ(x)   ((x) &= (~(0x1 << XDM_ACCESSMODE_READ)))
00301
00302
00313 #define XDM_CLEARACCESSMODE_WRITE(x)   ((x) &= (~(0x1 << XDM_ACCESSMODE_WRITE)))
00314
00315
00325 #define XDM_SETACCESSMODE_READ(x)   ((x) |= (0x1 << XDM_ACCESSMODE_READ))
00326
00327
00337 #define XDM_SETACCESSMODE_WRITE(x)  ((x) |= (0x1 << XDM_ACCESSMODE_WRITE))
00338
00339
00343 typedef struct XDM_AlgBufInfo {
00344     XDAS_Int32 minNumInBufs;
00345     XDAS_Int32 minNumOutBufs;
00346     XDAS_Int32 minInBufSize[XDM_MAX_IO_BUFFERS];
00349     XDAS_Int32 minOutBufSize[XDM_MAX_IO_BUFFERS];
00352 } XDM_AlgBufInfo;
00353
00354
00369 #define XDM_CUSTOMENUMBASE 0x100
00370
00371
00388 #define XDM_CUSTOMCMDBASE 0x100
00389
00409 typedef enum {
00410     XDM_GETSTATUS = 0,
00411     XDM_SETPARAMS = 1,
00412     XDM_RESET = 2,
00416     XDM_SETDEFAULT = 3,
00439     XDM_FLUSH = 4,
00455     XDM_GETBUFINFO = 5,
00469     XDM_GETVERSION = 6,
00477     XDM_GETCONTEXTINFO = 7
00483 } XDM_CmdId;
00484
00485
00504 typedef enum {
00505     XDM_PARAMSCHANGE = 8,
00517     XDM_APPLIEDCONCEALMENT = 9,
00530     XDM_INSUFFICIENTDATA = 10,
00547     XDM_CORRUPTEDDATA = 11,
00557     XDM_CORRUPTEDHEADER = 12,
00571     XDM_UNSUPPORTEDINPUT = 13,
00591     XDM_UNSUPPORTEDPARAM = 14,
00612     XDM_FATALERROR = 15
00634 } XDM_ErrorBit;
00635
00637 #define XDM_ISFATALERROR(x)         (((x) >> XDM_FATALERROR) & 0x1)
00638
00639 #define XDM_ISUNSUPPORTEDPARAM(x)   (((x) >> XDM_UNSUPPORTEDPARAM) & 0x1)
00640
00641 #define XDM_ISUNSUPPORTEDINPUT(x)   (((x) >> XDM_UNSUPPORTEDINPUT) & 0x1)
00642
00643 #define XDM_ISCORRUPTEDHEADER(x)    (((x) >> XDM_CORRUPTEDHEADER) & 0x1)
00644
00645 #define XDM_ISCORRUPTEDDATA(x)      (((x) >> XDM_CORRUPTEDDATA) & 0x1)
00646
00647 #define XDM_ISINSUFFICIENTDATA(x)   (((x) >> XDM_INSUFFICIENTDATA) & 0x1)
00648
00649 #define XDM_ISAPPLIEDCONCEALMENT(x) (((x) >> XDM_APPLIEDCONCEALMENT) & 0x1)
00650
00652 #define XDM_SETFATALERROR(x)         ((x) |= (0x1 << XDM_FATALERROR))
00653
00654 #define XDM_SETUNSUPPORTEDPARAM(x)   ((x) |= (0x1 << XDM_UNSUPPORTEDPARAM))
00655
00656 #define XDM_SETUNSUPPORTEDINPUT(x)   ((x) |= (0x1 << XDM_UNSUPPORTEDINPUT))
00657
00658 #define XDM_SETCORRUPTEDHEADER(x)    ((x) |= (0x1 << XDM_CORRUPTEDHEADER))
00659
00660 #define XDM_SETCORRUPTEDDATA(x)      ((x) |= (0x1 << XDM_CORRUPTEDDATA))
00661
00662 #define XDM_SETINSUFFICIENTDATA(x)   ((x) |= (0x1 << XDM_INSUFFICIENTDATA))
00663
00664 #define XDM_SETAPPLIEDCONCEALMENT(x) ((x) |= (0x1 << XDM_APPLIEDCONCEALMENT))
00665
00666
00674 typedef enum {
00675     XDM_BYTE = 1,
00676     XDM_LE_16 = 2,
00677     XDM_LE_32 = 3,
00678     XDM_LE_64 = 4,
00679     XDM_BE_16 = 5,
00680     XDM_BE_32 = 6,
00681     XDM_BE_64 = 7
00682 } XDM_DataFormat;
00683
00684
00688 typedef struct XDM_Date {
00689     XDAS_Int32 msecsOfDay;
00690     XDAS_Int32 month;
00691     XDAS_Int32 dayOfMonth;
00692     XDAS_Int32 dayOfWeek;
00693     XDAS_Int32 year;
00694 } XDM_Date;
00695
00696
00700 typedef struct XDM_Point {
00701     XDAS_Int32 x;
00702     XDAS_Int32 y;
00703 } XDM_Point;
00704
00705
00709 typedef struct XDM_Rect {
00710     XDM_Point topLeft;
00711     XDM_Point bottomRight;
00712 } XDM_Rect;
00713
00717 #define XDM_MAX_CONTEXT_BUFFERS   32
00718
00719
00723 typedef struct XDM_ContextInfo {
00724     XDAS_Int32 minContextSize;
00727     XDAS_Int32 minIntermediateBufSizes[XDM_MAX_CONTEXT_BUFFERS];
00736 } XDM_ContextInfo;
00737
00738
00742 typedef struct XDM_Context {
00743     XDM1_SingleBufDesc algContext;
00750     XDAS_Int32 numInBufs;
00751     XDAS_Int32 numOutBufs;
00752     XDAS_Int32 numInOutBufs;
00753     XDM1_SingleBufDesc inBufs[XDM_MAX_CONTEXT_BUFFERS];
00758     XDM1_SingleBufDesc outBufs[XDM_MAX_CONTEXT_BUFFERS];
00763     XDM1_SingleBufDesc inOutBufs[XDM_MAX_CONTEXT_BUFFERS];
00769     XDM1_SingleBufDesc intermediateBufs[XDM_MAX_CONTEXT_BUFFERS];
00794 } XDM_Context;
00795
00796
00804 typedef enum {
00805     XDM_DEFAULT = 0,
00809     XDM_HIGH_QUALITY = 1,
00810     XDM_HIGH_SPEED = 2,
00811     XDM_USER_DEFINED = 3
00814 } XDM_EncodingPreset;
00815
00816
00824 typedef enum {
00825     XDM_DECODE_AU = 0,
00828     XDM_PARSE_HEADER = 1
00829 } XDM_DecMode;
00830
00831
00839 typedef enum {
00840     XDM_ENCODE_AU = 0,
00843     XDM_GENERATE_HEADER = 1
00844 } XDM_EncMode;
00845
00846
00854 typedef enum {
00855     XDM_CHROMA_NA = -1,
00856     XDM_YUV_420P = 1,
00857     XDM_YUV_422P = 2,
00858     XDM_YUV_422IBE = 3,
00859     XDM_YUV_422ILE = 4,
00860     XDM_YUV_444P = 5,
00861     XDM_YUV_411P = 6,
00862     XDM_GRAY = 7,
00863     XDM_RGB = 8,
00864     XDM_YUV_420SP = 9,
00867     XDM_ARGB8888 = 10,
00868     XDM_RGB555 = 11,
00869     XDM_RGB565 = 12,
00870     XDM_YUV_444ILE = 13,
00872     XDM_CHROMAFORMAT_DEFAULT = XDM_YUV_422ILE
00873 } XDM_ChromaFormat;
00874
00875
00879 #ifdef __cplusplus
00880 }
00881 #endif
00882
00883 #endif  /* ti_xdais_dm_XDM_ */
00884 /*
00885  *  @(#) ti.xdais.dm; 1, 0, 5,251; 9-18-2010 14:46:05; /db/wtree/library/trees/dais/dais-t03x/src/ xlibrary
00886
00887  */
00888