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IMPORTANT NOTICE 

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other 
changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant 
information before placing orders and should verify that such information is current and complete. All products are sold subject to TI’s terms and 
conditions of sale supplied at the time of order acknowledgment. 

TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI’s standard warranty. Testing 
and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government 
requirements, testing of all parameters of each product is not necessarily performed. 

TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI 
components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating 
safeguards. 

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right, or other TI 
intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI 
regarding third-party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. 
Use of such information may require a license from a third party under the patents or other intellectual property of the third party, or a license from TI 
under the patents or other intellectual property of TI. 

Reproduction of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all 
associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. 
TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions. 

Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and 
any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any 
such statements. 

TI products are not authorized for use in safety-critical applications (such as life support) where a failure of the TI product would reasonably be expected 
to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing such use. Buyers represent 
that they have all necessary expertise in the safety and regulatory ramifications of their applications, and acknowledge and agree that they are solely 
responsible for all legal, regulatory and safety-related requirements concerning their products and any use of TI products in such safety-critical 
applications, notwithstanding any applications-related information or support that may be provided by TI. Further, Buyers must fully indemnify TI and its 
representatives against any damages arising out of the use of TI products in such safety-critical applications.  

TI products are neither designed nor intended for use in military/aerospace applications or environments unless the TI products are specifically 
designated by TI as military-grade or "enhanced plastic." Only products designated by TI as military-grade meet military specifications. Buyers 
acknowledge and agree that any such use of TI products which TI has not designated as military-grade is solely at the Buyer's risk, and that they are 
solely responsible for compliance with all legal and regulatory requirements in connection with such use.  

TI products are neither designed nor intended for use in automotive applications or environments unless the specific TI products are designated by TI 
as compliant with ISO/TS 16949 requirements. Buyers acknowledge and agree that, if they use any non-designated products in automotive 
applications, TI will not be responsible for any failure to meet such requirements. 

Following are URLs where you can obtain information on other Texas Instruments products and application solutions: 

Products    Applications    

Amplifiers amplifier.ti.com  Audio www.ti.com/audio  

Data Converters dataconverter.ti.com  Automotive www.ti.com/automotive  

DLP® Products www.dlp.com  Broadband www.ti.com/broadband  

DSP dsp.ti.com  Digital Control www.ti.com/digitalcontrol  

Clocks and Timers www.ti.com/clocks  Military www.ti.com/military  

Interface interface.ti.com  Optical Networking www.ti.com/opticalnetwork  

Logic logic.ti.com  Security www.ti.com/security  

Power Mgmt power.ti.com  Telephony www.ti.com/telephony  

Microcontrollers microcontroller.ti.com  Video & Imaging www.ti.com/video  

RFID www.ti-rfid.com Wireless www.ti.com/wireless  

RF/IF and ZigBee® Solutions www.ti.com/lprf    

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265 
Copyright © 2010, Texas Instruments Incorporated 
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Preface 

Read This First 
 

About This Manual 
This document describes the process of installing and using SYS/BIOS 6.33 for use with 
Code Composer Studio v5.1 (CCSv5.1). 

Previous versions of SYS/BIOS were called DSP/BIOS. The new name reflects that the 
kernel can also be use on processors other than DSPs. 

How to Use This Manual 
This document provides installation instructions in Chapter 1 and step-by-step instructions 
for starting to use SYS/BIOS in Chapter 2. 

After you install SYS/BIOS, you might want to review the release notes in the installation 
before reading further. 

After you have read this document, you should see the SYS/BIOS 6.33 User’s Guide 
(SPRUEX3) and the online CDOC reference for more information. 

Notational Conventions 
This document uses the following conventions: 

• Program listings, program examples, and interactive displays are shown in a special 
typeface. Examples use a bold version of the special typeface for emphasis. 

Here is a sample program listing: 

      #include <xdc/runtime/System.h> 
 
      int main(){ 
          System_printf("Hello World!\n"); 
          return (0); 
      } 

• Square brackets ( [ and ] ) identify an optional parameter. If you use an optional 
parameter, you specify the information within the brackets. Unless the square 
brackets are in a bold typeface, do not enter the brackets themselves.  

Related Documentation from Texas Instruments 
See Sections 1.9 and 1.10 in this document for a detailed list of other documentation 
resources. 
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Trademarks 

The Texas Instruments logo and Texas Instruments are registered trademarks of Texas 
Instruments. Trademarks of Texas Instruments include: TI, Code Composer, Code 
Composer Studio, DSP/BIOS, SYS/BIOS, SPOX, TMS320, TMS320C54x, TMS320C55x, 
TMS320C62x, TMS320C64x, TMS320C67x, TMS320C28x, TMS320C5000, 
TMS320C6000 and TMS320C2000. 

Windows is a registered trademark of Microsoft Corporation. 

Linux is a registered trademark of Linus Torvalds. 

All other brand or product names are trademarks or registered trademarks of their 
respective companies or organizations. 

 



 

 

Contents 
 

 
Read This First ......................................................................................................................................... iii 

About This Manual .............................................................................................................................. iii 
How to Use This Manual ..................................................................................................................... iii 
Notational Conventions ....................................................................................................................... iii 
Related Documentation from Texas Instruments ............................................................................... iii 
Trademarks ......................................................................................................................................... iv 

Contents .................................................................................................................................................. 0-5 
Using SYS/BIOS with CCSv5.1 ............................................................................................................. 1-6 

1.1 Installing SYS/BIOS as Part of CCSv5.1 ................................................................................. 1-6 
1.2 Creating Projects that Use SYS/BIOS 6.33 ............................................................................ 1-7 
1.3 Project Templates .................................................................................................................... 1-9 
1.4 Working with CCS Build Settings .......................................................................................... 1-10 
1.5 Using XGCONF to Configure SYS/BIOS Modules and Objects ........................................... 1-11 
1.6 Building a SYS/BIOS Project ................................................................................................. 1-12 
1.7 Running a SYS/BIOS Project ................................................................................................ 1-12 
1.8 Using SYS/BIOS as a Standalone Product ........................................................................... 1-13 
1.9 More About SYS/BIOS........................................................................................................... 1-14 
1.10 More About XDCtools ............................................................................................................ 1-15 

 

 

 

 

 



 

6 

Chapter 1 

Using SYS/BIOS with CCSv5.1 
 

This chapter describes how to build SYS/BIOS examples and applications. 

Topic Page 

1.1 Installing SYS/BIOS as Part of CCSv5.1 ...............................................................................6 

1.2 Creating Projects that Use SYS/BIOS 6.33 ...........................................................................7 

1.3 Project Templates ..................................................................................................................9 

1.4 Working with CCS Build Settings ....................................................................................... 10 

1.5 Using XGCONF to Configure SYS/BIOS Modules and Objects ......................................... 11 

1.6 Building a SYS/BIOS Project ............................................................................................... 12 

1.7 Running a SYS/BIOS Project............................................................................................... 12 

1.8 Using SYS/BIOS as a Standalone Product ......................................................................... 13 

1.9 More About SYS/BIOS ......................................................................................................... 14 

1.10 More About XDCtools ........................................................................................................ 15 

 
 

1.1 Installing SYS/BIOS as Part of CCSv5.1 

If you are installing Code Composer Studio v5.1 (CCSv5.1), all the components 
you need in order to use SYS/BIOS 6.33 can be installed as part of the CCSv5.1 
installation. When you perform the CCSv5.1 installation, make sure the 
checkboxes are selected for installing XDCtools and SYS/BIOS 6.33 for your 
specific platform or alternately select to install everything at the top level of the 
installer. 
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1.2 Creating Projects that Use SYS/BIOS 6.33 

Follow these steps to use CCSv5.1 to create a CCS project that can use 
SYS/BIOS 6.33. If you are using a different version of CCS, the steps may vary 
somewhat. 

1) Open CCSv5.1 and choose New Project from the “Welcome to Code 
Composer Studio v5” page or File > New > CCS Project from the menu bar. 

2) In the New CCS Project dialog, type a Project name. For example, to begin 
creating a project using the "log" example provided with SYS/BIOS, you can 
type "bioslog". The default project location automatically reflects the project 
name. 

3) Select your device family in the Family field. For example, you might select 
"C6000". 

4) In the Variant row, select a filter in the first field. This shortens the list of 
device variants in the second field. Then, select the actual device you are 
using. For example, you might select “DaVinci DM64x” in the filter field and 
"TMS320DM647" in the second field.  

5) You may also choose a Connection type to specify your emulator or 
simulator. 

 

6) Depending on your device, you might also need to adjust the Device 
Endianness setting under Advanced settings. 
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7) In the “Project Templates and examples” area, expand the SYS/BIOS > 
Generic Examples list to see the available examples. When you highlight a 
template, a brief description is provided to the right. For a sample first 
project, select the Sample: Log Example. 

8) Click Next (not Finish). 

 
9) On the “RTSC Configuration Settings” page, make sure the versions of 

XDCtools, SYS/BIOS, and other products that you want to use are selected 
and compatible.  Check the release notes “Dependencies” section or the 
SYS/BIOS software downloads site for recommended compatible versions.  
By default, the most recent versions installed are selected. 

 

http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/bios/sysbios/index.html
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10) Also on the “RTSC Configuration Settings” page, click the drop-down arrow 
next to the Platform field. CCSv5.1 scans the available packages for 
available platforms. After the list has been created, click on the list and 
choose the platform you want to use. (The Target setting is based on device 
settings you made on earlier pages, and should not need to be changed.) 

11) Choose which libraries you want the configuration build to link with in the 
Build-Profile field. The default “release” option is a good choice when you 
are first using SYS/BIOS with CCS. Then, click Finish.   

 

This adds a new project to the C/C++ Projects list in CCS. The project contains 
both the log.c source file and the log.cfg SYS/BIOS configuration file, which 
contains the static configuration of XDCtools and SYS/BIOS modules and 
objects. 

For more details, see Section 2.1 of the SYS/BIOS User’s Guide. 

1.3 Project Templates 

When you create a CCSv5.1 project, you select a Project Template. SYS/BIOS 
templates are in the SYS/BIOS category. The following SYS/BIOS templates are 
available when you choose File > New > CCS Project and get to the Project 
Templates page of the project creation wizard. 

• C++ Example (bigtime) 
• Clock Example 
• Error Example 
• Event Example 
• Hello Example 
• Log Example 
• Memory Example 
• Small Example 
• Stairstep Example 
• Static Example 
• Swi Example 
• Task Mutex Example 
• Task Mutex Example (separate config project).  
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The template with a separate configuration project creates two projects--one to 
contain the C source and one to contain the SYS/BIOS configuration file. 
Separating the application into two projects allows you to share the configuration 
project with multiple C source code projects. 

1.4 Working with CCS Build Settings 

After you have created a project that contains a SYS/BIOS configuration file, you 
can change the properties of the project in CCSv5.1 by right-clicking the project 
name and choosing Properties. Choose the “CCS General” category and then 
the “RTSC” tab. You can change the settings you made on the “RTSC 
Configuration Settings” page of the project creation wizard. See Section 1.2. 

In the “CCS General” category of the Properties dialog, the General tab applies 
to compiler settings, and the RTSC tab applies to the “configuro” utility provided 
by XDCtools to process the .cfg file. 

If your C source code and your SYS/BIOS configuration file are stored in 
separate projects, note that your build settings for both projects must match or be 
compatible. If you change the build settings for a configuration project, you 
should also change the build settings for application projects that use that 
configuration. 

Note that if there is any platform-specific configuration in your .cfg file, you much 
change those settings in addition to any changes you make to the CCS Build 
Settings. 

For more details, see Section 2.3 of the SYS/BIOS User’s Guide. 
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1.5 Using XGCONF to Configure SYS/BIOS Modules and Objects 

XGCONF is a tool that allows you to graphically create and view SYS/BIOS 
configuration scripts. (If you have used DSP/BIOS 5.x, it is somewhat similar to 
the DSP/BIOS Configuration Tool.)  

To start XGCONF, right-click on a *.cfg file in the "C/C++ Projects" view and 
select Open with > XGCONF. 

 

For more details, see Section 2.2 of the SYS/BIOS User’s Guide. 
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1.6 Building a SYS/BIOS Project 

To build your project, click on the project “bioslog [Active – Debug]” so it is 
highlighted and then choose Project > Build Active Project from the CCSv5.1 
menus. 

You will see messages about the build’s progress in a Console window. The 
“Invoking: XDCtools” section of the messages provides information about 
processing of the SYS/BIOS configuration file. For SYS/BIOS projects, this is 
performed before the compiler and linker are run. 

For more details, see Section 2.3 of the SYS/BIOS User’s Guide. 

1.7 Running a SYS/BIOS Project 

1) To run your project, choose Run > Debug from the CCSv5.1 menus. If this is 
the first time you are debugging a project for your target, you may need to set 
up a CCS Target Configuration. See the CCSv5.1 help or Section 2.3.4 of 
the SYS/BIOS User’s Guide for details. 

2) In the Debug perspective, open the Runtime Object Viewer (ROV) tool by 
choosing Tools > ROV. Also open the Raw Logs view by choosing Tools > 
RTA > Raw Logs. These tools allow you to see the activity of XDCtools and 
SYS/BIOS modules. 

3) Set some breakpoints in the log.c source file. (You can do this by right-
clicking on a line and choosing New Breakpoint > Breakpoint.) For 
example, set a breakpoint on the last line of each function in log.c. 

4) Run the application. 

5) In the Raw Logs window, you can see the informational, warning, and error 
messages sent by the calls to Log module APIs in log.c. The messages that 
begin with “LM” are diagnostics provided by XDCtools. Messages that begin 
with “WARNING” come from calls to Log_warning2. Messages that begin 
with “ERROR” come from calls to Log_error2. Messages that begin with 
“../log.c” come from calls to Log_info0 and Log_info2 (depending on the 
number of arguments). 

 

6) In the ROV window, expand the tree to see the ti.sysbios.knl.Task module. 
The right pane shows a list of the Task threads in the application. As you 
advance from breakpoint to breakpoint, you see the run mode of the threads 
change. 
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For more details, see Chapter 8 of the SYS/BIOS User’s Guide. 

1.8 Using SYS/BIOS as a Standalone Product 

You can also install SYS/BIOS for use outside of CCS.  

In order to use SYS/BIOS, you must also install XDCtools. See the XDCtools 
Getting Started Guide for installation instructions. XDCtools provides tools to 
build projects that contain the configuration files used by SYS/BIOS.  

To install SYS/BIOS as standalone software, follow these steps: 

1) Place the distribution file into a temporary location.  

2) Double-click on the distribution file to start the installation process. The 
installation directory, <bios_install_dir>, can be anywhere on your system, 
but make sure there are no spaces in the full path to <bios_install_dir>. 
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3) View documentation for the SYS/BIOS 6.33 packages at 
<bios_install_dir>/docs. 

You can build SYS/BIOS applications, including processing the SYS/BIOS 
configuration file, on the command line on Windows or Linux using makefiles. 
When you use a makefile to build, you can compile and link with the TI Code 
Generation Tools, the GCC compiler for your target, or other command-line 
compilers. 

For more details, see Section 2.3.3 of the SYS/BIOS User’s Guide. For sample 
files to download, see the SYS/BIOS with GCC topic on the TI Embedded 
Processors Wiki. 

1.9 More About SYS/BIOS 

To learn more about using SYS/BIOS, see the following: 

• SYS/BIOS Release Notes. In the top-level SYS/BIOS installation directory, or 
choose Help > Help Contents in CCSv5.1 and expand the SYS/BIOS item. 

• SYS/BIOS User’s Guide (SPRUEX3). In <bios_install_dir>/docs, or choose 
Help > Help Contents in CCSv5.1 and expand the SYS/BIOS item. Also 
available on the Texas Instruments website.  

• Migrating a DSP/BIOS 5 Application to SYS/BIOS 6 (SPRAAS7). In 
<bios_install_dir>/docs/ Bios_Legacy_App_Note.pdf, or choose Help > Help 
Contents in CCSv5.1 and expand the SYS/BIOS item. Also available on the 
Texas Instruments website. 

• SYS/BIOS API Reference (also called "CDOC"). Run 
<bios_install_dir>/docs/cdoc/index.html, or choose Help > Help Contents in 
CCSv5.1 and expand the SYS/BIOS item.  

• SYS/BIOS main page on the TI Embedded Processors Wiki. This page 
provides links to many resources for using SYS/BIOS. 

• BIOS forum on TI’s E2E Community. 

• SYS/BIOS 6.x Product Folder on ti.com 

• Embedded Software Download Page  

 

To learn more about using Code Composer Studio (CCS) v5.1, see the following: 

• CCS online help. Choose Help > Help Contents in CCSv5.1. 

• CCSv5 main page on the TI Embedded Processors Wiki  

• Code Composer forum on TI’s E2E Community  

http://processors.wiki.ti.com/index.php/SYS/BIOS_with_GCC
http://www.ti.com/lit/pdf/spruex3
http://www.ti.com/lit/pdf/spraas7
http://processors.wiki.ti.com/index.php/Category:SYSBIOS
http://e2e.ti.com/support/embedded/f/355.aspx
http://focus.ti.com/docs/toolsw/folders/print/dspbios6.html
http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/index.html
http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v5
http://e2e.ti.com/support/development_tools/code_composer_studio/f/81.aspx
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1.10 More About XDCtools 

XDCtools is a set of tools that enable the creation and use of software packages. 
It allows products to be developed as reusable packages. (RTSC is the 
underlying standard that is implemented by XDCtools.) 

XDCtools defines the configuration language used by SYS/BIOS (and other 
products that use XDCtools). For SYS/BIOS 6.x versions, the SYS/BIOS 
configuration scripts are stored in .cfg and other files. 

To learn more about using XDCtools, see the following: 

• XDCtools API Reference (also called "CDOC"). Run 
<xdctools_install_dir>/docs/xdctools.chm, or choose Help > Help Contents 
in CCSv5.1 and expand the XDCtools item.  

• RTSC-Pedia Wiki  

• BIOS forum on TI’s E2E Community  

• Embedded Software Download Page 

 

http://rtsc.eclipse.org/docs-tip
http://e2e.ti.com/support/embedded/f/355.aspx
http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/index.html
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