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CC3200 Tools Setup 

Introduction 
There are two main sections to this lab: 

1. Pre-work to be completed prior to the seminar. 

2. Final lab steps to install the CC3200 LaunchPad driver. 

The pre-work includes downloading and installing several software packages from the Texas 
Instruments website. It also includes the steps to import and build some Code Composer Studio 
projects that are needed for the CC3200 software examples in the Software Development Kit 
(SDK). 

The final steps of the lab require you to plug in a CC3200 LaunchPad board. Since you will 
receive this board at the seminar, this section of the lab will be performed at the seminar. 

Timing 
The pre-work for this lab should take from 45-60 minutes to complete, depending on the speed of 
your internet connection. The final steps at the workshop should take only 5-10 minutes, once 
you receive your CC3200 LaunchPad board. 

Prerequisites 
To run these labs you will need a Microsoft® Windows® 7 laptop with a good internet connection. 

Optional: Android or iOS smartphone to install SimpleLink Wi-Fi Starter application 
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CC3200 Software Development Kit (SDK) 
1. Download the CC3200 SDK version 0.5.2. The seminar labs are built with the version of 

the SDK. There may be later versions available, but this is the version you will need for 
the seminar. 

 ► Go to: 

 http://software-dl.ti.com/dsps/forms/self_cert_export.html?prod_no=CC3200SDK-0.5.2-
windows-installer.exe&ref_url=http://software-dl.ti.com/ecs/cc31xx/sdk/cc3200_sdk_v0_5_2 

 ► You must fill in the U.S. Government export approval fields to download this software. This 
will be the same procedure for several of the software packages you will need. 

2. Install the CC3200 SDK 

 ► Run the installer and choose the default installation folder c:\ti\CC3200SDK 

Note: ► If you already have the CC3200 SDK installed, this installer will over-write your current 
installation. If you have made any edits/additions to the SDK files, you should re-name 
your current installation folder. 

  
  

http://software-dl.ti.com/dsps/forms/self_cert_export.html?prod_no=CC3200SDK-0.5.2-windows-installer.exe&ref_url=http://software-dl.ti.com/ecs/cc31xx/sdk/cc3200_sdk_v0_5_2
http://software-dl.ti.com/dsps/forms/self_cert_export.html?prod_no=CC3200SDK-0.5.2-windows-installer.exe&ref_url=http://software-dl.ti.com/ecs/cc31xx/sdk/cc3200_sdk_v0_5_2
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SimpleLink Wi-Fi Starter Application 
If you have an Android or iOS device, download and install the “SimpleLink Wi-Fi Starter 
Application” from the App Store or Google Play. This application allows you to configure the 
CC3200s Wi-Fi network information for the first time, using Smart Config (the first tab). A second 
tab shows you a list of devices that are connected to the Wi-Fi network. A third tab lets you set 
options to show or hide device information. 

3. Download and install the application to your Android or iOS Device 

 ► Using your Android or iOS device browser, go to http://www.ti.com/tool/wifistarter and click 
on the appropriate download link (App Store or Google Play) 

 

 

 Note that you can also download the source code for either application from this page but you 
won’t need that for the seminar. 

  

http://www.ti.com/tool/wifistarter
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 ► For the Android app you will see this. Click on the INSTALL button to install. 

 
 . 

 ► For the iOS app you will see this. Click on the INSTALL button to install. Note: In this 
screenshot, the app was already installed, so you see the OPEN button instead. 
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Install Arrow IoT Seminar Files 
4. Download the Arrow IoT Seminar Installer 

 ► Go to http://processors.wiki.ti.com/index.php/Arrow_IoT_Seminar_2014  and click on the 
Arrow IoT Seminar Installer download link. 

 

5. Run the Arrow IoT Seminar Installer 

 ► Run the installer and choose the default installation folder c:\Arrow_IoT_Seminar 

 This will install the project files we’ll use in the seminar, along with some documentation files. 

  

 

http://processors.wiki.ti.com/index.php/Arrow_IoT_Seminar_2014
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Install Code Composer Studio (CCS) 
6. Download Code Composer Studio (CCS) version 6.0.1.00040 or later 

 ► Go to http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v6  and 
click on the Windows Download link. 

7. Install CCS 

 ► Run the installer program and when prompted for Processor Support, select “SimpleLink 
Wireless MCUs”. For the remaining options, select the default values. You should also 
temporarily turn off your anti-virus software for this installation. The installation time is 
typically 20 minutes, but can vary based on internet connection speed. If you are using 
additional processors you can install those as well. 

 

Hint: If you previously installed CCS version 6.0.1.00040 (or later) and you do NOT yet 
have SimpleLink Wireless MCUs support installed, you have two choices: 
 
1. We recommend that you re-install CCS. You can just delete or rename the 
c:\ti\ccsv6 folder, and then re-install CCS with the processor support you need, 
including the Wireless Connectivity MCUs. This has the advantage of giving you a 
clean installation, and might be more reliable than the next option. 
 
2. You can keep your current installation, and just install the Wireless Connectivity 
MCU support on top of your existing CCS. With CCS v6, this seems to work in most 
cases. You can’t remove existing installed processor support very easily, but it is 
possible to add new support. Simply run the installer and check the box for Wireless 
Connectivity MCUs. 

NOTE: 
This is the only processor 
support used in the seminar, 
although you can choose 
others if you need them. 
You can also install other 
processors later if needed. 

http://processors.wiki.ti.com/index.php/Category:Code_Composer_Studio_v6
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Note: The link we showed in the previous step is for the “online” installer. If you have any 
problems installing using this link, you can try downloading a zip file of the full “Off-line” 
installer from: 
http://processors.wiki.ti.com/index.php/Download_CCS#Code_Composer_Studio_Version_6_Downloads.  

 
  

 Should you decide to download this zip file, you should un-zip the file to a folder before 
running the installer. 

 
  

http://processors.wiki.ti.com/index.php/Download_CCS#Code_Composer_Studio_Version_6_Downloads
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8. Install CC3200 Add-on Update and TI-RTOS for SimpleLink add-on from the CCS App 
Center: 

 ► Start CCS, and choose a Workspace folder (choose the default folder). 

 ► Open the App Center from the Help->Getting Started screen. 

► Search 'cc3200' in the App Center to find ‘CC3200 Add-On and 'TI-RTOS for SimpleLink' 

 ► Select the update box for CC3200 Add-On and select the box for TI-RTOS for SimpleLink 

 ► Press 'Install Software' 

 

 

► Restart CCS when directed after installation 
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Import and Build Four Essential CCS Projects 
The CC3200 SDK contains four projects that you need to import and build: 

• simplelink – creates an object library for SimpleLink APIs 

• driverlib – creates an object library for CC3200 peripheral drivers 

• oslib – creates the OS adaptation layer library 

• ti_rtos_config – contains a common TI-RTOS configuration file 

It is necessary to build these projects since the libraries and shared TI-RTOS configuration file 
are used by the CC3200 SDK example projects. 

9. Import the four projects 

 ► Choose Projects>Import CCS Projects from the Project menu. 

 ► Select the Browse button in the Import CCS Eclipse Projects dialog, and select the 
directory c:\ti\CC3200SDK\cc3200-sdk. 

 ► Select the four projects by clicking the checkbox for the driverlib, oslib, simplelink, and 
ti_rtos_config projects.  

  

Note: ► Do NOT select “Copy projects into workspace” option or “Automatically import 
referenced projects found in same search-directory”. 

 ► After selecting all four projects, click “Finish”. 
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In the CCS Project Explorer, you should see your four projects listed: driverlib, oslib, 
simplelink, and ti_rtos_config. 

 

 

10. Set up the ti_rtos_config project configuration as shown. 

 ► Right-click the ti_rtos_config project name, and select “Properties” from the menu. 

 ► Click the “General” property in the left column. Click the RTSC tab, and select the latest 
versions of XDCtools and TI-RTOS for SimpleLink. Also verify the platform is selected as 
ti.platforms.simplelink:CC3200. Finally, click OK. 
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11. Build the simplelink project for two Build Configurations: NON_OS and OS 

 ► Right-click the simplelink project, choose Build Configurations, Set Active, and choose: 

  1 NON_OS (Simplelink for Non-OS).  

 This selects the NON_OS configuration to build. 
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 ► Select the simplelink project and build using the menu command Project → Build 
Project. This builds the NON_OS configuration. 

.  

 

 ► Right-click the simplelink project again and choose Build Configurations, Set Active, and 
choose: 

  2 OS (Simplelink with OS config).  

 This selects the OS configuration to be active 

 ► Select the simplelink project and build this OS configuration 

 ► Select the ti_rtos_config project and build it. 

 ► Select the driverlib project and build it. 

 ► Select the oslib project and build it for two Build Configurations: free_rtos and ti_rtos. 
Note that you may receive two warnings when you build the free_rtos configuration. You can 
ignore these warnings. 
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Set the Default Target Configuration 
12. The target configuration needs to be set before debugging from CCS.  

 ► Navigate to View  Target Configurations. 

 
 ► Right-Click on “User Defined,” select “Import Target Configuration” and navigate to the 

folder  c:\ti\CC3200SDK\cc3200-sdk\tools\ccs_patch and select the file 
CC3200.ccxml 

 
 ► Select the Copy files option when prompted. 
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 ► Set this new configuration as the default by right clicking on the file name as shown, and 
then select “Set as Default” 

 

\ 

 

 This is the end of the seminar pre-work. At the seminar you will receive a 
CC3200 LaunchPad board which is required for the remaining lab steps. If you already have 
a LaunchPad board, you can proceed with the remaining steps. 
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Configure the CC3200 LaunchPad Board 
This part of the lab will be done at the seminar you are attending. It requires that you have a 
CC3200 LaunchPad board. So if you’re just doing the pre-work steps, you’re done at this point. If 
you already have your own LaunchPad board, you can go ahead and perform these steps as 
well. 

Check CC3200 LaunchPad Jumpers 
13. The jumpers on the CC3200-LAUNCHXL should be connected as shown.  

► Make sure there is NO jumper on P58-VCC  

► Make sure the SOP2 jumper has been installed 

The jumper on SOP2 (sense on power) is used when debugging CCS projects. This allows 
downloading code to the CC3200 RAM, and inhibits the CC3200 from automatically boot-loading 
the application image that is stored in serial flash. This jumper is also used whenever you want to 
program the serial flash with a new application image, file, digital certificate, or CC3200 service 
pack. If this jumper is removed, the stored application image is bootloaded from serial flash. On a 
new board, a pre-programmed “out-of-box” example is loaded and run. 

.  

  
No jumper here! 
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Install USB Driver 
14. The USB drivers may need to be installed manually after connecting your LaunchPad 

board. 

 ► Connect the CC3200-LAUNCHXL to the PC using the provided micro-USB cable. 

 ► Open the Windows Device Manager by selecting Start Menu→Control Panel→Device 
Manager.  

 If you see two devices in the “Other devices” category named USB <-> JTAG/SWD, you will 
need to install the driver software for both instances. 

 If you DON’T see these devices in “Other devices”, check the Ports category to see if the 
CC3200LP already shows up there. If already installed you can skip the remaining steps. 

  

 

 

 ► Right click on the first instance of “USB <-> JTAG/SWD” and select “Update Driver 
Software…” 

 ► Select “Browse my computer for driver software.” 

Note: If you’ve previously installed a TI board that uses FTDI drivers, this process is not 
necessary. 
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 ► Browse or fill the search path as c:\ti\CC3200SDK\cc3200-sdk\tools\ftdi, and 

press Next. There is no need to restart the PC. 

 

15. Repeat the above steps for the other instance of "USB <-> JTAG/SWD." 

16. Repeat the same steps for the instance of “USB Serial Port” that should have 
appeared as shown 

 



 Configure the CC3200 LaunchPad Board 

Arrow IoT Seminar - CC3200 Tools Setup 1 - 19 

The CC3200-LAUNCHXL will now be visible in the Device Manager. Note the COM port number 
that appears. 

 

Trouble Installing FTDI Drivers? 
All new boards should already have the correct FTDI templates flashed into the FTDI chips. 
However, if your board is not recognized, installing the driver from the SDK is not working, or the 
built-in FTDI template is corrupted, you'll need to flash the FTDI chip again. Go to this link for 
instructions to flash the FTDI chip: 

http://processors.wiki.ti.com/index.php/CC31xx_%26_CC32xx_FTDI_Flashing#FTDI_Templates 

Summary 
After the development environment has been set up, see the following resources for further 
assistance in development: 

CC3200 Programmer's Guide – This guide contains information on how to use the SimpleLink 
API for writing WLAN-enabled applications. 

PinMux Tool – This utility helps determine how to best assign peripherals to the appropriate 
CC3200 package pins. 

Uniflash – The Uniflash tool manually stores files on the external serial flash. This includes the 
application binary and SimpleLink firmware patch files. Also, any configuration files, security 
certificates, web pages, and so forth can be stored using this tool. 

CC3200 Wiki – All information and tools for the CC3200, including the above, can be found on 
the CC3200 Wiki page 

http://processors.wiki.ti.com/index.php/CC31xx_%26_CC32xx_FTDI_Flashing#FTDI_Templates
http://www.ti.com/lit/pdf/SWRU369
http://processors.wiki.ti.com/index.php/CC32xx_PinMux_Tool
http://processors.wiki.ti.com/index.php/CC31xx_%26_CC32xx_UniFlash_Quick_Start_Guide
http://processors.wiki.ti.com/index.php/CC31xx_%26_CC32xx
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