Zoom™ OMAP-L138 eXperimenter Kit
User Guide

Logic PD // Products
Published: November 2010

This document contains valuable proprietary and confidential information and the attached file contains source code, ideas, and techniques that are owned by Logic Product Development Company (collectively “Logic PD’s Proprietary Information”). Logic PD’s Proprietary Information may not be used by or disclosed to any third party except under written license from Logic Product Development Company.

Logic Product Development Company makes no representation or warranties of any nature or kind regarding Logic PD’s Proprietary Information or any products offered by Logic Product Development Company. Logic PD’s Proprietary Information is disclosed herein pursuant and subject to the terms and conditions of a duly executed license or agreement to purchase or lease equipment. The only warranties made by Logic Product Development Company, if any, with respect to any products described in this document are set forth in such license or agreement. Logic Product Development Company shall have no liability of any kind, express or implied, arising out of the use of the Information in this document, including direct, indirect, special or consequential damages.

Logic Product Development Company may have patents, patent applications, trademarks, copyrights, trade secrets, or other intellectual property rights pertaining to Logic PD’s Proprietary Information and products described in this document (collectively “Logic PD’s Intellectual Property”). Except as expressly provided in any written license or agreement from Logic Product Development Company, this document and the information contained therein does not create any license to Logic PD’s Intellectual Property.

The Information contained herein is subject to change without notice. Revisions may be issued regarding changes and/or additions.

© Copyright 2010, Logic Product Development Company. All Rights Reserved.
# Revision History

<table>
<thead>
<tr>
<th>REV</th>
<th>EDITOR</th>
<th>DESCRIPTION</th>
<th>APPROVAL</th>
<th>DATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>JCA</td>
<td>Initial release</td>
<td>KJH</td>
<td>11/22/10</td>
</tr>
</tbody>
</table>
# Table of Contents

1 **Introduction** .......................................................................................................................... 1  
  1.1 Scope of Document .................................................................................................................. 1  
  1.2 Requirements .......................................................................................................................... 1  
2 **Application Baseboard** ........................................................................................................... 2  
  2.1 Application Baseboard Features Diagram ............................................................................ 2  
  2.2 Application Baseboard Ethernet Jack ..................................................................................... 2  
  2.3 DIP Switches ............................................................................................................................ 2  
3 **Installing Code Composer Studio** ............................................................................................ 3  
4 **Running Board Support Library (BSL) Sample Programs** ..................................................... 4  
  4.1 Copy BSL Files to PC .............................................................................................................. 4  
  4.2 Connect eXperimenter Kit to Host PC .................................................................................... 4  
  4.3 Launch Code Composer Studio .............................................................................................. 5  
  4.4 Run Sample Test ...................................................................................................................... 7  
**Appendix A: Additional Documentation** ...................................................................................... 13
1 Introduction

This User Guide continues where the QuickStart Guide documentation ended by providing additional hardware details about the Zoom OMAP-L138 eXperimenter Kit, as well as introductory instructions for using Code Composer Studio and the included Board Support Library (BSL) files.

1.1 Scope of Document

- This User Guide references specific connectors on the application baseboard. However, the discussion is limited to special use instructions; detailed information about the connectors should be referenced on the respective schematic and Bill of Material (BOM) documents. See Appendix A for links to these documents.
- This User Guide does not provide detailed instructions for the software included with the eXperimenter Kit. Please refer to the specific User Guides for each respective software product for additional information. A list of additional documentation is available in Appendix A.

1.2 Requirements

- It is assumed that the QuickStart Guide has been read in its entirety. See Appendix A for a link to the QuickStart Guide.
- A host PC with CD/DVD drive, USB port, and at least 2 GB of hard drive space.
2 Application Baseboard

2.1 Application Baseboard Features Diagram

2.2 Application Baseboard Ethernet Jack
The Ethernet jack located on the application baseboard is to only be used with the MII PHY; whereas the Ethernet jack located on the UI board is to be used only with the RMII PHY. The Ethernet controller on the CPU can only talk to one Ethernet PHY at a time. Which Ethernet PHY is being used is entirely controlled through software.

2.3 DIP Switches
There are two 8-position DIP switches located on the application baseboard at reference designators S2 and S7. By default, all of the switches are set to the "OFF" position.
The S2 DIP switch is reserved for user application general purpose. The S7 DIP switch controls the processor’s boot mode and several FET muxes on the baseboard. Table 2.1 describes the function of each switch.

### Table 2.1: S7 DIP Switch Functions

<table>
<thead>
<tr>
<th>Switch</th>
<th>OFF Position</th>
<th>ON Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>S7:1*</td>
<td>Baseboard LCD drive enabled.</td>
<td>Baseboard LCD drive disabled.</td>
</tr>
<tr>
<td>S7:2</td>
<td>Baseboard audio enabled. Associated McASP lines connect to baseboard audio only.</td>
<td>Baseboard audio disabled. Associated McASP lines are available on audio expansion connector.</td>
</tr>
<tr>
<td>S7:3</td>
<td>OMAP-L138 I/O runs at 3.3V</td>
<td>OMAP-L138 I/O runs at 1.8V</td>
</tr>
<tr>
<td>S7:4</td>
<td>No connection</td>
<td></td>
</tr>
<tr>
<td>S7:5</td>
<td>BOOT[1]</td>
<td></td>
</tr>
<tr>
<td>S7:6</td>
<td>BOOT[2]</td>
<td></td>
</tr>
<tr>
<td>S7:7</td>
<td>BOOT[3]</td>
<td></td>
</tr>
<tr>
<td>S7:8</td>
<td>BOOT[4]</td>
<td></td>
</tr>
</tbody>
</table>

*Note: S7:1 indicates slide 1 on the S7 DIP switch, S7:2 indicates slide 2 on the S7 DIP switch, and so on.

A default boot mode has been defined by pulling all boot pins (BOOT[0:7]) to a default state on the SOM. The default boot mode is SPI1 Flash; all available boot modes are described in Table 2.2.

### Table 2.2: S7 DIP Switch Boot Modes

<table>
<thead>
<tr>
<th>Boot Mode</th>
<th>DIP Switch Setting—S7[5:8]</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOR EMIFA</td>
<td>OFF</td>
</tr>
<tr>
<td>NAND-8 EMIFA</td>
<td>OFF</td>
</tr>
<tr>
<td>Default</td>
<td>SPI1 Flash</td>
</tr>
<tr>
<td>UART2</td>
<td>ON</td>
</tr>
<tr>
<td>EMU Debug</td>
<td>ON</td>
</tr>
</tbody>
</table>

### 3 Installing Code Composer Studio

The Zoom OMAP-L138 eXperimenter Kit includes a software DVD containing Code Composer Studio (CCStudio).

1. Insert the Code Composer Studio v4 software DVD into your host PC.

2. Navigate to the DVD drive and open the files on the CCStudio DVD. Double-click on `setup_CCS_4.2.x.xxxxx.exe` and a splash screen similar to the image below will appear. Click the **Next** button.
3. Follow the on screen instructions until you arrive at the screen for Product Configuration, select **Platinum Edition**.

4. On the next screen, leave the default ISA items checked. Click the **Next** button.

5. Click the **Next** button to start copying files.

6. Wait for CCStudio to finish installing; this process can take some time, so please be patient.

7. Click the **Finish** button when the installation is complete. You may eject the CCStudio DVD at this time.

### 4 Running Board Support Library (BSL) Sample Programs

The BSL sample programs are included to test the different features of the development kit and diagnose any potential problems. In order to run these tests, you first have to connect your development kit to a PC.

#### 4.1 Copy BSL Files to PC

Both SD cards included with the OMAP-L138 eXperimenter Kit contain the GEL and BSL files. These files need to be copied to your host PC.

1. Navigate into the SD card and locate the **BSL** directory.

2. Extract the ZIP archive and save the files to your host PC. *(NOTE: The files may be placed anywhere on your host PC; however, the original file structure must remain intact.)*

3. For the instructions in this User Guide, it is assumed the files were copied to the root C:\ drive. For example:

   C:\OMAP-L138_GEL_BSL_Files_v2.3
   C:\TMS320C6748_GEL_BSL_Files_v2.3

#### 4.2 Connect eXperimenter Kit to Host PC

To communicate with the OMAP-L138 eXperimenter Kit using CCStudio, you will need to connect the included USB A to mini-B cable to the USB emulator port on the application baseboard and your host PC.
As soon as the USB cable connects to your host PC, Windows should automatically recognize that new hardware has been connected and install the necessary drivers. Power on your OMAP-L138 eXperimenter Kit and continue with the next section.

4.3 Launch Code Composer Studio


2. Select a workspace location and then click the OK button.

3. CCStudio will finish launching and a Welcome to Code Composer Studio window will open. (NOTE: If you do not have the latest Adobe Flash Player installed on your machine, you will be prompted to install. This is required for proper viewing of the Code Composer Studio Welcome screen.)

4. If you do not have a license, select the Activate a License option and click the Use Free Limited License button. (NOTE: If you do not have an active Internet connection, you can select to Evaluate Code Composer Studio for 30 days. At any time during that period, you can change to the Free Limited License by selecting Help > License Options... from the CCStudio menu bar and then following the onscreen instructions.)
No valid license for Code Composer Studio could be found.

- Evaluate Code Composer Studio for 30 days
- Activate a License

**Step 1 - Generate License File**

Note: If you already have a license file, skip to the next step.

Please note that you will need to use one of the following Host IDs during the registration process:
842b2b9f0e97

- Register
- Use Free Limited License

Click to activate a free license that enables you to work with XDS100 emulators, simulators, and emulators integrated onto standard EVM/DSK/e2DSP development boards. Do not use this license for MSP430.

**Step 2 - Install License File**

- Specify a license file
- Specify a license server

Address:  Port:  

[OK]  [Cancel]
5. You will be redirected to TI’s website to login in with your myTI.com account. Follow all the online instructions. After completing the online instructions, you will receive an email containing an attachment that is your license file.

6. Save the license file to your host PC, then return to the Welcome to Code Composer Studio window and under Step 2 - Install License File, browse to where you saved the license file. Click the OK button.

7. You will then be presented with the Code Composer Studio Welcome screen. Click on the cube in the upper right-hand corner to go to the CCStudio workbench.

![Welcome to Code Composer Studio](image)

8. The CCStudio workbench will then appear.

![CCStudio Workbench](image)

### 4.4 Run Sample Test

As an example, we will run one feature test. In order to run a test program, you will have to select the program, compile (or build) the program, and then load the compiled program. The following steps will walk you through that process.
1. From the menu bar, select **Project > Import Existing CCS/CCE Eclipse Project**.

2. Browse to the location where you saved the BSL files on your host PC and down to the `OMAP-L138_GEL_BSL_Files_v2.3\bsl` directory. Click the **OK** button. Verify the correct project exists in the **Discovered projects:** window and then click the **Finish** button.
3. Once again, select Project > Import Existing CCS/CCE Eclipse Project. This time browse to the tests folder, OMAP-L138_GEL_BSL_v2.3\tests\experimenter. Click the OK button. Verify the correct project exists in the Discovered projects: window and then click the Finish button.

4. In the Projects window on the left, expand the evmomapl138_bsl folder and verify the .ccxml file is set as Active/Default. If not, right-click on the .ccxml file name and select Set as Active Target Configuration, then repeat to also Set as Default Target Configuration.
5. Once again in the Projects window on the left, expand the `evmomap138_test_led_dip` project. Right-click on the file name and select **Set as Active Project**.

6. The test must now be compiled; from the CCSstudio menu bar select **Project > Build Active Project**.
7. Once the Console window prints the message “Build Complete,” select **Target > Debug Active Project** from the menu bar. (**NOTE:** If you receive a message stating “Error connecting to the target,” press the reset button on the baseboard and then click **Retry**.)

8. After the test finishes debugging, you will see a message in the Console window stating “DSP Wake Complete.”

9. To run the program, select **Target > Run** from the menu bar.
10. The Console window provides a brief description of the test. If you move any of the S2 DIP switches, output text will print the switch that was moved and its new position (ON or OFF) and USER LED1 or USER LED2 will turn on or off in relation to the DIP switch position.

The steps in this section can be repeated to run any of the other tests for your eXperimenter Kit. (NOTE: All of the tests in the “experimenter” folder can be run on both the OMAP-L138 EVM and eXperimenter Kit; the tests in the “evm” folder can only be run on the OMAP-L138 EVM.)
Appendix A: Additional Documentation

Software Documentation

- The SD cards included with your OMAP-L138 eXperimenter Kit include Software Developer Guides for Linux and Windows CE. Please see the setup.htm files on each SD card for information.
- U-Boot documentation http://www.denx.de/wiki/U-Boot/WebHome
- TI Code Composer Studio documentation http://focus.ti.com/dsp/docs/dspsupportatn.tsp?sectionId=3&tabId=415&familyId=44&toolTypeld=30

Hardware Documentation

All of the following links are also available on your “My Account” page on the Logic PD website (http://support.logicpd.com/auth/).

- Logic PD Zoom OMAP-L138 eXperimenter Kit Hardware Design Files (BOMs, Schematics, and Layout Files for all boards included in the eXperimenter Kit) http://support.logicpd.com/downloads/1360/